Package HostCMS v 4 Element Index

Система управления сайтом HostCMS

Список элементов HostCMS v 4

Список всех элементов
$ a b c d e f g h i j k l m n o p q r s t u v w x y
top
$
$row['constants_name'] | в файле Kernel.php, константа $row['constants_name']
top
a
$action_width | в файле show_table.class.php, переменная show_table::$action_width
$additional_attribute | в файле show_table.class.php, переменная table_fields::$additional_attribute
$additional_filed | в файле show_table.class.php, переменная table_fields::$additional_filed
$additional_filed_value | в файле show_table.class.php, переменная table_fields::$additional_filed_value
$align | в файле show_table.class.php, переменная table_fields::$align
$align_title | в файле show_table.class.php, переменная table_fields::$align_title
$aling | в файле show_table.class.php, переменная show_table::$aling
$array | в файле show_table.class.php, переменная table_fields::$array
$attribute | в файле show_table.class.php, переменная table_fields::$attribute
$a_count_property в файле Structure.class.php, переменная Structure::$a_count_property
Ассоциативный массив-Кэш количества свойств для разных сайтов
$a_count_property в файле InformationSystems.class.php, переменная InformationSystem::$a_count_property
Кэш количества свойств
AddAdminMenuItem в файле AdminMenu.class.php, метод AdminMenu::AddAdminMenuItem()
Метод добавляет элемент в меню раздела администрирования
AddBanner в файле Advertisement.class.php, метод Advertisement::AddBanner()
Метод добавления/редактирования баннера
AddEditConstants в файле Constants.class.php, метод Constants::AddEditConstants()
Метод добавления/редактирования данных о константе
AddEditInitialData в файле Counter.class.php, метод counter::AddEditInitialData()
Метод добавления/редактирования начальных данных для счетчика
AddEditMessage в файле Forums.class.php, метод Forums::AddEditMessage()
Метод добавления/редактирования сообщения темы
AddEditTheme в файле Forums.class.php, метод Forums::AddEditTheme()
Метод осуществляет добавление/редактирование темы
AddInclude в файле Kernel.class.php, метод kernel::AddInclude()
Метод подключает переданный файл или выводит сообщение об ошибке подключения
AddIntoCart в файле shop.class.php, метод shop::AddIntoCart()
Метод помещения товара в корзину
AddModule в файле Kernel.class.php, метод kernel::AddModule()
Метод подключения модуля
ADD_COMMENT_DELAY | в файле Kernel.php, константа ADD_COMMENT_DELAY
add_modules_version в файле Kernel.class.php, метод kernel::add_modules_version()
Метод добавления модуля в массив-список модулей
add_page в файле Structure.class.php, метод Structure::add_page()
Метод добавления и редактирования данных о страницах
Admin в файле Admin.class.php, класс Admin
Ядро, методы управления разделом администрирования HostCMS
AdminMenu в файле AdminMenu.class.php, класс AdminMenu
Ядро, класс для формирования меню в разделе администрирования
admin_datetime_format в файле Date.class.php, метод DateClass::admin_datetime_format()
Метод для админки формат вывода даты-времени из SQL-формата в формат d-m-Y
admin_date_format в файле Date.class.php, метод DateClass::admin_date_format()
Метод для админки, преобразует формат выводы даты из sql-формата в формат d-m-Y
admin_init в файле Admin.class.php, метод Admin::admin_init()
Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта
admin_session_valid в файле Admin.class.php, метод Admin::admin_session_valid()
Метод проверки авторизации пользователя
Advertisement в файле Advertisement.class.php, класс Advertisement
Класс модуля "Реклама"
Advertisement.class.php | procedural page Advertisement.class.php
Advertisement.php | procedural page Advertisement.php
AlignTextSpace в файле Counter.class.php, метод counter::AlignTextSpace()
Метод выравнивания текста по центру с помощью пробелов
AssignGroupImage в файле shop.class.php, метод shop::AssignGroupImage()
Метод для установки имени изображения для группы товаров
AssignItemImage в файле shop.class.php, метод shop::AssignItemImage()
Метод для установки имени изображения для товара
AssignShopWatermark в файле shop.class.php, метод shop::AssignShopWatermark()
Метод осуществляющий обновление данных о файле watermark'a для магазина
AdminMenu.class.php | procedural page AdminMenu.class.php
Admin.class.php | procedural page Admin.class.php
admin_output.fns.php | procedural page admin_output.fns.php
top
b
$button | в файле show_table.class.php, переменная show_table::$button
$button_name | в файле show_table.class.php, переменная show_table::$button_name
$button_value | в файле show_table.class.php, переменная show_table::$button_value
Backup в файле Backup.class.php, класс Backup
Класс модуля "Резервное копирование"
Backup.class.php | procedural page Backup.class.php
Backup.php | procedural page Backup.php
BBcode2HTML в файле Forums.class.php, метод Forums::BBcode2HTML()
Метод замены BBcode на HTML
build в файле Xsl.class.php, метод xsl::build()
Метод обработки XML данных с помощью XSL шаблона
BuildCapture в файле Captcha.class.php, метод Captcha::BuildCapture()
Метод для построения изображения CAPTCHA и помещения его текста в сессию
build_counter в файле Counter.class.php, метод counter::build_counter()
Метод вывода счетчика
top
c
$CacheModificationItems в файле shop.class.php, переменная shop::$CacheModificationItems
Массив ID модификаций товара для товаров
$CacheSite в файле Site.class.php, переменная site::$CacheSite
Кэш данных о сайтах
$cache_InformationSystem в файле InformationSystems.class.php, переменная InformationSystem::$cache_InformationSystem
Кэш данных о информационной системе пример $this->cache_InformationSystem[$id]
$cache_mesure в файле shop.class.php, переменная shop::$cache_mesure
Кэш информации о единицах измерений
$cache_producer в файле shop.class.php, переменная shop::$cache_producer
Кэш информации о производителях
$cache_structure_property в файле Structure.class.php, переменная Structure::$cache_structure_property
Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.
$checked | в файле show_table.class.php, переменная table_fields::$checked
$CommentMass в файле InformationSystems.class.php, переменная InformationSystem::$CommentMass
Кэш с данными о комментариях
$copy_show | в файле show_table.class.php, переменная show_table::$copy_show
$count_mark_after_separator | в файле show_table.class.php, переменная table_fields::$count_mark_after_separator
$count_row в файле Structure.class.php, переменная Structure::$count_row
Количество выбранных элементов
$count_row | в файле Mysql.class.php, переменная MySQL::$count_row
$count_row | в файле Xsl.class.php, переменная xsl::$count_row
$count_row | в файле Templates.class.php, переменная templates::$count_row
$count_row | в файле Modules.class.php, переменная modules::$count_row
$count_row | в файле Site.class.php, переменная site::$count_row
$count_row_city_areas в файле shop.class.php, переменная shop::$count_row_city_areas
Количество выбранных районов города
$current_alias_cache | в файле Site.class.php, переменная site::$current_alias_cache
Cache в файле Cache.class.php, класс Cache
Класс модуля "Кэш"
Cache.class.php | procedural page Cache.class.php
Cache.php | procedural page Cache.php
config.php | procedural page config.php
CACHE_INSTALL | в файле Cache.php, константа CACHE_INSTALL
CACHE_LIMIT | в файле Cache.php, константа CACHE_LIMIT
Captcha в файле Captcha.class.php, класс Captcha
Ядро, класс для работы с CAPTCHA
ChangeMySqlDate в файле Date.class.php, метод DateClass::ChangeMySqlDate()
Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд
ChangeNormalDate в файле Date.class.php, метод DateClass::ChangeNormalDate()
Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд
CheckBot в файле Counter.class.php, метод counter::CheckBot()
Метод проверяет, является ли user-agent ботом
CheckTypeGzip в файле Compression.class.php, метод compression::CheckTypeGzip()
Метод вовзращает тип сжатия gzip, в противном случае false
ClearAdvertisementList в файле Advertisement.class.php, метод Advertisement::ClearAdvertisementList()
Метод очищающий список показов, произошедших $count_days назад
ClearCookieAndSessionCart в файле shop.class.php, метод shop::ClearCookieAndSessionCart()
Метод для очистки корзины кукисов и сессий
ClearPath в файле shop.class.php, метод shop::ClearPath()
Метод очищает путь от запрещенных символов
ClearStructure в файле Structure.class.php, метод Structure::ClearStructure()
Метод очистки параметров класса
CloseForum в файле Forums.class.php, метод Forums::CloseForum()
Метод, закрывающий/открывающий форум
CloseTheme в файле Forums.class.php, метод Forums::CloseTheme()
Метод, открыввающий/закрывающий тему для доступа
cms_error_handler в файле Error.fns.php, функция cms_error_handler()
Ядро, обработчики ошибок в HostCMS
code_ip в файле Counter.class.php, метод counter::code_ip()
Метод для преобразования IP в HEX
CODE_NAME | в файле Kernel.php, константа CODE_NAME
compression в файле Compression.class.php, класс compression
Класс модуля "Система сжатия (компрессия)"
Compression.class.php | procedural page Compression.class.php
Compression.php | procedural page Compression.php
COMPRESSION_INSTALL | в файле Compression.php, константа COMPRESSION_INSTALL
ConfirmGetForm в файле Forms.class.php, метод Forms::ConfirmGetForm()
Метод, определяющий может ли пользователь отправлять форму
confirm_information_item в файле InformationSystems.class.php, метод InformationSystem::confirm_information_item()
Метод определения возможности пользователя добавлять информационный элемент
Constants в файле Constants.class.php, класс Constants
Класс модуля "Константы"
Constants.class.php | procedural page Constants.class.php
Constants.php | procedural page Constants.php
ConvertPrice в файле shop.class.php, метод shop::ConvertPrice()
Конвертирует цену в различных форматах к цене в формате xxxx.yy
ConvertSqlProperty в файле lib.class.php, метод lib::ConvertSqlProperty()
Метод конвертирет SQL-запрос, введенный для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.
CopyDataTemplate в файле Templates.class.php, метод templates::CopyDataTemplate()
Метод копирования шаблона страниц
CopyDocuments в файле Documents.class.php, метод documents::CopyDocuments()
Метод копирования документа
CopyExtraProperty в файле Site_users.class.php, метод SiteUsers::CopyExtraProperty()
Метод копирования дополнительного параметра
CopyFascicle в файле Maillist.class.php, метод Maillist::CopyFascicle()
Метод копирования выпуска рассылки
CopyForms в файле Forms.class.php, метод Forms::CopyForms()
Метод копирования структуры формы и ее полей
CopyFormsField в файле Forms.class.php, метод Forms::CopyFormsField()
Метод копирования структуры поля формы
CopyImgWithWatermark в файле Image.class.php, метод Image::CopyImgWithWatermark()
Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя
CopyInformationItem в файле InformationSystems.class.php, метод InformationSystem::CopyInformationItem()
Метод копирования элемента информационной системы
CopyLib в файле lib.class.php, метод lib::CopyLib()
Метод создает копию типовой динамической страницы
CopyListItem в файле Lists.class.php, метод lists::CopyListItem()
Метод копирования элементов списка
CopyTemplate в файле Templates.class.php, метод templates::CopyTemplate()
Метод копирования макета
CopyXsl в файле Xsl.class.php, метод xsl::CopyXsl()
Метод копирования XSL-шаблона
CorrectPropertiesItem в файле shop.class.php, метод shop::CorrectPropertiesItem()
Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.
counter в файле Counter.class.php, класс counter
Класс модуля "Статистика посещаемости сайта"
COUNTER_BOT_COUNT | в файле config.php, константа COUNTER_BOT_COUNT
config.php | procedural page config.php
Counter.class.php | procedural page Counter.class.php
Counter.php | procedural page Counter.php
COUNTER_INSTALL в файле Counter.php, константа COUNTER_INSTALL
Модуль: /modules/Counter/Counter.php
CreateBackup в файле Backup.class.php, метод Backup::CreateBackup()
Метод создания резевной копии базы данных
CreateDirectory в файле shop.class.php, метод shop::CreateDirectory()
Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает
CreateGroupsXmlTree в файле InformationSystems.class.php, метод InformationSystem::CreateGroupsXmlTree()
Метод формирования XML дерева для информационных групп
CreateRSS в файле RssWrite.class.php, метод RssWrite::CreateRSS()
Метод формирования XML-файла в стандарте RSS
CreateWatermark | в файле Image.class.php, метод Image::CreateWatermark()
current_alias в файле Site.class.php, метод site::current_alias()
Метод преобразования алиаса (домена) сайта в основной
current_version в файле Documents.class.php, метод documents::current_version()
Метод для переобозначения текущей версии документа
CURRENT_VERSION | в файле Kernel.php, константа CURRENT_VERSION
config.php | procedural page config.php
Captcha.class.php | procedural page Captcha.class.php
config.php | procedural page config.php
top
d
$dec_point | в файле show_table.class.php, переменная table_fields::$dec_point
$delete_confirm | в файле show_table.class.php, переменная show_table::$delete_confirm
$delete_show | в файле show_table.class.php, переменная show_table::$delete_show
DateClass в файле Date.class.php, класс DateClass
Ядро, класс для работы с датами
DateSqlToUnix в файле Date.class.php, метод DateClass::DateSqlToUnix()
Метод преобразовывает дату в формате SQL в число секунд с начала эпохи
datetime_format в файле Date.class.php, метод DateClass::datetime_format()
Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT
datetime_format_sql в файле Date.class.php, метод DateClass::datetime_format_sql()
Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL
DateUnixToSQL в файле Date.class.php, метод DateClass::DateUnixToSQL()
Метод преобразовывает дату из числа секунд в формат SQL
date_format в файле Date.class.php, метод DateClass::date_format()
Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT
date_format_sql в файле Date.class.php, метод DateClass::date_format_sql()
Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат
db_connect в файле Mysql.class.php, метод MySQL::db_connect()
Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.
declension в файле Kernel.class.php, метод kernel::declension()
Метод получения существительного в форме, соответствующей числу
decode_ip в файле Counter.class.php, метод counter::decode_ip()
Метод для декодирования IP из HEX
DEFAULT_LNG | в файле Kernel.php, константа DEFAULT_LNG
DelBannerGroup в файле Advertisement.class.php, метод Advertisement::DelBannerGroup()
Метод исключения баннера из группы
DelBannersGroup в файле Advertisement.class.php, метод Advertisement::DelBannersGroup()
Метод удаления группы баннеров
DelConstants в файле Constants.class.php, метод Constants::DelConstants()
Метод удаления константы
DeleteAdvertisementFile в файле Advertisement.class.php, метод Advertisement::DeleteAdvertisementFile()
Метод удаляет загруженный файл для элемента с указанным идентификатором
DeleteAllItemsCatalogAndGroups в файле shop.class.php, метод shop::DeleteAllItemsCatalogAndGroups()
Метод очистки таблиц товаров и групп
DeleteBanner в файле Advertisement.class.php, метод Advertisement::DeleteBanner()
Метод удаления баннера
DeleteCacheItem в файле Cache.class.php, метод Cache::DeleteCacheItem()
Метод удаляет (помечает как удаленный) элемент с именем $item_name из кэша unknown_type
DeleteCart в файле shop.class.php, метод shop::DeleteCart()
Метод, осуществляющий удаление товара из корзины
DeleteCity в файле shop.class.php, метод shop::DeleteCity()
Метод, осуществляющий удаление города
DeleteCityArea в файле shop.class.php, метод shop::DeleteCityArea()
Метод удаления района города
DeleteComment в файле shop.class.php, метод shop::DeleteComment()
Метод удаления информации об отзыве на товар
DeleteCompany в файле shop.class.php, метод shop::DeleteCompany()
Метод удаления информации об организации
DeleteCondOfDelivery в файле shop.class.php, метод shop::DeleteCondOfDelivery()
Метод, осуществляющий удаление условия доставки
DeleteConference в файле Forums.class.php, метод Forums::DeleteConference()
Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.
DeleteCountry в файле shop.class.php, метод shop::DeleteCountry()
Метод, осуществляющий удаление страны
DeleteCoupon в файле shop.class.php, метод shop::DeleteCoupon()
Метод для удаления информации о купоне
DeleteCurrency в файле shop.class.php, метод shop::DeleteCurrency()
Метод, осуществляющий удаление валюты
DeleteDiscount в файле shop.class.php, метод shop::DeleteDiscount()
Метод, осуществляющий удаление скидки
DeleteExtraProperty в файле Site_users.class.php, метод SiteUsers::DeleteExtraProperty()
Метод удаления дополнительного параматра
DeleteForum в файле Forums.class.php, метод Forums::DeleteForum()
Метод удаления форума
DeleteGroup в файле shop.class.php, метод shop::DeleteGroup()
Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)
DeleteItem в файле shop.class.php, метод shop::DeleteItem()
Метод, осуществляющий удаление товара
DeleteItemDiscount в файле shop.class.php, метод shop::DeleteItemDiscount()
Метод удаления скики для товара
DeleteLib в файле lib.class.php, метод lib::DeleteLib()
Метод для удаления типовой динамической страницы из библиотеки страниц
DeleteLibDir в файле lib.class.php, метод lib::DeleteLibDir()
Метод для рекурсивного удаления раздела типовых дин. страниц со всеми его подразделами
DeleteLibProperty в файле lib.class.php, метод lib::DeleteLibProperty()
Метод для удаления параметра типовой динамической страницы
DeleteLibPropertyListItem в файле lib.class.php, метод lib::DeleteLibPropertyListItem()
Метод для удаления элемента списка параметра типовой динамической страницы
DeleteLocation в файле shop.class.php, метод shop::DeleteLocation()
Метод, осуществляющий удаление области
DeleteMesure в файле shop.class.php, метод shop::DeleteMesure()
Метод, осуществляющий удаление единицы измерения
DeleteOrder в файле shop.class.php, метод shop::DeleteOrder()
Метод, осуществляющий удаление заказа
DeleteOrderDiscount в файле shop.class.php, метод shop::DeleteOrderDiscount()
Метод для удаления информации о скидке для заказов
DeleteOrderItems в файле shop.class.php, метод shop::DeleteOrderItems()
Метод, осуществляющий удаление товара в заказе
DeleteOrderStatus в файле shop.class.php, метод shop::DeleteOrderStatus()
Метод, осуществляющий удаление статуса заказа
DeletePrice в файле shop.class.php, метод shop::DeletePrice()
Метод, осуществляющий удаление типа цены
DeletePriceForItem в файле shop.class.php, метод shop::DeletePriceForItem()
Метод удаляет цену для элемента каталога
DeletePricesForAllItem в файле shop.class.php, метод shop::DeletePricesForAllItem()
Метод удаляет все цены для элемента каталога
DeleteProducer в файле shop.class.php, метод shop::DeleteProducer()
Метод, осуществляющий удаление производителя
DeletePropertiesItem в файле shop.class.php, метод shop::DeletePropertiesItem()
Удаление информации о свойстве товара
DeletePropertyValue в файле Structure.class.php, метод Structure::DeletePropertyValue()
Метод для удаления значения свойтва узла структуры
DeletePropretyOfItems в файле shop.class.php, метод shop::DeletePropretyOfItems()
Метод, осуществляющий удаление свойства товара
DeleteSearchInfomationForSite в файле Search.class.php, метод Search::DeleteSearchInfomationForSite()
Метод для удаления поисковой информации сайта
DeleteSeller в файле shop.class.php, метод shop::DeleteSeller()
Метод, осуществляющий удаление продавца.
DeleteShop в файле shop.class.php, метод shop::DeleteShop()
Метод, осуществляющий удаление магазина
DeleteShopWatermark | в файле shop.class.php, метод shop::DeleteShopWatermark()
DeleteSiteUser в файле Site_users.class.php, метод SiteUsers::DeleteSiteUser()
Метод удаления пользователя из системы
DeleteStructure в файле Structure.class.php, метод Structure::DeleteStructure()
Метод для удлаения узла структуры с его дочерними узлами
DeleteSystemOfPay в файле shop.class.php, метод shop::DeleteSystemOfPay()
Метод, осуществляющий удаление платёжной системы
DeleteTax в файле shop.class.php, метод shop::DeleteTax()
Метод, осуществляющий удаление налога
DeleteTyingProducts в файле shop.class.php, метод shop::DeleteTyingProducts()
Метод удаления сопутствующих товаров
DeleteTypeOfDelivery в файле shop.class.php, метод shop::DeleteTypeOfDelivery()
Метод, осуществляющий удаление типа доставки
DeleteUserDeniedAccessBefore в файле UserAccess.class.php, метод UserAccessDenied::DeleteUserDeniedAccessBefore()
Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд
DeleteUsers в файле Maillist.class.php, метод Maillist::DeleteUsers()
Метод снятия подписки с подписчика
DeleteUsersGroup в файле Maillist.class.php, метод Maillist::DeleteUsersGroup()
Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке
delete_old_version в файле Documents.class.php, метод documents::delete_old_version()
Метод удаления записей обо всех не текущих версиях
delete_page в файле Structure.class.php, метод Structure::delete_page()
Метод удаления страницы
Delete_search_words в файле Search.class.php, метод Search::Delete_search_words()
Метод удаления из индекса страницы с указанным адресом
delete_status в файле Documents.class.php, метод documents::delete_status()
Метод удаления статуса документов
delete_version в файле Documents.class.php, метод documents::delete_version()
Метод удаления записей о версиях
DelFascicle в файле Maillist.class.php, метод Maillist::DelFascicle()
Метод удаления выпуска рассылки
DelFillForms в файле Forms.class.php, метод Forms::DelFillForms()
Удаление бланка заполненной формы
DelFillValues в файле Forms.class.php, метод Forms::DelFillValues()
Метод удаления значения одного из полей отправленной формы
DelForms в файле Forms.class.php, метод Forms::DelForms()
Метод удаления данных о форме
DelFormsFields в файле Forms.class.php, метод Forms::DelFormsFields()
Метод удаления поля формы
DelForumsGroup в файле Forums.class.php, метод Forums::DelForumsGroup()
Метод удаления группы форумов
DelGroupUser в файле Site_users.class.php, метод SiteUsers::DelGroupUser()
Метод удаления пользователя из группы
DelInformationGroupPropertys в файле InformationSystems.class.php, метод InformationSystem::DelInformationGroupPropertys()
Метод удаления дополнительного свойства информационной группы
DelInformationGroupPropertysValue в файле InformationSystems.class.php, метод InformationSystem::DelInformationGroupPropertysValue()
Метод удаления значений дополнительных свойств информационной группы
DelInformationSystem в файле InformationSystems.class.php, метод InformationSystem::DelInformationSystem()
Метод удаления информационной системы
DelIp в файле ip.class.php, метод ip::DelIp()
Метод удаления информации об IP-адресе
DelMaillist в файле Maillist.class.php, метод Maillist::DelMaillist()
Метод удаления рассылки
DelMessage в файле Forums.class.php, метод Forums::DelMessage()
Метод удаления сообщения темы
DelPollsGroup в файле Polls.class.php, метод polls::DelPollsGroup()
Метод удаления групп опросов
DelStatInfomationForSite в файле Counter.class.php, метод counter::DelStatInfomationForSite()
Метод удаления статистической информации для сайта
DelStructurePropertys в файле Structure.class.php, метод Structure::DelStructurePropertys()
Метод удаления дополнительного свойства
DelStructurePropertysValue в файле Structure.class.php, метод Structure::DelStructurePropertysValue()
Метод удаления значений дополнительных свойств из таблицы связи
DelTheme в файле Forums.class.php, метод Forums::DelTheme()
Метод удаления темы форума
DelUserGroup в файле Site_users.class.php, метод SiteUsers::DelUserGroup()
Метод удаления группы пользователей заданной идентификатором
del_alias в файле Site.class.php, метод site::del_alias()
Метод преобразования алиаса (домена) сайта в основной
del_comment в файле InformationSystems.class.php, метод InformationSystem::del_comment()
Метод удаления комментария к информационному элементу
del_data_templates в файле Templates.class.php, метод templates::del_data_templates()
Метод удаления шаблона страниц
del_dir в файле FileManager.class.php, метод FileManager::del_dir()
Метод удаления директории вместе с вложенными файлами и директориями
del_documents в файле Documents.class.php, метод documents::del_documents()
Метод удаления документов
del_documents_dir в файле Documents.class.php, метод documents::del_documents_dir()
Метод удаления разделов документов
del_file в файле FileManager.class.php, метод FileManager::del_file()
Метод удаления файла или директории
del_information_groups в файле InformationSystems.class.php, метод InformationSystem::del_information_groups()
Метод удаления информационных групп
del_information_items в файле InformationSystems.class.php, метод InformationSystem::del_information_items()
Метод удаления элемента информационной системы
del_information_propertys в файле InformationSystems.class.php, метод InformationSystem::del_information_propertys()
Метод удаления дополнительного свойства информационной системы
del_lists в файле Lists.class.php, метод lists::del_lists()
Метод удаления списка
del_lists_items в файле Lists.class.php, метод lists::del_lists_items()
Метод удаления элемента списка
del_module в файле Modules.class.php, метод modules::del_module()
Метод удаления информации о модуле
del_poll в файле Polls.class.php, метод polls::del_poll()
Метод удаления опроса
del_poll_reply в файле Polls.class.php, метод polls::del_poll_reply()
Метод удаления варианта ответа
del_site в файле Site.class.php, метод site::del_site()
Метод удаления информации о сайте
del_templates в файле Templates.class.php, метод templates::del_templates()
Метод удаления макета
del_user в файле UserAccess.class.php, метод user_access::del_user()
Метод удаления пользователя
del_user_type в файле UserAccess.class.php, метод user_access::del_user_type()
Метод удаления типа пользователей
del_xsl в файле Xsl.class.php, метод xsl::del_xsl()
Метод удаления XSL-шаблона
del_xsl_dir в файле Xsl.class.php, метод xsl::del_xsl_dir()
Метод удаления XSL-раздела
Diagramm в файле Graphic.class.php, метод graphic::Diagramm()
Метод рисования круговой диаграммы
DIAGRAMM_LIMIT | в файле Counter.php, константа DIAGRAMM_LIMIT
DIAGRAMM_WIDTH | в файле Counter.php, константа DIAGRAMM_WIDTH
documents в файле Documents.class.php, класс documents
Класс модуля "Старницы и документы"
Documents.class.php | procedural page Documents.class.php
Documents.php | procedural page Documents.php
Download в файле File.class.php, метод File::Download()
Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла
do_html_footer_admin в файле admin_output.fns.php, функция do_html_footer_admin()
Функция выводит "подвал" для страниц раздела администрирования
do_html_header_admin в файле admin_output.fns.php, функция do_html_header_admin()
Функция выводит "шапку" для страниц раздела администрирования
do_show_table в файле show_table.class.php, метод show_table::do_show_table()
Метод отображает сформированную таблицу
Date.class.php | procedural page Date.class.php
top
e
$edit_id в файле Structure.class.php, переменная Structure::$edit_id
Идентификатор редактируемого узла структуры
$edit_show | в файле show_table.class.php, переменная show_table::$edit_show
$error | в файле Modules.class.php, переменная modules::$error
$error | в файле Site.class.php, переменная site::$error
$error | в файле Templates.class.php, переменная templates::$error
$error | в файле shop.class.php, переменная shop::$error
EventsJournal в файле EventsJournal.class.php, класс EventsJournal
Ядро, класс журналирования событий
EventsJournalAdmin в файле EventsJournal.class.php, класс EventsJournalAdmin
Класс модуля "Журнал событий"
EventsJournal.class.php | procedural page EventsJournal.class.php
EventsJournal.php | procedural page EventsJournal.php
EventsMail в файле EventsJournal.class.php, метод EventsJournalAdmin::EventsMail()
Метод отправки письма с отчетом
ExecDump в файле ExecSqlQuery.class.php, метод ExecSqlQuery::ExecDump()
Метод выполнения SQL-запроса
ExecSqlQuery в файле ExecSqlQuery.class.php, класс ExecSqlQuery
Класс модуля "SQL-запросы"
ExecSqlQuery.class.php | procedural page ExecSqlQuery.class.php
ExecSqlQuery.php | procedural page ExecSqlQuery.php
ExecSystemsOfPayHandler в файле shop.class.php, метод shop::ExecSystemsOfPayHandler()
Метод выполнения обработчика платежной системы
ExternalXml в файле ExternalXml.class.php, класс ExternalXml
Ядро, класс формирует дерево XML по переданному массиву
E_STRICT | в файле Kernel.php, константа E_STRICT
Error.fns.php | procedural page Error.fns.php
EventsJournal.class.php | procedural page EventsJournal.class.php
ExternalXml.class.php | procedural page ExternalXml.class.php
top
f
$field | в файле show_table.class.php, переменная table_fields::$field
$FieldForIndexArray | в файле show_table.class.php, переменная table_fields::$FieldForIndexArray
$field_action_show | в файле show_table.class.php, переменная show_table::$field_action_show
$field_copy | в файле show_table.class.php, переменная show_table::$field_copy
$field_delete | в файле show_table.class.php, переменная show_table::$field_delete
$field_description | в файле show_table.class.php, переменная table_fields::$field_description
$field_edit | в файле show_table.class.php, переменная show_table::$field_edit
$field_link | в файле show_table.class.php, переменная table_fields::$field_link
$field_name | в файле show_table.class.php, переменная table_fields::$field_name
$field_prefix | в файле show_table.class.php, переменная table_fields::$field_prefix
$field_type | в файле show_table.class.php, переменная table_fields::$field_type
$flag | в файле ExternalXml.class.php, переменная ExternalXml::$flag
$form_action | в файле show_table.class.php, переменная show_table::$form_action
File в файле File.class.php, класс File
Ядро, класс для работы с файлами
FileManager в файле FileManager.class.php, класс FileManager
Класс модуля "Файловый менеджер"
FileManager.class.php | procedural page FileManager.class.php
FileManager.php | procedural page FileManager.php
FillMasGroup в файле InformationSystems.class.php, метод InformationSystem::FillMasGroup()
Метод формирования массива групп для информационной системы.
FillMasGroup в файле shop.class.php, метод shop::FillMasGroup()
Метод формирования массива групп самого верхнего уровня для данного магазина
FillMemCacheComments в файле shop.class.php, метод shop::FillMemCacheComments()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCacheCountItemsAndGroup в файле shop.class.php, метод shop::FillMemCacheCountItemsAndGroup()
Метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.
FillMemCacheCountItemsAndGroup в файле InformationSystems.class.php, метод InformationSystem::FillMemCacheCountItemsAndGroup()
Метод производит расчет числа подгрупп и элементов, содержащихся в группах информационной системы.
FillMemCacheDiscountsForItem в файле shop.class.php, метод shop::FillMemCacheDiscountsForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.
FillMemCacheGoupsIdTree в файле shop.class.php, метод shop::FillMemCacheGoupsIdTree()
Метод формирует дерево групп и подгрупп в массиве по их идентификаторам
FillMemCacheGoupsIdTree в файле InformationSystems.class.php, метод InformationSystem::FillMemCacheGoupsIdTree()
Метод формирует дерево групп и подгрупп в массиве по их идентификаторам
FillMemCacheModificationItems в файле shop.class.php, метод shop::FillMemCacheModificationItems()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCachePropertiesItem в файле shop.class.php, метод shop::FillMemCachePropertiesItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.
FillMemCacheTyingProducts в файле shop.class.php, метод shop::FillMemCacheTyingProducts()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
fill_xsl_dir в файле Xsl.class.php, метод xsl::fill_xsl_dir()
Метод формирования дерева разделов
Forms в файле Forms.class.php, класс Forms
Класс модуля "Формы"
Forms.class.php | procedural page Forms.class.php
Forms.php | procedural page Forms.php
Forums в файле Forums.class.php, класс Forums
Класс модуля "Форумы"
Forums.class.php | procedural page Forums.class.php
Forums.php | procedural page Forums.php
FREEDEBUG_URL | в файле Kernel.php, константа FREEDEBUG_URL
File.class.php | procedural page File.class.php
top
g
$GroupMass в файле InformationSystems.class.php, переменная InformationSystem::$GroupMass
Кэш с данными о группах
Graphic.class.php | procedural page Graphic.class.php
GenAddEditThemeXML в файле Forums.class.php, метод Forums::GenAddEditThemeXML()
УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
GenEditMessageXML в файле Forums.class.php, метод Forums::GenEditMessageXML()
УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
GenForumsXML в файле Forums.class.php, метод Forums::GenForumsXML()
Устаревший метод
GenGroupXmlTree в файле InformationSystems.class.php, метод InformationSystem::GenGroupXmlTree()
Метод формирования полного XML дерева информационных групп для информационной системы
GenMessageXML в файле Forums.class.php, метод Forums::GenMessageXML()
Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном
GenSmilesXML в файле Forums.class.php, метод Forums::GenSmilesXML()
Метод возвращает XML для смайликов
GenThemesXML в файле Forums.class.php, метод Forums::GenThemesXML()
Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном
GenUserInfoXML в файле Forums.class.php, метод Forums::GenUserInfoXML()
УСТАРЕВШИЙ Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном
GenXml в файле ExternalXml.class.php, метод ExternalXml::GenXml()
Метод генерации XML для переданного массива
GenXml4Comment в файле shop.class.php, метод shop::GenXml4Comment()
Метод генерирующий XML для отзыва о товаре
GenXml4Company в файле shop.class.php, метод shop::GenXml4Company()
Метод генерирует XML для организации
GenXml4CompareItems в файле shop.class.php, метод shop::GenXml4CompareItems()
Метод генерирует xml для товаров, выбранных для сравнения
GenXML4Currency в файле shop.class.php, метод shop::GenXML4Currency()
Метод генерирует XML для указанной валюты
GenXML4InfSys в файле Structure.class.php, метод Structure::GenXML4InfSys()
Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры
GenXml4Item в файле shop.class.php, метод shop::GenXml4Item()
Метод построения XML для товара, его свойств и сопутствующих товаров
GenXml4ItemCatalogCommentAverageGrade в файле shop.class.php, метод shop::GenXml4ItemCatalogCommentAverageGrade()
Метод возвращает среднею оценку по товару.
GenXml4ItemCatalogComments в файле shop.class.php, метод shop::GenXml4ItemCatalogComments()
Метод возвращает все комментарии, относящиеся к данному товару.
GenXml4ListItems в файле Lists.class.php, метод lists::GenXml4ListItems()
Метод генерирует XML для всех элементов списка.
GenXml4Mesures в файле shop.class.php, метод shop::GenXml4Mesures()
Метод генерирует XML для единиц измерения
GenXml4OrderStatus в файле shop.class.php, метод shop::GenXml4OrderStatus()
Метод генерирует XML для статуса доставки
GenXml4Poll в файле Polls.class.php, метод polls::GenXml4Poll()
Метод формирования XML для опроса
GenXml4Properties в файле shop.class.php, метод shop::GenXml4Properties()
Метод построения XML для свойств.
GenXml4Property в файле shop.class.php, метод shop::GenXml4Property()
Возвращает XML свойства.
GenXml4Saller в файле shop.class.php, метод shop::GenXml4Saller()
Возвращает XML продавца.
GenXml4Sallers в файле shop.class.php, метод shop::GenXml4Sallers()
Метод построения XML для продавцов.
GenXml4Shop | в файле shop.class.php, метод shop::GenXml4Shop()
GenXml4StructureLevelMass в файле Structure.class.php, метод Structure::GenXml4StructureLevelMass()
Метод генерации части XML-а для записей указанного уровня
GenXmlProducerList в файле shop.class.php, метод shop::GenXmlProducerList()
Метод генерирует XML для списка продавцов магазина
GetAccessItem в файле InformationSystems.class.php, метод InformationSystem::GetAccessItem()
Метод определения доступности информационного элемента
GetAdvertisement в файле Advertisement.class.php, метод Advertisement::GetAdvertisement()
Метод возвращает данные об элементе (баннере, всплывающем окне и т.п.)
GetAlias в файле Site.class.php, метод site::GetAlias()
Метод получения данных об алиасе сайта
GetAliasById в файле Site.class.php, метод site::GetAliasById()
Метод возвращает информацию об алиасе (домене)
GetAllAlias в файле Site.class.php, метод site::GetAllAlias()
Метод возвращает информацию обо всех доменах
GetAllCity в файле shop.class.php, метод shop::GetAllCity()
Enter description here...
GetAllCityArea в файле shop.class.php, метод shop::GetAllCityArea()
Метод выборки всех районов города
GetAllComments в файле shop.class.php, метод shop::GetAllComments()
Метод возвращает список всех комментариев
GetAllCompanies в файле shop.class.php, метод shop::GetAllCompanies()
Метод для получения списка всех компаний
GetAllCondOfDelivery в файле shop.class.php, метод shop::GetAllCondOfDelivery()
Метод выборки всех условий доставки
GetAllConferences в файле Forums.class.php, метод Forums::GetAllConferences()
Метод получения информации о всех конференциях сайт.
GetAllCountries | в файле shop.class.php, метод shop::GetAllCountries()
GetAllCoupons в файле shop.class.php, метод shop::GetAllCoupons()
Метод возвращает список купонов по заданным условиям
GetAllCurrency в файле shop.class.php, метод shop::GetAllCurrency()
Метод выборки информации обо всех валютах
GetAllDiscounts в файле shop.class.php, метод shop::GetAllDiscounts()
Метод возвращает список всех скидок
GetAllDiscountsForItem в файле shop.class.php, метод shop::GetAllDiscountsForItem()
Метод извлечения информации обо всех скидках для данного товара
GetAllForms в файле Forms.class.php, метод Forms::GetAllForms()
Метод получения всех форм.
GetAllForums в файле Forums.class.php, метод Forums::GetAllForums()
Метод для получения всех форумов
GetAllForumsGroup в файле Forums.class.php, метод Forums::GetAllForumsGroup()
Метод для получения списка всех групп
GetAllGroups в файле shop.class.php, метод shop::GetAllGroups()
Метод получения всех групп магазина
GetAllInformationSystems в файле InformationSystems.class.php, метод InformationSystem::GetAllInformationSystems()
Метод возвращает список инфосистем
GetAllItems в файле shop.class.php, метод shop::GetAllItems()
Метод получения всех товаров заданного магазина и заданной группы товаров
GetAllItemsForOrder в файле shop.class.php, метод shop::GetAllItemsForOrder()
Метод получения заказанных товаров
GetAllLibDirs в файле lib.class.php, метод lib::GetAllLibDirs()
Метод возвращает список всех директори типовых дин. страниц
GetAllLibProperties в файле lib.class.php, метод lib::GetAllLibProperties()
Метод возвращает всписок всех дополнительных параметров типовой динамической страницы
GetAllLibPropertyListItems в файле lib.class.php, метод lib::GetAllLibPropertyListItems()
Метод для получения списка всех элементов списка
GetAllLibs в файле lib.class.php, метод lib::GetAllLibs()
Метод возвращает список всех типовых страниц
GetAllListProperties в файле shop.class.php, метод shop::GetAllListProperties()
Метод получения всех дополнительных свойств для магазина
GetAllLocation в файле shop.class.php, метод shop::GetAllLocation()
Метод получения списка всех областей (штатов)
GetAllMessages в файле Forums.class.php, метод Forums::GetAllMessages()
Метод для получения всех сообщений
GetAllMesures в файле shop.class.php, метод shop::GetAllMesures()
Метод выборки всех единиц измерения
GetAllModificationItems в файле shop.class.php, метод shop::GetAllModificationItems()
Метод возвращает информацию обо всех модификациях данного товара
GetAllOrderDiscounts в файле shop.class.php, метод shop::GetAllOrderDiscounts()
Метод для извлечения информации обо всех скидках
GetAllOrders в файле shop.class.php, метод shop::GetAllOrders()
Метод выборки заказов для магазина
GetAllOrderStatus в файле shop.class.php, метод shop::GetAllOrderStatus()
Метод получения информации обо всех статусах заказаов
GetAllPollsGroups в файле Polls.class.php, метод polls::GetAllPollsGroups()
Метод получения информации о всех группах опросов
GetAllPricesForItem в файле shop.class.php, метод shop::GetAllPricesForItem()
Метод получения информации о ценах, заданных для товара
GetAllPricesForShop в файле shop.class.php, метод shop::GetAllPricesForShop()
Метод получения списка цен для магазина
GetAllProducers в файле shop.class.php, метод shop::GetAllProducers()
Метод получения информации обо всех производителях
GetAllPropertiesItem в файле shop.class.php, метод shop::GetAllPropertiesItem()
Метод извлечения информации о дополнительных свойствах заданного товара
GetAllSellers в файле shop.class.php, метод shop::GetAllSellers()
Метод получения информации о всех продавцах магазина $shop_id, если $shop_id = false, то о продавцах всех магазинов
GetAllSession в файле Counter.class.php, метод counter::GetAllSession()
Определяет число сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"
GetAllShops в файле shop.class.php, метод shop::GetAllShops()
Метод для получения списка всех магазинов
GetAllStructure в файле Structure.class.php, метод Structure::GetAllStructure()
Метод для получения списка всех узлов структуры сайта
GetAllStructureProperties в файле Structure.class.php, метод Structure::GetAllStructureProperties()
Метод для получения списка всех доп. свойств структуры
GetAllStructurePropertyValuesOfProperty в файле Structure.class.php, метод Structure::GetAllStructurePropertyValuesOfProperty()
Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства
GetAllSystemOfPay в файле shop.class.php, метод shop::GetAllSystemOfPay()
Метод получения всех активных платежных систем
GetAllTax в файле shop.class.php, метод shop::GetAllTax()
Метод получения информации о налогах
GetAllTypeOfDelivery в файле shop.class.php, метод shop::GetAllTypeOfDelivery()
Метод выборки всех типов доставки для конкретного магазина
GetAllUsers в файле Site_users.class.php, метод SiteUsers::GetAllUsers()
Метод выборки всех пользователей сайта
GetAllUserTypes в файле UserAccess.class.php, метод user_access::GetAllUserTypes()
Метод возвращает список типов пользователей
GetBotsInfo в файле Counter.class.php, метод counter::GetBotsInfo()
Метод получения данных о ботах и посещенных ими страницах
GetCacheContent в файле Cache.class.php, метод Cache::GetCacheContent()
Метод получения данных из кэша
GetCacheContentByAddress в файле Cache.class.php, метод Cache::GetCacheContentByAddress()
Метод возвращает данные из кэша, принимает адрес (позицию) блока в кэше и имя кэша
GetCaptchaId в файле Captcha.class.php, метод Captcha::GetCaptchaId()
Метод генерирует и возвращает уникальный индекс для CAPTCHA
GetCart в файле shop.class.php, метод shop::GetCart()
Метод, осуществляющий извлечение корзины
GetCity в файле shop.class.php, метод shop::GetCity()
Метод, осуществляющий извлечение города
GetComment в файле shop.class.php, метод shop::GetComment()
Метод возвращает информацию о комментарии к товару
GetCommentInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetCommentInformationSystemItem()
Метод получения комментариев информационных элементов
GetCompany в файле shop.class.php, метод shop::GetCompany()
Метод для получения информации об организации
GetCondOfDelivery в файле shop.class.php, метод shop::GetCondOfDelivery()
Метод, осуществляющий извлечение условия доставки
GetCondOfDeliveryXml в файле shop.class.php, метод shop::GetCondOfDeliveryXml()
Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)
GetConference в файле Forums.class.php, метод Forums::GetConference()
Метод для получения информации о конференции.
GetConferencePath в файле Forums.class.php, метод Forums::GetConferencePath()
Метод возвращает путь к конференции по ее идентификатору
GetConstants в файле Constants.class.php, метод Constants::GetConstants()
Метод получения данных о константах
GetCookieExpires в файле shop.class.php, метод shop::GetCookieExpires()
Метод возвращает время истечения данных в корзине, хранящейся в кукисах.
GetCountCity в файле shop.class.php, метод shop::GetCountCity()
Метод получения числа городов для области
GetCountCountry в файле shop.class.php, метод shop::GetCountCountry()
Метод получения числа стран
GetCountCurrency в файле shop.class.php, метод shop::GetCountCurrency()
Метод получения числа валют в справочнике
GetCountDiscount в файле shop.class.php, метод shop::GetCountDiscount()
Метод получения числа скидок для магазина
GetCounterInform в файле Counter.class.php, метод counter::GetCounterInform()
Метод получения информации о данных счетчика за определенную дату
GetCountInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetCountInformationSystemItem()
Метод получения количества элементов информационной системы
GetCountItemsAndGroups в файле InformationSystems.class.php, метод InformationSystem::GetCountItemsAndGroups()
Метод получения числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()
GetCountItemsAndGroups в файле shop.class.php, метод shop::GetCountItemsAndGroups()
Метод получения числа элементов и групп для переданной родительской группы
GetCountItemsCatalog в файле shop.class.php, метод shop::GetCountItemsCatalog()
Метод получения числа товаров в одном или во всех разделах магазина
GetCountItemsWithConditions в файле shop.class.php, метод shop::GetCountItemsWithConditions()
Метод получения числа товаров, параметры которых удовлетворяют заданным условиям
GetCountLocation в файле shop.class.php, метод shop::GetCountLocation()
Метод получения числа областей (штатов) для страны
GetCountMesures в файле shop.class.php, метод shop::GetCountMesures()
Метод получения числа единиц измерения в справочнике
GetCountOrder в файле shop.class.php, метод shop::GetCountOrder()
Метод выборки количества заказов для магазина
GetCountOrderStatus в файле shop.class.php, метод shop::GetCountOrderStatus()
Метод получения числа статусов заказа
GetCountPolls в файле Polls.class.php, метод polls::GetCountPolls()
Метод получения числа опросов в группе
GetCountPollsGroup в файле Polls.class.php, метод polls::GetCountPollsGroup()
Метод получения числа групп опросов для одного или всех сайтов
GetCountProducers в файле shop.class.php, метод shop::GetCountProducers()
Метод получения числа производителей для данного магазина
GetCountProperties в файле shop.class.php, метод shop::GetCountProperties()
Метод получения числа свойств товаров конкретного магазина
GetCountProperty4InformationSystem в файле InformationSystems.class.php, метод InformationSystem::GetCountProperty4InformationSystem()
Метод получения числа свойств информационной системы
GetCountProperty4Structure в файле Structure.class.php, метод Structure::GetCountProperty4Structure()
Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют
GetCountry в файле shop.class.php, метод shop::GetCountry()
Метод, осуществляющий извлечение страны
GetCountSellers в файле shop.class.php, метод shop::GetCountSellers()
Метод получения числа продавцов в справочнике
GetCountShops в файле shop.class.php, метод shop::GetCountShops()
Метод получения числа магазинов для одного или всех сайтов, обслуживаемых системой управления
GetCountShowingBanner в файле Advertisement.class.php, метод Advertisement::GetCountShowingBanner()
Метод возвращает количество показов баннера
GetCountShowingBannerAtDay в файле Advertisement.class.php, метод Advertisement::GetCountShowingBannerAtDay()
Метод возвращает количество показов баннера за конкретный день
GetCountSystemOfPay в файле shop.class.php, метод shop::GetCountSystemOfPay()
Метод получения числа систем оплаты
GetCountTax в файле shop.class.php, метод shop::GetCountTax()
Метод получения числа налогов в справочнике
GetCountTypeOfDelivery в файле shop.class.php, метод shop::GetCountTypeOfDelivery()
Метод получения числа типов доставок для данного магазина
GetCountTypePrices в файле shop.class.php, метод shop::GetCountTypePrices()
Метод получения числа типов цен для магазина
GetCoupon в файле shop.class.php, метод shop::GetCoupon()
Метод возвращает массив с информацией о купоне
GetCouponByText в файле shop.class.php, метод shop::GetCouponByText()
Возвращает информацию о купоне по его тексту
GetCurrency в файле shop.class.php, метод shop::GetCurrency()
Метод, осуществляющий извлечение информации о валюте
GetCurrencyCoefficientToShopCurrency в файле shop.class.php, метод shop::GetCurrencyCoefficientToShopCurrency()
Метод определения коэффициента пересчета валюты товара в валюту магазина
GetCurrencyForShop в файле shop.class.php, метод shop::GetCurrencyForShop()
Метод получения валюты, указанной по умолчанию для магазина
GetCurrencyXml в файле shop.class.php, метод shop::GetCurrencyXml()
Метод формирования xml для валюты
GetCurrentAlias в файле Site.class.php, метод site::GetCurrentAlias()
Метод определения основного алиаса сайта
GetCurrentSiteUser в файле Site_users.class.php, метод SiteUsers::GetCurrentSiteUser()
Метод определения идентификатора текущего пользователя сайта.
GetCurrentUser в файле Kernel.class.php, метод kernel::GetCurrentUser()
Метод определения идентификатора текущего авторизированного пользователя раздела администрирования
GetCurrentYear в файле Kernel.class.php, метод kernel::GetCurrentYear()
Метод получения значения текущего года
GetDayInformation в файле Counter.class.php, метод counter::GetDayInformation()
Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"
GetDBVersion в файле Kernel.class.php, метод kernel::GetDBVersion()
Метод определения версии MySQL
GetDefaultCurrency в файле shop.class.php, метод shop::GetDefaultCurrency()
Метод получения информации о базовой валюте
GetDefaultGroup в файле Site_users.class.php, метод SiteUsers::GetDefaultGroup()
Метод получения id группы используемой по умолчанию
GetDefaultOrderStatus в файле shop.class.php, метод shop::GetDefaultOrderStatus()
Метод получения статуса заказа, установленного по умолчанию
GetDelimitedGroups в файле shop.class.php, метод shop::GetDelimitedGroups()
Метод формирования дерева групп для магазина.
GetDiscount в файле shop.class.php, метод shop::GetDiscount()
Метод, осуществляющий извлечение информации о скидке
GetDocumentVersion в файле Documents.class.php, метод documents::GetDocumentVersion()
Метод получения информации о текущей версии документа
GetExpansion в файле InformationSystems.class.php, метод InformationSystem::GetExpansion()
Метод получения расширения файла
GetExpires в файле Kernel.class.php, метод kernel::GetExpires()
Метод получения времени истечения актуальности страницы
GetExtension в файле Kernel.class.php, метод kernel::GetExtension()
Метод возвращает расширение файла
GetExternalInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetExternalInformationSystemItem()
Метод получения элементов информационной системы. Переименован с GetInformationSystemItem
GetExtraProperty в файле Site_users.class.php, метод SiteUsers::GetExtraProperty()
Метод получения значения свойств дополнительного параметра
GetFascicle в файле Maillist.class.php, метод Maillist::GetFascicle()
Метод возвращает информацию о почтовой рассылке
GetFileContent в файле File.class.php, метод File::GetFileContent()
Метод получения содержимого файла
GetFillForms в файле Forms.class.php, метод Forms::GetFillForms()
Метод получения списка заполненных форм для формы $forms_id.
GetFillFormsFields в файле Forms.class.php, метод Forms::GetFillFormsFields()
Метод получения списка и значения полей для заполненной формы.
GetForm в файле Forms.class.php, метод Forms::GetForm()
Метод обработки содержимого отправленной формы
GetFormFields в файле Forms.class.php, метод Forms::GetFormFields()
Метод получения данных о полях формы
GetForum в файле Forums.class.php, метод Forums::GetForum()
Метод получения информации о форуме
GetForumAccess в файле Forums.class.php, метод Forums::GetForumAccess()
Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму
GetForumAndItemIdFromPath в файле Forums.class.php, метод Forums::GetForumAndItemIdFromPath()
Метод получения данных об идентификаторе форума и темы по переданному массиву с элементами пути
GetForumsGroup в файле Forums.class.php, метод Forums::GetForumsGroup()
Метод возвращает информацию о группе форумов
GetGDVersion в файле Kernel.class.php, метод kernel::GetGDVersion()
Метод определения версии GD библиотеки
GetGroup в файле shop.class.php, метод shop::GetGroup()
Метод, осуществляющий извлечение информации о группе
GetGroups в файле shop.class.php, метод shop::GetGroups()
Метод возвращает список групп магазина
GetGroupsForUser в файле Site_users.class.php, метод SiteUsers::GetGroupsForUser()
Метод определения идентификаторов групп, в которые входит пользователь
GetGroupsInformationSystem в файле InformationSystems.class.php, метод InformationSystem::GetGroupsInformationSystem()
Метод формирования дерева групп информационной группы
GetGroupsTree в файле shop.class.php, метод shop::GetGroupsTree()
Метод получения массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской
GetGroupsXmlTree в файле shop.class.php, метод shop::GetGroupsXmlTree()
Метод построения дерева xml для групп
GetGroupWithPath в файле shop.class.php, метод shop::GetGroupWithPath()
Метод получения информации о группе по пути, если такая существует в данной подгруппе магазина
GetGroupWithValue в файле shop.class.php, метод shop::GetGroupWithValue()
Метод получения информации о группе по наименованию, если такая существует в данной подгруппе магазина
GetIdInformationItem в файле InformationSystems.class.php, метод InformationSystem::GetIdInformationItem()
Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы
GetImageSize в файле Image.class.php, метод Image::GetImageSize()
Метод определяет высоту и ширину изображения
GetInformationFromPath в файле InformationSystems.class.php, метод InformationSystem::GetInformationFromPath()
Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI
GetInformationGroup в файле InformationSystems.class.php, метод InformationSystem::GetInformationGroup()
Получение информации о группе. Использует кэш "INF_SYS_GROUP"
GetInformationGroupName в файле InformationSystems.class.php, метод InformationSystem::GetInformationGroupName()
Метод получения имени информационной группы
GetInformationSystem в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystem()
Метод получения данных об информационной системе
GetInformationSystemGroupAccess в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemGroupAccess()
Метод определения уровня доступности информационной группы
GetInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemItem()
Метод для получения данных об информационном элементе
GetInformationSystemItemAccess в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemItemAccess()
Метод определения уровня доступности информационного элемента
GetInformationSystemItems в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemItems()
Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит
GetInitialData в файле Counter.class.php, метод counter::GetInitialData()
Метод получения начальных данных для счетчика
GetIpInfo в файле ip.class.php, метод ip::GetIpInfo()
Метод получения информации о запретах для переданного ip-адреса
GetIpInformation в файле Counter.class.php, метод counter::GetIpInformation()
Метод выборки информации для IP-адреса
GetItem в файле shop.class.php, метод shop::GetItem()
Метод, осуществляющий извлечение информации о товаре
GetItemByParam в файле shop.class.php, метод shop::GetItemByParam()
Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента
GetItemDiscount в файле shop.class.php, метод shop::GetItemDiscount()
Метод получения информации о скидке на товар
GetItemFromCart в файле shop.class.php, метод shop::GetItemFromCart()
Метод получения информации о товаре из корзины для пользователя
GetItemPath в файле shop.class.php, метод shop::GetItemPath()
Метод определения идентификатора группы товаров и идентификатора товара по значению URL
GetItemsFromCart в файле shop.class.php, метод shop::GetItemsFromCart()
Метод получения товаров, находящихся в корзине
GetItemsFromCookiesToCart в файле shop.class.php, метод shop::GetItemsFromCookiesToCart()
Метод перемещения информации о заказанном товаре в таблицу корзины
GetItemsXmlTree в файле shop.class.php, метод shop::GetItemsXmlTree()
Метод построения XML для товаров
GetItemXml в файле shop.class.php, метод shop::GetItemXml()
Метод формирования xml товара
GetLastModified в файле Kernel.class.php, метод kernel::GetLastModified()
Метод получения времени последнего изменения страницы
GetLib в файле lib.class.php, метод lib::GetLib()
Метод возвращает типовую динамическую страницу по её идентификатору
GetLibDir в файле lib.class.php, метод lib::GetLibDir()
Метод для получения информации о директории типовых дин. страниц
GetLibDirTree в файле lib.class.php, метод lib::GetLibDirTree()
Метод формирования дерева разделов
GetLibProperty в файле lib.class.php, метод lib::GetLibProperty()
Метод возвращает информацию о параметре типовой динамической страницы
GetList в файле Lists.class.php, метод lists::GetList()
Метод выборки данных о списках
GetListExtraProperties в файле Site_users.class.php, метод SiteUsers::GetListExtraProperties()
Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором
GetListItem в файле Lists.class.php, метод lists::GetListItem()
Метод получения данные об элементе списка
GetListItemIfIssetValue в файле Lists.class.php, метод lists::GetListItemIfIssetValue()
Метод проверки наличия значения в списке
GetListItemsValuesById в файле Lists.class.php, метод lists::GetListItemsValuesById()
Метод возвращает элементы списка.
GetListPrimaryProperties в файле Site_users.class.php, метод SiteUsers::GetListPrimaryProperties()
УСТАРЕВШИЙ Метод получения основных данных о пользователе
GetLocation в файле shop.class.php, метод shop::GetLocation()
Метод, осуществляющий извлечение области
GetLogStat в файле Search.class.php, метод Search::GetLogStat()
Метод для получения сгруппированной информации о поисковых запросах
GetMaillist в файле Maillist.class.php, метод Maillist::GetMaillist()
Метод возвращает ассоциативный массив с информацией о списке рассылок
GetMaillistXML в файле Maillist.class.php, метод Maillist::GetMaillistXML()
Метод генерирующий XML для состояния подписки конкретного пользователя сайта
GetMasGroup в файле InformationSystems.class.php, метод InformationSystem::GetMasGroup()
Метод получения массива информационных групп
GetMasGroupToRoot | в файле shop.class.php, метод shop::GetMasGroupToRoot()
GetMesure в файле shop.class.php, метод shop::GetMesure()
Метод, осуществляющий извлечение информации о единице измерения
getmicrotime в файле Kernel.class.php, метод kernel::getmicrotime()
Метод получения значения времени
GetMimeType в файле Kernel.class.php, метод kernel::GetMimeType()
Метод определения MIME-типа файла
GetNewUsersInform в файле Counter.class.php, метод counter::GetNewUsersInform()
Метод выборки информации о новых пользователях сайта
GetObject в файле Kernel.class.php, метод kernel::GetObject()
Метод создает глобально доступный объект
GetOrder в файле shop.class.php, метод shop::GetOrder()
Метод, осуществляющий извлечение заказа
GetOrderDiscount в файле shop.class.php, метод shop::GetOrderDiscount()
Метод возвращает информацию о скидке для заказов
GetOrderDiscountForSum в файле shop.class.php, метод shop::GetOrderDiscountForSum()
Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина
GetOrderDiscountWithConditions в файле shop.class.php, метод shop::GetOrderDiscountWithConditions()
Метод возвращает список скидок на сумму заказа по заданным условиям
GetOrderInfoArray в файле shop.class.php, метод shop::GetOrderInfoArray()
Метод формирования массива с информацией о заказе для вставки в заказы
GetOrderItem в файле shop.class.php, метод shop::GetOrderItem()
Метод, осуществляющий извлечение товара из заказа
GetOrderItems в файле shop.class.php, метод shop::GetOrderItems()
Метод, осуществляющий извлечение товаров из заказа
GetOrdersStatus в файле shop.class.php, метод shop::GetOrdersStatus()
Метод, осуществляющий извлечение состояния заказа
GetOrderXml в файле shop.class.php, метод shop::GetOrderXml()
Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных
GetPageCount в файле Search.class.php, метод Search::GetPageCount()
Метод определения числа проиндексированных страниц
GetPageInfo в файле Search.class.php, метод Search::GetPageInfo()
Метод получения информации о проиндексированных страницах
GetPathGroup в файле InformationSystems.class.php, метод InformationSystem::GetPathGroup()
Метод формирования пути по информационным группам
GetPathGroup в файле shop.class.php, метод shop::GetPathGroup()
Метод формирования пути по группам товара
GetPathItem в файле InformationSystems.class.php, метод InformationSystem::GetPathItem()
Метод формирования пути к данному информационному элементу
GetPathProducer | в файле shop.class.php, метод shop::GetPathProducer()
GetPoll в файле Polls.class.php, метод polls::GetPoll()
Метод возвращает данные об опросе
GetPollsGroup в файле Polls.class.php, метод polls::GetPollsGroup()
Метод получения информации о группе опросов
GetPrice в файле shop.class.php, метод shop::GetPrice()
Метод, осуществляющий извлечение типа цены
GetPriceForItem в файле shop.class.php, метод shop::GetPriceForItem()
Метод определения наличия указанной цены для заданного товара
GetPriceForUser в файле shop.class.php, метод shop::GetPriceForUser()
Метод определения цены товара для заданного пользователя
GetProducer в файле shop.class.php, метод shop::GetProducer()
Метод, осуществляющий извлечение информации о производителе
GetProperrtyMenuId в файле Structure.class.php, метод Structure::GetProperrtyMenuId()
Метод получения информации о текущем разделе меню
GetPropertiesOfGroup в файле shop.class.php, метод shop::GetPropertiesOfGroup()
Метод для получения списка идентификаторов свойств товаров для определенной группы.
GetPropertiesOfGroupForXml в файле shop.class.php, метод shop::GetPropertiesOfGroupForXml()
Возвращает список свойств, разврешенных для вывода в XML
GetPropertyACountProperty в файле Structure.class.php, метод Structure::GetPropertyACountProperty()
Метод получения количества свойств для разных сайтов
GetPropertyCountRow в файле InformationSystems.class.php, метод InformationSystem::GetPropertyCountRow()
Метод получения числа записей в выборке инфосистем, групп или информационных элементов
GetPropertyCountRow в файле Structure.class.php, метод Structure::GetPropertyCountRow()
Метод получения количества выбранных элементов
GetPropertyEditId в файле Structure.class.php, метод Structure::GetPropertyEditId()
Метод полчения информации о редактиремом элементе структуры
GetPropertyError в файле InformationSystems.class.php, метод InformationSystem::GetPropertyError()
Метод возвращающий код ошибки, возникающей при работе с методами класса
GetPropertyLevel в файле Structure.class.php, метод Structure::GetPropertyLevel()
Метод получения информации о максимальном уровне
GetPropertyMasInformationGroups в файле InformationSystems.class.php, метод InformationSystem::GetPropertyMasInformationGroups()
Метод получения массива свойств информацуонных групп
GetPropertyParentId в файле Structure.class.php, метод Structure::GetPropertyParentId()
Метод получения идентификатора родительского узла текущего элемента структуры
GetPropertyRecordOnPage в файле InformationSystems.class.php, метод InformationSystem::GetPropertyRecordOnPage()
Метод получения числа записей, выводимых на страницу
GetPropertySectionPath в файле InformationSystems.class.php, метод InformationSystem::GetPropertySectionPath()
Метод получения значения свойтва, содержащего пути по группам
GetPropertySeparator в файле Structure.class.php, метод Structure::GetPropertySeparator()
Метод получения информации о разделителе
GetPropertysGroup в файле InformationSystems.class.php, метод InformationSystem::GetPropertysGroup()
Метод получения данных о дополнительных свойствах информационной группы
GetPropertysInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetPropertysInformationSystemItem()
Метод получения свойств информационных элементов
GetPropertyStructureMass в файле Structure.class.php, метод Structure::GetPropertyStructureMass()
Метод получения информации об элементах структуры
GetPropertyStructureParentMass в файле Structure.class.php, метод Structure::GetPropertyStructureParentMass()
Метод получения информации о родительских разделах элемента структуры
GetPropertyStructurePropertysList в файле Structure.class.php, метод Structure::GetPropertyStructurePropertysList()
Метод получения дополнительных свойств структуры
GetPropertyValue в файле Structure.class.php, метод Structure::GetPropertyValue()
Метод для получения информации о значении свойства структуры
GetPropretyOfItems в файле shop.class.php, метод shop::GetPropretyOfItems()
Метод, осуществляющий извлечение свойства товара (по идентификатору таблицы связи свойств и товаров)
GetSearchSystemInform в файле Counter.class.php, метод counter::GetSearchSystemInform()
Метод выборки информации о поисковых системах
GetSecondaryStat в файле Counter.class.php, метод counter::GetSecondaryStat()
Метод получения статистической информации из таблицы сессий
GetSectionPath в файле lib.class.php, метод lib::GetSectionPath()
Метод возвращает путь к типовой дин. стренице
GetSelect в файле show_table.class.php, метод show_table::GetSelect()
Метод формирования html содержимого тега select
GetSeller в файле shop.class.php, метод shop::GetSeller()
Метод получения информации о продавце по его идентификатору.
GetShop в файле shop.class.php, метод shop::GetShop()
Метод, осуществляющий извлечение информации о магазине
GetShopCurrency в файле shop.class.php, метод shop::GetShopCurrency()
Метод получения информации о валюте магазина
GetShopDiscount в файле shop.class.php, метод shop::GetShopDiscount()
Метод получения списка скидок для магазина
GetShopGroupsToRoot в файле shop.class.php, метод shop::GetShopGroupsToRoot()
Метод получения массива с данными о каталогах магазина, начиная с данной и до корневой
GetShopWhithStructureId в файле shop.class.php, метод shop::GetShopWhithStructureId()
Метод выбора информации о магазине данного узла структуры сайта
GetSite в файле Site.class.php, метод site::GetSite()
Метод получения данных о сайте по его идентификатору
GetSiteUser в файле Site_users.class.php, метод SiteUsers::GetSiteUser()
Метод получения информации о пользователе сайта
GetSiteUserXml в файле Site_users.class.php, метод SiteUsers::GetSiteUserXml()
Метод формирования XML с данными о пользователе
GetStatArray в файле Counter.class.php, метод counter::GetStatArray()
Метод получения статистической информации из основной таблицы
GetStatDataArray в файле Counter.class.php, метод counter::GetStatDataArray()
Метод получения статистических данных за переданный промежуток времени
GetStructure в файле Structure.class.php, метод Structure::GetStructure()
Метод выборки всех страниц структуры
GetStructureAccess в файле Structure.class.php, метод Structure::GetStructureAccess()
Метод получения информации о доступе к узлу элементов структуры
GetStructureForParent в файле Structure.class.php, метод Structure::GetStructureForParent()
Метод получения подразделов для раздела
GetStructureItem в файле Structure.class.php, метод Structure::GetStructureItem()
* Метод получения данных об элементе структуры
GetStructurePath в файле Structure.class.php, метод Structure::GetStructurePath()
Метод определения полного пути к странице
GetStructureProperty в файле Structure.class.php, метод Structure::GetStructureProperty()
Метод возвращает заполненные св-ва узлов структуры
GetSystemOfPay в файле shop.class.php, метод shop::GetSystemOfPay()
Метод, осуществляющий извлечение платёжной системы
GetTableNames в файле ExecSqlQuery.class.php, метод ExecSqlQuery::GetTableNames()
Метод для получения списка таблиц, разделенных запятыми.
GetTax в файле shop.class.php, метод shop::GetTax()
Метод, осуществляющий извлечение налога
GetTemplate в файле Templates.class.php, метод templates::GetTemplate()
Метод получения информации о макете
GetTemplate в файле Kernel.class.php, метод kernel::GetTemplate()
Метод получения текущего макета
GetTheme в файле Forums.class.php, метод Forums::GetTheme()
Метод возвращает информацию о теме форума
GetTyingProducts в файле shop.class.php, метод shop::GetTyingProducts()
Метод получения информации о сопутствующем товаре
GetTyingProductsForItem в файле shop.class.php, метод shop::GetTyingProductsForItem()
Метод получения ID сопутствующих товаров для заданного товара
GetTypeOfDelivery в файле shop.class.php, метод shop::GetTypeOfDelivery()
Метод, осуществляющий извлечение типа доставки
GetTypeOfDeliveryForOrder в файле shop.class.php, метод shop::GetTypeOfDeliveryForOrder()
Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.
GetUseCJ в файле Counter.class.php, метод counter::GetUseCJ()
Метод получения данных о использовании кукисов и Java
GetUserDir в файле Site_users.class.php, метод SiteUsers::GetUserDir()
Метод возвращает абсолютный путь к директории пользователя сайта
GetUserGroups в файле Site_users.class.php, метод SiteUsers::GetUserGroups()
УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.
GetUsersDir в файле Site_users.class.php, метод SiteUsers::GetUsersDir()
Метод возвращает абсолютный путь к директории для хранения файлов пользователей
GetValueExtraProperty в файле Site_users.class.php, метод SiteUsers::GetValueExtraProperty()
Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра
GetValueItemProperty в файле shop.class.php, метод shop::GetValueItemProperty()
Метод получения значения дополнительного свойства для товара
GetXml4StructurePropertys в файле Structure.class.php, метод Structure::GetXml4StructurePropertys()
Метод получения XML для свойств структуры
GetXmlForInformatioItem в файле InformationSystems.class.php, метод InformationSystem::GetXmlForInformatioItem()
Метод формирования XML для отображения информационного элемента
GetXmlForItemsOrder в файле shop.class.php, метод shop::GetXmlForItemsOrder()
Метод формирования xml для товаров в заказе
GetXmlForOrder в файле shop.class.php, метод shop::GetXmlForOrder()
Метод формирования xml о заказе по идентификатору заказа
GetXmlProducer | в файле shop.class.php, метод shop::GetXmlProducer()
GetXsl в файле Xsl.class.php, метод xsl::GetXsl()
Метод получения информаци об XSL-шаблоне по его имени
get_count_row в файле Mysql.class.php, метод MySQL::get_count_row()
Метод возвращает количество строк в последнем запросе
get_CSS в файле Kernel.class.php, метод kernel::get_CSS()
Метод получения CSS стиля для страницы
get_current_page в файле Kernel.class.php, метод kernel::get_current_page()
Метод получения идентификатора текущего узла структуры
get_current_page_path в файле Kernel.class.php, метод kernel::get_current_page_path()
Метод получения пути текущей страницы
get_description в файле Kernel.class.php, метод kernel::get_description()
Метод получения описания страницы
get_documents_dir в файле Documents.class.php, метод documents::get_documents_dir()
Метод формирования дерева разделов
get_file_perms в файле File.class.php, метод File::get_file_perms()
Метод получения строки прав доступа к файлу
get_information_groups_path в файле InformationSystems.class.php, метод InformationSystem::get_information_groups_path()
Метод формирования пути по дереву информационных групп.
get_keywords в файле Kernel.class.php, метод kernel::get_keywords()
Метод получения ключевых слов страницы
get_mas_information_groups_for_xml в файле InformationSystems.class.php, метод InformationSystem::get_mas_information_groups_for_xml()
Метод возвращает XML для информационных групп
get_page_id в файле Kernel.class.php, метод kernel::get_page_id()
Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя
get_path в файле Documents.class.php, метод documents::get_path()
Метод формирования строки ссылок с родительскими разделами
get_polls_name в файле Polls.class.php, метод polls::get_polls_name()
Метод получения названия опроса
get_section_path в файле Xsl.class.php, метод xsl::get_section_path()
Функция возвращает путь по дереву разделов
get_title в файле Kernel.class.php, метод kernel::get_title()
Метод получения заголовка страницы
GISTOGRAMM_LIMIT | в файле Counter.php, константа GISTOGRAMM_LIMIT
GoSearch в файле Search.class.php, метод Search::GoSearch()
Метод выводит результаты поиска запроса $query с помощью XSL-шаблона $xslname в соответствии с дополнительными параметрами
graphic | в файле Graphic.class.php, класс graphic
graphic_diagramma в файле Graphic.class.php, метод graphic::graphic_diagramma()
Метод вывода круговой диаграммы
graphic_gistogramma в файле Graphic.class.php, метод graphic::graphic_gistogramma()
Метод вывода гистограммы
top
h
$hidden | в файле shop.class.php, переменная shop::$hidden
$html | в файле show_table.class.php, переменная show_table::$html
top
i
$image | в файле show_table.class.php, переменная show_table::$image
$image | в файле show_table.class.php, переменная table_fields::$image
$image_is_link | в файле show_table.class.php, переменная table_fields::$image_is_link
$image_link | в файле show_table.class.php, переменная table_fields::$image_link
$IndexForArray | в файле show_table.class.php, переменная table_fields::$IndexForArray
$ItemMass в файле InformationSystems.class.php, переменная InformationSystem::$ItemMass
Кэш с данными об элементах
$item_catalog_price в файле shop.class.php, переменная shop::$item_catalog_price
Цена товара магазина
Image в файле Image.class.php, класс Image
Ядро, класс для работы с графическими изображениями
imagebar в файле Graphic.class.php, метод graphic::imagebar()
Метод вывода гистограммы
implode_array в файле Kernel.class.php, метод kernel::implode_array()
Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно
IncCountMessage в файле Forums.class.php, метод Forums::IncCountMessage()
Метод наращивания счётчика количества сообщений для пользователя
IncPollReply в файле Polls.class.php, метод polls::IncPollReply()
Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote
IndexationForums в файле Forums.class.php, метод Forums::IndexationForums()
Метод индексации форумов
IndexationForumsMessages в файле Forums.class.php, метод Forums::IndexationForumsMessages()
Метод индексации сообщений тем форумов
IndexationShopItems | в файле shop.class.php, метод shop::IndexationShopItems()
IndexationStructure в файле Structure.class.php, метод Structure::IndexationStructure()
Метод индексации элементов структуры
InformationSystem в файле InformationSystems.class.php, класс InformationSystem
Класс модуля "Информационные системы"
InformationSystemItemAccess в файле InformationSystems.class.php, метод InformationSystem::InformationSystemItemAccess()
Метод определения доступности информационного элемента для пользователя
InformationSystems.class.php | procedural page InformationSystems.class.php
InformationSystems.php | procedural page InformationSystems.php
InitConstants в файле Kernel.class.php, метод kernel::InitConstants()
Метод инициализации констант сайта в соответствии с константой CURRENT_SITE
Insert в файле Cache.class.php, метод Cache::Insert()
Вставка значения в кэш
InsertBanners в файле Advertisement.class.php, метод Advertisement::InsertBanners()
Метод добавления баннера в группу/редактирования приоритета показа баннера в группе
InsertBannersGroup в файле Advertisement.class.php, метод Advertisement::InsertBannersGroup()
Метод добавления/редактирования информации о группе баннеров
InsertCity в файле shop.class.php, метод shop::InsertCity()
Метод, осуществляющий вставку города
InsertCityArea в файле shop.class.php, метод shop::InsertCityArea()
Метод добавления/редактирования информации о районе города
InsertComment в файле shop.class.php, метод shop::InsertComment()
Метод добавления/обновления информации об отзыве на товар
InsertCompany в файле shop.class.php, метод shop::InsertCompany()
Метод для вставки/обновления организации
InsertCondOfDelivery в файле shop.class.php, метод shop::InsertCondOfDelivery()
Метод, осуществляющий вставку условия доставки
InsertConference в файле Forums.class.php, метод Forums::InsertConference()
Метод, осуществляющий вставку информации о конференции.
InsertCountry в файле shop.class.php, метод shop::InsertCountry()
Метод, осуществляющий вставку области
InsertCoupon в файле shop.class.php, метод shop::InsertCoupon()
Метод для вставки/обновления информации о купоне
InsertCurrency в файле shop.class.php, метод shop::InsertCurrency()
Метод,осуществляющий вставку информации о валюте
InsertDiscount в файле shop.class.php, метод shop::InsertDiscount()
Метод, осуществляющий вставку информации о скидке
InsertExtraProperty в файле Site_users.class.php, метод SiteUsers::InsertExtraProperty()
Метод добавления/редактирования дополнительного параметра
InsertFascicle в файле Maillist.class.php, метод Maillist::InsertFascicle()
Метод добавления/редактирования выпуска рассылки
InsertForms в файле Forms.class.php, метод Forms::InsertForms()
Метод вставки/обновления информации о форме
InsertFormsFields в файле Forms.class.php, метод Forms::InsertFormsFields()
Метод вставки/обновления информации о поле формы
InsertFormsFill в файле Forms.class.php, метод Forms::InsertFormsFill()
Метод вставки/обновления информации о заполнении формы
InsertFormsFillValues в файле Forms.class.php, метод Forms::InsertFormsFillValues()
Метод вставки/обновления значений заполненной формы
InsertForum в файле Forums.class.php, метод Forums::InsertForum()
Метод добавления/редактирования форума.
InsertForumsGroup в файле Forums.class.php, метод Forums::InsertForumsGroup()
Метод добавления/редактирования группы форумов
InsertGroup в файле shop.class.php, метод shop::InsertGroup()
Метод, осуществляющий вставку группы, к которой могут относиться товары
InsertGroupPolls в файле Polls.class.php, метод polls::InsertGroupPolls()
Метод вставки информации о группе опросов
InsertInformationGroups в файле InformationSystems.class.php, метод InformationSystem::InsertInformationGroups()
Метод вставки/обновления данных об информационной группе
InsertInformationItems в файле InformationSystems.class.php, метод InformationSystem::InsertInformationItems()
Метод вставки/обновления данных об информационном элементе
InsertInformationPropertys в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertys()
Метод вставки/обновления информации о свойстве информационной системы
InsertInformationPropertysGroups в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertysGroups()
Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы
InsertInformationPropertysGroupsValue в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertysGroupsValue()
Метод вставки/обновления значения свойства информационной группы
InsertInformationPropertysItems в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertysItems()
Метод вставки/обновления значения свойства информационной
InsertInfotmationSystem в файле InformationSystems.class.php, метод InformationSystem::InsertInfotmationSystem()
Метод вставки/обновления данных об информационной системе
InsertIp в файле ip.class.php, метод ip::InsertIp()
Метод вставки/обновления информации об IP-адресе
InsertItem в файле shop.class.php, метод shop::InsertItem()
Метод, осуществляющий вставку информации о товаре
InsertItemDiscount в файле shop.class.php, метод shop::InsertItemDiscount()
Метод вставки скидки для определенного товара
InsertLib в файле lib.class.php, метод lib::InsertLib()
Метод для вставки информации о типовой динамической странице
InsertLibDir в файле lib.class.php, метод lib::InsertLibDir()
Метод для вставки/обновления информации о разделе типовых дин. страниц
InsertLibProperty в файле lib.class.php, метод lib::InsertLibProperty()
Метод вставки информации о параметре типовой динамической страницы
InsertLibPropertyListItem в файле lib.class.php, метод lib::InsertLibPropertyListItem()
Метод для вставки/обновления элемента списка для параметра типовой дин. страницы
InsertLocation в файле shop.class.php, метод shop::InsertLocation()
Метод, осуществляющий вставку области
InsertMaillist в файле Maillist.class.php, метод Maillist::InsertMaillist()
Метод добавления/редактирования информации о рассылке
InsertMesure в файле shop.class.php, метод shop::InsertMesure()
Метод, осуществляющий вставку информации о единице измерения
InsertOrder в файле shop.class.php, метод shop::InsertOrder()
Метод, осуществляющий вставку заказа
InsertOrderDiscount в файле shop.class.php, метод shop::InsertOrderDiscount()
Метод для вставки/обновления информации о скидке для заказов
InsertOrderItems в файле shop.class.php, метод shop::InsertOrderItems()
Метод, осуществляющий вставку товара в заказ
InsertOrderStatus в файле shop.class.php, метод shop::InsertOrderStatus()
Метод, осуществляющий вставку статуса заказа
InsertOrderWithoutSystemOfPay в файле shop.class.php, метод shop::InsertOrderWithoutSystemOfPay()
Метод вставки заказа, если платежная система не выбрана
InsertPrice в файле shop.class.php, метод shop::InsertPrice()
Метод, осуществляющий вставку типа цены
InsertPricesToItem в файле shop.class.php, метод shop::InsertPricesToItem()
Метод вставки связи товара и цены из справочника цен
InsertProducer в файле shop.class.php, метод shop::InsertProducer()
Метод, осуществляющий вставку производителя
InsertPropertiesItem в файле shop.class.php, метод shop::InsertPropertiesItem()
Метод вставки информации о дополнительных свойствах товра
InsertPropretyOfItems в файле shop.class.php, метод shop::InsertPropretyOfItems()
Метод, осуществляющий вставку свойства товара
InsertRecord в файле Counter.class.php, метод counter::InsertRecord()
Метод добавления записи в основную таблицу статистики
InsertSearchInquiry в файле Search.class.php, метод Search::InsertSearchInquiry()
Метод для вставки запроса в журнал поисковых запросов
InsertSeller в файле shop.class.php, метод shop::InsertSeller()
Метод, осуществляющий вставку или обновление продавца.
InsertSession в файле Counter.class.php, метод counter::InsertSession()
Метод для вставки записи о сессии
InsertShop в файле shop.class.php, метод shop::InsertShop()
Метод, осуществляющий вставку информации о магазине
InsertSiteUser в файле Site_users.class.php, метод SiteUsers::InsertSiteUser()
Метод добавления нового пользователя в систему
InsertStructurePropertys в файле Structure.class.php, метод Structure::InsertStructurePropertys()
Метод вставки и редактирования дополнительного свойства для структуры
InsertStructurePropertysValue в файле Structure.class.php, метод Structure::InsertStructurePropertysValue()
Метод вставки и редактирования значения дополнительного свойства в таблице связи
InsertSystemOfPay в файле shop.class.php, метод shop::InsertSystemOfPay()
Метод, осуществляющий вставку платёжной системы
InsertTax в файле shop.class.php, метод shop::InsertTax()
Метод, осуществляющий вставку налога
InsertTheme в файле Forums.class.php, метод Forums::InsertTheme()
Метод для вставки информации о теме
InsertToCart в файле shop.class.php, метод shop::InsertToCart()
Метод добавления информации о товаре в таблицу корзины
InsertTyingProducts в файле shop.class.php, метод shop::InsertTyingProducts()
Метод добавления информации о сопутствующем товаре
InsertTypeOfDelivery в файле shop.class.php, метод shop::InsertTypeOfDelivery()
Метод, осуществляющий вставку типа доставки
InsertUserDeniedAccess в файле UserAccess.class.php, метод UserAccessDenied::InsertUserDeniedAccess()
Метод записи в базу информации о неудачной попытке входа в BackOffice
InsertUserGroup в файле Site_users.class.php, метод SiteUsers::InsertUserGroup()
Метод вставки и обновления информации о группе пользователей
InsertUsers в файле Site_users.class.php, метод SiteUsers::InsertUsers()
Метод добавления пользователя в группу
InsertUsers в файле Maillist.class.php, метод Maillist::InsertUsers()
Метод добавления/редактирования информации о подписчике
InsertUsersGroup в файле Forums.class.php, метод Forums::InsertUsersGroup()
Метод добавления/редактирования группы пользователей для определения доступа к форуму
InsertUsersGroup в файле Maillist.class.php, метод Maillist::InsertUsersGroup()
Метод, открывающий доступ группе пользователей сайта к рассылке
InsertVote в файле Polls.class.php, метод polls::InsertVote()
Метод вставки ответа на опрос
insert_alias в файле Site.class.php, метод site::insert_alias()
Метод вставки/обновления информации об алиасе (домене) сайта
insert_comment в файле InformationSystems.class.php, метод InformationSystem::insert_comment()
Метод вставки/обновления комментария для элемента информационной системы
insert_comment_without_striptags в файле InformationSystems.class.php, метод InformationSystem::insert_comment_without_striptags()
Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах
insert_data_templates в файле Templates.class.php, метод templates::insert_data_templates()
Методы добавления (редактирования) шаблонов страниц
insert_documents в файле Documents.class.php, метод documents::insert_documents()
Метод вставки и обновления новых документов
insert_documents_dir в файле Documents.class.php, метод documents::insert_documents_dir()
Метод вставки и обновления разделов документов
insert_lists в файле Lists.class.php, метод lists::insert_lists()
Метод вставки/обновления данных о списке
insert_lists_items в файле Lists.class.php, метод lists::insert_lists_items()
Метод вставки/обновления данных об элементе списка
insert_module в файле Modules.class.php, метод modules::insert_module()
Метод вставки/обновления информации о модуле
insert_poll в файле Polls.class.php, метод polls::insert_poll()
Метод осуществляет вставку и обновление опросов
insert_poll_reply в файле Polls.class.php, метод polls::insert_poll_reply()
Метод, осуществляет вставку и обновление вариантов ответов
insert_site в файле Site.class.php, метод site::insert_site()
Метод вставки/обновления информации о сайте
insert_status в файле Documents.class.php, метод documents::insert_status()
Метод добавления(редактирования) статусов документов
insert_template в файле Templates.class.php, метод templates::insert_template()
Метод добавления макета
insert_user в файле UserAccess.class.php, метод user_access::insert_user()
Метод вставки и обновления информации о пользователе
insert_user_type в файле UserAccess.class.php, метод user_access::insert_user_type()
Метод вставки и обновления информации о типе пользователей
insert_version в файле Documents.class.php, метод documents::insert_version()
Метод добавления/редактирования записей о версиях
insert_xsl в файле Xsl.class.php, метод xsl::insert_xsl()
Метод вставки/обновления XSL
insert_xsl_dir в файле Xsl.class.php, метод xsl::insert_xsl_dir()
Метод вставки и обновления XSL рубрик
ip в файле ip.class.php, класс ip
Класс модуля "IP-адреса"
IpIsNew в файле Counter.class.php, метод counter::IpIsNew()
Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта
ip.class.php | procedural page ip.class.php
ip.php | procedural page ip.php
IsOrderOfThisSiteUser в файле shop.class.php, метод shop::IsOrderOfThisSiteUser()
Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта
IsSearchSystem в файле Counter.class.php, метод counter::IsSearchSystem()
Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:
IssetAccessForInformationSystemGroup в файле InformationSystems.class.php, метод InformationSystem::IssetAccessForInformationSystemGroup()
Метод проверяет возможность доступа пользователя указанной группы к группе информационной системы
IssetGroup в файле InformationSystems.class.php, метод InformationSystem::IssetGroup()
Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе
IssetGroupItemInsertUpdate в файле InformationSystems.class.php, метод InformationSystem::IssetGroupItemInsertUpdate()
Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента
IssetItem в файле InformationSystems.class.php, метод InformationSystem::IssetItem()
Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы
IssetItemGroupInsertUpdate в файле InformationSystems.class.php, метод InformationSystem::IssetItemGroupInsertUpdate()
Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы
IssetModule в файле Modules.class.php, метод modules::IssetModule()
Метод проверки наличия активного модуля
IssetPath в файле Structure.class.php, метод Structure::IssetPath()
Метод определения наличия пути
isset_id в файле Counter.class.php, метод counter::isset_id()
Метод проверки наличия id сайта
Image.class.php | procedural page Image.class.php
top
j
JPG_QUALITY | в файле Kernel.php, константа JPG_QUALITY
JsHttpRequest.php | procedural page JsHttpRequest.php
top
k
$key_id | в файле show_table.class.php, переменная show_table::$key_id
kernel в файле Kernel.class.php, класс kernel
Класс ядра системы управления сайтом HostCMS
Kernel.class.php | procedural page Kernel.class.php
Kernel.php | procedural page Kernel.php
top
l
$level в файле Structure.class.php, переменная Structure::$level
Максимальный уровень структуры
lib | в файле lib.class.php, класс lib
lib.class.php | procedural page lib.class.php
lib.php | procedural page lib.php
link_len в файле Url.class.php, метод url::link_len()
Метод сокращения длины строки
lists в файле Lists.class.php, класс lists
Класс модуля "Списки"
Lists.class.php | procedural page Lists.class.php
Lists.php | procedural page Lists.php
LoadLibPropertiesValue в файле lib.class.php, метод lib::LoadLibPropertiesValue()
Метод загружает значения параметров типовой дин. страницы для структуры
LoadModules в файле Kernel.class.php, метод kernel::LoadModules()
Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS
LoadModulesLngFile в файле Kernel.class.php, метод kernel::LoadModulesLngFile()
Метод загрузки языкового файла для модуля
load_files в файле FileManager.class.php, метод FileManager::load_files()
Метод загрузки файлов
log_access в файле EventsJournal.class.php, метод EventsJournal::log_access()
Метод протоколирования получения доступа к системе управления
top
m
$mas | в файле show_table.class.php, переменная show_table::$mas
$MasGroup | в файле shop.class.php, переменная shop::$MasGroup
$MasGroup в файле InformationSystems.class.php, переменная InformationSystem::$MasGroup
Массив групп
$mas_documents_dir в файле Documents.class.php, переменная documents::$mas_documents_dir
Массив разделов документов
$mas_image | в файле show_table.class.php, переменная table_fields::$mas_image
$mas_lib_dir | в файле lib.class.php, переменная lib::$mas_lib_dir
$mas_xsl_dir | в файле Xsl.class.php, переменная xsl::$mas_xsl_dir
$menu_id в файле Structure.class.php, переменная Structure::$menu_id
Идентификатор раздела меню
Mysqldump.class.php | procedural page Mysqldump.class.php
Message.fns.php | procedural page Message.fns.php
Mysql.class.php | procedural page Mysql.class.php
Maillist в файле Maillist.class.php, класс Maillist
Класс модуля "Почтовые рассылки"
Maillist.class.php | procedural page Maillist.class.php
Maillist.php | procedural page Maillist.php
MailReport в файле Counter.class.php, метод counter::MailReport()
Метод отправки письма с отчетом администратору сайта
MAIL_EVENTS_STATUS | в файле Kernel.php, константа MAIL_EVENTS_STATUS
memory_get_usage | в файле Kernel.php, функция memory_get_usage()
Menu.class.php | procedural page Menu.class.php
Menu.php | procedural page Menu.php
modules в файле Modules.class.php, класс modules
Класс модуля "Управление модулями"
Modules.class.php | procedural page Modules.class.php
Modules.php | procedural page Modules.php
MySQL в файле Mysql.class.php, класс MySQL
Ядро, класс для работы с MySQL
top
n
$new_session в файле Counter.class.php, переменная counter::$new_session
Флаг добавления новой сессии при обновлении данных счетчика
NodeIsParent в файле Structure.class.php, метод Structure::NodeIsParent()
Метод определения принадлежности узла структуры вышестоящему родителю
NoticeTheme в файле Forums.class.php, метод Forums::NoticeTheme()
Метод делающий тему объявлением или наоборот
top
o
ON_PAGE | в файле Kernel.php, константа ON_PAGE
OrderExtraProperty в файле Site_users.class.php, метод SiteUsers::OrderExtraProperty()
Метод обновления коэффициентов порядка сортировки
OrderForums в файле Forums.class.php, метод Forums::OrderForums()
Метод изменения порядка сортировки форумов в группе
OrderForumsGroup в файле Forums.class.php, метод Forums::OrderForumsGroup()
Метод изменения порядка сортировки групп форумов
OS_UNIX | в файле tar.class.php, константа OS_UNIX
top
p
$parent_id в файле Structure.class.php, переменная Structure::$parent_id
Идентификатор родительского узла элемента структуры
$PropertyGroupMass в файле InformationSystems.class.php, переменная InformationSystem::$PropertyGroupMass
Кэш с данными о дополнительных свойствах информационных групп
$PropertyMass в файле InformationSystems.class.php, переменная InformationSystem::$PropertyMass
Кэш с данными о свойствах инфоррмационных элементов
Password.class.php | procedural page Password.class.php
PageCompressionBegin в файле Compression.class.php, метод compression::PageCompressionBegin()
Метод начала приема из стандартного потока содержимого для компрессии
PageCompressionEnd в файле Compression.class.php, метод compression::PageCompressionEnd()
Метод выводит сжатые данные, размещаемые в потоке
PathCorrection в файле File.class.php, метод File::PathCorrection()
Метод удаляет потенциально опасных символы из пути или имени файла
PathCorrection в файле FileManager.class.php, метод FileManager::PathCorrection()
Метод удаляет потенциально опасных символы из пути или имени файла
phpversion в файле Kernel.class.php, метод kernel::phpversion()
Метод возвращает номер версии PHP
polls в файле Polls.class.php, класс polls
Класс модуля "Опросы"
Polls.class.php | procedural page Polls.class.php
Polls.php | procedural page Polls.php
POLLS_WIDTH | в файле Kernel.php, константа POLLS_WIDTH
PrintIndex | в файле Cache.class.php, метод Cache::PrintIndex()
PrivateOfficeXML в файле Site_users.class.php, метод SiteUsers::PrivateOfficeXML()
УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.
ProcessOrder в файле shop.class.php, метод shop::ProcessOrder()
Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты
ProcessTypographic в файле typograph.class.php, метод typograph::ProcessTypographic()
Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.
top
q
$query | в файле show_table.class.php, переменная show_table::$query
query в файле Mysql.class.php, метод MySQL::query()
Метод выполнения SQL-запроса
quote_smart в файле Security.fns.php, функция quote_smart()
Экранирует потенциально опасные символы для MySQL запросов
top
r
$record_on_page | в файле Modules.class.php, переменная modules::$record_on_page
$record_on_page в файле Documents.class.php, переменная documents::$record_on_page
Число записей, выводимых на странице в административной части
$record_on_page в файле RssWrite.class.php, переменная RssWrite::$record_on_page
Количество в потоке
$record_on_page | в файле Site.class.php, переменная site::$record_on_page
$record_on_page в файле Lists.class.php, переменная lists::$record_on_page
Количество выводимых элементов на страницу
$record_on_page | в файле Xsl.class.php, переменная xsl::$record_on_page
$record_on_page | в файле Templates.class.php, переменная templates::$record_on_page
$record_on_page в файле ip.class.php, переменная ip::$record_on_page
Число записей, отображаемых на странице
$result | в файле Mysql.class.php, переменная MySQL::$result
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RssRead.class.php | procedural page RssRead.class.php
RssWrite.class.php | procedural page RssWrite.class.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
random_shuffle в файле Kernel.class.php, метод kernel::random_shuffle()
Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.
ReadRSS в файле RssRead.class.php, метод RssRead::ReadRSS()
Метод чтения данных из RSS потока
RecursiveRemoveDir в файле File.class.php, метод File::RecursiveRemoveDir()
Метод удаляет директорию со всеми поддиректориями и файлами
RenewMaillist в файле Maillist.class.php, метод Maillist::RenewMaillist()
Метод обновления информации о подписке для конкретного подписчика
resizeToFile в файле Image.class.php, метод Image::resizeToFile()
Метод изменения размера изображения
RssRead в файле RssRead.class.php, класс RssRead
Ядро, класс для чтения RSS
RssWrite в файле RssWrite.class.php, класс RssWrite
Ядро, класс для генерации RSS
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
top
s
$section_path | в файле Xsl.class.php, переменная xsl::$section_path
$section_path | в файле lib.class.php, переменная lib::$section_path
$separator в файле Structure.class.php, переменная Structure::$separator
Разделитель для уровней
$size | в файле show_table.class.php, переменная table_fields::$size
$StructureMass в файле Structure.class.php, переменная Structure::$StructureMass
Массив с элементами структуры
$StructureParentMass в файле Structure.class.php, переменная Structure::$StructureParentMass
Массив родительских разделов
$structure_propertys_list в файле Structure.class.php, переменная Structure::$structure_propertys_list
Хранит результат запроса на выборку дополнительных свойств структуры
Security.fns.php | procedural page Security.fns.php
show_table.class.php | procedural page show_table.class.php
SaveLibPropertiesValue в файле lib.class.php, метод lib::SaveLibPropertiesValue()
Метод для сохранения настроек типовой динамической страницы для стурктуры в файл
Search | в файле Search.class.php, класс Search
SearchWords в файле Search.class.php, метод Search::SearchWords()
Поиск списка слов в индексе
Search.class.php | procedural page Search.class.php
Search.php | procedural page Search.php
select в файле Mysql.class.php, метод MySQL::select()
Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()
SelectAllItemsFromCartForUser в файле shop.class.php, метод shop::SelectAllItemsFromCartForUser()
Метод получения количества элементов и их общей цены для заданного пользователя
SelectAllItemsFromCookieCart в файле shop.class.php, метод shop::SelectAllItemsFromCookieCart()
Метод получения общего количества товаров, их общей стоимости и веса из корзины
(в случае, когда пользователь не задан и данные корзины хранятся в кукисах)
SelectBannersGroup в файле Advertisement.class.php, метод Advertisement::SelectBannersGroup()
Метод получения информации о конкретной группе баннеров или обо всех баннерах
SelectCityArea в файле shop.class.php, метод shop::SelectCityArea()
Метод получения информации о районе города (обо всех районах при $city_area_id=-1)
SelectFascicle в файле Maillist.class.php, метод Maillist::SelectFascicle()
Метод получения данных о выпуске рассылки
SelectForms в файле Forms.class.php, метод Forms::SelectForms()
Метод выбора данных о формах
SelectFormsFields в файле Forms.class.php, метод Forms::SelectFormsFields()
Метод выбора данных о поле формы
SelectForum в файле Forums.class.php, метод Forums::SelectForum()
Устаревший метод, возвращающий информацию о форуме
SelectForumsGroup в файле Forums.class.php, метод Forums::SelectForumsGroup()
Устарвший метод, возвращающий информацию о группе форумов
SelectInformationGroupPropertys в файле InformationSystems.class.php, метод InformationSystem::SelectInformationGroupPropertys()
Метод получения данных о свойствах группы информационной системы
SelectInformationGroups в файле InformationSystems.class.php, метод InformationSystem::SelectInformationGroups()
Метод получения информации об информационных группах конкретной информационной системы
SelectInformationSystem в файле InformationSystems.class.php, метод InformationSystem::SelectInformationSystem()
Метод получения информации об информационной системе
SelectIp в файле ip.class.php, метод ip::SelectIp()
Метод получения информации об IP-адресах
SelectListInformationGroupPropertys в файле InformationSystems.class.php, метод InformationSystem::SelectListInformationGroupPropertys()
Метод получения списка дополнительных свойств информационноq группы данной инфосистемы
SelectListsItems в файле Lists.class.php, метод lists::SelectListsItems()
Метод получения данных об элементах списка
SelectMaillist в файле Maillist.class.php, метод Maillist::SelectMaillist()
Метод получения данных о рассылке
SelectMessage в файле Forums.class.php, метод Forums::SelectMessage()
Метод возвращающий информацию о сообщении
SelectPollReply4Poll в файле Polls.class.php, метод polls::SelectPollReply4Poll()
Получение списка вариантов ответов на опрос
SelectPrice в файле shop.class.php, метод shop::SelectPrice()
Метод определения цены для заданной группы пользователей
SelectSites в файле Site.class.php, метод site::SelectSites()
Метод выбора всех сайтов, поддерживаемых системой управления
SelectStructurePropertys в файле Structure.class.php, метод Structure::SelectStructurePropertys()
Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)
SelectTheme в файле Forums.class.php, метод Forums::SelectTheme()
Устаревший метод, возвращающий информацию о теме
SelectUser в файле Maillist.class.php, метод Maillist::SelectUser()
Метод получения информации о состоянии подписки подписчика на рассылку
SelectUserDeniedAccess в файле UserAccess.class.php, метод UserAccessDenied::SelectUserDeniedAccess()
Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса
SelectUserType в файле Site_users.class.php, метод SiteUsers::SelectUserType()
Метод возвращает параметры группы пользователя
select_alias в файле Site.class.php, метод site::select_alias()
Метод получения информации об алиасе (домене) сайта
select_comments в файле InformationSystems.class.php, метод InformationSystem::select_comments()
Метод получения комментариев к информационному элементу
select_data_templates в файле Templates.class.php, метод templates::select_data_templates()
Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)
select_documents в файле Documents.class.php, метод documents::select_documents()
Метод получения информации о документе или обо всех документах
select_documents_dir в файле Documents.class.php, метод documents::select_documents_dir()
Метод выбора раздела документов
select_information_items в файле InformationSystems.class.php, метод InformationSystem::select_information_items()
Метод получения данных об информационном элементе
select_information_propertys в файле InformationSystems.class.php, метод InformationSystem::select_information_propertys()
Метод получения данных о свойствах информационной системы
select_lists_items в файле Lists.class.php, метод lists::select_lists_items()
Метод получения данных об элементе списка
select_modules в файле Modules.class.php, метод modules::select_modules()
Метод получения информации о модуле
select_poll в файле Polls.class.php, метод polls::select_poll()
Метод осуществляет выборку опросов
select_poll_reply в файле Polls.class.php, метод polls::select_poll_reply()
Метод выбора вариантов ответов
select_site в файле Site.class.php, метод site::select_site()
Метод получения данных о сайте
select_status в файле Documents.class.php, метод documents::select_status()
Метод получения информации о статусе документа
select_user в файле UserAccess.class.php, метод user_access::select_user()
Метод получения информации о пользователе
select_user_access в файле UserAccess.class.php, метод user_access::select_user_access()
Метод получения нформации о типах доступа пользователей
select_user_type в файле UserAccess.class.php, метод user_access::select_user_type()
Метод выбора типа пользователей
select_version в файле Documents.class.php, метод documents::select_version()
Метод выборки информации о версиях
select_xsl в файле Xsl.class.php, метод xsl::select_xsl()
Метод получения данных о XSL-шаблонах
select_xsl_dir в файле Xsl.class.php, метод xsl::select_xsl_dir()
Метод получения информации о XSL-разделах
SendFascicle в файле Maillist.class.php, метод Maillist::SendFascicle()
Метод отправки выпуска всем подписчикам рассылки
SendMailAboutOrder в файле shop.class.php, метод shop::SendMailAboutOrder()
Метод отправки писем о поступившем заказе пользователю и администратору
SendMailWithFile в файле Kernel.class.php, метод kernel::SendMailWithFile()
Метод отправки электронного письма с прикрепленным файлом
SendNewPassword в файле Site_users.class.php, метод SiteUsers::SendNewPassword()
Метод отправки нового пароля на почтовый ящик пользователю
SendRegistInf в файле Site_users.class.php, метод SiteUsers::SendRegistInf()
Метод отправки пользователю регистрационной информации
session_start в файле Admin.class.php, метод Admin::session_start()
Метод старта сессии для раздела администрирования
SetActionWidth в файле show_table.class.php, метод show_table::SetActionWidth()
Изменяет ширину поля Действие
SetButton в файле show_table.class.php, метод show_table::SetButton()
Изменяет флаг вывода кнопки
SetButtonName в файле show_table.class.php, метод show_table::SetButtonName()
Устанавливает наименование кнопки
SetButtonValue в файле show_table.class.php, метод show_table::SetButtonValue()
Изменяет value кнопки
SetConfirmation в файле Site_users.class.php, метод SiteUsers::SetConfirmation()
Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)
SetConfirmationID в файле Site_users.class.php, метод SiteUsers::SetConfirmationID()
Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки
SetCopyShow в файле show_table.class.php, метод show_table::SetCopyShow()
Изменяет флаг показа кнопки для копирования
SetCurrentSite в файле Admin.class.php, метод Admin::SetCurrentSite()
Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта
SetCurrentSiteUser в файле Site_users.class.php, метод SiteUsers::SetCurrentSiteUser()
Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток
SetDefaultGroup в файле Site_users.class.php, метод SiteUsers::SetDefaultGroup()
Метод установления группы с указанным идентификатором по умолчанию
SetDeleteConfirm в файле show_table.class.php, метод show_table::SetDeleteConfirm()
Изменяет сообщение, выводимое при удалении
SetDeleteShow в файле show_table.class.php, метод show_table::SetDeleteShow()
Изменяет флаг показа кнопки удалить
SetEditShow в файле show_table.class.php, метод show_table::SetEditShow()
Изменяет флаг показа кнопки редактировать
SetExpires в файле Kernel.class.php, метод kernel::SetExpires()
Метод установления времени истечения актуальности страницы
SetFieldActionShow в файле show_table.class.php, метод show_table::SetFieldActionShow()
Изменяет флаг вывода поля с действиями
SetFieldCopy в файле show_table.class.php, метод show_table::SetFieldCopy()
Изменяет поле для копирования
SetFieldDelete в файле show_table.class.php, метод show_table::SetFieldDelete()
Изменяет поле для удаления
SetFieldEdit в файле show_table.class.php, метод show_table::SetFieldEdit()
Изменяет поле для редактирования
SetFormAction в файле show_table.class.php, метод show_table::SetFormAction()
Изменяет action формы
SetHtml в файле show_table.class.php, метод show_table::SetHtml()
Устанавливает значение свойству html
SetImage в файле show_table.class.php, метод show_table::SetImage()
Изменяет значение свойства - путь к картинке
SetKeyId в файле show_table.class.php, метод show_table::SetKeyId()
Изменяет ключевое поле
SetLastModified в файле Kernel.class.php, метод kernel::SetLastModified()
Метод установления времени последнего изменения страницы
SetMas в файле show_table.class.php, метод show_table::SetMas()
Изменяет массив экземпляров класса table_fields
SetModerator в файле Forums.class.php, метод Forums::SetModerator()
Метод установления/снятия прав модератора текущего форума для группы пользователей
SetQuery в файле show_table.class.php, метод show_table::SetQuery()
Изменяет запрос для выборки данных
SetTableWidth в файле show_table.class.php, метод show_table::SetTableWidth()
Изменяет ширину таблицы
SetTemplate в файле Kernel.class.php, метод kernel::SetTemplate()
Метод установления текущего макета
SetValueExtraProperty в файле Site_users.class.php, метод SiteUsers::SetValueExtraProperty()
Метод установки значения дополнительного параметра пользователя
set_CSS в файле Kernel.class.php, метод kernel::set_CSS()
Метод изменения адреса файла CSS-стиля для страницы
set_current_page в файле Kernel.class.php, метод kernel::set_current_page()
Метод изменения адреса страницы
set_current_page_data_template в файле Kernel.class.php, метод kernel::set_current_page_data_template()
Метод изменения шаблона страницы
set_description в файле Kernel.class.php, метод kernel::set_description()
Метод изменения описания страницы
set_keywords в файле Kernel.class.php, метод kernel::set_keywords()
Метод изменения ключевых слов страницы
set_title в файле Kernel.class.php, метод kernel::set_title()
Метод изменения заголовока страницы
shop в файле shop.class.php, класс shop
Класс модуля "Интернет-магазин"
shop.class.php | procedural page shop.class.php
shop.php | procedural page shop.php
ShowAddComment в файле InformationSystems.class.php, метод InformationSystem::ShowAddComment()
Метод добавления комментария к элементу информационной системы
ShowAddEditTheme в файле Forums.class.php, метод Forums::ShowAddEditTheme()
Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
ShowAddress в файле shop.class.php, метод shop::ShowAddress()
Метод показа адреса для заказчика
ShowBanner в файле Advertisement.class.php, метод Advertisement::ShowBanner()
Метод показа баннера
ShowBannerGroup в файле Advertisement.class.php, метод Advertisement::ShowBannerGroup()
Метод показа баннера из указанной группы в соответствии с приоритетом
ShowBannerIsTrue в файле Advertisement.class.php, метод Advertisement::ShowBannerIsTrue()
Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили
ShowCart в файле shop.class.php, метод shop::ShowCart()
Метод показа содержимого корзины
ShowConference в файле Forums.class.php, метод Forums::ShowConference()
Метод отображения конференции
ShowConfirmation в файле shop.class.php, метод shop::ShowConfirmation()
Метод вывода сообщения о необходимости подтвердить аккаунт
ShowCounterCode в файле Counter.class.php, метод counter::ShowCounterCode()
Метод, осуществляющий вывод кода счетчика
ShowDocument в файле Documents.class.php, метод documents::ShowDocument()
Метод вызывает показ текущей версии переданной страницы
ShowEditMessage в файле Forums.class.php, метод Forums::ShowEditMessage()
Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
ShowEnter в файле shop.class.php, метод shop::ShowEnter()
Метод вывода формы для авторизации пользователя
ShowForm в файле Forms.class.php, метод Forms::ShowForm()
Метод отображения формы
ShowInformationSystem в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystem()
Метод отображения групп и элементов информационной системы
ShowInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemItem()
Метод отображения информацию об информационном элементе
ShowInformationSystemPageConfig в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemPageConfig()
Метод вызова настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы
ShowInformationSystemPageContent в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemPageContent()
Метод вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы
ShowInformationSystemRss в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemRss()
Метод отображения RSS ленты
ShowItem в файле shop.class.php, метод shop::ShowItem()
Метод вывода информации об элементе
ShowItemsCompare в файле shop.class.php, метод shop::ShowItemsCompare()
Метод отображает сравнение выбранных товаров в магазине
ShowList в файле Lists.class.php, метод lists::ShowList()
Метод отображения элементов списка
ShowMessage в файле Forums.class.php, метод Forums::ShowMessage()
Метод отображения сообщений форума
ShowPoll в файле Polls.class.php, метод polls::ShowPoll()
Метод отображения опроса
ShowPollResult в файле Polls.class.php, метод polls::ShowPollResult()
Метод вывода результатов голосования
ShowPolls в файле Polls.class.php, метод polls::ShowPolls()
Метод отображения всех активных опросов
ShowPollsGroup в файле Polls.class.php, метод polls::ShowPollsGroup()
Метод отображения групп опросов
ShowPriceList | в файле shop.class.php, метод shop::ShowPriceList()
ShowProducer | в файле shop.class.php, метод shop::ShowProducer()
ShowProducersList в файле shop.class.php, метод shop::ShowProducersList()
Метод формирования xml для производителей *
ShowSaller в файле shop.class.php, метод shop::ShowSaller()
Метод для отображение информации о продавце в клиентской части
ShowShop в файле shop.class.php, метод shop::ShowShop()
Метод показа магазина
ShowSiteUserInfo в файле Forums.class.php, метод Forums::ShowSiteUserInfo()
Отображение данных о пользователе форума
ShowSiteUserRegistartion в файле Site_users.class.php, метод SiteUsers::ShowSiteUserRegistartion()
Метод вывода формы регистрации для пользователя сайта
ShowStructure в файле Structure.class.php, метод Structure::ShowStructure()
Метод для отображения структуры в клиентской части сайта
ShowSystemOfPay в файле shop.class.php, метод shop::ShowSystemOfPay()
Метод построения XML для платежных систем
ShowThemes в файле Forums.class.php, метод Forums::ShowThemes()
Метод отображения тем форума
ShowTypeOfDelivery в файле shop.class.php, метод shop::ShowTypeOfDelivery()
Метод выбора и показа типов доставки
ShowUserOffice в файле Site_users.class.php, метод SiteUsers::ShowUserOffice()
Метод отображения кабинета пользователя
ShowUserOrders в файле shop.class.php, метод shop::ShowUserOrders()
Метод отображает информацию о заказах пользователя
show_CSS в файле Kernel.class.php, метод kernel::show_CSS()
Метод вывода CSS стиля для страницы
show_current_page в файле Kernel.class.php, метод kernel::show_current_page()
Метод вывода установленной страницы
show_current_template в файле Kernel.class.php, метод kernel::show_current_template()
Метод вывода текущего макета
show_date в файле Counter.class.php, метод counter::show_date()
Метод для вывода формы с полями для дат (для вывода статистики)
show_description в файле Kernel.class.php, метод kernel::show_description()
Метод вывода описания страницы
show_error_message в файле Message.fns.php, функция show_error_message()
Функция выводит сообщение об ошибке
show_information_message в файле Message.fns.php, функция show_information_message()
Функция выводит информационное сообщение
show_keywords в файле Kernel.class.php, метод kernel::show_keywords()
Метод вывода ключевых слов страницы
show_link в файле Documents.class.php, метод documents::show_link()
Метод формирования строки ссылок на разделы и подразделы
show_link в файле Url.class.php, функция show_link()
Функция показа строки ссылок
show_link в файле Counter.class.php, метод counter::show_link()
Метод для вывода ссылок на различные пункты статистики
show_link_location | в файле shop.class.php, метод shop::show_link_location()
show_message в файле Message.fns.php, функция show_message()
Функция выводит сообщение об успешной операции
show_table | в файле show_table.class.php, класс show_table
show_title в файле Kernel.class.php, метод kernel::show_title()
Метод вывода заголовка страницы
show_ws в файле Wysiwyg.class.php, метод wysiwyg::show_ws()
Метод отображает визуальный редактор
site в файле Site.class.php, класс site
Класс модуля "Сайты"
SiteUsers в файле Site_users.class.php, класс SiteUsers
Класс модуля "Пользователи сайта"
Site.class.php | procedural page Site.class.php
Site.php | procedural page Site.php
Site_users.class.php | procedural page Site_users.class.php
Site_users.php | procedural page Site_users.php
Smile2HTML в файле Forums.class.php, метод Forums::Smile2HTML()
Метод замены смайликов на HTML
SortStructureMass в файле Structure.class.php, метод Structure::SortStructureMass()
Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией
STAT_ON_PAGE | в файле Counter.php, константа STAT_ON_PAGE
STAT_PERIOD_STORAGE | в файле Counter.php, константа STAT_PERIOD_STORAGE
strips в файле Security.fns.php, функция strips()
Вызывает stripslashes для всех элементов массива
strips в файле Kernel.class.php, метод kernel::strips()
Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag
structure в файле Structure.class.php, метод Structure::structure()
Конструктор
Structure | в файле Structure.class.php, класс Structure
Structure.class.php | procedural page Structure.class.php
Structure.php | procedural page Structure.php
str_for_xml в файле Security.fns.php, функция str_for_xml()
Функция преобразует строку для публикации в XML
SuccessVote в файле Polls.class.php, метод polls::SuccessVote()
УСТАРЕВШИЙ МЕТОД. Метод определения права пользователя участвовать в голосовании и изменения статистики голосования, если пользователь имеет право участвовать в нем
SUPERUSER_EMAIL | в файле Kernel.php, константа SUPERUSER_EMAIL
Support в файле Support.class.php, класс Support
Класс модуля "Техническая поддержка"
SupportMail в файле Support.class.php, метод Support::SupportMail()
Метод отправки письма с просьбой о технической поддержке
Support.class.php | procedural page Support.class.php
Support.php | procedural page Support.php
symbol2ASCII в файле Security.fns.php, функция symbol2ASCII()
Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t
top
t
$table_width | в файле show_table.class.php, переменная show_table::$table_width
$thousands_sep | в файле show_table.class.php, переменная table_fields::$thousands_sep
tar.class.php | procedural page tar.class.php
table_fields | в файле show_table.class.php, класс table_fields
table_fields в файле show_table.class.php, метод table_fields::table_fields()
Метод, установления свойств класса
templates в файле Templates.class.php, класс templates
Класс модуля "Шаблоны и макеты"
Templates.class.php | procedural page Templates.class.php
Templates.php | procedural page Templates.php
TMP_DIR | в файле Kernel.php, константа TMP_DIR
to_array в файле Security.fns.php, функция to_array()
Функция приведения аргумента к массиву
to_bool в файле Security.fns.php, функция to_bool()
Функция приведения аргумента к логическому типу
to_float в файле Security.fns.php, функция to_float()
Функция приведения аргумента к вещественному типу
to_int в файле Security.fns.php, функция to_int()
Функция приведения аргумента к целочисленному типу
to_str в файле Security.fns.php, функция to_str()
Функция приведения аргумента к строковому типу
translit_lower в файле Url.class.php, метод url::translit_lower()
Метод транслитерации с переводом символам исходного текста к прописным
typograph | в файле typograph.class.php, класс typograph
typograph.class.php | procedural page typograph.class.php
typograph.php | procedural page typograph.php
top
u
Url.class.php | procedural page Url.class.php
UserAccess.class.php | procedural page UserAccess.class.php
Unregistration в файле Site_users.class.php, метод SiteUsers::Unregistration()
Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя
UnsetCurrentSiteUser в файле Site_users.class.php, метод SiteUsers::UnsetCurrentSiteUser()
Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из кабинета пользователя
UpdateCart в файле shop.class.php, метод shop::UpdateCart()
Метод, осуществляющий обновление данных корзины
UpdateCity в файле shop.class.php, метод shop::UpdateCity()
УСТАРЕВШИЙ! Метод, осуществляющий обновление города
UpdateCondOfDelivery в файле shop.class.php, метод shop::UpdateCondOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки
UpdateCountry в файле shop.class.php, метод shop::UpdateCountry()
УСТАРЕВШИЙ! Метод, осуществляющий обновление страны
UpdateCurrency в файле shop.class.php, метод shop::UpdateCurrency()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()
UpdateDiscount в файле shop.class.php, метод shop::UpdateDiscount()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке
UpdateGroup в файле shop.class.php, метод shop::UpdateGroup()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары
UpdateGroupPolls в файле Polls.class.php, метод polls::UpdateGroupPolls()
Метод обновления информаци о группе опросов
UpdateImageForItem в файле shop.class.php, метод shop::UpdateImageForItem()
Метод обновления информации об изображении для товара
UpdateItem в файле shop.class.php, метод shop::UpdateItem()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о товаре
UpdateItemDiscount в файле shop.class.php, метод shop::UpdateItemDiscount()
УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара
UpdateItemPrice в файле shop.class.php, метод shop::UpdateItemPrice()
Метод обновления связи товара и цены
UpdateLibPropertyOrder в файле lib.class.php, метод lib::UpdateLibPropertyOrder()
Метод для обновления порядка сортировки параметра типовой дин. страницы
UpdateLocation в файле shop.class.php, метод shop::UpdateLocation()
УСТАРЕВШИЙ! Метод, осуществляющий обновление области
UpdateMesure в файле shop.class.php, метод shop::UpdateMesure()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения
UpdateOrder в файле shop.class.php, метод shop::UpdateOrder()
Метод, осуществляющий обновление заказа
UpdateOrderItems в файле shop.class.php, метод shop::UpdateOrderItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе
UpdateOrderPropretyOfItems в файле shop.class.php, метод shop::UpdateOrderPropretyOfItems()
Метод изменения порядка сортировки дополнительных свойств товара
UpdatePrice в файле shop.class.php, метод shop::UpdatePrice()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены
UpdatePricesToItem в файле shop.class.php, метод shop::UpdatePricesToItem()
Метод обновления дополнительной цены для элемента
UpdateProducer в файле shop.class.php, метод shop::UpdateProducer()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе
UpdatePropertiesItem в файле shop.class.php, метод shop::UpdatePropertiesItem()
Метод обновления информации о дополнительных свойствах товара
UpdatePropretyOfItems в файле shop.class.php, метод shop::UpdatePropretyOfItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара
UpdateShop в файле shop.class.php, метод shop::UpdateShop()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине
UpdateSiteUser в файле Site_users.class.php, метод SiteUsers::UpdateSiteUser()
Метод обновления анкетных данных пользователя
UpdateSubDir в файле Structure.class.php, метод Structure::UpdateSubDir()
Метод обновления идентификатора меню у подразделов определенного раздела
UpdateSystemOfPay в файле shop.class.php, метод shop::UpdateSystemOfPay()
УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы
UpdateTax в файле shop.class.php, метод shop::UpdateTax()
Метод, осуществляющий обновление налога
UpdateTyingProducts в файле shop.class.php, метод shop::UpdateTyingProducts()
УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах
UpdateTypeOfDelivery в файле shop.class.php, метод shop::UpdateTypeOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки
update_vote в файле Polls.class.php, метод polls::update_vote()
УСТАРЕВШИЙ Метод обработки результата голосования
UPLOADDIR | в файле Kernel.php, константа UPLOADDIR
url в файле Url.class.php, класс url
Ядро, класс для работы с адресной строкой
UserAccessDenied в файле UserAccess.class.php, класс UserAccessDenied
Ядро, класс проверки возможности доступа пользователей BackOffice
UserAccess.class.php | procedural page UserAccess.class.php
UserAccess.php | procedural page UserAccess.php
UserAuth в файле Admin.class.php, метод Admin::UserAuth()
Метод производит авторизацию пользователя в разделе администрирования
UserCanAddComment в файле InformationSystems.class.php, метод InformationSystem::UserCanAddComment()
Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY
UserIsModerator в файле Forums.class.php, метод Forums::UserIsModerator()
Метод для определения, является ли данный пользователь модератором
user_access в файле UserAccess.class.php, класс user_access
Класс модуля "Пользователи раздела администрирования"
USER_NONE | в файле Kernel.php, константа USER_NONE
top
v
ValidCaptcha в файле Captcha.class.php, метод Captcha::ValidCaptcha()
Метод проверки соответствия введенного пользователем текста хранимому в сессии
ValidUser в файле Site_users.class.php, метод SiteUsers::ValidUser()
Метод возвращает идентификатор пользователя по его логину и паролю
valid_email в файле Security.fns.php, функция valid_email()
Проверка правильности электронного адреса
VisibleTheme в файле Forums.class.php, метод Forums::VisibleTheme()
Метод, устанавливающий видимость/невидимость темы
vote_result в файле Polls.class.php, метод polls::vote_result()
Устаревший метод
top
w
Wysiwyg.class.php | procedural page Wysiwyg.class.php
win2uni в файле Graphic.class.php, метод graphic::win2uni()
Метод перекодировки из win в unicode
wysiwyg в файле Wysiwyg.class.php, класс wysiwyg
Ядро, класс визуального редактора
top
x
$xml | в файле ExternalXml.class.php, переменная ExternalXml::$xml
XMLparser.class.php | procedural page XMLparser.class.php
xsl в файле Xsl.class.php, класс xsl
Класс модуля "XSL-шаблоны"
Xsl.class.php | procedural page Xsl.class.php
Xsl.php | procedural page Xsl.php
top
y
YandexMarket в файле shop.class.php, метод shop::YandexMarket()
Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и возвращает XML данные.

support@hostcms.ru

http://www.hostcms.ru

Copyright © 2004—2007 ООО "Хостмэйк"

Запрещено любое воспроизведение системы HostCMS и ее элементов в какой бы то ни было форме и какими бы то ни было средствами без письменного разрешения владельцев авторских прав.


Дерево классов HostCMS v 4

Root class Admin
  • Admin
 Root class AdminMenu
  • AdminMenu
 Root class Advertisement
  • Advertisement
 Root class Backup
  • Backup
 Root class Cache
  • Cache
 Root class Captcha
  • Captcha
 Root class compression
  • compression
 Root class Constants
  • Constants
 Root class counter
  • counter
 Root class DateClass
  • DateClass
 Root class documents
  • documents
 Root class EventsJournal
  • EventsJournal
    • EventsJournalAdmin
 Root class ExecSqlQuery
  • ExecSqlQuery
 Root class ExternalXml
  • ExternalXml
 Root class File
  • File
 Root class FileManager
  • FileManager
 Root class Forms
  • Forms
 Root class Forums
  • Forums
 Root class graphic
  • graphic
 Root class Image
  • Image
 Root class InformationSystem
  • InformationSystem
 Root class ip
  • ip
 Root class kernel
  • kernel
 Root class lib
  • lib
 Root class lists
  • lists
 Root class Maillist
  • Maillist
 Root class modules
  • modules
 Root class MySQL
  • MySQL
 Root class polls
  • polls
 Root class RssRead
  • RssRead
 Root class RssWrite
  • RssWrite
 Root class Search
  • Search
 Root class shop
  • shop
 Root class show_table
  • show_table
 Root class site
  • site
 Root class SiteUsers
  • SiteUsers
 Root class Structure
  • Structure
 Root class Support
  • Support
 Root class table_fields
  • table_fields
 Root class templates
  • templates
 Root class typograph
  • typograph
 Root class url
  • url
 Root class UserAccessDenied
  • UserAccessDenied
 Root class user_access
  • user_access
 Root class wysiwyg
  • wysiwyg
 Root class xsl
  • xsl


Docs for page Admin.class.php

Файл: /Kernel/Admin.class.php

Классы в этом файле:
Admin
Ядро, методы управления разделом администрирования HostCMS

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page AdminMenu.class.php

Файл: /Kernel/AdminMenu.class.php

Классы в этом файле:
AdminMenu
Ядро, класс для формирования меню в разделе администрирования

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page admin_output.fns.php

Файл: /Kernel/admin_output.fns.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void do_html_footer_admin()
    Функция выводит "подвал" для страниц раздела администрирования
  • void do_html_header_admin()
    Функция выводит "шапку" для страниц раздела администрирования

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void do_html_footer_admin() [Строка 275]

    Usage: do_html_footer_admin( )

    Описание

    Функция выводит "подвал" для страниц раздела администрирования

    [ Top ]

  • void do_html_header_admin() [Строка 14]

    Usage: do_html_header_admin( string $title, [array $param = false])

    Принимаемые параметры

    $title

    $param

    массив с доп. параметрами
    string $param['use_ajax'] использовать AJAX

    Описание

    Функция выводит "шапку" для страниц раздела администрирования

    [ Top ]


Docs for page Advertisement.class.php

Файл: /Advertisement/Advertisement.class.php

Классы в этом файле:
Advertisement
Класс модуля "Реклама"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Advertisement.php

Файл: /Advertisement/Advertisement.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Advertisement/Advertisement.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Advertisement/Advertisement.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Backup.class.php

Файл: /Backup/Backup.class.php

Классы в этом файле:
Backup
Класс модуля "Резервное копирование"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Backup.php

Файл: /Backup/Backup.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Backup/Backup.class.php'
  • include = CMS_FOLDER.'modules/Backup/Mysqldump.class.php'
  • include = CMS_FOLDER.'modules/Backup/tar/tar.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Backup/Backup.class.php' [Строка 7]

  • include file: = CMS_FOLDER.'modules/Backup/Mysqldump.class.php' [Строка 8]

  • include file: = CMS_FOLDER.'modules/Backup/tar/tar.class.php' [Строка 9]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Cache.class.php

Файл: /Cache/Cache.class.php

Классы в этом файле:
Cache
Класс модуля "Кэш"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Cache.php

Файл: /Cache/Cache.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Cache/Cache.class.php'

Список глобальных переменных

Список констант

  • CACHE_INSTALL = true
  • CACHE_LIMIT = 300

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Cache/Cache.class.php' [Строка 10]

Описания глобальных переменных

Описания констант

  • CACHE_INSTALL = true [Строка 8]

  • CACHE_LIMIT = 300 [Строка 17]

Описания функций

support@hostcms.ru


Docs for page Captcha.class.php

Файл: /Kernel/Captcha.class.php

Классы в этом файле:
Captcha
Ядро, класс для работы с CAPTCHA

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Compression.class.php

Файл: /Compression/Compression.class.php

Классы в этом файле:
compression
Класс модуля "Система сжатия (компрессия)"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Compression.php

Файл: /Compression/Compression.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Compression/Compression.class.php'

Список глобальных переменных

Список констант

  • COMPRESSION_INSTALL = 1

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Compression/Compression.class.php' [Строка 10]

Описания глобальных переменных

Описания констант

  • COMPRESSION_INSTALL = 1 [Строка 8]

Описания функций

support@hostcms.ru


Docs for page config.php

Файл: /Counter/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • COUNTER_BOT_COUNT = true

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • COUNTER_BOT_COUNT = true [Строка 3]

Описания функций

support@hostcms.ru


Docs for page config.php

Файл: /Kernel/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page config.php

Файл: /Forums/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page config.php

Файл: /Cache/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Constants.class.php

Файл: /Constants/Constants.class.php

Классы в этом файле:
Constants
Класс модуля "Константы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Constants.php

Файл: /Constants/Constants.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Constants/Constants.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Constants/Constants.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Counter.class.php

Файл: /Counter/Counter.class.php

Классы в этом файле:
counter
Класс модуля "Статистика посещаемости сайта"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Counter.php

Файл: /Counter/Counter.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Counter/Graphic.class.php'
  • include = CMS_FOLDER.'modules/Counter/Counter.class.php'

Список глобальных переменных

Список констант

  • COUNTER_INSTALL = true
    Модуль: /modules/Counter/Counter.php
  • DIAGRAMM_LIMIT = 20
  • DIAGRAMM_WIDTH = 500
  • GISTOGRAMM_LIMIT = STAT_ON_PAGE
  • STAT_ON_PAGE = 50
  • STAT_PERIOD_STORAGE = 30

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Counter/Graphic.class.php' [Строка 39]

  • include file: = CMS_FOLDER.'modules/Counter/Counter.class.php' [Строка 38]

Описания глобальных переменных

Описания констант

  • COUNTER_INSTALL = true [Строка 11]

    Описание

    Модуль: /modules/Counter/Counter.php

    Copyright (c) 2004-2007 ООО Хостмэйк

    version

    4.0

  • DIAGRAMM_LIMIT = 20 [Строка 27]

  • DIAGRAMM_WIDTH = 500 [Строка 35]

  • GISTOGRAMM_LIMIT = STAT_ON_PAGE [Строка 31]

  • STAT_ON_PAGE = 50 [Строка 23]

  • STAT_PERIOD_STORAGE = 30 [Строка 19]

Описания функций

support@hostcms.ru


Docs for page Date.class.php

Файл: /Kernel/Date.class.php

Классы в этом файле:
DateClass
Ядро, класс для работы с датами

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Documents.class.php

Файл: /Documents/Documents.class.php

Классы в этом файле:
documents
Класс модуля "Старницы и документы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Documents.php

Файл: /Documents/Documents.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Documents/Documents.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Documents/Documents.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Error.fns.php

Файл: /Kernel/Error.fns.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void cms_error_handler()
    Ядро, обработчики ошибок в HostCMS

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void cms_error_handler() [Строка 15]

    Usage: cms_error_handler( int $code, string $msg, string $file, int $line)

    Принимаемые параметры

    $code

    код ошибки - E_ERROR и т.д.

    $msg

    сообщение об ошбике

    $file

    имя файла, в котором произошла ошибка

    $line

    строка, в котором произошла ошибка

    Описание

    Ядро, обработчики ошибок в HostCMS

    [ Top ]


Docs for page EventsJournal.class.php

Файл: /EventsJournal/EventsJournal.class.php

Классы в этом файле:
EventsJournalAdmin
Класс модуля "Журнал событий"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page EventsJournal.class.php

Файл: /Kernel/EventsJournal.class.php

Классы в этом файле:
EventsJournal
Ядро, класс журналирования событий

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page EventsJournal.php

Файл: /EventsJournal/EventsJournal.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/EventsJournal/EventsJournal.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/EventsJournal/EventsJournal.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ExecSqlQuery.class.php

Файл: /ExecSqlQuery/ExecSqlQuery.class.php

Классы в этом файле:
ExecSqlQuery
Класс модуля "SQL-запросы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ExecSqlQuery.php

Файл: /ExecSqlQuery/ExecSqlQuery.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/ExecSqlQuery/ExecSqlQuery.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/ExecSqlQuery/ExecSqlQuery.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ExternalXml.class.php

Файл: /Kernel/ExternalXml.class.php

Классы в этом файле:
ExternalXml
Ядро, класс формирует дерево XML по переданному массиву

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page File.class.php

Файл: /Kernel/File.class.php

Классы в этом файле:
File
Ядро, класс для работы с файлами

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page FileManager.class.php

Файл: /FileManager/FileManager.class.php

Классы в этом файле:
FileManager
Класс модуля "Файловый менеджер"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page FileManager.php

Файл: /FileManager/FileManager.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/FileManager/FileManager.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/FileManager/FileManager.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Forms.class.php

Файл: /Forms/Forms.class.php

Классы в этом файле:
Forms
Класс модуля "Формы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Forms.php

Файл: /Forms/Forms.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Forms/Forms.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Forms/Forms.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Forums.class.php

Файл: /Forums/Forums.class.php

Классы в этом файле:
Forums
Класс модуля "Форумы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Forums.php

Файл: /Forums/Forums.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Forums/Forums.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Forums/Forums.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Graphic.class.php

Файл: /Counter/Graphic.class.php

Классы в этом файле:
graphic

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Image.class.php

Файл: /Kernel/Image.class.php

Классы в этом файле:
Image
Ядро, класс для работы с графическими изображениями

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page InformationSystems.class.php

Файл: /InformationSystems/InformationSystems.class.php

Классы в этом файле:
InformationSystem
Класс модуля "Информационные системы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page InformationSystems.php

Файл: /InformationSystems/InformationSystems.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/InformationSystems/InformationSystems.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/InformationSystems/InformationSystems.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ip.class.php

Файл: /ip/ip.class.php

Классы в этом файле:
ip
Класс модуля "IP-адреса"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ip.php

Файл: /ip/ip.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/ip/ip.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/ip/ip.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page JsHttpRequest.php

Файл: /Kernel/ajax/JsHttpRequest.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Kernel.class.php

Файл: /Kernel/Kernel.class.php

Классы в этом файле:
kernel
Класс ядра системы управления сайтом HostCMS

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Kernel.php

Файл: /Kernel/Kernel.php

Классы в этом файле:

Список вложений

  • require_once = CMS_FOLDER.'modules/Kernel/Image.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Date.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Admin.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Wysiwyg.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Password.class.php'
  • require_once = CMS_FOLDER."modules/Kernel/show_table.class.php"
  • require_once = CMS_FOLDER.'modules/Kernel/File.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Url.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Error.fns.php'
  • require_once = CMS_FOLDER.'modules/Kernel/ExternalXml.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Captcha.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Mysql.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/RssRead.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/XMLparser.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/UserAccess.class.php'
  • require_once = $config_path
  • require_once = CMS_FOLDER."modules/Kernel/admin_output.fns.php"
  • require_once = CMS_FOLDER.'modules/Kernel/RssWrite.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Message.fns.php'
  • require_once = CMS_FOLDER.'modules/Kernel/EventsJournal.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/ajax/JsHttpRequest.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Security.fns.php'
  • require_once = CMS_FOLDER.'modules/Kernel/Kernel.class.php'
  • require_once = CMS_FOLDER.'modules/Kernel/AdminMenu.class.php'

Список глобальных переменных

Список констант

  • $row['constants_name'] = $row['constants_value']
  • ADD_COMMENT_DELAY = 10
  • CODE_NAME = 'Infinity'
  • CURRENT_VERSION = '<b>v. 4.0</b> Beta 2303'
  • DEFAULT_LNG = 'ru'
  • E_STRICT = 2048
  • FREEDEBUG_URL = 'http://www.hostcms.ru/freedebug.php'
  • JPG_QUALITY = 60
  • MAIL_EVENTS_STATUS = 2
  • ON_PAGE = 20
  • POLLS_WIDTH = 100
  • SUPERUSER_EMAIL = 'email@not.exists'
  • TMP_DIR = 'tmp/'
  • UPLOADDIR = 'upload/'
  • USER_NONE = '#####'

Список функций

  • void memory_get_usage()

Описания вложений

  • require_once file: = CMS_FOLDER.'modules/Kernel/Image.class.php' [Строка 312]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Date.class.php' [Строка 300]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Admin.class.php' [Строка 308]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Wysiwyg.class.php' [Строка 306]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Password.class.php' [Строка 302]

  • require_once file: = CMS_FOLDER."modules/Kernel/show_table.class.php" [Строка 82]

  • require_once file: = CMS_FOLDER.'modules/Kernel/File.class.php' [Строка 310]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Url.class.php' [Строка 315]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Error.fns.php' [Строка 304]

  • require_once file: = CMS_FOLDER.'modules/Kernel/ExternalXml.class.php' [Строка 78]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Captcha.class.php' [Строка 323]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Mysql.class.php' [Строка 76]

  • require_once file: = CMS_FOLDER.'modules/Kernel/RssRead.class.php' [Строка 319]

  • require_once file: = CMS_FOLDER.'modules/Kernel/XMLparser.class.php' [Строка 325]

  • require_once file: = CMS_FOLDER.'modules/Kernel/UserAccess.class.php' [Строка 321]

  • require_once file: = $config_path [Строка 57]

  • require_once file: = CMS_FOLDER."modules/Kernel/admin_output.fns.php" [Строка 80]

  • require_once file: = CMS_FOLDER.'modules/Kernel/RssWrite.class.php' [Строка 317]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Message.fns.php' [Строка 65]

  • require_once file: = CMS_FOLDER.'modules/Kernel/EventsJournal.class.php' [Строка 67]

  • require_once file: = CMS_FOLDER.'modules/Kernel/ajax/JsHttpRequest.php' [Строка 63]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Security.fns.php' [Строка 69]

  • require_once file: = CMS_FOLDER.'modules/Kernel/Kernel.class.php' [Строка 71]

  • require_once file: = CMS_FOLDER.'modules/Kernel/AdminMenu.class.php' [Строка 293]

Описания глобальных переменных

Описания констант

  • $row['constants_name'] = $row['constants_value'] [Строка 222]

  • ADD_COMMENT_DELAY = 10 [Строка 242]

  • CODE_NAME = 'Infinity' [Строка 9]

  • CURRENT_VERSION = '<b>v. 4.0</b> Beta 2303' [Строка 7]

  • DEFAULT_LNG = 'ru' [Строка 252]

  • E_STRICT = 2048 [Строка 278]

  • FREEDEBUG_URL = 'http://www.hostcms.ru/freedebug.php' [Строка 288]

  • JPG_QUALITY = 60 [Строка 267]

  • MAIL_EVENTS_STATUS = 2 [Строка 247]

  • ON_PAGE = 20 [Строка 232]

  • POLLS_WIDTH = 100 [Строка 257]

  • SUPERUSER_EMAIL = 'email@not.exists' [Строка 237]

  • TMP_DIR = 'tmp/' [Строка 283]

  • UPLOADDIR = 'upload/' [Строка 272]

  • USER_NONE = '#####' [Строка 262]

Описания функций

  • void memory_get_usage() [Строка 14]

    Usage: memory_get_usage( )

    [ Top ]


Docs for page lib.class.php

Файл: /lib/lib.class.php

Классы в этом файле:
lib

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page lib.php

Файл: /lib/lib.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER."modules/$module_path_name/$module_path_name.class.php"

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER."modules/$module_path_name/$module_path_name.class.php" [Строка 9]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Lists.class.php

Файл: /Lists/Lists.class.php

Классы в этом файле:
lists
Класс модуля "Списки"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Lists.php

Файл: /Lists/Lists.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Lists/Lists.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Lists/Lists.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Maillist.class.php

Файл: /Maillist/Maillist.class.php

Классы в этом файле:
Maillist
Класс модуля "Почтовые рассылки"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Maillist.php

Файл: /Maillist/Maillist.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Maillist/Maillist.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Maillist/Maillist.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Menu.class.php

Файл: /Menu/Menu.class.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Menu.php

Файл: /Menu/Menu.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Menu/Menu.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Menu/Menu.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Message.fns.php

Файл: /Kernel/Message.fns.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void show_error_message()
    Функция выводит сообщение об ошибке
  • void show_information_message()
    Функция выводит информационное сообщение
  • void show_message()
    Функция выводит сообщение об успешной операции

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void show_error_message() [Строка 26]

    Usage: show_error_message( string $text)

    Принимаемые параметры

    $text

    Описание

    Функция выводит сообщение об ошибке

    [ Top ]

  • void show_information_message() [Строка 44]

    Usage: show_information_message( unknown_type $text, [unknown_type $width = '100%'])

    Принимаемые параметры

    $text

    $width

    Описание

    Функция выводит информационное сообщение

    [ Top ]

  • void show_message() [Строка 11]

    Usage: show_message( string $text)

    Принимаемые параметры

    $text

    Описание

    Функция выводит сообщение об успешной операции

    [ Top ]


Docs for page Modules.class.php

Файл: /Modules/Modules.class.php

Классы в этом файле:
modules
Класс модуля "Управление модулями"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Modules.php

Файл: /Modules/Modules.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Modules/Modules.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Modules/Modules.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Mysql.class.php

Файл: /Kernel/Mysql.class.php

Классы в этом файле:
MySQL
Ядро, класс для работы с MySQL

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Mysqldump.class.php

Файл: /Backup/Mysqldump.class.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Password.class.php

Файл: /Kernel/Password.class.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Polls.class.php

Файл: /Polls/Polls.class.php

Классы в этом файле:
polls
Класс модуля "Опросы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Polls.php

Файл: /Polls/Polls.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Polls/Polls.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Polls/Polls.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page RssRead.class.php

Файл: /Kernel/RssRead.class.php

Классы в этом файле:
RssRead
Ядро, класс для чтения RSS

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page RssWrite.class.php

Файл: /Kernel/RssWrite.class.php

Классы в этом файле:
RssWrite
Ядро, класс для генерации RSS

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Polls/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Backup/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Counter/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Modules/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /InformationSystems/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Cache/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /shop/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Constants/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Site_users/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /typograph/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /UserAccess/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Xsl/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Templates/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Support/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Menu/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Structure/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Site/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Search/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /ExecSqlQuery/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Documents/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /ip/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Advertisement/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /lib/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /FileManager/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Forums/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Maillist/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Lists/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /Forms/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page ru.php

Файл: /EventsJournal/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Search.class.php

Файл: /Search/Search.class.php

Классы в этом файле:
Search

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Search.php

Файл: /Search/Search.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Search/Search.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Search/Search.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Security.fns.php

Файл: /Kernel/Security.fns.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • string quote_smart()
    Экранирует потенциально опасные символы для MySQL запросов
  • void strips()
    Вызывает stripslashes для всех элементов массива
  • string str_for_xml()
    Функция преобразует строку для публикации в XML
  • string symbol2ASCII()
    Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t
  • array to_array()
    Функция приведения аргумента к массиву
  • bool to_bool()
    Функция приведения аргумента к логическому типу
  • float to_float()
    Функция приведения аргумента к вещественному типу
  • int to_int()
    Функция приведения аргумента к целочисленному типу
  • string to_str()
    Функция приведения аргумента к строковому типу
  • boolean valid_email()
    Проверка правильности электронного адреса

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • string quote_smart() [Строка 34]

    Usage: quote_smart( string $value, [boolean $remove_xss = true])

    Принимаемые параметры

    $value

    значение

    $remove_xss

    удалять элементы XSS атак

    Описание

    Экранирует потенциально опасные символы для MySQL запросов

    [ Top ]

  • void strips() [Строка 12]

    Usage: strips( array &$var)

    Принимаемые параметры

    $var

    Описание

    Вызывает stripslashes для всех элементов массива

    [ Top ]

  • string str_for_xml() [Строка 222]

    Usage: str_for_xml( string $str)

    Принимаемые параметры

    $str

    Описание

    Функция преобразует строку для публикации в XML

    [ Top ]

  • string symbol2ASCII() [Строка 190]

    Usage: symbol2ASCII( mixed &$string, string $num)

    Принимаемые параметры

    $num

    Описание

    Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t

    [ Top ]

  • array to_array() [Строка 329]

    Usage: to_array( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к массиву

    [ Top ]

  • bool to_bool() [Строка 307]

    Usage: to_bool( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к логическому типу

    [ Top ]

  • float to_float() [Строка 288]

    Usage: to_float( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к вещественному типу

    [ Top ]

  • int to_int() [Строка 265]

    Usage: to_int( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к целочисленному типу

    [ Top ]

  • string to_str() [Строка 235]

    Usage: to_str( unknown_type &$var, [mixed $remove_xss = true])

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к строковому типу

    [ Top ]

  • boolean valid_email() [Строка 138]

    Usage: valid_email( string $address)

    Принимаемые параметры

    $address

    e-mail адрес

    Возвращает

    true или false

    Описание

    Проверка правильности электронного адреса

    [ Top ]


Docs for page shop.class.php

Файл: /shop/shop.class.php

Классы в этом файле:
shop
Класс модуля "Интернет-магазин"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page shop.php

Файл: /shop/shop.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/shop/shop.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/shop/shop.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page show_table.class.php

Файл: /Kernel/show_table.class.php

Классы в этом файле:
table_fields
show_table

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Site.class.php

Файл: /Site/Site.class.php

Классы в этом файле:
site
Класс модуля "Сайты"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Site.php

Файл: /Site/Site.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Site/Site.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Site/Site.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Site_users.class.php

Файл: /Site_users/Site_users.class.php

Классы в этом файле:
SiteUsers
Класс модуля "Пользователи сайта"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Site_users.php

Файл: /Site_users/Site_users.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Site_users/Site_users.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Site_users/Site_users.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Structure.class.php

Файл: /Structure/Structure.class.php

Классы в этом файле:
Structure

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Structure.php

Файл: /Structure/Structure.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Structure/Structure.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Structure/Structure.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Support.class.php

Файл: /Support/Support.class.php

Классы в этом файле:
Support
Класс модуля "Техническая поддержка"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Support.php

Файл: /Support/Support.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Support/Support.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Support/Support.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page tar.class.php

Файл: /Backup/tar/tar.class.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • OS_UNIX = false

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • OS_UNIX = false [Строка 10]

Описания функций

support@hostcms.ru


Docs for page Templates.class.php

Файл: /Templates/Templates.class.php

Классы в этом файле:
templates
Класс модуля "Шаблоны и макеты"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Templates.php

Файл: /Templates/Templates.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Templates/Templates.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Templates/Templates.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page typograph.class.php

Файл: /typograph/typograph.class.php

Классы в этом файле:
typograph

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page typograph.php

Файл: /typograph/typograph.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER."modules/$module_path_name/$module_path_name.class.php"

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER."modules/$module_path_name/$module_path_name.class.php" [Строка 9]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Url.class.php

Файл: /Kernel/Url.class.php

Классы в этом файле:
url
Ядро, класс для работы с адресной строкой

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void show_link()
    Функция показа строки ссылок

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void show_link() [Строка 85]

    Usage: show_link( int $total_count, int $count_on_page, int $current_page, string $link, [array $param = array()])

    Принимаемые параметры

    $total_count

    общее число записей

    $count_on_page

    число записей на страницу

    $current_page

    номер текущей страницы

    $link

    адрес ссылки на страницу

    $param

    массив дополнительных параметров
    $param['separator'] разделитель между ссылками
    $param['count_num'] число ссылок перед и после текущей страницы, а также в окончании стороки ссылок
    $param['first'] строка для отображения ссылки на первую страницу
    $param['pred'] строка для отображения ссылки на предыдущую страницу
    $param['last'] строка для отображения ссылки на последнюю страницу
    $param['next'] строка для отображения ссылки на следующую страницу
    $param['show_first'] параметр, определяющий показывать ссылку на первую страницу
    $param['show_pred'] параметр, определяющий показывать ссылку на предыдущую страницу
    $param['show_last'] параметр, определяющий показывать ссылку на последнюю страницу
    $param['show_next'] параметр, определяющий показывать ссылку на следующую страницу

    Описание

    Функция показа строки ссылок

    [ Top ]


Docs for page UserAccess.class.php

Файл: /UserAccess/UserAccess.class.php

Классы в этом файле:
user_access
Класс модуля "Пользователи раздела администрирования"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page UserAccess.class.php

Файл: /Kernel/UserAccess.class.php

Классы в этом файле:
UserAccessDenied
Ядро, класс проверки возможности доступа пользователей BackOffice

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page UserAccess.php

Файл: /UserAccess/UserAccess.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/UserAccess/UserAccess.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/UserAccess/UserAccess.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Wysiwyg.class.php

Файл: /Kernel/Wysiwyg.class.php

Классы в этом файле:
wysiwyg
Ядро, класс визуального редактора

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page XMLparser.class.php

Файл: /Kernel/XMLparser.class.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Xsl.class.php

Файл: /Xsl/Xsl.class.php

Классы в этом файле:
xsl
Класс модуля "XSL-шаблоны"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs for page Xsl.php

Файл: /Xsl/Xsl.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER.'modules/Xsl/Xsl.class.php'

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER.'modules/Xsl/Xsl.class.php' [Строка 7]

Описания глобальных переменных

Описания констант

Описания функций

support@hostcms.ru


Docs For Class Admin

Class Admin

[Строка 10]

Размещен: /Kernel/Admin.class.php

Описание

Ядро, методы управления разделом администрирования HostCMS

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void admin_init()

    Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта

  • boolean admin_session_valid()

    Метод проверки авторизации пользователя

  • void session_start()

    Метод старта сессии для раздела администрирования

  • void SetCurrentSite()

    Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта

  • mixed UserAuth()

    Метод производит авторизацию пользователя в разделе администрирования

Унаследованные методы

Описания методов

    Admin::admin_init

admin_init(
 );

    Описание

    Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта

    [ Top ]

    Admin::admin_session_valid

admin_session_valid(
string
$modules_path );

    Принимаемые параметры

    $modules_path

    путь к модулю

    Возвращает

    true в случае  наличия у авторизированного пользователя прав доступа к данному модулю на текущем сайте или прерывает выполнение страницы, производя редирект на страницу авторизации в противном случае

    Описание

    Метод проверки авторизации пользователя

    [ Top ]

    Admin::session_start

session_start(
 );

    Описание

    Метод старта сессии для раздела администрирования

    [ Top ]

    Admin::SetCurrentSite

SetCurrentSite(
 );

    Описание

    Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта

    [ Top ]

    Admin::UserAuth

UserAuth(
string
$login, string
$password );

    Принимаемые параметры

    $login

    логин

    $password

    пароль

    Возвращает

    true -- автооризация произведена успешно
    -2 или false -- неправильные данные доступа

    Описание

    Метод производит авторизацию пользователя в разделе администрирования

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class AdminMenu

Class AdminMenu

[Строка 11]

Размещен: /Kernel/AdminMenu.class.php

Описание

Ядро, класс для формирования меню в разделе администрирования

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AddAdminMenuItem()

    Метод добавляет элемент в меню раздела администрирования

Унаследованные методы

Описания методов

    AdminMenu::AddAdminMenuItem

AddAdminMenuItem(
string
$order, string
$name, string
$link, string
$module_name );

    Принимаемые параметры

    $order

    порядок элемента в меню

    $name

    имя элемента

    $link

    ссылка

    $module_name

    имя модуля-владельца раздела меню

    Описание

    Метод добавляет элемент в меню раздела администрирования

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Advertisement

Class Advertisement

[Строка 11]

Размещен: /Advertisement/Advertisement.class.php

Описание

Класс модуля "Реклама"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean AddBanner()

    Метод добавления/редактирования баннера

  • boolean ClearAdvertisementList()

    Метод очищающий список показов, произошедших $count_days назад

  • boolean DelBannerGroup()

    Метод исключения баннера из группы

  • boolean DelBannersGroup()

    Метод удаления группы баннеров

  • void DeleteAdvertisementFile()

    Метод удаляет загруженный файл для элемента с указанным идентификатором

  • boolean DeleteBanner()

    Метод удаления баннера

  • mixed GetAdvertisement()

    Метод возвращает данные об элементе (баннере, всплывающем окне и т.п.)

  • mixed:
     GetCountShowingBanner()

    Метод возвращает количество показов баннера

  • mixed:
     GetCountShowingBannerAtDay()

    Метод возвращает количество показов баннера за конкретный день

  • boolean InsertBanners()

    Метод добавления баннера в группу/редактирования приоритета показа баннера в группе

  • mixed InsertBannersGroup()

    Метод добавления/редактирования информации о группе баннеров

  • resource SelectBannersGroup()

    Метод получения информации о конкретной группе баннеров или обо всех баннерах

  • boolean ShowBanner()

    Метод показа баннера

  • boolean ShowBannerGroup()

    Метод показа баннера из указанной группы в соответствии с приоритетом

  • mixed:
     ShowBannerIsTrue()

    Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили

Унаследованные методы

Описания методов

    Advertisement::AddBanner

AddBanner(
int
$advertisement_id, string
$advertisement_name, string
$advertisement_comment, int
$advertisement_width, int
$advertisement_height, int
$advertisement_allcount, int
$advertisement_allcount_at_day, int
$advertisement_type, array
$advertisement_image_path, string
$advertisement_image_link, string
$advertisement_text, int
$structure_id, [int
$users_id = false] );

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    $advertisement_name

    название баннера

    $advertisement_comment

    описание баннера

    $advertisement_width

    ширина баннера

    $advertisement_height

    высота баннера

    $advertisement_allcount

    сколько раз показать

    $advertisement_allcount_at_day

    сколько раз показывать в день

    $advertisement_type

    тип баннера

    $advertisement_image_path

    элемент массива $_FILES

    $advertisement_image_link

    ссылка с баннера

    $advertisement_text

    текст баннера

    $structure_id

    идентификатор элемента структуры

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Описание

    Метод добавления/редактирования баннера

    [ Top ]

    Advertisement::ClearAdvertisementList

ClearAdvertisementList(
[mixed
$count_days = 1], int
$count_days=1 );

    Принимаемые параметры

    $count_days=1

    количество дней хранения списка показов

    Описание

    Метод очищающий список показов, произошедших $count_days назад

    [ Top ]

    Advertisement::DelBannerGroup

DelBannerGroup(
int
$advertisement_group_id, int
$advertisement_id );

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $advertisement_id

    идентификатор баннера

    Описание

    Метод исключения баннера из группы

    [ Top ]

    Advertisement::DelBannersGroup

DelBannersGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы баннеров

    Описание

    Метод удаления группы баннеров

    [ Top ]

    Advertisement::DeleteAdvertisementFile

DeleteAdvertisementFile(
int
$advertisement_id );

    Принимаемые параметры

    $advertisement_id

    идентификатор элемента

    Описание

    Метод удаляет загруженный файл для элемента с указанным идентификатором

    [ Top ]

    Advertisement::DeleteBanner

DeleteBanner(
int
$advertisement_id );

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    Описание

    Метод удаления баннера

    [ Top ]

    Advertisement::GetAdvertisement

GetAdvertisement(
int
$advertisement_id );

    Принимаемые параметры

    $advertisement_id

    идентификатор

    Возвращает

    массив с данными или false, если элемент с указанным идентификатором не найден

    Описание

    Метод возвращает данные об элементе (баннере, всплывающем окне и т.п.)

    [ Top ]

    Advertisement::GetCountShowingBanner

GetCountShowingBanner(
int
$banner_id );

    Принимаемые параметры

    $banner_id

    идентификатор баннера

    Возвращает

    int количество показов, если операция была выполнена;
      boolean false если операция не была выполнена

    Описание

    Метод возвращает количество показов баннера

    [ Top ]

    Advertisement::GetCountShowingBannerAtDay

GetCountShowingBannerAtDay(
string
$date, int
$banner_id );

    Принимаемые параметры

    $date

    дата

    $banner_id

    идентификатор баннера

    Возвращает

    int количество показов, если операция была выполнена;
      boolean false если операция не была выполнена

    Описание

    Метод возвращает количество показов баннера за конкретный день

    [ Top ]

    Advertisement::InsertBanners

InsertBanners(
int
$advertisement_group_id, int
$banner_id, int
$banner_value );

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $banner_id

    идентификатор баннера

    $banner_value

    значение приоретета показа

    Описание

    Метод добавления баннера в группу/редактирования приоритета показа баннера в группе

    [ Top ]

    Advertisement::InsertBannersGroup

InsertBannersGroup(
int
$advertisement_group_id, string
$advertisement_group_name, string
$advertisement_group_comment, [int
$users_id = false] );

    Принимаемые параметры

    $advertisement_group_id

    идентификатор  группы баннеров

    $advertisement_group_name

    имя группы баннеров

    $advertisement_group_comment

    комментарий к группе баннеров

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    результат выполнения запроса:
    int идентификатор успешно добавленной/редактированной группы;
    boolean false если операция не была выполнена

    Описание

    Метод добавления/редактирования информации о группе баннеров

    [ Top ]

    Advertisement::SelectBannersGroup

SelectBannersGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы баннеров (-1 выбрать все)

    Возвращает

    результат выполнения запроса на выборку

    Описание

    Метод получения информации о конкретной группе баннеров или обо всех баннерах

    [ Top ]

    Advertisement::ShowBanner

ShowBanner(
int
$banner_id );

    Принимаемые параметры

    $banner_id

    идентификатор баннера

    Описание

    Метод показа баннера

    [ Top ]

    Advertisement::ShowBannerGroup

ShowBannerGroup(
int
$group_id );

    Принимаемые параметры

    $group_id

    идентификатор группы баннеров

    Описание

    Метод показа баннера из указанной группы в соответствии с приоритетом

    [ Top ]

    Advertisement::ShowBannerIsTrue

ShowBannerIsTrue(
int
$list_id );

    Принимаемые параметры

    $list_id

    идентификатор записи показа

    Возвращает

    string ссылка с баннера, если операция была выполнена;
      boolean false, если операция не была выполнена

    Описание

    Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Backup

Class Backup

[Строка 11]

Размещен: /Backup/Backup.class.php

Описание

Класс модуля "Резервное копирование"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void CreateBackup()

    Метод создания резевной копии базы данных

Унаследованные методы

Описания методов

    Backup::CreateBackup

CreateBackup(
string
$backup_name, string
$userName, string
$password, string
$host, string
$db_name );

    Принимаемые параметры

    $backup_name

    полный путь к файлу для резервной копии

    $userName

    имя пользователя БД

    $password

    пароль пользователя БД

    $host

    host БД

    $db_name

    имя базы данных

    Описание

    Метод создания резевной копии базы данных

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Cache

Class Cache

[Строка 11]

Размещен: /Cache/Cache.class.php

Описание

Класс модуля "Кэш"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • bool DeleteCacheItem()

    Метод удаляет (помечает как удаленный) элемент с именем $item_name из кэша unknown_type

  • mixed GetCacheContent()

    Метод получения данных из кэша

  • void GetCacheContentByAddress()

    Метод возвращает данные из кэша, принимает адрес (позицию) блока в кэше и имя кэша

  • bool Insert()

    Вставка значения в кэш

  • void PrintIndex()

Унаследованные методы

Описания методов

    Cache::DeleteCacheItem

DeleteCacheItem(
string
$cache_name, string
$item_name );

    Принимаемые параметры

    $cache_name

    название кэша

    $item_name

    название элемента в кэше

    Возвращает

    результат работы ф-ции

    Описание

    Метод удаляет (помечает как удаленный) элемент с именем $item_name из кэша unknown_type

    [ Top ]

    Cache::GetCacheContent

GetCacheContent(
str
$name, str
$cache_name, [int
$time = false] );

    Принимаемые параметры

    $name

    имя элемента

    $cache_name

    имя кэша

    $time

    время актуальности элемента кэша. По умолчанию false.  Если false - данные берутся из параметров кэша с именем $cache_name

    Возвращает

    если элемент найден в кэше и актуален возвращает array ('value' => значение), если элемент не найден или не актуален возвращает false

    Описание

    Метод получения данных из кэша

    [ Top ]

    Cache::GetCacheContentByAddress

GetCacheContentByAddress(
str
$address, str
$cache_name );

    Принимаемые параметры

    $address

    $cache_name

    Описание

    Метод возвращает данные из кэша, принимает адрес (позицию) блока в кэше и имя кэша

    [ Top ]

    Cache::Insert

Insert(
str
$name, str
$value, str
$cache_name );

    Принимаемые параметры

    $name

    имя элемента в кэше

    $value

    значение элемента

    $cache_name

    имя кэша

    Возвращает

    статус вставки в кэш (истину или ложь)

    Описание

    Вставка значения в кэш

    [ Top ]

    Cache::PrintIndex

PrintIndex(
mixed
$cache_name );

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Captcha

Class Captcha

[Строка 11]

Размещен: /Kernel/Captcha.class.php

Описание

Ядро, класс для работы с CAPTCHA

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void BuildCapture()

    Метод для построения изображения CAPTCHA и помещения его текста в сессию

  • unknown GetCaptchaId()

    Метод генерирует и возвращает уникальный индекс для CAPTCHA

  • boolean ValidCaptcha()

    Метод проверки соответствия введенного пользователем текста хранимому в сессии

Унаследованные методы

Описания методов

    Captcha::BuildCapture

BuildCapture(
int
$id, [mixed
$param = array()], array
$param
 );

    Принимаемые параметры

    $id

    - уникальный номер CAPTCHA

    $param

    $param['alphabet'] Символы используемые в тексте
    $param['allowed_symbols'] Символы, исключающие ошибки распознавания (o = 0, i = j, 1 = l) используются для формирования строки
    $param['fontsdir'] Путь к шрифтам
    $param['length'] Количество символов
    $param['width'] Ширина базового изображения
    $param['height'] Высота базового изображения
    $param['dest_x'] Ширина реального изображения
    $param['dest_y'] Высота реального изображения
    $param['foreground_color'] Цвет текста в RGB задаётся массивом
    $param['background_color'] Цвет фона в RGB задаётся массивом

    Описание

    Метод для построения изображения CAPTCHA и помещения его текста в сессию

    [ Top ]

    Captcha::GetCaptchaId

GetCaptchaId(
 );

    Описание

    Метод генерирует и возвращает уникальный индекс для CAPTCHA

    [ Top ]

    Captcha::ValidCaptcha

ValidCaptcha(
int
$id, string
$text );

    Принимаемые параметры

    $id

    уникальный номер CAPTCHA

    $text

    текст, введённый пользователем

    Описание

    Метод проверки соответствия введенного пользователем текста хранимому в сессии

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class compression

Class compression

[Строка 11]

Размещен: /Compression/Compression.class.php

Описание

Класс модуля "Система сжатия (компрессия)"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string CheckTypeGzip()

    Метод вовзращает тип сжатия gzip, в противном случае false

  • boolean PageCompressionBegin()

    Метод начала приема из стандартного потока содержимого для компрессии

  • void PageCompressionEnd()

    Метод выводит сжатые данные, размещаемые в потоке

Унаследованные методы

Описания методов

    compression::CheckTypeGzip

CheckTypeGzip(
 );

    Возвращает

    возвращает строку или false

    Описание

    Метод вовзращает тип сжатия gzip, в противном случае false

    [ Top ]

    compression::PageCompressionBegin

PageCompressionBegin(
 );

    Описание

    Метод начала приема из стандартного потока содержимого для компрессии

    [ Top ]

    compression::PageCompressionEnd

PageCompressionEnd(
 );

    Описание

    Метод выводит сжатые данные, размещаемые в потоке

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Constants

Class Constants

[Строка 11]

Размещен: /Constants/Constants.class.php

Описание

Класс модуля "Константы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed AddEditConstants()

    Метод добавления/редактирования данных о константе

  • boolean DelConstants()

    Метод удаления константы

  • mixed GetConstants()

    Метод получения данных о константах

Унаследованные методы

Описания методов

    Constants::AddEditConstants

AddEditConstants(
int
$type, int
$constants_id, string
$constants_name, string
$constants_value, string
$constants_description, int
$constants_activity );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление данных о константе (0 - вставка, 1 - обновление)

    $constants_id

    идентификатор константы, если идет обновление

    $constants_name

    имя константы

    $constants_value

    значение константы

    $constants_description

    описание константы

    $constants_activity

    статус активности константы (0 - неактивна, 1 - активна)

    Возвращает

    идентификатор вставленной/обновленной записи в случае успешного выполнения, false - в противном случае

    Описание

    Метод добавления/редактирования данных о константе

    [ Top ]

    Constants::DelConstants

DelConstants(
int
$constants_id );

    Принимаемые параметры

    $constants_id

    идентификатор удаляемой константы

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления константы

    [ Top ]

    Constants::GetConstants

GetConstants(
mixed
$constants_id );

    Принимаемые параметры

    $constants_id

    идентификатор константы, данные о которой необходимо получить,  false - получаем данные о всех константах

    Возвращает

    resource в случае успешного выполнения, false в противном случае

    Описание

    Метод получения данных о константах

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class counter

Class counter

[Строка 8]

Размещен: /Counter/Counter.class.php

Описание

Класс модуля "Статистика посещаемости сайта"

Свойства класса

  • $new_session =  false

        Флаг добавления новой сессии при обновлении данных счетчика

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean AddEditInitialData()

    Метод добавления/редактирования начальных данных для счетчика

  • string AlignTextSpace()

    Метод выравнивания текста по центру с помощью пробелов

  • mixed build_counter()

    Метод вывода счетчика

  • bool CheckBot()

    Метод проверяет, является ли user-agent ботом

  • string code_ip()

    Метод для преобразования IP в HEX

  • string decode_ip()

    Метод для декодирования IP из HEX

  • void DelStatInfomationForSite()

    Метод удаления статистической информации для сайта

  • int GetAllSession()

    Определяет число сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"

  • mixed GetBotsInfo()

    Метод получения данных о ботах и посещенных ими страницах

  • mixed GetCounterInform()

    Метод получения информации о данных счетчика за определенную дату

  • mixed GetDayInformation()

    Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"

  • mixed GetInitialData()

    Метод получения начальных данных для счетчика

  • mixed GetIpInformation()

    Метод выборки информации для IP-адреса

  • mixed GetNewUsersInform()

    Метод выборки информации о новых пользователях сайта

  • mixed GetSearchSystemInform()

    Метод выборки информации о поисковых системах

  • array GetSecondaryStat()

    Метод получения статистической информации из таблицы сессий

  • array GetStatArray()

    Метод получения статистической информации из основной таблицы

  • array GetStatDataArray()

    Метод получения статистических данных за переданный промежуток времени

  • mixed GetUseCJ()

    Метод получения данных о использовании кукисов и Java

  • void InsertRecord()

    Метод добавления записи в основную таблицу статистики

  • int InsertSession()

    Метод для вставки записи о сессии

  • int IpIsNew()

    Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта

  • string IsSearchSystem()

    Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:

  • boolean isset_id()

    Метод проверки наличия id сайта

  • boolean MailReport()

    Метод отправки письма с отчетом администратору сайта

  • void ShowCounterCode()

    Метод, осуществляющий вывод кода счетчика

  • void show_date()

    Метод для вывода формы с полями для дат (для вывода статистики)

  • void show_link()

    Метод для вывода ссылок на различные пункты статистики

Унаследованные методы

Описания методов

    counter::AddEditInitialData

AddEditInitialData(
int
$type, int
$site_id, int
$sessions, int
$hosts, int
$hits, int
$new_users, int
$bots );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $site_id

    идентификатор сайта

    $sessions

    начальное значение сессий

    $hosts

    начальное значение хостов

    $hits

    начальное значение новых пользователей

    $new_users

    начальное значение ботов

    $bots

    начальное значение типа дейтсвия (0-вставка, 1-редактирование)

    Возвращает

    истину при удачной вставке/обновлении или ложь в случае ошибки

    Описание

    Метод добавления/редактирования начальных данных для счетчика

    [ Top ]

    counter::AlignTextSpace

AlignTextSpace(
int
$count_all, strlen
$text );

    Принимаемые параметры

    $count_all

    общее количество символов

    $text

    текст

    Возвращает

    строка с выровненным текстом

    Описание

    Метод выравнивания текста по центру с помощью пробелов

    [ Top ]

    counter::build_counter

build_counter(
int
$site_id, int
$js_version, int
$screen, int
$remote_addr, string
$current_page, string
$refer, int
$px, string
$user_agent, string
$cookie, string
$java, int
$counter, [int
$update_counter = 1] );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $js_version

    js версия пользователя

    $screen

    параметры экрана пользователя

    $remote_addr

    ip адрес пользователя

    $current_page

    посещенная страница

    $refer

    ссылающаяся страница

    $px

    глубина цвета пользователя

    $user_agent

    user agent пользователя

    $cookie

    флаг поддержки кукисов

    $java

    флаг поддержки java

    $counter

    номер счетчика для определения изображения

    $update_counter

    - флаг обновления данных счетчика (1-обновлять (по умолчанию), 0-просто построить счетчик)

    Возвращает

    ложь в случае ошибки, в случае успешного построения счетчика и вставки/обновления данных метод ничего не возвращает

    Описание

    Метод вывода счетчика

    [ Top ]

    counter::CheckBot

CheckBot(
string
$agent );

    Принимаемые параметры

    $agent

    user-agent

    Возвращает

    истину, если это бот или ложь в противном случае

    Описание

    Метод проверяет, является ли user-agent ботом

    [ Top ]

    counter::code_ip

code_ip(
string
$ip );

    Принимаемые параметры

    $ip

    ip-адрес

    Возвращает

    ip-адрес, преобразованный в 16-ое значение для записи в базу

    Описание

    Метод для преобразования IP в HEX

    [ Top ]

    counter::decode_ip

decode_ip(
srting
$ip );

    Принимаемые параметры

    $ip

    ip-адрес в 16-ричном формате

    Возвращает

    ip-адрес в обычном формате для вывода

    Описание

    Метод для декодирования IP из HEX

    [ Top ]

    counter::DelStatInfomationForSite

DelStatInfomationForSite(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Описание

    Метод удаления статистической информации для сайта

    [ Top ]

    counter::GetAllSession

GetAllSession(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    число сессий для сайта

    Описание

    Определяет число сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"

    [ Top ]

    counter::GetBotsInfo

GetBotsInfo(
string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    информация о ботах в случае удачной выборки, ложь - при возникновении ошибки

    Описание

    Метод получения данных о ботах и посещенных ими страницах

    [ Top ]

    counter::GetCounterInform

GetCounterInform(
int
$site_id, [string
$date = ''], [string
$mark = "="] );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $date

    дата (не обязательный параметр, по умолчанию = '')

    $mark

    знак сравнения с датой (по умолчанию - "=")

    Возвращает

    массив с данными при успешной выборке, иначе - ложь

    Описание

    Метод получения информации о данных счетчика за определенную дату

    [ Top ]

    counter::GetDayInformation

GetDayInformation(
str
$date, int
$site_id );

    Принимаемые параметры

    $date

    дата в формате ГГГГ-ММ-ДД

    $site_id

    идентификатор сайта

    Возвращает

    array с данными или false, если данные отсутствуют

    Описание

    Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"

    [ Top ]

    counter::GetInitialData

GetInitialData(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    информация о начальных данных, ложь - если запись не выбрана

    Описание

    Метод получения начальных данных для счетчика

    [ Top ]

    counter::GetIpInformation

GetIpInformation(
string
$ip_adr, string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $ip_adr

    ip адрес

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    массив с данными по ip адресу при успешной выборке, иначе - ложь

    Описание

    Метод выборки информации для IP-адреса

    [ Top ]

    counter::GetNewUsersInform

GetNewUsersInform(
string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    массив с данными о новых пользователях при успешной выборке, иначе - ложь

    Описание

    Метод выборки информации о новых пользователях сайта

    [ Top ]

    counter::GetSearchSystemInform

GetSearchSystemInform(
string
$date_from, string
$date_to, int
$site_id, [int
$limit = ''] );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничение количества выбираемых записей (не обязательный параметр)

    Возвращает

    массив с данными о поисковых системах при успешной выборке, ложь при возникновении ошибок

    Описание

    Метод выборки информации о поисковых системах

    [ Top ]

    counter::GetSecondaryStat

GetSecondaryStat(
int
$type, string
$date_from, string
$date_to, int
$site_id, [string
$limit = ''] );

    Принимаемые параметры

    $type

    вид информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничение количества страниц ($limit - не обязательный параметр)

    Возвращает

    информация с данными статистики

    Описание

    Метод получения статистической информации из таблицы сессий

    [ Top ]

    counter::GetStatArray

GetStatArray(
int
$type, string
$date_from, string
$date_to, int
$site_id, [string
$limit = ''] );

    Принимаемые параметры

    $type

    вид информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничения количества страниц

    Возвращает

    данные статистики

    Описание

    Метод получения статистической информации из основной таблицы

    [ Top ]

    counter::GetStatDataArray

GetStatDataArray(
string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    ассоциативный массив с данными

    Описание

    Метод получения статистических данных за переданный промежуток времени

    [ Top ]

    counter::GetUseCJ

GetUseCJ(
int
$type, string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $type

    тип отбираемой информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор данных

    Возвращает

    ассоциативный массив с данными об использовании кукисов и Java при успешной выборке, иначе - ложь

    Описание

    Метод получения данных о использовании кукисов и Java

    [ Top ]

    counter::InsertRecord

InsertRecord(
int
$session_id, int
$site_id, string
$refer, string_type
$page, string
$cookie, string
$java, string
$search_system, string
$search_query, int_type
$user_number, int_type
$user_is_new, string
$ip_adr, string
$hostname );

    Принимаемые параметры

    $session_id

    идентификатор сессии

    $site_id

    идентификатор сайта

    $refer

    ссылающаяся страница

    $page

    страница

    $cookie

    флаг поддержки кукисов

    $java

    флаг поддержки java

    $search_system

    флаг поисковой системы

    $search_query

    поисковая фраза

    $user_number

    номер пользователя

    $user_is_new

    флаг новый пользователь или нет

    $ip_adr

    преобразованный ip

    $hostname

    имя хоста

    Описание

    Метод добавления записи в основную таблицу статистики

    [ Top ]

    counter::InsertSession

InsertSession(
int
$site_id, int
$color_depth, string
$display_name, string
$js_version, string
$ip_adr, string
$user_agent, int
$is_bot );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $color_depth

    глубина цвета

    $display_name

    параметры экрана

    $js_version

    версия js

    $ip_adr

    преобразованный ip

    $user_agent

    user agent

    $is_bot

    флаг - бот/не бот

    Возвращает

    идетнификатор вставленной записи, либо идентификатор уже имеющейся записи о текущей сессии

    Описание

    Метод для вставки записи о сессии

    [ Top ]

    counter::IpIsNew

IpIsNew(
str
$ip_adr, str
$date_t, int
$site_id );

    Принимаемые параметры

    $ip_adr

    упакованный IP-адрес

    $date_t

    дата

    $site_id

    идентификатор сайта

    Возвращает

    1 - новый, 0 - не новый

    Описание

    Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта

    [ Top ]

    counter::IsSearchSystem

IsSearchSystem(
string
$str );

    Принимаемые параметры

    $str

    адрес ссылающейся страницы

    Возвращает

    поисковый запрос

    Описание

    Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:

    Yandex
    Rambler
    Google
    Mail.Ru
    Aport
    MSN
    Altavista
    KM.Ru
    Yahoo.com
    Webalta
    Metabot
    Nigma

    [ Top ]

    counter::isset_id

isset_id(
int
$id );

    Принимаемые параметры

    $id

    идентификатор сайта

    Возвращает

    Истина при наличии сайта, ложь - если данного сайта не существует

    Описание

    Метод проверки наличия id сайта

    [ Top ]

    counter::MailReport

MailReport(
int
$site_id, string
$date );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $date

    дата отчета

    Возвращает

    ложь в случае ошибки, в случае успеной отправки метод не возвращет никаких значений

    Описание

    Метод отправки письма с отчетом администратору сайта

    [ Top ]

    counter::ShowCounterCode

ShowCounterCode(
number
$counter_type, string
$alias_name, array
$gCounterProperties, [string
$get_update_counter = ''] );

    Принимаемые параметры

    $counter_type

    тип выводимого счетчика (файл счетчика должен быть расположен в директории /counter/ и представлять собой изображение с именем {НОМЕР}.gif)

    $alias_name

    наименование домена сайта, например www.hostcms.ru

    $gCounterProperties

    глобальный массив, содержащий свойства счетчика

    $get_update_counter

    переменная с информацией о необходимости обновления счетчика, не обязательный параметр, по умолчанию равен пустоте

    Описание

    Метод, осуществляющий вывод кода счетчика

    Пример использования:

    1      <?
    2              $counter = new counter();
    3              $counter->ShowCounterCode(0,"www.hostcms.ru",$GLOBALS['gCounterProperties'],"&update_counter=0");
    4      ?>

    [ Top ]

    counter::show_date

show_date(
string
$part, [string
$action = 'counter.php'] );

    Принимаемые параметры

    $part

    раздел статистики (например, show_stat_user)

    $action

    action для формы

    Описание

    Метод для вывода формы с полями для дат (для вывода статистики)

    [ Top ]

    counter::show_link

show_link(
 );

    Описание

    Метод для вывода ссылок на различные пункты статистики

    [ Top ]

Описания переменных

  • $new_session =  false [Строка 14]
    •

  • Data type: boolean
    •

    Описание

    Флаг добавления новой сессии при обновлении данных счетчика

Описание констант класса

support@hostcms.ru


Docs For Class DateClass

Class DateClass

[Строка 11]

Размещен: /Kernel/Date.class.php

Описание

Ядро, класс для работы с датами

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed admin_datetime_format()

    Метод для админки формат вывода даты-времени из SQL-формата в формат d-m-Y

  • mixed admin_date_format()

    Метод для админки, преобразует формат выводы даты из sql-формата в формат d-m-Y

  • string ChangeMySqlDate()

    Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд

  • string ChangeNormalDate()

    Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд

  • mixe DateSqlToUnix()

    Метод преобразовывает дату в формате SQL в число секунд с начала эпохи

  • mixed datetime_format()

    Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT

  • mixed datetime_format_sql()

    Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL

  • string DateUnixToSQL()

    Метод преобразовывает дату из числа секунд в формат SQL

  • mixed date_format()

    Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT

  • mixed date_format_sql()

    Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат

Унаследованные методы

Описания методов

    DateClass::admin_datetime_format

admin_datetime_format(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    Описание

    Метод для админки формат вывода даты-времени из SQL-формата в формат d-m-Y

    [ Top ]

    DateClass::admin_date_format

admin_date_format(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    Описание

    Метод для админки, преобразует формат выводы даты из sql-формата в формат d-m-Y

    [ Top ]

    DateClass::ChangeMySqlDate

ChangeMySqlDate(
int
$second, [string
$date = ''] );

    Принимаемые параметры

    $second

    число секунд

    $date

    принимаемая дата

    Возвращает

    измененная дата

    Описание

    Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд

    [ Top ]

    DateClass::ChangeNormalDate

ChangeNormalDate(
int
$second, [string
$date = ''] );

    Принимаемые параметры

    $second

    число секунд

    $date

    дата в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС

    Возвращает

    дата в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС

    Описание

    Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд

    [ Top ]

    DateClass::DateSqlToUnix

DateSqlToUnix(
string
$date, [string
$date_separator = '-'] );

    Принимаемые параметры

    $date

    дата в формате MySQL

    $date_separator

    разделитель даты (по умолчанию "-")

    Возвращает

    дата в формате числа секунд с начала эпохи в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразовывает дату в формате SQL в число секунд с начала эпохи

    [ Top ]

    DateClass::datetime_format

datetime_format(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT

    [ Top ]

    DateClass::datetime_format_sql

datetime_format_sql(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    дата в формате MySQL в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL

    [ Top ]

    DateClass::DateUnixToSQL

DateUnixToSQL(
string
$datetime );

    Принимаемые параметры

    $datetime

    число секунд с начала эпохи

    Возвращает

    дата в формате SQL

    Описание

    Метод преобразовывает дату из числа секунд в формат SQL

    [ Top ]

    DateClass::date_format

date_format(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT

    [ Top ]

    DateClass::date_format_sql

date_format_sql(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    дата в формате MySQL в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class documents

Class documents

[Строка 11]

Размещен: /Documents/Documents.class.php

Описание

Класс модуля "Старницы и документы"

Свойства класса

  • $mas_documents_dir = array()

        Массив разделов документов

  • $record_on_page = ON_PAGE

        Число записей, выводимых на странице в административной части

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void CopyDocuments()

    Метод копирования документа

  • boolean current_version()

    Метод для переобозначения текущей версии документа

  • boolean delete_old_version()

    Метод удаления записей обо всех не текущих версиях

  • boolean delete_status()

    Метод удаления статуса документов

  • boolean delete_version()

    Метод удаления записей о версиях

  • boolean del_documents()

    Метод удаления документов

  • boolean del_documents_dir()

    Метод удаления разделов документов

  • mixed GetDocumentVersion()

    Метод получения информации о текущей версии документа

  • array get_documents_dir()

    Метод формирования дерева разделов

  • string get_path()

    Метод формирования строки ссылок с родительскими разделами

  • int insert_documents()

    Метод вставки и обновления новых документов

  • int insert_documents_dir()

    Метод вставки и обновления разделов документов

  • int insert_status()

    Метод добавления(редактирования) статусов документов

  • int insert_version()

    Метод добавления/редактирования записей о версиях

  • resource select_documents()

    Метод получения информации о документе или обо всех документах

  • resource select_documents_dir()

    Метод  выбора раздела документов

  • resource select_status()

    Метод получения информации о статусе документа

  • resource select_version()

    Метод выборки информации о версиях

  • void ShowDocument()

    Метод вызывает показ текущей версии переданной страницы

  • void show_link()

    Метод формирования строки ссылок на разделы и подразделы

Унаследованные методы

Описания методов

    documents::CopyDocuments

CopyDocuments(
int
$documents_id );

    Принимаемые параметры

    $documents_id

    идентификатор копируемого документа

    Описание

    Метод копирования документа

    [ Top ]

    documents::current_version

current_version(
int
$documents_id, int
$id );

    Принимаемые параметры

    $documents_id

    идентификатор документа

    $id

    идентификатор текущей версии

    Возвращает

    true при удачном обновлении данных, false в обратном случае

    Описание

    Метод для переобозначения текущей версии документа

    [ Top ]

    documents::delete_old_version

delete_old_version(
int
$documents_id );

    Принимаемые параметры

    $documents_id

    идентификатор документа

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления записей обо всех не текущих версиях

    [ Top ]

    documents::delete_status

delete_status(
int
$status_id );

    Принимаемые параметры

    $status_id

    идентификатор удаляемого статуса документов

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления статуса документов

    [ Top ]

    documents::delete_version

delete_version(
int
$version_id );

    Принимаемые параметры

    $version_id

    идентификатор удаляемой версии

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления записей о версиях

    [ Top ]

    documents::del_documents

del_documents(
int
$id );

    Принимаемые параметры

    $id

    идентификатор документа

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления документов

    [ Top ]

    documents::del_documents_dir

del_documents_dir(
int
$id );

    Принимаемые параметры

    $id

    идентификатор раздела

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления разделов документов

    [ Top ]

    documents::GetDocumentVersion

GetDocumentVersion(
int
$documents_id );

    Принимаемые параметры

    $documents_id

    идентификатор отображаемого документа

    Возвращает

    информарция о версии документа в случае успешного выполнения или false, если текущая версия не найдена

    Описание

    Метод получения информации о текущей версии документа

    [ Top ]

    documents::get_documents_dir

get_documents_dir(
int
$documents_dir_parent_id, int
$separator_dir, [int
$id_red = 0] );

    Принимаемые параметры

    $documents_dir_parent_id

    идентификатор родительского раздела, с которого начинается формирование

    $separator_dir

    отступ для подразделов

    $id_red

    идентификатор раздела, который необходимо пропустить (не включать в дерево вместе с подразделами)

    Возвращает

    ассоциативный массив с информацией о дереве разделов

    Описание

    Метод формирования дерева разделов

    [ Top ]

    documents::get_path

get_path(
int
$dir_id, string
$prefix, string
$sufix );

    Принимаемые параметры

    $dir_id

    идентификатор раздела

    $prefix

    префикс для формирования ссылки на раздел

    $sufix

    строку, дописываемую к ссылке

    Возвращает

    строка ссылок с родительскими разделами

    Описание

    Метод формирования строки ссылок с родительскими разделами

    [ Top ]

    documents::insert_documents

insert_documents(
int
$type, int
$documents_id, int
$documents_dir_id, int
$users_id, int
$documents_status_id, string
$documents_name, int
$version_id, int
$version_current, int
$version_comment, string
$documents_text, int
$templates_id );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_id

    идентификатор документа

    $documents_dir_id

    идентификатор радздела

    $users_id

    идентификатор пользователя

    $documents_status_id

    идентификатор статуса документа

    $documents_name

    наименование документа

    $version_id

    идентификатор версии документа

    $version_current

    указатель на текущую версию

    $version_comment

    комментарий к версии документа

    $documents_text

    текст документа

    $templates_id

    идентификатор шаблона

    Возвращает

    идентификатор документа

    Описание

    Метод вставки и обновления новых документов

    [ Top ]

    documents::insert_documents_dir

insert_documents_dir(
int
$type, int
$documents_dir_id, int
$documents_dir_parent_id, string
$documents_dir_name, [int
$users_id = false] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_dir_id

    идентификатор раздела

    $documents_dir_parent_id

    идентификатор родительского раздела

    $documents_dir_name

    наименование раздела

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор отредактированного (вставленного) раздела

    Описание

    Метод вставки и обновления разделов документов

    [ Top ]

    documents::insert_status

insert_status(
int
$type, int
$status_id, string_type
$status_name, string
$status_description, [int
$users_id = false] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $status_id

    идентификатор статуса документа

    $status_name

    наименование статуса

    $status_description

    описание статуса

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор нового или редатируемого статуса (в зависимости от типа действия)

    Описание

    Метод добавления(редактирования) статусов документов

    [ Top ]

    documents::insert_version

insert_version(
int
$type, int
$version_id, int
$documents_id, int
$version_current, string
$version_comment, string
$documents_text, int
$users_id, int
$templates_id );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $version_id

    идентификатор версии документа

    $documents_id

    идентификатор документа

    $version_current

    флаг текущей версии

    $version_comment

    комментарий к версии

    $documents_text

    текст документа

    $users_id

    идентификатор пользователя

    $templates_id

    идентификатор шаблона

    Возвращает

    идентификатор новой или редатируемой версии (в зависимости от типа действия)

    Описание

    Метод добавления/редактирования записей о версиях

    [ Top ]

    documents::select_documents

select_documents(
int
$id );

    Принимаемые параметры

    $id

    идентификатор документа (-1 - выбор всех документов)

    Возвращает

    реестр документов или данные о конкретном документе

    Описание

    Метод получения информации о документе или обо всех документах

    [ Top ]

    documents::select_documents_dir

select_documents_dir(
int
$id );

    Принимаемые параметры

    $id

    идентификатор раздела (-1 - выбор всех разделов)

    Возвращает

    список всех разделов или данные о конкретном разделе

    Описание

    Метод  выбора раздела документов

    [ Top ]

    documents::select_status

select_status(
int
$id );

    Принимаемые параметры

    $id

    идентификатор статуса (-1 - выбор всех статусов)

    Возвращает

    информация о статусе документа (обо всех статусах)

    Описание

    Метод получения информации о статусе документа

    [ Top ]

    documents::select_version

select_version(
int
$documents_id, int
$id, int
$current );

    Принимаемые параметры

    $documents_id

    идентификатор документа

    $id

    идентификатор версии

    $current

    указатель на текущую версию

    Возвращает

    информация о версиях документа

    Описание

    Метод выборки информации о версиях

    [ Top ]

    documents::ShowDocument

ShowDocument(
int
$document_id );

    Принимаемые параметры

    $document_id

    иднетификатор отображаемого документа

    Описание

    Метод вызывает показ текущей версии переданной страницы

    [ Top ]

    documents::show_link

show_link(
int
$documents_dir_id );

    Принимаемые параметры

    $documents_dir_id

    идентификатор раздела

    Описание

    Метод формирования строки ссылок на разделы и подразделы

    [ Top ]

Описания переменных

  • $mas_documents_dir = array() [Строка 34]
    •

  • Data type: array
    •

    Описание

    Массив разделов документов

  • $record_on_page = ON_PAGE [Строка 27]
    •

  • Data type: int
    •

    Описание

    Число записей, выводимых на странице в административной части

Описание констант класса

support@hostcms.ru


Docs For Class EventsJournalAdmin

Class EventsJournalAdmin

[Строка 11]
EventsJournal
   |
   --EventsJournalAdmin
Размещен: /EventsJournal/EventsJournal.class.php

Описание

Класс модуля "Журнал событий"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean EventsMail()
    Метод отправки письма с отчетом

Унаследованные методы

Унаследованные от класса EventsJournal

  • EventsJournal::log_access()
    Метод протоколирования получения доступа к системе управления

Описания методов

    EventsJournalAdmin::EventsMail

    EventsMail( string $date );

    Принимаемые параметры

    $date

    дата отчета

    Описание

    Метод отправки письма с отчетом

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class EventsJournal

Class EventsJournal

[Строка 11]

Classes extended from EventsJournal:

EventsJournalAdmin

Класс модуля "Журнал событий"

Размещен: /Kernel/EventsJournal.class.php

Описание

Ядро, класс журналирования событий

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean log_access()

    Метод протоколирования получения доступа к системе управления

Унаследованные методы

Описания методов

    EventsJournal::log_access

log_access(
string
$login, string_type
$message, [string
$status = 0], [string
$send_email = true] );

    Принимаемые параметры

    $login

    логин пользователя

    $message

    текст сообщения для события

    $status

    статус события (значимость события), необязательный параметр.
    Статус имеет значения:
    0 – Нейтральное
    1 – Успешное
    2 – Низкий уровень критичности
    3 – Средний уровень критичности
    4 – Наивысший уровень критичности

    $send_email

    отправлять администратору сообщение о произошедшем событии (по умолчанию true), необязательный параметр

    Описание

    Метод протоколирования получения доступа к системе управления

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class ExecSqlQuery

Class ExecSqlQuery

[Строка 11]

Размещен: /ExecSqlQuery/ExecSqlQuery.class.php

Описание

Класс модуля "SQL-запросы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int ExecDump()

    Метод выполнения SQL-запроса

  • str GetTableNames()

    Метод для получения списка таблиц, разделенных запятыми.

Унаследованные методы

Описания методов

    ExecSqlQuery::ExecDump

ExecDump(
string
$query );

    Принимаемые параметры

    $query

    SQL-запрос

    Возвращает

    количество выполненных запросов или false

    Описание

    Метод выполнения SQL-запроса

    [ Top ]

    ExecSqlQuery::GetTableNames

GetTableNames(
 );

    Возвращает

    список таблиц в виде: `table1`,`table2`,`table3` либо false.

    Описание

    Метод для получения списка таблиц, разделенных запятыми.

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class ExternalXml

Class ExternalXml

[Строка 6]

Размещен: /Kernel/ExternalXml.class.php

Описание

Ядро, класс формирует дерево XML по переданному массиву

Свойства класса

  • $flag =  false

  • $xml =  ''

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string GenXml()

    Метод генерации XML для переданного массива

Унаследованные методы

Описания методов

    ExternalXml::GenXml

GenXml(
array
$array, [int
$type = 0] );

    Принимаемые параметры

    $array

    массив с информацией о дереве

    $type

    тип переданного массива
      Тип 0:  $x['xml_tag_name'] = "value";
      Тип 1:  $x[0]['xml_name'] = 'xml_name';
      $x[0]['value'] = 'value';
      value может быть массивом неограниченного уровня вложенности

    Возвращает

    XML-код

    Описание

    Метод генерации XML для переданного массива

    [ Top ]

Описания переменных

  • $flag =  false [Строка 9]
    •

  • Data type: mixed
    •

  • $xml =  '' [Строка 8]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class File

Class File

[Строка 11]

Размещен: /Kernel/File.class.php

Описание

Ядро, класс для работы с файлами

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean Download()

    Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла

  • string GetFileContent()

    Метод получения содержимого файла

  • string get_file_perms()

    Метод получения строки прав доступа к файлу

  • string PathCorrection()

    Метод удаляет потенциально опасных символы из пути или имени файла

  • void RecursiveRemoveDir()

    Метод удаляет директорию со всеми поддиректориями и файлами

Унаследованные методы

Описания методов

    File::Download

Download(
string
$file, string
$filename );

    Принимаемые параметры

    $file

    абсолютный путь к файлу

    $filename

    имя файла

    Описание

    Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла

    [ Top ]

    File::GetFileContent

GetFileContent(
string
$filename );

    Принимаемые параметры

    $filename

    абсолютный путь к файлу

    Возвращает

    содержимое файла, если такой файл существует или false, если файл не существует или его невозможно прочитать

    Описание

    Метод получения содержимого файла

    [ Top ]

    File::get_file_perms

get_file_perms(
string
$filename, int
$type );

    Принимаемые параметры

    $filename

    имя файла

    $type

    тип строки (0 - "-rw-rw-rw-"; 1 - "0755")

    Возвращает

    строка прав доступа к файлу

    Описание

    Метод получения строки прав доступа к файлу

    [ Top ]

    File::PathCorrection

PathCorrection(
string
$path );

    Принимаемые параметры

    $path

    путь

    Возвращает

    путь без потенциально опасных символов

    Описание

    Метод удаляет потенциально опасных символы из пути или имени файла

    [ Top ]

    File::RecursiveRemoveDir

RecursiveRemoveDir(
mixed
$dir, string
$path );

    Принимаемые параметры

    $path

    абсолютный путь к директории

    Описание

    Метод удаляет директорию со всеми поддиректориями и файлами

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class FileManager

Class FileManager

[Строка 11]

Размещен: /FileManager/FileManager.class.php

Описание

Класс модуля "Файловый менеджер"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean del_dir()

    Метод удаления директории вместе с вложенными файлами и директориями

  • boolean del_file()

    Метод удаления файла или директории

  • boolean load_files()

    Метод загрузки файлов

  • string PathCorrection()

    Метод удаляет потенциально опасных символы из пути или имени файла

Унаследованные методы

Описания методов

    FileManager::del_dir

del_dir(
string
$dir );

    Принимаемые параметры

    $dir

    полный путь

    Возвращает

    true в случаее успешного выполнеия, false в противном случае

    Описание

    Метод удаления директории вместе с вложенными файлами и директориями

    [ Top ]

    FileManager::del_file

del_file(
string
$file_name );

    Принимаемые параметры

    $file_name

    полный путь

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления файла или директории

    [ Top ]

    FileManager::load_files

load_files(
array
$source, string
$file_name, string
$dir_file, [boolean
$rewrite = true] );

    Принимаемые параметры

    $source

    информация о файле $_FILES['file']

    $file_name

    имя файла

    $dir_file

    директория для размещения файла

    $rewrite

    разрешает замену уже существующего файла, по молчанию true

    Описание

    Метод загрузки файлов

    [ Top ]

    FileManager::PathCorrection

PathCorrection(
string
$path );

    Принимаемые параметры

    $path

    путь

    Возвращает

    путь без потенциально опасных символов

    Описание

    Метод удаляет потенциально опасных символы из пути или имени файла

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Forms

Class Forms

[Строка 11]

Размещен: /Forms/Forms.class.php

Описание

Класс модуля "Формы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int ConfirmGetForm()

    Метод, определяющий может ли пользователь отправлять форму

  • void CopyForms()

    Метод копирования структуры формы и ее полей

  • mixed CopyFormsField()

    Метод копирования структуры поля формы

  • boolean DelFillForms()

    Удаление бланка заполненной формы

  • boolean DelFillValues()

    Метод удаления значения одного из полей отправленной формы

  • boolean DelForms()

    Метод удаления данных о форме

  • boolean DelFormsFields()

    Метод удаления поля формы

  • mixed GetAllForms()

    Метод получения всех форм.

  • resource GetFillForms()

    Метод получения списка заполненных форм для формы $forms_id.

  • resource GetFillFormsFields()

    Метод получения списка и значения полей для заполненной формы.

  • boolean GetForm()

    Метод обработки содержимого отправленной формы

  • mixed GetFormFields()

    Метод получения данных о полях формы

  • mixed InsertForms()

    Метод вставки/обновления информации о форме

  • mixed InsertFormsFields()

    Метод вставки/обновления информации о поле формы

  • mixed InsertFormsFill()

    Метод вставки/обновления информации о заполнении формы

  • mixed InsertFormsFillValues()

    Метод вставки/обновления значений заполненной формы

  • mixed SelectForms()

    Метод выбора данных о формах

  • mixed SelectFormsFields()

    Метод выбора данных о поле формы

  • boolean ShowForm()

    Метод отображения формы

Унаследованные методы

Описания методов

    Forms::ConfirmGetForm

ConfirmGetForm(
int
$forms_id, string
$date, string
$forms_fill_ip );

    Принимаемые параметры

    $forms_id

    идентификатор отправляемой формы

    $date

    дата и время (в формате MySQL) отправки формы

    $forms_fill_ip

    ip-адрес компьютера отправителя формы

    Возвращает

    1 – пользователь может отправлять данные формы, 0 – пользователь не может отправлять данные формы

    Описание

    Метод, определяющий может ли пользователь отправлять форму

    [ Top ]

    Forms::CopyForms

CopyForms(
int
$forms_id );

    Принимаемые параметры

    $forms_id

    идентификатор формы, структуру которой необходимо скопировать

    Описание

    Метод копирования структуры формы и ее полей

    [ Top ]

    Forms::CopyFormsField

CopyFormsField(
int
$forms_field_id, [array
$param = array()] );

    Принимаемые параметры

    $forms_field_id

    идентификатор поля формы, копию которого необходимо сделать

    $param

    ассоциативный массив параметров
    $param['show_text_copy'] параметр, определяющий будет добавляться текcт "Копия [датавремя создания копии]" к названию копии поля формы (true - добавлять текст, false - не добавлять), по умолчанию $param['show_text_copy'] = true

    Возвращает

    идентификатор нового (скопированного) поля формы, false в противном случае

    Описание

    Метод копирования структуры поля формы

    [ Top ]

    Forms::DelFillForms

DelFillForms(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого бланка

    Возвращает

    true в случае успешного удаления, false в противном случае

    Описание

    Удаление бланка заполненной формы

    [ Top ]

    Forms::DelFillValues

DelFillValues(
int
$id );

    Принимаемые параметры

    $id

    идентификатор записи, содержащей значение поля отправленной формы

    Возвращает

    true в случае успешного удаления значения поля отправленной формы, false в противном случае

    Описание

    Метод удаления значения одного из полей отправленной формы

    [ Top ]

    Forms::DelForms

DelForms(
int
$id );

    Принимаемые параметры

    $id

    идентификатор формы, информацию о которой необходимо удалить

    Возвращает

    true в случае успешного удаления формы, false в противном случае

    Описание

    Метод удаления данных о форме

    [ Top ]

    Forms::DelFormsFields

DelFormsFields(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого поля формы

    Возвращает

    true в случае успешного удаления поля формы, false в противном случае

    Описание

    Метод удаления поля формы

    [ Top ]

    Forms::GetAllForms

GetAllForms(
 );

    Возвращает

    ресурс или, в случае неудачи, false

    Описание

    Метод получения всех форм.

    [ Top ]

    Forms::GetFillForms

GetFillForms(
[int
$forms_id = false] );

    Принимаемые параметры

    $forms_id

    - идентификатор формы, если false - все заполненные формы всех форм

    Описание

    Метод получения списка заполненных форм для формы $forms_id.

    [ Top ]

    Forms::GetFillFormsFields

GetFillFormsFields(
int
$fill_forms_id );

    Принимаемые параметры

    $fill_forms_id

    Описание

    Метод получения списка и значения полей для заполненной формы.

    [ Top ]

    Forms::GetForm

GetForm(
int
$form_id, string
$xsl_forms, string
$xsl_email, [array
$param = array()], [array
$external_propertys = array()] );

    Принимаемые параметры

    $form_id

    идентификатор отправленной формы

    $xsl_forms

    XSL-шаблон, формирующий сообщение пользователю при отправке формы

    $xsl_email

    XSL-шаблон, формирующий текст письма куратору отправленной формы с данными, переданными в форме

    $param

    массив дополнительных параметров, имеет следующую структуру  $param['e-mail'] - поле формы, содержащие email адрес отправителя  $param['subject'] - тема письма куратору формы  $param['type'] - тип письма (0- text/html, 1- text/plain).

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    Возвращает

    true в случае успешного отправления формы, false в противном случае

    Описание

    Метод обработки содержимого отправленной формы

    [ Top ]

    Forms::GetFormFields

GetFormFields(
int
$form_id );

    Принимаемые параметры

    $form_id

    идентификатор формы

    Возвращает

    resorce в случае успешного выполнения, false в противном случае

    Описание

    Метод получения данных о полях формы

    [ Top ]

    Forms::InsertForms

InsertForms(
int
$type, int
$forms_id, string
$forms_name, string
$forms_description, string
$forms_email, int
$forms_button_type, string
$forms_button_name, string
$forms_button_value, string
$forms_button_text_value, [array
$param = array()], [mixed
$forms_mail_subject = ''], [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о форме( 0 – вставка, 1 обновление)

    $forms_id

    идентификатор обновляемой формы (при вставке равен 0)

    $forms_name

    имя формы

    $forms_description

    описание формы

    $forms_email

    e-mail куратора формы

    $forms_button_type

    тип кнопки для формы (0 – простая кнопка, 1кнопка типа button)

    $forms_button_name

    название кнопки (английское)

    $forms_button_value

    значение, передаваемое при нажатии кнопки

    $forms_button_text_value

    текст на кнопке

    $param

    массив дополнительных параметров
     $param['forms_captcha_used'] параметр, определяющий использовать при отображении формы captcha (1 использовать, 0 не использовать)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной/обновленной формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления информации о форме

    [ Top ]

    Forms::InsertFormsFields

InsertFormsFields(
int
$type, int
$forms_fields_id, int
$forms_id, int
$lists_id, int
$forms_fields_type, string
$forms_fields_name, string
$forms_fields_text_name, string
$forms_fields_default_value, int
$forms_fields_order, int
$forms_fields_size, int
$forms_fields_rows, int
$forms_fields_cols, int
$forms_fields_checked, string
$forms_fields_comment, [int
$forms_fields_obligatory = 0], [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о поле формы (0 – вставка, 1 обновление)

    $forms_fields_id

    идентификатор обновляемого поля формы (при вставке равен 0)

    $forms_id

    идентификатор формы, к которой относится обновляемое/добавляемое поле

    $lists_id

    идентификатор списка, с которым связано поле (для полей типа «радиогруппа»,  «выпадающий список»)

    $forms_fields_type

    – тип поля формы (0 – текстовое поле, 1 – поле пароля, 2 – поле загрузки файла,    3 – радиокнопка, 4 – checkbox, 5 – большое текстовое поле, 6 – список, 7 – скрытое поле)

    $forms_fields_name

    английское название поля (тег “name”)

    $forms_fields_text_name

    поясняющий текст для поля формы

    $forms_fields_default_value

    значение по умолчанию

    $forms_fields_order

    порядоковый номер поля

    $forms_fields_size

    ширина поля формы (для текстового поля и поля пароля)

    $forms_fields_rows

    высота большого текстового поля

    $forms_fields_cols

    ширина большого текстового поля

    $forms_fields_checked

    параметр, определяющий отображать поле типа checkbox выбранным или нет (0 – не выбрано, 1 выбрано)

    $forms_fields_comment

    поясняющий комментарий к полю

    $forms_fields_obligatory

    параметр, определяющий является поле обязательным для заполнения (0 – необязательное (по умолчанию), 1 – обязательное)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной/обновленной записи с информацией о поле формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления информации о поле формы

    [ Top ]

    Forms::InsertFormsFill

InsertFormsFill(
int
$type, int
$forms_fill_id, int
$forms_id, int
$forms_fill_ip, string
$forms_fill_date );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о заполнении формы

    $forms_fill_id

    идентификатор редактируемой записи с информацией о заполненной форме (при вставке равен 0)

    $forms_id

    идентификатор формы

    $forms_fill_ip

    ip-адрес компьютера пользователя, отправившего данные формы

    $forms_fill_date

    дата заполнения формы

    Возвращает

    идентификатор вставленной/обновленной записи с информацией о заполнении поле формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления информации о заполнении формы

    [ Top ]

    Forms::InsertFormsFillValues

InsertFormsFillValues(
int
$type, int
$forms_fill_values_id, int
$forms_fill_id, int
$forms_fields_id, string
$forms_fill_values_value );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление значений заполненной формы (0 - вставка, 1- обновление)

    $forms_fill_values_id

    идентификатор записи, хранящей данные одного из элементов формы

    $forms_fill_id

    идентификатор записи, хранящей данные о заполненной форме

    $forms_fields_id

    идентификатор элемента заполняемой формы

    $forms_fill_values_value

    значение элемента формы

    Возвращает

    идентификатор добавленной/отредактированной записи, хранящей данные о значении, переданном из формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления значений заполненной формы

    [ Top ]

    Forms::SelectForms

SelectForms(
int
$id );

    Принимаемые параметры

    $id

    идентификатор формы, данные о которой необходимо получить, если $id = -1, то получаем данные о всех формах

    Возвращает

    resource в случае успешного выполнения, false в потивном случае

    Описание

    Метод выбора данных о формах

    [ Top ]

    Forms::SelectFormsFields

SelectFormsFields(
int
$field_id );

    Принимаемые параметры

    $field_id

    идентификатор поля формы, данные о котором необходимо получить

    Возвращает

    resource в случае успешного выполнения, false в противном случае

    Описание

    Метод выбора данных о поле формы

    [ Top ]

    Forms::ShowForm

ShowForm(
int
$form_id, string
$xsl_name, [array
$external_propertys = array()], [array
$param = array()] );

    Принимаемые параметры

    $form_id

    идентификатор формы

    $xsl_name

    название XSL-шаблона

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    $param

    массив дополнительных параметров  $param['forms_fields_name'] название поля формы

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод отображения формы

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Forums

Class Forums

[Строка 11]

Размещен: /Forums/Forums.class.php

Описание

Класс модуля "Форумы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int:
     AddEditMessage()

    Метод добавления/редактирования сообщения темы

  • int:
     AddEditTheme()

    Метод осуществляет добавление/редактирование темы

  • string BBcode2HTML()

    Метод замены BBcode на HTML

  • boolean CloseForum()

    Метод, закрывающий/открывающий форум

  • boolean CloseTheme()

    Метод, открыввающий/закрывающий тему для доступа

  • boolean DeleteConference()

    Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.

  • boolean DeleteForum()

    Метод удаления форума

  • boolean DelForumsGroup()

    Метод удаления группы форумов

  • boolean DelMessage()

    Метод удаления сообщения темы

  • boolean DelTheme()

    Метод удаления темы форума

  • boolean GenAddEditThemeXML()

    УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean GenEditMessageXML()

    УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

  • void GenForumsXML()

    Устаревший метод

  • boolean GenMessageXML()

    Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном

  • string GenSmilesXML()

    Метод возвращает XML для смайликов

  • boolean GenThemesXML()

    Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном

  • boolean GenUserInfoXML()

    УСТАРЕВШИЙ  Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном

  • resource GetAllConferences()

    Метод получения информации о всех конференциях сайт.

  • resource GetAllForums()

    Метод для получения всех форумов

  • resource GetAllForumsGroup()

    Метод для получения списка всех групп

  • array GetAllMessages()

    Метод для получения всех сообщений

  • array GetConference()

    Метод для получения информации о конференции.

  • mixed GetConferencePath()

    Метод возвращает путь к конференции по ее идентификатору

  • mixed GetForum()

    Метод получения информации о форуме

  • array GetForumAccess()

    Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму

  • array GetForumAndItemIdFromPath()

    Метод получения данных об идентификаторе форума и темы по переданному массиву с элементами пути

  • mixed GetForumsGroup()

    Метод возвращает информацию о группе форумов

  • mixed GetTheme()

    Метод возвращает информацию о теме форума

  • boolean IncCountMessage()

    Метод наращивания счётчика количества сообщений для пользователя

  • array IndexationForums()

    Метод индексации форумов

  • array IndexationForumsMessages()

    Метод индексации сообщений тем форумов

  • int_or_false InsertConference()

    Метод, осуществляющий вставку информации о конференции.

  • boolean InsertForum()

    Метод добавления/редактирования форума.

  • boolean InsertForumsGroup()

    Метод добавления/редактирования группы форумов

  • mixed InsertTheme()

    Метод для вставки информации о теме

  • boolean InsertUsersGroup()

    Метод добавления/редактирования группы пользователей для определения доступа к форуму

  • boolean NoticeTheme()

    Метод делающий тему объявлением или наоборот

  • boolean OrderForums()

    Метод изменения порядка сортировки форумов в группе

  • boolean OrderForumsGroup()

    Метод изменения порядка сортировки групп форумов

  • mixed:
     SelectForum()

    Устаревший метод, возвращающий информацию о форуме

  • mixed:
     SelectForumsGroup()

    Устарвший метод, возвращающий информацию о группе форумов

  • mixed:
     SelectMessage()

    Метод возвращающий информацию о сообщении

  • mixed:
     SelectTheme()

    Устаревший метод, возвращающий информацию о теме

  • boolean SetModerator()

    Метод установления/снятия прав модератора текущего форума для группы пользователей

  • boolean ShowAddEditTheme()

    Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean ShowConference()

    Метод отображения конференции

  • boolean ShowEditMessage()

    Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

  • unknown ShowMessage()

    Метод отображения сообщений форума

  • boolean ShowSiteUserInfo()

    Отображение данных о пользователе форума

  • void ShowThemes()

    Метод отображения тем форума

  • string Smile2HTML()

    Метод замены смайликов на HTML

  • bool UserIsModerator()

    Метод для определения, является ли данный пользователь модератором

  • boolean VisibleTheme()

    Метод, устанавливающий видимость/невидимость темы

Унаследованные методы

Описания методов

    Forums::AddEditMessage

AddEditMessage(
int
$conference_id, int
$forums_id, int
$forums_theme_id, string
$forums_theme_title, string
$forums_message_text, int
$site_users_id, int
$current_time, int
$forums_message_id, [array
$param = array()] );

    Принимаемые параметры

    $conference_id

    идентификатор конференции

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_theme_title

    тема сообщения

    $forums_message_text

    текст сообщения

    $site_users_id

    идентификатор пользователя

    $current_time

    текущее время в Unix формате

    $forums_message_id

    идентификатор сообщения

    $param

    массив дополнительных параметров:
      string $param['xsl_name_add_user'] название XSL шаблона письма пользователю при добавлении  string $param['xsl_name_add_curator'] название XSL шаблона письма куратору при добавлении  string $param['xsl_name_edit_user'] название XSL шаблона письма пользователю при изменении  string $param['xsl_name_edit_curator'] название XSL шаблона письма куратору при изменении  string $param['content_type_add_user'] тип контекнта письма для пользователя при добавлении  string $param['content_type_add_curator'] тип контекнта письма для куратора при добавлении  string $param['content_type_edit_user'] тип контекнта письма для пользователя при изменении  string $param['content_type_edit_curator'] тип контекнта письма для куратора при изменении

    Возвращает

    -2 - неверное значение CAPTCHA,
      -1 - сработала защита от флуда,

    1. - ошибка выполнения запроса,
    2. - операция выполнена успешно

    Описание

    Метод добавления/редактирования сообщения темы

    [ Top ]

    Forums::AddEditTheme

AddEditTheme(
mixed
$conference_id, int
$forums_id, int
$theme_id, string
$theme_title, int
$theme_close, int
$theme_notice, int
$theme_visible, string
$first_message, int
$site_users_id, int
$current_time, [array
$param = array()] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $theme_title

    заголовок темы

    $theme_close

    флаг открытости (0 - закрыта, 1 - открыта)

    $theme_notice

    флаг объявления (1 - объявление)

    $theme_visible

    флаг видимости (0 - невидима, 1 - видима)

    $first_message

    текст первого сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_time

    текущее время в Unix формате

    $param

    массив дополнительных параметров:
      $param['xslname'] string имя xsl шаблона письма куратору форума

    Возвращает

    -2 -- сработала защита от флуда,
      -1 -- неверное значение CAPTCHA,

    1. -- не найден форум или конференция
    2. -- операция выполнена успешно

    Описание

    Метод осуществляет добавление/редактирование темы

    [ Top ]

    Forums::BBcode2HTML

BBcode2HTML(
string
$text );

    Принимаемые параметры

    $text

    исходный текст

    Возвращает

    текст после замены

    Описание

    Метод замены BBcode на HTML

    [ Top ]

    Forums::CloseForum

CloseForum(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Описание

    Метод, закрывающий/открывающий форум

    [ Top ]

    Forums::CloseTheme

CloseTheme(
int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод, открыввающий/закрывающий тему для доступа

    [ Top ]

    Forums::DeleteConference

DeleteConference(
int
$forums_conference_id );

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    Возвращает

    результат выполнения запроса

    Описание

    Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.

    [ Top ]

    Forums::DeleteForum

DeleteForum(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Описание

    Метод удаления форума

    [ Top ]

    Forums::DelForumsGroup

DelForumsGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы форумов

    Возвращает

    результат выполнения запроса

    Описание

    Метод удаления группы форумов

    [ Top ]

    Forums::DelMessage

DelMessage(
int
$forums_id, int
$forums_theme_id, int
$forums_message_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы форума

    $forums_message_id

    идентификатор сообщения темы

    $site_users_id

    идентификатор пользователя сайта, если false - определяется автоматически. По умолчанию false

    Описание

    Метод удаления сообщения темы

    [ Top ]

    Forums::DelTheme

DelTheme(
mixed
$conference_id, int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод удаления темы форума

    [ Top ]

    Forums::GenAddEditThemeXML

GenAddEditThemeXML(
int
$forums_id, int
$theme_id, int
$site_users_id, int
$current_page, stringe
$xslname, [string
$error = ''], [array
$param = array()], [mixed
$conference_id = 0] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    индекс текущей страницы

    $xslname

    имя xsl шаблона

    $error

    текст сообщения об ошибке

    $param

    массив параметров темы:
      $param['theme_close'] int флаг закрытости темы;
      $param['theme_notice'] int флаг объявления;
      $param['theme_visible'] int флаг видимости;
      $param['theme_title'] string заголовок темы;
      $param['theme_message_text'] string текст первого сообщения;
      $param['theme_send_letter'] string отправлять письма с ответами на тему

    Описание

    УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenEditMessageXML

GenEditMessageXML(
int
$forums_id, int
$forums_theme_id, int
$forums_message_id, int
$site_users_id, int
$current_page_theme, int
$current_page_message, string
$xslname, [mixed
$error = ''], [array
$param = array()], string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_message_id

    идентификатор сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    $param

    массив параметров сообщения:
      $param['message_theme'] string тема собщения;
      $param['message_текст'] string текст сообщения

    Описание

    УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenForumsXML

GenForumsXML(
int
$site_users_id, string
$xslname, [mixed
$error = ''], [mixed
$conference_id = 0], string
$error='' );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    имя xsl шаблона

    $error=''

    текст ошибки доступа

    Описание

    Устаревший метод

    [ Top ]

    Forums::GenMessageXML

GenMessageXML(
int
$forums_id, int
$forums_theme_id, int
$site_users_id, int
$current_page_theme, int
$current_page_message, int
$items_on_page, string
$xslname, [string
$error = ''], [array
$param = array()] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $items_on_page

    количество элементов на странице

    $xslname

    имя xsl шаблона

    $error

    текст сообщения об ошибке

    $param

    массив дополнительных параметров

    Описание

    Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenSmilesXML

GenSmilesXML(
 );

    Возвращает

    XML

    Описание

    Метод возвращает XML для смайликов

    [ Top ]

    Forums::GenThemesXML

GenThemesXML(
int
$forums_id, int
$site_users_id, int
$current_page, int
$items_on_page, string
$xslname, [mixed
$error = ''], string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    индекс текущей страницы

    $items_on_page

    количество записей на странице

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    Описание

    Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenUserInfoXML

GenUserInfoXML(
int
$forums_id, int
$theme_id, int
$site_users_id, string
$xslname, [mixed
$current_page_theme = 0], [mixed
$current_page_message = 0], [mixed
$error = ''], int
$current_page_theme=0, int
$current_page_message=0, string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    имя xsl шаблона

    $current_page_theme=0

    индекс текущей страницы тем

    $current_page_message=0

    индекс текущей страницы сообщений

    $error=''

    текст сообщения об ошибке

    Описание

    УСТАРЕВШИЙ  Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GetAllConferences

GetAllConferences(
[int
$site_id = false] );

    Принимаемые параметры

    $site_id

    - идентификатор сайта, если false, то метод вернёт информацию обо всех конференциях всех сайтов.

    Возвращает

    Информация о конференциях.

    Описание

    Метод получения информации о всех конференциях сайт.

    [ Top ]

    Forums::GetAllForums

GetAllForums(
[int
$forums_group_id = false] );

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов, если false - получаем форумы всех групп

    Возвращает

    результат выборки

    Описание

    Метод для получения всех форумов

    [ Top ]

    Forums::GetAllForumsGroup

GetAllForumsGroup(
[int
$forums_conference_id = false] );

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции, если false - метод возвращает список всех конференций

    Возвращает

    результат выборки

    Описание

    Метод для получения списка всех групп

    [ Top ]

    Forums::GetAllMessages

GetAllMessages(
[int
$forums_theme_id = false] );

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы, если false - получаем сообщения всех тем

    Возвращает

    с результатом выборки или false

    Описание

    Метод для получения всех сообщений

    [ Top ]

    Forums::GetConference

GetConference(
int
$forums_conference_id );

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции.

    Возвращает

    возвращает ассоциативный массив с информацией о конференции.

    Описание

    Метод для получения информации о конференции.

    [ Top ]

    Forums::GetConferencePath

GetConferencePath(
int
$forums_conference_id );

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    Возвращает

    путь к конференции или false, если конференция не найдена

    Описание

    Метод возвращает путь к конференции по ее идентификатору

    [ Top ]

    Forums::GetForum

GetForum(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Возвращает

    массив с данными о форуме или ложь, если форум не найден

    Описание

    Метод получения информации о форуме

    [ Top ]

    Forums::GetForumAccess

GetForumAccess(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Возвращает

    массив идентификаторов групп пользователей сайта

    Описание

    Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму

    [ Top ]

    Forums::GetForumAndItemIdFromPath

GetForumAndItemIdFromPath(
int
$forums_conference_id, [array
$path_array = array()] );

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    $path_array

    массив с элементами пути, если не пердан, используется $GLOBALS['URL_ARRAY']

    Возвращает

    $result['forum'] - идентификатор форума или false
    $result['theme'] - идентификатор темы или false

    Описание

    Метод получения данных об идентификаторе форума и темы по переданному массиву с элементами пути

    [ Top ]

    Forums::GetForumsGroup

GetForumsGroup(
int
$forums_group_id );

    Принимаемые параметры

    $forums_group_id

    Возвращает

    ассоциативный массив с ифнормацией о группе форумов или false, если группа с указанным идентификатором отсутствует

    Описание

    Метод возвращает информацию о группе форумов

    [ Top ]

    Forums::GetTheme

GetTheme(
int
$forums_theme_id );

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы

    Возвращает

    ассоциативный массив с данными или ложь, если тема не найдена

    Описание

    Метод возвращает информацию о теме форума

    [ Top ]

    Forums::IncCountMessage

IncCountMessage(
int
$site_users_id );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод наращивания счётчика количества сообщений для пользователя

    [ Top ]

    Forums::IndexationForums

IndexationForums(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Принимаемые параметры

    $limit

    сколько записей проиндексировано

    $on_step

    сколько индексировать

    $parameters

    массив дополнительных параметров

    Возвращает

    массив данных для индексации:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string текст страницы;
      $result[$i][3] float размер страницы;
      $result[$i][4] int идентификатор сайта (0 - для всех сайтов);
      $result[$i][5] array массив идентификаторов групп пользователей (0 - для всех)  $result[$i][6] string дата создания страницы

    Описание

    Метод индексации форумов

    [ Top ]

    Forums::IndexationForumsMessages

IndexationForumsMessages(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Принимаемые параметры

    $limit

    сколько записей проиндексировано

    $on_step

    сколько индексировать

    $parameters

    массив дополнительных параметров

    Возвращает

    массив данных для индексации:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string текст страницы;
      $result[$i][3] float размер страницы;
      $result[$i][4] int идентификатор сайта (0 - для всех сайтов);
      $result[$i][5] array массив идентификаторов групп пользователей (0 - для всех)  $result[$i][6] string дата создания страницы

    Описание

    Метод индексации сообщений тем форумов

    [ Top ]

    Forums::InsertConference

InsertConference(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     string $param['forums_conference_name'] название конференции
     string $param['forums_conference_description'] описание конференции
     int $param['structure_id'] узел структуры
     int $param['forums_conference_on_page_theme'] максимальное количество тем, которое может отображаться на странице
     int $param['forums_conference_on_page_message'] максимальное количество сообщений, которое может отображаться на странице
     int $param['forums_conference_flude_protection'] время задержки для защиты от флуда
     int $param['forums_conference_edit_time'] время, в течение которого можно редактировать свои сообщений
     int $param['forums_conference_del_time'] время, в течение которого можно удалять свои сообщений

    Возвращает

    идентификатор вставленной конференции ( false при неудачной вставке)

    Описание

    Метод, осуществляющий вставку информации о конференции.

    [ Top ]

    Forums::InsertForum

InsertForum(
array
$param );

    Принимаемые параметры

    $param

    массив параметров
     int $param['forums_id'] идентификатор форума
     int $param['forums_group_id'] идентификатор группы форумов
     string $param['forums_name'] название форума
     string $param['forums_description'] описание форума
     string $param['forums_curator_email'] E-mail куратора форума
     int $param['forums_postmoderation'] использовать ли постмодерацию (0 - нет, 1 - да)
     int $param['visible4all'] отображать ли содержимое форума всем посетителям (0 - нет, 1 - да)
     int $param['forums_captcha_used'] использовать ли CAPTCHA (0 - нет, 1 - да)
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Описание

    Метод добавления/редактирования форума.

    [ Top ]

    Forums::InsertForumsGroup

InsertForumsGroup(
int
$forums_group_id, string
$forums_group_name, string
$forums_group_comment, int
$forums_conference_id, [int
$users_id = false] );

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $forums_group_name

    название группы форумов

    $forums_group_comment

    коментарий к группе форумов

    $forums_conference_id

    идентификатор конференции.

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной записи

    Описание

    Метод добавления/редактирования группы форумов

    [ Top ]

    Forums::InsertTheme

InsertTheme(
array
$param );

    Принимаемые параметры

    $param

    дополнительные праметры
     int $param['forums_theme_id'] идентификатор темы форума
     int $param['forums_id'] идентификатор форума
     int $param['forums_theme_visible'] тема видима
     int $param['forums_theme_notice'] тема является объявлением
     int $param['forums_theme_close'] тема закрыта
     int $param['forums_theme_send_letter'] оповещать создателя темы о новых сообщениях
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    результат вставки

    Описание

    Метод для вставки информации о теме

    [ Top ]

    Forums::InsertUsersGroup

InsertUsersGroup(
int
$forums_id, int
$site_users_group_id, int
$moderator );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_group_id

    идентификатор группы пользователей

    $moderator

    является ли эта группа модераторами (0 - нет, 1 - да)

    Описание

    Метод добавления/редактирования группы пользователей для определения доступа к форуму

    [ Top ]

    Forums::NoticeTheme

NoticeTheme(
int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    Описание

    Метод делающий тему объявлением или наоборот

    [ Top ]

    Forums::OrderForums

OrderForums(
int
$forums_group_id, array
$mas_orders );

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $mas_orders

    массив коэффициентов вида $mas_orders['order<идентификатор форума>']

    Описание

    Метод изменения порядка сортировки форумов в группе

    [ Top ]

    Forums::OrderForumsGroup

OrderForumsGroup(
array
$mas_orders );

    Принимаемые параметры

    $mas_orders

    массив коэффициентов вида $mas_orders['order<идентификатор группы форумов>']

    Описание

    Метод изменения порядка сортировки групп форумов

    [ Top ]

    Forums::SelectForum

SelectForum(
int
$id );

    Принимаемые параметры

    $id

    идентификатор форума (-1 выбрать все)

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Устаревший метод, возвращающий информацию о форуме

    [ Top ]

    Forums::SelectForumsGroup

SelectForumsGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы форумов (-1 выбрать все)

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Устарвший метод, возвращающий информацию о группе форумов

    [ Top ]

    Forums::SelectMessage

SelectMessage(
int
$id );

    Принимаемые параметры

    $id

    идентификатор сообщения

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Метод возвращающий информацию о сообщении

    [ Top ]

    Forums::SelectTheme

SelectTheme(
int
$id );

    Принимаемые параметры

    $id

    идентификатор темы

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Устаревший метод, возвращающий информацию о теме

    [ Top ]

    Forums::SetModerator

SetModerator(
int
$forums_users_group_list_id );

    Принимаемые параметры

    $forums_users_group_list_id

    идентификатор в таблице связи форумов и групп пользователей

    Описание

    Метод установления/снятия прав модератора текущего форума для группы пользователей

    [ Top ]

    Forums::ShowAddEditTheme

ShowAddEditTheme(
mixed
$conference_id, int
$forums_id, int
$theme_id, stringe
$xslname, [mixed
$external_propertys = array()], [array
$param = array()], int
$site_users_id, int
$current_page );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    $xslname

    имя xsl шаблона

    $param

    массив параметров темы:
      $param['theme_close'] int флаг закрытости темы;
      $param['theme_notice'] int флаг объявления;
      $param['theme_visible'] int флаг видимости;
      $param['theme_title'] string заголовок темы;
      $param['theme_message_text'] string текст первого сообщения;
      $param['theme_send_letter'] string отправлять письма с ответами на тему;
      $param['site_users_id'] идентификатор пользователя сайта, если не передан - определяется автоматически

    Возвращает

    int индекс текущей страницы

    Описание

    Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::ShowConference

ShowConference(
int
$conference_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Принимаемые параметры

    $conference_id

    идентификатор конференции

    $xslname

    имя XSL-шаблона для отображения

    $external_propertys

    массив внешних параметров, передающихся в XML

    $param

    массив дополнительных параметров
    $param['site_users_id'] - идентификатор пользователя сайта, если не передан - определяется автоматически

    Возвращает

    -1 -- Конференция с указанным кодом не найдена

    Описание

    Метод отображения конференции

    [ Top ]

    Forums::ShowEditMessage

ShowEditMessage(
mixed
$conference_id, int
$forums_id, int
$forums_theme_id, int
$forums_message_id, string
$xslname, [mixed
$external_propertys = array()], [array
$param = array()], int
$site_users_id, int
$current_page_theme, int
$current_page_message, string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_message_id

    идентификатор сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    $param

    массив параметров сообщения:
      $param['message_theme'] string тема собщения;
      $param['message_текст'] string текст сообщения

    Описание

    Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::ShowMessage

ShowMessage(
int
$forums_conference_id, int
$forums_id, int
$forums_theme_id, str
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $xslname

    наименование XSL-шаблона

    $external_propertys

    массив внешних параметров, передающихся в XML

    $param

    массив дополнительных параметров
    $param['site_users_id'] - Идентификатор пользователя сайта, если не переда -- определяется автоматически
    $param['current_page_theme'] - Номер текущей страницы тем
    $param['current_page_message'] - Номер текущей страницы сообщений
    $param['items_on_page'] - Число сообщений на страницу, если не передан, то определяется автоматически
    $param['message_theme'] - Тема сообщения
    $param['message_text'] - Текст сообщения

    Описание

    Метод отображения сообщений форума

    [ Top ]

    Forums::ShowSiteUserInfo

ShowSiteUserInfo(
int
$conference_id, int
$forums_id, int
$theme_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Принимаемые параметры

    $conference_id

    идентификатор конференции

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $xslname

    имя xsl шаблона

    $external_propertys

    массив внешних данных, передаваемых в XML
    $external_propertys['current_page_message'] - идентификатор текущего сообщения
    $external_propertys['error'] - сообщение об ошибке

    $param

    массив дополнительных параметров  $param['site_users_id'] - идентификатор пользователя сайта, если не передан - определяется автоматически

    Описание

    Отображение данных о пользователе форума

    [ Top ]

    Forums::ShowThemes

ShowThemes(
int
$conference_id, int
$forums_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Принимаемые параметры

    $conference_id

    идентификатор концеренции

    $forums_id

    идентификатор форума

    $xslname

    имя XSL-шаблона для отображения тем форума

    $external_propertys

    массив внешних параметров, передающихся в XML

    $param

    массив дополнительных параметров
    $param['site_users_id'] - идентификатор пользоватлея сайта, если не передан - определяется автоматически
    $param['current_page_theme'] - номер текущей страницы, по умолчанию 0
    $param['items_on_page'] - число тем на страницу, по умолчанию 10

    Описание

    Метод отображения тем форума

    [ Top ]

    Forums::Smile2HTML

Smile2HTML(
string
$text );

    Принимаемые параметры

    $text

    исходный текст

    Возвращает

    текст после замены

    Описание

    Метод замены смайликов на HTML

    [ Top ]

    Forums::UserIsModerator

UserIsModerator(
int
$forums_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод для определения, является ли данный пользователь модератором

    [ Top ]

    Forums::VisibleTheme

VisibleTheme(
int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта, необзяталеьный параметр. по умолчанию равен false - определять автоматически.

    Описание

    Метод, устанавливающий видимость/невидимость темы

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class graphic

Class graphic

[Строка 2]

Размещен: /Counter/Graphic.class.php

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void Diagramm()

    Метод рисования круговой диаграммы

  • void graphic_diagramma()

    Метод вывода круговой диаграммы

  • boolean graphic_gistogramma()

    Метод вывода гистограммы

  • void imagebar()

    Метод вывода гистограммы

  • string win2uni()

    Метод перекодировки из win в unicode

Унаследованные методы

Описания методов

    graphic::Diagramm

Diagramm(
int
$im, array
$VALUES, array
$LEGEND, array
$COLORS, array
$SHADOWS );

    Принимаемые параметры

    $im

    идентификатор изображения

    $VALUES

    массив со значениями

    $LEGEND

    массив с подписями

    $COLORS

    массив цветов для диаграммы

    $SHADOWS

    массив цветов теней

    Описание

    Метод рисования круговой диаграммы

    [ Top ]

    graphic::graphic_diagramma

graphic_diagramma(
array
$VALUES, array
$LEGEND, int
$width );

    Принимаемые параметры

    $VALUES

    значения (массив со значениями)

    $LEGEND

    подписи (значения легенды, массив строк)

    $width

    - ширина изображения в пикселях

    Описание

    Метод вывода круговой диаграммы

    [ Top ]

    graphic::graphic_gistogramma

graphic_gistogramma(
int_type
$width, int
$height, array
$DATA, [array
$LEGEND = array('Хиты','Сессии','Хосты')] );

    Принимаемые параметры

    $width

    ширина гистограммы в пикселях

    $height

    высота гистограммы в пикселях

    $DATA

    массив со значенями для гистограммы

    $LEGEND

    массив подписей для легенды

    Возвращает

    истина при удачном выводе, ложь - в случае возникновения ошибки

    Описание

    Метод вывода гистограммы

    [ Top ]

    graphic::imagebar

imagebar(
int
$im, int
$x, int
$y, int
$w, int
$h, int
$dx, int
$dy, string
$c1, string
$c2, string
$c3 );

    Принимаемые параметры

    $im

    идентификатор изображения

    $x

    координата x верхнего левого угла куба

    $y

    координата y верхнего левого угла куба

    $w

    ширина куба

    $h

    высота куба

    $dx

    смещение задней грани куба по оси X

    $dy

    смещение задней грани куба по оси Y

    $c1

    цвет видимой граней куба

    $c2

    цвет видимой граней куба

    $c3

    цвет видимой граней куба

    Описание

    Метод вывода гистограммы

    [ Top ]

    graphic::win2uni

win2uni(
string
$winline );

    Принимаемые параметры

    $winline

    строка в win

    Возвращает

    перекодированная строка

    Описание

    Метод перекодировки из win в unicode

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Image

Class Image

[Строка 11]

Размещен: /Kernel/Image.class.php

Описание

Ядро, класс для работы с графическими изображениями

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • bool CopyImgWithWatermark()

    Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя

  • void CreateWatermark()

  • array GetImageSize()

    Метод определяет высоту и ширину изображения

  • boolean resizeToFile()

    Метод изменения размера изображения

Унаследованные методы

Описания методов

    Image::CopyImgWithWatermark

CopyImgWithWatermark(
string
$source, string
$targetfile, string
$watermark, [string
$watermark_x = false], [string
$watermark_y = false] );

    Принимаемые параметры

    $source

    путь к файлу источнику

    $targetfile

    путь к файлу получателю

    $watermark

    путь к файлу watermark-а (в формате PNG)

    $watermark_x

    позиция по оси X (в пикселях или процентах)

    $watermark_y

    позиция по оси Y (в пикселях или процентах)

    Возвращает

    результат работы ф-ции.

    Описание

    Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя

    [ Top ]

    Image::CreateWatermark

CreateWatermark(
mixed
$main_img_obj, mixed
$watermark_img_obj, [mixed
$watermark_x = false], [mixed
$watermark_y = false] );

    [ Top ]

    Image::GetImageSize

GetImageSize(
string
$path );

    Принимаемые параметры

    $path

    полный путь к изображению

    Возвращает

    ассоциативный массив, содержащий высоту и ширину изображения
    array['width'] - ширина
    array['['height'] - высота  или false, если файл не существует

    Описание

    Метод определяет высоту и ширину изображения

    [ Top ]

    Image::resizeToFile

resizeToFile(
string
$sourcefile, int
$maxsize, string
$targetfile, int
$jpegqual );

    Принимаемые параметры

    $sourcefile

    путь к исходному файлу

    $maxsize

    максимальный размер в одном из измерений

    $targetfile

    путь для размещения преобразованного файла

    $jpegqual

    качество JPG

    Описание

    Метод изменения размера изображения

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class InformationSystem

Class InformationSystem

[Строка 20]

Размещен: /InformationSystems/InformationSystems.class.php

Описание

Класс модуля "Информационные системы"

Свойства класса

  • $a_count_property = array()

        Кэш количества свойств

  • $cache_InformationSystem = array()

        Кэш данных о информационной системе  пример $this->cache_InformationSystem[$id]

  • $CommentMass = array()

        Кэш с данными о комментариях

  • $GroupMass = array()

        Кэш с данными о группах

  • $ItemMass = array()

        Кэш с данными об элементах

  • $MasGroup = array()

        Массив групп

  • $PropertyGroupMass = array()

        Кэш с данными о дополнительных свойствах информационных групп

  • $PropertyMass = array()

        Кэш с данными о свойствах инфоррмационных элементов

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int confirm_information_item()

    Метод определения возможности пользователя добавлять информационный элемент

  • void CopyInformationItem()

    Метод копирования элемента информационной системы

  • string CreateGroupsXmlTree()

    Метод формирования XML дерева для информационных групп

  • boolean DelInformationGroupPropertys()

    Метод удаления дополнительного свойства информационной группы

  • boolean DelInformationGroupPropertysValue()

    Метод удаления значений дополнительных свойств информационной группы

  • resource DelInformationSystem()

    Метод удаления информационной системы

  • boolean del_comment()

    Метод удаления комментария к информационному элементу

  • boolean del_information_groups()

    Метод удаления информационных групп

  • boolean del_information_items()

    Метод удаления элемента информационной системы

  • boolean del_information_propertys()

    Метод удаления дополнительного свойства информационной системы

  • void FillMasGroup()

    Метод формирования массива групп для информационной системы.

  • void FillMemCacheCountItemsAndGroup()

    Метод производит расчет числа подгрупп и элементов, содержащихся в группах информационной системы.

  • void FillMemCacheGoupsIdTree()

    Метод формирует дерево групп и подгрупп в массиве по их идентификаторам

  • string GenGroupXmlTree()

    Метод формирования  полного XML дерева информационных групп для информационной системы

  • boolean GetAccessItem()

    Метод определения доступности информационного элемента

  • mixed GetAllInformationSystems()

    Метод возвращает список инфосистем

  • mixed GetCommentInformationSystemItem()

    Метод получения комментариев информационных элементов

  • int GetCountInformationSystemItem()

    Метод получения количества элементов информационной системы

  • array GetCountItemsAndGroups()

    Метод получения числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()

  • int GetCountProperty4InformationSystem()

    Метод получения числа свойств информационной системы

  • string GetExpansion()

    Метод получения расширения файла

  • $result GetExternalInformationSystemItem()

    Метод получения элементов информационной системы. Переименован с GetInformationSystemItem

  • array GetGroupsInformationSystem()

    Метод формирования дерева групп информационной группы

  • int GetIdInformationItem()

    Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы

  • mixed GetInformationFromPath()

    Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI

  • mixed GetInformationGroup()

    Получение информации о группе. Использует кэш "INF_SYS_GROUP"

  • mixed GetInformationGroupName()

    Метод получения имени информационной группы

  • mixed GetInformationSystem()

    Метод получения данных об информационной системе

  • int GetInformationSystemGroupAccess()

    Метод определения уровня доступности информационной группы

  • mixed GetInformationSystemItem()

    Метод для получения данных об информационном элементе

  • int GetInformationSystemItemAccess()

    Метод определения уровня доступности информационного элемента

  • mixed GetInformationSystemItems()

    Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит

  • array GetMasGroup()

    Метод получения массива информационных групп

  • string GetPathGroup()

    Метод формирования пути по информационным группам

  • string GetPathItem()

    Метод формирования пути к данному информационному элементу

  • int GetPropertyCountRow()

    Метод получения числа записей в выборке инфосистем, групп или информационных элементов

  • $this->error GetPropertyError()

    Метод возвращающий код ошибки, возникающей при работе с методами класса

  • array GetPropertyMasInformationGroups()

    Метод получения массива свойств информацуонных групп

  • int GetPropertyRecordOnPage()

    Метод получения числа записей, выводимых на страницу

  • string GetPropertySectionPath()

    Метод получения значения свойтва, содержащего пути по группам

  • array GetPropertysGroup()

    Метод получения данных о дополнительных свойствах информационной группы

  • mixed GetPropertysInformationSystemItem()

    Метод получения свойств информационных элементов

  • string GetXmlForInformatioItem()

    Метод формирования XML для отображения информационного элемента

  • void get_information_groups_path()

    Метод формирования пути по дереву информационных групп.

  • $this->mas_information_groups_for_xml get_mas_information_groups_for_xml()

    Метод возвращает XML для информационных групп

  • boolean InformationSystemItemAccess()

    Метод определения доступности информационного элемента для пользователя

  • int InsertInformationGroups()

    Метод вставки/обновления данных об информационной группе

  • int InsertInformationItems()

    Метод вставки/обновления данных об информационном элементе

  • int InsertInformationPropertys()

    Метод вставки/обновления информации о свойстве информационной системы

  • int InsertInformationPropertysGroups()

    Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы

  • int InsertInformationPropertysGroupsValue()

    Метод вставки/обновления значения свойства информационной группы

  • int InsertInformationPropertysItems()

    Метод вставки/обновления значения свойства информационной

  • int InsertInfotmationSystem()

    Метод вставки/обновления данных об информационной системе

  • int insert_comment()

    Метод вставки/обновления комментария для элемента информационной системы

  • int insert_comment_without_striptags()

    Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах

  • bool IssetAccessForInformationSystemGroup()

    Метод проверяет возможность доступа пользователя указанной группы к группе информационной системы

  • boolean IssetGroup()

    Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе

  • boolean IssetGroupItemInsertUpdate()

    Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента

  • boolean IssetItem()

    Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы

  • boolean IssetItemGroupInsertUpdate()

    Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы

  • resource SelectInformationGroupPropertys()

    Метод получения данных о свойствах группы информационной системы

  • resource SelectInformationGroups()

    Метод получения информации об информационных группах конкретной информационной системы

  • resource SelectInformationSystem()

    Метод получения информации об информационной системе

  • resource SelectListInformationGroupPropertys()

    Метод получения списка дополнительных свойств информационноq группы данной инфосистемы

  • resource select_comments()

    Метод получения комментариев к информационному элементу

  • resource select_information_items()

    Метод получения данных об информационном элементе

  • resource select_information_propertys()

    Метод получения данных о свойствах информационной системы

  • boollean ShowAddComment()

    Метод добавления комментария к элементу информационной системы

  • array ShowInformationSystem()

    Метод отображения групп и элементов информационной системы

  • boolean ShowInformationSystemItem()

    Метод отображения информацию об информационном элементе

  • void ShowInformationSystemPageConfig()

    Метод вызова настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы

  • void ShowInformationSystemPageContent()

    Метод вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы

  • void ShowInformationSystemRss()

    Метод отображения RSS ленты

  • boolean UserCanAddComment()

    Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY

Унаследованные методы

Описания методов

    InformationSystem::confirm_information_item

confirm_information_item(
string
$date, string
$information_item_ip );

    Принимаемые параметры

    $date

    дата и время (в Unix-формате) добавления информационного элемента

    $information_item_ip

    ip-адрес компьютера пользователя, добавляющего информационный элемент

    Возвращает

    0 – пользователь не может добавлять информационный элемент, 1- может добавлять информационный элемент

    Описание

    Метод определения возможности пользователя добавлять информационный элемент

    [ Top ]

    InformationSystem::CopyInformationItem

CopyInformationItem(
int
$information_item_id );

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента, который необходимо скопировать

    Описание

    Метод копирования элемента информационной системы

    [ Top ]

    InformationSystem::CreateGroupsXmlTree

CreateGroupsXmlTree(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$xmlData, int
$items_on_page, int
$items_begin );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор информационной группы, подгруппы которой будут включены для построения XML дерева

    $InformationSystem_id

    идентификатор информационной системы, для групп которой будет строиться XML дерево

    $xmlData

    XML с данными об информационной системе

    $items_on_page

    параметр, указывающий сколько элементов информационной системы будет отображаться на странице

    $items_begin

    параметр, указывающий с какого информационного элемента отображать элементы

    Возвращает

    XML дерево с данными об информационной системе и ее группах

    Описание

    Метод формирования XML дерева для информационных групп

    [ Top ]

    InformationSystem::DelInformationGroupPropertys

DelInformationGroupPropertys(
int
$property_id, [$group_id
$group_id = false] );

    Принимаемые параметры

    $property_id

    идентификатор дополнительного свойства информационной группы

    $group_id

    идентификатор группы

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления дополнительного свойства информационной группы

    [ Top ]

    InformationSystem::DelInformationGroupPropertysValue

DelInformationGroupPropertysValue(
int
$property_id, int
$group_id );

    Принимаемые параметры

    $property_id

    идентификатор значения дополнительного свойства информационной группы

    $group_id

    идентификатор информационной группы

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления значений дополнительных свойств информационной группы

    [ Top ]

    InformationSystem::DelInformationSystem

DelInformationSystem(
int
$id );

    Принимаемые параметры

    $id

    идентификатор информационной системы

    Описание

    Метод удаления информационной системы

    [ Top ]

    InformationSystem::del_comment

del_comment(
int
$id );

    Принимаемые параметры

    $id

    идентификатор комментария

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления комментария к информационному элементу

    [ Top ]

    InformationSystem::del_information_groups

del_information_groups(
int
$id, int
$InformationSystem_id );

    Принимаемые параметры

    $id

    идентификатор удаляемой информационной группы

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит информационная группа

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления информационных групп

    [ Top ]

    InformationSystem::del_information_items

del_information_items(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого информационного элемента

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления элемента информационной системы

    [ Top ]

    InformationSystem::del_information_propertys

del_information_propertys(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого свойства информационной системы

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления дополнительного свойства информационной системы

    [ Top ]

    InformationSystem::FillMasGroup

FillMasGroup(
[int
$InformationSystem_id = false] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы, для которой заполняем массив групп самого верхнего уровня

    Описание

    Метод формирования массива групп для информационной системы.

    [ Top ]

    InformationSystem::FillMemCacheCountItemsAndGroup

FillMemCacheCountItemsAndGroup(
int
$information_system_id );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    Описание

    Метод производит расчет числа подгрупп и элементов, содержащихся в группах информационной системы.

    Информация сохраняется в массиве:
    для числа групп в группе $this->CacheCountGroupsAndItems[information_system_id][information_groups_id]['GROUPS']
    для числа элементов в группе $this->CacheCountGroupsAndItems[information_system_id][information_groups_id]['ITEMS']

    [ Top ]

    InformationSystem::FillMemCacheGoupsIdTree

FillMemCacheGoupsIdTree(
int
$information_system_id );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    Описание

    Метод формирует дерево групп и подгрупп в массиве по их идентификаторам

    [ Top ]

    InformationSystem::GenGroupXmlTree

GenGroupXmlTree(
int
$information_system_id, [array
$property = array()] );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $property

    массив дополнительных параметров  $property['groups_parent_id'] идентификатор группы, начиная с которой необходимо строить дерево

    Возвращает

    XML дерево групп информационной системы

    Описание

    Метод формирования  полного XML дерева информационных групп для информационной системы

    [ Top ]

    InformationSystem::GetAccessItem

GetAccessItem(
int
$user_id, int
$item_id, [array
$row_item = array()], int
$parent );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $item_id

    идентификатор инфоэлемента

    $parent

    параметр, определяющий наследует ли информационный элемент тип доступа от родителя (1 - наследует, 0 - не наследует)

    $row_item

    ассоциативный массив свойств информационного элемента

    Возвращает

    true - информационный элемент доступен пользователю, false - не доступен пользователю

    Описание

    Метод определения доступности информационного элемента

    [ Top ]

    InformationSystem::GetAllInformationSystems

GetAllInformationSystems(
[int
$site_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта, если false - ограничения по сайтам нет

    Возвращает

    результат выборки

    Описание

    Метод возвращает список инфосистем

    [ Top ]

    InformationSystem::GetCommentInformationSystemItem

GetCommentInformationSystemItem(
int
$items_id );

    Принимаемые параметры

    $items_id

    идентификатор информационного элемента

    Возвращает

    массив со строками - комментариями, false в случае отсутствия комментариев к информационному элементу

    Описание

    Метод получения комментариев информационных элементов

    [ Top ]

    InformationSystem::GetCountInformationSystemItem

GetCountInformationSystemItem(
[mixed
$information_system_id = false], [mixed
$information_group_id = false] );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы, по умолчанию - false

    $information_group_id

    идентификатор группы информационной системы, по умолчанию - false

    Возвращает

    количество элементов информационной системы

    Описание

    Метод получения количества элементов информационной системы

    [ Top ]

    InformationSystem::GetCountItemsAndGroups

GetCountItemsAndGroups(
int
$parent_group_id, int
$information_system_id, [boolean
$sub = true] );

    Принимаемые параметры

    $parent_group_id

    идентификатор группы, для которой необходимо получить число
    элементов и групп.

    $information_system_id

    идентификатор информационной системы, к которой принадлежит группа

    $sub

    параметр, определяющий будут ли учитываться подгруппы данной
    группы при подсчете элементов и групп (true - подгруппы учитываются, false - не учитываются).  По умолчанию $sub = true

    Возвращает

    массив из 4-х элементов
    $mas['count_items'] число элементов в группе без учета элементов в подгруппах
    $mas['count_all_items'] число элементов в группе с учетом элементов в подгруппах
    $mas['count_groups'] число групп в данной группе без учета вложенности подгрупп
    $mas['count_all_groups'] число групп в данной группе с учетом вложенности подгрупп

    Описание

    Метод получения числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()

    [ Top ]

    InformationSystem::GetCountProperty4InformationSystem

GetCountProperty4InformationSystem(
int
$information_system_id );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    Возвращает

    число свойств информационной системы

    Описание

    Метод получения числа свойств информационной системы

    [ Top ]

    InformationSystem::GetExpansion

GetExpansion(
string
$fname );

    Принимаемые параметры

    $fname

    имя файла (путь к файлу)

    Возвращает

    расширение файла

    Описание

    Метод получения расширения файла

    [ Top ]

    InformationSystem::GetExternalInformationSystemItem

GetExternalInformationSystemItem(
[array
$select = array()] );

    Принимаемые параметры

    $select

    array('information_items_name'=>$result['items'][$i]['title'],    'information_blocks_id'=>$infsys_id)

    Описание

    Метод получения элементов информационной системы. Переименован с GetInformationSystemItem

    [ Top ]

    InformationSystem::GetGroupsInformationSystem

GetGroupsInformationSystem(
int
$information_groups_parent_id, int
$InformationSystem_id, [string
$separator = ''], [int
$information_grops_id = false] );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор группы, относительно которой строится дерево групп

    $InformationSystem_id

    идентификатор информационной системы, для которой строится дерево групп

    $separator

    символ, отделяющий группу нижнего уровня от родительской группы

    $information_grops_id

    идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы.

    Возвращает

    двумерный массив, содержащий дерево подгрупп

    Описание

    Метод формирования дерева групп информационной группы

    [ Top ]

    InformationSystem::GetIdInformationItem

GetIdInformationItem(
string
$information_item_url, int
$information_group_id, [int
$information_system_id = 0] );

    Принимаемые параметры

    $information_item_url

    URL информационного элемента

    $information_group_id

    идентификатор информационной группы

    $information_system_id

    идентификатор информационной системы, к которой принадлежит информационный элемент, идентификатор которого надо определить

    Возвращает

    идентификатор информационного элемента

    Описание

    Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы

    [ Top ]

    InformationSystem::GetInformationFromPath

GetInformationFromPath(
int
$InformationSystem_id, [array
$param1 = ''] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит данный информационный элемент

    $param1

    массив, содержащий все элементы URL

    Возвращает

    ассоциативный массив, содержащий идентификатор информационной группы и идентификатор информационного элемента в случае успешного выполнения, false в противном случае

    Описание

    Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI

    [ Top ]

    InformationSystem::GetInformationGroup

GetInformationGroup(
int
$group_id );

    Принимаемые параметры

    $group_id

    идентификатор группы

    Возвращает

    массив с данными о группе или false

    Описание

    Получение информации о группе. Использует кэш "INF_SYS_GROUP"

    [ Top ]

    InformationSystem::GetInformationGroupName

GetInformationGroupName(
int
$information_groups_id );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, имя которой необходимо получить

    Возвращает

    название группы информационной системы. Если группы с таким идентификатором нет, то возвращает false

    Описание

    Метод получения имени информационной группы

    [ Top ]

    InformationSystem::GetInformationSystem

GetInformationSystem(
int
$InformationSystem_id, [boolean
$use_cache = true], [array
$param = array()] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    $use_cache

    параметр, определяющий использовать кэш в памяти или нет (по умолчанию истина)

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с данными об информационной системе или false, если информационная система не найдена

    Описание

    Метод получения данных об информационной системе

    [ Top ]

    InformationSystem::GetInformationSystemGroupAccess

GetInformationSystemGroupAccess(
int
$information_group_id, [int
$information_system_id = 0], [array
$row_group = array()] );

    Принимаемые параметры

    $information_group_id

    идентификатор информационной группы

    $information_system_id

    идентификатор информационной системы

    $row_group

    ассоциативный массив с информацией о группе, по умолчанию пустой

    Возвращает

    уровень (группа) доступа пользователя к информационной группе, 0 - доступ разрешен всем

    Описание

    Метод определения уровня доступности информационной группы

    [ Top ]

    InformationSystem::GetInformationSystemItem

GetInformationSystemItem(
int
$items_id );

    Принимаемые параметры

    $items_id

    идентификатор информационного элемента

    Возвращает

    ассоциативный массив с данными об информационном элементе или ложь, если элемент не найден

    Описание

    Метод для получения данных об информационном элементе

    [ Top ]

    InformationSystem::GetInformationSystemItemAccess

GetInformationSystemItemAccess(
mixed
$item_id, int
$information_group_id, int
$information_system_id );

    Принимаемые параметры

    $information_group_id

    идентификатор информационной группы

    $information_system_id

    идентификатор информационной системы

    Возвращает

    уровень (группа) доступа пользователя к информационной группе, 0 - доступ разрешен всем

    Описание

    Метод определения уровня доступности информационного элемента

    [ Top ]

    InformationSystem::GetInformationSystemItems

GetInformationSystemItems(
int
$information_item_id );

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента

    Возвращает

    ассоциативный массив с именами информационного элемента, информационной группы и системы, к которым он принадлежит, false - в том случае если данный элемент отсутствует

    Описание

    Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит

    [ Top ]

    InformationSystem::GetMasGroup

GetMasGroup(
 );

    Возвращает

    ассоциативный массив с данными об информационных группах

    Описание

    Метод получения массива информационных групп

    [ Top ]

    InformationSystem::GetPathGroup

GetPathGroup(
int
$information_groups_id, string
$path );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, для которой надо сформировать путь

    $path

    параметр, используемый при формировании пути по группам

    Возвращает

    путь по группам от корневой до данной

    Описание

    Метод формирования пути по информационным группам

    [ Top ]

    InformationSystem::GetPathItem

GetPathItem(
int
$information_items_id, string
$path, [array
$row = ''] );

    Принимаемые параметры

    $information_items_id

    идентификатор информационного элемента

    $path

    параметр для хранения пути к данному информационному элементу

    $row

    ассоциативный массив, содержащий информацию об информационном элементе

    Возвращает

    путь к информационному элементу

    Описание

    Метод формирования пути к данному информационному элементу

    [ Top ]

    InformationSystem::GetPropertyCountRow

GetPropertyCountRow(
 );

    Описание

    Метод получения числа записей в выборке инфосистем, групп или информационных элементов

    [ Top ]

    InformationSystem::GetPropertyError

GetPropertyError(
 );

    Описание

    Метод возвращающий код ошибки, возникающей при работе с методами класса

    [ Top ]

    InformationSystem::GetPropertyMasInformationGroups

GetPropertyMasInformationGroups(
 );

    Возвращает

    ассоциативный массив с данными о свойствах информационных групп

    Описание

    Метод получения массива свойств информацуонных групп

    [ Top ]

    InformationSystem::GetPropertyRecordOnPage

GetPropertyRecordOnPage(
 );

    Возвращает

    - число записей на странице

    Описание

    Метод получения числа записей, выводимых на страницу

    [ Top ]

    InformationSystem::GetPropertySectionPath

GetPropertySectionPath(
 );

    Описание

    Метод получения значения свойтва, содержащего пути по группам

    [ Top ]

    InformationSystem::GetPropertysGroup

GetPropertysGroup(
int
$group_id, int
$information_system_id );

    Принимаемые параметры

    $group_id

    идентификатор группы

    $information_system_id

    идентификатор информационной системы

    Возвращает

    массив с информацией о дополнительных свойствах

    Описание

    Метод получения данных о дополнительных свойствах информационной группы

    [ Top ]

    InformationSystem::GetPropertysInformationSystemItem

GetPropertysInformationSystemItem(
int
$items_id, [int
$information_system_id = 0] );

    Принимаемые параметры

    $items_id

    идентификатор информационного элемента

    $information_system_id

    идентификатор информационной системы

    Возвращает

    массив с данными о свойствах информационного элемента или false - в случае отсутствия дополнительных свойств у элементов данной информационной системы

    Описание

    Метод получения свойств информационных элементов

    [ Top ]

    InformationSystem::GetXmlForInformatioItem

GetXmlForInformatioItem(
int
$information_item_id, [array
$property = array('is_get_information_for_property' => false, 'show_text'=>true)] );

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента, который необходимо отобразить

    $property

    массив дополнительных параметров  $property['is_get_information_for_property'] параметр, исключающий рекурсию, возникающую при вызове свойства типа информационная система для элемента, имеющего также свойство типа информационная система (эффект зазеркаливания), по умолчанию false  $property['show_text'] параметр, указывающий включать в XML текст информационного элемента или нет, по умолчанию равен true. Если этот параметр не указан, то текст элемента включается в XML  Замечание: перед вызовом необходимо заполнить массив групп для конкретной информационной системы, например $InformationSystem->FillMasGroup($information_system_id);

    Возвращает

    метод, формирующий XML для отображения информационного элемента

    Описание

    Метод формирования XML для отображения информационного элемента

    [ Top ]

    InformationSystem::get_information_groups_path

get_information_groups_path(
int
$information_groups_id, int
$InformationSystem_id );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, для которой необходимо построить путь

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит группа.

    Описание

    Метод формирования пути по дереву информационных групп.

    [ Top ]

    InformationSystem::get_mas_information_groups_for_xml

get_mas_information_groups_for_xml(
 );

    Описание

    Метод возвращает XML для информационных групп

    [ Top ]

    InformationSystem::InformationSystemItemAccess

InformationSystemItemAccess(
int
$user_id, int
$information_item_id );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $information_item_id

    идентификатор информационного элемента

    Возвращает

    true - элемент доступен, false - элемент недоступен

    Описание

    Метод определения доступности информационного элемента для пользователя

    [ Top ]

    InformationSystem::InsertInformationGroups

InsertInformationGroups(
int
$type, int
$information_groups_id, int
$InformationSystem_id, int
$information_groups_parent_id, string
$information_groups_name, string
$information_groups_description, int
$information_groups_order, string
$information_groups_path, string
$information_groups_image, [int
$information_groups_allow_indexation = 1], [string
$information_groups_seo_title = ''], [string
$information_groups_seo_description = ''], [string
$information_groups_seo_keywords = ''], [int
$information_groups_access = -1], [int
$users_id = false], [$param
$param = array()], $param['information_groups_small_image']
16 );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных об информационной группе (0 – вставка, 1 - обновление)

    $information_groups_id

    идентификатор обновляемой информационной группы (при вставке равен 0)

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит группа

    $information_groups_parent_id

    идентификатор родительской группы данной информационной группы

    $information_groups_name

    название информационной группы

    $information_groups_description

    описание информационной группы

    $information_groups_order

    порядковый номер группы в родительской группе

    $information_groups_path

    элемент URL информационной системы для данной группы

    $information_groups_image

    имя файла с изображением для информационной группы

    $information_groups_allow_indexation

    параметр, определяющий индексировать данную информационную группу или нет (1- индексировать, 0 - неиндексировать)

    $information_groups_seo_title

    параметр, используемый для задания заголовка страницы

    $information_groups_seo_description

    параметр, используемый для задания значения мета-тега description страницы

    $information_groups_seo_keywords

    параметр, используемый для задания значения мета-тега keywords страницы

    $information_groups_access

    параметр, определяющий тип доступа для данной информационной группы (0 - доступна всем, -1 - доступ как у родителя, 6 - доступно пользователю, 7 - недоступно всем, 8 - доступно модераторам)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    16

    имя файла с малым изображением для информационной группы

    $param

    массив параметров

    Возвращает

    идентификатор вставленной/обновленной информационной группы

    Описание

    Метод вставки/обновления данных об информационной группе

    [ Top ]

    InformationSystem::InsertInformationItems

InsertInformationItems(
int
$type, int
$information_items_id, int
$InformationSystem_id, int
$information_groups_id, string
$information_items_date, string
$information_items_name, string
$information_items_description, int
$information_items_status, string
$information_items_text, string
$information_items_image, int
$information_items_order, string
$information_items_ip, [string
$information_items_url = ''], [int
$information_items_allow_indexation = 1], [string
$information_items_seo_title = ''], [string
$information_items_seo_description = ''], [string
$information_items_seo_keywords = ''], [int
$information_items_access = -1], [array
$param = array()], [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление данных об информационном элементе (0 – вставка, 1 обновление)

    $information_items_id

    идентификатор обновляемого информационного элемента (при вставке равен 0)

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит элемент

    $information_groups_id

    идентификатор информационной группы, к которой принадлежит элемент

    $information_items_date

    дата добавления/обновления информационного элемента;

    $information_items_name

    название информационного элемента

    $information_items_description

    описание информационного элемента

    $information_items_status

    параметр, определяющий активность информационного элемента (0 – неактивен, 1 -активен)

    $information_items_text

    текст информационного элемента

    $information_items_image

    название файла изображения для информационного элемента

    $information_items_order

    порядковый номер информационного элемента

    $information_items_ip

    ip-адрес компьтера, с которого был добавлен инфорнмационный элемент

    $information_items_url

    название информационного элемента в URL

    $information_items_allow_indexation

    параметр, определяющий индексировать информационный элемент или нет (0 неиндексировать, 1- индексировать)

    $information_items_seo_title

    параметр, определяющий заголовок страницы при отображении информационного элемента

    $information_items_seo_description

    параметр, определяющий значение мета-тега description страницы, на которой отображается содержимое информационного элемента

    $information_items_seo_keywords

    параметр, определяющий значение мета-тега keywords страницы, на которой отображается содержимое информационного элемента

    $information_items_access

    параметр, определяющий тип доступа для данного информационного элемента (0 доступна всем, -1 доступ как у родителя, 6 доступно пользователю, 7 недоступно всем, 8 доступно модераторам)

    $param

    массив дополнительных параметров  $param['putoff_date'] дата начала публикации, по умолчанию текущее значение даты  $param['putend_date'] дата окончания публикации, по умолчанию отсутствует  $param['information_items_small_image'] название файла малого изображения для информационного элемента

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного/обновленного  элемента информационной системы

    Описание

    Метод вставки/обновления данных об информационном элементе

    [ Top ]

    InformationSystem::InsertInformationPropertys

InsertInformationPropertys(
int
$type, int
$information_propertys_id, int
$InformationSystem_id, string
$information_propertys_name, int
$information_propertys_type, int
$information_propertys_order, string
$information_propertys_define_value, string
$information_propertys_xml_name, int
$information_propertys_lists_id, int
$information_propertys_information_systems_id, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных о свойстве информационной системы (0 вставка, 1 обновление)

    $information_propertys_id

    идентификатор обновляемого свойства (при вставке равен 0);

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит свойство

    $information_propertys_name

    название свойства информационной системы

    $information_propertys_type

    код типа свойства информационной системы (0 число, 1 строка, 2 файл, 3 список, 4 большое текстовое поле, 5 информационная система, 6 визуальный редактор)

    $information_propertys_order

    порядковый номер свойства информационной системы

    $information_propertys_define_value

    значение свойства информационной системы по умолчанию

    $information_propertys_xml_name

    имя XML тэга для данного свойства информационной системы

    $information_propertys_lists_id

    идентификатор списка, который указывается в качестве свойства информационной системы

    $information_propertys_information_systems_id

    идентификатор информационной системы, которая указывается в качестве свойства данной информационной системы

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного/обновленного свойства информационной системы

    Описание

    Метод вставки/обновления информации о свойстве информационной системы

    [ Top ]

    InformationSystem::InsertInformationPropertysGroups

InsertInformationPropertysGroups(
int
$type, int
$information_propertys_groups_id, int
$InformationSystem_id, string
$information_propertys_groups_name, int
$information_propertys_groups_type, int
$information_propertys_groups_order, string
$information_propertys_groups_default_value, string
$information_propertys_groups_xml_name, int
$information_propertys_groups_lists_id, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление информации о дополнительном свойстве информационной группы (0 - вставка, 1 - обновление)

    $information_propertys_groups_id

    идентификатор дополнительного свойства информационной группы (при вставке равен 0)

    $InformationSystem_id

    идентификатор информационной системы

    $information_propertys_groups_name

    название дополнительного свойства информационной группы

    $information_propertys_groups_type

    тип дополнительного свойства информационной группы (0 - число, 1 - строка, 2- файл, 3 - список, 4 - большое текстовое поле, 5 - информационная система, 6 - визуальный редактор)

    $information_propertys_groups_order

    порядковый номер информационной группы

    $information_propertys_groups_default_value

    значение дополнительного свойства информационной группы по умолчанию

    $information_propertys_groups_xml_name

    название xml-тега, соответсвующего данному дополнительному свойству информационной группы

    $information_propertys_groups_lists_id

    идентификатор списка, который указывается в качестве дополнительного свойства информационной группы

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного/обновленного дополнительного свойства информационной системы для элемента информационной группы

    Описание

    Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы

    [ Top ]

    InformationSystem::InsertInformationPropertysGroupsValue

InsertInformationPropertysGroupsValue(
int
$type, int
$information_propertys_groups_value_id, int
$information_groups_id, int
$information_propertys_groups_id, string
$information_propertys_groups_value_value, [mixed
$information_propertys_groups_value_file = ''] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление значения дополнительного свойства информационной группы (0 - вставка, 1 - обновление)

    $information_propertys_groups_value_id

    идентификатор дополнительного свойства информационной группы (при вставке равен 0)

    $information_groups_id

    идентификатор информационной группы

    $information_propertys_groups_id

    идентификатор дополнительного свойства группы

    $information_propertys_groups_value_value

    значение дополнительного свойства информационной группы

    Возвращает

    идентификатор добавленнного/обновленного значения дополнительного свойства информационной группы

    Описание

    Метод вставки/обновления значения свойства информационной группы

    [ Top ]

    InformationSystem::InsertInformationPropertysItems

InsertInformationPropertysItems(
int
$type, int
$information_propertys_items_id, int
$information_propertys_id, int
$information_items_id, string
$information_propertys_items_value, [mixed
$information_propertys_items_file = ''] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление значения свойства информационной системы (0 - вставка, 1 - обновление)

    $information_propertys_items_id

    идентификатор значения свойства информационной системы для конкретного элемента информационной системы (при вставке равен 0)

    $information_propertys_id

    идентификатор свойства информационной системы

    $information_items_id

    идентификатор элемента информационной системы

    $information_propertys_items_value

    значение элемента информационной системы

    Возвращает

    идентификатор вставленного/обновленного значения свойства информационной системы для элемента информационной системы

    Описание

    Метод вставки/обновления значения свойства информационной

    [ Top ]

    InformationSystem::InsertInfotmationSystem

InsertInfotmationSystem(
mixed
$param, array
$param
 );

    Принимаемые параметры

    $param

    $param['type'] элемент, определяющий будет производиться вставка или обновление данных об информационной системе (0 – вставка, 1 - обновление);  $param['id'] идентификатор обновляемой информационной системы (при вставке равен 0)  $param['site_id'] идентификатор сайта, к которому принадлежит информационная система  $param['name'] название информационной системы  $param['description']  описание информационной системы  $param['url'] адрес страницы из структуры сайта  $param['items_order_field'] поле сортировки элементов данной информационной системы  $param['items_order_type'] направление сортировки элементов информационной системы  $param['information_blocks_group_items_order_field'] поле сортировки групп данной информационной системы  $param['information_blocks_group_items_order_type'] направление сортировки элементов информационной системы  $param['big_image_max_size'] максимальный размер «большого» варианта изображения при уменьшении загружаемого изображения элемента информационной системы  $param['small_image_max_size'] максимальный размер «маленького» варианта изображения при уменьшении загружаемого изображения элемента информационной системы  $param['template_id'] идентификатор применяемого макета  $param['information_blocks_captcha_used'] использовать автоматизированный тест Тьюринга разделения
    людей и компьютеров (1 - использовать, 0 - не использовать). По умолчанию используется  $param['watermark_file'] - файл марки для наложения на изображения  $param['watermark_file_expantion'] - расширение файла марки для наложения  $param['watermark_default_used'] - параметр, определяющий используется ли файл марки по умолчанию (1 - используется, 0 - не используется).  $param['watermark_default_used_small'] - параметр, определяющий используется ли файл марки по умолчанию для малых изображений(1 - используется, 0 - не используется).  $param['structure_id'] - параметр определяющий идентификатор узла структуры, где будет отображаться данный элемент  $param['information_blocks_format_date'] формат даты  $param['information_blocks_format_datetime'] формат дата/время  По умолчанию - используется  $param['watermark_default_position_x'] - позиция изображения по оси X по умолчанию. По умолчанию равна 50%.  $param['watermark_default_position_y'] - позиция изображения по оси Y по умолчанию. По умолчанию равна 100%.  $param['items_on_page'] - число информационных элементов выводимых на страницу  $param['users_id'] - идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной/обновленной информационной системы

    Описание

    Метод вставки/обновления данных об информационной системе

    [ Top ]

    InformationSystem::insert_comment

insert_comment(
int
$type, int
$comment_id, int
$information_items_id, string
$comment_fio, string
$comment_email, string
$comment_text, int
$comment_status, string
$comment_subject, string
$comment_ip, string
$comment_date, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление комментария информационного элемента (0 - вставка, 1 - обновление)

    $comment_id

    идентификатор обновляемого комментария (при вставке равен 0)

    $information_items_id

    идентификатор информационного элемента

    $comment_fio

    ФИО автора комментария

    $comment_email

    e-mail автора комментария

    $comment_text

    текст комментария

    $comment_status

    статус активности комментария (0 – не отображать, 1- отображать)

    $comment_subject

    тема комментария

    $comment_ip

    ip-адрес отправителя комментария

    $comment_date

    дата отправки комментария

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного/обновленного комментария для элемента информационной системы

    Описание

    Метод вставки/обновления комментария для элемента информационной системы

    [ Top ]

    InformationSystem::insert_comment_without_striptags

insert_comment_without_striptags(
int
$type, int
$comment_id, int
$information_items_id, string
$comment_fio, string
$comment_email, string
$comment_text, string
$comment_status, string
$comment_subject, string
$comment_ip, string
$comment_date, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление комментария информационного элемента (0 - вставка, 1 - обновление)

    $comment_id

    идентификатор обновляемого комментария (при вставке равен 0)

    $information_items_id

    идентитфикатор информационного элемента

    $comment_fio

    ФИО автора комментария

    $comment_email

    e-mail автора комментария

    $comment_text

    текст комментария

    $comment_status

    параметр, определяющий статус активности комментария (0 – не отображать, 1- отображать)

    $comment_subject

    тема комментария

    $comment_ip

    ip-адрес отправителя комментария

    $comment_date

    дата отправки комментария

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного/обновленного комментария для элемента информационной системы

    Описание

    Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах

    [ Top ]

    InformationSystem::IssetAccessForInformationSystemGroup

IssetAccessForInformationSystemGroup(
int
$user_id, int
$information_group_id, [int
$information_system_id = 0], [array
$row_group = array()] );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $information_group_id

    идентификатор информационной группы

    $information_system_id

    идентификатор информационной системы, не обязательный параметр, по умолчанию 0

    $row_group

    ассоциативный массив с информацией о группе, по умолчанию пустой

    Описание

    Метод проверяет возможность доступа пользователя указанной группы к группе информационной системы

    [ Top ]

    InformationSystem::IssetGroup

IssetGroup(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$information_groups_path, [int
$edit_mode = 0], [int
$information_groups_id = 0] );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор родительской группы

    $InformationSystem_id

    идентификатор информационной системы, к которой относится данная группа

    $information_groups_path

    URL вставляемой/обновляемой группы

    $edit_mode

    параметр, указывающий производится вставка или обновление группы (0 –вставка, 1 – обновление)

    $information_groups_id

    идентификатор редактируемой информационной группы

    Возвращает

    true – в данной группе есть подгруппа, которая имеет такой же URL как и вставляемая/редактируемая подгруппа. В противном случае возвращает false

    Описание

    Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе

    [ Top ]

    InformationSystem::IssetGroupItemInsertUpdate

IssetGroupItemInsertUpdate(
int
$information_groups_id, int
$InformationSystem_id, string
$information_items_url );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, в которой осуществляется поиск

    $InformationSystem_id

    идентификатор информационной системы, к которой относится группа

    $information_items_url

    URL информационного элемента

    Возвращает

    true - в данной группе есть подгруппа, URL которой совпадает с URL информационного элемента, относящегося к данной группе. В противном случае возвращает false

    Описание

    Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента

    [ Top ]

    InformationSystem::IssetItem

IssetItem(
int
$information_groups_id, int
$InformationSystem_id, string
$information_items_url, [int
$information_items_id = 0], [int
$edit_mode = 0] );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, среди элементов которой проводится проверка

    $InformationSystem_id

    идентификатор информационной системы, среди элементов которой проводится проверка;

    $information_items_url

    URL информационного элемента, для которого ищем совпадения среди URL других элементов данной информационной группы

    $information_items_id

    идентификатор редактируемого информационного элемента, при добавлении $id=0

    $edit_mode

    параметр, определяющий  режим вставки или добавления элемента (0 – вставка, 1- редактирование)

    Возвращает

    true – в информационной группе уже существует информационный элемент с таким же URL как и у данного элемента, false – в информационной группе не существует элементов с таким URL

    Описание

    Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы

    [ Top ]

    InformationSystem::IssetItemGroupInsertUpdate

IssetItemGroupInsertUpdate(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$information_groups_path );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор родительской группы

    $InformationSystem_id

    идентификатор информационной системы

    $information_groups_path

    URL вставляемой/редактируемой группы

    Возвращает

    true – в данной группе есть информационный элемент, у которого URL совпадает с URL добавляемой/редактируемой группы. В противном случае возвращает false

    Описание

    Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы

    [ Top ]

    InformationSystem::SelectInformationGroupPropertys

SelectInformationGroupPropertys(
int
$id, int
$InformationSystem_id );

    Принимаемые параметры

    $id

    идентификатор свойства информационной группы

    $InformationSystem_id

    идентификатор информационной системы

    Описание

    Метод получения данных о свойствах группы информационной системы

    [ Top ]

    InformationSystem::SelectInformationGroups

SelectInformationGroups(
int
$id, [int
$information_system_id = false], [array
$param = array()] );

    Принимаемые параметры

    $id

    идентификатор выбираемой информационной группы, если $id = -1 – выбираются все группы данной информационной системы

    $information_system_id

    идентификатотр информационной системы

    $param

    массив дополнительных параметров  $param['OrderGroup'] = ASC/DESC порядок сортировки информацтонных групп  $param['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()  $param['NotInGroup'] идентификатор информационных групп, которые необходимо исключить из результатов  $param['groups_parent_id'] идентификатор родительской группы, необязательный параметр, по умолчанию false

    Описание

    Метод получения информации об информационных группах конкретной информационной системы

    [ Top ]

    InformationSystem::SelectInformationSystem

SelectInformationSystem(
mixed
$information_blocks_id, int
$id );

    Принимаемые параметры

    $id

    идентифиеатор информационной системы

    Описание

    Метод получения информации об информационной системе

    [ Top ]

    InformationSystem::SelectListInformationGroupPropertys

SelectListInformationGroupPropertys(
int
$InformationSystem_id );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    Описание

    Метод получения списка дополнительных свойств информационноq группы данной инфосистемы

    [ Top ]

    InformationSystem::select_comments

select_comments(
int
$id, int
$information_items_id );

    Принимаемые параметры

    $id

    идентификатор комментария

    $information_items_id

    идентификатор информационного элемента

    Описание

    Метод получения комментариев к информационному элементу

    [ Top ]

    InformationSystem::select_information_items

select_information_items(
int
$id, [int
$information_groups_id = false], [int
$information_system_id = false] );

    Принимаемые параметры

    $id

    идентификатор выбираемого информационного элемента, если $id = false – выбираем все информационные элементы данной информационной системы

    $information_groups_id

    идентификатор информационной группы, элементы которой необходимо выбрать, если $id = false (по умолчанию), то выбираются все элементы данной информационной системы

    $information_system_id

    идентификатор информационной системы

    Описание

    Метод получения данных об информационном элементе

    [ Top ]

    InformationSystem::select_information_propertys

select_information_propertys(
int
$id, int
$InformationSystem_id );

    Принимаемые параметры

    $id

    идентификатор свойства информационной системы, если $id = -1, то выбираем все свойства информационной системы

    $InformationSystem_id

    идентификатор информационной системы

    Описание

    Метод получения данных о свойствах информационной системы

    [ Top ]

    InformationSystem::ShowAddComment

ShowAddComment(
string
$xslname, [array
$param = array(
    'confirm_comment'=>false,
    'status' => 0
    )] );

    Принимаемые параметры

    $xslname

    имя XSL шаблона для отображения информации о добавлении комментария

    $param

    массив дополнительных параметров  $param['confirm_comment'] определяет имеет ли пользователь право на добавления комментария (true - имеет право, false - не имеет право)  $param['status'] статус сообщения, добавленного пользователем (0 - недоступно посетителям, 1 - доступно посетителям сразу после публикации)  $param['information_items_id'] идентификатор информационной системы, для которой производится добавление комментария  $param['admin_email_xsl'] наименование XSL-шаблона для отправки информации о комментарии администратору

    Возвращает

    false в случае отсутствия данного информационного элемента

    Описание

    Метод добавления комментария к элементу информационной системы

    [ Top ]

    InformationSystem::ShowInformationSystem

ShowInformationSystem(
mixed
$InformationSystemIdArray, int
$information_groups_id, string
$xsl_name, int
$items_on_page, int
$items_begin, [array
$external_propertys = array()], [array
$property = array()] );

    Принимаемые параметры

    $InformationSystemIdArray

    массив идентификаторов или идентификатор информационной системы

    $information_groups_id

    информационной группы, подгруппы и элементы которой необходимо показать

    $xsl_name

    имя XSL шаблона для отображения групп и элементов информационной системы

    $items_on_page

    число информационных элементов, отображаемых на странице

    $items_begin

    номер, начиная с которого выводить информационные элементы

    $external_propertys

    массив дополнительных свойств для включения в XML

    $property

    массив дополнительных параметров  $property['Order'] = ASC/DESC порядок сортировки информационных элементов
    $property['OrderField'] поле сортировки информационных элементов, если случайная сортировка, то записать RAND()
    $property['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
    $property['OrderGroup'] направление сортировки (ASC - по возрастанию, DESC - по убыванию)
    $property['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()
    $property['NotInGroup'] идентификатор групп информационных элементов, которые необходимо исключить из результатов
    $property['cache'] разрешение кэширования, по умолчанию true
    $property['select'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных элементов
    $element['type'] определяет, является ли поле основным свойством информационного элемента или дополнительным (0 - основное, 1 - дополнительное)
    $element['prefix'] префикс - строка, размещаемая перед условием
    $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    $element['property_id'] идентификатор дополнительногого свойства
    $element['if'] строка, содержащая условный оператор
    $elemenr['value'] значение поля (или параметра)
    $element['sufix'] суффикс - строка, размещаемая после условия
    $property['show_group'] содержит массив групп системы для показа
    $property['show_text'] параметр, указывающий включать в XML текст информационного элемента или нет, по умолчанию равен true

    Пример использования:

    1      <?
    2      $InformationSystem = new InformationSystem();
    3      $external_propertys=array();
    4      $external_propertys[‘ПоказыватьСсылкиНаДругиеСтраницы’]=1;
    5      $property=array();
    6      # Заполняем первое условие
    7      $element['type']=0;
    8      $element['prefix'] = ' and (';
    9      $element['name'] = 'information_items_date';
    10     $element['if'] = '>';
    11     $elemenr['value'] = '2005-12-23 00:00:00';
    12     $element['sufix']='';
    13     $property['select'][]=$element;
    14     # Заполняем второе условие, в данном случае по значению дополнительного св-ва
    15     $element['type']=1;
    16     $element['prefix'] = 'and';
    17     $element['property_id'] = 17;
    18     $element['if'] = '>';
    19     $element['value'] = '2005-12-23 00:00:00';
    20     $element['sufix']=')';
    21     $property['select'][]=$element;
    22     # Выводим элементы
    23     $InformationSystem-> ShowInformationSystem(1, 0, ‘СписокНовостей’, 10, 0, external_propertys, $property);
    24     ?>

    Пример сортировки по значению дополнительного поля:  <?  $InformationSystem = new InformationSystem();  $external_propertys=array();  $external_propertys[‘ПоказыватьСсылкиНаДругиеСтраницы’]=1;  $property=array();
    • Заполняем первое условие
     $element['type']=0;  $element['prefix'] = 'and (';  $element['name'] = 'information_items_date';  $element['if'] = '>';  $elemenr['value'] = '2005-12-23 00:00:00';  $element['sufix']='';  $property['select'][]=$element;  $element['type']=0;  $element['prefix'] = ' and '; // префикс  $element['name'] = 'information_propertys_table.information_propertys_id';  $element['if'] = '='; // Условие
    • Здесь указывается ID доп. св-ва, по которому производится сортировка
     $element['value'] = '38'; // ID дополнительного св-ва, по которому сортируем  $element['sufix']=')';  $property['select'][]=$element;
    // Указываем, что мы сортируем по значениям дополнительных полей  $property['OrderField'] = 'information_propertys_table.information_propertys_id, information_propertys_items_value';  // Выводим элементы  $InformationSystem-> ShowInformationSystem(1, 0, ‘СписокНовостей’, 10, 0, $external_propertys, $property);  ?>

    Возвращает

    двумерный массив с данными о показанных записях информационной системы

    Описание

    Метод отображения групп и элементов информационной системы

    [ Top ]

    InformationSystem::ShowInformationSystemItem

ShowInformationSystemItem(
int
$information_item_id, string
$xsl_name, [array
$external_propertys = array()] );

    Принимаемые параметры

    $information_item_id

    идентификатор, отображаемого информационного элемента

    $xsl_name

    имя XSL-шаблона, применяемого для отображения информационного элемента

    $external_propertys

    массив дополнительных свойств, индексы массива - имена дополнительных XML-тэгов, элементы массива - значения этих тэгов

    Возвращает

    true

    Описание

    Метод отображения информацию об информационном элементе

    [ Top ]

    InformationSystem::ShowInformationSystemPageConfig

ShowInformationSystemPageConfig(
int
$InformationSystem_id, int
$items_on_page, [array
$property = array()] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    $items_on_page

    количество элементов на страницу

    $property

    массив дополнительных параметров
      $property['page'] текстовая информация для указания номера страницы, например "страница"  $property['separator'] разделитель, по умолчанию ' /'

    Описание

    Метод вызова настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы

    [ Top ]

    InformationSystem::ShowInformationSystemPageContent

ShowInformationSystemPageContent(
int
$InformationSystem_id, string
$xsl_list, string
$xsl_item, [array
$property = array()], [array
$external_propertys = array()], [array
$infsys_property = array()] );

    Принимаемые параметры

    $InformationSystem_id

    $xsl_list

    XSL шаблон для вывода спсика инфорамционных элементов

    $xsl_item

    XSL шаблон для вывода одного элемента

    $property

    массив дополнительных параметров
      $property['items_on_page'] число элементов на страницу, по умолчанию 10  $property['items_begin'] элемент, с которого начинать вывод, по умолчанию 0

    $external_propertys

    внешние параметры, передаваемы в XML

    $infsys_property

    дополнительные свойства для показа информационной системы, см. ShowInformationSystem

    Описание

    Метод вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы

    [ Top ]

    InformationSystem::ShowInformationSystemRss

ShowInformationSystemRss(
int
$InformationSystem_id, mixed
$information_groups_id, [int
$items_on_page = 10], [int
$items_begin = 0], [array
$property = array()] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    $information_groups_id

    идентификатор информационной группы, если все группы – то false

    $items_on_page

    количество выводимых записей в ленте

    $items_begin

    параметр, определяющий с какой записи начинать вывод

    $property

    массив дополнительных параметров
    $property['title'] string Заголовок канала
    $property['description'] string Краткое описание RSS-канала
    $property['link'] string Ссылка на сайт
    $property['image'] Картинка для представления канала (необязательный элемент)
    $property['image']['url'] string Ссылка на файл изображения
    $property['image']['title'] string Заменяющий текст для изображения
    $property['image']['link'] string Ссылка для перехода при щелчке по изображению
    $property['yandex:full-text'] bool Вывод полного текста для Яндекс, по умолчанию false
    $property['strip-tags'] bool Указывает на необходимость удаления тегов из содержания RSS, по умолчанию false
    $property['show-image'] bool Разрешает передачу картинки для информационного элемента в теге enclosure

    Описание

    Метод отображения RSS ленты

    [ Top ]

    InformationSystem::UserCanAddComment

UserCanAddComment(
string
$date, mixed
$ip, string
$comment_ip );

    Принимаемые параметры

    $date

    дата и время (в Unix-формате) добавления комментария

    $comment_ip

    ip-адрес компьютера пользователя, добавляющего комментарий

    Возвращает

    true - пользователь может отправлять комментарий, false - не может отправлять комментарий

    Описание

    Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY

    [ Top ]

Описания переменных

  • $a_count_property = array() [Строка 139]
    •

  • Data type: array
    •

    Описание

    Кэш количества свойств

  • $cache_InformationSystem = array() [Строка 147]
    •

  • Data type: array
    •

    Описание

    Кэш данных о информационной системе  пример $this->cache_InformationSystem[$id]

  • $CommentMass = array() [Строка 102]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о комментариях

  • $GroupMass = array() [Строка 88]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о группах

  • $ItemMass = array() [Строка 95]
    •

  • Data type: array
    •

    Описание

    Кэш с данными об элементах

  • $MasGroup = array() [Строка 132]
    •

  • Data type: array
    •

    Описание

    Массив групп

  • $PropertyGroupMass = array() [Строка 116]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о дополнительных свойствах информационных групп

  • $PropertyMass = array() [Строка 109]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о свойствах инфоррмационных элементов

Описание констант класса

support@hostcms.ru


Docs For Class ip

Class ip

[Строка 11]

Размещен: /ip/ip.class.php

Описание

Класс модуля "IP-адреса"

Свойства класса

  • $record_on_page = ON_PAGE

        Число записей, отображаемых на странице

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • resource DelIp()

    Метод удаления информации об IP-адресе

  • mixed GetIpInfo()

    Метод получения информации о запретах для переданного ip-адреса

  • int InsertIp()

    Метод вставки/обновления информации об IP-адресе

  • resource SelectIp()

    Метод получения информации об IP-адресах

Унаследованные методы

Описания методов

    ip::DelIp

DelIp(
int
$id );

    Принимаемые параметры

    $id

    идентификатор IP-адреса

    Описание

    Метод удаления информации об IP-адресе

    [ Top ]

    ip::GetIpInfo

GetIpInfo(
string
$ip, [array
$param = array()] );

    Принимаемые параметры

    $ip

    IP-адрес

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    массив с информацией о запретах для IP-адреса, или false, если запретов нет

    Описание

    Метод получения информации о запретах для переданного ip-адреса

    [ Top ]

    ip::InsertIp

InsertIp(
int
$type, array
$fields );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации об IP-адресе (0-вставка, 1-обновление)

    $fields

    массив полей

    Возвращает

    идентификатор вставленной/обновленной записи с информацией об IP-адресе

    Описание

    Метод вставки/обновления информации об IP-адресе

    [ Top ]

    ip::SelectIp

SelectIp(
int
$id );

    Принимаемые параметры

    $id

    идентификатор IP-адреса, о котором необходимо получить информацию, если  $id=false - получаем информацию о всех  IP-адресах

    Описание

    Метод получения информации об IP-адресах

    [ Top ]

Описания переменных

  • $record_on_page = ON_PAGE [Строка 26]
    •

  • Data type: int
    •

    Описание

    Число записей, отображаемых на странице

Описание констант класса

support@hostcms.ru


Docs For Class kernel

Class kernel

[Строка 10]

Размещен: /Kernel/Kernel.class.php

Описание

Класс ядра системы управления сайтом HostCMS

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • bool AddInclude()

    Метод подключает переданный файл или выводит сообщение об ошибке подключения

  • void AddModule()

    Метод подключения модуля

  • void add_modules_version()

    Метод добавления модуля в массив-список модулей

  • string declension()

    Метод получения существительного в форме, соответствующей числу

  • int GetCurrentUser()

    Метод определения идентификатора текущего авторизированного пользователя раздела администрирования

  • int GetCurrentYear()

    Метод получения значения текущего года

  • string GetDBVersion()

    Метод определения версии MySQL

  • int GetExpires()

    Метод получения времени истечения актуальности страницы

  • string GetExtension()

    Метод возвращает расширение файла

  • string GetGDVersion()

    Метод определения версии GD библиотеки

  • int GetLastModified()

    Метод получения времени последнего изменения страницы

  • int getmicrotime()

    Метод получения значения времени

  • string GetMimeType()

    Метод определения MIME-типа файла

  • mixed GetObject()

    Метод создает глобально доступный объект

  • int GetTemplate()

    Метод получения текущего макета

  • string get_CSS()

    Метод получения CSS стиля для страницы

  • int get_current_page()

    Метод получения идентификатора текущего узла структуры

  • string get_current_page_path()

    Метод получения пути текущей страницы

  • string get_description()

    Метод получения описания страницы

  • string get_keywords()

    Метод получения ключевых слов страницы

  • int get_page_id()

    Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя

  • string get_title()

    Метод получения заголовка страницы

  • string implode_array()

    Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно

  • boolean InitConstants()

    Метод инициализации констант сайта в соответствии с константой CURRENT_SITE

  • void LoadModules()

    Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS

  • void LoadModulesLngFile()

    Метод загрузки языкового файла для модуля

  • int phpversion()

    Метод возвращает номер версии PHP

  • array random_shuffle()

    Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.

  • bool SendMailWithFile()

    Метод отправки электронного письма с прикрепленным файлом

  • void SetExpires()

    Метод установления времени истечения актуальности страницы

  • void SetLastModified()

    Метод установления времени последнего изменения страницы

  • void SetTemplate()

    Метод установления текущего макета

  • void set_CSS()

    Метод изменения адреса файла CSS-стиля для страницы

  • void set_current_page()

    Метод изменения адреса страницы

  • void set_current_page_data_template()

    Метод изменения шаблона страницы

  • void set_description()

    Метод изменения описания страницы

  • void set_keywords()

    Метод изменения ключевых слов страницы

  • void set_title()

    Метод изменения заголовока страницы

  • void show_CSS()

    Метод вывода CSS стиля для страницы

  • void show_current_page()

    Метод вывода установленной страницы

  • void show_current_template()

    Метод вывода текущего макета

  • void show_description()

    Метод вывода описания страницы

  • void show_keywords()

    Метод вывода ключевых слов страницы

  • void show_title()

    Метод вывода заголовка страницы

  • void strips()

    Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag

Унаследованные методы

Описания методов

    kernel::AddInclude

AddInclude(
string
$file );

    Принимаемые параметры

    $file

    имя файла

    Описание

    Метод подключает переданный файл или выводит сообщение об ошибке подключения

    [ Top ]

    kernel::AddModule

AddModule(
string
$modules_path );

    Принимаемые параметры

    $modules_path

    path-имя модуля, например Structure

    Описание

    Метод подключения модуля

    [ Top ]

    kernel::add_modules_version

add_modules_version(
string
$path, string
$version, [string
$date = ''] );

    Принимаемые параметры

    $path

    путь к модулю

    $version

    версия модуля

    $date

    дата

    Описание

    Метод добавления модуля в массив-список модулей

    [ Top ]

    kernel::declension

declension(
int
$num, int
$word_stem, int
$ends_of_word, [mixed
$prefix = ''], [mixed
$postfix = ''], int
$prefix='', int
$postfix='' );

    Принимаемые параметры

    $num

    число, с которым связано существительное

    $word_stem

    основа слова

    $ends_of_word

    массив окончаний слова

    $prefix=''

    префикс (возможно прилагательное)

    $postfix=''

    постфикс - конец фразы

    Возвращает

    сформированная строка

    Описание

    Метод получения существительного в форме, соответствующей числу

    version

    3.2

    [ Top ]

    kernel::GetCurrentUser

GetCurrentUser(
 );

    Возвращает

    идентификатор пользователя или 0, если нет авторизированного пользователя

    Описание

    Метод определения идентификатора текущего авторизированного пользователя раздела администрирования

    [ Top ]

    kernel::GetCurrentYear

GetCurrentYear(
 );

    Возвращает

    текущий год

    Описание

    Метод получения значения текущего года

    [ Top ]

    kernel::GetDBVersion

GetDBVersion(
 );

    Возвращает

    версия MySQL

    Описание

    Метод определения версии MySQL

    [ Top ]

    kernel::GetExpires

GetExpires(
 );

    Возвращает

    временная метка для страницы

    Описание

    Метод получения времени истечения актуальности страницы

    [ Top ]

    kernel::GetExtension

GetExtension(
string
$filename );

    Принимаемые параметры

    $filename

    имя файла

    Возвращает

    расширение файла

    Описание

    Метод возвращает расширение файла

    [ Top ]

    kernel::GetGDVersion

GetGDVersion(
 );

    Возвращает

    версия GD библиотеки

    Описание

    Метод определения версии GD библиотеки

    [ Top ]

    kernel::GetLastModified

GetLastModified(
 );

    Возвращает

    временная метка для страницы

    Описание

    Метод получения времени последнего изменения страницы

    [ Top ]

    kernel::getmicrotime

getmicrotime(
 );

    Возвращает

    время

    Описание

    Метод получения значения времени

    [ Top ]

    kernel::GetMimeType

GetMimeType(
string
$filename );

    Принимаемые параметры

    $filename

    имя файла с расширением

    Возвращает

    mime-тип

    Описание

    Метод определения MIME-типа файла

    [ Top ]

    kernel::GetObject

&GetObject(
string
$class_name );

    Принимаемые параметры

    $class_name

    имя класса

    Возвращает

    object или false, если класс отсутствует

    Описание

    Метод создает глобально доступный объект

    [ Top ]

    kernel::GetTemplate

GetTemplate(
 );

    Возвращает

    идентификатор макета

    Описание

    Метод получения текущего макета

    [ Top ]

    kernel::get_CSS

get_CSS(
[boolean
$is_external = true] );

    Принимаемые параметры

    $is_external

    необязательный параметр $is_external - true - ссылка на CSS, false - возвращение содержания CSS стиля

    Возвращает

    CSS стиль для страницы

    Описание

    Метод получения CSS стиля для страницы

    [ Top ]

    kernel::get_current_page

get_current_page(
array
$param, [int
$site_id = CURRENT_SITE] );

    Принимаемые параметры

    $param

    имена разделов от родителя к ребенку, например services | guard_business_center,  например Array ( [0] => services [1] => guard_business_center)

    $site_id

    идентификатор сайта

    Возвращает

    идентификатор узла структуры

    Описание

    Метод получения идентификатора текущего узла структуры

    [ Top ]

    kernel::get_current_page_path

get_current_page_path(
 );

    Возвращает

    абсолютный путь к текущей статичной странице

    Описание

    Метод получения пути текущей страницы

    [ Top ]

    kernel::get_description

get_description(
 );

    Возвращает

    описание страницы

    Описание

    Метод получения описания страницы

    [ Top ]

    kernel::get_keywords

get_keywords(
 );

    Возвращает

    ключевые слова, установленные для страницы

    Описание

    Метод получения ключевых слов страницы

    [ Top ]

    kernel::get_page_id

get_page_id(
string
$name, int
$parent_id, int
$site_id );

    Принимаемые параметры

    $name

    имя узла стурктуры

    $parent_id

    идентификатор родителя

    $site_id

    идентификатор сайта

    Возвращает

    идентификатор узла структуры или false

    Описание

    Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя

    [ Top ]

    kernel::get_title

get_title(
 );

    Возвращает

    значение заголовка страницы

    Описание

    Метод получения заголовка страницы

    [ Top ]

    kernel::implode_array

implode_array(
array
$array, [array
$separator = ''] );

    Принимаемые параметры

    $array

    массив

    $separator

    разделитель

    Возвращает

    строка

    Описание

    Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно

    [ Top ]

    kernel::InitConstants

InitConstants(
 );

    Возвращает

    true в случае успеха, false - данные о сайте отсутствуют

    Описание

    Метод инициализации констант сайта в соответствии с константой CURRENT_SITE

    [ Top ]

    kernel::LoadModules

LoadModules(
[bool
$load_all_active_module = true] );

    Принимаемые параметры

    $load_all_active_module

    необязательный параметр, указывает на обязательную загрузку всех активных модулей (для PHP 5 и выше), по умолчанию true

    Описание

    Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS

    [ Top ]

    kernel::LoadModulesLngFile

LoadModulesLngFile(
string
$module_path_name, string
$modules_name );

    Принимаемые параметры

    $module_path_name

    имя в пути модуля, например Document

    $modules_name

    текстовое имя модуля, например "Документы"

    Описание

    Метод загрузки языкового файла для модуля

    [ Top ]

    kernel::phpversion

phpversion(
 );

    Возвращает

    новер версии PHP, например 4 или 5

    Описание

    Метод возвращает номер версии PHP

    [ Top ]

    kernel::random_shuffle

random_shuffle(
array
$array, [int
$hash = false] );

    Принимаемые параметры

    $array

    массив

    $hash

    некое числовое значение

    Возвращает

    перемешанный массив

    Описание

    Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.

    [ Top ]

    kernel::SendMailWithFile

SendMailWithFile(
string
$to, string
$from, string
$subject, string
$text, array
$file_path_name );

    Принимаемые параметры

    $to

    адрес получателя письма

    $from

    адрес отправителя письма

    $subject

    тема письма

    $text

    текст письма

    $file_path_name

    ассоциативный массив, содержащий пути к прикрепляемым файлам и их именам, например
     $file_path_name[0]['filepath'] = "C:\file1.txt"
    $file_path_name[0]['filename'] = "file1.txt"

    Возвращает

    true - письмо отправлено успешно, false - неуспешно

    Описание

    Метод отправки электронного письма с прикрепленным файлом

    [ Top ]

    kernel::SetExpires

SetExpires(
int
$time );

    Принимаемые параметры

    $time

    временная метка

    Описание

    Метод установления времени истечения актуальности страницы

    [ Top ]

    kernel::SetLastModified

SetLastModified(
int
$time );

    Принимаемые параметры

    $time

    временная метка

    Описание

    Метод установления времени последнего изменения страницы

    [ Top ]

    kernel::SetTemplate

SetTemplate(
int
$template_id );

    Принимаемые параметры

    $template_id

    идентификатор макета

    Описание

    Метод установления текущего макета

    [ Top ]

    kernel::set_CSS

set_CSS(
string
$CSS );

    Принимаемые параметры

    $CSS

    код стилей

    Описание

    Метод изменения адреса файла CSS-стиля для страницы

    [ Top ]

    kernel::set_current_page

set_current_page(
string
$page );

    Принимаемые параметры

    $page

    абсолютный адрес файла статичного документа

    Описание

    Метод изменения адреса страницы

    [ Top ]

    kernel::set_current_page_data_template

set_current_page_data_template(
string
$data_template );

    Принимаемые параметры

    $data_template

    идентификатор шаблона страницы

    Описание

    Метод изменения шаблона страницы

    [ Top ]

    kernel::set_description

set_description(
string
$description );

    Принимаемые параметры

    $description

    описание страницы

    Описание

    Метод изменения описания страницы

    [ Top ]

    kernel::set_keywords

set_keywords(
string
$keywords );

    Принимаемые параметры

    $keywords

    ключевые слова

    Описание

    Метод изменения ключевых слов страницы

    [ Top ]

    kernel::set_title

set_title(
string
$title );

    Принимаемые параметры

    $title

    текст заголовка страницы

    Описание

    Метод изменения заголовока страницы

    [ Top ]

    kernel::show_CSS

show_CSS(
[boolean
$is_external = true] );

    Принимаемые параметры

    $is_external

    true - ссылка на CSS, false - вывод содержания CSS стиля

    Описание

    Метод вывода CSS стиля для страницы

    [ Top ]

    kernel::show_current_page

show_current_page(
 );

    Описание

    Метод вывода установленной страницы

    [ Top ]

    kernel::show_current_template

show_current_template(
 );

    Описание

    Метод вывода текущего макета

    [ Top ]

    kernel::show_description

show_description(
 );

    Описание

    Метод вывода описания страницы

    [ Top ]

    kernel::show_keywords

show_keywords(
 );

    Описание

    Метод вывода ключевых слов страницы

    [ Top ]

    kernel::show_title

show_title(
 );

    Описание

    Метод вывода заголовка страницы

    [ Top ]

    kernel::strips

strips(
 );

    Описание

    Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class lib

Class lib

[Строка 7]

Размещен: /lib/lib.class.php

Свойства класса

  • $mas_lib_dir = array()

  • $section_path =  ''

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void ConvertSqlProperty()

    Метод конвертирет SQL-запрос, введенный для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.

  • bool CopyLib()

    Метод создает копию типовой динамической страницы

  • mixed DeleteLib()

    Метод для удаления типовой динамической страницы из библиотеки страниц

  • bool DeleteLibDir()

    Метод для рекурсивного удаления раздела типовых дин. страниц со всеми его подразделами

  • mixed DeleteLibProperty()

    Метод для удаления параметра типовой динамической страницы

  • результат DeleteLibPropertyListItem()

    Метод для удаления элемента списка параметра типовой динамической страницы

  • mixed GetAllLibDirs()

    Метод возвращает список всех директори типовых дин. страниц

  • mixed GetAllLibProperties()

    Метод возвращает всписок всех дополнительных параметров типовой динамической страницы

  • mixed GetAllLibPropertyListItems()

    Метод для получения списка всех элементов списка

  • mixed GetAllLibs()

    Метод возвращает список всех типовых страниц

  • array GetLib()

    Метод возвращает типовую динамическую страницу по её идентификатору

  • array GetLibDir()

    Метод для получения информации о директории типовых дин. страниц

  • array GetLibDirTree()

    Метод формирования дерева разделов

  • mixed GetLibProperty()

    Метод возвращает информацию о параметре типовой динамической страницы

  • void GetSectionPath()

    Метод возвращает путь к типовой дин. стренице

  • идентификатор InsertLib()

    Метод для вставки информации о типовой динамической странице

  • идентификатор InsertLibDir()

    Метод для вставки/обновления информации о разделе типовых дин. страниц

  • mixed InsertLibProperty()

    Метод вставки информации о параметре типовой динамической страницы

  • mixed InsertLibPropertyListItem()

    Метод для вставки/обновления элемента списка для параметра типовой дин. страницы

  • array LoadLibPropertiesValue()

    Метод загружает значения параметров типовой дин. страницы для структуры

  • void SaveLibPropertiesValue()

    Метод для сохранения настроек типовой динамической страницы для стурктуры в файл

  • результат UpdateLibPropertyOrder()

    Метод для обновления порядка сортировки параметра типовой дин. страницы

Унаследованные методы

Описания методов

    lib::ConvertSqlProperty

ConvertSqlProperty(
unknown_type
$sql );

    Принимаемые параметры

    $sql

    Описание

    Метод конвертирет SQL-запрос, введенный для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.

    Список замен:
    {SITE_ID} - идентификатор текущего выбранного сайта

    [ Top ]

    lib::CopyLib

CopyLib(
int
$lib_id );

    Принимаемые параметры

    $lib_id

    идентификатор типовой дин. страницы

    Возвращает

    результат работы ф-ции

    Описание

    Метод создает копию типовой динамической страницы

    [ Top ]

    lib::DeleteLib

DeleteLib(
int
$lib_id );

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы

    Возвращает

    результат выполнения запроса

    Описание

    Метод для удаления типовой динамической страницы из библиотеки страниц

    [ Top ]

    lib::DeleteLibDir

DeleteLibDir(
int
$lib_dir_id );

    Принимаемые параметры

    $lib_dir_id

    идентификатор раздела

    Возвращает

    результат работы ф-ции

    Описание

    Метод для рекурсивного удаления раздела типовых дин. страниц со всеми его подразделами

    [ Top ]

    lib::DeleteLibProperty

DeleteLibProperty(
int
$lib_property_id );

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра типовой динамической страницы

    Возвращает

    результат выполнения запроса

    Описание

    Метод для удаления параметра типовой динамической страницы

    [ Top ]

    lib::DeleteLibPropertyListItem

DeleteLibPropertyListItem(
int
$lib_property_list_id );

    Принимаемые параметры

    $lib_property_list_id

    идентификатор элемента списка

    Возвращает

    выполнения запроса

    Описание

    Метод для удаления элемента списка параметра типовой динамической страницы

    [ Top ]

    lib::GetAllLibDirs

GetAllLibDirs(
[int
$lib_dir_parent_id = false] );

    Принимаемые параметры

    $lib_dir_parent_id

    идентификатор родительской директории, если false то отображаются все директории

    Возвращает

    результат выборки

    Описание

    Метод возвращает список всех директори типовых дин. страниц

    [ Top ]

    lib::GetAllLibProperties

GetAllLibProperties(
int
$lib_id );

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы

    Возвращает

    результат выборки

    Описание

    Метод возвращает всписок всех дополнительных параметров типовой динамической страницы

    [ Top ]

    lib::GetAllLibPropertyListItems

GetAllLibPropertyListItems(
[int
$lib_property_id = false] );

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра дин. страницы

    Возвращает

    результат выборки

    Описание

    Метод для получения списка всех элементов списка

    [ Top ]

    lib::GetAllLibs

GetAllLibs(
[int
$lib_dir_id = false] );

    Принимаемые параметры

    $lib_dir_id

    идентификатор родительской директории, если false то отображаются все директории

    Возвращает

    результат выборки

    Описание

    Метод возвращает список всех типовых страниц

    [ Top ]

    lib::GetLib

GetLib(
int
$lib_id );

    Принимаемые параметры

    $lib_id

    идентификатор типовой страницы

    Возвращает

    или false

    Описание

    Метод возвращает типовую динамическую страницу по её идентификатору

    [ Top ]

    lib::GetLibDir

GetLibDir(
int
$lib_dir_id );

    Принимаемые параметры

    $lib_dir_id

    идентификатор директории

    Возвращает

    с информацией о директории или false

    Описание

    Метод для получения информации о директории типовых дин. страниц

    [ Top ]

    lib::GetLibDirTree

GetLibDirTree(
int
$lib_dir_parent_id, string
$separator );

    Принимаемые параметры

    $lib_dir_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    Возвращает

    массив с данными о дереве разделов типовых дин. страниц

    Описание

    Метод формирования дерева разделов

    [ Top ]

    lib::GetLibProperty

GetLibProperty(
int
$lib_property_id );

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра

    Возвращает

    информация о параметре типовой динамической страниы или false

    Описание

    Метод возвращает информацию о параметре типовой динамической страницы

    [ Top ]

    lib::GetSectionPath

GetSectionPath(
int
$lib_dir_id );

    Принимаемые параметры

    $lib_dir_id

    идентификатор директории или типовой дин. страницы

    Описание

    Метод возвращает путь к типовой дин. стренице

    [ Top ]

    lib::InsertLib

InsertLib(
array
$param );

    Принимаемые параметры

    $param

    список доп. параметров
     int $param['lib_id'] идентификатор динамической страницы
     int $param['lib_dir_id'] идентификатор раздела динамической страницы
     string $param['lib_name'] название страницы
     string $param['lib_description'] описание страницы
     string $param['lib_module'] код динамической страницы (берем из файла)
     string $param['lib_module_config'] код настроек динамической страницы (берем из файла)
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    вставленной страницы или false

    Описание

    Метод для вставки информации о типовой динамической странице

    [ Top ]

    lib::InsertLibDir

InsertLibDir(
array
$param );

    Принимаемые параметры

    $param

    массив с доп. параметрами
     int $param['lib_dir_id'] идентификатор раздела динамической страницы
     int $param['lib_dir_parent_id'] идентификатор родителя раздела динамической страницы
     int $param['lib_dir_name'] название раздела
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    раздела

    Описание

    Метод для вставки/обновления информации о разделе типовых дин. страниц

    [ Top ]

    lib::InsertLibProperty

InsertLibProperty(
array
$param );

    Принимаемые параметры

    $param

    список доп. параметров
     int $param['lib_property_id'] идентификатор параметра динамической страницы
     int $param['lib_id'] идентификатор динамической страницы
     string $param['lib_property_name'] название параметра динамической страницы
     string $param['lib_property_description'] описание параметра динамической страницы
     string $param['lib_property_varible_name'] название переменной параметра динамической страницы
     int $param['lib_property_type'] тип свойства параметра динамической страницы
     string $param['lib_property_default_value'] значение по-умолчанию параметра динамической страницы
     int $param['lib_property_order'] порядок сортировки параметра динамической страницы
     int $param['lib_property_sql_request'] параметр типовой дин. страницы - SQL запрос, текст запроса
     int $param['lib_property_sql_caption_field'] параметр типовой дин. страницы - SQL запрос, поле заголовка
     int $param['lib_property_sql_value_field'] параметр типовой дин. страницы - SQL запрос, поле значения
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор вставленного параметра или false

    Описание

    Метод вставки информации о параметре типовой динамической страницы

    [ Top ]

    lib::InsertLibPropertyListItem

InsertLibPropertyListItem(
array
$param );

    Принимаемые параметры

    $param

    массив с параметрами элемента списка
     int $param['lib_property_list_id'] идентификатор элемента списка
     string $param['lib_property_list_name'] название элемента списка
     string $param['lib_property_list_value'] значение элемента списка
     int $param['$lib_property_list_order'] порядок сортировки элемента списка
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    ID вставленного/обновленного элемента или false

    Описание

    Метод для вставки/обновления элемента списка для параметра типовой дин. страницы

    [ Top ]

    lib::LoadLibPropertiesValue

LoadLibPropertiesValue(
int
$lib_id, int
$structure_id );

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы

    $structure_id

    идентификатор структуры

    Возвращает

    массив с данными в виде 'Имя_переменной' => 'значение'

    Описание

    Метод загружает значения параметров типовой дин. страницы для структуры

    [ Top ]

    lib::SaveLibPropertiesValue

SaveLibPropertiesValue(
int
$lib_id, int
$structure_id, array
$values );

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы

    $structure_id

    идентификатор структуры

    $values

    массив с данными в виде 'Имя_переменной' => 'значение'

    Описание

    Метод для сохранения настроек типовой динамической страницы для стурктуры в файл

    [ Top ]

    lib::UpdateLibPropertyOrder

UpdateLibPropertyOrder(
int
$lib_property_id, int
$lib_property_order );

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра типовой дин. страницы

    $lib_property_order

    порядок сортировки

    Возвращает

    запроса

    Описание

    Метод для обновления порядка сортировки параметра типовой дин. страницы

    [ Top ]

Описания переменных

  • $mas_lib_dir = array() [Строка 10]
    •

  • Data type: mixed
    •

  • $section_path =  '' [Строка 9]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class lists

Class lists

[Строка 11]

Размещен: /Lists/Lists.class.php

Описание

Класс модуля "Списки"

Свойства класса

  • $record_on_page = ON_PAGE

        Количество выводимых элементов на страницу

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int CopyListItem()

    Метод копирования элементов списка

  • boolean del_lists()

    Метод удаления списка

  • boolean del_lists_items()

    Метод удаления элемента списка

  • str GenXml4ListItems()

    Метод генерирует XML для всех элементов списка.

  • resource GetList()

    Метод выборки данных о списках

  • mixed GetListItem()

    Метод получения данные об элементе списка

  • mixed GetListItemIfIssetValue()

    Метод проверки наличия значения в списке

  • resource GetListItemsValuesById()

    Метод возвращает элементы списка.

  • int insert_lists()

    Метод вставки/обновления данных о списке

  • int insert_lists_items()

    Метод вставки/обновления данных об элементе списка

  • resource SelectListsItems()

    Метод получения данных об элементах списка

  • resource select_lists_items()

    Метод получения данных об элементе списка

  • void ShowList()

    Метод отображения элементов списка

Унаследованные методы

Описания методов

    lists::CopyListItem

CopyListItem(
int
$list_item_id );

    Принимаемые параметры

    $list_item_id

    идентификатор копируемого элемента списка

    Возвращает

    идентификатор копии элемента списка

    Описание

    Метод копирования элементов списка

    [ Top ]

    lists::del_lists

del_lists(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого списка

    Возвращает

    true в случае успешного удаления списка, false в противном случае

    Описание

    Метод удаления списка

    [ Top ]

    lists::del_lists_items

del_lists_items(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого элемента списка

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления элемента списка

    [ Top ]

    lists::GenXml4ListItems

GenXml4ListItems(
int
$list_id );

    Принимаемые параметры

    $list_id

    идентификатор списка

    Возвращает

    строка с XML или пустая строка

    Описание

    Метод генерирует XML для всех элементов списка.

    [ Top ]

    lists::GetList

GetList(
mixed
$id );

    Принимаемые параметры

    $id

    идентификатор выбираемого списка, если идентификатор равен false, то производится выбор информации о всех списках

    Возвращает

    с данными о выбранных списках

    Описание

    Метод выборки данных о списках

    [ Top ]

    lists::GetListItem

GetListItem(
int
$id, [array
$param = array()] );

    Принимаемые параметры

    $id

    идентификатор элемента списка

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с данными об элементе списка или false, если элемент не найден

    Описание

    Метод получения данные об элементе списка

    [ Top ]

    lists::GetListItemIfIssetValue

GetListItemIfIssetValue(
int
$list_id, string
$list_item_value );

    Принимаемые параметры

    $list_id

    идентификатор списка

    $list_item_value

    значение элемента списка

    Возвращает

    информация об элементе списка с таким значением, ложь, если элемента с данным значением не существует

    Описание

    Метод проверки наличия значения в списке

    [ Top ]

    lists::GetListItemsValuesById

GetListItemsValuesById(
int
$list_id );

    Принимаемые параметры

    $list_id

    идентификатор списка

    Возвращает

    с элементами списка или false

    Описание

    Метод возвращает элементы списка.

    [ Top ]

    lists::insert_lists

insert_lists(
int
$type, $lists_id
$lists_id, string
$lists_name, string_type
$lists_description, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных о списке (0 – вставка, 1 - обновление)

    $lists_name

    название списка

    $lists_description

    описание списка

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    $lists_id

    идентификатор списка, для которого обновляется информация

    Возвращает

    идентификатор вставленного/обновленного списка

    Описание

    Метод вставки/обновления данных о списке

    [ Top ]

    lists::insert_lists_items

insert_lists_items(
int
$type, int
$lists_items_id, int
$lists_id, int
$lists_items_value, [int
$lists_items_order = 0], mixed
$lists_items_description, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производится вставка или обновление данных об элементе списка (0 – вставка, 1 - обновление)

    $lists_items_id

    идентификатор элемента списка, для которого обновляется информация

    $lists_id

    идетификатор списка, к которому относится вставляемый/обновляемый элемент

    $lists_items_value

    значение элемента списка

    $lists_items_order

    порядок сортировки для элемента списка

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного/обновленного элемента списка

    Описание

    Метод вставки/обновления данных об элементе списка

    [ Top ]

    lists::SelectListsItems

SelectListsItems(
int
$list_id, [array
$property = array()] );

    Принимаемые параметры

    $list_id

    идентификатор списка

    $property

    дополнительные свойства
    $property['orderfield'] - поле сортировки, по умолчанию lists_items_order
    $property['ordertype'] - направление сортировки, по умолчанию

    Возвращает

    данных об элементах списка

    Описание

    Метод получения данных об элементах списка

    [ Top ]

    lists::select_lists_items

select_lists_items(
mixed
$id );

    Принимаемые параметры

    $id

    идентификатор выбираемого элемента. Если идетификатор = false или идентификатор = -1 - выбираются все элементы

    Возвращает

    данные об элементе списка

    Описание

    Метод получения данных об элементе списка

    [ Top ]

    lists::ShowList

ShowList(
int
$list_id, string
$xsl_name, [array
$external_propertys = array()] );

    Принимаемые параметры

    $list_id

    идентификатор списка, элементы которого необходимо отобразить

    $xsl_name

    название XSL-шаблона, используемого для отображения списка

    $external_propertys

    массив дополнительных парметров, добавляемых в XML

    Описание

    Метод отображения элементов списка

    [ Top ]

Описания переменных

  • $record_on_page = ON_PAGE [Строка 26]
    •

  • Data type: int
    •

    Описание

    Количество выводимых элементов на страницу

Описание констант класса

support@hostcms.ru


Docs For Class Maillist

Class Maillist

[Строка 11]

Размещен: /Maillist/Maillist.class.php

Описание

Класс модуля "Почтовые рассылки"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean CopyFascicle()

    Метод копирования выпуска рассылки

  • unknown DeleteUsers()

    Метод снятия подписки с подписчика

  • boolean DeleteUsersGroup()

    Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке

  • boolean DelFascicle()

    Метод удаления выпуска рассылки

  • boolean DelMaillist()

    Метод удаления рассылки

  • array GetFascicle()

    Метод возвращает информацию о почтовой рассылке

  • array GetMaillist()

    Метод возвращает ассоциативный массив с информацией о списке рассылок

  • выводит GetMaillistXML()

    Метод генерирующий XML для состояния подписки конкретного пользователя сайта

  • mixed InsertFascicle()

    Метод добавления/редактирования выпуска рассылки

  • boolean InsertMaillist()

    Метод добавления/редактирования информации о рассылке

  • boolean InsertUsers()

    Метод добавления/редактирования информации о подписчике

  • boolean InsertUsersGroup()

    Метод, открывающий доступ группе пользователей сайта к рассылке

  • boolean RenewMaillist()

    Метод обновления информации о подписке для конкретного подписчика

  • resource SelectFascicle()

    Метод получения данных о выпуске рассылки

  • resource SelectMaillist()

    Метод получения данных о рассылке

  • mixed SelectUser()

    Метод получения информации о состоянии подписки подписчика на рассылку

  • mixed SendFascicle()

    Метод отправки выпуска всем подписчикам рассылки

Унаследованные методы

Описания методов

    Maillist::CopyFascicle

CopyFascicle(
int
$fascicle_id );

    Принимаемые параметры

    $fascicle_id

    идентификатор выпуска рассылки

    Возвращает

    результат выполнения запроса на добавление

    Описание

    Метод копирования выпуска рассылки

    [ Top ]

    Maillist::DeleteUsers

DeleteUsers(
int
$user_id, int
$maillist_id );

    Принимаемые параметры

    $user_id

    идентификатор пользователя сайта

    $maillist_id

    идентификатор

    Описание

    Метод снятия подписки с подписчика

    [ Top ]

    Maillist::DeleteUsersGroup

DeleteUsersGroup(
int
$users_group_id, int
$maillist_id );

    Принимаемые параметры

    $users_group_id

    идентификатор группы пользователей

    $maillist_id

    идентификатор рассылки

    Возвращает

    результат выполнения запросов на удаление

    Описание

    Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке

    [ Top ]

    Maillist::DelFascicle

DelFascicle(
int
$id );

    Принимаемые параметры

    $id

    идентификатор выпуска рассылки

    Возвращает

    результат выполнения запроса на удаление

    Описание

    Метод удаления выпуска рассылки

    [ Top ]

    Maillist::DelMaillist

DelMaillist(
int
$id );

    Принимаемые параметры

    $id

    идентификатор рассылки

    Возвращает

    результат выполнения запросов на удаление

    Описание

    Метод удаления рассылки

    [ Top ]

    Maillist::GetFascicle

GetFascicle(
int
$maillist_fascicle_id );

    Принимаемые параметры

    $maillist_fascicle_id

    идентификатор рассылки

    Возвращает

    с информацией о рассылке или false

    Описание

    Метод возвращает информацию о почтовой рассылке

    [ Top ]

    Maillist::GetMaillist

GetMaillist(
int
$maillist_id );

    Принимаемые параметры

    $maillist_id

    идентификатор списка рассылок

    Возвращает

    с результатом выборки или false

    Описание

    Метод возвращает ассоциативный массив с информацией о списке рассылок

    [ Top ]

    Maillist::GetMaillistXML

GetMaillistXML(
int
$site_user_id, string
$xslname );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя сайта

    $xslname

    имя XSL шаблона

    Возвращает

    на экран HTML код

    Описание

    Метод генерирующий XML для состояния подписки конкретного пользователя сайта

    [ Top ]

    Maillist::InsertFascicle

InsertFascicle(
int
$maillist_id, int
$maillist_fascicle_id, int
$maillist_htmltotext, string
$maillist_fascicle_theme, string
$maillist_fascicle_text, string
$maillist_fascicle_html, [int
$users_id = false] );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $maillist_fascicle_id

    идентификатор выпуска рассылки, если вставка, то 0

    $maillist_htmltotext

    строить ли текстовую версию на основе HTML

    $maillist_fascicle_theme

    тема выпуска

    $maillist_fascicle_text

    текстовая версия выпуска

    $maillist_fascicle_html

    HTML версия выпуска

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    результат выполнение запроса:
      int идентификатор добавленного выпуска;
      boolean результат выполнения запроса на обновление

    Описание

    Метод добавления/редактирования выпуска рассылки

    [ Top ]

    Maillist::InsertMaillist

InsertMaillist(
int
$maillist_id, string
$maillist_name, string
$maillist_description, string
$maillist_sender_email, [int
$users_id = false] );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки (0 - добавляем, иначе - редактируем)

    $maillist_name

    нащвение рассылки

    $maillist_description

    описание рассылки

    $maillist_sender_email

    e-mail отправителя

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    результат выполнения запроса

    Описание

    Метод добавления/редактирования информации о рассылке

    [ Top ]

    Maillist::InsertUsers

InsertUsers(
int
$maillist_id, int
$site_user_id, int
$value );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $site_user_id

    идентификатор пользователя сайта

    $value

    тип подписки (0 - текст, 1 - HTML)

    Возвращает

    результат выполнения запроса на добавление/редактирование

    Описание

    Метод добавления/редактирования информации о подписчике

    [ Top ]

    Maillist::InsertUsersGroup

InsertUsersGroup(
int
$maillist_id, int
$site_users_group_id );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $site_users_group_id

    идентификатор группы пользователей

    Возвращает

    результат выполнения запроса на вставку

    Описание

    Метод, открывающий доступ группе пользователей сайта к рассылке

    [ Top ]

    Maillist::RenewMaillist

RenewMaillist(
int
$site_users_id, array
$array );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $array

    массив значений состояния подписки:
      $array['value'.$maillist_id] int тип подписки (0 - текст, 1 - HTML)

    Возвращает

    результат обновления состояния подписки

    Описание

    Метод обновления информации о подписке для конкретного подписчика

    [ Top ]

    Maillist::SelectFascicle

SelectFascicle(
int
$id );

    Принимаемые параметры

    $id

    идентификатор выпуска рассылки

    Возвращает

    результат выполнения запроса на выборку

    Описание

    Метод получения данных о выпуске рассылки

    [ Top ]

    Maillist::SelectMaillist

SelectMaillist(
int
$id );

    Принимаемые параметры

    $id

    идентификатор рассылки (-1 выбрать все рассылки)

    Возвращает

    результат выполнения запроса на выборку

    Описание

    Метод получения данных о рассылке

    [ Top ]

    Maillist::SelectUser

SelectUser(
int
$id, int
$maillist_id );

    Принимаемые параметры

    $id

    идентификатор пользователя сайта

    $maillist_id

    идентификатор рассылки

    Возвращает

    результат запроса на выборку:
      array массив данных о состоянии подписки  $result[0] Ф.И.О подписчика  $result[1] тип подписки (0 - текст, 1 - HTML)  boolean false если информация не найдена

    Описание

    Метод получения информации о состоянии подписки подписчика на рассылку

    [ Top ]

    Maillist::SendFascicle

SendFascicle(
int
$fascicle_id );

    Принимаемые параметры

    $fascicle_id

    идентификатор выпуска рассылки

    Возвращает

    результат отправки писем
      array результат успешной отправки:  $result[0] количество подписчиков;
      $result[1] количество успешных отправок  boolean false результат неудачной отправки

    Описание

    Метод отправки выпуска всем подписчикам рассылки

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class modules

Class modules

[Строка 20]

Размещен: /Modules/Modules.class.php

Описание

Класс модуля "Управление модулями"

Свойства класса

  • $count_row =

  • $error =

  • $record_on_page = ON_PAGE

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • resource del_module()

    Метод удаления информации о модуле

  • int insert_module()

    Метод вставки/обновления информации о модуле

  • boolean IssetModule()

    Метод проверки наличия активного модуля

  • resource select_modules()

    Метод получения информации о модуле

Унаследованные методы

Описания методов

    modules::del_module

del_module(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого модуля

    Возвращает

    результат запроса на удаление модуля

    Описание

    Метод удаления информации о модуле

    [ Top ]

    modules::insert_module

insert_module(
int
$type, int
$modules_id, string
$modules_name, string
$modules_description, string
$modules_status, string
$modules_path, int
$modules_order );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации о модуле (0 – вставка, 1 - обновление)

    $modules_id

    – идентификатор обновляемого модуля (при вставке равен 0)

    $modules_name

    - название модуля

    $modules_description

    – описание модуля

    $modules_status

    - флаг активности (доступности) модуля (1 – модуль активен (доступен), 0 – модуль неактивен)

    $modules_path

    – директория размещения модуля

    $modules_order

    – порядковый номер модуля в списке сортировки модулей

    Возвращает

    идентификатор добавляемого/редактируемого модуля

    Описание

    Метод вставки/обновления информации о модуле

    [ Top ]

    modules::IssetModule

IssetModule(
string
$module_path );

    Принимаемые параметры

    $module_path

    – название модуля, например Search

    Возвращает

    true - модуль существует и активен, false – модуль не существует или он не активен.

    Описание

    Метод проверки наличия активного модуля

    [ Top ]

    modules::select_modules

select_modules(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор модуля (если $id = -1 получаем информацию о всех модулях системы)

    Возвращает

    информация о модуле (модулях)

    Описание

    Метод получения информации о модуле

    [ Top ]

Описания переменных

  • $count_row =  [Строка 24]
    •

  • Data type: mixed
    •

  • $error =  [Строка 22]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [Строка 23]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class MySQL

Class MySQL

[Строка 19]

Размещен: /Kernel/Mysql.class.php

Описание

Ядро, класс для работы с MySQL

Свойства класса

  • $count_row =

  • $result =

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean db_connect()

    Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.

  • int get_count_row()

    Метод возвращает количество строк в последнем запросе

  • resource query()

    Метод выполнения SQL-запроса

  • resource select()

    Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()

Унаследованные методы

Описания методов

    MySQL::db_connect

db_connect(
 );

    Описание

    Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.

    [ Top ]

    MySQL::get_count_row

get_count_row(
 );

    Возвращает

    кличество строк, возвращенных последним запросом, выполненным методом select()

    Описание

    Метод возвращает количество строк в последнем запросе

    [ Top ]

    MySQL::query

query(
string
$query );

    Принимаемые параметры

    $query

    SQL-запрос

    Описание

    Метод выполнения SQL-запроса

    [ Top ]

    MySQL::select

select(
string
$query );

    Принимаемые параметры

    $query

    SQL-запрос

    Описание

    Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()

    [ Top ]

Описания переменных

  • $count_row =  [Строка 21]
    •

  • Data type: mixed
    •

  • $result =  [Строка 22]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class polls

Class polls

[Строка 10]

Размещен: /Polls/Polls.class.php

Описание

Класс модуля "Опросы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean DelPollsGroup()

    Метод удаления групп опросов

  • boolean del_poll()

    Метод удаления опроса

  • boolean del_poll_reply()

    Метод удаления варианта ответа

  • string GenXml4Poll()

    Метод формирования XML для опроса

  • void GetAllPollsGroups()

    Метод получения информации о всех группах опросов

  • int GetCountPolls()

    Метод получения числа опросов в группе

  • int GetCountPollsGroup()

    Метод получения числа групп опросов для одного или всех сайтов

  • mixed GetPoll()

    Метод возвращает данные об опросе

  • array GetPollsGroup()

    Метод получения информации о группе опросов

  • string get_polls_name()

    Метод получения названия опроса

  • bool IncPollReply()

    Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote

  • mixed InsertGroupPolls()

    Метод вставки информации о группе опросов

  • unknown InsertVote()

    Метод вставки ответа на опрос

  • mixed insert_poll()

    Метод осуществляет вставку и обновление опросов

  • int insert_poll_reply()

    Метод, осуществляет вставку и обновление вариантов ответов

  • resource SelectPollReply4Poll()

    Получение списка вариантов ответов на опрос

  • resource select_poll()

    Метод осуществляет выборку опросов

  • resource select_poll_reply()

    Метод выбора вариантов ответов

  • void ShowPoll()

    Метод отображения опроса

  • void ShowPollResult()

    Метод вывода результатов голосования

  • void ShowPolls()

    Метод отображения всех активных опросов

  • void ShowPollsGroup()

    Метод отображения групп опросов

  • bool SuccessVote()

    УСТАРЕВШИЙ МЕТОД. Метод определения права пользователя участвовать в голосовании и изменения статистики голосования, если пользователь имеет право участвовать в нем

  • mixed UpdateGroupPolls()

    Метод обновления информаци о группе опросов

  • void update_vote()

    УСТАРЕВШИЙ Метод обработки результата голосования

  • void vote_result()

    Устаревший метод

Унаследованные методы

Описания методов

    polls::DelPollsGroup

DelPollsGroup(
int
$polls_group_id );

    Принимаемые параметры

    $polls_group_id

    идентификатор удаляемой группы опросов

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод удаления групп опросов

    [ Top ]

    polls::del_poll

del_poll(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор удаляемого опроса

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод удаления опроса

    [ Top ]

    polls::del_poll_reply

del_poll_reply(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор удаляемого варианта ответа

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод удаления варианта ответа

    [ Top ]

    polls::GenXml4Poll

GenXml4Poll(
int
$poll_id, [array
$row = array()] );

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    $row

    ассоциативный массив с информацией о опросе

    Возвращает

    XML

    Описание

    Метод формирования XML для опроса

    [ Top ]

    polls::GetAllPollsGroups

GetAllPollsGroups(
mixed
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта, для групп опросов которого необходимо
     получить информацию, если $site_id = false, то получаем информацию группах опросов всех сайтов

    Описание

    Метод получения информации о всех группах опросов

    [ Top ]

    polls::GetCountPolls

GetCountPolls(
int
$group_id );

    Принимаемые параметры

    $group_id

    идентификатор группы

    Возвращает

    число опросов в группе

    Описание

    Метод получения числа опросов в группе

    [ Top ]

    polls::GetCountPollsGroup

GetCountPollsGroup(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта, для которого необходимо получить число групп опросов,
    если $site_id = false, то получаем число групп опросов всех сайтов

    Возвращает

    число групп опросов

    Описание

    Метод получения числа групп опросов для одного или всех сайтов

    [ Top ]

    polls::GetPoll

GetPoll(
int
$poll_id );

    Принимаемые параметры

    $poll_id

    – идентификатор опроса

    Возвращает

    ассоциативный массив с данными об опросе или false, если опрос не найден

    Описание

    Метод возвращает данные об опросе

    [ Top ]

    polls::GetPollsGroup

GetPollsGroup(
int
$polls_group_id );

    Принимаемые параметры

    $polls_group_id

    идентификатор группы опросов, о которой необходимо получить данные

    Возвращает

    ассоциативный массив с данными о группе опросов

    Описание

    Метод получения информации о группе опросов

    [ Top ]

    polls::get_polls_name

get_polls_name(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор опроса

    Возвращает

    название опроса, если запрос с таким идентификатором существует, или слово «Опросы» в противном случае

    Описание

    Метод получения названия опроса

    [ Top ]

    polls::IncPollReply

IncPollReply(
mixed
$poll_reply_id, int
$poll_id, [bool
$use_cookies = true] );

    Принимаемые параметры

    $poll_reply_id

    идентификатор ответа или массив идентификаторов ответов

    $poll_id

    идентификатор опроса

    $use_cookies

    использовать кукисы для защиты от повторного голосования

    Возвращает

    истина - голос принят, false - голос отвергнут

    Описание

    Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote

    [ Top ]

    polls::InsertGroupPolls

InsertGroupPolls(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров метода
    $param['site_id'] идентификатор сайта, которому принадлежит группа опросов
    $param['structure_id'] идентификатор узла структуры, в котором содержится обработчик
    $param['poll_group_name'] название группы опросов
    $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной группы в случае успешного выполнения, false - в противном случае

    Описание

    Метод вставки информации о группе опросов

    [ Top ]

    polls::InsertVote

InsertVote(
int
$poll_id, mixed
$vote );

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    $vote

    идентификатор ответа или массив с ответами на вопрос array(poll_reply_id['poll_reply_id3']=>'1',poll_reply_id['poll_reply_id5']=>'1')

    Описание

    Метод вставки ответа на опрос

    [ Top ]

    polls::insert_poll

insert_poll(
int
$type, int
$poll_id, mixed
$poll_group_id, string
$poll_name, int
$poll_type, int
$poll_vote_public, int
$poll_visible, string
$poll_begin_date, string
$poll_end_date, [int
$users_id = false], int
$poll_group, int
$structure_id, int
$site_id );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление опроса (0 – вставка, 1 - обновление)

    $poll_id

    идентификатор обновляемого опроса (при вставке нового опроса равен 0)

    $poll_group

    идентификатор группы опросов

    $poll_name

    название (заголовок) опроса

    $structure_id

    идентификатор структуры

    $site_id

    идентификатор сайта

    $poll_type

    тип опроса (0 – можно выбрать только один вариант ответа, 1- можно выбрать несколько вариантов ответа)

    $poll_vote_public

    параметр, определяющий показывать пользователю результаты голосования или нет (1 – показывать, 0 – не показывать)

    $poll_visible

    параметр, определяющий отображать опрос или нет (1 – отображать, 0 – не отображать)

    $poll_begin_date

    дата начала действия опроса

    $poll_end_date

    дата окончания действия опроса

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного или обновленного опроса в случае успешного выполнеия метода или false - в противном случае

    Описание

    Метод осуществляет вставку и обновление опросов

    [ Top ]

    polls::insert_poll_reply

insert_poll_reply(
int
$type, int
$poll_reply_id, string
$poll_id, string
$poll_reply_text, int
$poll_reply_number, int
$poll_reply_order, [int
$users_id = false] );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление варианта ответа

    $poll_reply_id

    – идентификатор обновляемого варианта ответа (при вставке нового варианта ответа равен 0)

    $poll_id

    – идентификатор опроса, к которому относится обновляемый/добавляемый вариант ответа

    $poll_reply_text

    – текст варианта ответа

    $poll_reply_number

    – количество голосов, отданных за данный вариант ответа

    $poll_reply_order

    – порядковый номер варианта ответа

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    or boolean идентификатор вставленного или обновленного варианта ответа в случае успешного выполнеия метода или false - в противном случае

    Описание

    Метод, осуществляет вставку и обновление вариантов ответов

    [ Top ]

    polls::SelectPollReply4Poll

SelectPollReply4Poll(
int
$poll_id );

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    Описание

    Получение списка вариантов ответов на опрос

    [ Top ]

    polls::select_poll

select_poll(
[int
$id = false] );

    Принимаемые параметры

    $id

    or boolean $id – идентификатор выбираемого опроса (по умолчанию равен false – выбираем все опросы)

    Описание

    Метод осуществляет выборку опросов

    [ Top ]

    polls::select_poll_reply

select_poll_reply(
[int
$id = false] );

    Принимаемые параметры

    $id

    or boolean $id – идентификатор выбираемого варианта ответа (по умолчанию равен false – выбираем все варианты ответов)

    Описание

    Метод выбора вариантов ответов

    [ Top ]

    polls::ShowPoll

ShowPoll(
string
$xsl_name, [int
$poll_id = false], [array
$external_propertys = array()] );

    Принимаемые параметры

    $xsl_name

    имя XSL–шаблона для отображения опроса

    $external_propertys

    ассоциативный массив внешних параметров

    $poll_id

    or boolean $poll_id идентификатор отображаемого опроса (по умолчанию равен false – опрос выбирается случайным образом)

    Описание

    Метод отображения опроса

    [ Top ]

    polls::ShowPollResult

ShowPollResult(
mixed
$poll_id, mixed
$xsl_name );

    Описание

    Метод вывода результатов голосования

    [ Top ]

    polls::ShowPolls

ShowPolls(
string
$xsl_name, int
$polls_on_page, int
$poll_begin, [array
$external_propertys = array()], [int
$site_id = CURRENT_SITE] );

    Принимаемые параметры

    $xsl_name

    – название XSL – шаблона для отображения опросов

    $polls_on_page

    – число опросов на страницу

    $poll_begin

    – номер опроса, с которого начинать отображать опросы

    $external_propertys

    - дополнительные св-ва

    $site_id

    - идентификатор сайта, по умолчанию равен CURRENT_SITE

    Описание

    Метод отображения всех активных опросов

    [ Top ]

    polls::ShowPollsGroup

ShowPollsGroup(
mixed
$group_id, mixed
$xsl_name, [array
$param = array()], [mixed
$external_propertys = array()], string
$xsl );

    Принимаемые параметры

    $group_id

    идентификатор группы, опросы которой необходимо показать, false - необходимо показать опросы всех групп данного сайта

    $xsl

    имя XSL-шаблона

    $param

    массив дополнительных параметров
    $param['order_field'] поле сортировки опросов
    $param['order_type'] направление сортировки ('asc' - по возрастанию, 'desc' - по убыванию, 'RAND()' - в произвольном порядке), по умолчанию $param['order_type'] = 'RAND()';
    $param['poll_begin'] порядковый номер опроса, с которого начинать показ списка опросов (по умолчанию $param['poll_begin'] = 0)
    $param['poll_count'] число показываемых опросов (по умолчанию $param['poll_count'] = 1)

    Описание

    Метод отображения групп опросов

    [ Top ]

    polls::SuccessVote

SuccessVote(
int
$poll_id );

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    Возвращает

    true, если пользователь имеет право участвовать в голосовании, false - в противном случае

    Описание

    УСТАРЕВШИЙ МЕТОД. Метод определения права пользователя участвовать в голосовании и изменения статистики голосования, если пользователь имеет право участвовать в нем

    [ Top ]

    polls::UpdateGroupPolls

UpdateGroupPolls(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров метода
    $param['poll_group_id'] идентификатор группы опросов
    $param['structure_id'] идентификатор узла структуры, в котором содержится обработчик
    $param['site_id'] идентификатор сайта, которому принадлежит группа опросов
    $param['poll_group_name'] название группы опросов
    $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор обновленной группы в случае успешного выполнения, false - в противном случае

    Описание

    Метод обновления информаци о группе опросов

    [ Top ]

    polls::update_vote

update_vote(
 );

    Описание

    УСТАРЕВШИЙ Метод обработки результата голосования

    [ Top ]

    polls::vote_result

vote_result(
 );

    Описание

    Устаревший метод

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class RssRead

Class RssRead

[Строка 7]

Размещен: /Kernel/RssRead.class.php

Описание

Ядро, класс для чтения RSS

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • array ReadRSS()

    Метод чтения данных из RSS потока

Унаследованные методы

Описания методов

    RssRead::ReadRSS

ReadRSS(
string
$url, [array
$param = array()] );

    Принимаемые параметры

    $url

    URL ресурса

    $param

    массив дополнительных параметров, необязательный параметр

    Возвращает

    ассоциативнй массив с инфомрацией о канале и элементах
    [chanel] => Array
     (
    [title] =>
    [link] =>
    [description] =>
    [image] => Array
    (
    [title] =>
    [link] =>
    [url] =>
    )
    )
    [items] => Array
    (
    [] => Array
    (
    [title] =>
    [link] =>
    [desc] =>
    [category] =>
    [pubdate] =>
    [yandex:full-text] =>
    )
    )
    [error] => Текст ошибки, если была

    Описание

    Метод чтения данных из RSS потока

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class RssWrite

Class RssWrite

[Строка 19]

Размещен: /Kernel/RssWrite.class.php

Описание

Ядро, класс для генерации RSS

Свойства класса

  • $record_on_page = ON_PAGE

        Количество в потоке

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string CreateRSS()

    Метод формирования XML-файла в стандарте RSS

Унаследованные методы

Описания методов

    RssWrite::CreateRSS

CreateRSS(
array
$rss_mas_header, array
$rss_mas_items, [array
$property = array()] );

    Принимаемые параметры

    $rss_mas_header

    массив, содержащий данные заголовка канала
    $rss_mas_items - массив, содержащий данные новостных заголовков
    $rss_mas_header['title'] - Заголовок канала
    $rss_mas_header['link'] - Ссылка на сайт
    $rss_mas_header['description'] - Краткое описание RSS-канала
    $rss_mas_header['image'] - Картинка для представления канала (необязательный элемент)
    $rss_mas_header['image']['url'] - Ссылка на файл изображения
    $rss_mas_header['image']['title'] - Заменяющий текст для изображения
    $rss_mas_header['image']['link'] - Ссылка для перехода при щелчке по изображению

    $rss_mas_items

    массив, соддержащий данные о элементах канала
    $rss_mas_items[]['title'] - Название новости
    $rss_mas_items[]['link'] - Ссылка на страничку, содержащую соответствующую новость
    $rss_mas_items[]['description'] - Краткое описание новости
    $rss_mas_items[]['pubDate'] - Дата публикации новости, ПРИНИМАЕТСЯ В ФОРМАТЕ SQL
    $rss_mas_items[]['enclosure'][0]['url'] - URL вложения
    $rss_mas_items[]['enclosure'][0]['type'] - type вложения, если явно не указан - определяется автоматически

    $property

    массив дополнительных параметров
    $property['yandex:full-text'] вывод полного текста для Яндекс, по умолчанию false

    Возвращает

    сгенерированный XML в формате RSS 2.0

    Описание

    Метод формирования XML-файла в стандарте RSS

    [ Top ]

Описания переменных

  • $record_on_page = ON_PAGE [Строка 50]
    •

  • Data type: int
    •

    Описание

    Количество в потоке

Описание констант класса

support@hostcms.ru


Docs For Class Search

Class Search

[Строка 7]

Размещен: /Search/Search.class.php

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void DeleteSearchInfomationForSite()

    Метод для удаления поисковой информации сайта

  • boolean Delete_search_words()

    Метод удаления из индекса страницы с указанным адресом

  • array GetLogStat()

    Метод для получения сгруппированной информации о поисковых запросах

  • void GetPageCount()

    Метод определения числа проиндексированных страниц

  • resource GetPageInfo()

    Метод получения информации о проиндексированных страницах

  • void GoSearch()

    Метод выводит результаты поиска запроса $query с помощью XSL-шаблона $xslname в соответствии с дополнительными параметрами

  • mixed InsertSearchInquiry()

    Метод для вставки запроса в журнал поисковых запросов

  • mixed SearchWords()

    Поиск списка слов в индексе

Унаследованные методы

Описания методов

    Search::DeleteSearchInfomationForSite

DeleteSearchInfomationForSite(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Описание

    Метод для удаления поисковой информации сайта

    [ Top ]

    Search::Delete_search_words

Delete_search_words(
string
$page_address );

    Принимаемые параметры

    $page_address

    адрес удаляемой из индекса страницы

    Возвращает

    результат выполнения запроса

    Описание

    Метод удаления из индекса страницы с указанным адресом

    [ Top ]

    Search::GetLogStat

GetLogStat(
string
$date_from, string
$date_to, [string
$limit = ''], [array
$param = array()] );

    Принимаемые параметры

    $date_from

    дата, с которой начинать выборку

    $date_to

    дата, которой заканичивать выборку

    $limit

    ограничение

    $param

    ассоциативный массив параметров
    string $param['site_id'] идентификтор сайта, по которому выводить статистику, если не передан - статистика по всем сайтам

    Возвращает

    с результатом выборки либо false

    Описание

    Метод для получения сгруппированной информации о поисковых запросах

    [ Top ]

    Search::GetPageCount

GetPageCount(
[int
$site_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта, по умолчанию false

    Описание

    Метод определения числа проиндексированных страниц

    [ Top ]

    Search::GetPageInfo

GetPageInfo(
[int
$page_id = false] );

    Принимаемые параметры

    $page_id

    идентификатор страницы
      (если равен false, то возвращает информацию обо всех проиндексированных страницах)

    Описание

    Метод получения информации о проиндексированных страницах

    [ Top ]

    Search::GoSearch

GoSearch(
string
$query, string
$xslname, array
$property );

    Принимаемые параметры

    $query

    текст поискового запроса

    $xslname

    имя XSL шаблона

    $property

    массив дополнительных параметров
    $property['current_page'] номер отображаемой страницы
    $property['items_on_page'] количество записей на странице

    Описание

    Метод выводит результаты поиска запроса $query с помощью XSL-шаблона $xslname в соответствии с дополнительными параметрами

    [ Top ]

    Search::InsertSearchInquiry

InsertSearchInquiry(
array
$param );

    Принимаемые параметры

    $param

    массив с доп. параметрами
     int $param['search_log_text'] текст поискового запроса
     int $param['site_users_id'] идентификатор пользователя сайта, сделавшего запрос,
     если не установлен - берется текущий пользователь
     int $param['site_id'] идентификатор сайта, с которого произвели запрос,
     если не установлен - берется текущий сайт
     int $param['search_log_datetime'] дата/время вставки запроса
     int $param['search_log_ip'] IP-адрес с которого сделали запрос

    Возвращает

    идентификатор вставленного запроса либо false

    Описание

    Метод для вставки запроса в журнал поисковых запросов

    [ Top ]

    Search::SearchWords

SearchWords(
string
$terms, [array
$param = array('len' => 200)] );

    Принимаемые параметры

    $terms

    поисковой запрос

    $param

    массив дополнительных параметров:
      $param['site_user_id'] int идентификатор пользователя сайта для определения прав доступа;
      $param['current_page'] int номер текущей страницы результатов поиска;
      $param['items_on_page'] int количество записей на странице;
      $param['len']=200 int максимальная длина поискового запроса;
      $param['site_id'] int идентификатор сайта, по которому производится поиск.  Если необходим поиск по текущему сайту, а не по всем сайтам, поддерживаемых системой,  укажите дополнительный параметр в следующей редакции: array('site_id'=>CURRENT_SITE ...)

    Возвращает

    результат поиска:
      array массив страниц:
      $result[$i]['search_page_name'] string название страницы;
      $result[$i]['search_page_address'] string адрес страницы;
      $result[$i]['search_page_date'] string дата индексации;
      $result[$i]['search_page_size'] float размер страницы;
      boolean false если ничего не найдено

    Описание

    Поиск списка слов в индексе

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class shop

Class shop

[Строка 10]

Размещен: /shop/shop.class.php

Описание

Класс модуля "Интернет-магазин"

Свойства класса

  • $CacheModificationItems =

        Массив ID модификаций товара для товаров

  • $cache_mesure =

        Кэш информации о единицах измерений

  • $cache_producer =

        Кэш информации о производителях

  • $count_row_city_areas =  0

        Количество выбранных районов города

  • $error =

  • $hidden =  ""

  • $item_catalog_price =  0

        Цена товара магазина

  • $MasGroup = array()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed AddIntoCart()

    Метод помещения товара в корзину

  • mixed AssignGroupImage()

    Метод для установки имени изображения для группы товаров

  • mixed AssignItemImage()

    Метод для установки имени изображения для товара

  • mixed AssignShopWatermark()

    Метод осуществляющий обновление данных о файле watermark'a для магазина

  • void ClearCookieAndSessionCart()

    Метод для очистки корзины кукисов и сессий

  • unknown ClearPath()

    Метод очищает путь от запрещенных символов

  • float ConvertPrice()

    Конвертирует цену в различных форматах к цене в формате xxxx.yy

  • array CorrectPropertiesItem()

    Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.

  • mixed CreateDirectory()

    Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает

  • void DeleteAllItemsCatalogAndGroups()

    Метод очистки таблиц товаров и групп

  • array DeleteCart()

    Метод, осуществляющий удаление товара из корзины

  • bool DeleteCity()

    Метод, осуществляющий удаление города

  • boolean DeleteCityArea()

    Метод удаления района города

  • mixed DeleteComment()

    Метод удаления информации об отзыве на товар

  • mixed DeleteCompany()

    Метод удаления информации об организации

  • array DeleteCondOfDelivery()

    Метод, осуществляющий удаление условия доставки

  • array DeleteCountry()

    Метод, осуществляющий удаление страны

  • mixed DeleteCoupon()

    Метод для удаления информации о купоне

  • resourse_or_false DeleteCurrency()

    Метод, осуществляющий удаление валюты

  • array DeleteDiscount()

    Метод, осуществляющий удаление скидки

  • boolean DeleteGroup()

    Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)

  • array DeleteItem()

    Метод, осуществляющий удаление товара

  • resource DeleteItemDiscount()

    Метод удаления скики для товара

  • array DeleteLocation()

    Метод, осуществляющий удаление области

  • array DeleteMesure()

    Метод, осуществляющий удаление единицы измерения

  • array DeleteOrder()

    Метод, осуществляющий удаление заказа

  • mixed DeleteOrderDiscount()

    Метод для удаления информации о скидке для заказов

  • array DeleteOrderItems()

    Метод, осуществляющий удаление товара в заказе

  • array DeleteOrderStatus()

    Метод, осуществляющий удаление статуса заказа

  • array DeletePrice()

    Метод, осуществляющий удаление типа цены

  • int DeletePriceForItem()

    Метод удаляет цену для элемента каталога

  • unknown DeletePricesForAllItem()

    Метод удаляет все цены для элемента каталога

  • array DeleteProducer()

    Метод, осуществляющий удаление производителя

  • boolean DeletePropertiesItem()

    Удаление информации о свойстве товара

  • array DeletePropretyOfItems()

    Метод, осуществляющий удаление свойства товара

  • mixed DeleteSeller()

    Метод, осуществляющий удаление продавца.

  • array DeleteShop()

    Метод, осуществляющий удаление магазина

  • void DeleteShopWatermark()

  • array DeleteSystemOfPay()

    Метод, осуществляющий удаление платёжной системы

  • array DeleteTax()

    Метод, осуществляющий удаление налога

  • array DeleteTyingProducts()

    Метод удаления сопутствующих товаров

  • boolean DeleteTypeOfDelivery()

    Метод, осуществляющий удаление типа доставки

  • void ExecSystemsOfPayHandler()

    Метод выполнения обработчика платежной системы

  • void FillMasGroup()

    Метод формирования массива групп самого верхнего уровня для данного магазина

  • void FillMemCacheComments()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

  • void FillMemCacheCountItemsAndGroup()

    Метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.

  • void FillMemCacheDiscountsForItem()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.

  • void FillMemCacheGoupsIdTree()

    Метод формирует дерево групп и подгрупп в массиве по их идентификаторам

  • void FillMemCacheModificationItems()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

  • void FillMemCachePropertiesItem()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.

  • void FillMemCacheTyingProducts()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

  • string GenXml4Comment()

    Метод генерирующий XML для отзыва о товаре

  • string GenXml4Company()

    Метод генерирует XML для организации

  • str GenXml4CompareItems()

    Метод генерирует xml для товаров, выбранных для сравнения

  • void GenXML4Currency()

    Метод генерирует XML для указанной валюты

  • string GenXml4Item()

    Метод построения XML для товара, его свойств и сопутствующих товаров

  • int GenXml4ItemCatalogCommentAverageGrade()

    Метод возвращает среднею оценку по товару.

  • string GenXml4ItemCatalogComments()

    Метод возвращает все комментарии, относящиеся к данному товару.

  • str GenXml4Mesures()

    Метод генерирует XML для единиц измерения

  • str GenXml4OrderStatus()

    Метод генерирует XML для статуса доставки

  • string GenXml4Properties()

    Метод построения XML для свойств.

  • str GenXml4Property()

    Возвращает XML свойства.

  • str GenXml4Saller()

    Возвращает XML продавца.

  • string GenXml4Sallers()

    Метод построения XML для продавцов.

  • void GenXml4Shop()

  • mixed GenXmlProducerList()

    Метод генерирует XML для списка продавцов магазина

  • unknown GetAllCity()

    Enter description here...

  • mixed GetAllCityArea()

    Метод выборки всех районов города

  • array GetAllComments()

    Метод возвращает список всех комментариев

  • mixed GetAllCompanies()

    Метод для получения списка всех компаний

  • resource GetAllCondOfDelivery()

    Метод выборки всех условий доставки

  • void GetAllCountries()

  • resource GetAllCoupons()

    Метод возвращает список купонов по заданным условиям

  • mixed GetAllCurrency()

    Метод выборки информации обо всех валютах

  • mixed GetAllDiscounts()

    Метод возвращает список всех скидок

  • mixed GetAllDiscountsForItem()

    Метод извлечения информации обо всех скидках для данного товара

  • array GetAllGroups()

    Метод получения всех групп магазина

  • mixed GetAllItems()

    Метод получения всех товаров заданного магазина и заданной группы товаров

  • mixed GetAllItemsForOrder()

    Метод получения заказанных товаров

  • resource GetAllListProperties()

    Метод получения всех дополнительных свойств для магазина

  • resource GetAllLocation()

    Метод получения списка всех областей (штатов)

  • resource GetAllMesures()

    Метод выборки всех единиц измерения

  • mixed GetAllModificationItems()

    Метод возвращает информацию обо всех модификациях данного товара

  • resource GetAllOrderDiscounts()

    Метод для извлечения информации обо всех скидках

  • mixed GetAllOrders()

    Метод выборки заказов для магазина

  • mixed GetAllOrderStatus()

    Метод получения информации обо всех статусах заказаов

  • mixed GetAllPricesForItem()

    Метод получения информации о ценах, заданных для товара

  • mixed GetAllPricesForShop()

    Метод получения списка цен для магазина

  • resource GetAllProducers()

    Метод получения информации обо всех производителях

  • mixed GetAllPropertiesItem()

    Метод извлечения информации о дополнительных свойствах заданного товара

  • resource GetAllSellers()

    Метод получения информации о всех продавцах магазина $shop_id, если $shop_id = false,  то о продавцах всех магазинов

  • resource GetAllShops()

    Метод для получения списка всех магазинов

  • resource GetAllSystemOfPay()

    Метод получения всех активных платежных систем

  • resource GetAllTax()

    Метод получения информации о налогах

  • resource GetAllTypeOfDelivery()

    Метод выборки всех типов доставки для конкретного магазина

  • array GetCart()

    Метод, осуществляющий извлечение корзины

  • array GetCity()

    Метод, осуществляющий извлечение города

  • array GetComment()

    Метод возвращает информацию о комментарии к товару

  • mixed GetCompany()

    Метод для получения информации об организации

  • array GetCondOfDelivery()

    Метод, осуществляющий извлечение условия доставки

  • mixed GetCondOfDeliveryXml()

    Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)

  • void GetCookieExpires()

    Метод возвращает время истечения данных в корзине, хранящейся в кукисах.

  • mixed GetCountCity()

    Метод получения числа городов для области

  • mixed GetCountCountry()

    Метод получения числа стран

  • mixed GetCountCurrency()

    Метод получения числа валют в справочнике

  • mixed GetCountDiscount()

    Метод получения числа скидок для магазина

  • array GetCountItemsAndGroups()

    Метод получения числа элементов и групп для переданной родительской группы

  • mixed GetCountItemsCatalog()

    Метод получения числа товаров в одном или во всех разделах магазина

  • mixed GetCountItemsWithConditions()

    Метод получения числа товаров, параметры которых удовлетворяют заданным условиям

  • mixed GetCountLocation()

    Метод получения числа областей (штатов) для страны

  • mixed GetCountMesures()

    Метод получения числа единиц измерения в справочнике

  • mixed GetCountOrder()

    Метод выборки количества заказов для магазина

  • mixed GetCountOrderStatus()

    Метод получения числа статусов заказа

  • mixed GetCountProducers()

    Метод получения числа производителей для данного магазина

  • mixed GetCountProperties()

    Метод получения числа свойств товаров конкретного магазина

  • array GetCountry()

    Метод, осуществляющий извлечение страны

  • mixed GetCountSellers()

    Метод получения числа продавцов в справочнике

  • mixed GetCountShops()

    Метод получения числа магазинов для одного или всех сайтов, обслуживаемых системой управления

  • mixed GetCountSystemOfPay()

    Метод получения числа систем оплаты

  • mixed GetCountTax()

    Метод получения числа налогов в справочнике

  • mixed GetCountTypeOfDelivery()

    Метод получения числа типов доставок для данного магазина

  • mixed GetCountTypePrices()

    Метод получения числа типов цен для магазина

  • mixed GetCoupon()

    Метод возвращает массив с информацией о купоне

  • mixed GetCouponByText()

    Возвращает информацию о купоне по его тексту

  • mixed GetCurrency()

    Метод, осуществляющий извлечение информации о валюте

  • float GetCurrencyCoefficientToShopCurrency()

    Метод определения коэффициента пересчета валюты товара в валюту магазина

  • mixed GetCurrencyForShop()

    Метод получения валюты, указанной по умолчанию для магазина

  • mixed GetCurrencyXml()

    Метод формирования xml для валюты

  • mixed GetDefaultCurrency()

    Метод получения информации о базовой валюте

  • mixer GetDefaultOrderStatus()

    Метод получения статуса заказа, установленного по умолчанию

  • array GetDelimitedGroups()

    Метод формирования дерева групп для магазина.

  • array GetDiscount()

    Метод, осуществляющий извлечение информации о скидке

  • array_or_false GetGroup()

    Метод, осуществляющий извлечение информации о группе

  • $resource GetGroups()

    Метод возвращает список групп магазина

  • array GetGroupsTree()

    Метод получения массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской

  • unknown GetGroupsXmlTree()

    Метод построения дерева xml для групп

  • mixed GetGroupWithPath()

    Метод получения информации о группе по пути, если такая существует в данной подгруппе магазина

  • mixed GetGroupWithValue()

    Метод получения информации о группе по наименованию, если такая существует в данной подгруппе магазина

  • array GetItem()

    Метод, осуществляющий извлечение информации о товаре

  • resource GetItemByParam()

    Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента

  • array_or_false GetItemDiscount()

    Метод получения информации о скидке на товар

  • int GetItemFromCart()

    Метод получения информации о товаре из корзины для пользователя

  • array GetItemPath()

    Метод определения идентификатора группы товаров и идентификатора товара по значению URL

  • array GetItemsFromCart()

    Метод получения товаров, находящихся в корзине

  • void GetItemsFromCookiesToCart()

    Метод перемещения информации о заказанном товаре в таблицу корзины

  • string GetItemsXmlTree()

    Метод построения XML для товаров

  • mixed GetItemXml()

    Метод формирования xml товара

  • array GetLocation()

    Метод, осуществляющий извлечение области

  • void GetMasGroupToRoot()

  • array GetMesure()

    Метод, осуществляющий извлечение информации о единице измерения

  • array GetOrder()

    Метод, осуществляющий извлечение заказа

  • mixed GetOrderDiscount()

    Метод возвращает информацию о скидке для заказов

  • float GetOrderDiscountForSum()

    Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина

  • resource GetOrderDiscountWithConditions()

    Метод возвращает список скидок на сумму заказа по заданным условиям

  • mixed GetOrderInfoArray()

    Метод формирования массива с информацией о заказе для вставки в заказы

  • array GetOrderItem()

    Метод, осуществляющий извлечение товара из заказа

  • resource GetOrderItems()

    Метод, осуществляющий извлечение товаров из заказа

  • array GetOrdersStatus()

    Метод, осуществляющий извлечение состояния заказа

  • string GetOrderXml()

    Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных

  • string GetPathGroup()

    Метод формирования пути по группам товара

  • void GetPathProducer()

  • array GetPrice()

    Метод, осуществляющий извлечение типа цены

  • array GetPriceForItem()

    Метод определения наличия указанной цены для заданного товара

  • array GetPriceForUser()

    Метод определения цены товара для заданного пользователя

  • array GetProducer()

    Метод, осуществляющий извлечение информации о производителе

  • array GetPropertiesOfGroup()

    Метод для получения списка идентификаторов свойств товаров для определенной группы.

  • mixed GetPropertiesOfGroupForXml()

    Возвращает список свойств, разврешенных для вывода в XML

  • array GetPropretyOfItems()

    Метод, осуществляющий извлечение свойства товара (по идентификатору таблицы связи свойств и товаров)

  • array GetSeller()

    Метод получения информации о продавце по его идентификатору.

  • array GetShop()

    Метод, осуществляющий извлечение информации о магазине

  • mixed GetShopCurrency()

    Метод получения информации о валюте магазина

  • resource GetShopDiscount()

    Метод получения списка скидок для магазина

  • array GetShopGroupsToRoot()

    Метод получения массива с данными о каталогах магазина, начиная с данной и до корневой

  • mixed GetShopWhithStructureId()

    Метод выбора информации о магазине данного узла структуры сайта

  • mixed GetSystemOfPay()

    Метод, осуществляющий извлечение платёжной системы

  • array GetTax()

    Метод, осуществляющий извлечение налога

  • array GetTyingProducts()

    Метод получения информации о сопутствующем товаре

  • array GetTyingProductsForItem()

    Метод получения ID сопутствующих товаров для заданного товара

  • array GetTypeOfDelivery()

    Метод, осуществляющий извлечение типа доставки

  • array GetTypeOfDeliveryForOrder()

    Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.

  • mixed GetValueItemProperty()

    Метод получения значения дополнительного свойства для товара

  • mixed GetXmlForItemsOrder()

    Метод формирования xml для товаров в заказе

  • string GetXmlForOrder()

    Метод формирования xml о заказе по идентификатору заказа

  • void GetXmlProducer()

  • void IndexationShopItems()

  • int InsertCity()

    Метод, осуществляющий вставку города

  • int InsertCityArea()

    Метод добавления/редактирования информации о районе города

  • mixed InsertComment()

    Метод добавления/обновления информации об отзыве на товар

  • mixed InsertCompany()

    Метод для вставки/обновления организации

  • int InsertCondOfDelivery()

    Метод, осуществляющий вставку условия доставки

  • int InsertCountry()

    Метод, осуществляющий вставку области

  • mixed InsertCoupon()

    Метод для вставки/обновления информации о купоне

  • int_or_false InsertCurrency()

    Метод,осуществляющий вставку информации о валюте

  • array InsertDiscount()

    Метод, осуществляющий вставку  информации о скидке

  • mixed InsertGroup()

    Метод, осуществляющий вставку группы, к которой могут относиться товары

  • int InsertItem()

    Метод, осуществляющий вставку информации о товаре

  • int_or_false InsertItemDiscount()

    Метод вставки скидки для определенного товара

  • int InsertLocation()

    Метод, осуществляющий вставку области

  • array InsertMesure()

    Метод, осуществляющий вставку  информации о единице измерения

  • int InsertOrder()

    Метод, осуществляющий вставку заказа

  • mixed InsertOrderDiscount()

    Метод для вставки/обновления информации о скидке для заказов

  • int InsertOrderItems()

    Метод, осуществляющий вставку товара в заказ

  • int InsertOrderStatus()

    Метод, осуществляющий вставку статуса заказа

  • void InsertOrderWithoutSystemOfPay()

    Метод вставки заказа, если платежная система не выбрана

  • int InsertPrice()

    Метод, осуществляющий вставку типа цены

  • mixed InsertPricesToItem()

    Метод вставки связи товара и цены из справочника цен

  • int InsertProducer()

    Метод, осуществляющий вставку производителя

  • int InsertPropertiesItem()

    Метод вставки информации о дополнительных свойствах товра

  • mixed InsertPropretyOfItems()

    Метод, осуществляющий вставку свойства товара

  • int InsertSeller()

    Метод, осуществляющий вставку или обновление продавца.

  • int InsertShop()

    Метод, осуществляющий вставку  информации о магазине

  • int InsertSystemOfPay()

    Метод, осуществляющий вставку платёжной системы

  • int InsertTax()

    Метод, осуществляющий вставку налога

  • mixed InsertToCart()

    Метод добавления информации о товаре в таблицу корзины

  • unknown InsertTyingProducts()

    Метод добавления информации о сопутствующем товаре

  • int InsertTypeOfDelivery()

    Метод, осуществляющий вставку типа доставки

  • bool IsOrderOfThisSiteUser()

    Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта

  • int ProcessOrder()

    Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты

  • array SelectAllItemsFromCartForUser()

    Метод получения количества элементов и их общей цены для заданного пользователя

  • void SelectAllItemsFromCookieCart()

    Метод получения общего количества товаров, их общей стоимости и веса из корзины
    (в случае, когда пользователь не задан и данные корзины хранятся в кукисах)

  • mixed SelectCityArea()

    Метод получения информации о районе города (обо всех районах при $city_area_id=-1)

  • array SelectPrice()

    Метод определения цены для заданной группы пользователей

  • bool SendMailAboutOrder()

    Метод отправки писем о поступившем заказе пользователю и администратору

  • void ShowAddress()

    Метод показа адреса для заказчика

  • void ShowCart()

    Метод показа содержимого корзины

  • void ShowConfirmation()

    Метод вывода сообщения о необходимости подтвердить аккаунт

  • void ShowEnter()

    Метод вывода формы для авторизации пользователя

  • unknown ShowItem()

    Метод вывода информации об элементе

  • false ShowItemsCompare()

    Метод отображает сравнение выбранных товаров в магазине

  • void ShowPriceList()

  • void ShowProducer()

  • bool ShowProducersList()

    Метод формирования xml для производителей	 *

  • void ShowSaller()

    Метод для отображение информации о продавце в клиентской части

  • void ShowShop()

    Метод показа магазина

  • void ShowSystemOfPay()

    Метод построения XML для платежных систем

  • void ShowTypeOfDelivery()

    Метод выбора и показа типов доставки

  • false ShowUserOrders()

    Метод отображает информацию о заказах пользователя

  • void show_link_location()

  • mixed UpdateCart()

    Метод, осуществляющий обновление данных корзины

  • array UpdateCity()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление города

  • array UpdateCondOfDelivery()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки

  • array UpdateCountry()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление страны

  • int_or_false UpdateCurrency()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()

  • array UpdateDiscount()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке

  • int_or_false UpdateGroup()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары

  • boolean UpdateImageForItem()

    Метод обновления информации об изображении для товара

  • array UpdateItem()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о товаре

  • int_or_false UpdateItemDiscount()

    УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара

  • unknown UpdateItemPrice()

    Метод обновления связи товара и цены

  • array UpdateLocation()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление области

  • array UpdateMesure()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения

  • array UpdateOrder()

    Метод, осуществляющий обновление заказа

  • mixed UpdateOrderItems()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе

  • mixed UpdateOrderPropretyOfItems()

    Метод изменения порядка сортировки дополнительных свойств товара

  • array UpdatePrice()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены

  • mixed UpdatePricesToItem()

    Метод обновления дополнительной цены для элемента

  • array UpdateProducer()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе

  • int UpdatePropertiesItem()

    Метод обновления информации о дополнительных свойствах товара

  • mixed UpdatePropretyOfItems()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара

  • void UpdateShop()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине

  • array UpdateSystemOfPay()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы

  • array UpdateTax()

    Метод, осуществляющий обновление налога

  • array UpdateTyingProducts()

    УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах

  • array UpdateTypeOfDelivery()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки

  • string YandexMarket()

    Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и возвращает XML данные.

Унаследованные методы

Описания методов

    shop::AddIntoCart

AddIntoCart(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    $param['shop_id'] int идентификатор магазина
    $param['item_id'] int идентификатор товара
    $param['user_id'] int идентификатор пользователя
    $param['count'] int количество товара
    $param['postpone'] int флаг, указывающия на то, является ли данный товар отложенным

    Возвращает

    идентификатор записи таблицы корзины, id товара, если пользователь не указан, ложь - в случае возникновения ошибки

    Описание

    Метод помещения товара в корзину

    [ Top ]

    shop::AssignGroupImage

AssignGroupImage(
int
$shop_groups_id, string
$shop_groups_image );

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы товаров

    $shop_groups_image

    название картинки

    Возвращает

    название картинки или false

    Описание

    Метод для установки имени изображения для группы товаров

    [ Top ]

    shop::AssignItemImage

AssignItemImage(
int
$shop_items_catalog_item_id, string
$shop_items_catalog_image );

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $shop_items_catalog_image

    название картинки

    Возвращает

    название картинки или false

    Описание

    Метод для установки имени изображения для товара

    [ Top ]

    shop::AssignShopWatermark

AssignShopWatermark(
int
$shop_shops_id, [string
$shop_watermark_ext = false] );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $shop_watermark_ext

    имя расширения файла watermark'a, если false - очищаем имя файла

    Возвращает

    строку с именем файла или false

    Описание

    Метод осуществляющий обновление данных о файле watermark'a для магазина

    [ Top ]

    shop::ClearCookieAndSessionCart

ClearCookieAndSessionCart(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    Описание

    Метод для очистки корзины кукисов и сессий

    [ Top ]

    shop::ClearPath

ClearPath(
unknown_type
$path );

    Принимаемые параметры

    $path

    Описание

    Метод очищает путь от запрещенных символов

    [ Top ]

    shop::ConvertPrice

ConvertPrice(
string
$price );

    Принимаемые параметры

    $price

    цена

    Возвращает

    отформатированная цена

    Описание

    Конвертирует цену в различных форматах к цене в формате xxxx.yy

    [ Top ]

    shop::CorrectPropertiesItem

CorrectPropertiesItem(
array
$row );

    Принимаемые параметры

    $row

    данные о дополнительном свойстве

    Возвращает

    откорректированне данные

    Описание

    Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.

    [ Top ]

    shop::CreateDirectory

CreateDirectory(
int
$shop_shops_id, string
$dir_name, [bool
$link_path = false], [bool
$create = true] );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $dir_name

    директория, которую необходимо создать

    $link_path

    выводиь путь для отображения в ссылке

    $create

    создавать каталог, если он не существует

    Возвращает

    созданая или уже существующая директория, либо false, если не удалось создать.

    Описание

    Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает

    [ Top ]

    shop::DeleteAllItemsCatalogAndGroups

DeleteAllItemsCatalogAndGroups(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Описание

    Метод очистки таблиц товаров и групп

    [ Top ]

    shop::DeleteCart

DeleteCart(
array
$param );

    Принимаемые параметры

    $param

    массив с данными
     $param['shop_id'] - идентификатор магазина
     $param['user_id'] - идентификатор пользователя
     $param['item_id'] - идентификатор элемента

    Возвращает

    возвращает результат удаления корзины

    Описание

    Метод, осуществляющий удаление товара из корзины

    [ Top ]

    shop::DeleteCity

DeleteCity(
int
$shop_city_id );

    Принимаемые параметры

    $shop_city_id

    идентификационный города

    Описание

    Метод, осуществляющий удаление города

    [ Top ]

    shop::DeleteCityArea

DeleteCityArea(
int
$id );

    Принимаемые параметры

    $id

    идентификатор района

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления района города

    [ Top ]

    shop::DeleteComment

DeleteComment(
int
$shop_comment_id );

    Принимаемые параметры

    $shop_comment_id

    идентификатор отзыва

    Возвращает

    результат выполнения запроса

    Описание

    Метод удаления информации об отзыве на товар

    [ Top ]

    shop::DeleteCompany

DeleteCompany(
int
$shop_company_id );

    Принимаемые параметры

    $shop_company_id

    идентификатор организации

    Возвращает

    результат выполнения запроса

    Описание

    Метод удаления информации об организации

    [ Top ]

    shop::DeleteCondOfDelivery

DeleteCondOfDelivery(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер условия доставки

    Возвращает

    возвращает результат удаления условия доставки

    Описание

    Метод, осуществляющий удаление условия доставки

    [ Top ]

    shop::DeleteCountry

DeleteCountry(
mixed
$country_id, int
$id );

    Принимаемые параметры

    $id

    идентификационный номер страны

    Возвращает

    возвращает результат удаления страны

    Описание

    Метод, осуществляющий удаление страны

    [ Top ]

    shop::DeleteCoupon

DeleteCoupon(
int
$shop_coupon_id );

    Принимаемые параметры

    $shop_coupon_id

    идентификатор купона

    Возвращает

    результат выполнения запроса

    Описание

    Метод для удаления информации о купоне

    [ Top ]

    shop::DeleteCurrency

DeleteCurrency(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер валюты

    Возвращает

    возвращает результат удаления валюты ( false при неудачном удалении)

    Описание

    Метод, осуществляющий удаление валюты

    [ Top ]

    shop::DeleteDiscount

DeleteDiscount(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер скидки

    Возвращает

    возвращает результат удаления скидки

    Описание

    Метод, осуществляющий удаление скидки

    [ Top ]

    shop::DeleteGroup

DeleteGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификтаор группы товаров

    Возвращает

    истину при удачном обновлении, ложь - в обратном случае

    Описание

    Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)

    [ Top ]

    shop::DeleteItem

DeleteItem(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер товара

    Возвращает

    возвращает результат удаления товара

    Описание

    Метод, осуществляющий удаление товара

    [ Top ]

    shop::DeleteItemDiscount

DeleteItemDiscount(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемой записи

    Возвращает

    возвращает результат удаления

    Описание

    Метод удаления скики для товара

    [ Top ]

    shop::DeleteLocation

DeleteLocation(
mixed
$shop_location_id, int
$id );

    Принимаемые параметры

    $id

    идентификационный номер области

    Возвращает

    возвращает результат удаления области

    Описание

    Метод, осуществляющий удаление области

    [ Top ]

    shop::DeleteMesure

DeleteMesure(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер единицы измерения

    Возвращает

    возвращает результат удаления единицы измерения

    Описание

    Метод, осуществляющий удаление единицы измерения

    [ Top ]

    shop::DeleteOrder

DeleteOrder(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер заказа

    Возвращает

    возвращает результат удаления заказа

    Описание

    Метод, осуществляющий удаление заказа

    [ Top ]

    shop::DeleteOrderDiscount

DeleteOrderDiscount(
int
$shop_order_discount_id );

    Принимаемые параметры

    $shop_order_discount_id

    идентификатор скидки

    Возвращает

    результат выполнения запроса

    Описание

    Метод для удаления информации о скидке для заказов

    [ Top ]

    shop::DeleteOrderItems

DeleteOrderItems(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер товара в заказе

    Возвращает

    возвращает результат удаления товара в заказе

    Описание

    Метод, осуществляющий удаление товара в заказе

    [ Top ]

    shop::DeleteOrderStatus

DeleteOrderStatus(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер статуса заказа

    Возвращает

    возвращает результат удаления статуса заказа

    Описание

    Метод, осуществляющий удаление статуса заказа

    [ Top ]

    shop::DeletePrice

DeletePrice(
mixed
$prices_id, int
$id );

    Принимаемые параметры

    $id

    идентификационный номер типа цены

    Возвращает

    возвращает результат удаления типа цены

    Описание

    Метод, осуществляющий удаление типа цены

    [ Top ]

    shop::DeletePriceForItem

DeletePriceForItem(
mixed
$shop_items_catalog_item_id, int
$shop_list_of_prices_id, int
$shop_items_catalog_id );

    Принимаемые параметры

    $shop_items_catalog_id

    $shop_list_of_prices_id

    Описание

    Метод удаляет цену для элемента каталога

    [ Top ]

    shop::DeletePricesForAllItem

DeletePricesForAllItem(
mixed
$shop_items_catalog_id, int
$id );

    Принимаемые параметры

    $id

    Описание

    Метод удаляет все цены для элемента каталога

    [ Top ]

    shop::DeleteProducer

DeleteProducer(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер производителя

    Возвращает

    возвращает результат удаления производителя

    Описание

    Метод, осуществляющий удаление производителя

    [ Top ]

    shop::DeletePropertiesItem

DeletePropertiesItem(
int
$shop_id, int
$shop_items_catalog_item_id, int
$shop_list_of_properties_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $shop_items_catalog_item_id

    идентификатор элемента

    $shop_list_of_properties_id

    идентификатор дополнительного свойства

    Возвращает

    истина при удачном удалении, ложь в обратном случае

    Описание

    Удаление информации о свойстве товара

    [ Top ]

    shop::DeletePropretyOfItems

DeletePropretyOfItems(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер свойства товара

    Возвращает

    возвращает результат удаления свойства товара

    Описание

    Метод, осуществляющий удаление свойства товара

    [ Top ]

    shop::DeleteSeller

DeleteSeller(
int
$seller_id );

    Принимаемые параметры

    $seller_id

    идентификационный номер продавца

    Возвращает

    возвращает результат удаления продавца

    Описание

    Метод, осуществляющий удаление продавца.

    [ Top ]

    shop::DeleteShop

DeleteShop(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер магазина

    Возвращает

    возвращает результат удаления магазина

    Описание

    Метод, осуществляющий удаление магазина

    [ Top ]

    shop::DeleteShopWatermark

DeleteShopWatermark(
mixed
$shop_shops_id );

    [ Top ]

    shop::DeleteSystemOfPay

DeleteSystemOfPay(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер платёжной системы

    Возвращает

    возвращает результат удаления платёжной системы

    Описание

    Метод, осуществляющий удаление платёжной системы

    [ Top ]

    shop::DeleteTax

DeleteTax(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер налога

    Возвращает

    возвращает результат удаления налога

    Описание

    Метод, осуществляющий удаление налога

    [ Top ]

    shop::DeleteTyingProducts

DeleteTyingProducts(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемой записи о сопутствующих товарах

    Возвращает

    результат удаления

    Описание

    Метод удаления сопутствующих товаров

    [ Top ]

    shop::DeleteTypeOfDelivery

DeleteTypeOfDelivery(
mixed
$shop_type_of_delivery_id, int
$id );

    Принимаемые параметры

    $id

    идентификационный номер типа доставки

    Возвращает

    истина при удачном обновлении, ложь в обратном случае

    Описание

    Метод, осуществляющий удаление типа доставки

    [ Top ]

    shop::ExecSystemsOfPayHandler

ExecSystemsOfPayHandler(
int
$system_of_pay_id );

    Принимаемые параметры

    $system_of_pay_id

    идентификатор платежной системы

    Описание

    Метод выполнения обработчика платежной системы

    [ Top ]

    shop::FillMasGroup

FillMasGroup(
int
$shop_id, [mixed
$param = array()] );

    Принимаемые параметры

    $shop_id

    - идентификатор магазина, для которого заполняем массив групп самого верхнего уровня

    Описание

    Метод формирования массива групп самого верхнего уровня для данного магазина

    [ Top ]

    shop::FillMemCacheComments

FillMemCacheComments(
array
$mas_items_in );

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

    Заполнению подвергается массив $this->CacheTyingProducts[shop_items_catalog_item_id][] = shop_items_catalog_item_id

    [ Top ]

    shop::FillMemCacheCountItemsAndGroup

FillMemCacheCountItemsAndGroup(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Описание

    Метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.

    Информация сохраняется в массиве:
    для числа групп в группе $this->CacheCountGroupsAndItems[shop_shops_id][information_groups_id]['GROUPS']
    для числа элементов в группе $this->CacheCountGroupsAndItems[shop_shops_id][information_groups_id]['ITEMS']

    [ Top ]

    shop::FillMemCacheDiscountsForItem

FillMemCacheDiscountsForItem(
array
$mas_items_in );

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.

    Заполнению подвергается массив $this->CacheDiscountsForItem[shop_items_catalog_item_id][]

    [ Top ]

    shop::FillMemCacheGoupsIdTree

FillMemCacheGoupsIdTree(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Описание

    Метод формирует дерево групп и подгрупп в массиве по их идентификаторам

    [ Top ]

    shop::FillMemCacheModificationItems

FillMemCacheModificationItems(
array
$mas_items_in );

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

    Заполнению подвергается массив $this->CacheTyingProducts[shop_items_catalog_item_id][] = shop_items_catalog_item_id

    [ Top ]

    shop::FillMemCachePropertiesItem

FillMemCachePropertiesItem(
array
$mas_items_in );

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.

    Заполнению подвергается массив $this->CacheDiscountsForItem[shop_items_catalog_item_id][]

    [ Top ]

    shop::FillMemCacheTyingProducts

FillMemCacheTyingProducts(
array
$mas_items_in );

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

    Заполнению подвергается массив $this->CacheTyingProducts[shop_items_catalog_item_id][] = shop_items_catalog_item_id

    [ Top ]

    shop::GenXml4Comment

GenXml4Comment(
int
$shop_comment_id, [array
$comment_row = false] );

    Принимаемые параметры

    $shop_comment_id

    идентификатор отзыва о товаре, может быть 0, если указан $comment_row

    $comment_row

    массив с данными о товаре или false (тогда должен быть указан $shop_comment_id)

    Возвращает

    XML текс с данными об отзыве

    Описание

    Метод генерирующий XML для отзыва о товаре

    [ Top ]

    shop::GenXml4Company

GenXml4Company(
int
$shop_company_id, [array
$company_row = false] );

    Принимаемые параметры

    $shop_company_id

    идентификатор организации

    $company_row

    массив с параметрами, может быть указан вместо $shop_company_id

    Возвращает

    с XML

    Описание

    Метод генерирует XML для организации

    [ Top ]

    shop::GenXml4CompareItems

GenXml4CompareItems(
 );

    Возвращает

    сгенерированный XML

    Описание

    Метод генерирует xml для товаров, выбранных для сравнения

    [ Top ]

    shop::GenXML4Currency

GenXML4Currency(
int
$shop_currency_id );

    Принимаемые параметры

    $shop_currency_id

    идентификатор валюты

    Описание

    Метод генерирует XML для указанной валюты

    [ Top ]

    shop::GenXml4Item

GenXml4Item(
int
$root, array
$row, [int
$user_id = 0], [array
$param = array()] );

    Принимаемые параметры

    $root

    параметр, определяющий, является ли данный товар сопутствующим (0-основной, 1 - сопутствующий)

    $row

    информация о товаре

    $user_id

    идентификатор пользователя

    $param

    дополнительные параметры

    Возвращает

    XML для свойств товара

    Описание

    Метод построения XML для товара, его свойств и сопутствующих товаров

    [ Top ]

    shop::GenXml4ItemCatalogCommentAverageGrade

GenXml4ItemCatalogCommentAverageGrade(
int
$shop_items_catalog_item_id );

    Принимаемые параметры

    $shop_items_catalog_item_id

    метод генерирующий XML отзывов для данного товара

    Возвращает

    среднея оценка

    Описание

    Метод возвращает среднею оценку по товару.

    [ Top ]

    shop::GenXml4ItemCatalogComments

GenXml4ItemCatalogComments(
int
$shop_items_catalog_item_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_items_catalog_item_id

    метод генерирующий XML отзывов для данного товара

    $param

    массив с доп. параметрами

    Возвращает

    XML с данными об отзывах

    Описание

    Метод возвращает все комментарии, относящиеся к данному товару.

    [ Top ]

    shop::GenXml4Mesures

GenXml4Mesures(
int
$shop_mesures_id );

    Принимаемые параметры

    $shop_mesures_id

    Описание

    Метод генерирует XML для единиц измерения

    [ Top ]

    shop::GenXml4OrderStatus

GenXml4OrderStatus(
mixed
$shop_order_status_id, int
$shop_delivery_id );

    Принимаемые параметры

    $shop_delivery_id

    Описание

    Метод генерирует XML для статуса доставки

    [ Top ]

    shop::GenXml4Properties

GenXml4Properties(
[int
$shop_groups_id = 0] );

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы, если 0, то XML генерируется для корневой группы.

    Возвращает

    XML для свойств

    Описание

    Метод построения XML для свойств.

    $shop = new shop();  $external_propertys=array();  $external_propertys[‘ПоказыватьСсылкиНаДругиеСтраницы’]=1;  $property=array();
    • Заполняем первое условие
     $element['type']=0;  $element['prefix'] = 'and (';  $element['name'] = 'information_items_date';  $element['if'] = '>';  $elemenr['value'] = '2005-12-23 00:00:00';  $element['sufix']='';  $property['select'][]=$element;  $element['type']=0;  $element['prefix'] = ' and '; // префикс  $element['name'] = 'shop_properties_items_table.shop_properties_items_id';  $element['if'] = '='; // Условие
    • Здесь указывается ID доп. св-ва, по которому производится сортировка
     $element['value'] = '38'; // ID дополнительного св-ва, по которому сортируем  $element['sufix']=')';  $property['select'][]=$element;
    • Указываем, что мы сортируем по значениям дополнительных полей
     $property['OrderField'] = 'shop_properties_items_table.shop_properties_items_id, shop_properties_items_value';
    • Выводим элементы свойство с пом. GenXml4Properties

    [ Top ]

    shop::GenXml4Property

GenXml4Property(
int
$shop_list_of_properties_id, [mixed
$property_row = false], array
$shop_sallers_row );

    Принимаемые параметры

    $shop_list_of_properties_id

    свойства

    $shop_sallers_row

    информация о продавце, если не false, то берется не из базы а отсюда.

    Возвращает

    XML текст с информацией о свойстве.

    Описание

    Возвращает XML свойства.

    [ Top ]

    shop::GenXml4Saller

GenXml4Saller(
int
$shop_sallers_id, [array
$shop_sallers_row = false] );

    Принимаемые параметры

    $shop_sallers_id

    идентификатор продавца

    $shop_sallers_row

    информация о продавце, если не false, то берется не из базы а отсюда.

    Возвращает

    XML текст с информацией о продавце.

    Описание

    Возвращает XML продавца.

    [ Top ]

    shop::GenXml4Sallers

GenXml4Sallers(
[int
$shop_id = 0] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина, если 0, то XML генерируется для всех магазинов

    Возвращает

    XML для продавцов

    Описание

    Метод построения XML для продавцов.

    [ Top ]

    shop::GenXml4Shop

GenXml4Shop(
mixed
$shop_id, [mixed
$shop_row = false] );

    [ Top ]

    shop::GenXmlProducerList

GenXmlProducerList(
array
$param );

    Принимаемые параметры

    $param

    массив дополнительных параметров
      $param['shop_id'] идентификатор магазина

    Возвращает

    XML или false в случае отсутствия продавцов

    Описание

    Метод генерирует XML для списка продавцов магазина

    [ Top ]

    shop::GetAllCity

GetAllCity(
[mixed
$shop_location_id = 0], unknown_type
$location_id );

    Принимаемые параметры

    $location_id

    Описание

    Enter description here...

    [ Top ]

    shop::GetAllCityArea

GetAllCityArea(
[mixed
$shop_city_id = 0] );

    Возвращает

    информация о выбранных районах города (результат запроса) или ложь в случае возникновения ошибки

    Описание

    Метод выборки всех районов города

    [ Top ]

    shop::GetAllComments

GetAllComments(
int
$shop_items_catalog_item_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара, если не равен false, то метод  вернет список комментариев, относящихся только к данному товару

    $param

    массив дополнительных параметров
    $param['shop_comment_active'] статус активности выбираемых элементов (0/1). Параметр может быть не задан.

    Возвращает

    или false - результат выборки

    Описание

    Метод возвращает список всех комментариев

    [ Top ]

    shop::GetAllCompanies

GetAllCompanies(
 );

    Возвращает

    ресурс или false

    Описание

    Метод для получения списка всех компаний

    [ Top ]

    shop::GetAllCondOfDelivery

GetAllCondOfDelivery(
[array
$param = array()] );

    Принимаемые параметры

    $param

    массив дополнительных параметров, влияющих на выборку
    $param['type_of_delivery_id'] int идентификатор типа доставок, для которого необходимо выбрать все условия

    Возвращает

    результат выборки условий доставки

    Описание

    Метод выборки всех условий доставки

    [ Top ]

    shop::GetAllCountries

GetAllCountries(
 );

    [ Top ]

    shop::GetAllCoupons

GetAllCoupons(
array
$param );

    Принимаемые параметры

    $param

    список дополнительных параметров

    Возвращает

    ресурс с данными выборки

    Описание

    Метод возвращает список купонов по заданным условиям

    [ Top ]

    shop::GetAllCurrency

GetAllCurrency(
 );

    Возвращает

    информация обо всех валютах (результат запроса), ложь в случае возникновения ошибки (или если не существует ни одной валюты)

    Описание

    Метод выборки информации обо всех валютах

    [ Top ]

    shop::GetAllDiscounts

GetAllDiscounts(
[mixed
$shop_shops_id = false], int
$lib_dir_parent_id );

    Принимаемые параметры

    $lib_dir_parent_id

    идентификатор родительской директории, если false то отображаются все директории

    Возвращает

    результат выборки

    Описание

    Метод возвращает список всех скидок

    [ Top ]

    shop::GetAllDiscountsForItem

GetAllDiscountsForItem(
int
$shop_items_catalog_item_id );

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    Возвращает

    массив идентификаторов или false

    Описание

    Метод извлечения информации обо всех скидках для данного товара

    [ Top ]

    shop::GetAllGroups

GetAllGroups(
int
$shop_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $param

    массив дополнительных параметров для выборки
     $param['shop_groups_parent_id'] int идентификатор родительской группы
     $param['group_field_order'] поле сортировки группы
     $param['group_order'] направление сортировки группы ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)

    Возвращает

    результат выборки

    Описание

    Метод получения всех групп магазина

    [ Top ]

    shop::GetAllItems

GetAllItems(
int
$shop_id, [mixed
$group_id = false], [array
$param = array()] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $group_id

    идентификатор группы товаров, если $group_id = false, то получаем информацию о товарах всех групп

    $param

    массив дополнительных параметров  $param['items_begin'] номер товара в выборке, с которого начинать отображение товаров магазина  $param['items_on_page'] число товаров, отображаемых на странице  $param['items_field_order'] поле сортировки  $param['items_order'] направление сортировки ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)  $param['FillMemCacheTyingProducts'] указывает на необходимость заполнения кэша сопутствующих товаров для выбранных товаров. По умолчанию false  $param['FillMemCacheDiscountsForItem'] указывает на необходимость заполнения кэша скидок для выбранных товаров. По умолчанию true  $param['FillMemCacheComments'] указывает на необходимость заполнения кэша комментариев для выбранных товаров. По умолчанию false  $param['FillMemCachePropertiesItem'] указывает на необходимость заполнения кэша дополнительных свойств для выбранных товаров. По умолчанию false  $param['select'] массив внешних условий для выборки, например
    $param_array['select'][0]['type'] = 0;
    $param_array['select'][0]['prefix'] = 'AND';
    $param_array['select'][0]['name'] = 'shop_items_catalog_yandex_market_allow';
    $param_array['select'][0]['if'] = '=';
    $param_array['select'][0]['value'] = '1';
    $param_array['select'][0]['sufix'] = '';

    Возвращает

    массив или false

    Описание

    Метод получения всех товаров заданного магазина и заданной группы товаров

    [ Top ]

    shop::GetAllItemsForOrder

GetAllItemsForOrder(
int
$shop_order_id );

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа

    Возвращает

    результат выборки в случае, если выбрана хотя бы одна запись, ложь - если нет ни одной записи

    Описание

    Метод получения заказанных товаров

    [ Top ]

    shop::GetAllListProperties

GetAllListProperties(
int
$shop_shops_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    массив дополнительных параметров
    $param['order'] поле сортировки
    $param['where'] дополнительное услвоие для where

    Возвращает

    информация о дополнительных свойств для магазина (результат выполнения запроса)

    Описание

    Метод получения всех дополнительных свойств для магазина

    [ Top ]

    shop::GetAllLocation

GetAllLocation(
[mixed
$country_id = 0], int
$county_id );

    Принимаемые параметры

    $county_id

    идентификатор страны, для которой выбираем области (при =0 - выбираем все области)

    Возвращает

    информация об областях (штатах)

    Описание

    Метод получения списка всех областей (штатов)

    [ Top ]

    shop::GetAllMesures

GetAllMesures(
 );

    Возвращает

    результат выборки единиц измерения

    Описание

    Метод выборки всех единиц измерения

    [ Top ]

    shop::GetAllModificationItems

GetAllModificationItems(
int
$shop_items_catalog_item_id, array
$param );

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $param

    массив дополнительных параметров
    $param['shop_items_catalog_is_active'] статус активности выбираемых элементов (0/1). Параметр может быть не задан.

    Возвращает

    ассоциативный массив с информацией о модификации товаров

    Описание

    Метод возвращает информацию обо всех модификациях данного товара

    [ Top ]

    shop::GetAllOrderDiscounts

GetAllOrderDiscounts(
[int
$shop_shops_id = false] );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    результат выборки

    Описание

    Метод для извлечения информации обо всех скидках

    [ Top ]

    shop::GetAllOrders

GetAllOrders(
int
$shop_shops_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    массив дополнительных параметров для выборки
     $param['order'] поле, по которому осуществляем сортировку
     $param['order_sort'] порядок сортировки (ASC - прямой, DESC - обратный)
     $param['user_id'] идентификатор пользователя (если необходимо выбрать заказы для пользователя)
     $param['limit_from'] номер записи, с которой начинаем выборку (нумерация записей с 0)
     $param['limit_count'] количество выбираемых записей

    Возвращает

    результат выборки запроса

    Описание

    Метод выборки заказов для магазина

    [ Top ]

    shop::GetAllOrderStatus

GetAllOrderStatus(
 );

    Возвращает

    информация о статусах заказа (результат выборки)

    Описание

    Метод получения информации обо всех статусах заказаов

    [ Top ]

    shop::GetAllPricesForItem

GetAllPricesForItem(
int
$shop_items_catalog_item_id );

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    Возвращает

    информация о ценах товара (массив с данными о ценах), ложь, если возникла ошибка или нет ни одной цены

    Описание

    Метод получения информации о ценах, заданных для товара

    [ Top ]

    shop::GetAllPricesForShop

GetAllPricesForShop(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    информация о ценах для магазина при успешной выборке, ложь, если возникла ошибка или нет ни одной цены

    Описание

    Метод получения списка цен для магазина

    [ Top ]

    shop::GetAllProducers

GetAllProducers(
[array
$param = array()] );

    Принимаемые параметры

    $param

    массив дополнительных условий для выборки
      $param['shop_id'] идентификатор магазина

    Возвращает

    информация о производителях (результат запроса)

    Описание

    Метод получения информации обо всех производителях

    [ Top ]

    shop::GetAllPropertiesItem

GetAllPropertiesItem(
int
$item_id, [array
$param = array()] );

    Принимаемые параметры

    $item_id

    идентификатор товара

    $param

    массив дополнительных свойств

    Возвращает

    массив дополнительных свойств для товара, ложь - если не задано ни одного свойства для товара

    Описание

    Метод извлечения информации о дополнительных свойствах заданного товара

    [ Top ]

    shop::GetAllSellers

GetAllSellers(
[int
$shop_id = false] );

    Принимаемые параметры

    $shop_id

    - идентификатор магазина

    Возвращает

    Информация о продавцах

    Описание

    Метод получения информации о всех продавцах магазина $shop_id, если $shop_id = false,  то о продавцах всех магазинов

    [ Top ]

    shop::GetAllShops

GetAllShops(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    результат выборки

    Описание

    Метод для получения списка всех магазинов

    [ Top ]

    shop::GetAllSystemOfPay

GetAllSystemOfPay(
 );

    Возвращает

    возвращает результат выборки

    Описание

    Метод получения всех активных платежных систем

    [ Top ]

    shop::GetAllTax

GetAllTax(
 );

    Возвращает

    информация о налогах (результат запроса)

    Описание

    Метод получения информации о налогах

    [ Top ]

    shop::GetAllTypeOfDelivery

GetAllTypeOfDelivery(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    список типов доставки (результат запроса)

    Описание

    Метод выборки всех типов доставки для конкретного магазина

    [ Top ]

    shop::GetCart

GetCart(
int
$id );

    Принимаемые параметры

    $id

    идентификатор корзины

    Возвращает

    возвращает результат выборки корзины

    Описание

    Метод, осуществляющий извлечение корзины

    [ Top ]

    shop::GetCity

GetCity(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер города

    Возвращает

    возвращает результат выборки города

    Описание

    Метод, осуществляющий извлечение города

    [ Top ]

    shop::GetComment

GetComment(
int
$shop_comment_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_comment_id

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    с информацией о комментарии или false

    Описание

    Метод возвращает информацию о комментарии к товару

    [ Top ]

    shop::GetCompany

GetCompany(
int
$shop_company_id );

    Принимаемые параметры

    $shop_company_id

    идентификатор организации

    Возвращает

    массив с информацией об организации или false

    Описание

    Метод для получения информации об организации

    [ Top ]

    shop::GetCondOfDelivery

GetCondOfDelivery(
int
$id, [boolean
$select_delivery_type = false] );

    Принимаемые параметры

    $id

    идентификационный номер условия доставки

    $select_delivery_type

    флаг, указывающий на необходимость получить информацию о типе доставки

    Возвращает

    результат выборки условия доставки (+ информация о типе доставки при установленном флаге)

    Описание

    Метод, осуществляющий извлечение условия доставки

    [ Top ]

    shop::GetCondOfDeliveryXml

GetCondOfDeliveryXml(
int
$cond_of_delivery_id );

    Принимаемые параметры

    $cond_of_delivery_id

    идентификатор условия доставки

    Возвращает

    xml для условия доставки, ложь, если информация не выбрана

    Описание

    Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)

    [ Top ]

    shop::GetCookieExpires

GetCookieExpires(
 );

    Описание

    Метод возвращает время истечения данных в корзине, хранящейся в кукисах.

    Метод работает на основе значение константы SHOP_COOKIE_EXPIRES, если она задана.  Значение = 0 означает хранение данных до закрытия браузера.  При отсутствии заданной константы данные в кукисах хранятся 365 дней (31536000 секунд). Значение константы задается в секундах.

    [ Top ]

    shop::GetCountCity

GetCountCity(
[int
$shop_location_id = 0] );

    Принимаемые параметры

    $shop_location_id

    идентификатор области

    Возвращает

    число стран в справочнике в случае удачного выполнения, false - в противном случае

    Описание

    Метод получения числа городов для области

    [ Top ]

    shop::GetCountCountry

GetCountCountry(
 );

    Возвращает

    число стран в справочнике в случае удачного выполнения, false - в противном случае

    Описание

    Метод получения числа стран

    [ Top ]

    shop::GetCountCurrency

GetCountCurrency(
 );

    Возвращает

    число валют в справочнике в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа валют в справочнике

    [ Top ]

    shop::GetCountDiscount

GetCountDiscount(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    Возвращает

    число скидок для магазина в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа скидок для магазина

    [ Top ]

    shop::GetCountItemsAndGroups

GetCountItemsAndGroups(
int
$parent_group_id, int
$shop_shops_id, [boolean
$sub = true] );

    Принимаемые параметры

    $parent_group_id

    идентификатор группы, для которой необходимо получить число элементов и групп.

    $shop_shops_id

    идентификатор магазина, к которому принадлежит группа.

    $sub

    параметр, определяющий будут ли учитываться подгруппы данной группы при подсчете элементов и групп (true - подгруппы учитываются, false - не учитываются). По умолчанию $sub = true

    Возвращает

    массив из 4-х элементов
    $mas['count_items'] число элементов в группе без учета элементов в подгруппах
    $mas['count_all_items'] число элементов в группе с учетом элементов в подгруппах
    $mas['count_groups'] число групп в данной группе без учета вложенности подгрупп
    $mas['count_all_groups'] число групп в данной группе с учетом вложенности подгрупп

    Описание

    Метод получения числа элементов и групп для переданной родительской группы

    [ Top ]

    shop::GetCountItemsCatalog

GetCountItemsCatalog(
int
$shop_id, mixed
$group_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазиа

    $group_id

    идентификатор раздела магазина, или false - если необходимо получить число всех товаров магазина

    Возвращает

    число товаров одного или всех разделов магазина в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод получения числа товаров в одном или во всех разделах магазина

    [ Top ]

    shop::GetCountItemsWithConditions

GetCountItemsWithConditions(
int
$shop_id, [mixed
$group_id = false], [array
$param = array()] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $group_id

    идентификатор группы товаров, если $group_id = false, то получаем информацию о товарах всех групп, если $group_id равен строке с перечислением идентификаторов - '1,2,10,12,17', то возвращаются данные о товарах из указанных групп

    $param

    массив дополнительных параметров
    $property['OrderField'] поле сортировки, если случайная сортировка, то записать RAND()
    $property['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
    $property['OrderGroup'] направление сортировки (ASC - по возрастанию, DESC - по убыванию)
    $property['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()
    $property['NotInGroup'] идентификатор групп информационных элементов, которые необходимо исключить из результатов
    $property['cache'] разрешение кэширования, по умолчанию true
    $property['select'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных элементов
    $element['type'] определяет, является ли поле основным свойством информационного элемента или дополнительным (0 - основное, 1 - дополнительное)
    $element['prefix'] префикс - строка, размещаемая перед условием
    $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    $element['property_id'] идентификатор дополнительногого свойства
    $element['if'] строка, содержащая условный оператор
    $elemenr['value'] значение поля (или параметра)
    $element['sufix'] суффикс - строка, размещаемая после условия
    Например
    $element['type']=1; // 0 - основное св-во, 1 - дополнительное
    $element['prefix'] = 'and'; // префикс
    $element['property_id'] = 26; // ID дополнительного св-ва, указывается если тип = 1
    $element['if'] = '='; // Условие
    $element['value'] = '10';
    $element['sufix']='';
    $param['select'][]=$element;
    $element['type']=1; // 0 - основное св-во, 1 - дополнительное
    $element['prefix'] = 'and'; // префикс
    $element['property_id'] = 28; // ID дополнительного св-ва, указывается если тип = 1
    $element['if'] = '='; // Условие
    $element['value'] = 1;
    $element['sufix']='';  $param['select'][]=$element;

    Возвращает

    число товаров в случае успешного выполнения, false в противном случае

    Описание

    Метод получения числа товаров, параметры которых удовлетворяют заданным условиям

    [ Top ]

    shop::GetCountLocation

GetCountLocation(
[mixed
$shop_country_id = 0] );

    Возвращает

    число областей в справочнике в случае удачного выполнения, false - в противном случае

    Описание

    Метод получения числа областей (штатов) для страны

    [ Top ]

    shop::GetCountMesures

GetCountMesures(
 );

    Возвращает

    число единиц измерения в справочнике в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа единиц измерения в справочнике

    [ Top ]

    shop::GetCountOrder

GetCountOrder(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    количество заказов для магазина или ложь при возникновении ошибки

    Описание

    Метод выборки количества заказов для магазина

    [ Top ]

    shop::GetCountOrderStatus

GetCountOrderStatus(
 );

    Возвращает

    число статусов заказа в справочнике в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа статусов заказа

    [ Top ]

    shop::GetCountProducers

GetCountProducers(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    Возвращает

    число производителей для данного магазина в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа производителей для данного магазина

    [ Top ]

    shop::GetCountProperties

GetCountProperties(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    Возвращает

    число свойств товаров магазина в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа свойств товаров конкретного магазина

    [ Top ]

    shop::GetCountry

GetCountry(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер страны

    Возвращает

    возвращает результат выборки страны

    Описание

    Метод, осуществляющий извлечение страны

    [ Top ]

    shop::GetCountSellers

GetCountSellers(
 );

    Возвращает

    число продавцов в справочнике в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа продавцов в справочнике

    [ Top ]

    shop::GetCountShops

GetCountShops(
mixed
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта, для которого необходимо получить магазинов или false, если необходимо получить число магазинов для всех сайтов

    Возвращает

    число магазинов для одного или всех сайтов в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод получения числа магазинов для одного или всех сайтов, обслуживаемых системой управления

    [ Top ]

    shop::GetCountSystemOfPay

GetCountSystemOfPay(
 );

    Возвращает

    число систем оплаты в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод получения числа систем оплаты

    [ Top ]

    shop::GetCountTax

GetCountTax(
 );

    Возвращает

    число налогов в справочнике в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа налогов в справочнике

    [ Top ]

    shop::GetCountTypeOfDelivery

GetCountTypeOfDelivery(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    Возвращает

    число типов доставок для магазина в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа типов доставок для данного магазина

    [ Top ]

    shop::GetCountTypePrices

GetCountTypePrices(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    Возвращает

    число типов цен для магазина в случае успешного выполнения, false - в противном случае

    Описание

    Метод получения числа типов цен для магазина

    [ Top ]

    shop::GetCoupon

GetCoupon(
int
$shop_coupon_id );

    Принимаемые параметры

    $shop_coupon_id

    идентификатор купона

    Возвращает

    данные о купоне или false

    Описание

    Метод возвращает массив с информацией о купоне

    [ Top ]

    shop::GetCouponByText

GetCouponByText(
string
$shop_coupon_text, [bool
$shop_coupon_active = false] );

    Принимаемые параметры

    $shop_coupon_text

    текст купона

    $shop_coupon_active

    активность купона, false - все купоны, т.е. активные и не активные

    Возвращает

    результат выборки в виде ассоциативного массива или false

    Описание

    Возвращает информацию о купоне по его тексту

    [ Top ]

    shop::GetCurrency

GetCurrency(
mixed
$id_currency, [array
$param = array()], int
$id );

    Принимаемые параметры

    $id

    идентификационный номер валюты

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки валюты ( false при неудачной выборке)

    Описание

    Метод, осуществляющий извлечение информации о валюте

    [ Top ]

    shop::GetCurrencyCoefficientToShopCurrency

GetCurrencyCoefficientToShopCurrency(
float
$item_shop_currency_id, float
$shop_currency_id );

    Принимаемые параметры

    $item_shop_currency_id

    идентифкатор валюты товара

    $shop_currency_id

    идентифкатор валюты магазина

    Возвращает

    коэффициент пересечета валюты товара в валюту магазина

    Описание

    Метод определения коэффициента пересчета валюты товара в валюту магазина

    [ Top ]

    shop::GetCurrencyForShop

GetCurrencyForShop(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    результат выборки или ложь, если запись не выбрана

    Описание

    Метод получения валюты, указанной по умолчанию для магазина

    [ Top ]

    shop::GetCurrencyXml

GetCurrencyXml(
int
$currency_id );

    Принимаемые параметры

    $currency_id

    идентификатор валюты

    Возвращает

    xml для валюты магазина, ложь, если такой валюты не существует

    Описание

    Метод формирования xml для валюты

    [ Top ]

    shop::GetDefaultCurrency

GetDefaultCurrency(
 );

    Возвращает

    информация о базовой валюте или ложь, если базовой валюты не существует

    Описание

    Метод получения информации о базовой валюте

    [ Top ]

    shop::GetDefaultOrderStatus

GetDefaultOrderStatus(
int
$shop_id );

    Принимаемые параметры

    $shop_id

    идентфикатор магазина

    Возвращает

    результат выборки

    Описание

    Метод получения статуса заказа, установленного по умолчанию

    [ Top ]

    shop::GetDelimitedGroups

GetDelimitedGroups(
int
$shop_parent_group_id, int
$shop_id, [string
$separator = ''], [int
$shop_groups_id = false] );

    Принимаемые параметры

    $shop_parent_group_id

    идентификатор группы, относительно которой строится дерево групп.

    $shop_id

    идентификатор магазина, для которого строится дерево групп.

    $separator

    символ, отделяющий группу нижнего уровня от родительской группы.

    $shop_groups_id

    идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы.

    Возвращает

    двумерный массив, содержащий дерево подгрупп.

    Описание

    Метод формирования дерева групп для магазина.

    [ Top ]

    shop::GetDiscount

GetDiscount(
int
$shop_discount_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_discount_id

    идентификационный номер скидки

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки скидки

    Описание

    Метод, осуществляющий извлечение информации о скидке

    [ Top ]

    shop::GetGroup

GetGroup(
int
$shop_groups_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_groups_id

    идентификационный номер группы

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки группы

    Описание

    Метод, осуществляющий извлечение информации о группе

    [ Top ]

    shop::GetGroups

GetGroups(
$shop_id
$shop_id, [$shop_groups_parent_id
$shop_groups_parent_id = false] );

    Принимаемые параметры

    $shop_id

    int идентификатор магазина

    $shop_groups_parent_id

    int идентификатор родительской группы, по умолчанию не задан. При задании идентификатора родительской группы выбираются только непосредственные потомки указанного родителя.

    Описание

    Метод возвращает список групп магазина

    [ Top ]

    shop::GetGroupsTree

GetGroupsTree(
mixed
$shop_current_group_id, mixed
$shop_id, [array
$mass = array()], int
$shop_groups_id );

    Принимаемые параметры

    $shop_groups_id

    идентификатор текущей

    $mass

    массив идентификаторов подгрупп

    Возвращает

    массив идетификаторов подгрупп

    Описание

    Метод получения массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской

    [ Top ]

    shop::GetGroupsXmlTree

GetGroupsXmlTree(
unknown_type
$shop_id, unknown_type
$param, unknown_type
$a_group );

    Принимаемые параметры

    $shop_id

    $param

    $a_group

    Описание

    Метод построения дерева xml для групп

    [ Top ]

    shop::GetGroupWithPath

GetGroupWithPath(
string
$group_path, int
$group_parent_id, int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $group_parent_id

    идентификатор родительской группы

    $group_path

    путь к группе

    Возвращает

    информация о группе с таким путем в данной подгруппе для магазина, ложь, если такой группы нет

    Описание

    Метод получения информации о группе по пути, если такая существует в данной подгруппе магазина

    [ Top ]

    shop::GetGroupWithValue

GetGroupWithValue(
string
$groups_name, int
$groups_parent_id, int
$shop_shops_id, [array
$param = array()] );

    Принимаемые параметры

    $groups_name

    наименование группы

    $groups_parent_id

    идентификатор родительской группы

    $shop_shops_id

    идентификатор магазина

    $param

    список доп. параметров

    Возвращает

    информация о группе, ложь - если не существует группы с таким наименованием

    Описание

    Метод получения информации о группе по наименованию, если такая существует в данной подгруппе магазина

    [ Top ]

    shop::GetItem

GetItem(
mixed
$shop_items_catalog_item_id, [array
$param = array()], int
$id );

    Принимаемые параметры

    $id

    идентификационный номер товара

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвраает результат выборки товара

    Описание

    Метод, осуществляющий извлечение информации о товаре

    [ Top ]

    shop::GetItemByParam

GetItemByParam(
$param
$param );

    Принимаемые параметры

    $param

    массив с параметрами для условий

    Возвращает

    ресурс или false

    Описание

    Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента

    [ Top ]

    shop::GetItemDiscount

GetItemDiscount(
int
$id, [array
$param = array()] );

    Принимаемые параметры

    $id

    идентификатор извлекаемой записи

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает информацию о скидке на товар, если записи с таким идентификатором нет, то false

    Описание

    Метод получения информации о скидке на товар

    [ Top ]

    shop::GetItemFromCart

GetItemFromCart(
int
$shop_id, int
$user_id, int
$item_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $user_id

    идентификатор пользователя

    $item_id

    идентификатор товара

    Возвращает

    or false идентификатор выбранной записи

    Описание

    Метод получения информации о товаре из корзины для пользователя

    [ Top ]

    shop::GetItemPath

GetItemPath(
int
$shop_id, [array
$param1 = ''] );

    Принимаемые параметры

    $shop_id

    - идентификатор магазина, к которому принадлежит данный товар

    $param1

    - массив, содержащий все элементы URL

    Возвращает

    or boolean - возвращает ассоциативный массив, содержащий идентификатор группы товаров и идентификатор товара

    Описание

    Метод определения идентификатора группы товаров и идентификатора товара по значению URL

    [ Top ]

    shop::GetItemsFromCart

GetItemsFromCart(
int
$user_id, int
$shop_id, [bool
$always_use_cookies_cart = true] );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $shop_id

    идентификатор магазина

    $always_use_cookies_cart

    использовать корзину кукисов, если $user_id = false

    Возвращает

    массив товаров и их свойств

    Описание

    Метод получения товаров, находящихся в корзине

    [ Top ]

    shop::GetItemsFromCookiesToCart

GetItemsFromCookiesToCart(
int
$user_id );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    Описание

    Метод перемещения информации о заказанном товаре в таблицу корзины

    [ Top ]

    shop::GetItemsXmlTree

GetItemsXmlTree(
int
$shop_id, [mixed
$group_id = false], [array
$param = array()] );

    Принимаемые параметры

    $shop_id

    идентификатор Internet-магазина

    $group_id

    идентификатор раздела каталога, если $group_id=false, то генерируем XML для товаров из всех разделов

    $param

    массив дополнительных параметров  $param['items_begin'] номер товара в выборке, с которого начинать отображение товаров магазина  $param['items_on_page'] число товаров, отображаемых на странице  $param['items_field_order'] поле сортировки  $param['items_order'] направление сортировки ('Asc' - по возрастанию, 'Desc' - по убываниюб , 'Rand' - произвольный порядок)

    Возвращает

    XML с данными о товарах

    Описание

    Метод построения XML для товаров

    [ Top ]

    shop::GetItemXml

GetItemXml(
int
$item_id, [int
$user_id = 0] );

    Принимаемые параметры

    $item_id

    идентификатор товара

    $user_id

    идентификатор пользователя

    Возвращает

    xml для товара (информация о товаре + дополнительные свойства + сопуствующие товары и т.д.), ложь - если запись не выбрана

    Описание

    Метод формирования xml товара

    [ Top ]

    shop::GetLocation

GetLocation(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер области

    Возвращает

    возвращает результат выборки области

    Описание

    Метод, осуществляющий извлечение области

    [ Top ]

    shop::GetMasGroupToRoot

GetMasGroupToRoot(
 );

    [ Top ]

    shop::GetMesure

GetMesure(
mixed
$id_mesure, [array
$param = array()], int
$id );

    Принимаемые параметры

    $id

    идентификационный номер единицы измерения

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки единицы измерения

    Описание

    Метод, осуществляющий извлечение информации о единице измерения

    [ Top ]

    shop::GetOrder

GetOrder(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер заказа

    Возвращает

    возвращает результат выборки заказа

    Описание

    Метод, осуществляющий извлечение заказа

    [ Top ]

    shop::GetOrderDiscount

GetOrderDiscount(
int
$shop_order_discount_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_order_discount_id

    идентификатор скидки для заказов

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с результатом выборки или false

    Описание

    Метод возвращает информацию о скидке для заказов

    [ Top ]

    shop::GetOrderDiscountForSum

GetOrderDiscountForSum(
int
$shop_shops_id, float
$sum, [string
$shop_coupon_text = ''] );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $sum

    сумма заказа

    $shop_coupon_text

    текст купона, если таковой есть

    Возвращает

    величина скидки, -1 в случае ошибки

    Описание

    Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина

    [ Top ]

    shop::GetOrderDiscountWithConditions

GetOrderDiscountWithConditions(
array
$param );

    Принимаемые параметры

    $param

    массив с дополнительными параметрами
     int $param['shop_shops_id'] идентификатор магазина
     int $param['shop_order_discount_active'] активность неактивность скидки
     int $param['date'] дата, должна быть в интервале действия скидки
     int $param['shop_order_discount_is_coupon'] скидка для купона

    Возвращает

    результат выборки

    Описание

    Метод возвращает список скидок на сумму заказа по заданным условиям

    [ Top ]

    shop::GetOrderInfoArray

GetOrderInfoArray(
int
$shop_id, int
$user_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $user_id

    идентификатор пользователя сайта

    Возвращает

    массив с данными заказа, ложь - если магазина нет

    Описание

    Метод формирования массива с информацией о заказе для вставки в заказы

    [ Top ]

    shop::GetOrderItem

GetOrderItem(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер товара в заказе

    Возвращает

    возвращает результат выборки товара в заказе

    Описание

    Метод, осуществляющий извлечение товара из заказа

    [ Top ]

    shop::GetOrderItems

GetOrderItems(
int
$shop_order_id, [mixed
$limit1 = false], [mixed
$limit2 = false] );

    Принимаемые параметры

    $shop_order_id

    идентификационный номер заказа

    Возвращает

    ресурс с элементами заказа

    Описание

    Метод, осуществляющий извлечение товаров из заказа

    [ Top ]

    shop::GetOrdersStatus

GetOrdersStatus(
int
$shop_order_status_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_order_status_id

    идентификационный номер состояния заказа

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки статуса заказа

    Описание

    Метод, осуществляющий извлечение состояния заказа

    [ Top ]

    shop::GetOrderXml

GetOrderXml(
array
$param, array
$param_item, [string
$xsl_name = ''] );

    Принимаемые параметры

    $param

    массив с данными о заказе

    $param_item

    массив с данными о заказанных товарах

    $xsl_name

    наименование xsl шаблона (не обязательный параметр, если не указан метод возврщает xml)

    Возвращает

    дерево xml с данными о заказе

    Описание

    Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных

    [ Top ]

    shop::GetPathGroup

GetPathGroup(
int
$shop_groups_id, [string
$path = ''] );

    Принимаемые параметры

    $shop_groups_id

    - идентификатор группы, для которой надо сформировать путь

    $path

    - параметр, используемый при формировании пути по группам

    Возвращает

    - путь по группам от корневой до данной

    Описание

    Метод формирования пути по группам товара

    [ Top ]

    shop::GetPathProducer

GetPathProducer(
mixed
$path );

    [ Top ]

    shop::GetPrice

GetPrice(
int
$id, [array
$param = array()] );

    Принимаемые параметры

    $id

    идентификационный номер типа цены

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки типа цены

    Описание

    Метод, осуществляющий извлечение типа цены

    [ Top ]

    shop::GetPriceForItem

GetPriceForItem(
int
$price_id, int
$item_id );

    Принимаемые параметры

    $price_id

    идентификатор цены

    $item_id

    идентификатор товара

    Возвращает

    or false результат выборки

    Описание

    Метод определения наличия указанной цены для заданного товара

    [ Top ]

    shop::GetPriceForUser

GetPriceForUser(
int
$user_id, int
$item_id, [int
$item_row = array()] );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $item_id

    идентификатор товара

    $item_row

    строка даных о товаре, необязательное поле

    Возвращает

    возвращает массив значений цен(цена с учетом валюты, цена с учетом налога) товара для данного пользователя

    Описание

    Метод определения цены товара для заданного пользователя

    [ Top ]

    shop::GetProducer

GetProducer(
mixed
$producer_id, [array
$param = array()], int
$id );

    Принимаемые параметры

    $id

    идентификационный номер производителя

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки производителя

    Описание

    Метод, осуществляющий извлечение информации о производителе

    [ Top ]

    shop::GetPropertiesOfGroup

GetPropertiesOfGroup(
int
$shop_groups_id, [int
$shop_items_catalog_item_id = false] );

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы.

    $shop_items_catalog_item_id

    идентификатор идентификатор товара.

    Возвращает

    вектор с идентификаторами свойств.

    Описание

    Метод для получения списка идентификаторов свойств товаров для определенной группы.

    [ Top ]

    shop::GetPropertiesOfGroupForXml

GetPropertiesOfGroupForXml(
[int
$shop_groups_id = 0] );

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы, если 0, то возвращает свойства, разрешенные для корневой группы

    Возвращает

    resource или fasle

    Описание

    Возвращает список свойств, разврешенных для вывода в XML

    [ Top ]

    shop::GetPropretyOfItems

GetPropretyOfItems(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер свойства товара

    Возвращает

    возвращает результат выборки свойства товара

    Описание

    Метод, осуществляющий извлечение свойства товара (по идентификатору таблицы связи свойств и товаров)

    [ Top ]

    shop::GetSeller

GetSeller(
int
$seller_id, [array
$param = array()] );

    Принимаемые параметры

    $seller_id

    Идентификатор продавца

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Ассоциативный массив с информацией о продавце

    Описание

    Метод получения информации о продавце по его идентификатору.

    [ Top ]

    shop::GetShop

GetShop(
int
$id, [array
$param = array()] );

    Принимаемые параметры

    $id

    идентификационный номер магазине

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    возвращает результат выборки магазина

    Описание

    Метод, осуществляющий извлечение информации о магазине

    [ Top ]

    shop::GetShopCurrency

GetShopCurrency(
unknown_type
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    Возвращает

    информация о валюте или ложь, если магазина не существует

    Описание

    Метод получения информации о валюте магазина

    [ Top ]

    shop::GetShopDiscount

GetShopDiscount(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    ресурс в данными о скидке

    Описание

    Метод получения списка скидок для магазина

    [ Top ]

    shop::GetShopGroupsToRoot

GetShopGroupsToRoot(
int
$group_id, int
$shop_id );

    Принимаемые параметры

    $group_id

    идентификатор группы

    $shop_id

    идентификатор магазина

    Возвращает

    ассоциативный массив с данными о каталогах магазина

    Описание

    Метод получения массива с данными о каталогах магазина, начиная с данной и до корневой

    [ Top ]

    shop::GetShopWhithStructureId

GetShopWhithStructureId(
int
$structure_id, int
$site_id, [int
$shop_shops_id = 0] );

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    $site_id

    идентификатор сайта

    $shop_shops_id

    идентификатор магазина, который не включать в условие (по умолчанию 0 - не ограничиваем по id магазина)

    Возвращает

    информация о магазине или ложь, если нет магазина с таким узлом структуры для сайта

    Описание

    Метод выбора информации о магазине данного узла структуры сайта

    [ Top ]

    shop::GetSystemOfPay

GetSystemOfPay(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер платёжной системы

    Возвращает

    возвращает результат выборки платёжной системы или ложь, если запись не выбрана

    Описание

    Метод, осуществляющий извлечение платёжной системы

    [ Top ]

    shop::GetTax

GetTax(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер налога

    Возвращает

    возвращает результат выборки налога

    Описание

    Метод, осуществляющий извлечение налога

    [ Top ]

    shop::GetTyingProducts

GetTyingProducts(
int
$shop_intermediate_id, [array
$param = array()] );

    Принимаемые параметры

    $shop_intermediate_id

    идентификатор записи о сопутствующем товаре

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    результат выборки

    Описание

    Метод получения информации о сопутствующем товаре

    [ Top ]

    shop::GetTyingProductsForItem

GetTyingProductsForItem(
int
$shop_items_catalog_item_id );

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    Возвращает

    массив идентификаторов сопутствующих товаров

    Описание

    Метод получения ID сопутствующих товаров для заданного товара

    [ Top ]

    shop::GetTypeOfDelivery

GetTypeOfDelivery(
int
$id );

    Принимаемые параметры

    $id

    идентификационный номер типа доставки

    Возвращает

    возвращает результат выборки типа доставки

    Описание

    Метод, осуществляющий извлечение типа доставки

    [ Top ]

    shop::GetTypeOfDeliveryForOrder

GetTypeOfDeliveryForOrder(
int
$shop_type_of_delivery_id, int
$country, int
$location, int
$city, int
$city_area, float
$weight, float
$price );

    Принимаемые параметры

    $shop_type_of_delivery_id

    идентификатор типа доставки

    $country

    идентификатор страны доставки

    $location

    идентификатор области доставки

    $city

    идентификатор города доставки

    $city_area

    идентификатор района доставки

    $weight

    вес заказа

    $price

    цена заказа

    Возвращает

    результат выборки

    Описание

    Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.

    [ Top ]

    shop::GetValueItemProperty

GetValueItemProperty(
int
$item_id, int
$list_of_properties_id );

    Принимаемые параметры

    $item_id

    идентификатор товара

    $list_of_properties_id

    идентификатор дополнительного свойства

    Возвращает

    информация о дополнительном свойстве товара или ложь - если свойство для товара не задано

    Описание

    Метод получения значения дополнительного свойства для товара

    [ Top ]

    shop::GetXmlForItemsOrder

GetXmlForItemsOrder(
int
$shop_order_id );

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа

    Возвращает

    xml для товаров в заказе, ложь, если нет ни одного товара

    Описание

    Метод формирования xml для товаров в заказе

    [ Top ]

    shop::GetXmlForOrder

GetXmlForOrder(
int
$shop_order_id, [array
$order_row = false], [bool
$need_user_info = true] );

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа

    $order_row

    массив с данными о заказе или false

    $need_user_info

    определяет, нужно ли добавить информацию о юзере в XML

    Возвращает

    сформированный xml для заказа

    Описание

    Метод формирования xml о заказе по идентификатору заказа

    [ Top ]

    shop::GetXmlProducer

GetXmlProducer(
mixed
$select );

    [ Top ]

    shop::IndexationShopItems

IndexationShopItems(
mixed
$limit, mixed
$on_step );

    [ Top ]

    shop::InsertCity

InsertCity(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор города
     string $param['name'] название города
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного города

    Описание

    Метод, осуществляющий вставку города

    [ Top ]

    shop::InsertCityArea

InsertCityArea(
int
$type, int
$city_area_id, int
$city_area_name, int
$city_id, [int
$users_id = false] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $city_area_id

    идентификатор района

    $city_area_name

    название района

    $city_id

    идентификатор города, в котором находится район

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор нового или редатируемого района(в зависимости от типа действия)

    Описание

    Метод добавления/редактирования информации о районе города

    [ Top ]

    shop::InsertComment

InsertComment(
array
$param );

    Принимаемые параметры

    $param

    массив доп. параметров
     int $param['shop_comment_id'] идентификатор комментария
     int $param['shop_items_catalog_item_id'] идентификатор товара
     int $param['shop_comment_active'] активность комментария
     int $param['shop_comment_grade'] оценка
     int $param['site_users_id'] идентификатор пользователя сайта
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
     string $param['shop_comment_date_time'] дата/время комментария
     string $param['shop_comment_user_name'] имя пользователя, оставившего комментарий
     string $param['shop_comment_subject'] тема комментария
     string $param['shop_comment_text'] текст комментария
     string $param['shop_comment_subject'] тема комментария

    Возвращает

    идентификатор комментария (отзыва) или false

    Описание

    Метод добавления/обновления информации об отзыве на товар

    [ Top ]

    shop::InsertCompany

InsertCompany(
array
$param );

    Принимаемые параметры

    $param

    массив доп. параметров
     int $param['shop_company_id'] идентификатор организации
     string $param['shop_company_name'] название организации
     string $param['shop_company_description'] описание организации
     string $param['shop_company_inn'] ИНН организации
     string $param['shop_company_kpp'] КПП организации
     string $param['shop_company_ogrn'] ОГРН организации
     string $param['shop_company_okpo'] ОКПО организации
     string $param['shop_company_okved'] ОКВЕД организации
     string $param['shop_company_bik'] БИК организации
     string $param['shop_company_account'] счет организации
     string $param['shop_company_corr_account'] корр. счет организации
     string $param['shop_company_bank_name'] название банка
     string $param['shop_company_bank_address'] адрес банка
     string $param['shop_company_fio'] ФИО директора организации
     string $param['shop_company_accountant_fio'] ФИО бухгалтера организации
     string $param['shop_company_address'] адрес организации
     string $param['shop_company_phone'] телефон организации
     string $param['shop_company_fax'] факс организации
     string $param['shop_company_site'] сайт организации
     string $param['shop_company_email'] e-mail организации
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор организации или false

    Описание

    Метод для вставки/обновления организации

    [ Top ]

    shop::InsertCondOfDelivery

InsertCondOfDelivery(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор условия доставки
    string $param['name'] название условия доставки
    int $param['type_of_delivery'] идентификатор типа доставки
    $param['location'] идентификатор области
    double $param['weight_from'] вес от
    double $param['weight_to'] вес до
    double $param['price_from'] цена заказа от
    double $param['price_to'] цена заказа до
    string $param['description'] описание условия доставки
    double $param['price'] цена доставки
    int $param['currency] идентификатор валюты цены доставки
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного условия доставки

    Описание

    Метод, осуществляющий вставку условия доставки

    [ Top ]

    shop::InsertCountry

InsertCountry(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор страны
     string $param['name'] название области
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной области

    Описание

    Метод, осуществляющий вставку области

    [ Top ]

    shop::InsertCoupon

InsertCoupon(
array
$param );

    Принимаемые параметры

    $param

    массив с данными о купоне
     int $param['shop_coupon_id'] идентификатор купона
     int $param['shop_order_discount_id'] идентификатор скидки на сумму заказа
     str $param['shop_coupon_name'] название купона
     int $param['shop_coupon_active'] активность купона
     int $param['shop_coupon_count'] количество купонов
     int $param['shop_coupon_text'] текст купона
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор вставленного/обновленного купона или false

    Описание

    Метод для вставки/обновления информации о купоне

    [ Top ]

    shop::InsertCurrency

InsertCurrency(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    string $param['name'] параметр, определяющий название валюты
    string $param['currency_international_name'] интернациональное название валюты
    double $param['value_in_basic_currency'] значение курса валюты в базовой валюте
    boolean $param['is_default'] параметр, определяющий, является ли валюта базовой
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной валюты ( false при неудачной вставке)

    Описание

    Метод,осуществляющий вставку информации о валюте

    [ Top ]

    shop::InsertDiscount

InsertDiscount(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер скидки
    string $param['name'] наименование скидки
    date $param['from'] с какого времени действует скидка
    string $param['to'] по какое время действует скидка
    int $param['is_active'] активна ли скидка в настоящий момент
    numeric $param['percent'] процент скидки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает идентификационный номер вставленной скидки

    Описание

    Метод, осуществляющий вставку  информации о скидке

    [ Top ]

    shop::InsertGroup

InsertGroup(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификационный номер группы
     string $param['name'] имя группы
     int $param['shop_shops_id'] идентификатор магазина
     int $param['parent_id'] идентификатор родителя группы (в корне - 0)
     string $param['description'] описание группы
     string $param['image'] путь к изображению (логотипу) группы
     int $param['order'] порядок сортировки
     int $param['indexation'] флаг индексации
     string $param['path'] путь к группе
     string $param['seo_title'] заголовок страницы
     string $param['seo_description'] задание значения мета-тэга description страницы
     string $param['seo_keywords'] задание значения мета-тэга keywords страницы
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
     int $param['shop_groups_big_image_width'] ширина большой картинки
     int $param['shop_groups_big_image_height'] высота большой картинки
     int $param['shop_groups_small_image_width'] ширина маленькой картинки
     int $param['shop_groups_small_image_height'] высота маленькой картинки

    Возвращает

    возвращает идентификатор вставленной группы (false при неудачной вставке)

    Описание

    Метод, осуществляющий вставку группы, к которой могут относиться товары

    [ Top ]

    shop::InsertItem

InsertItem(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационнный номер товара
    string $param['name'] наименование товара
    string $param['description'] краткое описание товара
    string $param['shop_items_catalog_date_time'] дата добавления
    string $param['text'] детальное описание товара
    string $param['image'] путь к изображению товара
    double $param['weight'] вес товара
    int $param['rest'] количество оставшихся на складе единиц товара
    double $param['price'] цена товара для пользователя
    int $param['is_active'] флаг доступности товара
    int $param['order'] порядок сортировки товара
    int $param['indexation'] флаг индексации товара
    string $param['path'] путь к товару
    string $param['seo_title'] заголовок страницы товара
    string $param['seo_description'] задание значения мета-тэга description страницы товара
    string $param['seo_keywords'] задание значения мета-тэга keywords страницы товара
    int $param['shop_sallers_id'] значение идентификатора продавца товара
    int $param['shop_items_catalog_modification_id'] идентификатор основного товара для модификации, указывается если данный товар является модификацией
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификационный номер вставленного товара, false или -1

    Описание

    Метод, осуществляющий вставку информации о товаре

    [ Top ]

    shop::InsertItemDiscount

InsertItemDiscount(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_item_discount_id'] идентификатор обновляемой записи
     int $param['item_catalog_id'] идентификатор товара
     int $param['shop_discount_id'] идентификатор скидки

    Возвращает

    возвращает идентификатор вставленной записи

    Описание

    Метод вставки скидки для определенного товара

    [ Top ]

    shop::InsertLocation

InsertLocation(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор области
     string $param['name'] название области
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной области

    Описание

    Метод, осуществляющий вставку области

    [ Top ]

    shop::InsertMesure

InsertMesure(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационнный номер единицы измерения
    string $param['name'] наименование единицы измерения
    string $param['description'] описание единицы измерения
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает идентификационный номер вставленной единицы измерения

    Описание

    Метод, осуществляющий вставку  информации о единице измерения

    [ Top ]

    shop::InsertOrder

InsertOrder(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_shops_id'] идентификатор магазина
     int $param['location_id'] идентификатор области
     int $param['country_id'] идентификатор страны
     int $param['shop_city_id'] идентификатор города
     int $param['city_area_id'] идентификатор района
     int $param['shop_cond_of_delivery_id'] идентификатор способа доставки
     float $param['delivery_price'] стоимость доставки
     int $param['site_user_id'] идентификатор пользователя
     int $param['shop_order_status_id'] идентификатор статуса заказа
     int $param['currency_id'] идентификатор валюты
     int $param['shop_system_of_pay_id'] идентификатор платежной системы
     string $param['order_date_time'] дата заказа
     float $param['sum'] общая стоимость заказа
     int $param['status_of_pay'] статус оплаты
     string $param['date_of_pay'] дата оплаты
     string $param['address'] адрес доставки
     int $param['index'] почтовый индекс
     string $param['phone'] телефон пользователя
     string $param['description'] описание для заказа
     string $param['system_information'] системная информация для заказа
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного заказа

    Описание

    Метод, осуществляющий вставку заказа

    [ Top ]

    shop::InsertOrderDiscount

InsertOrderDiscount(
array
$param );

    Принимаемые параметры

    $param

    массив с параметрами скидки
     int $param['shop_order_discount_id'] идентификатор скидки (указывается в случае обновления)
     int $param['shop_shops_id'] идентификатор магазина
     int $param['shop_currency_id'] идентификатор валюты
     string $param['shop_order_discount_name'] название скидки
     int $param['shop_order_discount_sum_from'] скидка активна для сумм товара начиная с данной
     int $param['shop_order_discount_sum_to'] скидка активна для сумм товара не более данной
     int $param['shop_order_discount_active'] активность скидки
     int $param['shop_order_discount_active_from'] дата, начиная с которой данная скидка активна
     int $param['shop_order_discount_active_to'] дата до которой активна скидка
     int $param['shop_order_discount_type'] тип скидки (процент или фиксированная сумма)
     int $param['shop_order_discount_value'] величина скидки
     int $param['shop_order_discount_is_coupon'] применять скидку только к купонам - 1, обычная скидка - 0
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор вставленной/обновленной скидки или false

    Описание

    Метод для вставки/обновления информации о скидке для заказов

    [ Top ]

    shop::InsertOrderItems

InsertOrderItems(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_order_items_id'] идентификатор обновляемой записи
     int $param['shop_items_catalog_item_id'] идентификатор товара
     int $param['shop_order_id'] идентификатор заказа, которому принадлежит товар
     int $param['shop_order_items_quantity'] количество определенного товара в заказе
     float $param['shop_order_items_price'] цена товара в заказе
     string $param['shop_order_items_name'] наименование товара в заказе
     string $param['shop_order_items_marking'] артикул товара в заказе

    Возвращает

    идентификатор вставленного товара в заказ

    Описание

    Метод, осуществляющий вставку товара в заказ

    [ Top ]

    shop::InsertOrderStatus

InsertOrderStatus(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер статуса заказа
    string $param['name'] название состояния доставки
    string $param['description'] описание состояния доставки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного состояния доставки

    Описание

    Метод, осуществляющий вставку статуса заказа

    [ Top ]

    shop::InsertOrderWithoutSystemOfPay

InsertOrderWithoutSystemOfPay(
int
$shop_id, int
$user_id, [array
$additional_param = array()], [string
$xsl_name = false] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $user_id

    идентификатор пользователя сайта

    $additional_param

    массив с дополнительными параметрами
      $additional_param['description'] string описание для заказа  $additional_param['system_information'] string системная информация для заказа

    $xsl_name

    название xsl-шаблона (не обязательный параметр, передается при необходимости - вывести данные о заказе)

    Описание

    Метод вставки заказа, если платежная система не выбрана

    [ Top ]

    shop::InsertPrice

InsertPrice(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор цены
     string $param['name'] название цены
     double $param['percent_to_basic'] процент по отношению к базовой цене
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного типа цены

    Описание

    Метод, осуществляющий вставку типа цены

    [ Top ]

    shop::InsertPricesToItem

InsertPricesToItem(
mixed
$param, array
$param
 );

    Принимаемые параметры

    $param

    $param['shop_items_catalog_item_id'] - идентификатор элемента каталога
      $param['shop_list_of_prices_id'] - идентификатор дополнительной цены
      $param['shop_prices_to_item_value'] - значение дополнительной цены

    Возвращает

    идентификатор обновленной записи или false в случае ошибки

    Описание

    Метод вставки связи товара и цены из справочника цен

    [ Top ]

    shop::InsertProducer

InsertProducer(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификационный номер производителя
     string $param['name'] имя (название) производителя
     string $param['description'] краткая информация о производителе
     string $param['image'] путь к логотипу производителя
     int $param['order'] тип сортировки производителей
     string $param['path'] путь к производителю
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного производителя

    Описание

    Метод, осуществляющий вставку производителя

    [ Top ]

    shop::InsertPropertiesItem

InsertPropertiesItem(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вставляются свойства
     int $param['shop_list_of_properties_id'] идентификатор свойства товара
     int $param['shop_properties_items_value'] значение свойства товара

    Возвращает

    идентификатор вставленной записи

    Описание

    Метод вставки информации о дополнительных свойствах товра

    [ Top ]

    shop::InsertPropretyOfItems

InsertPropretyOfItems(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор свойства товаров
     string $param['name'] название свойства товара
     string $param['xml_name'] наименование xml-тега
     int $param['type'] тип свойства товара
     string $param['prefics'] префикс свойства товара (например: свыше, более, до ...)
     string $param['default_value'] значение свойства товара, устанавливаемое по умолчанию
     int $param['order'] порядок сортировки
     int $param['list_id'] порядок сортировки
     int $param['shop_list_of_properties_show_kind'] способ отображения в фильтре
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного товара в случае успешной вставки, ложь при возникновении ошибки

    Описание

    Метод, осуществляющий вставку свойства товара

    [ Top ]

    shop::InsertSeller

InsertSeller(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     string $param['shop_sallers_name'] имя (название) продавца
     string $param['shop_sallers_contact_person'] контактное лицо
     string $param['shop_sallers_comment'] комментарий к продавцу
     string $param['shop_sallers_address'] адрес продавца
     string $param['shop_sallers_phone'] телефон продавца
     string $param['shop_sallers_fax'] факс продавца
     string $param['shop_sallers_http'] сайт продавца
     string $param['shop_sallers_email'] e-mail продавца
     string $param['shop_sallers_inn'] ИНН продавца
     string $param['shop_shops_id'] идентификатор магазина
     string $param['shop_sallers_id'] идентификатор продавца, указывается если нужно обновить информацию  об уже существующем продавце.
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного или обновленного продавца.

    Описание

    Метод, осуществляющий вставку или обновление продавца.

    [ Top ]

    shop::InsertShop

InsertShop(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_id'] идентификатор магазина (указывается при обновлении)
     string $param['name'] наименование магазина
     int $param['site_id'] идентификатор сайта
     string $param['description'] описание магазина
     int $param['max_size_small_image'] максимальный размер минимальной картинки
     int $param['max_size_big_image'] максимальный размер большой картинки
     int $param['shop_country_id'] идентификатор страны по умолчанию
     int $param['shop_currency_id'] идентификатор валюты по умолчанию
     int $param['shop_order_status_id'] идентификатор состояния заказа по умолчанию
     int $param['shop_mesures_id'] идентификатор единицы измерения
     int $param['structure_id'] идентификатор узла структуры
     int $param['shop_shops_send_order_mail_admin'] флаг необходимости отправки письма о заказе администратору
     int $param['shop_shops_send_order_mail_user'] флаг необходимости отправки письма о заказе пользователю (заказчику)
     string $param['shop_shops_admin_mail'] адрес(а) куратора(ов) магазина
     int $param['shop_sort_order_field'] поле сортировки товара
     int $param['shop_sort_order_type'] тип сортировки товара
     int $param['shop_group_sort_order_field'] поле сортировки групп товара
     int $param['shop_group_sort_order_type'] тип сортировки групп товара
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
     int $param['shop_comment_active'] активность комментария к товару
     int $param['shop_company_id'] идентификатор компании
     string $param['watermark_file'] - файл марки для наложения на изображения
     string $param['watermark_file_expantion'] - расширение файла марки для наложения
     int $param['watermark_default_used'] - параметр, определяющий используется ли файл марки по умолчанию (1 - используется, 0 - не используется).
     int $param['watermark_default_used_small'] - параметр, определяющий используется ли файл марки по умолчанию для малых изображений(1 - используется, 0 - не используется).
     string $param['watermark_default_position_x'] - позиция изображения по оси X по умолчанию. По умолчанию равна 50%.
     string $param['watermark_default_position_y'] - позиция изображения по оси Y по умолчанию. По умолчанию равна 100%.

    Возвращает

    or boolean возвращает идентификационный номер вставленного магазина в случае успешного выполнения запроса или false в противном случае

    Описание

    Метод, осуществляющий вставку  информации о магазине

    [ Top ]

    shop::InsertSystemOfPay

InsertSystemOfPay(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор платёжной системы
     string $param['name'] название платёжной системы
     string $param['description'] описание платёжной системы
     int $param['is_active'] активна ли платёжная система
     string  $param['handler'] обработчик платёжной системы
     int $param['currency_id'] номер валюты
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной платёжной системы

    Описание

    Метод, осуществляющий вставку платёжной системы

    [ Top ]

    shop::InsertTax

InsertTax(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер налога
    string $param['name'] название налога
    double $param['rate'] ставка налога
    int $param['is_in_price'] входит ли налог в цену
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного налога

    Описание

    Метод, осуществляющий вставку налога

    [ Top ]

    shop::InsertToCart

InsertToCart(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    $param['user_id'] int идентификатор пользователя (при значение 0 или false - данные вставляем в кукисы)
    $param['shop_id'] int идентификатор магазина
    $param['item_id'] int идентификатор товара
    $param['postpone'] int флаг, указывающий на то является ли данный товар отложенным
    $param['count'] int колитчество заказываемого товара
    $param['get_info_isset_shop'] boolean флаг необходимости проверки наличия магазина

    Возвращает

    идентификатор вставленной записи или идентификатор единицы каталога, если вставка осуществлялась в кукисы, возвращает ложь в случае возникновения ошибки

    Описание

    Метод добавления информации о товаре в таблицу корзины

    [ Top ]

    shop::InsertTyingProducts

InsertTyingProducts(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_intermediate_id'] идетификатор записи о сопутствующем товаре
     int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вводится сопутствующий товар
     int $param['sho_shop_items_catalog_item_id'] идентификатор сопутствующего товара

    Описание

    Метод добавления информации о сопутствующем товаре

    [ Top ]

    shop::InsertTypeOfDelivery

InsertTypeOfDelivery(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор типа доставки
     string $param['name'] название типа доставки
     string $param['description'] описание типа доставки
     string $param['image'] путь к логотипу службы доставки
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного типа доставки

    Описание

    Метод, осуществляющий вставку типа доставки

    [ Top ]

    shop::IsOrderOfThisSiteUser

IsOrderOfThisSiteUser(
int
$shop_order_id, int
$site_users_id );

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа

    $site_users_id

    идентификатор пользователя

    Описание

    Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта

    [ Top ]

    shop::ProcessOrder

ProcessOrder(
int
$shop_id, int
$site_users_id, int
$system_of_pay_id, array
&$order_row );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя сайта, если false - определяем внутри метода

    $system_of_pay_id

    идентификатор системы оплаты

    &$order_row

    ВОЗВРАЩАЕТ информацию о заказе, в случае успешной вставки, иначе - false

    Возвращает

    результат выполнения метода,
     идентификатор добавленного заказа в случае успеха
     -1 ошибка вставки в БД
     -2 возможно не найден магазин

    Описание

    Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты

    [ Top ]

    shop::SelectAllItemsFromCartForUser

SelectAllItemsFromCartForUser(
int
$shop_id, int
$user_id );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $user_id

    идентификатор пользователя

    Возвращает

    ассоциативный массив, где $a_items['price'] общая цена товаров, $a_items['quantity'] общее число товаров

    Описание

    Метод получения количества элементов и их общей цены для заданного пользователя

    [ Top ]

    shop::SelectAllItemsFromCookieCart

SelectAllItemsFromCookieCart(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Описание

    Метод получения общего количества товаров, их общей стоимости и веса из корзины
    (в случае, когда пользователь не задан и данные корзины хранятся в кукисах)

    [ Top ]

    shop::SelectCityArea

SelectCityArea(
int
$city_area_id, [int
$city_id = 0] );

    Принимаемые параметры

    $city_area_id

    идентификатор района (при $city_area_id=-1 выбираем все районы)

    $city_id

    идентификатор города

    Возвращает

    информация о выбранных районах города (результат запроса) или ложь в случае возникновения ошибки

    Описание

    Метод получения информации о районе города (обо всех районах при $city_area_id=-1)

    [ Top ]

    shop::SelectPrice

SelectPrice(
int
$user_group_id );

    Принимаемые параметры

    $user_group_id

    идентификатор группы пользователей

    Возвращает

    or false массив информации о цене

    Описание

    Метод определения цены для заданной группы пользователей

    [ Top ]

    shop::SendMailAboutOrder

SendMailAboutOrder(
int
$shop_id, mixed
$shop_order_id, mixed
$site_user_id, [string
$xsl_name_for_admin = ''], [string
$xsl_name_for_user = ''], [string
$custom_email = false] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $xsl_name_for_admin

    имя XSL шаблона для письма админу

    $xsl_name_for_user

    имя XSL шаблона для письма юзеру

    $custom_email

    e-mail заказчика, если задан, то берется из этого параметра, а не из БД

    Возвращает

    результат работы ф-ции

    Описание

    Метод отправки писем о поступившем заказе пользователю и администратору

    [ Top ]

    shop::ShowAddress

ShowAddress(
string
$xsl_name, int
$shop_id );

    Принимаемые параметры

    $xsl_name

    имя XSL-шаблона

    $shop_id

    идентификатор магазина

    Описание

    Метод показа адреса для заказчика

    [ Top ]

    shop::ShowCart

ShowCart(
int
$shop_id, [int
$user_id = false], string
$xsl_name, [string
$shop_coupon_text = ''] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $user_id

    идентификатор пользователя, если false - определяем пользователя внутри метода.

    $xsl_name

    имя XSL-шаблона

    $shop_coupon_text

    текс купона

    Описание

    Метод показа содержимого корзины

    [ Top ]

    shop::ShowConfirmation

ShowConfirmation(
string
$xsl_name, [array
$external_propertys = array()] );

    Принимаемые параметры

    $xsl_name

    наименование xsl-шаблона

    $external_propertys

    дополнительные параметры, которые возможно необходимо будет вывести

    Описание

    Метод вывода сообщения о необходимости подтвердить аккаунт

    [ Top ]

    shop::ShowEnter

ShowEnter(
string
$xsl_name, [array
$external_propertys = array()] );

    Принимаемые параметры

    $xsl_name

    наименование xsl-шаблона в соответствии, с которым выводим данные

    $external_propertys

    дополнительные параметры, которые возможно необходимо будет вывести

    Описание

    Метод вывода формы для авторизации пользователя

    [ Top ]

    shop::ShowItem

ShowItem(
int
$item_id, string
$xsl_name, [array
$param = array()], [array
$external_propertys = array()] );

    Принимаемые параметры

    $item_id

    идентификатор товара

    $xsl_name

    название XSL шаблона

    $param

    доп. параметры

    $external_propertys

    доп. свойства, которые добавляются в XML

    Описание

    Метод вывода информации об элементе

    [ Top ]

    shop::ShowItemsCompare

ShowItemsCompare(
int
$shop_id, string
$xsl_name );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $xsl_name

    имя XSL-шаблона

    Возвращает

    в случае неудачи

    Описание

    Метод отображает сравнение выбранных товаров в магазине

    [ Top ]

    shop::ShowPriceList

ShowPriceList(
mixed
$shop_id );

    [ Top ]

    shop::ShowProducer

ShowProducer(
mixed
$producer_id, mixed
$xsl_name, [mixed
$param = array()] );

    [ Top ]

    shop::ShowProducersList

ShowProducersList(
str
$xsl_name, [array
$param = array()] );

    Принимаемые параметры

    $xsl_name

    имя XSL шаблона

    $param

    массив дополнительных параметров
      $param['shop_id'] идентификатор магазина

    Описание

    Метод формирования xml для производителей	 *

    [ Top ]

    shop::ShowSaller

ShowSaller(
int
$shop_sallers_id, string
$xsl_name );

    Принимаемые параметры

    $shop_sallers_id

    идентификатор продавца

    $xsl_name

    имя XSL шаблона

    Описание

    Метод для отображение информации о продавце в клиентской части

    [ Top ]

    shop::ShowShop

ShowShop(
int
$shop_id, string
$xsl_name, [array
$param = array()], [array
$external_propertys = array()] );

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $xsl_name

    имя XSL-шаблона

    $param

    ассоциативный массив параметров
    $param['current_group_id'] mixed идентификатор раздела магазина или массив идентификаторов, товары которого отображаются, если $param['current_group_id']=false, то отображаются элементы всех каталогов
    $param['items_begin'] номер товара в выборке, с которого начинать отображение товаров магазина
    $param['items_on_page'] число товаров, отображаемых на странице
    $param['items_field_order'] поле сортировки товаров каталога
    $param['items_order'] направление сортировки ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)
    $param['user_id'] идентификатор пользователя
    $param['group_field_order'] поле сортировки группы
    $param['group_order'] направление сортировки группы ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)
    $param['dec_reques_number'] использовать режим снижения количесва запросов, актуален для больших выборок
    $param['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
    $param['OrderGroup'] направление сортировки (ASC - по возрастанию, DESC - по убыванию)
    $param['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()
    $param['NotInGroup'] идентификатор групп информационных элементов, которые необходимо исключить из результатов
    $param['cache'] разрешение кэширования, по умолчанию true
    $param['select'] массив массивов $element, каждый из которых задает дополнительные условия отбора товаров

    $element['type'] определяет, является ли поле основным свойством информационного элемента или дополнительным (0 - основное, 1 - дополнительное)
    $element['prefix'] префикс - строка, размещаемая перед условием
    $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    $element['property_id'] идентификатор дополнительногого свойства
    $element['if'] строка, содержащая условный оператор
    $elemenr['value'] значение поля (или параметра)
    $element['sufix'] суффикс - строка, размещаемая после условия

    Например:
    $element = array();
    $element['type']=1; // 0 - основное св-во, 1 - дополнительное
    $element['prefix'] = 'and'; // префикс
    $element['property_id'] = 26; // ID дополнительного св-ва, указывается если тип = 1
    $element['if'] = '='; // Условие
    $element['value'] = '10';
    $element['sufix']='';
    $param['select'][]=$element; // Указываем очередное ограничение, введенное выше

    $element = array();
    $element['type']=1; // 0 - основное св-во, 1 - дополнительное
    $element['prefix'] = 'and'; // префикс
    $element['property_id'] = 28; // ID дополнительного св-ва, указывается если тип = 1
    $element['if'] = '='; // Условие
    $element['value'] = 1;
    $element['sufix']='';
    $param['select'][]=$element; // Указываем очередное ограничение, введенное выше

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код     *

    Описание

    Метод показа магазина

    [ Top ]

    shop::ShowSystemOfPay

ShowSystemOfPay(
string
$xsl_name, [array
$external_propertys = array()] );

    Принимаемые параметры

    $xsl_name

    имя XSL шаблона

    $external_propertys

    массив дополнительных  параметров

    Описание

    Метод построения XML для платежных систем

    [ Top ]

    shop::ShowTypeOfDelivery

ShowTypeOfDelivery(
mixed
$shop_shops_id, int
$country, int
$location, int
$city, int
$city_area, float
$weight, float
$price, string
$xsl_name, [mixed
$external_propertys = array()], int
$currency );

    Принимаемые параметры

    $country

    идентификатор страны (0-любая страна)

    $location

    идентификатор местоположения (области) (0-любая область)

    $city

    идентификатор города (0-любой город)

    $city_area

    идентификатор района (0-любой район)

    $weight

    вес корзины

    $price

    цена корзины

    $currency

    идентификатор валюты

    $xsl_name

    имя XSL-шаблона

    Описание

    Метод выбора и показа типов доставки

    [ Top ]

    shop::ShowUserOrders

ShowUserOrders(
int
$site_users_id, string
$xsl_name );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $xsl_name

    имя XSL шаблонав

    Возвращает

    в случае неудачи

    Описание

    Метод отображает информацию о заказах пользователя

    [ Top ]

    shop::show_link_location

show_link_location(
mixed
$a1, mixed
$a2, mixed
$separator );

    [ Top ]

    shop::UpdateCart

UpdateCart(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     $param['user_id'] int идентификатор пользователя (если передан 0 или ложь - работаем с кукисами)
     $param['shop_id'] int идентификатор магазина
     $param['item_id'] int идентификатор товара
     $param['cart_id'] int идентификатор корзины
     $param['count'] int количество товара в корзине
     $param['postpone'] int отложить ли товар для следующей покупки
    $param['get_info_isset_shop'] boolean флаг необходимости проверки наличия магазина

    Возвращает

    идентификатор отредактрованной записи или ложь в случае возникновения ошибки

    Описание

    Метод, осуществляющий обновление данных корзины

    [ Top ]

    shop::UpdateCity

UpdateCity(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор города
     string $param['name'] название города
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления города

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление города

    [ Top ]

    shop::UpdateCondOfDelivery

UpdateCondOfDelivery(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор условия доставки
    string $param['name'] название условия доставки
    int $param['type_of_delivery'] идентификатор типа доставки
    $param['location'] идентификатор области
    double $param['weight_from] вес от
    double $param['weight_to'] вес до
    double $param['price_from'] цена заказа от
    double $param['price_to'] цена заказа до
    string $param['description'] описание условия доставки
    double $param['price'] цена доставки
    int $param['currency] идентификатор валюты цены доставки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления условия доставки

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки

    [ Top ]

    shop::UpdateCountry

UpdateCountry(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор страны
     string $param['name'] название страны
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления страны

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление страны

    [ Top ]

    shop::UpdateCurrency

UpdateCurrency(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор обновляемого запроса
    string $param['name'] параметр, определяющий название валюты
    double $param['value_in_basic_currency'] значение курса валюты в базовой валюте
    boolean $param['is_default'] параметр, определяющий, является ли валюта базовой

    Возвращает

    возвращает результат обновления валюты ( false при неудачном обновлении)

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()

    [ Top ]

    shop::UpdateDiscount

UpdateDiscount(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер скидки
    string $param['name'] наименование скидки
    string $param['from'] с какого времени действует скидка
    string $param['to'] по какое время действует скидка
    boolean $param['is_active'] активна ли скидка в настоящий момент
    numeric $param['percent'] процент скидки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления информации о скидке

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке

    [ Top ]

    shop::UpdateGroup

UpdateGroup(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер группы
    int $param['shop_shops_id'] идентификатор магазина
    string $param['name'] имя группы
    string $param['parent_id'] идентификатор родителя группы (в корне - 0)
    string $param['description'] описание группы
    string $param['image'] путь к изображению (логотипу) группы
    int $param['order'] порядок сортировки
    int $param['indexation'] флаг индексации
    string $param['path'] путь к группе
    string $param['seo_title'] заголовок страницы
    string $param['seo_description'] задание значения мета-тэга description страницы
    string $param['seo_keywords'] задание значения мета-тэга keywords страницы
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает идентификатор обновленной группы (false при неудачном обновлении)

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары

    [ Top ]

    shop::UpdateImageForItem

UpdateImageForItem(
mixed
$shop_id, mixed
$shop_items_catalog_id, mixed
$shop_items_catalog_image, string
$item_image );

    Принимаемые параметры

    $item_image

    наименование файла изображения для товара

    Возвращает

    истина в случае удачного обновления, ложь в обратном случае

    Описание

    Метод обновления информации об изображении для товара

    [ Top ]

    shop::UpdateItem

UpdateItem(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационнный номер товара
    string $param['name'] наименование товара
    string $param['description'] краткое описание товара
    string $param['shop_items_catalog_date_time'] дата добавления товара
    string $param['text'] детальное описание товара
    string $param['image'] путь к изображению товара
    double $param['weight'] вес товара
    int $param['rest'] количество оставшихся на складе единиц товара
    double $param['price'] цена товара для пользователя
    int $param['is_active'] флаг доступности товара
    int $param['order'] порядок сортировки товара
    int $param['indexation'] флаг индексации товара
    string $param['path'] путь к товару
    string $param['seo_title'] заголовок страницы товара
    string $param['seo_description'] задание значения мета-тэга description страницы товара
    string $param['seo_keywords'] задание значения мета-тэга keywords страницы товара
    bool $param['delete_image'] удалять ли изображения для элемнетов, если передано пусток имя изображения, по умолчанию false
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления товара

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о товаре

    [ Top ]

    shop::UpdateItemDiscount

UpdateItemDiscount(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_item_discount_id'] идентификатор обновляемой записи
     int $param['item_catalog_id'] идентификатор товара
     int $param['shop_discount_id'] идентификатор скидки

    Возвращает

    возвращает идентификатор обновленной валюты ( false при неудачном обновлении)

    Описание

    УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара

    [ Top ]

    shop::UpdateItemPrice

UpdateItemPrice(
unknown_type
$param );

    Принимаемые параметры

    $param

    Описание

    Метод обновления связи товара и цены

    [ Top ]

    shop::UpdateLocation

UpdateLocation(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    string $param['name'] название области
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления области

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление области

    [ Top ]

    shop::UpdateMesure

UpdateMesure(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационнный номер единицы измерения
    string $param['name'] наименование единицы измерения
    string $param['description'] описание единицы измерения
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления информации о единице измерения

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения

    [ Top ]

    shop::UpdateOrder

UpdateOrder(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shops_id'] идентификатор магазина
     int $param['location_id'] идентификатор области
     int $param['country_id'] идентификатор страны
     int $param['city_id'] идентификатор города
     int $param['city_area_id'] идентификатор района
     int $param['cond_of_delivery_id'] идентификатор способа доставки
     float $param['delivery_price'] стоимость доставки
     int $param['users_id'] идентификатор пользователя
     int $param['delivery_id'] идентификатор статуса доставки
     int $param['currency_id'] идентификатор валюты
     int $param['system_of_pay_id'] идентификатор платежной системы
     string $param['date_time'] дата заказа
     float $param['sum'] общая стоимость заказа
     int $param['status_of_pay'] статус оплаты
     string $param['date_of_pay'] дата оплаты
     string $param['address'] адрес доставки
     int $param['index'] почтовый индекс
     string $param['phone'] телефон пользователя
     string $param['description'] описание для заказа
     string $param['system_information'] системная информация для заказа
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления заказа

    Описание

    Метод, осуществляющий обновление заказа

    [ Top ]

    shop::UpdateOrderItems

UpdateOrderItems(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_order_items_id'] идентификатор обновляемой записи
     int $param['shop_items_catalog_item_id'] идентификатор товара
     int $param['shop_order_id'] идентификатор заказа, которому принадлежит товар
     int $param['shop_order_items_quantity'] количество определенного товара в заказе
     float $param['shop_order_items_price'] цена товара в заказе
     string $param['shop_order_items_name'] наименование товара в заказе
     string $param['shop_order_items_marking'] артикул товара в заказе

    Возвращает

    идентификатор обновленного заказа или false в случае неудачи

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе

    [ Top ]

    shop::UpdateOrderPropretyOfItems

UpdateOrderPropretyOfItems(
int
$list_of_properties_id, int
$list_of_properties_order );

    Принимаемые параметры

    $list_of_properties_id

    идентификатор дополнительного свойства

    $list_of_properties_order

    порядок сортировки

    Возвращает

    идентификатор записи, если обновление прошло успешно, иначе - ложь

    Описание

    Метод изменения порядка сортировки дополнительных свойств товара

    [ Top ]

    shop::UpdatePrice

UpdatePrice(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор цены
     string $param['name'] название цены
     double $param['percent_to_basic'] процент по отношению к базовой цене
     string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления типа цены

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены

    [ Top ]

    shop::UpdatePricesToItem

UpdatePricesToItem(
array
$param );

    Принимаемые параметры

    $param

      $param['shop_prices_to_item_id'] - идентификатор из таблицы связи элементов каталога и значений дополнительных цен (не обязательное поле)
      $param['shop_items_catalog_item_id'] - идентификатор элемента каталога
      $param['shop_list_of_prices_id'] - идентификатор дополнительной цены
      $param['shop_prices_to_item_value'] - значение дополнительной цены

    Возвращает

    идентификатор обновленной записи или false в случае ошибки

    Описание

    Метод обновления дополнительной цены для элемента

    [ Top ]

    shop::UpdateProducer

UpdateProducer(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер производителя
    string $param['name'] имя (название) производителя
    string $param['description'] краткая информация о производителе
    string $param['image'] путь к логотипу производителя
    int $param['order'] порядок сортировки производителя
    string $param['path'] путь к производителю
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления информации о производителе

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе

    [ Top ]

    shop::UpdatePropertiesItem

UpdatePropertiesItem(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_properties_items_id'] идентификатор обновляемой записи
     int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вставляются свойства
     int $param['shop_list_of_properties_id'] идентификатор свойства товара
     int $param['shop_properties_items_value'] значение свойства товара

    Возвращает

    идентификатор обновленной записи

    Описание

    Метод обновления информации о дополнительных свойствах товара

    [ Top ]

    shop::UpdatePropretyOfItems

UpdatePropretyOfItems(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор свойства товаров
    string $param['name'] название свойства товара
    string $param['xml_name'] наименование xml-тега
    int $param['order'] порядок сортировки
    int $param['type'] тип свойства товара
    int $param['type'] тип свойства товара
    string $param['prefics'] префикс свойства товара (например: свыше, более, до ...)
    string $param['default_value'] значение свойства товара, устанавливаемое по умолчанию
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор обновленной записи, ложь - если обновление не произведено

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара

    [ Top ]

    shop::UpdateShop

UpdateShop(
mixed
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине

    [ Top ]

    shop::UpdateSystemOfPay

UpdateSystemOfPay(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор платёжной системы
     string $param['name'] название платёжной системы
     string $param['description'] описание платёжной системы
     int $param['is_active'] активна ли платёжная система
     string $param['handler'] обработчик платёжной системы
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления платёжной системы

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы

    [ Top ]

    shop::UpdateTax

UpdateTax(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер налога
    string $param['name'] название налога
    double $param['rate'] ставка налога
    int $param['is_in_price'] входит ли налог в цену
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления налога

    Описание

    Метод, осуществляющий обновление налога

    [ Top ]

    shop::UpdateTyingProducts

UpdateTyingProducts(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['shop_intermediate_id'] идетификатор записи о сопутствующем товаре
     int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вводится сопутствующий товар
     int $param['sho_shop_items_catalog_item_id'] идентификатор сопутствующего товара

    Возвращает

    идентификатор результата обновления

    Описание

    УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах

    [ Top ]

    shop::UpdateTypeOfDelivery

UpdateTypeOfDelivery(
array
$param );

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     int $param['id'] идентификатор типа доставки
     string $param['name'] название типа доставки
     string $param['description'] описание типа доставки
     string $param['image'] путь к логотипу службы доставки
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления типа доставки

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки

    [ Top ]

    shop::YandexMarket

YandexMarket(
int
$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    данные в формате XML

    Описание

    Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и возвращает XML данные.

    [ Top ]

Описания переменных

  • $CacheModificationItems =  [Строка 65]
    •

  • Data type: array
    •

    Описание

    Массив ID модификаций товара для товаров

  • $cache_mesure =  [Строка 155]
    •

  • Data type: array
    •

    Описание

    Кэш информации о единицах измерений

  • $cache_producer =  [Строка 148]
    •

  • Data type: array
    •

    Описание

    Кэш информации о производителях

  • $count_row_city_areas =  0 [Строка 84]
    •

  • Data type: int
    •

    Описание

    Количество выбранных районов города

  • $error =  [Строка 67]
    •

  • Data type: mixed
    •

  • $hidden =  "" [Строка 77]
    •

  • Data type: mixed
    •

  • $item_catalog_price =  0 [Строка 113]
    •

  • Data type: float
    •

    Описание

    Цена товара магазина

  • $MasGroup = array() [Строка 79]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class show_table

Class show_table

[Строка 200]

Размещен: /Kernel/show_table.class.php

Свойства класса

  • $action_width = 70

  • $aling =  ''

  • $button = false

  • $button_name = ''

  • $button_value = 'Добавить/изменить'

  • $copy_show = false

  • $delete_confirm = 'Вы уверены, что хотите удалить?'

  • $delete_show = true

  • $edit_show = true

  • $field_action_show = true

  • $field_copy = ''

  • $field_delete = ''

  • $field_edit = ''

  • $form_action = ''

  • $html = ''

  • $image = ''

  • $key_id =

  • $mas =

  • $query =

  • $table_width = '100%'

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void do_show_table()

    Метод отображает сформированную таблицу

  • string GetSelect()

    Метод формирования html содержимого тега select

  • void SetActionWidth()

    Изменяет ширину поля Действие

  • void SetButton()

    Изменяет флаг вывода кнопки

  • void SetButtonName()

    Устанавливает наименование кнопки

  • void SetButtonValue()

    Изменяет value кнопки

  • void SetCopyShow()

    Изменяет флаг показа кнопки для копирования

  • void SetDeleteConfirm()

    Изменяет сообщение, выводимое при удалении

  • void SetDeleteShow()

    Изменяет флаг показа кнопки удалить

  • void SetEditShow()

    Изменяет флаг показа кнопки редактировать

  • void SetFieldActionShow()

    Изменяет флаг вывода поля с действиями

  • void SetFieldCopy()

    Изменяет поле для копирования

  • void SetFieldDelete()

    Изменяет поле для удаления

  • void SetFieldEdit()

    Изменяет поле для редактирования

  • void SetFormAction()

    Изменяет action формы

  • void SetHtml()

    Устанавливает значение свойству html

  • void SetImage()

    Изменяет значение свойства - путь к картинке

  • void SetKeyId()

    Изменяет ключевое поле

  • void SetMas()

    Изменяет массив экземпляров класса table_fields

  • void SetQuery()

    Изменяет запрос для выборки данных

  • void SetTableWidth()

    Изменяет ширину таблицы

Унаследованные методы

Описания методов

    show_table::do_show_table

do_show_table(
 );

    Описание

    Метод отображает сформированную таблицу

    [ Top ]

    show_table::GetSelect

GetSelect(
array
$mas, string
$index_selected );

    Принимаемые параметры

    $mas

    - массив, элементами которого заполняется тег select

    $index_selected

    - индекс элемента, выводимого по умолчанию

    Возвращает

    html-содержимого тега select

    Описание

    Метод формирования html содержимого тега select

    [ Top ]

    show_table::SetActionWidth

SetActionWidth(
string
$action_width );

    Принимаемые параметры

    $action_width

    - ширина поля Действие

    Описание

    Изменяет ширину поля Действие

    [ Top ]

    show_table::SetButton

SetButton(
unknown_type
$button );

    Принимаемые параметры

    $button

    Описание

    Изменяет флаг вывода кнопки

    [ Top ]

    show_table::SetButtonName

SetButtonName(
string
$button_name );

    Принимаемые параметры

    $button_name

    Описание

    Устанавливает наименование кнопки

    [ Top ]

    show_table::SetButtonValue

SetButtonValue(
unknown_type
$button_value );

    Принимаемые параметры

    $button_value

    Описание

    Изменяет value кнопки

    [ Top ]

    show_table::SetCopyShow

SetCopyShow(
boolean
$copy_show );

    Принимаемые параметры

    $copy_show

    - значение флага показа кнопки копирования

    Описание

    Изменяет флаг показа кнопки для копирования

    [ Top ]

    show_table::SetDeleteConfirm

SetDeleteConfirm(
string
$delete_confirm );

    Принимаемые параметры

    $delete_confirm

    - сообщение выводимое при удалении строки

    Описание

    Изменяет сообщение, выводимое при удалении

    [ Top ]

    show_table::SetDeleteShow

SetDeleteShow(
boolean
$delete_show );

    Принимаемые параметры

    $delete_show

    - значение флага показа кнопки удаления

    Описание

    Изменяет флаг показа кнопки удалить

    [ Top ]

    show_table::SetEditShow

SetEditShow(
boolean
$edit_show );

    Принимаемые параметры

    $edit_show

    - значение флага показа кнопки редактирования

    Описание

    Изменяет флаг показа кнопки редактировать

    [ Top ]

    show_table::SetFieldActionShow

SetFieldActionShow(
boolean
$field_action_show );

    Принимаемые параметры

    $field_action_show

    - значение флага вывода поля с действиями

    Описание

    Изменяет флаг вывода поля с действиями

    [ Top ]

    show_table::SetFieldCopy

SetFieldCopy(
int
$field_copy );

    Принимаемые параметры

    $field_copy

    - идентификатор поля для копирования

    Описание

    Изменяет поле для копирования

    [ Top ]

    show_table::SetFieldDelete

SetFieldDelete(
int
$field_delete );

    Принимаемые параметры

    $field_delete

    - идентификатор поля для удаления

    Описание

    Изменяет поле для удаления

    [ Top ]

    show_table::SetFieldEdit

SetFieldEdit(
unknown_type
$field_edit );

    Принимаемые параметры

    $field_edit

    Описание

    Изменяет поле для редактирования

    [ Top ]

    show_table::SetFormAction

SetFormAction(
unknown_type
$form_action );

    Принимаемые параметры

    $form_action

    Описание

    Изменяет action формы

    [ Top ]

    show_table::SetHtml

SetHtml(
string
$html );

    Принимаемые параметры

    $html

    - значение свойства $html

    Описание

    Устанавливает значение свойству html

    [ Top ]

    show_table::SetImage

SetImage(
string
$image );

    Принимаемые параметры

    $image

    - путь к изображению, выводимому вместо значения поля

    Описание

    Изменяет значение свойства - путь к картинке

    [ Top ]

    show_table::SetKeyId

SetKeyId(
int
$key_id );

    Принимаемые параметры

    $key_id

    Описание

    Изменяет ключевое поле

    [ Top ]

    show_table::SetMas

SetMas(
string
$mas );

    Принимаемые параметры

    $mas

    Описание

    Изменяет массив экземпляров класса table_fields

    [ Top ]

    show_table::SetQuery

SetQuery(
string
$query );

    Принимаемые параметры

    $query

    Описание

    Изменяет запрос для выборки данных

    [ Top ]

    show_table::SetTableWidth

SetTableWidth(
string
$table_width );

    Принимаемые параметры

    $table_width

    - ширина таблицы

    Описание

    Изменяет ширину таблицы

    [ Top ]

Описания переменных

  • $action_width = 70 [Строка 218]
    •

  • Data type: mixed
    •

  • $aling =  '' [Строка 221]
    •

  • Data type: mixed
    •

  • $button = false [Строка 205]
    •

  • Data type: mixed
    •

  • $button_name = '' [Строка 206]
    •

  • Data type: mixed
    •

  • $button_value = 'Добавить/изменить' [Строка 207]
    •

  • Data type: mixed
    •

  • $copy_show = false [Строка 215]
    •

  • Data type: mixed
    •

  • $delete_confirm = 'Вы уверены, что хотите удалить?' [Строка 220]
    •

  • Data type: mixed
    •

  • $delete_show = true [Строка 214]
    •

  • Data type: mixed
    •

  • $edit_show = true [Строка 213]
    •

  • Data type: mixed
    •

  • $field_action_show = true [Строка 212]
    •

  • Data type: mixed
    •

  • $field_copy = '' [Строка 211]
    •

  • Data type: mixed
    •

  • $field_delete = '' [Строка 210]
    •

  • Data type: mixed
    •

  • $field_edit = '' [Строка 209]
    •

  • Data type: mixed
    •

  • $form_action = '' [Строка 208]
    •

  • Data type: mixed
    •

  • $html = '' [Строка 216]
    •

  • Data type: mixed
    •

  • $image = '' [Строка 219]
    •

  • Data type: mixed
    •

  • $key_id =  [Строка 204]
    •

  • Data type: mixed
    •

  • $mas =  [Строка 203]
    •

  • Data type: mixed
    •

  • $query =  [Строка 202]
    •

  • Data type: mixed
    •

  • $table_width = '100%' [Строка 217]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class table_fields

Class table_fields

[Строка 7]

Размещен: /Kernel/show_table.class.php

Свойства класса

  • $additional_attribute = ''

  • $additional_filed = ''

  • $additional_filed_value = ''

  • $align = 'align=left'

  • $align_title = 'align=center'

  • $array = ''

  • $attribute = ''

  • $checked = '1'

  • $count_mark_after_separator = 2

  • $dec_point = '.'

  • $field =

  • $FieldForIndexArray = ''

  • $field_description =

  • $field_link = ''

  • $field_name =

  • $field_prefix = ''

  • $field_type = 0

  • $image = ''

  • $image_is_link = false

  • $image_link = ''

  • $IndexForArray = ''

  • $mas_image =

  • $size = 5

  • $thousands_sep = ' '

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • table_fields table_fields()

    Метод, установления свойств класса

Унаследованные методы

Описания методов

    table_fields::table_fields

table_fields(
[mixed
$mas = array()], array
$mas
 );

    Принимаемые параметры

    $mas

    $mas['field_description'] - название столбца таблицы  $mas['field_name'] - наименования поля  $mas['field_type'] - тип столбца  $mas['field_prefix'] - префикс имени  $mas['field_link'] - ссылка  $mas['checked'] - свойства, определяющее является ли элемент элемент checkbox в столбце выделенным  $mas['align'] - выравнивание для поля  $mas['align_title'] - выравнивание для заголовка  $mas['size'] - длина поля ввода  $mas['attribute'] - свойство, содержащее  значения атрибутов столбца таблицы  $mas['mas_image'] - массив картинок для значений поля  $mas['field'] - наименование поля при выводе картинки вместо значения поля  $mas['image_is_link'] - параметр, указывающий является изображение, выводимое вместо значения поля ссылкой;  $mas['image_link'] - текст, дописываемый для картинки-ссылки  $mas['FieldForIndexArray'] -  имя поля, служащего индексом для ассоциативного массива  $mas['array'] - параметр, используемый для вывода массива  $mas['additional_filed'] - параметр - дополнительное поле, определяющий выводим мы дополнительные атрибуты или нет  $mas['additional_filed_value'] - значение параметра $mas['additional_filed'], при котором мы выводим дополнительные атрибуты  $mas['additional_attribute'] - ширина и другие атрибуты ячейки, применение которых зависит от дополнительного поля  $mas['image'] - путь к файлу картинки  $mas['count_mark_after_separator'] - количество знаков после запятой для форматирования строки  $mas['dec_point'] - разделитель, используемый в качестве десятичной точки  $mas['thousands_sep'] - разделитель для групп (по умолчанию пробел)

    Описание

    Метод, установления свойств класса

    [ Top ]

Описания переменных

  • $additional_attribute = '' [Строка 39]
    •

  • Data type: mixed
    •

  • $additional_filed = '' [Строка 37]
    •

  • Data type: mixed
    •

  • $additional_filed_value = '' [Строка 38]
    •

  • Data type: mixed
    •

  • $align = 'align=left' [Строка 26]
    •

  • Data type: mixed
    •

  • $align_title = 'align=center' [Строка 27]
    •

  • Data type: mixed
    •

  • $array = '' [Строка 36]
    •

  • Data type: mixed
    •

  • $attribute = '' [Строка 29]
    •

  • Data type: mixed
    •

  • $checked = '1' [Строка 25]
    •

  • Data type: mixed
    •

  • $count_mark_after_separator = 2 [Строка 42]
    •

  • Data type: mixed
    •

  • $dec_point = '.' [Строка 43]
    •

  • Data type: mixed
    •

  • $field =  [Строка 31]
    •

  • Data type: mixed
    •

  • $FieldForIndexArray = '' [Строка 34]
    •

  • Data type: mixed
    •

  • $field_description =  [Строка 9]
    •

  • Data type: mixed
    •

  • $field_link = '' [Строка 24]
    •

  • Data type: mixed
    •

  • $field_name =  [Строка 10]
    •

  • Data type: mixed
    •

  • $field_prefix = '' [Строка 23]
    •

  • Data type: mixed
    •

  • $field_type = 0 [Строка 11]
    •

  • Data type: mixed
    •

  • $image = '' [Строка 40]
    •

  • Data type: mixed
    •

  • $image_is_link = false [Строка 32]
    •

  • Data type: mixed
    •

  • $image_link = '' [Строка 33]
    •

  • Data type: mixed
    •

  • $IndexForArray = '' [Строка 35]
    •

  • Data type: mixed
    •

  • $mas_image =  [Строка 30]
    •

  • Data type: mixed
    •

  • $size = 5 [Строка 28]
    •

  • Data type: mixed
    •

  • $thousands_sep = ' ' [Строка 44]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class site

Class site

[Строка 11]

Размещен: /Site/Site.class.php

Описание

Класс модуля "Сайты"

Свойства класса

  • $CacheSite =

        Кэш данных о сайтах

  • $count_row =

  • $current_alias_cache =

  • $error =

  • $record_on_page = ON_PAGE

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • true current_alias()

    Метод преобразования алиаса (домена) сайта в основной

  • bool del_alias()

    Метод преобразования алиаса (домена) сайта в основной

  • resource del_site()

    Метод удаления информации о сайте

  • mixed GetAlias()

    Метод получения данных об алиасе сайта

  • mixed GetAliasById()

    Метод возвращает информацию об алиасе (домене)

  • resource GetAllAlias()

    Метод возвращает информацию обо всех доменах

  • string GetCurrentAlias()

    Метод определения основного алиаса сайта

  • array GetSite()

    Метод получения данных о сайте по его  идентификатору

  • int insert_alias()

    Метод вставки/обновления информации об алиасе (домене) сайта

  • int insert_site()

    Метод вставки/обновления информации о сайте

  • resource SelectSites()

    Метод выбора всех сайтов, поддерживаемых системой управления

  • resource select_alias()

    Метод получения информации об алиасе (домене) сайта

  • resource select_site()

    Метод получения данных о сайте

Унаследованные методы

Описания методов

    site::current_alias

current_alias(
unknown_type
$site_id, unknown_type
$id );

    Принимаемые параметры

    $site_id

    – идентификатор сайта

    $id

    – идентификатор алиаса сайта, который необходимо сделать основным

    Описание

    Метод преобразования алиаса (домена) сайта в основной

    [ Top ]

    site::del_alias

del_alias(
int
$id );

    Принимаемые параметры

    $id

    – – идентификатор алиаса сайта, который необходимо сделать основным

    Возвращает

    результат работы ф-ции

    Описание

    Метод преобразования алиаса (домена) сайта в основной

    [ Top ]

    site::del_site

del_site(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор удаляемого сайта

    Возвращает

    рузельтат выполнения запроса

    Описание

    Метод удаления информации о сайте

    [ Top ]

    site::GetAlias

GetAlias(
string
$alias_name, [array
$param = array()] );

    Принимаемые параметры

    $alias_name

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    array данные об алиасе, false - если алиас не найден

    Описание

    Метод получения данных об алиасе сайта

    [ Top ]

    site::GetAliasById

GetAliasById(
int
$alias_id );

    Принимаемые параметры

    $alias_id

    идентификатор домена

    Возвращает

    ассоциативный массив с информацией об алиасе или false

    Описание

    Метод возвращает информацию об алиасе (домене)

    [ Top ]

    site::GetAllAlias

GetAllAlias(
[int
$site_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит домен, если false - учитываются все сайты

    Возвращает

    с информацией о доменах (алиасах)

    Описание

    Метод возвращает информацию обо всех доменах

    [ Top ]

    site::GetCurrentAlias

GetCurrentAlias(
int
$site_id );

    Принимаемые параметры

    $site_id

    – идентификатор сайта

    Возвращает

    имя основного алиаса сайта или false – в случае если основной алиас не найден

    Описание

    Метод определения основного алиаса сайта

    [ Top ]

    site::GetSite

GetSite(
[int
$site_id = CURRENT_SITE], array
$param );

    Принимаемые параметры

    $site_id

    – идентификатор сайта (по умолчанию равен идентификатору текущего сайта)

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с информацией о сайте, если такой сайт существует или false – в противном случае

    Описание

    Метод получения данных о сайте по его  идентификатору

    [ Top ]

    site::insert_alias

insert_alias(
int
$type, int
$alias_id, int
$site_id, string
$alias_name, int
$alias_current, [int
$users_id = false] );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации об алиасе сайта (0 – вставка, 1 - обновление)

    $alias_id

    – идентификатор обновляемого алиаса сайта (при вставке алиаса равен 0)

    $site_id

    – идентификатор сайта, для которого добавляется/обновляется алиас

    $alias_name

    – название алиаса сайта

    $alias_current

    – параметр, указывающий является ли алиас сайта основным (1 – основной, 0 - неосновной)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор добавляемого/обновляемого алиаса сайта

    Описание

    Метод вставки/обновления информации об алиасе (домене) сайта

    [ Top ]

    site::insert_site

insert_site(
int
$type, int
$site_id, string
$site_name, int
$site_is_active, string
$site_coding, int
$site_order, string
$site_locale, int
$site_max_size_load_image, int
$site_max_size_load_image_big, string
$site_admin_email, string
$site_backup_dir, string
$site_chmod, string
$site_files_chmod, string
$site_date_format, string
$site_date_time_format, string
$site_error, int
$site_error404, int
$site_access_denied, string
$site_robots, mixed
$site_key, mixed
$site_contract_number, mixed
$site_pin, [int
$users_id = false], string
$site_key='' );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации о сайте (0 – вставка, 1 - обновление)

    $site_id

    – идентификатор сайта, информация о котором обновляется

    $site_name

    – название добавляемого/обновляемого сайта

    $site_is_active

    – параметр, определяющий  активность (доступность) сайта (1 – активен,    0 - неактивен)

    $site_coding

    – кодировка, используемая сайтом

    $site_order

    – порядок сортировки сайта в административной части

    $site_locale

    – используемая локаль

    $site_max_size_load_image

    – максимальный размер малых изображений загружаемых на сайт

    $site_max_size_load_image_big

    – максимальный размер больших картинок загружаемых на сайт

    $site_admin_email

    – электронный адрес администратора сайта

    $site_backup_dir

    – адрес директории для резервных копий

    $site_chmod

    – права доступа к файлам

    $site_files_chmod

    – права доступа к файлам

    $site_date_format

    – формат даты

    $site_date_time_format

    – формат даты-времени

    $site_error

    – режим вывода ошибок

    $site_error404

    – страница, отображаемая при возникновении 404 ошибки (страница не найдена),  если страница не указана, производится редирект на главную страницу

    $site_access_denied

    – страница, отображаемая при попытке доступа пользователя, не имеющего права доступа

    $site_robots

    – содержимое файла robots.txt для данного сайта

    $site_key=''

    - регистрационный ключ

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор добавленного или обновленного сайта

    Описание

    Метод вставки/обновления информации о сайте

    [ Top ]

    site::SelectSites

SelectSites(
[array
$param = array()] );

    Принимаемые параметры

    $param

    массив дополнительных параметров, необязательный параметр
    $param['limit0'] - с какого совпадения начинать отбор, по умолчанию 0
    $param['limit1'] - число элементов для выбора, по умолчанию не ограничено

    Описание

    Метод выбора всех сайтов, поддерживаемых системой управления

    [ Top ]

    site::select_alias

select_alias(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор алиаса, о котором необходимо получить информацию, -1 - выбрать все

    Возвращает

    данные об алиасе сайта

    Описание

    Метод получения информации об алиасе (домене) сайта

    [ Top ]

    site::select_site

select_site(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор сайта, -1 выбрать все

    Описание

    Метод получения данных о сайте

    [ Top ]

Описания переменных

  • $CacheSite =  [Строка 24]
    •

  • Data type: unknown_type
    •

    Описание

    Кэш данных о сайтах

  • $count_row =  [Строка 15]
    •

  • Data type: mixed
    •

  • $current_alias_cache =  [Строка 17]
    •

  • Data type: mixed
    •

  • $error =  [Строка 13]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [Строка 14]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class SiteUsers

Class SiteUsers

[Строка 11]

Размещен: /Site_users/Site_users.class.php

Описание

Класс модуля "Пользователи сайта"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean CopyExtraProperty()

    Метод копирования дополнительного параметра

  • boolean DeleteExtraProperty()

    Метод удаления дополнительного параматра

  • boolean DeleteSiteUser()

    Метод удаления пользователя из системы

  • boolean DelGroupUser()

    Метод удаления пользователя из группы

  • boolean DelUserGroup()

    Метод удаления группы пользователей заданной идентификатором

  • resource GetAllUsers()

    Метод выборки всех пользователей сайта

  • int GetCurrentSiteUser()

    Метод определения идентификатора текущего пользователя сайта.

  • mixed:
     GetDefaultGroup()

    Метод получения id группы используемой по умолчанию

  • mixed GetExtraProperty()

    Метод получения значения свойств дополнительного параметра

  • array GetGroupsForUser()

    Метод определения идентификаторов групп, в которые входит пользователь

  • array GetListExtraProperties()

    Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором

  • mixed GetListPrimaryProperties()

    УСТАРЕВШИЙ Метод получения основных данных о пользователе

  • mixed GetSiteUser()

    Метод получения информации о пользователе сайта

  • string GetSiteUserXml()

    Метод формирования XML с данными о пользователе

  • unknown GetUserDir()

    Метод возвращает абсолютный путь к директории пользователя сайта

  • array GetUserGroups()

    УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.

  • unknown GetUsersDir()

    Метод возвращает абсолютный путь к директории для хранения файлов пользователей

  • mixed: GetValueExtraProperty()

    Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра

  • int InsertExtraProperty()

    Метод добавления/редактирования дополнительного параметра

  • int InsertSiteUser()

    Метод добавления нового пользователя в систему

  • boolean InsertUserGroup()

    Метод вставки и обновления информации о группе пользователей

  • boolean InsertUsers()

    Метод добавления пользователя в группу

  • boolean OrderExtraProperty()

    Метод обновления коэффициентов порядка сортировки

  • void PrivateOfficeXML()

    УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.

  • resource SelectUserType()

    Метод возвращает параметры группы пользователя

  • boolean SendNewPassword()

    Метод отправки нового пароля на почтовый ящик пользователю

  • boolean SendRegistInf()

    Метод отправки пользователю регистрационной информации

  • boolean SetConfirmation()

    Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)

  • int SetConfirmationID()

    Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки

  • void SetCurrentSiteUser()

    Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток

  • boolean SetDefaultGroup()

    Метод установления группы с указанным идентификатором по умолчанию

  • boolean SetValueExtraProperty()

    Метод установки значения дополнительного параметра пользователя

  • void ShowSiteUserRegistartion()

    Метод вывода формы регистрации для пользователя сайта

  • void ShowUserOffice()

    Метод отображения кабинета пользователя

  • boolean Unregistration()

    Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя

  • void UnsetCurrentSiteUser()

    Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из кабинета пользователя

  • mixed:
     UpdateSiteUser()

    Метод обновления анкетных данных пользователя

  •  ValidUser()

    Метод возвращает идентификатор пользователя по его логину и паролю

Унаследованные методы

Описания методов

    SiteUsers::CopyExtraProperty

CopyExtraProperty(
int
$extraproperty_id );

    Принимаемые параметры

    $extraproperty_id

    идентификатор копируемого дополнительного параметра

    Описание

    Метод копирования дополнительного параметра

    [ Top ]

    SiteUsers::DeleteExtraProperty

DeleteExtraProperty(
int
$extraproperty_id );

    Принимаемые параметры

    $extraproperty_id

    идентификатор дополнительного параметра

    Описание

    Метод удаления дополнительного параматра

    [ Top ]

    SiteUsers::DeleteSiteUser

DeleteSiteUser(
int
$site_users_id );

    Принимаемые параметры

    $site_users_id

    - идентификатор удаляемого пользователя

    Описание

    Метод удаления пользователя из системы

    [ Top ]

    SiteUsers::DelGroupUser

DelGroupUser(
int
$site_users_id, [mixed
$site_users_group_id = -1], int
$site_users_group_id=-1 );

    Принимаемые параметры

    $site_users_id

    идентификатор группы

    $site_users_group_id=-1

    идентификатор пользователя сайта(-1 исключаем пользователя из всех групп)

    Описание

    Метод удаления пользователя из группы

    [ Top ]

    SiteUsers::DelUserGroup

DelUserGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы пользователей

    Описание

    Метод удаления группы пользователей заданной идентификатором

    [ Top ]

    SiteUsers::GetAllUsers

GetAllUsers(
[array
$param = array()] );

    Принимаемые параметры

    $param

    массив дополнительных ограничений для выборки
     $param['site_users_group_id'] int идентификатор группы пользователей

    Возвращает

    результат выборки пользователей

    Описание

    Метод выборки всех пользователей сайта

    [ Top ]

    SiteUsers::GetCurrentSiteUser

GetCurrentSiteUser(
 );

    Возвращает

    идентификатор текущего пользователя сайта (пользователь не задан - 0)

    Описание

    Метод определения идентификатора текущего пользователя сайта.

    [ Top ]

    SiteUsers::GetDefaultGroup

GetDefaultGroup(
 );

    Возвращает

    int идентификатор группы используемой по умолчанию,
      boolean false если запись не найдена

    Описание

    Метод получения id группы используемой по умолчанию

    [ Top ]

    SiteUsers::GetExtraProperty

GetExtraProperty(
string
$site_users_extra_property_name );

    Принимаемые параметры

    $site_users_extra_property_name

    имя дополнительного параметра

    Возвращает

    данные о стовйстве

    Описание

    Метод получения значения свойств дополнительного параметра

    [ Top ]

    SiteUsers::GetGroupsForUser

GetGroupsForUser(
int
$site_users_id );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    Возвращает

    ассоциативный массив с идентификаторами групп.

    Описание

    Метод определения идентификаторов групп, в которые входит пользователь

    [ Top ]

    SiteUsers::GetListExtraProperties

GetListExtraProperties(
int
$site_user_id );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    Возвращает

    массив характеристик дополнительных параметров:
      $result[$i]['site_users_extra_property_id'] int идентификатор;
      $result[$i]['site_users_extra_property_name'] string имя;
      $result[$i]['site_users_extra_property_title'] string название;
      $result[$i]['site_users_extra_property_type'] string тип;
      $result[$i]['site_users_extra_property_size'] int размер значения;
      $result[$i]['site_users_extra_property_rows'] int количество строк;
      $result[$i]['site_users_extra_property_cols'] int количество столбцов;
      $result[$i]['site_users_extra_property_checked'] int выбран(1) или нет(0);
      $result[$i]['site_users_extra_property_default_value'] mixed значение по умолчанию;
      $result[$i]['site_users_extra_property_order'] int порядок сортировки;
      $result[$i]['site_users_extra_property_comment'] string коментарий;
      $result[$i]['lists_id'] int идентификатор списка;
      $result[$i]['site_users_property_value'] mixed значение

    Описание

    Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором

    [ Top ]

    SiteUsers::GetListPrimaryProperties

GetListPrimaryProperties(
int
$site_user_id );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    Возвращает

    ассоциативный массив с данными или false если пользователь не найден

    Описание

    УСТАРЕВШИЙ Метод получения основных данных о пользователе

    [ Top ]

    SiteUsers::GetSiteUser

GetSiteUser(
int
$site_user_id, [array
$param = array()] );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    информация о пользователе, если пользователь есть в базе, иначе - ложь

    Описание

    Метод получения информации о пользователе сайта

    [ Top ]

    SiteUsers::GetSiteUserXml

GetSiteUserXml(
int
$site_user_id, [array
$external_property = array()], [mixed
$default_property = array()] );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    $external_property

    массив дополнительных параметров

    Возвращает

    сформированный xml для регистрации

    Описание

    Метод формирования XML с данными о пользователе

    [ Top ]

    SiteUsers::GetUserDir

GetUserDir(
unknown_type
$site_users_id );

    Принимаемые параметры

    $site_users_id

    Описание

    Метод возвращает абсолютный путь к директории пользователя сайта

    [ Top ]

    SiteUsers::GetUserGroups

GetUserGroups(
int
$site_users_id );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    Возвращает

    ассоциативный массив, индексы которого - идентификаторы групп, а значения единицы

    Описание

    УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.

    Вместо него рекоменджуется использовать GetGroupsForUser($site_users_id)

    [ Top ]

    SiteUsers::GetUsersDir

GetUsersDir(
 );

    Описание

    Метод возвращает абсолютный путь к директории для хранения файлов пользователей

    [ Top ]

    SiteUsers::GetValueExtraProperty

GetValueExtraProperty(
int
$site_users_id, string
$name_extra_property );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $name_extra_property

    наименование дополнительного параметра

    Возвращает

    string значение дополнительного параметра,
    boolean false если операция не выполнена

    Описание

    Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра

    [ Top ]

    SiteUsers::InsertExtraProperty

InsertExtraProperty(
int
$property_id, string
$property_name, string
$property_type, string
$property_title, int
$property_size, int
$property_rows, int
$property_cols, int
$property_checked, string
$property_default_value, int
$property_order, string
$property_comment, int
$lists_id, [int
$users_id = false] );

    Принимаемые параметры

    $property_id

    идентификатор дополнительного параметра

    $property_name

    имя

    $property_type

    тип

    $property_title

    название

    $property_size

    размер

    $property_rows

    кол-во строк (для большого текстового поля)

    $property_cols

    ширина (для большого текстового поля)

    $property_checked

    значение свойства 'selected' тэга элемента формы

    $property_default_value

    значение по умолчанию

    $property_order

    порядок сортировки

    $property_comment

    комментарий

    $lists_id

    id списка

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    результат выполнения:
      -1 - если неверно задано имя параметра или оно дублируется,

    1. - произошла ошибка выполнения запроса,
    2. - функция выполнена успешно

    Описание

    Метод добавления/редактирования дополнительного параметра

    [ Top ]

    SiteUsers::InsertSiteUser

InsertSiteUser(
mixed
$param, array
$param
 );

    Принимаемые параметры

    $param

    $param['site_users_group_id'] группа пользователей
    $param['site_users_login'] логин
    $param['site_users_password'] пароль
    $param['site_users_email'] эл.почта
    $param['site_users_name'] имя
    $param['site_users_surname'] фамилия
    $param['site_users_patronymic'] отчество
    $param['site_users_phone'] телефон
    $param['site_users_fax'] факс
    $param['site_users_site'] сайт
    $param['site_users_icq'] ICQ
    $param['site_users_country'] страна
    $param['site_users_postcode'] почтовый индекс
    $param['site_users_city'] город
    $param['site_users_date_registration'] дата регистрации, необязательное поле
    $param['site_users_ip'] IP адрес, необязательное поле

    $param['allow_access'] bool авторизировать пользователя сразу после регистрации;

    $param['location'] string путь к странице, на которую перейдет пользователь при подтверждении регистрации
    $param['not_send_mail_confirm'] bool флаг, указывающий на то, что письмо с подтверждением отправлять не надо
    $param['xslname'] XSL шаблон для отправки сообщения о регистрации
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной записи

    Описание

    Метод добавления нового пользователя в систему

    [ Top ]

    SiteUsers::InsertUserGroup

InsertUserGroup(
int
$site_users_group_id, string
$site_users_group_name, string
$site_users_group_comment, [int
$users_id = false] );

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы (если 0, то добавление, в противном случае - редактирование)

    $site_users_group_name

    имя группы

    $site_users_group_comment

    коментарий к группе

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Описание

    Метод вставки и обновления информации о группе пользователей

    [ Top ]

    SiteUsers::InsertUsers

InsertUsers(
int
$site_users_group_id, int
$site_user_id );

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы

    $site_user_id

    идентификатор пользователя сайта

    Описание

    Метод добавления пользователя в группу

    [ Top ]

    SiteUsers::OrderExtraProperty

OrderExtraProperty(
array
$mas_orders );

    Принимаемые параметры

    $mas_orders

    массив коэффициентов
      $mas_orders['order<идентификатор параметра>']

    Описание

    Метод обновления коэффициентов порядка сортировки

    [ Top ]

    SiteUsers::PrivateOfficeXML

PrivateOfficeXML(
string
$title, array
$links, string
$xslname, [int
$sire_users_id = false] );

    Принимаемые параметры

    $title

    заголовок

    $links

    массив с информацией о ссылке:
      $link[$i][0] string текст ссылки,
      $link[$i][1] string адрес ссылки

    $xslname

    наименование xsl шаблона

    $sire_users_id

    идентификатор пользователя

    Описание

    УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.

    [ Top ]

    SiteUsers::SelectUserType

SelectUserType(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы пользователей (-1 выбрать все)

    Возвращает

    результат запроса на выборку по идентификатору

    Описание

    Метод возвращает параметры группы пользователя

    [ Top ]

    SiteUsers::SendNewPassword

SendNewPassword(
string
$login, string
$email, [mixed
$xslname = ''], [array
$param = array()], string
$xslname='' );

    Принимаемые параметры

    $login

    логин пользователя

    $email

    e-mail пользователя

    $xslname=''

    xsl-шаблон для письма

    $param

    дополнительные параметры

    Описание

    Метод отправки нового пароля на почтовый ящик пользователю

    [ Top ]

    SiteUsers::SendRegistInf

SendRegistInf(
array
$param );

    Принимаемые параметры

    $param

    массив параметров, содержит следующие элементы:
      $param['site_user_id'] int идентификатор пользователя,
      $param['xslname'] string шаблон письма пользователю,
      $param['site_user_password'] string пароль пользователя,
      $param['subject'] string пароль пользователя,
      $param['mail_type'] тип письма - текст или HTML
      $param['location'] string указатель на страницу перехода после подтверждения регистрации.

    Описание

    Метод отправки пользователю регистрационной информации

    [ Top ]

    SiteUsers::SetConfirmation

SetConfirmation(
string
$site_user_index );

    Принимаемые параметры

    $site_user_index

    индекс пользователя сайта

    Описание

    Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)

    [ Top ]

    SiteUsers::SetConfirmationID

SetConfirmationID(
int
$site_user_id );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    Возвращает

    значение подтверждения, или -1, если операция не выполнена

    Описание

    Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки

    [ Top ]

    SiteUsers::SetCurrentSiteUser

SetCurrentSiteUser(
int
$site_user, [int
$expires = 2678400] );

    Принимаемые параметры

    $site_user

    идентификатор пользователя, должен быть больше 0

    $expires

    время в секундах, в течении которого регистрация активна. По умолчанию = 2678400 (месяц)

    Описание

    Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток

    [ Top ]

    SiteUsers::SetDefaultGroup

SetDefaultGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы по умолчанию

    Описание

    Метод установления группы с указанным идентификатором по умолчанию

    [ Top ]

    SiteUsers::SetValueExtraProperty

SetValueExtraProperty(
int
$site_users_id, mixed
$extra_property_value, array
$param );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $extra_property_value

    значение дополнительнго параметра

    $param

    массив дополнительных параметров, позволяющий задать дополнительное свойство как идентификатором array('id' => 1), так и именем array('name' => 'myname')

    Описание

    Метод установки значения дополнительного параметра пользователя

    [ Top ]

    SiteUsers::ShowSiteUserRegistartion

ShowSiteUserRegistartion(
int
$site_users_id, string
$xslname, [array
$external_property = array()], [array
$default_property = array()] );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    наименование xsl-шаблона

    $external_property

    массив внешних параметров для XML

    $default_property

    массив дополнительных значений (заменяет введенные значения для полей пользователя)

    Описание

    Метод вывода формы регистрации для пользователя сайта

    [ Top ]

    SiteUsers::ShowUserOffice

ShowUserOffice(
string
$xslname, mixed
$external_propertys, [int
$sire_users_id = false], array
$external_property );

    Принимаемые параметры

    $xslname

    $external_property

    массив внешних параметров, формат:
    $external_property[0]['xml_name'] = 'xml_name';
    $external_property[0]['value'] = 'value';

    $sire_users_id

    идентификатор пользователя, если не указан - берется текущий авторизированный пользователь, если есть

    Описание

    Метод отображения кабинета пользователя

    [ Top ]

    SiteUsers::Unregistration

Unregistration(
string
$site_user_index );

    Принимаемые параметры

    $site_user_index

    индекс пользователя

    Описание

    Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя

    [ Top ]

    SiteUsers::UnsetCurrentSiteUser

UnsetCurrentSiteUser(
 );

    Описание

    Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из кабинета пользователя

    [ Top ]

    SiteUsers::UpdateSiteUser

UpdateSiteUser(
int
$site_user_id, string
$param, string
2, string
3, string
4, string
5, string
6, string
7, string
8, string
9, string
10, string
11, string
12, string
13, string
14, string
15, string
16, string
17 );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    2

    site_user_password пароль

    3

    site_user_email e-mail

    4

    site_users_name имя

    5

    site_users_surname фамилия

    6

    site_users_patronymic отчество

    7

    site_users_company компания

    8

    site_users_phone телефон

    9

    site_users_fax факс

    10

    site_users_site сайт

    11

    site_users_icq аська

    12

    site_users_country страна

    13

    site_users_postcode почтовый индекс

    14

    site_users_city город

    15

    site_users_address адрес

    16

    site_users_date_registration дата регистрации (не обязательное)

    17

    site_users_ip IP (не обязательное)
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    $param

    site_user_login логин

    Возвращает

    boolean true при успешном обновлении,
      int 0,-1,-2,-3 - в случае возникновения раличного рода ошибок
      (0 - ошибка выполнения запроса, -1 - некорректный e-mail, -2 - дублирующийся e-mail, -3 - дублирующийся логин)

    Описание

    Метод обновления анкетных данных пользователя

    [ Top ]

    SiteUsers::ValidUser

ValidUser(
string
$login, string
$password );

    Принимаемые параметры

    $login

    логин пользователя

    $password

    пароль пользователя

    Возвращает

    int идентификатор пользователя, если пользователь зарегистрирован,

    1. - пользователь не зарегистрирован,
     -1 - если пользователь зарегистрирован, но не подтвердил свою регистрацию

    Описание

    Метод возвращает идентификатор пользователя по его логину и паролю

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class Structure

Class Structure

[Строка 9]

Размещен: /Structure/Structure.class.php

Свойства класса

  • $a_count_property =

        Ассоциативный массив-Кэш количества свойств для разных сайтов

  • $cache_structure_property =

        Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.

  • $count_row =

        Количество выбранных элементов

  • $edit_id =

        Идентификатор редактируемого узла структуры

  • $level =

        Максимальный уровень структуры

  • $menu_id =

        Идентификатор раздела меню

  • $parent_id =

        Идентификатор родительского узла элемента структуры

  • $separator = ''

        Разделитель для уровней

  • $StructureMass = array()

        Массив с элементами структуры

  • $StructureParentMass = array()

        Массив родительских разделов

  • $structure_propertys_list =

        Хранит результат запроса на выборку дополнительных свойств структуры

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed add_page()

    Метод добавления и редактирования данных о страницах

  • void ClearStructure()

    Метод очистки параметров класса

  • результат DeletePropertyValue()

    Метод для удаления значения свойтва узла структуры

  • mixed DeleteStructure()

    Метод для удлаения узла структуры с его дочерними узлами

  • boolean delete_page()

    Метод удаления страницы

  • истина DelStructurePropertys()

    Метод удаления дополнительного свойства

  • void DelStructurePropertysValue()

    Метод удаления значений дополнительных свойств из таблицы связи

  • string GenXML4InfSys()

    Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры

  • string GenXml4StructureLevelMass()

    Метод генерации части XML-а для записей указанного уровня

  • resource GetAllStructure()

    Метод для получения списка всех узлов структуры сайта

  • resource GetAllStructureProperties()

    Метод для получения списка всех доп. свойств структуры

  • resource GetAllStructurePropertyValuesOfProperty()

    Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства

  • mixed GetCountProperty4Structure()

    Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют

  • int GetProperrtyMenuId()

    Метод получения информации о текущем разделе меню

  • array GetPropertyACountProperty()

    Метод получения количества свойств для разных сайтов

  • int GetPropertyCountRow()

    Метод получения количества выбранных элементов

  • int GetPropertyEditId()

    Метод полчения информации о редактиремом элементе структуры

  • int GetPropertyLevel()

    Метод получения информации о максимальном уровне

  • int GetPropertyParentId()

    Метод получения идентификатора родительского узла текущего элемента структуры

  • string GetPropertySeparator()

    Метод получения информации о разделителе

  • array GetPropertyStructureMass()

    Метод получения информации об элементах структуры

  • array GetPropertyStructureParentMass()

    Метод получения информации о родительских разделах элемента структуры

  • resource GetPropertyStructurePropertysList()

    Метод получения дополнительных свойств структуры

  • array GetPropertyValue()

    Метод для получения информации о значении свойства структуры

  • array GetStructure()

    Метод выборки всех страниц структуры

  • int GetStructureAccess()

    Метод получения информации о доступе к узлу элементов структуры

  • boolean GetStructureForParent()

    Метод получения подразделов для раздела

  • mixed GetStructureItem()

    *  Метод получения данных об элементе структуры

  • mixed GetStructurePath()

    Метод определения полного пути к странице

  • array GetStructureProperty()

    Метод возвращает заполненные св-ва узлов структуры

  • string GetXml4StructurePropertys()

    Метод получения XML для свойств структуры

  • array IndexationStructure()

    Метод индексации элементов структуры

  • int InsertStructurePropertys()

    Метод  вставки и редактирования дополнительного свойства для структуры

  • int InsertStructurePropertysValue()

    Метод вставки и редактирования значения дополнительного свойства в таблице связи

  • mixed IssetPath()

    Метод определения наличия пути

  • boolean NodeIsParent()

    Метод определения принадлежности узла структуры вышестоящему родителю

  • resource SelectStructurePropertys()

    Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)

  • boolean ShowStructure()

    Метод для отображения структуры в клиентской части сайта

  • array SortStructureMass()

    Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией

  • void structure()

    Конструктор

  • void UpdateSubDir()

    Метод обновления идентификатора меню у подразделов определенного раздела

Унаследованные методы

Описания методов

    Structure::add_page

add_page(
int
$type, int
$structure_id, int
$menu_id, int
$templates_id, int
$data_templates_id, int
$site_id, int
$documents_id, int
$structure_parent_id, int
$structure_show, string
$structure_menu_name, string
$structure_title, string
$structure_description, string
$structure_keywords, string
$structure_external_link, int
$structure_order, string
$structure_path_name, int
$structure_type, string
$module, string
$module_config, int
$structure_access, int
$structure_activity, [int
$structure_allow_indexation = 1], int
$lib_id, [int
$users_id = false] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_id

    идентификатор элемента структуры

    $menu_id

    идентификатор раздела меню

    $templates_id

    идентификатор макета

    $data_templates_id

    идентификатор шаблона страниц

    $site_id

    идентификатор сайта

    $documents_id

    идентификатор документа

    $structure_parent_id

    идентификатор родительского раздела

    $structure_show

    флаг вывода элемента структуры

    $structure_menu_name

    наименование раздела в меню

    $structure_title

    заголовок для раздела

    $structure_description

    описание раздела

    $structure_keywords

    ключевые фразы

    $structure_external_link

    внешняя ссылка для раздела

    $structure_order

    порядок сортировки

    $structure_path_name

    название раздела

    $structure_type

    тип раздела

    $module

    значение для динамической страницы

    $module_config

    конфиг для динамической страницы

    $structure_access

    доступ к разделу

    $structure_activity

    флаг активности раздела

    $structure_allow_indexation

    флаг индексирования раздела

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    $lib_id

    идентификатор типовой динамической страницы

    Возвращает

    идентификатор отредактированного раздела при успешной операции, ложь - при возникновении ошибки

    Описание

    Метод добавления и редактирования данных о страницах

    [ Top ]

    Structure::ClearStructure

ClearStructure(
 );

    Описание

    Метод очистки параметров класса

    [ Top ]

    Structure::DeletePropertyValue

DeletePropertyValue(
int
$structure_propertys_values_id );

    Принимаемые параметры

    $structure_propertys_values_id

    идентификатор значения свойства, которое нужно удалить

    Возвращает

    выполнения запроса

    Описание

    Метод для удаления значения свойтва узла структуры

    [ Top ]

    Structure::DeleteStructure

DeleteStructure(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    Возвращает

    результат выполнения запроса

    Описание

    Метод для удлаения узла структуры с его дочерними узлами

    [ Top ]

    Structure::delete_page

delete_page(
int
$id );

    Принимаемые параметры

    $id

    идентификатор страницы

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления страницы

    [ Top ]

    Structure::DelStructurePropertys

DelStructurePropertys(
int
$structure_propertys_id );

    Принимаемые параметры

    $structure_propertys_id

    идентификатор удаляемого дополнительного свойства

    Возвращает

    при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления дополнительного свойства

    [ Top ]

    Structure::DelStructurePropertysValue

DelStructurePropertysValue(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры

    Описание

    Метод удаления значений дополнительных свойств из таблицы связи

    [ Top ]

    Structure::GenXML4InfSys

GenXML4InfSys(
int
$inf_sys_id, int
$menu_id, int
$level, int
$inf_group_id, string
$full_path, [array
$param = array()] );

    Принимаемые параметры

    $inf_sys_id

    идентификатор информационной системы

    $menu_id

    идентификатор меню

    $level

    текущий уровень вложенности

    $inf_group_id

    идентификатор группы элементов информационной системы

    $full_path

    полный путь к текущей группе элементов информационной системы

    $param

    ассоциативный массив включающий следующие параметры:  $param['show_groups'] - отображать ли группы элементов инфосистемы  $param['show_items'] - отображать ли элементы инфосистемы  $param['hidden_groups'] - массив групп, скрытых для показа в текущем меню

    Возвращает

    XML для отображения элементов и групп элементов инфосистем при отображении структуры

    Описание

    Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры

    [ Top ]

    Structure::GenXml4StructureLevelMass

GenXml4StructureLevelMass(
int
$parent_id, array
$access, int
$level, [array
$param = array()] );

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $access

    массив с правами доступа

    $level

    уровень

    $param

    ассоциативный массив включающий следующие параметры:
      $param['show_groups'] - отображать ли группы элементов инфосистемы
      $param['show_items'] - отображать ли элементы инфосистемы
      $param['hidden_groups'] - массив групп, скрытых для показа в текущем меню

    Возвращает

    часть XML-а для записей указанного уровня

    Описание

    Метод генерации части XML-а для записей указанного уровня

    [ Top ]

    Structure::GetAllStructure

GetAllStructure(
[int
$site_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит узел структуры, если false - учитываются все сайты

    Возвращает

    с информацией об узлах структуры

    Описание

    Метод для получения списка всех узлов структуры сайта

    [ Top ]

    Structure::GetAllStructureProperties

GetAllStructureProperties(
[int
$site_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит свойство, если false - учитываются все сайты

    Возвращает

    с информацией о свойстве

    Описание

    Метод для получения списка всех доп. свойств структуры

    [ Top ]

    Structure::GetAllStructurePropertyValuesOfProperty

GetAllStructurePropertyValuesOfProperty(
[int
$structure_propertys_id = false] );

    Принимаемые параметры

    $structure_propertys_id

    свойства, которому принадлежит значение свойства, если false - учитываются все свойства

    Возвращает

    с информацией о значениях свойств

    Описание

    Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства

    [ Top ]

    Structure::GetCountProperty4Structure

GetCountProperty4Structure(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    число свойств раздела сайта или false, если свойства отсутствуют

    Описание

    Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют

    [ Top ]

    Structure::GetProperrtyMenuId

GetProperrtyMenuId(
 );

    Возвращает

    идентификатор текущего раздела

    Описание

    Метод получения информации о текущем разделе меню

    [ Top ]

    Structure::GetPropertyACountProperty

GetPropertyACountProperty(
 );

    Возвращает

    ассоциативный массив-Кэш количества свойств для разных сайтов

    Описание

    Метод получения количества свойств для разных сайтов

    [ Top ]

    Structure::GetPropertyCountRow

GetPropertyCountRow(
 );

    Возвращает

    количество выбранных элементов

    Описание

    Метод получения количества выбранных элементов

    [ Top ]

    Structure::GetPropertyEditId

GetPropertyEditId(
 );

    Возвращает

    идентификатор редактируемого элемента

    Описание

    Метод полчения информации о редактиремом элементе структуры

    [ Top ]

    Structure::GetPropertyLevel

GetPropertyLevel(
 );

    Возвращает

    значение максимального уровня

    Описание

    Метод получения информации о максимальном уровне

    [ Top ]

    Structure::GetPropertyParentId

GetPropertyParentId(
 );

    Возвращает

    идентификатор родительского узла элемента структуры

    Описание

    Метод получения идентификатора родительского узла текущего элемента структуры

    [ Top ]

    Structure::GetPropertySeparator

GetPropertySeparator(
 );

    Возвращает

    разделитель для уровней

    Описание

    Метод получения информации о разделителе

    [ Top ]

    Structure::GetPropertyStructureMass

GetPropertyStructureMass(
 );

    Возвращает

    массив с элементами структуры

    Описание

    Метод получения информации об элементах структуры

    [ Top ]

    Structure::GetPropertyStructureParentMass

GetPropertyStructureParentMass(
 );

    Возвращает

    информация о родительских разделах

    Описание

    Метод получения информации о родительских разделах элемента структуры

    [ Top ]

    Structure::GetPropertyStructurePropertysList

GetPropertyStructurePropertysList(
 );

    Возвращает

    результат запроса на выборку дополнительных свойств структуры

    Описание

    Метод получения дополнительных свойств структуры

    [ Top ]

    Structure::GetPropertyValue

GetPropertyValue(
int
$structure_propertys_values_id );

    Принимаемые параметры

    $structure_propertys_values_id

    идентификатор значения свойства

    Возвращает

    с информацией о значении свойства или false

    Описание

    Метод для получения информации о значении свойства структуры

    [ Top ]

    Structure::GetStructure

GetStructure(
string
$separator, int
$site_id, int
$menu_id, int
$level, int
$parent_id, [int
$edit_id = false] );

    Принимаемые параметры

    $separator

    разделитель для уровней

    $menu_id

    идентификатор раздела меню (если не задан - все разделы меню)

    $level

    максимальный уровень

    $parent_id

    идентификатор родительского узла

    $edit_id

    идентификатор редактируемой записи (необязательный параметр), для того, чтобы убрать редактируемую запись из списка возможных род. разделов

    $site_id

    or boolean $site_id идентификатор сайта, если равен 0 или false - то сайт игнорируется

    Возвращает

    информация обо всех страницах структуры

    Описание

    Метод выборки всех страниц структуры

    [ Top ]

    Structure::GetStructureAccess

GetStructureAccess(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор страницы структуры

    Возвращает

    structure_access для заданого узла, либо -1 если узел (или один из родительских узлов) не найден.

    Описание

    Метод получения информации о доступе к узлу элементов структуры

    [ Top ]

    Structure::GetStructureForParent

GetStructureForParent(
int
$parent_id, string
$separator, int
$current_level );

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $separator

    разделитель для уровней

    $current_level

    текущий уровень

    Возвращает

    формирует массив с информацией о подразделах, а в случае ошибки возвращает ложь

    Описание

    Метод получения подразделов для раздела

    [ Top ]

    Structure::GetStructureItem

GetStructureItem(
int
$structure_id, [array
$param = array()] );

    Принимаемые параметры

    $structure_id

    идетификатор структуры

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с данными об узле структуры или false, если узел не найден

    Описание

    *  Метод получения данных об элементе структуры

    [ Top ]

    Structure::GetStructurePath

GetStructurePath(
int
$structure_id, [int
$type = 0], [mixed
$path = ''] );

    Принимаемые параметры

    $structure_id

    идентификатор раздела, для него определяется полный пути снизу вверх

    $type

    тип результата (строка -- 0 или масссив -- 1). По умолчанию 0

    $path

    переменная, в которую возвращается результат (строка, либо массив)

    Возвращает

    полный путь к странице (в виде строки или массива)

    Описание

    Метод определения полного пути к странице

    [ Top ]

    Structure::GetStructureProperty

GetStructureProperty(
array
$propertylist );

    Принимаемые параметры

    $propertylist

    массив ID узлов структуры, например $propertylist[] = 149;

    Возвращает

    массив свойств элемента

    Описание

    Метод возвращает заполненные св-ва узлов структуры

    (также метод заполняет значение кэша $this->cache_structure_property)

    [ Top ]

    Structure::GetXml4StructurePropertys

GetXml4StructurePropertys(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры

    Возвращает

    XML для свойств структуры

    Описание

    Метод получения XML для свойств структуры

    [ Top ]

    Structure::IndexationStructure

IndexationStructure(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Принимаемые параметры

    $limit

    ограничение (по сколько элементов индексировать)

    $on_step

    шаг для индексации

    $parameters

    массив дополнительных параметров

    Возвращает

    массив с данными о  проиндексированных элементах

    Описание

    Метод индексации элементов структуры

    [ Top ]

    Structure::InsertStructurePropertys

InsertStructurePropertys(
int
$type, int
$structure_propertys_id, int_type
$site_id, string
$structure_propertys_name, int
$structure_propertys_type, int
$structure_propertys_order, string
$structure_propertys_define_value, string
$structure_propertys_xml_name, int
$structure_propertys_lists_id, int
$structure_propertys_information_systems_id, [int
$users_id = false] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_propertys_id

    идентификатор дополнительного свойства

    $site_id

    идентификатор сайта

    $structure_propertys_name

    наименование дополнительного свойства

    $structure_propertys_type

    тип дополнительного свойства

    $structure_propertys_order

    порядок сортировки

    $structure_propertys_define_value

    значение по умолчанию для дополнительного свойства

    $structure_propertys_xml_name

    имя xml тега для дополнительного свойства

    $structure_propertys_lists_id

    идентификатор списка (если тип свойства - список)

    $structure_propertys_information_systems_id

    идентификатор информационной системы (для типа информационная система)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор отредактированного (вставленного) дополнительного свойства

    Описание

    Метод  вставки и редактирования дополнительного свойства для структуры

    [ Top ]

    Structure::InsertStructurePropertysValue

InsertStructurePropertysValue(
int
$type, int
$structure_propertys_values_id, int
$structure_id, int
$structure_propertys_id, string
$structure_propertys_values_value );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_propertys_values_id

    идентификатор значения дополнительного свойства

    $structure_id

    идентификатор раздела структуры

    $structure_propertys_id

    идентификатор дополнительного свойства

    $structure_propertys_values_value

    значение дополнительного свойства

    Возвращает

    идентификатор отредактированной (добавленной) записи

    Описание

    Метод вставки и редактирования значения дополнительного свойства в таблице связи

    [ Top ]

    Structure::IssetPath

IssetPath(
array
$path_array, int
$menu_id );

    Принимаемые параметры

    $path_array

    массив с элементами пути, ID меню

    $menu_id

    идентификатор раздела меню

    Возвращает

    идентификатор родительского раздела - при наличии у данного меню страницы с аналогичным путем, false при ее отсутствии

    Описание

    Метод определения наличия пути

    [ Top ]

    Structure::NodeIsParent

NodeIsParent(
int
$children_node_id, int
$parent_node_id );

    Принимаемые параметры

    $children_node_id

    идентификатор дочернего узла

    $parent_node_id

    идетификатор узла - возможного родителя

    Возвращает

    истина, если узел принадлежит родителю, иначе ложь

    Описание

    Метод определения принадлежности узла структуры вышестоящему родителю

    [ Top ]

    Structure::SelectStructurePropertys

SelectStructurePropertys(
int
$site_id, [int
$structure_propertys_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $structure_propertys_id

    идентификатор дополнительного свойства

    Возвращает

    результат выборки информации о дополнительном свойстве (обо всех дополнительных свойствах)

    Описание

    Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)

    [ Top ]

    Structure::ShowStructure

ShowStructure(
int
$menu_id, string
$xsl, [array
$param = array()], [array
$external_propertys = array()] );

    Принимаемые параметры

    $menu_id

    ID меню для отображения

    $xsl

    имя XSL шаблона для отображения

    $param

    содержит дополнительные параметры
      $param['parent_id'] - ID родительского узла
      $param['cache'] - разрешение кэширования, по умолчанию true
      $param['show_groups'] - отображать ли группы элементов инфосистемы, по умолчанию false
      $param['show_items'] - отображать ли элементы инфосистемы, по умолчанию false
    $param['show_information_systems'] - отображать ли элементы указанных инфосистемы (массив)
      $param['do_not_show_information_systems'] - отображать ли элементы указанных инфосистемы (массив)
    $param['hidden_groups'] - массив групп, скрытых для показа в текущем меню
      $param['site_id'] - ID сайта, для которого отображается структура, по умолчанию равен текущему сайту

    $external_propertys

    многомерный массив дополнительных свойств для включения в исходный XML код

    Возвращает

    истину при успешном отображении меню

    Описание

    Метод для отображения структуры в клиентской части сайта

    [ Top ]

    Structure::SortStructureMass

SortStructureMass(
int
$parent_id, [array
$mass = array()] );

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $mass

    массив с элементами структуры

    Возвращает

    отсортированный массив

    Описание

    Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией

    [ Top ]

    Structure::structure

structure(
 );

    Описание

    Конструктор

    [ Top ]

    Structure::UpdateSubDir

UpdateSubDir(
int
$id, int
$menu_id );

    Принимаемые параметры

    $id

    идентификатор раздела структуры

    $menu_id

    идентификатор раздела меню

    Описание

    Метод обновления идентификатора меню у подразделов определенного раздела

    [ Top ]

Описания переменных

  • $a_count_property =  [Строка 72]
    •

  • Data type: array
    •

    Описание

    Ассоциативный массив-Кэш количества свойств для разных сайтов

  • $cache_structure_property =  [Строка 56]
    •

  • Data type: array
    •

    Описание

    Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.

  • $count_row =  [Строка 30]
    •

  • Data type: int
    •

    Описание

    Количество выбранных элементов

  • $edit_id =  [Строка 61]
    •

  • Data type: int
    •

    Описание

    Идентификатор редактируемого узла структуры

  • $level =  [Строка 20]
    •

  • Data type: int
    •

    Описание

    Максимальный уровень структуры

  • $menu_id =  [Строка 35]
    •

  • Data type: int
    •

    Описание

    Идентификатор раздела меню

  • $parent_id =  [Строка 15]
    •

  • Data type: int
    •

    Описание

    Идентификатор родительского узла элемента структуры

  • $separator = '' [Строка 25]
    •

  • Data type: string
    •

    Описание

    Разделитель для уровней

  • $StructureMass = array() [Строка 50]
    •

  • Data type: array
    •

    Описание

    Массив с элементами структуры

  • $StructureParentMass = array() [Строка 45]
    •

  • Data type: array
    •

    Описание

    Массив родительских разделов

  • $structure_propertys_list =  [Строка 67]
    •

  • Data type: resource
    •

    Описание

    Хранит результат запроса на выборку дополнительных свойств структуры

Описание констант класса

support@hostcms.ru


Docs For Class Support

Class Support

[Строка 11]

Размещен: /Support/Support.class.php

Описание

Класс модуля "Техническая поддержка"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean SupportMail()

    Метод отправки письма с просьбой о технической поддержке

Унаследованные методы

Описания методов

    Support::SupportMail

SupportMail(
string
$name, string
$mail, string
$phone, string
$number, string
$text, string
$sections, string
$priority, string
$subject, [string
$page = ''], [mixed
$file_path_name = array()], string
$filename );

    Принимаемые параметры

    $name

    ФИО пользователя

    $mail

    e-mail пользователя

    $phone

    телефон пользователя

    $number

    номер договора

    $text

    текст сообщения

    $sections

    отдел, в который необходимо направить письмо

    $priority

    приоритет сообщения

    $subject

    тема сообщения

    $page

    тема сообщения

    $filename

    путь к прикрепляемому файлу

    Возвращает

    истина при удачной отправке письма, ложь - в обратном случае

    Описание

    Метод отправки письма с просьбой о технической поддержке

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class templates

Class templates

[Строка 11]

Размещен: /Templates/Templates.class.php

Описание

Класс модуля "Шаблоны и макеты"

Свойства класса

  • $count_row =

  • $error =

  • $record_on_page = ON_PAGE

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int CopyDataTemplate()

    Метод копирования шаблона страниц

  • int CopyTemplate()

    Метод копирования макета

  • boolean del_data_templates()

    Метод удаления шаблона страниц

  • boolean del_templates()

    Метод удаления макета

  • mixed GetTemplate()

    Метод получения информации о макете

  • mixed insert_data_templates()

    Методы добавления (редактирования) шаблонов страниц

  • int insert_template()

    Метод добавления макета

  • resource select_data_templates()

    Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)

Унаследованные методы

Описания методов

    templates::CopyDataTemplate

CopyDataTemplate(
int
$data_template_id );

    Принимаемые параметры

    $data_template_id

    идентификатор копируемого шаблона страниц

    Возвращает

    идентификатор нового добавленного шаблона страниц

    Описание

    Метод копирования шаблона страниц

    [ Top ]

    templates::CopyTemplate

CopyTemplate(
int
$template_id );

    Принимаемые параметры

    $template_id

    идентификатор копируемого макета

    Возвращает

    идентификатор нового добавленного макета

    Описание

    Метод копирования макета

    [ Top ]

    templates::del_data_templates

del_data_templates(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого шаблона

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления шаблона страниц

    [ Top ]

    templates::del_templates

del_templates(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого макета

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления макета

    [ Top ]

    templates::GetTemplate

GetTemplate(
int
$templates_id, [array
$param = array()] );

    Принимаемые параметры

    $templates_id

    идентификатор макета

    $param

    ассоциативный массив параметров
     bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с информацией о макете в случае удачной выборки, ложь - если макет не выбран

    Описание

    Метод получения информации о макете

    [ Top ]

    templates::insert_data_templates

insert_data_templates(
int
$type, int
$data_templates_id, string
$data_templates_value, string
$data_templates_name, string
$data_templates_description, int
$data_templates_order, [int
$users_id = false] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $data_templates_id

    идентификатор шаблона страниц

    $data_templates_value

    шаблон

    $data_templates_name

    наименование шаблона страниц

    $data_templates_description

    описание шаблона страниц

    $data_templates_order

    порядок сортировки

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор добавленного (отредактированного) шаблона в случае успешной операции, ложь - при возникновении ошибки

    Описание

    Методы добавления (редактирования) шаблонов страниц

    [ Top ]

    templates::insert_template

insert_template(
int
$type, int
$templates_id, string
$templates_name, int
$templates_order, string
$templates_main, string
$templates_css );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $templates_id

    идентификатор макета

    $templates_name

    наименование макета

    $templates_order

    порядок сортировки

    $templates_main

    значение макета

    $templates_css

    таблица стилей для макета

    Возвращает

    идентификатор нового или редатируемого макета (в зависимости от типа действия)

    Описание

    Метод добавления макета

    [ Top ]

    templates::select_data_templates

select_data_templates(
int
$id );

    Принимаемые параметры

    $id

    идентификатор шаблона

    Возвращает

    информация о шаблоне (обо всех щаблонах)

    Описание

    Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)

    [ Top ]

Описания переменных

  • $count_row =  [Строка 14]
    •

  • Data type: mixed
    •

  • $error =  [Строка 13]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [Строка 15]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Docs For Class typograph

Class typograph

[Строка 6]

Размещен: /typograph/typograph.class.php

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • результат ProcessTypographic()

    Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.

Унаследованные методы

Описания методов

    typograph::ProcessTypographic

ProcessTypographic(
mixed
$source_string, [mixed
$use_trailing_punctuation = false] );

    Возвращает

    работы ф-ции в виде строки.

    Описание

    Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class url

Class url

[Строка 11]

Размещен: /Kernel/Url.class.php

Описание

Ядро, класс для работы с адресной строкой

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string link_len()

    Метод сокращения длины строки

  • string translit_lower()

    Метод транслитерации с переводом символам исходного текста к прописным

Унаследованные методы

Описания методов

    url::link_len

link_len(
string
$str, int
$max_lenght );

    Принимаемые параметры

    $str

    строка

    $max_lenght

    максимальная длина

    Возвращает

    сокращенная строка

    Описание

    Метод сокращения длины строки

    [ Top ]

    url::translit_lower

translit_lower(
string
$string );

    Принимаемые параметры

    $string

    Описание

    Метод транслитерации с переводом символам исходного текста к прописным

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class user_access

Class user_access

[Строка 11]

Размещен: /UserAccess/UserAccess.class.php

Описание

Класс модуля "Пользователи раздела администрирования"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean del_user()

    Метод удаления пользователя

  • boolean del_user_type()

    Метод удаления типа пользователей

  • resource GetAllUserTypes()

    Метод возвращает список типов пользователей

  • mixed insert_user()

    Метод вставки и обновления информации о пользователе

  • mixed insert_user_type()

    Метод вставки и обновления информации о типе пользователей

  • mixed select_user()

    Метод получения информации о пользователе

  • mixed select_user_access()

    Метод получения нформации о типах доступа пользователей

  • mixed select_user_type()

    Метод выбора типа пользователей

Унаследованные методы

Описания методов

    user_access::del_user

del_user(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор удаляемого пользователя

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления пользователя

    [ Top ]

    user_access::del_user_type

del_user_type(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор типа пользователей

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления типа пользователей

    [ Top ]

    user_access::GetAllUserTypes

GetAllUserTypes(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит тип пользователей, если false - учитываются все сайты

    Возвращает

    с информацией о типах пользователей

    Описание

    Метод возвращает список типов пользователей

    [ Top ]

    user_access::insert_user

insert_user(
int
$type, int
$users_id, int
$users_type_id, string
$users_name, string
$users_password, [int
$users_superuser = 0] );

    Принимаемые параметры

    $type

    - параметр, определяющий производится вставка или обновление информации о пользователе

    $users_id

    - идентификатор пользователя, для которого обновляется информация (при вставке равен 0)

    $users_type_id

    - идентификатор типа пользователей, к которому относится пользователь, для которого добавляется/обновляется информация

    $users_name

    - имя пользователя

    $users_password

    - пароль пользователя

    $users_superuser

    - параметр,  определяющий, является пользователь сурерюзером или нет (0 - обычный пользователь, 1 - суперюзер)

    Возвращает

    идентификатор добавленной/обновленной информации о пользователе в случае успешного выполнения метода, 0 или false в противном случае (false - при вставке/обновлении пользователя с именем уже имеющимся в базе данных, 0 - в случае ошибки выполнения запроса)

    Описание

    Метод вставки и обновления информации о пользователе

    [ Top ]

    user_access::insert_user_type

insert_user_type(
int
$type, int
$users_type_id, int
$site_id, string
$users_type_name, string
$users_type_comment );

    Принимаемые параметры

    $type

    - параметр, определяющий производится вставка или обновление информации о типе пользователей

    $users_type_id

    - идентификатор типа пользователей, для которого обновляется информация (при вставке равен 0)

    $site_id

    - идентификатор сайта, к которому принадлежит тип пользователей

    $users_type_name

    - название типа пользователей

    $users_type_comment

    - описпние типа пользователей

    Возвращает

    идентификатор добавленной/обновленной информации о типе пользователей в случае успешного выполнения или false в противном случае

    Описание

    Метод вставки и обновления информации о типе пользователей

    [ Top ]

    user_access::select_user

select_user(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор пользователя

    Возвращает

    ассоциативный массив с информацией о пользователе в случае успешного выполнения, false в противном случае

    Описание

    Метод получения информации о пользователе

    [ Top ]

    user_access::select_user_access

select_user_access(
mixed
$id );

    Принимаемые параметры

    $id

    - идентификатор типа доступа пользователей, если $id равен false получаем информацию о всех типах доступа пользователей

    Возвращает

    result в случае успешного выполнения метода, false в противном случае

    Описание

    Метод получения нформации о типах доступа пользователей

    [ Top ]

    user_access::select_user_type

select_user_type(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор типа пользователей

    Возвращает

    result в случае успешного выполнения, false в противном случае

    Описание

    Метод выбора типа пользователей

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class UserAccessDenied

Class UserAccessDenied

[Строка 11]

Размещен: /Kernel/UserAccess.class.php

Описание

Ядро, класс проверки возможности доступа пользователей BackOffice

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • resource DeleteUserDeniedAccessBefore()

    Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд

  • resource InsertUserDeniedAccess()

    Метод записи в базу информации о неудачной попытке входа в BackOffice

  • resource SelectUserDeniedAccess()

    Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса

Унаследованные методы

Описания методов

    UserAccessDenied::DeleteUserDeniedAccessBefore

DeleteUserDeniedAccessBefore(
string
$current_date, [int
$delta_time = 86400] );

    Принимаемые параметры

    $current_date

    текущая дата

    $delta_time

    число секунд, по умолчанию сутки, от текущего момента времени

    Описание

    Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд

    [ Top ]

    UserAccessDenied::InsertUserDeniedAccess

InsertUserDeniedAccess(
string
$user_ip, string
$current_date );

    Принимаемые параметры

    $user_ip

    IP-адрес пользователя

    $current_date

    текущая дата

    Описание

    Метод записи в базу информации о неудачной попытке входа в BackOffice

    [ Top ]

    UserAccessDenied::SelectUserDeniedAccess

SelectUserDeniedAccess(
string
$user_ip, string
$current_date );

    Принимаемые параметры

    $user_ip

    IP-адрес пользователя

    $current_date

    текущая дата

    Описание

    Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class wysiwyg

Class wysiwyg

[Строка 11]

Размещен: /Kernel/Wysiwyg.class.php

Описание

Ядро, класс визуального редактора

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void show_ws()

    Метод отображает визуальный редактор

Унаследованные методы

Описания методов

    wysiwyg::show_ws

show_ws(
string
$main_text, [int
$templates_id = 0], [string
$ws_name = 'textarea'] );

    Принимаемые параметры

    $main_text

    - содержит текст, включаемый в редактор

    $templates_id

    - идентификатор шаблона

    $ws_name

    Описание

    Метод отображает визуальный редактор

    [ Top ]

Описания переменных

Описание констант класса

support@hostcms.ru


Docs For Class xsl

Class xsl

[Строка 11]

Размещен: /Xsl/Xsl.class.php

Описание

Класс модуля "XSL-шаблоны"

Свойства класса

  • $count_row =

  • $mas_xsl_dir = array()

  • $record_on_page = ON_PAGE

  • $section_path = ''

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string build()

    Метод обработки XML данных с помощью XSL шаблона

  • unknown CopyXsl()

    Метод копирования XSL-шаблона

  • boolean del_xsl()

    Метод удаления XSL-шаблона

  • boolean del_xsl_dir()

    Метод удаления XSL-раздела

  • array fill_xsl_dir()

    Метод формирования дерева разделов

  • mixed GetXsl()

    Метод получения информаци об XSL-шаблоне по его имени

  • void get_section_path()

    Функция возвращает путь по дереву разделов

  • boolean insert_xsl()

    Метод вставки/обновления XSL

  • mixed insert_xsl_dir()

    Метод вставки и обновления XSL рубрик

  • mixed select_xsl()

    Метод получения данных о XSL-шаблонах

  • mixed select_xsl_dir()

    Метод получения информации о XSL-разделах

Унаследованные методы

Описания методов

    xsl::build

build(
string
$xmlData, string
$template_name );

    Принимаемые параметры

    $xmlData

    - XML данные

    $template_name

    • название XSL шаблона для обработки XML данных

    Возвращает

    результат обработки XML данных XSL шаблоном

    Описание

    Метод обработки XML данных с помощью XSL шаблона

    [ Top ]

    xsl::CopyXsl

CopyXsl(
int
$xsl_id );

    Принимаемые параметры

    $xsl_id

    Описание

    Метод копирования XSL-шаблона

    [ Top ]

    xsl::del_xsl

del_xsl(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор XSL-шаблона

    Возвращает

    true в случае успешного выполнения метода, false в противном случае

    Описание

    Метод удаления XSL-шаблона

    [ Top ]

    xsl::del_xsl_dir

del_xsl_dir(
int
$xsl_dir_id );

    Принимаемые параметры

    $xsl_dir_id

    - идентификатор XSL-заздела

    Возвращает

    true в случае успешного выполнения метода, false в противном случае

    Описание

    Метод удаления XSL-раздела

    [ Top ]

    xsl::fill_xsl_dir

fill_xsl_dir(
int
$xsl_dir_parent_id, string
$separator );

    Принимаемые параметры

    $xsl_dir_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    Возвращает

    массив с данными о дереве XSL-разделов

    Описание

    Метод формирования дерева разделов

    [ Top ]

    xsl::GetXsl

GetXsl(
string
$template_name );

    Принимаемые параметры

    $template_name

    - имя XSL-шаблона

    Возвращает

    ассоциативный массив с информацией об XSL-шаблоне в случае успешного выполнения, false в противном случае

    Описание

    Метод получения информаци об XSL-шаблоне по его имени

    [ Top ]

    xsl::get_section_path

get_section_path(
int
$xsl_dir_id );

    Принимаемые параметры

    $xsl_dir_id

    Описание

    Функция возвращает путь по дереву разделов

    [ Top ]

    xsl::insert_xsl

insert_xsl(
int
$type, int
$xsl_id, int
$xsl_dir_id, string
$xsl_name, string
$xsl_value, string
$xsl_comment, [int
$users_id = false] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление XSL

    $xsl_id

    идентификатор обновляемого XSL шаблона (при вставке нового XSL шаблона равен 0)

    $xsl_dir_id

    идентификатор раздела, к которому относится данный XSL шаблон

    $xsl_name

    имя XSL шаблона

    $xsl_value

    текст XSL шаблона

    $xsl_comment

    комментарий к XSL шаблону

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    true при успешном добавлении/обновлении XSL шаблона, false – в противном случае

    Описание

    Метод вставки/обновления XSL

    [ Top ]

    xsl::insert_xsl_dir

insert_xsl_dir(
int
$type, int
$xsl_dir_id, int
$xsl_dir_parent_id, string
$xsl_dir_name, [int
$users_id = false] );

    Принимаемые параметры

    $type

    - параметр, определяющий производится

    $xsl_dir_id

    - идентификатор обновляемой рубрики (при вставке равен 0)

    $xsl_dir_parent_id

    - идентификатор родительской рубрики

    $xsl_dir_name

    - название рубрики

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной/обновленной рубрики в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки и обновления XSL рубрик

    [ Top ]

    xsl::select_xsl

select_xsl(
int
$id, [int
$xsl_dir_id = false] );

    Принимаемые параметры

    $id

    - идентификатор XSL-шаблона, если необходимо получить информацию о конкретном XSL-шаблоне, -1 - получить информацию о всех XSL-шаблонах

    $xsl_dir_id

    - идентификатор директории XSL шаблона, если -1, то директория не учитывается

    Возвращает

    result в случае успешного выполнения метода, false в противном случае

    Описание

    Метод получения данных о XSL-шаблонах

    [ Top ]

    xsl::select_xsl_dir

select_xsl_dir(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор XSL-раздела, если необходимо получить информацию о конкретном разделе, -1 - получить информацию о всех XSL-разделах

    Возвращает

    resorce в случае успешного выполнения метода, false в противном случае

    Описание

    Метод получения информации о XSL-разделах

    [ Top ]

Описания переменных

  • $count_row =  [Строка 13]
    •

  • Data type: mixed
    •

  • $mas_xsl_dir = array() [Строка 15]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [Строка 14]
    •

  • Data type: mixed
    •

  • $section_path = '' [Строка 16]
    •

  • Data type: mixed
    •

Описание констант класса

support@hostcms.ru


Element Index

Список всех элементов

Indexes by package:
HostCMS v 4

$ a b c d e f g h i j k l m n o p q r s t u v w x y
top
$
$row['constants_name'] | в файле Kernel.php, константа $row['constants_name']
top
a
$action_width | в файле show_table.class.php, переменная show_table::$action_width
$additional_attribute | в файле show_table.class.php, переменная table_fields::$additional_attribute
$additional_filed | в файле show_table.class.php, переменная table_fields::$additional_filed
$additional_filed_value | в файле show_table.class.php, переменная table_fields::$additional_filed_value
$align | в файле show_table.class.php, переменная table_fields::$align
$align_title | в файле show_table.class.php, переменная table_fields::$align_title
$aling | в файле show_table.class.php, переменная show_table::$aling
$array | в файле show_table.class.php, переменная table_fields::$array
$attribute | в файле show_table.class.php, переменная table_fields::$attribute
$a_count_property в файле Structure.class.php, переменная Structure::$a_count_property
Ассоциативный массив-Кэш количества свойств для разных сайтов
$a_count_property в файле InformationSystems.class.php, переменная InformationSystem::$a_count_property
Кэш количества свойств
AddAdminMenuItem в файле AdminMenu.class.php, метод AdminMenu::AddAdminMenuItem()
Метод добавляет элемент в меню раздела администрирования
AddBanner в файле Advertisement.class.php, метод Advertisement::AddBanner()
Метод добавления/редактирования баннера
AddEditConstants в файле Constants.class.php, метод Constants::AddEditConstants()
Метод добавления/редактирования данных о константе
AddEditInitialData в файле Counter.class.php, метод counter::AddEditInitialData()
Метод добавления/редактирования начальных данных для счетчика
AddEditMessage в файле Forums.class.php, метод Forums::AddEditMessage()
Метод добавления/редактирования сообщения темы
AddEditTheme в файле Forums.class.php, метод Forums::AddEditTheme()
Метод осуществляет добавление/редактирование темы
AddInclude в файле Kernel.class.php, метод kernel::AddInclude()
Метод подключает переданный файл или выводит сообщение об ошибке подключения
AddIntoCart в файле shop.class.php, метод shop::AddIntoCart()
Метод помещения товара в корзину
AddModule в файле Kernel.class.php, метод kernel::AddModule()
Метод подключения модуля
ADD_COMMENT_DELAY | в файле Kernel.php, константа ADD_COMMENT_DELAY
add_modules_version в файле Kernel.class.php, метод kernel::add_modules_version()
Метод добавления модуля в массив-список модулей
add_page в файле Structure.class.php, метод Structure::add_page()
Метод добавления и редактирования данных о страницах
Admin в файле Admin.class.php, класс Admin
Ядро, методы управления разделом администрирования HostCMS
AdminMenu в файле AdminMenu.class.php, класс AdminMenu
Ядро, класс для формирования меню в разделе администрирования
admin_datetime_format в файле Date.class.php, метод DateClass::admin_datetime_format()
Метод для админки формат вывода даты-времени из SQL-формата в формат d-m-Y
admin_date_format в файле Date.class.php, метод DateClass::admin_date_format()
Метод для админки, преобразует формат выводы даты из sql-формата в формат d-m-Y
admin_init в файле Admin.class.php, метод Admin::admin_init()
Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта
admin_session_valid в файле Admin.class.php, метод Admin::admin_session_valid()
Метод проверки авторизации пользователя
Advertisement в файле Advertisement.class.php, класс Advertisement
Класс модуля "Реклама"
Advertisement.class.php | procedural page Advertisement.class.php
Advertisement.php | procedural page Advertisement.php
AlignTextSpace в файле Counter.class.php, метод counter::AlignTextSpace()
Метод выравнивания текста по центру с помощью пробелов
AssignGroupImage в файле shop.class.php, метод shop::AssignGroupImage()
Метод для установки имени изображения для группы товаров
AssignItemImage в файле shop.class.php, метод shop::AssignItemImage()
Метод для установки имени изображения для товара
AssignShopWatermark в файле shop.class.php, метод shop::AssignShopWatermark()
Метод осуществляющий обновление данных о файле watermark'a для магазина
AdminMenu.class.php | procedural page AdminMenu.class.php
Admin.class.php | procedural page Admin.class.php
admin_output.fns.php | procedural page admin_output.fns.php
top
b
$button | в файле show_table.class.php, переменная show_table::$button
$button_name | в файле show_table.class.php, переменная show_table::$button_name
$button_value | в файле show_table.class.php, переменная show_table::$button_value
Backup в файле Backup.class.php, класс Backup
Класс модуля "Резервное копирование"
Backup.class.php | procedural page Backup.class.php
Backup.php | procedural page Backup.php
BBcode2HTML в файле Forums.class.php, метод Forums::BBcode2HTML()
Метод замены BBcode на HTML
build в файле Xsl.class.php, метод xsl::build()
Метод обработки XML данных с помощью XSL шаблона
BuildCapture в файле Captcha.class.php, метод Captcha::BuildCapture()
Метод для построения изображения CAPTCHA и помещения его текста в сессию
build_counter в файле Counter.class.php, метод counter::build_counter()
Метод вывода счетчика
top
c
$CacheModificationItems в файле shop.class.php, переменная shop::$CacheModificationItems
Массив ID модификаций товара для товаров
$CacheSite в файле Site.class.php, переменная site::$CacheSite
Кэш данных о сайтах
$cache_InformationSystem в файле InformationSystems.class.php, переменная InformationSystem::$cache_InformationSystem
Кэш данных о информационной системе пример $this->cache_InformationSystem[$id]
$cache_mesure в файле shop.class.php, переменная shop::$cache_mesure
Кэш информации о единицах измерений
$cache_producer в файле shop.class.php, переменная shop::$cache_producer
Кэш информации о производителях
$cache_structure_property в файле Structure.class.php, переменная Structure::$cache_structure_property
Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.
$checked | в файле show_table.class.php, переменная table_fields::$checked
$CommentMass в файле InformationSystems.class.php, переменная InformationSystem::$CommentMass
Кэш с данными о комментариях
$copy_show | в файле show_table.class.php, переменная show_table::$copy_show
$count_mark_after_separator | в файле show_table.class.php, переменная table_fields::$count_mark_after_separator
$count_row в файле Structure.class.php, переменная Structure::$count_row
Количество выбранных элементов
$count_row | в файле Mysql.class.php, переменная MySQL::$count_row
$count_row | в файле Xsl.class.php, переменная xsl::$count_row
$count_row | в файле Templates.class.php, переменная templates::$count_row
$count_row | в файле Modules.class.php, переменная modules::$count_row
$count_row | в файле Site.class.php, переменная site::$count_row
$count_row_city_areas в файле shop.class.php, переменная shop::$count_row_city_areas
Количество выбранных районов города
$current_alias_cache | в файле Site.class.php, переменная site::$current_alias_cache
Cache в файле Cache.class.php, класс Cache
Класс модуля "Кэш"
Cache.class.php | procedural page Cache.class.php
Cache.php | procedural page Cache.php
config.php | procedural page config.php
CACHE_INSTALL | в файле Cache.php, константа CACHE_INSTALL
CACHE_LIMIT | в файле Cache.php, константа CACHE_LIMIT
Captcha в файле Captcha.class.php, класс Captcha
Ядро, класс для работы с CAPTCHA
ChangeMySqlDate в файле Date.class.php, метод DateClass::ChangeMySqlDate()
Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд
ChangeNormalDate в файле Date.class.php, метод DateClass::ChangeNormalDate()
Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд
CheckBot в файле Counter.class.php, метод counter::CheckBot()
Метод проверяет, является ли user-agent ботом
CheckTypeGzip в файле Compression.class.php, метод compression::CheckTypeGzip()
Метод вовзращает тип сжатия gzip, в противном случае false
ClearAdvertisementList в файле Advertisement.class.php, метод Advertisement::ClearAdvertisementList()
Метод очищающий список показов, произошедших $count_days назад
ClearCookieAndSessionCart в файле shop.class.php, метод shop::ClearCookieAndSessionCart()
Метод для очистки корзины кукисов и сессий
ClearPath в файле shop.class.php, метод shop::ClearPath()
Метод очищает путь от запрещенных символов
ClearStructure в файле Structure.class.php, метод Structure::ClearStructure()
Метод очистки параметров класса
CloseForum в файле Forums.class.php, метод Forums::CloseForum()
Метод, закрывающий/открывающий форум
CloseTheme в файле Forums.class.php, метод Forums::CloseTheme()
Метод, открыввающий/закрывающий тему для доступа
cms_error_handler в файле Error.fns.php, функция cms_error_handler()
Ядро, обработчики ошибок в HostCMS
code_ip в файле Counter.class.php, метод counter::code_ip()
Метод для преобразования IP в HEX
CODE_NAME | в файле Kernel.php, константа CODE_NAME
compression в файле Compression.class.php, класс compression
Класс модуля "Система сжатия (компрессия)"
Compression.class.php | procedural page Compression.class.php
Compression.php | procedural page Compression.php
COMPRESSION_INSTALL | в файле Compression.php, константа COMPRESSION_INSTALL
ConfirmGetForm в файле Forms.class.php, метод Forms::ConfirmGetForm()
Метод, определяющий может ли пользователь отправлять форму
confirm_information_item в файле InformationSystems.class.php, метод InformationSystem::confirm_information_item()
Метод определения возможности пользователя добавлять информационный элемент
Constants в файле Constants.class.php, класс Constants
Класс модуля "Константы"
Constants.class.php | procedural page Constants.class.php
Constants.php | procedural page Constants.php
ConvertPrice в файле shop.class.php, метод shop::ConvertPrice()
Конвертирует цену в различных форматах к цене в формате xxxx.yy
ConvertSqlProperty в файле lib.class.php, метод lib::ConvertSqlProperty()
Метод конвертирет SQL-запрос, введенный для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.
CopyDataTemplate в файле Templates.class.php, метод templates::CopyDataTemplate()
Метод копирования шаблона страниц
CopyDocuments в файле Documents.class.php, метод documents::CopyDocuments()
Метод копирования документа
CopyExtraProperty в файле Site_users.class.php, метод SiteUsers::CopyExtraProperty()
Метод копирования дополнительного параметра
CopyFascicle в файле Maillist.class.php, метод Maillist::CopyFascicle()
Метод копирования выпуска рассылки
CopyForms в файле Forms.class.php, метод Forms::CopyForms()
Метод копирования структуры формы и ее полей
CopyFormsField в файле Forms.class.php, метод Forms::CopyFormsField()
Метод копирования структуры поля формы
CopyImgWithWatermark в файле Image.class.php, метод Image::CopyImgWithWatermark()
Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя
CopyInformationItem в файле InformationSystems.class.php, метод InformationSystem::CopyInformationItem()
Метод копирования элемента информационной системы
CopyLib в файле lib.class.php, метод lib::CopyLib()
Метод создает копию типовой динамической страницы
CopyListItem в файле Lists.class.php, метод lists::CopyListItem()
Метод копирования элементов списка
CopyTemplate в файле Templates.class.php, метод templates::CopyTemplate()
Метод копирования макета
CopyXsl в файле Xsl.class.php, метод xsl::CopyXsl()
Метод копирования XSL-шаблона
CorrectPropertiesItem в файле shop.class.php, метод shop::CorrectPropertiesItem()
Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.
counter в файле Counter.class.php, класс counter
Класс модуля "Статистика посещаемости сайта"
COUNTER_BOT_COUNT | в файле config.php, константа COUNTER_BOT_COUNT
config.php | procedural page config.php
Counter.class.php | procedural page Counter.class.php
Counter.php | procedural page Counter.php
COUNTER_INSTALL в файле Counter.php, константа COUNTER_INSTALL
Модуль: /modules/Counter/Counter.php
CreateBackup в файле Backup.class.php, метод Backup::CreateBackup()
Метод создания резевной копии базы данных
CreateDirectory в файле shop.class.php, метод shop::CreateDirectory()
Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает
CreateGroupsXmlTree в файле InformationSystems.class.php, метод InformationSystem::CreateGroupsXmlTree()
Метод формирования XML дерева для информационных групп
CreateRSS в файле RssWrite.class.php, метод RssWrite::CreateRSS()
Метод формирования XML-файла в стандарте RSS
CreateWatermark | в файле Image.class.php, метод Image::CreateWatermark()
current_alias в файле Site.class.php, метод site::current_alias()
Метод преобразования алиаса (домена) сайта в основной
current_version в файле Documents.class.php, метод documents::current_version()
Метод для переобозначения текущей версии документа
CURRENT_VERSION | в файле Kernel.php, константа CURRENT_VERSION
config.php | procedural page config.php
Captcha.class.php | procedural page Captcha.class.php
config.php | procedural page config.php
top
d
$dec_point | в файле show_table.class.php, переменная table_fields::$dec_point
$delete_confirm | в файле show_table.class.php, переменная show_table::$delete_confirm
$delete_show | в файле show_table.class.php, переменная show_table::$delete_show
DateClass в файле Date.class.php, класс DateClass
Ядро, класс для работы с датами
DateSqlToUnix в файле Date.class.php, метод DateClass::DateSqlToUnix()
Метод преобразовывает дату в формате SQL в число секунд с начала эпохи
datetime_format в файле Date.class.php, метод DateClass::datetime_format()
Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT
datetime_format_sql в файле Date.class.php, метод DateClass::datetime_format_sql()
Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL
DateUnixToSQL в файле Date.class.php, метод DateClass::DateUnixToSQL()
Метод преобразовывает дату из числа секунд в формат SQL
date_format в файле Date.class.php, метод DateClass::date_format()
Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT
date_format_sql в файле Date.class.php, метод DateClass::date_format_sql()
Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат
db_connect в файле Mysql.class.php, метод MySQL::db_connect()
Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.
declension в файле Kernel.class.php, метод kernel::declension()
Метод получения существительного в форме, соответствующей числу
decode_ip в файле Counter.class.php, метод counter::decode_ip()
Метод для декодирования IP из HEX
DEFAULT_LNG | в файле Kernel.php, константа DEFAULT_LNG
DelBannerGroup в файле Advertisement.class.php, метод Advertisement::DelBannerGroup()
Метод исключения баннера из группы
DelBannersGroup в файле Advertisement.class.php, метод Advertisement::DelBannersGroup()
Метод удаления группы баннеров
DelConstants в файле Constants.class.php, метод Constants::DelConstants()
Метод удаления константы
DeleteAdvertisementFile в файле Advertisement.class.php, метод Advertisement::DeleteAdvertisementFile()
Метод удаляет загруженный файл для элемента с указанным идентификатором
DeleteAllItemsCatalogAndGroups в файле shop.class.php, метод shop::DeleteAllItemsCatalogAndGroups()
Метод очистки таблиц товаров и групп
DeleteBanner в файле Advertisement.class.php, метод Advertisement::DeleteBanner()
Метод удаления баннера
DeleteCacheItem в файле Cache.class.php, метод Cache::DeleteCacheItem()
Метод удаляет (помечает как удаленный) элемент с именем $item_name из кэша unknown_type
DeleteCart в файле shop.class.php, метод shop::DeleteCart()
Метод, осуществляющий удаление товара из корзины
DeleteCity в файле shop.class.php, метод shop::DeleteCity()
Метод, осуществляющий удаление города
DeleteCityArea в файле shop.class.php, метод shop::DeleteCityArea()
Метод удаления района города
DeleteComment в файле shop.class.php, метод shop::DeleteComment()
Метод удаления информации об отзыве на товар
DeleteCompany в файле shop.class.php, метод shop::DeleteCompany()
Метод удаления информации об организации
DeleteCondOfDelivery в файле shop.class.php, метод shop::DeleteCondOfDelivery()
Метод, осуществляющий удаление условия доставки
DeleteConference в файле Forums.class.php, метод Forums::DeleteConference()
Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.
DeleteCountry в файле shop.class.php, метод shop::DeleteCountry()
Метод, осуществляющий удаление страны
DeleteCoupon в файле shop.class.php, метод shop::DeleteCoupon()
Метод для удаления информации о купоне
DeleteCurrency в файле shop.class.php, метод shop::DeleteCurrency()
Метод, осуществляющий удаление валюты
DeleteDiscount в файле shop.class.php, метод shop::DeleteDiscount()
Метод, осуществляющий удаление скидки
DeleteExtraProperty в файле Site_users.class.php, метод SiteUsers::DeleteExtraProperty()
Метод удаления дополнительного параматра
DeleteForum в файле Forums.class.php, метод Forums::DeleteForum()
Метод удаления форума
DeleteGroup в файле shop.class.php, метод shop::DeleteGroup()
Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)
DeleteItem в файле shop.class.php, метод shop::DeleteItem()
Метод, осуществляющий удаление товара
DeleteItemDiscount в файле shop.class.php, метод shop::DeleteItemDiscount()
Метод удаления скики для товара
DeleteLib в файле lib.class.php, метод lib::DeleteLib()
Метод для удаления типовой динамической страницы из библиотеки страниц
DeleteLibDir в файле lib.class.php, метод lib::DeleteLibDir()
Метод для рекурсивного удаления раздела типовых дин. страниц со всеми его подразделами
DeleteLibProperty в файле lib.class.php, метод lib::DeleteLibProperty()
Метод для удаления параметра типовой динамической страницы
DeleteLibPropertyListItem в файле lib.class.php, метод lib::DeleteLibPropertyListItem()
Метод для удаления элемента списка параметра типовой динамической страницы
DeleteLocation в файле shop.class.php, метод shop::DeleteLocation()
Метод, осуществляющий удаление области
DeleteMesure в файле shop.class.php, метод shop::DeleteMesure()
Метод, осуществляющий удаление единицы измерения
DeleteOrder в файле shop.class.php, метод shop::DeleteOrder()
Метод, осуществляющий удаление заказа
DeleteOrderDiscount в файле shop.class.php, метод shop::DeleteOrderDiscount()
Метод для удаления информации о скидке для заказов
DeleteOrderItems в файле shop.class.php, метод shop::DeleteOrderItems()
Метод, осуществляющий удаление товара в заказе
DeleteOrderStatus в файле shop.class.php, метод shop::DeleteOrderStatus()
Метод, осуществляющий удаление статуса заказа
DeletePrice в файле shop.class.php, метод shop::DeletePrice()
Метод, осуществляющий удаление типа цены
DeletePriceForItem в файле shop.class.php, метод shop::DeletePriceForItem()
Метод удаляет цену для элемента каталога
DeletePricesForAllItem в файле shop.class.php, метод shop::DeletePricesForAllItem()
Метод удаляет все цены для элемента каталога
DeleteProducer в файле shop.class.php, метод shop::DeleteProducer()
Метод, осуществляющий удаление производителя
DeletePropertiesItem в файле shop.class.php, метод shop::DeletePropertiesItem()
Удаление информации о свойстве товара
DeletePropertyValue в файле Structure.class.php, метод Structure::DeletePropertyValue()
Метод для удаления значения свойтва узла структуры
DeletePropretyOfItems в файле shop.class.php, метод shop::DeletePropretyOfItems()
Метод, осуществляющий удаление свойства товара
DeleteSearchInfomationForSite в файле Search.class.php, метод Search::DeleteSearchInfomationForSite()
Метод для удаления поисковой информации сайта
DeleteSeller в файле shop.class.php, метод shop::DeleteSeller()
Метод, осуществляющий удаление продавца.
DeleteShop в файле shop.class.php, метод shop::DeleteShop()
Метод, осуществляющий удаление магазина
DeleteShopWatermark | в файле shop.class.php, метод shop::DeleteShopWatermark()
DeleteSiteUser в файле Site_users.class.php, метод SiteUsers::DeleteSiteUser()
Метод удаления пользователя из системы
DeleteStructure в файле Structure.class.php, метод Structure::DeleteStructure()
Метод для удлаения узла структуры с его дочерними узлами
DeleteSystemOfPay в файле shop.class.php, метод shop::DeleteSystemOfPay()
Метод, осуществляющий удаление платёжной системы
DeleteTax в файле shop.class.php, метод shop::DeleteTax()
Метод, осуществляющий удаление налога
DeleteTyingProducts в файле shop.class.php, метод shop::DeleteTyingProducts()
Метод удаления сопутствующих товаров
DeleteTypeOfDelivery в файле shop.class.php, метод shop::DeleteTypeOfDelivery()
Метод, осуществляющий удаление типа доставки
DeleteUserDeniedAccessBefore в файле UserAccess.class.php, метод UserAccessDenied::DeleteUserDeniedAccessBefore()
Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд
DeleteUsers в файле Maillist.class.php, метод Maillist::DeleteUsers()
Метод снятия подписки с подписчика
DeleteUsersGroup в файле Maillist.class.php, метод Maillist::DeleteUsersGroup()
Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке
delete_old_version в файле Documents.class.php, метод documents::delete_old_version()
Метод удаления записей обо всех не текущих версиях
delete_page в файле Structure.class.php, метод Structure::delete_page()
Метод удаления страницы
Delete_search_words в файле Search.class.php, метод Search::Delete_search_words()
Метод удаления из индекса страницы с указанным адресом
delete_status в файле Documents.class.php, метод documents::delete_status()
Метод удаления статуса документов
delete_version в файле Documents.class.php, метод documents::delete_version()
Метод удаления записей о версиях
DelFascicle в файле Maillist.class.php, метод Maillist::DelFascicle()
Метод удаления выпуска рассылки
DelFillForms в файле Forms.class.php, метод Forms::DelFillForms()
Удаление бланка заполненной формы
DelFillValues в файле Forms.class.php, метод Forms::DelFillValues()
Метод удаления значения одного из полей отправленной формы
DelForms в файле Forms.class.php, метод Forms::DelForms()
Метод удаления данных о форме
DelFormsFields в файле Forms.class.php, метод Forms::DelFormsFields()
Метод удаления поля формы
DelForumsGroup в файле Forums.class.php, метод Forums::DelForumsGroup()
Метод удаления группы форумов
DelGroupUser в файле Site_users.class.php, метод SiteUsers::DelGroupUser()
Метод удаления пользователя из группы
DelInformationGroupPropertys в файле InformationSystems.class.php, метод InformationSystem::DelInformationGroupPropertys()
Метод удаления дополнительного свойства информационной группы
DelInformationGroupPropertysValue в файле InformationSystems.class.php, метод InformationSystem::DelInformationGroupPropertysValue()
Метод удаления значений дополнительных свойств информационной группы
DelInformationSystem в файле InformationSystems.class.php, метод InformationSystem::DelInformationSystem()
Метод удаления информационной системы
DelIp в файле ip.class.php, метод ip::DelIp()
Метод удаления информации об IP-адресе
DelMaillist в файле Maillist.class.php, метод Maillist::DelMaillist()
Метод удаления рассылки
DelMessage в файле Forums.class.php, метод Forums::DelMessage()
Метод удаления сообщения темы
DelPollsGroup в файле Polls.class.php, метод polls::DelPollsGroup()
Метод удаления групп опросов
DelStatInfomationForSite в файле Counter.class.php, метод counter::DelStatInfomationForSite()
Метод удаления статистической информации для сайта
DelStructurePropertys в файле Structure.class.php, метод Structure::DelStructurePropertys()
Метод удаления дополнительного свойства
DelStructurePropertysValue в файле Structure.class.php, метод Structure::DelStructurePropertysValue()
Метод удаления значений дополнительных свойств из таблицы связи
DelTheme в файле Forums.class.php, метод Forums::DelTheme()
Метод удаления темы форума
DelUserGroup в файле Site_users.class.php, метод SiteUsers::DelUserGroup()
Метод удаления группы пользователей заданной идентификатором
del_alias в файле Site.class.php, метод site::del_alias()
Метод преобразования алиаса (домена) сайта в основной
del_comment в файле InformationSystems.class.php, метод InformationSystem::del_comment()
Метод удаления комментария к информационному элементу
del_data_templates в файле Templates.class.php, метод templates::del_data_templates()
Метод удаления шаблона страниц
del_dir в файле FileManager.class.php, метод FileManager::del_dir()
Метод удаления директории вместе с вложенными файлами и директориями
del_documents в файле Documents.class.php, метод documents::del_documents()
Метод удаления документов
del_documents_dir в файле Documents.class.php, метод documents::del_documents_dir()
Метод удаления разделов документов
del_file в файле FileManager.class.php, метод FileManager::del_file()
Метод удаления файла или директории
del_information_groups в файле InformationSystems.class.php, метод InformationSystem::del_information_groups()
Метод удаления информационных групп
del_information_items в файле InformationSystems.class.php, метод InformationSystem::del_information_items()
Метод удаления элемента информационной системы
del_information_propertys в файле InformationSystems.class.php, метод InformationSystem::del_information_propertys()
Метод удаления дополнительного свойства информационной системы
del_lists в файле Lists.class.php, метод lists::del_lists()
Метод удаления списка
del_lists_items в файле Lists.class.php, метод lists::del_lists_items()
Метод удаления элемента списка
del_module в файле Modules.class.php, метод modules::del_module()
Метод удаления информации о модуле
del_poll в файле Polls.class.php, метод polls::del_poll()
Метод удаления опроса
del_poll_reply в файле Polls.class.php, метод polls::del_poll_reply()
Метод удаления варианта ответа
del_site в файле Site.class.php, метод site::del_site()
Метод удаления информации о сайте
del_templates в файле Templates.class.php, метод templates::del_templates()
Метод удаления макета
del_user в файле UserAccess.class.php, метод user_access::del_user()
Метод удаления пользователя
del_user_type в файле UserAccess.class.php, метод user_access::del_user_type()
Метод удаления типа пользователей
del_xsl в файле Xsl.class.php, метод xsl::del_xsl()
Метод удаления XSL-шаблона
del_xsl_dir в файле Xsl.class.php, метод xsl::del_xsl_dir()
Метод удаления XSL-раздела
Diagramm в файле Graphic.class.php, метод graphic::Diagramm()
Метод рисования круговой диаграммы
DIAGRAMM_LIMIT | в файле Counter.php, константа DIAGRAMM_LIMIT
DIAGRAMM_WIDTH | в файле Counter.php, константа DIAGRAMM_WIDTH
documents в файле Documents.class.php, класс documents
Класс модуля "Старницы и документы"
Documents.class.php | procedural page Documents.class.php
Documents.php | procedural page Documents.php
Download в файле File.class.php, метод File::Download()
Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла
do_html_footer_admin в файле admin_output.fns.php, функция do_html_footer_admin()
Функция выводит "подвал" для страниц раздела администрирования
do_html_header_admin в файле admin_output.fns.php, функция do_html_header_admin()
Функция выводит "шапку" для страниц раздела администрирования
do_show_table в файле show_table.class.php, метод show_table::do_show_table()
Метод отображает сформированную таблицу
Date.class.php | procedural page Date.class.php
top
e
$edit_id в файле Structure.class.php, переменная Structure::$edit_id
Идентификатор редактируемого узла структуры
$edit_show | в файле show_table.class.php, переменная show_table::$edit_show
$error | в файле Modules.class.php, переменная modules::$error
$error | в файле Site.class.php, переменная site::$error
$error | в файле Templates.class.php, переменная templates::$error
$error | в файле shop.class.php, переменная shop::$error
EventsJournal в файле EventsJournal.class.php, класс EventsJournal
Ядро, класс журналирования событий
EventsJournalAdmin в файле EventsJournal.class.php, класс EventsJournalAdmin
Класс модуля "Журнал событий"
EventsJournal.class.php | procedural page EventsJournal.class.php
EventsJournal.php | procedural page EventsJournal.php
EventsMail в файле EventsJournal.class.php, метод EventsJournalAdmin::EventsMail()
Метод отправки письма с отчетом
ExecDump в файле ExecSqlQuery.class.php, метод ExecSqlQuery::ExecDump()
Метод выполнения SQL-запроса
ExecSqlQuery в файле ExecSqlQuery.class.php, класс ExecSqlQuery
Класс модуля "SQL-запросы"
ExecSqlQuery.class.php | procedural page ExecSqlQuery.class.php
ExecSqlQuery.php | procedural page ExecSqlQuery.php
ExecSystemsOfPayHandler в файле shop.class.php, метод shop::ExecSystemsOfPayHandler()
Метод выполнения обработчика платежной системы
ExternalXml в файле ExternalXml.class.php, класс ExternalXml
Ядро, класс формирует дерево XML по переданному массиву
E_STRICT | в файле Kernel.php, константа E_STRICT
Error.fns.php | procedural page Error.fns.php
EventsJournal.class.php | procedural page EventsJournal.class.php
ExternalXml.class.php | procedural page ExternalXml.class.php
top
f
$field | в файле show_table.class.php, переменная table_fields::$field
$FieldForIndexArray | в файле show_table.class.php, переменная table_fields::$FieldForIndexArray
$field_action_show | в файле show_table.class.php, переменная show_table::$field_action_show
$field_copy | в файле show_table.class.php, переменная show_table::$field_copy
$field_delete | в файле show_table.class.php, переменная show_table::$field_delete
$field_description | в файле show_table.class.php, переменная table_fields::$field_description
$field_edit | в файле show_table.class.php, переменная show_table::$field_edit
$field_link | в файле show_table.class.php, переменная table_fields::$field_link
$field_name | в файле show_table.class.php, переменная table_fields::$field_name
$field_prefix | в файле show_table.class.php, переменная table_fields::$field_prefix
$field_type | в файле show_table.class.php, переменная table_fields::$field_type
$flag | в файле ExternalXml.class.php, переменная ExternalXml::$flag
$form_action | в файле show_table.class.php, переменная show_table::$form_action
File в файле File.class.php, класс File
Ядро, класс для работы с файлами
FileManager в файле FileManager.class.php, класс FileManager
Класс модуля "Файловый менеджер"
FileManager.class.php | procedural page FileManager.class.php
FileManager.php | procedural page FileManager.php
FillMasGroup в файле InformationSystems.class.php, метод InformationSystem::FillMasGroup()
Метод формирования массива групп для информационной системы.
FillMasGroup в файле shop.class.php, метод shop::FillMasGroup()
Метод формирования массива групп самого верхнего уровня для данного магазина
FillMemCacheComments в файле shop.class.php, метод shop::FillMemCacheComments()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCacheCountItemsAndGroup в файле shop.class.php, метод shop::FillMemCacheCountItemsAndGroup()
Метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.
FillMemCacheCountItemsAndGroup в файле InformationSystems.class.php, метод InformationSystem::FillMemCacheCountItemsAndGroup()
Метод производит расчет числа подгрупп и элементов, содержащихся в группах информационной системы.
FillMemCacheDiscountsForItem в файле shop.class.php, метод shop::FillMemCacheDiscountsForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.
FillMemCacheGoupsIdTree в файле shop.class.php, метод shop::FillMemCacheGoupsIdTree()
Метод формирует дерево групп и подгрупп в массиве по их идентификаторам
FillMemCacheGoupsIdTree в файле InformationSystems.class.php, метод InformationSystem::FillMemCacheGoupsIdTree()
Метод формирует дерево групп и подгрупп в массиве по их идентификаторам
FillMemCacheModificationItems в файле shop.class.php, метод shop::FillMemCacheModificationItems()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCachePropertiesItem в файле shop.class.php, метод shop::FillMemCachePropertiesItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.
FillMemCacheTyingProducts в файле shop.class.php, метод shop::FillMemCacheTyingProducts()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
fill_xsl_dir в файле Xsl.class.php, метод xsl::fill_xsl_dir()
Метод формирования дерева разделов
Forms в файле Forms.class.php, класс Forms
Класс модуля "Формы"
Forms.class.php | procedural page Forms.class.php
Forms.php | procedural page Forms.php
Forums в файле Forums.class.php, класс Forums
Класс модуля "Форумы"
Forums.class.php | procedural page Forums.class.php
Forums.php | procedural page Forums.php
FREEDEBUG_URL | в файле Kernel.php, константа FREEDEBUG_URL
File.class.php | procedural page File.class.php
top
g
$GroupMass в файле InformationSystems.class.php, переменная InformationSystem::$GroupMass
Кэш с данными о группах
Graphic.class.php | procedural page Graphic.class.php
GenAddEditThemeXML в файле Forums.class.php, метод Forums::GenAddEditThemeXML()
УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
GenEditMessageXML в файле Forums.class.php, метод Forums::GenEditMessageXML()
УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
GenForumsXML в файле Forums.class.php, метод Forums::GenForumsXML()
Устаревший метод
GenGroupXmlTree в файле InformationSystems.class.php, метод InformationSystem::GenGroupXmlTree()
Метод формирования полного XML дерева информационных групп для информационной системы
GenMessageXML в файле Forums.class.php, метод Forums::GenMessageXML()
Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном
GenSmilesXML в файле Forums.class.php, метод Forums::GenSmilesXML()
Метод возвращает XML для смайликов
GenThemesXML в файле Forums.class.php, метод Forums::GenThemesXML()
Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном
GenUserInfoXML в файле Forums.class.php, метод Forums::GenUserInfoXML()
УСТАРЕВШИЙ Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном
GenXml в файле ExternalXml.class.php, метод ExternalXml::GenXml()
Метод генерации XML для переданного массива
GenXml4Comment в файле shop.class.php, метод shop::GenXml4Comment()
Метод генерирующий XML для отзыва о товаре
GenXml4Company в файле shop.class.php, метод shop::GenXml4Company()
Метод генерирует XML для организации
GenXml4CompareItems в файле shop.class.php, метод shop::GenXml4CompareItems()
Метод генерирует xml для товаров, выбранных для сравнения
GenXML4Currency в файле shop.class.php, метод shop::GenXML4Currency()
Метод генерирует XML для указанной валюты
GenXML4InfSys в файле Structure.class.php, метод Structure::GenXML4InfSys()
Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры
GenXml4Item в файле shop.class.php, метод shop::GenXml4Item()
Метод построения XML для товара, его свойств и сопутствующих товаров
GenXml4ItemCatalogCommentAverageGrade в файле shop.class.php, метод shop::GenXml4ItemCatalogCommentAverageGrade()
Метод возвращает среднею оценку по товару.
GenXml4ItemCatalogComments в файле shop.class.php, метод shop::GenXml4ItemCatalogComments()
Метод возвращает все комментарии, относящиеся к данному товару.
GenXml4ListItems в файле Lists.class.php, метод lists::GenXml4ListItems()
Метод генерирует XML для всех элементов списка.
GenXml4Mesures в файле shop.class.php, метод shop::GenXml4Mesures()
Метод генерирует XML для единиц измерения
GenXml4OrderStatus в файле shop.class.php, метод shop::GenXml4OrderStatus()
Метод генерирует XML для статуса доставки
GenXml4Poll в файле Polls.class.php, метод polls::GenXml4Poll()
Метод формирования XML для опроса
GenXml4Properties в файле shop.class.php, метод shop::GenXml4Properties()
Метод построения XML для свойств.
GenXml4Property в файле shop.class.php, метод shop::GenXml4Property()
Возвращает XML свойства.
GenXml4Saller в файле shop.class.php, метод shop::GenXml4Saller()
Возвращает XML продавца.
GenXml4Sallers в файле shop.class.php, метод shop::GenXml4Sallers()
Метод построения XML для продавцов.
GenXml4Shop | в файле shop.class.php, метод shop::GenXml4Shop()
GenXml4StructureLevelMass в файле Structure.class.php, метод Structure::GenXml4StructureLevelMass()
Метод генерации части XML-а для записей указанного уровня
GenXmlProducerList в файле shop.class.php, метод shop::GenXmlProducerList()
Метод генерирует XML для списка продавцов магазина
GetAccessItem в файле InformationSystems.class.php, метод InformationSystem::GetAccessItem()
Метод определения доступности информационного элемента
GetAdvertisement в файле Advertisement.class.php, метод Advertisement::GetAdvertisement()
Метод возвращает данные об элементе (баннере, всплывающем окне и т.п.)
GetAlias в файле Site.class.php, метод site::GetAlias()
Метод получения данных об алиасе сайта
GetAliasById в файле Site.class.php, метод site::GetAliasById()
Метод возвращает информацию об алиасе (домене)
GetAllAlias в файле Site.class.php, метод site::GetAllAlias()
Метод возвращает информацию обо всех доменах
GetAllCity в файле shop.class.php, метод shop::GetAllCity()
Enter description here...
GetAllCityArea в файле shop.class.php, метод shop::GetAllCityArea()
Метод выборки всех районов города
GetAllComments в файле shop.class.php, метод shop::GetAllComments()
Метод возвращает список всех комментариев
GetAllCompanies в файле shop.class.php, метод shop::GetAllCompanies()
Метод для получения списка всех компаний
GetAllCondOfDelivery в файле shop.class.php, метод shop::GetAllCondOfDelivery()
Метод выборки всех условий доставки
GetAllConferences в файле Forums.class.php, метод Forums::GetAllConferences()
Метод получения информации о всех конференциях сайт.
GetAllCountries | в файле shop.class.php, метод shop::GetAllCountries()
GetAllCoupons в файле shop.class.php, метод shop::GetAllCoupons()
Метод возвращает список купонов по заданным условиям
GetAllCurrency в файле shop.class.php, метод shop::GetAllCurrency()
Метод выборки информации обо всех валютах
GetAllDiscounts в файле shop.class.php, метод shop::GetAllDiscounts()
Метод возвращает список всех скидок
GetAllDiscountsForItem в файле shop.class.php, метод shop::GetAllDiscountsForItem()
Метод извлечения информации обо всех скидках для данного товара
GetAllForms в файле Forms.class.php, метод Forms::GetAllForms()
Метод получения всех форм.
GetAllForums в файле Forums.class.php, метод Forums::GetAllForums()
Метод для получения всех форумов
GetAllForumsGroup в файле Forums.class.php, метод Forums::GetAllForumsGroup()
Метод для получения списка всех групп
GetAllGroups в файле shop.class.php, метод shop::GetAllGroups()
Метод получения всех групп магазина
GetAllInformationSystems в файле InformationSystems.class.php, метод InformationSystem::GetAllInformationSystems()
Метод возвращает список инфосистем
GetAllItems в файле shop.class.php, метод shop::GetAllItems()
Метод получения всех товаров заданного магазина и заданной группы товаров
GetAllItemsForOrder в файле shop.class.php, метод shop::GetAllItemsForOrder()
Метод получения заказанных товаров
GetAllLibDirs в файле lib.class.php, метод lib::GetAllLibDirs()
Метод возвращает список всех директори типовых дин. страниц
GetAllLibProperties в файле lib.class.php, метод lib::GetAllLibProperties()
Метод возвращает всписок всех дополнительных параметров типовой динамической страницы
GetAllLibPropertyListItems в файле lib.class.php, метод lib::GetAllLibPropertyListItems()
Метод для получения списка всех элементов списка
GetAllLibs в файле lib.class.php, метод lib::GetAllLibs()
Метод возвращает список всех типовых страниц
GetAllListProperties в файле shop.class.php, метод shop::GetAllListProperties()
Метод получения всех дополнительных свойств для магазина
GetAllLocation в файле shop.class.php, метод shop::GetAllLocation()
Метод получения списка всех областей (штатов)
GetAllMessages в файле Forums.class.php, метод Forums::GetAllMessages()
Метод для получения всех сообщений
GetAllMesures в файле shop.class.php, метод shop::GetAllMesures()
Метод выборки всех единиц измерения
GetAllModificationItems в файле shop.class.php, метод shop::GetAllModificationItems()
Метод возвращает информацию обо всех модификациях данного товара
GetAllOrderDiscounts в файле shop.class.php, метод shop::GetAllOrderDiscounts()
Метод для извлечения информации обо всех скидках
GetAllOrders в файле shop.class.php, метод shop::GetAllOrders()
Метод выборки заказов для магазина
GetAllOrderStatus в файле shop.class.php, метод shop::GetAllOrderStatus()
Метод получения информации обо всех статусах заказаов
GetAllPollsGroups в файле Polls.class.php, метод polls::GetAllPollsGroups()
Метод получения информации о всех группах опросов
GetAllPricesForItem в файле shop.class.php, метод shop::GetAllPricesForItem()
Метод получения информации о ценах, заданных для товара
GetAllPricesForShop в файле shop.class.php, метод shop::GetAllPricesForShop()
Метод получения списка цен для магазина
GetAllProducers в файле shop.class.php, метод shop::GetAllProducers()
Метод получения информации обо всех производителях
GetAllPropertiesItem в файле shop.class.php, метод shop::GetAllPropertiesItem()
Метод извлечения информации о дополнительных свойствах заданного товара
GetAllSellers в файле shop.class.php, метод shop::GetAllSellers()
Метод получения информации о всех продавцах магазина $shop_id, если $shop_id = false, то о продавцах всех магазинов
GetAllSession в файле Counter.class.php, метод counter::GetAllSession()
Определяет число сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"
GetAllShops в файле shop.class.php, метод shop::GetAllShops()
Метод для получения списка всех магазинов
GetAllStructure в файле Structure.class.php, метод Structure::GetAllStructure()
Метод для получения списка всех узлов структуры сайта
GetAllStructureProperties в файле Structure.class.php, метод Structure::GetAllStructureProperties()
Метод для получения списка всех доп. свойств структуры
GetAllStructurePropertyValuesOfProperty в файле Structure.class.php, метод Structure::GetAllStructurePropertyValuesOfProperty()
Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства
GetAllSystemOfPay в файле shop.class.php, метод shop::GetAllSystemOfPay()
Метод получения всех активных платежных систем
GetAllTax в файле shop.class.php, метод shop::GetAllTax()
Метод получения информации о налогах
GetAllTypeOfDelivery в файле shop.class.php, метод shop::GetAllTypeOfDelivery()
Метод выборки всех типов доставки для конкретного магазина
GetAllUsers в файле Site_users.class.php, метод SiteUsers::GetAllUsers()
Метод выборки всех пользователей сайта
GetAllUserTypes в файле UserAccess.class.php, метод user_access::GetAllUserTypes()
Метод возвращает список типов пользователей
GetBotsInfo в файле Counter.class.php, метод counter::GetBotsInfo()
Метод получения данных о ботах и посещенных ими страницах
GetCacheContent в файле Cache.class.php, метод Cache::GetCacheContent()
Метод получения данных из кэша
GetCacheContentByAddress в файле Cache.class.php, метод Cache::GetCacheContentByAddress()
Метод возвращает данные из кэша, принимает адрес (позицию) блока в кэше и имя кэша
GetCaptchaId в файле Captcha.class.php, метод Captcha::GetCaptchaId()
Метод генерирует и возвращает уникальный индекс для CAPTCHA
GetCart в файле shop.class.php, метод shop::GetCart()
Метод, осуществляющий извлечение корзины
GetCity в файле shop.class.php, метод shop::GetCity()
Метод, осуществляющий извлечение города
GetComment в файле shop.class.php, метод shop::GetComment()
Метод возвращает информацию о комментарии к товару
GetCommentInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetCommentInformationSystemItem()
Метод получения комментариев информационных элементов
GetCompany в файле shop.class.php, метод shop::GetCompany()
Метод для получения информации об организации
GetCondOfDelivery в файле shop.class.php, метод shop::GetCondOfDelivery()
Метод, осуществляющий извлечение условия доставки
GetCondOfDeliveryXml в файле shop.class.php, метод shop::GetCondOfDeliveryXml()
Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)
GetConference в файле Forums.class.php, метод Forums::GetConference()
Метод для получения информации о конференции.
GetConferencePath в файле Forums.class.php, метод Forums::GetConferencePath()
Метод возвращает путь к конференции по ее идентификатору
GetConstants в файле Constants.class.php, метод Constants::GetConstants()
Метод получения данных о константах
GetCookieExpires в файле shop.class.php, метод shop::GetCookieExpires()
Метод возвращает время истечения данных в корзине, хранящейся в кукисах.
GetCountCity в файле shop.class.php, метод shop::GetCountCity()
Метод получения числа городов для области
GetCountCountry в файле shop.class.php, метод shop::GetCountCountry()
Метод получения числа стран
GetCountCurrency в файле shop.class.php, метод shop::GetCountCurrency()
Метод получения числа валют в справочнике
GetCountDiscount в файле shop.class.php, метод shop::GetCountDiscount()
Метод получения числа скидок для магазина
GetCounterInform в файле Counter.class.php, метод counter::GetCounterInform()
Метод получения информации о данных счетчика за определенную дату
GetCountInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetCountInformationSystemItem()
Метод получения количества элементов информационной системы
GetCountItemsAndGroups в файле InformationSystems.class.php, метод InformationSystem::GetCountItemsAndGroups()
Метод получения числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()
GetCountItemsAndGroups в файле shop.class.php, метод shop::GetCountItemsAndGroups()
Метод получения числа элементов и групп для переданной родительской группы
GetCountItemsCatalog в файле shop.class.php, метод shop::GetCountItemsCatalog()
Метод получения числа товаров в одном или во всех разделах магазина
GetCountItemsWithConditions в файле shop.class.php, метод shop::GetCountItemsWithConditions()
Метод получения числа товаров, параметры которых удовлетворяют заданным условиям
GetCountLocation в файле shop.class.php, метод shop::GetCountLocation()
Метод получения числа областей (штатов) для страны
GetCountMesures в файле shop.class.php, метод shop::GetCountMesures()
Метод получения числа единиц измерения в справочнике
GetCountOrder в файле shop.class.php, метод shop::GetCountOrder()
Метод выборки количества заказов для магазина
GetCountOrderStatus в файле shop.class.php, метод shop::GetCountOrderStatus()
Метод получения числа статусов заказа
GetCountPolls в файле Polls.class.php, метод polls::GetCountPolls()
Метод получения числа опросов в группе
GetCountPollsGroup в файле Polls.class.php, метод polls::GetCountPollsGroup()
Метод получения числа групп опросов для одного или всех сайтов
GetCountProducers в файле shop.class.php, метод shop::GetCountProducers()
Метод получения числа производителей для данного магазина
GetCountProperties в файле shop.class.php, метод shop::GetCountProperties()
Метод получения числа свойств товаров конкретного магазина
GetCountProperty4InformationSystem в файле InformationSystems.class.php, метод InformationSystem::GetCountProperty4InformationSystem()
Метод получения числа свойств информационной системы
GetCountProperty4Structure в файле Structure.class.php, метод Structure::GetCountProperty4Structure()
Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют
GetCountry в файле shop.class.php, метод shop::GetCountry()
Метод, осуществляющий извлечение страны
GetCountSellers в файле shop.class.php, метод shop::GetCountSellers()
Метод получения числа продавцов в справочнике
GetCountShops в файле shop.class.php, метод shop::GetCountShops()
Метод получения числа магазинов для одного или всех сайтов, обслуживаемых системой управления
GetCountShowingBanner в файле Advertisement.class.php, метод Advertisement::GetCountShowingBanner()
Метод возвращает количество показов баннера
GetCountShowingBannerAtDay в файле Advertisement.class.php, метод Advertisement::GetCountShowingBannerAtDay()
Метод возвращает количество показов баннера за конкретный день
GetCountSystemOfPay в файле shop.class.php, метод shop::GetCountSystemOfPay()
Метод получения числа систем оплаты
GetCountTax в файле shop.class.php, метод shop::GetCountTax()
Метод получения числа налогов в справочнике
GetCountTypeOfDelivery в файле shop.class.php, метод shop::GetCountTypeOfDelivery()
Метод получения числа типов доставок для данного магазина
GetCountTypePrices в файле shop.class.php, метод shop::GetCountTypePrices()
Метод получения числа типов цен для магазина
GetCoupon в файле shop.class.php, метод shop::GetCoupon()
Метод возвращает массив с информацией о купоне
GetCouponByText в файле shop.class.php, метод shop::GetCouponByText()
Возвращает информацию о купоне по его тексту
GetCurrency в файле shop.class.php, метод shop::GetCurrency()
Метод, осуществляющий извлечение информации о валюте
GetCurrencyCoefficientToShopCurrency в файле shop.class.php, метод shop::GetCurrencyCoefficientToShopCurrency()
Метод определения коэффициента пересчета валюты товара в валюту магазина
GetCurrencyForShop в файле shop.class.php, метод shop::GetCurrencyForShop()
Метод получения валюты, указанной по умолчанию для магазина
GetCurrencyXml в файле shop.class.php, метод shop::GetCurrencyXml()
Метод формирования xml для валюты
GetCurrentAlias в файле Site.class.php, метод site::GetCurrentAlias()
Метод определения основного алиаса сайта
GetCurrentSiteUser в файле Site_users.class.php, метод SiteUsers::GetCurrentSiteUser()
Метод определения идентификатора текущего пользователя сайта.
GetCurrentUser в файле Kernel.class.php, метод kernel::GetCurrentUser()
Метод определения идентификатора текущего авторизированного пользователя раздела администрирования
GetCurrentYear в файле Kernel.class.php, метод kernel::GetCurrentYear()
Метод получения значения текущего года
GetDayInformation в файле Counter.class.php, метод counter::GetDayInformation()
Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"
GetDBVersion в файле Kernel.class.php, метод kernel::GetDBVersion()
Метод определения версии MySQL
GetDefaultCurrency в файле shop.class.php, метод shop::GetDefaultCurrency()
Метод получения информации о базовой валюте
GetDefaultGroup в файле Site_users.class.php, метод SiteUsers::GetDefaultGroup()
Метод получения id группы используемой по умолчанию
GetDefaultOrderStatus в файле shop.class.php, метод shop::GetDefaultOrderStatus()
Метод получения статуса заказа, установленного по умолчанию
GetDelimitedGroups в файле shop.class.php, метод shop::GetDelimitedGroups()
Метод формирования дерева групп для магазина.
GetDiscount в файле shop.class.php, метод shop::GetDiscount()
Метод, осуществляющий извлечение информации о скидке
GetDocumentVersion в файле Documents.class.php, метод documents::GetDocumentVersion()
Метод получения информации о текущей версии документа
GetExpansion в файле InformationSystems.class.php, метод InformationSystem::GetExpansion()
Метод получения расширения файла
GetExpires в файле Kernel.class.php, метод kernel::GetExpires()
Метод получения времени истечения актуальности страницы
GetExtension в файле Kernel.class.php, метод kernel::GetExtension()
Метод возвращает расширение файла
GetExternalInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetExternalInformationSystemItem()
Метод получения элементов информационной системы. Переименован с GetInformationSystemItem
GetExtraProperty в файле Site_users.class.php, метод SiteUsers::GetExtraProperty()
Метод получения значения свойств дополнительного параметра
GetFascicle в файле Maillist.class.php, метод Maillist::GetFascicle()
Метод возвращает информацию о почтовой рассылке
GetFileContent в файле File.class.php, метод File::GetFileContent()
Метод получения содержимого файла
GetFillForms в файле Forms.class.php, метод Forms::GetFillForms()
Метод получения списка заполненных форм для формы $forms_id.
GetFillFormsFields в файле Forms.class.php, метод Forms::GetFillFormsFields()
Метод получения списка и значения полей для заполненной формы.
GetForm в файле Forms.class.php, метод Forms::GetForm()
Метод обработки содержимого отправленной формы
GetFormFields в файле Forms.class.php, метод Forms::GetFormFields()
Метод получения данных о полях формы
GetForum в файле Forums.class.php, метод Forums::GetForum()
Метод получения информации о форуме
GetForumAccess в файле Forums.class.php, метод Forums::GetForumAccess()
Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму
GetForumAndItemIdFromPath в файле Forums.class.php, метод Forums::GetForumAndItemIdFromPath()
Метод получения данных об идентификаторе форума и темы по переданному массиву с элементами пути
GetForumsGroup в файле Forums.class.php, метод Forums::GetForumsGroup()
Метод возвращает информацию о группе форумов
GetGDVersion в файле Kernel.class.php, метод kernel::GetGDVersion()
Метод определения версии GD библиотеки
GetGroup в файле shop.class.php, метод shop::GetGroup()
Метод, осуществляющий извлечение информации о группе
GetGroups в файле shop.class.php, метод shop::GetGroups()
Метод возвращает список групп магазина
GetGroupsForUser в файле Site_users.class.php, метод SiteUsers::GetGroupsForUser()
Метод определения идентификаторов групп, в которые входит пользователь
GetGroupsInformationSystem в файле InformationSystems.class.php, метод InformationSystem::GetGroupsInformationSystem()
Метод формирования дерева групп информационной группы
GetGroupsTree в файле shop.class.php, метод shop::GetGroupsTree()
Метод получения массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской
GetGroupsXmlTree в файле shop.class.php, метод shop::GetGroupsXmlTree()
Метод построения дерева xml для групп
GetGroupWithPath в файле shop.class.php, метод shop::GetGroupWithPath()
Метод получения информации о группе по пути, если такая существует в данной подгруппе магазина
GetGroupWithValue в файле shop.class.php, метод shop::GetGroupWithValue()
Метод получения информации о группе по наименованию, если такая существует в данной подгруппе магазина
GetIdInformationItem в файле InformationSystems.class.php, метод InformationSystem::GetIdInformationItem()
Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы
GetImageSize в файле Image.class.php, метод Image::GetImageSize()
Метод определяет высоту и ширину изображения
GetInformationFromPath в файле InformationSystems.class.php, метод InformationSystem::GetInformationFromPath()
Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI
GetInformationGroup в файле InformationSystems.class.php, метод InformationSystem::GetInformationGroup()
Получение информации о группе. Использует кэш "INF_SYS_GROUP"
GetInformationGroupName в файле InformationSystems.class.php, метод InformationSystem::GetInformationGroupName()
Метод получения имени информационной группы
GetInformationSystem в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystem()
Метод получения данных об информационной системе
GetInformationSystemGroupAccess в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemGroupAccess()
Метод определения уровня доступности информационной группы
GetInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemItem()
Метод для получения данных об информационном элементе
GetInformationSystemItemAccess в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemItemAccess()
Метод определения уровня доступности информационного элемента
GetInformationSystemItems в файле InformationSystems.class.php, метод InformationSystem::GetInformationSystemItems()
Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит
GetInitialData в файле Counter.class.php, метод counter::GetInitialData()
Метод получения начальных данных для счетчика
GetIpInfo в файле ip.class.php, метод ip::GetIpInfo()
Метод получения информации о запретах для переданного ip-адреса
GetIpInformation в файле Counter.class.php, метод counter::GetIpInformation()
Метод выборки информации для IP-адреса
GetItem в файле shop.class.php, метод shop::GetItem()
Метод, осуществляющий извлечение информации о товаре
GetItemByParam в файле shop.class.php, метод shop::GetItemByParam()
Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента
GetItemDiscount в файле shop.class.php, метод shop::GetItemDiscount()
Метод получения информации о скидке на товар
GetItemFromCart в файле shop.class.php, метод shop::GetItemFromCart()
Метод получения информации о товаре из корзины для пользователя
GetItemPath в файле shop.class.php, метод shop::GetItemPath()
Метод определения идентификатора группы товаров и идентификатора товара по значению URL
GetItemsFromCart в файле shop.class.php, метод shop::GetItemsFromCart()
Метод получения товаров, находящихся в корзине
GetItemsFromCookiesToCart в файле shop.class.php, метод shop::GetItemsFromCookiesToCart()
Метод перемещения информации о заказанном товаре в таблицу корзины
GetItemsXmlTree в файле shop.class.php, метод shop::GetItemsXmlTree()
Метод построения XML для товаров
GetItemXml в файле shop.class.php, метод shop::GetItemXml()
Метод формирования xml товара
GetLastModified в файле Kernel.class.php, метод kernel::GetLastModified()
Метод получения времени последнего изменения страницы
GetLib в файле lib.class.php, метод lib::GetLib()
Метод возвращает типовую динамическую страницу по её идентификатору
GetLibDir в файле lib.class.php, метод lib::GetLibDir()
Метод для получения информации о директории типовых дин. страниц
GetLibDirTree в файле lib.class.php, метод lib::GetLibDirTree()
Метод формирования дерева разделов
GetLibProperty в файле lib.class.php, метод lib::GetLibProperty()
Метод возвращает информацию о параметре типовой динамической страницы
GetList в файле Lists.class.php, метод lists::GetList()
Метод выборки данных о списках
GetListExtraProperties в файле Site_users.class.php, метод SiteUsers::GetListExtraProperties()
Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором
GetListItem в файле Lists.class.php, метод lists::GetListItem()
Метод получения данные об элементе списка
GetListItemIfIssetValue в файле Lists.class.php, метод lists::GetListItemIfIssetValue()
Метод проверки наличия значения в списке
GetListItemsValuesById в файле Lists.class.php, метод lists::GetListItemsValuesById()
Метод возвращает элементы списка.
GetListPrimaryProperties в файле Site_users.class.php, метод SiteUsers::GetListPrimaryProperties()
УСТАРЕВШИЙ Метод получения основных данных о пользователе
GetLocation в файле shop.class.php, метод shop::GetLocation()
Метод, осуществляющий извлечение области
GetLogStat в файле Search.class.php, метод Search::GetLogStat()
Метод для получения сгруппированной информации о поисковых запросах
GetMaillist в файле Maillist.class.php, метод Maillist::GetMaillist()
Метод возвращает ассоциативный массив с информацией о списке рассылок
GetMaillistXML в файле Maillist.class.php, метод Maillist::GetMaillistXML()
Метод генерирующий XML для состояния подписки конкретного пользователя сайта
GetMasGroup в файле InformationSystems.class.php, метод InformationSystem::GetMasGroup()
Метод получения массива информационных групп
GetMasGroupToRoot | в файле shop.class.php, метод shop::GetMasGroupToRoot()
GetMesure в файле shop.class.php, метод shop::GetMesure()
Метод, осуществляющий извлечение информации о единице измерения
getmicrotime в файле Kernel.class.php, метод kernel::getmicrotime()
Метод получения значения времени
GetMimeType в файле Kernel.class.php, метод kernel::GetMimeType()
Метод определения MIME-типа файла
GetNewUsersInform в файле Counter.class.php, метод counter::GetNewUsersInform()
Метод выборки информации о новых пользователях сайта
GetObject в файле Kernel.class.php, метод kernel::GetObject()
Метод создает глобально доступный объект
GetOrder в файле shop.class.php, метод shop::GetOrder()
Метод, осуществляющий извлечение заказа
GetOrderDiscount в файле shop.class.php, метод shop::GetOrderDiscount()
Метод возвращает информацию о скидке для заказов
GetOrderDiscountForSum в файле shop.class.php, метод shop::GetOrderDiscountForSum()
Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина
GetOrderDiscountWithConditions в файле shop.class.php, метод shop::GetOrderDiscountWithConditions()
Метод возвращает список скидок на сумму заказа по заданным условиям
GetOrderInfoArray в файле shop.class.php, метод shop::GetOrderInfoArray()
Метод формирования массива с информацией о заказе для вставки в заказы
GetOrderItem в файле shop.class.php, метод shop::GetOrderItem()
Метод, осуществляющий извлечение товара из заказа
GetOrderItems в файле shop.class.php, метод shop::GetOrderItems()
Метод, осуществляющий извлечение товаров из заказа
GetOrdersStatus в файле shop.class.php, метод shop::GetOrdersStatus()
Метод, осуществляющий извлечение состояния заказа
GetOrderXml в файле shop.class.php, метод shop::GetOrderXml()
Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных
GetPageCount в файле Search.class.php, метод Search::GetPageCount()
Метод определения числа проиндексированных страниц
GetPageInfo в файле Search.class.php, метод Search::GetPageInfo()
Метод получения информации о проиндексированных страницах
GetPathGroup в файле InformationSystems.class.php, метод InformationSystem::GetPathGroup()
Метод формирования пути по информационным группам
GetPathGroup в файле shop.class.php, метод shop::GetPathGroup()
Метод формирования пути по группам товара
GetPathItem в файле InformationSystems.class.php, метод InformationSystem::GetPathItem()
Метод формирования пути к данному информационному элементу
GetPathProducer | в файле shop.class.php, метод shop::GetPathProducer()
GetPoll в файле Polls.class.php, метод polls::GetPoll()
Метод возвращает данные об опросе
GetPollsGroup в файле Polls.class.php, метод polls::GetPollsGroup()
Метод получения информации о группе опросов
GetPrice в файле shop.class.php, метод shop::GetPrice()
Метод, осуществляющий извлечение типа цены
GetPriceForItem в файле shop.class.php, метод shop::GetPriceForItem()
Метод определения наличия указанной цены для заданного товара
GetPriceForUser в файле shop.class.php, метод shop::GetPriceForUser()
Метод определения цены товара для заданного пользователя
GetProducer в файле shop.class.php, метод shop::GetProducer()
Метод, осуществляющий извлечение информации о производителе
GetProperrtyMenuId в файле Structure.class.php, метод Structure::GetProperrtyMenuId()
Метод получения информации о текущем разделе меню
GetPropertiesOfGroup в файле shop.class.php, метод shop::GetPropertiesOfGroup()
Метод для получения списка идентификаторов свойств товаров для определенной группы.
GetPropertiesOfGroupForXml в файле shop.class.php, метод shop::GetPropertiesOfGroupForXml()
Возвращает список свойств, разврешенных для вывода в XML
GetPropertyACountProperty в файле Structure.class.php, метод Structure::GetPropertyACountProperty()
Метод получения количества свойств для разных сайтов
GetPropertyCountRow в файле InformationSystems.class.php, метод InformationSystem::GetPropertyCountRow()
Метод получения числа записей в выборке инфосистем, групп или информационных элементов
GetPropertyCountRow в файле Structure.class.php, метод Structure::GetPropertyCountRow()
Метод получения количества выбранных элементов
GetPropertyEditId в файле Structure.class.php, метод Structure::GetPropertyEditId()
Метод полчения информации о редактиремом элементе структуры
GetPropertyError в файле InformationSystems.class.php, метод InformationSystem::GetPropertyError()
Метод возвращающий код ошибки, возникающей при работе с методами класса
GetPropertyLevel в файле Structure.class.php, метод Structure::GetPropertyLevel()
Метод получения информации о максимальном уровне
GetPropertyMasInformationGroups в файле InformationSystems.class.php, метод InformationSystem::GetPropertyMasInformationGroups()
Метод получения массива свойств информацуонных групп
GetPropertyParentId в файле Structure.class.php, метод Structure::GetPropertyParentId()
Метод получения идентификатора родительского узла текущего элемента структуры
GetPropertyRecordOnPage в файле InformationSystems.class.php, метод InformationSystem::GetPropertyRecordOnPage()
Метод получения числа записей, выводимых на страницу
GetPropertySectionPath в файле InformationSystems.class.php, метод InformationSystem::GetPropertySectionPath()
Метод получения значения свойтва, содержащего пути по группам
GetPropertySeparator в файле Structure.class.php, метод Structure::GetPropertySeparator()
Метод получения информации о разделителе
GetPropertysGroup в файле InformationSystems.class.php, метод InformationSystem::GetPropertysGroup()
Метод получения данных о дополнительных свойствах информационной группы
GetPropertysInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::GetPropertysInformationSystemItem()
Метод получения свойств информационных элементов
GetPropertyStructureMass в файле Structure.class.php, метод Structure::GetPropertyStructureMass()
Метод получения информации об элементах структуры
GetPropertyStructureParentMass в файле Structure.class.php, метод Structure::GetPropertyStructureParentMass()
Метод получения информации о родительских разделах элемента структуры
GetPropertyStructurePropertysList в файле Structure.class.php, метод Structure::GetPropertyStructurePropertysList()
Метод получения дополнительных свойств структуры
GetPropertyValue в файле Structure.class.php, метод Structure::GetPropertyValue()
Метод для получения информации о значении свойства структуры
GetPropretyOfItems в файле shop.class.php, метод shop::GetPropretyOfItems()
Метод, осуществляющий извлечение свойства товара (по идентификатору таблицы связи свойств и товаров)
GetSearchSystemInform в файле Counter.class.php, метод counter::GetSearchSystemInform()
Метод выборки информации о поисковых системах
GetSecondaryStat в файле Counter.class.php, метод counter::GetSecondaryStat()
Метод получения статистической информации из таблицы сессий
GetSectionPath в файле lib.class.php, метод lib::GetSectionPath()
Метод возвращает путь к типовой дин. стренице
GetSelect в файле show_table.class.php, метод show_table::GetSelect()
Метод формирования html содержимого тега select
GetSeller в файле shop.class.php, метод shop::GetSeller()
Метод получения информации о продавце по его идентификатору.
GetShop в файле shop.class.php, метод shop::GetShop()
Метод, осуществляющий извлечение информации о магазине
GetShopCurrency в файле shop.class.php, метод shop::GetShopCurrency()
Метод получения информации о валюте магазина
GetShopDiscount в файле shop.class.php, метод shop::GetShopDiscount()
Метод получения списка скидок для магазина
GetShopGroupsToRoot в файле shop.class.php, метод shop::GetShopGroupsToRoot()
Метод получения массива с данными о каталогах магазина, начиная с данной и до корневой
GetShopWhithStructureId в файле shop.class.php, метод shop::GetShopWhithStructureId()
Метод выбора информации о магазине данного узла структуры сайта
GetSite в файле Site.class.php, метод site::GetSite()
Метод получения данных о сайте по его идентификатору
GetSiteUser в файле Site_users.class.php, метод SiteUsers::GetSiteUser()
Метод получения информации о пользователе сайта
GetSiteUserXml в файле Site_users.class.php, метод SiteUsers::GetSiteUserXml()
Метод формирования XML с данными о пользователе
GetStatArray в файле Counter.class.php, метод counter::GetStatArray()
Метод получения статистической информации из основной таблицы
GetStatDataArray в файле Counter.class.php, метод counter::GetStatDataArray()
Метод получения статистических данных за переданный промежуток времени
GetStructure в файле Structure.class.php, метод Structure::GetStructure()
Метод выборки всех страниц структуры
GetStructureAccess в файле Structure.class.php, метод Structure::GetStructureAccess()
Метод получения информации о доступе к узлу элементов структуры
GetStructureForParent в файле Structure.class.php, метод Structure::GetStructureForParent()
Метод получения подразделов для раздела
GetStructureItem в файле Structure.class.php, метод Structure::GetStructureItem()
* Метод получения данных об элементе структуры
GetStructurePath в файле Structure.class.php, метод Structure::GetStructurePath()
Метод определения полного пути к странице
GetStructureProperty в файле Structure.class.php, метод Structure::GetStructureProperty()
Метод возвращает заполненные св-ва узлов структуры
GetSystemOfPay в файле shop.class.php, метод shop::GetSystemOfPay()
Метод, осуществляющий извлечение платёжной системы
GetTableNames в файле ExecSqlQuery.class.php, метод ExecSqlQuery::GetTableNames()
Метод для получения списка таблиц, разделенных запятыми.
GetTax в файле shop.class.php, метод shop::GetTax()
Метод, осуществляющий извлечение налога
GetTemplate в файле Templates.class.php, метод templates::GetTemplate()
Метод получения информации о макете
GetTemplate в файле Kernel.class.php, метод kernel::GetTemplate()
Метод получения текущего макета
GetTheme в файле Forums.class.php, метод Forums::GetTheme()
Метод возвращает информацию о теме форума
GetTyingProducts в файле shop.class.php, метод shop::GetTyingProducts()
Метод получения информации о сопутствующем товаре
GetTyingProductsForItem в файле shop.class.php, метод shop::GetTyingProductsForItem()
Метод получения ID сопутствующих товаров для заданного товара
GetTypeOfDelivery в файле shop.class.php, метод shop::GetTypeOfDelivery()
Метод, осуществляющий извлечение типа доставки
GetTypeOfDeliveryForOrder в файле shop.class.php, метод shop::GetTypeOfDeliveryForOrder()
Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.
GetUseCJ в файле Counter.class.php, метод counter::GetUseCJ()
Метод получения данных о использовании кукисов и Java
GetUserDir в файле Site_users.class.php, метод SiteUsers::GetUserDir()
Метод возвращает абсолютный путь к директории пользователя сайта
GetUserGroups в файле Site_users.class.php, метод SiteUsers::GetUserGroups()
УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.
GetUsersDir в файле Site_users.class.php, метод SiteUsers::GetUsersDir()
Метод возвращает абсолютный путь к директории для хранения файлов пользователей
GetValueExtraProperty в файле Site_users.class.php, метод SiteUsers::GetValueExtraProperty()
Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра
GetValueItemProperty в файле shop.class.php, метод shop::GetValueItemProperty()
Метод получения значения дополнительного свойства для товара
GetXml4StructurePropertys в файле Structure.class.php, метод Structure::GetXml4StructurePropertys()
Метод получения XML для свойств структуры
GetXmlForInformatioItem в файле InformationSystems.class.php, метод InformationSystem::GetXmlForInformatioItem()
Метод формирования XML для отображения информационного элемента
GetXmlForItemsOrder в файле shop.class.php, метод shop::GetXmlForItemsOrder()
Метод формирования xml для товаров в заказе
GetXmlForOrder в файле shop.class.php, метод shop::GetXmlForOrder()
Метод формирования xml о заказе по идентификатору заказа
GetXmlProducer | в файле shop.class.php, метод shop::GetXmlProducer()
GetXsl в файле Xsl.class.php, метод xsl::GetXsl()
Метод получения информаци об XSL-шаблоне по его имени
get_count_row в файле Mysql.class.php, метод MySQL::get_count_row()
Метод возвращает количество строк в последнем запросе
get_CSS в файле Kernel.class.php, метод kernel::get_CSS()
Метод получения CSS стиля для страницы
get_current_page в файле Kernel.class.php, метод kernel::get_current_page()
Метод получения идентификатора текущего узла структуры
get_current_page_path в файле Kernel.class.php, метод kernel::get_current_page_path()
Метод получения пути текущей страницы
get_description в файле Kernel.class.php, метод kernel::get_description()
Метод получения описания страницы
get_documents_dir в файле Documents.class.php, метод documents::get_documents_dir()
Метод формирования дерева разделов
get_file_perms в файле File.class.php, метод File::get_file_perms()
Метод получения строки прав доступа к файлу
get_information_groups_path в файле InformationSystems.class.php, метод InformationSystem::get_information_groups_path()
Метод формирования пути по дереву информационных групп.
get_keywords в файле Kernel.class.php, метод kernel::get_keywords()
Метод получения ключевых слов страницы
get_mas_information_groups_for_xml в файле InformationSystems.class.php, метод InformationSystem::get_mas_information_groups_for_xml()
Метод возвращает XML для информационных групп
get_page_id в файле Kernel.class.php, метод kernel::get_page_id()
Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя
get_path в файле Documents.class.php, метод documents::get_path()
Метод формирования строки ссылок с родительскими разделами
get_polls_name в файле Polls.class.php, метод polls::get_polls_name()
Метод получения названия опроса
get_section_path в файле Xsl.class.php, метод xsl::get_section_path()
Функция возвращает путь по дереву разделов
get_title в файле Kernel.class.php, метод kernel::get_title()
Метод получения заголовка страницы
GISTOGRAMM_LIMIT | в файле Counter.php, константа GISTOGRAMM_LIMIT
GoSearch в файле Search.class.php, метод Search::GoSearch()
Метод выводит результаты поиска запроса $query с помощью XSL-шаблона $xslname в соответствии с дополнительными параметрами
graphic | в файле Graphic.class.php, класс graphic
graphic_diagramma в файле Graphic.class.php, метод graphic::graphic_diagramma()
Метод вывода круговой диаграммы
graphic_gistogramma в файле Graphic.class.php, метод graphic::graphic_gistogramma()
Метод вывода гистограммы
top
h
$hidden | в файле shop.class.php, переменная shop::$hidden
$html | в файле show_table.class.php, переменная show_table::$html
top
i
$image | в файле show_table.class.php, переменная show_table::$image
$image | в файле show_table.class.php, переменная table_fields::$image
$image_is_link | в файле show_table.class.php, переменная table_fields::$image_is_link
$image_link | в файле show_table.class.php, переменная table_fields::$image_link
$IndexForArray | в файле show_table.class.php, переменная table_fields::$IndexForArray
$ItemMass в файле InformationSystems.class.php, переменная InformationSystem::$ItemMass
Кэш с данными об элементах
$item_catalog_price в файле shop.class.php, переменная shop::$item_catalog_price
Цена товара магазина
Image в файле Image.class.php, класс Image
Ядро, класс для работы с графическими изображениями
imagebar в файле Graphic.class.php, метод graphic::imagebar()
Метод вывода гистограммы
implode_array в файле Kernel.class.php, метод kernel::implode_array()
Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно
IncCountMessage в файле Forums.class.php, метод Forums::IncCountMessage()
Метод наращивания счётчика количества сообщений для пользователя
IncPollReply в файле Polls.class.php, метод polls::IncPollReply()
Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote
IndexationForums в файле Forums.class.php, метод Forums::IndexationForums()
Метод индексации форумов
IndexationForumsMessages в файле Forums.class.php, метод Forums::IndexationForumsMessages()
Метод индексации сообщений тем форумов
IndexationShopItems | в файле shop.class.php, метод shop::IndexationShopItems()
IndexationStructure в файле Structure.class.php, метод Structure::IndexationStructure()
Метод индексации элементов структуры
InformationSystem в файле InformationSystems.class.php, класс InformationSystem
Класс модуля "Информационные системы"
InformationSystemItemAccess в файле InformationSystems.class.php, метод InformationSystem::InformationSystemItemAccess()
Метод определения доступности информационного элемента для пользователя
InformationSystems.class.php | procedural page InformationSystems.class.php
InformationSystems.php | procedural page InformationSystems.php
InitConstants в файле Kernel.class.php, метод kernel::InitConstants()
Метод инициализации констант сайта в соответствии с константой CURRENT_SITE
Insert в файле Cache.class.php, метод Cache::Insert()
Вставка значения в кэш
InsertBanners в файле Advertisement.class.php, метод Advertisement::InsertBanners()
Метод добавления баннера в группу/редактирования приоритета показа баннера в группе
InsertBannersGroup в файле Advertisement.class.php, метод Advertisement::InsertBannersGroup()
Метод добавления/редактирования информации о группе баннеров
InsertCity в файле shop.class.php, метод shop::InsertCity()
Метод, осуществляющий вставку города
InsertCityArea в файле shop.class.php, метод shop::InsertCityArea()
Метод добавления/редактирования информации о районе города
InsertComment в файле shop.class.php, метод shop::InsertComment()
Метод добавления/обновления информации об отзыве на товар
InsertCompany в файле shop.class.php, метод shop::InsertCompany()
Метод для вставки/обновления организации
InsertCondOfDelivery в файле shop.class.php, метод shop::InsertCondOfDelivery()
Метод, осуществляющий вставку условия доставки
InsertConference в файле Forums.class.php, метод Forums::InsertConference()
Метод, осуществляющий вставку информации о конференции.
InsertCountry в файле shop.class.php, метод shop::InsertCountry()
Метод, осуществляющий вставку области
InsertCoupon в файле shop.class.php, метод shop::InsertCoupon()
Метод для вставки/обновления информации о купоне
InsertCurrency в файле shop.class.php, метод shop::InsertCurrency()
Метод,осуществляющий вставку информации о валюте
InsertDiscount в файле shop.class.php, метод shop::InsertDiscount()
Метод, осуществляющий вставку информации о скидке
InsertExtraProperty в файле Site_users.class.php, метод SiteUsers::InsertExtraProperty()
Метод добавления/редактирования дополнительного параметра
InsertFascicle в файле Maillist.class.php, метод Maillist::InsertFascicle()
Метод добавления/редактирования выпуска рассылки
InsertForms в файле Forms.class.php, метод Forms::InsertForms()
Метод вставки/обновления информации о форме
InsertFormsFields в файле Forms.class.php, метод Forms::InsertFormsFields()
Метод вставки/обновления информации о поле формы
InsertFormsFill в файле Forms.class.php, метод Forms::InsertFormsFill()
Метод вставки/обновления информации о заполнении формы
InsertFormsFillValues в файле Forms.class.php, метод Forms::InsertFormsFillValues()
Метод вставки/обновления значений заполненной формы
InsertForum в файле Forums.class.php, метод Forums::InsertForum()
Метод добавления/редактирования форума.
InsertForumsGroup в файле Forums.class.php, метод Forums::InsertForumsGroup()
Метод добавления/редактирования группы форумов
InsertGroup в файле shop.class.php, метод shop::InsertGroup()
Метод, осуществляющий вставку группы, к которой могут относиться товары
InsertGroupPolls в файле Polls.class.php, метод polls::InsertGroupPolls()
Метод вставки информации о группе опросов
InsertInformationGroups в файле InformationSystems.class.php, метод InformationSystem::InsertInformationGroups()
Метод вставки/обновления данных об информационной группе
InsertInformationItems в файле InformationSystems.class.php, метод InformationSystem::InsertInformationItems()
Метод вставки/обновления данных об информационном элементе
InsertInformationPropertys в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertys()
Метод вставки/обновления информации о свойстве информационной системы
InsertInformationPropertysGroups в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertysGroups()
Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы
InsertInformationPropertysGroupsValue в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertysGroupsValue()
Метод вставки/обновления значения свойства информационной группы
InsertInformationPropertysItems в файле InformationSystems.class.php, метод InformationSystem::InsertInformationPropertysItems()
Метод вставки/обновления значения свойства информационной
InsertInfotmationSystem в файле InformationSystems.class.php, метод InformationSystem::InsertInfotmationSystem()
Метод вставки/обновления данных об информационной системе
InsertIp в файле ip.class.php, метод ip::InsertIp()
Метод вставки/обновления информации об IP-адресе
InsertItem в файле shop.class.php, метод shop::InsertItem()
Метод, осуществляющий вставку информации о товаре
InsertItemDiscount в файле shop.class.php, метод shop::InsertItemDiscount()
Метод вставки скидки для определенного товара
InsertLib в файле lib.class.php, метод lib::InsertLib()
Метод для вставки информации о типовой динамической странице
InsertLibDir в файле lib.class.php, метод lib::InsertLibDir()
Метод для вставки/обновления информации о разделе типовых дин. страниц
InsertLibProperty в файле lib.class.php, метод lib::InsertLibProperty()
Метод вставки информации о параметре типовой динамической страницы
InsertLibPropertyListItem в файле lib.class.php, метод lib::InsertLibPropertyListItem()
Метод для вставки/обновления элемента списка для параметра типовой дин. страницы
InsertLocation в файле shop.class.php, метод shop::InsertLocation()
Метод, осуществляющий вставку области
InsertMaillist в файле Maillist.class.php, метод Maillist::InsertMaillist()
Метод добавления/редактирования информации о рассылке
InsertMesure в файле shop.class.php, метод shop::InsertMesure()
Метод, осуществляющий вставку информации о единице измерения
InsertOrder в файле shop.class.php, метод shop::InsertOrder()
Метод, осуществляющий вставку заказа
InsertOrderDiscount в файле shop.class.php, метод shop::InsertOrderDiscount()
Метод для вставки/обновления информации о скидке для заказов
InsertOrderItems в файле shop.class.php, метод shop::InsertOrderItems()
Метод, осуществляющий вставку товара в заказ
InsertOrderStatus в файле shop.class.php, метод shop::InsertOrderStatus()
Метод, осуществляющий вставку статуса заказа
InsertOrderWithoutSystemOfPay в файле shop.class.php, метод shop::InsertOrderWithoutSystemOfPay()
Метод вставки заказа, если платежная система не выбрана
InsertPrice в файле shop.class.php, метод shop::InsertPrice()
Метод, осуществляющий вставку типа цены
InsertPricesToItem в файле shop.class.php, метод shop::InsertPricesToItem()
Метод вставки связи товара и цены из справочника цен
InsertProducer в файле shop.class.php, метод shop::InsertProducer()
Метод, осуществляющий вставку производителя
InsertPropertiesItem в файле shop.class.php, метод shop::InsertPropertiesItem()
Метод вставки информации о дополнительных свойствах товра
InsertPropretyOfItems в файле shop.class.php, метод shop::InsertPropretyOfItems()
Метод, осуществляющий вставку свойства товара
InsertRecord в файле Counter.class.php, метод counter::InsertRecord()
Метод добавления записи в основную таблицу статистики
InsertSearchInquiry в файле Search.class.php, метод Search::InsertSearchInquiry()
Метод для вставки запроса в журнал поисковых запросов
InsertSeller в файле shop.class.php, метод shop::InsertSeller()
Метод, осуществляющий вставку или обновление продавца.
InsertSession в файле Counter.class.php, метод counter::InsertSession()
Метод для вставки записи о сессии
InsertShop в файле shop.class.php, метод shop::InsertShop()
Метод, осуществляющий вставку информации о магазине
InsertSiteUser в файле Site_users.class.php, метод SiteUsers::InsertSiteUser()
Метод добавления нового пользователя в систему
InsertStructurePropertys в файле Structure.class.php, метод Structure::InsertStructurePropertys()
Метод вставки и редактирования дополнительного свойства для структуры
InsertStructurePropertysValue в файле Structure.class.php, метод Structure::InsertStructurePropertysValue()
Метод вставки и редактирования значения дополнительного свойства в таблице связи
InsertSystemOfPay в файле shop.class.php, метод shop::InsertSystemOfPay()
Метод, осуществляющий вставку платёжной системы
InsertTax в файле shop.class.php, метод shop::InsertTax()
Метод, осуществляющий вставку налога
InsertTheme в файле Forums.class.php, метод Forums::InsertTheme()
Метод для вставки информации о теме
InsertToCart в файле shop.class.php, метод shop::InsertToCart()
Метод добавления информации о товаре в таблицу корзины
InsertTyingProducts в файле shop.class.php, метод shop::InsertTyingProducts()
Метод добавления информации о сопутствующем товаре
InsertTypeOfDelivery в файле shop.class.php, метод shop::InsertTypeOfDelivery()
Метод, осуществляющий вставку типа доставки
InsertUserDeniedAccess в файле UserAccess.class.php, метод UserAccessDenied::InsertUserDeniedAccess()
Метод записи в базу информации о неудачной попытке входа в BackOffice
InsertUserGroup в файле Site_users.class.php, метод SiteUsers::InsertUserGroup()
Метод вставки и обновления информации о группе пользователей
InsertUsers в файле Site_users.class.php, метод SiteUsers::InsertUsers()
Метод добавления пользователя в группу
InsertUsers в файле Maillist.class.php, метод Maillist::InsertUsers()
Метод добавления/редактирования информации о подписчике
InsertUsersGroup в файле Forums.class.php, метод Forums::InsertUsersGroup()
Метод добавления/редактирования группы пользователей для определения доступа к форуму
InsertUsersGroup в файле Maillist.class.php, метод Maillist::InsertUsersGroup()
Метод, открывающий доступ группе пользователей сайта к рассылке
InsertVote в файле Polls.class.php, метод polls::InsertVote()
Метод вставки ответа на опрос
insert_alias в файле Site.class.php, метод site::insert_alias()
Метод вставки/обновления информации об алиасе (домене) сайта
insert_comment в файле InformationSystems.class.php, метод InformationSystem::insert_comment()
Метод вставки/обновления комментария для элемента информационной системы
insert_comment_without_striptags в файле InformationSystems.class.php, метод InformationSystem::insert_comment_without_striptags()
Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах
insert_data_templates в файле Templates.class.php, метод templates::insert_data_templates()
Методы добавления (редактирования) шаблонов страниц
insert_documents в файле Documents.class.php, метод documents::insert_documents()
Метод вставки и обновления новых документов
insert_documents_dir в файле Documents.class.php, метод documents::insert_documents_dir()
Метод вставки и обновления разделов документов
insert_lists в файле Lists.class.php, метод lists::insert_lists()
Метод вставки/обновления данных о списке
insert_lists_items в файле Lists.class.php, метод lists::insert_lists_items()
Метод вставки/обновления данных об элементе списка
insert_module в файле Modules.class.php, метод modules::insert_module()
Метод вставки/обновления информации о модуле
insert_poll в файле Polls.class.php, метод polls::insert_poll()
Метод осуществляет вставку и обновление опросов
insert_poll_reply в файле Polls.class.php, метод polls::insert_poll_reply()
Метод, осуществляет вставку и обновление вариантов ответов
insert_site в файле Site.class.php, метод site::insert_site()
Метод вставки/обновления информации о сайте
insert_status в файле Documents.class.php, метод documents::insert_status()
Метод добавления(редактирования) статусов документов
insert_template в файле Templates.class.php, метод templates::insert_template()
Метод добавления макета
insert_user в файле UserAccess.class.php, метод user_access::insert_user()
Метод вставки и обновления информации о пользователе
insert_user_type в файле UserAccess.class.php, метод user_access::insert_user_type()
Метод вставки и обновления информации о типе пользователей
insert_version в файле Documents.class.php, метод documents::insert_version()
Метод добавления/редактирования записей о версиях
insert_xsl в файле Xsl.class.php, метод xsl::insert_xsl()
Метод вставки/обновления XSL
insert_xsl_dir в файле Xsl.class.php, метод xsl::insert_xsl_dir()
Метод вставки и обновления XSL рубрик
ip в файле ip.class.php, класс ip
Класс модуля "IP-адреса"
IpIsNew в файле Counter.class.php, метод counter::IpIsNew()
Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта
ip.class.php | procedural page ip.class.php
ip.php | procedural page ip.php
IsOrderOfThisSiteUser в файле shop.class.php, метод shop::IsOrderOfThisSiteUser()
Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта
IsSearchSystem в файле Counter.class.php, метод counter::IsSearchSystem()
Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:
IssetAccessForInformationSystemGroup в файле InformationSystems.class.php, метод InformationSystem::IssetAccessForInformationSystemGroup()
Метод проверяет возможность доступа пользователя указанной группы к группе информационной системы
IssetGroup в файле InformationSystems.class.php, метод InformationSystem::IssetGroup()
Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе
IssetGroupItemInsertUpdate в файле InformationSystems.class.php, метод InformationSystem::IssetGroupItemInsertUpdate()
Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента
IssetItem в файле InformationSystems.class.php, метод InformationSystem::IssetItem()
Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы
IssetItemGroupInsertUpdate в файле InformationSystems.class.php, метод InformationSystem::IssetItemGroupInsertUpdate()
Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы
IssetModule в файле Modules.class.php, метод modules::IssetModule()
Метод проверки наличия активного модуля
IssetPath в файле Structure.class.php, метод Structure::IssetPath()
Метод определения наличия пути
isset_id в файле Counter.class.php, метод counter::isset_id()
Метод проверки наличия id сайта
Image.class.php | procedural page Image.class.php
top
j
JPG_QUALITY | в файле Kernel.php, константа JPG_QUALITY
JsHttpRequest.php | procedural page JsHttpRequest.php
top
k
$key_id | в файле show_table.class.php, переменная show_table::$key_id
kernel в файле Kernel.class.php, класс kernel
Класс ядра системы управления сайтом HostCMS
Kernel.class.php | procedural page Kernel.class.php
Kernel.php | procedural page Kernel.php
top
l
$level в файле Structure.class.php, переменная Structure::$level
Максимальный уровень структуры
lib | в файле lib.class.php, класс lib
lib.class.php | procedural page lib.class.php
lib.php | procedural page lib.php
link_len в файле Url.class.php, метод url::link_len()
Метод сокращения длины строки
lists в файле Lists.class.php, класс lists
Класс модуля "Списки"
Lists.class.php | procedural page Lists.class.php
Lists.php | procedural page Lists.php
LoadLibPropertiesValue в файле lib.class.php, метод lib::LoadLibPropertiesValue()
Метод загружает значения параметров типовой дин. страницы для структуры
LoadModules в файле Kernel.class.php, метод kernel::LoadModules()
Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS
LoadModulesLngFile в файле Kernel.class.php, метод kernel::LoadModulesLngFile()
Метод загрузки языкового файла для модуля
load_files в файле FileManager.class.php, метод FileManager::load_files()
Метод загрузки файлов
log_access в файле EventsJournal.class.php, метод EventsJournal::log_access()
Метод протоколирования получения доступа к системе управления
top
m
$mas | в файле show_table.class.php, переменная show_table::$mas
$MasGroup | в файле shop.class.php, переменная shop::$MasGroup
$MasGroup в файле InformationSystems.class.php, переменная InformationSystem::$MasGroup
Массив групп
$mas_documents_dir в файле Documents.class.php, переменная documents::$mas_documents_dir
Массив разделов документов
$mas_image | в файле show_table.class.php, переменная table_fields::$mas_image
$mas_lib_dir | в файле lib.class.php, переменная lib::$mas_lib_dir
$mas_xsl_dir | в файле Xsl.class.php, переменная xsl::$mas_xsl_dir
$menu_id в файле Structure.class.php, переменная Structure::$menu_id
Идентификатор раздела меню
Mysqldump.class.php | procedural page Mysqldump.class.php
Message.fns.php | procedural page Message.fns.php
Mysql.class.php | procedural page Mysql.class.php
Maillist в файле Maillist.class.php, класс Maillist
Класс модуля "Почтовые рассылки"
Maillist.class.php | procedural page Maillist.class.php
Maillist.php | procedural page Maillist.php
MailReport в файле Counter.class.php, метод counter::MailReport()
Метод отправки письма с отчетом администратору сайта
MAIL_EVENTS_STATUS | в файле Kernel.php, константа MAIL_EVENTS_STATUS
memory_get_usage | в файле Kernel.php, функция memory_get_usage()
Menu.class.php | procedural page Menu.class.php
Menu.php | procedural page Menu.php
modules в файле Modules.class.php, класс modules
Класс модуля "Управление модулями"
Modules.class.php | procedural page Modules.class.php
Modules.php | procedural page Modules.php
MySQL в файле Mysql.class.php, класс MySQL
Ядро, класс для работы с MySQL
top
n
$new_session в файле Counter.class.php, переменная counter::$new_session
Флаг добавления новой сессии при обновлении данных счетчика
NodeIsParent в файле Structure.class.php, метод Structure::NodeIsParent()
Метод определения принадлежности узла структуры вышестоящему родителю
NoticeTheme в файле Forums.class.php, метод Forums::NoticeTheme()
Метод делающий тему объявлением или наоборот
top
o
ON_PAGE | в файле Kernel.php, константа ON_PAGE
OrderExtraProperty в файле Site_users.class.php, метод SiteUsers::OrderExtraProperty()
Метод обновления коэффициентов порядка сортировки
OrderForums в файле Forums.class.php, метод Forums::OrderForums()
Метод изменения порядка сортировки форумов в группе
OrderForumsGroup в файле Forums.class.php, метод Forums::OrderForumsGroup()
Метод изменения порядка сортировки групп форумов
OS_UNIX | в файле tar.class.php, константа OS_UNIX
top
p
$parent_id в файле Structure.class.php, переменная Structure::$parent_id
Идентификатор родительского узла элемента структуры
$PropertyGroupMass в файле InformationSystems.class.php, переменная InformationSystem::$PropertyGroupMass
Кэш с данными о дополнительных свойствах информационных групп
$PropertyMass в файле InformationSystems.class.php, переменная InformationSystem::$PropertyMass
Кэш с данными о свойствах инфоррмационных элементов
Password.class.php | procedural page Password.class.php
PageCompressionBegin в файле Compression.class.php, метод compression::PageCompressionBegin()
Метод начала приема из стандартного потока содержимого для компрессии
PageCompressionEnd в файле Compression.class.php, метод compression::PageCompressionEnd()
Метод выводит сжатые данные, размещаемые в потоке
PathCorrection в файле File.class.php, метод File::PathCorrection()
Метод удаляет потенциально опасных символы из пути или имени файла
PathCorrection в файле FileManager.class.php, метод FileManager::PathCorrection()
Метод удаляет потенциально опасных символы из пути или имени файла
phpversion в файле Kernel.class.php, метод kernel::phpversion()
Метод возвращает номер версии PHP
polls в файле Polls.class.php, класс polls
Класс модуля "Опросы"
Polls.class.php | procedural page Polls.class.php
Polls.php | procedural page Polls.php
POLLS_WIDTH | в файле Kernel.php, константа POLLS_WIDTH
PrintIndex | в файле Cache.class.php, метод Cache::PrintIndex()
PrivateOfficeXML в файле Site_users.class.php, метод SiteUsers::PrivateOfficeXML()
УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.
ProcessOrder в файле shop.class.php, метод shop::ProcessOrder()
Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты
ProcessTypographic в файле typograph.class.php, метод typograph::ProcessTypographic()
Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.
top
q
$query | в файле show_table.class.php, переменная show_table::$query
query в файле Mysql.class.php, метод MySQL::query()
Метод выполнения SQL-запроса
quote_smart в файле Security.fns.php, функция quote_smart()
Экранирует потенциально опасные символы для MySQL запросов
top
r
$record_on_page | в файле Modules.class.php, переменная modules::$record_on_page
$record_on_page в файле Documents.class.php, переменная documents::$record_on_page
Число записей, выводимых на странице в административной части
$record_on_page в файле RssWrite.class.php, переменная RssWrite::$record_on_page
Количество в потоке
$record_on_page | в файле Site.class.php, переменная site::$record_on_page
$record_on_page в файле Lists.class.php, переменная lists::$record_on_page
Количество выводимых элементов на страницу
$record_on_page | в файле Xsl.class.php, переменная xsl::$record_on_page
$record_on_page | в файле Templates.class.php, переменная templates::$record_on_page
$record_on_page в файле ip.class.php, переменная ip::$record_on_page
Число записей, отображаемых на странице
$result | в файле Mysql.class.php, переменная MySQL::$result
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RssRead.class.php | procedural page RssRead.class.php
RssWrite.class.php | procedural page RssWrite.class.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
random_shuffle в файле Kernel.class.php, метод kernel::random_shuffle()
Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.
ReadRSS в файле RssRead.class.php, метод RssRead::ReadRSS()
Метод чтения данных из RSS потока
RecursiveRemoveDir в файле File.class.php, метод File::RecursiveRemoveDir()
Метод удаляет директорию со всеми поддиректориями и файлами
RenewMaillist в файле Maillist.class.php, метод Maillist::RenewMaillist()
Метод обновления информации о подписке для конкретного подписчика
resizeToFile в файле Image.class.php, метод Image::resizeToFile()
Метод изменения размера изображения
RssRead в файле RssRead.class.php, класс RssRead
Ядро, класс для чтения RSS
RssWrite в файле RssWrite.class.php, класс RssWrite
Ядро, класс для генерации RSS
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
top
s
$section_path | в файле Xsl.class.php, переменная xsl::$section_path
$section_path | в файле lib.class.php, переменная lib::$section_path
$separator в файле Structure.class.php, переменная Structure::$separator
Разделитель для уровней
$size | в файле show_table.class.php, переменная table_fields::$size
$StructureMass в файле Structure.class.php, переменная Structure::$StructureMass
Массив с элементами структуры
$StructureParentMass в файле Structure.class.php, переменная Structure::$StructureParentMass
Массив родительских разделов
$structure_propertys_list в файле Structure.class.php, переменная Structure::$structure_propertys_list
Хранит результат запроса на выборку дополнительных свойств структуры
Security.fns.php | procedural page Security.fns.php
show_table.class.php | procedural page show_table.class.php
SaveLibPropertiesValue в файле lib.class.php, метод lib::SaveLibPropertiesValue()
Метод для сохранения настроек типовой динамической страницы для стурктуры в файл
Search | в файле Search.class.php, класс Search
SearchWords в файле Search.class.php, метод Search::SearchWords()
Поиск списка слов в индексе
Search.class.php | procedural page Search.class.php
Search.php | procedural page Search.php
select в файле Mysql.class.php, метод MySQL::select()
Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()
SelectAllItemsFromCartForUser в файле shop.class.php, метод shop::SelectAllItemsFromCartForUser()
Метод получения количества элементов и их общей цены для заданного пользователя
SelectAllItemsFromCookieCart в файле shop.class.php, метод shop::SelectAllItemsFromCookieCart()
Метод получения общего количества товаров, их общей стоимости и веса из корзины
(в случае, когда пользователь не задан и данные корзины хранятся в кукисах)
SelectBannersGroup в файле Advertisement.class.php, метод Advertisement::SelectBannersGroup()
Метод получения информации о конкретной группе баннеров или обо всех баннерах
SelectCityArea в файле shop.class.php, метод shop::SelectCityArea()
Метод получения информации о районе города (обо всех районах при $city_area_id=-1)
SelectFascicle в файле Maillist.class.php, метод Maillist::SelectFascicle()
Метод получения данных о выпуске рассылки
SelectForms в файле Forms.class.php, метод Forms::SelectForms()
Метод выбора данных о формах
SelectFormsFields в файле Forms.class.php, метод Forms::SelectFormsFields()
Метод выбора данных о поле формы
SelectForum в файле Forums.class.php, метод Forums::SelectForum()
Устаревший метод, возвращающий информацию о форуме
SelectForumsGroup в файле Forums.class.php, метод Forums::SelectForumsGroup()
Устарвший метод, возвращающий информацию о группе форумов
SelectInformationGroupPropertys в файле InformationSystems.class.php, метод InformationSystem::SelectInformationGroupPropertys()
Метод получения данных о свойствах группы информационной системы
SelectInformationGroups в файле InformationSystems.class.php, метод InformationSystem::SelectInformationGroups()
Метод получения информации об информационных группах конкретной информационной системы
SelectInformationSystem в файле InformationSystems.class.php, метод InformationSystem::SelectInformationSystem()
Метод получения информации об информационной системе
SelectIp в файле ip.class.php, метод ip::SelectIp()
Метод получения информации об IP-адресах
SelectListInformationGroupPropertys в файле InformationSystems.class.php, метод InformationSystem::SelectListInformationGroupPropertys()
Метод получения списка дополнительных свойств информационноq группы данной инфосистемы
SelectListsItems в файле Lists.class.php, метод lists::SelectListsItems()
Метод получения данных об элементах списка
SelectMaillist в файле Maillist.class.php, метод Maillist::SelectMaillist()
Метод получения данных о рассылке
SelectMessage в файле Forums.class.php, метод Forums::SelectMessage()
Метод возвращающий информацию о сообщении
SelectPollReply4Poll в файле Polls.class.php, метод polls::SelectPollReply4Poll()
Получение списка вариантов ответов на опрос
SelectPrice в файле shop.class.php, метод shop::SelectPrice()
Метод определения цены для заданной группы пользователей
SelectSites в файле Site.class.php, метод site::SelectSites()
Метод выбора всех сайтов, поддерживаемых системой управления
SelectStructurePropertys в файле Structure.class.php, метод Structure::SelectStructurePropertys()
Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)
SelectTheme в файле Forums.class.php, метод Forums::SelectTheme()
Устаревший метод, возвращающий информацию о теме
SelectUser в файле Maillist.class.php, метод Maillist::SelectUser()
Метод получения информации о состоянии подписки подписчика на рассылку
SelectUserDeniedAccess в файле UserAccess.class.php, метод UserAccessDenied::SelectUserDeniedAccess()
Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса
SelectUserType в файле Site_users.class.php, метод SiteUsers::SelectUserType()
Метод возвращает параметры группы пользователя
select_alias в файле Site.class.php, метод site::select_alias()
Метод получения информации об алиасе (домене) сайта
select_comments в файле InformationSystems.class.php, метод InformationSystem::select_comments()
Метод получения комментариев к информационному элементу
select_data_templates в файле Templates.class.php, метод templates::select_data_templates()
Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)
select_documents в файле Documents.class.php, метод documents::select_documents()
Метод получения информации о документе или обо всех документах
select_documents_dir в файле Documents.class.php, метод documents::select_documents_dir()
Метод выбора раздела документов
select_information_items в файле InformationSystems.class.php, метод InformationSystem::select_information_items()
Метод получения данных об информационном элементе
select_information_propertys в файле InformationSystems.class.php, метод InformationSystem::select_information_propertys()
Метод получения данных о свойствах информационной системы
select_lists_items в файле Lists.class.php, метод lists::select_lists_items()
Метод получения данных об элементе списка
select_modules в файле Modules.class.php, метод modules::select_modules()
Метод получения информации о модуле
select_poll в файле Polls.class.php, метод polls::select_poll()
Метод осуществляет выборку опросов
select_poll_reply в файле Polls.class.php, метод polls::select_poll_reply()
Метод выбора вариантов ответов
select_site в файле Site.class.php, метод site::select_site()
Метод получения данных о сайте
select_status в файле Documents.class.php, метод documents::select_status()
Метод получения информации о статусе документа
select_user в файле UserAccess.class.php, метод user_access::select_user()
Метод получения информации о пользователе
select_user_access в файле UserAccess.class.php, метод user_access::select_user_access()
Метод получения нформации о типах доступа пользователей
select_user_type в файле UserAccess.class.php, метод user_access::select_user_type()
Метод выбора типа пользователей
select_version в файле Documents.class.php, метод documents::select_version()
Метод выборки информации о версиях
select_xsl в файле Xsl.class.php, метод xsl::select_xsl()
Метод получения данных о XSL-шаблонах
select_xsl_dir в файле Xsl.class.php, метод xsl::select_xsl_dir()
Метод получения информации о XSL-разделах
SendFascicle в файле Maillist.class.php, метод Maillist::SendFascicle()
Метод отправки выпуска всем подписчикам рассылки
SendMailAboutOrder в файле shop.class.php, метод shop::SendMailAboutOrder()
Метод отправки писем о поступившем заказе пользователю и администратору
SendMailWithFile в файле Kernel.class.php, метод kernel::SendMailWithFile()
Метод отправки электронного письма с прикрепленным файлом
SendNewPassword в файле Site_users.class.php, метод SiteUsers::SendNewPassword()
Метод отправки нового пароля на почтовый ящик пользователю
SendRegistInf в файле Site_users.class.php, метод SiteUsers::SendRegistInf()
Метод отправки пользователю регистрационной информации
session_start в файле Admin.class.php, метод Admin::session_start()
Метод старта сессии для раздела администрирования
SetActionWidth в файле show_table.class.php, метод show_table::SetActionWidth()
Изменяет ширину поля Действие
SetButton в файле show_table.class.php, метод show_table::SetButton()
Изменяет флаг вывода кнопки
SetButtonName в файле show_table.class.php, метод show_table::SetButtonName()
Устанавливает наименование кнопки
SetButtonValue в файле show_table.class.php, метод show_table::SetButtonValue()
Изменяет value кнопки
SetConfirmation в файле Site_users.class.php, метод SiteUsers::SetConfirmation()
Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)
SetConfirmationID в файле Site_users.class.php, метод SiteUsers::SetConfirmationID()
Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки
SetCopyShow в файле show_table.class.php, метод show_table::SetCopyShow()
Изменяет флаг показа кнопки для копирования
SetCurrentSite в файле Admin.class.php, метод Admin::SetCurrentSite()
Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта
SetCurrentSiteUser в файле Site_users.class.php, метод SiteUsers::SetCurrentSiteUser()
Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток
SetDefaultGroup в файле Site_users.class.php, метод SiteUsers::SetDefaultGroup()
Метод установления группы с указанным идентификатором по умолчанию
SetDeleteConfirm в файле show_table.class.php, метод show_table::SetDeleteConfirm()
Изменяет сообщение, выводимое при удалении
SetDeleteShow в файле show_table.class.php, метод show_table::SetDeleteShow()
Изменяет флаг показа кнопки удалить
SetEditShow в файле show_table.class.php, метод show_table::SetEditShow()
Изменяет флаг показа кнопки редактировать
SetExpires в файле Kernel.class.php, метод kernel::SetExpires()
Метод установления времени истечения актуальности страницы
SetFieldActionShow в файле show_table.class.php, метод show_table::SetFieldActionShow()
Изменяет флаг вывода поля с действиями
SetFieldCopy в файле show_table.class.php, метод show_table::SetFieldCopy()
Изменяет поле для копирования
SetFieldDelete в файле show_table.class.php, метод show_table::SetFieldDelete()
Изменяет поле для удаления
SetFieldEdit в файле show_table.class.php, метод show_table::SetFieldEdit()
Изменяет поле для редактирования
SetFormAction в файле show_table.class.php, метод show_table::SetFormAction()
Изменяет action формы
SetHtml в файле show_table.class.php, метод show_table::SetHtml()
Устанавливает значение свойству html
SetImage в файле show_table.class.php, метод show_table::SetImage()
Изменяет значение свойства - путь к картинке
SetKeyId в файле show_table.class.php, метод show_table::SetKeyId()
Изменяет ключевое поле
SetLastModified в файле Kernel.class.php, метод kernel::SetLastModified()
Метод установления времени последнего изменения страницы
SetMas в файле show_table.class.php, метод show_table::SetMas()
Изменяет массив экземпляров класса table_fields
SetModerator в файле Forums.class.php, метод Forums::SetModerator()
Метод установления/снятия прав модератора текущего форума для группы пользователей
SetQuery в файле show_table.class.php, метод show_table::SetQuery()
Изменяет запрос для выборки данных
SetTableWidth в файле show_table.class.php, метод show_table::SetTableWidth()
Изменяет ширину таблицы
SetTemplate в файле Kernel.class.php, метод kernel::SetTemplate()
Метод установления текущего макета
SetValueExtraProperty в файле Site_users.class.php, метод SiteUsers::SetValueExtraProperty()
Метод установки значения дополнительного параметра пользователя
set_CSS в файле Kernel.class.php, метод kernel::set_CSS()
Метод изменения адреса файла CSS-стиля для страницы
set_current_page в файле Kernel.class.php, метод kernel::set_current_page()
Метод изменения адреса страницы
set_current_page_data_template в файле Kernel.class.php, метод kernel::set_current_page_data_template()
Метод изменения шаблона страницы
set_description в файле Kernel.class.php, метод kernel::set_description()
Метод изменения описания страницы
set_keywords в файле Kernel.class.php, метод kernel::set_keywords()
Метод изменения ключевых слов страницы
set_title в файле Kernel.class.php, метод kernel::set_title()
Метод изменения заголовока страницы
shop в файле shop.class.php, класс shop
Класс модуля "Интернет-магазин"
shop.class.php | procedural page shop.class.php
shop.php | procedural page shop.php
ShowAddComment в файле InformationSystems.class.php, метод InformationSystem::ShowAddComment()
Метод добавления комментария к элементу информационной системы
ShowAddEditTheme в файле Forums.class.php, метод Forums::ShowAddEditTheme()
Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
ShowAddress в файле shop.class.php, метод shop::ShowAddress()
Метод показа адреса для заказчика
ShowBanner в файле Advertisement.class.php, метод Advertisement::ShowBanner()
Метод показа баннера
ShowBannerGroup в файле Advertisement.class.php, метод Advertisement::ShowBannerGroup()
Метод показа баннера из указанной группы в соответствии с приоритетом
ShowBannerIsTrue в файле Advertisement.class.php, метод Advertisement::ShowBannerIsTrue()
Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили
ShowCart в файле shop.class.php, метод shop::ShowCart()
Метод показа содержимого корзины
ShowConference в файле Forums.class.php, метод Forums::ShowConference()
Метод отображения конференции
ShowConfirmation в файле shop.class.php, метод shop::ShowConfirmation()
Метод вывода сообщения о необходимости подтвердить аккаунт
ShowCounterCode в файле Counter.class.php, метод counter::ShowCounterCode()
Метод, осуществляющий вывод кода счетчика
ShowDocument в файле Documents.class.php, метод documents::ShowDocument()
Метод вызывает показ текущей версии переданной страницы
ShowEditMessage в файле Forums.class.php, метод Forums::ShowEditMessage()
Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
ShowEnter в файле shop.class.php, метод shop::ShowEnter()
Метод вывода формы для авторизации пользователя
ShowForm в файле Forms.class.php, метод Forms::ShowForm()
Метод отображения формы
ShowInformationSystem в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystem()
Метод отображения групп и элементов информационной системы
ShowInformationSystemItem в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemItem()
Метод отображения информацию об информационном элементе
ShowInformationSystemPageConfig в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemPageConfig()
Метод вызова настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы
ShowInformationSystemPageContent в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemPageContent()
Метод вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы
ShowInformationSystemRss в файле InformationSystems.class.php, метод InformationSystem::ShowInformationSystemRss()
Метод отображения RSS ленты
ShowItem в файле shop.class.php, метод shop::ShowItem()
Метод вывода информации об элементе
ShowItemsCompare в файле shop.class.php, метод shop::ShowItemsCompare()
Метод отображает сравнение выбранных товаров в магазине
ShowList в файле Lists.class.php, метод lists::ShowList()
Метод отображения элементов списка
ShowMessage в файле Forums.class.php, метод Forums::ShowMessage()
Метод отображения сообщений форума
ShowPoll в файле Polls.class.php, метод polls::ShowPoll()
Метод отображения опроса
ShowPollResult в файле Polls.class.php, метод polls::ShowPollResult()
Метод вывода результатов голосования
ShowPolls в файле Polls.class.php, метод polls::ShowPolls()
Метод отображения всех активных опросов
ShowPollsGroup в файле Polls.class.php, метод polls::ShowPollsGroup()
Метод отображения групп опросов
ShowPriceList | в файле shop.class.php, метод shop::ShowPriceList()
ShowProducer | в файле shop.class.php, метод shop::ShowProducer()
ShowProducersList в файле shop.class.php, метод shop::ShowProducersList()
Метод формирования xml для производителей *
ShowSaller в файле shop.class.php, метод shop::ShowSaller()
Метод для отображение информации о продавце в клиентской части
ShowShop в файле shop.class.php, метод shop::ShowShop()
Метод показа магазина
ShowSiteUserInfo в файле Forums.class.php, метод Forums::ShowSiteUserInfo()
Отображение данных о пользователе форума
ShowSiteUserRegistartion в файле Site_users.class.php, метод SiteUsers::ShowSiteUserRegistartion()
Метод вывода формы регистрации для пользователя сайта
ShowStructure в файле Structure.class.php, метод Structure::ShowStructure()
Метод для отображения структуры в клиентской части сайта
ShowSystemOfPay в файле shop.class.php, метод shop::ShowSystemOfPay()
Метод построения XML для платежных систем
ShowThemes в файле Forums.class.php, метод Forums::ShowThemes()
Метод отображения тем форума
ShowTypeOfDelivery в файле shop.class.php, метод shop::ShowTypeOfDelivery()
Метод выбора и показа типов доставки
ShowUserOffice в файле Site_users.class.php, метод SiteUsers::ShowUserOffice()
Метод отображения кабинета пользователя
ShowUserOrders в файле shop.class.php, метод shop::ShowUserOrders()
Метод отображает информацию о заказах пользователя
show_CSS в файле Kernel.class.php, метод kernel::show_CSS()
Метод вывода CSS стиля для страницы
show_current_page в файле Kernel.class.php, метод kernel::show_current_page()
Метод вывода установленной страницы
show_current_template в файле Kernel.class.php, метод kernel::show_current_template()
Метод вывода текущего макета
show_date в файле Counter.class.php, метод counter::show_date()
Метод для вывода формы с полями для дат (для вывода статистики)
show_description в файле Kernel.class.php, метод kernel::show_description()
Метод вывода описания страницы
show_error_message в файле Message.fns.php, функция show_error_message()
Функция выводит сообщение об ошибке
show_information_message в файле Message.fns.php, функция show_information_message()
Функция выводит информационное сообщение
show_keywords в файле Kernel.class.php, метод kernel::show_keywords()
Метод вывода ключевых слов страницы
show_link в файле Documents.class.php, метод documents::show_link()
Метод формирования строки ссылок на разделы и подразделы
show_link в файле Url.class.php, функция show_link()
Функция показа строки ссылок
show_link в файле Counter.class.php, метод counter::show_link()
Метод для вывода ссылок на различные пункты статистики
show_link_location | в файле shop.class.php, метод shop::show_link_location()
show_message в файле Message.fns.php, функция show_message()
Функция выводит сообщение об успешной операции
show_table | в файле show_table.class.php, класс show_table
show_title в файле Kernel.class.php, метод kernel::show_title()
Метод вывода заголовка страницы
show_ws в файле Wysiwyg.class.php, метод wysiwyg::show_ws()
Метод отображает визуальный редактор
site в файле Site.class.php, класс site
Класс модуля "Сайты"
SiteUsers в файле Site_users.class.php, класс SiteUsers
Класс модуля "Пользователи сайта"
Site.class.php | procedural page Site.class.php
Site.php | procedural page Site.php
Site_users.class.php | procedural page Site_users.class.php
Site_users.php | procedural page Site_users.php
Smile2HTML в файле Forums.class.php, метод Forums::Smile2HTML()
Метод замены смайликов на HTML
SortStructureMass в файле Structure.class.php, метод Structure::SortStructureMass()
Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией
STAT_ON_PAGE | в файле Counter.php, константа STAT_ON_PAGE
STAT_PERIOD_STORAGE | в файле Counter.php, константа STAT_PERIOD_STORAGE
strips в файле Security.fns.php, функция strips()
Вызывает stripslashes для всех элементов массива
strips в файле Kernel.class.php, метод kernel::strips()
Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag
structure в файле Structure.class.php, метод Structure::structure()
Конструктор
Structure | в файле Structure.class.php, класс Structure
Structure.class.php | procedural page Structure.class.php
Structure.php | procedural page Structure.php
str_for_xml в файле Security.fns.php, функция str_for_xml()
Функция преобразует строку для публикации в XML
SuccessVote в файле Polls.class.php, метод polls::SuccessVote()
УСТАРЕВШИЙ МЕТОД. Метод определения права пользователя участвовать в голосовании и изменения статистики голосования, если пользователь имеет право участвовать в нем
SUPERUSER_EMAIL | в файле Kernel.php, константа SUPERUSER_EMAIL
Support в файле Support.class.php, класс Support
Класс модуля "Техническая поддержка"
SupportMail в файле Support.class.php, метод Support::SupportMail()
Метод отправки письма с просьбой о технической поддержке
Support.class.php | procedural page Support.class.php
Support.php | procedural page Support.php
symbol2ASCII в файле Security.fns.php, функция symbol2ASCII()
Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t
top
t
$table_width | в файле show_table.class.php, переменная show_table::$table_width
$thousands_sep | в файле show_table.class.php, переменная table_fields::$thousands_sep
tar.class.php | procedural page tar.class.php
table_fields | в файле show_table.class.php, класс table_fields
table_fields в файле show_table.class.php, метод table_fields::table_fields()
Метод, установления свойств класса
templates в файле Templates.class.php, класс templates
Класс модуля "Шаблоны и макеты"
Templates.class.php | procedural page Templates.class.php
Templates.php | procedural page Templates.php
TMP_DIR | в файле Kernel.php, константа TMP_DIR
to_array в файле Security.fns.php, функция to_array()
Функция приведения аргумента к массиву
to_bool в файле Security.fns.php, функция to_bool()
Функция приведения аргумента к логическому типу
to_float в файле Security.fns.php, функция to_float()
Функция приведения аргумента к вещественному типу
to_int в файле Security.fns.php, функция to_int()
Функция приведения аргумента к целочисленному типу
to_str в файле Security.fns.php, функция to_str()
Функция приведения аргумента к строковому типу
translit_lower в файле Url.class.php, метод url::translit_lower()
Метод транслитерации с переводом символам исходного текста к прописным
typograph | в файле typograph.class.php, класс typograph
typograph.class.php | procedural page typograph.class.php
typograph.php | procedural page typograph.php
top
u
Url.class.php | procedural page Url.class.php
UserAccess.class.php | procedural page UserAccess.class.php
Unregistration в файле Site_users.class.php, метод SiteUsers::Unregistration()
Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя
UnsetCurrentSiteUser в файле Site_users.class.php, метод SiteUsers::UnsetCurrentSiteUser()
Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из кабинета пользователя
UpdateCart в файле shop.class.php, метод shop::UpdateCart()
Метод, осуществляющий обновление данных корзины
UpdateCity в файле shop.class.php, метод shop::UpdateCity()
УСТАРЕВШИЙ! Метод, осуществляющий обновление города
UpdateCondOfDelivery в файле shop.class.php, метод shop::UpdateCondOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки
UpdateCountry в файле shop.class.php, метод shop::UpdateCountry()
УСТАРЕВШИЙ! Метод, осуществляющий обновление страны
UpdateCurrency в файле shop.class.php, метод shop::UpdateCurrency()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()
UpdateDiscount в файле shop.class.php, метод shop::UpdateDiscount()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке
UpdateGroup в файле shop.class.php, метод shop::UpdateGroup()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары
UpdateGroupPolls в файле Polls.class.php, метод polls::UpdateGroupPolls()
Метод обновления информаци о группе опросов
UpdateImageForItem в файле shop.class.php, метод shop::UpdateImageForItem()
Метод обновления информации об изображении для товара
UpdateItem в файле shop.class.php, метод shop::UpdateItem()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о товаре
UpdateItemDiscount в файле shop.class.php, метод shop::UpdateItemDiscount()
УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара
UpdateItemPrice в файле shop.class.php, метод shop::UpdateItemPrice()
Метод обновления связи товара и цены
UpdateLibPropertyOrder в файле lib.class.php, метод lib::UpdateLibPropertyOrder()
Метод для обновления порядка сортировки параметра типовой дин. страницы
UpdateLocation в файле shop.class.php, метод shop::UpdateLocation()
УСТАРЕВШИЙ! Метод, осуществляющий обновление области
UpdateMesure в файле shop.class.php, метод shop::UpdateMesure()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения
UpdateOrder в файле shop.class.php, метод shop::UpdateOrder()
Метод, осуществляющий обновление заказа
UpdateOrderItems в файле shop.class.php, метод shop::UpdateOrderItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе
UpdateOrderPropretyOfItems в файле shop.class.php, метод shop::UpdateOrderPropretyOfItems()
Метод изменения порядка сортировки дополнительных свойств товара
UpdatePrice в файле shop.class.php, метод shop::UpdatePrice()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены
UpdatePricesToItem в файле shop.class.php, метод shop::UpdatePricesToItem()
Метод обновления дополнительной цены для элемента
UpdateProducer в файле shop.class.php, метод shop::UpdateProducer()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе
UpdatePropertiesItem в файле shop.class.php, метод shop::UpdatePropertiesItem()
Метод обновления информации о дополнительных свойствах товара
UpdatePropretyOfItems в файле shop.class.php, метод shop::UpdatePropretyOfItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара
UpdateShop в файле shop.class.php, метод shop::UpdateShop()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине
UpdateSiteUser в файле Site_users.class.php, метод SiteUsers::UpdateSiteUser()
Метод обновления анкетных данных пользователя
UpdateSubDir в файле Structure.class.php, метод Structure::UpdateSubDir()
Метод обновления идентификатора меню у подразделов определенного раздела
UpdateSystemOfPay в файле shop.class.php, метод shop::UpdateSystemOfPay()
УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы
UpdateTax в файле shop.class.php, метод shop::UpdateTax()
Метод, осуществляющий обновление налога
UpdateTyingProducts в файле shop.class.php, метод shop::UpdateTyingProducts()
УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах
UpdateTypeOfDelivery в файле shop.class.php, метод shop::UpdateTypeOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки
update_vote в файле Polls.class.php, метод polls::update_vote()
УСТАРЕВШИЙ Метод обработки результата голосования
UPLOADDIR | в файле Kernel.php, константа UPLOADDIR
url в файле Url.class.php, класс url
Ядро, класс для работы с адресной строкой
UserAccessDenied в файле UserAccess.class.php, класс UserAccessDenied
Ядро, класс проверки возможности доступа пользователей BackOffice
UserAccess.class.php | procedural page UserAccess.class.php
UserAccess.php | procedural page UserAccess.php
UserAuth в файле Admin.class.php, метод Admin::UserAuth()
Метод производит авторизацию пользователя в разделе администрирования
UserCanAddComment в файле InformationSystems.class.php, метод InformationSystem::UserCanAddComment()
Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY
UserIsModerator в файле Forums.class.php, метод Forums::UserIsModerator()
Метод для определения, является ли данный пользователь модератором
user_access в файле UserAccess.class.php, класс user_access
Класс модуля "Пользователи раздела администрирования"
USER_NONE | в файле Kernel.php, константа USER_NONE
top
v
ValidCaptcha в файле Captcha.class.php, метод Captcha::ValidCaptcha()
Метод проверки соответствия введенного пользователем текста хранимому в сессии
ValidUser в файле Site_users.class.php, метод SiteUsers::ValidUser()
Метод возвращает идентификатор пользователя по его логину и паролю
valid_email в файле Security.fns.php, функция valid_email()
Проверка правильности электронного адреса
VisibleTheme в файле Forums.class.php, метод Forums::VisibleTheme()
Метод, устанавливающий видимость/невидимость темы
vote_result в файле Polls.class.php, метод polls::vote_result()
Устаревший метод
top
w
Wysiwyg.class.php | procedural page Wysiwyg.class.php
win2uni в файле Graphic.class.php, метод graphic::win2uni()
Метод перекодировки из win в unicode
wysiwyg в файле Wysiwyg.class.php, класс wysiwyg
Ядро, класс визуального редактора
top
x
$xml | в файле ExternalXml.class.php, переменная ExternalXml::$xml
XMLparser.class.php | procedural page XMLparser.class.php
xsl в файле Xsl.class.php, класс xsl
Класс модуля "XSL-шаблоны"
Xsl.class.php | procedural page Xsl.class.php
Xsl.php | procedural page Xsl.php
top
y
YandexMarket в файле shop.class.php, метод shop::YandexMarket()
Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и возвращает XML данные.


HostCMS v 4

Добро пожаловать в описание API HostCMS v 4!
* API (интерфейс программирования приложений) — набор методов (функций), который программист может использовать для доступа к функциональности программы.


phpDocumentor Parser Errors and Warnings

Post-parsing
AdminMenu.class.php
admin_output.fns.php
Advertisement.class.php
Advertisement.php
Backup.class.php
Backup.php
Cache.class.php
Cache.php
Captcha.class.php
Compression.class.php
Compression.php
config.php
Constants.class.php
Constants.php
Counter.class.php
Counter.php
Date.class.php
Documents.class.php
Documents.php
Error.fns.php
EventsJournal.class.php
EventsJournal.php
ExecSqlQuery.class.php
ExecSqlQuery.php
ExternalXml.class.php
File.class.php
FileManager.class.php
FileManager.php
Forms.class.php
Forms.php
Forums.class.php
Forums.php
Graphic.class.php
Image.class.php
InformationSystems.class.php
InformationSystems.php
ip.class.php
ip.php
JsHttpRequest.php
Kernel.class.php
Kernel.php
lib.class.php
lib.php
Lists.class.php
Lists.php
Maillist.class.php
Maillist.php
Menu.class.php
Menu.php
Message.fns.php
Modules.class.php
Modules.php
Mysql.class.php
Mysqldump.class.php
Password.class.php
Polls.class.php
Polls.php
RssRead.class.php
RssWrite.class.php
ru.php
Search.class.php
Search.php
Security.fns.php
shop.class.php
shop.php
show_table.class.php
Site.class.php
Site.php
Site_users.class.php
Site_users.php
Structure.class.php
Structure.php
Support.class.php
Support.php
tar.class.php
Templates.class.php
Templates.php
typograph.class.php
typograph.php
Url.class.php
UserAccess.class.php
UserAccess.php
Wysiwyg.class.php
XMLparser.class.php
Xsl.class.php
Xsl.php

Post-parsing

Warnings:

Warning - duplicate function element "mod" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\Mysql.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "Square" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\Kernel.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "EqKeys" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\Kernel.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "SiteCreate" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\Kernel.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "ClearSite" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\Url.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "send_error_letter" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\Message.fns.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "LoadKeys" in file C:\Internet\home\hostcms4\htdocs\modules\Kernel\UserAccess.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.

Admin.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class Admin
Warning on line 496 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Admin.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

AdminMenu.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class AdminMenu
Warning on line 34 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\AdminMenu.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

admin_output.fns.php

Warnings:

Warning on line 315 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\admin_output.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Advertisement.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Advertisement
Warning on line 769 - File "C:\Internet\home\hostcms4\htdocs\modules\Advertisement\Advertisement.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Advertisement.php

Warnings:

Warning on line 23 - File "C:\Internet\home\hostcms4\htdocs\modules\Advertisement\Advertisement.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Backup.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Backup
Warning on line 30 - File "C:\Internet\home\hostcms4\htdocs\modules\Backup\Backup.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Backup.php

Warnings:

Warning on line 26 - File "C:\Internet\home\hostcms4\htdocs\modules\Backup\Backup.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Cache.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Cache
Warning on line 868 - File "C:\Internet\home\hostcms4\htdocs\modules\Cache\Cache.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Cache.php

Warnings:

Warning on line 30 - File "C:\Internet\home\hostcms4\htdocs\modules\Cache\Cache.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Captcha.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Captcha
Warning on line 392 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Captcha.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Compression.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class compression
Warning on line 110 - File "C:\Internet\home\hostcms4\htdocs\modules\Compression\Compression.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Compression.php

Warnings:

Warning on line 13 - File "C:\Internet\home\hostcms4\htdocs\modules\Compression\Compression.php" has no page-level DocBlock, use @package in the first DocBlock to create one

config.php

Warnings:

Warning on line 4 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 66 - File "C:\Internet\home\hostcms4\htdocs\modules\Forums\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 154 - File "C:\Internet\home\hostcms4\htdocs\modules\Counter\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 321 - File "C:\Internet\home\hostcms4\htdocs\modules\Cache\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Constants.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Constants
Warning on line 136 - File "C:\Internet\home\hostcms4\htdocs\modules\Constants\Constants.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Constants.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\Constants\Constants.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Counter.class.php

Warnings:

Warning on line 8 - no @package tag was used in a DocBlock for class counter
Warning on line 34 - Unknown tag "@return " used
Warning on line 1970 - File "C:\Internet\home\hostcms4\htdocs\modules\Counter\Counter.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Counter.php

Warnings:

Warning on line 54 - File "C:\Internet\home\hostcms4\htdocs\modules\Counter\Counter.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Date.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class DateClass
Warning on line 432 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Date.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Documents.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class documents
Warning on line 930 - File "C:\Internet\home\hostcms4\htdocs\modules\Documents\Documents.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Documents.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Documents\Documents.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Error.fns.php

Warnings:

Warning on line 145 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Error.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

EventsJournal.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class EventsJournalAdmin
Warning on line 11 - no @package tag was used in a DocBlock for class EventsJournal
Warning on line 147 - File "C:\Internet\home\hostcms4\htdocs\modules\EventsJournal\EventsJournal.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 283 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\EventsJournal.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

EventsJournal.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\EventsJournal\EventsJournal.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ExecSqlQuery.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class ExecSqlQuery
Warning on line 102 - File "C:\Internet\home\hostcms4\htdocs\modules\ExecSqlQuery\ExecSqlQuery.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ExecSqlQuery.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\ExecSqlQuery\ExecSqlQuery.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ExternalXml.class.php

Warnings:

Warning on line 6 - no @package tag was used in a DocBlock for class ExternalXml
Warning on line 99 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\ExternalXml.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

File.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class File
Warning on line 304 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\File.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

FileManager.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class FileManager
Warning on line 143 - File "C:\Internet\home\hostcms4\htdocs\modules\FileManager\FileManager.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

FileManager.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\FileManager\FileManager.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forms.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Forms
Warning on line 1329 - File "C:\Internet\home\hostcms4\htdocs\modules\Forms\Forms.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forms.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\Forms\Forms.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forums.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Forums
Warning on line 4130 - File "C:\Internet\home\hostcms4\htdocs\modules\Forums\Forums.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Errors:

Error on line 2793 - DocBlock has multiple @return tags, illegal. ignoring additional tag "@return boolean "

Forums.php

Warnings:

Warning on line 96 - File "C:\Internet\home\hostcms4\htdocs\modules\Forums\Forums.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Graphic.class.php

Warnings:

Warning on line 2 - no @package tag was used in a DocBlock for class graphic
Warning on line 575 - File "C:\Internet\home\hostcms4\htdocs\modules\Counter\Graphic.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Image.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Image
Warning on line 342 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Image.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

InformationSystems.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class information_blocks
Warning on line 20 - no @package tag was used in a DocBlock for class InformationSystem
Warning on line 7135 - File "C:\Internet\home\hostcms4\htdocs\modules\InformationSystems\InformationSystems.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

InformationSystems.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\InformationSystems\InformationSystems.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ip.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class ip
Warning on line 229 - File "C:\Internet\home\hostcms4\htdocs\modules\ip\ip.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ip.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\ip\ip.php" has no page-level DocBlock, use @package in the first DocBlock to create one

JsHttpRequest.php

Warnings:

Warning on line 22 - no @package tag was used in a DocBlock for class JsHttpRequest
Warning on line 359 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\ajax\JsHttpRequest.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Kernel.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class kernel
Warning on line 1722 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Kernel.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Kernel.php

Warnings:

Warning on line 478 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Kernel.php" has no page-level DocBlock, use @package in the first DocBlock to create one

lib.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class lib
Warning on line 970 - File "C:\Internet\home\hostcms4\htdocs\modules\lib\lib.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

lib.php

Warnings:

Warning on line 28 - File "C:\Internet\home\hostcms4\htdocs\modules\lib\lib.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Lists.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class lists
Warning on line 599 - File "C:\Internet\home\hostcms4\htdocs\modules\Lists\Lists.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Lists.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\Lists\Lists.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Maillist.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Maillist
Warning on line 647 - File "C:\Internet\home\hostcms4\htdocs\modules\Maillist\Maillist.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Maillist.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\Maillist\Maillist.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Menu.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class menu
Warning on line 205 - File "C:\Internet\home\hostcms4\htdocs\modules\Menu\Menu.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Menu.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Menu\Menu.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Message.fns.php

Warnings:

Warning on line 266 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Message.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Modules.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class modules_admin
Warning on line 20 - no @package tag was used in a DocBlock for class modules
Warning on line 177 - File "C:\Internet\home\hostcms4\htdocs\modules\Modules\Modules.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Modules.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Modules\Modules.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Mysql.class.php

Warnings:

Warning on line 19 - no @package tag was used in a DocBlock for class MySQL
Warning on line 295 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Mysql.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Mysqldump.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class mysqldump
Warning on line 198 - File "C:\Internet\home\hostcms4\htdocs\modules\Backup\Mysqldump.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Password.class.php

Warnings:

Warning on line 12 - no @package tag was used in a DocBlock for class Password
Warning on line 64 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Password.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Polls.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class polls
Warning on line 1478 - File "C:\Internet\home\hostcms4\htdocs\modules\Polls\Polls.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Polls.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Polls\Polls.php" has no page-level DocBlock, use @package in the first DocBlock to create one

RssRead.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class RssRead
Warning on line 290 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\RssRead.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

RssWrite.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class rss
Warning on line 19 - no @package tag was used in a DocBlock for class RssWrite
Warning on line 370 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\RssWrite.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ru.php

Warnings:

Warning on line 12 - File "C:\Internet\home\hostcms4\htdocs\modules\typograph\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 19 - File "C:\Internet\home\hostcms4\htdocs\modules\Search\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 20 - File "C:\Internet\home\hostcms4\htdocs\modules\Backup\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 21 - File "C:\Internet\home\hostcms4\htdocs\modules\Menu\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 22 - File "C:\Internet\home\hostcms4\htdocs\modules\ip\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 23 - File "C:\Internet\home\hostcms4\htdocs\modules\Constants\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 26 - File "C:\Internet\home\hostcms4\htdocs\modules\ExecSqlQuery\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 30 - File "C:\Internet\home\hostcms4\htdocs\modules\EventsJournal\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 32 - File "C:\Internet\home\hostcms4\htdocs\modules\Cache\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 37 - File "C:\Internet\home\hostcms4\htdocs\modules\Modules\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 40 - File "C:\Internet\home\hostcms4\htdocs\modules\FileManager\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 41 - File "C:\Internet\home\hostcms4\htdocs\modules\Lists\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 42 - File "C:\Internet\home\hostcms4\htdocs\modules\Xsl\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 48 - File "C:\Internet\home\hostcms4\htdocs\modules\Templates\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 48 - File "C:\Internet\home\hostcms4\htdocs\modules\Support\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 61 - File "C:\Internet\home\hostcms4\htdocs\modules\UserAccess\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 71 - File "C:\Internet\home\hostcms4\htdocs\modules\Polls\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 80 - File "C:\Internet\home\hostcms4\htdocs\modules\Site\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 83 - File "C:\Internet\home\hostcms4\htdocs\modules\lib\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 87 - File "C:\Internet\home\hostcms4\htdocs\modules\Documents\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 90 - File "C:\Internet\home\hostcms4\htdocs\modules\Maillist\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 93 - File "C:\Internet\home\hostcms4\htdocs\modules\Forms\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 101 - File "C:\Internet\home\hostcms4\htdocs\modules\Advertisement\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 107 - File "C:\Internet\home\hostcms4\htdocs\modules\Structure\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 111 - File "C:\Internet\home\hostcms4\htdocs\modules\Forums\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 124 - File "C:\Internet\home\hostcms4\htdocs\modules\Site_users\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 200 - File "C:\Internet\home\hostcms4\htdocs\modules\Counter\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 259 - File "C:\Internet\home\hostcms4\htdocs\modules\InformationSystems\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 907 - File "C:\Internet\home\hostcms4\htdocs\modules\shop\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Search.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class Search
Warning on line 1582 - File "C:\Internet\home\hostcms4\htdocs\modules\Search\Search.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Errors:

Error on line 31 - DocBlock has multiple @access tags, illegal. ignoring additional tag "@access private"

Search.php

Warnings:

Warning on line 24 - File "C:\Internet\home\hostcms4\htdocs\modules\Search\Search.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Security.fns.php

Warnings:

Warning on line 332 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Security.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

shop.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class shop
Warning on line 14218 - File "C:\Internet\home\hostcms4\htdocs\modules\shop\shop.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Errors:

Error on line 8907 - "@return" tag was used without any parameters, illegal

shop.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\shop\shop.php" has no page-level DocBlock, use @package in the first DocBlock to create one

show_table.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class table_fields
Warning on line 200 - no @package tag was used in a DocBlock for class show_table
Warning on line 612 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\show_table.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class site
Warning on line 801 - File "C:\Internet\home\hostcms4\htdocs\modules\Site\Site.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Site\Site.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site_users.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class SiteUsers
Warning on line 2282 - File "C:\Internet\home\hostcms4\htdocs\modules\Site_users\Site_users.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site_users.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Site_users\Site_users.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Structure.class.php

Warnings:

Warning on line 9 - no @package tag was used in a DocBlock for class Structure
Warning on line 2338 - File "C:\Internet\home\hostcms4\htdocs\modules\Structure\Structure.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Structure.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Structure\Structure.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Support.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Support
Warning on line 131 - File "C:\Internet\home\hostcms4\htdocs\modules\Support\Support.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Support.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Support\Support.php" has no page-level DocBlock, use @package in the first DocBlock to create one

tar.class.php

Warnings:

Warning on line 13 - duplicate define element "OS_WINDOWS" in file C:\Internet\home\hostcms4\htdocs\modules\Backup\tar\tar.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning on line 14 - duplicate define element "OS_UNIX" in file C:\Internet\home\hostcms4\htdocs\modules\Backup\tar\tar.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning on line 25 - no @package tag was used in a DocBlock for class Archive_Tar
Warning on line 1697 - File "C:\Internet\home\hostcms4\htdocs\modules\Backup\tar\tar.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Templates.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class templates
Warning on line 467 - File "C:\Internet\home\hostcms4\htdocs\modules\Templates\Templates.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Templates.php

Warnings:

Warning on line 29 - File "C:\Internet\home\hostcms4\htdocs\modules\Templates\Templates.php" has no page-level DocBlock, use @package in the first DocBlock to create one

typograph.class.php

Warnings:

Warning on line 6 - no @package tag was used in a DocBlock for class typograph
Warning on line 13 - Unknown tag "@source_string" used
Warning on line 222 - File "C:\Internet\home\hostcms4\htdocs\modules\typograph\typograph.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

typograph.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\typograph\typograph.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Url.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class url
Warning on line 465 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Url.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

UserAccess.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class UserAccessDenied
Warning on line 11 - no @package tag was used in a DocBlock for class user_access
Warning on line 181 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\UserAccess.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 326 - File "C:\Internet\home\hostcms4\htdocs\modules\UserAccess\UserAccess.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

UserAccess.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\UserAccess\UserAccess.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Wysiwyg.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class wysiwyg
Warning on line 160 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\Wysiwyg.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

XMLparser.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class XMLparser
Warning on line 120 - File "C:\Internet\home\hostcms4\htdocs\modules\Kernel\XMLparser.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Xsl.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class xsl
Warning on line 667 - File "C:\Internet\home\hostcms4\htdocs\modules\Xsl\Xsl.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Xsl.php

Warnings:

Warning on line 25 - File "C:\Internet\home\hostcms4\htdocs\modules\Xsl\Xsl.php" has no page-level DocBlock, use @package in the first DocBlock to create one


Система управления сайтом HostCMS