Package HostCMS_5 Element Index

Список элементов HostCMS_5

Список всех элементов
$ a b c d e f g h i j k l m n o p q r s t u v w x y _
top
$
$row['constants_name'] | in file Kernel.php, constant $row['constants_name']
top
_
$_contentTypes | in file JsHttpRequest.php, variable JsHttpRequest::$_contentTypes
$_emergBuffer | in file JsHttpRequest.php, variable JsHttpRequest::$_emergBuffer
$_encTables in file JsHttpRequest.php, variable JsHttpRequest::$_encTables
UCS-2BE -> 1-byte encodings (from #128).
$_magic | in file JsHttpRequest.php, variable JsHttpRequest::$_magic
$_nonAsciiChars | in file JsHttpRequest.php, variable JsHttpRequest::$_nonAsciiChars
$_prevDisplayErrors | in file JsHttpRequest.php, variable JsHttpRequest::$_prevDisplayErrors
$_toUtfFailed | in file JsHttpRequest.php, variable JsHttpRequest::$_toUtfFailed
$_unicodeConvMethod | in file JsHttpRequest.php, variable JsHttpRequest::$_unicodeConvMethod
$_uniqHash | in file JsHttpRequest.php, variable JsHttpRequest::$_uniqHash
_CallbackSearch in file Structure.class.php, method Structure::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_CallbackSearch in file InformationSystems.class.php, method InformationSystem::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_CallbackSearch in file shop.class.php, method shop::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_CallbackSearch in file Site_users.class.php, method SiteUsers::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_correctSuperglobals in file JsHttpRequest.php, method JsHttpRequest::_correctSuperglobals()
Parse & decode QUERY_STRING.
_decUcs2Decode in file JsHttpRequest.php, method JsHttpRequest::_decUcs2Decode()
Convert FROM UCS-2BE decimal to $toEnc.
_lock | in file Kernel.php, method Session::_lock()
_obHandler in file JsHttpRequest.php, method JsHttpRequest::_obHandler()
Called in case of error too!
_toUtf8_callback in file JsHttpRequest.php, method JsHttpRequest::_toUtf8_callback()
Internal function, used in array_walk_recursive() before json_encode() call.
_ucs2EntitiesDecode in file JsHttpRequest.php, method JsHttpRequest::_ucs2EntitiesDecode()
Decode all %uXXXX entities in string or array (recurrent).
_ucs2EntitiesDecodeCallback in file JsHttpRequest.php, method JsHttpRequest::_ucs2EntitiesDecodeCallback()
Decode one %uXXXX entity (RE callback).
_unicodeConv in file JsHttpRequest.php, method JsHttpRequest::_unicodeConv()
Wrapper for iconv() or mb_convert_encoding() functions.
_unlock | in file Kernel.php, method Session::_unlock()
_xml2Array | in file Kernel.class.php, method kernel::_xml2Array()
__autoload | in file Kernel.php, function __autoload()
__construct | in file File.class.php, method File::__construct()
__destruct | in file Mysql.class.php, method DataBase::__destruct()
top
a
$AAction in file admin_forms.class.php, variable admin_forms::$AAction
Значение AAction, переданное DoLoadAjax
$AAdditionalParams in file admin_forms.class.php, variable admin_forms::$AAdditionalParams
Значение AAdditionalParams, переданное DoLoadAjax
$aJs | in file Kernel.class.php, variable kernel::$aJs
$allowed_symbols in file Captcha.class.php, variable Captcha::$allowed_symbols
Разрешенные символы. Исключены похожие по написанию o=0, 1=l, i=j, t=f:
$angle in file Graphic.class.php, variable graphic::$angle
Вращение диаграммы вокруг оси
$array_template_ids | in file Templates.class.php, variable templates::$array_template_ids
$available_extantions in file Kernel.class.php, variable kernel::$available_extantions
Доступные для загрузки расширения файлов
$a_count_property in file Structure.class.php, variable Structure::$a_count_property
Ассоциативный массив-Кэш количества свойств для разных сайтов
AcceptAffiliatePlanForSiteUsers in file affiliate.class.php, method affiliate::AcceptAffiliatePlanForSiteUsers()
Начисление пользователю сумм с заказа по партнеской программе
AcceptAffiliatePlanToShop in file affiliate.class.php, method affiliate::AcceptAffiliatePlanToShop()
Добавление/удаление ассоциации партнерской программы магазину
AcceptTransaction in file warehouse.class.php, method warehouse::AcceptTransaction()
Списание с определенного склада определенное количество определенного товара
AccessSiteUserToMessage in file messages.class.php, method messages::AccessSiteUserToMessage()
Проверка доступа пользователя сайта к сообщению
AccessToAttachment in file helpdesk.class.php, method helpdesk::AccessToAttachment()
Проверка доступа пользователя сайта к вложенным файлам
AddAdminMenuItem in file AdminMenu.class.php, method AdminMenu::AddAdminMenuItem()
Метод добавляет модуль в меню раздела администрирования
AddBanner in file Advertisement.class.php, method Advertisement::AddBanner()
Добавление/редактирование баннера
AddBbCode in file Forums.class.php, method Forums::AddBbCode()
Добавление правила BB-кодов
AddButton in file admin_forms_fields.class.php, method admin_forms_fields::AddButton()
Вставка кнопки в форму
AddComment in file InformationSystems.class.php, method InformationSystem::AddComment()
Вставка/обновление комментария для элемента информационной системы
AddCommentWithoutStriptags in file InformationSystems.class.php, method InformationSystem::AddCommentWithoutStriptags()
Вставка/обновление комментария без удаления тегов в передаваемых параметрах
AddEditConstants in file Constants.class.php, method Constants::AddEditConstants()
Добавление/редактирование данных о константе
AddEditInitialData in file Counter.class.php, method counter::AddEditInitialData()
Добавление/редактирование начальных данных для счетчика
AddEditTheme in file Forums.class.php, method Forums::AddEditTheme()
Добавление/редактирование темы
AddExternalHtml in file admin_forms_fields.class.php, method admin_forms_fields::AddExternalHtml()
Добавить внешний HTML для формы
AddExternalReplace in file admin_forms.class.php, method admin_forms::AddExternalReplace()
Добавление внешней подстановки
AddField in file admin_forms_fields.class.php, method admin_forms_fields::AddField()
Добавление элемента на форму.
AddInclude in file Kernel.class.php, method kernel::AddInclude()
Метод подключает файл по указанному адресу
AddInit in file Wysiwyg.class.php, method wysiwyg::AddInit()
Добавление записи в блок tinyMCE.init
AddIntoCart in file shop.class.php, method shop::AddIntoCart()
Метод помещения товара в корзину
AddJs in file Kernel.class.php, method kernel::AddJs()
Добавление внешнего JavaScript файла для подключения в центре администрирования
AddLanguage in file admin_forms.class.php, method admin_forms::AddLanguage()
Вставка/обновление информации о языке
AddMenu in file admin_forms_fields.class.php, method admin_forms_fields::AddMenu()
Добавление верхнего меню
AddModule in file Kernel.class.php, method kernel::AddModule()
Метод подключения модуля
AddModuleFile in file Kernel.class.php, method kernel::AddModuleFile()
Осуществляет добавление файла модуля в список файлов модулей для загрузки.
AddSeparator in file admin_forms_fields.class.php, method admin_forms_fields::AddSeparator()
Вставка разделителя
AddTab in file admin_forms_fields.class.php, method admin_forms_fields::AddTab()
Вставка новой закладки
AddUserMessage in file admin_forms.class.php, method admin_forms::AddUserMessage()
Добавление текста, выводимого перед формой
AddXmlContent in file Kernel.class.php, method kernel::AddXmlContent()
Дописывает $xml к $this->ShowXmlContent
add_modules_version in file Kernel.class.php, method kernel::add_modules_version()
Метод добавления модуля в массив-список модулей
Admin | in file Admin.class.php, method Admin::Admin()
Admin in file Admin.class.php, class Admin
Система управления сайтом HostCMS v. 5.xx
AdminLoadFiles in file Kernel.class.php, method kernel::AdminLoadFiles()
Метод загрузки файлов в центре администрирования
AdminMainPage in file InformationSystems.class.php, method InformationSystem::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Cache.class.php, method Cache::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Site.class.php, method site::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Site_users.class.php, method SiteUsers::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Search.class.php, method Search::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file shop.class.php, method shop::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Counter.class.php, method counter::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMenu in file AdminMenu.class.php, class AdminMenu
Система управления сайтом HostCMS v. 5.xx
AdminSessionStart in file Admin.class.php, method Admin::AdminSessionStart()
Запуск сессии для центра администрирования
admin_datetime_format in file Date.class.php, method DateClass::admin_datetime_format()
Метод для центра администрирования, преобразует формат выводы даты из sql-формата в формат d.m.Y H:i:s
admin_date_format in file Date.class.php, method DateClass::admin_date_format()
Метод для центра администрирования, преобразует формат выводы даты из sql-формата в формат d.m.Y
admin_forms in file admin_forms.class.php, method admin_forms::admin_forms()
Конструктор, инициализирует значения свойств класса $this->AAction, $this->AAdditionalParams
admin_forms in file admin_forms.class.php, class admin_forms
Система управления сайтом HostCMS v. 5.xx
admin_forms.class.php | procedural page admin_forms.class.php
admin_forms.php | procedural page admin_forms.php
admin_forms_fields.class.php | procedural page admin_forms_fields.class.php
admin_forms_fields in file admin_forms_fields.class.php, class admin_forms_fields
Система управления сайтом HostCMS v. 5.xx
admin_forms_fields in file admin_forms_fields.class.php, method admin_forms_fields::admin_forms_fields()
Конструктор класса
admin_init in file Admin.class.php, method Admin::admin_init()
Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта
admin_session_valid in file Admin.class.php, method Admin::admin_session_valid()
Метод проверки авторизации пользователя
Advertisement in file Advertisement.class.php, class Advertisement
Класс модуля "Реклама"
Advertisement.class.php | procedural page Advertisement.class.php
Advertisement.php | procedural page Advertisement.php
affiliate in file affiliate.class.php, class affiliate
Система управления сайтом HostCMS v. 5.xx Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
AlignTextSpace in file Counter.class.php, method counter::AlignTextSpace()
Выравнивание текста по центру с помощью пробелов
AllowShowPanel in file Kernel.class.php, method kernel::AllowShowPanel()
Определяет возможность отображения панели пользователю.
AllowYandexXml in file seo.class.php, method Seo::AllowYandexXml()
Проверка возможности использования Яндекс.XML
AnalizeForKeyWords in file helpdesk.class.php, method helpdesk::AnalizeForKeyWords()
Анализ сообщения на предмет содержания ключевых слов для стандартных ответов.
ApplyFormat in file admin_forms.class.php, method admin_forms::ApplyFormat()
Применяет формат отображения $format к строке $str.
ApplyMailTemplate in file Maillist.class.php, method Maillist::ApplyMailTemplate()
Метод осуществляющий шаблонную подстановку в текст письма информации о пользоваетеле сайта
ApplyTextFunctionWithoutCodeSection in file Forums.class.php, method Forums::ApplyTextFunctionWithoutCodeSection()
Применение функции к фрагментам текста, содержащихся во вне блоков [code]...[/code]
array_fill_keys | in file Kernel.php, function array_fill_keys()
array_intersect_key | in file Kernel.php, function array_intersect_key()
array_values_to_int in file Security.fns.php, function array_values_to_int()
Функция приведения значений одномерного массива к целому, ключи сохраняются
AssignGroupImage in file shop.class.php, method shop::AssignGroupImage()
Метод для установки имени изображения для группы товаров
AssignItemImage in file shop.class.php, method shop::AssignItemImage()
Метод для установки имени изображения для товара
AssignShopWatermark in file shop.class.php, method shop::AssignShopWatermark()
Метод осуществляющий обновление данных о файле watermark'a для магазина
Admin.class.php | procedural page Admin.class.php
AdminMenu.class.php | procedural page AdminMenu.class.php
admin_output.fns.php | procedural page admin_output.fns.php
affiliate.class.php | procedural page affiliate.class.php
top
b
$buttons | in file admin_forms_fields.class.php, variable admin_forms_fields::$buttons
Backup in file Backup.class.php, class Backup
Класс модуля "Резервное копирование"
Backup.class.php | procedural page Backup.class.php
Backup.php | procedural page Backup.php
BBcode2HTML in file Forums.class.php, method Forums::BBcode2HTML()
Замена BBcode на HTML.
bcpow | in file Kernel.php, function bcpow()
BodyDecode in file Mail.class.php, method Mail::BodyDecode()
Перекодировщик тела письма
build in file Xsl.class.php, method xsl::build()
Метод обработки XML данных с помощью XSL шаблона
BuildCapture in file Captcha.class.php, method Captcha::BuildCapture()
Метод для построения изображения CAPTCHA и помещения его текста в сессию
BuildMassReport in file seo.class.php, method Seo::BuildMassReport()
Игнорирование столбцов таблицы
BuildSubject in file helpdesk.class.php, method helpdesk::BuildSubject()
Формирование темы сообщения в соответствии с масками имени тикета и номера сообщения
build_counter in file Counter.class.php, method counter::build_counter()
Отображение счетчика
top
c
$CacheDiscountsForItem | in file shop.class.php, variable shop::$CacheDiscountsForItem
$CacheGetAdminFormsWord in file admin_forms.class.php, variable admin_forms::$CacheGetAdminFormsWord
Массив-кэш для метода GetAdminFormsWord()
$CacheGetAllPricesForItem in file shop.class.php, variable shop::$CacheGetAllPricesForItem
Кэш для метода GetAllPricesForItem()
$CacheGetAllWarehousesForShop in file warehouse.class.php, variable warehouse::$CacheGetAllWarehousesForShop
Кэш для метода GetAllWarehousesForShop()
$CacheGetAttachment in file helpdesk.class.php, variable helpdesk::$CacheGetAttachment
Кэш для метода GetAttachment()
$CacheGetCatalogItemIdByCmlId | in file shop.class.php, variable shop::$CacheGetCatalogItemIdByCmlId
$CacheGetCity in file shop.class.php, variable shop::$CacheGetCity
Кэш для метода GetCity()
$CacheGetCityArea in file shop.class.php, variable shop::$CacheGetCityArea
Кэш для метода GetCityArea()
$CacheGetConference in file Forums.class.php, variable Forums::$CacheGetConference
Кэш для метода GetConference()
$CacheGetCountItemsAndGroups in file shop.class.php, variable shop::$CacheGetCountItemsAndGroups
Кэш для GetCountItemsAndGroups
$CacheGetCountry in file shop.class.php, variable shop::$CacheGetCountry
Кэш для метода GetCountry()
$CacheGetCriticalLevel in file helpdesk.class.php, variable helpdesk::$CacheGetCriticalLevel
Кэш для метода GetCriticalLevel()
$CacheGetCurrencyByLike | in file shop.class.php, variable shop::$CacheGetCurrencyByLike
$CacheGetCurrentDocumentVersion in file Documents.class.php, variable documents::$CacheGetCurrentDocumentVersion
Кэш для метода GetCurrentDocumentVersion()
$CacheGetDiscount in file shop.class.php, variable shop::$CacheGetDiscount
Кэш скидок для GetDiscount
$CacheGetEmail in file helpdesk.class.php, variable helpdesk::$CacheGetEmail
Кэш для метода GetEmail()
$CacheGetFirstMessageTicket in file helpdesk.class.php, variable helpdesk::$CacheGetFirstMessageTicket
Кэш для метода GetFirstMessageTicket()
$CacheGetHelpdesk in file helpdesk.class.php, variable helpdesk::$CacheGetHelpdesk
Кэш для метода GetHelpdesk()
$CacheGetInfo4Messages in file helpdesk.class.php, variable helpdesk::$CacheGetInfo4Messages
Кэш для метода GetInfo4Messages()
$CacheGetItem in file shop.class.php, variable shop::$CacheGetItem
Кэш товаров для метода GetItem
$CacheGetItemCountForWarehouse in file warehouse.class.php, variable warehouse::$CacheGetItemCountForWarehouse
Кэш для метода GetItemCountForWarehouse()
$CacheGetItemPropertyIdByCmlId | in file shop.class.php, variable shop::$CacheGetItemPropertyIdByCmlId
$CacheGetLanguage in file admin_forms.class.php, variable admin_forms::$CacheGetLanguage
Массив кэш для GetLanguage()
$CacheGetLanguageByShortName in file admin_forms.class.php, variable admin_forms::$CacheGetLanguageByShortName
Массив-кэш для GetLanguageByShortName()
$CacheGetLocation in file shop.class.php, variable shop::$CacheGetLocation
Кэш для метода GetLocation()
$CacheGetMessage in file helpdesk.class.php, variable helpdesk::$CacheGetMessage
Кэш для метода GetMessage()
$CacheGetPriceByCmlId | in file shop.class.php, variable shop::$CacheGetPriceByCmlId
$CacheGetPriceForItem in file shop.class.php, variable shop::$CacheGetPriceForItem
Кэш для метода GetPriceForItem()
$CacheGetResponsible in file helpdesk.class.php, variable helpdesk::$CacheGetResponsible
Кэш для метода GetResponsible()
$CacheGetSiteUserByEmail in file helpdesk.class.php, variable helpdesk::$CacheGetSiteUserByEmail
Кэш для метода GetSiteUserByEmail()
$CacheGetSpecialPriceForItem in file shop.class.php, variable shop::$CacheGetSpecialPriceForItem
Кэш для метода GetSpecialPriceForItem()
$CacheGetSpecialPricesForItem in file shop.class.php, variable shop::$CacheGetSpecialPricesForItem
Кэш для метода GetSpecialPricesForItem()
$CacheGetStatus in file helpdesk.class.php, variable helpdesk::$CacheGetStatus
Кэш для метода GetStatus()
$CacheGetTag in file tag.class.php, variable Tag::$CacheGetTag
mem-cache для GetTag()
$CacheGetTagRelation in file tag.class.php, variable Tag::$CacheGetTagRelation
mem-cache для GetTagRelation()
$CacheGetTax in file shop.class.php, variable shop::$CacheGetTax
Кэш для метода GetTax()
$CacheGetTemplate in file helpdesk.class.php, variable helpdesk::$CacheGetTemplate
Кэш для метода GetTemplate()
$CacheGetTemplateDir in file helpdesk.class.php, variable helpdesk::$CacheGetTemplateDir
Кэш для метода GetTemplateDir()
$CacheGetTemplateKeyWords in file helpdesk.class.php, variable helpdesk::$CacheGetTemplateKeyWords
Кэш для метода GetTemplateKeyWords()
$CacheGetThemeLastMessage in file Forums.class.php, variable Forums::$CacheGetThemeLastMessage
Кэш для метода GetThemeLastMessage()
$CacheGetTicket in file helpdesk.class.php, variable helpdesk::$CacheGetTicket
Кэш для метода GetTicket()
$CacheGetTicketByName in file helpdesk.class.php, variable helpdesk::$CacheGetTicketByName
Кэш для метода GetTicketByName()
$CacheGetTicketCategory in file helpdesk.class.php, variable helpdesk::$CacheGetTicketCategory
Кэш для метода GetTicketCategory()
$CacheGetTicketFlags in file helpdesk.class.php, variable helpdesk::$CacheGetTicketFlags
Кэш для метода GetTicketFlags()
$CacheGetUser in file UserAccess.class.php, variable user_access::$CacheGetUser
Кэш для метода GetUser()
$CacheGetWarehouse in file warehouse.class.php, variable warehouse::$CacheGetWarehouse
Кэш для метода GetWarehouse()
$CacheGetWeekend in file helpdesk.class.php, variable helpdesk::$CacheGetWeekend
Кэш для метода GetWeekend()
$CacheGetWorkTime in file helpdesk.class.php, variable helpdesk::$CacheGetWorkTime
Кэш для метода GetWorkTime()
$CacheGetXsl in file Xsl.class.php, variable xsl::$CacheGetXsl
Кэш для метода GetXsl()
$CacheMessages in file messages.class.php, variable messages::$CacheMessages
Кэш сообщений
$CacheModificationItems in file shop.class.php, variable shop::$CacheModificationItems
Массив ID модификаций товара для товаров
$CacheSite in file Site.class.php, variable site::$CacheSite
Кэш данных о сайтах
$cache_dir_is_exist in file Cache.class.php, variable Cache::$cache_dir_is_exist
Флаг наличия директории для сохранения файлов кэша
$cache_mesure in file shop.class.php, variable shop::$cache_mesure
Кэш информации о единицах измерений
$cache_producer in file shop.class.php, variable shop::$cache_producer
Кэш информации о производителях
$cache_structure_property in file Structure.class.php, variable Structure::$cache_structure_property
Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.
$cache_systems in file Cache.class.php, variable Cache::$cache_systems
Массив доступных способов кэширования
$CallbackFunctionName in file admin_forms.class.php, variable admin_forms::$CallbackFunctionName
Наименование функции обратного вызова
$CartType in file shop.class.php, variable shop::$CartType
Тип сохранения корзины, 0 - COOKIES, 1 - СЕССИЯ.
$chmod_file | in file File.class.php, variable File::$chmod_file
$chmod_file | in file SiteTemplate.class.php, variable SiteTemplate::$chmod_file
$color in file Graphic.class.php, variable graphic::$color
Массив основных цветов
$CommentMass in file InformationSystems.class.php, variable InformationSystem::$CommentMass
Кэш с данными о комментариях
$CountDays4FirstWorkDay in file helpdesk.class.php, variable helpdesk::$CountDays4FirstWorkDay
Число дней до первого рабочего
$count_row in file Mysql.class.php, variable DataBase::$count_row
Количество выбранных строк в последнем запросе
$CURLOPT_HTTPPROXYTUNNEL in file Kernel.class.php, variable kernel::$CURLOPT_HTTPPROXYTUNNEL
При установке этого параметра в true данные будут передаваться через прокси-сервер
$CURLOPT_PROXY in file Kernel.class.php, variable kernel::$CURLOPT_PROXY
HTTP-прокси
$CURLOPT_PROXYAUTH in file Kernel.class.php, variable kernel::$CURLOPT_PROXYAUTH
Метод HTTP-авторизации для использования при соединении с прокси.
$CURLOPT_PROXYPORT in file Kernel.class.php, variable kernel::$CURLOPT_PROXYPORT
Номер порта для соединения с прокси-сервером; используется совместно с CURLOPT_PROXY
$CURLOPT_PROXYTYPE in file Kernel.class.php, variable kernel::$CURLOPT_PROXYTYPE
CURLPROXY_HTTP по умолчанию или CURLPROXY_SOCKS5
$CURLOPT_PROXYUSERPWD in file Kernel.class.php, variable kernel::$CURLOPT_PROXYUSERPWD
Имя пользователя и пароль в формате "[username]:[password]" для использования при соединении с прокси
$current_alias_cache | in file Site.class.php, variable site::$current_alias_cache
$c_dev in file Graphic.class.php, variable graphic::$c_dev
Отклонение углов сегментов
Cache in file Cache.class.php, class Cache
Класс модуля "Кэш"
Cache in file Cache.class.php, method Cache::Cache()
Конструктор
Cache.class.php | procedural page Cache.class.php
Cache.php | procedural page Cache.php
config.php | procedural page config.php
CACHE_INSTALL in file Cache.php, constant CACHE_INSTALL
Система управления сайтом HostCMS v. 5.xx
CallProbability in file Cache.class.php, method Cache::CallProbability()
Определяет необходимости удаления истекших элементов кэша
CancelOrder in file shop.class.php, method shop::CancelOrder()
Метод для отмены заказа (устанавливает поле shop_order_cancel = 1)
Captcha in file Captcha.class.php, class Captcha
Система управления сайтом HostCMS v. 5.xx
CdirCorrection in file FileManager.class.php, method FileManager::CdirCorrection()
Обработка (удаление имени файла, "лишних" слэшей и т.д) пути к директории
ChangeAssociateSiteUserWithUsersGroupInformationGroup in file InformationSystems.class.php, method InformationSystem::ChangeAssociateSiteUserWithUsersGroupInformationGroup()
Добавление/удаление связи пользователя с группой пользователей, связанной с информационной группой
ChangeItemsOfOrderRest in file shop.class.php, method shop::ChangeItemsOfOrderRest()
Изменение остатка товаров в заказе
ChangeMessagesReadStatus in file messages.class.php, method messages::ChangeMessagesReadStatus()
Метод изменения статуса сообщения "прочитано"/"не прочитано"
ChangeMySqlDate in file Date.class.php, method DateClass::ChangeMySqlDate()
Получение значения даты в формате MySQL путем изменения переданной на заданное число секунд
ChangeNormalDate in file Date.class.php, method DateClass::ChangeNormalDate()
Получение значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд
charset_koi_win in file Security.fns.php, function charset_koi_win()
Преобразует текст из KOI8-R в WIN-1251
CheckBot in file Counter.class.php, method counter::CheckBot()
Проверка user-agent на принадлежность к ботам
CheckSiteUserAffiliate in file affiliate.class.php, method affiliate::CheckSiteUserAffiliate()
Проеверка участия пользователя сайта в аффилиат программе в качестве привлеченного пользователя
CheckTypeGzip in file Compression.class.php, method compression::CheckTypeGzip()
Получение типа сжатия gzip
CheckUsersAccessToForum | in file Forums.class.php, method Forums::CheckUsersAccessToForum()
ClearAdvertisementList in file Advertisement.class.php, method Advertisement::ClearAdvertisementList()
Очищение списка показов, произошедших $count_days назад
ClearAllCache in file Cache.class.php, method Cache::ClearAllCache()
Очистка всех кэшей (не очищая кэш статичных файлов)
ClearCache in file Cache.class.php, method Cache::ClearCache()
Очистка кэша
ClearCachePage in file seo.class.php, method Seo::ClearCachePage()
Очищает кэш запрошенных страниц в $this->CachePage
ClearCookieAndSessionCart in file shop.class.php, method shop::ClearCookieAndSessionCart()
Метод для очистки корзины кукисов и сессий
ClearExpireItems in file Cache.class.php, method Cache::ClearExpireItems()
Удаление истекших элементов кэша
ClearPath in file shop.class.php, method shop::ClearPath()
Метод очищает путь от запрещенных символов
ClearStaticCache in file Cache.class.php, method Cache::ClearStaticCache()
Очистка кэша в статичных файлах
ClearStructure in file Structure.class.php, method Structure::ClearStructure()
Метод очистки кэша($this->structure_mass)
CloseForum in file Forums.class.php, method Forums::CloseForum()
Метод, закрывающий/открывающий форум
CloseOldTicket in file helpdesk.class.php, method helpdesk::CloseOldTicket()
Закрытие старых (ответ на которые дан более 10 дней назад) тикетов
CloseTheme in file Forums.class.php, method Forums::CloseTheme()
Открытие/закрытие темы для доступа
cml in file cml.class.php, class cml
Система управления сайтом HostCMS v. 5.xx
cms_error_handler in file Error.fns.php, function cms_error_handler()
Ядро, обработчики ошибок в HostCMS
code_ip in file Kernel.class.php, method kernel::code_ip()
Метод для преобразования IP в HEX
code_ip in file Counter.class.php, method counter::code_ip()
Преобразование IP в HEX
ColorAllocateFactor in file Graphic.class.php, method graphic::ColorAllocateFactor()
Метод возвращающий оттенок цвета
colors in file Graphic.class.php, method graphic::colors()
Метод возвращает идентификатор основного цвета
CombineTickets in file helpdesk.class.php, method helpdesk::CombineTickets()
Объединение тикетов
compression in file Compression.class.php, class compression
Класс модуля "Система сжатия (компрессия)"
Compression.class.php | procedural page Compression.class.php
Compression.php | procedural page Compression.php
COMPRESSION_INSTALL in file Compression.php, constant COMPRESSION_INSTALL
Система управления сайтом HostCMS v. 5.xx
com_create_guid | in file Kernel.php, function com_create_guid()
ConfirmGetForm in file Forms.class.php, method Forms::ConfirmGetForm()
Определение права пользователя отправлять форму
confirm_information_item in file InformationSystems.class.php, method InformationSystem::confirm_information_item()
Определение возможности пользователя добавлять информационный элемент
Constants in file Constants.class.php, class Constants
Система управления сайтом HostCMS v. 5.xx
Constants.class.php | procedural page Constants.class.php
Constants.php | procedural page Constants.php
ConvertPrice in file shop.class.php, method shop::ConvertPrice()
Конвертирует цену в различных форматах к цене в формате xxxx.yy
ConvertSqlProperty in file lib.class.php, method lib::ConvertSqlProperty()
Конвертирование SQL-запроса, введенного для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.
convert_str_for_csv in file EventsJournal.class.php, method EventsJournal::convert_str_for_csv()
Подготовка строки к записи в CSV-файл
CopyAdminFormEvent in file admin_forms_fields.class.php, method admin_forms_fields::CopyAdminFormEvent()
Копирование события формы центра администрирования
CopyAdminFormField in file admin_forms_fields.class.php, method admin_forms_fields::CopyAdminFormField()
Копирование поля формы центра администрирования
CopyAdvertisement in file Advertisement.class.php, method Advertisement::CopyAdvertisement()
Копирование баннера
CopyAffiliats in file shop.class.php, method shop::CopyAffiliats()
Копирование парнерских программ
CopyBannersAndBannersGroupsFromSiteToSite in file Advertisement.class.php, method Advertisement::CopyBannersAndBannersGroupsFromSiteToSite()
Копирование всех групп баннеров и баннеров, а также их связей с одного сайта на другой
CopyComment in file InformationSystems.class.php, method InformationSystem::CopyComment()
Копирование комментария к информационному элементу
CopyCondOfDelivery in file shop.class.php, method shop::CopyCondOfDelivery()
Копирование условий типа доставки
CopyContextualWords in file Advertisement.class.php, method Advertisement::CopyContextualWords()
Копирование информации о контекстной фразе
CopyCoupons in file shop.class.php, method shop::CopyCoupons()
Копирование купонов магазина на скидку
CopyCriticalLevel in file helpdesk.class.php, method helpdesk::CopyCriticalLevel()
Копирование информации об уровне критичности
CopyCurrentDocumentVersion in file Documents.class.php, method documents::CopyCurrentDocumentVersion()
Копирование текущей версии документа
CopyDataTemplate in file Templates.class.php, method templates::CopyDataTemplate()
Метод копирования шаблона страниц
CopyDataTemplatesDir in file Templates.class.php, method templates::CopyDataTemplatesDir()
Копирование групп шаблонов с шаблонами и подгруппами
CopyDir in file File.class.php, method File::CopyDir()
Копирование директории
CopyDiscounts in file shop.class.php, method shop::CopyDiscounts()
Копирование скидок на товары
CopyDocuments in file Documents.class.php, method documents::CopyDocuments()
Метод копирования документа
CopyDocumentsDir in file Documents.class.php, method documents::CopyDocumentsDir()
Копирование групп документов с документами
CopyDocumentStatus in file Documents.class.php, method documents::CopyDocumentStatus()
Копирование статуса документа
CopyEmail in file helpdesk.class.php, method helpdesk::CopyEmail()
Копирование информации об электронном адресе службы поддержки
CopyExternalPropertiesForItem in file shop.class.php, method shop::CopyExternalPropertiesForItem()
Копирование значений дополнительных свойств товара
CopyExtraProperty in file Site_users.class.php, method SiteUsers::CopyExtraProperty()
Метод копирования дополнительного параметра
CopyFascicle in file Maillist.class.php, method Maillist::CopyFascicle()
Метод копирования выпуска рассылки
CopyForms in file Forms.class.php, method Forms::CopyForms()
Копирование структуры формы и ее полей
CopyFormsField in file Forms.class.php, method Forms::CopyFormsField()
Копирование структуры поля формы
CopyForum in file Forums.class.php, method Forums::CopyForum()
Копирование информации о форуме
CopyForumsConference in file Forums.class.php, method Forums::CopyForumsConference()
Копирование конференции, групп форумов, а так же форумов, входящих в данную конференцию
CopyForumsGroup in file Forums.class.php, method Forums::CopyForumsGroup()
Копирование информации о группе форумов
CopyGroupAdvertisement in file Advertisement.class.php, method Advertisement::CopyGroupAdvertisement()
Копирование группы баннеров
CopyGroupsItemsProperty in file shop.class.php, method shop::CopyGroupsItemsProperty()
Копирование дополнительного свойства товаров
CopyGroupsProperty in file InformationSystems.class.php, method InformationSystem::CopyGroupsProperty()
Копирование дополнительного свойства информационных групп
CopyHelpdesk in file helpdesk.class.php, method helpdesk::CopyHelpdesk()
Копирование службы поддержки
CopyImgWithWatermark in file Image.class.php, method Image::CopyImgWithWatermark()
Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя
CopyInformationItem in file InformationSystems.class.php, method InformationSystem::CopyInformationItem()
Копирование информационного элемента
CopyInformationSystem in file InformationSystems.class.php, method InformationSystem::CopyInformationSystem()
Копирование информационной системы
CopyInformationSystemDir | in file InformationSystems.class.php, method InformationSystem::CopyInformationSystemDir()
CopyItem in file shop.class.php, method shop::CopyItem()
Копирование товара
CopyItemsProperty in file InformationSystems.class.php, method InformationSystem::CopyItemsProperty()
Копирование дополнительного свойства информационных элементов
CopyItemsProperty in file shop.class.php, method shop::CopyItemsProperty()
Копирование дополнительного свойства товаров
CopyLib in file lib.class.php, method lib::CopyLib()
Создание копии типовой динамической страницы
CopyList in file Lists.class.php, method lists::CopyList()
Копирование списка
CopyListItem in file Lists.class.php, method lists::CopyListItem()
Копирование элемента списка
CopyMaillist in file Maillist.class.php, method Maillist::CopyMaillist()
Копирование почтовой рассылки
CopyMaillistUsers in file Maillist.class.php, method Maillist::CopyMaillistUsers()
Копирование связи пользователя с почтовой рассылкой
CopyMaillistUsersGroup in file Maillist.class.php, method Maillist::CopyMaillistUsersGroup()
Копирование связи почтовой рассылки с группой пользователей
CopyOrderDiscounts in file shop.class.php, method shop::CopyOrderDiscounts()
Копирование скидок от суммы заказа и их купонов
CopyPoll in file Polls.class.php, method polls::CopyPoll()
Копирование опроса
CopyPollGroup in file Polls.class.php, method polls::CopyPollGroup()
Копирование группы опросов
CopyPollReply in file Polls.class.php, method polls::CopyPollReply()
Копирование ответа на опрос
CopyPrices in file shop.class.php, method shop::CopyPrices()
Копирование цен для магазина
CopyProducers in file shop.class.php, method shop::CopyProducers()
Копирование производителей
CopyPropertiesForGroup in file shop.class.php, method shop::CopyPropertiesForGroup()
Копирование дополнительных свойств групп товаров, включая группы дополнительных свойств групп
CopyPropertiesForItem in file shop.class.php, method shop::CopyPropertiesForItem()
Копирование дополнительных свойств товаров, включая подгруппы дополнительных свойств
CopyPropertysGroupsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::CopyPropertysGroupsDirForInformationSystem()
Копирование дочерних групп дополнительных свойств информационных групп
CopyPropertysItemsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::CopyPropertysItemsDirForInformationSystem()
Копирование дочерних групп дополнительных свойств информационных элементов
CopySallers in file shop.class.php, method shop::CopySallers()
Копирование продавцов
CopyShop in file shop.class.php, method shop::CopyShop()
Копирование информации о магазине, а также дополнительных свойствах товаров, групп и групп этих свойств
CopyShopDir | in file shop.class.php, method shop::CopyShopDir()
CopySite in file Site.class.php, method site::CopySite()
Копирование сайта
CopyStatus in file helpdesk.class.php, method helpdesk::CopyStatus()
Копирование статуса сообщения
CopyStructure in file Structure.class.php, method Structure::CopyStructure()
Копирование узла структуры
CopyStructureProperty in file Structure.class.php, method Structure::CopyStructureProperty()
Копирование дополнительного свойства узлов структуры
CopySystemsOfPay in file shop.class.php, method shop::CopySystemsOfPay()
Копирование платежных систем
CopyTemplate in file Templates.class.php, method templates::CopyTemplate()
Метод копирования макета
CopyTemplateKeyWords in file helpdesk.class.php, method helpdesk::CopyTemplateKeyWords()
Копирование ключевого слова
CopyTemplatesDir in file Templates.class.php, method templates::CopyTemplatesDir()
Копирование групп макетов с макетами и подгруппами
CopyTicketCategory in file helpdesk.class.php, method helpdesk::CopyTicketCategory()
Копирование категории тикетов
CopyTicketFlag in file helpdesk.class.php, method helpdesk::CopyTicketFlag()
Копирование флага тикетов
CopyTypesOfDelivery in file shop.class.php, method shop::CopyTypesOfDelivery()
Копирование типа доставки
CopyUserType in file UserAccess.class.php, method user_access::CopyUserType()
Копирование информации о группе пользователей центра администрирования
CopyWarehouse in file warehouse.class.php, method warehouse::CopyWarehouse()
Копирование склада
CopyXsl in file Xsl.class.php, method xsl::CopyXsl()
Метод копирования XSL-шаблона
CorrectPropertiesGroup in file shop.class.php, method shop::CorrectPropertiesGroup()
Метод корректирует строку данных о дополнительном свойстве группы в соответствии с его типом.
CorrectPropertiesItem in file shop.class.php, method shop::CorrectPropertiesItem()
Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.
CorrectText in file Graphic.class.php, method graphic::CorrectText()
Корректировка текста.
counter in file Counter.class.php, class counter
Класс модуля "Статистика посещаемости сайта"
config.php | procedural page config.php
Counter.class.php | procedural page Counter.class.php
Counter.php | procedural page Counter.php
COUNTER_BOT_COUNT in file config.php, constant COUNTER_BOT_COUNT
Система управления сайтом HostCMS v. 5.xx
COUNTER_INSTALL in file Counter.php, constant COUNTER_INSTALL
Система управления сайтом HostCMS v. 5.xx
crc32 in file Kernel.class.php, method kernel::crc32()
Вычисление crc32 в диапазоне от -2147483647 до 2147483647.
CreateBackup in file Backup.class.php, method Backup::CreateBackup()
Создание резевной копии базы данных
CreateDirectory in file shop.class.php, method shop::CreateDirectory()
Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает
CreateForm in file admin_forms.class.php, method admin_forms::CreateForm()
Прорисовка формы центра администрирования.
CreateGroupsXmlTree in file InformationSystems.class.php, method InformationSystem::CreateGroupsXmlTree()
Формирование XML дерева для информационных групп
CreateMainMenu | in file admin_forms.class.php, method admin_forms::CreateMainMenu()
CreateOptions in file admin_forms_fields.class.php, method admin_forms_fields::CreateOptions()
Создание тегов <option> для каждого элемента ассоциативного массива
CreateRSS in file RssWrite.class.php, method RssWrite::CreateRSS()
Метод формирования XML-файла в стандарте RSS
CreateWatermark in file Image.class.php, method Image::CreateWatermark()
Служебный метод для наложения водяного знака
current_alias in file Site.class.php, method site::current_alias()
Метод установки алиаса (домена) сайта в статус "основной"
CURRENT_VERSION | in file Kernel.php, constant CURRENT_VERSION
current_version in file Documents.class.php, method documents::current_version()
Метод для переобозначения текущей версии документа
CutQuotetion in file helpdesk.class.php, method helpdesk::CutQuotetion()
Удаление из текста сообщения цитаты
CutWordLen in file Url.class.php, method url::CutWordLen()
Уменьшает длину слов в строке, имеющий длину больше $max_word_len
config.php | procedural page config.php
Captcha.class.php | procedural page Captcha.class.php
config.php | procedural page config.php
cml.class.php | procedural page cml.class.php
top
d
$data_under_menu in file admin_forms.class.php, variable admin_forms::$data_under_menu
Код для вывода под меню
$db_connect | in file Mysql.class.php, variable DataBase::$db_connect
$debug in file admin_forms.class.php, variable admin_forms::$debug
Сообщения отладки
$default_cache_systems in file Cache.class.php, variable Cache::$default_cache_systems
Способ кэширования по умолчанию
$distortion_amplitude in file Captcha.class.php, variable Captcha::$distortion_amplitude
амплитуда искажения
$dividend in file Cache.class.php, variable Cache::$dividend
Максимальное значение, генерируемое для определения необходимости удаления истекших элементов кэша
$documents_id_array in file Documents.class.php, variable documents::$documents_id_array
Массив соответствия старых и новых идентификаторов скопированных документов
DataBase in file Mysql.class.php, class DataBase
Ядро, класс для работы с СУБД
DateClass in file Date.class.php, class DateClass
Система управления сайтом HostCMS v. 5.xx
DateSqlToUnix in file Date.class.php, method DateClass::DateSqlToUnix()
Метод преобразовывает дату в формате SQL в число секунд с начала эпохи
datetime_format in file Date.class.php, method DateClass::datetime_format()
Метод преобразует формат вывода даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT
datetime_format_sql in file Date.class.php, method DateClass::datetime_format_sql()
Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL
DateUnixToSQL in file Date.class.php, method DateClass::DateUnixToSQL()
Метод преобразовывает дату из числа секунд в формат SQL
date_format in file Date.class.php, method DateClass::date_format()
Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT
date_format_sql in file Date.class.php, method DateClass::date_format_sql()
Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат
db_close in file Mysql.class.php, method DataBase::db_close()
Закрывает соединение $this->db_connect
db_connect in file Mysql.class.php, method DataBase::db_connect()
Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.
declension in file Kernel.class.php, method kernel::declension()
Получение существительного в форме, соответствующей числу
decode_ip in file Counter.class.php, method counter::decode_ip()
Декодирование IP из HEX
decode_ip in file Kernel.class.php, method kernel::decode_ip()
Метод для декодирования IP из HEX
DelBannerGroup in file Advertisement.class.php, method Advertisement::DelBannerGroup()
Исключение баннера из группы
DelBannersGroup in file Advertisement.class.php, method Advertisement::DelBannersGroup()
Удаление группы баннеров
DelConstants in file Constants.class.php, method Constants::DelConstants()
Удаление константы
DelDataTemplatesGroup in file Templates.class.php, method templates::DelDataTemplatesGroup()
Метод удаления группы шаблонов данных
Delete in file Mysql.class.php, method DataBase::Delete()
Удаление записей из таблиц.
DeleteAdminForm in file admin_forms.class.php, method admin_forms::DeleteAdminForm()
Удаление формы центра администрирования
DeleteAdminFormsEvent in file admin_forms.class.php, method admin_forms::DeleteAdminFormsEvent()
Удаление события (дейтсвия) формы администрирования
DeleteAdminFormsField in file admin_forms.class.php, method admin_forms::DeleteAdminFormsField()
Удаление поля формы администрирования
DeleteAdminLanguage in file admin_forms.class.php, method admin_forms::DeleteAdminLanguage()
Удаление языка центра администрирования
DeleteAdvertisementFile in file Advertisement.class.php, method Advertisement::DeleteAdvertisementFile()
Удаление загруженного файл для элемента
DeleteAdvertisementSwfFile in file Advertisement.class.php, method Advertisement::DeleteAdvertisementSwfFile()
Удаление загруженного swf-файл для элемента
DeleteAffiliate in file affiliate.class.php, method affiliate::DeleteAffiliate()
Удаление информации об аффилиате
DeleteAffiliatePlans in file affiliate.class.php, method affiliate::DeleteAffiliatePlans()
Удаление информации о плане аффилиата
DeleteAffiliateValues in file affiliate.class.php, method affiliate::DeleteAffiliateValues()
Удаление информации о комиссии
DeleteAllEItems in file shop.class.php, method shop::DeleteAllEItems()
Метод удаляет все электронные товары заданного товара
DeleteAllItemsCatalogAndGroups in file shop.class.php, method shop::DeleteAllItemsCatalogAndGroups()
Метод очистки таблиц товаров и групп
DeleteAllModificationForItem in file shop.class.php, method shop::DeleteAllModificationForItem()
Метод удаления всех модификаций товара
DeleteAttachments in file helpdesk.class.php, method helpdesk::DeleteAttachments()
Удаление информации о вложенных файлах в сообщениях
DeleteBanner in file Advertisement.class.php, method Advertisement::DeleteBanner()
Удаление баннера
DeleteCacheItem in file Cache.class.php, method Cache::DeleteCacheItem()
Метод удаляет элемент с именем $item_name из кэша $cache_name
DeleteCart in file shop.class.php, method shop::DeleteCart()
Удаление товара из корзины
DeleteCharacteristic in file seo.class.php, method Seo::DeleteCharacteristic()
Удаление характеристик страницы
DeleteCity in file shop.class.php, method shop::DeleteCity()
Метод, осуществляющий удаление города
DeleteCityArea in file shop.class.php, method shop::DeleteCityArea()
Метод удаления района города
DeleteComment in file shop.class.php, method shop::DeleteComment()
Метод удаления информации об отзыве на товар
DeleteCompany in file shop.class.php, method shop::DeleteCompany()
Метод удаления информации об организации
DeleteCondOfDelivery in file shop.class.php, method shop::DeleteCondOfDelivery()
Метод, осуществляющий удаление условия доставки
DeleteConference in file Forums.class.php, method Forums::DeleteConference()
Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.
DeleteContextualWords in file Advertisement.class.php, method Advertisement::DeleteContextualWords()
Удаление информации о контекстной фразе
DeleteCountry in file shop.class.php, method shop::DeleteCountry()
Метод, осуществляющий удаление страны
DeleteCoupon in file shop.class.php, method shop::DeleteCoupon()
Метод для удаления информации о купоне
DeleteCriticalLevel in file helpdesk.class.php, method helpdesk::DeleteCriticalLevel()
Удаление информации об уровне критичности
DeleteCurrency in file shop.class.php, method shop::DeleteCurrency()
Метод, осуществляющий удаление валюты
DeleteDir in file File.class.php, method File::DeleteDir()
Метод удаления директории вместе с вложенными файлами и директориями.
DeleteDiscount in file shop.class.php, method shop::DeleteDiscount()
Метод, осуществляющий удаление скидки
DeleteEItem in file shop.class.php, method shop::DeleteEItem()
Метод удаления информации об электронном товаре
DeleteEmail in file helpdesk.class.php, method helpdesk::DeleteEmail()
Удаление информациии об электронном адресе
DeleteExternalPropertyValue in file Site_users.class.php, method SiteUsers::DeleteExternalPropertyValue()
Метод удаления значения доплнительного параметра пользователя сайта
DeleteExtraProperty in file Site_users.class.php, method SiteUsers::DeleteExtraProperty()
Удаление дополнительного параматра
DeleteFascicleFiles in file Maillist.class.php, method Maillist::DeleteFascicleFiles()
Метод, осуществляющий удаление файла выпуска рассылки
DeleteFile in file File.class.php, method File::DeleteFile()
Удаление файла с проверкой на его существованием
DeleteForum in file Forums.class.php, method Forums::DeleteForum()
Метод удаления форума
DeleteGroup in file shop.class.php, method shop::DeleteGroup()
Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)
DeleteHelpdesk in file helpdesk.class.php, method helpdesk::DeleteHelpdesk()
Удаление информации о службе технической поддержки
DeleteInformationSystemsDir in file InformationSystems.class.php, method InformationSystem::DeleteInformationSystemsDir()
Удаление раздела информационных систем. Информационные системы, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.
DeleteItem in file shop.class.php, method shop::DeleteItem()
Метод, осуществляющий удаление товара
DeleteItemDiscount in file shop.class.php, method shop::DeleteItemDiscount()
Метод удаления скики для товара
DeleteLib in file lib.class.php, method lib::DeleteLib()
Удаление типовой динамической страницы из библиотеки страниц
DeleteLibDir in file lib.class.php, method lib::DeleteLibDir()
Рекурсивное удаление раздела типовых динамической страниц со всеми его подразделами
DeleteLibProperty in file lib.class.php, method lib::DeleteLibProperty()
Удаление параметра типовой динамической страницы
DeleteLibPropertyListItem in file lib.class.php, method lib::DeleteLibPropertyListItem()
Удаление элемента списка параметра типовой динамической страницы типа "Список"
DeleteListDir in file Lists.class.php, method lists::DeleteListDir()
Удаление раздела списков
DeleteLocation in file shop.class.php, method shop::DeleteLocation()
Метод, осуществляющий удаление области
DeleteMessage in file helpdesk.class.php, method helpdesk::DeleteMessage()
Удаление сообщения
DeleteMessages in file Mail.class.php, method Mail::DeleteMessages()
Удаление всех писем из почтового ящика
DeleteMesure in file shop.class.php, method shop::DeleteMesure()
Метод, осуществляющий удаление единицы измерения
DeleteOrder in file shop.class.php, method shop::DeleteOrder()
Метод, осуществляющий удаление заказа
DeleteOrderDiscount in file shop.class.php, method shop::DeleteOrderDiscount()
Метод для удаления информации о скидке для заказов
DeleteOrderItems in file shop.class.php, method shop::DeleteOrderItems()
Метод, осуществляющий удаление товара в заказе
DeleteOrderStatus in file shop.class.php, method shop::DeleteOrderStatus()
Метод, осуществляющий удаление статуса заказа
DeletePositionSearch in file seo.class.php, method Seo::DeletePositionSearch()
Удаление позиции в поисковой системе из БД
DeletePrice in file shop.class.php, method shop::DeletePrice()
Метод, осуществляющий удаление типа цены
DeletePriceForItem in file shop.class.php, method shop::DeletePriceForItem()
Метод удаляет цену для элемента каталога
DeletePricesForAllItem in file shop.class.php, method shop::DeletePricesForAllItem()
Метод удаляет все дополнительные цены для товара
DeleteProducer in file shop.class.php, method shop::DeleteProducer()
Метод, осуществляющий удаление производителя
DeletePropertiesGroupsDir in file shop.class.php, method shop::DeletePropertiesGroupsDir()
Удаление информации о группе дополнительных свойств групп товаров
DeletePropertiesGroupValue in file shop.class.php, method shop::DeletePropertiesGroupValue()
Удаление значения дополнительного свойства группы
DeletePropertiesItem in file shop.class.php, method shop::DeletePropertiesItem()
Удаление значение дополнительного свойства товара
DeletePropertiesItemsDir in file shop.class.php, method shop::DeletePropertiesItemsDir()
Удаление информации о группе дополнительных свойств товара
DeletePropertyForGroup in file shop.class.php, method shop::DeletePropertyForGroup()
Метод удаляет принадлежность дополнительного свойтсва группе товаров
DeletePropertyGroupsDir in file InformationSystems.class.php, method InformationSystem::DeletePropertyGroupsDir()
Удаление информации о группе дополнительных свойств групп информационной системы
DeletePropertysItemsDir in file InformationSystems.class.php, method InformationSystem::DeletePropertysItemsDir()
Удаление информации о группе дополнительных свойств информационных элементов
DeletePropertyValue in file Structure.class.php, method Structure::DeletePropertyValue()
Метод для удаления значения свойства узла структуры
DeletePropretyOfGroup in file shop.class.php, method shop::DeletePropretyOfGroup()
Удаление дополнительного свойства группы товаров
DeletePropretyOfItems in file shop.class.php, method shop::DeletePropretyOfItems()
Метод, осуществляющий удаление свойства товара
DeleteQuery in file seo.class.php, method Seo::DeleteQuery()
Удаление запроса
DeleteResponsible in file helpdesk.class.php, method helpdesk::DeleteResponsible()
Удаление ответственного пользователя
DeleteSearchInfomationForSite in file Search.class.php, method Search::DeleteSearchInfomationForSite()
Удаление поисковой информации сайта
DeleteSeller in file shop.class.php, method shop::DeleteSeller()
Метод, осуществляющий удаление продавца.
DeleteShop in file shop.class.php, method shop::DeleteShop()
Метод, осуществляющий удаление магазина
DeleteShopsDir in file shop.class.php, method shop::DeleteShopsDir()
Удаление раздела интернет-магазинов. Магазины, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.
DeleteShopWatermark | in file shop.class.php, method shop::DeleteShopWatermark()
DeleteSiteUser in file Site_users.class.php, method SiteUsers::DeleteSiteUser()
Метод удаления пользователя из системы
DeleteSiteUserAccountTransaction in file shop.class.php, method shop::DeleteSiteUserAccountTransaction()
Удаление транзакции
DeleteSiteUsersMail in file messages.class.php, method messages::DeleteSiteUsersMail()
Удаление сообщения
DeleteSpecialPrice in file shop.class.php, method shop::DeleteSpecialPrice()
Удаление информации о специальной цене
DeleteStatus in file helpdesk.class.php, method helpdesk::DeleteStatus()
Удаление статуса сообщений
DeleteStructure in file Structure.class.php, method Structure::DeleteStructure()
Метод для удлаения узла структуры с его дочерними узлами
DeleteSupportWoktime in file helpdesk.class.php, method helpdesk::DeleteSupportWoktime()
Удаление рабочего дня службы технической поддержки
DeleteSystemOfPay in file shop.class.php, method shop::DeleteSystemOfPay()
Метод, осуществляющий удаление платёжной системы
DeleteTag in file tag.class.php, method Tag::DeleteTag()
Удаление тега
DeleteTagRelation in file tag.class.php, method Tag::DeleteTagRelation()
Список соответствий тега
DeleteTagsGroup in file tag.class.php, method Tag::DeleteTagsGroup()
Удаление группы тегов
DeleteTax in file shop.class.php, method shop::DeleteTax()
Метод, осуществляющий удаление налога
DeleteTemplate in file helpdesk.class.php, method helpdesk::DeleteTemplate()
Удаление стандартного ответа
DeleteTemplateDir in file helpdesk.class.php, method helpdesk::DeleteTemplateDir()
Удаление группы стандартных ответов
DeleteTemplateKeyWords in file helpdesk.class.php, method helpdesk::DeleteTemplateKeyWords()
Удаление ключевого слова
DeleteThemeUserSubscribe in file Forums.class.php, method Forums::DeleteThemeUserSubscribe()
Удаление подписки пользователя сайта на тему форума
DeleteTicket in file helpdesk.class.php, method helpdesk::DeleteTicket()
Удаление информациии об инциденте
DeleteTicketCategory in file helpdesk.class.php, method helpdesk::DeleteTicketCategory()
Удаление информации о категории инцидентов
DeleteTicketFlags in file helpdesk.class.php, method helpdesk::DeleteTicketFlags()
Удаление информации о флаге для тикетов
DeleteTyingProducts in file shop.class.php, method shop::DeleteTyingProducts()
Метод удаления сопутствующих товаров
DeleteTypeOfDelivery in file shop.class.php, method shop::DeleteTypeOfDelivery()
Метод, осуществляющий удаление типа доставки
DeleteUserDeniedAccessBefore in file UserAccess.class.php, method user_access::DeleteUserDeniedAccessBefore()
Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд
DeleteUserDeniedAccessIP in file UserAccess.class.php, method user_access::DeleteUserDeniedAccessIP()
Метод удаления неудачных попыток входа в BackOffice для заданного IP-адреса
DeleteUsers in file Maillist.class.php, method Maillist::DeleteUsers()
Метод снятия подписки с подписчика по его идентификатору пользователя сайта (УСТАРЕВШИЙ МЕТОД!)
DeleteUsersFascicle in file Maillist.class.php, method Maillist::DeleteUsersFascicle()
Метод снятия подписки с подписчика по его идентификатору подписчика
DeleteUsersGroupFromMaillist in file Maillist.class.php, method Maillist::DeleteUsersGroupFromMaillist()
Метод закрывающий доступ к рассылке определенной группе пользователей
DeleteWarehouse in file warehouse.class.php, method warehouse::DeleteWarehouse()
Удаление информации о складе
DeleteWarehouseItem in file warehouse.class.php, method warehouse::DeleteWarehouseItem()
Удаление информации о связи товара и склада
DeleteWeekend in file helpdesk.class.php, method helpdesk::DeleteWeekend()
Удаление информации о специальном рабочем/выходном дне
DeleteWord in file admin_forms.class.php, method admin_forms::DeleteWord()
Удаление слова и всех его значений
delete_old_version in file Documents.class.php, method documents::delete_old_version()
Метод удаления записей обо всех не текущих версиях
delete_page in file Structure.class.php, method Structure::delete_page()
Устаревший метод удаления страницы. Рекомендуется использовать $this->DeleteStructure($structure_id);
Delete_search_words in file Search.class.php, method Search::Delete_search_words()
Метод удаления из индекса страницы с указанным адресом
delete_status in file Documents.class.php, method documents::delete_status()
Метод удаления статуса документов
delete_version in file Documents.class.php, method documents::delete_version()
Метод удаления записей о версиях
DelFascicle in file Maillist.class.php, method Maillist::DelFascicle()
Удаление выпуска рассылки
DelFillForms in file Forms.class.php, method Forms::DelFillForms()
Удаление бланка заполненной формы
DelFillValues in file Forms.class.php, method Forms::DelFillValues()
Удаление значения одного из полей отправленной формы
DelForms in file Forms.class.php, method Forms::DelForms()
Удаление данных о форме
DelFormsFields in file Forms.class.php, method Forms::DelFormsFields()
Удаление поля формы
DelForumsGroup in file Forums.class.php, method Forums::DelForumsGroup()
Метод удаления группы форумов
DelGroupUser in file Site_users.class.php, method SiteUsers::DelGroupUser()
Удаление пользователя из группы
DelInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertys()
Удаление дополнительного свойства информационной группы
DelInformationGroupPropertysValue in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertysValue()
Удаление значений дополнительных свойств информационной группы по идентификатору дополнительного свойства и информационной группы
DelInformationGroupPropertyValue in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertyValue()
Удаление значения дополнительного свойства информационной группы по идентификатору значения дополнительного свойства
DelInformationItemPropertyValue in file InformationSystems.class.php, method InformationSystem::DelInformationItemPropertyValue()
Удаление значения дополнительного свойства информационного элемента
DelInformationSystem in file InformationSystems.class.php, method InformationSystem::DelInformationSystem()
Удаление информационной системы
DelIp in file ip.class.php, method ip::DelIp()
Удаление информации об IP-адресе
DelMaillist in file Maillist.class.php, method Maillist::DelMaillist()
Удаление рассылки
DelMessage in file Forums.class.php, method Forums::DelMessage()
Метод удаления сообщения темы
DelPollsGroup in file Polls.class.php, method polls::DelPollsGroup()
Метод удаления групп опросов
DelStatInfomationForSite in file Counter.class.php, method counter::DelStatInfomationForSite()
Удаление статистической информации для сайта
DelStructurePropertys in file Structure.class.php, method Structure::DelStructurePropertys()
Метод удаления дополнительного свойства
DelStructurePropertysValue in file Structure.class.php, method Structure::DelStructurePropertysValue()
Метод удаления значений дополнительных свойств из таблицы связи
DelTemplatesGroup in file Templates.class.php, method templates::DelTemplatesGroup()
Метод удаления группы макетов
DelTheme in file Forums.class.php, method Forums::DelTheme()
Удаление темы форума
DelUserGroup in file Site_users.class.php, method SiteUsers::DelUserGroup()
Удаление группы пользователей заданной идентификатором
del_alias in file Site.class.php, method site::del_alias()
Метод преобразования алиаса (домена) сайта в основной
del_comment in file InformationSystems.class.php, method InformationSystem::del_comment()
Удаление комментария к информационному элементу
del_data_templates in file Templates.class.php, method templates::del_data_templates()
Метод удаления шаблона страниц
del_dir in file FileManager.class.php, method FileManager::del_dir()
Удаление директории вместе с вложенными файлами и директориями.
del_documents in file Documents.class.php, method documents::del_documents()
Удаления документов
del_documents_dir in file Documents.class.php, method documents::del_documents_dir()
Удаление разделов документов
del_file in file FileManager.class.php, method FileManager::del_file()
Удаление файла или директории
del_information_groups in file InformationSystems.class.php, method InformationSystem::del_information_groups()
Удаление информационной группы
del_information_items in file InformationSystems.class.php, method InformationSystem::del_information_items()
Удаление элемента информационной системы
del_information_propertys in file InformationSystems.class.php, method InformationSystem::del_information_propertys()
Удаление дополнительного свойства элементов информационной системы
del_lists in file Lists.class.php, method lists::del_lists()
Удаление списка
del_lists_items in file Lists.class.php, method lists::del_lists_items()
Удаление элемента списка
del_module in file Modules.class.php, method modules::del_module()
Метод удаления информации о модуле
del_poll in file Polls.class.php, method polls::del_poll()
Метод удаления опроса
del_poll_reply in file Polls.class.php, method polls::del_poll_reply()
Метод удаления варианта ответа
del_site in file Site.class.php, method site::del_site()
Удаление информации о сайте
del_templates in file Templates.class.php, method templates::del_templates()
Метод удаления макета
del_user in file UserAccess.class.php, method user_access::del_user()
Метод удаления пользователя
del_user_type in file UserAccess.class.php, method user_access::del_user_type()
Метод удаления типа пользователей
del_xsl in file Xsl.class.php, method xsl::del_xsl()
Метод удаления XSL-шаблона
del_xsl_dir in file Xsl.class.php, method xsl::del_xsl_dir()
Метод удаления XSL-раздела
Diagramm in file Graphic.class.php, method graphic::Diagramm()
Метод для рисования диаграммы
DIAGRAMM_LIMIT | in file Counter.php, constant DIAGRAMM_LIMIT
DIAGRAMM_WIDTH | in file Counter.php, constant DIAGRAMM_WIDTH
DisableAffiliatePlanToShop in file affiliate.class.php, method affiliate::DisableAffiliatePlanToShop()
Удаление ассоциации партнерской программы магазину
DisableModule in file Cache.class.php, method Cache::DisableModule()
Служебный метод, вызываемый при отключении модуля.
documents in file Documents.class.php, class documents
Система управления сайтом HostCMS v. 5.xx
Documents.class.php | procedural page Documents.class.php
Documents.php | procedural page Documents.php
DoReplaces in file admin_forms.class.php, method admin_forms::DoReplaces()
Подстановка стандартных значений полей
Download in file File.class.php, method File::Download()
Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла
do_html_footer_admin in file admin_output.fns.php, function do_html_footer_admin()
Функция выводит "подвал" для страниц раздела администрирования
do_html_header_admin in file admin_output.fns.php, function do_html_header_admin()
Функция выводит "шапку" для страниц раздела администрирования
DrawAlphaPixel in file Graphic.class.php, method graphic::DrawAlphaPixel()
Метод для рисования точек с оттенком
DrawFilledRectangle in file Graphic.class.php, method graphic::DrawFilledRectangle()
Метод для рисования заполненного прямоугольника
DrawFilledRoundedRectangle in file Graphic.class.php, method graphic::DrawFilledRoundedRectangle()
Метод для рисования заполненного округленного прямоугольника
DrawLegend in file Graphic.class.php, method graphic::DrawLegend()
Метод для рисования легенды
DrawLegend_linear in file Graphic.class.php, method graphic::DrawLegend_linear()
Метод рисует легенду для линейной диаграммы
DrawLine in file Graphic.class.php, method graphic::DrawLine()
Метод для рисования линий поточечно
DrawPixel in file Graphic.class.php, method graphic::DrawPixel()
Метод для рисования точек
DrawRectangle in file Graphic.class.php, method graphic::DrawRectangle()
Метод для рисования незаполненого прямоугольника
DrawRoundedRectangle in file Graphic.class.php, method graphic::DrawRoundedRectangle()
Метод для рисования незаполненного округленного прямоугольника.
DrawStatusReport in file seo.class.php, method Seo::DrawStatusReport()
Графическое отображение статуса наличия счетчиков и страницы в каталогах в отчете
Date.class.php | procedural page Date.class.php
top
e
$email_login in file Mail.class.php, variable Mail::$email_login
Имя ящика (Логин)
$email_password in file Mail.class.php, variable Mail::$email_password
Пароль ящика пользователя
$encoding in file RssRead.class.php, variable RssRead::$encoding
Внутренняя кодировка, используемая при работе с RSS
$error | in file Modules.class.php, variable modules::$error
$error | in file shop.class.php, variable shop::$error
$error | in file Templates.class.php, variable templates::$error
$export_csv in file admin_forms.class.php, variable admin_forms::$export_csv
Флаг экспорта в CSV
$external_html in file admin_forms_fields.class.php, variable admin_forms_fields::$external_html
Свойство, содержащее html-код, дописываемый после отображения формы
$external_replaces in file admin_forms.class.php, variable admin_forms::$external_replaces
Массив внешнех подстановок, применяется в DoReplaces()
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
eacceleratorClearCache in file Cache.class.php, method Cache::eacceleratorClearCache()
Очистка кэша $cache_name и элемента $item_name в eAccelerator
eacceleratorGetCountItem in file Cache.class.php, method Cache::eacceleratorGetCountItem()
Определение количества элементов в кэше для eaccelerator
EdZero in file seo.class.php, method Seo::EdZero()
Заменяет "млн" и "тыс" на соответствующее количество нулей
email_encode_js in file Security.fns.php, function email_encode_js()
Публикует с помощью JavaScript ссылку на эл.почту, защищенную от индексации ботами
EnableAffiliatePlanToShop in file affiliate.class.php, method affiliate::EnableAffiliatePlanToShop()
Добавление ассоциации партнерской программы магазину
EraseOpticalAlignment in file typograph.class.php, method typograph::EraseOpticalAlignment()
Метод для удаления тегов предыдущего оптического выравнивания
EventsJournal in file EventsJournal.class.php, class EventsJournal
Система управления сайтом HostCMS v. 5.xx
EventsJournal.class.php | procedural page EventsJournal.class.php
EventsJournal.php | procedural page EventsJournal.php
en.php | procedural page en.php
EventsJournalAdmin in file EventsJournal.class.php, class EventsJournalAdmin
Класс модуля "Журнал событий"
EventsMail in file EventsJournal.class.php, method EventsJournalAdmin::EventsMail()
Метод отправки письма с отчетом
ExecDump in file ExecSqlQuery.class.php, method ExecSqlQuery::ExecDump()
Выполнение SQL-запроса
ExecSqlQuery in file ExecSqlQuery.class.php, class ExecSqlQuery
Система управления сайтом HostCMS v. 5.xx
ExecSqlQuery.class.php | procedural page ExecSqlQuery.class.php
ExecSqlQuery.php | procedural page ExecSqlQuery.php
en.php | procedural page en.php
ExecSystemsOfPayChangeStatus in file shop.class.php, method shop::ExecSystemsOfPayChangeStatus()
Метод выполнения обработчика платежной системы для смены статуса заказа
ExecSystemsOfPayHandler in file shop.class.php, method shop::ExecSystemsOfPayHandler()
Метод выполнения обработчика платежной системы
ExecuteUsersEvents in file admin_forms.class.php, method admin_forms::ExecuteUsersEvents()
Вызов пользовательских ф-ций (событий)
exif_imagetype | in file Kernel.php, function exif_imagetype()
ExternalXml in file ExternalXml.class.php, class ExternalXml
Система управления сайтом HostCMS v. 5.xx
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
Error.fns.php | procedural page Error.fns.php
EventsJournal.class.php | procedural page EventsJournal.class.php
ExternalXml.class.php | procedural page ExternalXml.class.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
top
f
$fields | in file admin_forms_fields.class.php, variable admin_forms_fields::$fields
$flag | in file ExternalXml.class.php, variable ExternalXml::$flag
$float_format in file shop.class.php, variable shop::$float_format
Формат для this->Round()
$fonts_dir in file Captcha.class.php, variable Captcha::$fonts_dir
Путь к шрифтам
$font_name in file Graphic.class.php, variable graphic::$font_name
Название шрифта
$font_path in file Graphic.class.php, variable graphic::$font_path
Путь к шрифту
$font_size in file Graphic.class.php, variable graphic::$font_size
Размер шрифта
$font_width in file Graphic.class.php, variable graphic::$font_width
Ширина одного символа в легенде
$form_params in file admin_forms.class.php, variable admin_forms::$form_params
Свойство с параметрами формы
$form_params in file admin_forms_fields.class.php, variable admin_forms_fields::$form_params
Свойство с параметрами формы
File in file File.class.php, class File
Система управления сайтом HostCMS v. 5.xx
FileClearCache in file Cache.class.php, method Cache::FileClearCache()
Очистка кэша в файле
FileDeleteCacheItem in file Cache.class.php, method Cache::FileDeleteCacheItem()
Метод удаляет элемент с именем $item_name из кэша $cache_name в файле
FileGetCountItem in file Cache.class.php, method Cache::FileGetCountItem()
Определение количества элементов в кэше для файлов
FileManager in file FileManager.class.php, class FileManager
Класс модуля "Файловый менеджер"
FileManager.class.php | procedural page FileManager.class.php
FileManager.php | procedural page FileManager.php
FillItemCountForWarehouse | in file warehouse.class.php, method warehouse::FillItemCountForWarehouse()
FillMasGroup in file InformationSystems.class.php, method InformationSystem::FillMasGroup()
Формирование массива групп для информационной системы (MasGroup) и массива дерева идентификаторов групп (FullCacheGoupsIdTree).
FillMasGroup in file shop.class.php, method shop::FillMasGroup()
Метод формирования массива групп верхнего уровня для данного магазина
FillMasGroupDirExtProperty in file shop.class.php, method shop::FillMasGroupDirExtProperty()
Заполнение массива групп дополнительных свойств групп товаров
FillMasGroupExtProperty in file shop.class.php, method shop::FillMasGroupExtProperty()
Метод формирования массива групп дополнительных свойств товара самого верхнего уровня для данного магазина
FillMasGroupExtProperty in file InformationSystems.class.php, method InformationSystem::FillMasGroupExtProperty()
Формирование массива групп дополнительных свойств информационных элементов самого верхнего уровня для данной информационной системы
FillMasGroupProperty in file InformationSystems.class.php, method InformationSystem::FillMasGroupProperty()
Заполнение массива групп дополнительных свойств групп информационных элементов
FillMemCacheComments in file shop.class.php, method shop::FillMemCacheComments()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCacheCountItemsAndGroup in file InformationSystems.class.php, method InformationSystem::FillMemCacheCountItemsAndGroup()
Определение числа подгрупп и элементов, содержащихся в группах информационной системы
FillMemCacheCountItemsAndGroup in file shop.class.php, method shop::FillMemCacheCountItemsAndGroup()
Внутренний метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.
FillMemCacheDiscountsForItem in file shop.class.php, method shop::FillMemCacheDiscountsForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.
FillMemCacheGetAllPricesForItem in file shop.class.php, method shop::FillMemCacheGetAllPricesForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров ценами для групп товаров. Заполнению подвергается массив $this->CacheGetSpecialPricesForItem[$shop_items_catalog_item_id]
FillMemCacheGetTagRelation in file tag.class.php, method Tag::FillMemCacheGetTagRelation()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров соответствиями тегов.
FillMemCacheGoupsIdTree in file shop.class.php, method shop::FillMemCacheGoupsIdTree()
Внутренний метод формирует дерево групп и подгрупп в массиве по их идентификаторам. Заполянется также в методе FillMasGroup()
FillMemCacheItems in file shop.class.php, method shop::FillMemCacheItems()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров товаров. Заполнению подвергается массив $this->CacheGetItem[$shop_items_catalog_item_id]
FillMemCacheModificationItems in file shop.class.php, method shop::FillMemCacheModificationItems()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCachePriceForItem in file shop.class.php, method shop::FillMemCachePriceForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров ценами для товаров. Заполнению подвергается массив $this->CacheGetPriceForItem[$shop_list_of_prices_id . '_' . $shop_items_catalog_item_id]
FillMemCachePropertiesItem in file shop.class.php, method shop::FillMemCachePropertiesItem()
Внутренний метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.
FillMemCachePropertysGroup in file shop.class.php, method shop::FillMemCachePropertysGroup()
Метод формирует в памяти данные о свойствах групп магазина.
FillMemCachePropertysGroup in file InformationSystems.class.php, method InformationSystem::FillMemCachePropertysGroup()
Формирование в памяти данных о свойствах групп информационной системы.
FillMemCacheSpecialPricesForItem in file shop.class.php, method shop::FillMemCacheSpecialPricesForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров специальными ценами. Заполнению подвергается массив $this->CacheGetSpecialPricesForItem [$shop_items_catalog_item_id]
FillMemCacheTyingProducts in file shop.class.php, method shop::FillMemCacheTyingProducts()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemFullCacheGoupsIdTree in file InformationSystems.class.php, method InformationSystem::FillMemFullCacheGoupsIdTree()
Формирование дерева групп и подгрупп в массиве по их идентификаторам
fill_xsl_dir in file Xsl.class.php, method xsl::fill_xsl_dir()
Метод формирования дерева разделов
flush | in file File.class.php, method File::flush()
FormatGetCart in file shop.class.php, method shop::FormatGetCart()
Преобразование массива корзины при извлечении
FormatSetCart in file shop.class.php, method shop::FormatSetCart()
Преобразование массива корзины при записи
FormatXml in file Xsl.class.php, method xsl::FormatXml()
Форматирование XML-документа
Forms in file Forms.class.php, class Forms
Класс модуля "Формы"
Forms.class.php | procedural page Forms.class.php
Forms.php | procedural page Forms.php
Forums in file Forums.class.php, class Forums
Класс модуля "Форумы"
Forums | in file Forums.class.php, method Forums::Forums()
Forums.class.php | procedural page Forums.class.php
Forums.php | procedural page Forums.php
function_enabled in file Kernel.class.php, method kernel::function_enabled()
Определение доступности php-функции
File.class.php | procedural page File.class.php
top
g
$GetAllItemTotalCount in file shop.class.php, variable shop::$GetAllItemTotalCount
Свойство содержит информацию об общем количестве товаров, выбранных методом GetAllItems()
$GetAllProducersTotalCount in file shop.class.php, variable shop::$GetAllProducersTotalCount
Свойство содержит информацию об общем количестве производителей, выбранных методом GetAllProducers()
$GET_LOCK_timeout in file Kernel.php, variable Session::$GET_LOCK_timeout
Таймаут для GET_LOCK, в секундах
GenAddEditThemeXML in file Forums.class.php, method Forums::GenAddEditThemeXML()
УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
GenCmlId in file shop.class.php, method shop::GenCmlId()
Генерация идентификатора в формате CommerceML для группы товаров
GenEditMessageXML in file Forums.class.php, method Forums::GenEditMessageXML()
УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
GenerateKeyString in file Captcha.class.php, method Captcha::GenerateKeyString()
Генерация строки CAPTCHA
GenGroupXmlTree in file InformationSystems.class.php, method InformationSystem::GenGroupXmlTree()
Формирование полного XML дерева информационных групп для информационной системы
GenMessageXML in file Forums.class.php, method Forums::GenMessageXML()
Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном
GenSmilesXML in file Forums.class.php, method Forums::GenSmilesXML()
Метод возвращает XML для смайликов
GenUserInfoXML in file Forums.class.php, method Forums::GenUserInfoXML()
УСТАРЕВШИЙ Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном
GenXml in file ExternalXml.class.php, method ExternalXml::GenXml()
Генерация XML для переданного массива
GenXML4AffiliatePlan in file affiliate.class.php, method affiliate::GenXML4AffiliatePlan()
Генерация XML-данных для партнерских программ магазина
GenXML4AffiliateValues in file affiliate.class.php, method affiliate::GenXML4AffiliateValues()
Генерация XML для уровней партнерской программы
GenXml4Comment in file shop.class.php, method shop::GenXml4Comment()
Метод генерирующий XML для отзыва о товаре
GenXml4Company in file shop.class.php, method shop::GenXml4Company()
Метод генерирует XML для организации
GenXml4CompareItems in file shop.class.php, method shop::GenXml4CompareItems()
Метод генерирует xml для товаров, выбранных для сравнения
GenXML4Currency in file shop.class.php, method shop::GenXML4Currency()
Метод генерирует XML для указанной валюты
GenXml4Helpdesk in file helpdesk.class.php, method helpdesk::GenXml4Helpdesk()
Формирование XML для службы техподдержки
GenXml4InformationSystem in file InformationSystems.class.php, method InformationSystem::GenXml4InformationSystem()
Формирование XML для информационной системы
GenXML4InfSys in file Structure.class.php, method Structure::GenXML4InfSys()
Внутренний метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры. В своей работе использует массивы $this->MassIG, $this->MassII.
GenXml4InsertEditLetters in file Forums.class.php, method Forums::GenXml4InsertEditLetters()
Генерация XML для письма о вставке/редактировании
GenXml4Item in file shop.class.php, method shop::GenXml4Item()
Внутренний метод построения XML для товара, его свойств и сопутствующих товаров
GenXml4ItemCatalogCommentAverageGrade in file shop.class.php, method shop::GenXml4ItemCatalogCommentAverageGrade()
Метод возвращает XML со средней оценкой описания активных отзывов по товару.
GenXml4ItemCatalogComments in file shop.class.php, method shop::GenXml4ItemCatalogComments()
Метод возвращает все комментарии, относящиеся к данному товару.
GenXml4ListItems in file Lists.class.php, method lists::GenXml4ListItems()
Генерация XML для всех элементов списка
GenXML4Message in file Forums.class.php, method Forums::GenXML4Message()
Генерация XML для сообщения
GenXml4Message in file helpdesk.class.php, method helpdesk::GenXml4Message()
Формирование XML для сообщений
GenXml4Mesures in file shop.class.php, method shop::GenXml4Mesures()
Метод генерирует XML для единиц измерения
GenXml4OrderStatus in file shop.class.php, method shop::GenXml4OrderStatus()
Метод генерирует XML для статуса доставки
GenXml4Poll in file Polls.class.php, method polls::GenXml4Poll()
Формирование XML для опроса
GenXML4PriceForShop in file shop.class.php, method shop::GenXML4PriceForShop()
Возвращает XML цены для группы пользователей.
GenXml4Properties in file shop.class.php, method shop::GenXml4Properties()
Метод построения XML для свойств товаров, доступных группе.
GenXml4Property in file shop.class.php, method shop::GenXml4Property()
Возвращает XML свойства.
GenXml4Saller in file shop.class.php, method shop::GenXml4Saller()
Возвращает XML продавца.
GenXml4Sallers in file shop.class.php, method shop::GenXml4Sallers()
Метод построения XML для продавцов.
GenXML4Shop in file Structure.class.php, method Structure::GenXML4Shop()
Внутренний метод построения XML для групп товаров и товаров интернет-магазина при отображении структуры. Использует в своей работе $this->MassShopGroups, $this->MassShopItems
GenXml4Shop in file shop.class.php, method shop::GenXml4Shop()
Метод генерации XML для магазина
GenXML4SpecialPrice in file shop.class.php, method shop::GenXML4SpecialPrice()
Формирование XML для специальных цен товара
GenXml4StructureLevelMass in file Structure.class.php, method Structure::GenXml4StructureLevelMass()
Внутренний метод генерации части XML-а для записей указанного уровня
GenXml4Taxes in file shop.class.php, method shop::GenXml4Taxes()
Формирование XML для налогов
GenXml4Theme in file Forums.class.php, method Forums::GenXml4Theme()
Формирование XML для темы форума
GenXml4Ticket in file helpdesk.class.php, method helpdesk::GenXml4Ticket()
Формирование XML для тикета
GenXml4TicketCategory in file helpdesk.class.php, method helpdesk::GenXml4TicketCategory()
Формирование XML для категорий тикетов
GenXml4WorkTime in file helpdesk.class.php, method helpdesk::GenXml4WorkTime()
Формирование XML для режима работы службы техподдержки
GenXmlAffiliatTree | in file affiliate.class.php, method affiliate::GenXmlAffiliatTree()
GenXmlForGroup in file InformationSystems.class.php, method InformationSystem::GenXmlForGroup()
Генерация XML для группы
GenXmlForGroupsPropertyDir in file InformationSystems.class.php, method InformationSystem::GenXmlForGroupsPropertyDir()
Генерация XML для групп дополнительных свойств групп информационных элементов
GenXmlForGroupsPropertyDir in file shop.class.php, method shop::GenXmlForGroupsPropertyDir()
Генерация XML для групп дополнительных свойств групп товаров
GenXmlForItemsPropertyDir in file shop.class.php, method shop::GenXmlForItemsPropertyDir()
Генерация XML для групп дополнительных свойств
GenXmlForItemsPropertyDir in file InformationSystems.class.php, method InformationSystem::GenXmlForItemsPropertyDir()
Генерация XML для групп дополнительных свойств информационных элементов
GenXmlForSystemOfPays in file shop.class.php, method shop::GenXmlForSystemOfPays()
Генерация XML для списка всех платежных систем.
GenXmlForTag in file tag.class.php, method Tag::GenXmlForTag()
Генерация XML для тега
GenXmlProducerList in file shop.class.php, method shop::GenXmlProducerList()
Метод генерирует XML для списка продавцов магазина
GetAccessItem in file InformationSystems.class.php, method InformationSystem::GetAccessItem()
Определение доступности информационного элемента
GetAccessShopItem in file shop.class.php, method shop::GetAccessShopItem()
Определение доступности товара
GetAdditionalPropertyDirPathArray in file shop.class.php, method shop::GetAdditionalPropertyDirPathArray()
Получение пути от текущего каталога дополнительных свойств товара к корневому
GetAdditionalPropertyPathArray in file InformationSystems.class.php, method InformationSystem::GetAdditionalPropertyPathArray()
Построение пути от конкретной группы дополнительных свойств информационных элементов до корня
GetAdditionalPropertyPathArray in file shop.class.php, method shop::GetAdditionalPropertyPathArray()
Получение пути от текущего каталога дополнительных свойств товара к корневому
GetAdditionalPropertyPathArrayGroup in file InformationSystems.class.php, method InformationSystem::GetAdditionalPropertyPathArrayGroup()
Построение пути от конкретной группы дополнительных свойств информационных групп до корня
GetAdminForm in file admin_forms.class.php, method admin_forms::GetAdminForm()
Получение данных о форме центра управления.
GetAdminFormsEvent in file admin_forms.class.php, method admin_forms::GetAdminFormsEvent()
Получение информации о событии (действии) формы центра администрирования
GetAdminFormsEventByName in file admin_forms.class.php, method admin_forms::GetAdminFormsEventByName()
Получение информации о событии (действии) формы центра администрирования по идентификатору формы и псевдониму действия
GetAdminFormsField in file admin_forms.class.php, method admin_forms::GetAdminFormsField()
Извлечение информации о поле формы центра администрирования
GetAdminFormsWord in file admin_forms.class.php, method admin_forms::GetAdminFormsWord()
Получение названия и описания слова на выбранном языке
GetAdminFormsWordOrDefaultLanguageWord in file admin_forms.class.php, method admin_forms::GetAdminFormsWordOrDefaultLanguageWord()
Получение названия и описания слова на выбранном языке. Если для выбранного языка не найдено значение, получается значения для языка "по умолчанию".
GetAdvertisement in file Advertisement.class.php, method Advertisement::GetAdvertisement()
Получение данных об элементе (баннере, всплывающем окне и т.п.)
GetAffiliate in file affiliate.class.php, method affiliate::GetAffiliate()
Получение информации об аффилиате
GetAffiliatePlans in file affiliate.class.php, method affiliate::GetAffiliatePlans()
Получение информации о плане аффилиата
GetAffiliatePlansIdForShop in file affiliate.class.php, method affiliate::GetAffiliatePlansIdForShop()
Получение идентификаторов всех парнерских программ для магазина
GetAffiliateValues in file affiliate.class.php, method affiliate::GetAffiliateValues()
Получение информации о комисии
getAffiliatInnerLevelForUser | in file affiliate.class.php, method affiliate::getAffiliatInnerLevelForUser()
GetAffiliatsForUser in file affiliate.class.php, method affiliate::GetAffiliatsForUser()
Получение массива идентификаторов аффилиатов пользователя
GetAlias in file Site.class.php, method site::GetAlias()
Получение данных об алиасе сайта
GetAliasById in file Site.class.php, method site::GetAliasById()
Метод возвращает информацию об алиасе (домене)
GetAllAdminFormEvents in file admin_forms.class.php, method admin_forms::GetAllAdminFormEvents()
Получение списка всех событий формы администрирования
GetAllAdminFormFields in file admin_forms.class.php, method admin_forms::GetAllAdminFormFields()
Получение списка всех полей формы администрирования
GetAllAdvertisementForSite in file Advertisement.class.php, method Advertisement::GetAllAdvertisementForSite()
Получаем список всех групп баннеров заданного сайта
GetAllAffiliatePlans in file affiliate.class.php, method affiliate::GetAllAffiliatePlans()
Получение всех партнерских программ
GetAllAffiliateValuesForAffiliate in file affiliate.class.php, method affiliate::GetAllAffiliateValuesForAffiliate()
Получение всех уровней партнерской программы
GetAllAlias in file Site.class.php, method site::GetAllAlias()
Метод возвращает информацию обо всех доменах
GetAllAttachments in file helpdesk.class.php, method helpdesk::GetAllAttachments()
Получение вложенных файлов сообщения
GetAllBanners in file Advertisement.class.php, method Advertisement::GetAllBanners()
Получение информации обо всех баннерах сайта или обо всех баннерах
GetAllBlockedMessages in file helpdesk.class.php, method helpdesk::GetAllBlockedMessages()
Получение всех заблокированных сообщений тикета
GetAllCity in file shop.class.php, method shop::GetAllCity()
Получение списка городов
GetAllCityArea in file shop.class.php, method shop::GetAllCityArea()
Метод выборки всех районов города
GetAllComments in file shop.class.php, method shop::GetAllComments()
Метод возвращает список всех комментариев
GetAllCompanies in file shop.class.php, method shop::GetAllCompanies()
Метод для получения списка всех компаний
GetAllCondOfDelivery in file shop.class.php, method shop::GetAllCondOfDelivery()
Метод выборки всех условий доставки
GetAllConferences in file Forums.class.php, method Forums::GetAllConferences()
Получение информации о всех конференциях сайт.
GetAllConstants in file Constants.class.php, method Constants::GetAllConstants()
Получение данных обо всех константах
GetAllContextualWords in file Advertisement.class.php, method Advertisement::GetAllContextualWords()
Получение информации о контекстных фразах для баннера
GetAllCountries in file shop.class.php, method shop::GetAllCountries()
Метод, осуществляющий извлечение всех стран
GetAllCoupons in file shop.class.php, method shop::GetAllCoupons()
Метод возвращает список купонов по заданным условиям
GetAllCriticalLevel in file helpdesk.class.php, method helpdesk::GetAllCriticalLevel()
Получение информации обо всех уровнях критичности. Если передан параметр $helpdesk_id, то выбираются уровни критичности службы техподдержки с id $helpdesk_id
GetAllCurrency in file shop.class.php, method shop::GetAllCurrency()
Метод выборки информации обо всех валютах
GetAllDataTemplates in file Templates.class.php, method templates::GetAllDataTemplates()
Метод для получения списка шаблонов страниц текущего сайта
GetAllDataTemplatesGroups in file Templates.class.php, method templates::GetAllDataTemplatesGroups()
Метод для получения информации обо всех группах шаблонов сайта
GetAllDiscounts in file shop.class.php, method shop::GetAllDiscounts()
Метод возвращает список всех скидок
GetAllDiscountsForItem in file shop.class.php, method shop::GetAllDiscountsForItem()
Метод извлечения информации обо всех скидках для данного товара
GetAllEmail in file helpdesk.class.php, method helpdesk::GetAllEmail()
Получение информации обо всех электронных адресах службы техподдержки
GetAllEvents in file admin_forms.class.php, method admin_forms::GetAllEvents()
Получение списка всех событий формы центра администрирования
GetAllFascicle in file Maillist.class.php, method Maillist::GetAllFascicle()
Получение списка всех выпусков рассылки
GetAllFascicleFiles in file Maillist.class.php, method Maillist::GetAllFascicleFiles()
Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки
GetAllFlags in file helpdesk.class.php, method helpdesk::GetAllFlags()
Получение списка флагов
GetAllForms in file Forms.class.php, method Forms::GetAllForms()
Получение информации о всех формах
GetAllForums in file Forums.class.php, method Forums::GetAllForums()
Метод для получения всех форумов
GetAllForumsGroup in file Forums.class.php, method Forums::GetAllForumsGroup()
Метод для получения списка всех групп
GetAllGroups in file shop.class.php, method shop::GetAllGroups()
Получение всех групп магазина
GetAllHelpdesk in file helpdesk.class.php, method helpdesk::GetAllHelpdesk()
Получение информации обо всех службах техподдержки на конкретном сайте. Если параметр $site_id не передан, или равен false - выбирается информация обо всех службах техподдержки.
GetAllInformationGroups in file InformationSystems.class.php, method InformationSystem::GetAllInformationGroups()
Получение информации об информационных группах
GetAllInformationGroupsPropertys in file InformationSystems.class.php, method InformationSystem::GetAllInformationGroupsPropertys()
Получение данных о дополнительных свойствах информационных групп
GetAllInformationItemsPropertys in file InformationSystems.class.php, method InformationSystem::GetAllInformationItemsPropertys()
Получение данных о дополнительных свойствах элементов информационной системы
GetAllInformationSystems in file InformationSystems.class.php, method InformationSystem::GetAllInformationSystems()
Получение информации о инфосистемах
GetAllInformationSystemsDirs in file InformationSystems.class.php, method InformationSystem::GetAllInformationSystemsDirs()
Получение информации о разделах информационных систем
GetAllInformationSystemsFromDir in file InformationSystems.class.php, method InformationSystem::GetAllInformationSystemsFromDir()
Получение информации о информационных системах раздела
GetAllItems in file shop.class.php, method shop::GetAllItems()
Получение всех товаров заданного магазина и заданной группы товаров
GetAllItemsForOrder in file shop.class.php, method shop::GetAllItemsForOrder()
Получение заказанных товаров
GetAllItemWarehouses in file warehouse.class.php, method warehouse::GetAllItemWarehouses()
Получение всех складов, которым принадлежит товар
GetAllJs in file Kernel.class.php, method kernel::GetAllJs()
Получения списка внешних JavaScript файлов
GetAllLanguages in file admin_forms.class.php, method admin_forms::GetAllLanguages()
Извлечение всех языков
GetAllLibDirs in file lib.class.php, method lib::GetAllLibDirs()
Получение списка директорий типовых дин. страниц
GetAllLibProperties in file lib.class.php, method lib::GetAllLibProperties()
Получение списка всех дополнительных параметров типовой динамической страницы
GetAllLibPropertyListItems in file lib.class.php, method lib::GetAllLibPropertyListItems()
Получение списка элеметов параметра типовой динамической страницы типа "Список"
GetAllLibs in file lib.class.php, method lib::GetAllLibs()
Получение списка типовых динамических страниц
GetAllListDirs in file Lists.class.php, method lists::GetAllListDirs()
Получение информации о разделах списков
GetAllListProperties in file shop.class.php, method shop::GetAllListProperties()
Получение всех дополнительных свойств для магазина
GetAllListsForSite in file Lists.class.php, method lists::GetAllListsForSite()
Получение списков определенного сайта
GetAllLocation in file shop.class.php, method shop::GetAllLocation()
Получение списка всех областей (штатов)
GetAllMaillistsForSite in file Maillist.class.php, method Maillist::GetAllMaillistsForSite()
Получение списка почтовых рассылок заданного сайта
GetAllMaillistUsers in file Maillist.class.php, method Maillist::GetAllMaillistUsers()
Получение списка связей пользователей с рассылкой
GetAllMaillistUsersGroup in file Maillist.class.php, method Maillist::GetAllMaillistUsersGroup()
Получение списка групп пользователей, подписанных на рассылку
GetAllMessage in file helpdesk.class.php, method helpdesk::GetAllMessage()
Получение списка сообщений, относящихся к тикету с идентификатором $helpdesk_ticket_id. Если задан параметр $helpdesk_message_id, выбираются все сообщения, кроме сообщения с id $helpdesk_message_id.
GetAllMessages in file Forums.class.php, method Forums::GetAllMessages()
Метод для получения всех сообщений
GetAllMessageWithParentId in file helpdesk.class.php, method helpdesk::GetAllMessageWithParentId()
Получение списка сообщений, дочерних по отношению к сообщению с id $helpdesk_message_parent_id
GetAllMesures in file shop.class.php, method shop::GetAllMesures()
Метод выборки всех единиц измерения
GetAllModificationItems in file shop.class.php, method shop::GetAllModificationItems()
Метод возвращает информацию обо всех модификациях данного товара
GetAllOrderDiscounts in file shop.class.php, method shop::GetAllOrderDiscounts()
Метод для извлечения информации обо всех скидках
GetAllOrders in file shop.class.php, method shop::GetAllOrders()
Метод выборки заказов для магазина
GetAllOrderStatus in file shop.class.php, method shop::GetAllOrderStatus()
Получение информации обо всех статусах заказаов
GetAllPollReply in file Polls.class.php, method polls::GetAllPollReply()
Получение списка всех ответов на опрос
GetAllPolls in file Polls.class.php, method polls::GetAllPolls()
Получение информации обо всех опросах
GetAllPollsGroups in file Polls.class.php, method polls::GetAllPollsGroups()
Получение информации о всех группах опросов
GetAllPricesForItem in file shop.class.php, method shop::GetAllPricesForItem()
Получение информации о ценах, заданных для товара
GetAllPricesForShop in file shop.class.php, method shop::GetAllPricesForShop()
Получение списка цен для магазина
GetAllProducers in file shop.class.php, method shop::GetAllProducers()
Получение информации обо всех производителях
GetAllPropertiesGroup in file shop.class.php, method shop::GetAllPropertiesGroup()
Метод извлечения информации о дополнительных свойствах группы товаров
GetAllPropertiesGroupsDirForDir in file shop.class.php, method shop::GetAllPropertiesGroupsDirForDir()
Получаем список всех групп дополнительных свойств групп товаров
GetAllPropertiesGroupsDirForShop in file shop.class.php, method shop::GetAllPropertiesGroupsDirForShop()
Получение инфомации обо всех группах дополнительных свойств групп товаров конкретного магазина
GetAllPropertiesItem in file shop.class.php, method shop::GetAllPropertiesItem()
Метод извлечения информации о дополнительных свойствах заданного товара
GetAllPropertiesItemsDirForShop in file shop.class.php, method shop::GetAllPropertiesItemsDirForShop()
Получение информации обо всех группах дополнительных свойств товара для конкретного магазина
GetAllPropertiesItemsForDir in file shop.class.php, method shop::GetAllPropertiesItemsForDir()
Получение информации обо всех свойствах хранящихся в конкретной группе дополнительных свойств конкртеного магазина
GetAllPropertyGroupsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::GetAllPropertyGroupsDirForInformationSystem()
Получение информации о всех группах дополнительных свойств групп информационных элементов конкретной информационной системы
GetAllPropertysItemsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::GetAllPropertysItemsDirForInformationSystem()
Получение информации обо всех группах дополнительных свойств информационных элементов конкретной информационной системы
GetAllPropretyOfGroup in file shop.class.php, method shop::GetAllPropretyOfGroup()
Получение информации о ВСЕХ дополнительных свойствах групп магазина
GetAllQuery in file seo.class.php, method Seo::GetAllQuery()
Получение списка поисковых запросов
GetAllResponsible in file helpdesk.class.php, method helpdesk::GetAllResponsible()
Получение информации обо всех ответственных лицах
GetAllSellers in file shop.class.php, method shop::GetAllSellers()
Получение информации о всех продавцах магазина $shop_id, если $shop_id = false, то о продавцах всех магазинов
GetAllSession in file Counter.class.php, method counter::GetAllSession()
Определение числа сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"
GetAllShops in file shop.class.php, method shop::GetAllShops()
Метод для получения списка всех магазинов
GetAllShopsDirs in file shop.class.php, method shop::GetAllShopsDirs()
Получение информации о разделах интернет-магазинов
GetAllShopsFromDir in file shop.class.php, method shop::GetAllShopsFromDir()
Получение информации о интернет-магазинах раздела
GetAllSiteUserAccountTransaction in file shop.class.php, method shop::GetAllSiteUserAccountTransaction()
Метод возвращает данные обо всех транзакциях пользователя сайта
GetAllSpecialPricesForItem in file shop.class.php, method shop::GetAllSpecialPricesForItem()
Получение информации о всех специальных ценах товара
GetAllStatus in file helpdesk.class.php, method helpdesk::GetAllStatus()
Получение списка статусов. Если передан параметр $helpdesk_id, то выбираются сообщения, относящиеся к службе техподдержки с идентификатором $helpdesk_id
GetAllStructure in file Structure.class.php, method Structure::GetAllStructure()
Метод для получения списка всех узлов структуры сайта
GetAllStructureProperties in file Structure.class.php, method Structure::GetAllStructureProperties()
Метод для получения списка всех доп. свойств структуры
GetAllStructurePropertyValuesOfProperty in file Structure.class.php, method Structure::GetAllStructurePropertyValuesOfProperty()
Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства
GetAllSystemOfPay in file shop.class.php, method shop::GetAllSystemOfPay()
Получение всех активных платежных систем
GetAllTags in file tag.class.php, method Tag::GetAllTags()
Получение информации о тегах
GetAllTagsGroups in file tag.class.php, method Tag::GetAllTagsGroups()
Получение информации о группах меток
GetAllTax in file shop.class.php, method shop::GetAllTax()
Получение информации о налогах
GetAllTemplate in file helpdesk.class.php, method helpdesk::GetAllTemplate()
Получение списка стандартных ответов службы техподдержки. Если передан параметр $helpdesk_letter_template_dir_id, выбираются все стандартные ответы, принадлежащие категории с этим идентификатором
GetAllTemplateDir in file helpdesk.class.php, method helpdesk::GetAllTemplateDir()
Получение списка групп стандартных ответов.
GetAllTemplateDirWithParentId in file helpdesk.class.php, method helpdesk::GetAllTemplateDirWithParentId()
Получение списка директорий стандартных ответов, вложенных в директорию с идентификатором $helpdesk_letter_template_dir_parent_id
GetAllTemplateKeyWords in file helpdesk.class.php, method helpdesk::GetAllTemplateKeyWords()
Получение списка всех ключевых слов, относящихся к шаблонному ответу с id $helpdesk_letter_template_id. Если $helpdesk_letter_template_id не задан, или равен 0, выбираются абсолютно все ключевые слова
GetAllTemplates in file Templates.class.php, method templates::GetAllTemplates()
Метод для получения списка макетов текущего сайта
GetAllTemplatesGroups in file Templates.class.php, method templates::GetAllTemplatesGroups()
Получение информации о всех группах макетов
GetAllTemplateWithDirId in file helpdesk.class.php, method helpdesk::GetAllTemplateWithDirId()
Получение списка стандартных ответов, относящихся к директории стандартных ответов с идентификатором $helpdesk_letter_template_dir_id
GetAllTicket in file helpdesk.class.php, method helpdesk::GetAllTicket()
Получение информации обо всех инцидентах конкретной службы техподдержки (если передан параметр $helpdesk_id), или конкретной категории (если передан параметр $helpdesk_ticket_category_id). Если параметры не переданы, выбирается информация обо всех инцидентах
GetAllTicketCategory in file helpdesk.class.php, method helpdesk::GetAllTicketCategory()
Получение информации о категориях инцидентов. Если передан параметр helpdesk_id, выбираются категории, принадлежащие службе техподдержки с id helpdesk_id. Если передан параметр $helpdesk_ticket_category_parent_id, выбираются категории вложенные в категорию с id $helpdesk_ticket_category_parent_id.
GetAllTicketFlag in file helpdesk.class.php, method helpdesk::GetAllTicketFlag()
Получение информации обо всех флагах тикетов
GetAllTypeOfDelivery in file shop.class.php, method shop::GetAllTypeOfDelivery()
Метод выборки всех типов доставки для конкретного магазина
GetAllUsers in file helpdesk.class.php, method helpdesk::GetAllUsers()
Получение информации обо всех пользователях центра администрирования данного сайта
GetAllUsers in file Site_users.class.php, method SiteUsers::GetAllUsers()
Получение информации о всех пользователях сайта
GetAllUsers in file UserAccess.class.php, method user_access::GetAllUsers()
Получение данных о всех пользователях центра администрирования
GetAllUsersForAffiliate in file affiliate.class.php, method affiliate::GetAllUsersForAffiliate()
Получение всех пользователей, привлеченных определенным аффилиатом
GetAllUserTypes in file UserAccess.class.php, method user_access::GetAllUserTypes()
Метод возвращает список типов пользователей
GetAllWarehouseItems in file warehouse.class.php, method warehouse::GetAllWarehouseItems()
Получение всех товаров склада
GetAllWarehousesForShop in file warehouse.class.php, method warehouse::GetAllWarehousesForShop()
Получение всех складов магазина
GetAllWeekends in file helpdesk.class.php, method helpdesk::GetAllWeekends()
Получение списка всех специальных рабочих/выходных днях
GetAllWordsByLanguage in file admin_forms.class.php, method admin_forms::GetAllWordsByLanguage()
Извлечения списка слов определенного языка
GetAnswerDate in file helpdesk.class.php, method helpdesk::GetAnswerDate()
Получение даты ответа для тикета
GetAportCatalog in file seo.class.php, method Seo::GetAportCatalog()
Определение наличия страницы в каталоге Апорт
GetArrayAttachment in file helpdesk.class.php, method helpdesk::GetArrayAttachment()
Получение массива с информацией обо всех вложениях сообщения
GetAttachment in file helpdesk.class.php, method helpdesk::GetAttachment()
Получение информации о вложенном файле
GetAttachmentPath in file helpdesk.class.php, method helpdesk::GetAttachmentPath()
Получение полного пути к вложенному файлу
GetBit in file Kernel.class.php, method kernel::GetBit()
Получить бит номер $bit_number числа $int
GetBotsInfo in file Counter.class.php, method counter::GetBotsInfo()
Получение данных о ботах и посещенных ими страницах
getBrowserName | in file Counter.class.php, method counter::getBrowserName()
GetCacheContent in file Cache.class.php, method Cache::GetCacheContent()
Получение данных из кэша
GetCacheSystem in file Cache.class.php, method Cache::GetCacheSystem()
Определение системы кэширования для кэша
GetCaptchaId in file Captcha.class.php, method Captcha::GetCaptchaId()
Метод генерирует и возвращает уникальный индекс для CAPTCHA
GetCart in file shop.class.php, method shop::GetCart()
Извлечение корзины в зависимости от CartType.
GetCatalogItemIdByCmlId in file shop.class.php, method shop::GetCatalogItemIdByCmlId()
Метод возвращает данные о товаре по идентификатору товара стандарта CommerceML
GetCharacteristic in file seo.class.php, method Seo::GetCharacteristic()
Получение характеристики
GetChildrenItemMasDataTemplatesGroup in file Templates.class.php, method templates::GetChildrenItemMasDataTemplatesGroup()
Метод построения поддерева узла дерева
GetChildrenItemMasTemplatesGroup in file Templates.class.php, method templates::GetChildrenItemMasTemplatesGroup()
Метод построения поддерева узла дерева
GetChmod | in file Cache.class.php, method Cache::GetChmod()
GetChmodFile | in file Cache.class.php, method Cache::GetChmodFile()
GetChmodFile in file File.class.php, method File::GetChmodFile()
Получение прав доступа к создаваемым объектом файлов
GetChmodFile in file SiteTemplate.class.php, method SiteTemplate::GetChmodFile()
Получение прав доступа к создаваемым объектом файлов
GetCity in file shop.class.php, method shop::GetCity()
Метод, осуществляющий извлечение города
GetCityArea in file shop.class.php, method shop::GetCityArea()
Получение информации о районе города по идентификатору района
GetCityAreaByName | in file shop.class.php, method shop::GetCityAreaByName()
GetCityByName | in file shop.class.php, method shop::GetCityByName()
GetColor in file Kernel.class.php, method kernel::GetColor()
Создание цвета для некоторого идентификатора.
GetComment in file shop.class.php, method shop::GetComment()
Метод возвращает информацию о комментарии к товару
GetComment in file InformationSystems.class.php, method InformationSystem::GetComment()
Получение информации о комментарии к информационному элементу
GetCommentInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCommentInformationSystemItem()
Получение комментариев информационных элементов
GetCompany in file shop.class.php, method shop::GetCompany()
Метод для получения информации об организации
GetCondOfDelivery in file shop.class.php, method shop::GetCondOfDelivery()
Метод, осуществляющий извлечение условия доставки
GetCondOfDeliveryXml in file shop.class.php, method shop::GetCondOfDeliveryXml()
Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)
GetConference in file Forums.class.php, method Forums::GetConference()
Метод для получения информации о конференции.
GetConferencePath in file Forums.class.php, method Forums::GetConferencePath()
Получение пути к конференции по ее идентификатору
GetConstant in file Constants.class.php, method Constants::GetConstant()
Получение данных о константе
GetConstantByName in file Constants.class.php, method Constants::GetConstantByName()
Получение данных о константе по ее имени
GetConstants in file Constants.class.php, method Constants::GetConstants()
Устаревший метод, не рекомендуется к использованию с версии 5.1.2
GetContextualWords in file Advertisement.class.php, method Advertisement::GetContextualWords()
Получение информации о контекстной фразе
GetCookie in file shop.class.php, method shop::GetCookie()
Загрузка массива данных из cookies
GetCookieCart in file shop.class.php, method shop::GetCookieCart()
Получить содержимое корзины в cookies
GetCookieExpires in file shop.class.php, method shop::GetCookieExpires()
Метод возвращает время истечения данных в корзине, хранящейся в кукисах.
GetCountAllComments in file shop.class.php, method shop::GetCountAllComments()
Получение числа комментариев к товарам
GetCountCity in file shop.class.php, method shop::GetCountCity()
Получение числа городов для области
GetCountCityAreas in file shop.class.php, method shop::GetCountCityAreas()
Получение числа районов города
GetCountCommentInformationItem in file InformationSystems.class.php, method InformationSystem::GetCountCommentInformationItem()
Определение числа комментариев для информационного элемента
GetCountComments in file InformationSystems.class.php, method InformationSystem::GetCountComments()
Получение числа комментариев к информационным элементам
GetCountCondOfDelivery in file shop.class.php, method shop::GetCountCondOfDelivery()
Получение числа условий доставки для типа доставки
GetCountCountry in file shop.class.php, method shop::GetCountCountry()
Получение числа стран
GetCountCurrency in file shop.class.php, method shop::GetCountCurrency()
Получение числа валют в справочнике
GetCountDiscount in file shop.class.php, method shop::GetCountDiscount()
Получение числа скидок для магазина
GetCounterHotLog in file seo.class.php, method Seo::GetCounterHotLog()
Проверка наличия счетчика статистики HotLog
GetCounterInform in file Counter.class.php, method counter::GetCounterInform()
Получение информации о данных счетчика за определенную дату
GetCounterLiveInternet in file seo.class.php, method Seo::GetCounterLiveInternet()
Проверка наличия счетчика статистики LiveInternet
GetCounterMail in file seo.class.php, method Seo::GetCounterMail()
Проверка наличия счетчика статистики Mail
GetCounterRambler in file seo.class.php, method Seo::GetCounterRambler()
Проверка наличия счетчика статистики Rambler
GetCounterSpyLog in file seo.class.php, method Seo::GetCounterSpyLog()
Проверка наличия счетчика статистики SpyLog
GetCounterYandex in file seo.class.php, method Seo::GetCounterYandex()
Проверка наличия счетчика статистики Yandex
GetCountFormsFill in file Forms.class.php, method Forms::GetCountFormsFill()
Получение количества заполнений формы.
GetCountInformationSystem in file InformationSystems.class.php, method InformationSystem::GetCountInformationSystem()
Определение количества инфосистем
GetCountInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCountInformationSystemItem()
Получение количества элементов информационной системы
GetCountItem in file Cache.class.php, method Cache::GetCountItem()
Определение количества элементов в кэше
GetCountItemsAndGroups in file InformationSystems.class.php, method InformationSystem::GetCountItemsAndGroups()
Получение числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()
GetCountItemsAndGroups in file shop.class.php, method shop::GetCountItemsAndGroups()
Получение числа элементов и групп для переданной родительской группы
GetCountItemsCatalog in file shop.class.php, method shop::GetCountItemsCatalog()
Получение числа товаров в одном или во всех разделах магазина
GetCountItemsWithConditions in file shop.class.php, method shop::GetCountItemsWithConditions()
Получение числа товаров, параметры которых удовлетворяют заданным условиям
GetCountLocation in file shop.class.php, method shop::GetCountLocation()
Получение числа областей (штатов) для страны
GetCountMessageTheme in file Forums.class.php, method Forums::GetCountMessageTheme()
Получение количества сообщений в теме
GetCountMesures in file shop.class.php, method shop::GetCountMesures()
Получение числа единиц измерения в справочнике
GetCountOrder in file shop.class.php, method shop::GetCountOrder()
Метод выборки количества заказов для магазина
GetCountOrderStatus in file shop.class.php, method shop::GetCountOrderStatus()
Получение числа статусов заказа
GetCountPolls in file Polls.class.php, method polls::GetCountPolls()
Получение числа опросов в группе
GetCountPollsGroup in file Polls.class.php, method polls::GetCountPollsGroup()
Получение числа групп опросов для одного или всех сайтов
GetCountProducers in file shop.class.php, method shop::GetCountProducers()
Получение числа производителей для данного магазина
GetCountProperties in file shop.class.php, method shop::GetCountProperties()
Получение числа свойств товаров конкретного магазина
GetCountProperty4InformationSystem in file InformationSystems.class.php, method InformationSystem::GetCountProperty4InformationSystem()
Получение числа свойств информационных элементов информационной системы
GetCountProperty4Structure in file Structure.class.php, method Structure::GetCountProperty4Structure()
Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют
GetCountry in file shop.class.php, method shop::GetCountry()
Метод, осуществляющий извлечение страны
GetCountryByName | in file shop.class.php, method shop::GetCountryByName()
GetCountSellers in file shop.class.php, method shop::GetCountSellers()
Получение числа продавцов в справочнике
GetCountShops in file shop.class.php, method shop::GetCountShops()
Получение числа магазинов для одного или всех сайтов, обслуживаемых системой управления
GetCountShowingBanner in file Advertisement.class.php, method Advertisement::GetCountShowingBanner()
Получение количества показов баннера
GetCountShowingBannerAtDay in file Advertisement.class.php, method Advertisement::GetCountShowingBannerAtDay()
Получение количества показов баннера за конкретный день
GetCountSystemOfPay in file shop.class.php, method shop::GetCountSystemOfPay()
Получение числа систем оплаты
GetCountTax in file shop.class.php, method shop::GetCountTax()
Получение числа налогов в справочнике
GetCountTypeOfDelivery in file shop.class.php, method shop::GetCountTypeOfDelivery()
Получение числа типов доставок для данного магазина
GetCountTypePrices in file shop.class.php, method shop::GetCountTypePrices()
Получение числа типов цен для магазина
GetCountUnreadMessages in file messages.class.php, method messages::GetCountUnreadMessages()
Получение количества не прочитанных сообщений
GetCoupon in file shop.class.php, method shop::GetCoupon()
Метод возвращает массив с информацией о купоне
GetCouponByText in file shop.class.php, method shop::GetCouponByText()
Возвращает информацию о купоне по его тексту
GetCriticalLevel in file helpdesk.class.php, method helpdesk::GetCriticalLevel()
Получение информации об уровне критичности
GetCurrency in file shop.class.php, method shop::GetCurrency()
Метод, осуществляющий извлечение информации о валюте
GetCurrencyByInternationalName in file shop.class.php, method shop::GetCurrencyByInternationalName()
Метод для получения списка валют с указанным международным названием
GetCurrencyByLike in file shop.class.php, method shop::GetCurrencyByLike()
Метод, возвращающий информацию о валюте из базы согласно имени $string используя оператор LIKE
GetCurrencyCoefficientToShopCurrency in file shop.class.php, method shop::GetCurrencyCoefficientToShopCurrency()
Метод определения коэффициента пересчета валюты товара в валюту магазина
GetCurrencyForShop in file shop.class.php, method shop::GetCurrencyForShop()
Получение валюты, указанной по умолчанию для магазина
GetCurrencyXml in file shop.class.php, method shop::GetCurrencyXml()
Метод формирования xml для валюты
GetCurrentAlias in file Site.class.php, method site::GetCurrentAlias()
Определение основного алиаса сайта
GetCurrentDocumentVersion in file Documents.class.php, method documents::GetCurrentDocumentVersion()
Получение информации о текущей версии документа
GetCurrentLng in file Kernel.class.php, method kernel::GetCurrentLng()
Получения текущего языка центра администрирования
GetCurrentSiteUser in file Site_users.class.php, method SiteUsers::GetCurrentSiteUser()
Метод определения идентификатора текущего пользователя сайта.
GetCurrentUser in file Kernel.class.php, method kernel::GetCurrentUser()
Метод определения идентификатора текущего авторизированного пользователя раздела администрирования
GetCurrentYear in file Kernel.class.php, method kernel::GetCurrentYear()
Получение значения текущего года
GetDataTemplateDirTree in file Templates.class.php, method templates::GetDataTemplateDirTree()
Метод формирования дерева шаблонов.
GetDataTemplatePath in file Templates.class.php, method templates::GetDataTemplatePath()
Получение пути к файлу шаблона
GetDataTemplatePathArray in file Templates.class.php, method templates::GetDataTemplatePathArray()
Метод для построения массива пути от текущего узла к корневому
GetDataTemplatesGroup in file Templates.class.php, method templates::GetDataTemplatesGroup()
Получение информации о группе шаблонов данных
GetDataTemplatesTree in file Templates.class.php, method templates::GetDataTemplatesTree()
Метод построения дерева шаблонов сайта
GetDayInformation in file Counter.class.php, method counter::GetDayInformation()
Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"
GetDBVersion in file Kernel.class.php, method kernel::GetDBVersion()
Метод определения версии MySQL
GetDefaultCurrency in file shop.class.php, method shop::GetDefaultCurrency()
Получение информации о базовой валюте
GetDefaultGroup in file Site_users.class.php, method SiteUsers::GetDefaultGroup()
Получение id группы используемой по умолчанию
GetDefaultOrderStatus in file shop.class.php, method shop::GetDefaultOrderStatus()
Получение статуса заказа, установленного по умолчанию
GetDefaultWarehouse in file warehouse.class.php, method warehouse::GetDefaultWarehouse()
Получение склада по умолчанию для магазина
GetDelimitedGroups in file InformationSystems.class.php, method InformationSystem::GetDelimitedGroups()
Получение иерархического списка групп дополнительнгых свойств групп информационных элементов
GetDelimitedGroups in file shop.class.php, method shop::GetDelimitedGroups()
Формирование дерева групп для магазина.
GetDelimitedGroupsDirExtProperty in file shop.class.php, method shop::GetDelimitedGroupsDirExtProperty()
Метод формирования дерева групп дополнительных свойств групп товаров для магазина.
GetDelimitedGroupsExtProperty in file shop.class.php, method shop::GetDelimitedGroupsExtProperty()
Метод формирования дерева групп для магазина.
GetDelimitedGroupsExtProperty in file InformationSystems.class.php, method InformationSystem::GetDelimitedGroupsExtProperty()
Формирование дерева групп для информационной системы
GetDirPath in file Kernel.class.php, method kernel::GetDirPath()
Получение пути к директории, используемой для решения проблемы с ограничением количества поддиректорий в директории.
GetDiscount in file shop.class.php, method shop::GetDiscount()
Метод, осуществляющий извлечение информации о скидке
GetDmozCatalog in file seo.class.php, method Seo::GetDmozCatalog()
Определение наличия страницы в каталоге Dmoz
GetDocument in file Documents.class.php, method documents::GetDocument()
Получение информации о документе
GetDocumentDir in file Documents.class.php, method documents::GetDocumentDir()
Получение информации о разделе документов
GetDocumentsDirTree in file Documents.class.php, method documents::GetDocumentsDirTree()
Метод формирования дерева разделов документов.
GetDocumentsFromDir in file Documents.class.php, method documents::GetDocumentsFromDir()
Получение списка документов раздела без учета подразделов
GetDocumentsPathArray in file Documents.class.php, method documents::GetDocumentsPathArray()
Метод для построения массива пути от текущего узла к корневому. Предназначен для использования только в центре администрирования.
GetDocumentVersion in file Documents.class.php, method documents::GetDocumentVersion()
Получение информации о версии документа
GetDocumentVersionPath in file Documents.class.php, method documents::GetDocumentVersionPath()
Получение пути к файлу версии документа
GetEItem in file shop.class.php, method shop::GetEItem()
Метод, осуществляющий извлечение информации об электронном товаре
GetEitemCount in file shop.class.php, method shop::GetEitemCount()
Получение количества оставшегося электронного товара
GetEitemsForItem in file shop.class.php, method shop::GetEitemsForItem()
Метод получения данных об электронных товарах конкретного товара
GetEmail in file helpdesk.class.php, method helpdesk::GetEmail()
Получение информации об электронном адресе
GetEmailIsHelpdeskEmail in file helpdesk.class.php, method helpdesk::GetEmailIsHelpdeskEmail()
Проверка, является ли переданный текст адресом службы техподдержки или почтовым демоном, а также, нужно ли отсылать сообщения на электронный адрес пользователю
GetExpires in file Kernel.class.php, method kernel::GetExpires()
Получение времени истечения актуальности страницы
GetExtension in file Kernel.class.php, method kernel::GetExtension()
Метод возвращает расширение файла
GetExternalHtml in file admin_forms_fields.class.php, method admin_forms_fields::GetExternalHtml()
Получить установленный внешний HTML для формы
GetExternalInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetExternalInformationSystemItem()
Получение элементов информационной системы. Переименован с GetInformationSystemItem
GetExtraProperties in file Site_users.class.php, method SiteUsers::GetExtraProperties()
Получение дополнительных свойств по их идентификатору
GetExtraProperty in file Site_users.class.php, method SiteUsers::GetExtraProperty()
Получение значения свойств дополнительного параметра
GetFascicle in file Maillist.class.php, method Maillist::GetFascicle()
Метод возвращает информацию о почтовой рассылке
GetFascicleFiles in file Maillist.class.php, method Maillist::GetFascicleFiles()
Метод возвращает информацию о файле выпуска почтовой рассылки
GetFields | in file SiteTemplate.class.php, method SiteTemplate::GetFields()
GetFileContent in file File.class.php, method File::GetFileContent()
Получение содержимого файла
GetFileExtension in file SiteTemplate.class.php, method SiteTemplate::GetFileExtension()
Определение расширения файла по его названию без расширения
GetFillForm in file Forms.class.php, method Forms::GetFillForm()
Получение списка и значения полей для заполненной формы.
GetFillForms in file Forms.class.php, method Forms::GetFillForms()
Получение списка заполненных форм для формы $forms_id.
GetFillFormsFields in file Forms.class.php, method Forms::GetFillFormsFields()
Получение списка и значения полей для заполненной формы.
GetFirstMessageTicket in file helpdesk.class.php, method helpdesk::GetFirstMessageTicket()
Получение информации о первом сообщении тикета
GetForm in file Forms.class.php, method Forms::GetForm()
Обработка содержимого отправленной формы
GetFormFields in file Forms.class.php, method Forms::GetFormFields()
Получение данных о полях формы
GetFormInfo in file Forms.class.php, method Forms::GetFormInfo()
Получение информации о форме
GetForum in file Forums.class.php, method Forums::GetForum()
Получение информации о форуме
GetForumAccess in file Forums.class.php, method Forums::GetForumAccess()
Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму
GetForumAndItemIdFromPath in file Forums.class.php, method Forums::GetForumAndItemIdFromPath()
Получение данных об идентификаторе форума и темы по переданному массиву с элементами пути
GetForumsGroup in file Forums.class.php, method Forums::GetForumsGroup()
Метод возвращает информацию о группе форумов
GetForumsUsersGroupList in file Forums.class.php, method Forums::GetForumsUsersGroupList()
Получение данных о связи группы пользователей с форумом
GetForumView in file Forums.class.php, method Forums::GetForumView()
Получение информации о дате последнего просмотра форума пользователем
GetGDVersion in file Kernel.class.php, method kernel::GetGDVersion()
Метод определения версии GD библиотеки
GetGradeInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetGradeInformationSystemItem()
Получение информации об оценке информационного элемента
GetGroup in file shop.class.php, method shop::GetGroup()
Получение информации о группе товаров
GetGroupDir in file shop.class.php, method shop::GetGroupDir()
Получение пути хранения файлов группы товаров
GetGroupIdByCmlId in file shop.class.php, method shop::GetGroupIdByCmlId()
Внутренний метод возвращает данные о группе товаров по идентификатору группы товаров стандарта CommerceML
GetGroupPollsWithConditions in file Polls.class.php, method polls::GetGroupPollsWithConditions()
Метод для получения списка групп с запросами по условиям
GetGroups in file shop.class.php, method shop::GetGroups()
Метод возвращает список групп магазина
GetGroupsByPropertyValue in file shop.class.php, method shop::GetGroupsByPropertyValue()
Получение информации обо всех группах, по значению доп. свойства
GetGroupsForUser in file Site_users.class.php, method SiteUsers::GetGroupsForUser()
Определение идентификаторов групп, в которые входит пользователь
GetGroupsInformationSystem in file InformationSystems.class.php, method InformationSystem::GetGroupsInformationSystem()
Формирование дерева групп информационной системы
GetGroupsTree in file shop.class.php, method shop::GetGroupsTree()
Получение массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской
GetGroupsXmlTree in file shop.class.php, method shop::GetGroupsXmlTree()
Служебный метод построения дерева xml для групп.
GetGroupWithPath in file shop.class.php, method shop::GetGroupWithPath()
Получение информации о группе по пути, если такая существует в данной подгруппе магазина
GetGroupWithValue in file shop.class.php, method shop::GetGroupWithValue()
Получение информации о группе по наименованию, если такая существует в данной подгруппе магазина
GetHelpdesk in file helpdesk.class.php, method helpdesk::GetHelpdesk()
Получение данных о службе технической поддержки.
GetHtmlCallDoLoadAjax in file admin_forms.class.php, method admin_forms::GetHtmlCallDoLoadAjax()
Получение кода вызова DoLoadAjax для атрибута href
GetHtmlCallTrigerSingleAction in file admin_forms.class.php, method admin_forms::GetHtmlCallTrigerSingleAction()
Формирует ссылку действия для содержимого атрибута href тега a
GetIdInformationItem in file InformationSystems.class.php, method InformationSystem::GetIdInformationItem()
Определение идентификатора информационного элемента по URI элемента и идентификатору информационной группы
GetImageSize in file Image.class.php, method Image::GetImageSize()
Метод определяет высоту и ширину изображения
GetIndexAport in file seo.class.php, method Seo::GetIndexAport()
Определение количества проиндексированных странниц сервисом Апорт
GetIndexGoogle in file seo.class.php, method Seo::GetIndexGoogle()
Определяет количество проиндексированных странниц сервисом Google
GetIndexMsn in file seo.class.php, method Seo::GetIndexMsn()
Определение количества проиндексированных странниц сервисом Bing.com
GetIndexRambler in file seo.class.php, method Seo::GetIndexRambler()
Определение количества проиндексированных странниц сервисом Rambler
GetIndexYahoo in file seo.class.php, method Seo::GetIndexYahoo()
Определение количества проиндексированных странниц сервисом Yahoo
GetIndexYandex in file seo.class.php, method Seo::GetIndexYandex()
Определение количества проиндексированных странниц в Яндекс.ру
GetInfo4Messages in file helpdesk.class.php, method helpdesk::GetInfo4Messages()
Информация о количестве сообщений тикета
GetInformationFromPath in file InformationSystems.class.php, method InformationSystem::GetInformationFromPath()
Определение идентификатора информационной группы и идентификатора информационного элемента по значению URI
GetInformationGroup in file InformationSystems.class.php, method InformationSystem::GetInformationGroup()
Получение информации о группе. Использует кэш "INF_SYS_GROUP"
GetInformationGroupDir in file InformationSystems.class.php, method InformationSystem::GetInformationGroupDir()
Получение пути хранения файлов информационной группы
GetInformationGroupName in file InformationSystems.class.php, method InformationSystem::GetInformationGroupName()
Получение имени информационной группы
GetInformationGroupsPathArray in file InformationSystems.class.php, method InformationSystem::GetInformationGroupsPathArray()
Построение массива пути от текущей группы к корневой
GetInformationGroupsPropertys in file InformationSystems.class.php, method InformationSystem::GetInformationGroupsPropertys()
Получение данных о дополнительном свойстве групп информационной системы
GetInformationGroupsPropertyValue in file InformationSystems.class.php, method InformationSystem::GetInformationGroupsPropertyValue()
Получение информации о значении дополнительного свойства информационных групп
GetInformationItemDir in file InformationSystems.class.php, method InformationSystem::GetInformationItemDir()
Получение пути хранения файлов информационного элемента
GetInformationItemPropertyValue in file InformationSystems.class.php, method InformationSystem::GetInformationItemPropertyValue()
Получение информации о значении дополнительного свойства информационного элемента
GetInformationItemsFromGroup in file InformationSystems.class.php, method InformationSystem::GetInformationItemsFromGroup()
Получение информации об элементах, находящихся в информационной группе
GetInformationItemsPropertyValue in file InformationSystems.class.php, method InformationSystem::GetInformationItemsPropertyValue()
Получение информации о значении дополнительного свойства информационного элемента по ID связи таблицы information_propertys_items_table
GetInformationSystem in file InformationSystems.class.php, method InformationSystem::GetInformationSystem()
Получение данных об информационной системе
GetInformationSystemByStructureId in file InformationSystems.class.php, method InformationSystem::GetInformationSystemByStructureId()
Получение информации об информационной системе, связанной с узлом структуры
GetInformationSystemGroupAccess in file InformationSystems.class.php, method InformationSystem::GetInformationSystemGroupAccess()
Определения уровня доступности информационной группы
GetInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItem()
Получение данных об информационном элементе
GetInformationSystemItemAccess in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItemAccess()
Определение уровня доступности информационного элемента
GetInformationSystemItemProperty in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItemProperty()
Получение данных о дополнительных свойствах элементов
GetInformationSystemItems in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItems()
Получение информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит
GetInformationSystemsDir | in file InformationSystems.class.php, method InformationSystem::GetInformationSystemsDir()
GetInformationSystemsDirPathArray in file InformationSystems.class.php, method InformationSystem::GetInformationSystemsDirPathArray()
Построение массива пути от текущего раздела информационных систем к корневому
GetInformationSystemsDirs in file InformationSystems.class.php, method InformationSystem::GetInformationSystemsDirs()
Формирование дерева разделов информационных систем
GetInitialData in file Counter.class.php, method counter::GetInitialData()
Получение начальных данных для счетчика
GetIp in file ip.class.php, method ip::GetIp()
Получение информации об IP-адресе
GetIpInfo in file ip.class.php, method ip::GetIpInfo()
Получение информации о запретах для переданного ip-адреса
GetIpInformation in file Counter.class.php, method counter::GetIpInformation()
Выборка информации для IP-адреса
GetItem in file shop.class.php, method shop::GetItem()
Метод, осуществляющий извлечение информации о товаре
GetItemByParam in file shop.class.php, method shop::GetItemByParam()
Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента
GetItemCountForAllWarehouses in file warehouse.class.php, method warehouse::GetItemCountForAllWarehouses()
Получение количества определенного товара на всех складах
GetItemCountForWarehouse in file warehouse.class.php, method warehouse::GetItemCountForWarehouse()
Получение количества определенного товара на определенном складе
GetItemDir in file shop.class.php, method shop::GetItemDir()
Получение пути хранения файлов товара
GetItemDiscount in file shop.class.php, method shop::GetItemDiscount()
Получение информации о скидке на товар
GetItemFromCart in file shop.class.php, method shop::GetItemFromCart()
Получение информации о товаре из корзины для пользователя
GetItemPath in file Cache.class.php, method Cache::GetItemPath()
Определение пути к элементу
GetItemPath in file shop.class.php, method shop::GetItemPath()
Метод определения идентификатора группы товаров и идентификатора товара по значению URL
GetItemPropertyIdByCmlId in file shop.class.php, method shop::GetItemPropertyIdByCmlId()
Метод возвращает данные о дополнительном свойстве товара по идентификатору дополнительного свойства формата CommerceML
GetItemPropertyValueById in file shop.class.php, method shop::GetItemPropertyValueById()
Метод получения информации о значении дополнительного свойства товара по идентификатору значения
GetItemsFromCart in file shop.class.php, method shop::GetItemsFromCart()
Получение товаров, находящихся в корзине
GetItemsFromCookiesToCart in file shop.class.php, method shop::GetItemsFromCookiesToCart()
Устаревший метод. См. TransferFromCartIntoTable()
GetItemsXmlTree in file shop.class.php, method shop::GetItemsXmlTree()
Метод построения XML для товаров
GetItemXml in file shop.class.php, method shop::GetItemXml()
Метод формирования xml товара
getJsCode in file JsHttpRequest.php, method JsHttpRequest::getJsCode()
string getJsCode()
GetLanguage in file admin_forms.class.php, method admin_forms::GetLanguage()
Получение информации о языке центра администрирования
GetLanguageByShortName in file admin_forms.class.php, method admin_forms::GetLanguageByShortName()
Получение информации о языке центра администрирования по его обозначени.
GetLastInsertId in file Mysql.class.php, method DataBase::GetLastInsertId()
Возвращает ID, сгенерированный колонкой с AUTO_INCREMENT последним запросом INSERT к серверу
GetLastModified in file Kernel.class.php, method kernel::GetLastModified()
Получение времени последнего изменения страницы
GetLastPageTheme in file Forums.class.php, method Forums::GetLastPageTheme()
Получение номера последней страницы темы
GetLib in file lib.class.php, method lib::GetLib()
Получение типовой динамической страницы по её идентификатору
GetLibDir in file lib.class.php, method lib::GetLibDir()
Получение информации о директории типовых дин. страниц
GetLibDirTree in file lib.class.php, method lib::GetLibDirTree()
Формирование дерева разделов
GetLibPath in file lib.class.php, method lib::GetLibPath()
Получение пути к директории lib
GetLibPathArray in file lib.class.php, method lib::GetLibPathArray()
Получение пути от текущего каталога типовых динамических страниц до корневого
GetLibProperty in file lib.class.php, method lib::GetLibProperty()
Получение информации о параметре типовой динамической страницы
GetLinksGoogle in file seo.class.php, method Seo::GetLinksGoogle()
Определение количества ссылающихся страниц с сервиса Google
GetLinksMsn in file seo.class.php, method Seo::GetLinksMsn()
Определение количества ссылающихся страниц с сервиса Bing.com
GetLinksYahoo in file seo.class.php, method Seo::GetLinksYahoo()
Определение количества ссылающихся страниц с сервиса Yahoo
GetLinksYandex in file seo.class.php, method Seo::GetLinksYandex()
Определение количества ссылающихся страниц с сервиса Yandex
GetList in file Lists.class.php, method lists::GetList()
Получение данных о списках
GetListDir in file Lists.class.php, method lists::GetListDir()
Получение информации о разделе списков
GetListDirPathArray in file Lists.class.php, method lists::GetListDirPathArray()
Построение массива пути от текущего раздела к корневому
GetListDirsTree in file Lists.class.php, method lists::GetListDirsTree()
Формирование дерева разделов списков
GetListExtraProperties in file Site_users.class.php, method SiteUsers::GetListExtraProperties()
Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором
GetListItem in file Lists.class.php, method lists::GetListItem()
Получение данных об элементе списка
GetListItemIfIssetValue in file Lists.class.php, method lists::GetListItemIfIssetValue()
Проверка наличия значения в списке
GetListItemsById in file Lists.class.php, method lists::GetListItemsById()
Получение элементов списка в виде массива
GetListItemsValuesById in file Lists.class.php, method lists::GetListItemsValuesById()
Получение элементов списка в виде resource.
GetListPrimaryProperties in file Site_users.class.php, method SiteUsers::GetListPrimaryProperties()
УСТАРЕВШИЙ Получение основных данных о пользователе
GetListsItems in file Lists.class.php, method lists::GetListsItems()
Получение данных об элементах списка
GetLocation in file shop.class.php, method shop::GetLocation()
Метод, осуществляющий извлечение области
GetLocationByName | in file shop.class.php, method shop::GetLocationByName()
GetLogStat in file Search.class.php, method Search::GetLogStat()
Метод для получения сгруппированной информации о поисковых запросах
GetLr | in file seo.class.php, method Seo::GetLr()
GetMailBox in file Mail.class.php, method Mail::GetMailBox()
Формирование имени почтового ящика
GetMailCatalog in file seo.class.php, method Seo::GetMailCatalog()
Определение наличия страницы в каталоге Mail.ru
GetMaillist in file Maillist.class.php, method Maillist::GetMaillist()
Метод возвращает ассоциативный массив с информацией о списке рассылок
GetMaillistXML in file Maillist.class.php, method Maillist::GetMaillistXML()
Устаревший метод генерирующий XML для состояния подписки конкретного пользователя сайта
GetMasGroup in file InformationSystems.class.php, method InformationSystem::GetMasGroup()
Получение массива информационных групп
GetMasGroupToRoot in file shop.class.php, method shop::GetMasGroupToRoot()
Возвращает $this->mas_groups_to_root
GetMasXslGroupPath in file Xsl.class.php, method xsl::GetMasXslGroupPath()
Получение массива с информацией о разделах, составляющих путь от текущего до корневого раздела
GetMd5CacheCountItemsAndGroup in file shop.class.php, method shop::GetMd5CacheCountItemsAndGroup()
Получение хэша для кэширвоания количества товаров и групп
GetMessage in file messages.class.php, method messages::GetMessage()
Получение информации о сообщении
GetMessage in file helpdesk.class.php, method helpdesk::GetMessage()
Получение информации о сообщении.
GetMessage in file Forums.class.php, method Forums::GetMessage()
Получение информации о сообщении
GetMessageByNumber in file helpdesk.class.php, method helpdesk::GetMessageByNumber()
Получение информации о сообщении по его порядковому номеру в тикете
GetMessageForHistory in file helpdesk.class.php, method helpdesk::GetMessageForHistory()
Получение отформатированного сообщения для истории сообщений
GetMessageHistory in file helpdesk.class.php, method helpdesk::GetMessageHistory()
Построение дерева сообщений
GetMesure in file shop.class.php, method shop::GetMesure()
Метод, осуществляющий извлечение информации о единице измерения
GetMesuresByLike in file shop.class.php, method shop::GetMesuresByLike()
Метод, возвращающий информацию о мере измерения из базы согласно имени $string используя оператор LIKE
getmicrotime in file Kernel.class.php, method kernel::getmicrotime()
Получение значения времени
GetMimeType in file Kernel.class.php, method kernel::GetMimeType()
Метод определения MIME-типа файла
GetModule in file Modules.class.php, method modules::GetModule()
Получение информации о модуле
GetMsgList in file Mail.class.php, method Mail::GetMsgList()
Получение списка писем
GetNewUsersInform in file Counter.class.php, method counter::GetNewUsersInform()
Получение информации о новых пользователях сайта
GetOnClickCallDoLoadAjax in file admin_forms.class.php, method admin_forms::GetOnClickCallDoLoadAjax()
Получение кода вызова DoLoadAjax для события onClick
GetOnClickCallTrigerSingleAction in file admin_forms.class.php, method admin_forms::GetOnClickCallTrigerSingleAction()
Формирует ссылку действия для содержимого атрибута onclick тега a
GetOnPageCount in file admin_forms.class.php, method admin_forms::GetOnPageCount()
Получение числа элементов на страницу
GetOrder in file shop.class.php, method shop::GetOrder()
Извлечение заказа по его ID
GetOrderByGuid in file shop.class.php, method shop::GetOrderByGuid()
Извлечение заказа по его GUID
GetOrderDiscount in file shop.class.php, method shop::GetOrderDiscount()
Метод возвращает информацию о скидке для заказов
GetOrderDiscountForSum in file shop.class.php, method shop::GetOrderDiscountForSum()
Устаревший метод. Заменен на GetOrderDiscountForSumAndCount() Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина
GetOrderDiscountForSumAndCount in file shop.class.php, method shop::GetOrderDiscountForSumAndCount()
Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных для указанного магазина
GetOrderDiscountWithConditions in file shop.class.php, method shop::GetOrderDiscountWithConditions()
Метод возвращает список скидок на сумму заказа по заданным условиям
GetOrderInfoArray in file shop.class.php, method shop::GetOrderInfoArray()
Метод формирования массива с информацией о заказе для вставки в заказы
GetOrderItem in file shop.class.php, method shop::GetOrderItem()
Метод, осуществляющий извлечение товара из заказа
GetOrderItems in file shop.class.php, method shop::GetOrderItems()
Метод, осуществляющий извлечение товаров из заказа
GetOrdersStatus in file shop.class.php, method shop::GetOrdersStatus()
Метод, осуществляющий извлечение состояния заказа
GetOrderSum in file shop.class.php, method shop::GetOrderSum()
Расчет суммы заказа
GetOrderXml in file shop.class.php, method shop::GetOrderXml()
Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных
getOsName | in file Counter.class.php, method counter::getOsName()
GetPageCount in file Search.class.php, method Search::GetPageCount()
Метод определения числа проиндексированных страниц
GetPageInfo in file Search.class.php, method Search::GetPageInfo()
Получение информации о проиндексированных страницах
GetPageRank in file seo.class.php, method Seo::GetPageRank()
Поиск значения Google PageRank. Основан на данных Google toolbar. Возвращает значение PageRank страницы
GetPathDataTemplatesGroupCurrentToRoot in file Templates.class.php, method templates::GetPathDataTemplatesGroupCurrentToRoot()
Метод построения пути от заданного узла дерева групп шаблонов страниц до корневого
GetPathGroup in file shop.class.php, method shop::GetPathGroup()
Метод формирования пути по группам товара
GetPathGroup in file InformationSystems.class.php, method InformationSystem::GetPathGroup()
Формирование пути по информационным группам
GetPathItem in file shop.class.php, method shop::GetPathItem()
Метод формирования пути к товару
GetPathItem in file InformationSystems.class.php, method InformationSystem::GetPathItem()
Формирование пути к данному информационному элементу
GetPathProducer in file shop.class.php, method shop::GetPathProducer()
Метод формирования пути по производителю
GetPathTemplatesGroupCurrentToRoot in file Templates.class.php, method templates::GetPathTemplatesGroupCurrentToRoot()
Метод построения пути от заданного узла дерева групп макетов страниц до корневого
GetPoll in file Polls.class.php, method polls::GetPoll()
Метод возвращает данные об опросе
GetPollsGroup in file Polls.class.php, method polls::GetPollsGroup()
Получение информации о группе опросов
GetPosAport in file seo.class.php, method Seo::GetPosAport()
Определение позиции сайта в поисковой системе Апорт
GetPosGogo in file seo.class.php, method Seo::GetPosGogo()
Определение позиции сайта в поисковой системе GoGo
GetPosGoogle in file seo.class.php, method Seo::GetPosGoogle()
Определение позиции сайта в поисковой системе Google
GetPositionSearch in file seo.class.php, method Seo::GetPositionSearch()
Получение списка позиций в поисковой системе из БД
GetPosLivesearch in file seo.class.php, method Seo::GetPosLivesearch()
Определение позиции сайта в поисковой системе Bing.com
GetPosRambler in file seo.class.php, method Seo::GetPosRambler()
Определение позиции сайта в поисковой системе Rambler
GetPosYahoo in file seo.class.php, method Seo::GetPosYahoo()
Определение позиции сайта в поисковой системе Yahoo
GetPosYandex in file seo.class.php, method Seo::GetPosYandex()
Определение позиции сайта в поисковой системе Yandex
GetPrice in file shop.class.php, method shop::GetPrice()
Метод, осуществляющий извлечение типа цены
GetPriceByCmlId in file shop.class.php, method shop::GetPriceByCmlId()
Метод возвращает данные о цене по идентификатору цены формата CommerceML
GetPriceForCondOfDelivery in file shop.class.php, method shop::GetPriceForCondOfDelivery()
Получение цены доставки с учетом указанного налога
GetPriceForItem in file shop.class.php, method shop::GetPriceForItem()
Метод определения наличия указанной цены для заданного товара
GetPriceForUser in file shop.class.php, method shop::GetPriceForUser()
Метод определения цены товара для заданного пользователя
GetProducer in file shop.class.php, method shop::GetProducer()
Метод, осуществляющий извлечение информации о производителе
GetProducerByName in file shop.class.php, method shop::GetProducerByName()
Метод для получения списка производителей по названию
GetPropertiesGroup in file InformationSystems.class.php, method InformationSystem::GetPropertiesGroup()
Получение данных о дополнительных свойствах информационной группы и их значениях .
GetPropertiesGroupsDir in file shop.class.php, method shop::GetPropertiesGroupsDir()
Получение информации о группе дополнительных свойств групп товаров
GetPropertiesGroupValue in file shop.class.php, method shop::GetPropertiesGroupValue()
Получение данных о значении дополнительного свойства групп товаров
GetPropertiesItemForGroups in file shop.class.php, method shop::GetPropertiesItemForGroups()
Получение информации о принадлежности дополнительного свойства группе товаров
GetPropertiesItemsDir in file shop.class.php, method shop::GetPropertiesItemsDir()
Получение данных о группе дополнительных свойств товара
GetPropertiesOfGroup in file shop.class.php, method shop::GetPropertiesOfGroup()
Метод для получения списка идентификаторов свойств товаров для определенной группы.
GetPropertiesOfGroupForXml in file shop.class.php, method shop::GetPropertiesOfGroupForXml()
Возвращает список свойств, доступных для вывода в группе
GetPropertyACountProperty in file Structure.class.php, method Structure::GetPropertyACountProperty()
Получение количества свойств для разных сайтов
GetPropertyError in file InformationSystems.class.php, method InformationSystem::GetPropertyError()
Метод возвращающий код ошибки, возникающей при работе с методами класса
GetPropertyGroupsDir in file InformationSystems.class.php, method InformationSystem::GetPropertyGroupsDir()
Получение информации о группе дополнительных свойств групп информационной системы
GetPropertyLevel in file Structure.class.php, method Structure::GetPropertyLevel()
Получение информации о максимальном уровне($this->level)
GetPropertyMenuId in file Structure.class.php, method Structure::GetPropertyMenuId()
Получение информации о текущем разделе меню($this->menu_id)
GetPropertySectionPath in file InformationSystems.class.php, method InformationSystem::GetPropertySectionPath()
Получение значения свойтва, содержащего пути по группам
GetPropertySeparator in file Structure.class.php, method Structure::GetPropertySeparator()
Получение информации о разделителе($this->separator)
GetPropertysGroup in file shop.class.php, method shop::GetPropertysGroup()
Получение данных о дополнительных свойствах группы магазина.
GetPropertysInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetPropertysInformationSystemItem()
Получение списка дополнительных свойств и их значений для информационного элемента
GetPropertysItemsDir in file InformationSystems.class.php, method InformationSystem::GetPropertysItemsDir()
Получение информации о группе дополнительных свойств информационных элементов
GetPropertyStructureMass in file Structure.class.php, method Structure::GetPropertyStructureMass()
Получение информации об элементах структуры
GetPropertyStructureParentMass in file Structure.class.php, method Structure::GetPropertyStructureParentMass()
Получение информации о родительских разделах элемента структуры($this->StructureParentMass)
GetPropertyStructurePropertysList in file Structure.class.php, method Structure::GetPropertyStructurePropertysList()
Получение дополнительных свойств структуры
GetPropertyValue in file Structure.class.php, method Structure::GetPropertyValue()
Метод для получения информации о значении свойства структуры
GetPropretyOfGroup in file shop.class.php, method shop::GetPropretyOfGroup()
Получение информации о дополнительном свойстве группы товаров
GetPropretyOfItems in file shop.class.php, method shop::GetPropretyOfItems()
Метод, осуществляющий извлечение свойства товара по идентификатору свойства товара
GetQuery in file seo.class.php, method Seo::GetQuery()
Получение списка поисковых запросов из БД
GetRamblerCatalog in file seo.class.php, method Seo::GetRamblerCatalog()
Определение наличия страницы в каталоге Rambler
GetRealPath in file shop.class.php, method shop::GetRealPath()
Корректирует путь
GetResponsible in file helpdesk.class.php, method helpdesk::GetResponsible()
Получение информации об ответственном лице
GetSearchSystemInform in file Counter.class.php, method counter::GetSearchSystemInform()
Получение информации о поисковых системах
GetSecondaryStat in file Counter.class.php, method counter::GetSecondaryStat()
Получение статистической информации из таблицы сессий
GetSectionPath in file lib.class.php, method lib::GetSectionPath()
Внутренний метод возвращает путь к типовой дин. странице
GetSeller in file shop.class.php, method shop::GetSeller()
Получение информации о продавце по его идентификатору.
GetSellerByName in file shop.class.php, method shop::GetSellerByName()
Метод для получения списка продавцов по названию
GetSessionCart in file shop.class.php, method shop::GetSessionCart()
Получить содержимое корзины в session
GetSettingsForForm in file admin_forms.class.php, method admin_forms::GetSettingsForForm()
Получение информации о настройках для формы у указанного пользователя.
GetShop in file shop.class.php, method shop::GetShop()
Метод, осуществляющий извлечение информации о магазине
GetShopByStructureId in file shop.class.php, method shop::GetShopByStructureId()
Получение информации о магазине, связанном с узлом структуры
GetShopCurrency in file shop.class.php, method shop::GetShopCurrency()
Получение информации о валюте магазина
GetShopDiscount in file shop.class.php, method shop::GetShopDiscount()
Получение списка скидок для магазина
GetShopGroupAccess in file shop.class.php, method shop::GetShopGroupAccess()
Определение уровня доступности группы товаров
GetShopGroupsToRoot in file shop.class.php, method shop::GetShopGroupsToRoot()
Получение массива с данными о каталогах магазина, начиная с данной и до корневой
GetShopItemAccess in file shop.class.php, method shop::GetShopItemAccess()
Определение уровня доступности товара
GetShopPathArray in file shop.class.php, method shop::GetShopPathArray()
Получение пути от текущего каталога к корневому
GetShopsDir | in file shop.class.php, method shop::GetShopsDir()
GetShopsDirPathArray in file shop.class.php, method shop::GetShopsDirPathArray()
Построение массива пути от текущего раздела интернет-магазинов к корневому
GetShopsDirs in file shop.class.php, method shop::GetShopsDirs()
Формирование дерева разделов интернет-магазинов
GetShopsIdForAffiliatePlans in file affiliate.class.php, method affiliate::GetShopsIdForAffiliatePlans()
Получение идентификаторов всех магазинов, в которых доступна парнерская программа
GetShopWhithStructureId in file shop.class.php, method shop::GetShopWhithStructureId()
Метод выбора информации о магазине данного узла структуры сайта
GetSite in file Site.class.php, method site::GetSite()
Получение данных о сайте по его идентификатору
GetSiteUser in file Site_users.class.php, method SiteUsers::GetSiteUser()
Получение информации о пользователе сайта
GetSiteUserAccountSum in file shop.class.php, method shop::GetSiteUserAccountSum()
Метод возвращает сумму пользователя сайта в базовой валюте
GetSiteUserAccountTransaction in file shop.class.php, method shop::GetSiteUserAccountTransaction()
Получение информации о транзакции
GetSiteUserByEmail in file helpdesk.class.php, method helpdesk::GetSiteUserByEmail()
Получение информации о пользователе сайта по его e-mail'у
GetSiteUserByLogin in file Site_users.class.php, method SiteUsers::GetSiteUserByLogin()
Получение информации о пользователе сайта по его логину
GetSiteUsersGroup in file Site_users.class.php, method SiteUsers::GetSiteUsersGroup()
Получение информации о группе пользователей сайта
GetSiteUsersGroupList in file Site_users.class.php, method SiteUsers::GetSiteUsersGroupList()
Получение данных соответствия, пользователя группе пользователей, по идентификатору соответствия
GetSiteUsersGroupsForUser in file shop.class.php, method shop::GetSiteUsersGroupsForUser()
Получение списка групп пользователий, в которых содержится пользователь сайта
GetSiteUsersGroupsForUser in file InformationSystems.class.php, method InformationSystem::GetSiteUsersGroupsForUser()
Получение списка групп пользователий, в которых содержится пользователь сайта
GetSiteUsersGroupsXml in file Site_users.class.php, method SiteUsers::GetSiteUsersGroupsXml()
Формирование XML для группы пользователей
GetSiteUserXml in file Site_users.class.php, method SiteUsers::GetSiteUserXml()
Метод формирования XML с данными о пользователе
GetSpecialPrice in file shop.class.php, method shop::GetSpecialPrice()
Получение информации о специальной цене
GetSpecialPriceForItem in file shop.class.php, method shop::GetSpecialPriceForItem()
Получение информации о специальной цене (в зависимости от количества этого товара в корзине), подходящей для товара.
GetSpecialPricesForItem in file shop.class.php, method shop::GetSpecialPricesForItem()
Получение информации в виде массива о всех специальных ценах товара
GetSpecialPriceValueForItem in file shop.class.php, method shop::GetSpecialPriceValueForItem()
Получение специальной цены (в зависимости от количества этого товара в корзине), подходящей для товара.
GetStatArray in file Counter.class.php, method counter::GetStatArray()
Получение статистической информации из основной таблицы
GetStatDataArray in file Counter.class.php, method counter::GetStatDataArray()
Получение статистических данных за переданный промежуток времени
GetStatus in file helpdesk.class.php, method helpdesk::GetStatus()
Получение информации о статусе
GetStructure in file Structure.class.php, method Structure::GetStructure()
Метод выборки всех страниц структуры
GetStructureAccess in file Structure.class.php, method Structure::GetStructureAccess()
Получение информации о доступе к узлу элементов структуры
GetStructuredListCategoryTicket in file helpdesk.class.php, method helpdesk::GetStructuredListCategoryTicket()
Формирование структурированного списка категорий тикетов
GetStructuredListMessage in file helpdesk.class.php, method helpdesk::GetStructuredListMessage()
Получение структурированного списка сообщений
GetStructuredListTemplateDir in file helpdesk.class.php, method helpdesk::GetStructuredListTemplateDir()
Формирование стуктурированного списка категорий стандартных ответов
GetStructureFilesPath in file Structure.class.php, method Structure::GetStructureFilesPath()
Получение пути к директории lib
GetStructureForParent in file Structure.class.php, method Structure::GetStructureForParent()
Получение дочерних узлов структуры для узла структуры.
GetStructureItem in file Structure.class.php, method Structure::GetStructureItem()
Получение данных об элементе структуры. Идентификатор текущего узла структуры содержится в константе CURRENT_STRUCTURE_ID
GetStructureItemDir in file Structure.class.php, method Structure::GetStructureItemDir()
Получение пути хранения файлов узла структуры
GetStructurePath in file Structure.class.php, method Structure::GetStructurePath()
Определение полного пути к странице
GetStructurePathArray in file Structure.class.php, method Structure::GetStructurePathArray()
Получение пути от текущего узла к корневому
GetStructureProperty in file Structure.class.php, method Structure::GetStructureProperty()
Метод возвращает заполненные св-ва узлов структуры
GetStructurePropertyValue in file Structure.class.php, method Structure::GetStructurePropertyValue()
Получение значения свойства узла структуры по идентификатору узла структуры и идентификатору свойства
GetStructureXml in file Structure.class.php, method Structure::GetStructureXml()
XML для узла структуры. Перед вызовом очистите $Structure->XmlDataFromGenXml4StructureLevelMass
GetSupportEmailId in file helpdesk.class.php, method helpdesk::GetSupportEmailId()
Получение идентификатора электронного адреса службы техподдержки
GetSystemOfPay in file shop.class.php, method shop::GetSystemOfPay()
Метод, осуществляющий извлечение платёжной системы
GetTableFields in file Kernel.class.php, method kernel::GetTableFields()
Получение структуры таблицы БД
GetTableFieldSize in file Kernel.class.php, method kernel::GetTableFieldSize()
Получение размера в символах (не занимаемые байты) поля таблицы.
GetTableNames in file ExecSqlQuery.class.php, method ExecSqlQuery::GetTableNames()
Получение списка таблиц, разделенных запятыми.
GetTag in file tag.class.php, method Tag::GetTag()
Получение информации о теге
GetTagByName in file tag.class.php, method Tag::GetTagByName()
Получение информации о теге по его имени
GetTagByPath in file tag.class.php, method Tag::GetTagByPath()
Получение информации о теге по его пути
GetTagRelation in file tag.class.php, method Tag::GetTagRelation()
Список соответствий тега
GetTags in file tag.class.php, method Tag::GetTags()
Получение информации о тегах
GetTagsGroup in file tag.class.php, method Tag::GetTagsGroup()
Получение информации о группе меток
GetTagsGroupsPathArray in file tag.class.php, method Tag::GetTagsGroupsPathArray()
Построение массива пути от текущей группы меток к корневой
GetTagsGroupsTree in file tag.class.php, method Tag::GetTagsGroupsTree()
Формирование дерева групп меток
GetTax in file shop.class.php, method shop::GetTax()
Метод, осуществляющий извлечение налога
GetTaxIdByCmlId in file shop.class.php, method shop::GetTaxIdByCmlId()
Внутренний метод возвращает данные о налоге по идентификатору налога формата CommerceML
GetTemplate in file Templates.class.php, method templates::GetTemplate()
Получение информации о макете
GetTemplate in file helpdesk.class.php, method helpdesk::GetTemplate()
Получение информации о стандартном ответе
GetTemplate in file Kernel.class.php, method kernel::GetTemplate()
Получение текущего макета
GetTemplateContentFilePath | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateContentFilePath()
GetTemplateContentXml | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateContentXml()
GetTemplateDir in file helpdesk.class.php, method helpdesk::GetTemplateDir()
Получение информации о группе стандартных ответов
GetTemplateDirPathArray in file helpdesk.class.php, method helpdesk::GetTemplateDirPathArray()
Построение пути от корневой директории стандартных ответов до текущей
GetTemplateDirTree in file Templates.class.php, method templates::GetTemplateDirTree()
Метод формирования дерева макетов.
GetTemplateFilePath | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateFilePath()
GetTemplateKeyWords in file helpdesk.class.php, method helpdesk::GetTemplateKeyWords()
Получение информации о ключевом слове
GetTemplatePath | in file SiteTemplate.class.php, method SiteTemplate::GetTemplatePath()
GetTemplatePathArray in file Templates.class.php, method templates::GetTemplatePathArray()
Метод для построения массива пути от текущего узла к корневому
GetTemplatesGroup in file Templates.class.php, method templates::GetTemplatesGroup()
Получение информации о группе макетов
GetTemplatesTree in file Templates.class.php, method templates::GetTemplatesTree()
Метод построения дерева макетов сайта
GetTemplatesUrlServer | in file SiteTemplate.class.php, method SiteTemplate::GetTemplatesUrlServer()
GetTemplateXml | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateXml()
GetTextConformityCoefficient in file Advertisement.class.php, method Advertisement::GetTextConformityCoefficient()
Получение коэффициента схожести текста
GetTextFileSize in file helpdesk.class.php, method helpdesk::GetTextFileSize()
Получение тесктового названия размера файла (в Кб, Мб, Гб)
GetTheme in file Forums.class.php, method Forums::GetTheme()
Метод возвращает информацию о теме форума
GetThemeId in file Forums.class.php, method Forums::GetThemeId()
Получение идентификатора добавленнной темы форума
GetThemeLastMessage in file Forums.class.php, method Forums::GetThemeLastMessage()
Получение последнего сообщения темы
GetThemeView in file Forums.class.php, method Forums::GetThemeView()
Получение информации о дате последнего просмотра темы форума пользователем
GetTicket in file helpdesk.class.php, method helpdesk::GetTicket()
Получение информации об инциденте по его идентификатору
GetTicketByName in file helpdesk.class.php, method helpdesk::GetTicketByName()
Получение информации об инциденте по его имени
GetTicketCategory in file helpdesk.class.php, method helpdesk::GetTicketCategory()
Получение данных о категории инцидентов
GetTicketCategoryPathArray in file helpdesk.class.php, method helpdesk::GetTicketCategoryPathArray()
Построение пути от корневой категории тикетов к заданной
GetTicketFlags in file helpdesk.class.php, method helpdesk::GetTicketFlags()
Получение информации о флаге тикетов
getTimestamp in file Kernel.class.php, method kernel::getTimestamp()
Получение временной метки файла CSS-стиля для страницы
GetTmpId | in file Forums.class.php, method Forums::GetTmpId()
GetTopParentInformationGroup in file InformationSystems.class.php, method InformationSystem::GetTopParentInformationGroup()
Получение родительской группы находящейся в корне для информационной группы
GetTyingProducts in file shop.class.php, method shop::GetTyingProducts()
Получение информации о сопутствующем товаре
GetTyingProductsForItem in file shop.class.php, method shop::GetTyingProductsForItem()
Получение ID сопутствующих товаров для заданного товара
GetTypeOfDelivery in file shop.class.php, method shop::GetTypeOfDelivery()
Метод, осуществляющий извлечение типа доставки
GetTypeOfDeliveryForOrder in file shop.class.php, method shop::GetTypeOfDeliveryForOrder()
Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.
GetUpdatePath in file update.class.php, method update::GetUpdatePath()
Получение пути к директории update
GetUrl in file seo.class.php, method Seo::GetUrl()
Поисковый запрос URL и сохранение полученной страницы в кэше
GetUrl in file Kernel.class.php, method kernel::GetUrl()
Запрос URL
GetUrlWithHeader in file Kernel.class.php, method kernel::GetUrlWithHeader()
Запрос URL с возвращением заголовка и данных
GetUseCJ in file Counter.class.php, method counter::GetUseCJ()
Получение данных о использовании кукисов и Java
GetUser in file UserAccess.class.php, method user_access::GetUser()
Получение информации о пользователе
GetUserByName in file UserAccess.class.php, method user_access::GetUserByName()
Получение информации о пользователе по его имени
GetUserDir in file Site_users.class.php, method SiteUsers::GetUserDir()
Метод возвращает абсолютный путь к директории пользователя сайта
GetUserGroups in file Site_users.class.php, method SiteUsers::GetUserGroups()
УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.
GetUsersDir in file Site_users.class.php, method SiteUsers::GetUsersDir()
Метод возвращает абсолютный путь к директории для хранения файлов пользователей
getUsersID in file affiliate.class.php, method affiliate::getUsersID()
Метод формирования массива идентификаторов пользавателей сайта, участвующих в программе партнерских отношений.
GetUsersSuccess in file UserAccess.class.php, method user_access::GetUsersSuccess()
Определение информации о правах доступа пользователя к модулю
GetUsersSuccessEvent in file UserAccess.class.php, method user_access::GetUsersSuccessEvent()
Определение информации о правах доступа пользователя к действию
GetUsersTemplateByUsersId in file helpdesk.class.php, method helpdesk::GetUsersTemplateByUsersId()
Получение информации о шаблонах писем по идентификатору пользователя
GetUserType in file UserAccess.class.php, method user_access::GetUserType()
Метод возвращает данные о группе пользователей центр администрирования
GetValueExtraProperty in file Site_users.class.php, method SiteUsers::GetValueExtraProperty()
Получение значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра
GetValueItemProperty in file shop.class.php, method shop::GetValueItemProperty()
Получение значения дополнительного свойства для товара
GetVersionTimestamp in file Kernel.class.php, method kernel::GetVersionTimestamp()
Получения временной метки по текущей версии системы управления
GetWarehouse in file warehouse.class.php, method warehouse::GetWarehouse()
Получение информации о складе
GetWarehouseItem in file warehouse.class.php, method warehouse::GetWarehouseItem()
Получение информации об остатке товара на складе, получение возможно по shop_warehouse_items_id или паре значений идентификатор склада и идентификатор товара
GetWarehousesXml in file warehouse.class.php, method warehouse::GetWarehousesXml()
Формирование XML для всех складов магазина
GetWarehouseXml in file warehouse.class.php, method warehouse::GetWarehouseXml()
Формирование XML для конкретного склада магазина
GetWeekDayName in file helpdesk.class.php, method helpdesk::GetWeekDayName()
Определение названия дня недели по его номеру
GetWeekend in file helpdesk.class.php, method helpdesk::GetWeekend()
Получение информации о специальном рабочем/выходном дне
GetWeekendArray in file helpdesk.class.php, method helpdesk::GetWeekendArray()
Получение массива дополнительных выходных дней
GetWindowId | in file admin_forms.class.php, method admin_forms::GetWindowId()
GetWorkdayArray in file helpdesk.class.php, method helpdesk::GetWorkdayArray()
Получение массива дополнительных рабочих дней
GetWorkTime in file helpdesk.class.php, method helpdesk::GetWorkTime()
Получение массива рабочих часов службы техподдержки
GetXML4Maillist in file Maillist.class.php, method Maillist::GetXML4Maillist()
Генерация XML для почтовой рассылки
GetXml4StructurePropertys in file Structure.class.php, method Structure::GetXml4StructurePropertys()
Получение XML для свойств структуры. Перед вызовом метода необходимо вызвать $this->GetStructureProperty(array()); и передать массив ID узлов, для которых геренируются св-ва
GetXml4Tags in file shop.class.php, method shop::GetXml4Tags()
Генерация XML для облака тегов магазина
GetXml4Tags in file InformationSystems.class.php, method InformationSystem::GetXml4Tags()
Генерация XML для облака тегов информационной системы
GetXmlContent in file Kernel.class.php, method kernel::GetXmlContent()
Возвращает $this->ShowXmlContent
GetXmlForInformatioItem | in file InformationSystems.class.php, method InformationSystem::GetXmlForInformatioItem()
GetXmlForInformatioItemComments in file InformationSystems.class.php, method InformationSystem::GetXmlForInformatioItemComments()
Создает XML для комметариев
GetXmlForInformationItem in file InformationSystems.class.php, method InformationSystem::GetXmlForInformationItem()
Формирование XML для отображения информационного элемента
GetXmlForItemsOrder in file shop.class.php, method shop::GetXmlForItemsOrder()
Метод формирования xml для товаров в заказе
GetXMLForMessage in file messages.class.php, method messages::GetXMLForMessage()
Формирование XML сообщения
GetXmlForOneComment in file InformationSystems.class.php, method InformationSystem::GetXmlForOneComment()
Генерация XML для комментария и всех его дочерних комментариев.
GetXmlForOrder in file shop.class.php, method shop::GetXmlForOrder()
Метод формирования xml о заказе по идентификатору заказа
GetXmlForSite in file Site.class.php, method site::GetXmlForSite()
Создание XML с информацией о сайте и алиасах
GetXmlProducer in file shop.class.php, method shop::GetXmlProducer()
Метод генерирует XML для производителя в магазине
GetXsl in file Xsl.class.php, method xsl::GetXsl()
Получение информаци об XSL-шаблоне по его имени
GetXslPath in file Xsl.class.php, method xsl::GetXslPath()
Получение пути к файлу xsl
GetYandexCatalog in file seo.class.php, method Seo::GetYandexCatalog()
Определения наличия страницы в каталоге Yandex, тИЦ, темы, страны и региона страницы
get_count_row in file Mysql.class.php, method DataBase::get_count_row()
Метод возвращает количество строк в последнем запросе
get_CSS in file Kernel.class.php, method kernel::get_CSS()
Получение CSS стиля для страницы
get_current_page in file Kernel.class.php, method kernel::get_current_page()
Получение идентификатора текущего узла структуры
get_current_page_path in file Kernel.class.php, method kernel::get_current_page_path()
Получение пути текущей страницы
get_description in file Kernel.class.php, method kernel::get_description()
Получение описания страницы
get_documents_dir in file Documents.class.php, method documents::get_documents_dir()
Метод формирования дерева разделов текущего сайта
get_file_perms in file File.class.php, method File::get_file_perms()
Получение строки прав доступа к файлу
get_information_groups_path in file InformationSystems.class.php, method InformationSystem::get_information_groups_path()
Формирование пути по дереву информационных групп
get_keywords in file Kernel.class.php, method kernel::get_keywords()
Получение ключевых слов страницы
get_mas_information_groups_for_xml in file InformationSystems.class.php, method InformationSystem::get_mas_information_groups_for_xml()
Метод возвращает XML для информационных групп
get_page_id in file Kernel.class.php, method kernel::get_page_id()
Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя
get_polls_name in file Polls.class.php, method polls::get_polls_name()
Получение названия опроса
get_section_path in file Xsl.class.php, method xsl::get_section_path()
Получение пути по дереву разделов XSL. Устаревший метод
get_title in file Kernel.class.php, method kernel::get_title()
Получение заголовка страницы
GISTOGRAMM_LIMIT | in file Counter.php, constant GISTOGRAMM_LIMIT
GoSearch in file Search.class.php, method Search::GoSearch()
Метод выводит результаты поиска запроса $query с помощью XSL-шаблона $xslname в соответствии с дополнительными параметрами
graphic in file Graphic.class.php, class graphic
Система управления сайтом HostCMS v. 5.xx
graphic_diagramma in file Graphic.class.php, method graphic::graphic_diagramma()
Метод вывода круговой диаграммы
graphic_gistogramma in file Graphic.class.php, method graphic::graphic_gistogramma()
Метод вывода гистограммы
Graphic_Linear in file Graphic.class.php, method graphic::Graphic_Linear()
Метод вывода линейного графика
GroupIsParent in file InformationSystems.class.php, method InformationSystem::GroupIsParent()
Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id
GroupIsParent in file shop.class.php, method shop::GroupIsParent()
Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id
Guid in file Kernel.class.php, method kernel::Guid()
Возвращает уникальный идентификатор GUID
Graphic.class.php | procedural page Graphic.class.php
top
h
$headers_string in file Mail.class.php, variable Mail::$headers_string
Заголовки письма
$hidden | in file shop.class.php, variable shop::$hidden
$host in file Mail.class.php, variable Mail::$host
Имя хоста
HeaderDecode in file Mail.class.php, method Mail::HeaderDecode()
Перекодировщик из кодировки письма в кодировку системы
helpdesk in file helpdesk.class.php, class helpdesk
Система управления сайтом HostCMS v. 5.xx
helpdesk.class.php | procedural page helpdesk.class.php
helpdesk.php | procedural page helpdesk.php
hexcode_str in file Security.fns.php, function hexcode_str()
Преобразует строку в hex-последовательность.
HighlightSql | in file Mysql.class.php, method DataBase::HighlightSql()
HtmlToText in file Maillist.class.php, method Maillist::HtmlToText()
Преобразование html в текст
top
i
$iConvertPriceFractionalPart in file shop.class.php, variable shop::$iConvertPriceFractionalPart
Количество знаков после запятой при округлении методом ConvertPrice()
$icon_array in file Kernel.class.php, variable kernel::$icon_array
Массив ассоциаций расширений и пиктограмм
$ID | in file JsHttpRequest.php, variable JsHttpRequest::$ID
$image_extension in file Captcha.class.php, variable Captcha::$image_extension
Расширение рисунка CAPTCHA
$image_height in file Captcha.class.php, variable Captcha::$image_height
Высота изображения с CAPTCHA
$image_width in file Captcha.class.php, variable Captcha::$image_width
Ширина изображения с CAPTCHA
$init in file Wysiwyg.class.php, variable wysiwyg::$init
Массив настроек для tinyMCE.init, заполняется в конструкторе, пример: $this->init['mode'] = "exact";
$is_dir_array in file Cache.class.php, variable Cache::$is_dir_array
Кэш существующих директорий
$ItemMass in file InformationSystems.class.php, variable InformationSystem::$ItemMass
Кэш с данными об элементах
$item_catalog_price in file shop.class.php, variable shop::$item_catalog_price
Цена товара магазина
$iThemeId in file Forums.class.php, variable Forums::$iThemeId
Идентификатор вставленной темы
$iTmpId | in file Forums.class.php, variable Forums::$iTmpId
IconvText in file Mail.class.php, method Mail::IconvText()
Перекодирование текста из кодировки письма в кодировку системы
Image in file Image.class.php, class Image
Система управления сайтом HostCMS v. 5.xx
imagebar in file Graphic.class.php, method graphic::imagebar()
Метод вывода гистограммы
implode_array in file Kernel.class.php, method kernel::implode_array()
Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно
ImportCML in file shop.class.php, method shop::ImportCML()
Импорт из формата CommerceML
ImportCML in file cml.class.php, method cml::ImportCML()
Импорт из формата CommerceML
IncCountMessage in file Forums.class.php, method Forums::IncCountMessage()
Метод наращивания счётчика количества сообщений для пользователя
IncPollReply in file Polls.class.php, method polls::IncPollReply()
Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote
IndexationForums in file Forums.class.php, method Forums::IndexationForums()
Метод индексации форумов
IndexationForumsMessages in file Forums.class.php, method Forums::IndexationForumsMessages()
Метод индексации сообщений тем форумов
IndexationShopItems in file shop.class.php, method shop::IndexationShopItems()
Индексация товаров
IndexationStructure in file Structure.class.php, method Structure::IndexationStructure()
Метод индексации элементов структуры
IndexationUser in file Site_users.class.php, method SiteUsers::IndexationUser()
Метод индексации пользователей сайта
InformationItemIncShowCount in file InformationSystems.class.php, method InformationSystem::InformationItemIncShowCount()
Инкрементирование счетчика показов информационного элемента
InformationSystem in file InformationSystems.class.php, class InformationSystem
Класс модуля "Информационные системы"
InformationSystemItemAccess in file InformationSystems.class.php, method InformationSystem::InformationSystemItemAccess()
Определение доступности информационного элемента для пользователя
InformationSystems.class.php | procedural page InformationSystems.class.php
InformationSystems.php | procedural page InformationSystems.php
InitConstants in file Kernel.class.php, method kernel::InitConstants()
Метод инициализации констант сайта в соответствии с константой CURRENT_SITE
Insert in file Cache.class.php, method Cache::Insert()
Вставка значения в кэш
Insert in file Mysql.class.php, method DataBase::Insert()
Вставка записи в таблицу.
InsertAdminForm in file admin_forms.class.php, method admin_forms::InsertAdminForm()
Вставка/обновление формы центра управления
InsertAdminFormsEvent in file admin_forms.class.php, method admin_forms::InsertAdminFormsEvent()
Вставка/обновление информации о событии (дейтсвии) формы администрирования
InsertAdminFormsField in file admin_forms.class.php, method admin_forms::InsertAdminFormsField()
Вставка информации о поле формы центра администрирования
InsertAffiliate in file affiliate.class.php, method affiliate::InsertAffiliate()
Добавление информации об аффилиате
InsertAffiliatePlans in file affiliate.class.php, method affiliate::InsertAffiliatePlans()
Добавление информации о плане аффилиата
InsertAffiliateValues in file affiliate.class.php, method affiliate::InsertAffiliateValues()
Добавление информации о комиссии
InsertBanners in file Advertisement.class.php, method Advertisement::InsertBanners()
Добавление баннера в группу/редактирование приоритета показа баннера в группе
InsertBannersGroup in file Advertisement.class.php, method Advertisement::InsertBannersGroup()
Добавление/редактирование информации о группе баннеров
InsertCategoryTicket in file helpdesk.class.php, method helpdesk::InsertCategoryTicket()
Добавление/обновление информации о категории тикетов
InsertCharacteristic in file seo.class.php, method Seo::InsertCharacteristic()
Добавление характеристики страницы
InsertCity in file shop.class.php, method shop::InsertCity()
Метод, осуществляющий вставку города
InsertCityArea in file shop.class.php, method shop::InsertCityArea()
Метод добавления/редактирования информации о районе города
InsertComment in file shop.class.php, method shop::InsertComment()
Метод добавления/обновления информации об отзыве на товар
InsertCompany in file shop.class.php, method shop::InsertCompany()
Метод для вставки/обновления организации
InsertCondOfDelivery in file shop.class.php, method shop::InsertCondOfDelivery()
Метод, осуществляющий вставку условия доставки
InsertConference in file Forums.class.php, method Forums::InsertConference()
Метод, осуществляющий вставку информации о конференции.
InsertContextualWords in file Advertisement.class.php, method Advertisement::InsertContextualWords()
Добавление/обновление информации о контекстной фразе
InsertCountry in file shop.class.php, method shop::InsertCountry()
Метод, осуществляющий вставку страны
InsertCoupon in file shop.class.php, method shop::InsertCoupon()
Метод для вставки/обновления информации о купоне
InsertCriticalLevel in file helpdesk.class.php, method helpdesk::InsertCriticalLevel()
Добавление/обновление информации об уровне критичности
InsertCurrency in file shop.class.php, method shop::InsertCurrency()
Метод,осуществляющий вставку информации о валюте
InsertDataTemplatesGroup in file Templates.class.php, method templates::InsertDataTemplatesGroup()
Метод добавления/обновления группы шаблонов данных
InsertDiscount in file shop.class.php, method shop::InsertDiscount()
Метод, осуществляющий вставку информации о скидке
InsertEditMessage in file Forums.class.php, method Forums::InsertEditMessage()
Добавление/редактирование сообщения
InsertEItem in file shop.class.php, method shop::InsertEItem()
Метод вставки/обновления информации об электронном товаре
InsertEmail in file helpdesk.class.php, method helpdesk::InsertEmail()
Добавление/обновление информации об электронных адресах
InsertExtraProperty in file Site_users.class.php, method SiteUsers::InsertExtraProperty()
Добавление/редактирование дополнительного параметра
InsertFascicle in file Maillist.class.php, method Maillist::InsertFascicle()
Добавление/редактирование выпуска рассылки
InsertFascicleFiles in file Maillist.class.php, method Maillist::InsertFascicleFiles()
Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки
InsertForms in file Forms.class.php, method Forms::InsertForms()
Вставка/обновление информации о форме
InsertFormsFields in file Forms.class.php, method Forms::InsertFormsFields()
Вставка/обновление информации о поле формы
InsertFormsFill in file Forms.class.php, method Forms::InsertFormsFill()
Вставка/обновление информации о заполнении формы
InsertFormsFillValues in file Forms.class.php, method Forms::InsertFormsFillValues()
Вставка/обновление значений заполненной формы
InsertForum in file Forums.class.php, method Forums::InsertForum()
Добавление/редактирование форума
InsertForumsGroup in file Forums.class.php, method Forums::InsertForumsGroup()
Метод добавления/редактирования группы форумов
InsertForumView in file Forums.class.php, method Forums::InsertForumView()
Вставка информации о дате последнего посещения темы форума пользователем.
InsertGroup in file shop.class.php, method shop::InsertGroup()
Вставку/обновление группы товаров
InsertGroupPolls in file Polls.class.php, method polls::InsertGroupPolls()
Вставка информации о группе опросов
InsertHelpdesk in file helpdesk.class.php, method helpdesk::InsertHelpdesk()
Добавление информации о службе технической поддержки.
InsertInformationGroup in file InformationSystems.class.php, method InformationSystem::InsertInformationGroup()
Вставка/обновление информации об информационной группе
InsertInformationGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationGroups()
Вставка/обновление данных об информационной группе. Устаревший метод
InsertInformationItem in file InformationSystems.class.php, method InformationSystem::InsertInformationItem()
Вставка/обновление данных об информационном элементе
InsertInformationItems in file InformationSystems.class.php, method InformationSystem::InsertInformationItems()
Вставка/обновление данных об информационном элементе. Устаревший метод
InsertInformationItemTags in file InformationSystems.class.php, method InformationSystem::InsertInformationItemTags()
Вставка тегов для информационных элементов
InsertInformationPropertys in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertys()
Вставка/обновление информации о дополнительном свойстве информационных элементов
InsertInformationPropertysGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroups()
Вставка/редактирование информации о дополнительном свойстве групп информационной системы
InsertInformationPropertysGroupsValue in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroupsValue()
Вставка/обновление значения свойства информационной группы
InsertInformationPropertysItems in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysItems()
Вставка/обновление значения свойства элемента информационной системы
InsertInformationSystemsDir in file InformationSystems.class.php, method InformationSystem::InsertInformationSystemsDir()
Добавление/обновление раздела информационных систем
InsertInfotmationSystem in file InformationSystems.class.php, method InformationSystem::InsertInfotmationSystem()
Вставка/обновление данных об информационной системе
InsertIp in file ip.class.php, method ip::InsertIp()
Вставка/обновление информации об IP-адресе
InsertItem in file shop.class.php, method shop::InsertItem()
Вставка информации о товаре. Может принимать только часть параметров, при этом обновлены будут только переданные значения
InsertItemDiscount in file shop.class.php, method shop::InsertItemDiscount()
Метод вставки скидки для определенного товара
InsertItemsCatalogTags in file shop.class.php, method shop::InsertItemsCatalogTags()
Вставка тегов для товаров
InsertLib in file lib.class.php, method lib::InsertLib()
Вставка информации о типовой динамической странице
InsertLibDir in file lib.class.php, method lib::InsertLibDir()
Вставка/обновление информации о разделе типовых динамических страниц
InsertLibProperty in file lib.class.php, method lib::InsertLibProperty()
Вставка информации о параметре типовой динамической страницы
InsertLibPropertyListItem in file lib.class.php, method lib::InsertLibPropertyListItem()
Вставка/обновление элемента списка для параметра типовой динамической страницы
InsertList in file Lists.class.php, method lists::InsertList()
Вставка/обновление данных о списке
InsertListDir in file Lists.class.php, method lists::InsertListDir()
Добавление/редактирование раздела списков
InsertListItem in file Lists.class.php, method lists::InsertListItem()
Вставка/обновление данных об элементе списка
InsertLocation in file shop.class.php, method shop::InsertLocation()
Метод, осуществляющий вставку области
InsertMaillist in file Maillist.class.php, method Maillist::InsertMaillist()
Добавление/редактирование информации о рассылке
InsertMessage in file helpdesk.class.php, method helpdesk::InsertMessage()
Добавление/обновление сообщения
InsertMesure in file shop.class.php, method shop::InsertMesure()
Метод, осуществляющий вставку информации о единице измерения
InsertOrder in file shop.class.php, method shop::InsertOrder()
Метод, осуществляющий вставку заказа
InsertOrderDiscount in file shop.class.php, method shop::InsertOrderDiscount()
Метод для вставки/обновления информации о скидке для заказов
InsertOrderItems in file shop.class.php, method shop::InsertOrderItems()
Метод, осуществляющий вставку товара в заказ
InsertOrderStatus in file shop.class.php, method shop::InsertOrderStatus()
Метод, осуществляющий вставку статуса заказа
InsertOrderWithoutSystemOfPay in file shop.class.php, method shop::InsertOrderWithoutSystemOfPay()
Метод вставки заказа, если платежная система не выбрана
InsertPositionSearch in file seo.class.php, method Seo::InsertPositionSearch()
Добавление/обновление статистики по поисковым запросам в БД
InsertPrice in file shop.class.php, method shop::InsertPrice()
Метод, осуществляющий вставку типа цены
InsertPricesToItem in file shop.class.php, method shop::InsertPricesToItem()
Метод вставки связи товара и цены из справочника цен
InsertProducer in file shop.class.php, method shop::InsertProducer()
Метод, осуществляющий вставку производителя
InsertPropertiesGroupsDir in file shop.class.php, method shop::InsertPropertiesGroupsDir()
Добавление информации о группе дополнительных свойств каталогов товаров
InsertPropertiesGroupValue in file shop.class.php, method shop::InsertPropertiesGroupValue()
Вставка значение дополнительного свойства групп товаров
InsertPropertiesItem in file shop.class.php, method shop::InsertPropertiesItem()
Метод вставки значения дополнительного свойства товара
InsertPropertiesItemsDir in file shop.class.php, method shop::InsertPropertiesItemsDir()
Добавление информации о группе дополнительных свойств товара
InsertPropertyForGroup in file shop.class.php, method shop::InsertPropertyForGroup()
Установка принадлежности дополнительного свойства группе товаров
InsertPropertyGroupsDir in file InformationSystems.class.php, method InformationSystem::InsertPropertyGroupsDir()
Добавление информации о группе дополнительных свойств групп информационной системы
InsertPropertysItemsDir in file InformationSystems.class.php, method InformationSystem::InsertPropertysItemsDir()
Добавление информации о группе дополнительных свойств информационных элементов
InsertPropretyOfGroup in file shop.class.php, method shop::InsertPropretyOfGroup()
Вставка дополнительного свойства группы товаров
InsertPropretyOfItems in file shop.class.php, method shop::InsertPropretyOfItems()
Метод, осуществляющий вставку свойства товара
InsertQuery in file seo.class.php, method Seo::InsertQuery()
Добавление/обновление поискового запроса в БД
InsertRecord in file Counter.class.php, method counter::InsertRecord()
Добавление записи в основную таблицу статистики
InsertResponsible in file helpdesk.class.php, method helpdesk::InsertResponsible()
Добавление ответственного пользователя
InsertSearchInQuery in file Search.class.php, method Search::InsertSearchInQuery()
Метод для вставки запроса в журнал поисковых запросов
InsertSeller in file shop.class.php, method shop::InsertSeller()
Метод, осуществляющий вставку или обновление продавца.
InsertSession in file Counter.class.php, method counter::InsertSession()
Вставка записи о сессии
InsertSettings in file admin_forms.class.php, method admin_forms::InsertSettings()
Вставка/обновление информации о настройках формы для пользователя
InsertShop in file shop.class.php, method shop::InsertShop()
Вставка информации о магазине
InsertShopsDir in file shop.class.php, method shop::InsertShopsDir()
Добавление/обновление раздела иентернет-магазинов
InsertSiteUser in file Site_users.class.php, method SiteUsers::InsertSiteUser()
Добавление/обновление информации о пользователе сайта
InsertSiteUserAccountTransaction in file shop.class.php, method shop::InsertSiteUserAccountTransaction()
Вставка в базу данных транзакции по лицевому счету пользователя
InsertSiteUsersMail in file messages.class.php, method messages::InsertSiteUsersMail()
Вставка/обновление сообщения
InsertSpecialPrice in file shop.class.php, method shop::InsertSpecialPrice()
Добавление информации о специальной цене
InsertStatus in file helpdesk.class.php, method helpdesk::InsertStatus()
Обновление/добавление статуса
InsertStructure in file Structure.class.php, method Structure::InsertStructure()
Метод добавления/редактирования узла структуры
InsertStructurePropertys in file Structure.class.php, method Structure::InsertStructurePropertys()
Метод вставки и редактирования дополнительного свойства для структуры
InsertStructurePropertysValue in file Structure.class.php, method Structure::InsertStructurePropertysValue()
Метод вставки и редактирования значения дополнительного свойства в таблице связи
InsertSupportWoktime in file helpdesk.class.php, method helpdesk::InsertSupportWoktime()
Добавление рабочего дня службы технической поддержки
InsertSystemOfPay in file shop.class.php, method shop::InsertSystemOfPay()
Метод, осуществляющий вставку платёжной системы
InsertTag in file tag.class.php, method Tag::InsertTag()
Вставка/обновление тега
InsertTagRelation in file tag.class.php, method Tag::InsertTagRelation()
Вставка соответствия тега элементам контента
InsertTagsGroup in file tag.class.php, method Tag::InsertTagsGroup()
Вставка/обновление группы тегов
InsertTax in file shop.class.php, method shop::InsertTax()
Метод, осуществляющий вставку налога
InsertTemplate in file Templates.class.php, method templates::InsertTemplate()
Метод добавления макета
InsertTemplate in file helpdesk.class.php, method helpdesk::InsertTemplate()
Добавление/обновление информации о стандартном ответе
InsertTemplateDir in file helpdesk.class.php, method helpdesk::InsertTemplateDir()
Добавление/обновление информации о категории стандартных ответов
InsertTemplateKeyWords in file helpdesk.class.php, method helpdesk::InsertTemplateKeyWords()
Добавление/обновление информации о ключевом слове
InsertTemplatesGroup in file Templates.class.php, method templates::InsertTemplatesGroup()
Метод добавления/обновления группы макетов
InsertTheme in file Forums.class.php, method Forums::InsertTheme()
Вставка/обновление информации о теме
InsertThemeUserSubscribe in file Forums.class.php, method Forums::InsertThemeUserSubscribe()
Подписка пользователя сайта на тему форума
InsertTicket in file helpdesk.class.php, method helpdesk::InsertTicket()
Добавление информации об инциденте
InsertTicketFlags in file helpdesk.class.php, method helpdesk::InsertTicketFlags()
Добавление/обновление флага к тикету
InsertToCart in file shop.class.php, method shop::InsertToCart()
Метод добавления информации о товаре в таблицу корзины
InsertTreeGroup in file shop.class.php, method shop::InsertTreeGroup()
Вставки дерева групп для CML v. 2.0x
InsertTyingProducts in file shop.class.php, method shop::InsertTyingProducts()
Метод добавления информации о сопутствующем товаре
InsertTypeOfDelivery in file shop.class.php, method shop::InsertTypeOfDelivery()
Метод, осуществляющий вставку типа доставки
InsertUser in file UserAccess.class.php, method user_access::InsertUser()
Метод вставки и обновления информации о пользователе
InsertUserDeniedAccess in file UserAccess.class.php, method user_access::InsertUserDeniedAccess()
Метод записи в базу информации о неудачной попытке входа в BackOffice
InsertUserGroup in file Site_users.class.php, method SiteUsers::InsertUserGroup()
Вставки/обновление информации о группе пользователей
InsertUsers in file Maillist.class.php, method Maillist::InsertUsers()
Метод добавления/редактирования информации о подписчике
InsertUsers in file Site_users.class.php, method SiteUsers::InsertUsers()
Добавление пользователя в группу
InsertUsersGroup in file Maillist.class.php, method Maillist::InsertUsersGroup()
Метод, открывающий доступ группе пользователей сайта к рассылке
InsertUsersGroup in file Forums.class.php, method Forums::InsertUsersGroup()
Метод добавления/редактирования группы пользователей для определения доступа к форуму
InsertUsersLetterTemplate in file helpdesk.class.php, method helpdesk::InsertUsersLetterTemplate()
Добавление/обновление шаблона письма
InsertVote in file Polls.class.php, method polls::InsertVote()
Устаревший метод. Вставка ответа на опрос.
InsertWarehouse in file warehouse.class.php, method warehouse::InsertWarehouse()
Вставка/обновление склада
InsertWarehouseItems in file warehouse.class.php, method warehouse::InsertWarehouseItems()
Вставка/обновление количества товара на складе.
InsertWeekend in file helpdesk.class.php, method helpdesk::InsertWeekend()
Вставка/обновление информации о специальном рабочем/выходном дне
InsertWord in file admin_forms.class.php, method admin_forms::InsertWord()
Вставка/обновление слова
InsertWordsValue in file admin_forms.class.php, method admin_forms::InsertWordsValue()
Вставка информации о значении слова
InsertXsl in file Xsl.class.php, method xsl::InsertXsl()
Метод вставки/обновления информации об XSL-шаблоне.
InsertXslDir in file Xsl.class.php, method xsl::InsertXslDir()
Метод вставки и обновления XSL-рубрик
insert_alias in file Site.class.php, method site::insert_alias()
Метод вставки/обновления информации об алиасе (домене) сайта
insert_data_templates in file Templates.class.php, method templates::insert_data_templates()
Методы добавления (редактирования) шаблонов страниц
insert_documents in file Documents.class.php, method documents::insert_documents()
Вставка/обновление новых документов
insert_documents_dir in file Documents.class.php, method documents::insert_documents_dir()
Вставка/обновления разделов документов
insert_lists in file Lists.class.php, method lists::insert_lists()
Устаревший метод. Вставка/обновление данных о списке
insert_lists_items in file Lists.class.php, method lists::insert_lists_items()
Устаревший метод. Вставка/обновление данных об элементе списка
insert_module in file Modules.class.php, method modules::insert_module()
Метод вставки/обновления информации о модуле
insert_poll in file Polls.class.php, method polls::insert_poll()
Вставка и обновление опроса
insert_poll_reply in file Polls.class.php, method polls::insert_poll_reply()
Вставка и обновление вариантов ответов
Insert_search_word in file Search.class.php, method Search::Insert_search_word()
Метод формирует индекс для переданного блока страниц
insert_site in file Site.class.php, method site::insert_site()
Вставка/обновление информации о сайте
insert_status in file Documents.class.php, method documents::insert_status()
Метод добавления(редактирования) статусов документов
insert_user_type in file UserAccess.class.php, method user_access::insert_user_type()
Метод вставки и обновления информации о типе пользователей
insert_version in file Documents.class.php, method documents::insert_version()
Метод добавления/редактирования записей о версиях
insert_xsl in file Xsl.class.php, method xsl::insert_xsl()
Метод вставки/обновления XSL. Устаревший метод
insert_xsl_dir in file Xsl.class.php, method xsl::insert_xsl_dir()
Метод вставки и обновления XSL-рубрик. Устаревший метод
ip in file ip.class.php, class ip
Система управления сайтом HostCMS v. 5.xx
ip.class.php | procedural page ip.class.php
ip.php | procedural page ip.php
IpIsNew in file Counter.class.php, method counter::IpIsNew()
Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта
isActive in file JsHttpRequest.php, method JsHttpRequest::isActive()
Static function.
IsBase64Encoded in file Mail.class.php, method Mail::IsBase64Encoded()
Проверка строки на то, является ли она закодированной base64
IsOrderOfThisSiteUser in file shop.class.php, method shop::IsOrderOfThisSiteUser()
Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта
IsSearchSystem in file Counter.class.php, method counter::IsSearchSystem()
Определение запроса из поисковой системы. Метод работает с поисковыми системами:
IssetAccessForInformationSystemGroup in file InformationSystems.class.php, method InformationSystem::IssetAccessForInformationSystemGroup()
Проверка возможности доступа пользователя к информационной группе
IssetAccessForShopGroup in file shop.class.php, method shop::IssetAccessForShopGroup()
Проверка возможности доступа пользователя к группе товаров
IssetForumAccess in file Forums.class.php, method Forums::IssetForumAccess()
Определение доступа пользователя к форуму
IssetGroup in file InformationSystems.class.php, method InformationSystem::IssetGroup()
Проверка наличия среди подгрупп данной группы подгруппы с таким же URL как и у вставляемой/редактируемой группы
IssetGroupItemInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetGroupItemInsertUpdate()
Проверка наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента
IssetItem in file InformationSystems.class.php, method InformationSystem::IssetItem()
Проверка наличия элемента с конкретным URL среди информационных элементов данной группы
IssetItemGroupInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetItemGroupInsertUpdate()
Проверка наличия среди информационных элементов данной группы такого, у которого URL совпадает с URL добавляемой/редактируемой информационной группы
IssetModule in file Modules.class.php, method modules::IssetModule()
Метод проверки наличия активного модуля
IssetPath in file Structure.class.php, method Structure::IssetPath()
Метод определения наличия пути
IssetPropertyForGroup in file shop.class.php, method shop::IssetPropertyForGroup()
Определение принадлежности дополнительного свойства группе товаров
IssetSiteUserInUsersGroupInformationGroup in file InformationSystems.class.php, method InformationSystem::IssetSiteUserInUsersGroupInformationGroup()
Проверка вхождения пользователя сайта в группу пользователей, связанную с информационной группой
IssetThemeUserSubscribe in file Forums.class.php, method Forums::IssetThemeUserSubscribe()
Проверка подписки пользователя сайта на тему форума
IssetUserAccessForObject in file UserAccess.class.php, method user_access::IssetUserAccessForObject()
Определене возможности доступа пользователя к управлению объектом
IssetUserEventAccess in file UserAccess.class.php, method user_access::IssetUserEventAccess()
Определение доступности действия формы центра администрирования для пользователя
IssetUsersTypeEventAccess in file UserAccess.class.php, method user_access::IssetUsersTypeEventAccess()
Определение доступности действия формы центра администрирования для группы пользователей
isset_id in file Counter.class.php, method counter::isset_id()
Проверка наличия id сайта
is_dir in file Cache.class.php, method Cache::is_dir()
Проверяет наличие директории и в случае успеха сохраняет результат. Служебный метод.
Image.class.php | procedural page Image.class.php
top
j
$joint_height in file Graphic.class.php, variable graphic::$joint_height
Высота соединяемых частей
$joint_space in file Graphic.class.php, variable graphic::$joint_space
Расстояние между углами сегментов
$joint_space_connection in file Graphic.class.php, variable graphic::$joint_space_connection
Расстояние между сегментами
JoinTags in file tag.class.php, method Tag::JoinTags()
Объединение тегов, теги объединяются по наименьшему идентификатору, тег с наименьшим идентификатором получает данные всех остальных тегов, остальные теги удаляются
JsHttpRequest in file JsHttpRequest.php, method JsHttpRequest::JsHttpRequest()
Constructor.
JsHttpRequest in file JsHttpRequest.php, class JsHttpRequest
JsHttpRequest: PHP backend for JavaScript DHTML loader.
JsHttpRequest.php | procedural page JsHttpRequest.php
top
k
$kernel | in file SiteTemplate.class.php, variable SiteTemplate::$kernel
$keystring in file Captcha.class.php, variable Captcha::$keystring
Значение CAPTCHA
kernel | in file Kernel.class.php, method kernel::kernel()
kernel in file Kernel.class.php, class kernel
Система управления сайтом HostCMS v. 5.xx
Kernel.class.php | procedural page Kernel.class.php
Kernel.php | procedural page Kernel.php
top
l
$legend_height in file Graphic.class.php, variable graphic::$legend_height
Длина легенды
$legend_width in file Graphic.class.php, variable graphic::$legend_width
Ширина легенды
$letters in file Mail.class.php, variable Mail::$letters
Массив, содержащий письма
$level in file Structure.class.php, variable Structure::$level
Максимальный уровень структуры
$line_width in file Graphic.class.php, variable graphic::$line_width
Ширина линии
$LOADER | in file JsHttpRequest.php, variable JsHttpRequest::$LOADER
$lockPrefix in file Kernel.php, variable Session::$lockPrefix
Префикс для блокировки
$lockTimeout in file Kernel.php, variable Session::$lockTimeout
Таймаут попытки заблокировать сессию, в секундах.
lib in file lib.class.php, class lib
Система управления сайтом HostCMS v. 5.xx
lib.class.php | procedural page lib.class.php
lib.php | procedural page lib.php
LinearGraphic in file Graphic.class.php, method graphic::LinearGraphic()
Построение линейного графика
link_len in file Url.class.php, method url::link_len()
Метод сокращения длины строки
lists in file Lists.class.php, class lists
Класс модуля "Списки"
Lists.class.php | procedural page Lists.class.php
Lists.php | procedural page Lists.php
LoadAttachments in file helpdesk.class.php, method helpdesk::LoadAttachments()
Загрузка на сервер вложенных файлов
LoadFile | in file SiteTemplate.class.php, method SiteTemplate::LoadFile()
LoadLibPropertiesValue in file lib.class.php, method lib::LoadLibPropertiesValue()
Загрузка значений параметров типовой дин. страницы для структуры
LoadModuleFiles in file Kernel.class.php, method kernel::LoadModuleFiles()
Служебный метод
LoadModules in file Kernel.class.php, method kernel::LoadModules()
Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS
LoadModulesLngFile in file Kernel.class.php, method kernel::LoadModulesLngFile()
Метод загрузки языкового файла для модуля
load_files in file FileManager.class.php, method FileManager::load_files()
Загрузка файлов
log_access in file EventsJournal.class.php, method EventsJournal::log_access()
Метод протоколирования получения доступа к системе управления
top
m
$mail_box in file Mail.class.php, variable Mail::$mail_box
Почтовый ящик, к которому выполняется доступ
$MasGroup | in file shop.class.php, variable shop::$MasGroup
$MasGroup in file InformationSystems.class.php, variable InformationSystem::$MasGroup
Массив групп
$mas_data_templates_dir | in file Templates.class.php, variable templates::$mas_data_templates_dir
$mas_documents_dir in file Documents.class.php, variable documents::$mas_documents_dir
Массив разделов документов
$mas_lib_dir | in file lib.class.php, variable lib::$mas_lib_dir
$mas_xsl_dir | in file Xsl.class.php, variable xsl::$mas_xsl_dir
$mas_xsl_group_path in file Xsl.class.php, variable xsl::$mas_xsl_group_path
Массив с информацией о пути к каждому разделу XSL
$max_leght_legend in file Graphic.class.php, variable graphic::$max_leght_legend
Максимальная длина подписи легенды в диаграмме
$max_lenght in file Captcha.class.php, variable Captcha::$max_lenght
Максимальная длина строки CAPTCHA
$menus | in file admin_forms_fields.class.php, variable admin_forms_fields::$menus
$menu_id in file Structure.class.php, variable Structure::$menu_id
Идентификатор раздела меню
$MessageTree in file helpdesk.class.php, variable helpdesk::$MessageTree
Дерево сообщений тикета
$min_division_x in file Graphic.class.php, variable graphic::$min_division_x
Минимальное расстояние между делениями по оси х
$min_lenght in file Captcha.class.php, variable Captcha::$min_lenght
Минимальная длина строки CAPTCHA
$min_percent_diagr in file Graphic.class.php, variable graphic::$min_percent_diagr
Минимальный процент, отображаемый на диаграмме
$ModuleClass in file Search.class.php, variable Search::$ModuleClass
Массив соответствия идентификаторов модулей в таблице страниц модулям,
$modules in file Kernel.class.php, variable kernel::$modules
Информация о загруженных модулях системы
Mysqldump.class.php | procedural page Mysqldump.class.php
Mail.class.php | procedural page Mail.class.php
Mbstring.fns.php | procedural page Mbstring.fns.php
Message.fns.php | procedural page Message.fns.php
Mysql.class.php | procedural page Mysql.class.php
MacroReplace | in file SiteTemplate.class.php, method SiteTemplate::MacroReplace()
Mail in file Mail.class.php, class Mail
Система управления сайтом HostCMS v. 5.xx
Maillist in file Maillist.class.php, class Maillist
Класс модуля "Почтовые рассылки"
Maillist.class.php | procedural page Maillist.class.php
Maillist.php | procedural page Maillist.php
MailReport in file Counter.class.php, method counter::MailReport()
Отправка письма с отчетом администратору сайта
MarkEraseSiteUsersMail in file messages.class.php, method messages::MarkEraseSiteUsersMail()
Удаление сообщения пользователем сайта
mb_ereg | in file Mbstring.fns.php, function mb_ereg()
mb_strlen | in file Mbstring.fns.php, function mb_strlen()
mb_strpos | in file Mbstring.fns.php, function mb_strpos()
mb_strrpos | in file Mbstring.fns.php, function mb_strrpos()
mb_strtolower | in file Mbstring.fns.php, function mb_strtolower()
mb_strtoupper | in file Mbstring.fns.php, function mb_strtoupper()
mb_substr | in file Mbstring.fns.php, function mb_substr()
mb_substr_count | in file Mbstring.fns.php, function mb_substr_count()
memory_get_usage | in file Kernel.php, function memory_get_usage()
MessageBlockUnblock in file helpdesk.class.php, method helpdesk::MessageBlockUnblock()
Блокирование/разблокирование сообщения
MessageIsTheme in file Forums.class.php, method Forums::MessageIsTheme()
Проверка сообщения на то, что является ли оно темой
MessageOnlyOwn | in file UserAccess.class.php, method user_access::MessageOnlyOwn()
messages | in file messages.class.php, class messages
messages.class.php | procedural page messages.class.php
messages.php | procedural page messages.php
modules in file Modules.class.php, class modules
Класс модуля "Управление модулями"
Modules.class.php | procedural page Modules.class.php
Modules.php | procedural page Modules.php
MoveInfGroupImage in file SiteTemplate.class.php, method SiteTemplate::MoveInfGroupImage()
Копирование изображений для ИГ
MoveInfItemImage in file SiteTemplate.class.php, method SiteTemplate::MoveInfItemImage()
Копирование изображений для ИЭ
MoveInfItemPropertyImage in file SiteTemplate.class.php, method SiteTemplate::MoveInfItemPropertyImage()
Копирование изображений для доп. свойств ИЭ
MoveShopGroupImage in file SiteTemplate.class.php, method SiteTemplate::MoveShopGroupImage()
Копирование изображений для группы товаров
MoveShopItemImage in file SiteTemplate.class.php, method SiteTemplate::MoveShopItemImage()
Копирование изображений для товара
MoveShopItemPropertyImage in file SiteTemplate.class.php, method SiteTemplate::MoveShopItemPropertyImage()
Копирование изображений для доп. свойств товара
MoveStructureItemPropertyImage in file SiteTemplate.class.php, method SiteTemplate::MoveStructureItemPropertyImage()
Копирование значения доп. свойства типа "Файл" узла структуры
my_array_multisort in file Kernel.class.php, method kernel::my_array_multisort()
Сортировка многомерного массива $array по полю $filed_name
Menu.class.php | procedural page Menu.class.php
top
n
$new_session in file Counter.class.php, variable counter::$new_session
Флаг добавления новой сессии при обновлении данных счетчика
$nextStepDelay in file Kernel.php, variable Session::$nextStepDelay
Время задержки перед повторной блокировкой, в мс.
$nl2br | in file cml.class.php, variable cml::$nl2br
$no_spaces in file Captcha.class.php, variable Captcha::$no_spaces
Флаг, указывающий, слитно писать символы CAPTCHA или нет
NodeIsParent in file Structure.class.php, method Structure::NodeIsParent()
Метод определения принадлежности узла структуры вышестоящему родителю
NoticeTheme in file Forums.class.php, method Forums::NoticeTheme()
Метод делающий тему объявлением или наоборот
numeric_character_references in file Kernel.class.php, method kernel::numeric_character_references()
Метод преобразует сущности в их числовое представление, например &amp;nbsp; в &#160;
top
o
$on_page in file admin_forms.class.php, variable admin_forms::$on_page
Число элементов формы на страницу
$order_field_direction in file admin_forms.class.php, variable admin_forms::$order_field_direction
Направление сортировки: 1 - ASC, 2 - DESC.
$order_field_id in file admin_forms.class.php, variable admin_forms::$order_field_id
Идентификатор поля сортировки.
OrderExtraProperty in file Site_users.class.php, method SiteUsers::OrderExtraProperty()
Метод обновления коэффициентов порядка сортировки
OrderForums in file Forums.class.php, method Forums::OrderForums()
Метод изменения порядка сортировки форумов в группе
OrderForumsGroup in file Forums.class.php, method Forums::OrderForumsGroup()
Метод изменения порядка сортировки групп форумов
OS_UNIX | in file tar.class.php, constant OS_UNIX
top
p
$page_number in file admin_forms.class.php, variable admin_forms::$page_number
Номер текущей страницы формы
$parent_id in file Structure.class.php, variable Structure::$parent_id
Идентификатор родительского узла элемента структуры
$Path in file helpdesk.class.php, variable helpdesk::$Path
Массив, содержащий путь от корневой категории
$PathArrayGetInformationFromPath in file InformationSystems.class.php, variable InformationSystem::$PathArrayGetInformationFromPath
Массив имен узлов, для которых необходимо в результирующем массиве метода GetInformationFromPath() указать наличие этих узлов.
$path_array | in file Documents.class.php, variable documents::$path_array
$path_array | in file Templates.class.php, variable templates::$path_array
$polygon_max_corner in file Captcha.class.php, variable Captcha::$polygon_max_corner
Максимальное значение количества углов многоугольника на фоне CAPTCHA
$polygon_max_radius in file Captcha.class.php, variable Captcha::$polygon_max_radius
Максимальное значение радиуса многоугольника на фоне CAPTCHA
$polygon_min_corner in file Captcha.class.php, variable Captcha::$polygon_min_corner
Минимальное значение количества углов многоугольника на фоне CAPTCHA
$polygon_min_radius in file Captcha.class.php, variable Captcha::$polygon_min_radius
Минимальное значение радиуса многоугольника на фоне CAPTCHA
$port in file Mail.class.php, variable Mail::$port
Порт
$probability in file Cache.class.php, variable Cache::$probability
Вероятность удаления истекших элементов кэша
$PropertyGroupMass in file shop.class.php, variable shop::$PropertyGroupMass
Кэш с данными о дополнительных свойствах групп магазина
$PropertyGroupMass in file InformationSystems.class.php, variable InformationSystem::$PropertyGroupMass
Кэш с данными о дополнительных свойствах информационных групп
$PropertyMass in file InformationSystems.class.php, variable InformationSystem::$PropertyMass
Кэш с данными о свойствах инфоррмационных элементов
$protocol in file Mail.class.php, variable Mail::$protocol
Протокол соединения
Password.class.php | procedural page Password.class.php
PageCompressionBegin in file Compression.class.php, method compression::PageCompressionBegin()
Запуск приема из стандартного потока содержимого для компрессии
PageCompressionEnd in file Compression.class.php, method compression::PageCompressionEnd()
Вывод сжатых данных, размещенных в потоке
PAGE_DIR | in file Kernel.php, constant PAGE_DIR
ParseGoogle | in file seo.class.php, method Seo::ParseGoogle()
ParseHeaderAndBody in file Mail.class.php, method Mail::ParseHeaderAndBody()
Разбор тела сообщения
ParseMessage in file Mail.class.php, method Mail::ParseMessage()
Разбор сообщения по частям
ParseYandex | in file seo.class.php, method Seo::ParseYandex()
PathCorrection in file File.class.php, method File::PathCorrection()
Метод удаляет потенциально опасные символы из пути или имени файла
PathCorrection in file FileManager.class.php, method FileManager::PathCorrection()
Устаревший, заменен File::PathCorrection(). Метод удаляет потенциально опасные символы из пути или имени файла.
PathMkdir in file Kernel.class.php, method kernel::PathMkdir()
Создание директорий относительно корневой директории сайта
php2js in file JsHttpRequest.php, method JsHttpRequest::php2js()
Convert a PHP scalar, array or hash to JS scalar/array/hash. This function is an analog of json_encode(), but it can work with a non-UTF8 input and does not analyze the passed data. Output format must be fully JSON compatible.
phpversion in file Kernel.class.php, method kernel::phpversion()
Метод возвращает номер версии PHP
PNG_QUALITY | in file Kernel.php, constant PNG_QUALITY
polls in file Polls.class.php, class polls
Класс модуля "Опросы"
Polls.class.php | procedural page Polls.class.php
Polls.php | procedural page Polls.php
PrivateOfficeXML in file Site_users.class.php, method SiteUsers::PrivateOfficeXML()
УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.
ProcessAjax in file admin_forms.class.php, method admin_forms::ProcessAjax()
Обработчик вызывает обработку действий и построение формы
ProcessOrder in file shop.class.php, method shop::ProcessOrder()
Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты
ProcessTypographic in file typograph.class.php, method typograph::ProcessTypographic()
Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.
top
q
$quality in file Graphic.class.php, variable graphic::$quality
Качество рисунка
query in file Mysql.class.php, method DataBase::query()
Метод выполнения SQL-запроса
quoteInput in file JsHttpRequest.php, method JsHttpRequest::quoteInput()
string quoteInput(string $input)
quote_smart in file Security.fns.php, function quote_smart()
Экранирует потенциально опасные символы для MySQL запросов
top
r
$read_lock in file Cache.class.php, variable Cache::$read_lock
Блокировать ли файл кэша при чтении. по умолчанию false
$resize_extension in file Kernel.class.php, variable kernel::$resize_extension
Рашсирения графических файлов, доступные для уменьшения
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RssRead.class.php | procedural page RssRead.class.php
RssWrite.class.php | procedural page RssWrite.class.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RamblerPokupki in file shop.class.php, method shop::RamblerPokupki()
Вывод данных для эксопрта в RamblerPokupki. Метод отправляет соответствующий заголовок и возвращает XML данные.
random_shuffle in file Kernel.class.php, method kernel::random_shuffle()
Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.
ReadRSS in file RssRead.class.php, method RssRead::ReadRSS()
Метод чтения данных из RSS потока
RecalcMessagesInfo in file messages.class.php, method messages::RecalcMessagesInfo()
Метод пересчёта информации о дереве сообщений
RecountAnswerDateTime in file helpdesk.class.php, method helpdesk::RecountAnswerDateTime()
Обновление приблизительной даты ответа на сообщение
ReductionDescription in file Kernel.class.php, method kernel::ReductionDescription()
Укорачивает описание до определённого количества символов, оставляя целое число предлодений
ReFormat in file helpdesk.class.php, method helpdesk::ReFormat()
Преобразование текста в другой формат
RemoveInit in file Wysiwyg.class.php, method wysiwyg::RemoveInit()
Удаление записи из блока tinyMCE.init
RenewMaillist in file Maillist.class.php, method Maillist::RenewMaillist()
Метод обновления информации о подписке для конкретного подписчика
ReplaceFile in file SiteTemplate.class.php, method SiteTemplate::ReplaceFile()
Заменяет макросы в уже существующем файле
ReplaceMacro in file Maillist.class.php, method Maillist::ReplaceMacro()
Производит замену макроподстановки %TEXT в $template_text на переданный текст в $param['text']
ReplaceMailMacro in file helpdesk.class.php, method helpdesk::ReplaceMailMacro()
Макроподстановки в тексте
ReplaceMask in file Site.class.php, method site::ReplaceMask()
Удаляет маску "*." из адреса домена
ReplaceWithoutTagAttribute in file typograph.class.php, method typograph::ReplaceWithoutTagAttribute()
Производит замену массива подстрок $search на массив подстрок $replace в тексте $html, исключая замену в атрибутах HTML-тегов
ReplyMessageText in file helpdesk.class.php, method helpdesk::ReplyMessageText()
Цитирование текста сообщения, на которое посылается ответ
ResetBit in file Kernel.class.php, method kernel::ResetBit()
Установить бит числа в 0
resizeToFile in file Image.class.php, method Image::resizeToFile()
Метод изменения размера изображения
ResizeToFileEx in file Image.class.php, method Image::ResizeToFileEx()
Метод для пропорционального масштабирования изображения
Round in file shop.class.php, method shop::Round()
Округление цен к формату, приведенного в $this->float_format
RssRead in file RssRead.class.php, class RssRead
Система управления сайтом HostCMS v. 5.xx
RssWrite in file RssWrite.class.php, class RssWrite
Ядро, класс для генерации RSS.
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
top
s
$sAllowTag | in file helpdesk.class.php, variable helpdesk::$sAllowTag
$SCRIPT_DECODE_MODE | in file JsHttpRequest.php, variable JsHttpRequest::$SCRIPT_DECODE_MODE
$SCRIPT_ENCODING | in file JsHttpRequest.php, variable JsHttpRequest::$SCRIPT_ENCODING
$section_path | in file Xsl.class.php, variable xsl::$section_path
$section_path | in file lib.class.php, variable lib::$section_path
$SelectFilterCount | in file admin_forms_fields.class.php, variable admin_forms_fields::$SelectFilterCount
$separator in file Structure.class.php, variable Structure::$separator
Разделитель для уровней
$setCookieSubdomain in file shop.class.php, variable shop::$setCookieSubdomain
Устанавливать cookies для поддоменов.
$ShowBottom in file admin_forms.class.php, variable admin_forms::$ShowBottom
Показывать нижнюю строку с действиями
$ShowFilter in file admin_forms.class.php, variable admin_forms::$ShowFilter
Показывать фильтр
$ShowOperations in file admin_forms.class.php, variable admin_forms::$ShowOperations
Показывать действия
$ShowXmlContent | in file Kernel.class.php, variable kernel::$ShowXmlContent
$simbols in file Captcha.class.php, variable Captcha::$simbols
Порядок символов в шрифтах
$sModulesPath | in file Kernel.class.php, variable kernel::$sModulesPath
$sTemplatesUrlServer | in file SiteTemplate.class.php, variable SiteTemplate::$sTemplatesUrlServer
$stream in file Mail.class.php, variable Mail::$stream
Идентификатор открытого соединения с почтовым сервером
$StructuredList in file helpdesk.class.php, variable helpdesk::$StructuredList
Массив, содержащий структурированный список директорий
$StructureMass in file Structure.class.php, variable Structure::$StructureMass
Массив с элементами структуры
$StructureParentMass in file Structure.class.php, variable Structure::$StructureParentMass
Массив родительских разделов
$structure_propertys_list in file Structure.class.php, variable Structure::$structure_propertys_list
Хранит результат запроса на выборку дополнительных свойств структуры
Security.fns.php | procedural page Security.fns.php
SaveHeaders in file Mail.class.php, method Mail::SaveHeaders()
Сохранение заголовков письма
SaveLibPropertiesValue in file lib.class.php, method lib::SaveLibPropertiesValue()
Сохранение настроек типовой динамической страницы для стурктуры в файл
SaveStructure in file Mail.class.php, method Mail::SaveStructure()
Сохранение структуры сообщения
SaveToFile in file File.class.php, method File::SaveToFile()
Сохранение содержимого $content в файл с путем $filepath
Search in file Search.class.php, class Search
Система управления сайтом HostCMS v. 5.xx
Search.class.php | procedural page Search.class.php
Search.php | procedural page Search.php
SearchIndexing in file InformationSystems.class.php, method InformationSystem::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file Forums.class.php, method Forums::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file Site_users.class.php, method SiteUsers::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file Structure.class.php, method Structure::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file shop.class.php, method shop::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file helpdesk.class.php, method helpdesk::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchWords in file Search.class.php, method Search::SearchWords()
Поиск списка слов в индексе. Примеры использования см. в руководстве по интеграции.
select in file Mysql.class.php, method DataBase::select()
Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()
SelectAllItemsFromCartForUser in file shop.class.php, method shop::SelectAllItemsFromCartForUser()
Получение суммы налога, количества элементов и их общей цены для заданного пользователя
SelectAllItemsFromCookieCart in file shop.class.php, method shop::SelectAllItemsFromCookieCart()
Получение общего количества товаров, их общей стоимости и веса из корзины
SelectBanner in file Advertisement.class.php, method Advertisement::SelectBanner()
Определение баннера, доступного для показа
SelectBannersFromGroup in file Advertisement.class.php, method Advertisement::SelectBannersFromGroup()
Получение информации о баннерах группы
SelectBannersGroup in file Advertisement.class.php, method Advertisement::SelectBannersGroup()
Получение информации о конкретной группе баннеров или обо всех группах баннеров
SelectCityArea in file shop.class.php, method shop::SelectCityArea()
Получение информации о районе города (обо всех районах при $city_area_id=-1)
SelectExtraProperties in file Site_users.class.php, method SiteUsers::SelectExtraProperties()
Получение всех дополнительных свойств
SelectFascicle in file Maillist.class.php, method Maillist::SelectFascicle()
Получение данных о выпуске рассылки
SelectForms in file Forms.class.php, method Forms::SelectForms()
Получение данных о формах
SelectFormsFields in file Forms.class.php, method Forms::SelectFormsFields()
Получение данных о поле формы
SelectFormThemes in file Forums.class.php, method Forums::SelectFormThemes()
Получение результата запроса на выборку тем форума
SelectForumsGroup in file Forums.class.php, method Forums::SelectForumsGroup()
Устарвший метод, возвращающий информацию о группе форумов
SelectGroupsByName in file shop.class.php, method shop::SelectGroupsByName()
Получение информации обо всех группах магазина, имеющих название $shop_groups_name
SelectInformationGroups in file InformationSystems.class.php, method InformationSystem::SelectInformationGroups()
Получение информации об информационных группах Устаревший метод, ОСТАВЛЕН ДЛЯ СОВМЕСТИМОСТИ.
SelectInformationSystem in file InformationSystems.class.php, method InformationSystem::SelectInformationSystem()
Получение информации об информационной системе
SelectIp in file ip.class.php, method ip::SelectIp()
Получение информации об IP-адресах
SelectList in file Lists.class.php, method lists::SelectList()
Получение данных о списке
SelectListInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::SelectListInformationGroupPropertys()
Получение списка дополнительных свойств информационных группы информационной системы
SelectListsItems in file Lists.class.php, method lists::SelectListsItems()
Получение данных об элементах списка
SelectMaillist in file Maillist.class.php, method Maillist::SelectMaillist()
Получение данных о рассылке
SelectMessage in file Forums.class.php, method Forums::SelectMessage()
Метод возвращающий информацию о сообщении
SelectPollReply4Poll in file Polls.class.php, method polls::SelectPollReply4Poll()
Получение списка вариантов ответов на опрос по ID опроса
SelectPrice in file shop.class.php, method shop::SelectPrice()
Метод определения цены для заданной группы пользователей
SelectPropertysGroupsByDirParentId in file InformationSystems.class.php, method InformationSystem::SelectPropertysGroupsByDirParentId()
Получение списка дополнительных свойств информационных групп по идентификатору группы дополнительных свойств
SelectPropertysItemsByDirParentId in file InformationSystems.class.php, method InformationSystem::SelectPropertysItemsByDirParentId()
Получение списка дополнительных свойств информационных элементов по идентификатору группы дополнительных свойств
SelectSites in file Site.class.php, method site::SelectSites()
Выбор всех сайтов, поддерживаемых системой управления
SelectSiteUsersGroups in file Site_users.class.php, method SiteUsers::SelectSiteUsersGroups()
Получение данных о всех группах пользователей сайта
SelectStructureForParent in file Structure.class.php, method Structure::SelectStructureForParent()
Получение информации об узлах структуры конкрентного уровня
SelectStructurePropertys in file Structure.class.php, method Structure::SelectStructurePropertys()
Метод выбора дополнительного свойства структуры определенного сайта(false - выбор всех)
SelectThemeSubscribers in file Forums.class.php, method Forums::SelectThemeSubscribers()
Получение списка подписчиков на тему форума
SelectUser in file Maillist.class.php, method Maillist::SelectUser()
Получение информации о состоянии подписки подписчика на рассылку
SelectUserDeniedAccess in file UserAccess.class.php, method user_access::SelectUserDeniedAccess()
Получение списка неудачных доступов к BackOffice для конкретного ip-адреса
SelectUserSubscriptions in file Forums.class.php, method Forums::SelectUserSubscriptions()
Получение списка подписанных тем форума
SelectUserType in file Site_users.class.php, method SiteUsers::SelectUserType()
Метод возвращает параметры группы пользователя
select_alias in file Site.class.php, method site::select_alias()
Получение информации об алиасе (домене) сайта
select_comments in file InformationSystems.class.php, method InformationSystem::select_comments()
Получение комментариев к информационному элементу
select_data_templates in file Templates.class.php, method templates::select_data_templates()
Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $data_templates_id = -1)
select_documents in file Documents.class.php, method documents::select_documents()
Получение информации о документе или обо всех документах.
select_documents_dir in file Documents.class.php, method documents::select_documents_dir()
Метод выбора раздела документов
select_information_items in file InformationSystems.class.php, method InformationSystem::select_information_items()
Устаревший метод получения данных об информационном элементе. Рекомендуется использовать GetInformationSystemItem
select_lists_items in file Lists.class.php, method lists::select_lists_items()
Получение данных об элементе списка
select_modules in file Modules.class.php, method modules::select_modules()
Получение информации о модуле
select_poll in file Polls.class.php, method polls::select_poll()
Метод осуществляет выборку опросов
select_poll_reply in file Polls.class.php, method polls::select_poll_reply()
Метод выбора вариантов ответов по ID ответа
select_site in file Site.class.php, method site::select_site()
Получение данных о сайте
select_status in file Documents.class.php, method documents::select_status()
Получение информации о статусе документа
select_user in file UserAccess.class.php, method user_access::select_user()
УСТАРЕВШИЙ. Получение информации о пользователе
select_user_access in file UserAccess.class.php, method user_access::select_user_access()
Получение нформации о типах доступа пользователей
select_user_type in file UserAccess.class.php, method user_access::select_user_type()
УСТАРЕВШИЙ. Метод выбора типа пользователей
select_version in file Documents.class.php, method documents::select_version()
Метод выборки информации о версиях
select_xsl in file Xsl.class.php, method xsl::select_xsl()
Получение данных о XSL-шаблонах
select_xsl_dir in file Xsl.class.php, method xsl::select_xsl_dir()
Получение информации о XSL-разделах
SendFascicle in file Maillist.class.php, method Maillist::SendFascicle()
Метод отправки выпуска всем подписчикам рассылки
SendMailAboutOrder in file shop.class.php, method shop::SendMailAboutOrder()
Метод отправки писем о поступившем заказе пользователю и администратору
SendMailWithFile in file Kernel.class.php, method kernel::SendMailWithFile()
Метод отправки электронного письма с прикрепленным файлом
SendMessage in file helpdesk.class.php, method helpdesk::SendMessage()
Отправка сообщений
SendNewPassword in file Site_users.class.php, method SiteUsers::SendNewPassword()
Метод отправки нового пароля на почтовый ящик пользователю
SendRegistInf in file Site_users.class.php, method SiteUsers::SendRegistInf()
Метод отправки пользователю регистрационной информации
SentAutoAnswer in file helpdesk.class.php, method helpdesk::SentAutoAnswer()
Формирование и отсылка автоответа на сообщение
Seo in file seo.class.php, class Seo
Система управления сайтом HostCMS v. 5.xx
seo.class.php | procedural page seo.class.php
seo.php | procedural page seo.php
serverParse | in file Kernel.class.php, method kernel::serverParse()
Session | in file Kernel.php, class Session
Session | in file Kernel.php, method Session::Session()
sessionClose | in file Kernel.php, method Session::sessionClose()
sessionDestroyer | in file Kernel.php, method Session::sessionDestroyer()
sessionGc | in file Kernel.php, method Session::sessionGc()
sessionOpen | in file Kernel.php, method Session::sessionOpen()
sessionRead | in file Kernel.php, method Session::sessionRead()
sessionWrite | in file Kernel.php, method Session::sessionWrite()
setAAction in file admin_forms.class.php, method admin_forms::setAAction()
Устанавливает значение AAction
setAAdditionalParams in file admin_forms.class.php, method admin_forms::setAAdditionalParams()
Устанавливает значение AAdditionalParams
SetBit in file Kernel.class.php, method kernel::SetBit()
Установить бит числа
SetCart in file shop.class.php, method shop::SetCart()
Сохранение корзины в зависимости от CartType
SetChmodFile in file File.class.php, method File::SetChmodFile()
Установка прав доступа к создаваемых объектом файлов
SetChmodFile in file SiteTemplate.class.php, method SiteTemplate::SetChmodFile()
Установка прав доступа к создаваемых объектом файлов
SetConfirmation in file Site_users.class.php, method SiteUsers::SetConfirmation()
Установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)
SetConfirmationID in file Site_users.class.php, method SiteUsers::SetConfirmationID()
Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору
SetCookie in file shop.class.php, method shop::SetCookie()
Установка значения cookie
SetCookieCart in file shop.class.php, method shop::SetCookieCart()
Отправить в cookies содержимое корзины
SetCountAllComments in file shop.class.php, method shop::SetCountAllComments()
Установление числа комментариев к товарам
SetCurrentSite in file Admin.class.php, method Admin::SetCurrentSite()
Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта
SetCurrentSiteUser in file Site_users.class.php, method SiteUsers::SetCurrentSiteUser()
Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток
SetDefaultGroup in file Site_users.class.php, method SiteUsers::SetDefaultGroup()
Установка группы пользователей по умолчанию
setEncoding in file JsHttpRequest.php, method JsHttpRequest::setEncoding()
void setEncoding(string $encoding)
SetExpires in file Kernel.class.php, method kernel::SetExpires()
Метод установления времени истечения актуальности страницы
SetExternalHtml in file admin_forms_fields.class.php, method admin_forms_fields::SetExternalHtml()
Установить внешний HTML для формы
SetFlagTicket in file helpdesk.class.php, method helpdesk::SetFlagTicket()
Применение флага к тикету
SetLastModified in file Kernel.class.php, method kernel::SetLastModified()
Метод установления времени последнего изменения страницы
SetModerator in file Forums.class.php, method Forums::SetModerator()
Метод установления/снятия прав модератора текущего форума для группы пользователей
SetOrderPaymentStatus in file shop.class.php, method shop::SetOrderPaymentStatus()
Изменение статуса оплаты заказа
SetPathArrayGetInformationFromPath in file InformationSystems.class.php, method InformationSystem::SetPathArrayGetInformationFromPath()
Устаналивает свойство $this->PathArrayGetInformationFromPath
SetSessionCart in file shop.class.php, method shop::SetSessionCart()
Отправить в session содержимое корзины
SetTemplate in file Kernel.class.php, method kernel::SetTemplate()
Метод установления текущего макета
SetTemplatePath | in file SiteTemplate.class.php, method SiteTemplate::SetTemplatePath()
SetTemplatesUrlServer | in file SiteTemplate.class.php, method SiteTemplate::SetTemplatesUrlServer()
SetThemeId in file Forums.class.php, method Forums::SetThemeId()
Установка значения идентификатора добавленной темы форума
setTimestamp in file Kernel.class.php, method kernel::setTimestamp()
Изменение временной метки файла CSS-стиля для страницы
setTransparency in file Image.class.php, method Image::setTransparency()
Установка прозрачности для $new_image, равной прозрачности $image_source
SetUnload in file shop.class.php, method shop::SetUnload()
Установка статуса выгрузки заказа
SetUsersTypeAccess in file UserAccess.class.php, method user_access::SetUsersTypeAccess()
Метод вставки/обновления информации о доступе группы пользователей к модулю
SetUsersTypeAccessFormEvents in file UserAccess.class.php, method user_access::SetUsersTypeAccessFormEvents()
Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования
SetUsersTypeEventAccess in file UserAccess.class.php, method user_access::SetUsersTypeEventAccess()
Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования
SetValueExtraProperty in file Site_users.class.php, method SiteUsers::SetValueExtraProperty()
Установка значения дополнительного параметра пользователя
set_CSS in file Kernel.class.php, method kernel::set_CSS()
Метод изменения адреса файла CSS-стиля для страницы
set_current_page in file Kernel.class.php, method kernel::set_current_page()
Метод изменения адреса страницы
set_current_page_data_template in file Kernel.class.php, method kernel::set_current_page_data_template()
Метод изменения шаблона страницы
set_description in file Kernel.class.php, method kernel::set_description()
Метод изменения описания страницы
set_keywords in file Kernel.class.php, method kernel::set_keywords()
Метод изменения ключевых слов страницы
set_title in file Kernel.class.php, method kernel::set_title()
Метод изменения заголовока страницы
shop in file shop.class.php, class shop
Система управления сайтом HostCMS v. 5.xx
shop.class.php | procedural page shop.class.php
shop.php | procedural page shop.php
ShowAddComment in file InformationSystems.class.php, method InformationSystem::ShowAddComment()
Добавление комментария к элементу информационной системы
ShowAddEditTheme in file Forums.class.php, method Forums::ShowAddEditTheme()
Формирование XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
ShowAddress in file shop.class.php, method shop::ShowAddress()
Метод показа адреса для заказчика
ShowAdvertisement in file Advertisement.class.php, method Advertisement::ShowAdvertisement()
Показ баннера с использованием XML
ShowAdvertisementGroup in file Advertisement.class.php, method Advertisement::ShowAdvertisementGroup()
Показ баннера из указанной группы в соответствии с приоритетом. Для вывода баннера используется XSL-шаблон.
ShowAffiliate in file affiliate.class.php, method affiliate::ShowAffiliate()
Показ партнерских программ.
ShowAffiliatStatistics | in file affiliate.class.php, method affiliate::ShowAffiliatStatistics()
ShowArrow in file seo.class.php, method Seo::ShowArrow()
Отображение стрелочек динамики изменения значений
ShowArrowQuery in file seo.class.php, method Seo::ShowArrowQuery()
Отображение стрелочек динамики изменения значений поисковых запросов
ShowBanner in file Advertisement.class.php, method Advertisement::ShowBanner()
Показ баннера
ShowBannerGroup in file Advertisement.class.php, method Advertisement::ShowBannerGroup()
Показ баннера из указанной группы в соответствии с приоритетом
ShowBannerIsTrue in file Advertisement.class.php, method Advertisement::ShowBannerIsTrue()
Переход по ссылке баннера и наращивание счётчика, если с этого показа мы ещё не переходили
ShowBreadCrumbs in file admin_forms.class.php, method admin_forms::ShowBreadCrumbs()
Отображение хлебных крошек.
ShowCart in file shop.class.php, method shop::ShowCart()
Метод показа содержимого корзины
ShowConference in file Forums.class.php, method Forums::ShowConference()
Метод отображения конференции
ShowConfirmation in file shop.class.php, method shop::ShowConfirmation()
Метод вывода сообщения о необходимости подтвердить аккаунт
ShowCounterCode in file Counter.class.php, method counter::ShowCounterCode()
Отображение кода счетчика
ShowDocument in file Documents.class.php, method documents::ShowDocument()
Показ текста текущей версии страницы
ShowEditMessage in file Forums.class.php, method Forums::ShowEditMessage()
Формирование XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
ShowEmptyImage | in file Graphic.class.php, method graphic::ShowEmptyImage()
ShowEnter in file shop.class.php, method shop::ShowEnter()
Метод вывода формы для авторизации пользователя
ShowFlyPanel in file Kernel.class.php, method kernel::ShowFlyPanel()
Формирование панели редактирования элементов ЦА в клиентской части
ShowForm in file Forms.class.php, method Forms::ShowForm()
Отображение формы
ShowForm in file admin_forms_fields.class.php, method admin_forms_fields::ShowForm()
Отображение формы центра администрирования
ShowForm in file admin_forms.class.php, method admin_forms::ShowForm()
Обрабатывает действия формы, вызывает построение формы
ShowForumRss in file Forums.class.php, method Forums::ShowForumRss()
Отображение RSS ленты
ShowHelpdesk in file helpdesk.class.php, method helpdesk::ShowHelpdesk()
Показ списка тикетов службы поддержки
ShowInformationSystem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystem()
Отображение групп и элементов информационной системы
ShowInformationSystemItem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemItem()
Отображение информации об информационном элементе
ShowInformationSystemPageConfig in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemPageConfig()
Вызов настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы
ShowInformationSystemPageContent in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemPageContent()
Вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы
ShowInformationSystemRss in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemRss()
Отображение RSS ленты
ShowItem in file shop.class.php, method shop::ShowItem()
Метод вывода информации о товаре
ShowItemsCompare in file shop.class.php, method shop::ShowItemsCompare()
Метод отображает сравнение выбранных товаров в магазине
ShowLink in file admin_forms.class.php, method admin_forms::ShowLink()
Показ строки ссылок
ShowList in file Lists.class.php, method lists::ShowList()
Отображение элементов списка. Внутренний метод
ShowMaillist in file Maillist.class.php, method Maillist::ShowMaillist()
Метод отображения списка почтовых расслок пользователя
ShowMessage in file Forums.class.php, method Forums::ShowMessage()
Метод отображения сообщений форума
ShowMessages in file messages.class.php, method messages::ShowMessages()
Вывод личных сообщений пользователя сайта
ShowPoll in file Polls.class.php, method polls::ShowPoll()
Метод отображения опроса
ShowPollResult in file Polls.class.php, method polls::ShowPollResult()
Устаревший метод вывода результатов голосования
ShowPolls in file Polls.class.php, method polls::ShowPolls()
Устаревший метод! Метод отображения всех активных опросов
ShowPollsGroup in file Polls.class.php, method polls::ShowPollsGroup()
Отображение групп опросов
ShowPriceList | in file shop.class.php, method shop::ShowPriceList()
ShowProducersList in file shop.class.php, method shop::ShowProducersList()
Метод формирования xml для производителей
ShowSaller in file shop.class.php, method shop::ShowSaller()
Метод для отображение информации о продавце в клиентской части
ShowShop in file shop.class.php, method shop::ShowShop()
Показ магазина (товаров и групп).
ShowShops in file shop.class.php, method shop::ShowShops()
Показ списка магазинов
ShowSiteUserInfo in file Forums.class.php, method Forums::ShowSiteUserInfo()
Отображение данных о пользователе форума
ShowSiteUserRegistartion in file Site_users.class.php, method SiteUsers::ShowSiteUserRegistartion()
Вывод формы регистрации для пользователя сайта
ShowSiteUsersAccount in file shop.class.php, method shop::ShowSiteUsersAccount()
Отображение списка лицевых счетов пользователя
ShowSiteUsersAccountTransaction in file shop.class.php, method shop::ShowSiteUsersAccountTransaction()
Отображение списка транзакций пользователя
ShowStructure in file Structure.class.php, method Structure::ShowStructure()
Метод для отображения структуры в клиентском разделе сайта
ShowSystemOfPay in file shop.class.php, method shop::ShowSystemOfPay()
Метод построения XML для платежных систем
ShowTableRow in file seo.class.php, method Seo::ShowTableRow()
Отображение строк таблицы в Отчете
ShowTableTitleReport in file seo.class.php, method Seo::ShowTableTitleReport()
Отображение шапки таблицы в отчете
ShowTagsCloud in file shop.class.php, method shop::ShowTagsCloud()
Показ облака тегов для магазина
ShowTagsCloud in file InformationSystems.class.php, method InformationSystem::ShowTagsCloud()
Показ облака тегов для информационной системы
ShowThemes in file Forums.class.php, method Forums::ShowThemes()
Метод отображения тем форума
ShowTicket in file helpdesk.class.php, method helpdesk::ShowTicket()
Показ списка сообщений тикета
ShowTypeOfDelivery in file shop.class.php, method shop::ShowTypeOfDelivery()
Метод выбора и показа типов доставки
ShowUserMessages in file Forums.class.php, method Forums::ShowUserMessages()
Показ сообщений пользователя
ShowUserOffice in file Site_users.class.php, method SiteUsers::ShowUserOffice()
Метод отображения кабинета пользователя
ShowUserOrders in file shop.class.php, method shop::ShowUserOrders()
Отображение информации о заказах пользователя
ShowWorktime in file helpdesk.class.php, method helpdesk::ShowWorktime()
Показ режима работы службы техподдержки
show_CSS in file Kernel.class.php, method kernel::show_CSS()
Метод вывода CSS стиля для страницы
show_current_page in file Kernel.class.php, method kernel::show_current_page()
Метод вывода установленной страницы
show_current_template in file Kernel.class.php, method kernel::show_current_template()
Метод вывода текущего макета.
show_description in file Kernel.class.php, method kernel::show_description()
Метод вывода описания страницы
show_error_message in file Message.fns.php, function show_error_message()
Функция выводит сообщение об ошибке
show_information_message in file Message.fns.php, function show_information_message()
Функция выводит информационное сообщение
show_keywords in file Kernel.class.php, method kernel::show_keywords()
Метод вывода ключевых слов страницы
show_message in file Message.fns.php, function show_message()
Функция выводит сообщение об успешной операции
show_title in file Kernel.class.php, method kernel::show_title()
Метод вывода заголовка страницы
show_ws in file Wysiwyg.class.php, method wysiwyg::show_ws()
Метод отображает визуальный редактор
singleton in file Kernel.php, function singleton()
Функция используется для создания сингелтона
site in file Site.class.php, class site
Система управления сайтом HostCMS v. 5.xx
Site.class.php | procedural page Site.class.php
Site.php | procedural page Site.php
SiteTemplate.class.php | procedural page SiteTemplate.class.php
SiteTemplate in file SiteTemplate.class.php, class SiteTemplate
Система управления сайтом HostCMS v. 5.xx
SiteTemplate | in file SiteTemplate.class.php, method SiteTemplate::SiteTemplate()
SiteUsers in file Site_users.class.php, class SiteUsers
Класс модуля "Пользователи сайта"
Site_users.class.php | procedural page Site_users.class.php
Site_users.php | procedural page Site_users.php
Smile2HTML in file Forums.class.php, method Forums::Smile2HTML()
Метод замены смайликов на HTML
smtpMail | in file Kernel.class.php, method kernel::smtpMail()
SortStructureMass in file Structure.class.php, method Structure::SortStructureMass()
Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией
STAT_PERIOD_STORAGE | in file Counter.php, constant STAT_PERIOD_STORAGE
StripInvalidXml | in file Security.fns.php, function StripInvalidXml()
strips in file Kernel.class.php, method kernel::strips()
Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag
strips in file Security.fns.php, function strips()
Вызывает stripslashes для всех элементов массива
strip_tags_attributes in file Kernel.php, function strip_tags_attributes()
Удаление HTML-тегов вместе с атрибутами
Structure in file Structure.class.php, class Structure
Система управления сайтом HostCMS v. 5.xx
Structure.class.php | procedural page Structure.class.php
Structure.php | procedural page Structure.php
StructureToArray in file Mail.class.php, method Mail::StructureToArray()
Разбор структуры сообщения и сохранение результата в массив
str_for_rss in file RssWrite.class.php, method RssWrite::str_for_rss()
Преобразует строку для публикации в RSS, использует str_for_xml() и kernel::numeric_character_references()
str_for_xml in file Security.fns.php, function str_for_xml()
Функция преобразует строку для публикации в XML
Support in file Support.class.php, class Support
Класс модуля "Техническая поддержка"
Support.class.php | procedural page Support.class.php
Support.php | procedural page Support.php
SupportMail in file Support.class.php, method Support::SupportMail()
Метод отправки письма с просьбой о технической поддержке
symbol2ASCII in file Security.fns.php, function symbol2ASCII()
Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t
system_init in file Admin.class.php, method Admin::system_init()
Метод старта сессии для раздела администрирования
top
t
$tabs | in file admin_forms_fields.class.php, variable admin_forms_fields::$tabs
$template_content_filename | in file SiteTemplate.class.php, variable SiteTemplate::$template_content_filename
$template_filename | in file SiteTemplate.class.php, variable SiteTemplate::$template_filename
$template_path | in file SiteTemplate.class.php, variable SiteTemplate::$template_path
$tilt in file Graphic.class.php, variable graphic::$tilt
Наклон диаграммы
tar.class.php | procedural page tar.class.php
Tag in file tag.class.php, class Tag
Система управления сайтом HostCMS v. 5.xx
tag.class.php | procedural page tag.class.php
tag.php | procedural page tag.php
templates in file Templates.class.php, class templates
Система управления сайтом HostCMS v. 5.xx
Templates.class.php | procedural page Templates.class.php
Templates.php | procedural page Templates.php
TicketStatusChange in file helpdesk.class.php, method helpdesk::TicketStatusChange()
Изменение статуса тикета
to_array in file Security.fns.php, function to_array()
Функция приведения аргумента к массиву
to_bool in file Security.fns.php, function to_bool()
Функция приведения аргумента к логическому типу
to_float in file Security.fns.php, function to_float()
Функция приведения аргумента к вещественному типу
to_int in file Security.fns.php, function to_int()
Функция приведения аргумента к целочисленному типу
to_str in file Security.fns.php, function to_str()
Функция приведения аргумента к строковому типу
TransferFromCartIntoTable in file shop.class.php, method shop::TransferFromCartIntoTable()
Метод перемещения информации о заказанном товаре в таблицу корзины
translit_lower in file Url.class.php, method url::translit_lower()
Метод транслитерации с переводом символам исходного текста к прописным
typograph in file typograph.class.php, class typograph
Система управления сайтом HostCMS v. 5.xx
typograph.class.php | procedural page typograph.class.php
typograph.php | procedural page typograph.php
TypographText in file Forums.class.php, method Forums::TypographText()
Типографирование текста с использованием модуля "Типограф"
top
u
$user_function_message in file admin_forms.class.php, variable admin_forms::$user_function_message
Строка с суммарной строкой ошибок, произошедших в пользовательских событиях.
$user_function_result in file admin_forms.class.php, variable admin_forms::$user_function_result
Строка с результатом выполнения пользовательской функции.
$useSmtp in file Kernel.class.php, variable kernel::$useSmtp
Данные внешнего SMTP-сервера для отправки писем
$use_cookies_read_control in file shop.class.php, variable shop::$use_cookies_read_control
Использовать ли систему контроля корректности данных, принимаемых из cookies.
$use_read_control in file Cache.class.php, variable Cache::$use_read_control
Использовать контроль данных с помощью crc32
Url.class.php | procedural page Url.class.php
Unregistration in file Site_users.class.php, method SiteUsers::Unregistration()
Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя
UnsetCurrentSiteUser in file Site_users.class.php, method SiteUsers::UnsetCurrentSiteUser()
Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из
UnsetSiteUserAccountTransaction in file shop.class.php, method shop::UnsetSiteUserAccountTransaction()
Установка активности транзакции в 0 (делает неактивной)
Update in file Mysql.class.php, method DataBase::Update()
Обновление записей в таблицах.
update in file update.class.php, class update
Система управления сайтом HostCMS v. 5.xx
update.class.php | procedural page update.class.php
update.php | procedural page update.php
UpdateCart in file shop.class.php, method shop::UpdateCart()
Метод, осуществляющий обновление данных корзины
UpdateCity in file shop.class.php, method shop::UpdateCity()
УСТАРЕВШИЙ! Метод, осуществляющий обновление города
UpdateCondOfDelivery in file shop.class.php, method shop::UpdateCondOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки
UpdateCountry in file shop.class.php, method shop::UpdateCountry()
УСТАРЕВШИЙ! Метод, осуществляющий обновление страны
UpdateCurrency in file shop.class.php, method shop::UpdateCurrency()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()
UpdateDataTemplatesGroup in file Templates.class.php, method templates::UpdateDataTemplatesGroup()
Метод обновления информации о группе шаблонов данных
UpdateDiscount in file shop.class.php, method shop::UpdateDiscount()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке
UpdateGroup in file shop.class.php, method shop::UpdateGroup()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары
UpdateGroupPolls in file Polls.class.php, method polls::UpdateGroupPolls()
Метод обновления информаци о группе опросов
UpdateImageForItem in file shop.class.php, method shop::UpdateImageForItem()
Метод обновления информации об изображении для товара
UpdateItem in file shop.class.php, method shop::UpdateItem()
Устаревший метод, осуществляющий обновление информации о товаре. Заменен на InsertItem()
UpdateItemDiscount in file shop.class.php, method shop::UpdateItemDiscount()
УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара
UpdateItemPrice in file shop.class.php, method shop::UpdateItemPrice()
Метод обновления связи товара и цены
UpdateLibPropertyOrder in file lib.class.php, method lib::UpdateLibPropertyOrder()
Обновление порядка сортировки параметра типовой дин. страницы
UpdateLocation in file shop.class.php, method shop::UpdateLocation()
УСТАРЕВШИЙ! Метод, осуществляющий обновление области
UpdateMesure in file shop.class.php, method shop::UpdateMesure()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения
UpdateOrder in file shop.class.php, method shop::UpdateOrder()
УСТАРЕВШИЙ метод, осуществляющий обновление заказа. См. InsertOrder()
UpdateOrderItems in file shop.class.php, method shop::UpdateOrderItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе
UpdateOrderPropretyOfItems in file shop.class.php, method shop::UpdateOrderPropretyOfItems()
Метод изменения порядка сортировки дополнительных свойств товара
UpdatePrice in file shop.class.php, method shop::UpdatePrice()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены
UpdatePricesToItem in file shop.class.php, method shop::UpdatePricesToItem()
Метод обновления дополнительной цены для элемента
UpdateProducer in file shop.class.php, method shop::UpdateProducer()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе
UpdatePropertiesItem in file shop.class.php, method shop::UpdatePropertiesItem()
Метод обновления информации о дополнительных свойствах товара
UpdatePropretyOfItems in file shop.class.php, method shop::UpdatePropretyOfItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара
UpdateShop in file shop.class.php, method shop::UpdateShop()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине
UpdateSiteUser in file Site_users.class.php, method SiteUsers::UpdateSiteUser()
Обновление анкетных данных пользователя. Рекомендуется использовать InsertSiteUser().
UpdateSubDir in file Structure.class.php, method Structure::UpdateSubDir()
Метод обновления идентификатора меню у подразделов определенного раздела
UpdateSystemOfPay in file shop.class.php, method shop::UpdateSystemOfPay()
УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы
UpdateTax in file shop.class.php, method shop::UpdateTax()
Метод, осуществляющий обновление налога. Рекомендуется использовать InsertTax()
UpdateTyingProducts in file shop.class.php, method shop::UpdateTyingProducts()
УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах
UpdateTypeOfDelivery in file shop.class.php, method shop::UpdateTypeOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки
url in file Url.class.php, class url
Система управления сайтом HostCMS v. 5.xx
UrlWww in file seo.class.php, method Seo::UrlWww()
Обрезает "www" у домена
UseHttps in file Kernel.class.php, method kernel::UseHttps()
Используется ли HTTPS-доступ
UserAccess.class.php | procedural page UserAccess.class.php
UserAccess.php | procedural page UserAccess.php
UserAuth in file Admin.class.php, method Admin::UserAuth()
Метод производит авторизацию пользователя в разделе администрирования
UserCanAddComment in file InformationSystems.class.php, method InformationSystem::UserCanAddComment()
Определение возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY
UserIsModerator in file Forums.class.php, method Forums::UserIsModerator()
Метод для определения, является ли данный пользователь модератором
UserSessionValid in file Admin.class.php, method Admin::UserSessionValid()
Проверяет, авторизован ли текущий пользователь в центре администрирования
user_access | in file UserAccess.class.php, class user_access
Utf8ToWindows1251 in file Kernel.class.php, method kernel::Utf8ToWindows1251()
Преобразует текст из UTF-8 в Windows1251. В своей работе использует iconv() при его наличии или kernel::utf8_win1251()
utf8_win1251 in file Kernel.class.php, method kernel::utf8_win1251()
Перевод из UTF-8 в Windows-1251, используется при отсутствии iconv()
top
v
$value_cont in file Graphic.class.php, variable graphic::$value_cont
Число значений элементов, для которых строится диаграмма
ValidCaptcha in file Captcha.class.php, method Captcha::ValidCaptcha()
Метод проверки соответствия введенного пользователем текста хранимому в сессии Пример использования метода см. в руководстве по интеграции.
ValidUser in file Site_users.class.php, method SiteUsers::ValidUser()
Метод возвращает идентификатор пользователя по его логину и паролю
valid_email in file Security.fns.php, function valid_email()
Проверка правильности электронного адреса
VisibleTheme in file Forums.class.php, method Forums::VisibleTheme()
Метод, устанавливающий видимость/невидимость темы
vote_result in file Polls.class.php, method polls::vote_result()
Устаревший метод
top
w
$window_id in file admin_forms.class.php, variable admin_forms::$window_id
Идентификатор окна
Wysiwyg.class.php | procedural page Wysiwyg.class.php
warehouse.class.php | procedural page warehouse.class.php
warehouse in file warehouse.class.php, class warehouse
Система управления сайтом HostCMS v. 5.xx
win1251_utf8 in file Kernel.class.php, method kernel::win1251_utf8()
Перевод из Windows-1251 в UTF-8, используется при отсутствии iconv()
Windows1251ToUtf8 in file Kernel.class.php, method kernel::Windows1251ToUtf8()
Преобразует текст из Windows1251 в UTF-8. В своей работе использует iconv() при его наличии или kernel::win1251_utf8()
WordExists in file admin_forms.class.php, method admin_forms::WordExists()
Проверка, существования идентификатора слова
wysiwyg in file Wysiwyg.class.php, method wysiwyg::wysiwyg()
Конструктор
wysiwyg in file Wysiwyg.class.php, class wysiwyg
Система управления сайтом HostCMS v. 5.xx
top
x
$xml | in file ExternalXml.class.php, variable ExternalXml::$xml
$x_pos_1_leg in file Graphic.class.php, variable graphic::$x_pos_1_leg
Х - координата верхнего угла легенды
$x_size in file Graphic.class.php, variable graphic::$x_size
Ширина рисунка
XMLparser.class.php | procedural page XMLparser.class.php
xcacheClearCache in file Cache.class.php, method Cache::xcacheClearCache()
Очистка кэша $cache_name и элемента $item_name в xcache
Xml2Array | in file Kernel.class.php, method kernel::Xml2Array()
Xml2Array2 in file Kernel.class.php, method kernel::Xml2Array2()
Преобразование XML в массив
xsl in file Xsl.class.php, class xsl
Система управления сайтом HostCMS v. 5.xx
Xsl.class.php | procedural page Xsl.class.php
Xsl.php | procedural page Xsl.php
top
y
$y_pos_1_leg in file Graphic.class.php, variable graphic::$y_pos_1_leg
Y - координата верхнего угла легенды
$y_size in file Graphic.class.php, variable graphic::$y_size
Высота рисунка
YandexMarket in file shop.class.php, method shop::YandexMarket()
Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и выводит XML данные.
YandexXmlRequest | in file seo.class.php, method Seo::YandexXmlRequest()
Copyright © 2005—2010 ООО «Хостмэйк»


Дерево классов HostCMS_5

Root class Admin
  • Admin
 Root class AdminMenu
  • AdminMenu
 Root class admin_forms
  • admin_forms
    • admin_forms_fields
 Root class Advertisement
  • Advertisement
 Root class affiliate
  • affiliate
 Root class Backup
  • Backup
 Root class Cache
  • Cache
 Root class Captcha
  • Captcha
 Root class cml
  • cml
 Root class compression
  • compression
 Root class Constants
  • Constants
 Root class counter
  • counter
 Root class DataBase
  • DataBase
 Root class DateClass
  • DateClass
 Root class documents
  • documents
 Root class EventsJournal
  • EventsJournal
    • EventsJournalAdmin
 Root class ExecSqlQuery
  • ExecSqlQuery
 Root class ExternalXml
  • ExternalXml
 Root class File
  • File
 Root class FileManager
  • FileManager
 Root class Forms
  • Forms
 Root class Forums
  • Forums
 Root class graphic
  • graphic
 Root class helpdesk
  • helpdesk
 Root class Image
  • Image
 Root class InformationSystem
  • InformationSystem
 Root class ip
  • ip
 Root class JsHttpRequest
  • JsHttpRequest
 Root class kernel
  • kernel
 Root class lib
  • lib
 Root class lists
  • lists
 Root class Mail
  • Mail
 Root class Maillist
  • Maillist
 Root class messages
  • messages
 Root class modules
  • modules
 Root class polls
  • polls
 Root class RssRead
  • RssRead
 Root class RssWrite
  • RssWrite
 Root class Search
  • Search
 Root class Seo
  • Seo
 Root class Session
  • Session
 Root class shop
  • shop
 Root class site
  • site
 Root class SiteTemplate
  • SiteTemplate
 Root class SiteUsers
  • SiteUsers
 Root class Structure
  • Structure
 Root class Support
  • Support
 Root class Tag
  • Tag
 Root class templates
  • templates
 Root class typograph
  • typograph
 Root class update
  • update
 Root class url
  • url
 Root class user_access
  • user_access
 Root class warehouse
  • warehouse
 Root class wysiwyg
  • wysiwyg
 Root class xsl
  • xsl


Docs for page Admin.class.php

Файл: /Kernel/Admin.class.php

Классы в этом файле:
Admin
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page AdminMenu.class.php

Файл: /Kernel/AdminMenu.class.php

Классы в этом файле:
AdminMenu
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page admin_forms.class.php

Файл: /admin_forms/admin_forms.class.php

Классы в этом файле:
admin_forms
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page admin_forms.php

Файл: /admin_forms/admin_forms.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page admin_forms_fields.class.php

Файл: /admin_forms/admin_forms_fields.class.php

Классы в этом файле:
admin_forms_fields
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page admin_output.fns.php

Файл: /Kernel/admin_output.fns.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Файл: /modules/Kernel/admin_output.fns.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void do_html_footer_admin()
    Функция выводит "подвал" для страниц раздела администрирования
  • void do_html_header_admin()
    Функция выводит "шапку" для страниц раздела администрирования

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void do_html_footer_admin() [Строка 307]

    Usage: do_html_footer_admin( )

    Описание

    Функция выводит "подвал" для страниц раздела администрирования

    [ Наверх ]

  • void do_html_header_admin() [Строка 29]

    Usage: do_html_header_admin( string $title, [array $param = false])

    Описание

    Функция выводит "шапку" для страниц раздела администрирования

    Принимаемые параметры

    $title

    $param

    массив с доп. параметрами

    [ Наверх ]


Docs for page Advertisement.class.php

Файл: /Advertisement/Advertisement.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Реклама".

Файл: /modules/Advertisement/Advertisement.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Advertisement
Класс модуля "Реклама"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Advertisement.php

Файл: /Advertisement/Advertisement.php

Классы в этом файле:

Список вложений

  • include = CMS_FOLDER."modules/{$module_path_name}/{$module_path_name}.class.php"
    Система управления сайтом HostCMS v. 5.xx

Список глобальных переменных

Список констант

Список функций

Описания вложений

  • include file: = CMS_FOLDER."modules/{$module_path_name}/{$module_path_name}.class.php" [Строка 22]

    Описание

    Система управления сайтом HostCMS v. 5.xx

    Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

    Модуль Advertisement.

    Файл: /modules/Advertisement/Advertisement.php

    author

    Hostmake LLC

    version

    5.x

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page affiliate.class.php

Файл: /shop/affiliate.class.php

Классы в этом файле:
affiliate
Система управления сайтом HostCMS v. 5.xx Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Backup.class.php

Файл: /Backup/Backup.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Резервное копирование".

Файл: /modules/Backup/Backup.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Backup
Класс модуля "Резервное копирование"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Backup.php

Файл: /Backup/Backup.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Cache.class.php

Файл: /Cache/Cache.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Кэш".

Файл: /modules/Cache/Cache.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Cache
Класс модуля "Кэш"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Cache.php

Файл: /Cache/Cache.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • CACHE_INSTALL = true
    Система управления сайтом HostCMS v. 5.xx

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • CACHE_INSTALL = true [Строка 20]

    Описание

    Система управления сайтом HostCMS v. 5.xx

    Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

    Модуль Cache.

    Файл: /modules/Cache/Cache.php

    author

    Hostmake LLC

    version

    5.x

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Captcha.class.php

Файл: /Kernel/Captcha.class.php

Классы в этом файле:
Captcha
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page cml.class.php

Файл: /shop/cml.class.php

Классы в этом файле:
cml
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Compression.class.php

Файл: /Compression/Compression.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Система сжатия (компрессия)".

Файл: /modules/Compression/Compression.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
compression
Класс модуля "Система сжатия (компрессия)"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Compression.php

Файл: /Compression/Compression.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • COMPRESSION_INSTALL = 1
    Система управления сайтом HostCMS v. 5.xx

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • COMPRESSION_INSTALL = 1 [Строка 20]

    Описание

    Система управления сайтом HostCMS v. 5.xx

    Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

    Модуль Compression.

    Файл: /modules/Compression/Compression.php

    author

    Hostmake LLC

    version

    5.x

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page config.php

Файл: /Counter/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • COUNTER_BOT_COUNT = true
    Система управления сайтом HostCMS v. 5.xx

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • COUNTER_BOT_COUNT = true [Строка 15]

    Описание

    Система управления сайтом HostCMS v. 5.xx

    Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

    Модуль Counter.

    Файл: /modules/Counter/config/config.php

    author

    Hostmake LLC

    version

    5.x

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page config.php

Файл: /Cache/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page config.php

Файл: /Kernel/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page config.php

Файл: /Forums/config/config.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Constants.class.php

Файл: /Constants/Constants.class.php

Классы в этом файле:
Constants
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Constants.php

Файл: /Constants/Constants.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Counter.class.php

Файл: /Counter/Counter.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Статистика посещаемости сайта".

Файл: /modules/Counter/Counter.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
counter
Класс модуля "Статистика посещаемости сайта"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Counter.php

Файл: /Counter/Counter.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • COUNTER_INSTALL = true
    Система управления сайтом HostCMS v. 5.xx
  • DIAGRAMM_LIMIT = 20
  • DIAGRAMM_WIDTH = 500
  • GISTOGRAMM_LIMIT = 20
  • STAT_PERIOD_STORAGE = 30

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • COUNTER_INSTALL = true [Строка 19]

    Описание

    Система управления сайтом HostCMS v. 5.xx

    Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

    Модуль Counter.

    Файл: /modules/Counter/Counter.php

    author

    Hostmake LLC

    version

    5.x

  • DIAGRAMM_LIMIT = 20 [Строка 32]

  • DIAGRAMM_WIDTH = 500 [Строка 40]

  • GISTOGRAMM_LIMIT = 20 [Строка 36]

  • STAT_PERIOD_STORAGE = 30 [Строка 27]

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Date.class.php

Файл: /Kernel/Date.class.php

Классы в этом файле:
DateClass
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Documents.class.php

Файл: /Documents/Documents.class.php

Классы в этом файле:
documents
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Documents.php

Файл: /Documents/Documents.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Site_users/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Forums/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /messages/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Site/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /shop/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Maillist/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Forms/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /seo/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Kernel/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /InformationSystems/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /FileManager/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Search/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /ip/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Polls/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /helpdesk/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Modules/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /lib/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /typograph/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Cache/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Constants/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Templates/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Counter/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Lists/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /update/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Xsl/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /admin_forms/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Advertisement/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /UserAccess/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Backup/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Documents/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /tag/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /EventsJournal/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Structure/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /ExecSqlQuery/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page en.php

Файл: /Support/lng/en/en.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Error.fns.php

Файл: /Kernel/Error.fns.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, обработчики ошибок в HostCMS.

Файл: /modules/Kernel/Error.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void cms_error_handler()
    Ядро, обработчики ошибок в HostCMS

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void cms_error_handler() [Строка 23]

    Usage: cms_error_handler( int $code, string $msg, string $file, int $line)

    Описание

    Ядро, обработчики ошибок в HostCMS

    Принимаемые параметры

    $code

    код ошибки - E_ERROR и т.д.

    $msg

    сообщение об ошбике

    $file

    имя файла, в котором произошла ошибка

    $line

    строка, в котором произошла ошибка

    [ Наверх ]


Docs for page EventsJournal.class.php

Файл: /Kernel/EventsJournal.class.php

Классы в этом файле:
EventsJournal
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page EventsJournal.class.php

Файл: /EventsJournal/EventsJournal.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Журнал событий".

Файл: /modules/EventsJournal/EventsJournal.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
EventsJournalAdmin
Класс модуля "Журнал событий"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page EventsJournal.php

Файл: /EventsJournal/EventsJournal.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ExecSqlQuery.class.php

Файл: /ExecSqlQuery/ExecSqlQuery.class.php

Классы в этом файле:
ExecSqlQuery
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ExecSqlQuery.php

Файл: /ExecSqlQuery/ExecSqlQuery.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ExternalXml.class.php

Файл: /Kernel/ExternalXml.class.php

Классы в этом файле:
ExternalXml
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page File.class.php

Файл: /Kernel/File.class.php

Классы в этом файле:
File
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page FileManager.class.php

Файл: /FileManager/FileManager.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Файловый менеджер".

Файл: /modules/FileManager/FileManager.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
FileManager
Класс модуля "Файловый менеджер"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page FileManager.php

Файл: /FileManager/FileManager.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Forms.class.php

Файл: /Forms/Forms.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Формы".

Файл: /modules/Forms/Forms.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Forms
Класс модуля "Формы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Forms.php

Файл: /Forms/Forms.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Forums.class.php

Файл: /Forums/Forums.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Форумы".

Файл: /modules/Forums/Forums.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Forums
Класс модуля "Форумы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Forums.php

Файл: /Forums/Forums.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Graphic.class.php

Файл: /Kernel/Graphic.class.php

Классы в этом файле:
graphic
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page helpdesk.class.php

Файл: /helpdesk/helpdesk.class.php

Классы в этом файле:
helpdesk
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page helpdesk.php

Файл: /helpdesk/helpdesk.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Image.class.php

Файл: /Kernel/Image.class.php

Классы в этом файле:
Image
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page InformationSystems.class.php

Файл: /InformationSystems/InformationSystems.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Информационные системы".

Файл: /modules/InformationSystems/InformationSystems.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
InformationSystem
Класс модуля "Информационные системы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page InformationSystems.php

Файл: /InformationSystems/InformationSystems.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ip.class.php

Файл: /ip/ip.class.php

Классы в этом файле:
ip
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ip.php

Файл: /ip/ip.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page JsHttpRequest.php

Файл: /Kernel/ajax/JsHttpRequest.php

Классы в этом файле:
JsHttpRequest
JsHttpRequest: PHP backend for JavaScript DHTML loader.

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Kernel.class.php

Файл: /Kernel/Kernel.class.php

Классы в этом файле:
kernel
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Kernel.php

Файл: /Kernel/Kernel.php

Классы в этом файле:
Session

Список вложений

  • require_once = $sModulesPath."Kernel/admin_output.fns.php"
  • require_once = $sModulesPath.'Kernel/Core.php'
  • require_once = $path
    Система управления сайтом HostCMS v. 5.xx
  • require_once = $sModulesPath.'Kernel/Message.fns.php'
  • require_once = $sModulesPath.'Kernel/Mbstring.fns.php'
  • require_once = $sModulesPath.'Kernel/Security.fns.php'
  • require_once = $config_path
  • require_once = $sModulesPath.'Kernel/Kernel.class.php'
  • require_once = $sModulesPath.'Kernel/lng/'.DEFAULT_LNG.'/'.DEFAULT_LNG.'.php'
  • require_once = $sModulesPath.'Kernel/Error.fns.php'
  • require_once = $sModulesPath.'Kernel/lng/'.$current_lng.'/'.$current_lng.'.php'

Список глобальных переменных

Список констант

  • $row['constants_name'] = $row['constants_value']
  • CURRENT_VERSION = '6.x.x'
  • PAGE_DIR = CMS_FOLDER.'hostcmsfiles/documents/'
  • PNG_QUALITY = 9

Список функций

  • void array_fill_keys()
  • void array_intersect_key()
  • void bcpow()
  • void com_create_guid()
  • void exif_imagetype()
  • void memory_get_usage()
  • object singleton()
    Функция используется для создания сингелтона
  • string strip_tags_attributes()
    Удаление HTML-тегов вместе с атрибутами
  • void __autoload()

Описания вложений

  • require_once file: = $sModulesPath."Kernel/admin_output.fns.php" [Строка 622]

  • require_once file: = $sModulesPath.'Kernel/Core.php' [Строка 763]

  • require_once file: = $path [Строка 63]

    Описание

    Система управления сайтом HostCMS v. 5.xx

    Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

    Модуль Kernel.

    Файл: /modules/Kernel/Kernel.php

    author

    Hostmake LLC

    version

    5.x

  • require_once file: = $sModulesPath.'Kernel/Message.fns.php' [Строка 381]

  • require_once file: = $sModulesPath.'Kernel/Mbstring.fns.php' [Строка 378]

  • require_once file: = $sModulesPath.'Kernel/Security.fns.php' [Строка 383]

  • require_once file: = $config_path [Строка 371]

  • require_once file: = $sModulesPath.'Kernel/Kernel.class.php' [Строка 384]

  • require_once file: = $sModulesPath.'Kernel/lng/'.DEFAULT_LNG.'/'.DEFAULT_LNG.'.php' [Строка 829]

  • require_once file: = $sModulesPath.'Kernel/Error.fns.php' [Строка 387]

  • require_once file: = $sModulesPath.'Kernel/lng/'.$current_lng.'/'.$current_lng.'.php' [Строка 823]

Описания глобальных переменных

Описания констант

  • $row['constants_name'] = $row['constants_value'] [Строка 644]

  • CURRENT_VERSION = '6.x.x' [Строка 768]

  • PAGE_DIR = CMS_FOLDER.'hostcmsfiles/documents/' [Строка 778]

  • PNG_QUALITY = 9 [Строка 773]

Описания функций

  • void array_fill_keys() [Строка 280]

    Usage: array_fill_keys( $keys, $value)

    Принимаемые параметры

    $keys

    $value

    [ Наверх ]

  • void array_intersect_key() [Строка 288]

    Usage: array_intersect_key( $isec, $keys)

    Принимаемые параметры

    $isec

    $keys

    [ Наверх ]

  • void bcpow() [Строка 270]

    Usage: bcpow( $a, $b)

    Принимаемые параметры

    $a

    $b

    [ Наверх ]

  • void com_create_guid() [Строка 253]

    Usage: com_create_guid( )

    [ Наверх ]

  • void exif_imagetype() [Строка 323]

    Usage: exif_imagetype( $filename)

    Принимаемые параметры

    $filename

    [ Наверх ]

  • void memory_get_usage() [Строка 339]

    Usage: memory_get_usage( )

    [ Наверх ]

  • object singleton() [Строка 209]

    Usage: &singleton( string $class)

    Описание

    Функция используется для создания сингелтона

    Принимаемые параметры

    $class

    Имя класса

    [ Наверх ]

  • string strip_tags_attributes() [Строка 234]

    Usage: strip_tags_attributes( string $sSource, string $aAllowedTags, [array $aDisabledAttributes = array('onabort', 'onactivate', 'onafterprint', 'onafterupdate', 'onbeforeactivate', 'onbeforecopy', 'onbeforecut', 'onbeforedeactivate', 'onbeforeeditfocus', 'onbeforepaste', 'onbeforeprint', 'onbeforeunload', 'onbeforeupdate', 'onblur', 'onbounce', 'oncellchange', 'onchange', 'onclick', 'oncontextmenu', 'oncontrolselect', 'oncopy', 'oncut', 'ondataavaible', 'ondatasetchanged', 'ondatasetcomplete', 'ondblclick', 'ondeactivate', 'ondrag', 'ondragdrop', 'ondragend', 'ondragenter', 'ondragleave', 'ondragover', 'ondragstart', 'ondrop', 'onerror', 'onerrorupdate', 'onfilterupdate', 'onfinish', 'onfocus', 'onfocusin', 'onfocusout', 'onhelp', 'onkeydown', 'onkeypress', 'onkeyup', 'onlayoutcomplete', 'onload', 'onlosecapture', 'onmousedown', 'onmouseenter', 'onmouseleave', 'onmousemove', 'onmoveout', 'onmouseover', 'onmouseup', 'onmousewheel', 'onmove', 'onmoveend', 'onmovestart', 'onpaste', 'onpropertychange', 'onreadystatechange', 'onreset', 'onresize', 'onresizeend', 'onresizestart', 'onrowexit', 'onrowsdelete', 'onrowsinserted', 'onscroll', 'onselect', 'onselectionchange', 'onselectstart', 'onstart', 'onstop', 'onsubmit', 'onunload')])

    Описание

    Удаление HTML-тегов вместе с атрибутами

    Принимаемые параметры

    $sSource

    Исходная строка

    $aAllowedTags

    Список разрешенных тегов, например, "

    $aDisabledAttributes

    Массив запрещенных атрибутов тегов, например array('onabort', 'onactivate', 'onafterprint', 'onafterupdate', 'onbeforeactivate', 'onbeforecopy', 'onbeforecut', 'onbeforedeactivate', 'onbeforeeditfocus', 'onbeforepaste', 'onbeforeprint', 'onbeforeunload', 'onbeforeupdate', 'onblur', 'onbounce', 'oncellchange', 'onchange', 'onclick', 'oncontextmenu', 'oncontrolselect', 'oncopy', 'oncut', 'ondataavaible', 'ondatasetchanged', 'ondatasetcomplete', 'ondblclick', 'ondeactivate', 'ondrag', 'ondragdrop', 'ondragend', 'ondragenter', 'ondragleave', 'ondragover', 'ondragstart', 'ondrop', 'onerror', 'onerrorupdate', 'onfilterupdate', 'onfinish', 'onfocus', 'onfocusin', 'onfocusout', 'onhelp', 'onkeydown', 'onkeypress', 'onkeyup', 'onlayoutcomplete', 'onload', 'onlosecapture', 'onmousedown', 'onmouseenter', 'onmouseleave', 'onmousemove', 'onmoveout', 'onmouseover', 'onmouseup', 'onmousewheel', 'onmove', 'onmoveend', 'onmovestart', 'onpaste', 'onpropertychange', 'onreadystatechange', 'onreset', 'onresize', 'onresizeend', 'onresizestart', 'onrowexit', 'onrowsdelete', 'onrowsinserted', 'onscroll', 'onselect', 'onselectionchange', 'onselectstart', 'onstart', 'onstop', 'onsubmit', 'onunload')

    [ Наверх ]

  • void __autoload() [Строка 197]

    Usage: __autoload( $className)

    Принимаемые параметры

    $className

    [ Наверх ]


Docs for page lib.class.php

Файл: /lib/lib.class.php

Классы в этом файле:
lib
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page lib.php

Файл: /lib/lib.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Lists.class.php

Файл: /Lists/Lists.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Списки".

Файл: /modules/Lists/Lists.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
lists
Класс модуля "Списки"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Lists.php

Файл: /Lists/Lists.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Mail.class.php

Файл: /Kernel/Mail.class.php

Классы в этом файле:
Mail
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Maillist.class.php

Файл: /Maillist/Maillist.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Почтовые рассылки".

Файл: /modules/Maillist/Maillist.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Maillist
Класс модуля "Почтовые рассылки"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Maillist.php

Файл: /Maillist/Maillist.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Mbstring.fns.php

Файл: /Kernel/Mbstring.fns.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Модуль Kernel.

Файл: /modules/Kernel/Mbstring.fns.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void mb_ereg()
  • void mb_strlen()
  • void mb_strpos()
  • void mb_strrpos()
  • void mb_strtolower()
  • void mb_strtoupper()
  • void mb_substr()
  • void mb_substr_count()

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void mb_ereg() [Строка 23]

    Usage: mb_ereg( $pattern $pattern, $string $string, $regs &$regs)

    Принимаемые параметры

    $pattern

    $string

    &$regs

    [ Наверх ]

  • void mb_strlen() [Строка 193]

    Usage: mb_strlen( $str, [ $encoding = null])

    Принимаемые параметры

    $str

    $encoding

    [ Наверх ]

  • void mb_strpos() [Строка 386]

    Usage: mb_strpos( $haystack, $needle, [ $offset = null], [ $encoding = null])

    Принимаемые параметры

    $haystack

    $needle

    $offset

    $encoding

    [ Наверх ]

  • void mb_strrpos() [Строка 434]

    Usage: mb_strrpos( $haystack, $needle, [ $offset = null], [ $encoding = null])

    Принимаемые параметры

    $haystack

    $needle

    $offset

    $encoding

    [ Наверх ]

  • void mb_strtolower() [Строка 102]

    Usage: mb_strtolower( $str, [ $encoding = null])

    Принимаемые параметры

    $str

    $encoding

    [ Наверх ]

  • void mb_strtoupper() [Строка 184]

    Usage: mb_strtoupper( $str, [ $encoding = null])

    Принимаемые параметры

    $str

    $encoding

    [ Наверх ]

  • void mb_substr() [Строка 233]

    Usage: mb_substr( $str, $start, [ $length = null], [ $encoding = null])

    Принимаемые параметры

    $str

    $start

    $length

    $encoding

    [ Наверх ]

  • void mb_substr_count() [Строка 477]

    Usage: mb_substr_count( $haystack, $needle, [ $encoding = null])

    Принимаемые параметры

    $haystack

    $needle

    $encoding

    [ Наверх ]


Docs for page Menu.class.php

Файл: /Structure/Menu.class.php

Описание

Система управления сайтом HostCMS v. 5.xx Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Меню".

Файл: /modules/Menu/Menu.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Message.fns.php

Файл: /Kernel/Message.fns.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, методы управления сообщениями центра администрирования.

Файл: /modules/Kernel/Message.fns.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • void show_error_message()
    Функция выводит сообщение об ошибке
  • void show_information_message()
    Функция выводит информационное сообщение
  • void show_message()
    Функция выводит сообщение об успешной операции

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • void show_error_message() [Строка 28]

    Usage: show_error_message( string $text)

    Описание

    Функция выводит сообщение об ошибке

    Принимаемые параметры

    $text

    [ Наверх ]

  • void show_information_message() [Строка 41]

    Usage: show_information_message( string $text, [string $width = '100%'])

    Описание

    Функция выводит информационное сообщение

    Принимаемые параметры

    $text

    $width

    [ Наверх ]

  • void show_message() [Строка 18]

    Usage: show_message( string $text)

    Описание

    Функция выводит сообщение об успешной операции

    Принимаемые параметры

    $text

    [ Наверх ]


Docs for page messages.class.php

Файл: /messages/messages.class.php

Классы в этом файле:
messages

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page messages.php

Файл: /messages/messages.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Modules.class.php

Файл: /Modules/Modules.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Управление модулями".

Файл: /modules/Modules/Modules.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
modules
Класс модуля "Управление модулями"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Modules.php

Файл: /Modules/Modules.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Mysql.class.php

Файл: /Kernel/Mysql.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, класс для работы с СУБД.

Файл: /modules/Kernel/mysql.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
DataBase
Ядро, класс для работы с СУБД

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Mysqldump.class.php

Файл: /Backup/Mysqldump.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Резервное копирование", предназначен для создания резервной копии базы данных.

Файл: /modules/admin_forms/Mysqldump.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Password.class.php

Файл: /Kernel/Password.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, класс для работы с паролями.

Файл: /modules/Kernel/Password.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Polls.class.php

Файл: /Polls/Polls.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Опросы".

Файл: /modules/Polls/Polls.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
polls
Класс модуля "Опросы"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Polls.php

Файл: /Polls/Polls.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page RssRead.class.php

Файл: /Kernel/RssRead.class.php

Классы в этом файле:
RssRead
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page RssWrite.class.php

Файл: /Kernel/RssWrite.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, класс для генерации RSS.

Файл: /modules/Kernel/RSS.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
RssWrite
Ядро, класс для генерации RSS.

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Support/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Counter/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Documents/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /EventsJournal/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Site/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Forms/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Maillist/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Site_users/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Structure/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /ExecSqlQuery/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /tag/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Constants/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Advertisement/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /UserAccess/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /admin_forms/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Xsl/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /update/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Backup/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Templates/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Cache/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /typograph/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /shop/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /FileManager/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Polls/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Search/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /ip/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Modules/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /messages/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Lists/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /lib/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /seo/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Kernel/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /InformationSystems/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /helpdesk/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page ru.php

Файл: /Forums/lng/ru/ru.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Search.class.php

Файл: /Search/Search.class.php

Классы в этом файле:
Search
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Search.php

Файл: /Search/Search.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Security.fns.php

Файл: /Kernel/Security.fns.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, класс для генерации RSS.

Файл: /modules/Kernel/RSS.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

  • array array_values_to_int()
    Функция приведения значений одномерного массива к целому, ключи сохраняются
  • string charset_koi_win()
    Преобразует текст из KOI8-R в WIN-1251
  • str email_encode_js()
    Публикует с помощью JavaScript ссылку на эл.почту, защищенную от индексации ботами
  • str hexcode_str()
    Преобразует строку в hex-последовательность.
  • string quote_smart()
    Экранирует потенциально опасные символы для MySQL запросов
  • void StripInvalidXml()
  • void strips()
    Вызывает stripslashes для всех элементов массива
  • string str_for_xml()
    Функция преобразует строку для публикации в XML
  • string symbol2ASCII()
    Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t
  • array to_array()
    Функция приведения аргумента к массиву
  • bool to_bool()
    Функция приведения аргумента к логическому типу
  • float to_float()
    Функция приведения аргумента к вещественному типу
  • int to_int()
    Функция приведения аргумента к целочисленному типу
  • string to_str()
    Функция приведения аргумента к строковому типу
  • boolean valid_email()
    Проверка правильности электронного адреса

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

  • array array_values_to_int() [Строка 413]

    Usage: array_values_to_int( array $var)

    Описание

    Функция приведения значений одномерного массива к целому, ключи сохраняются

    Принимаемые параметры

    $var

    [ Наверх ]

  • string charset_koi_win() [Строка 434]

    Usage: charset_koi_win( string $string)

    Описание

    Преобразует текст из KOI8-R в WIN-1251

    Принимаемые параметры

    $string

    исходная строка

    [ Наверх ]

  • str email_encode_js() [Строка 460]

    Usage: email_encode_js( string $email, string $name)

    Описание

    Публикует с помощью JavaScript ссылку на эл.почту, защищенную от индексации ботами

    Принимаемые параметры

    $email

    Электронный адрес

    $name

    Текст ссылки

    Возвращает

    HTML-код

    [ Наверх ]

  • str hexcode_str() [Строка 486]

    Usage: hexcode_str( string $str)

    Описание

    Преобразует строку в hex-последовательность.

    Принимаемые параметры

    $str

    исходная строка

    Возвращает

    преобразованная строка

    [ Наверх ]

  • string quote_smart() [Строка 42]

    Usage: quote_smart( string $value, [boolean $remove_xss = false])

    Описание

    Экранирует потенциально опасные символы для MySQL запросов

    Принимаемые параметры

    $value

    значение

    $remove_xss

    удалять элементы XSS атак

    [ Наверх ]

  • void StripInvalidXml() [Строка 215]

    Usage: StripInvalidXml( $xml)

    Принимаемые параметры

    $xml

    [ Наверх ]

  • void strips() [Строка 20]

    Usage: strips( &$var, array $var)

    Описание

    Вызывает stripslashes для всех элементов массива

    Принимаемые параметры

    $var

    &$var

    [ Наверх ]

  • string str_for_xml() [Строка 275]

    Usage: str_for_xml( string $str)

    Описание

    Функция преобразует строку для публикации в XML

    Принимаемые параметры

    $str

    [ Наверх ]

  • string symbol2ASCII() [Строка 189]

    Usage: symbol2ASCII( &$string, string $num)

    Описание

    Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t

    Принимаемые параметры

    $num

    &$string

    [ Наверх ]

  • array to_array() [Строка 402]

    Usage: to_array( &$var, mixed $var)

    Описание

    Функция приведения аргумента к массиву

    Принимаемые параметры

    $var

    &$var

    [ Наверх ]

  • bool to_bool() [Строка 379]

    Usage: to_bool( &$var, mixed $var)

    Описание

    Функция приведения аргумента к логическому типу

    Принимаемые параметры

    $var

    &$var

    [ Наверх ]

  • float to_float() [Строка 360]

    Usage: to_float( &$var, mixed $var)

    Описание

    Функция приведения аргумента к вещественному типу

    Принимаемые параметры

    $var

    &$var

    [ Наверх ]

  • int to_int() [Строка 334]

    Usage: to_int( &$var, mixed $var)

    Описание

    Функция приведения аргумента к целочисленному типу

    Принимаемые параметры

    $var

    &$var

    [ Наверх ]

  • string to_str() [Строка 304]

    Usage: to_str( &$var, [ $remove_xss = true], mixed $var)

    Описание

    Функция приведения аргумента к строковому типу

    Принимаемые параметры

    $var

    &$var

    $remove_xss

    [ Наверх ]

  • boolean valid_email() [Строка 137]

    Usage: valid_email( string $address)

    Описание

    Проверка правильности электронного адреса

    Принимаемые параметры

    $address

    e-mail адрес

    Возвращает

    true или false

    [ Наверх ]


Docs for page seo.class.php

Файл: /seo/seo.class.php

Классы в этом файле:
Seo
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page seo.php

Файл: /seo/seo.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page shop.class.php

Файл: /shop/shop.class.php

Классы в этом файле:
shop
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page shop.php

Файл: /shop/shop.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Site.class.php

Файл: /Site/Site.class.php

Классы в этом файле:
site
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Site.php

Файл: /Site/Site.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page SiteTemplate.class.php

Файл: /Site/SiteTemplate.class.php

Классы в этом файле:
SiteTemplate
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Site_users.class.php

Файл: /Site_users/Site_users.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Пользователи сайта".

Файл: /modules/Site_users/Site_users.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
SiteUsers
Класс модуля "Пользователи сайта"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Site_users.php

Файл: /Site_users/Site_users.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Structure.class.php

Файл: /Structure/Structure.class.php

Классы в этом файле:
Structure
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Structure.php

Файл: /Structure/Structure.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Support.class.php

Файл: /Support/Support.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Техническая поддержка".

Файл: /modules/Support/Support.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
Support
Класс модуля "Техническая поддержка"

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Support.php

Файл: /Support/Support.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page tag.class.php

Файл: /tag/tag.class.php

Классы в этом файле:
Tag
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page tag.php

Файл: /tag/tag.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page tar.class.php

Файл: /Kernel/tar.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, creates a (compressed) Tar archive.

Файл: /modules/Kernel/tar.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

  • OS_UNIX = false

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

  • OS_UNIX = false [Строка 22]

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Templates.class.php

Файл: /Templates/Templates.class.php

Классы в этом файле:
templates
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Templates.php

Файл: /Templates/Templates.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page typograph.class.php

Файл: /typograph/typograph.class.php

Классы в этом файле:
typograph
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page typograph.php

Файл: /typograph/typograph.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page update.class.php

Файл: /update/update.class.php

Классы в этом файле:
update
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page update.php

Файл: /update/update.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Url.class.php

Файл: /Kernel/Url.class.php

Классы в этом файле:
url
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page UserAccess.class.php

Файл: /UserAccess/UserAccess.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Пользователи раздела администрирования".

Файл: /modules/UserAccess/UserAccess.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:
user_access

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page UserAccess.php

Файл: /UserAccess/UserAccess.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page warehouse.class.php

Файл: /shop/warehouse.class.php

Классы в этом файле:
warehouse
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Wysiwyg.class.php

Файл: /Kernel/Wysiwyg.class.php

Классы в этом файле:
wysiwyg
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page XMLparser.class.php

Файл: /Kernel/XMLparser.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Ядро, методы анализа XML.

Файл: /modules/Kernel/XMLparser.class.php

author

Hostmake LLC

version

5.x

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Xsl.class.php

Файл: /Xsl/Xsl.class.php

Классы в этом файле:
xsl
Система управления сайтом HostCMS v. 5.xx

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs for page Xsl.php

Файл: /Xsl/Xsl.php

Классы в этом файле:

Список вложений

Список глобальных переменных

Список констант

Список функций

Описания вложений

Описания глобальных переменных

Описания констант

Описания функций

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Admin

Class Admin

[Строка 14]

Размещен: /Kernel/Admin.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, методы управления разделом центра администрирования.
Файл: /modules/Kernel/Admin.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • Admin Admin()

  • void AdminSessionStart()

    Запуск сессии для центра администрирования

  • void admin_init()

    Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта

  • boolean admin_session_valid()

    Метод проверки авторизации пользователя

  • void SetCurrentSite()

    Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта

  • void system_init()

    Метод старта сессии для раздела администрирования

  • mixed UserAuth()

    Метод производит авторизацию пользователя в разделе администрирования

  • bool UserSessionValid()

    Проверяет, авторизован ли текущий пользователь в центре администрирования

Унаследованные методы

Описания методов

    Admin::Admin

Admin(
 );

    [ Наверх ]

    Admin::AdminSessionStart

AdminSessionStart(
[int
$expires = 86400] );

    Описание

    Запуск сессии для центра администрирования

    Принимаемые параметры

    $expires

    время сохранения идентификатора сессии в cookies,  необязательный параметр, по умолчанию имеет значение 86400 (24 часа)

    [ Наверх ]

    Admin::admin_init

admin_init(
 );

    Описание

    Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта

    [ Наверх ]

    Admin::admin_session_valid

admin_session_valid(
string
$modules_path );

    Описание

    Метод проверки авторизации пользователя

    Принимаемые параметры

    $modules_path

    путь к модулю

    Возвращает

    true в случае  наличия у авторизированного пользователя прав доступа к данному модулю на текущем сайте или прерывает выполнение страницы, производя редирект на страницу авторизации в противном случае

    [ Наверх ]

    Admin::SetCurrentSite

SetCurrentSite(
 );

    Описание

    Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта

    [ Наверх ]

    Admin::system_init

system_init(
 );

    Описание

    Метод старта сессии для раздела администрирования

    [ Наверх ]

    Admin::UserAuth

UserAuth(
string
$login, string
$password );

    Описание

    Метод производит авторизацию пользователя в разделе администрирования

    Принимаемые параметры

    $login

    логин

    $password

    пароль

    Возвращает

    true -- автооризация произведена успешно
    false -- неправильные данные доступа
    -1 -- не истекло время до следующей попытки авторизации

    [ Наверх ]

    Admin::UserSessionValid

UserSessionValid(
 );

    Описание

    Проверяет, авторизован ли текущий пользователь в центре администрирования

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class AdminMenu

Class AdminMenu

[Строка 14]

Размещен: /Kernel/AdminMenu.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для формирования меню в разделе администрирования.
Файл: /modules/Kernel/AdminMenu.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AddAdminMenuItem()

    Метод добавляет модуль в меню раздела администрирования

Унаследованные методы

Описания методов

    AdminMenu::AddAdminMenuItem

AddAdminMenuItem(
int
$order, string
$name, string
$onclick, string
$link, string
$module_name, [int
$sub_menu_id = 0] );

    Описание

    Метод добавляет модуль в меню раздела администрирования

    Принимаемые параметры

    $order

    порядок элемента в меню

    $name

    имя элемента

    $onclick

    обработчик события onclick

    $link

    ссылка

    $module_name

    имя модуля-владельца раздела меню

    $sub_menu_id

    идентификатор подменю, в которое будет включен модуль

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class admin_forms

Class admin_forms

[Строка 14]

Classes extended from admin_forms:

admin_forms_fields

Система управления сайтом HostCMS v. 5.xx

Размещен: /admin_forms/admin_forms.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Формы центра администрирования.
Файл: /modules/admin_forms/admin_forms.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $AAction =  ''

        Значение AAction, переданное DoLoadAjax

  • $AAdditionalParams =  ''

        Значение AAdditionalParams, переданное DoLoadAjax

  • $CacheGetAdminFormsWord = array()

        Массив-кэш для метода GetAdminFormsWord()

  • $CacheGetLanguage = array()

        Массив кэш для GetLanguage()

  • $CacheGetLanguageByShortName = array()

        Массив-кэш для GetLanguageByShortName()

  • $CallbackFunctionName =  'LoadAjaxData'

        Наименование функции обратного вызова

  • $data_under_menu =

        Код для вывода под меню

  • $debug =

        Сообщения отладки

  • $export_csv =  false

        Флаг экспорта в CSV

  • $external_replaces = array()

        Массив внешнех подстановок, применяется в DoReplaces()

  • $form_params = array()

        Свойство с параметрами формы

  • $on_page =  0

        Число элементов формы на страницу

  • $order_field_direction =  1

        Направление сортировки: 1 - ASC, 2 - DESC.

  • $order_field_id =  0

        Идентификатор поля сортировки.

  • $page_number =  0

        Номер текущей страницы формы

  • $ShowBottom =  true

        Показывать нижнюю строку с действиями

  • $ShowFilter =  true

        Показывать фильтр

  • $ShowOperations =  true

        Показывать действия

  • $user_function_message =  ''

        Строка с суммарной строкой ошибок, произошедших в пользовательских событиях.

  • $user_function_result =  ''

        Строка с результатом выполнения пользовательской функции.

  • $window_id =  NULL

        Идентификатор окна

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • admin_forms admin_forms()

    Конструктор, инициализирует значения свойств класса $this->AAction, $this->AAdditionalParams

  • void AddExternalReplace()

    Добавление внешней подстановки

  • mixed AddLanguage()

    Вставка/обновление информации о языке

  • void AddUserMessage()

    Добавление текста, выводимого перед формой

  • void ApplyFormat()

    Применяет формат отображения $format к строке $str.

  • array CreateForm()

    Прорисовка формы центра администрирования.

  • void CreateMainMenu()

  • bool DeleteAdminForm()

    Удаление формы центра администрирования

  • resource DeleteAdminFormsEvent()

    Удаление события (дейтсвия) формы администрирования

  • resource DeleteAdminFormsField()

    Удаление поля формы администрирования

  • boolean DeleteAdminLanguage()

    Удаление языка центра администрирования

  • bool DeleteWord()

    Удаление слова и всех его значений

  • string DoReplaces()

    Подстановка стандартных значений полей

  • void ExecuteUsersEvents()

    Вызов пользовательских ф-ций (событий)

  • array GetAdminForm()

    Получение данных о форме центра управления.

  • mixed GetAdminFormsEvent()

    Получение информации о событии (действии) формы центра администрирования

  • mixed GetAdminFormsEventByName()

    Получение информации о событии (действии) формы центра администрирования  по идентификатору формы и псевдониму действия

  • mixed GetAdminFormsField()

    Извлечение информации о поле формы центра администрирования

  • mixed GetAdminFormsWord()

    Получение названия и описания слова на выбранном языке

  • mixed GetAdminFormsWordOrDefaultLanguageWord()

    Получение названия и описания слова на выбранном языке. Если для выбранного  языка не найдено значение, получается значения для языка "по умолчанию".

  • array GetAllAdminFormEvents()

    Получение списка всех событий формы администрирования

  • array GetAllAdminFormFields()

    Получение списка всех полей формы администрирования

  • array GetAllEvents()

    Получение списка всех событий формы центра администрирования

  • array GetAllLanguages()

    Извлечение всех языков

  • array GetAllWordsByLanguage()

    Извлечения списка слов определенного языка

  • string GetHtmlCallDoLoadAjax()

    Получение кода вызова DoLoadAjax для атрибута href

  • string GetHtmlCallTrigerSingleAction()

    Формирует ссылку действия для содержимого атрибута href тега a

  • mixed GetLanguage()

    Получение информации о языке центра администрирования

  • mixed GetLanguageByShortName()

    Получение информации о языке центра администрирования по его обозначени.

  • string GetOnClickCallDoLoadAjax()

    Получение кода вызова DoLoadAjax для события onClick

  • string GetOnClickCallTrigerSingleAction()

    Формирует ссылку действия для содержимого атрибута onclick тега a

  • int GetOnPageCount()

    Получение числа элементов на страницу

  • mixed GetSettingsForForm()

    Получение информации о настройках для формы у указанного пользователя.

  • void GetWindowId()

  • int InsertAdminForm()

    Вставка/обновление формы центра управления

  • mixed InsertAdminFormsEvent()

    Вставка/обновление информации о событии (дейтсвии) формы администрирования

  • int InsertAdminFormsField()

    Вставка информации о поле формы центра администрирования

  • int InsertSettings()

    Вставка/обновление информации о настройках формы для пользователя

  • int InsertWord()

    Вставка/обновление слова

  • int InsertWordsValue()

    Вставка информации о значении слова

  • bool ProcessAjax()

    Обработчик вызывает обработку действий и построение формы

  • void setAAction()

    Устанавливает значение AAction

  • void setAAdditionalParams()

    Устанавливает значение AAdditionalParams

  • void ShowBreadCrumbs()

    Отображение хлебных крошек.

  • array ShowForm()

    Обрабатывает действия формы, вызывает построение формы

  • void ShowLink()

    Показ строки ссылок

  • bool WordExists()

    Проверка, существования идентификатора слова

Унаследованные методы

Описания методов

    admin_forms::admin_forms

admin_forms(
 );

    Описание

    Конструктор, инициализирует значения свойств класса $this->AAction, $this->AAdditionalParams

    [ Наверх ]

    admin_forms::AddExternalReplace

AddExternalReplace(
string
$name, string
$value );

    Описание

    Добавление внешней подстановки

    Принимаемые параметры

    $name

    навание подстановки

    $value

    значение подстановки

    [ Наверх ]

    admin_forms::AddLanguage

AddLanguage(
array
$param );

    Описание

    Вставка/обновление информации о языке

    Принимаемые параметры

    $param

    массив параметров  $param['admin_language_id'] идентификатор обновляемого языка  $param['admin_language_name'] название языка  $param['admin_language_active'] параметр, определяющий доступен язык или нет (1 - доступен (по умолчанию), 0 - не доступен )  $param['admin_language_order'] порядковый номер языка в списке языков  $param['admin_language_short_name'] короткое обозначение языка

    Возвращает

    идентификатор вставленного/обновленного языка в случае успешного завершения, false - в противном случае
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $param['admin_language_name'] = 'Французский';
      5.

    5.  $param['admin_language_active'] = 0;
      6.

    6.  $param['admin_language_order'] = 30;
      7.

    7.  $param['admin_language_short_name'] = 'fr';
      8.

    8.
      9.

    9.  $newid = $admin_forms->AddLanguage($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    [ Наверх ]

    admin_forms::AddUserMessage

AddUserMessage(
string
$message );

    Описание

    Добавление текста, выводимого перед формой

    Принимаемые параметры

    $message

    текст сообщения

    [ Наверх ]

    admin_forms::ApplyFormat

ApplyFormat(
string
$str, string
$format );

    Описание

    Применяет формат отображения $format к строке $str.

    Если формат является пустой строкой - $str возвращается в исходном виде.

    Принимаемые параметры

    $str

    исходная строка

    $format

    форма отображения. Строка формата состоит из директив: обычных символов (за исключением %),  которые копируются в результирующую строку, и описатели преобразований,  каждый из которых заменяется на один из параметров.

    [ Наверх ]

    admin_forms::CreateForm

CreateForm(
int
$admin_forms_id );

    Описание

    Прорисовка формы центра администрирования.

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы

    Возвращает

    данные о форме в массиве:
    array(
    'form_html' => Основной код,
    'error' => Текст ошибки,
    'title' => Заголовок страницы);

    [ Наверх ]

    admin_forms::CreateMainMenu

    CreateMainMenu(

$menu, [
$field_list = false], [
$first_level = true], [
$menu_id = false] );

    Принимаемые параметры

    $menu

    $field_list

    $first_level

    $menu_id

    [ Наверх ]

    admin_forms::DeleteAdminForm

DeleteAdminForm(
int
$admin_forms_id );

    Описание

    Удаление формы центра администрирования

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы центра администрирования

    Возвращает

    результат выполнения запроса
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = 1;
      5.

    5.
      6.

    6.  $result = $admin_forms->DeleteAdminForm($admin_forms_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    admin_forms::DeleteAdminFormsEvent

DeleteAdminFormsEvent(
int
$admin_forms_events_id );

    Описание

    Удаление события (дейтсвия) формы администрирования

    Принимаемые параметры

    $admin_forms_events_id

    идентификатор события, которое нужно удалить

    Возвращает

    результат выполнения запроса
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_events_id = 100001;
      5.

    5.
      6.

    6.  $resource = $admin_forms->DeleteAdminFormsEvent($admin_forms_events_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $resource;
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::DeleteAdminFormsField

DeleteAdminFormsField(
int
$admin_forms_field_id );

    Описание

    Удаление поля формы администрирования

    Принимаемые параметры

    $admin_forms_field_id

    идентификатор поля

    Возвращает

    результат выполнения запроса
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_field_id = 100002;
      5.

    5.
      6.

    6.  $resource = $admin_forms->DeleteAdminFormsField($admin_forms_field_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $resource;
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::DeleteAdminLanguage

DeleteAdminLanguage(
int
$admin_language_id );

    Описание

    Удаление языка центра администрирования

    Принимаемые параметры

    $admin_language_id

    идентификатор удаляемого языка центра администрирования

    Возвращает

    в случае успешного удаления, false - в противном случае
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_language_id = 100000;
      5.

    5.
      6.

    6.  $result = $admin_forms->DeleteAdminLanguage($admin_language_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    admin_forms::DeleteWord

DeleteWord(
int
$admin_words_id );

    Описание

    Удаление слова и всех его значений

    Принимаемые параметры

    $admin_words_id

    идентификатор слова

    Возвращает

    результат выполнения запроса
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_words_id = 4;
      5.

    5.
      6.

    6.  $result = $admin_forms->DeleteWord($admin_words_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    admin_forms::DoReplaces

    DoReplaces(
[int
$admin_forms_id = false], [array
$field_list = false], string
$subject );

    Описание

    Подстановка стандартных значений полей

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы, если указан - берется список полей данной формы.

    $field_list

    массив со списком полей, может быть false

    $subject

    строка, в которой необходимо произвести подстановки

    Возвращает

    строка с заменой подстановок

    [ Наверх ]

    admin_forms::ExecuteUsersEvents

ExecuteUsersEvents(
int
$admin_forms_id,
$operation );

    Описание

    Вызов пользовательских ф-ций (событий)

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы центра управления

    $operation

    [ Наверх ]

    admin_forms::GetAdminForm

GetAdminForm(
int
$admin_forms_id );

    Описание

    Получение данных о форме центра управления.

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы

    Возвращает

    массив с данными о форме
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = 11;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAdminForm($admin_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetAdminFormsEvent

GetAdminFormsEvent(
int
$admin_forms_events_id );

    Описание

    Получение информации о событии (действии) формы центра администрирования

    Принимаемые параметры

    $admin_forms_events_id

    идентификатор события

    Возвращает

    массив с информацией о событии или false
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_events_id = 1;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAdminFormsEvent($admin_forms_events_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetAdminFormsEventByName

GetAdminFormsEventByName(
int
$admin_forms_id, int
$admin_forms_events_function );

    Описание

    Получение информации о событии (действии) формы центра администрирования  по идентификатору формы и псевдониму действия

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы

    $admin_forms_events_function

    псевдоним действия (имя функции обработчика)

    Возвращает

    массив с информацией о событии или false
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = 1;
      5.

    5.  $admin_forms_events_function = 'edit_form';
      6.

    6.
      7.

    7.  $row = $admin_forms->GetAdminFormsEvent($admin_forms_events_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    admin_forms::GetAdminFormsField

GetAdminFormsField(
int
$admin_forms_field_id );

    Описание

    Извлечение информации о поле формы центра администрирования

    Принимаемые параметры

    $admin_forms_field_id

    идентификатор поля

    Возвращает

    массив с информацией о поле или false
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_field_id = 1;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAdminFormsField($admin_forms_field_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetAdminFormsWord

GetAdminFormsWord(
int
$admin_words_id, [int
$admin_language_id = CURRENT_LANGUAGE_ID] );

    Описание

    Получение названия и описания слова на выбранном языке

    Принимаемые параметры

    $admin_words_id

    идентификатор слова

    $admin_language_id

    идентификатор языка, по умолчанию - текущий

    Возвращает

    массив с результатом, ['name'] - имя, ['description'] - описание.

    [ Наверх ]

    admin_forms::GetAdminFormsWordOrDefaultLanguageWord

GetAdminFormsWordOrDefaultLanguageWord(
int
$admin_words_id, [int
$admin_language_id = CURRENT_LANGUAGE_ID] );

    Описание

    Получение названия и описания слова на выбранном языке. Если для выбранного  языка не найдено значение, получается значения для языка "по умолчанию".

    Принимаемые параметры

    $admin_words_id

    идентификатор слова

    $admin_language_id

    идентификатор языка, по умолчанию - текущий

    Возвращает

    массив с результатом, ['name'] - имя, ['description'] - описание.

    see

    admin_forms::GetAdminFormsWord()

    [ Наверх ]

    admin_forms::GetAllAdminFormEvents

GetAllAdminFormEvents(
[int
$admin_forms_id = false] );

    Описание

    Получение списка всех событий формы администрирования

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы, если false - извлекается информация о событиях всех форм

    Возвращает

    с данными о полях или false
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = false;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAllAdminFormEvents($admin_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetAllAdminFormFields

GetAllAdminFormFields(
[int
$admin_forms_id = false] );

    Описание

    Получение списка всех полей формы администрирования

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы, если false - извлекается информация о полях всех форм

    Возвращает

    со данными о полях или false
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = false;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAllAdminFormFields($admin_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetAllEvents

GetAllEvents(
int
$admin_forms_id, [int
$users_id = false] );

    Описание

    Получение списка всех событий формы центра администрирования

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы центра администрирования

    $users_id

    идентификатор пользователя, по умолчанию false. Если передан - производится выборка только доступных действий для пользователя

    Возвращает

    массив со списком событий
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = 11;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAllEvents($admin_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetAllLanguages

GetAllLanguages(
 );

    Описание

    Извлечение всех языков

    Возвращает

    со списком языков или false
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $rows = $admin_forms->GetAllLanguages();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  print_r ($rows);
      8.

    8.  ?>
      9.

    [ Наверх ]

    admin_forms::GetAllWordsByLanguage

GetAllWordsByLanguage(
[int
$admin_language_id = false] );

    Описание

    Извлечения списка слов определенного языка

    Принимаемые параметры

    $admin_language_id

    идентификатор языка

    Возвращает

    массив с данными о словах
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_language_id = 1;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetAllWordsByLanguage($admin_language_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetHtmlCallDoLoadAjax

GetHtmlCallDoLoadAjax(
string
$AAction, string
$AAdditionalParams, int
$AAdminFromsId, string
$AOperation, [int
$ALimit = 0], [int
$AOnPage = 0], [mixed
$AOrderFieldId = false], [mixed
$AOrderDirection = false] );

    Описание

    Получение кода вызова DoLoadAjax для атрибута href

    Принимаемые параметры

    $AAction

    адрес страницы для обращения, например, '/admin/admin_forms/admin_forms.php'

    $AAdditionalParams

    дополнительные параметры для передачи на страницу, например "&admin_forms_edit_id=$admin_forms_id"

    $AAdminFromsId

    идентификатор формы центра администрирования

    $AOperation

    наименование операции, например, 'load_data'

    $ALimit

    позиция, начиная с которой начинается вывод записей, по умолчанию 0. Необязательный параметр.

    $AOnPage

    количество записей на страницу. Необязательный параметр.

    $AOrderFieldId

    Идентификатор поля сортировки. Необязательный параметр.

    $AOrderDirection

    Направление сортировки (1 - ASC, 2 - DESC). Необязательный параметр.

    Возвращает

    строка кода вызова

    [ Наверх ]

    admin_forms::GetHtmlCallTrigerSingleAction

GetHtmlCallTrigerSingleAction(
string
$AOperation, string
$AItemName, int
$AAdminFromsId, [int
$ALimit = 0], [int
$AOnPage = 0], [mixed
$AOrderFieldId = false], [mixed
$AOrderDirection = false], [mixed
$AAction = false], [mixed
$AAdditionalParams = false] );

    Описание

    Формирует ссылку действия для содержимого атрибута href тега a

    Принимаемые параметры

    $AOperation

    Наименование действия, например, 'edit_affiliate'

    $AItemName

    Наименование объекта с указанием источника и ID объекта по схеме check_{номер источника}_{код объекта}, например, 'check_0_10'

    $AAdminFromsId

    Идентификатор формы центра администрирования

    $ALimit

    Позиция, начиная с которой начинается вывод записей, по умолчанию 0. Необязательный параметр.

    $AOnPage

    Количество записей на страницу. Необязательный параметр.

    $AOrderFieldId

    Идентификатор поля сортировки. Необязательный параметр.

    $AOrderDirection

    Направление сортировки (1 - ASC, 2 - DESC). Необязательный параметр.

    $AAction

    Адрес страницы для обращения, например, '/admin/admin_forms/admin_forms.php'.

    $AAdditionalParams

    Дополнительные параметры для передачи на страницу, например "&admin_forms_edit_id=$admin_forms_id"

    Возвращает

    строка кода вызова

    [ Наверх ]

    admin_forms::GetLanguage

GetLanguage(
int
$admin_language_id );

    Описание

    Получение информации о языке центра администрирования

    Принимаемые параметры

    $admin_language_id

    идентификатор языка

    Возвращает

    ассоциативный массив с даными о языке в случае успешного выполнения, false - в противном случае
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_language_id = 1;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetLanguage($admin_language_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetLanguageByShortName

GetLanguageByShortName(

$admin_language_short_name, int
$admin_language_id );

    Описание

    Получение информации о языке центра администрирования по его обозначени.

    Принимаемые параметры

    $admin_language_id

    идентификатор языка

    $admin_language_short_name

    Возвращает

    ассоциативный массив с даными о языке в случае успешного выполнения, false - в противном случае
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_language_short_name = 'ru';
      5.

    5.
      6.

    6.  $row = $admin_forms->GetLanguageByShortName($admin_language_short_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetOnClickCallDoLoadAjax

GetOnClickCallDoLoadAjax(
string
$AAction, string
$AAdditionalParams, int
$AAdminFromsId, string
$AOperation, [int
$ALimit = 0], [int
$AOnPage = 0], [mixed
$AOrderFieldId = false], [mixed
$AOrderDirection = false] );

    Описание

    Получение кода вызова DoLoadAjax для события onClick

    Принимаемые параметры

    $AAction

    адрес страницы для обращения, например, '/admin/admin_forms/admin_forms.php'

    $AAdditionalParams

    дополнительные параметры для передачи на страницу, например "&admin_forms_edit_id=$admin_forms_id"

    $AAdminFromsId

    идентификатор формы центра администрирования

    $AOperation

    наименование операции, например, 'load_data'

    $ALimit

    позиция, начиная с которой начинается вывод записей, по умолчанию 0. Необязательный параметр.

    $AOnPage

    количество записей на страницу. Необязательный параметр.

    $AOrderFieldId

    Идентификатор поля сортировки. Необязательный параметр.

    $AOrderDirection

    Направление сортировки (1 - ASC, 2 - DESC). Необязательный параметр.

    Возвращает

    строка кода вызова

    [ Наверх ]

    admin_forms::GetOnClickCallTrigerSingleAction

GetOnClickCallTrigerSingleAction(
string
$AOperation, string
$AItemName, int
$AAdminFromsId, [int
$ALimit = 0], [int
$AOnPage = 0], [mixed
$AOrderFieldId = false], [mixed
$AOrderDirection = false], [mixed
$AAction = false], [mixed
$AAdditionalParams = false] );

    Описание

    Формирует ссылку действия для содержимого атрибута onclick тега a

    Принимаемые параметры

    $AOperation

    Наименование действия, например, 'edit_affiliate'

    $AItemName

    Наименование объекта с указанием источника и ID объекта по схеме check_{номер источника}_{код объекта}, например, 'check_0_10'

    $AAdminFromsId

    Идентификатор формы центра администрирования

    $ALimit

    Позиция, начиная с которой начинается вывод записей, по умолчанию 0. Необязательный параметр.

    $AOnPage

    Количество записей на страницу. Необязательный параметр.

    $AOrderFieldId

    Идентификатор поля сортировки. Необязательный параметр.

    $AOrderDirection

    Направление сортировки (1 - ASC, 2 - DESC). Необязательный параметр.

    $AAction

    Адрес страницы для обращения, например, '/admin/admin_forms/admin_forms.php'.

    $AAdditionalParams

    Дополнительные параметры для передачи на страницу, например "&admin_forms_edit_id=$admin_forms_id"

    Возвращает

    строка кода вызова

    [ Наверх ]

    admin_forms::GetOnPageCount

GetOnPageCount(
[mixed
$admin_forms_id = false] );

    Описание

    Получение числа элементов на страницу

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы. Если не указан, берется из $_REQUEST['admin_forms_id']. по умолчанию false

    Возвращает

    число элементов на страницу
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $result = $admin_forms->GetOnPageCount();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    [ Наверх ]

    admin_forms::GetSettingsForForm

GetSettingsForForm(
int
$admin_forms_id, [int
$users_id = false] );

    Описание

    Получение информации о настройках для формы у указанного пользователя.

    Принимаемые параметры

    $admin_forms_id

    идентификтор формы центры администрирования

    $users_id

    идентификтор пользователя

    Возвращает

    массив с данными или false, если данные не найдены
    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_forms_id = 11;
      5.

    5.
      6.

    6.  $row = $admin_forms->GetSettingsForForm($admin_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms::GetWindowId

GetWindowId(
 );

    [ Наверх ]

    admin_forms::InsertAdminForm

InsertAdminForm(
array
$param );

    Описание

    Вставка/обновление формы центра управления

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['admin_forms_id'] идентификатор формы
    int $param['admin_words_id'] идентификатор слова названия/описания формы
    int $param['admin_forms_on_page'] количество строк, выводимых на страницу
    string $param['admin_forms_key_field'] ключевое поле формы
    int $param['admin_forms_show_operations'] отображать столбец действий
    int $param['admin_forms_show_group_operations'] отображать групповые операции
    string $param['admin_forms_default_order_field'] поле для сортировки по умолчанию
    int $param['admin_forms_default_order_direction'] направление сортировки по умолчанию (1 - ASC, 2 - DESC)
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной/обновленной формы или false

    see

    InsertWordsValue()
 <code>
 <?php
 $admin_forms = new admin_forms();

 $param['admin_words_id'] = 4;
 $param['admin_forms_on_page'] = 5;
 $param['admin_forms_key_field'] = '';
 $param['admin_forms_show_operations'] = 1;
 $param['admin_forms_show_group_operations'] = 1;
 $param['admin_forms_default_order_field'] = '';
 $param['admin_forms_default_order_direction'] = 1;

 $newid = $admin_forms->InsertAdminForm($param);

 // Распечатаем результат
 echo $newid;
 ?>
 </code>

    see

    admin_forms::InsertWord()

    [ Наверх ]

    admin_forms::InsertAdminFormsEvent

InsertAdminFormsEvent(
array
$param );

    Описание

    Вставка/обновление информации о событии (дейтсвии) формы администрирования

    Принимаемые параметры

    $param

    массив с параметрами
    int $param['admin_forms_events_id'] идентификатор события
    int $param['admin_forms_id'] идентификатор формы центра администрирования
    int $param['admin_words_id'] идентификатор слова с названием и описанием события
    string $param['admin_forms_events_function'] функция вызываемая загрузчиком
    string $param['admin_forms_events_picture'] путь к изображению
    int $param['admin_forms_events_show_button'] отображать кнопку действия
    int $param['admin_forms_events_group_operation'] отображать в групповых операциях
    int $param['admin_forms_events_order'] порядок сортировки
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор вставленной/обновленной записи или false

    see

    InsertWordsValue()
 <code>
 <?php
 $admin_forms = new admin_forms();

 $param['admin_forms_id'] = 100000;
 $param['admin_words_id'] = 5;
 $param['admin_forms_events_function'] = '';
 $param['admin_forms_events_picture'] = '';
 $param['admin_forms_events_show_button'] = 1;
 $param['admin_forms_events_group_operation'] = 1;
 $param['admin_forms_events_order'] = 10;

 $newid = $admin_forms->InsertAdminFormsEvent($param);

 // Распечатаем результат
 echo $newid;
 ?>
 </code>

    see

    admin_forms::InsertWord()

    [ Наверх ]

    admin_forms::InsertAdminFormsField

InsertAdminFormsField(
array
$param );

    Описание

    Вставка информации о поле формы центра администрирования

    Принимаемые параметры

    $param

    массив с параметрами
    int $param['admin_forms_field_id'] идентификатор поля формы
    int $param['admin_forms_id'] идентификатор формы
    int $param['admin_words_id'] идентификатор слова названия/описания формы
    string $param['admin_forms_field_name'] название поля БД
    int $param['admin_forms_field_order'] порядок сортировки
    int $param['admin_forms_field_type'] тип поля
    string $param['admin_forms_field_format'] формат отображения данных
    int $param['admin_forms_field_allow_order'] разрешить сортировку поля
    int $param['admin_forms_field_allow_filter'] разрешить фильтр для поля
    string $param['admin_forms_field_align_title'] выравнивание заголовка (left, center, right)
    string $param['admin_forms_field_align'] выравнивание значения (left, center, right)
    string $param['admin_forms_field_width'] ширина поля
    string $param['admin_forms_field_style'] CSS-стиль
    string $param['admin_forms_field_attrib'] список атрибутов
    string $param['admin_forms_field_image'] путь к изображению с картинкой
    string $param['admin_forms_field_list'] массив значений выпадающего списка
    string $param['admin_forms_field_link'] адрес ссылки
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленного поля

    see

    InsertWordsValue()
 <code>
 <?php
 $admin_forms = new admin_forms();

 $param['admin_forms_id'] = 100000;
 $param['admin_words_id'] = 5;
 $param['admin_forms_field_name'] = 'New';
 $param['admin_forms_field_order'] = 1;
 $param['admin_forms_field_type'] = 1;
 $param['admin_forms_field_allow_order'] = 1;
 $param['admin_forms_field_allow_filter'] = 1;
 $param['admin_forms_field_link'] = '';
 $param['admin_forms_field_onclick'] = '';
 $param['admin_forms_field_list'] = '';

 $newid = $admin_forms->InsertAdminFormsField($param);

 // Распечатаем результат
 echo $newid;
 ?>
 </code>

    see

    admin_forms::InsertWord()

    [ Наверх ]

    admin_forms::InsertSettings

InsertSettings(
array
$param );

    Описание

    Вставка/обновление информации о настройках формы для пользователя

    Принимаемые параметры

    $param

    массив параметров
    int $param['admin_forms_settings_id'] идентификатор настройки, если не указан - производится вставка записи
    int $param['users_id'] идентификатор пользователя
    int $param['admin_forms_id'] идентификатор формы
    int $param['admin_forms_settings_page_number'] номер страницы
    int $param['admin_forms_settings_order_field_id'] идентификатор поля сортировки
    int $param['admin_forms_settings_order_direction'] направление сортировки (1 - ASC, 2 - DESC)
    string $param['admin_forms_settings_filter'] сериализованный массив с фильтром
    int $param['admin_forms_settings_on_page'] число элементов на страницу

    Возвращает

    идентификтор вставленной/обновленной настройки или false

    [ Наверх ]

    admin_forms::InsertWord

InsertWord(
array
$param );

    Описание

    Вставка/обновление слова

    Принимаемые параметры

    $param

    массив параметров
    • int $param['admin_words_id'] идентификатор слова
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор вставленного/обновленного слова

    see

    admin_forms::InsertWordsValue()

    [ Наверх ]

    admin_forms::InsertWordsValue

InsertWordsValue(
array
$param );

    Описание

    Вставка информации о значении слова

    Принимаемые параметры

    $param

    параметры
    • int $param['admin_words_value_id'] идентификатор значения слова
    • int $param['admin_words_id'] идентификатор слова (обязательный параметр)
    • int $param['admin_language_id'] идентификатор языка (обязательный параметр)
    • string $param['admin_words_value_name'] имя на указанном языке
    • string $param['admin_words_value_description'] описание на указанном языке

    Возвращает

    идентификатор вставленного значения слова

    see

    admin_forms::InsertWord()

    [ Наверх ]

    admin_forms::ProcessAjax

ProcessAjax(
int
$admin_forms_id );

    Описание

    Обработчик вызывает обработку действий и построение формы

    Принимаемые параметры

    $admin_forms_id

    Идентификатор формы центра администрирования

    [ Наверх ]

    admin_forms::setAAction

setAAction(
string
$AAction );

    Описание

    Устанавливает значение AAction

    Принимаемые параметры

    $AAction

    [ Наверх ]

    admin_forms::setAAdditionalParams

setAAdditionalParams(
string
$AAdditionalParams );

    Описание

    Устанавливает значение AAdditionalParams

    Принимаемые параметры

    $AAdditionalParams

    [ Наверх ]

    admin_forms::ShowBreadCrumbs

ShowBreadCrumbs(
 );

    Описание

    Отображение хлебных крошек.

    Используются данные $this->form_params['path_array'] и $this->form_params['path_separator']

    [ Наверх ]

    admin_forms::ShowForm

ShowForm(
[int
$admin_forms_id = 0], [mixed
$operation = false] );

    Overridden in child classes as:

    admin_forms_fields::ShowForm()

    Отображение формы центра администрирования

    Описание

    Обрабатывает действия формы, вызывает построение формы

    Принимаемые параметры

    $admin_forms_id

    Идентификатор формы центра администрирования

    $operation

    наименование действия, если false - получается из $_GET['operation']. по умолчанию false

    Возвращает

    массив для передачи на отправку ProcessAjax, формат:
    array(
    'form_html' => Основной код,
    'error' => Текст ошибки,
    'title' => Заголовок страницы);

    [ Наверх ]

    admin_forms::ShowLink

ShowLink(
int
$total_count, int
$count_on_page, int
$current_page, [array
$param = array()] );

    Описание

    Показ строки ссылок

    Принимаемые параметры

    $total_count

    общее число записей

    $count_on_page

    число записей на страницу

    $current_page

    номер текущей страницы

    $param

    массив дополнительных параметров
    • $param['separator'] разделитель между ссылками
    • $param['count_num'] число ссылок перед и после текущей страницы, а также в окончании стороки ссылок
    • $param['first'] строка для отображения ссылки на первую страницу
    • $param['pred'] строка для отображения ссылки на предыдущую страницу
    • $param['last'] строка для отображения ссылки на последнюю страницу
    • $param['next'] строка для отображения ссылки на следующую страницу
    • $param['show_first'] параметр, определяющий показывать ссылку на первую страницу
    • $param['show_last'] параметр, определяющий показывать ссылку на последнюю страницу
    • $param['show_pred'] параметр, определяющий показывать ссылку на предыдущую страницу
    • $param['show_next'] параметр, определяющий показывать ссылку на следующую страницу
    • $param['admin_forms_id'] идентификатор формы центра администрирования

    [ Наверх ]

    admin_forms::WordExists

WordExists(
int
$admin_words_id );

    Описание

    Проверка, существования идентификатора слова

    Принимаемые параметры

    $admin_words_id

    идентификатор слова

    Возвращает

    1.  <?php
      2.

    2.  $admin_forms = new admin_forms();
      3.

    3.
      4.

    4.  $admin_words_id = 60;
      5.

    5.
      6.

    6.  $result = $admin_forms->WordExists($admin_words_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Слово существует";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Слово не существует";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

Описания переменных

  • $AAction =  '' [Строка 114]
    •

  • Data type: str
    •

    Описание

    Значение AAction, переданное DoLoadAjax

  • $AAdditionalParams =  '' [Строка 121]
    •

  • Data type: str
    •

    Описание

    Значение AAdditionalParams, переданное DoLoadAjax

  • $CacheGetAdminFormsWord = array() [Строка 128]
    •

  • Data type: array
    •

    Описание

    Массив-кэш для метода GetAdminFormsWord()

  • $CacheGetLanguage = array() [Строка 142]
    •

  • Data type: array
    •

    Описание

    Массив кэш для GetLanguage()

  • $CacheGetLanguageByShortName = array() [Строка 135]
    •

  • Data type: array
    •

    Описание

    Массив-кэш для GetLanguageByShortName()

  • $CallbackFunctionName =  'LoadAjaxData' [Строка 148]
    •

  • Data type: string
    •

    Описание

    Наименование функции обратного вызова

  • $data_under_menu =  [Строка 100]
    •

  • Data type: string
    •

    Описание

    Код для вывода под меню

  • $debug =  [Строка 93]
    •

  • Data type: string
    •

    Описание

    Сообщения отладки

  • $export_csv =  false [Строка 107]
    •

  • Data type: boolean
    •

    Описание

    Флаг экспорта в CSV

  • $external_replaces = array() [Строка 44]
    •

  • Data type: array
    •

    Описание

    Массив внешнех подстановок, применяется в DoReplaces()

  • $form_params = array() [Строка 37]
    •

  • Data type: array
    •

    Описание

    Свойство с параметрами формы

    var

    - $form_params['data'] - массив наборов данных
    • $form_params['limit'] - массив лимитов для источников данных по схеме [] = array('begin' => $x, 'count' => $y)
    • $form_params['error'] - тест ошибки, передаваемый из пользовательского обработчика
    • $form_params['total_count'] - массив с общим числом элементов на страницу для каждого набора данных
    • $form_params['redirect'] - адрес страницы, на которую необходимо осуществить редирект
    • $form_params['current_page'] - номер текущей страницы
    • $form_params['on_page'] - элементов на страницу
    • $form_params['menus'] - массив меню
    • $form_params['field_params'] - массив с перекрываемыми параметрами полей по наборам данных для каждого идентификатора набора данных
    • в виде $form_params['field_params'][<идентификатор набора данных>][<имя поля>] - массив параметров
    • $form_params['field_params'][<идентификатор набора данных>][<имя поля>]['callback_function'] - имя функции обратного вызова
    • $form_params['path_array'] - массив хлебных крошек, передается по форме

      [x]['name'] - название ссылки

      [x]['link'] - адрес ссылки

      [x]['onclick'] - код события onclick
    • $form_params['path_separator'] - разделитель для строки навигации

  • $on_page =  0 [Строка 79]
    •

  • Data type: int
    •

    Описание

    Число элементов формы на страницу

  • $order_field_direction =  1 [Строка 72]
    •

  • Data type: int
    •

    Описание

    Направление сортировки: 1 - ASC, 2 - DESC.

  • $order_field_id =  0 [Строка 65]
    •

  • Data type: int
    •

    Описание

    Идентификатор поля сортировки.

  • $page_number =  0 [Строка 86]
    •

  • Data type: int
    •

    Описание

    Номер текущей страницы формы

  • $ShowBottom =  true [Строка 166]
    •

  • Data type: bool
    •

    Описание

    Показывать нижнюю строку с действиями

  • $ShowFilter =  true [Строка 154]
    •

  • Data type: bool
    •

    Описание

    Показывать фильтр

  • $ShowOperations =  true [Строка 160]
    •

  • Data type: bool
    •

    Описание

    Показывать действия

  • $user_function_message =  '' [Строка 51]
    •

  • Data type: string
    •

    Описание

    Строка с суммарной строкой ошибок, произошедших в пользовательских событиях.

  • $user_function_result =  '' [Строка 58]
    •

  • Data type: string
    •

    Описание

    Строка с результатом выполнения пользовательской функции.

  • $window_id =  NULL [Строка 171]
    •

  • Data type: mixed
    •

    Описание

    Идентификатор окна

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class admin_forms_fields

Class admin_forms_fields

[Строка 14]
admin_forms
   |
   --admin_forms_fields
Размещен: /admin_forms/admin_forms_fields.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс, реализующий UI для редактирования различных параметров центра управления.

Файл: /modules/admin_forms/admin_forms.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $buttons = array()
  • $external_html =  ''
    Свойство, содержащее html-код, дописываемый после отображения формы
  • $fields = array()
  • $form_params = array()
    Свойство с параметрами формы
  • $menus = array()
  • $SelectFilterCount =  0
  • $tabs = array()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Унаследованные от класса admin_forms

  • admin_forms::$AAction = ''
    Значение AAction, переданное DoLoadAjax
  • admin_forms::$AAdditionalParams = ''
    Значение AAdditionalParams, переданное DoLoadAjax
  • admin_forms::$CacheGetAdminFormsWord = array()
    Массив-кэш для метода GetAdminFormsWord()
  • admin_forms::$CacheGetLanguage = array()
    Массив кэш для GetLanguage()
  • admin_forms::$CacheGetLanguageByShortName = array()
    Массив-кэш для GetLanguageByShortName()
  • admin_forms::$CallbackFunctionName = 'LoadAjaxData'
    Наименование функции обратного вызова
  • admin_forms::$data_under_menu =
    Код для вывода под меню
  • admin_forms::$debug =
    Сообщения отладки
  • admin_forms::$export_csv = false
    Флаг экспорта в CSV
  • admin_forms::$external_replaces = array()
    Массив внешнех подстановок, применяется в DoReplaces()
  • admin_forms::$on_page = 0
    Число элементов формы на страницу
  • admin_forms::$order_field_direction = 1
    Направление сортировки: 1 - ASC, 2 - DESC.
  • admin_forms::$order_field_id = 0
    Идентификатор поля сортировки.
  • admin_forms::$page_number = 0
    Номер текущей страницы формы
  • admin_forms::$ShowBottom = true
    Показывать нижнюю строку с действиями
  • admin_forms::$ShowFilter = true
    Показывать фильтр
  • admin_forms::$ShowOperations = true
    Показывать действия
  • admin_forms::$user_function_message = ''
    Строка с суммарной строкой ошибок, произошедших в пользовательских событиях.
  • admin_forms::$user_function_result = ''
    Строка с результатом выполнения пользовательской функции.
  • admin_forms::$window_id = NULL
    Идентификатор окна

Методы

  • admin_forms_fields admin_forms_fields()
    Конструктор класса
  • int AddButton()
    Вставка кнопки в форму
  • void AddExternalHtml()
    Добавить внешний HTML для формы
  • int AddField()
    Добавление элемента на форму.
  • int AddMenu()
    Добавление верхнего меню
  • void AddSeparator()
    Вставка разделителя
  • return AddTab()
    Вставка новой закладки
  • mixed CopyAdminFormEvent()
    Копирование события формы центра администрирования
  • mixed CopyAdminFormField()
    Копирование поля формы центра администрирования
  • void CreateOptions()
    Создание тегов <option> для каждого элемента ассоциативного массива
  • str GetExternalHtml()
    Получить установленный внешний HTML для формы
  • void SetExternalHtml()
    Установить внешний HTML для формы
  • void ShowForm()
    Отображение формы центра администрирования

Унаследованные методы

Унаследованные от класса admin_forms

  • admin_forms::admin_forms()
    Конструктор, инициализирует значения свойств класса $this->AAction, $this->AAdditionalParams
  • admin_forms::AddExternalReplace()
    Добавление внешней подстановки
  • admin_forms::AddLanguage()
    Вставка/обновление информации о языке
  • admin_forms::AddUserMessage()
    Добавление текста, выводимого перед формой
  • admin_forms::ApplyFormat()
    Применяет формат отображения $format к строке $str.
  • admin_forms::CreateForm()
    Прорисовка формы центра администрирования.
  • admin_forms::CreateMainMenu()
  • admin_forms::DeleteAdminForm()
    Удаление формы центра администрирования
  • admin_forms::DeleteAdminFormsEvent()
    Удаление события (дейтсвия) формы администрирования
  • admin_forms::DeleteAdminFormsField()
    Удаление поля формы администрирования
  • admin_forms::DeleteAdminLanguage()
    Удаление языка центра администрирования
  • admin_forms::DeleteWord()
    Удаление слова и всех его значений
  • admin_forms::DoReplaces()
    Подстановка стандартных значений полей
  • admin_forms::ExecuteUsersEvents()
    Вызов пользовательских ф-ций (событий)
  • admin_forms::GetAdminForm()
    Получение данных о форме центра управления.
  • admin_forms::GetAdminFormsEvent()
    Получение информации о событии (действии) формы центра администрирования
  • admin_forms::GetAdminFormsEventByName()
    Получение информации о событии (действии) формы центра администрирования по идентификатору формы и псевдониму действия
  • admin_forms::GetAdminFormsField()
    Извлечение информации о поле формы центра администрирования
  • admin_forms::GetAdminFormsWord()
    Получение названия и описания слова на выбранном языке
  • admin_forms::GetAdminFormsWordOrDefaultLanguageWord()
    Получение названия и описания слова на выбранном языке. Если для выбранного языка не найдено значение, получается значения для языка "по умолчанию".
  • admin_forms::GetAllAdminFormEvents()
    Получение списка всех событий формы администрирования
  • admin_forms::GetAllAdminFormFields()
    Получение списка всех полей формы администрирования
  • admin_forms::GetAllEvents()
    Получение списка всех событий формы центра администрирования
  • admin_forms::GetAllLanguages()
    Извлечение всех языков
  • admin_forms::GetAllWordsByLanguage()
    Извлечения списка слов определенного языка
  • admin_forms::GetHtmlCallDoLoadAjax()
    Получение кода вызова DoLoadAjax для атрибута href
  • admin_forms::GetHtmlCallTrigerSingleAction()
    Формирует ссылку действия для содержимого атрибута href тега a
  • admin_forms::GetLanguage()
    Получение информации о языке центра администрирования
  • admin_forms::GetLanguageByShortName()
    Получение информации о языке центра администрирования по его обозначени.
  • admin_forms::GetOnClickCallDoLoadAjax()
    Получение кода вызова DoLoadAjax для события onClick
  • admin_forms::GetOnClickCallTrigerSingleAction()
    Формирует ссылку действия для содержимого атрибута onclick тега a
  • admin_forms::GetOnPageCount()
    Получение числа элементов на страницу
  • admin_forms::GetSettingsForForm()
    Получение информации о настройках для формы у указанного пользователя.
  • admin_forms::GetWindowId()
  • admin_forms::InsertAdminForm()
    Вставка/обновление формы центра управления
  • admin_forms::InsertAdminFormsEvent()
    Вставка/обновление информации о событии (дейтсвии) формы администрирования
  • admin_forms::InsertAdminFormsField()
    Вставка информации о поле формы центра администрирования
  • admin_forms::InsertSettings()
    Вставка/обновление информации о настройках формы для пользователя
  • admin_forms::InsertWord()
    Вставка/обновление слова
  • admin_forms::InsertWordsValue()
    Вставка информации о значении слова
  • admin_forms::ProcessAjax()
    Обработчик вызывает обработку действий и построение формы
  • admin_forms::setAAction()
    Устанавливает значение AAction
  • admin_forms::setAAdditionalParams()
    Устанавливает значение AAdditionalParams
  • admin_forms::ShowBreadCrumbs()
    Отображение хлебных крошек.
  • admin_forms::ShowForm()
    Обрабатывает действия формы, вызывает построение формы
  • admin_forms::ShowLink()
    Показ строки ссылок
  • admin_forms::WordExists()
    Проверка, существования идентификатора слова

Описания методов

    admin_forms_fields::admin_forms_fields

    admin_forms_fields( [array $form_params = array()] );

    Описание

    Конструктор класса

    Принимаемые параметры

    $form_params

    массив с параметрами

    • string $form_params['form_attribs'] атрибуты формы

    [ Наверх ]

    admin_forms_fields::AddButton

    AddButton( array $param );

    Описание

    Вставка кнопки в форму

    Принимаемые параметры

    $param

    массив параметров

    • $param['name']
    • $param['caption']
    • $param['image']
    • $param['type']

    Возвращает

    индекс вставленной кнопки

    [ Наверх ]

    admin_forms_fields::AddExternalHtml

    AddExternalHtml( str $external_html );

    Описание

    Добавить внешний HTML для формы

    Принимаемые параметры

    $external_html

    код

    [ Наверх ]

    admin_forms_fields::AddField

    AddField( array $param );

    Описание

    Добавление элемента на форму.

    Принимаемые параметры

    $param

    массив параметров

    • int $param['tab_id'] идентификатор закладки
    • int $param['type'] тип поля:
    • 0 - Поле ввода (input).
    • 1 - Флажок (checkbox).
    • 2 - Выпадающий список (select).
    • 3 - Зарезервировано для разделителя.
    • 4 - Скрытое поле.
    • 5 - Большое текстовое поле (textarea).
    • 6 - Пароль.
    • 7 - Визуальный редактор.
    • 8 - Текст.
    • 9 - Поле загрузки файла.
    • 10 - Дата.
    • 11 - Дата-время.
    • 12 - Оценка-радиогруппа со звездочками.
    • 13 - Радиогруппа.
    • 14 - Компонент импорта из CSV-файла.
    • 15 - Как есть. Используется при необходимости добавить в форму HTML-код.
    • string $param['caption'] тестовое название поля
    • string $param['name'] name-элемента
    • string $param['lable'] пояснение для checkbox
    • string $param['html_id'] id-элемента
    • array $param['items'] массив элементов по форме:
      $param['items'][1] = 'Значение 1';
      $param['items'][2] = 'Значение 2';
    • bool $param['apply_filter'] выводить для поля типа "Выпадающий список" поля фильтра, по умолчанию false
    • array $param['attributes'] дополнительные атрибуты поля, например $param['attributes']['class'] = 'large';
    • string $params['separator'] разделитель для радиогрупп, по умолчанию используется тег br
    • array $param['options'] - дополнительные параметры формы:
    • - $param['options']['make_small_image_from_big_show'] - отображать ли checkbox с подписью "Создать малое изображение из большого" (1 - отображать (по умолчанию), 0 - не отображать);
    • - $param['options']['make_small_image_from_big_checked'] - вид ображения checkbox'а с подписью "Создать малое изображение из большого" выбранным (1 - отображать выбранным (по умолчанию), 0 - невыбранным);
    • - $param['options']['load_small_image_show'] - отображать ли поле загрузки малого изображения (1 - отображать (по умолчанию), 0 - не отображать);
    • - $param['options']['image_big_max_width'] - значение максимальной ширины большого изображения;
    • - $param['options']['image_big_max_height'] - значение максимальной высоты большого изображения;
    • - $param['options']['image_small_max_width'] - значение максимальной ширины малого изображения;
    • - $param['options']['image_small_max_height'] - значение максимальной высоты малого изображения;
    • - $param['options']['used_watermark_big_image_show'] - отображать ли checkbox с подписью "Наложить водяной знак на большое изображение" (1 - отображать (по умолчанию), 0 - не отображать);
    • - $param['options']['used_watermark_big_image_checked'] - вид ображения checkbox'а с подписью "Наложить водяной знак на большое изображение" (1 - отображать выбранным (по умолчанию), 0 - невыбранным);
    • - $param['options']['watermark_position_x'] - значение поля ввода с подписью "По оси X"
    • - $param['options']['watermark_position_y'] - значение поля ввода с подписью "По оси Y"
    • - $param['options']['used_big_image_preserve_aspect_ratio'] - отображать ли checkbox с подписью "Сохранять пропорции изображения" (1 - отображать (по умолчанию), 0 - не отображать);
    • - $param['options']['used_big_image_preserve_aspect_ratio_checked'] - вид ображения checkbox'а с подписью "Сохранять пропорции изображения" (1 - отображать выбранным (по умолчанию), 0 - невыбранным);
    • - $param['options']['used_watermark_small_image_show'] - отображать ли checkbox с подписью "Наложить водяной знак на малое изображение" (1 - отображать (по умолчанию), 0 - не отображать);
    • - $param['options']['used_watermark_small_image_checked'] - вид ображения checkbox'а с подписью "Наложить водяной знак на малое изображение" (1 - отображать выбранным (по умолчанию), 0 - невыбранным);
    • - $param['options']['big_image_path'] - адрес большого загруженного изображения
    • - $param['options']['small_image_path'] - адрес малого загруженного изображения
    • - $param['options']['show_big_image_params'] - параметр, определяющий отображать ли настройки большого изображения
    • - $param['options']['show_small_image_params'] - параметр, определяющий отображать ли настройки малого изображения
    • - $param['options']['used_small_image_preserve_aspect_ratio'] - отображать ли checkbox с подписью "Сохранять пропорции малого изображения" (1 - отображать (по умолчанию), 0 - не отображать);
    • - $param['options']['used_small_image_preserve_aspect_ratio_checked'] - вид ображения checkbox'а с подписью "Сохранять пропорции малого изображения" (1 - отображать выбранным (по умолчанию), 0 - невыбранным);
    • - $param['options']['onclick_delete_big_image'] - значение onclick для удаления большой картинки
    • - $param['options']['href_delete_big_image'] - значение href для удаления большой картинки
    • - $param['options']['onclick_delete_small_image'] - значение onclick для удаления малой картинки
    • - $param['options']['href_delete_small_image'] - значение href для удаления малой картинки
    • - $field['format']['minlen']['value'] минимальная длина содержимого поля
    • - $field['format']['minlen']['message'] сообщение о несоответствии длины. Необязательное поле.
    • - $field['format']['maxlen']['value'] максимальная длина содержимого поля
    • - $field['format']['maxlen']['message'] сообщение о несоответствии длины. Необязательное поле.
    • - $field['format']['reg']['value'] регулярное выражение для контроля содержимого поля
    • - $field['format']['reg']['message'] сообщение о несоответствии длины.
    • - $field['format']['fieldEquality']['value'] идентификатор поля в DOM-модели, которому должно соответствовать это поле.
    • - $param['format']['fieldEquality']['message'] сообщение о несоответствии поля.
    • - $field['format']['lib']['value'] название типового шаблона контроля содержимого поля
    • int $param['template'] идентификатор макета (используется в визуальном редакторе)
    • array $param['div_attributes'] - дополнительные атрибуты div-а, в который вложено поле с заголовом, например $param['div_attributes']['style'] = 'float: left;';
    • mixed $param['value'] значение поля

    Возвращает

    индекс добавленного поля

    [ Наверх ]

    admin_forms_fields::AddMenu

    AddMenu( [array $menu = array()] );

    Описание

    Добавление верхнего меню

    Принимаемые параметры

    $menu

    массив с элементами меню

    Возвращает

    индекс добавленного меню

    [ Наверх ]

    admin_forms_fields::AddSeparator

    AddSeparator( $tab_id );

    Описание

    Вставка разделителя

    Принимаемые параметры

    $tab_id

    [ Наверх ]

    admin_forms_fields::AddTab

    AddTab( string $tab_caption, [ $tab_id = false] );

    Описание

    Вставка новой закладки

    Принимаемые параметры

    $tab_caption

    название закладки

    • string $param['name'] название закладки

    $tab_id

    Возвращает

    int индекс закладки

    [ Наверх ]

    admin_forms_fields::CopyAdminFormEvent

    CopyAdminFormEvent( int $admin_form_event_id );

    Описание

    Копирование события формы центра администрирования

    Принимаемые параметры

    $admin_form_event_id

    идентификатор события формы центра администрирования

    Возвращает

    идентификатор копии события формы центра администрирования в случае успешного выполнения, false - в противном случае

    1.  <?php
      2.

    2.  $admin_forms_fields = new admin_forms_fields();
      3.

    3.
      4.

    4.  $admin_form_event_id = 399;
      5.

    5.
      6.

    6.  $newid = $admin_forms_fields->CopyAdminFormEvent($admin_form_event_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms_fields::CopyAdminFormField

    CopyAdminFormField( int $admin_form_field_id );

    Описание

    Копирование поля формы центра администрирования

    Принимаемые параметры

    $admin_form_field_id

    идентификатор поля формы центра администрирования

    Возвращает

    идентификатор копии поля формы центра администрирования в случае успешного выполнения, false - в противном случае

    1.  <?php
      2.

    2.  $admin_forms_fields = new admin_forms_fields();
      3.

    3.
      4.

    4.  $admin_form_field_id = 683;
      5.

    5.
      6.

    6.  $newid = $admin_forms_fields->CopyAdminFormField($admin_form_field_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    admin_forms_fields::CreateOptions

    CreateOptions( $aOptions $aOptions, $sCurrentValue $sCurrentValue );

    Описание

    Создание тегов <option> для каждого элемента ассоциативного массива

    Принимаемые параметры

    $aOptions

    массив значений

    $sCurrentValue

    текущее значение

    [ Наверх ]

    admin_forms_fields::GetExternalHtml

    GetExternalHtml( );

    Описание

    Получить установленный внешний HTML для формы

    [ Наверх ]

    admin_forms_fields::SetExternalHtml

    SetExternalHtml( str $external_html );

    Описание

    Установить внешний HTML для формы

    Принимаемые параметры

    $external_html

    код

    [ Наверх ]

    admin_forms_fields::ShowForm

    ShowForm( [ $admin_forms_id = 0], [ $operation = false] );

    Overrides admin_forms::ShowForm() (Обрабатывает действия формы, вызывает построение формы)

    Описание

    Отображение формы центра администрирования

    Принимаемые параметры

    $admin_forms_id

    $operation

    [ Наверх ]

Описания переменных

  • $buttons = array() [Строка 18]
  • Data type: mixed

  • $external_html =  '' [Строка 28]
  • Data type: string

    • Описание

    Свойство, содержащее html-код, дописываемый после отображения формы

  • $fields = array() [Строка 17]
  • Data type: mixed

  • $form_params = array() [Строка 39]
  • Data type: array Overrides: Array

    • Описание

    Свойство с параметрами формы

    var

    - массив хлебных крошек, передается по форме
    [x]['name'] - название ссылки
    [x]['link'] - адрес ссылки

    • $form_params['path_separator'] - разделитель для хлебных крошек

  • $menus = array() [Строка 19]
  • Data type: mixed

  • $SelectFilterCount =  0 [Строка 21]
  • Data type: mixed

  • $tabs = array() [Строка 16]
  • Data type: mixed

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Advertisement

Class Advertisement

[Строка 22]

Размещен: /Advertisement/Advertisement.class.php

Описание

Класс модуля "Реклама"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed AddBanner()

    Добавление/редактирование баннера

  • boolean ClearAdvertisementList()

    Очищение списка показов, произошедших $count_days назад

  • mixed CopyAdvertisement()

    Копирование баннера

  • void CopyBannersAndBannersGroupsFromSiteToSite()

    Копирование всех групп баннеров и баннеров, а также их связей с одного сайта на другой

  • идентификатор CopyContextualWords()

    Копирование информации о контекстной фразе

  • mixed CopyGroupAdvertisement()

    Копирование группы баннеров

  • boolean DelBannerGroup()

    Исключение баннера из группы

  • boolean DelBannersGroup()

    Удаление группы баннеров

  • boolean DeleteAdvertisementFile()

    Удаление загруженного файл для элемента

  • boolean DeleteAdvertisementSwfFile()

    Удаление загруженного swf-файл для элемента

  • boolean DeleteBanner()

    Удаление баннера

  • resourse DeleteContextualWords()

    Удаление информации о контекстной фразе

  • mixed GetAdvertisement()

    Получение данных об элементе (баннере, всплывающем окне и т.п.)

  • mixed GetAllAdvertisementForSite()

    Получаем список всех групп баннеров заданного сайта

  • mixed GetAllBanners()

    Получение информации обо всех баннерах сайта или обо всех баннерах

  • resource GetAllContextualWords()

    Получение информации о контекстных фразах для баннера

  • mixed GetContextualWords()

    Получение информации о контекстной фразе

  • int GetCountShowingBanner()

    Получение количества показов баннера

  • int GetCountShowingBannerAtDay()

    Получение количества показов баннера за конкретный день

  • int GetTextConformityCoefficient()

    Получение коэффициента схожести текста

  • mixed InsertBanners()

    Добавление баннера в группу/редактирование приоритета показа баннера в группе

  • mixed InsertBannersGroup()

    Добавление/редактирование информации о группе баннеров

  • mixed InsertContextualWords()

    Добавление/обновление информации о контекстной фразе

  • mixed SelectBanner()

    Определение баннера, доступного для показа

  • resource SelectBannersFromGroup()

    Получение информации о баннерах группы

  • resource SelectBannersGroup()

    Получение информации о конкретной группе баннеров или обо всех группах баннеров

  • boolean ShowAdvertisement()

    Показ баннера с использованием XML

  • boolean ShowAdvertisementGroup()

    Показ баннера из указанной группы в соответствии с приоритетом. Для вывода баннера используется XSL-шаблон.

  • boolean ShowBanner()

    Показ баннера

  • boolean ShowBannerGroup()

    Показ баннера из указанной группы в соответствии с приоритетом

  • string ShowBannerIsTrue()

    Переход по ссылке баннера и наращивание счётчика, если с этого показа мы ещё не переходили

Унаследованные методы

Описания методов

    Advertisement::AddBanner

AddBanner(
array
$param );

    Описание

    Добавление/редактирование баннера

    Принимаемые параметры

    $param

    массив пареметров
    • $param['advertisement_id'] идентификатор баннера
    • $param['advertisement_name'] название баннера
    • $param['advertisement_comment'] описание баннера
    • $param['advertisement_width'] ширина баннера
    • $param['advertisement_height'] высота баннера
    • $param['advertisement_allcount'] сколько раз показать
    • $param['advertisement_allcount_at_day'] сколько раз показывать в день
    • $param['advertisement_type'] тип баннера
    • $param['advertisement_image_path'] $_FILES
    • $param['advertisement_swf_path'] $_FILES
    • $param['advertisement_image_link'] ссылка с баннера
    • $param['advertisement_text'] текст баннера
    • $param['structure_id'] идентификатор элемента структуры
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • $param['advertisement_date_from'] дата начала действия опроса
    • $param['advertisement_date_to'] дата окончания действия опроса
    • $param['location_structure_id'] идентификатор узла структуры, на
     странице или дочених страницах которого будет отображаться баннер. По  умолчанию равен 0 - баннер отображается на всех страницах сайта

    Возвращает

    идентификатор добавленного/измененного баннера в случае успешного выполнения, false - в противном случае
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $param['advertisement_name'] = 'Баннер1';
      5.

    5.  $param['advertisement_comment'] = '';
      6.

    6.  $param['advertisement_width'] = '';
      7.

    7.  $param['advertisement_height'] = '';
      8.

    8.  $param['advertisement_allcount'] = 1;
      9.

    9.  $param['advertisement_allcount_at_day'] = 1;
      10.

    10.  $param['advertisement_type'] = 1;
      11.

    11.
      12.

    12.  $newid = $Advertisement->AddBanner($param);
      13.

    13.
      14.

    14.  // Распечатаем результат
      15.

    15.  echo $newid;
      16.

    16.  ?>
      17.

    [ Наверх ]

    Advertisement::ClearAdvertisementList

ClearAdvertisementList(
[
$count_days = 1], int
$count_days=1 );

    Описание

    Очищение списка показов, произошедших $count_days назад

    Принимаемые параметры

    $count_days=1

    количество дней хранения списка показов. Необязательный параметр, по умолчанию имеет значение 1.

    $count_days

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $count_days = 1;
      5.

    5.
      6.

    6.  $result = $Advertisement->ClearAdvertisementList($count_days);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Список показов очищен";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка выполнения очистки";
      15.

    15.  }
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  echo $result;
      19.

    19.  ?>
      20.

    [ Наверх ]

    Advertisement::CopyAdvertisement

CopyAdvertisement(
int
$advertisement_id, [
$new_site_id = false] );

    Описание

    Копирование баннера

    Принимаемые параметры

    $advertisement_id

    Идентификатор баннера, который необходимо копировать

    $new_site_id

    Возвращает

    Идентификатор скопированного баннера или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 1;
      5.

    5.
      6.

    6.  $newid = $Advertisement->CopyGroupAdvertisement($advertisement_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::CopyBannersAndBannersGroupsFromSiteToSite

CopyBannersAndBannersGroupsFromSiteToSite(
int
$site_id, int
$new_site_id );

    Описание

    Копирование всех групп баннеров и баннеров, а также их связей с одного сайта на другой

    Принимаемые параметры

    $site_id

    идентификатор сайта, с которого нужно скопировать данные

    $new_site_id

    идентификатор сайта на который нужно скопировать данные

    [ Наверх ]

    Advertisement::CopyContextualWords

CopyContextualWords(
int
$advertisement_contextual_words_id, [array
$param = array()] );

    Описание

    Копирование информации о контекстной фразе

    Принимаемые параметры

    $advertisement_contextual_words_id

    Идентификатор контекстной фразы, информацию о которой необходимо скопировать

    $param

    Массив дополнительных параметров
    • int $param['advertisement_id'] - Идентификатор баннера, в соответствие которому нужно поставить скопированную контекстную фразу (не обязательный параметр.)
    • bool $param['add_copy_info'] Флаг, указывающий, нужно ли добавлять к значению контекстной фразы слово "Копия" (не обязательный параметр. по умолчанию - true)

    Возвращает

    новой записи или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_contextual_words_id = 1;
      5.

    5.
      6.

    6.  $newid = $Advertisement->CopyContextualWords($advertisement_contextual_words_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::CopyGroupAdvertisement

CopyGroupAdvertisement(
int
$advertisement_group_id, [int
$new_site_id = false], [bool
$copy_with_association = false] );

    Описание

    Копирование группы баннеров

    Принимаемые параметры

    $advertisement_group_id

    Идентификатор группы, которую необходимо копировать

    $new_site_id

    Идентификатор сайта, на который следует перенести скопированную группу, если не передан, берется текущий сайт

    $copy_with_association

    Флаг, указывающий, копировать ли ассоциации баннеров вместе с группами

    Возвращает

    Идентификатор скопированной группы или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 3;
      5.

    5.
      6.

    6.  $newid = $Advertisement->CopyGroupAdvertisement($advertisement_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::DelBannerGroup

DelBannerGroup(
int
$advertisement_group_id, int
$advertisement_id );

    Описание

    Исключение баннера из группы

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $advertisement_id

    идентификатор баннера

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 3;
      5.

    5.  $advertisement_id = 4;
      6.

    6.
      7.

    7.  $result = $Advertisement->DelBannerGroup($advertisement_group_id, $advertisement_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo 'Баннер исключен из группы';
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo 'Ошибка';
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    Advertisement::DelBannersGroup

DelBannersGroup(
int
$advertisement_group_id );

    Описание

    Удаление группы баннеров

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 1;
      5.

    5.
      6.

    6.  $result = $Advertisement->DelBannersGroup($advertisement_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Advertisement::DeleteAdvertisementFile

DeleteAdvertisementFile(
int
$advertisement_id );

    Описание

    Удаление загруженного файл для элемента

    Принимаемые параметры

    $advertisement_id

    идентификатор элемента

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 4;
      5.

    5.
      6.

    6.  $result = $Advertisement->DeleteAdvertisementFile($advertisement_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Advertisement::DeleteAdvertisementSwfFile

DeleteAdvertisementSwfFile(
int
$advertisement_id );

    Описание

    Удаление загруженного swf-файл для элемента

    Принимаемые параметры

    $advertisement_id

    идентификатор элемента

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 4;
      5.

    5.
      6.

    6.  $result = $Advertisement->DeleteAdvertisementSwfFile($advertisement_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Advertisement::DeleteBanner

DeleteBanner(
int
$advertisement_id );

    Описание

    Удаление баннера

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 5;
      5.

    5.
      6.

    6.  $result = $Advertisement->DeleteBanner($advertisement_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.   if ($result)
      10.

    10.  {
      11.

    11.      echo 'Баннер удален';
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo 'Ошибка удаления баннера';
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    Advertisement::DeleteContextualWords

DeleteContextualWords(
int
$advertisement_contextual_words_id );

    Описание

    Удаление информации о контекстной фразе

    Принимаемые параметры

    $advertisement_contextual_words_id

    Идентификатор удаляемой фразы

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_contextual_words_id = 1;
      5.

    5.
      6.

    6.  $resource = $Advertisement->DeleteContextualWords($advertisement_contextual_words_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $resource;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::GetAdvertisement

GetAdvertisement(
int
$advertisement_id );

    Описание

    Получение данных об элементе (баннере, всплывающем окне и т.п.)

    Принимаемые параметры

    $advertisement_id

    идентификатор

    Возвращает

    массив с данными или false, если элемент с указанным идентификатором не найден
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 4;
      5.

    5.
      6.

    6.  $row = $Advertisement->GetAdvertisement($advertisement_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::GetAllAdvertisementForSite

GetAllAdvertisementForSite(
int
$site_id );

    Описание

    Получаем список всех групп баннеров заданного сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    resource, либо False

    [ Наверх ]

    Advertisement::GetAllBanners

GetAllBanners(
[int
$site_id = false] );

    Описание

    Получение информации обо всех баннерах сайта или обо всех баннерах

    Принимаемые параметры

    $site_id

    Идентификатор сайта

    Возвращает

    resource или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $resource = $Advertisement->GetAllBanners($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    Advertisement::GetAllContextualWords

GetAllContextualWords(
[int
$advertisement_id = false] );

    Описание

    Получение информации о контекстных фразах для баннера

    Принимаемые параметры

    $advertisement_id

    Идентификатор баннера

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 1;
      5.

    5.
      6.

    6.  $resource = $Advertisement->GetAllContextualWords($advertisement_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    Advertisement::GetContextualWords

GetContextualWords(
int
$advertisement_contextual_words_id );

    Описание

    Получение информации о контекстной фразе

    Принимаемые параметры

    $advertisement_contextual_words_id

    Идентификатор контекстной фразы

    Возвращает

    массив с информацией о контекcтной фразе или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_contextual_words_id = 1;
      5.

    5.
      6.

    6.  $row = $Advertisement->GetContextualWords($advertisement_contextual_words_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::GetCountShowingBanner

GetCountShowingBanner(
int
$advertisement_id );

    Описание

    Получение количества показов баннера

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    Возвращает

    количество показов или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 1;
      5.

    5.
      6.

    6.  $result = $Advertisement->GetCountShowingBanner($advertisement_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Advertisement::GetCountShowingBannerAtDay

GetCountShowingBannerAtDay(
string
$date, int
$advertisement_id );

    Описание

    Получение количества показов баннера за конкретный день

    Принимаемые параметры

    $date

    дата

    $advertisement_id

    идентификатор баннера

    Возвращает

    количество показов или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $date = date('Y-m-d H:i:s');
      5.

    5.  $advertisement_id = 1;
      6.

    6.
      7.

    7.  $result = $Advertisement->GetCountShowingBannerAtDay($date, $advertisement_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Advertisement::GetTextConformityCoefficient

GetTextConformityCoefficient(
array
$mas1, array
$mas2, int
$count1, int
$count2, [string
$method = 'max'] );

    Описание

    Получение коэффициента схожести текста

    Принимаемые параметры

    $mas1

    массив слов первого текста

    $mas2

    массив слов второго текста

    $count1

    количество элементов в первом тексте

    $count2

    количество элементов во втором тексте

    $method

    метод расчета схожести - min или max, по умолчанию 'max'. Необязательный параметр

    [ Наверх ]

    Advertisement::InsertBanners

InsertBanners(
int
$advertisement_group_id, int
$advertisement_id, int
$banner_value );

    Описание

    Добавление баннера в группу/редактирование приоритета показа баннера в группе

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $advertisement_id

    идентификатор баннера

    $banner_value

    значение приоретета показа

    Возвращает

    идентификатор добавленного/измененного баннера или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 3;
      5.

    5.  $advertisement_id = 5;
      6.

    6.  $banner_value = 1;
      7.

    7.
      8.

    8.  $advertisement_id = $Advertisement->InsertBanners($advertisement_group_id, $advertisement_id, $banner_value);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $advertisement_id;
      12.

    12.  ?>
      13.

    [ Наверх ]

    Advertisement::InsertBannersGroup

InsertBannersGroup(
int
$advertisement_group_id, string
$advertisement_group_name, string
$advertisement_group_comment, [int
$users_id = false], [int
$site_id = false] );

    Описание

    Добавление/редактирование информации о группе баннеров

    Принимаемые параметры

    $advertisement_group_id

    идентификатор  группы баннеров

    $advertisement_group_name

    имя группы баннеров

    $advertisement_group_comment

    комментарий к группе баннеров

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь

    $site_id

    идентификатор сайта, если false - берется текущий сайт

    Возвращает

    идентификатор успешно добавленной/редактированной группы или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 0;
      5.

    5.  $advertisement_group_name = 'Группа баннеров';
      6.

    6.  $advertisement_group_comment = '';
      7.

    7.
      8.

    8.  $newid = $Advertisement->InsertBannersGroup($advertisement_group_id, $advertisement_group_name, $advertisement_group_comment);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    [ Наверх ]

    Advertisement::InsertContextualWords

InsertContextualWords(
array
$param );

    Описание

    Добавление/обновление информации о контекстной фразе

    Принимаемые параметры

    $param

    Массив значений
    • int $param['advertisement_contextual_words_id'] Идентификатор обновляемой контекстной фразы
    • int $param['users_id'] Идентификатор пользователя центра администрирования
    • int $param['advertisement_id'] Идентификатор баннера
    • str $param['advertisement_contextual_words_value'] Контекстная фраза

    Возвращает

    Идентификатор обновленной/добавленной записи или false
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $param['advertisement_contextual_words_id'] = 0;
      5.

    5.  $param['users_id'] = CURRENT_SITE;
      6.

    6.  $param['advertisement_id'] = 1;
      7.

    7.  $param['advertisement_contextual_words_value'] = 'Контекстная фраза2';
      8.

    8.
      9.

    9.  $newid = $Advertisement->InsertContextualWords($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    [ Наверх ]

    Advertisement::SelectBanner

SelectBanner(
int
$advertisement_group_id, [array
$param = array()] );

    Описание

    Определение баннера, доступного для показа

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $param

    массив дополнительных параметров
    • $param['contextual_words'] строка, содержащая контекстную информацию, на основании которой будет показан баннер. Это может быть поисковый запрос, по которому пришел пользователь или содержимое страницы. Если строка не передана - используется случайный выбор баннеров из группы.
    • $param['show_only_context'] по умолчанию false, разрешает показ только баннеров, найденых по переданному контексту
    • $param['show_banner_type'] строка с типом отображаемых баннеров. Может принимать значение

      'ALL' для показа баннеров из списка баннеров группы (по умолчанию)

      'TYPE' для показа только контекстных баннеров при переданном контексте и неконтекстных баннеров, если контекст не передан

    Возвращает

    идентификатор баннера, доступного к показу или false

    [ Наверх ]

    Advertisement::SelectBannersFromGroup

SelectBannersFromGroup(
$advertisement_group_id
$advertisement_group_id );

    Описание

    Получение информации о баннерах группы

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    Возвращает

    результат выполнения запроса на выборку
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 1;
      5.

    5.
      6.

    6.  $resource = $Advertisement->SelectBannersFromGroup($advertisement_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    Advertisement::SelectBannersGroup

SelectBannersGroup(
int
$advertisement_group_id, [int
$site_id = false] );

    Описание

    Получение информации о конкретной группе баннеров или обо всех группах баннеров

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров (-1 или false - выбрать все)

    $site_id

    идентификатор сайта, если не передан - используется текущий сайт

    Возвращает

    результат выполнения запроса на выборку
    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_group_id = 1;
      5.

    5.
      6.

    6.  $resource = $Advertisement->SelectBannersGroup($advertisement_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  $row = mysql_fetch_assoc($resource))
      10.

    10.
      11.

    11.  print_r($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

    Advertisement::ShowAdvertisement

ShowAdvertisement(
int
$advertisement_id, string
$xsl_name );

    Описание

    Показ баннера с использованием XML

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    $xsl_name

    имя XSL-шаблона

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 1;
      5.

    5.  $xsl_name = 'ОтображениеБаннера';
      6.

    6.
      7.

    7.  $Advertisement->ShowAdvertisement($advertisement_id, $xsl_name);
      8.

    8.  ?>
      9.

    [ Наверх ]

    Advertisement::ShowAdvertisementGroup

ShowAdvertisementGroup(
int
$advertisement_group_id, string
$xsl_name, [array
$param = array()] );

    Описание

    Показ баннера из указанной группы в соответствии с приоритетом. Для вывода баннера используется XSL-шаблон.

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $xsl_name

    имя XSL-шаблона

    $param

    массив дополнительных параметров
    • $param['contextual_words'] строка, содержащая контекстную информацию, на основании которой будет показан баннер. Это может быть поисковый запрос, по которому пришел пользователь или содержимое страницы. Если строка не передана - используется случайный выбор баннеров из группы.
    • $param['show_only_context'] по умолчанию false, разрешает показ только баннеров, найденых по переданному контексту

    see

    ShowBannerGroup()
 <code>
 <?php
 $Advertisement = new Advertisement();

 $advertisement_group_id = 3;
 $xsl_name = 'ОтображениеБаннера';

 $Advertisement->ShowAdvertisementGroup($advertisement_group_id, $xsl_name);
 ?>
 </code>

 <br />Пример контекстного показа баннера в зависимости от текста страницы.
 Остальные примеры см. в руководстве по интеграции.
 <code>
 <?php

 ob_start();

 // здесь показ контента, в зависимости от которого необходимо выводить баннер

 // Записываем текст в параметр и выводим в поток
 $param['contextual_words'] = ob_get_clean();
 $param['show_only_context'] = true;

 $Advertisement = new Advertisement();

 $advertisement_group_id = 3;
 $xsl_name = 'ОтображениеБаннера';

 $Advertisement->ShowAdvertisementGroup($advertisement_group_id, $xsl_name, $param);
 ?>
 </code>

    [ Наверх ]

    Advertisement::ShowBanner

ShowBanner(
int
$advertisement_id, [int
$count_days = 1] );

    Описание

    Показ баннера

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    $count_days

    количество дней хранения списка показов. Необязательный параметр, по умолчанию имеет значение 1

    Возвращает

    1.  <?php
      2.

    2.  $Advertisement = new Advertisement();
      3.

    3.
      4.

    4.  $advertisement_id = 1;
      5.

    5.
      6.

    6.  $result = $Advertisement->ShowBanner($advertisement_id);
      7.

    7.
      8.

    8.  ?>
      9.

    [ Наверх ]

    Advertisement::ShowBannerGroup

ShowBannerGroup(
int
$advertisement_group_id, [array
$param = array()] );

    Описание

    Показ баннера из указанной группы в соответствии с приоритетом

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $param

    массив дополнительных параметров
    • $param['contextual_words'] строка, содержащая контекстную информацию, на основании которой будет показан баннер. Это может быть поисковый запрос, по которому пришел пользователь или содержимое страницы. Если строка не передана - используется случайный выбор баннеров из группы.
    • $param['show_only_context'] по умолчанию false, разрешает показ только баннеров, найденых по переданному контексту
    • $param['show_banner_type'] строка с типом отображаемых баннеров. Может принимать значение

      'ALL' для показа баннеров из списка баннеров группы (по умолчанию)

      'TYPE' для показа только контекстных баннеров при переданном контексте и неконтекстных баннеров, если контекст не передан

    see

    ShowAdvertisementGroup()
 <code>
 <?php
 $Advertisement = new Advertisement();

 $advertisement_group_id = 3;

 $Advertisement->ShowBannerGroup($advertisement_group_id);
 ?>
 </code>

    [ Наверх ]

    Advertisement::ShowBannerIsTrue

ShowBannerIsTrue(
int
$list_id, [int
$count_days = 1] );

    Описание

    Переход по ссылке баннера и наращивание счётчика, если с этого показа мы ещё не переходили

    Принимаемые параметры

    $list_id

    идентификатор записи показа

    $count_days

    количество дней хранения списка показов. Необязательный параметр, по умолчанию имеет значение 1

    Возвращает

    ссылка с баннера или false

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class affiliate

Class affiliate

[Строка 14]

Размещен: /shop/affiliate.class.php

Описание

Система управления сайтом HostCMS v. 5.xx  Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru

Класс модуля "Аффилиаты".
Файл: /modules/affiliate/affiliate.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AcceptAffiliatePlanForSiteUsers()

    Начисление пользователю сумм с заказа по партнеской программе

  • void AcceptAffiliatePlanToShop()

    Добавление/удаление ассоциации партнерской программы магазину

  • mixed CheckSiteUserAffiliate()

    Проеверка участия пользователя сайта в аффилиат программе в качестве привлеченного пользователя

  • resource DeleteAffiliate()

    Удаление информации об аффилиате

  • resource DeleteAffiliatePlans()

    Удаление информации о плане аффилиата

  • resource DeleteAffiliateValues()

    Удаление информации о комиссии

  • void DisableAffiliatePlanToShop()

    Удаление ассоциации партнерской программы магазину

  • void EnableAffiliatePlanToShop()

    Добавление ассоциации партнерской программы магазину

  • str GenXML4AffiliatePlan()

    Генерация XML-данных для партнерских программ магазина

  • str GenXML4AffiliateValues()

    Генерация XML для уровней партнерской программы

  • void GenXmlAffiliatTree()

  • mixed GetAffiliate()

    Получение информации об аффилиате

  • mixed GetAffiliatePlans()

    Получение информации о плане аффилиата

  • arr GetAffiliatePlansIdForShop()

    Получение идентификаторов всех парнерских программ для магазина

  • mixed GetAffiliateValues()

    Получение информации о комисии

  • void getAffiliatInnerLevelForUser()

  • array GetAffiliatsForUser()

    Получение массива идентификаторов аффилиатов пользователя

  • mixed GetAllAffiliatePlans()

    Получение всех партнерских программ

  • mixed GetAllAffiliateValuesForAffiliate()

    Получение всех уровней партнерской программы

  • unknown GetAllUsersForAffiliate()

    Получение всех пользователей, привлеченных определенным аффилиатом

  • arr GetShopsIdForAffiliatePlans()

    Получение идентификаторов всех магазинов, в которых доступна парнерская программа

  • void getUsersID()

    Метод формирования массива идентификаторов пользавателей сайта, участвующих в программе партнерских отношений.

  • mixed InsertAffiliate()

    Добавление информации об аффилиате

  • mixed InsertAffiliatePlans()

    Добавление информации о плане аффилиата

  • mixed InsertAffiliateValues()

    Добавление информации о комиссии

  • void ShowAffiliate()

    Показ партнерских программ.

  • void ShowAffiliatStatistics()

Унаследованные методы

Описания методов

    affiliate::AcceptAffiliatePlanForSiteUsers

AcceptAffiliatePlanForSiteUsers(
$site_users_id
$site_users_id, $shop_order_id
$shop_order_id );

    Описание

    Начисление пользователю сумм с заказа по партнеской программе

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта (реферала), который оформил заказ

    $shop_order_id

    идентификатор заказа

    [ Наверх ]

    affiliate::AcceptAffiliatePlanToShop

AcceptAffiliatePlanToShop(
int
$affiliate_plans_id, int
$shop_shops_id );

    Описание

    Добавление/удаление ассоциации партнерской программы магазину

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор партнерской программы

    $shop_shops_id

    идентификатор магазина

    [ Наверх ]

    affiliate::CheckSiteUserAffiliate

CheckSiteUserAffiliate(
int
$site_users_id, [int
$affiliate_site_users_id = false] );

    Описание

    Проеверка участия пользователя сайта в аффилиат программе в качестве привлеченного пользователя

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $affiliate_site_users_id

    идентификатор аффилиата

    Возвращает

    массив данных, либо False

    [ Наверх ]

    affiliate::DeleteAffiliate

DeleteAffiliate(
int
$affiliate_id );

    Описание

    Удаление информации об аффилиате

    Принимаемые параметры

    $affiliate_id

    идентификатор аффилиата

    [ Наверх ]

    affiliate::DeleteAffiliatePlans

DeleteAffiliatePlans(
int
$affiliate_plans_id );

    Описание

    Удаление информации о плане аффилиата

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор плана

    [ Наверх ]

    affiliate::DeleteAffiliateValues

DeleteAffiliateValues(
int
$affiliate_values_id );

    Описание

    Удаление информации о комиссии

    Принимаемые параметры

    $affiliate_values_id

    идентификатор комиссии

    [ Наверх ]

    affiliate::DisableAffiliatePlanToShop

DisableAffiliatePlanToShop(
int
$affiliate_plans_id, int
$shop_shops_id );

    Описание

    Удаление ассоциации партнерской программы магазину

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор партнерской программы

    $shop_shops_id

    идентификатор магазина

    [ Наверх ]

    affiliate::EnableAffiliatePlanToShop

EnableAffiliatePlanToShop(
int
$affiliate_plans_id, int
$shop_shops_id );

    Описание

    Добавление ассоциации партнерской программы магазину

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор партнерской программы

    $shop_shops_id

    идентификатор магазина

    [ Наверх ]

    affiliate::GenXML4AffiliatePlan

GenXML4AffiliatePlan(
int
$shop_shops_id, int
$site_user_id );

    Описание

    Генерация XML-данных для партнерских программ магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $site_user_id

    идентификатор пользователя сайта - аффилиата

    Возвращает

    XML данные

    [ Наверх ]

    affiliate::GenXML4AffiliateValues

GenXML4AffiliateValues(
int
$affiliate_plans_id );

    Описание

    Генерация XML для уровней партнерской программы

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор партнерской программы

    Возвращает

    XML-код

    [ Наверх ]

    affiliate::GenXmlAffiliatTree

GenXmlAffiliatTree(

$affiliate_site_users_id );

    Принимаемые параметры

    $affiliate_site_users_id

    [ Наверх ]

    affiliate::GetAffiliate

GetAffiliate(
int
$affiliate_id );

    Описание

    Получение информации об аффилиате

    Принимаемые параметры

    $affiliate_id

    идентификатор аффилиата

    Возвращает

    массив данных, либо False

    [ Наверх ]

    affiliate::GetAffiliatePlans

GetAffiliatePlans(
int
$affiliate_plans_id );

    Описание

    Получение информации о плане аффилиата

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор плана аффилиата

    Возвращает

    массив данных, либо False

    [ Наверх ]

    affiliate::GetAffiliatePlansIdForShop

GetAffiliatePlansIdForShop(
int
$shop_shops_id, int
$site_user_id, [arr
$param = array()] );

    Описание

    Получение идентификаторов всех парнерских программ для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $site_user_id

    идентификатор пользователя сайта - Аффилиата

    $param

    массив дополнительных параметров
    • array['affiliate_plans_min_num_of_items'] минимальное количество купленного товара
    • array['affiliate_plans_min_sum_of_items'] минимальная сумма, на которую куплен товар

    Возвращает

    массив идентификаторов партнерских программ

    [ Наверх ]

    affiliate::GetAffiliateValues

GetAffiliateValues(
int
$affiliate_values_id );

    Описание

    Получение информации о комисии

    Принимаемые параметры

    $affiliate_values_id

    идентификатор комиссии

    Возвращает

    массив данных, либо False

    [ Наверх ]

    affiliate::getAffiliatInnerLevelForUser

getAffiliatInnerLevelForUser(

$site_user_id,
$affiliat_users_id, [
$innerLevel = 0] );

    Принимаемые параметры

    $site_user_id

    $affiliat_users_id

    $innerLevel

    [ Наверх ]

    affiliate::GetAffiliatsForUser

GetAffiliatsForUser(
int
$site_users_id, [bool
$first_call = true], [
$overflow_protection = 0] );

    Описание

    Получение массива идентификаторов аффилиатов пользователя

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $first_call

    флаг первого вызова

    $overflow_protection

    Возвращает

    массив аффилиатов данного пользователя

    [ Наверх ]

    affiliate::GetAllAffiliatePlans

GetAllAffiliatePlans(
arr
$site_users_group_array, [int
$site_id = false] );

    Описание

    Получение всех партнерских программ

    Принимаемые параметры

    $site_users_group_array

    массив идентификаторов групп пользователей сайта

    $site_id

    идентификатор сайта (0 - выборка со всех сайтов)

    Возвращает

    Resource или False

    [ Наверх ]

    affiliate::GetAllAffiliateValuesForAffiliate

GetAllAffiliateValuesForAffiliate(
int
$affiliate_plans_id );

    Описание

    Получение всех уровней партнерской программы

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор партнерской программы

    Возвращает

    Resource или False

    [ Наверх ]

    affiliate::GetAllUsersForAffiliate

GetAllUsersForAffiliate(
unknown_type
$affiliate_site_users_id );

    Описание

    Получение всех пользователей, привлеченных определенным аффилиатом

    Принимаемые параметры

    $affiliate_site_users_id

    [ Наверх ]

    affiliate::GetShopsIdForAffiliatePlans

GetShopsIdForAffiliatePlans(
int
$affiliate_plans_id );

    Описание

    Получение идентификаторов всех магазинов, в которых доступна парнерская программа

    Принимаемые параметры

    $affiliate_plans_id

    идентификатор партнерской программы

    Возвращает

    массив идентификаторов магазинов

    [ Наверх ]

    affiliate::getUsersID

getUsersID(
point
&$users_id_array, bool
$current_site_user_id );

    Описание

    Метод формирования массива идентификаторов пользавателей сайта, участвующих в программе партнерских отношений.

    Принимаемые параметры

    $current_site_user_id

    идентификатор пользователя сайта, для которого требуется получить цепочку идентификаторов

    &$users_id_array

    arr $users_id_array указатель на массив, в который будут возвращены данные

    [ Наверх ]

    affiliate::InsertAffiliate

InsertAffiliate(
array
$param );

    Описание

    Добавление информации об аффилиате

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['affiliate_id'] идентификатор связи пользователя и аффилиата
    • int $param['site_users_id'] идентификатор пользователя, которого привел аффилиат
    • int $param['affiliate_plans_id'] идентификатор патрнерской программы
    • int $param['affiliate_site_users_id'] идентификатор аффилиата
    • int $param['affiliate_active'] флаг активности польщователя аффилиата
    • str $param['affiliate_invite_date'] дата приглашения аффилиата, если не передана, ставится текущая

    Возвращает

    Идентификатор вставленной записи, либо False

    [ Наверх ]

    affiliate::InsertAffiliatePlans

InsertAffiliatePlans(
array
$param );

    Описание

    Добавление информации о плане аффилиата

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['affiliate_plans_id'] идентификатор плана аффилиата
    • int $param['site_id'] идентификатор сайта
    • str $param['affiliate_plans_name'] название плана
    • str $param['affiliate_plans_description'] описание плана
    • int $param['affiliate_plans_activity'] статус активности
    • int $param['site_users_group_id'] идентификатор группы пользователей сайта
    • str $param['affiliate_plans_last_change_datetime'] дата последнего изменения плана
    • int $param['affiliate_plans_min_num_of_items'] минимальное количество товаров в заказе для активации плана
    • int $param['affiliate_plans_min_sum_of_items'] минимальное сумма единовременной покупки для активации плана
    • int $param['affiliate_plans_delivery_on'] флаг учета доставки при просчете комиссии

    Возвращает

    Идентификатор вставленной записи, либо False

    [ Наверх ]

    affiliate::InsertAffiliateValues

InsertAffiliateValues(
array
$param );

    Описание

    Добавление информации о комиссии

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['affiliate_values_id'] идентификатор комиссии
    • int $param['affiliate_plans_id'] идентификатор плана
    • int $param['affiliate_values_inner_level'] уровень вложенности
    • int $param['affiliate_values_percent'] комиссия в процентах
    • int $param['affiliate_values_value'] комиссия в одной из валют магазина
    • int $param['affiliate_values_type'] тип комиссии

    Возвращает

    Идентификатор вставленной записи, либо False

    [ Наверх ]

    affiliate::ShowAffiliate

ShowAffiliate(
int
$site_id, str
$xsl_name, [arr
$param = array()], [array
$external_propertys = array()] );

    Описание

    Показ партнерских программ.

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $xsl_name

    имя XSL-шаблона

    $param

    ассоциативный массив параметров
    • array['site_user_id'] идентификатор пользователя сайта

    $external_propertys

    массив дополнительных свойств для включения в исходный XML-код

    [ Наверх ]

    affiliate::ShowAffiliatStatistics

ShowAffiliatStatistics(

$site_user_id,
$xsl_name,
$date_from,
$date_to );

    Принимаемые параметры

    $site_user_id

    $xsl_name

    $date_from

    $date_to

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Backup

Class Backup

[Строка 23]

Размещен: /Backup/Backup.class.php

Описание

Класс модуля "Резервное копирование"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void CreateBackup()

    Создание резевной копии базы данных

Унаследованные методы

Описания методов

    Backup::CreateBackup

CreateBackup(
string
$backup_name, string
$userName, string
$password, string
$host, string
$db_name,
$table_number );

    Описание

    Создание резевной копии базы данных

    Принимаемые параметры

    $backup_name

    полный путь к файлу для резервной копии

    $userName

    имя пользователя БД

    $password

    пароль пользователя БД

    $host

    host БД

    $db_name

    имя базы данных

    $table_number

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Cache

Class Cache

[Строка 23]

Размещен: /Cache/Cache.class.php

Описание

Класс модуля "Кэш"

Свойства класса

  • $cache_dir_is_exist =  false

        Флаг наличия директории для сохранения файлов кэша

  • $cache_systems = array()

        Массив доступных способов кэширования

  • $default_cache_systems =  'file'

        Способ кэширования по умолчанию

  • $dividend =  100

        Максимальное значение, генерируемое для определения необходимости удаления истекших элементов кэша

  • $is_dir_array = array()

        Кэш существующих директорий

  • $probability =  1

        Вероятность удаления истекших элементов кэша

  • $read_lock =  false

        Блокировать ли файл кэша при чтении. по умолчанию false

  • $use_read_control =  true

        Использовать контроль данных с помощью crc32

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • Cache Cache()

    Конструктор

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • boolean CallProbability()

    Определяет необходимости удаления истекших элементов кэша

  • boolean ClearAllCache()

    Очистка всех кэшей (не очищая кэш статичных файлов)

  • boolean ClearCache()

    Очистка кэша

  • boolean ClearExpireItems()

    Удаление истекших элементов кэша

  • bool ClearStaticCache()

    Очистка кэша в статичных файлах

  • bool DeleteCacheItem()

    Метод удаляет элемент с именем $item_name из кэша $cache_name

  • void DisableModule()

    Служебный метод, вызываемый при отключении модуля.

  • boolean eacceleratorClearCache()

    Очистка кэша $cache_name и элемента $item_name в eAccelerator

  • int eacceleratorGetCountItem()

    Определение количества элементов в кэше для eaccelerator

  • boolean FileClearCache()

    Очистка кэша в файле

  • bool FileDeleteCacheItem()

    Метод удаляет элемент с именем $item_name из кэша $cache_name в файле

  • int FileGetCountItem()

    Определение количества элементов в кэше для файлов

  • mixed GetCacheContent()

    Получение данных из кэша

  • string GetCacheSystem()

    Определение системы кэширования для кэша

  • void GetChmod()

  • void GetChmodFile()

  • int GetCountItem()

    Определение количества элементов в кэше

  • string GetItemPath()

    Определение пути к элементу

  • bool Insert()

    Вставка значения в кэш

  • void is_dir()

    Проверяет наличие директории и в случае успеха сохраняет результат. Служебный метод.

  • boolean xcacheClearCache()

    Очистка кэша $cache_name и элемента $item_name в xcache

Унаследованные методы

Описания методов

    Cache::Cache

Cache(
 );

    Описание

    Конструктор

    [ Наверх ]

    Cache::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    Cache::CallProbability

CallProbability(
 );

    Описание

    Определяет необходимости удаления истекших элементов кэша

    [ Наверх ]

    Cache::ClearAllCache

ClearAllCache(
 );

    Описание

    Очистка всех кэшей (не очищая кэш статичных файлов)

    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  $result = $Cache->ClearAllCache();
      5.

    5.
      6.

    6.  if ($result)
      7.

    7.  {
      8.

    8.      echo "Очистка выполнена успешно";
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Ошибка очистки кэшей";
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    Cache::ClearCache

ClearCache(
string
$cache_name );

    Описание

    Очистка кэша

    Принимаемые параметры

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      5.

    5.  $cache_name = "TMP";
      6.

    6.
      7.

    7.  $result = $Cache->ClearCache($cache_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Cache::ClearExpireItems

ClearExpireItems(
string
$cache_name );

    Описание

    Удаление истекших элементов кэша

    Принимаемые параметры

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      5.

    5.  $cache_name = "TMP";
      6.

    6.
      7.

    7.  $result = $Cache->ClearExpireItems($cache_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Cache::ClearStaticCache

ClearStaticCache(
mixed
$site_id );

    Описание

    Очистка кэша в статичных файлах

    Принимаемые параметры

    $site_id

    идентифкатор сайта или false, если для всех сайтов
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $result = $Cache->ClearStaticCache($site_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Очистка выполнена успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка очистки кэша";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Cache::DeleteCacheItem

DeleteCacheItem(
string
$cache_name, string
$item_name );

    Описание

    Метод удаляет элемент с именем $item_name из кэша $cache_name

    Принимаемые параметры

    $cache_name

    название кэша

    $item_name

    название элемента в кэше
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Имя элемента, наиболее часто используется идентификатор или строка идентификаторов
      5.

    5.  $item_name = 'my_item_1';
      6.

    6.
      7.

    7.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      8.

    8.  $cache_name = "TMP";
      9.

    9.
      10.

    10.  $Cache->DeleteCacheItem($cache_name, $item_name);
      11.

    11.
      12.

    12.  if ($result)
      13.

    13.  {
      14.

    14.      echo "Удаление выполнена успешно";
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Ошибка удаления";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    Cache::DisableModule

DisableModule(
 );

    Описание

    Служебный метод, вызываемый при отключении модуля.

    Осуществляет очистку кэша.

    [ Наверх ]

    Cache::eacceleratorClearCache

eacceleratorClearCache(
[string
$cache_name = false], [string
$item_name = false] );

    Описание

    Очистка кэша $cache_name и элемента $item_name в eAccelerator

    Принимаемые параметры

    $cache_name

    имя кэша, если не передан - очищается полностью кэш

    $item_name

    имя элемента в кэше, если не передан - очищается элемент кэша $cache_name с именем $item_name

    [ Наверх ]

    Cache::eacceleratorGetCountItem

eacceleratorGetCountItem(
string
$cache_name );

    Описание

    Определение количества элементов в кэше для eaccelerator

    Принимаемые параметры

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      5.

    5.  $cache_name = "TMP";
      6.

    6.
      7.

    7.  $count_item = $Cache->eacceleratorGetCountItem($cache_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $count_item;
      11.

    11.  ?>
      12.

    Возвращает

    количество элементов в кэше

    [ Наверх ]

    Cache::FileClearCache

FileClearCache(
string
$cache_name );

    Описание

    Очистка кэша в файле

    Принимаемые параметры

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      5.

    5.  $cache_name = "TMP";
      6.

    6.
      7.

    7.  $result = $Cache->ClearCache($cache_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Cache::FileDeleteCacheItem

FileDeleteCacheItem(
string
$cache_name, string
$item_name );

    Описание

    Метод удаляет элемент с именем $item_name из кэша $cache_name в файле

    Принимаемые параметры

    $cache_name

    название кэша

    $item_name

    название элемента в кэше
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Имя элемента, наиболее часто используется идентификатор или строка идентификаторов
      5.

    5.  $item_name = 'my_item_1';
      6.

    6.
      7.

    7.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      8.

    8.  $cache_name = "TMP";
      9.

    9.
      10.

    10.  $Cache->FileDeleteCacheItem($cache_name, $item_name);
      11.

    11.
      12.

    12.  if ($result)
      13.

    13.  {
      14.

    14.      echo "Удаление выполнена успешно";
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Ошибка удаления";
      19.

    19.  }
      20.

    20.  ?>
      21.

    see

    Cache::DeleteCacheItem()

    [ Наверх ]

    Cache::FileGetCountItem

FileGetCountItem(
string
$cache_name );

    Описание

    Определение количества элементов в кэше для файлов

    Принимаемые параметры

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      5.

    5.  $cache_name = "TMP";
      6.

    6.
      7.

    7.  $count_item = $Cache->FileGetCountItem($cache_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $count_item;
      11.

    11.  ?>
      12.

    Возвращает

    количество элементов в кэше

    [ Наверх ]

    Cache::GetCacheContent

GetCacheContent(
string
$item_name, string
$cache_name, [int
$time = false] );

    Описание

    Получение данных из кэша

    Принимаемые параметры

    $item_name

    имя элемента

    $cache_name

    имя кэша

    $time

    время актуальности элемента кэша. по умолчанию false.  Если false - данные берутся из параметров кэша с именем $cache_name
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Имя элемента, наиболее часто используется идентификатор или строка идентификаторов
      5.

    5.  $item_name = 'my_item_1';
      6.

    6.
      7.

    7.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      8.

    8.  $cache_name = "TMP";
      9.

    9.
      10.

    10.  if ($in_cache = $Cache->GetCacheContent($item_name, $cache_name))
      11.

    11.  {
      12.

    12.      $value = $in_cache['value'];
      13.

    13.
      14.

    14.      // В $value содержится закэшированный элемент
      15.

    15.      echo $value;
      16.

    16.  }
      17.

    17.  else
      18.

    18.  {
      19.

    19.      echo "Элемент в кэше не найден!";
      20.

    20.  }
      21.

    21.  ?>
      22.

    Возвращает

    если элемент найден в кэше и актуален возвращает array ('value' => значение), если элемент не найден или не актуален возвращает false

    [ Наверх ]

    Cache::GetCacheSystem

GetCacheSystem(
$cache_name
$cache_name );

    Описание

    Определение системы кэширования для кэша

    Принимаемые параметры

    $cache_name

    имя кэша

    [ Наверх ]

    Cache::GetChmod

GetChmod(
 );

    [ Наверх ]

    Cache::GetChmodFile

GetChmodFile(
 );

    [ Наверх ]

    Cache::GetCountItem

GetCountItem(
string
$cache_name );

    Описание

    Определение количества элементов в кэше

    Принимаемые параметры

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      5.

    5.  $cache_name = "TMP";
      6.

    6.
      7.

    7.  $count_item = $Cache->GetCountItem($cache_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $count_item;
      11.

    11.  ?>
      12.

    Возвращает

    количество элементов в кэше

    [ Наверх ]

    Cache::GetItemPath

GetItemPath(
string
$cache_name, string
$item_name );

    Описание

    Определение пути к элементу

    Принимаемые параметры

    $cache_name

    название кэша

    $item_name

    название элемента в кэше
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Имя элемента, наиболее часто используется идентификатор или строка идентификаторов
      5.

    5.  $item_name = 'my_item_1';
      6.

    6.
      7.

    7.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      8.

    8.  $cache_name = "TMP";
      9.

    9.
      10.

    10.  $pathitem = $Cache->GetItemPath($cache_name, $item_name);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $pathitem;
      14.

    14.  ?>
      15.

    Возвращает

    путь

    [ Наверх ]

    Cache::Insert

Insert(
string
$item_name, string
$value, string
$cache_name );

    Описание

    Вставка значения в кэш

    Принимаемые параметры

    $item_name

    имя элемента в кэше

    $value

    значение элемента

    $cache_name

    имя кэша
    1.  <?php
      2.

    2.  $Cache = & singleton('Cache');
      3.

    3.
      4.

    4.  // Имя элемента, наиболее часто используется идентификатор или строка идентификаторов
      5.

    5.  $item_name = 'my_item_1';
      6.

    6.
      7.

    7.  $value = "Некое значение, может быть разных типов";
      8.

    8.
      9.

    9.  // Для кэширования различных элементов используются различные кэши. Список кэшей задается в настройках модуля "Кэширование"
      10.

    10.  $cache_name = "TMP";
      11.

    11.
      12.

    12.  $result = $Cache->Insert($item_name, $value, $cache_name);
      13.

    13.
      14.

    14.  if ($result)
      15.

    15.  {
      16.

    16.      echo "Вставка выполнена успешно";
      17.

    17.  }
      18.

    18.  else
      19.

    19.  {
      20.

    20.      echo "Ошибка вставки";
      21.

    21.  }
      22.

    22.  ?>
      23.

    Возвращает

    статус вставки в кэш (истину или ложь)

    [ Наверх ]

    Cache::is_dir

is_dir(
string
$dir_name );

    Описание

    Проверяет наличие директории и в случае успеха сохраняет результат. Служебный метод.

    Принимаемые параметры

    $dir_name

    [ Наверх ]

    Cache::xcacheClearCache

xcacheClearCache(
[string
$cache_name = false], [string
$item_name = false] );

    Описание

    Очистка кэша $cache_name и элемента $item_name в xcache

    Принимаемые параметры

    $cache_name

    имя кэша, если не передан - очищается полностью кэш

    $item_name

    имя элемента в кэше, если не передан - очищается элемент кэша $cache_name с именем $item_name

    [ Наверх ]

Описания переменных

  • $cache_dir_is_exist =  false [Строка 45]
    •

  • Data type: boolean
    •

    Описание

    Флаг наличия директории для сохранения файлов кэша

  • $cache_systems = array() [Строка 80]
    •

  • Data type: array
    •

    Описание

    Массив доступных способов кэширования

  • $default_cache_systems =  'file' [Строка 87]
    •

  • Data type: string
    •

    Описание

    Способ кэширования по умолчанию

  • $dividend =  100 [Строка 66]
    •

  • Data type: int
    •

    Описание

    Максимальное значение, генерируемое для определения необходимости удаления истекших элементов кэша

    var

    целое число, по умолчанию имеет значение 100

  • $is_dir_array = array() [Строка 52]
    •

  • Data type: array
    •

    Описание

    Кэш существующих директорий

  • $probability =  1 [Строка 59]
    •

  • Data type: int
    •

    Описание

    Вероятность удаления истекших элементов кэша

    var

    целое число от 1 до dividend

  • $read_lock =  false [Строка 73]
    •

  • Data type: bool
    •

    Описание

    Блокировать ли файл кэша при чтении. по умолчанию false

  • $use_read_control =  true [Строка 38]
    •

  • Data type: boolean
    •

    Описание

    Использовать контроль данных с помощью crc32

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Captcha

Class Captcha

[Строка 16]

Размещен: /Kernel/Captcha.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для работы с CAPTCHA.
Файл: /modules/Kernel/captcha.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $allowed_symbols =  '1234567890'

        Разрешенные символы. Исключены похожие по написанию o=0, 1=l, i=j, t=f:

  • $distortion_amplitude =  10

        амплитуда искажения

  • $fonts_dir =  'hostcmsfiles/captcha/fonts'

        Путь к шрифтам

  • $image_extension =  'gif'

        Расширение рисунка CAPTCHA

  • $image_height =  50

        Высота изображения с CAPTCHA

  • $image_width =  120

        Ширина изображения с CAPTCHA

  • $keystring =  ''

        Значение CAPTCHA

  • $max_lenght =  4

        Максимальная длина строки CAPTCHA

  • $min_lenght =  4

        Минимальная длина строки CAPTCHA

  • $no_spaces =  true

        Флаг, указывающий, слитно писать символы CAPTCHA или нет

  • $polygon_max_corner =  6

        Максимальное значение количества углов многоугольника на фоне CAPTCHA

  • $polygon_max_radius =  15

        Максимальное значение радиуса многоугольника на фоне CAPTCHA

  • $polygon_min_corner =  6

        Минимальное значение количества углов многоугольника на фоне CAPTCHA

  • $polygon_min_radius =  10

        Минимальное значение радиуса многоугольника на фоне CAPTCHA

  • $simbols =  '0123456789abcdefghijklmnopqrstuvwxyz'

        Порядок символов в шрифтах

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void BuildCapture()

    Метод для построения изображения CAPTCHA и помещения его текста в сессию

  • str GenerateKeyString()

    Генерация строки CAPTCHA

  • int GetCaptchaId()

    Метод генерирует и возвращает уникальный индекс для CAPTCHA

  • boolean ValidCaptcha()

    Метод проверки соответствия введенного пользователем текста хранимому в сессии  Пример использования метода см. в руководстве по интеграции.

Унаследованные методы

Описания методов

    Captcha::BuildCapture

BuildCapture(
int
$captcha_id, [array
$param = array ()] );

    Описание

    Метод для построения изображения CAPTCHA и помещения его текста в сессию

    Принимаемые параметры

    $captcha_id

    - уникальный номер CAPTCHA

    $param

    - $param['alphabet'] Символы используемые в тексте
    • $param['allowed_symbols'] Символы, исключающие ошибки распознавания (o = 0, i = j, 1 = l) используются для формирования строки
    • $param['fontsdir'] Путь к шрифтам
    • $param['length'] Количество символов
    • $param['width'] Ширина базового изображения
    • $param['height'] Высота базового изображения
    • $param['dest_x'] Ширина реального изображения
    • $param['dest_y'] Высота реального изображения
    • $param['foreground_color'] Цвет текста в RGB задаётся массивом
    • $param['background_color'] Цвет фона в RGB задаётся массивом
    • $param['image_extension'] Расширение выходного изображения CAPTCHA (jpg, gif или png)

    [ Наверх ]

    Captcha::GenerateKeyString

GenerateKeyString(
 );

    Описание

    Генерация строки CAPTCHA

    [ Наверх ]

    Captcha::GetCaptchaId

GetCaptchaId(
 );

    Описание

    Метод генерирует и возвращает уникальный индекс для CAPTCHA

    [ Наверх ]

    Captcha::ValidCaptcha

ValidCaptcha(
int
$captcha_id, string
$text );

    Описание

    Метод проверки соответствия введенного пользователем текста хранимому в сессии  Пример использования метода см. в руководстве по интеграции.

    Принимаемые параметры

    $captcha_id

    уникальный номер CAPTCHA

    $text

    текст, введённый пользователем

    [ Наверх ]

Описания переменных

  • $allowed_symbols =  '1234567890' [Строка 46]
    •

  • Data type: mixed
    •

    Описание

    Разрешенные символы. Исключены похожие по написанию o=0, 1=l, i=j, t=f:

  • $distortion_amplitude =  10 [Строка 61]
    •

  • Data type: mixed
    •

    Описание

    амплитуда искажения

  • $fonts_dir =  'hostcmsfiles/captcha/fonts' [Строка 21]
    •

  • Data type: mixed
    •

    Описание

    Путь к шрифтам

  • $image_extension =  'gif' [Строка 71]
    •

  • Data type: mixed
    •

    Описание

    Расширение рисунка CAPTCHA

  • $image_height =  50 [Строка 56]
    •

  • Data type: mixed
    •

    Описание

    Высота изображения с CAPTCHA

  • $image_width =  120 [Строка 51]
    •

  • Data type: mixed
    •

    Описание

    Ширина изображения с CAPTCHA

  • $keystring =  '' [Строка 31]
    •

  • Data type: mixed
    •

    Описание

    Значение CAPTCHA

  • $max_lenght =  4 [Строка 36]
    •

  • Data type: mixed
    •

    Описание

    Максимальная длина строки CAPTCHA

  • $min_lenght =  4 [Строка 41]
    •

  • Data type: mixed
    •

    Описание

    Минимальная длина строки CAPTCHA

  • $no_spaces =  true [Строка 66]
    •

  • Data type: mixed
    •

    Описание

    Флаг, указывающий, слитно писать символы CAPTCHA или нет

  • $polygon_max_corner =  6 [Строка 91]
    •

  • Data type: mixed
    •

    Описание

    Максимальное значение количества углов многоугольника на фоне CAPTCHA

  • $polygon_max_radius =  15 [Строка 81]
    •

  • Data type: mixed
    •

    Описание

    Максимальное значение радиуса многоугольника на фоне CAPTCHA

  • $polygon_min_corner =  6 [Строка 86]
    •

  • Data type: mixed
    •

    Описание

    Минимальное значение количества углов многоугольника на фоне CAPTCHA

  • $polygon_min_radius =  10 [Строка 76]
    •

  • Data type: mixed
    •

    Описание

    Минимальное значение радиуса многоугольника на фоне CAPTCHA

  • $simbols =  '0123456789abcdefghijklmnopqrstuvwxyz' [Строка 26]
    •

  • Data type: mixed
    •

    Описание

    Порядок символов в шрифтах

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class cml

Class cml

[Строка 15]

Размещен: /shop/cml.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "CommerceML".
Файл: /modules/shop/cml.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $nl2br =

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • array ImportCML()

    Импорт из формата CommerceML

Унаследованные методы

Описания методов

    cml::ImportCML

ImportCML(
int
$array_of_cml_data, int
$shop_shops_id, int
$import_price_action_items, int
$shop_groups_parent_id, [str
$images_path = ''], [
$nl2br = TRUE] );

    Описание

    Импорт из формата CommerceML

    Принимаемые параметры

    $array_of_cml_data

    массив с данными в формате CommerceML, полученный в результате работы метода Xml2Array класса kernel, выполненного на целевом XML файле, содержащим данные в формате CommerceML

    $shop_shops_id

    идентификатор интернет-магазина

    $import_price_action_items

    идентификатор действия с уже существующими товарами (0 - Удалить существующие товары (во всех группах), 1 - Обновить информацию для существующих товаров, 2 - Оставить без изменений)

    $shop_groups_parent_id

    идентификатор группы в которую выгружать данные из CommerceML

    $images_path

    путь к картинкам

    $nl2br

    Возвращает

    ассоциативный массив с данными о количестве обработанных данных
    • array['count_insert_item'] - количество вставленных товаров
    • array['count_update_item'] - количество обновленных товаров
    • array['count_dir'] - количество вставленных групп товаров

    [ Наверх ]

Описания переменных

  • $nl2br =  [Строка 18]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class compression

Class compression

[Строка 23]

Размещен: /Compression/Compression.class.php

Описание

Класс модуля "Система сжатия (компрессия)"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string CheckTypeGzip()

    Получение типа сжатия gzip

  • boolean PageCompressionBegin()

    Запуск приема из стандартного потока содержимого для компрессии

  • void PageCompressionEnd()

    Вывод сжатых данных, размещенных в потоке

Унаследованные методы

Описания методов

    compression::CheckTypeGzip

CheckTypeGzip(
 );

    Описание

    Получение типа сжатия gzip

    Возвращает

    возвращает строку или false

    [ Наверх ]

    compression::PageCompressionBegin

PageCompressionBegin(
 );

    Описание

    Запуск приема из стандартного потока содержимого для компрессии

    [ Наверх ]

    compression::PageCompressionEnd

PageCompressionEnd(
 );

    Описание

    Вывод сжатых данных, размещенных в потоке

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Constants

Class Constants

[Строка 14]

Размещен: /Constants/Constants.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Константы".
Файл: /modules/Constants/Constants.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed AddEditConstants()

    Добавление/редактирование данных о константе

  • boolean DelConstants()

    Удаление константы

  • resource GetAllConstants()

    Получение данных обо всех константах

  • mixed GetConstant()

    Получение данных о константе

  • mixed GetConstantByName()

    Получение данных о константе по ее имени

  • void GetConstants()

    Устаревший метод, не рекомендуется к использованию с версии 5.1.2

Унаследованные методы

Описания методов

    Constants::AddEditConstants

AddEditConstants(
int
$type, int
$constants_id, string
$constants_name, string
$constants_value, string
$constants_description, int
$constants_activity, [int
$users_id = false] );

    Описание

    Добавление/редактирование данных о константе

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление данных о константе (0 - вставка, 1 - обновление)

    $constants_id

    идентификатор константы, если идет обновление

    $constants_name

    имя константы

    $constants_value

    значение константы

    $constants_description

    описание константы

    $constants_activity

    статус активности константы (0 - неактивна, 1 - активна)

    $users_id

    идентификатор пользователя центра администрирования, добавившего элемент

    Возвращает

    идентификатор вставленной/обновленной записи в случае успешного выполнения, false - в противном случае
    1.  <?php
      2.

    2.  $Constant = new Constants();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $constants_name = 'Константа 1';
      6.

    6.  $constants_value = '';
      7.

    7.  $constants_description = '';
      8.

    8.  $constants_activity = '';
      9.

    9.
      10.

    10.  $newid = $Constant->AddEditConstants($type, $constants_id, $constants_name, $constants_value, $constants_description, $constants_activity);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    [ Наверх ]

    Constants::DelConstants

DelConstants(
int
$constants_id );

    Описание

    Удаление константы

    Принимаемые параметры

    $constants_id

    идентификатор удаляемой константы

    Возвращает

    true в случае успешного выполнения, false в противном случае
    1.  <?php
      2.

    2.  $Constant = new Constants();
      3.

    3.
      4.

    4.  $constants_id = 51;
      5.

    5.
      6.

    6.  $result = $Constant->DelConstants($constants_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Constants::GetAllConstants

GetAllConstants(
 );

    Описание

    Получение данных обо всех константах

    Возвращает

    1.  <?php
      2.

    2.  $Constant = new Constants();
      3.

    3.
      4.

    4.  $resource = $Constant->GetAllConstants();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.     print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    Constants::GetConstant

GetConstant(
int
$constants_id );

    Описание

    Получение данных о константе

    Принимаемые параметры

    $constants_id

    идентификатор константы

    Возвращает

    array с данными или false при отсутствии константы
    1.  <?php
      2.

    2.  $Constant = new Constants();
      3.

    3.
      4.

    4.  $constants_id = 47;
      5.

    5.
      6.

    6.  $row = $Constant->GetConstant($constants_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Constants::GetConstantByName

GetConstantByName(
int
$constants_name );

    Описание

    Получение данных о константе по ее имени

    Принимаемые параметры

    $constants_name

    наименование константы

    Возвращает

    array с данными или false при отсутствии константы
    1.  <?php
      2.

    2.  $Constant = new Constants();
      3.

    3.
      4.

    4.  $constants_name = 'LOG_DAYS_LIMIT';
      5.

    5.
      6.

    6.  $row = $Constant->GetConstantByName($constants_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Constants::GetConstants

GetConstants(
int
$constants_id );

    Описание

    Устаревший метод, не рекомендуется к использованию с версии 5.1.2

    Принимаемые параметры

    $constants_id

    see

    Constants::GetConstant(), Constants::GetAllConstants()

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class counter

Class counter

[Строка 23]

Размещен: /Counter/Counter.class.php

Описание

Класс модуля "Статистика посещаемости сайта"

Свойства класса

  • $new_session =  false

        Флаг добавления новой сессии при обновлении данных счетчика

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean AddEditInitialData()

    Добавление/редактирование начальных данных для счетчика

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • string AlignTextSpace()

    Выравнивание текста по центру с помощью пробелов

  • mixed build_counter()

    Отображение счетчика

  • bool CheckBot()

    Проверка user-agent на принадлежность к ботам

  • string code_ip()

    Преобразование IP в HEX

  • string decode_ip()

    Декодирование IP из HEX

  • void DelStatInfomationForSite()

    Удаление статистической информации для сайта

  • int GetAllSession()

    Определение числа сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"

  • mixed GetBotsInfo()

    Получение данных о ботах и посещенных ими страницах

  • void getBrowserName()

  • mixed GetCounterInform()

    Получение информации о данных счетчика за определенную дату

  • mixed GetDayInformation()

    Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"

  • resource GetInitialData()

    Получение начальных данных для счетчика

  • mixed GetIpInformation()

    Выборка информации для IP-адреса

  • mixed GetNewUsersInform()

    Получение информации о новых пользователях сайта

  • void getOsName()

  • mixed GetSearchSystemInform()

    Получение информации о поисковых системах

  • array GetSecondaryStat()

    Получение статистической информации из таблицы сессий

  • array GetStatArray()

    Получение статистической информации из основной таблицы

  • array GetStatDataArray()

    Получение статистических данных за переданный промежуток времени

  • mixed GetUseCJ()

    Получение данных о использовании кукисов и Java

  • void InsertRecord()

    Добавление записи в основную таблицу статистики

  • int InsertSession()

    Вставка записи о сессии

  • int IpIsNew()

    Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта

  • string IsSearchSystem()

    Определение запроса из поисковой системы. Метод работает с поисковыми системами:

  • boolean isset_id()

    Проверка наличия id сайта

  • boolean MailReport()

    Отправка письма с отчетом администратору сайта

  • Метод ShowCounterCode()

    Отображение кода счетчика

Унаследованные методы

Описания методов

    counter::AddEditInitialData

AddEditInitialData(
int
$type, int
$site_id, int
$sessions, int
$hosts, int
$hits, int
$new_users, int
$bots );

    Описание

    Добавление/редактирование начальных данных для счетчика

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $site_id

    идентификатор сайта

    $sessions

    начальное значение сессий

    $hosts

    начальное значение хостов

    $hits

    начальное значение новых пользователей

    $new_users

    начальное значение ботов

    $bots

    начальное значение типа дейтсвия (0-вставка, 1-редактирование)

    Возвращает

    true при удачной вставке/обновлении, false в случае ошибки
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $type = 1;
      5.

    5.  $site_id = 1;
      6.

    6.  $sessions = 555;
      7.

    7.  $hosts = 555;
      8.

    8.  $hits = 555;
      9.

    9.  $new_users = 555;
      10.

    10.  $bots = 555;
      11.

    11.
      12.

    12.  $result = $counter->AddEditInitialData($type, $site_id, $sessions, $hosts, $hits, $new_users, $bots);
      13.

    13.
      14.

    14.  if ($result)
      15.

    15.  {
      16.

    16.      echo "Вставка/обновление выполнена успешно";
      17.

    17.  }
      18.

    18.  else
      19.

    19.  {
      20.

    20.      echo "Ошибка вставки/обновления";
      21.

    21.  }
      22.

    22.  ?>
      23.

    [ Наверх ]

    counter::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    counter::AlignTextSpace

AlignTextSpace(
int
$count_all, strlen
$text );

    Описание

    Выравнивание текста по центру с помощью пробелов

    Принимаемые параметры

    $count_all

    общее количество символов

    $text

    текст

    Возвращает

    строка с выровненным текстом
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $count_all = 31;
      5.

    5.  $text = 'Тестовый текст для выравнивания';
      6.

    6.
      7.

    7.  $result = $counter->AlignTextSpace($count_all,$text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    counter::build_counter

build_counter(
int
$site_id, int
$js_version, int
$screen, int
$remote_addr, string
$current_page, string
$refer, int
$px, string
$user_agent, string
$cookie, string
$java, int
$counter, [int
$update_counter = 1] );

    Описание

    Отображение счетчика

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $js_version

    js версия пользователя

    $screen

    параметры экрана пользователя

    $remote_addr

    ip адрес пользователя

    $current_page

    посещенная страница

    $refer

    ссылающаяся страница

    $px

    глубина цвета пользователя

    $user_agent

    user agent пользователя

    $cookie

    флаг поддержки кукисов

    $java

    флаг поддержки java

    $counter

    номер счетчика для определения изображения

    $update_counter

    - флаг обновления данных счетчика (1-обновлять (по умолчанию), 0-просто построить счетчик)

    Возвращает

    ложь в случае ошибки, в случае успешного построения счетчика и вставки/обновления данных метод ничего не возвращает
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.  $js_version = '';
      6.

    6.  $screen = '';
      7.

    7.  $remote_addr = '';
      8.

    8.  $current_page = '';
      9.

    9.  $refer = '';
      10.

    10.  $px = '';
      11.

    11.  $user_agent = '';
      12.

    12.  $cookie = '';
      13.

    13.  $java = '';
      14.

    14.  $counter_num = 1;
      15.

    15.  $update_counter = 0;
      16.

    16.
      17.

    17.  $result = $counter->build_counter($site_id, $js_version, $screen, $remote_addr, $current_page,$refer, $px, $user_agent, $cookie, $java, $counter_num, $update_counter);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  echo $result;
      21.

    21.  ?>
      22.

    [ Наверх ]

    counter::CheckBot

CheckBot(
string
$agent );

    Описание

    Проверка user-agent на принадлежность к ботам

    Принимаемые параметры

    $agent

    user-agent

    Возвращает

    true, если это бот, false в противном случае
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $agent = 'YANDEX';
      5.

    5.
      6.

    6.  $is_bot = $counter->CheckBot($agent);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  var_dump($is_bot);
      10.

    10.  ?>
      11.

    [ Наверх ]

    counter::code_ip

code_ip(
string
$ip );

    Описание

    Преобразование IP в HEX

    Принимаемые параметры

    $ip

    ip-адрес

    Возвращает

    ip-адрес, преобразованный в 16-ое значение для записи в базу
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $ip = '192.168.0.1';
      5.

    5.
      6.

    6.  $result = $counter->code_ip($ip);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    counter::decode_ip

decode_ip(
srting
$ip );

    Описание

    Декодирование IP из HEX

    Принимаемые параметры

    $ip

    ip-адрес в 16-ричном формате

    Возвращает

    ip-адрес в обычном формате для вывода
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $ip = 'c0a80001';
      5.

    5.
      6.

    6.  $result = $counter->decode_ip($ip);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    counter::DelStatInfomationForSite

DelStatInfomationForSite(
int
$site_id );

    Описание

    Удаление статистической информации для сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $counter->DelStatInfomationForSite($site_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    counter::GetAllSession

GetAllSession(
int
$site_id );

    Описание

    Определение числа сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    число сессий для сайта
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $result = $counter->GetAllSession($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    counter::GetBotsInfo

GetBotsInfo(
string
$date_from, string
$date_to, int
$site_id );

    Описание

    Получение данных о ботах и посещенных ими страницах

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    информация о ботах в случае удачной выборки, false - при возникновении ошибки
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      6.

    6.  $date_to = date('Y-m-d H:i:s');
      7.

    7.
      8.

    8.  $row = $counter->GetBotsInfo($date_from, $date_to, $site_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  if ($row)
      12.

    12.  {
      13.

    13.      print_r ($row);
      14.

    14.  }
      15.

    15.  else
      16.

    16.  {
      17.

    17.      echo "Данные за указанный период не найдены";
      18.

    18.  }
      19.

    19.  ?>
      20.

    [ Наверх ]

    counter::getBrowserName

getBrowserName(

$user_agent );

    Принимаемые параметры

    $user_agent

    [ Наверх ]

    counter::GetCounterInform

GetCounterInform(
int
$site_id, [string
$date = ''], [string
$mark = "="] );

    Описание

    Получение информации о данных счетчика за определенную дату

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $date

    дата (не обязательный параметр, по умолчанию = '')

    $mark

    знак сравнения с датой (по умолчанию - "=")
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $row = $counter->GetCounterInform ($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($row)
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.     echo "Данные за указанный период не найдены";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    массив с данными в случае успешного выполнения, иначе - false

    [ Наверх ]

    counter::GetDayInformation

GetDayInformation(
string
$date, int
$site_id );

    Описание

    Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"

    Принимаемые параметры

    $date

    дата в формате ГГГГ-ММ-ДД

    $site_id

    идентификатор сайта

    Возвращает

    array с данными или false, если данные отсутствуют
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $date = date('Y-m-d');
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.
      7.

    7. $row = $counter->GetDayInformation($date, $site_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  if ($row)
      11.

    11.  {
      12.

    12.      print_r ($row);
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Данные за указанный период не найдены";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    counter::GetInitialData

GetInitialData(
int
$site_id );

    Описание

    Получение начальных данных для счетчика

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    информация о начальных данных, false - если запись не выбрана
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $resource = $counter->GetInitialData($site_id);
      7.

    7.
      8.

    8.  if ($resource)
      9.

    9.  {
      10.

    10.      $row = mysql_fetch_assoc($resource);
      11.

    11.      // Распечатаем результат
      12.

    12.      print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    counter::GetIpInformation

GetIpInformation(
string
$ip_adr, string
$date_from, string
$date_to, int
$site_id );

    Описание

    Выборка информации для IP-адреса

    Принимаемые параметры

    $ip_adr

    ip адрес

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    массив с данными по ip адресу или false
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $ip_adr = $_SERVER['REMOTE_ADDR'];
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      7.

    7.  $date_to = date('Y-m-d H:i:s');
      8.

    8.
      9.

    9.  $row = $counter->GetIpInformation($ip_adr, $date_from, $date_to, $site_id);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  if ($row)
      13.

    13.  {
      14.

    14.      print_r ($row);
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Данные за указанный период не найдены";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    counter::GetNewUsersInform

GetNewUsersInform(
string
$date_from, string
$date_to, int
$site_id );

    Описание

    Получение информации о новых пользователях сайта

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    массив с данными о новых пользователях или false
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      6.

    6.  $date_to = date('Y-m-d H:i:s');
      7.

    7.
      8.

    8.  $row = $counter->GetNewUsersInform($date_from, $date_to, $site_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  if ($row)
      12.

    12.  {
      13.

    13.      print_r ($row);
      14.

    14.  }
      15.

    15.  else
      16.

    16.  {
      17.

    17.      echo "Данные за указанный период не найдены";
      18.

    18.  }
      19.

    19.  ?>
      20.

    [ Наверх ]

    counter::getOsName

getOsName(

$user_agent );

    Принимаемые параметры

    $user_agent

    [ Наверх ]

    counter::GetSearchSystemInform

GetSearchSystemInform(
string
$date_from, string
$date_to, int
$site_id, [int
$limit = ''], [array
$filter_param = array()] );

    Описание

    Получение информации о поисковых системах

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничение количества выбираемых записей (не обязательный параметр)

    $filter_param

    массив со значениями параметров фильтра
    • $filter_param['stat_searh_query'] значение фильтра по поисковым фразам
    • $filter_param['stat_search_system'] значение фильтра по поисковым системам

    Возвращает

    массив с данными о поисковых системах в случае успешного выполнения илиfalse при возникновении ошибок
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      6.

    6.  $date_to = date('Y-m-d H:i:s');
      7.

    7.
      8.

    8.  $row = $counter->GetSearchSystemInform($date_from, $date_to, $site_id, $limit, $filter_param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  if ($row)
      12.

    12.  {
      13.

    13.      print_r ($row);
      14.

    14.  }
      15.

    15.  else
      16.

    16.  {
      17.

    17.      echo "Данные за указанный период не найдены";
      18.

    18.  }
      19.

    19.  ?>
      20.

    [ Наверх ]

    counter::GetSecondaryStat

GetSecondaryStat(
int
$type, string
$date_from, string
$date_to, int
$site_id, [string
$limit = ''], [array
$filter_param = array()] );

    Описание

    Получение статистической информации из таблицы сессий

    Принимаемые параметры

    $type

    вид информации
    0 - Операционные системы
    1 - Браузеры
    2 - Разрешение монитора
    3 - Глубина цвета
    4 - Версии JS
    5 - User agents
    6 - User agents ботов

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничение количества страниц ($limit - не обязательный параметр)

    $filter_param

    массив со значениями параметров фильтра
    • $filter_param['stat_name_value'] название показателя

    Возвращает

    информация с данными статистики
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $type = 1;
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      7.

    7.  $date_to = date('Y-m-d H:i:s');
      8.

    8.
      9.

    9.  $row = $counter->GetSecondaryStat($type, $date_from, $date_to, $site_id);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  if ($row)
      13.

    13.  {
      14.

    14.      print_r ($row);
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Данные за указанный период не найдены";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    counter::GetStatArray

GetStatArray(
int
$type, string
$date_from, string
$date_to, int
$site_id, [string
$limit = ''], [array
$filter_param = array()] );

    Описание

    Получение статистической информации из основной таблицы

    Принимаемые параметры

    $type

    вид информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничения количества страниц

    $filter_param

    массив со значениями параметров фильтра
    • $filter_param['stat_name_value'] название показателя
    • $filter_param['stat_ip'] ip-адрес

    Возвращает

    данные статистики
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $type = 1;
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      7.

    7.  $date_to = date('Y-m-d H:i:s');
      8.

    8.  $limit = '';
      9.

    9.
      10.

    10.  $row = $counter->GetStatArray($type, $date_from, $date_to, $site_id, $limit='', $filter_param);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  if ($row)
      14.

    14.  {
      15.

    15.      print_r ($row);
      16.

    16.  }
      17.

    17.  else
      18.

    18.  {
      19.

    19.      echo "Данные за указанный период не найдены";
      20.

    20.  }
      21.

    21.  ?>
      22.

    [ Наверх ]

    counter::GetStatDataArray

GetStatDataArray(
string
$date_from, string
$date_to, int
$site_id, [array
$filter_param = array()] );

    Описание

    Получение статистических данных за переданный промежуток времени

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $filter_param

    массив со значениями параметров фильтра
    • $filter_param['stat_hits_value'] значение фильтра хитов
    • $filter_param['stat_sessions_value'] значение фильтра по сессиям
    • $filter_param['stat_hosts_value'] значение фильтра по хостам
    • $filter_param['stat_new_users_value'] значение фильтра по новым посетителям
    • $filter_param['stat_search_bots_value'] значение фильтра по поисковым ботам

    Возвращает

    ассоциативный массив с данными
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      6.

    6.  $date_to = date('Y-m-d H:i:s');
      7.

    7.
      8.

    8.  $row = $counter->GetStatDataArray($date_from, $date_to, $site_id, $filter_param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  if ($row)
      12.

    12.  {
      13.

    13.       print_r ($row);
      14.

    14.  }
      15.

    15.  else
      16.

    16.  {
      17.

    17.     echo "Данные за указанный период не найдены";
      18.

    18.  }
      19.

    19.  ?>
      20.

    [ Наверх ]

    counter::GetUseCJ

GetUseCJ(
int
$type, string
$date_from, string
$date_to, int
$site_id );

    Описание

    Получение данных о использовании кукисов и Java

    Принимаемые параметры

    $type

    тип отбираемой информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор данных

    Возвращает

    ассоциативный массив с данными об использовании кукисов и Java при успешной выборке, иначе - false
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $type = 1;
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.  $date_from = date('Y-m-d H:i:s', time() - 60*60*24*30);
      7.

    7.  $date_to = date('Y-m-d H:i:s');
      8.

    8.
      9.

    9.  $row = $counter->GetUseCJ($type, $date_from, $date_to, $site_id);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  if ($row)
      13.

    13.  {
      14.

    14.      print_r ($row);
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Данные за указанный период не найдены";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    counter::InsertRecord

InsertRecord(
int
$session_id, int
$site_id, string
$refer, string_type
$page, string
$cookie, string
$java, string
$search_system, string
$search_query, int_type
$user_number, int_type
$user_is_new, string
$ip_adr, string
$hostname );

    Описание

    Добавление записи в основную таблицу статистики

    Принимаемые параметры

    $session_id

    идентификатор сессии

    $site_id

    идентификатор сайта

    $refer

    ссылающаяся страница

    $page

    страница

    $cookie

    флаг поддержки кукисов

    $java

    флаг поддержки java

    $search_system

    флаг поисковой системы

    $search_query

    поисковая фраза

    $user_number

    номер пользователя

    $user_is_new

    флаг новый пользователь или нет

    $ip_adr

    преобразованный ip

    $hostname

    имя хоста
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $session_id = '';
      5.

    5.  $site_id = 1;
      6.

    6.  $refer = '';
      7.

    7.  $page = '';
      8.

    8.  $cookie = '';
      9.

    9.  $java = '';
      10.

    10.  $search_system = '';
      11.

    11.  $search_query = '';
      12.

    12.  $user_number = 1;
      13.

    13.  $user_is_new = 1;
      14.

    14.  $ip_adr = '192.168.0.1';
      15.

    15.  $hostname = '';
      16.

    16.
      17.

    17.  $result = $counter->InsertRecord($session_id, $site_id, $refer, $page, $cookie, $java, $search_system, $search_query, $user_number, $user_is_new, $ip_adr, $hostname);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  echo $result;
      21.

    21.  ?>
      22.

    [ Наверх ]

    counter::InsertSession

InsertSession(
int
$site_id, int
$color_depth, string
$display_name, string
$js_version, string
$ip_adr, string
$user_agent, int
$is_bot );

    Описание

    Вставка записи о сессии

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $color_depth

    глубина цвета

    $display_name

    параметры экрана

    $js_version

    версия js

    $ip_adr

    преобразованный ip

    $user_agent

    user agent

    $is_bot

    флаг - бот/не бот

    Возвращает

    идетнификатор вставленной записи, либо идентификатор уже имеющейся записи о текущей сессии
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.  $color_depth = 32;
      6.

    6.  $display_name = '1024x768';
      7.

    7.  $js_version = '1.3';
      8.

    8.  $ip_adr = '192.168.0.1';
      9.

    9.  $user_agent = 'Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)';
      10.

    10.  $is_bot = 0;
      11.

    11.
      12.

    12.  $newid = $counter->InsertSession($site_id, $color_depth, $display_name, $js_version, $ip_adr,$user_agent, $is_bot);
      13.

    13.
      14.

    14.  // Распечатаем результат
      15.

    15.  echo $newid;
      16.

    16.  ?>
      17.

    [ Наверх ]

    counter::IpIsNew

IpIsNew(
string
$ip_adr, string
$date_t, int
$site_id );

    Описание

    Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта

    Принимаемые параметры

    $ip_adr

    упакованный IP-адрес

    $date_t

    дата

    $site_id

    идентификатор сайта

    Возвращает

    1 - новый, 0 - не новый
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $ip_adr = '192.168.0.1';
      5.

    5.  $date_t = date('Y-m-d H:i:s');
      6.

    6.  $site_id = 1;
      7.

    7.
      8.

    8.  $result = $counter->IpIsNew($ip_adr, $date_t, $site_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $result;
      12.

    12.  ?>
      13.

    [ Наверх ]

    counter::IsSearchSystem

IsSearchSystem(
string
$str );

    Описание

    Определение запроса из поисковой системы. Метод работает с поисковыми системами:

    • Yandex
    • Rambler
    • Google
    • Mail.Ru
    • Aport
    • MSN
    • Altavista
    • KM.Ru
    • Yahoo.com
    • Webalta
    • Metabot
    • Nigma
    • bing.com

    Принимаемые параметры

    $str

    адрес ссылающейся страницы

    Возвращает

    поисковый запрос
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $str = 'http://yandex.ru/yandsearch?clid=13999&yasoft=barff&text=cms';
      5.

    5.
      6.

    6.  $search_query = $counter->IsSearchSystem($str);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  var_dump($search_query);
      10.

    10.  ?>
      11.

    [ Наверх ]

    counter::isset_id

isset_id(
int
$site_id );

    Описание

    Проверка наличия id сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    true при наличии сайта, false - если данного сайта не существует
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $result = $counter->isset_id($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo 'Сайт с идентификатором ' . $site_id . ' существует.';
      12.

    12.  }
      13.

    13.  echo
      14.

    14.  {
      15.

    15.      echo 'Сайт с идентификатором ' . $site_id . ' не существует.';
      16.

    16.  }
      17.

    17.
      18.

    18.  ?>
      19.

    [ Наверх ]

    counter::MailReport

MailReport(
int
$site_id, string
$date );

    Описание

    Отправка письма с отчетом администратору сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $date

    дата отчета

    Возвращает

    false в случае ошибки, в случае успеной отправки метод не возвращет никаких значений
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.  $date = date('Y-m-d H:i:s');
      6.

    6.
      7.

    7.  $counter->MailReport($site_id, $date);
      8.

    8.  ?>
      9.

    [ Наверх ]

    counter::ShowCounterCode

ShowCounterCode(
int
$counter_type, string
$alias_name, array
$gCounterProperties, [string
$get_update_counter = ''] );

    Описание

    Отображение кода счетчика

    Принимаемые параметры

    $counter_type

    тип выводимого счетчика (файл счетчика должен быть расположен в директории /counter/ и представлять собой изображение с именем {НОМЕР}.gif)

    $alias_name

    наименование домена сайта, например www.site.ru

    $gCounterProperties

    глобальный массив, содержащий свойства счетчика

    $get_update_counter

    переменная с информацией о необходимости обновления счетчика, не обязательный параметр, по умолчанию равен пустоте

    Возвращает

    не возвращает никаких значений.
    Пример использования:
    1.  <?php
      2.

    2.  $counter = new counter();
      3.

    3.  $counter->ShowCounterCode(0,"www.site.ru",$GLOBALS['gCounterProperties'],"&update_counter=0");
      4.

    4.  ?>
      5.

    [ Наверх ]

Описания переменных

  • $new_session =  false [Строка 29]
    •

  • Data type: boolean
    •

    Описание

    Флаг добавления новой сессии при обновлении данных счетчика

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class DateClass

Class DateClass

[Строка 14]

Размещен: /Kernel/Date.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для работы с датами.
Файл: /modules/Kernel/date.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed admin_datetime_format()

    Метод для центра администрирования,  преобразует формат выводы даты из sql-формата в формат  d.m.Y H:i:s

  • mixed admin_date_format()

    Метод для центра администрирования,  преобразует формат выводы даты из sql-формата в формат d.m.Y

  • string ChangeMySqlDate()

    Получение значения даты в формате MySQL путем изменения переданной на заданное число секунд

  • string ChangeNormalDate()

    Получение значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд

  • mixe DateSqlToUnix()

    Метод преобразовывает дату в формате SQL в число секунд с начала эпохи

  • mixed datetime_format()

    Метод преобразует формат вывода даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT

  • mixed datetime_format_sql()

    Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL

  • string DateUnixToSQL()

    Метод преобразовывает дату из числа секунд в формат SQL

  • mixed date_format()

    Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT

  • mixed date_format_sql()

    Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат

Унаследованные методы

Описания методов

    DateClass::admin_datetime_format

admin_datetime_format(
string
$date );

    Описание

    Метод для центра администрирования,  преобразует формат выводы даты из sql-формата в формат  d.m.Y H:i:s

    Принимаемые параметры

    $date

    принимаемая дата
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('Y-m-d H:i:s');
      5.

    5.
      6.

    6.  echo $DateClass->admin_datetime_format($date);
      7.

    7.  ?>
      8.

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    [ Наверх ]

    DateClass::admin_date_format

admin_date_format(
string
$date );

    Описание

    Метод для центра администрирования,  преобразует формат выводы даты из sql-формата в формат d.m.Y

    Принимаемые параметры

    $date

    принимаемая дата
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('Y-m-d H:i:s');
      5.

    5.
      6.

    6.  echo $DateClass->admin_date_format($date);
      7.

    7.  ?>
      8.

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    [ Наверх ]

    DateClass::ChangeMySqlDate

ChangeMySqlDate(
int
$second, [string
$date = ''] );

    Описание

    Получение значения даты в формате MySQL путем изменения переданной на заданное число секунд

    Принимаемые параметры

    $second

    число секунд

    $date

    принимаемая дата
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $second = 1221030528;
      5.

    5.  $date = date('d.m.Y');
      6.

    6.
      7.

    7.  echo $DateClass->ChangeMySqlDate($second, $date='');
      8.

    8.  ?>
      9.

    Возвращает

    измененная дата

    [ Наверх ]

    DateClass::ChangeNormalDate

ChangeNormalDate(
int
$second, [string
$date = ''] );

    Описание

    Получение значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд

    Принимаемые параметры

    $second

    число секунд

    $date

    дата в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $second = 100000;
      5.

    5.  $date = date('d.m.Y H:i:s');
      6.

    6.
      7.

    7.  echo $DateClass->ChangeNormalDate($second, $date);
      8.

    8.  ?>
      9.

    Возвращает

    дата в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС

    [ Наверх ]

    DateClass::DateSqlToUnix

DateSqlToUnix(
string
$date, [string
$date_separator = '-'] );

    Описание

    Метод преобразовывает дату в формате SQL в число секунд с начала эпохи

    Принимаемые параметры

    $date

    дата в формате MySQL

    $date_separator

    разделитель даты (по умолчанию "-")
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('Y-m-d H:i:s');
      5.

    5.  $date_separator = '-';
      6.

    6.
      7.

    7.  echo $DateClass->DateSqlToUnix($date, $date_separator);
      8.

    8.  ?>
      9.

    Возвращает

    дата в формате числа секунд с начала эпохи в случае успешного выполнения, false в противном случае

    [ Наверх ]

    DateClass::datetime_format

datetime_format(
string
$date );

    Описание

    Метод преобразует формат вывода даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT

    Принимаемые параметры

    $date

    принимаемая дата в SQL формате
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('Y-m-d H:i:s');
      5.

    5.
      6.

    6.  echo $DateClass->datetime_format($date);
      7.

    7.  ?>
      8.

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    [ Наверх ]

    DateClass::datetime_format_sql

datetime_format_sql(
string
$date );

    Описание

    Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL

    Принимаемые параметры

    $date

    принимаемая дата
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('d.m.Y H:i:s');
      5.

    5.
      6.

    6.  echo $DateClass->datetime_format_sql($date);
      7.

    7.  ?>
      8.

    Возвращает

    датавремя в формате MySQL в случае успешного выполнения, false в противном случае

    [ Наверх ]

    DateClass::DateUnixToSQL

DateUnixToSQL(
string
$datetime );

    Описание

    Метод преобразовывает дату из числа секунд в формат SQL

    Принимаемые параметры

    $datetime

    число секунд с начала эпохи
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $datetime = 1221030528;
      5.

    5.
      6.

    6.  echo $DateClass->DateUnixToSQL($datetime);
      7.

    7.  ?>
      8.

    Возвращает

    дата в формате SQL

    [ Наверх ]

    DateClass::date_format

date_format(
string
$date, [string
$date_format = "%d.%m.%Y"] );

    Описание

    Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT

    Принимаемые параметры

    $date

    принимаемая дата

    $date_format

    формат даты, необязательное поле, по умолчанию %d.%m.%Y
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('Y-m-d H:i:s');
      5.

    5.
      6.

    6.  echo $DateClass->date_format($date, $date_format = "%d.%m.%Y");
      7.

    7.  ?>
      8.

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    [ Наверх ]

    DateClass::date_format_sql

date_format_sql(
string
$date );

    Описание

    Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат

    Принимаемые параметры

    $date

    принимаемая дата
    1.  <?php
      2.

    2.  $DateClass = new DateClass();
      3.

    3.
      4.

    4.  $date = date('d.m.Y H:i:s');
      5.

    5.
      6.

    6.  echo $DateClass->datetime_format_sql($date);
      7.

    7.  ?>
      8.

    Возвращает

    дата в формате MySQL в случае успешного выполнения, false в противном случае

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class documents

Class documents

[Строка 14]

Размещен: /Documents/Documents.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Старницы и документы".
Файл: /modules/Documents/Documents.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheGetCurrentDocumentVersion = array()

        Кэш для метода GetCurrentDocumentVersion()

  • $documents_id_array = array()

        Массив соответствия старых и новых идентификаторов скопированных документов

  • $mas_documents_dir = array()

        Массив разделов документов

  • $path_array = array()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed CopyCurrentDocumentVersion()

    Копирование текущей версии документа

  • void CopyDocuments()

    Метод копирования документа

  • void CopyDocumentsDir()

    Копирование групп документов с документами

  • mixed CopyDocumentStatus()

    Копирование статуса документа

  • boolean current_version()

    Метод для переобозначения текущей версии документа

  • boolean delete_old_version()

    Метод удаления записей обо всех не текущих версиях

  • boolean delete_status()

    Метод удаления статуса документов

  • boolean delete_version()

    Метод удаления записей о версиях

  • boolean del_documents()

    Удаления документов

  • boolean del_documents_dir()

    Удаление разделов документов

  • mixed GetCurrentDocumentVersion()

    Получение информации о текущей версии документа

  • mixed GetDocument()

    Получение информации о документе

  • resource GetDocumentDir()

    Получение информации о разделе документов

  • array GetDocumentsDirTree()

    Метод формирования дерева разделов документов.

  • resource GetDocumentsFromDir()

    Получение списка документов раздела без учета подразделов

  • array GetDocumentsPathArray()

    Метод для построения массива пути от текущего узла к корневому. Предназначен для использования только в центре администрирования.

  • mixed GetDocumentVersion()

    Получение информации о версии документа

  • string GetDocumentVersionPath()

    Получение пути к файлу версии документа

  • array get_documents_dir()

    Метод формирования дерева разделов текущего сайта

  • int insert_documents()

    Вставка/обновление новых документов

  • int insert_documents_dir()

    Вставка/обновления разделов документов

  • int insert_status()

    Метод добавления(редактирования) статусов документов

  • int insert_version()

    Метод добавления/редактирования записей о версиях

  • resource select_documents()

    Получение информации о документе или обо всех документах.

  • resource select_documents_dir()

    Метод выбора раздела документов

  • resource select_status()

    Получение информации о статусе документа

  • resource select_version()

    Метод выборки информации о версиях

  • void ShowDocument()

    Показ текста текущей версии страницы

Унаследованные методы

Описания методов

    documents::CopyCurrentDocumentVersion

CopyCurrentDocumentVersion(
int
$documents_id, [
$new_document_id = 0], [
$array_template_ids = array()] );

    Описание

    Копирование текущей версии документа

    Принимаемые параметры

    $documents_id

    Идентификатор документа

    $new_document_id

    $array_template_ids

    Возвращает

    int или false

    [ Наверх ]

    documents::CopyDocuments

    CopyDocuments(
int
$documents_id, [
$new_site_id = false], [int
$documents_dir_parent_id = -1], [bool
$return_array_ids = false], [array
$array_template_ids = array()], [array
$array_document_status_ids = array()] );

    Описание

    Метод копирования документа

    Принимаемые параметры

    $documents_id

    идентификатор копируемого документа

    $documents_dir_parent_id

    идентификатор категории, к которой необходимо отнести скопированный документ (не обязательный параметр. Если имеет значение -1 - скопированные документы кладутся в ту же директорию, что и копируемые. по умолчанию -1)

    $return_array_ids

    Флаг, указывающий, нужно ли запоминать соответсятвия старых и новых идентификаторов (по умолчанию - false)

    $array_template_ids

    Массив с соответствиями старых и новых идентификаторов (не обязательный параметр)

    $array_document_status_ids

    Массив с соответствиями новых и старых идентификаторов статусов документов (не обязательный параметр)
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $documents_id = 7;
      5.

    5.
      6.

    6.  $newid = $documents->CopyDocuments($documents_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    $new_site_id

    [ Наверх ]

    documents::CopyDocumentsDir

CopyDocumentsDir(
int
$documents_dir_parent_id,
$site_id, [
$new_site_id = false], [int
$new_documents_dir_parent_id = 0], [bool
$return_array_ids = false], [array
$array_template_ids = array()], [array
$array_document_status_ids = array()] );

    Описание

    Копирование групп документов с документами

    Принимаемые параметры

    $documents_dir_parent_id

    идентификатор группы документов

    $new_documents_dir_parent_id

    идентификатор скопированной группы документов

    $return_array_ids

    Флаг, указывающий, нужно ли возвращать массив с соответствиями старых и новых идентификаторов фокументов (по умолчанию false)

    $array_template_ids

    Массив с соответствиями новых и старых идентификаторов макетов (не обязательный параметр)

    $array_document_status_ids

    Массив с соответствиями новых и старых идентификаторов статусов документов (не обязательный параметр)

    $site_id

    $new_site_id

    [ Наверх ]

    documents::CopyDocumentStatus

CopyDocumentStatus(
int
$documents_status_id, [int
$new_site_id = 0] );

    Описание

    Копирование статуса документа

    Принимаемые параметры

    $documents_status_id

    Идентификатор копируемого статуса документа

    $new_site_id

    Идентификатор сайта, к которому необходимо отнести скопированный статус (не обязательный параметр. Если не указан, скопированный статус будет отнесен к тому же сайту, что и копируемый)

    Возвращает

    false или int Идентификатор скопированного статуса

    [ Наверх ]

    documents::current_version

current_version(
int
$documents_id, int
$documents_version_id );

    Описание

    Метод для переобозначения текущей версии документа

    Принимаемые параметры

    $documents_id

    идентификатор документа

    $documents_version_id

    идентификатор текущей версии
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.  $documents_id = 7;
      4.

    4.  $documents_version_id = 20;
      5.

    5.  $new_current_version = $documents->current_version($documents_id, $documents_version_id);
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $new_current_version;
      8.

    8.  ?>
      9.

    [ Наверх ]

    documents::delete_old_version

delete_old_version(
int
$documents_id );

    Описание

    Метод удаления записей обо всех не текущих версиях

    Принимаемые параметры

    $documents_id

    идентификатор документа
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор документа
      5.

    5.  $documents_id = 12;
      6.

    6.
      7.

    7.  $result = $documents->delete_old_version($documents_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    true при удачном удалении, false - в обратном случае

    [ Наверх ]

    documents::delete_status

delete_status(
int
$status_id );

    Описание

    Метод удаления статуса документов

    Принимаемые параметры

    $status_id

    идентификатор удаляемого статуса документов
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор статуса документа
      5.

    5.  $status_id = 3;
      6.

    6.
      7.

    7.  $result = $documents->delete_status($status_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.
      12.

    12.  ?>
      13.

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    documents::delete_version

delete_version(
int
$documents_version_id );

    Описание

    Метод удаления записей о версиях

    Принимаемые параметры

    $documents_version_id

    идентификатор удаляемой версии
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор версии документа
      5.

    5.  $documents_version_id = 28;
      6.

    6.
      7.

    7.  $result = $documents->delete_version($documents_version_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    true при удачном удалении, false - в обратном случае

    [ Наверх ]

    documents::del_documents

del_documents(
int
$documents_id );

    Описание

    Удаления документов

    Принимаемые параметры

    $documents_id

    идентификатор документа

    Возвращает

    true при удачном удалении, false - в обратном случае
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор удаляемого документа
      5.

    5.  $documents_id = 7;
      6.

    6.
      7.

    7.  $result = $documents->del_documents($documents_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    documents::del_documents_dir

del_documents_dir(
int
$documents_dir_id );

    Описание

    Удаление разделов документов

    Принимаемые параметры

    $documents_dir_id

    идентификатор раздела

    Возвращает

    true при удачном удалении, false - в обратном случае
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.  // Идентификатор удаляемого раздела документов
      4.

    4.  $documents_dir_id = 3;
      5.

    5.
      6.

    6.  $result = $documents->del_documents_dir($documents_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    documents::GetCurrentDocumentVersion

GetCurrentDocumentVersion(
int
$documents_id );

    Описание

    Получение информации о текущей версии документа

    Принимаемые параметры

    $documents_id

    идентификатор отображаемого документа

    Возвращает

    информарция о версии документа в случае успешного выполнения или false, если текущая версия не найдена
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор документа
      5.

    5.  $documents_id = 12;
      6.

    6.
      7.

    7.  $row = $documents->GetCurrentDocumentVersion($documents_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    documents::GetDocument

GetDocument(
int
$documents_id );

    Описание

    Получение информации о документе

    Принимаемые параметры

    $documents_id

    идентификатор документа

    Возвращает

    массив с информацией о документе или false
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор документа
      5.

    5.  $documents_id = 12;
      6.

    6.
      7.

    7.  $row = $documents->GetDocument($documents_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    documents::GetDocumentDir

GetDocumentDir(
int
$documents_dir_id );

    Описание

    Получение информации о разделе документов

    Принимаемые параметры

    $documents_dir_id

    идентификатор раздела документов

    Возвращает

    список всех разделов или данные о конкретном разделе

    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор раздела документов
      5.

    5.  $documents_dir_id = 4;
      6.

    6.
      7.

    7.  $row = $documents->GetDocumentDir($documents_dir_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    documents::GetDocumentsDirTree

GetDocumentsDirTree(
int
$documents_dir_parent_id, string
$separator, [
$current_group_id = false], [bool
$first_call = true], [int
$site_id = false] );

    Описание

    Метод формирования дерева разделов документов.

    Принимаемые параметры

    $documents_dir_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    $first_call

    $site_id

    идентификатор сайта, необязательный параметр. Если не передан - определяется автоматически.
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор родительского раздела документов
      5.

    5.  $documents_dir_parent_id = 0;
      6.

    6.  $separator = '';
      7.

    7.  $documents_dir_tree = $documents->GetDocumentsDirTree($documents_dir_parent_id, $separator);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($documents_dir_tree);
      11.

    11.  ?>
      12.

    $current_group_id

    Возвращает

    массив с данными о дереве разделов документов

    [ Наверх ]

    documents::GetDocumentsFromDir

GetDocumentsFromDir(
int
$documents_dir_id, [int
$site_id = 0] );

    Описание

    Получение списка документов раздела без учета подразделов

    Принимаемые параметры

    $documents_dir_id

    идентификатор раздела документов

    $site_id

    идентификатор сайта (не обязательный параметр. Если не передан, или имеет значение 0, то подставляется идентификатор текущего сайта)
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор раздела документов
      5.

    5.  $documents_dir_id = 0;
      6.

    6.
      7.

    7.  $documents_from_dir = $documents->GetDocumentsFromDir($documents_dir_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($documents_from_dir))
      11.

    11.  {
      12.

    12.          print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    documents::GetDocumentsPathArray

GetDocumentsPathArray(
int
$documents_dir_id, [bool
$first_call = true] );

    Описание

    Метод для построения массива пути от текущего узла к корневому. Предназначен для использования только в центре администрирования.

    Принимаемые параметры

    $documents_dir_id

    идентификатор текущего узла

    $first_call

    первый вызов ф-ции, по умолчанию - true
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор раздела документов
      5.

    5.  $documents_dir_id = 4;
      6.

    6.
      7.

    7.  $path = $documents->GetDocumentsPathArray($documents_dir_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($path);
      11.

    11.  ?>
      12.

    Возвращает

    массив с элементами пути группы

    [ Наверх ]

    documents::GetDocumentVersion

GetDocumentVersion(
int
$documents_version_id );

    Описание

    Получение информации о версии документа

    Принимаемые параметры

    $documents_version_id

    идентификатор версии документа

    Возвращает

    массив с данными о версии документа или false
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор версии документа
      5.

    5.  $documents_version_id = 29;
      6.

    6.
      7.

    7.  $row = $documents->GetDocumentVersion($documents_version_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    documents::GetDocumentVersionPath

GetDocumentVersionPath(
int
$documents_version_id );

    Описание

    Получение пути к файлу версии документа

    Принимаемые параметры

    $documents_version_id

    идентификатор версии документа

    Возвращает

    путь к документу

    [ Наверх ]

    documents::get_documents_dir

get_documents_dir(
int
$documents_dir_parent_id, int
$separator_dir, [int
$documents_dir_id = 0] );

    Описание

    Метод формирования дерева разделов текущего сайта

    Принимаемые параметры

    $documents_dir_parent_id

    идентификатор родительского раздела, с которого начинается формирование

    $separator_dir

    отступ для подразделов

    $documents_dir_id

    идентификатор раздела, который необходимо пропустить (не включать в дерево вместе с подразделами)
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $documents_dir_parent_id = 0;
      5.

    5.  $separator_dir = '&nbsp';
      6.

    6.
      7.

    7.  $documents_tree = $documents->get_documents_dir($documents_dir_parent_id, $separator_dir);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($documents_tree);
      11.

    11.  ?>
      12.

    Возвращает

    ассоциативный массив с информацией о дереве разделов

    [ Наверх ]

    documents::insert_documents

insert_documents(
int
$type, int
$documents_id, int
$documents_dir_id, int
$users_id, int
$documents_status_id, string
$documents_name, int
$documents_version_id, int
$version_current, int
$version_comment, string
$documents_text, int
$templates_id,
$site_id );

    Описание

    Вставка/обновление новых документов

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_id

    идентификатор документа

    $documents_dir_id

    идентификатор радздела

    $users_id

    идентификатор пользователя

    $documents_status_id

    идентификатор статуса документа

    $documents_name

    наименование документа

    $documents_version_id

    идентификатор версии документа

    $version_current

    указатель на текущую версию

    $version_comment

    комментарий к версии документа

    $documents_text

    текст документа

    $templates_id

    идентификатор шаблона

    $site_id

    Возвращает

    идентификатор документа
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $documents_id = 0;
      6.

    6.  $documents_dir_id = 0;
      7.

    7.  $users_id = false;
      8.

    8.  $documents_status_id = 0;
      9.

    9.  $documents_name = 'Тестовый документ';
      10.

    10.  $documents_version_id = 0;
      11.

    11.  $version_current = 1;
      12.

    12.  $version_comment = 'Комментарий к версии';
      13.

    13.  $documents_text = 'Тестовый текст';
      14.

    14.  $templates_id = 1;
      15.

    15.  $site_id = 1;
      16.

    16.
      17.

    17.  $newid = $documents->insert_documents($type, $documents_id, $documents_dir_id, $users_id, $documents_status_id, $documents_name, $documents_version_id, $version_current, $version_comment, $documents_text, $templates_id, $site_id);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  echo $newid;
      21.

    21.  ?>
      22.

    [ Наверх ]

    documents::insert_documents_dir

insert_documents_dir(
int
$type, int
$documents_dir_id, int
$documents_dir_parent_id, string
$documents_dir_name, [int
$users_id = false], [int
$site_id = 0] );

    Описание

    Вставка/обновления разделов документов

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_dir_id

    идентификатор раздела

    $documents_dir_parent_id

    идентификатор родительского раздела

    $documents_dir_name

    наименование раздела

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    $site_id

    идентификатор сайта. Если 0, то система получит текущий сайт из константы CURRENT_SITE. В противном случае можно указать ID сайта явно. по умолчанию равен 0.

    Возвращает

    идентификатор отредактированного (вставленного) раздела
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $documents_dir_id = '';
      6.

    6.  $documents_dir_parent_id = 0;
      7.

    7.  $documents_dir_name = 'Тестовый раздел';
      8.

    8.
      9.

    9.  // Если 0, то система получит текущий сайт из константы CURRENT_SITE. В противном случае можно указать ID сайта явно
      10.

    10.  $site_id = 0;
      11.

    11.  $users_id = false;
      12.

    12.
      13.

    13.  $newid = $documents->insert_documents_dir($type, $documents_dir_id, $documents_dir_parent_id, $documents_dir_name, $users_id, $site_id);
      14.

    14.
      15.

    15.  // Распечатаем результат
      16.

    16.  echo $newid;
      17.

    17.  ?>
      18.

    [ Наверх ]

    documents::insert_status

insert_status(
int
$type, int
$status_id, string_type
$status_name, string
$status_description, [int
$users_id = false], [
$site_id = false] );

    Описание

    Метод добавления(редактирования) статусов документов

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $status_id

    идентификатор статуса документа

    $status_name

    наименование статуса

    $status_description

    описание статуса

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $status_id = '';
      6.

    6.  $status_name = 'Новый статус';
      7.

    7.  $status_description = 'Описание нового статуса';
      8.

    8.
      9.

    9.  $newid = $documents->insert_status($type, $status_id, $status_name, $status_description);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    $site_id

    Возвращает

    идентификатор нового или редатируемого статуса (в зависимости от типа действия)

    [ Наверх ]

    documents::insert_version

insert_version(
int
$type, int
$documents_version_id, int
$documents_id, int
$version_current, string
$version_comment, string
$documents_text, int
$users_id, int
$templates_id );

    Описание

    Метод добавления/редактирования записей о версиях

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_version_id

    идентификатор версии документа

    $documents_id

    идентификатор документа

    $version_current

    флаг текущей версии

    $version_comment

    комментарий к версии

    $documents_text

    текст документа

    $users_id

    идентификатор пользователя

    $templates_id

    идентификатор шаблона
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $documents_version_id = '';
      6.

    6.  $documents_id = 12;
      7.

    7.  $version_current = 1;
      8.

    8.  $version_comment = 'Новая версия';
      9.

    9.  $documents_text = 'Тестовый текст';
      10.

    10.  $users_id = '';
      11.

    11.  $templates_id = '';
      12.

    12.
      13.

    13.  $newid = $documents->insert_version($type, $documents_version_id, $documents_id, $version_current, $version_comment, $documents_text, $users_id, $templates_id);
      14.

    14.
      15.

    15.  // Распечатаем результат
      16.

    16.  echo $newid;
      17.

    17.  ?>
      18.

    Возвращает

    идентификатор новой или редатируемой версии (в зависимости от типа действия)

    [ Наверх ]

    documents::select_documents

select_documents(
int
$documents_id, [
$site_id = false] );

    Описание

    Получение информации о документе или обо всех документах.

    Принимаемые параметры

    $documents_id

    идентификатор документа (-1 - выбор всех документов)

    $site_id

    Возвращает

    реестр документов или данные о конкретном документе

    see

    GetDocument()
 <br />Пример использования:
 <code>
 <?php
 $documents = new documents();

 // Идентификатор выбираемого документа
 $documents_id = 12;

 $resource = $documents->select_documents($documents_id);

 // Распечатаем результат
 while($row = mysql_fetch_assoc($resource))
 {
         print_r($row);
 }
 ?>
 </code>

    [ Наверх ]

    documents::select_documents_dir

select_documents_dir(
int
$documents_dir_id, [
$site_id = false] );

    Описание

    Метод выбора раздела документов

    Принимаемые параметры

    $documents_dir_id

    идентификатор раздела (-1 - выбор всех разделов)

    $site_id

    Возвращает

    список всех разделов или данные о конкретном разделе
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.  // Идентификатор выбираемого раздела
      4.

    4.  $documents_dir_id = 4;
      5.

    5.
      6.

    6.  $resource = $documents->select_documents_dir($documents_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  $row = mysql_fetch_assoc($resource);
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    documents::select_status

select_status(
int
$documents_status_id, [int
$site_id = false] );

    Описание

    Получение информации о статусе документа

    Принимаемые параметры

    $documents_status_id

    идентификатор статуса (false - выбор всех статусов)

    $site_id

    идентификатор сайта
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор статуса
      5.

    5.  $documents_status_id = 1;
      6.

    6.
      7.

    7.  $resource = $documents->select_status($documents_status_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($resource))
      11.

    11.  {
      12.

    12.          print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    documents::select_version

select_version(
int
$documents_id, int
$documents_version_id, [int
$current = 1] );

    Описание

    Метод выборки информации о версиях

    Принимаемые параметры

    $documents_id

    идентификатор документа

    $documents_version_id

    идентификатор версии, если false - версия неизвестна. При этом текущую версию необходимо установить в 1

    $current

    указатель на текущую версию, по умолчанию равен 1 - выбрать текущую версию.
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  $documents_id = 12;
      5.

    5.  $documents_version_id = false;
      6.

    6.
      7.

    7.  $resource = $documents->select_version($documents_id, $documents_version_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($resource))
      11.

    11.  {
      12.

    12.          print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    информация о версиях документа

    [ Наверх ]

    documents::ShowDocument

ShowDocument(
int
$document_id );

    Описание

    Показ текста текущей версии страницы

    Принимаемые параметры

    $document_id

    иднетификатор отображаемого документа
    Пример использования:
    1.  <?php
      2.

    2.  $documents = new documents();
      3.

    3.
      4.

    4.  // Идентификатор документа
      5.

    5.  $document_id = 12;
      6.

    6.
      7.

    7.  $documents->ShowDocument($document_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

Описания переменных

  • $CacheGetCurrentDocumentVersion = array() [Строка 53]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetCurrentDocumentVersion()

  • $documents_id_array = array() [Строка 46]
    •

  • Data type: array
    •

    Описание

    Массив соответствия старых и новых идентификаторов скопированных документов

  • $mas_documents_dir = array() [Строка 21]
    •

  • Data type: array
    •

    Описание

    Массив разделов документов

  • $path_array = array() [Строка 39]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class EventsJournal

Class EventsJournal

[Строка 14]

Classes extended from EventsJournal:

EventsJournalAdmin

Класс модуля "Журнал событий"

Размещен: /Kernel/EventsJournal.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс журналирования событий.
Файл: /modules/Kernel/EventsJournal.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • str convert_str_for_csv()

    Подготовка строки к записи в CSV-файл

  • boolean log_access()

    Метод протоколирования получения доступа к системе управления

Унаследованные методы

Описания методов

    EventsJournal::convert_str_for_csv

convert_str_for_csv(
str
$str );

    Описание

    Подготовка строки к записи в CSV-файл

    Принимаемые параметры

    $str

    исходная строка
    1.  <?php
      2.

    2.  $EventsJournal = new EventsJournal();
      3.

    3.
      4.

    4.  $str = 'Строка с "текстом" к записи в CSV-файл';
      5.

    5.
      6.

    6.  $newstr = $EventsJournal->convert_str_for_csv($str);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newstr;
      10.

    10.  ?>
      11.

    Возвращает

    обработанная строка

    [ Наверх ]

    EventsJournal::log_access

log_access(
string
$login, string_type
$message, [string
$status = 0], [string
$send_email = true] );

    Описание

    Метод протоколирования получения доступа к системе управления

    Принимаемые параметры

    $login

    логин пользователя

    $message

    текст сообщения для события

    $status

    статус события (значимость события), необязательный параметр.
    Статус имеет значения:
    0 – Нейтральное
    1 – Успешное
    2 – Низкий уровень критичности
    3 – Средний уровень критичности
    4 – Наивысший уровень критичности

    $send_email

    отправлять администратору сообщение о произошедшем событии (по умолчанию true), необязательный параметр
    1.  <?php
      2.

    2.  $EventsJournal = new EventsJournal();
      3.

    3.
      4.

    4.  $login = 'tygra';
      5.

    5.  $message = 'Текст сообщения';
      6.

    6.  $status = 0;
      7.

    7.
      8.

    8.  $result = $EventsJournal->log_access($login, $message, $status);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo "Доступ получен";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Ошибка получения доступа";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class EventsJournalAdmin

Class EventsJournalAdmin

[Строка 23]
EventsJournal
   |
   --EventsJournalAdmin
Размещен: /EventsJournal/EventsJournal.class.php

Описание

Класс модуля "Журнал событий"

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean EventsMail()
    Метод отправки письма с отчетом

Унаследованные методы

Унаследованные от класса EventsJournal

  • EventsJournal::convert_str_for_csv()
    Подготовка строки к записи в CSV-файл
  • EventsJournal::log_access()
    Метод протоколирования получения доступа к системе управления

Описания методов

    EventsJournalAdmin::EventsMail

    EventsMail( string $date );

    Описание

    Метод отправки письма с отчетом

    Принимаемые параметры

    $date

    дата отчета формата YYYY-MM-DD

    Возвращает

    1.  <?php
      2.

    2.  $EventsJournalAdmin = new EventsJournalAdmin();
      3.

    3.
      4.

    4.  $date = date('Y-m-d');
      5.

    5.
      6.

    6.  if ($EventsJournalAdmin->EventsMail($date))
      7.

    7.  {
      8.

    8.      echo "Отчет отправлен успешно\n";
      9.

    9.  }
      10.

    10.  ?>
      11.

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class ExecSqlQuery

Class ExecSqlQuery

[Строка 14]

Размещен: /ExecSqlQuery/ExecSqlQuery.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "SQL-запросы".
Файл: /modules/ExecSqlQuery/ExecSqlQuery.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int ExecDump()

    Выполнение SQL-запроса

  • str GetTableNames()

    Получение списка таблиц, разделенных запятыми.

Унаследованные методы

Описания методов

    ExecSqlQuery::ExecDump

ExecDump(
string
$query );

    Описание

    Выполнение SQL-запроса

    Принимаемые параметры

    $query

    SQL-запрос
    1.  <?php
      2.

    2.  $ExecSqlQuery = new ExecSqlQuery();
      3.

    3.
      4.

    4.  $site_id = intval(CURRENT_SITE);
      5.

    5.
      6.

    6.  $query = "INSERT INTO `structure_table` (  `menu_id` , `templates_id` , `data_templates_id` , `site_id` , `documents_id` , `lib_id` , `structure_parent_id` , `structure_show` , `structure_menu_name` , `structure_title` , `structure_description` , `structure_keywords` , `structure_external_link` , `structure_order` , `structure_path_name` , `structure_type` , `structure_access` , `structure_activity` , `structure_allow_indexation` , `structure_change_frequency` , `structure_priority` , `users_id` )
      7.

    7.
      8.

    8.  -- Далее можно указывать следующие запросы";
      9.

    9.
      10.

    10.  $ExecSqlQuery->ExecDump($query);
      11.

    11.  ?>
      12.

    Возвращает

    количество выполненных запросов или false

    [ Наверх ]

    ExecSqlQuery::GetTableNames

GetTableNames(
 );

    Описание

    Получение списка таблиц, разделенных запятыми.

    Возвращает

    список таблиц в виде: `table1`,`table2`,`table3` либо false.
    1.  <?php
      2.

    2.  $ExecSqlQuery = new ExecSqlQuery();
      3.

    3.
      4.

    4.  $list_table = $ExecSqlQuery->GetTableNames();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $list_table;
      8.

    8.  ?>
      9.

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class ExternalXml

Class ExternalXml

[Строка 14]

Размещен: /Kernel/ExternalXml.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс формирует дерево XML по переданному массиву.
Файл: /modules/Kernel/ExternalXml.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $flag =  false

  • $xml =  ''

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string GenXml()

    Генерация XML для переданного массива

Унаследованные методы

Описания методов

    ExternalXml::GenXml

GenXml(
array
$array, [int
$type = 0] );

    Описание

    Генерация XML для переданного массива

    Принимаемые параметры

    $array

    массив с информацией о дереве

    $type

    тип переданного массива
      Тип 0:  $x['xml_tag_name'] = "value";
      Тип 1:  $x[0]['xml_name'] = 'xml_tag_name';
      $x[0]['value'] = 'value'; // value может быть массивом неограниченного уровня вложенности
      $x[0]['attribute'] = array('name' => 'value', 'name2' => 'value2');
    //Пример 1
    1.  <?php
      2.

    2.  $ExternalXml = new ExternalXml();
      3.

    3.
      4.

    4.  $array['xml_tag_name'] = "value";
      5.

    5.  $array['xml_tag_name2'] = "value2";
      6.

    6.  $type = 0;
      7.

    7.
      8.

    8.  $newxml = $ExternalXml->GenXml($array, $type);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo htmlspecialchars($newxml);
      12.

    12.  ?>
      13.

    //Пример 2
    1.  <?php
      2.

    2.  $ExternalXml = new ExternalXml();
      3.

    3.
      4.

    4.  $array[0]['xml_name'] = 'xml_tag_name';
      5.

    5.  $array[0]['value'] = 'value';
      6.

    6.
      7.

    7.  $array[1]['xml_name'] = 'xml_tag_name2';
      8.

    8.  $array[1]['value'] = 'value2';
      9.

    9.
      10.

    10.  $array[2]['xml_name'] = 'xml_tag_name3';
      11.

    11.  $array[2]['value'] = array(0 =>array('xml_name' => 'children_tag1',    'value' => 'children_value'));
      12.

    12.
      13.

    13.  $type = 1;
      14.

    14.
      15.

    15.  $newxml = $ExternalXml->GenXml($array, $type);
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  echo htmlspecialchars($newxml);
      19.

    19.  ?>
      20.

    Возвращает

    XML-код

    [ Наверх ]

Описания переменных

  • $flag =  false [Строка 17]
    •

  • Data type: mixed
    •

  • $xml =  '' [Строка 16]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class File

Class File

[Строка 14]

Размещен: /Kernel/File.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для работы с файлами.
Файл: /modules/Kernel/File.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $chmod_file =  null

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • File __construct()

  • boolean CopyDir()

    Копирование директории

  • boolean DeleteDir()

    Метод удаления директории вместе с вложенными файлами и директориями.

  • boolean DeleteFile()

    Удаление файла с проверкой на его существованием

  • boolean Download()

    Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла

  • void flush()

  • void GetChmodFile()

    Получение прав доступа к создаваемым объектом файлов

  • string GetFileContent()

    Получение содержимого файла

  • string get_file_perms()

    Получение строки прав доступа к файлу

  • string PathCorrection()

    Метод удаляет потенциально опасные символы из пути или имени файла

  • boolean SaveToFile()

    Сохранение содержимого $content в файл с путем $filepath

  • void SetChmodFile()

    Установка прав доступа к создаваемых объектом файлов

Унаследованные методы

Описания методов

    File::__construct

__construct(
 );

    [ Наверх ]

    File::CopyDir

CopyDir(
string
$source, string
$target );

    Описание

    Копирование директории

    Принимаемые параметры

    $source

    директория источник

    $target

    target директория получатель

    [ Наверх ]

    File::DeleteDir

DeleteDir(
string
$dir, [boolean
$delete_self = true] );

    Описание

    Метод удаления директории вместе с вложенными файлами и директориями.

    При указании $delete_self в true удаляет переданную дерикторию тоже.

    Принимаемые параметры

    $dir

    абсолютный путь к директории

    $delete_self

    необязательный флаг удаления переданной директории, по умолчанию true
    1.  <?php
      2.

    2.  $File = new File();
      3.

    3.
      4.

    4.  $dir = CMS_FOLDER . 'dir';
      5.

    5.
      6.

    6.  $File->DeleteDir($dir, true);
      7.

    7.
      8.

    8.  ?>
      9.

    [ Наверх ]

    File::DeleteFile

DeleteFile(
string
$filepath );

    Описание

    Удаление файла с проверкой на его существованием

    Принимаемые параметры

    $filepath

    путь к файлу
    1.  <?php
      2.

    2.  $File = new File();
      3.

    3.
      4.

    4.  $filepath = CMS_FOLDER . 'dir/myfile.txt';
      5.

    5.
      6.

    6.  $File->DeleteFile($filepath);
      7.

    7.
      8.

    8.  ?>
      9.

    [ Наверх ]

    File::Download

Download(
string
$file, string
$filename, [array
$param = array()] );

    Описание

    Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла

    Принимаемые параметры

    $file

    абсолютный путь к файлу

    $filename

    имя файла

    $param

    массив дополнительных параметров
    • $param['content_disposition'] заголовок, определяющий вывод файла (inline - открывается в браузере (по умолчанию), attachment - скачивается)

      1.  <?php
        2.

      2.  $File = new File();
        3.

      3.
        4.

      4.  $file = CMS_FOLDER . 'file.dat';
        5.

      5.  $filename = 'Пользовательское_имя_файла.dat';
        6.

      6.
        7.

      7.  $File->Download($file, $filename);
        8.

      8.
        9.

      9.  exit();
        10.

      10.  ?>
        11.

    [ Наверх ]

    File::flush

flush(
 );

    [ Наверх ]

    File::GetChmodFile

GetChmodFile(
 );

    Описание

    Получение прав доступа к создаваемым объектом файлов

    [ Наверх ]

    File::GetFileContent

GetFileContent(
string
$filename );

    Описание

    Получение содержимого файла

    Принимаемые параметры

    $filename

    абсолютный путь к файлу
    1.  <?php
      2.

    2.  $File = new File();
      3.

    3.
      4.

    4.  $filename = 'file.txt';
      5.

    5.
      6.

    6.  $contents = $File->GetFileContent($filename);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $contents;
      10.

    10.  ?>
      11.

    Возвращает

    содержимое файла, если такой файл существует или false, если файл не существует или его невозможно прочитать

    [ Наверх ]

    File::get_file_perms

get_file_perms(
string
$filename, int
$type );

    Описание

    Получение строки прав доступа к файлу

    Принимаемые параметры

    $filename

    имя файла

    $type

    тип строки (0 - "-rw-rw-rw-"; 1 - "0755")
    1.  <?php
      2.

    2.  $File = new File();
      3.

    3.
      4.

    4.  $filename = 'index.php';
      5.

    5.  $type = 1;
      6.

    6.
      7.

    7.  $newstr = $File->get_file_perms($filename, $type);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $newstr;
      11.

    11.  ?>
      12.

    Возвращает

    строка прав доступа к файлу

    [ Наверх ]

    File::PathCorrection

PathCorrection(
string
$path );

    Описание

    Метод удаляет потенциально опасные символы из пути или имени файла

    Принимаемые параметры

    $path

    путь
    1.  <?php
      2.

    2.  $File = new File();
      3.

    3.
      4.

    4.  $path = CMS_FOLDER . 'dir//subdir/../...//.//../file.txt';
      5.

    5.
      6.

    6.  $newpath = $File->PathCorrection($path);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newpath;
      10.

    10.  ?>
      11.

    Возвращает

    путь без потенциально опасных символов

    [ Наверх ]

    File::SaveToFile

SaveToFile(
string
$filepath, string
$content );

    Описание

    Сохранение содержимого $content в файл с путем $filepath

    Принимаемые параметры

    $filepath

    путь к файлу

    $content

    содержимое файла

    [ Наверх ]

    File::SetChmodFile

SetChmodFile(
int
$chmod_file );

    Описание

    Установка прав доступа к создаваемых объектом файлов

    Принимаемые параметры

    $chmod_file

    права доступа к создаваемых файлам, например, 0644

    [ Наверх ]

Описания переменных

  • $chmod_file =  null [Строка 16]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class FileManager

Class FileManager

[Строка 23]

Размещен: /FileManager/FileManager.class.php

Описание

Класс модуля "Файловый менеджер"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • корректный CdirCorrection()

    Обработка (удаление имени файла, "лишних" слэшей и т.д) пути к директории

  • boolean del_dir()

    Удаление директории вместе с вложенными файлами и директориями.

  • boolean del_file()

    Удаление файла или директории

  • boolean load_files()

    Загрузка файлов

  • string PathCorrection()

    Устаревший, заменен File::PathCorrection(). Метод удаляет потенциально опасные символы из пути или имени файла.

Унаследованные методы

Описания методов

    FileManager::CdirCorrection

CdirCorrection(
$current_dir
$current_dir );

    Описание

    Обработка (удаление имени файла, "лишних" слэшей и т.д) пути к директории

    Принимаемые параметры

    $current_dir

    исходная директория
    1.  <?php
      2.

    2.  $FileManager = new FileManager();
      3.

    3.
      4.

    4.  $current_dir = '/dir';
      5.

    5.
      6.

    6.  $result = $FileManager->CdirCorrection($current_dir);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Путь к директории успешно обработан";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка обработки пути директории";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    путь к исходной директории

    [ Наверх ]

    FileManager::del_dir

del_dir(
string
$dir );

    Описание

    Удаление директории вместе с вложенными файлами и директориями.

    Использует $File->DeleteDir()

    Принимаемые параметры

    $dir

    полный путь
    1.  <?php
      2.

    2.  $FileManager = new FileManager();
      3.

    3.
      4.

    4.  $dir = 'dir';
      5.

    5.
      6.

    6.  $result = $FileManager->del_dir($dir);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Директория успешно удалена";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления директории";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случаее успешного выполнеия, false в противном случае

    [ Наверх ]

    FileManager::del_file

del_file(
string
$file_name );

    Описание

    Удаление файла или директории

    Принимаемые параметры

    $file_name

    полный путь
    1.  <?php
      2.

    2.  $FileManager = new FileManager();
      3.

    3.
      4.

    4.  $file_name = 'file.txt';
      5.

    5.
      6.

    6.  $result = $FileManager->del_file($file_name);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Файл успешно удален";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления файла";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения, false в противном случае

    [ Наверх ]

    FileManager::load_files

load_files(
array
$source, string
$file_name, string
$dir_file, [boolean
$rewrite = true] );

    Описание

    Загрузка файлов

    Принимаемые параметры

    $source

    информация о файле $_FILES['file']

    $file_name

    имя файла

    $dir_file

    директория для размещения файла

    $rewrite

    разрешает замену уже существующего файла, по молчанию true

    [ Наверх ]

    FileManager::PathCorrection

PathCorrection(
string
$path );

    Описание

    Устаревший, заменен File::PathCorrection(). Метод удаляет потенциально опасные символы из пути или имени файла.

    Принимаемые параметры

    $path

    путь

    Возвращает

    путь без потенциально опасных символов

    version

    4.1

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Forms

Class Forms

[Строка 23]

Размещен: /Forms/Forms.class.php

Описание

Класс модуля "Формы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int ConfirmGetForm()

    Определение права пользователя отправлять форму

  • mixed CopyForms()

    Копирование структуры формы и ее полей

  • mixed CopyFormsField()

    Копирование структуры поля формы

  • boolean DelFillForms()

    Удаление бланка заполненной формы

  • boolean DelFillValues()

    Удаление значения одного из полей отправленной формы

  • boolean DelForms()

    Удаление данных о форме

  • boolean DelFormsFields()

    Удаление поля формы

  • resource GetAllForms()

    Получение информации о всех формах

  • resource GetCountFormsFill()

    Получение количества заполнений формы.

  • array GetFillForm()

    Получение списка и значения полей для заполненной формы.

  • resource GetFillForms()

    Получение списка заполненных форм для формы $forms_id.

  • resource GetFillFormsFields()

    Получение списка и значения полей для заполненной формы.

  • boolean GetForm()

    Обработка содержимого отправленной формы

  • mixed GetFormFields()

    Получение данных о полях формы

  • mixed GetFormInfo()

    Получение информации о форме

  • mixed InsertForms()

    Вставка/обновление информации о форме

  • mixed InsertFormsFields()

    Вставка/обновление информации о поле формы

  • mixed InsertFormsFill()

    Вставка/обновление информации о заполнении формы

  • mixed InsertFormsFillValues()

    Вставка/обновление значений заполненной формы

  • mixed SelectForms()

    Получение данных о формах

  • mixed SelectFormsFields()

    Получение данных о поле формы

  • boolean ShowForm()

    Отображение формы

Унаследованные методы

Описания методов

    Forms::ConfirmGetForm

ConfirmGetForm(
int
$forms_id, string
$date, string
$forms_fill_ip );

    Описание

    Определение права пользователя отправлять форму

    Принимаемые параметры

    $forms_id

    идентификатор отправляемой формы

    $date

    дата и время (в формате MySQL) отправки формы

    $forms_fill_ip

    ip-адрес компьютера отправителя формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $form_id = 6;
      5.

    5.  $date = date('Y-m-d H:i:s');
      6.

    6.  $forms_fill_ip = '';
      7.

    7.
      8.

    8.  $result = $Form->ConfirmGetForm($forms_id, $date, $forms_fill_ip);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  if ($result)
      12.

    12.  {
      13.

    13.      echo 'Пользователь имеет право отправлять данные';
      14.

    14.  }
      15.

    15.  else
      16.

    16.  {
      17.

    17.      echo 'Пользователь не имеет право отправлять данные';
      18.

    18.  }
      19.

    19.  ?>
      20.

    Возвращает

    1 – пользователь может отправлять данные формы, 0 – пользователь не может отправлять данные формы

    [ Наверх ]

    Forms::CopyForms

CopyForms(
int
$forms_id, [int
$site_id = false] );

    Описание

    Копирование структуры формы и ее полей

    Принимаемые параметры

    $forms_id

    идентификатор формы, структуру которой необходимо скопировать

    $site_id

    идентификатор сайта, куда следует скопировать форму, если не передан, используется текущий сайт
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_id = 6;
      5.

    5.
      6.

    6.  $newid = $Form->CopyForms($forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    Возвращает

    идентификатор новой формы в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Forms::CopyFormsField

CopyFormsField(
int
$forms_field_id, [array
$param = array()] );

    Описание

    Копирование структуры поля формы

    Принимаемые параметры

    $forms_field_id

    идентификатор поля формы, копию которого необходимо сделать

    $param

    ассоциативный массив параметров
    • $param['show_text_copy'] параметр, определяющий будет добавляться текcт "Копия [датавремя создания копии]" к названию копии поля формы (true - добавлять текст, false - не добавлять), по умолчанию $param['show_text_copy'] = true

      1.  <?php
        2.

      2.  $Form = new Forms();
        3.

      3.
        4.

      4.  $forms_field_id = 6;
        5.

      5.
        6.

      6.  $newid = $Form->CopyFormsField($forms_field_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $newid;
        10.

      10.  ?>
        11.

    Возвращает

    идентификатор нового (скопированного) поля формы, false в противном случае

    [ Наверх ]

    Forms::DelFillForms

DelFillForms(
int
$forms_fill_id );

    Описание

    Удаление бланка заполненной формы

    Принимаемые параметры

    $forms_fill_id

    идентификатор удаляемого бланка
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_fill_id = 2;
      5.

    5.
      6.

    6.  $result = $Form->DelFillForms($forms_fill_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного удаления, false в противном случае

    [ Наверх ]

    Forms::DelFillValues

DelFillValues(
int
$forms_fill_values_id );

    Описание

    Удаление значения одного из полей отправленной формы

    Принимаемые параметры

    $forms_fill_values_id

    идентификатор записи, содержащей значение поля отправленной формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_fill_values_id = 4;
      5.

    5.
      6.

    6.  $result = $Form->DelFillValues($forms_fill_values_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного удаления значения поля отправленной формы, false в противном случае

    [ Наверх ]

    Forms::DelForms

DelForms(
int
$forms_id );

    Описание

    Удаление данных о форме

    Принимаемые параметры

    $forms_id

    идентификатор формы, информацию о которой необходимо удалить
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_id = 4;
      5.

    5.
      6.

    6.  $result = $Form->DelForms($forms_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного удаления формы, false в противном случае

    [ Наверх ]

    Forms::DelFormsFields

DelFormsFields(
int
$forms_fields_id );

    Описание

    Удаление поля формы

    Принимаемые параметры

    $forms_fields_id

    идентификатор удаляемого поля формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_fields_id = 8;
      5.

    5.
      6.

    6.  $result = $Form->DelFormsFields($forms_fields_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного удаления поля формы, false в противном случае

    [ Наверх ]

    Forms::GetAllForms

GetAllForms(
[mixed
$site_id = 0] );

    Описание

    Получение информации о всех формах

    Принимаемые параметры

    $site_id

    идентификатор сайта, для которого необходимо получить список форм
    • (по умолчанию получаем список форм текущего сайта, false - информация о формах всех сайтов)

      1.  <?php
        2.

      2.  $Form = new Forms();
        3.

      3.
        4.

      4.  $site_id = 1;
        5.

      5.
        6.

      6.  $resource = $Form->GetAllForms($site_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

    Возвращает

    или false

    [ Наверх ]

    Forms::GetCountFormsFill

GetCountFormsFill(
[int
$forms_id = 0] );

    Описание

    Получение количества заполнений формы.

    Принимаемые параметры

    $forms_id

    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_id = 0;
      5.

    5.
      6.

    6.  $resource = $Form->GetCountFormsFill($forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($resource);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Forms::GetFillForm

GetFillForm(
int
$fill_forms_id );

    Описание

    Получение списка и значения полей для заполненной формы.

    Принимаемые параметры

    $fill_forms_id

    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $fill_forms_id = 1;
      5.

    5.
      6.

    6.  $row = $Form->GetFillForm($fill_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о заполненной форме

    [ Наверх ]

    Forms::GetFillForms

GetFillForms(
[int
$forms_id = false] );

    Описание

    Получение списка заполненных форм для формы $forms_id.

    Принимаемые параметры

    $forms_id

    - идентификатор формы, если false - все заполненные формы всех форм
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_id = false;
      5.

    5.
      6.

    6.  $resource = $Form->GetFillForms($forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    Forms::GetFillFormsFields

GetFillFormsFields(
int
$fill_forms_id );

    Описание

    Получение списка и значения полей для заполненной формы.

    Принимаемые параметры

    $fill_forms_id

    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $fill_forms_id = 1;
      5.

    5.
      6.

    6.  $resource = $Form->GetFillFormsFields($fill_forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    Forms::GetForm

GetForm(
int
$form_id, string
$xsl_forms, string
$xsl_email, [array
$param = array()], [array
$external_propertys = array()] );

    Описание

    Обработка содержимого отправленной формы

    Принимаемые параметры

    $form_id

    идентификатор отправленной формы

    $xsl_forms

    XSL-шаблон, формирующий сообщение пользователю при отправке формы

    $xsl_email

    XSL-шаблон, формирующий текст письма куратору отправленной формы с данными, переданными в форме

    $param

    массив дополнительных параметров, имеет следующую структуру
    • $param['e-mail'] - поле формы, содержащее email адрес отправителя;
    • $param['e-mail-to'] - строка со списком электронных адресов получателей.
     При явном указании списка электронных адресов, адреса указанные в  атрибутах формы игнорируются;
    • $param['subject'] - тема письма куратору формы;
    • $param['type'] - тип письма (0 - text/html, 1 - text/plain);
    • $param['bound'] - граница прикрепляемого файла. Если не передан, создается
     автоматически.

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    Возвращает

    true в случае успешного отправления формы, false в противном случае

    [ Наверх ]

    Forms::GetFormFields

GetFormFields(
int
$form_id );

    Описание

    Получение данных о полях формы

    Принимаемые параметры

    $form_id

    идентификатор формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $form_id = 6;
      5.

    5.
      6.

    6.  $resource = $Form->GetFormFields($form_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    resorce в случае успешного выполнения, false в противном случае

    [ Наверх ]

    Forms::GetFormInfo

GetFormInfo(
int
$form_id );

    Описание

    Получение информации о форме

    Принимаемые параметры

    $form_id

    идентификатор формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $form_id = 6;
      5.

    5.
      6.

    6.  $row = $Form->GetFormInfo($form_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с данными о форме в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Forms::InsertForms

InsertForms(
int
$type, int
$forms_id, string
$forms_name, string
$forms_description, string
$forms_email, int
$forms_button_type, string
$forms_button_name, string
$forms_button_value, string
$forms_button_text_value, [array
$param = array()], [string
$forms_mail_subject = ''], [int
$users_id = false], [int
$site_id = false] );

    Описание

    Вставка/обновление информации о форме

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о форме( 0 – вставка, 1 обновление)

    $forms_id

    идентификатор обновляемой формы (при вставке равен 0)

    $forms_name

    имя формы

    $forms_description

    описание формы

    $forms_email

    e-mail куратора формы

    $forms_button_type

    тип кнопки для формы (0 – простая кнопка, 1 - кнопка типа button)

    $forms_button_name

    название кнопки (английское)

    $forms_button_value

    значение, передаваемое при нажатии кнопки

    $forms_button_text_value

    текст на кнопке

    $param

    массив дополнительных параметров
     $param['forms_captcha_used'] параметр, определяющий использовать при отображении формы captcha (1 использовать, 0 не использовать)

    $forms_mail_subject

    тема письма администратору об отправке формы

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь

    $site_id

    идентификатор сайта, если false - берется текущий сайт
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $forms_id = 0;
      6.

    6.  $forms_name = 'Новая форма';
      7.

    7.  $forms_description = '';
      8.

    8.  $forms_email = '';
      9.

    9.  $forms_button_type = 1;
      10.

    10.  $forms_button_name = 'Btn';
      11.

    11.  $forms_button_value = '';
      12.

    12.  $forms_button_text_value = '';
      13.

    13.  $param = array();
      14.

    14.  $forms_mail_subject = '';
      15.

    15.
      16.

    16.  $newid = $Form->InsertForms($type, $forms_id, $forms_name, $forms_description, $forms_email, $forms_button_type, $forms_button_name, $forms_button_value, $forms_button_text_value);
      17.

    17.
      18.

    18.  // Распечатаем результат
      19.

    19.  echo $newid;
      20.

    20.  ?>
      21.

    Возвращает

    идентификатор вставленной/обновленной формы в случае успешного выполнения, false в противном случае

    [ Наверх ]

    Forms::InsertFormsFields

InsertFormsFields(
int
$type, int
$forms_fields_id, int
$forms_id, int
$lists_id, int
$forms_fields_type, string
$forms_fields_name, string
$forms_fields_text_name, string
$forms_fields_default_value, int
$forms_fields_order, int
$forms_fields_size, int
$forms_fields_rows, int
$forms_fields_cols, int
$forms_fields_checked, string
$forms_fields_comment, [int
$forms_fields_obligatory = 0], [int
$users_id = false] );

    Описание

    Вставка/обновление информации о поле формы

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о поле формы (0 – вставка, 1 обновление)

    $forms_fields_id

    идентификатор обновляемого поля формы (при вставке равен 0)

    $forms_id

    идентификатор формы, к которой относится обновляемое/добавляемое поле

    $lists_id

    идентификатор списка, с которым связано поле (для полей типа «радиогруппа», «выпадающий список»)

    $forms_fields_type

    – тип поля формы (0 – текстовое поле, 1 – поле пароля, 2 – поле загрузки файла,    3 – радиокнопка, 4 – checkbox, 5 – большое текстовое поле, 6 – список, 7 – скрытое поле, 9 - список из чекбоксов)

    $forms_fields_name

    английское название поля (тег “name”)

    $forms_fields_text_name

    поясняющий текст для поля формы

    $forms_fields_default_value

    значение по умолчанию

    $forms_fields_order

    порядоковый номер поля

    $forms_fields_size

    ширина поля формы (для текстового поля и поля пароля)

    $forms_fields_rows

    высота большого текстового поля

    $forms_fields_cols

    ширина большого текстового поля

    $forms_fields_checked

    параметр, определяющий отображать поле типа checkbox выбранным или нет (0 – не выбрано, 1 выбрано)

    $forms_fields_comment

    поясняющий комментарий к полю

    $forms_fields_obligatory

    параметр, определяющий является поле обязательным для заполнения (0 – необязательное (по умолчанию), 1 – обязательное)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $forms_fields_id = 0;
      6.

    6.  $forms_id = 6;
      7.

    7.  $lists_id = 1;
      8.

    8.  $forms_fields_type = 0;
      9.

    9.  $forms_fields_name = 'Field';
      10.

    10.  $forms_fields_text_name = 'Поле';
      11.

    11.  $forms_fields_default_value = '';
      12.

    12.  $forms_fields_order = 10;
      13.

    13.  $forms_fields_size = '';
      14.

    14.  $forms_fields_rows = '';
      15.

    15.  $forms_fields_cols = '';
      16.

    16.  $forms_fields_checked = 0;
      17.

    17.  $forms_fields_comment = '';
      18.

    18.  $forms_fields_obligatory = 0;
      19.

    19.
      20.

    20.  newid = $Form->InsertFormsFields($type, $forms_fields_id, $forms_id, $lists_id, $forms_fields_type, $forms_fields_name, $forms_fields_text_name, $forms_fields_default_value, $forms_fields_order, $forms_fields_size, $forms_fields_rows, $forms_fields_cols, $forms_fields_checked, $forms_fields_comment);
      21.

    21.
      22.

    22.  // Распечатаем результат
      23.

    23.  echo $newid;
      24.

    24.
      25.

    25.  ?>
      26.

    Возвращает

    идентификатор вставленной/обновленной записи с информацией о поле формы в случае успешного выполнения, false в противном случае

    [ Наверх ]

    Forms::InsertFormsFill

InsertFormsFill(
int
$type, int
$forms_fill_id, int
$forms_id, int
$forms_fill_ip, string
$forms_fill_date );

    Описание

    Вставка/обновление информации о заполнении формы

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о заполнении формы

    $forms_fill_id

    идентификатор редактируемой записи с информацией о заполненной форме (при вставке равен 0)

    $forms_id

    идентификатор формы

    $forms_fill_ip

    ip-адрес компьютера пользователя, отправившего данные формы

    $forms_fill_date

    дата заполнения формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $forms_fill_id = 0;
      6.

    6.  $forms_id = 6;
      7.

    7.  $forms_fill_ip = '';
      8.

    8.  $forms_fill_date = date('Y-m-d H:i:s');
      9.

    9.
      10.

    10.  $newid = $Form->InsertFormsFill($type, $forms_fill_id, $forms_id, $forms_fill_ip, $forms_fill_date);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    Возвращает

    идентификатор вставленной/обновленной записи с информацией о заполнении поле формы в случае успешного выполнения, false в противном случае

    [ Наверх ]

    Forms::InsertFormsFillValues

InsertFormsFillValues(
int
$type, int
$forms_fill_values_id, int
$forms_fill_id, int
$forms_fields_id, string
$forms_fill_values_value );

    Описание

    Вставка/обновление значений заполненной формы

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление значений заполненной формы (0 - вставка, 1- обновление)

    $forms_fill_values_id

    идентификатор записи, хранящей данные одного из элементов формы

    $forms_fill_id

    идентификатор записи, хранящей данные о заполненной форме

    $forms_fields_id

    идентификатор элемента заполняемой формы

    $forms_fill_values_value

    значение элемента формы
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $forms_fill_values_id = '';
      6.

    6.  $forms_fill_id = 6;
      7.

    7.  $forms_fields_id = 0;
      8.

    8.  $forms_fill_values_value = '';
      9.

    9.
      10.

    10.  $newid = $Form->InsertFormsFillValues($type, $forms_fill_values_id, $forms_fill_id, $forms_fields_id, $forms_fill_values_value);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    Возвращает

    идентификатор добавленной/отредактированной записи, хранящей данные о значении, переданном из формы в случае успешного выполнения, false в противном случае

    [ Наверх ]

    Forms::SelectForms

SelectForms(
int
$forms_id );

    Описание

    Получение данных о формах

    Принимаемые параметры

    $forms_id

    идентификатор формы, данные о которой необходимо получить, если $forms_id = -1, то получаем данные о всех формах
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $forms_id = 6;
      5.

    5.
      6.

    6.  $resource = $Form->SelectForms($forms_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    resource в случае успешного выполнения, false в потивном случае

    [ Наверх ]

    Forms::SelectFormsFields

SelectFormsFields(
int
$field_id );

    Описание

    Получение данных о поле формы

    Принимаемые параметры

    $field_id

    идентификатор поля формы, данные о котором необходимо получить
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $field_id = 6;
      5.

    5.
      6.

    6.  $resource = $Form->SelectFormsFields($field_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  $row = mysql_fetch_assoc($resource);
      10.

    10.
      11.

    11.  print_r($row);
      12.

    12.
      13.

    13.  ?>
      14.

    Возвращает

    resource в случае успешного выполнения, false в противном случае

    [ Наверх ]

    Forms::ShowForm

ShowForm(
int
$form_id, string
$xsl_name, [array
$external_propertys = array()], [array
$fill_value = array()] );

    Описание

    Отображение формы

    Принимаемые параметры

    $form_id

    идентификатор формы

    $xsl_name

    название XSL-шаблона

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    $fill_value

    массив заполненых значений для полей. Если не передан, используются данные, переданные методом POST
    1.  <?php
      2.

    2.  $Form = new Forms();
      3.

    3.
      4.

    4.  $form_id = 6;
      5.

    5.  $xsl_name = 'ОтобразитьФорму';
      6.

    6.
      7.

    7.  $result = $Form->ShowForm($form_id, $xsl_name);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    true в случае успешного выполнения, false в противном случае

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Forums

Class Forums

[Строка 23]

Размещен: /Forums/Forums.class.php

Описание

Класс модуля "Форумы"

Свойства класса

  • $CacheGetConference = array()

        Кэш для метода GetConference()

  • $CacheGetThemeLastMessage = array()

        Кэш для метода GetThemeLastMessage()

  • $iThemeId =  0

        Идентификатор вставленной темы

  • $iTmpId =  0

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • Forums Forums()

  • void AddBbCode()

    Добавление правила BB-кодов

  • int:
     AddEditTheme()

    Добавление/редактирование темы

  • void ApplyTextFunctionWithoutCodeSection()

    Применение функции к фрагментам текста, содержащихся во вне блоков [code]...[/code]

  • string BBcode2HTML()

    Замена BBcode на HTML.

  • void CheckUsersAccessToForum()

  • boolean CloseForum()

    Метод, закрывающий/открывающий форум

  • boolean CloseTheme()

    Открытие/закрытие темы для доступа

  • mixed CopyForum()

    Копирование информации о форуме

  • mixed CopyForumsConference()

    Копирование конференции, групп форумов, а так же форумов, входящих в данную конференцию

  • mixed CopyForumsGroup()

    Копирование информации о группе форумов

  • boolean DeleteConference()

    Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.

  • boolean DeleteForum()

    Метод удаления форума

  • boolean DeleteThemeUserSubscribe()

    Удаление подписки пользователя сайта на тему форума

  • boolean DelForumsGroup()

    Метод удаления группы форумов

  • boolean DelMessage()

    Метод удаления сообщения темы

  • boolean DelTheme()

    Удаление темы форума

  • boolean GenAddEditThemeXML()

    УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean GenEditMessageXML()

    УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean GenMessageXML()

    Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном

  • string GenSmilesXML()

    Метод возвращает XML для смайликов

  • boolean GenUserInfoXML()

    УСТАРЕВШИЙ  Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном

  • string GenXml4InsertEditLetters()

    Генерация XML для письма о вставке/редактировании

  • string GenXML4Message()

    Генерация XML для сообщения

  • string GenXml4Theme()

    Формирование XML для темы форума

  • resource GetAllConferences()

    Получение информации о всех конференциях сайт.

  • resource GetAllForums()

    Метод для получения всех форумов

  • resource GetAllForumsGroup()

    Метод для получения списка всех групп

  • array GetAllMessages()

    Метод для получения всех сообщений

  • array GetConference()

    Метод для получения информации о конференции.

  • mixed GetConferencePath()

    Получение пути к конференции по ее идентификатору

  • int GetCountMessageTheme()

    Получение количества сообщений в теме

  • mixed GetForum()

    Получение информации о форуме

  • array GetForumAccess()

    Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму

  • array GetForumAndItemIdFromPath()

    Получение данных об идентификаторе форума и темы по переданному массиву с элементами пути

  • mixed GetForumsGroup()

    Метод возвращает информацию о группе форумов

  • mixed GetForumsUsersGroupList()

    Получение данных о связи группы пользователей с форумом

  • mixed GetForumView()

    Получение информации о дате последнего просмотра форума пользователем

  • int GetLastPageTheme()

    Получение номера последней страницы темы

  • array GetMessage()

    Получение информации о сообщении

  • mixed GetTheme()

    Метод возвращает информацию о теме форума

  • int GetThemeId()

    Получение идентификатора добавленнной темы форума

  • mixed GetThemeLastMessage()

    Получение последнего сообщения темы

  • mixed GetThemeView()

    Получение информации о дате последнего просмотра темы форума пользователем

  • void GetTmpId()

  • boolean IncCountMessage()

    Метод наращивания счётчика количества сообщений для пользователя

  • array IndexationForums()

    Метод индексации форумов

  • array IndexationForumsMessages()

    Метод индексации сообщений тем форумов

  • mixed InsertConference()

    Метод, осуществляющий вставку информации о конференции.

  • boolean InsertEditMessage()

    Добавление/редактирование сообщения

  • int InsertForum()

    Добавление/редактирование форума

  • int InsertForumsGroup()

    Метод добавления/редактирования группы форумов

  • boolean InsertForumView()

    Вставка информации о дате последнего посещения темы форума пользователем.

  • mixed InsertTheme()

    Вставка/обновление информации о теме

  • boolean InsertThemeUserSubscribe()

    Подписка пользователя сайта на тему форума

  • boolean InsertUsersGroup()

    Метод добавления/редактирования группы пользователей для определения доступа к форуму

  • boolean IssetForumAccess()

    Определение доступа пользователя к форуму

  • boolean IssetThemeUserSubscribe()

    Проверка подписки пользователя сайта на тему форума

  • boolean MessageIsTheme()

    Проверка сообщения на то, что является ли оно темой

  • boolean NoticeTheme()

    Метод делающий тему объявлением или наоборот

  • boolean OrderForums()

    Метод изменения порядка сортировки форумов в группе

  • boolean OrderForumsGroup()

    Метод изменения порядка сортировки групп форумов

  • array SearchIndexing()

    Функция обратного вызова для поисковой индексации данных модуля

  • resource SelectFormThemes()

    Получение результата запроса на выборку тем форума

  • mixed:
     SelectForumsGroup()

    Устарвший метод, возвращающий информацию о группе форумов

  • mixed:
     SelectMessage()

    Метод возвращающий информацию о сообщении

  • resource SelectThemeSubscribers()

    Получение списка подписчиков на тему форума

  • resource SelectUserSubscriptions()

    Получение списка подписанных тем форума

  • boolean SetModerator()

    Метод установления/снятия прав модератора текущего форума для группы пользователей

  • void SetThemeId()

    Установка значения идентификатора добавленной темы форума

  • boolean ShowAddEditTheme()

    Формирование XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean ShowConference()

    Метод отображения конференции

  • boolean ShowEditMessage()

    Формирование XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

  • void ShowForumRss()

    Отображение RSS ленты

  • boolean ShowMessage()

    Метод отображения сообщений форума

  • boolean ShowSiteUserInfo()

    Отображение данных о пользователе форума

  • void ShowThemes()

    Метод отображения тем форума

  • void ShowUserMessages()

    Показ сообщений пользователя

  • string Smile2HTML()

    Метод замены смайликов на HTML

  • оттипографированный TypographText()

    Типографирование текста с использованием модуля "Типограф"

  • bool UserIsModerator()

    Метод для определения, является ли данный пользователь модератором

  • boolean VisibleTheme()

    Метод, устанавливающий видимость/невидимость темы

Унаследованные методы

Описания методов

    Forums::Forums

Forums(
 );

    [ Наверх ]

    Forums::AddBbCode

AddBbCode(
mixed
$BBpattern, mixed
$BBreplace );

    Описание

    Добавление правила BB-кодов

    Принимаемые параметры

    $BBpattern

    регулярное выражение шаблона

    $BBreplace

    регулярное выражение замены

    [ Наверх ]

    Forums::AddEditTheme

AddEditTheme(

$conference_id, int
$forums_id, int
$theme_id, string
$theme_title, int
$theme_close, int
$theme_notice, int
$theme_visible, string
$first_message, int
$site_users_id, int
$current_time, [array
$param = array()] );

    Описание

    Добавление/редактирование темы

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $theme_title

    заголовок темы

    $theme_close

    флаг открытости (0 - закрыта, 1 - открыта)

    $theme_notice

    флаг объявления (1 - объявление)

    $theme_visible

    флаг видимости (0 - невидима, 1 - видима)

    $first_message

    текст первого сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_time

    текущее время в Unix формате

    $param

    массив дополнительных параметров:

    • $param['xslname'] string имя xsl шаблона письма куратору форума
    • $param['theme_send_letter'] int параметр, определяющий сообщать куратору форума о добавлении ответов или нет (1- сообщать, 0 - не сообщать). по умолчанию равен 0.
    • $param['content_type'] str по умолчанию 'text/plain'
    • $param['subject_add_theme'] str тема письма о добавлении темы, необязательное поле
    • $param['subject_edit_theme'] str тема письма о редактировании темы, необязательное поле

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $conference_id = 1;
        5.

      5.  $forums_id = 1;
        6.

      6.  $theme_id = 0;
        7.

      7.  $theme_title = 'Новая тема';
        8.

      8.  $theme_close = 1;
        9.

      9.  $theme_notice = 0;
        10.

      10.  $theme_visible = 1;
        11.

      11.  $first_message = 'Текст первого сообщения';
        12.

      12.  $current_time = date('Y-m-d H:i:s');
        13.

      13.
        14.

      14.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        15.

      15.  if (class_exists('SiteUsers'))
        16.

      16.  {
        17.

      17.      $SiteUsers = & singleton('SiteUsers');
        18.

      18.     $site_users_id = $SiteUsers->GetCurrentSiteUser();
        19.

      19.  }
        20.

      20.  else
        21.

      21.  {
        22.

      22.      $site_users_id = 0;
        23.

      23.  }
        24.

      24.
        25.

      25.  $newid = $Forums->AddEditTheme($conference_id, $forums_id, $theme_id, $theme_title, $theme_close, $theme_notice, $theme_visible, $first_message, $site_users_id, $current_time);
        26.

      26.
        27.

      27.  // Распечатаем результат
        28.

      28.  echo $newid;
        29.

      29.  ?>
        30.

    $conference_id

    Возвращает

    -2 -- сработала защита от флуда,
      -1 -- неверное значение CAPTCHA,

    1. -- не найден форум или конференция
    2. -- операция выполнена успешно

    [ Наверх ]

    Forums::ApplyTextFunctionWithoutCodeSection

ApplyTextFunctionWithoutCodeSection(
str
$text, str
$function_name );

    Описание

    Применение функции к фрагментам текста, содержащихся во вне блоков [code]...[/code]

    Принимаемые параметры

    $text

    текст

    $function_name

    имя метода класса

    [ Наверх ]

    Forums::BBcode2HTML

BBcode2HTML(
string
$text, [bool
$use_typograph = true] );

    Описание

    Замена BBcode на HTML.

    С версии 5.1.7 осуществляет типографирование текста, если модуль "Типограф" активен. Запрет на типографирование передается параметром или объявлением константы DENY_FORUM_TYPOGRAPH со значенем true

    Принимаемые параметры

    $text

    исходный текст

    $use_typograph

    указывает на необходимость типографирования текста. Необязательный параметр, по умолчанию true

    Возвращает

    текст после замены

    [ Наверх ]

    Forums::CheckUsersAccessToForum

CheckUsersAccessToForum(

$param );

    Принимаемые параметры

    $param

    [ Наверх ]

    Forums::CloseForum

CloseForum(
int
$forums_id );

    Описание

    Метод, закрывающий/открывающий форум

    Принимаемые параметры

    $forums_id

    идентификатор форума
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.
      6.

    6.  $result = $Forums->CloseForum($forums_id);
      7.

    7.
      8.

    8.  //Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Forums::CloseTheme

CloseTheme(
int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Описание

    Открытие/закрытие темы для доступа

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.  $forums_theme_id = 1;
      6.

    6.
      7.

    7.  $result = $Forums->CloseTheme($forums_id, $forums_theme_id);
      8.

    8.
      9.

    9.  //Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Forums::CopyForum

CopyForum(
int
$forums_id, [int
$forums_group_id = false] );

    Описание

    Копирование информации о форуме

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_group_id

    идентификатор группы форумов, куда следует скопировать данный форум, если не передан, используется текущая группа

    Возвращает

    Идентификатор скопированной записи, или False

    [ Наверх ]

    Forums::CopyForumsConference

CopyForumsConference(
int
$forums_conference_id, [int
$site_id = false], [int
$structure_id = false] );

    Описание

    Копирование конференции, групп форумов, а так же форумов, входящих в данную конференцию

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    $site_id

    идентификатор сайта на который следует поместить копию конференции, если не передан, используется текущий

    $structure_id

    идентификатор структуры, с которой следует связать копию конференции, если не передан, используется текущая

    Возвращает

    идентификатор скопированной записи, либо False

    [ Наверх ]

    Forums::CopyForumsGroup

CopyForumsGroup(
int
$forums_group_id, [int
$forums_conference_id = false] );

    Описание

    Копирование информации о группе форумов

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $forums_conference_id

    идентификатор конференции, в которую следует перенести скопированную группу форумов

    Возвращает

    идентфикатор скопированной записи, либо False

    [ Наверх ]

    Forums::DeleteConference

DeleteConference(
int
$forums_conference_id );

    Описание

    Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_conference_id = 2;
      5.

    5.
      6.

    6.  $result = $Forums->DeleteConference($forums_conference_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    Forums::DeleteForum

DeleteForum(
int
$forums_id );

    Описание

    Метод удаления форума

    Принимаемые параметры

    $forums_id

    идентификатор форума
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 5;
      5.

    5.
      6.

    6.  $result = $Forums->DeleteForum($forums_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Forums::DeleteThemeUserSubscribe

DeleteThemeUserSubscribe(
array
$param );

    Описание

    Удаление подписки пользователя сайта на тему форума

    Принимаемые параметры

    $param

    массив параметров
    • $param['theme_id'] идентификатор темы форума
    • $param['site_user_id'] идентификатор пользователя сайта

    [ Наверх ]

    Forums::DelForumsGroup

DelForumsGroup(
int
$forums_group_id );

    Описание

    Метод удаления группы форумов

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_group_id = 3;
      5.

    5.
      6.

    6.  $result = $Forums->DelForumsGroup($forums_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    Forums::DelMessage

DelMessage(
int
$forums_id, int
$forums_theme_id, int
$forums_message_id, int
$site_users_id );

    Описание

    Метод удаления сообщения темы

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы форума

    $forums_message_id

    идентификатор сообщения темы

    $site_users_id

    идентификатор пользователя сайта, если false - определяется автоматически. по умолчанию false
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.  $forums_theme_id = 4;
      6.

    6.  $forums_message_id = 7;
      7.

    7.
      8.

    8.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      9.

    9.  if (class_exists('SiteUsers'))
      10.

    10.  {
      11.

    11.      $SiteUsers = & singleton('SiteUsers');
      12.

    12.     $site_users_id = $SiteUsers->GetCurrentSiteUser();
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      $site_users_id = 0;
      17.

    17.  }
      18.

    18.
      19.

    19.  $result = $Forums->DelMessage($forums_id, $forums_theme_id, $forums_message_id, $site_users_id);
      20.

    20.
      21.

    21.  if ($result)
      22.

    22.  {
      23.

    23.     echo "Удаление выполнено успешно";
      24.

    24.  }
      25.

    25.  else
      26.

    26.  {
      27.

    27.      echo "Ошибка удаления";
      28.

    28.  }
      29.

    29.  ?>
      30.

    [ Наверх ]

    Forums::DelTheme

DelTheme(

$conference_id, int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Описание

    Удаление темы форума

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $conference_id = 1;
      5.

    5.  $forums_id = 1;
      6.

    6.  $forums_theme_id = 3;
      7.

    7.
      8.

    8.  $result = $Forums->DelTheme($conference_id, $forums_id, $forums_theme_id);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.     echo "Удаление выполнено успешно";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.     echo "Ошибка удаления";
      17.

    17.  }
      18.

    18.  ?>
      19.

    $conference_id

    [ Наверх ]

    Forums::GenAddEditThemeXML

GenAddEditThemeXML(
int
$forums_id, int
$theme_id, int
$site_users_id, int
$current_page, stringe
$xslname, [string
$error = ''], [array
$param = array()], [
$conference_id = 0] );

    Описание

    УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    индекс текущей страницы

    $xslname

    имя xsl шаблона

    $error

    текст сообщения об ошибке

    $param

    массив параметров темы:
      $param['theme_close'] int флаг закрытости темы;
      $param['theme_notice'] int флаг объявления;
      $param['theme_visible'] int флаг видимости;
      $param['theme_title'] string заголовок темы;
      $param['theme_message_text'] string текст первого сообщения;
      $param['theme_send_letter'] string отправлять письма с ответами на тему

    $conference_id

    [ Наверх ]

    Forums::GenEditMessageXML

GenEditMessageXML(
int
$forums_id, int
$forums_theme_id, int
$forums_message_id, int
$site_users_id, int
$current_page_theme, int
$current_page_message, string
$xslname, [
$error = ''], [array
$param = array()], string
$error='' );

    Описание

    УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_message_id

    идентификатор сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    $param

    массив параметров сообщения:
      $param['message_theme'] string тема собщения;
      $param['message_текст'] string текст сообщения

    $error

    [ Наверх ]

    Forums::GenMessageXML

GenMessageXML(
int
$forums_id, int
$forums_theme_id, int
$site_users_id, int
$current_page_theme, int
$current_page_message, int
$items_on_page, string
$xslname, [string
$error = ''], [array
$param = array()] );

    Описание

    Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $items_on_page

    количество элементов на странице

    $xslname

    имя xsl шаблона

    $error

    текст сообщения об ошибке

    $param

    массив дополнительных параметров

    [ Наверх ]

    Forums::GenSmilesXML

GenSmilesXML(
 );

    Описание

    Метод возвращает XML для смайликов

    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $newxml = $Forums->GenSmilesXML();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo htmlspecialchars($newxml);
      8.

    8.  ?>
      9.

    Возвращает

    XML

    [ Наверх ]

    Forums::GenUserInfoXML

GenUserInfoXML(
int
$forums_id, int
$theme_id, int
$site_users_id, string
$xslname, [
$current_page_theme = 0], [
$current_page_message = 0], [
$error = ''], int
$current_page_theme=0, int
$current_page_message=0, string
$error='' );

    Описание

    УСТАРЕВШИЙ  Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    имя xsl шаблона

    $current_page_theme=0

    индекс текущей страницы тем

    $current_page_message=0

    индекс текущей страницы сообщений

    $error=''

    текст сообщения об ошибке

    $current_page_theme

    $current_page_message

    $error

    [ Наверх ]

    Forums::GenXml4InsertEditLetters

GenXml4InsertEditLetters(
array
$param, [array
$external_propertys = array()] );

    Описание

    Генерация XML для письма о вставке/редактировании

    Принимаемые параметры

    $param

    параметры

    $external_propertys

    массив дополнительных свойств для включения в XML

    [ Наверх ]

    Forums::GenXML4Message

GenXML4Message(

$conference_id,
$forum_id, int
$forum_message_id,
$site_users_id, [
$param = array()], array
$row );

    Описание

    Генерация XML для сообщения

    Принимаемые параметры

    $forum_message_id

    идентификатор сообщения

    $row

    массив, содержащзий информацию о сообщении

    $conference_id

    $forum_id

    $site_users_id

    $param

    Возвращает

    строка с XML

    [ Наверх ]

    Forums::GenXml4Theme

GenXml4Theme(
int
$forums_theme_id, [
$site_users_id = false], [
$row = false], [
$param = array()] );

    Описание

    Формирование XML для темы форума

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы форума

    $site_users_id

    $row

    $param

    Возвращает

    XMl с данными о теме форума

    [ Наверх ]

    Forums::GetAllConferences

GetAllConferences(
[int
$site_id = false] );

    Описание

    Получение информации о всех конференциях сайт.

    Принимаемые параметры

    $site_id

    - идентификатор сайта, если false, то метод вернёт информацию обо всех конференциях всех сайтов.
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $resource = $Forums->GetAllConferences($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    Информация о конференциях.

    [ Наверх ]

    Forums::GetAllForums

GetAllForums(
[int
$forums_group_id = false] );

    Описание

    Метод для получения всех форумов

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов, если false - получаем форумы всех групп
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_group_id = 1;
      5.

    5.
      6.

    6.  $resource = $Forums->GetAllForums($forums_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    Forums::GetAllForumsGroup

GetAllForumsGroup(
[int
$forums_conference_id = false] );

    Описание

    Метод для получения списка всех групп

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции, если false - метод возвращает список всех конференций
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_conference_id = 1;
      5.

    5.
      6.

    6.  $resource = $Forums->GetAllForumsGroup($forums_conference_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    Forums::GetAllMessages

    GetAllMessages(
[int
$forums_theme_id = false], [int
$limit_begin = false], [int
$limit_count = false], [array
$param = array()] );

    Описание

    Метод для получения всех сообщений

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы, если false - получаем сообщения всех тем

    $limit_begin

    строка, с которой выбирать, по умолчанию false

    $limit_count

    количество выбираемых строк, по умочанию false

    $param

    массив дополнительных атрибутов
    • $param['order_field'] - поле сортировки, по умолчанию 'forums_message_datetime'
    • $param['order_type'] - направление сортировки, по умолчанию 'ASC'

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $row = $Forums->GetAllMessages();
        5.

      5.
        6.

      6.  // Распечатаем результат
        7.

      7.  print_r ($row);
        8.

      8.  ?>
        9.

    Возвращает

    с результатом выборки или false

    [ Наверх ]

    Forums::GetConference

GetConference(
int
$forums_conference_id );

    Описание

    Метод для получения информации о конференции.

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции.
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_conference_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetConference($forums_conference_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает ассоциативный массив с информацией о конференции.

    [ Наверх ]

    Forums::GetConferencePath

GetConferencePath(
int
$forums_conference_id );

    Описание

    Получение пути к конференции по ее идентификатору

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_conference_id = 1;
      5.

    5.
      6.

    6.  $path = $Forums->GetConferencePath($forums_conference_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $path;
      10.

    10.  ?>
      11.

    Возвращает

    путь к конференции или false, если конференция не найдена

    [ Наверх ]

    Forums::GetCountMessageTheme

GetCountMessageTheme(
int
$forums_theme_id );

    Описание

    Получение количества сообщений в теме

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_theme_id = 1;
      5.

    5.
      6.

    6.  $count = $Forums->GetCountMessageTheme($forums_theme_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    количество сообщений

    [ Наверх ]

    Forums::GetForum

GetForum(
int
$forums_id );

    Описание

    Получение информации о форуме

    Принимаемые параметры

    $forums_id

    идентификатор форума
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetForum($forums_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с данными о форуме или ложь, если форум не найден

    [ Наверх ]

    Forums::GetForumAccess

GetForumAccess(
int
$forums_id );

    Описание

    Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму

    Принимаемые параметры

    $forums_id

    идентификатор форума
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetForumAccess($forums_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив идентификаторов групп пользователей сайта

    [ Наверх ]

    Forums::GetForumAndItemIdFromPath

GetForumAndItemIdFromPath(
int
$forums_conference_id, [array
$path_array = array()] );

    Описание

    Получение данных об идентификаторе форума и темы по переданному массиву с элементами пути

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    $path_array

    массив с элементами пути, если не передан, используется $GLOBALS['URL_ARRAY']
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_conference_id = 1;
      5.

    5.  $path_array = $GLOBALS['URL_ARRAY'];
      6.

    6.
      7.

    7.  $row = $Forums->GetForumAndItemIdFromPath($forums_conference_id, $path_array);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    $result['forum'] - идентификатор форума или false
    $result['theme'] - идентификатор темы или false

    [ Наверх ]

    Forums::GetForumsGroup

GetForumsGroup(
int
$forums_group_id );

    Описание

    Метод возвращает информацию о группе форумов

    Принимаемые параметры

    $forums_group_id

    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_group_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetForumsGroup($forums_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с ифнормацией о группе форумов или false, если группа с указанным идентификатором отсутствует

    [ Наверх ]

    Forums::GetForumsUsersGroupList

GetForumsUsersGroupList(
int
$forums_users_group_list_id );

    Описание

    Получение данных о связи группы пользователей с форумом

    Принимаемые параметры

    $forums_users_group_list_id

    Идентификатор связи
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_users_group_list_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetForumsUsersGroupList($forums_users_group_list_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив данных, либо False

    [ Наверх ]

    Forums::GetForumView

GetForumView(
$site_users_id
$site_users_id, $forums_id
$forums_id );

    Описание

    Получение информации о дате последнего просмотра форума пользователем

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $forums_id

    идентификатор форума

    Возвращает

    массив или false

    [ Наверх ]

    Forums::GetLastPageTheme

GetLastPageTheme(
int
$forums_theme_id );

    Описание

    Получение номера последней страницы темы

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_theme_id = 1;
      5.

    5.
      6.

    6.  $page = $Forums->GetLastPageTheme($forums_theme_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $page;
      10.

    10.  ?>
      11.

    Возвращает

    номер последней страницы темы

    [ Наверх ]

    Forums::GetMessage

GetMessage(
int
$forums_message_id );

    Описание

    Получение информации о сообщении

    Принимаемые параметры

    $forums_message_id

    идентификатор сообщения
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_message_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetMessage($forums_message_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает ассоциативный массив с информацией о сообщении

    [ Наверх ]

    Forums::GetTheme

GetTheme(
int
$forums_theme_id );

    Описание

    Метод возвращает информацию о теме форума

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_theme_id = 1;
      5.

    5.
      6.

    6.  $row = $Forums->GetTheme($forums_theme_id);
      7.

    7.
      8.

    8.  //Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с данными или ложь, если тема не найдена

    [ Наверх ]

    Forums::GetThemeId

GetThemeId(
 );

    Описание

    Получение идентификатора добавленнной темы форума

    Возвращает

    идентификатор добавленной темы форума

    [ Наверх ]

    Forums::GetThemeLastMessage

GetThemeLastMessage(
$forums_theme_id
$forums_theme_id );

    Описание

    Получение последнего сообщения темы

    Принимаемые параметры

    $forums_theme_id

    идентификатор темы

    Возвращает

    массив или false

    [ Наверх ]

    Forums::GetThemeView

GetThemeView(
$site_users_id
$site_users_id, $forums_theme_id
$forums_theme_id );

    Описание

    Получение информации о дате последнего просмотра темы форума пользователем

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $forums_theme_id

    идентификатор темы форума

    Возвращает

    массив или false

    [ Наверх ]

    Forums::GetTmpId

GetTmpId(
 );

    [ Наверх ]

    Forums::IncCountMessage

IncCountMessage(
int
$site_users_id );

    Описание

    Метод наращивания счётчика количества сообщений для пользователя

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      5.

    5.  if (class_exists('SiteUsers'))
      6.

    6.  {
      7.

    7.      $SiteUsers = & singleton('SiteUsers');
      8.

    8.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      $site_users_id = 0;
      13.

    13.  }
      14.

    14.
      15.

    15.  $result = $Forums->IncCountMessage($site_users_id);
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  echo $result;
      19.

    19.  ?>
      20.

    [ Наверх ]

    Forums::IndexationForums

IndexationForums(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Описание

    Метод индексации форумов

    Принимаемые параметры

    $limit

    сколько записей проиндексировано

    $on_step

    сколько индексировать

    $parameters

    массив дополнительных параметров
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $limit = 0;
      5.

    5.  $on_step = 10;
      6.

    6.
      7.

    7.  $row = $Forums->IndexationForums($limit, $on_step);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив данных для индексации:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string текст страницы;
      $result[$i][3] float размер страницы;
      $result[$i][4] int идентификатор сайта (0 - для всех сайтов);
      $result[$i][5] array массив идентификаторов групп пользователей (0 - для всех)  $result[$i][6] string дата создания страницы

    [ Наверх ]

    Forums::IndexationForumsMessages

IndexationForumsMessages(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Описание

    Метод индексации сообщений тем форумов

    Принимаемые параметры

    $limit

    сколько записей проиндексировано

    $on_step

    сколько индексировать

    $parameters

    массив дополнительных параметров
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $limit = 0;
      5.

    5.  $on_step = 10;
      6.

    6.
      7.

    7.  $row = $Forums->IndexationForumsMessages($limit, $on_step);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив данных для индексации:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string текст страницы;
      $result[$i][3] float размер страницы;
      $result[$i][4] int идентификатор сайта (0 - для всех сайтов);
      $result[$i][5] array массив идентификаторов групп пользователей (0 - для всех)  $result[$i][6] string дата создания страницы

    [ Наверх ]

    Forums::InsertConference

InsertConference(
array
$param );

    Описание

    Метод, осуществляющий вставку информации о конференции.

    Принимаемые параметры

    $param

    ассоциативный массив параметров
     string $param['forums_conference_name'] название конференции
     string $param['forums_conference_description'] описание конференции
     int $param['structure_id'] узел структуры
     int $param['forums_conference_on_page_theme'] максимальное количество тем, которое может отображаться на странице
     int $param['forums_conference_on_page_message'] максимальное количество сообщений, которое может отображаться на странице
     int $param['forums_conference_flude_protection'] время задержки для защиты от флуда
     int $param['forums_conference_edit_time'] время, в течение которого можно редактировать свои сообщений
     int $param['forums_conference_del_time'] время, в течение которого можно удалять свои сообщений
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $param['forums_conference_name'] = 'Новая конференция';
      5.

    5.  $param['forums_conference_description'] = 'Описание конференции';
      6.

    6.  $param['structure_id'] = 36;
      7.

    7.  $param['forums_conference_on_page_theme'] = 10;
      8.

    8.  $param['forums_conference_on_page_message'] = 10;
      9.

    9.  $param['forums_conference_flude_protection'] = 5;
      10.

    10.  $param['forums_conference_edit_time'] = 60;
      11.

    11.  $param['forums_conference_del_time'] = 60;
      12.

    12.
      13.

    13.  $newid = $Forums->InsertConference($param);
      14.

    14.
      15.

    15.  // Распечатаем результат
      16.

    16.  echo $newid;
      17.

    17.  ?>
      18.

    Возвращает

    идентификатор вставленной конференции ( false при неудачной вставке)

    [ Наверх ]

    Forums::InsertEditMessage

InsertEditMessage(
array
$param, [array
$external_propertys = array()] );

    Описание

    Добавление/редактирование сообщения

    Принимаемые параметры

    $param

    - $param['forums_conference_id'] идентификатор конференции
    • $param['forums_id'] идентификатор форума
    • $param['forums_theme_id'] идентификатор темы
    • $param['forums_theme_title'] заголовок сообщения
    • $param['forums_message_text'] текст сообщения
    • $param['site_users_id'] идентификатор пользователя сайта
    • $param['xsl_name_add_user'] имя XSL-шаблона для письма пользователю о добавлении
    • $param['xsl_name_add_curator'] имя XSL-шаблона для письма куратору форума о добавлении
    • $param['xsl_name_edit_user'] имя XSL-шаблона для письма пользователю о редактировании
    • $param['xsl_name_edit_curator'] имя XSL-шаблона для письма куратору форума о редактировании
    • $param['forums_message_id'] идентификатор сообщения для редактирования, необязательный параметр
    • $param['content_type_add_user'] по умолчанию 'text/plain'
    • $param['content_type_add_curator'] по умолчанию 'text/plain'
    • $param['content_type_edit_user'] по умолчанию 'text/plain'
    • $param['content_type_edit_curator'] по умолчанию 'text/plain'

    $external_propertys

    массив дополнительных свойств для включения в XML
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $param['forums_conference_id'] = 1;
      5.

    5.  $param['forums_id'] = 1;
      6.

    6.  $param['forums_theme_id'] = 1;
      7.

    7.  $param['forums_theme_title'] = 'Тема_1';
      8.

    8.  $param['forums_message_text'] = 'Текст Тема_1';
      9.

    9.  $param['xsl_name_add_user'] = 'ПисьмоДобавленияСообщенияПользователю';
      10.

    10.  $param['xsl_name_add_curator'] = 'ПисьмоОДобавленииСообщения';
      11.

    11.  $param['xsl_name_edit_user'] = 'ПисьмоРедактированияСообщенияПользователю';
      12.

    12.  $param['xsl_name_edit_curator'] = 'ПисьмоРедактированияСообщенияКуратору';
      13.

    13.
      14.

    14.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      15.

    15.  if (class_exists('SiteUsers'))
      16.

    16.  {
      17.

    17.      $SiteUsers = & singleton('SiteUsers');
      18.

    18.     $site_users_id = $SiteUsers->GetCurrentSiteUser();
      19.

    19.  }
      20.

    20.  else
      21.

    21.  {
      22.

    22.      $site_users_id = 0;
      23.

    23.  }
      24.

    24.
      25.

    25.  $param['site_users_id'] = $site_users_id;
      26.

    26.
      27.

    27.  $result = $Forums->InsertEditMessage($param);
      28.

    28.
      29.

    29.  // Распечатаем результат
      30.

    30.  echo $result;
      31.

    31.  ?>
      32.

    [ Наверх ]

    Forums::InsertForum

InsertForum(
array
$param );

    Описание

    Добавление/редактирование форума

    Принимаемые параметры

    $param

    массив параметров
     int $param['forums_id'] идентификатор форума
     int $param['forums_group_id'] идентификатор группы форумов
     string $param['forums_name'] название форума
     string $param['forums_description'] описание форума
     string $param['forums_curator_email'] E-mail куратора форума
     int $param['forums_postmoderation'] использовать ли постмодерацию (0 - нет, 1 - да)
     int $param['visible4all'] отображать ли содержимое форума всем посетителям (0 - нет, 1 - да)
     int $param['forums_captcha_used'] использовать ли CAPTCHA (0 - нет, 1 - да)
     int $param['forums_allow_guest'] разрешить добавлять сообщения гостям (0 - нет, 1 - да)
     int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $param['forums_id'] = 0;
      5.

    5.  $param['forums_group_id'] = 1;
      6.

    6.  $param['forums_name'] = 'Новый форум';
      7.

    7.  $param['forums_description'] = 'Описание форума';
      8.

    8.  $param['forums_curator_email'] = 'admin@site.ru';
      9.

    9.  $param['forums_postmoderation'] = 0;
      10.

    10.  $param['visible4all'] = 0;
      11.

    11.  $param['forums_captcha_used'] = 0;
      12.

    12.  $param['forums_allow_guest'] = 0;
      13.

    13.
      14.

    14.  $newid = $Forums->InsertForum($param);
      15.

    15.
      16.

    16.  // Распечатаем результат
      17.

    17.  echo $newid;
      18.

    18.  ?>
      19.

    Возвращает

    идентификатор вставленной/обновленной записи

    [ Наверх ]

    Forums::InsertForumsGroup

InsertForumsGroup(
int
$forums_group_id, string
$forums_group_name, string
$forums_group_comment, int
$forums_conference_id, [int
$users_id = false] );

    Описание

    Метод добавления/редактирования группы форумов

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $forums_group_name

    название группы форумов

    $forums_group_comment

    коментарий к группе форумов

    $forums_conference_id

    идентификатор конференции.

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_group_id = 0;
      5.

    5.  $forums_group_name = 'Group1';
      6.

    6.  $forums_group_comment = 'Коментарий к группе форумов';
      7.

    7.  $forums_conference_id = 1;
      8.

    8.
      9.

    9.  $newid = $Forums->InsertForumsGroup($forums_group_id, $forums_group_name, $forums_group_comment, $forums_conference_id);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    Возвращает

    идентификатор вставленной/обновленной записи

    [ Наверх ]

    Forums::InsertForumView

InsertForumView(
$site_users_id
$site_users_id, $forums_theme_id
$forums_theme_id, [$forums_view_datetime
$forums_view_datetime = false] );

    Описание

    Вставка информации о дате последнего посещения темы форума пользователем.

    Если пользователь уже посещал тему, то информация о дате посещения обновится.

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $forums_theme_id

    идентификатор темы форума

    $forums_view_datetime

    дата время в формате MySQL или false.  Если указано false - устанавливется текущее дата-время. Необязательное поле.

    [ Наверх ]

    Forums::InsertTheme

InsertTheme(
array
$param );

    Описание

    Вставка/обновление информации о теме

    Принимаемые параметры

    $param

    дополнительные праметры
    • int $param['forums_theme_id'] идентификатор темы форума, необязательный параметр
    • int $param['forums_id'] идентификатор форума
    • int $param['forums_theme_visible'] тема видима
    • int $param['forums_theme_notice'] тема является объявлением
    • int $param['forums_theme_close'] тема закрыта
    • int $param['forums_theme_send_letter'] оповещать создателя темы о новых сообщениях
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $param['forums_id'] = 1;
        5.

      5.  $param['forums_theme_visible'] = 1;
        6.

      6.  $param['forums_theme_notice'] = 0;
        7.

      7.  $param['forums_theme_close'] = 0;
        8.

      8.
        9.

      9.  $newid = $Forums->InsertTheme($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $newid;
        13.

      13.  ?>
        14.

    Возвращает

    результат вставки

    [ Наверх ]

    Forums::InsertThemeUserSubscribe

InsertThemeUserSubscribe(
array
$param );

    Описание

    Подписка пользователя сайта на тему форума

    Принимаемые параметры

    $param

    массив параметров
    • $param['theme_id'] идентификатор темы форума
    • $param['site_user_id'] идентификатор пользователя сайта

    [ Наверх ]

    Forums::InsertUsersGroup

InsertUsersGroup(
int
$forums_id, int
$site_users_group_id, int
$moderator, int
$users_id );

    Описание

    Метод добавления/редактирования группы пользователей для определения доступа к форуму

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_group_id

    идентификатор группы пользователей

    $moderator

    является ли эта группа модераторами (0 - нет, 1 - да)

    $users_id

    идентификатор пользователя центра администрирования, добавившего запись
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.  $site_users_group_id = 7;
      6.

    6.  $moderator = 1;
      7.

    7.
      8.

    8.  $result = $Forums->InsertUsersGroup($forums_id, $site_users_group_id, $moderator);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.     echo "Доступ разрешен";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.     echo "Ошибка получения доступа";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    Forums::IssetForumAccess

IssetForumAccess(
$forums_id
$forums_id, [$site_users_id
$site_users_id = false], [$is_moderator
$is_moderator = true] );

    Описание

    Определение доступа пользователя к форуму

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_id

    идентификатор пользователя сайта

    $is_moderator

    проверять на принадлежность пользователя группе модераторов

    [ Наверх ]

    Forums::IssetThemeUserSubscribe

IssetThemeUserSubscribe(
array
$param );

    Описание

    Проверка подписки пользователя сайта на тему форума

    Принимаемые параметры

    $param

    массив параметров
    • $param['theme_id'] идентификатор темы форума
    • $param['site_user_id'] идентификатор пользователя сайта

    [ Наверх ]

    Forums::MessageIsTheme

MessageIsTheme(
int
$forum_theme_id, int
$forum_message_id );

    Описание

    Проверка сообщения на то, что является ли оно темой

    Принимаемые параметры

    $forum_theme_id

    идентификатор темы

    $forum_message_id

    идентификатор сообщения

    [ Наверх ]

    Forums::NoticeTheme

NoticeTheme(
int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Описание

    Метод делающий тему объявлением или наоборот

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.  $forums_theme_id = 1;
      6.

    6.
      7.

    7.  $result = $Forums->NoticeTheme($forums_id, $forums_theme_id);
      8.

    8.
      9.

    9.  //Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Forums::OrderForums

OrderForums(
int
$forums_group_id, array
$mas_orders );

    Описание

    Метод изменения порядка сортировки форумов в группе

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $mas_orders

    массив коэффициентов вида $mas_orders['order<идентификатор форума>']
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_group_id = 1;
      5.

    5.  $mas_orders['order1'] = 20;
      6.

    6.  $mas_orders['order2'] = 10;
      7.

    7.
      8.

    8.  $result = $Forums->OrderForums($forums_group_id, $mas_orders);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $result;
      12.

    12.  ?>
      13.

    [ Наверх ]

    Forums::OrderForumsGroup

OrderForumsGroup(
array
$mas_orders );

    Описание

    Метод изменения порядка сортировки групп форумов

    Принимаемые параметры

    $mas_orders

    массив коэффициентов вида $mas_orders['order<идентификатор группы форумов>']
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $mas_orders['order1'] = 20;
      5.

    5.  $mas_orders['order2'] = 10;
      6.

    6.
      7.

    7.  $result = $Forums->OrderForumsGroup($mas_orders);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Forums::SearchIndexing

SearchIndexing(
$limit
$limit, $on_step
$on_step );

    Описание

    Функция обратного вызова для поисковой индексации данных модуля

    Принимаемые параметры

    $limit

    текущая позиция

    $on_step

    шаг

    [ Наверх ]

    Forums::SelectFormThemes

SelectFormThemes(
mixed
$forums_id, int
$item_begin, int
$items_count, [array
$param = array()] );

    Описание

    Получение результата запроса на выборку тем форума

    Принимаемые параметры

    $forums_id

    идентификатор или массив идентификаторов форума

    $item_begin

    номер записи, с которой надо начать выборку

    $items_count

    число записей в выборке

    $param

    массив дополнительных параметров
    • $param['order_by_forums_theme_notice'] показывать темы-объявления в начале списка, по умочланию true
    • $param['OrderField'] поле сортировки, по умолчанию 'datetime_max'.
     Возможны сортировки по 'datetime_max', 'datetime_min', 'count' и другим полям.
    • $param['OrderType'] направление сортировки, по умолчанию DESC

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $forums_id = 1;
        5.

      5.  $item_begin = 0;
        6.

      6.  $items_count = 5;
        7.

      7.
        8.

      8.  $resource = $Forums->SelectFormThemes($forums_id, $item_begin, $items_count);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  while($row = mysql_fetch_assoc($resource))
        12.

      12.  {
        13.

      13.      print_r($row);
        14.

      14.  }
        15.

      15.  ?>
        16.

    Возвращает

    в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Forums::SelectForumsGroup

SelectForumsGroup(
int
$forums_group_id );

    Описание

    Устарвший метод, возвращающий информацию о группе форумов

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов (-1 выбрать все)

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    [ Наверх ]

    Forums::SelectMessage

SelectMessage(
int
$forums_message_id );

    Описание

    Метод возвращающий информацию о сообщении

    Принимаемые параметры

    $forums_message_id

    идентификатор сообщения
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_message_id = 1;
      5.

    5.
      6.

    6.  $resource = $Forums->SelectMessage($forums_message_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    [ Наверх ]

    Forums::SelectThemeSubscribers

SelectThemeSubscribers(
int
$theme_id );

    Описание

    Получение списка подписчиков на тему форума

    Принимаемые параметры

    $theme_id

    идентификатор темы форума

    [ Наверх ]

    Forums::SelectUserSubscriptions

SelectUserSubscriptions(
int
$site_users_id );

    Описание

    Получение списка подписанных тем форума

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    [ Наверх ]

    Forums::SetModerator

SetModerator(
int
$forums_users_group_list_id );

    Описание

    Метод установления/снятия прав модератора текущего форума для группы пользователей

    Принимаемые параметры

    $forums_users_group_list_id

    идентификатор в таблице связи форумов и групп пользователей
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_users_group_list_id = 1;
      5.

    5.
      6.

    6.  $result = $Forums->SetModerator($forums_users_group_list_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Права установлены";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка установки прав";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Forums::SetThemeId

SetThemeId(
int
$theme_id );

    Описание

    Установка значения идентификатора добавленной темы форума

    Принимаемые параметры

    $theme_id

    идентификатор добавленной темы форума

    [ Наверх ]

    Forums::ShowAddEditTheme

ShowAddEditTheme(

$conference_id, int
$forums_id, int
$theme_id, stringe
$xslname, [
$external_propertys = array()], [array
$param = array()], int
$site_users_id, int
$current_page );

    Описание

    Формирование XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    $xslname

    имя xsl шаблона

    $param

    массив параметров темы:
      $param['theme_close'] int флаг закрытости темы;
      $param['theme_notice'] int флаг объявления;
      $param['theme_visible'] int флаг видимости;
      $param['theme_title'] string заголовок темы;
      $param['theme_message_text'] string текст первого сообщения;
      $param['theme_send_letter'] string отправлять письма с ответами на тему;
      $param['site_users_id'] идентификатор пользователя сайта, если не передан - определяется автоматически  $param['current_page'] int индекс текущей страницы
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $conference_id = 1;
      5.

    5.  $forums_id = 1;
      6.

    6.  $theme_id = 1;
      7.

    7.  $xslname = 'СозданиеТемы';
      8.

    8.
      9.

    9.  $Forums->ShowAddEditTheme($conference_id, $forums_id, $theme_id, $xslname);
      10.

    10.  ?>
      11.

    $conference_id

    $external_propertys

    [ Наверх ]

    Forums::ShowConference

ShowConference(
int
$conference_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Описание

    Метод отображения конференции

    Принимаемые параметры

    $conference_id

    идентификатор конференции

    $xslname

    имя XSL-шаблона для отображения

    $external_propertys

    массив внешних параметров, передающихся в XML

    $param

    массив дополнительных параметров
    • $param['site_users_id'] - идентификатор пользователя сайта, если не передан - определяется автоматически

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $conference_id = 1;
        5.

      5.  $xslname = 'Форумы';
        6.

      6.
        7.

      7.  $Forums->ShowConference($conference_id, $xslname);
        8.

      8.
        9.

      9.  ?>
        10.

    Возвращает

    -1 -- Конференция с указанным кодом не найдена

    [ Наверх ]

    Forums::ShowEditMessage

ShowEditMessage(

$conference_id, int
$forums_id, int
$forums_theme_id, int
$forums_message_id, string
$xslname, [
$external_propertys = array()], [array
$param = array()], int
$site_users_id, int
$current_page_theme, int
$current_page_message, string
$error='' );

    Описание

    Формирование XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_message_id

    идентификатор сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    $param

    массив параметров сообщения:
      $param['message_theme'] string тема собщения;
      $param['message_текст'] string текст сообщения
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $conference_id = 1;
      5.

    5.  $forums_id = 1;
      6.

    6.  $forums_theme_id = 5;
      7.

    7.  $forums_message_id = 8;
      8.

    8.  $xslname = 'РедактированиеСообщения';
      9.

    9.
      10.

    10.  $Forums->ShowEditMessage($conference_id, $forums_id, $forums_theme_id, $forums_message_id, $xslname);
      11.

    11.  ?>
      12.

    $conference_id

    $external_propertys

    [ Наверх ]

    Forums::ShowForumRss

ShowForumRss(
int
$forums_id, [int
$items_on_page = 10], [int
$items_begin = 0], [array
$property = array()] );

    Описание

    Отображение RSS ленты

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $items_on_page

    количество выводимых записей в ленте

    $items_begin

    параметр, определяющий с какой записи начинать вывод

    $property

    массив дополнительных параметров
    • $property['title'] string Заголовок канала
    • $property['description'] string Краткое описание RSS-канала
    • $property['link'] string Ссылка на сайт
    • $property['image'] Картинка для представления канала (необязательный элемент)
    • $property['image']['url'] string Ссылка на файл изображения
    • $property['image']['title'] string Заменяющий текст для изображения
    • $property['image']['link'] string Ссылка для перехода при щелчке по изображению
    • $property['yandex:full-text'] bool Вывод полного текста для Яндекс, по умолчанию false
    • $property['strip-tags'] bool Указывает на необходимость удаления тегов из содержания RSS, по умолчанию false
    • $property['show-image'] bool Разрешает передачу картинки для информационного элемента в теге enclosure

    [ Наверх ]

    Forums::ShowMessage

ShowMessage(
int
$forums_conference_id, int
$forums_id, int
$forums_theme_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Описание

    Метод отображения сообщений форума

    Принимаемые параметры

    $forums_conference_id

    идентификатор конференции

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $xslname

    наименование XSL-шаблона

    $external_propertys

    массив внешних параметров, передающихся в XML

    $param

    массив дополнительных параметров
    • $param['site_users_id'] - Идентификатор пользователя сайта, если не переда -- определяется автоматически
    • $param['current_page_theme'] - Номер текущей страницы тем
    • $param['current_page_message'] - Номер текущей страницы сообщений
    • $param['items_on_page'] - Число сообщений на страницу, если не передан, то определяется автоматически
    • $param['message_theme'] - Тема сообщения
    • $param['message_text'] - Текст сообщения

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $forums_conference_id = 1;
        5.

      5.  $forums_id = 1;
        6.

      6.  $forums_theme_id = 4;
        7.

      7.  $xslname = 'СообщенияТемы';
        8.

      8.
        9.

      9.  $Forums->ShowMessage($forums_conference_id, $forums_id, $forums_theme_id, $xslname);
        10.

      10.  ?>
        11.

    [ Наверх ]

    Forums::ShowSiteUserInfo

ShowSiteUserInfo(
int
$conference_id, int
$forums_id, int
$theme_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Описание

    Отображение данных о пользователе форума

    Принимаемые параметры

    $conference_id

    идентификатор конференции

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $xslname

    имя xsl шаблона

    $external_propertys

    массив внешних данных, передаваемых в XML
    $external_propertys['current_page_message'] - идентификатор текущего сообщения
    $external_propertys['error'] - сообщение об ошибке

    $param

    массив дополнительных параметров  $param['site_users_id'] - идентификатор пользователя сайта, если не передан - определяется автоматически
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $conference_id = 1;
      5.

    5.  $forums_id = 1;
      6.

    6.  $theme_id = 1;
      7.

    7.  $xslname = 'АнкетныеДанные';
      8.

    8.
      9.

    9.  $result = $Forums->ShowSiteUserInfo($conference_id, $forums_id, $theme_id, $xslname);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $result;
      13.

    13.  ?>
      14.

    [ Наверх ]

    Forums::ShowThemes

ShowThemes(
int
$conference_id, int
$forums_id, string
$xslname, [array
$external_propertys = array()], [array
$param = array()] );

    Описание

    Метод отображения тем форума

    Принимаемые параметры

    $conference_id

    идентификатор конференции

    $forums_id

    идентификатор форума

    $xslname

    имя XSL-шаблона для отображения тем форума

    $external_propertys

    массив внешних параметров, передающихся в XML

    $param

    массив дополнительных параметров
    • $param['site_users_id'] - идентификатор пользоватлея сайта, если не передан - определяется автоматически
    • $param['current_page_theme'] - номер текущей страницы, по умолчанию 0
    • $param['items_on_page'] - число тем на страницу, по умолчанию 10

      1.  <?php
        2.

      2.  $Forums = new Forums();
        3.

      3.
        4.

      4.  $conference_id = 1;
        5.

      5.  $forums_id = 1;
        6.

      6.  $xslname = 'ТемыФорума';
        7.

      7.
        8.

      8.  $Forums->ShowThemes($conference_id, $forums_id, $xslname);
        9.

      9.  ?>
        10.

    see

    Forums::SelectFormThemes()

    [ Наверх ]

    Forums::ShowUserMessages

ShowUserMessages(
array
$param, [array
$external_propertys = array()] );

    Описание

    Показ сообщений пользователя

    Принимаемые параметры

    $param

    массив параметров
    • $param['site_users_id'] идентификатор пользователя сайтов
    • $param['forums_conference_id'] идентификатор конференции
    • $param['xsl_name'] имя XSL-шаблона отображения списка сообщений
    • $param['messages_on_page'] количество сообщений, отображаемых на странице
    • $param['messages_begin'] номер сообщения, с которого начинать отображение (по умолчанию равен 0)

    $external_propertys

    массив дополнительных свойств для включения в XML

    [ Наверх ]

    Forums::Smile2HTML

Smile2HTML(
string
$text );

    Описание

    Метод замены смайликов на HTML

    Принимаемые параметры

    $text

    исходный текст
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $text = ':-)';
      5.

    5.
      6.

    6.  $result = $Forums->Smile2HTML($text);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    текст после замены

    [ Наверх ]

    Forums::TypographText

TypographText(
str
$text );

    Описание

    Типографирование текста с использованием модуля "Типограф"

    Принимаемые параметры

    $text

    текст

    Возвращает

    текст

    [ Наверх ]

    Forums::UserIsModerator

UserIsModerator(
int
$forums_id, int
$site_users_id );

    Описание

    Метод для определения, является ли данный пользователь модератором

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_id

    идентификатор пользователя сайта
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.     $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      $site_users_id = 0;
      15.

    15.  }
      16.

    16.
      17.

    17.  $result = $Forums->UserIsModerator($forums_id, $site_users_id);
      18.

    18.
      19.

    19.  if ($result)
      20.

    20.  {
      21.

    21.      echo "Пользователь является модератором";
      22.

    22.  }
      23.

    23.  else
      24.

    24.  {
      25.

    25.      echo "Пользователь не является модератором";
      26.

    26.  }
      27.

    27.  ?>
      28.

    [ Наверх ]

    Forums::VisibleTheme

VisibleTheme(
int
$forums_id, int
$forums_theme_id, [int
$site_users_id = false] );

    Описание

    Метод, устанавливающий видимость/невидимость темы

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта, необзяталеьный параметр. по умолчанию равен false - определять автоматически.
    1.  <?php
      2.

    2.  $Forums = new Forums();
      3.

    3.
      4.

    4.  $forums_id = 1;
      5.

    5.  $forums_theme_id = 1;
      6.

    6.
      7.

    7.  $result = $Forums->VisibleTheme($forums_id, $forums_theme_id);
      8.

    8.
      9.

    9.  //Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

Описания переменных

  • $CacheGetConference = array() [Строка 30]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetConference()

  • $CacheGetThemeLastMessage = array() [Строка 37]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetThemeLastMessage()

  • $iThemeId =  0 [Строка 44]
    •

  • Data type: int
    •

    Описание

    Идентификатор вставленной темы

  • $iTmpId =  0 [Строка 60]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class graphic

Class graphic

[Строка 14]

Размещен: /Kernel/Graphic.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, методы построения графиков.
Файл: /modules/Kernel/graphic.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $angle =  1

        Вращение диаграммы вокруг оси

  • $color = array(
// основные цвета, используемые для рисования диаграммы
"0" => array("r" => 154, "g" => 205, "b" => 50),"1"=>array("r"=>255,"g"=>99,"b"=>71),"2"=>array("r"=>251,"g"=>195,"b"=>0),"3"=>array("r"=>100,"g"=>149,"b"=>237),"4"=>array("r"=>138,"g"=>43,"b"=>226),"5"=>array("r"=>58,"g"=>166,"b"=>0),"6"=>array("r"=>210,"g"=>180,"b"=>140),// 72, 20, 245
"7"=>array("r"=>0,"g"=>206,"b"=>209),"8"=>array("r"=>255,"g"=>0,"b"=>255),"9"=>array("r"=>255,"g"=>140,"b"=>0),"10"=>array("r"=>95,"g"=>158,"b"=>160),"11"=>array("r"=>244,"g"=>164,"b"=>96),"12"=>array("r"=>218,"g"=>3,"b"=>18),"13"=>array("r"=>153,"g"=>50,"b"=>204),"14"=>array("r"=>72,"g"=>20,"b"=>245),"15"=>array("r"=>220,"g"=>20,"b"=>60),"16"=>array("r"=>189,"g"=>183,"b"=>107),"17"=>array("r"=>218,"g"=>165,"b"=>32),// системные цвета, используемые для рисования текста, фона
"18"=>array("r"=>250,"g"=>250,"b"=>250),"19"=>array("r"=>220,"g"=>220,"b"=>220),"20"=>array("r"=>250,"g"=>250,"b"=>250),"21"=>array("r"=>0,"g"=>0,"b"=>0),// Черный
"22"=>array("r"=>255,"g"=>255,"b"=>255),// Белый
"23"=>array("r"=>230,"g"=>230,"b"=>230))
Массив основных цветов
  • $c_dev =  0

        Отклонение углов сегментов

  • $font_name =  'tahoma.ttf'

        Название шрифта

  • $font_path =  ''

        Путь к шрифту

  • $font_size =  8

        Размер шрифта

  • $font_width =  8

        Ширина одного символа в легенде

  • $joint_height =  15

        Высота соединяемых частей

  • $joint_space =  5

        Расстояние между углами сегментов

  • $joint_space_connection =  5

        Расстояние между сегментами

  • $legend_height =  0

        Длина легенды

  • $legend_width =  0

        Ширина легенды

  • $line_width =  1.2

        Ширина линии

  • $max_leght_legend =  15

        Максимальная длина подписи легенды в диаграмме

  • $min_division_x =  17

        Минимальное расстояние между делениями по оси х

  • $min_percent_diagr =  0.9

        Минимальный процент, отображаемый на диаграмме

  • $quality =  10

        Качество рисунка

  • $tilt =  60

        Наклон диаграммы

  • $value_cont =  0

        Число значений элементов, для которых строится диаграмма

  • $x_pos_1_leg =  0

        Х - координата верхнего угла легенды

  • $x_size =  0

        Ширина рисунка

  • $y_pos_1_leg =  0

        Y - координата верхнего угла легенды

  • $y_size =  0

        Высота рисунка

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int ColorAllocateFactor()

    Метод возвращающий оттенок цвета

  • int colors()

    Метод возвращает идентификатор основного цвета

  • string CorrectText()

    Корректировка текста.

  • void Diagramm()

    Метод для рисования диаграммы

  • boolean DrawAlphaPixel()

    Метод для рисования точек с оттенком

  • void DrawFilledRectangle()

    Метод для рисования заполненного прямоугольника

  • void DrawFilledRoundedRectangle()

    Метод для рисования заполненного округленного прямоугольника

  • void DrawLegend()

    Метод для рисования легенды

  • boolean DrawLegend_linear()

    Метод рисует легенду для линейной диаграммы

  • boolean DrawLine()

    Метод для рисования линий поточечно

  • boolean DrawPixel()

    Метод для рисования точек

  • void DrawRectangle()

    Метод для рисования незаполненого прямоугольника

  • void DrawRoundedRectangle()

    Метод для рисования незаполненного округленного прямоугольника.

  • void graphic_diagramma()

    Метод вывода круговой диаграммы

  • boolean graphic_gistogramma()

    Метод вывода гистограммы

  • void Graphic_Linear()

    Метод вывода линейного графика

  • void imagebar()

    Метод вывода гистограммы

  • boolean LinearGraphic()

    Построение линейного графика

  • void ShowEmptyImage()

Унаследованные методы

Описания методов

    graphic::ColorAllocateFactor

ColorAllocateFactor(
int
$im, int
$color_id, int
$color_factor );

    Описание

    Метод возвращающий оттенок цвета

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $color_id

    Идентификатор исходного цвета

    $color_factor

    Коэффициент смещения оттенка

    Возвращает

    Идентификатор оттенка

    [ Наверх ]

    graphic::colors

colors(
int
$im, int
$color_id );

    Описание

    Метод возвращает идентификатор основного цвета

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $color_id

    Порядковый номер цвета

    Возвращает

    Идентификатор основного цвета

    [ Наверх ]

    graphic::CorrectText

CorrectText(
string
$text );

    Описание

    Корректировка текста.

    Принимаемые параметры

    $text

    [ Наверх ]

    graphic::Diagramm

Diagramm(
int
$im, array
$values, array
$LEGEND );

    Описание

    Метод для рисования диаграммы

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $values

    Массив значений элементов диаграммы

    $LEGEND

    Массив подписей диаграммы

    [ Наверх ]

    graphic::DrawAlphaPixel

DrawAlphaPixel(
int
$im, int
$X, int
$Y, int
$alpha, int
$R, int
$G, int
$B );

    Описание

    Метод для рисования точек с оттенком

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X

    Координата х

    $Y

    Координата у

    $alpha

    Коэффициент изменения цвета

    $R

    Значение красного цвета

    $G

    Значение зеленого цвета

    $B

    Значение голубого цвета

    Возвращает

    true в случае успешного выполнения, false иначе

    [ Наверх ]

    graphic::DrawFilledRectangle

DrawFilledRectangle(
int
$im, int
$X1, int
$Y1, int
$X2, int
$Y2, int
$color, [boolean
$DrawBorder = TRUE] );

    Описание

    Метод для рисования заполненного прямоугольника

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X1

    Координата х верхнего левого угла прямоугольника

    $Y1

    Координата у верхнего левого угла прямоугольника

    $X2

    Координата х правого нижнего угла прямоугольника

    $Y2

    Координата у правого нижнего угла прямоугольника

    $color

    Цвет заливки

    $DrawBorder

    Указывает, нужна ли обводка прямоугольника. по умолчанию TRUE.

    [ Наверх ]

    graphic::DrawFilledRoundedRectangle

DrawFilledRoundedRectangle(
int
$im, int
$X1, int
$Y1, int
$X2, int
$Y2, int
$radius, int
$bg_color );

    Описание

    Метод для рисования заполненного округленного прямоугольника

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X1

    Координата х верхнего левого угла прямоугольника

    $Y1

    Координата у верхнего левого угла прямоугольника

    $X2

    Координата х правого нижнего угла прямоугольника

    $Y2

    Координата у правого нижнего угла прямоугольника

    $radius

    Радиус округления углов

    $bg_color

    Цвет заливки

    [ Наверх ]

    graphic::DrawLegend

DrawLegend(
int
$im,
$diagramm_array, array
$values, array
$LEGEND );

    Описание

    Метод для рисования легенды

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $values

    Массив значений элементов диаграммы

    $LEGEND

    Массив подписей диаграммы

    $diagramm_array

    [ Наверх ]

    graphic::DrawLegend_linear

DrawLegend_linear(
int
$im, array
$DATA );

    Описание

    Метод рисует легенду для линейной диаграммы

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $DATA

    Массив со значениями, подписями и легендой
    • $DATA['x'] str Подписи по оси х
    • $DATA[]['name'] str Надписи легенды
    • $DATA[] int Значения диаграммы

    Возвращает

    true в случае успешного выполнения, false в случае ошибки

    [ Наверх ]

    graphic::DrawLine

DrawLine(
int
$im, int
$X1, int
$Y1, int
$X2, int
$Y2, int
$color_id, [int
$color_factor = 0] );

    Описание

    Метод для рисования линий поточечно

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X1

    Х - координата начала линии

    $Y1

    У - координата начала линии

    $X2

    Х - координата конца линии

    $Y2

    У - координата конца линии

    $color_id

    Идентификатор цвета

    $color_factor

    Коэффициент изменения цвета

    Возвращает

    true в случае успешного выполнения, false иначе

    [ Наверх ]

    graphic::DrawPixel

DrawPixel(
int
$im, int
$X, int
$Y, int
$R, int
$G, int
$B, [
$color_factor = 0] );

    Описание

    Метод для рисования точек

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X

    Координата х

    $Y

    Координата у

    $R

    Значение красного цвета

    $G

    Значение зеленого цвета

    $B

    Значение голубого цвета

    $color_factor

    Возвращает

    true в случае успешного выполнения, false иначе

    [ Наверх ]

    graphic::DrawRectangle

DrawRectangle(
int
$im, unknown_type
$X1, unknown_type
$Y1, unknown_type
$X2, unknown_type
$Y2, unknown_type
$color );

    Описание

    Метод для рисования незаполненого прямоугольника

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X1

    $Y1

    $X2

    $Y2

    $color

    [ Наверх ]

    graphic::DrawRoundedRectangle

DrawRoundedRectangle(
int
$im, int
$X1, int
$Y1, int
$X2, int
$Y2, int
$radius, int
$bg_color );

    Описание

    Метод для рисования незаполненного округленного прямоугольника.

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $X1

    Координата х верхнего левого угла прямоугольника

    $Y1

    Координата у верхнего левого угла прямоугольника

    $X2

    Координата х правого нижнего угла прямоугольника

    $Y2

    Координата у правого нижнего угла прямоугольника

    $radius

    Радиус округления углов

    $bg_color

    Цвет заливки

    [ Наверх ]

    graphic::graphic_diagramma

graphic_diagramma(
array
$VALUES, array
$LEGEND, int
$width, [
$max_leght_legend = false] );

    Описание

    Метод вывода круговой диаграммы

    Принимаемые параметры

    $VALUES

    значения (массив со значениями)

    $LEGEND

    подписи (значения легенды, массив строк)

    $width

    - ширина изображения в пикселях

    $max_leght_legend

    [ Наверх ]

    graphic::graphic_gistogramma

graphic_gistogramma(
int_type
$width, int
$height, array
$DATA, [array
$LEGEND = array('Хиты','Сессии','Хосты')], [
$param = array()] );

    Описание

    Метод вывода гистограммы

    Принимаемые параметры

    $width

    ширина гистограммы в пикселях

    $height

    высота гистограммы в пикселях

    $DATA

    массив со значенями для гистограммы

    $LEGEND

    массив подписей для легенды

    $param

    Возвращает

    истина при удачном выводе, ложь - в случае возникновения ошибки

    [ Наверх ]

    graphic::Graphic_Linear

Graphic_Linear(
array
$DATA, array
$LEGEND, [array
$param = array()] );

    Описание

    Метод вывода линейного графика

    Принимаемые параметры

    $DATA

    Массив со значениями и подписями по оси х  $DATA['x'] str подписи  $DATA[0] int значения

    $LEGEND

    Массив с легендой

    $param

    Массив дополнительных параметров

    [ Наверх ]

    graphic::imagebar

imagebar(
int
$im, int
$x, int
$y, int
$w, int
$h, int
$dx, int
$dy, string
$c1, string
$c2, string
$c3 );

    Описание

    Метод вывода гистограммы

    Принимаемые параметры

    $im

    идентификатор изображения

    $x

    координата x верхнего левого угла куба

    $y

    координата y верхнего левого угла куба

    $w

    ширина куба

    $h

    высота куба

    $dx

    смещение задней грани куба по оси X

    $dy

    смещение задней грани куба по оси Y

    $c1

    цвет видимой граней куба

    $c2

    цвет видимой граней куба

    $c3

    цвет видимой граней куба

    [ Наверх ]

    graphic::LinearGraphic

LinearGraphic(
int
$im, array
$DATA, array
$LEGEND, [array
$param = array()] );

    Описание

    Построение линейного графика

    Принимаемые параметры

    $im

    Идентификатор рисунка

    $DATA

    Массив со значениями для графика и подписями для оси х
    • $DATA['x'] str Подписи оси х
    • $DATA[] int Значения

    $LEGEND

    Массив с надписями легенды

    $param

    Массив дополнительных параметров
    • $param['cheakpoint'] boolean Нужно ли отражать значения кружками
    • $param['null'] boolean Нужно ли отображать нулевую отметку на графике
    • $param['divis'] int Число делений по оси у

    Возвращает

    true в случае успешного выполнения, false иначе

    [ Наверх ]

    graphic::ShowEmptyImage

ShowEmptyImage(
 );

    [ Наверх ]

Описания переменных

  • $angle =  1 [Строка 124]
    •

  • Data type: int
    •

    Описание

    Вращение диаграммы вокруг оси

  • $color = array(
// основные цвета, используемые для рисования диаграммы
"0" => array("r" => 154, "g" => 205, "b" => 50),"1"=>array("r"=>255,"g"=>99,"b"=>71),"2"=>array("r"=>251,"g"=>195,"b"=>0),"3"=>array("r"=>100,"g"=>149,"b"=>237),"4"=>array("r"=>138,"g"=>43,"b"=>226),"5"=>array("r"=>58,"g"=>166,"b"=>0),"6"=>array("r"=>210,"g"=>180,"b"=>140),// 72, 20, 245
"7"=>array("r"=>0,"g"=>206,"b"=>209),"8"=>array("r"=>255,"g"=>0,"b"=>255),"9"=>array("r"=>255,"g"=>140,"b"=>0),"10"=>array("r"=>95,"g"=>158,"b"=>160),"11"=>array("r"=>244,"g"=>164,"b"=>96),"12"=>array("r"=>218,"g"=>3,"b"=>18),"13"=>array("r"=>153,"g"=>50,"b"=>204),"14"=>array("r"=>72,"g"=>20,"b"=>245),"15"=>array("r"=>220,"g"=>20,"b"=>60),"16"=>array("r"=>189,"g"=>183,"b"=>107),"17"=>array("r"=>218,"g"=>165,"b"=>32),// системные цвета, используемые для рисования текста, фона
"18"=>array("r"=>250,"g"=>250,"b"=>250),"19"=>array("r"=>220,"g"=>220,"b"=>220),"20"=>array("r"=>250,"g"=>250,"b"=>250),"21"=>array("r"=>0,"g"=>0,"b"=>0),// Черный
"22"=>array("r"=>255,"g"=>255,"b"=>255),// Белый
"23"=>array("r"=>230,"g"=>230,"b"=>230)) [Строка 21]
    •

  • Data type: int
    •

    Описание

    Массив основных цветов

  • $c_dev =  0 [Строка 131]
    •

  • Data type: int
    •

    Описание

    Отклонение углов сегментов

  • $font_name =  'tahoma.ttf' [Строка 75]
    •

  • Data type: str
    •

    Описание

    Название шрифта

  • $font_path =  '' [Строка 82]
    •

  • Data type: str
    •

    Описание

    Путь к шрифту

  • $font_size =  8 [Строка 103]
    •

  • Data type: int
    •

    Описание

    Размер шрифта

  • $font_width =  8 [Строка 110]
    •

  • Data type: int
    •

    Описание

    Ширина одного символа в легенде

  • $joint_height =  15 [Строка 117]
    •

  • Data type: int
    •

    Описание

    Высота соединяемых частей

  • $joint_space =  5 [Строка 138]
    •

  • Data type: int
    •

    Описание

    Расстояние между углами сегментов

  • $joint_space_connection =  5 [Строка 89]
    •

  • Data type: int
    •

    Описание

    Расстояние между сегментами

  • $legend_height =  0 [Строка 68]
    •

  • Data type: int
    •

    Описание

    Длина легенды

  • $legend_width =  0 [Строка 61]
    •

  • Data type: int
    •

    Описание

    Ширина легенды

  • $line_width =  1.2 [Строка 158]
    •

  • Data type: int
    •

    Описание

    Ширина линии

  • $max_leght_legend =  15 [Строка 200]
    •

  • Data type: int
    •

    Описание

    Максимальная длина подписи легенды в диаграмме

  • $min_division_x =  17 [Строка 172]
    •

  • Data type: int
    •

    Описание

    Минимальное расстояние между делениями по оси х

  • $min_percent_diagr =  0.9 [Строка 193]
    •

  • Data type: float
    •

    Описание

    Минимальный процент, отображаемый на диаграмме

  • $quality =  10 [Строка 165]
    •

  • Data type: int
    •

    Описание

    Качество рисунка

  • $tilt =  60 [Строка 96]
    •

  • Data type: int
    •

    Описание

    Наклон диаграммы

  • $value_cont =  0 [Строка 54]
    •

  • Data type: int
    •

    Описание

    Число значений элементов, для которых строится диаграмма

  • $x_pos_1_leg =  0 [Строка 145]
    •

  • Data type: int
    •

    Описание

    Х - координата верхнего угла легенды

  • $x_size =  0 [Строка 179]
    •

  • Data type: int
    •

    Описание

    Ширина рисунка

  • $y_pos_1_leg =  0 [Строка 151]
    •

  • Data type: int
    •

    Описание

    Y - координата верхнего угла легенды

  • $y_size =  0 [Строка 186]
    •

  • Data type: int
    •

    Описание

    Высота рисунка

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class helpdesk

Class helpdesk

[Строка 16]

Размещен: /helpdesk/helpdesk.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Службы техподдержки".
Файл: /modules/helpdesk/helpdesk.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheGetAttachment = array ()

        Кэш для метода GetAttachment()

  • $CacheGetCriticalLevel = array ()

        Кэш для метода GetCriticalLevel()

  • $CacheGetEmail = array ()

        Кэш для метода GetEmail()

  • $CacheGetFirstMessageTicket = array ()

        Кэш для метода GetFirstMessageTicket()

  • $CacheGetHelpdesk = array ()

        Кэш для метода GetHelpdesk()

  • $CacheGetInfo4Messages = array ()

        Кэш для метода GetInfo4Messages()

  • $CacheGetMessage = array ()

        Кэш для метода GetMessage()

  • $CacheGetResponsible = array ()

        Кэш для метода GetResponsible()

  • $CacheGetSiteUserByEmail = array ()

        Кэш для метода GetSiteUserByEmail()

  • $CacheGetStatus = array ()

        Кэш для метода GetStatus()

  • $CacheGetTemplate = array ()

        Кэш для метода GetTemplate()

  • $CacheGetTemplateDir = array ()

        Кэш для метода GetTemplateDir()

  • $CacheGetTemplateKeyWords = array ()

        Кэш для метода GetTemplateKeyWords()

  • $CacheGetTicket = array ()

        Кэш для метода GetTicket()

  • $CacheGetTicketByName = array ()

        Кэш для метода GetTicketByName()

  • $CacheGetTicketCategory = array ()

        Кэш для метода GetTicketCategory()

  • $CacheGetTicketFlags = array ()

        Кэш для метода GetTicketFlags()

  • $CacheGetWeekend = array ()

        Кэш для метода GetWeekend()

  • $CacheGetWorkTime = array ()

        Кэш для метода GetWorkTime()

  • $CountDays4FirstWorkDay =  0

        Число дней до первого рабочего

  • $MessageTree =  ''

        Дерево сообщений тикета

  • $Path = array ()

        Массив, содержащий путь от корневой категории

  • $sAllowTag =  '<style><b><strong><p><br><br/><br /><li><ol><ul><pre><em><i><table><tr><td><tbody><h1><h2><h3><h4><h5><h6>'

  • $StructuredList = array ()

        Массив, содержащий структурированный список директорий

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • bool AccessToAttachment()

    Проверка доступа пользователя сайта к вложенным файлам

  • mixed AnalizeForKeyWords()

    Анализ сообщения на предмет содержания ключевых слов для стандартных ответов.

  • mixed BuildSubject()

    Формирование темы сообщения в соответствии с масками имени тикета и номера сообщения

  • bool CloseOldTicket()

    Закрытие старых (ответ на которые дан более 10 дней назад) тикетов

  • bool CombineTickets()

    Объединение тикетов

  • mixed CopyCriticalLevel()

    Копирование информации об уровне критичности

  • mixed CopyEmail()

    Копирование информации об электронном адресе службы поддержки

  • mixed CopyHelpdesk()

    Копирование службы поддержки

  • mixed CopyStatus()

    Копирование статуса сообщения

  • mixed CopyTemplateKeyWords()

    Копирование ключевого слова

  • mixed CopyTicketCategory()

    Копирование категории тикетов

  • mixed CopyTicketFlag()

    Копирование флага тикетов

  • str CutQuotetion()

    Удаление из текста сообщения цитаты

  • mixed DeleteAttachments()

    Удаление информации о вложенных файлах в сообщениях

  • mixed DeleteCriticalLevel()

    Удаление информации об уровне критичности

  • mixed DeleteEmail()

    Удаление информациии об электронном адресе

  • mixed DeleteHelpdesk()

    Удаление информации о службе технической поддержки

  • mixed DeleteMessage()

    Удаление сообщения

  • resource DeleteResponsible()

    Удаление ответственного пользователя

  • mixed DeleteStatus()

    Удаление статуса сообщений

  • mixed DeleteSupportWoktime()

    Удаление рабочего дня службы технической поддержки

  • mixed DeleteTemplate()

    Удаление стандартного ответа

  • mixed DeleteTemplateDir()

    Удаление группы стандартных ответов

  • resource DeleteTemplateKeyWords()

    Удаление ключевого слова

  • mixed DeleteTicket()

    Удаление информациии об инциденте

  • mixed DeleteTicketCategory()

    Удаление информации о категории инцидентов

  • mixed DeleteTicketFlags()

    Удаление информации о флаге для тикетов

  • resource DeleteWeekend()

    Удаление информации о специальном рабочем/выходном дне

  • mixed GenXml4Helpdesk()

    Формирование XML для службы техподдержки

  • mixed GenXml4Message()

    Формирование XML для сообщений

  • mixed GenXml4Ticket()

    Формирование XML для тикета

  • str GenXml4TicketCategory()

    Формирование XML для категорий тикетов

  • mixed GenXml4WorkTime()

    Формирование XML для режима работы службы техподдержки

  • mixed GetAllAttachments()

    Получение вложенных файлов сообщения

  • resource GetAllBlockedMessages()

    Получение всех заблокированных сообщений тикета

  • resource GetAllCriticalLevel()

    Получение информации обо всех уровнях критичности. Если передан параметр $helpdesk_id, то выбираются уровни критичности службы техподдержки с id $helpdesk_id

  • resource GetAllEmail()

    Получение информации обо всех электронных адресах службы техподдержки

  • resource GetAllFlags()

    Получение списка флагов

  • resource GetAllHelpdesk()

    Получение информации обо всех службах техподдержки на конкретном сайте. Если параметр $site_id не передан, или равен false - выбирается информация обо всех службах техподдержки.

  • resource GetAllMessage()

    Получение списка сообщений, относящихся к тикету с идентификатором $helpdesk_ticket_id. Если задан параметр $helpdesk_message_id, выбираются все сообщения, кроме сообщения с id $helpdesk_message_id.

  • resource GetAllMessageWithParentId()

    Получение списка сообщений, дочерних по отношению к сообщению с id $helpdesk_message_parent_id

  • resource GetAllResponsible()

    Получение информации обо всех ответственных лицах

  • resource GetAllStatus()

    Получение списка статусов. Если передан параметр $helpdesk_id, то выбираются сообщения, относящиеся к службе техподдержки с идентификатором $helpdesk_id

  • resource GetAllTemplate()

    Получение списка стандартных ответов службы техподдержки. Если передан параметр $helpdesk_letter_template_dir_id, выбираются все стандартные ответы, принадлежащие категории с этим идентификатором

  • resource GetAllTemplateDir()

    Получение списка групп стандартных ответов.

  • resource GetAllTemplateDirWithParentId()

    Получение списка директорий стандартных ответов, вложенных в директорию с идентификатором $helpdesk_letter_template_dir_parent_id

  • resource GetAllTemplateKeyWords()

    Получение списка всех ключевых слов, относящихся к шаблонному ответу с id $helpdesk_letter_template_id. Если $helpdesk_letter_template_id не задан, или равен 0, выбираются абсолютно все ключевые слова

  • resource GetAllTemplateWithDirId()

    Получение списка стандартных ответов, относящихся к директории стандартных ответов с идентификатором $helpdesk_letter_template_dir_id

  • resource GetAllTicket()

    Получение информации обо всех инцидентах конкретной службы техподдержки (если передан параметр $helpdesk_id), или конкретной категории (если передан параметр $helpdesk_ticket_category_id). Если параметры не переданы, выбирается информация обо всех инцидентах

  • resource GetAllTicketCategory()

    Получение информации о категориях инцидентов. Если передан параметр helpdesk_id, выбираются категории, принадлежащие службе техподдержки с id helpdesk_id. Если передан параметр $helpdesk_ticket_category_parent_id, выбираются категории вложенные в категорию с id $helpdesk_ticket_category_parent_id.

  • resource GetAllTicketFlag()

    Получение информации обо всех флагах тикетов

  • resource GetAllUsers()

    Получение информации обо всех пользователях центра администрирования данного сайта

  • resource GetAllWeekends()

    Получение списка всех специальных рабочих/выходных днях

  • str GetAnswerDate()

    Получение даты ответа для тикета

  • array GetArrayAttachment()

    Получение массива с информацией обо всех вложениях сообщения

  • mixed GetAttachment()

    Получение информации о вложенном файле

  • mixed GetAttachmentPath()

    Получение полного пути к вложенному файлу

  • mixed GetCriticalLevel()

    Получение информации об уровне критичности

  • mixed GetEmail()

    Получение информации об электронном адресе

  • bool GetEmailIsHelpdeskEmail()

    Проверка, является ли переданный текст адресом службы техподдержки или почтовым демоном, а также, нужно ли отсылать сообщения на электронный адрес пользователю

  • mixed GetFirstMessageTicket()

    Получение информации о первом сообщении тикета

  • mixed GetHelpdesk()

    Получение данных о службе технической поддержки.

  • array GetInfo4Messages()

    Информация о количестве сообщений тикета

  • mixed GetMessage()

    Получение информации о сообщении.

  • mixed GetMessageByNumber()

    Получение информации о сообщении по его порядковому номеру в тикете

  • str GetMessageForHistory()

    Получение отформатированного сообщения для истории сообщений

  • str GetMessageHistory()

    Построение дерева сообщений

  • mixed GetResponsible()

    Получение информации об ответственном лице

  • Массив GetSiteUserByEmail()

    Получение информации о пользователе сайта по его e-mail'у

  • mixed GetStatus()

    Получение информации о статусе

  • array GetStructuredListCategoryTicket()

    Формирование структурированного списка категорий тикетов

  • array GetStructuredListMessage()

    Получение структурированного списка сообщений

  • array GetStructuredListTemplateDir()

    Формирование стуктурированного списка категорий стандартных ответов

  • int GetSupportEmailId()

    Получение идентификатора электронного адреса службы техподдержки

  • mixed GetTemplate()

    Получение информации о стандартном ответе

  • mixed GetTemplateDir()

    Получение информации о группе стандартных ответов

  • array GetTemplateDirPathArray()

    Построение пути от корневой директории стандартных ответов до текущей

  • mixed GetTemplateKeyWords()

    Получение информации о ключевом слове

  • string GetTextFileSize()

    Получение тесктового названия размера файла (в Кб, Мб, Гб)

  • mixed GetTicket()

    Получение информации об инциденте по его идентификатору

  • mixed GetTicketByName()

    Получение информации об инциденте по его имени

  • mixed GetTicketCategory()

    Получение данных о категории инцидентов

  • array GetTicketCategoryPathArray()

    Построение пути от корневой категории тикетов к заданной

  • mixed GetTicketFlags()

    Получение информации о флаге тикетов

  • mixed GetUsersTemplateByUsersId()

    Получение информации о шаблонах писем по идентификатору пользователя

  • str GetWeekDayName()

    Определение названия дня недели по его номеру

  • mixed GetWeekend()

    Получение информации о специальном рабочем/выходном дне

  • array GetWeekendArray()

    Получение массива дополнительных выходных дней

  • array GetWorkdayArray()

    Получение массива дополнительных рабочих дней

  • mixed GetWorkTime()

    Получение массива рабочих часов службы техподдержки

  • mixed InsertCategoryTicket()

    Добавление/обновление информации о категории тикетов

  • mixed InsertCriticalLevel()

    Добавление/обновление информации об уровне критичности

  • mixed InsertEmail()

    Добавление/обновление информации об электронных адресах

  • mixed InsertHelpdesk()

    Добавление информации о службе технической поддержки.

  • mixed InsertMessage()

    Добавление/обновление сообщения

  • mixed InsertResponsible()

    Добавление ответственного пользователя

  • mixed InsertStatus()

    Обновление/добавление статуса

  • int InsertSupportWoktime()

    Добавление рабочего дня службы технической поддержки

  • mixed InsertTemplate()

    Добавление/обновление информации о стандартном ответе

  • mixed InsertTemplateDir()

    Добавление/обновление информации о категории стандартных ответов

  • mixed InsertTemplateKeyWords()

    Добавление/обновление информации о ключевом слове

  • mixed InsertTicket()

    Добавление информации об инциденте

  • mixed InsertTicketFlags()

    Добавление/обновление флага к тикету

  • mixed InsertUsersLetterTemplate()

    Добавление/обновление шаблона письма

  • mixed InsertWeekend()

    Вставка/обновление информации о специальном рабочем/выходном дне

  • mixed LoadAttachments()

    Загрузка на сервер вложенных файлов

  • bool MessageBlockUnblock()

    Блокирование/разблокирование сообщения

  • bool RecountAnswerDateTime()

    Обновление приблизительной даты ответа на сообщение

  • str ReFormat()

    Преобразование текста в другой формат

  • str ReplaceMailMacro()

    Макроподстановки в тексте

  • str ReplyMessageText()

    Цитирование текста сообщения, на которое посылается ответ

  • array SearchIndexing()

    Функция обратного вызова для поисковой индексации данных модуля

  • bool SendMessage()

    Отправка сообщений

  • bool SentAutoAnswer()

    Формирование и отсылка автоответа на сообщение

  • bool SetFlagTicket()

    Применение флага к тикету

  • bool ShowHelpdesk()

    Показ списка тикетов службы поддержки

  • bool ShowTicket()

    Показ списка сообщений тикета

  • bool ShowWorktime()

    Показ режима работы службы техподдержки

  • bool TicketStatusChange()

    Изменение статуса тикета

Унаследованные методы

Описания методов

    helpdesk::AccessToAttachment

AccessToAttachment(
int
$helpdesk_attachment_id, int
$site_users_id );

    Описание

    Проверка доступа пользователя сайта к вложенным файлам

    Принимаемые параметры

    $helpdesk_attachment_id

    Идентификатор вложенного файла

    $site_users_id

    Идентификатор пользователя сайта

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_attachment_id = 2;
      5.

    5.
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      $site_users_id = 0;
      15.

    15.  }
      16.

    16.
      17.

    17.  $result = $helpdesk->AccessToAttachment($helpdesk_attachment_id, $site_users_id);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  echo $result;
      21.

    21.  ?>
      22.

    [ Наверх ]

    helpdesk::AnalizeForKeyWords

AnalizeForKeyWords(
int
$helpdesk_id, str
$text );

    Описание

    Анализ сообщения на предмет содержания ключевых слов для стандартных ответов.

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $text

    Текст сообщения

    Возвращает

    Идентификатор стандартного ответа, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $text = 'Ключевое слово стандартного ответа';
      6.

    6.
      7.

    7.  $result = $helpdesk->AnalizeForKeyWords($helpdesk_id, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::BuildSubject

BuildSubject(
int
$helpdesk_message_id, [array
$param = array ()] );

    Описание

    Формирование темы сообщения в соответствии с масками имени тикета и номера сообщения

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения, на основе темы которого строится тема нового сообщения

    $param

    Массив дополнительных параметров
    • int $param['make_from_old'] Флаг, указывающий, создавать тему для нового сообщения, или изменить тему старого сообщения (1 - изменить, 0 - создать).

    Возвращает

    str Тема сообщения, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->BuildSubject($helpdesk_message_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::CloseOldTicket

CloseOldTicket(
int
$helpdesk_id );

    Описание

    Закрытие старых (ответ на которые дан более 10 дней назад) тикетов

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->CloseOldTicket($helpdesk_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Тикет закрыт";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка закрытия тикета";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::CombineTickets

CombineTickets(
array
$tickets_id_array, int
$ticket_id );

    Описание

    Объединение тикетов

    Принимаемые параметры

    $tickets_id_array

    Массив идентификаторов тикетов, которые необходимо объединить

    $ticket_id

    Идентификатор тикета, с которым объединяются тикеты

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $tickets_id_array = array(6,7);
      5.

    5.  $ticket_id = 5;
      6.

    6.
      7.

    7.  $result = $helpdesk->CombineTickets($tickets_id_array, $ticket_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::CopyCriticalLevel

CopyCriticalLevel(
int
$helpdesk_critical_level_id, [array
$param = array ()] );

    Описание

    Копирование информации об уровне критичности

    Принимаемые параметры

    $helpdesk_critical_level_id

    Идентификатор копируемого уровня критичности

    $param

    Массив дополнительных параметров (не обязательный параметр)
    • int $param['helpdesk_id'] Идентификатор службы поддержки, к которой нужно отнести скопированный уровень критичности (если не указан, или меньше 0, скопированный уровень критичности будет отнесен к той же службе поддержки, что и копируемый)

    Возвращает

    идентификатор копии в случае успешного выполнения, false - в противном случае
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_critical_level_id = 1;
      5.

    5.
      6.

    6.  $newid = $helpdesk->CopyCriticalLevel($helpdesk_critical_level_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::CopyEmail

CopyEmail(
int
$helpdesk_email_id, [array
$param = array ()] );

    Описание

    Копирование информации об электронном адресе службы поддержки

    Принимаемые параметры

    $helpdesk_email_id

    $param

    Массив дополнительных параметров
    • int $param['helpdesk_id'] Идентификатор службы поддержки, к которой необходимо отнести скопированный email (если неуказан, или меньше 0 - скопированный email будет отнесен к той же службе поддержки, что и копируемый)
    • int $param['helpdesk_ticket_category_id'] Идентификатор категории тикетов, в которую будут попадать письма с данного email'а (если неуказан, или меньше 0 - сообщения со скопированного email'а будут попадать в ту же категорию, что и с копируемого)

    Возвращает

    false или int Идентификатор вставленной записи
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_email_id = 2;
      5.

    5.  $param['helpdesk_id'] = 1;
      6.

    6.  $param['helpdesk_ticket_category_id'] = 1;
      7.

    7.
      8.

    8.  $result = $helpdesk->CopyEmail($helpdesk_email_id, $param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $result;
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::CopyHelpdesk

CopyHelpdesk(
int
$helpdesk_id, [array
$param = array ()] );

    Описание

    Копирование службы поддержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор копируемой службы поддержки

    $param

    Массив дополнительных параметров
    • int $param['site_id'] Идентификатор ссайта, к которому нужно отнести скопированную службу поддержки (если не указан, или меньше 0 - как у копируемого)
    • int $param['structure_id'] Идентификатор структуры сайта, к которой нужно отнести скопированную службу поддержки (если не указан, или меньше 0 - как у копируемого)

    Возвращает

    false или int Идентификатор вставленной записи
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $param['site_id'] = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->CopyHelpdesk($helpdesk_id, $param);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::CopyStatus

CopyStatus(
int
$helpdesk_status_id, [array
$param = array ()] );

    Описание

    Копирование статуса сообщения

    Принимаемые параметры

    $helpdesk_status_id

    Идентификатор копируемого статуса

    $param

    Массив дополнительных параметров
    • int $param['helpdesk_id'] Идентификатор службы поддержки, к которой необходимо отнести скопированный статус (если неуказан, или меньше 0 - скопированный статус будет отнесен к той же службе поддержки, что и копируемый)

    Возвращает

    false или int Идентификатор вставленной записи
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_status_id = 1;
      5.

    5.  $param['helpdesk_id'] = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->CopyStatus($helpdesk_status_id, $param);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::CopyTemplateKeyWords

CopyTemplateKeyWords(
int
$helpdesk_letter_template_words_id );

    Описание

    Копирование ключевого слова

    Принимаемые параметры

    $helpdesk_letter_template_words_id

    Идентификатор копируемого ключевого слова

    Возвращает

    Идентификатор скопированного ключевого слова в случае успешного копирования, false - иначе
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_words_id = 2;
      5.

    5.
      6.

    6.  $newid = $helpdesk->CopyTemplateKeyWords($helpdesk_letter_template_words_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::CopyTicketCategory

CopyTicketCategory(
int
$helpdesk_ticket_category_id, [array
$param = array ()] );

    Описание

    Копирование категории тикетов

    Принимаемые параметры

    $helpdesk_ticket_category_id

    $param

    Массив дополнительных параметров
    • int $param['helpdesk_id'] Идентификатор службы поддержки, к которой необходимо отнести скопированную категорию (если неуказан, или меньше 0 - скопированная категория будет отнесена к той же службе поддержки, что и копируемая)
    • int $param['helpdesk_email_id'] Идентификатор email'а, который нужно сопоставить со скопированной категорией (если неуказан, или меньше 0 - скопированная категория будет отнесена к тому же email'у, что и копируемая)
    • int $param['helpdesk_ticket_category_parent_id'] Идентификатор родительской категории, к которой нужно отнести скопированную категорию (если неуказан, или меньше 0 - скопированная категория будет отнесена к той же категории, что и копируемая)

    Возвращает

    false или int Идентификатор вставленной записи
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_category_id = 1;
      5.

    5.  $param['helpdesk_id'] = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->CopyTicketCategory($helpdesk_ticket_category_id, $param);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::CopyTicketFlag

CopyTicketFlag(
int
$helpdesk_ticket_flags_id, [array
$param = array ()] );

    Описание

    Копирование флага тикетов

    Принимаемые параметры

    $helpdesk_ticket_flags_id

    $param

    Массив дополнительных параметров
    • int $param['helpdesk_id'] Идентификатор службы поддержки, к которой необходимо отнести скопированный флаг (если неуказан, или меньше 0 - скопированный флаг будет отнесен к той же службе поддержки, что и копируемый)

    Возвращает

    false или int Идентификатор вставленной записи
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_flags_id = 5;
      5.

    5.  $param['helpdesk_id'] = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->CopyTicketFlag($helpdesk_ticket_flags_id, $param);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::CutQuotetion

CutQuotetion(
str
$message_text, int
$message_type );

    Описание

    Удаление из текста сообщения цитаты

    Принимаемые параметры

    $message_text

    Исходный текст

    $message_type

    Тип сообщения (1 - текст, 0 - html)

    Возвращает

    Текст без цитат
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $message_text = "> > #----------------------\n> > Привет!\n> > #----------------------";
      5.

    5.  $message_type = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->CutQuotetion ($message_text, $message_type);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::DeleteAttachments

DeleteAttachments(
int
$helpdesk_message_id );

    Описание

    Удаление информации о вложенных файлах в сообщениях

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 9;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteAttachments($helpdesk_message_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteCriticalLevel

DeleteCriticalLevel(
int
$helpdesk_critical_level_id );

    Описание

    Удаление информации об уровне критичности

    Принимаемые параметры

    $helpdesk_critical_level_id

    Идентификатор уровня критичности

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_critical_level_id = 4;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteCriticalLevel($helpdesk_critical_level_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteEmail

DeleteEmail(
int
$helpdesk_email_id );

    Описание

    Удаление информациии об электронном адресе

    Принимаемые параметры

    $helpdesk_email_id

    Идентификатор электронного адреса

    Возвращает

    resource или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_email_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteEmail($helpdesk_email_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Загрузка выполнена успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка загрузки файла";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteHelpdesk

DeleteHelpdesk(

$helpdesk_id, int
$helpdesk );

    Описание

    Удаление информации о службе технической поддержки

    Принимаемые параметры

    $helpdesk

    Идентификатор службы технической поддержки

    $helpdesk_id

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 2;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteHelpdesk($helpdesk_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteMessage

DeleteMessage(
int
$helpdesk_message_id );

    Описание

    Удаление сообщения

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    Возвращает

    Идентификатор удаленной записи, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 2;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteMessage($helpdesk_message_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.  echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteResponsible

DeleteResponsible(
int
$helpdesk_responsible_id );

    Описание

    Удаление ответственного пользователя

    Принимаемые параметры

    $helpdesk_responsible_id

    Идентификатор ответственного пользователя

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_responsible_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteResponsible($helpdesk_responsible_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteStatus

DeleteStatus(
int
$helpdesk_status_id );

    Описание

    Удаление статуса сообщений

    Принимаемые параметры

    $helpdesk_status_id

    Идентификатор удаляемого статуса

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_status_id = 3;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteStatus($helpdesk_status_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteSupportWoktime

DeleteSupportWoktime(
int
$helpdesk_id, int
$helpdesk_support_worktime_day, int
$helpdesk_support_worktime_hour );

    Описание

    Удаление рабочего дня службы технической поддержки

    Принимаемые параметры

    $helpdesk_id

    идентификатор службы технической поддержки

    $helpdesk_support_worktime_day

    номер дня (0 - Понедельник, 1 - Вторник и т.д.)

    $helpdesk_support_worktime_hour

    номер часа (0 - 00:00 часов ночи, 1 - 01:00 и т.д.)

    Возвращает

    resource or false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_support_worktime_day = 6;
      6.

    6.  $helpdesk_support_worktime_hour = 15;
      7.

    7.
      8.

    8.  $result = $helpdesk->DeleteSupportWoktime($helpdesk_id, $helpdesk_support_worktime_day, $helpdesk_support_worktime_hour);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo "Удаление выполнено успешно";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Ошибка удаления";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    helpdesk::DeleteTemplate

DeleteTemplate(
int
$helpdesk_letter_template_id );

    Описание

    Удаление стандартного ответа

    Принимаемые параметры

    $helpdesk_letter_template_id

    Идентификатор стандартного ответа

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteTemplate($helpdesk_letter_template_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteTemplateDir

DeleteTemplateDir(
int
$helpdesk_id, int
$helpdesk_letter_template_dir_id );

    Описание

    Удаление группы стандартных ответов

    Принимаемые параметры

    $helpdesk_letter_template_dir_id

    Идентификатор группы стандартных ответов

    $helpdesk_id

    Идентификатор службы техподдержки

    Возвращает

    resource, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_letter_template_dir_id = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->DeleteTemplateDir($helpdesk_id, $helpdesk_letter_template_dir_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    helpdesk::DeleteTemplateKeyWords

DeleteTemplateKeyWords(
int
$helpdesk_letter_template_words_id );

    Описание

    Удаление ключевого слова

    Принимаемые параметры

    $helpdesk_letter_template_words_id

    Идентификатор ключевого слова

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_words_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteTemplateKeyWords($helpdesk_letter_template_words_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteTicket

DeleteTicket(
int
$helpdesk_ticket_id );

    Описание

    Удаление информациии об инциденте

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор инцидента

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 2;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteTicket($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteTicketCategory

DeleteTicketCategory(
int
$helpdesk_ticket_category_id );

    Описание

    Удаление информации о категории инцидентов

    Принимаемые параметры

    $helpdesk_ticket_category_id

    Идентификатор категории инцидентов

    Возвращает

    resource в случае успешного выполнения, false - иначе
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_category_id = 3;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteTicketCategory($helpdesk_ticket_category_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteTicketFlags

DeleteTicketFlags(
int
$helpdesk_ticket_flags_id );

    Описание

    Удаление информации о флаге для тикетов

    Принимаемые параметры

    $helpdesk_ticket_flags_id

    Идентификатор удаляемого флага

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_flags_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->DeleteTicketFlags($helpdesk_ticket_flags_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    helpdesk::DeleteWeekend

DeleteWeekend(
int
$helpdesk_weekend_id );

    Описание

    Удаление информации о специальном рабочем/выходном дне

    Принимаемые параметры

    $helpdesk_weekend_id

    Идентификатор специального рабочего/выходного дня

    [ Наверх ]

    helpdesk::GenXml4Helpdesk

GenXml4Helpdesk(
int
$helpdesk_id, [array
$helpdesk_row = false], [array
$param = array ()], [
$external_propertys = array ()] );

    Описание

    Формирование XML для службы техподдержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки (не обязательный)

    $helpdesk_row

    Массив с информацией о службе техподдержки (не обязательный)

    $param

    Массив дополнительных параметров (не обязательный)
    • int $param['site_users_id'] Идентификатора пользователя сайта
    • int $param['status'] Фильтр по статусам тикетов (-1 - показать все тикеты, 0 - только закрытые, 1 - только открытые. по умолчанию -1)
    • int $param['ticket_begin'] Номер элемента, с которого необходимо добавлять в xml тикеты
    • int $param['ticket_on_page'] Количество выводимых тикетов на страницу
    • int $param['ticket_count'] Число тикетов

    $external_propertys

    Возвращает

    XML с данными о тикете, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->GenXml4Helpdesk($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($result);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GenXml4Message

GenXml4Message(
int
$helpdesk_message_id, int
$helpdesk_message_parent_id, [array
$message_row = false], [
$param = array ()] );

    Описание

    Формирование XML для сообщений

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    $helpdesk_message_parent_id

    Идентификатор родительского сообщения

    $message_row

    Массив с информацией о сообщении (не обязательный параметр)

    $param

    Возвращает

    XML с данными о сообщении, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 5;
      5.

    5.  $helpdesk_message_parent_id = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->GenXml4Message($helpdesk_message_id, $helpdesk_message_parent_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo htmlspecialchars($result);
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GenXml4Ticket

GenXml4Ticket(
int
$helpdesk_ticket_id, [array
$ticket_row = false], [array
$param = array ()] );

    Описание

    Формирование XML для тикета

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $ticket_row

    Массив с информацией о тикете (не обязательный параметр)

    $param

    Массив дополнительных параметров

    Возвращает

    XML с данными о тикете, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->GenXml4Ticket($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($result);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GenXml4TicketCategory

GenXml4TicketCategory(
int
$hellpdesk_id, int
$helpdesk_ticket_category_id, [array
$ticket_category_row = false], [array
$param = array ()] );

    Описание

    Формирование XML для категорий тикетов

    Принимаемые параметры

    $hellpdesk_id

    Идентификатор службы поддержки

    $helpdesk_ticket_category_id

    Идентификатор родительской категории

    $ticket_category_row

    Массив с информацией о родительской категории тикетов

    $param

    Массив дополнительных параметров

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $hellpdesk_id = 1;
      5.

    5.  $helpdesk_ticket_category_id = 4;
      6.

    6.
      7.

    7.  $result = $helpdesk->GenXml4TicketCategory ($hellpdesk_id, $helpdesk_ticket_category_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo htmlspecialchars($result);
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GenXml4WorkTime

GenXml4WorkTime(
int
$helpdesk_id, [array
$helpdesk_row = false], [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Формирование XML для режима работы службы техподдержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $helpdesk_row

    Массив с информацией о службе техподдержки (не обязательный параметр)

    $param

    Массив дополнительных параметров (не обязательный параметр)

    $external_propertys

    Массив дополнительных параметров для включения в XML

    Возвращает

    XML или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $result = $helpdesk->GenXml4WorkTime($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($result);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetAllAttachments

GetAllAttachments(
int
$helpdesk_message_id );

    Описание

    Получение вложенных файлов сообщения

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    Возвращает

    resource, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 14;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllAttachments($helpdesk_message_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllBlockedMessages

GetAllBlockedMessages(
[int
$ticket_id = 0] );

    Описание

    Получение всех заблокированных сообщений тикета

    Принимаемые параметры

    $ticket_id

    идентификатор тикета. Если передан - будут выбраны все заблокированные сообщения тикета

    [ Наверх ]

    helpdesk::GetAllCriticalLevel

GetAllCriticalLevel(
int
$helpdesk_id );

    Описание

    Получение информации обо всех уровнях критичности. Если передан параметр $helpdesk_id, то выбираются уровни критичности службы техподдержки с id $helpdesk_id

    Принимаемые параметры

    $helpdesk_id

    helpdesk_id Идентификатор службы технической поддержки (если 0, выборка всех уровней) (параметр не обязателен)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllCriticalLevel($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllEmail

GetAllEmail(
int
$helpdesk_id, [array
$param = array ()] );

    Описание

    Получение информации обо всех электронных адресах службы техподдержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $param

    Массив дополнительных параметров
    • int $param['limit'] Ограничение числа записей в выборке (Не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllEmail($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllFlags

GetAllFlags(
int
$helpdesk_id );

    Описание

    Получение списка флагов

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllFlags($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllHelpdesk

GetAllHelpdesk(
[mixed
$site_id = false] );

    Описание

    Получение информации обо всех службах техподдержки на конкретном сайте. Если параметр $site_id не передан, или равен false - выбирается информация обо всех службах техподдержки.

    Принимаемые параметры

    $site_id

    Идентификатор сайта, или false

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $resource = $helpdesk->GetAllHelpdesk();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetAllMessage

GetAllMessage(
int
$helpdesk_ticket_id, [int
$helpdesk_message_id = 0], [array
$param = array ()] );

    Описание

    Получение списка сообщений, относящихся к тикету с идентификатором $helpdesk_ticket_id. Если задан параметр $helpdesk_message_id, выбираются все сообщения, кроме сообщения с id $helpdesk_message_id.

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $helpdesk_message_id

    Идентификатор сообщения, которое не нужно включать в список (не обязательный параметр)

    $param

    Массив дополнительных параметров ( не обязательный параметр)
    • int $param['helpdesk_message_inbox'] Флаг, указывающий, являются ли сообщения входящими (1 - входящие, 0 - исходящие)
    • int $param['helpdesk_message_parent_id'] Идентификатор родительского сообщения
    • int $param['limit'] Лимит выборки
    • str $param['helpdesk_message_blocked_at'] Ограничение выборки по значениям поля `helpdesk_message_blocked_at`

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllMessage($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllMessageWithParentId

GetAllMessageWithParentId(
int
$helpdesk_message_parent_id, [int
$ticket_id = false] );

    Описание

    Получение списка сообщений, дочерних по отношению к сообщению с id $helpdesk_message_parent_id

    Принимаемые параметры

    $helpdesk_message_parent_id

    Идентификатор родительского сообщения

    $ticket_id

    Идентификатор тикета. (Не обязательный параметр. по умолчанию - false. Если false - то выбираются все дочерние сообщения, независимо от их принадлежности тикету)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_parent_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllMessageWithParentId($helpdesk_message_parent_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      var_dump($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllResponsible

GetAllResponsible(
int
$helpdesk_ticket_category_id );

    Описание

    Получение информации обо всех ответственных лицах

    Принимаемые параметры

    $helpdesk_ticket_category_id

    Идентификатор категории тикетов.

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_category_id = 4;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllResponsible($helpdesk_ticket_category_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllStatus

GetAllStatus(
int
$helpdesk_id );

    Описание

    Получение списка статусов. Если передан параметр $helpdesk_id, то выбираются сообщения, относящиеся к службе техподдержки с идентификатором $helpdesk_id

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки (параметр не обязателен)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllStatus($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllTemplate

GetAllTemplate(
int
$helpdesk_id, [int
$helpdesk_letter_template_dir_id = false] );

    Описание

    Получение списка стандартных ответов службы техподдержки. Если передан параметр $helpdesk_letter_template_dir_id, выбираются все стандартные ответы, принадлежащие категории с этим идентификатором

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки.

    $helpdesk_letter_template_dir_id

    Идентификатор категории стандартных ответов

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllTemplate($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllTemplateDir

GetAllTemplateDir(
int
$helpdesk_id, [int
$helpdesk_letter_template_dir_id = 0] );

    Описание

    Получение списка групп стандартных ответов.

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки. Ели 0 или не передан, выбираются группы всех техподдержек

    $helpdesk_letter_template_dir_id

    Идентификатор группы, которую не нужно включать в список

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllTemplateDir($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllTemplateDirWithParentId

GetAllTemplateDirWithParentId(

$helpdesk_id, int
$helpdesk_letter_template_dir_parent_id, [int
$helpdesk_letter_template_dir_id = 0] );

    Описание

    Получение списка директорий стандартных ответов, вложенных в директорию с идентификатором $helpdesk_letter_template_dir_parent_id

    Принимаемые параметры

    $helpdesk_letter_template_dir_parent_id

    Идентификатор родительской категории

    $helpdesk_letter_template_dir_id

    Идентификатор категории, которую не нужно включать в список

    $helpdesk_id

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_letter_template_dir_parent_id = 2;
      6.

    6.
      7.

    7.  $resource = $helpdesk->GetAllTemplateDirWithParentId($helpdesk_id, $helpdesk_letter_template_dir_parent_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($resource))
      11.

    11.  {
      12.

    12.      print_r ($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    helpdesk::GetAllTemplateKeyWords

GetAllTemplateKeyWords(
[int
$helpdesk_letter_template_id = 0] );

    Описание

    Получение списка всех ключевых слов, относящихся к шаблонному ответу с id $helpdesk_letter_template_id. Если $helpdesk_letter_template_id не задан, или равен 0, выбираются абсолютно все ключевые слова

    Принимаемые параметры

    $helpdesk_letter_template_id

    Идентификатор стандартного ответа (не обязавтельный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $resource = $helpdesk->GetAllTemplateKeyWords();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r ($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetAllTemplateWithDirId

GetAllTemplateWithDirId(
int
$helpdesk_letter_template_dir_id );

    Описание

    Получение списка стандартных ответов, относящихся к директории стандартных ответов с идентификатором $helpdesk_letter_template_dir_id

    Принимаемые параметры

    $helpdesk_letter_template_dir_id

    Идентификатор родительской директории стандартных ответов

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_dir_id = 2;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllTemplateWithDirId($helpdesk_letter_template_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllTicket

    GetAllTicket(
[int
$helpdesk_id = 0], [int
$helpdesk_ticket_category_id = false], [array
$param = array ()] );

    Описание

    Получение информации обо всех инцидентах конкретной службы техподдержки (если передан параметр $helpdesk_id), или конкретной категории (если передан параметр $helpdesk_ticket_category_id). Если параметры не переданы, выбирается информация обо всех инцидентах

    Принимаемые параметры

    $helpdesk_ticket_category_id

    Идентификатор родительской категории (не обязательный параметр)

    $param

    массив дополнительных параметров
    • int $param['site_users_id'] Ограничение выборки по идентификатору пользователя сайта
    • str $param['date_start'] Ограничение по дате "от" (формат даты: гггг-мм-дд чч:мм:сс)
    • str $param['date_end'] Ограничение по дате "до" (формат даты: гггг-мм-дд чч:мм:сс)
    • str $param['order'] Порядок сортировки (ASC, DESC)
    • str $param['order_field'] Поле по которому сортировать
    • int $param['ticket_begin'] Выбрать из выборки тикеты, начиная с
    • int $param['ticket_on_page'] Выбрать число тикетов из выборки

    $helpdesk_id

    helpdesk_id Идентификатор службы технической поддержки (не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $resource = $helpdesk->GetAllTicket();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetAllTicketCategory

    GetAllTicketCategory(
[int
$helpdesk_id = 0], [int
$helpdesk_ticket_category_parent_id = 0], [
$helpdesk_ticket_category_id = 0] );

    Описание

    Получение информации о категориях инцидентов. Если передан параметр helpdesk_id, выбираются категории, принадлежащие службе техподдержки с id helpdesk_id. Если передан параметр $helpdesk_ticket_category_parent_id, выбираются категории вложенные в категорию с id $helpdesk_ticket_category_parent_id.

    Принимаемые параметры

    $helpdesk_ticket_category_parent_id

    Идентификатор родительской категории, или 0 (не обязательный параметр)  int $helpdesk_ticket_category_id Идентификатор категории, которую не нужно включать в список (не обязательный параметр

    $helpdesk_id

    helpdesk_id Идентификатор службы технической поддержки, или 0 (не обязательный параметр)

    $helpdesk_ticket_category_id

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $resource = $helpdesk->GetAllTicketCategory();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetAllTicketFlag

GetAllTicketFlag(
int
$helpdesk_id );

    Описание

    Получение информации обо всех флагах тикетов

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы поддержки

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllTicketFlag($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllUsers

GetAllUsers(

$helpdesk_id, [int
$site_id = 0], [int
$helpdesk_ticket_category_parent_id = false] );

    Описание

    Получение информации обо всех пользователях центра администрирования данного сайта

    Принимаемые параметры

    $site_id

    Идентификатор сайта (если не указан, выбирается текущий сайт) (не обязательный параметр)

    $helpdesk_ticket_category_parent_id

    Идентификатор категории, для которой назначен ответственный пользователь

    $helpdesk_id

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllUsers($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::GetAllWeekends

GetAllWeekends(
int
$helpdesk_id );

    Описание

    Получение списка всех специальных рабочих/выходных днях

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы поддержки

    [ Наверх ]

    helpdesk::GetAnswerDate

GetAnswerDate(
str
$day, str
$time_answer, array
$worktime_array, array
$weekend_array, array
$workday_array );

    Описание

    Получение даты ответа для тикета

    Принимаемые параметры

    $day

    Дата-время в формате SQL (ГГГГ-ММ-ДД чч:мм:сс), с которой считать время ответа

    $time_answer

    Время ответа в минутах

    $worktime_array

    Массив режима работы

    $weekend_array

    Массив дополнительных выходных

    $workday_array

    Массив дополнительных рабочих дней

    Возвращает

    Дата-время в формате SQL

    [ Наверх ]

    helpdesk::GetArrayAttachment

GetArrayAttachment(
int
$helpdesk_message_id );

    Описание

    Получение массива с информацией обо всех вложениях сообщения

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 14;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetArrayAttachment($helpdesk_message_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetAttachment

GetAttachment(
int
$helpdesk_attachment_id, [array
$param = array ()] );

    Описание

    Получение информации о вложенном файле

    Принимаемые параметры

    $helpdesk_attachment_id

    Идентификатор вложенного файла

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив с информацией, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_attachment_id = 2;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetAttachment($helpdesk_attachment_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetAttachmentPath

GetAttachmentPath(
int
$helpdesk_attachment_id );

    Описание

    Получение полного пути к вложенному файлу

    Принимаемые параметры

    $helpdesk_attachment_id

    Идентификатор вложенного файла

    Возвращает

    Строка, содержащая путь к вложенному файлу, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_attachment_id = 2;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetAttachmentPath($helpdesk_attachment_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetCriticalLevel

GetCriticalLevel(
int
$helpdesk_critical_level_id, [array
$param = array ()] );

    Описание

    Получение информации об уровне критичности

    Принимаемые параметры

    $helpdesk_critical_level_id

    Идентификатор уровня критичности

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_critical_level_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetCriticalLevel($helpdesk_critical_level_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetEmail

GetEmail(
int
$helpdesk_email_id, [array
$param = array ()] );

    Описание

    Получение информации об электронном адресе

    Принимаемые параметры

    $helpdesk_email_id

    Идентификатор записи

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_email_id = 2;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetEmail($helpdesk_email_id);
      7.

    7.
      8.

    8.  print_r ($row);
      9.

    9.  ?>
      10.

    [ Наверх ]

    helpdesk::GetEmailIsHelpdeskEmail

GetEmailIsHelpdeskEmail(
int
$helpdesk_id, str
$email, [str
$helpdesk_message_subject = ''], [int
$helpdesk_ticket_id = 0] );

    Описание

    Проверка, является ли переданный текст адресом службы техподдержки или почтовым демоном, а также, нужно ли отсылать сообщения на электронный адрес пользователю

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $email

    электронный адрес

    $helpdesk_message_subject

    Тема письма (не обязательный параметр)

    $helpdesk_ticket_id

    Идентификатор тикета

    Возвращает

    (true - отсылать ответ не нужно, false - иначе)

    [ Наверх ]

    helpdesk::GetFirstMessageTicket

GetFirstMessageTicket(
int
$helpdesk_ticket_id, [array
$param = array ()] );

    Описание

    Получение информации о первом сообщении тикета

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив с информацией о сообщении, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetFirstMessageTicket($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetHelpdesk

GetHelpdesk(
int
$helpdesk_id, [array
$param = array ()] );

    Описание

    Получение данных о службе технической поддержки.

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы технической поддержки

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetHelpdesk($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetInfo4Messages

GetInfo4Messages(
int
$helpdesk_ticket_id, [array
$param = array ()] );

    Описание

    Информация о количестве сообщений тикета

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 5;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetInfo4Messages($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetMessage

GetMessage(
int
$helpdesk_message_id, [array
$param = array ()] );

    Описание

    Получение информации о сообщении.

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetMessage($helpdesk_message_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetMessageByNumber

GetMessageByNumber(
int
$helpdesk_ticket_id, int
$helpdesk_message_number );

    Описание

    Получение информации о сообщении по его порядковому номеру в тикете

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $helpdesk_message_number

    Порядковый номер сообщения в тикете

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.  $helpdesk_message_number = 1;
      6.

    6.
      7.

    7.  $row = $helpdesk->GetMessageByNumber($helpdesk_ticket_id, $helpdesk_message_number);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetMessageForHistory

GetMessageForHistory(
$helpdesk_message_id
$helpdesk_message_id );

    Описание

    Получение отформатированного сообщения для истории сообщений

    Принимаемые параметры

    $helpdesk_message_id

    идентификатор сообщения

    [ Наверх ]

    helpdesk::GetMessageHistory

GetMessageHistory(
int
$helpdesk_ticket_id, [int
$message_parent_id = 0], [int
$count_call = 0], [array
$param = array ()] );

    Описание

    Построение дерева сообщений

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $message_parent_id

    Идентификатор сообщения, от которого будет строиться дерево. Если не указан, или имеет значение 0 - дерево сообщений строится для всех сообщений тикета. (не обязательный параметр)

    $count_call

    Число вызовов функции (не обязательный параметр)

    $param

    Массив дополнительных параметров ( не обязательный параметр)
    • $param['margin-left'] отступ в дереве сообщений в зависимости от вложенности сообщения (в px, по умолчанию - 10)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetMessageHistory($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetResponsible

GetResponsible(
int
$helpdesk_responsible_id, [array
$param = array ()] );

    Описание

    Получение информации об ответственном лице

    Принимаемые параметры

    $helpdesk_responsible_id

    Идентификатор ответственного лица

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_responsible_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetResponsible($helpdesk_responsible_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetSiteUserByEmail

GetSiteUserByEmail(
str
$site_users_email, [array
$param = array ()] );

    Описание

    Получение информации о пользователе сайта по его e-mail'у

    Принимаемые параметры

    $site_users_email

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    данных, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $site_users_email = 'admin@site.ru';
      5.

    5.
      6.

    6.  $row = $helpdesk->GetSiteUserByEmail($site_users_email);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetStatus

GetStatus(
int
$helpdesk_status_id, [array
$param = array ()] );

    Описание

    Получение информации о статусе

    Принимаемые параметры

    $helpdesk_status_id

    Идентификатор статуса

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_status_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetStatus($helpdesk_status_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetStructuredListCategoryTicket

GetStructuredListCategoryTicket(
int
$helpdesk_id, [int
$helpdesk_ticket_category_parent_id = 0], str
$separator, [int
$helpdesk_ticket_category_id = 0], [int
$pow_taken_up = 0], [bool
$is_first = true] );

    Описание

    Формирование структурированного списка категорий тикетов

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $helpdesk_ticket_category_parent_id

    Идентификатор категории, с вложенных категорий которой строится список. (если не указан, такой категорией является корневая)

    $separator

    Разделитель между уровнями вложенности

    $helpdesk_ticket_category_id

    Идентификатор категории, которую не нужно включать в список (параметр не обязательный)

    $pow_taken_up

    Степень вложенности (параметр не обязательный)

    $is_first

    Флаг, указывающий, первый ли это вызов функции (параметр не обязательный, по умолчанию - true)

    Возвращает

    Структурированный список категорий
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_ticket_category_parent_id = 0;
      6.

    6.  $separator = '';
      7.

    7.
      8.

    8.  $row = $helpdesk->GetStructuredListCategoryTicket($helpdesk_id, $helpdesk_ticket_category_parent_id, $separator);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::GetStructuredListMessage

    GetStructuredListMessage(

$helpdesk_ticket_id, [int
$helpdesk_message_parent_id = 0], unknown_type
$separator, [int
$helpdesk_message_id = 0], [int
$pow_taken_up = 0], [bool
$is_first = true], int
$helpdesk_id );

    Описание

    Получение структурированного списка сообщений

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $helpdesk_message_parent_id

    Идентификатор родительского сообщения

    $separator

    Разделитель между разными уровнями вложенности

    $helpdesk_message_id

    Идентификатор сообщения, которое не нужно включать в список (не обязателен)

    $pow_taken_up

    Степень вложенности (параметр не обязательный, по умолчанию - 0)

    $is_first

    Флаг, указывающий, что функция вызывается впервые (параметр не обязательный, по умолчанию - true)

    $helpdesk_ticket_id

    Возвращает

    Структурированный список сообщений
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.  $helpdesk_message_parent_id = 0;
      6.

    6.  $separator = '';
      7.

    7.
      8.

    8.  $row = $helpdesk->GetStructuredListMessage($helpdesk_ticket_id, $helpdesk_message_parent_id, $separator);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::GetStructuredListTemplateDir

GetStructuredListTemplateDir(
int
$helpdesk_id, [
$helpdesk_letter_template_dir_parent_id = 0], str
$separator, [int
$helpdesk_letter_template_dir_id = 0], [int
$pow_taken_up = 0], [bool
$is_first = true], int
$helpdesk_ticket_category_parent_id );

    Описание

    Формирование стуктурированного списка категорий стандартных ответов

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $helpdesk_ticket_category_parent_id

    Идентификатор родительской категории, с содержимого которой строится список. Если не передан, то выводятся все категории, начиная с корневой (не обязательный параметр)

    $separator

    Разделитель между уровнями

    $helpdesk_letter_template_dir_id

    Идентификатор категории, которую не нужно включать в список. Если не указан, то в список включаются абсолютно все категории (не обязательный параметр)

    $pow_taken_up

    Степень вложенности. (не обязательный параметр, по умолчанию - 0)

    $is_first

    Флаг, указывающий, первый ли раз вызывается функция. (не обязательный параметр, по умолчанию true)

    $helpdesk_letter_template_dir_parent_id

    Возвращает

    Структурированный список категорий
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_letter_template_dir_parent_id = 0;
      6.

    6.  $separator = '';
      7.

    7.
      8.

    8.  $row = $helpdesk->GetStructuredListTemplateDir($helpdesk_id, $helpdesk_letter_template_dir_parent_id, $separator);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::GetSupportEmailId

GetSupportEmailId(
int
$helpdesk_id, int
$helpdesk_ticket_category_id );

    Описание

    Получение идентификатора электронного адреса службы техподдержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $helpdesk_ticket_category_id

    Идентификатор категории тикетов

    Возвращает

    Идентификатор электронного адреса службы техподдержки
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_ticket_category_id = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->GetSupportEmailId($helpdesk_id, $helpdesk_ticket_category_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetTemplate

GetTemplate(
int
$helpdesk_letter_template_id, [array
$param = array ()] );

    Описание

    Получение информации о стандартном ответе

    Принимаемые параметры

    $helpdesk_letter_template_id

    Идентификатор стандартного ответа

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTemplate($helpdesk_letter_template_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTemplateDir

GetTemplateDir(
int
$helpdesk_letter_template_dir_id, [array
$param = array ()] );

    Описание

    Получение информации о группе стандартных ответов

    Принимаемые параметры

    $helpdesk_letter_template_dir_id

    Идентификатор группы стандартных ответов

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_dir_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTemplateDir($helpdesk_letter_template_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTemplateDirPathArray

GetTemplateDirPathArray(
int
$helpdesk_letter_template_dir_id, [bool
$first_call = true] );

    Описание

    Построение пути от корневой директории стандартных ответов до текущей

    Принимаемые параметры

    $helpdesk_letter_template_dir_id

    Идентификатор текущей директории

    $first_call

    Флаг, указывающий, первый ли вызов функции (не обязательный параметр, по умолчанию - true)

    Возвращает

    Путь от корневой директории
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_dir_id = 3;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTemplateDirPathArray($helpdesk_letter_template_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTemplateKeyWords

GetTemplateKeyWords(
int
$helpdesk_letter_template_words_id, [array
$param = array ()] );

    Описание

    Получение информации о ключевом слове

    Принимаемые параметры

    $helpdesk_letter_template_words_id

    Идентификатор ключевого слова

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_letter_template_words_id = 2;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTemplateKeyWords($helpdesk_letter_template_words_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTextFileSize

GetTextFileSize(
int
$filesize );

    Описание

    Получение тесктового названия размера файла (в Кб, Мб, Гб)

    Принимаемые параметры

    $filesize

    размер файла

    [ Наверх ]

    helpdesk::GetTicket

GetTicket(
int
$helpdesk_ticket_id, [array
$param = array ()] );

    Описание

    Получение информации об инциденте по его идентификатору

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор инцидента

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTicket($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTicketByName

GetTicketByName(
str
$helpdesk_ticket_name, [array
$param = array ()] );

    Описание

    Получение информации об инциденте по его имени

    Принимаемые параметры

    $helpdesk_ticket_name

    Имя тикета

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются
    • int $param['helpdesk_id'] - идентификатор HelpDesk, необязательное поле

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_name = '000000001';
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTicketByName($helpdesk_ticket_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTicketCategory

GetTicketCategory(
int
$helpdesk_ticket_category_id, [int
$helpdesk_id = false], [array
$param = array ()] );

    Описание

    Получение данных о категории инцидентов

    Принимаемые параметры

    $helpdesk_ticket_category_id

    Идентификатор категории инцидентов

    $helpdesk_id

    Идентификатор службы техподдержки (Не обязательный параметр)

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив данных, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_category_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTicketCategory($helpdesk_ticket_category_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTicketCategoryPathArray

GetTicketCategoryPathArray(

$helpdesk_ticket_category_parent_id, [bool
$first_call = true], int
$helpdesk_ticket_category_id );

    Описание

    Построение пути от корневой категории тикетов к заданной

    Принимаемые параметры

    $helpdesk_ticket_category_id

    Идентификатор группы от которой необходимо построить путь

    $first_call

    Флаг, указывающий первый ли это вызов функции или нет (не обязательный параметр)

    $helpdesk_ticket_category_parent_id

    Возвращает

    Массив, содержащий путь от заданной группы к корневой
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_category_parent_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTicketCategoryPathArray($helpdesk_ticket_category_parent_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetTicketFlags

GetTicketFlags(
int
$helpdesk_ticket_flags_id, [array
$param = array ()] );

    Описание

    Получение информации о флаге тикетов

    Принимаемые параметры

    $helpdesk_ticket_flags_id

    Идентификатор флага

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    Массив с информацией о флаге, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_flags_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetTicketFlags($helpdesk_ticket_flags_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetUsersTemplateByUsersId

GetUsersTemplateByUsersId(
int
$helpdesk_id, int
$users_id );

    Описание

    Получение информации о шаблонах писем по идентификатору пользователя

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $users_id

    Идентификатор пользователя

    Возвращает

    Массив данных, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $users_id = 19;
      6.

    6.
      7.

    7.  $row = $helpdesk->GetUsersTemplateByUsersId($helpdesk_id, $users_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::GetWeekDayName

GetWeekDayName(
int
$week_day_num );

    Описание

    Определение названия дня недели по его номеру

    Принимаемые параметры

    $week_day_num

    Номер дня недели

    Возвращает

    Название дня недели
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $week_day_num = 5;
      5.

    5.
      6.

    6.  $result = $helpdesk->GetWeekDayName($week_day_num);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::GetWeekend

GetWeekend(
int
$helpdesk_weekend_id, [array
$param = array ()] );

    Описание

    Получение информации о специальном рабочем/выходном дне

    Принимаемые параметры

    $helpdesk_weekend_id

    Идентификатор специального рабочего/выходного дня

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    array Массив с информацией или false

    [ Наверх ]

    helpdesk::GetWeekendArray

GetWeekendArray(
int
$helpdesk_id );

    Описание

    Получение массива дополнительных выходных дней

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы поддержки

    Возвращает

    Массив дополнительных выходных дней

    [ Наверх ]

    helpdesk::GetWorkdayArray

GetWorkdayArray(
int
$helpdesk_id );

    Описание

    Получение массива дополнительных рабочих дней

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы поддержки

    Возвращает

    Массив дополнительных рабочих дней

    [ Наверх ]

    helpdesk::GetWorkTime

GetWorkTime(
int
$helpdesk_id, [array
$param = array ()] );

    Описание

    Получение массива рабочих часов службы техподдержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $param

    Массив дополнительных параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    array Массив часов, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $row = $helpdesk->GetWorkTime($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::InsertCategoryTicket

InsertCategoryTicket(
array
$param );

    Описание

    Добавление/обновление информации о категории тикетов

    Принимаемые параметры

    $param

    - $param['helpdesk_ticket_category_id'] int Идентификатор редактируемого каталога
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_ticket_category_parent_id'] int Идентификатор родительской категории тикетов
    • $param['helpdesk_ticket_category_name'] str Название категории тикетов
    • $param['helpdesk_ticket_category_description'] str Описание категории тикетов
    • $param['helpdesk_ticket_category_image_big'] str Большое изображение категории тикетов
    • $param['helpdesk_ticket_category_image_small'] str Малое изображение категории тикетов
    • $param['helpdesk_ticket_category_image_small_height'] int Высота малого изображения
    • $param['helpdesk_ticket_category_image_small_width'] int Ширина малого изображения
    • $param['helpdesk_ticket_category_image_big_height'] int Высота большого изображения
    • $param['helpdesk_ticket_category_image_big_width'] int Ширина большого изображения
    • $param['helpdesk_email_id'] int Идентификатор электронного адреса по умолчанию для тикетов (адрес службы техподдержки)

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_id'] = 1;
      5.

    5.  $param['helpdesk_ticket_category_parent_id'] = 1;
      6.

    6.  $param['helpdesk_ticket_category_name'] = 'ticket_category';
      7.

    7.
      8.

    8.  $newid = $helpdesk->InsertCategoryTicket($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::InsertCriticalLevel

InsertCriticalLevel(
array
$param );

    Описание

    Добавление/обновление информации об уровне критичности

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_critical_level_id'] int Идентификатор редактируемого уровня критичности
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_critical_level_name'] str Название уровня критичности
    • $param['helpdesk_critical_level_description'] str Описание уровня критичности
    • $param['helpdesk_critical_level_time'] int Время ответа в минутах
    • $param['helpdesk_critical_level_order'] int Порядок сортировки

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_id'] = 1;
      5.

    5.  $param['helpdesk_critical_level_name'] = 'critical_level';
      6.

    6.  $param['helpdesk_critical_level_description'] = '';
      7.

    7.  $param['helpdesk_critical_level_time'] = 200;
      8.

    8.  $param['helpdesk_critical_level_order'] = 10;
      9.

    9.
      10.

    10.  $newid = $helpdesk->InsertCriticalLevel($param);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    [ Наверх ]

    helpdesk::InsertEmail

InsertEmail(
array
$param );

    Описание

    Добавление/обновление информации об электронных адресах

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_email_id'] int Идентификатор редактируемой записи
    • $param['users_id'] int Идентификатор пользователя центар администрирования
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['helpdesk_email_name'] int Имя почтового ящика
    • $param['helpdesk_email_email'] int Почтовый ящик вида mailbox@host.ru
    • $param['helpdesk_email_login'] int Логин (в зависимости от почтового сервера, почтовый ящик до значка @ (mailbox), или полный адрес почтового ящика (mailbox@host.ru))
    • $param['helpdesk_email_password'] int Пароль к почтовому ящику
    • $param['helpdesk_email_smtp'] int Хост для smtp-соединения
    • $param['helpdesk_email_pop3'] int Хост для pop3-соединения
    • $param['helpdesk_email_imap'] int Хост для imap-соединения
    • $param['helpdesk_email_delete_message'] bool Флаг, указывающий, удалять ли сообщения с сервера, после получения
    • $param['helpdesk_email_use_secury_protocol'] bool Флаг, указывающий, нужно ли использовать защищенный протокол ssl
    • $param['helpdesk_ticket_category_id'] int Идентификатор категории тикетов, в которую будут помещаться все новые тикеты, инициированные сообщениями на данный электронный адрес
    • $param['helpdesk_email_order'] int Порядок сортировки
    • $param['helpdesk_email_active'] Флаг, указывающий, активен ли электронный адрес

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['users_id'] = 19;
      5.

    5.  $param['helpdesk_id'] = 1;
      6.

    6.  $param['helpdesk_email_name'] = 'admin@site.ru';
      7.

    7.  $param['helpdesk_email_email'] = 'admin@site.ru';
      8.

    8.  $param['helpdesk_email_login'] = 'admin';
      9.

    9.  $param['helpdesk_email_password'] = 'admin';
      10.

    10.
      11.

    11.  $newid = $helpdesk->InsertEmail($param);
      12.

    12.
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    [ Наверх ]

    helpdesk::InsertHelpdesk

InsertHelpdesk(
array
$param );

    Описание

    Добавление информации о службе технической поддержки.

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['helpdesk_id'] Идентификатор службы технической поддержки
    • int $param['users_id'] Идентификатор пользователя центра администрирования
    • int $param['helpdesk_ticket_category_id'] Идентификатор категории по умолчанию, в которую помещаются новые инциденты
    • int $param['site_id'] Идентификатор сайта
    • int $param['structure_id'] Идентификатор узла структуры
    • str $param['helpdesk_name'] Название службы технической поддержки (параметр обязателен!)
    • int $param['helpdesk_notify_critical_level_change'] Флаг, указывающий отправлять ли пользователю уведомление об изменении уровня критичности его инцидента
    • int $param['helpdesk_notify_for_query'] Флаг, указывающий отправлять ли пользователю уведомление о получении его запроса
    • str $param['helpdesk_description'] Описание службы технической поддержки
    • str $param['helpdesk_ticket_mask'] Маска формирования имени тикетов (по умолчанию '%09d')
    • str $param['helpdesk_ticket_message_number_mask'] Маска формирования имени тикета и номера сообщения (по умолчанию '%1$09d:%2$d')
    • str $param['helpdesk_message_subject_mask'] Маска формирования темы сообщения (по умолчанию 'Re: %1$s %2$s')
    • int $param['helpdesk_status_reply_id'] Идентификатор статуса для отвеченных сообщений
    • int $param['helpdesk_status_new_id'] Идентификатор статуса для новых сообщений
    • int $param['helpdesk_critical_level_id'] Идентификатор уровня критичности для новых тикетов
    • str $param['helpdesk_report_for_query'] Текст отчета о получении запроса в службу технической поддержки
    • str $param['helpdesk_report_for_critical_level_change'] Текст отчета о смене статуса сообщения
    • int $param['helpdesk_email_id'] Идентификатор электронного адреса для тикетов, подставляемый по умолчанию (адрес техподдержки)
    • str $param['helpdesk_report_for_query'] Тема отчета о получении запроса в службу техподдержки
    • str $param['helpdesk_report_for_critical_level_change_subject'] Тема отчета о смене уровня критичности сообщения
    • str $param['helpdesk_auto_answer_subject'] Тема автоматического ответа
    • int $param['helpdesk_sort_field_ticket'] Идентификатор поля сортировки тикетов (0 - по дате; 1 - по названию)
    • int $param['helpdesk_sort_order_ticket'] Идентификатор направления сортировки (0 - по убыванию, 1 - по возрастанию)
    • str $param['helpdesk_report_for_status_message_change_subject'] Тема отчета о смене статуса сообщения
    • str $param['helpdesk_report_for_status_message_change'] Отчет о смене статуса сообщения пользователя
    • int $param['helpdesk_message_type'] Тип писем, отсылаемых службой техподдержки (0 - html, 1 - text)
    • int $param['helpdesk_close_ticket_time'] Количество дней, после которых неактивный (не ведется переписка) тикет закрывается
    • int $param['helpdesk_block_ticket_time'] Количество минут, после которых заблокированный тикет разблокируется автоматически
    • $param['helpdesk_block_message_time'] Количество минут, после которых заблокированное сообщение разблокируется автоматически

    Возвращает

    Идентификатор вставленной записи, либо false

    [ Наверх ]

    helpdesk::InsertMessage

InsertMessage(
array
$param );

    Описание

    Добавление/обновление сообщения

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_message_id'] int Идентификатор обновляемого сообщения
    • $param['helpdesk_status_id'] int Идентификатор статуса сообщения
    • $param['helpdesk_ticket_id'] int Идентификатор тикета
    • $param['helpdesk_message_parent_id'] int Идентификатор родительского сообщения
    • $param['helpdesk_message_subject'] str Тема сообщения
    • $param['helpdesk_message_message'] str Текст сообщения
    • $param['helpdesk_message_creation_datetime'] str Дата-время создания сообщения
    • $param['helpdesk_message_modification_datetime'] str Дата-время модификации сообщения
    • $param['helpdesk_message_responsible_user_id'] int Идентификатор ответственного пользователя
    • $param['helpdesk_message_grade'] int Оценка ответа на сообщение
    • $param['helpdesk_message_responsible_description'] str Служебный текст
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_message_processed'] int Флаг, показывающий, обработано сообщение, или нет (0 - не обработано, 1 - обработано)
    • $param['helpdesk_message_number'] int Порядковый номер сообщения в тикете
    • $param['helpdesk_message_inbox'] int Флаг, указывающий, входящее сообщение, или нет
    • $param['helpdesk_message_type'] int Тип письма (0 - html, 1 - text)
    • $param['helpdesk_message_headers'] str Заголовки письма
    • $param['helpdesk_message_allow_indexation'] Флаг, указывающий, индексировать ли сообщение для поиска (1 - индексировать, 0 - нет)

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_status_id'] = 1;
      5.

    5.  $param['helpdesk_ticket_id'] = 1;
      6.

    6.  $param['helpdesk_message_parent_id'] = 1;
      7.

    7.  $param['helpdesk_message_subject'] = 'Тема сообщения';
      8.

    8.  $param['helpdesk_message_message'] = 'Текст сообщения';
      9.

    9.  $param['helpdesk_message_creation_datetime'] = date('Y-m-d H:i:s');
      10.

    10.  $param['helpdesk_message_modification_datetime'] = date('Y-m-d H:i:s');
      11.

    11.  $param['helpdesk_message_responsible_user_id'] = 1;
      12.

    12.  $param['helpdesk_message_grade'] = 5;
      13.

    13.
      14.

    14.  $newid = $helpdesk->InsertMessage($param);
      15.

    15.
      16.

    16.  // Распечатаем результат
      17.

    17.  echo $newid;
      18.

    18.  ?>
      19.

    [ Наверх ]

    helpdesk::InsertResponsible

InsertResponsible(
array
$param );

    Описание

    Добавление ответственного пользователя

    Принимаемые параметры

    $param

    Массив Параметров
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_ticket_category_id'] int Идентификатор категории тикетов
    • $param['helpdesk_responsible_users_id'] int Идентификатор пользователя, добавляемого в ответственные пользователи
    • $param['helpdesk_id'] int Идентификатор службы техподдержки

    Возвращает

    Идентификатор вставленной записи, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_ticket_category_id'] = 2;
      5.

    5.  $param['helpdesk_responsible_users_id'] = 19;
      6.

    6.  $param['helpdesk_id'] = 1;
      7.

    7.
      8.

    8.  $newid = $helpdesk->InsertResponsible($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::InsertStatus

InsertStatus(
array
$param );

    Описание

    Обновление/добавление статуса

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_status_id'] Идентификатор обновляемого статуса
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_status_name'] str Название статуса
    • $param['helpdesk_status_description'] str Описание статуса
    • $param['helpdesk_status_order'] int Порядок сортировки

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_id'] = 1;
      5.

    5.  $param['helpdesk_status_name'] = 'newstatus';
      6.

    6.  $param['helpdesk_status_description'] = 'Описание статуса';
      7.

    7.  $param['helpdesk_status_order'] = 10;
      8.

    8.
      9.

    9.  $newid = $helpdesk->InsertStatus($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::InsertSupportWoktime

InsertSupportWoktime(
int
$helpdesk_id, int
$helpdesk_support_worktime_day, int
$helpdesk_support_worktime_hour );

    Описание

    Добавление рабочего дня службы технической поддержки

    Принимаемые параметры

    $helpdesk_id

    идентификатор службы технической поддержки

    $helpdesk_support_worktime_day

    номер дня (0 - Понедельник, 1 - Вторник и т.д.)

    $helpdesk_support_worktime_hour

    номер часа (0 - 00:00 часов ночи, 1 - 01:00 и т.д.)

    Возвращает

    идентификатор вставленной записи
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_support_worktime_day = 6;
      6.

    6.  $helpdesk_support_worktime_hour = 15;
      7.

    7.
      8.

    8.  $newid = $helpdesk->InsertSupportWoktime($helpdesk_id, $helpdesk_support_worktime_day, $helpdesk_support_worktime_hour);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    [ Наверх ]

    helpdesk::InsertTemplate

InsertTemplate(
array
$param );

    Описание

    Добавление/обновление информации о стандартном ответе

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_letter_template_id'] int Идентификатор обновляемого шаблонного ответа
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_letter_template_dir_id'] int Идентификатор родительской категории
    • $param['helpdesk_letter_template_name'] str Название стандартного ответа
    • $param['helpdesk_letter_template_description'] str Описание стандартного ответа
    • $param['helpdesk_letter_template_text'] str Текст стандартного ответа
    • $param['helpdesk_letter_template_answer_user_id'] int Идентификатор пользователя, от имени которого будет отослан стандартный ответ
    • $param['helpdesk_letter_template_type'] int Тип стандартного ответа (0 - html, 1 - text)

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.
      6.

    6.  $resource = $helpdesk->GetAllTemplateDir($helpdesk_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r ($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::InsertTemplateDir

InsertTemplateDir(
array
$param );

    Описание

    Добавление/обновление информации о категории стандартных ответов

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_letter_template_dir_id'] int Идентификатор обновляемой категории стандартных ответов
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_letter_template_dir_parent_id'] int Идентификатор родительской категории стандартных ответов
    • $param['helpdesk_letter_template_dir_name'] str Имя категории стандартных ответов
    • $param['helpdesk_letter_template_dir_description'] str Описание категории стандартных ответов

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_id'] = 1;
      5.

    5.  $param['helpdesk_letter_template_dir_parent_id'] = 2;
      6.

    6.  $param['helpdesk_letter_template_dir_name'] = 'newtemplatedir';
      7.

    7.  $param['helpdesk_letter_template_dir_description'] = 'Описание категории';
      8.

    8.
      9.

    9.  $newid = $helpdesk->InsertTemplateDir($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::InsertTemplateKeyWords

InsertTemplateKeyWords(
array
$param );

    Описание

    Добавление/обновление информации о ключевом слове

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_letter_template_words_id'] int Идентификатор обновляемого ключевого слова
    • $param['users_id'] int Идентификатор пользователя центра администрирования
    • $param['helpdesk_letter_template_id'] int Идентификатор шаблонного ответа, для которого создается/обновляется ключевое слово
    • $param['helpdesk_letter_template_words_value'] str Ключевое слово или фраза

    Возвращает

    Идентификатор вставленной/обновленной записи, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_letter_template_id'] = 8;
      5.

    5.  $param['helpdesk_letter_template_words_value'] = 'Ключевое слово';
      6.

    6.
      7.

    7.  $newid = $helpdesk->InsertTemplateKeyWords($param);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $newid;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::InsertTicket

InsertTicket(
array
$param );

    Описание

    Добавление информации об инциденте

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['helpdesk_ticket_id'] Идентификатор инцидента
    • str $param['helpdesk_ticket_name'] Название инцидента
    • int $param['users_id'] Идентификатор пользователя центра администрирования
    • int $param['helpdesk_critical_level_id'] Идентификатор уровня критичности
    • int $param['helpdesk_ticket_category_id'] Идентификатор категории инцидентов
    • int $param['site_users_id'] Идентификатор пользователя сайта
    • int $param['helpdesk_id'] Идентификатор службы технической поддержки
    • int $param['helpdesk_ticket_email'] Email пользователя инициировавшего инцидент
    • int $param['helpdesk_ticket_datetime'] Дата-время создания инцидента
    • int $param['helpdesk_ticket_notify_status_message_change'] Флаг, указывающий отправлять ли пользователю уведомление об изменении статуса его сообщения
    • int $param['helpdesk_ticket_sent_answer_for_message'] Флаг, указывающий отправлять ли пользователю ответы на электронный адрес
    • int $param['helpdesk_ticket_is_open'] Флаг, указывающий открыт инцидент или закрыт
    • int $param['helpdesk_ticket_source'] Флаг, указывающий откуда был запрос на создание инцидента (0 - сайт, 1 - E-mail)
    • int $param['helpdesk_email_id'] Идентификатор Emailа службы техподдержки, на который пришло сообщение, инициировавшее инцидент
    • str $param['helpdesk_ticket_answer_by'] - Дата-время приблизительного ответа на сообщение в тикете в формате "Y-m-d H:i:s"

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_ticket_name'] = 'newticket';
      5.

    5.  $param['users_id'] = 19;
      6.

    6.  $param['helpdesk_critical_level_id'] = 3;
      7.

    7.  $param['helpdesk_id'] = 1;
      8.

    8.  $param['helpdesk_ticket_email'] = 'admin@site.ru';
      9.

    9.  $param['helpdesk_ticket_datetime'] = date('Y-m-d H:i:s');
      10.

    10.  $param['helpdesk_ticket_notify_status_message_change'] = 0;
      11.

    11.  $param['helpdesk_ticket_sent_answer_for_message'] = 1;
      12.

    12.  $param['helpdesk_ticket_is_open'] = 1;
      13.

    13.  $param['helpdesk_ticket_source'] = 0;
      14.

    14.  $param['helpdesk_email_id'] = 1;
      15.

    15.  $param['helpdesk_ticket_answer_by'] = '2008-12-23 15:30:37';
      16.

    16.
      17.

    17.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      18.

    18.  if (class_exists('SiteUsers'))
      19.

    19.  {
      20.

    20.      $SiteUsers = & singleton('SiteUsers');
      21.

    21.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      22.

    22.  }
      23.

    23.  else
      24.

    24.  {
      25.

    25.      $site_users_id = 0;
      26.

    26.  }
      27.

    27.
      28.

    28.  $newid = $helpdesk->InsertTicket($param);
      29.

    29.
      30.

    30.  // Распечатаем результат
      31.

    31.  echo $newid;
      32.

    32.  ?>
      33.

    [ Наверх ]

    helpdesk::InsertTicketFlags

InsertTicketFlags(
array
$param );

    Описание

    Добавление/обновление флага к тикету

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['helpdesk_ticket_flags_id'] Идентификтор обновляемой записи
    • int $param['users_id'] Идентификатор пользователя ЦА
    • str $param['helpdesk_ticket_flags_text'] Текст флага
    • int $param['helpdesk_id'] Идентификатор службы техподдержки (Обязательный параметр)
    • int $param['helpdesk_ticket_flags_order'] Порядок сортировки

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['users_id'] = 19;
      5.

    5.  $param['helpdesk_ticket_flags_text'] = 'Текст флага';
      6.

    6.  $param['helpdesk_id'] = 1;
      7.

    7.  $param['helpdesk_ticket_flags_order'] = 10;
      8.

    8.
      9.

    9.  $newid = $helpdesk->InsertTicketFlags($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::InsertUsersLetterTemplate

InsertUsersLetterTemplate(
array
$param );

    Описание

    Добавление/обновление шаблона письма

    Принимаемые параметры

    $param

    Массив параметров
    • $param['helpdesk_id'] int Идентификатор службы техподдержки
    • $param['users_id'] int Идентификатор пользователя
    • $param['helpdesk_users_letter_template_reply'] str Шаблон ответа
    • $param['helpdesk_users_letter_template_new_mail'] str Шаблон нового письма
    • $param['helpdesk_users_letter_template_id'] int Идентификатор шаблона в БД

    Возвращает

    Идентификатор вставленной строки, или false
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['helpdesk_id'] = 1;
      5.

    5.  $param['helpdesk_users_letter_template_reply'] = 'Шаблон ответа';
      6.

    6.  $param['helpdesk_users_letter_template_new_mail'] = 'Шаблон нового письма';
      7.

    7.  $param['users_id'] = 20;
      8.

    8.
      9.

    9.  $result = $helpdesk->InsertUsersLetterTemplate($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $result;
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::InsertWeekend

InsertWeekend(
array
$param );

    Описание

    Вставка/обновление информации о специальном рабочем/выходном дне

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['helpdesk_weekend_id'] Идентификатор специального рабочего/выходного дня, информация о котором обновляется
    • int $param['helpdesk_id'] Идентификатор службы техподдержки (при вставке обязательный параметр)
    • int $param['users_id'] Идентификатор пользователя ЦА
    • str $param['helpdesk_weekend_date'] Дата специального рабочего/выходного дня в формате SQL: ГГГГ-ММ-ДД (при вставке обязательный параметр)
    • int $param['helpdesk_weekend_weekday_num'] Номер дня недели, по расписанию которого будет работать в этот день служба поддержки
    • str $param['helpdesk_weekend_description'] Описание специального рабочего/выходного дня
    • int $param['helpdesk_weekend_is_weekend'] Флаг, указывающий, рабочий день, или выходной (0 - рабочий, 1 - выходной. по умолчанию 0)

    Возвращает

    Идентификатор вставленной/обновленной записи, либо false

    [ Наверх ]

    helpdesk::LoadAttachments

LoadAttachments(
[
$attachments = array ()], int
$helpdesk_id, int
$ticket_id, int
$message_id, array
$attachments[] );

    Описание

    Загрузка на сервер вложенных файлов

    Принимаемые параметры

    $attachments[]

    Массив вложенных файлов
    • $attachments[]['name'] str Оригинальное имя файла
    • $attachments[]['body'] str Тело файла

    $helpdesk_id

    Идентификатор службы техподдержки

    $ticket_id

    Идентификатор тикета

    $message_id

    Идентификатор сообщения

    $attachments

    Возвращает

    Массив с именами записанных на сервер файлов, либо false

    [ Наверх ]

    helpdesk::MessageBlockUnblock

MessageBlockUnblock(
int
$helpdesk_message_id, [int
$message_status_new = -1] );

    Описание

    Блокирование/разблокирование сообщения

    Принимаемые параметры

    $helpdesk_message_id

    Идентификатор сообщения

    $message_status_new

    Флаг, указывающий, нужно заблокировать, или разблокировать сообщение (1 - блокировать, 0 - разблокировать. Не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_id = 14;
      5.

    5.
      6.

    6.  $message_status_new = 1;
      7.

    7.
      8.

    8.  $result = $helpdesk->MessageBlockUnblock($helpdesk_message_id, $message_status_new);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo "Сообщение заблокировано";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Ошибка блокировки";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    helpdesk::RecountAnswerDateTime

RecountAnswerDateTime(
int
$helpdesk_ticket_id, [array
$param = array ()] );

    Описание

    Обновление приблизительной даты ответа на сообщение

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $param

    Массив дополнительных параметров (не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 8;
      5.

    5.
      6.

    6.  $result = $helpdesk->RecountAnswerDateTime($helpdesk_ticket_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    helpdesk::ReFormat

ReFormat(
str
$text, int
$new_type );

    Описание

    Преобразование текста в другой формат

    Принимаемые параметры

    $text

    Текст

    $new_type

    Необходимый формат текста (0 - html, 1 - text)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $text = '<ul><li>Исходный&nbsp;<li>текст <li>для преобразования</ul>';
      5.

    5.  $new_type = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->ReFormat($text, $new_type);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::ReplaceMailMacro

ReplaceMailMacro(
str
$text, [array
$param = array ()] );

    Описание

    Макроподстановки в тексте

    Принимаемые параметры

    $text

    Текст шаблона

    $param

    Массив параметров
    • int $param['helpdesk_message_id'] Идентификатор сообщения, на которое формируется ответ
    • int $param['helpdesk_ticket_id'] Идентификатор тикета
    • str $param['message_body'] Текст сообщения. Если указан, то добавляется как основной текст сообщения-ответа (не обязательный параметр)
    • int $param['users_id'] Идентификатор пользователя - автора ответа

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $text = 'Имя и фамилия отправителя - %FROMNAME';
      5.

    5.  $param['helpdesk_message_id'] = 1;
      6.

    6.  $param['helpdesk_ticket_id'] = 1;
      7.

    7.  $param['users_id'] = 19;
      8.

    8.
      9.

    9.  $result = $helpdesk->ReplaceMailMacro($text, $param = array());
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $result;
      13.

    13.  ?>
      14.

    [ Наверх ]

    helpdesk::ReplyMessageText

ReplyMessageText(
str
$helpdesk_message_message, int
$message_type );

    Описание

    Цитирование текста сообщения, на которое посылается ответ

    Принимаемые параметры

    $helpdesk_message_message

    Текст цитируемого сообщения

    $message_type

    Тип сообщения (0 - html, 1 - text)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_message_message = 'Текст цитируемого сообщения';
      5.

    5.  $message_type = 0;
      6.

    6.
      7.

    7.  $result = $helpdesk->ReplyMessageText($helpdesk_message_message, $message_type);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::SearchIndexing

SearchIndexing(
$limit
$limit, $on_step
$on_step );

    Описание

    Функция обратного вызова для поисковой индексации данных модуля

    Принимаемые параметры

    $limit

    текущая позиция

    $on_step

    шаг

    [ Наверх ]

    helpdesk::SendMessage

SendMessage(
array
$param, int
$helpdesk_message_type );

    Описание

    Отправка сообщений

    Принимаемые параметры

    $param

    Массив параметров
    • str $param['email_to'] Электронный адрес получателя
    • str $param['helpdesk_message_subject'] Тема сообщения
    • str $param['helpdesk_message_message'] Текст сообщения
    • int $param['helpdesk_ticket_id'] Идентификатор тикета
    • array $param['header'] массив дополнительных заголовков сообщения (например, array('Precedence' => 'bulk'))
    • array $param['attachments'][] Массив идентификаторов вложенных файлов

    $helpdesk_message_type

    Тип сообщения (0 - html, 1 - text)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $param['email_to'] = 'admin@site.ru';
      5.

    5.  $param['helpdesk_message_subject'] = 'Тема сообщения';
      6.

    6.  $param['helpdesk_message_message'] = 'Текст сообщения';
      7.

    7.  $param['helpdesk_ticket_id'] = 5;
      8.

    8.  $helpdesk_message_type = 1;
      9.

    9.
      10.

    10.  $result = $helpdesk->SendMessage($param, $helpdesk_message_type);
      11.

    11.
      12.

    12.  if ($result)
      13.

    13.  {
      14.

    14.      echo "Отправка сообщения выполнена успешно";
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Ошибка отправки";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    helpdesk::SentAutoAnswer

SentAutoAnswer(
int
$helpdesk_id, int
$helpdesk_letter_template_id, int
$helpdesk_message_id );

    Описание

    Формирование и отсылка автоответа на сообщение

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $helpdesk_letter_template_id

    Идентификатор автоответа

    $helpdesk_message_id

    Идентификатор сообщения, на которое отсылается автоответ

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $helpdesk_letter_template_id = 6;
      6.

    6.  $helpdesk_message_id = 1;
      7.

    7.
      8.

    8.  $result = $helpdesk->SentAutoAnswer($helpdesk_id, $helpdesk_letter_template_id, $helpdesk_message_id);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo "Отправка автоответа выполнена успешно";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Ошибка отправки";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    helpdesk::SetFlagTicket

SetFlagTicket(
int
$helpdesk_ticket_id, int
$helpdesk_ticket_flags_id );

    Описание

    Применение флага к тикету

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $helpdesk_ticket_flags_id

    Идентификатор флага

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.  $helpdesk_ticket_flags_id = 1;
      6.

    6.
      7.

    7.  $result = $helpdesk->SetFlagTicket($helpdesk_ticket_id, $helpdesk_ticket_flags_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    helpdesk::ShowHelpdesk

ShowHelpdesk(
int
$helpdesk_id, str
$xsl_name, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Показ списка тикетов службы поддержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы поддержки

    $xsl_name

    Название xsl-шаблона

    $param

    Массив дополнительных параметров (не обязательный параметр)
    • int $param['site_users_id'] Идентификатор пользователя сайта, которому принадлежат тикеты
    • int $param['ticket_on_page'] Количество тикетов на странице

    $external_propertys

    Массив дополнительных параметров для включения в XML (не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $xsl_name = 'ВыводСпискаТикетов';
      6.

    6.
      7.

    7.  $helpdesk->ShowHelpdesk ($helpdesk_id, $xsl_name);
      8.

    8.  ?>
      9.

    [ Наверх ]

    helpdesk::ShowTicket

ShowTicket(
int
$helpdesk_ticket_id, str
$xsl_name, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Показ списка сообщений тикета

    Принимаемые параметры

    $helpdesk_ticket_id

    Идентификатор тикета

    $xsl_name

    Название xsl-шаблона

    $param

    Массив дополнительных параметров

    $external_propertys

    (не обязательный параметр)
    • int $param['site_users_id'] Идентификатор пользователя сайта, которому принадлежит тикет
    • array $param['external_xml'] Внешний XML. (отличается от параметров $external_propertys тем, что добавляется блоком в начало документа)
    • int $param['show_add_message'] Флаг, указывающий, отображать форму для добавления сообщения (1 - Только авторизированным, 2 - Всем (по умолчанию))

    Возвращает

    Массив дополнительных параметров для включения в XML (не обязательный параметр)
    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_ticket_id = 1;
      5.

    5.  $xsl_name = 'ВыводСпискаСообщенийТикета';
      6.

    6.
      7.

    7.  $helpdesk->ShowTicket ($helpdesk_ticket_id, $xsl_name);
      8.

    8.  ?>
      9.

    [ Наверх ]

    helpdesk::ShowWorktime

ShowWorktime(
int
$helpdesk_id, str
$xsl_worktime, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Показ режима работы службы техподдержки

    Принимаемые параметры

    $helpdesk_id

    Идентификатор службы техподдержки

    $xsl_worktime

    Название xsl-шаблона для отображения режима работы

    $param

    Массив параметров (не обязательный параметр)

    $external_propertys

    Массив дополнительных параметров для всключения в XML (не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $helpdesk_id = 1;
      5.

    5.  $xsl_worktime = 'ВыводРежимаРаботыСлужбыТехподдержки';
      6.

    6.
      7.

    7.  $helpdesk->ShowWorktime($helpdesk_id, $xsl_worktime);
      8.

    8.  ?>
      9.

    [ Наверх ]

    helpdesk::TicketStatusChange

TicketStatusChange(
int
$ticket_id, [int
$ticket_status_new = -1] );

    Описание

    Изменение статуса тикета

    Принимаемые параметры

    $ticket_id

    Идентификатор тикета

    $ticket_status_new

    Новый статус тикета (0 - закрыт, 1 - открыт, 2 - заблокирован. Не обязательный параметр)

    Возвращает

    1.  <?php
      2.

    2.  $helpdesk = new helpdesk();
      3.

    3.
      4.

    4.  $ticket_id = 1;
      5.

    5.  $ticket_status_new = 2;
      6.

    6.
      7.

    7.  $result = $helpdesk->TicketStatusChange($ticket_id, $ticket_status_new);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

Описания переменных

  • $CacheGetAttachment = array () [Строка 142]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetAttachment()

  • $CacheGetCriticalLevel = array () [Строка 58]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetCriticalLevel()

  • $CacheGetEmail = array () [Строка 170]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetEmail()

  • $CacheGetFirstMessageTicket = array () [Строка 156]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetFirstMessageTicket()

  • $CacheGetHelpdesk = array () [Строка 65]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetHelpdesk()

  • $CacheGetInfo4Messages = array () [Строка 135]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetInfo4Messages()

  • $CacheGetMessage = array () [Строка 93]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetMessage()

  • $CacheGetResponsible = array () [Строка 100]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetResponsible()

  • $CacheGetSiteUserByEmail = array () [Строка 128]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetSiteUserByEmail()

  • $CacheGetStatus = array () [Строка 107]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetStatus()

  • $CacheGetTemplate = array () [Строка 114]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTemplate()

  • $CacheGetTemplateDir = array () [Строка 121]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTemplateDir()

  • $CacheGetTemplateKeyWords = array () [Строка 177]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTemplateKeyWords()

  • $CacheGetTicket = array () [Строка 86]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTicket()

  • $CacheGetTicketByName = array () [Строка 79]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTicketByName()

  • $CacheGetTicketCategory = array () [Строка 72]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTicketCategory()

  • $CacheGetTicketFlags = array () [Строка 51]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTicketFlags()

  • $CacheGetWeekend = array () [Строка 163]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetWeekend()

  • $CacheGetWorkTime = array () [Строка 149]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetWorkTime()

  • $CountDays4FirstWorkDay =  0 [Строка 37]
    •

  • Data type: int
    •

    Описание

    Число дней до первого рабочего

  • $MessageTree =  '' [Строка 44]
    •

  • Data type: str
    •

    Описание

    Дерево сообщений тикета

  • $Path = array () [Строка 23]
    •

  • Data type: array
    •

    Описание

    Массив, содержащий путь от корневой категории

  • $sAllowTag =  '<style><b><strong><p><br><br/><br /><li><ol><ul><pre><em><i><table><tr><td><tbody><h1><h2><h3><h4><h5><h6>' [Строка 179]
    •

  • Data type: mixed
    •

  • $StructuredList = array () [Строка 30]
    •

  • Data type: array
    •

    Описание

    Массив, содержащий структурированный список директорий

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Image

Class Image

[Строка 14]

Размещен: /Kernel/Image.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для работы с графическими изображениями.
Файл: /modules/Kernel/image.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • bool CopyImgWithWatermark()

    Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя

  • resource CreateWatermark()

    Служебный метод для наложения водяного знака

  • array GetImageSize()

    Метод определяет высоту и ширину изображения

  • boolean resizeToFile()

    Метод изменения размера изображения

  • bool ResizeToFileEx()

    Метод для пропорционального масштабирования изображения

  • void setTransparency()

    Установка прозрачности для $new_image, равной прозрачности $image_source

Унаследованные методы

Описания методов

    Image::CopyImgWithWatermark

CopyImgWithWatermark(
string
$source, string
$target_file, string
$watermark, [string
$watermark_x = false], [string
$watermark_y = false] );

    Описание

    Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя

    Принимаемые параметры

    $source

    путь к файлу источнику

    $target_file

    путь к файлу получателю

    $watermark

    путь к файлу watermark-а (в формате PNG)

    $watermark_x

    позиция по оси X (в пикселях или процентах)

    $watermark_y

    позиция по оси Y (в пикселях или процентах)
    1.  <?php
      2.

    2.  $Image = new Image();
      3.

    3.
      4.

    4.  $source = 'file1.jpg';
      5.

    5.  $target_file = 'file2.jpg';
      6.

    6.  $watermark = CMS_FOLDER . 'information_system_watermark1.png';
      7.

    7.
      8.

    8.  $result = $Image->CopyImgWithWatermark($source, $target_file, $watermark);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $result;
      12.

    12.  ?>
      13.

    Возвращает

    результат работы ф-ции.

    [ Наверх ]

    Image::CreateWatermark

CreateWatermark(

&$source_id,
&$watermark_img_obj, [int
$watermark_x = false], [int
$watermark_y = false], resource
$source_id, resource
$watermark_img_obj );

    Описание

    Служебный метод для наложения водяного знака

    Принимаемые параметры

    $source_id

    исходное изображение

    $watermark_img_obj

    водяной знак

    $watermark_x

    позиция по оси X

    $watermark_y

    позиция по оси Y

    &$source_id

    &$watermark_img_obj

    [ Наверх ]

    Image::GetImageSize

GetImageSize(
string
$path );

    Описание

    Метод определяет высоту и ширину изображения

    Принимаемые параметры

    $path

    полный путь к изображению
    1.  <?php
      2.

    2.  $Image = new Image();
      3.

    3.
      4.

    4.  $path = 'file.jpg';
      5.

    5.
      6.

    6.  $row = $Image->GetImageSize($path);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив, содержащий высоту и ширину изображения
    array['width'] - ширина
    array['['height'] - высота  или false, если файл не существует

    [ Наверх ]

    Image::resizeToFile

resizeToFile(
string
$sourcefile, int
$maxsize, string
$target_file, int
$jpegqual );

    Описание

    Метод изменения размера изображения

    Принимаемые параметры

    $sourcefile

    путь к исходному файлу

    $maxsize

    максимальный размер в одном из измерений

    $target_file

    путь для размещения преобразованного файла

    $jpegqual

    качество JPG

    [ Наверх ]

    Image::ResizeToFileEx

ResizeToFileEx(
string
$source_file, int
$max_width, int
$max_height, string
$target_file, [int
$img_quality = false], [int
$image_preserve_aspect_ratio = true] );

    Описание

    Метод для пропорционального масштабирования изображения

    Принимаемые параметры

    $source_file

    путь к исходному файлу

    $max_width

    максимальная ширина картинки

    $max_height

    максимальная высота картинки

    $target_file

    путь к результирующему файлу

    $img_quality

    качество JPEG/PNG файла, если не передано, то берется значение JPG_QUALITY

    $image_preserve_aspect_ratio

    сохранять пропорции изображения, по умолчанию true
    1.  <?php
      2.

    2.  $Image = new Image();
      3.

    3.
      4.

    4.  $source_file = CMS_FOLDER . 'file1.jpg';
      5.

    5.  $max_width = 100;
      6.

    6.  $max_height = 50;
      7.

    7.  $target_file = CMS_FOLDER . 'file2.jpg';
      8.

    8.  $jpeg_quality = JPG_QUALITY;
      9.

    9.
      10.

    10.  $result = $Image->ResizeToFileEx($source_file, $max_width, $max_height, $target_file, $jpeg_quality);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $result;
      14.

    14.  ?>
      15.

    Возвращает

    результат

    [ Наверх ]

    Image::setTransparency

setTransparency(
$new_image
$new_image, $image_source
$image_source );

    Описание

    Установка прозрачности для $new_image, равной прозрачности $image_source

    Принимаемые параметры

    $new_image

    Изображение получатель

    $image_source

    Изображение источник

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class InformationSystem

Class InformationSystem

[Строка 35]

Размещен: /InformationSystems/InformationSystems.class.php

Описание

Класс модуля "Информационные системы"

Свойства класса

  • $CommentMass = array()

        Кэш с данными о комментариях

  • $ItemMass = array()

        Кэш с данными об элементах

  • $MasGroup = array()

        Массив групп

  • $PathArrayGetInformationFromPath = array()

        Массив имен узлов, для которых необходимо в результирующем массиве метода GetInformationFromPath() указать наличие этих узлов.

  • $PropertyGroupMass = array()

        Кэш с данными о дополнительных свойствах информационных групп

  • $PropertyMass = array()

        Кэш с данными о свойствах инфоррмационных элементов

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed AddComment()

    Вставка/обновление комментария для элемента информационной системы

  • mixed AddCommentWithoutStriptags()

    Вставка/обновление комментария без удаления тегов в передаваемых параметрах

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • boolean ChangeAssociateSiteUserWithUsersGroupInformationGroup()

    Добавление/удаление связи пользователя с группой пользователей, связанной с информационной группой

  • int confirm_information_item()

    Определение возможности пользователя добавлять информационный элемент

  • mixed CopyComment()

    Копирование комментария к информационному элементу

  • mixed CopyGroupsProperty()

    Копирование дополнительного свойства информационных групп

  • void CopyInformationItem()

    Копирование информационного элемента

  • mixed CopyInformationSystem()

    Копирование информационной системы

  • void CopyInformationSystemDir()

  • mixed CopyItemsProperty()

    Копирование дополнительного свойства информационных элементов

  • void CopyPropertysGroupsDirForInformationSystem()

    Копирование дочерних групп дополнительных свойств информационных групп

  • void CopyPropertysItemsDirForInformationSystem()

    Копирование дочерних групп дополнительных свойств информационных элементов

  • string CreateGroupsXmlTree()

    Формирование XML дерева для информационных групп

  • boolean DeleteInformationSystemsDir()

    Удаление раздела информационных систем. Информационные системы, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.

  • resource DeletePropertyGroupsDir()

    Удаление информации о группе дополнительных свойств групп информационной системы

  • resource DeletePropertysItemsDir()

    Удаление информации о группе дополнительных свойств информационных элементов

  • boolean DelInformationGroupPropertys()

    Удаление дополнительного свойства информационной группы

  • boolean DelInformationGroupPropertysValue()

    Удаление значений дополнительных свойств информационной группы по идентификатору дополнительного свойства и информационной группы

  • boolean DelInformationGroupPropertyValue()

    Удаление значения дополнительного свойства информационной группы по идентификатору значения дополнительного свойства

  • boolean DelInformationItemPropertyValue()

    Удаление значения дополнительного свойства информационного элемента

  • resource DelInformationSystem()

    Удаление информационной системы

  • boolean del_comment()

    Удаление комментария к информационному элементу

  • boolean del_information_groups()

    Удаление информационной группы

  • boolean del_information_items()

    Удаление элемента информационной системы

  • boolean del_information_propertys()

    Удаление дополнительного свойства элементов информационной системы

  • void FillMasGroup()

    Формирование массива групп для информационной системы (MasGroup)  и массива дерева идентификаторов групп (FullCacheGoupsIdTree).

  • void FillMasGroupExtProperty()

    Формирование массива групп дополнительных свойств информационных элементов самого верхнего уровня для данной информационной системы

  • array FillMasGroupProperty()

    Заполнение массива групп дополнительных свойств групп информационных элементов

  • void FillMemCacheCountItemsAndGroup()

    Определение числа подгрупп и элементов, содержащихся в группах информационной системы

  • void FillMemCachePropertysGroup()

    Формирование в памяти данных о свойствах групп информационной системы.

  • void FillMemFullCacheGoupsIdTree()

    Формирование дерева групп и подгрупп в массиве по их идентификаторам

  • string GenGroupXmlTree()

    Формирование полного XML дерева информационных групп для информационной системы

  • string GenXml4InformationSystem()

    Формирование XML для информационной системы

  • string GenXmlForGroup()

    Генерация XML для группы

  • void GenXmlForGroupsPropertyDir()

    Генерация XML для групп дополнительных свойств групп информационных элементов

  • void GenXmlForItemsPropertyDir()

    Генерация XML для групп дополнительных свойств информационных элементов

  • boolean GetAccessItem()

    Определение доступности информационного элемента

  • array GetAdditionalPropertyPathArray()

    Построение пути от конкретной группы дополнительных свойств информационных элементов до корня

  • array GetAdditionalPropertyPathArrayGroup()

    Построение пути от конкретной группы дополнительных свойств информационных групп до корня

  • массив GetAllInformationGroups()

    Получение информации об информационных группах

  • resource GetAllInformationGroupsPropertys()

    Получение данных о дополнительных свойствах информационных групп

  • resource GetAllInformationItemsPropertys()

    Получение данных о дополнительных свойствах элементов информационной системы

  • mixed GetAllInformationSystems()

    Получение информации о инфосистемах

  • void GetAllInformationSystemsDirs()

    Получение информации о разделах информационных систем

  • resource GetAllInformationSystemsFromDir()

    Получение информации о информационных системах раздела

  • resource GetAllPropertyGroupsDirForInformationSystem()

    Получение информации о всех группах дополнительных свойств групп информационных элементов конкретной информационной системы

  • mixed GetAllPropertysItemsDirForInformationSystem()

    Получение информации обо всех группах дополнительных свойств информационных элементов конкретной информационной системы

  • array GetComment()

    Получение информации о комментарии к информационному элементу

  • mixed GetCommentInformationSystemItem()

    Получение комментариев информационных элементов

  • mixed GetCountCommentInformationItem()

    Определение числа комментариев для информационного элемента

  • mixed GetCountComments()

    Получение числа комментариев к информационным элементам

  • int GetCountInformationSystem()

    Определение количества инфосистем

  • mixed GetCountInformationSystemItem()

    Получение количества элементов информационной системы

  • array GetCountItemsAndGroups()

    Получение числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()

  • int GetCountProperty4InformationSystem()

    Получение числа свойств информационных элементов информационной системы

  • array GetDelimitedGroups()

    Получение иерархического списка групп дополнительнгых свойств групп информационных элементов

  • array GetDelimitedGroupsExtProperty()

    Формирование дерева групп для информационной системы

  • resource GetExternalInformationSystemItem()

    Получение элементов информационной системы. Переименован с GetInformationSystemItem

  • mixed GetGradeInformationSystemItem()

    Получение информации об оценке информационного элемента

  • array GetGroupsInformationSystem()

    Формирование дерева групп информационной системы

  • mixed GetIdInformationItem()

    Определение идентификатора информационного элемента по URI элемента и идентификатору информационной группы

  • mixed GetInformationFromPath()

    Определение идентификатора информационной группы и идентификатора информационного элемента по значению URI

  • mixed GetInformationGroup()

    Получение информации о группе. Использует кэш "INF_SYS_GROUP"

  • mixed GetInformationGroupDir()

    Получение пути хранения файлов информационной группы

  • mixed GetInformationGroupName()

    Получение имени информационной группы

  • array GetInformationGroupsPathArray()

    Построение массива пути от текущей группы к корневой

  • mixed GetInformationGroupsPropertys()

    Получение данных о дополнительном свойстве групп информационной системы

  • mixed GetInformationGroupsPropertyValue()

    Получение информации о значении дополнительного свойства информационных групп

  • mixed GetInformationItemDir()

    Получение пути хранения файлов информационного элемента

  • mixed GetInformationItemPropertyValue()

    Получение информации о значении дополнительного свойства информационного элемента

  • resource GetInformationItemsFromGroup()

    Получение информации об элементах, находящихся в информационной группе

  • mixed GetInformationItemsPropertyValue()

    Получение информации о значении дополнительного свойства информационного элемента по ID связи таблицы information_propertys_items_table

  • mixed GetInformationSystem()

    Получение данных об информационной системе

  • int GetInformationSystemByStructureId()

    Получение информации об информационной системе, связанной с узлом структуры

  • int GetInformationSystemGroupAccess()

    Определения уровня доступности информационной группы

  • mixed GetInformationSystemItem()

    Получение данных об информационном элементе

  • int GetInformationSystemItemAccess()

    Определение уровня доступности информационного элемента

  • mixed GetInformationSystemItemProperty()

    Получение данных о дополнительных свойствах элементов

  • mixed GetInformationSystemItems()

    Получение информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит

  • void GetInformationSystemsDir()

  • array GetInformationSystemsDirPathArray()

    Построение массива пути от текущего раздела информационных систем к корневому

  • array GetInformationSystemsDirs()

    Формирование дерева разделов информационных систем

  • array GetMasGroup()

    Получение массива информационных групп

  • string GetPathGroup()

    Формирование пути по информационным группам

  • string GetPathItem()

    Формирование пути к данному информационному элементу

  • array GetPropertiesGroup()

    Получение данных о дополнительных свойствах информационной группы и их значениях .

  • $this->error GetPropertyError()

    Метод возвращающий код ошибки, возникающей при работе с методами класса

  • array GetPropertyGroupsDir()

    Получение информации о группе дополнительных свойств групп информационной системы

  • string GetPropertySectionPath()

    Получение значения свойтва, содержащего пути по группам

  • mixed GetPropertysInformationSystemItem()

    Получение списка дополнительных свойств и их значений для информационного элемента

  • mixed GetPropertysItemsDir()

    Получение информации о группе дополнительных свойств информационных элементов

  • array GetSiteUsersGroupsForUser()

    Получение списка групп пользователий, в которых содержится пользователь сайта

  • mixed GetTopParentInformationGroup()

    Получение родительской группы находящейся в корне для информационной группы

  • boolean GetXml4Tags()

    Генерация XML для облака тегов информационной системы

  • void GetXmlForInformatioItem()

  • void GetXmlForInformatioItemComments()

    Создает XML для комметариев

  • string GetXmlForInformationItem()

    Формирование XML для отображения информационного элемента

  • string GetXmlForOneComment()

    Генерация XML для комментария и всех его дочерних комментариев.

  • void get_information_groups_path()

    Формирование пути по дереву информационных групп

  • $this->mas_information_groups_for_xml get_mas_information_groups_for_xml()

    Метод возвращает XML для информационных групп

  • bool GroupIsParent()

    Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id

  • void InformationItemIncShowCount()

    Инкрементирование счетчика показов информационного элемента

  • boolean InformationSystemItemAccess()

    Определение доступности информационного элемента для пользователя

  • int InsertInformationGroup()

    Вставка/обновление информации об информационной группе

  • int InsertInformationGroups()

    Вставка/обновление данных об информационной группе. Устаревший метод

  • int InsertInformationItem()

    Вставка/обновление данных об информационном элементе

  • int InsertInformationItems()

    Вставка/обновление данных об информационном элементе. Устаревший метод

  • boolean InsertInformationItemTags()

    Вставка тегов для информационных элементов

  • int InsertInformationPropertys()

    Вставка/обновление информации о дополнительном свойстве информационных элементов

  • int InsertInformationPropertysGroups()

    Вставка/редактирование информации о дополнительном свойстве групп информационной системы

  • int InsertInformationPropertysGroupsValue()

    Вставка/обновление значения свойства информационной группы

  • int InsertInformationPropertysItems()

    Вставка/обновление значения свойства элемента информационной системы

  • mixed InsertInformationSystemsDir()

    Добавление/обновление раздела информационных систем

  • int InsertInfotmationSystem()

    Вставка/обновление данных об информационной системе

  • mixed InsertPropertyGroupsDir()

    Добавление информации о группе дополнительных свойств групп информационной системы

  • mixed InsertPropertysItemsDir()

    Добавление информации о группе дополнительных свойств информационных элементов

  • bool IssetAccessForInformationSystemGroup()

    Проверка возможности доступа пользователя к информационной группе

  • boolean IssetGroup()

    Проверка наличия среди подгрупп данной группы подгруппы с таким же URL как и у вставляемой/редактируемой группы

  • boolean IssetGroupItemInsertUpdate()

    Проверка наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента

  • boolean IssetItem()

    Проверка наличия элемента с конкретным URL среди информационных элементов данной группы

  • boolean IssetItemGroupInsertUpdate()

    Проверка наличия среди информационных элементов данной группы такого, у которого URL совпадает с URL добавляемой/редактируемой информационной группы

  • boolean IssetSiteUserInUsersGroupInformationGroup()

    Проверка вхождения пользователя сайта в группу пользователей, связанную с информационной группой

  • array SearchIndexing()

    Функция обратного вызова для поисковой индексации данных модуля

  • resource SelectInformationGroups()

    Получение информации об информационных группах  Устаревший метод, ОСТАВЛЕН ДЛЯ СОВМЕСТИМОСТИ.

  • resource SelectInformationSystem()

    Получение информации об информационной системе

  • resource SelectListInformationGroupPropertys()

    Получение списка дополнительных свойств информационных группы информационной системы

  • resource SelectPropertysGroupsByDirParentId()

    Получение списка дополнительных свойств информационных групп по идентификатору группы дополнительных свойств

  • resource SelectPropertysItemsByDirParentId()

    Получение списка дополнительных свойств информационных элементов по идентификатору группы дополнительных свойств

  • resource select_comments()

    Получение комментариев к информационному элементу

  • resource select_information_items()

    Устаревший метод получения данных об информационном элементе. Рекомендуется использовать GetInformationSystemItem

  • void SetPathArrayGetInformationFromPath()

    Устаналивает свойство $this->PathArrayGetInformationFromPath

  • boollean ShowAddComment()

    Добавление комментария к элементу информационной системы

  • array ShowInformationSystem()

    Отображение групп и элементов информационной системы

  • boolean ShowInformationSystemItem()

    Отображение информации об информационном элементе

  • void ShowInformationSystemPageConfig()

    Вызов настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы

  • void ShowInformationSystemPageContent()

    Вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы

  • void ShowInformationSystemRss()

    Отображение RSS ленты

  • boolean ShowTagsCloud()

    Показ облака тегов для информационной системы

  • boolean UserCanAddComment()

    Определение возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY

  • string _CallbackSearch()

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

Унаследованные методы

Описания методов

    InformationSystem::AddComment

AddComment(
array
$param );

    Описание

    Вставка/обновление комментария для элемента информационной системы

    Принимаемые параметры

    $param

    массив значений
    • int $param['comment_id'] идентификатор обновляемого комментария (при вставке равен 0)
    • int $param['information_items_id'] идентитфикатор информационного элемента
    • int $param['comment_parent_id'] идентитфикатор родительского комментария
    • string $param['comment_fio'] ФИО автора комментария
    • string $param['comment_email'] e-mail автора комментария
    • string $param['comment_text'] текст комментария
    • string $param['comment_status'] параметр, определяющий статус активности комментария
    1. – не отображать, 1 - отображать
    • string $param['comment_subject'] тема комментария
    • string $param['comment_ip'] ip-адрес отправителя комментария
    • string $param['comment_date'] дата отправки комментария
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['comment_grade'] оценка по 5 бальной шкале
    • int $param['users_id'] идентификатор пользователя ЦЕНТРА АДМИНИСТРИРОВАНИЯ, добавившего элемент
    • int $param['site_users_id'] идентификатор пользователя САЙТА, добавившего элемент

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $param['comment_id'] = 0;
        5.

      5.  $param['information_items_id'] = 106;
        6.

      6.  $param['comment_parent_id'] = 0;
        7.

      7.  $param['comment_fio'] = 'ФИО';
        8.

      8.  $param['comment_email'] = 'info@site.ru';
        9.

      9.  $param['comment_text'] = 'Текст комментария';
        10.

      10.  $param['comment_status'] = 1;
        11.

      11.  $param['comment_subject'] = 'Тема комментария';
        12.

      12.  $param['comment_ip'] = '';
        13.

      13.  $param['comment_date'] = date('Y-m-d H:i:s');
        14.

      14.  $param['comment_grade'] = 3;
        15.

      15.  $param['users_id'] = '';
        16.

      16.
        17.

      17.
        18.

      18.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        19.

      19.  if (class_exists('SiteUsers'))
        20.

      20.  {
        21.

      21.     $SiteUsers = & singleton('SiteUsers');
        22.

      22.     $param['site_users_id'] =$SiteUsers->GetCurrentSiteUser();
        23.

      23.  }
        24.

      24.  else
        25.

      25.  {
        26.

      26.      $param['site_users_id'] =0;
        27.

      27.  }
        28.

      28.
        29.

      29.  $newid = $InformationSystem->AddComment($param);
        30.

      30.
        31.

      31.  // Распечатаем результат
        32.

      32.  if ($newid)
        33.

      33.  {
        34.

      34.      echo 'Комментарий добавлен';
        35.

      35.  }
        36.

      36.  else
        37.

      37.  {
        38.

      38.      echo 'Ошибка! Комментарий не добавлен!';
        39.

      39.  }
        40.

      40.  ?>
        41.

    Возвращает

    идентификатор элемента или false в случае ошибки

    [ Наверх ]

    InformationSystem::AddCommentWithoutStriptags

AddCommentWithoutStriptags(
array
$param );

    Описание

    Вставка/обновление комментария без удаления тегов в передаваемых параметрах

    Принимаемые параметры

    $param

    массив значений
    • int $param['comment_id'] идентификатор обновляемого комментария (при вставке равен 0)
    • int $param['information_items_id'] идентитфикатор информационного элемента
    • int $param['comment_parent_id'] идентитфикатор родительского комментария
    • string $param['comment_fio'] ФИО автора комментария
    • string $param['comment_email'] e-mail автора комментария
    • string $param['comment_text'] текст комментария
    • string $param['comment_status'] параметр, определяющий статус активности комментария^
    1. – не отображать, 1 - отображать
    • string $param['comment_subject'] тема комментария
    • string $param['comment_ip'] ip-адрес отправителя комментария
    • string $param['comment_date'] дата отправки комментария
    • int $param['comment_grade'] оценка по 5 бальной шкале
    • int $param['users_id'] идентификатор пользователя ЦЕНТРА АДМИНИСТРИРОВАНИЯ, добавившего элемент
    • int $param['site_users_id'] идентификатор пользователя, добавившего элемент (необязательное поле,
    • string $param['comment_phone'] номер телефона
     значение может быть определено автоматически)
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $param['comment_id'] = 9;
      5.

    5.  $param['information_items_id'] = 106;
      6.

    6.  $param['comment_parent_id'] = 0;
      7.

    7.  $param['comment_fio'] = 'ФИО';
      8.

    8.  $param['comment_email'] = 'info@site.ru';
      9.

    9.  $param['comment_text'] = 'Измененный текст комментария';
      10.

    10.  $param['comment_status'] = 1;
      11.

    11.  $param['comment_subject'] = 'Тема комментария';
      12.

    12.  $param['comment_ip'] = '';
      13.

    13.  $param['comment_date'] = date('Y-m-d H:i:s');
      14.

    14.  $param['comment_grade'] = 5;
      15.

    15.  $param['users_id'] = '';
      16.

    16.
      17.

    17.
      18.

    18.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      19.

    19.  if (class_exists('SiteUsers'))
      20.

    20.  {
      21.

    21.     $SiteUsers = & singleton('SiteUsers');
      22.

    22.     $param['site_users_id'] = $SiteUsers->GetCurrentSiteUser();
      23.

    23.  }
      24.

    24.
      25.

    25.  else
      26.

    26.  {
      27.

    27.     $param['site_users_id'] = 0;
      28.

    28.  }
      29.

    29.
      30.

    30.  $newid = $InformationSystem->AddCommentWithoutStriptags($param);
      31.

    31.
      32.

    32.  // Распечатаем результат
      33.

    33.  if ($newid)
      34.

    34.  {
      35.

    35.      echo 'Комментарий изменен';
      36.

    36.  }
      37.

    37.  else
      38.

    38.  {
      39.

    39.      echo 'Ошибка! Комментарий не изменен!';
      40.

    40.  }
      41.

    41.  ?>
      42.

    Возвращает

    идентификатор элемента или false в случае ошибки

    [ Наверх ]

    InformationSystem::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    InformationSystem::ChangeAssociateSiteUserWithUsersGroupInformationGroup

ChangeAssociateSiteUserWithUsersGroupInformationGroup(
array
$param );

    Описание

    Добавление/удаление связи пользователя с группой пользователей, связанной с информационной группой

    Принимаемые параметры

    $param

    массив параметров
    • $param['site_user_id'] идентификатор пользователя сайта
    • $param['site_users_group_id'] идентификатор группы пользователей сайта
    • $param['information_group_id'] идентификатор информационной группы
    • $param['associate'] параметр, определяющий добавить или удалить связь пользователя с группой пользователей (1 - включить в группу, 0 - удалить из группы)

    Возвращает

    true в случае отсутствия ошибки, false - в противном случае

    [ Наверх ]

    InformationSystem::confirm_information_item

confirm_information_item(
string
$date, string
$information_item_ip );

    Описание

    Определение возможности пользователя добавлять информационный элемент

    Принимаемые параметры

    $date

    дата и время (в Unix-формате) добавления информационного элемента

    $information_item_ip

    ip-адрес компьютера пользователя, добавляющего информационный элемент
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $date = time();
      5.

    5.  $information_item_ip = '192.169.0.4';
      6.

    6.
      7.

    7.  $result = $InformationSystem->confirm_information_item($date, $information_item_ip);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    0 – пользователь не может добавлять информационный элемент, 1- может добавлять информационный элемент

    [ Наверх ]

    InformationSystem::CopyComment

CopyComment(
int
$comment_id );

    Описание

    Копирование комментария к информационному элементу

    Принимаемые параметры

    $comment_id

    идентификатор копируемого комментария
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $comment_id = 11;
      5.

    5.
      6.

    6.  $newid = $InformationSystem->CopyComment($comment_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($newid)
      10.

    10.  {
      11.

    11.      echo 'Комментарий скопирован';
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo 'Ошибка! Комментарий не скопирован!';
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    идентификатор копии коментария в случае успешного выполнения, в противном случае -  false

    [ Наверх ]

    InformationSystem::CopyGroupsProperty

CopyGroupsProperty(
$groups_property_id
$groups_property_id, [$information_system_id
$information_system_id = false] );

    Описание

    Копирование дополнительного свойства информационных групп

    Принимаемые параметры

    $groups_property_id

    идентификатор дополнительного свойства информационных групп

    $information_system_id

    идентификатор информационной системы, в которую будет скопировано дополнительное свойство.
    По умолчанию равен false - используется информационная система, к которой принадлежит копируемое дополнительное свойство.

    Возвращает

    идентификатор копии дополнительного свойства информационных групп в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    InformationSystem::CopyInformationItem

CopyInformationItem(
int
$information_item_id );

    Описание

    Копирование информационного элемента

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента, который необходимо скопировать
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_item_id = 1;
      5.

    5.
      6.

    6.  $InformationSystem->CopyInformationItem($information_item_id);
      7.

    7.
      8.

    8.  ?>
      9.

    [ Наверх ]

    InformationSystem::CopyInformationSystem

CopyInformationSystem(
int
$information_system_id, [int
$new_site_id = false], [int
$structure_id = false], [bool
$copy_with_sns = false], [
$information_systems_dir_id = false] );

    Описание

    Копирование информационной системы

    Принимаемые параметры

    $information_system_id

    идентификатор копируемой информационной системы

    $new_site_id

    идентификатор нового сайта, если не передан копируется в текущий сайт

    $structure_id

    идентификатор узла структуры, которому следует ассоциировать копию информационной системы, если не передан используется "0"

    $copy_with_sns

    флаг, указывающий копировать ли все блоги, ассоциированные данной информационной системе с сохранением связей, либо не копировать
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_system_id = 1;
      5.

    5.
      6.

    6.  $new_information_system_id = $InformationSystem->CopyInformationSystem($information_system_id);
      7.

    7.
      8.

    8.  if ($new_information_system_id)
      9.

    9.  {
      10.

    10.      echo 'Информационная система скопирована!';
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo 'Ошибка! Информационная система не скопирована!';
      15.

    15.  }
      16.

    16.  ?>
      17.

    $information_systems_dir_id

    Возвращает

    идентификатор копии информационной системы или false

    [ Наверх ]

    InformationSystem::CopyInformationSystemDir

CopyInformationSystemDir(

$param );

    Принимаемые параметры

    $param

    [ Наверх ]

    InformationSystem::CopyItemsProperty

CopyItemsProperty(
$items_property_id
$items_property_id, [$information_system_id
$information_system_id = false] );

    Описание

    Копирование дополнительного свойства информационных элементов

    Принимаемые параметры

    $items_property_id

    идентификатор дополнительного свойства информационных элементов

    $information_system_id

    идентификатор информационной системы, в которую будет скопировано дополнительное свойство.
    По умолчанию равен false - используется информационная система, к которой принадлежит копируемое дополнительное свойство.

    Возвращает

    идентификатор копии дополнительного свойства информационных элементов в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    InformationSystem::CopyPropertysGroupsDirForInformationSystem

CopyPropertysGroupsDirForInformationSystem(
int
$propertys_groups_dir_parent_id, [int
$information_system_id = 0], [int
$copy_propertys_groups_dir_parent_id = 0], [$copy_information_system_id
$copy_information_system_id = 0] );

    Описание

    Копирование дочерних групп дополнительных свойств информационных групп

    Принимаемые параметры

    $propertys_groups_dir_parent_id

    идентификатор родительской группы дополнительных свойств информационных групп

    $information_system_id

    идентификатор информационной системы

    $copy_propertys_groups_dir_parent_id

    идентификатор копии родительской группы дополнительных свойств групп (служебный параметр)

    $copy_information_system_id

    идентификатор копируемой информационной системы

    [ Наверх ]

    InformationSystem::CopyPropertysItemsDirForInformationSystem

CopyPropertysItemsDirForInformationSystem(
int
$propertys_items_dir_parent_id, [int
$information_system_id = 0], [int
$copy_propertys_items_dir_parent_id = 0], [$copy_information_system_id
$copy_information_system_id = 0] );

    Описание

    Копирование дочерних групп дополнительных свойств информационных элементов

    Принимаемые параметры

    $propertys_items_dir_parent_id

    идентификатор родительской группы дополнительных свойств информационных элементов

    $information_system_id

    идентификатор информационной системы

    $copy_propertys_items_dir_parent_id

    идентификатор копии родительской группы дополнительных свойств (служебный параметр)

    $copy_information_system_id

    идентификатор копируемой информационной системы

    [ Наверх ]

    InformationSystem::CreateGroupsXmlTree

CreateGroupsXmlTree(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$xmlData, int
$items_on_page, int
$items_begin );

    Описание

    Формирование XML дерева для информационных групп

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор информационной группы, подгруппы которой будут включены для построения XML дерева

    $InformationSystem_id

    идентификатор информационной системы, для групп которой будет строиться XML дерево

    $xmlData

    XML с данными об информационной системе

    $items_on_page

    параметр, указывающий количество элементов информационной системы отображаемых на странице

    $items_begin

    параметр, указывающий с какого информационного элемента отображать элементы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_groups_parent_id = 0;
      5.

    5.  $InformationSystem_id = 1;
      6.

    6.  $xmlData = '';
      7.

    7.  $items_on_page = 5;
      8.

    8.  $items_begin = 1;
      9.

    9.
      10.

    10.  $xml = $InformationSystem->CreateGroupsXmlTree($information_groups_parent_id, $InformationSystem_id, $xmlData, $items_on_page, $items_begin);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo nl2br(htmlspecialchars($xml));
      14.

    14.  ?>
      15.

    Возвращает

    XML дерево с данными об информационной системе и ее группах

    [ Наверх ]

    InformationSystem::DeleteInformationSystemsDir

DeleteInformationSystemsDir(
int
$information_systems_dir_id );

    Описание

    Удаление раздела информационных систем. Информационные системы, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.

    Принимаемые параметры

    $information_systems_dir_id

    идентификатор раздела информационных систем

    [ Наверх ]

    InformationSystem::DeletePropertyGroupsDir

DeletePropertyGroupsDir(
int
$information_propertys_groups_dir_id );

    Описание

    Удаление информации о группе дополнительных свойств групп информационной системы

    Принимаемые параметры

    $information_propertys_groups_dir_id

    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_groups_dir_id = 3;
      5.

    5.
      6.

    6.  $result = $InformationSystem->DeletePropertyGroupsDir($information_propertys_groups_dir_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Группа дополнительных cвойств информационных групп удалена";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка! Группа дополнительных cвойств информационных групп не удалена!";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    InformationSystem::DeletePropertysItemsDir

DeletePropertysItemsDir(
int
$information_propertys_items_dir_id );

    Описание

    Удаление информации о группе дополнительных свойств информационных элементов

    Принимаемые параметры

    $information_propertys_items_dir_id

    Идентификатор группы дополнительных свойств информационных элементов
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_items_dir_id = 2;
      5.

    5.
      6.

    6.  $resource = $InformationSystem->DeletePropertysItemsDir($information_propertys_items_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($resource)
      10.

    10.  {
      11.

    11.      echo 'Группа дополнительных свойств информационных элементов удалена';
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo 'Ошибка! Группа дополнительных свойств информационных элементов не удалена!';
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    InformationSystem::DelInformationGroupPropertys

DelInformationGroupPropertys(
int
$property_id, [$group_id
$group_id = false] );

    Описание

    Удаление дополнительного свойства информационной группы

    Принимаемые параметры

    $property_id

    идентификатор дополнительного свойства информационной группы

    $group_id

    идентификатор группы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $property_id= 9;
      5.

    5.
      6.

    6.  $result = $InformationSystem->DelInformationGroupPropertys($property_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::DelInformationGroupPropertysValue

DelInformationGroupPropertysValue(
int
$property_id, int
$group_id, [
$param = array('del_big_image'=>true, 'del_small_image'=>true)] );

    Описание

    Удаление значений дополнительных свойств информационной группы по идентификатору дополнительного свойства и информационной группы

    Принимаемые параметры

    $property_id

    идентификатор дополнительного свойства информационной группы

    $group_id

    идентификатор информационной группы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $property_id= 8;
      5.

    5.  $group_id = 12;
      6.

    6.
      7.

    7.  $result = $InformationSystem->DelInformationGroupPropertysValue($property_id, $group_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Значение дополнительного свойства инфорационной группы удалено";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка! Значение дополнительного свойства информационной группы не удалено!";
      16.

    16.  }
      17.

    17.  ?>
      18.

    $param

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::DelInformationGroupPropertyValue

DelInformationGroupPropertyValue(
int
$property_value_id, array
$param );

    Описание

    Удаление значения дополнительного свойства информационной группы по идентификатору значения дополнительного свойства

    Принимаемые параметры

    $property_value_id

    идентификатор значения дополнительного свойства информационной группы

    $param

    массив дополнительных параметров
    • $param['del_big_image'] параметр, определяющий удалять файл большого изображения или нет (true - удалять (по умолчанию), false - не удалять)
    • $param['del_small_image'] параметр, определяющий удалять файл малого изображения или нет (true - удалять (по умолчанию), false - не удалять)

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $property_value_id = 8;
        5.

      5.
        6.

      6.  $result = $InformationSystem->DelInformationGroupPropertyValue($property_value_id);
        7.

      7.
        8.

      8.  if ($result)
        9.

      9.  {
        10.

      10.      echo "Удаление выполнено успешно";
        11.

      11.  }
        12.

      12.  else
        13.

      13.  {
        14.

      14.      echo "Ошибка удаления";
        15.

      15.  }
        16.

      16.  ?>
        17.

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::DelInformationItemPropertyValue

DelInformationItemPropertyValue(
int
$information_propertys_item_id, [array
$param = array()] );

    Описание

    Удаление значения дополнительного свойства информационного элемента

    Принимаемые параметры

    $information_propertys_item_id

    идентификатор зачения дополнительного свойства информационного элемента

    $param

    массив дополнительных параметров
    • $param['del_big_image'] параметр, определяющий удалять файл большого изображения или нет (true - удалять (по умолчанию), false - не удалять)
    • $param['del_small_image'] параметр, определяющий удалять файл малого изображения или нет (true - удалять (по умолчанию), false - не удалять)

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_propertys_item_id= 67;
        5.

      5.
        6.

      6.  $result = $InformationSystem->DelInformationItemPropertyValue($information_propertys_item_id);
        7.

      7.
        8.

      8.  if ($result)
        9.

      9.  {
        10.

      10.     echo "Удаление выполнено успешно";
        11.

      11.  }
        12.

      12.  else
        13.

      13.  {
        14.

      14.      echo "Ошибка удаления";
        15.

      15.  }
        16.

      16.  ?>
        17.

    Возвращает

    true - значение дополнительного свойства элемента удалено, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::DelInformationSystem

DelInformationSystem(
int
$information_systems_id );

    Описание

    Удаление информационной системы

    Принимаемые параметры

    $information_systems_id

    идентификатор информационной системы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_systems_id = 16;
      5.

    5.
      6.

    6.  $resource = $InformationSystem->DelInformationSystem($information_systems_id);
      7.

    7.
      8.

    8.  if ($resource)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    InformationSystem::del_comment

del_comment(
int
$comment_id );

    Описание

    Удаление комментария к информационному элементу

    Принимаемые параметры

    $comment_id

    идентификатор комментария
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $comment_id = 10;
      5.

    5.
      6.

    6.  $result = $InformationSystem->del_comment($comment_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::del_information_groups

del_information_groups(
int
$information_groups_id, int
$InformationSystem_id );

    Описание

    Удаление информационной группы

    Принимаемые параметры

    $information_groups_id

    идентификатор удаляемой информационной группы

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит информационная группа
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_groups_id = 1;
      5.

    5.  $InformationSystem_id = 1;
      6.

    6.
      7.

    7.  $result = $InformationSystem->del_information_groups($information_groups_id, $InformationSystem_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::del_information_items

del_information_items(
int
$information_items_id );

    Описание

    Удаление элемента информационной системы

    Принимаемые параметры

    $information_items_id

    идентификатор удаляемого информационного элемента
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_items_id = 106;
      5.

    5.
      6.

    6.  $result = $InformationSystem->del_information_items($information_items_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::del_information_propertys

del_information_propertys(
int
$information_propertys_id );

    Описание

    Удаление дополнительного свойства элементов информационной системы

    Принимаемые параметры

    $information_propertys_id

    идентификатор удаляемого свойства элементов информационной системы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_id = 99;
      5.

    5.
      6.

    6.  $result = $InformationSystem->del_information_propertys($information_propertys_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    [ Наверх ]

    InformationSystem::FillMasGroup

FillMasGroup(
[int
$InformationSystem_id = false], [$param
$param = array()] );

    Описание

    Формирование массива групп для информационной системы (MasGroup)  и массива дерева идентификаторов групп (FullCacheGoupsIdTree).

    При вызове метода FillMasGroup(), метод FillMemFullCacheGoupsIdTree() вызывать не следует,  т.к. его функционал выполняется FillMasGroup

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы, для которой заполняем массив групп самого верхнего уровня

    $param

    массив дополнительных параметров

    see

    InformationSystem::GetAllInformationGroups()

    [ Наверх ]

    InformationSystem::FillMasGroupExtProperty

FillMasGroupExtProperty(
int
$information_systems_id, [array
$param = array()] );

    Описание

    Формирование массива групп дополнительных свойств информационных элементов самого верхнего уровня для данной информационной системы

    Принимаемые параметры

    $information_systems_id

    идентификатор информационной системы, для которой заполняем массив групп самого верхнего уровня
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_systems_id = 1;
      5.

    5.
      6.

    6.  $row = $InformationSystem->FillMasGroupExtProperty($information_systems_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    $param

    массив дополнительных параметров

    [ Наверх ]

    InformationSystem::FillMasGroupProperty

FillMasGroupProperty(
int
$information_systems_id, [array
$param = array()] );

    Описание

    Заполнение массива групп дополнительных свойств групп информационных элементов

    Принимаемые параметры

    $information_systems_id

    идентифкатор информационной системы

    $param

    массив дополнительных параметров
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_systems_id = 1;
      5.

    5.
      6.

    6.  $row = $InformationSystem->FillMasGroupProperty($information_systems_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив групп дополнительных свойств

    [ Наверх ]

    InformationSystem::FillMemCacheCountItemsAndGroup

FillMemCacheCountItemsAndGroup(
int
$information_system_id, [int
$site_user_id = 0] );

    Описание

    Определение числа подгрупп и элементов, содержащихся в группах информационной системы

    Информация сохраняется в массиве:
    для числа групп в группе $this->CacheCountGroupsAndItems[information_system_id][information_groups_id]['GROUPS']
    для числа элементов в группе $this->CacheCountGroupsAndItems[information_system_id][information_groups_id]['ITEMS']

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $site_user_id

    идентификатор пользователя сайта, необязательный параметр. по умолчанию = 0.

    [ Наверх ]

    InformationSystem::FillMemCachePropertysGroup

FillMemCachePropertysGroup(
int
$information_system_id, [array
$information_propertys_groups_id_array = array()] );

    Описание

    Формирование в памяти данных о свойствах групп информационной системы.

    Рекомендуется использовать совместно с GetPropertiesGroup() при выборе свойств всех групп информационной системы.

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $information_propertys_groups_id_array

    массив свойств, для которых осущестлвяется выборка,  если не передан (по умолчанию является пустым массивом) - выбираются все свойства  param
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_system_id = 1;
      5.

    5.
      6.

    6.  $row = $InformationSystem->FillMemCachePropertysGroup($information_system_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    InformationSystem::FillMemFullCacheGoupsIdTree

FillMemFullCacheGoupsIdTree(
int
$information_system_id, [array
$param = array()] );

    Описание

    Формирование дерева групп и подгрупп в массиве по их идентификаторам

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $param

    массив дополнительных параметров
    • Все параметры метода GetAllInformationGroups()
    • $param['cache_name'] - ссылка на переменную для сохранения дерева групп, по умолчанию $this->FullCacheGoupsIdTree, необязательный параметр

    [ Наверх ]

    InformationSystem::GenGroupXmlTree

GenGroupXmlTree(
int
$information_system_id, [array
$property = array('is_get_information_for_property' => false)] );

    Описание

    Формирование полного XML дерева информационных групп для информационной системы

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $property

    массив дополнительных параметров
    • $property['is_get_information_for_property'] параметр, исключающий рекурсию, возникающую при вызове для группы свойства типа "Информационная система" , имеющего также свойство типа "Информационная система" (эффект зазеркаливания), по умолчанию false
    • $property['groups_parent_id'] идентификатор группы, начиная с которой необходимо строить дерево
    • $property['current_group_id'] идентификатор текущей группы, используется для вывода всех дополнительных
    • $property['xml_show_group_property'] параметр, определяющий необходимо ли добавлять в XML-данные о дополнительных свойствах информацию о группах дополнительных свойств для информационной группы
    • $property['groups_activity'] параметр, учитывающий активность групп при выборке. 1 - получаем информацию только об активных группах, если не задан, то активность группы не учитывается
    • $property['sql_from_select_groups'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.
    • $property['xml_show_group_type'] параметр, определяющий тип генерации XML групп, может принимать значения (по умолчанию 'tree'):

      • all - все группы всех уровней;
      • current - группы только текущего уровня;
      • tree - будет выбрана текущая группа, все группы, находящиеся на одном уровне с ней, непосредственные потомки текущей группы, а также все группы, являющиеся предками для текущей
      • one_group - только текущая группа;
      • none - не выбирать группы.
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_system_id = 1;
      5.

    5.
      6.

    6.  $property['is_get_information_for_property'] = false;
      7.

    7.  $property['groups_parent_id'] = 0;
      8.

    8.  $property['xml_show_group_property'] = 1;
      9.

    9.
      10.

    10.  $xmlData = $InformationSystem->GenGroupXmlTree($information_system_id, $property);
      11.

    11.
      12.

    12.  echo nl2br(htmlspecialchars($xmlData));
      13.

    13.  ?>
      14.

    Возвращает

    XML дерево групп информационной системы

    see

    InformationSystem::FillMasGroup(), InformationSystem::GetAllInformationGroups()

    [ Наверх ]

    InformationSystem::GenXml4InformationSystem

GenXml4InformationSystem(
int
$information_system_id, [mixed
$information_system_row = false] );

    Описание

    Формирование XML для информационной системы

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $information_system_row

    массив с информацией об информационной системе
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_system_id = 1;
      5.

    5.
      6.

    6.  $xml = $InformationSystem->GenXml4InformationSystem($information_system_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo nl2br(htmlspecialchars($xml));
      10.

    10.  ?>
      11.

    Возвращает

    XML с данными о информационной системе

    [ Наверх ]

    InformationSystem::GenXmlForGroup

GenXmlForGroup(
int
$information_system_id, array
$row, array
$property, [int
$site_user_id = false] );

    Описание

    Генерация XML для группы

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $row

    массив с информацией о группе

    $property

    массив свойств, принимаемых GenGroupXmlTree()
    • $property['xml_show_external_property'] параметр, разрешающий передачу в XML информации о дополнительных свойствах пользователя, по умолчанию false
    • $property['xml_show_count_items_and_group'] отображать количество элементов и групп

    $site_user_id

    идентификатор пользователя сайта, если не указан, определяется автоматически
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $group_info = $InformationSystem->GetInformationGroup(3);
      5.

    5.
      6.

    6.  $information_system_id = 1;
      7.

    7.  $property = array();
      8.

    8.
      9.

    9.  $xmlData = $InformationSystem->GenXmlForGroup($information_system_id, $group_info, $property);
      10.

    10.
      11.

    11.  echo nl2br(htmlspecialchars($xmlData));
      12.

    12.  ?>
      13.

    see

    InformationSystem::GenGroupXmlTree()

    [ Наверх ]

    InformationSystem::GenXmlForGroupsPropertyDir

GenXmlForGroupsPropertyDir(
int
$information_systems_id, [int
$information_propertys_groups_dir_parent_id = 0] );

    Описание

    Генерация XML для групп дополнительных свойств групп информационных элементов

    Принимаемые параметры

    $information_systems_id

    Идентификатор информационной системы

    $information_propertys_groups_dir_parent_id

    Идентификатор родительской группы

    [ Наверх ]

    InformationSystem::GenXmlForItemsPropertyDir

GenXmlForItemsPropertyDir(
int
$information_systems_id, [int
$information_propertys_items_dir_parent_id = 0] );

    Описание

    Генерация XML для групп дополнительных свойств информационных элементов

    Принимаемые параметры

    $information_systems_id

    идентификатор информационной системы

    $information_propertys_items_dir_parent_id

    идентификатор родительской директории дополнительных свойств информационных элементов

    [ Наверх ]

    InformationSystem::GetAccessItem

GetAccessItem(
int
$site_users_id, int
$information_items_id, [array
$row_item = array()], int
$parent );

    Описание

    Определение доступности информационного элемента

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $information_items_id

    идентификатор инфоэлемента

    $parent

    параметр, определяющий наследует ли информационный элемент тип доступа от родителя (1 - наследует, 0 - не наследует)

    $row_item

    ассоциативный массив свойств информационного элемента
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  // Получим текущего пользователя
      5.

    5.  $SiteUsers = new SiteUsers();
      6.

    6.  $site_users_id = $SiteUsers->GetCurrentSiteUser();
      7.

    7.
      8.

    8.  $information_items_id = 2;
      9.

    9.
      10.

    10.  $result = $InformationSystem->GetAccessItem($site_users_id, $information_items_id);
      11.

    11.
      12.

    12.  if ($result)
      13.

    13.  {
      14.

    14.      echo "Информационный элемент доступен пользователю";
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.  echo "Информационный элемент не доступен пользователю";
      19.

    19.  }
      20.

    20.  ?>
      21.

    Возвращает

    true - информационный элемент доступен пользователю, false - не доступен пользователю

    [ Наверх ]

    InformationSystem::GetAdditionalPropertyPathArray

GetAdditionalPropertyPathArray(
int
$information_propertys_items_dir_id, [boolean
$first_call = true] );

    Описание

    Построение пути от конкретной группы дополнительных свойств информационных элементов до корня

    Принимаемые параметры

    $information_propertys_items_dir_id

    Идентификатор группы дополнительных свойств информационных элементов

    $first_call

    параметр, определяющий первый ли это вызов метода
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_items_dir_id = 4;
      5.

    5.
      6.

    6.  $row = $InformationSystem->GetAdditionalPropertyPathArray($information_propertys_items_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив элементов пути

    [ Наверх ]

    InformationSystem::GetAdditionalPropertyPathArrayGroup

GetAdditionalPropertyPathArrayGroup(

$information_propertys_groups_dir_id, [boolean
$first_call = true], int
$information_propertys_items_dir_id );

    Описание

    Построение пути от конкретной группы дополнительных свойств информационных групп до корня

    Принимаемые параметры

    $information_propertys_items_dir_id

    Идентификатор группы дополнительных свойств информационных элементов

    $first_call

    Первый ли это вызов функции
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_groups_dir_id = 3;
      5.

    5.
      6.

    6.  $row = $InformationSystem->GetAdditionalPropertyPathArrayGroup($information_propertys_groups_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    $information_propertys_groups_dir_id

    Возвращает

    массив элементов пути

    [ Наверх ]

    InformationSystem::GetAllInformationGroups

GetAllInformationGroups(
array
$param );

    Описание

    Получение информации об информационных группах

    Принимаемые параметры

    $param

    массив параметров параметров
    • $param['information_system_id'] идентификатор информационной системы, по умолчанию равен false
    • $param['OrderGroup'] = ASC/DESC порядок сортировки информационных групп
    • $param['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()
    • $param['NotInGroup'] строка с идентификаторами информационных групп (через запятую), которые (группы) необходимо исключить из результатов. Не влияет на выборку информационных элементов.
    • $param['groups_parent_id'] идентификатор родительской группы, необязательный параметр, по умолчанию false
    • $param['groups_on_page'] число информационных групп, отображаемых на странице
    • $param['groups_begin'] номер, начиная с которого выводить информационные группы
    • $param['groups_activity'] параметр, учитывающий активность групп при выборке. 1 - получаем информацию только об активных группах, если не задан, то активность группы не учитывается
    • $param['sql_from_select_groups'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.
    • $param['select_groups'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных групп

    • $element['type'] определяет, является ли поле основным свойством информационной группы или дополнительным (0 - основное, 1 - дополнительное)
    • $element['prefix'] префикс - строка, размещаемая перед условием
    • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    • $element['property_id'] идентификатор дополнительногого свойства информационных групп
    • $element['if'] строка, содержащая условный оператор
    • $element['value'] значение поля (или параметра)
    • $element['sufix'] суффикс - строка, размещаемая после условия

    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  // Получаем информацию об активных информационных группах, находящихся в корне информационной системы с идентификатором 1, при этом отсортированных по убыванию порядкового номера
      5.

    5.  $param['information_system_id'] = 1;
      6.

    6.  $param['groups_activity'] = 1;
      7.

    7.  $param['OrderGroup'] = 'DESC';
      8.

    8.  $param['OrderGroupField'] = 'information_groups_order';
      9.

    9.
      10.

    10.  // Формируем дополнительные условия отбора информационных групп
      11.

    11.  $element['type'] = 0;
      12.

    12.  $element['prefix'] = '';
      13.

    13.  $element['name'] = 'information_groups_parent_id';
      14.

    14.  $element['if'] = '=';
      15.

    15.  $element['value'] = '0';
      16.

    16.  $element['sufix'] = '';
      17.

    17.  $param['select_groups'][] = $element;
      18.

    18.
      19.

    19.  $mas_groups = $InformationSystem->GetAllInformationGroups($param);
      20.

    20.
      21.

    21.  // Распечатаем результат
      22.

    22.  foreach ($mas_groups as $row)
      23.

    23.  {
      24.

    24.     print_r($row);
      25.

    25.  }
      26.

    26.  ?>
      27.

    Возвращает

    с информацией о группах

    [ Наверх ]

    InformationSystem::GetAllInformationGroupsPropertys

GetAllInformationGroupsPropertys(
int
$InformationSystem_id );

    Описание

    Получение данных о дополнительных свойствах информационных групп

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $InformationSystem_id = 1;
      5.

    5.
      6.

    6.  $resource = $InformationSystem->GetAllInformationGroupsPropertys($InformationSystem_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    InformationSystem::GetAllInformationItemsPropertys

GetAllInformationItemsPropertys(
int
$information_systems_id );

    Описание

    Получение данных о дополнительных свойствах элементов информационной системы

    Принимаемые параметры

    $information_systems_id

    идентификатор информационной системы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_systems_id = 1;
      5.

    5.
      6.

    6.  $resource = $InformationSystem->GetAllInformationItemsPropertys($information_systems_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    InformationSystem::GetAllInformationSystems

GetAllInformationSystems(
[int
$site_id = false] );

    Описание

    Получение информации о инфосистемах

    Принимаемые параметры

    $site_id

    идентификатор сайта, если false - ограничения по сайтам нет
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $resource = $InformationSystem->GetAllInformationSystems($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    InformationSystem::GetAllInformationSystemsDirs

GetAllInformationSystemsDirs(
[array
$param = array()] );

    Описание

    Получение информации о разделах информационных систем

    Принимаемые параметры

    $param

    массив параметров
    • $param['information_systems_dir_parent_id'] идентификатор родительского раздела информационных систем. По умолчанию равен 0.
    • $param['site_id'] идентификатор сайта. По умолчанию имеет значение идентификатора текущего сайта.    *

    [ Наверх ]

    InformationSystem::GetAllInformationSystemsFromDir

GetAllInformationSystemsFromDir(
int
$information_systems_dir_id );

    Описание

    Получение информации о информационных системах раздела

    Принимаемые параметры

    $information_systems_dir_id

    идентификатор раздела информационных систем

    [ Наверх ]

    InformationSystem::GetAllPropertyGroupsDirForInformationSystem

GetAllPropertyGroupsDirForInformationSystem(
int
$information_systems_id, [
$param = array()] );

    Описание

    Получение информации о всех группах дополнительных свойств групп информационных элементов конкретной информационной системы

    Принимаемые параметры

    $information_systems_id

    Идентификатор информационной системы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_systems_id = 1;
      5.

    5.
      6.

    6.  $resource = $InformationSystem->GetAllPropertyGroupsDirForInformationSystem($information_systems_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    $param

    [ Наверх ]

    InformationSystem::GetAllPropertysItemsDirForInformationSystem

GetAllPropertysItemsDirForInformationSystem(
int
$information_systems_id, [array
$param = array()] );

    Описание

    Получение информации обо всех группах дополнительных свойств информационных элементов конкретной информационной системы

    Принимаемые параметры

    $information_systems_id

    Идентификатор информационной системы

    $param

    массив параметров
    • $param['parent_properties_items_dir_id'] идентификатор группы дополнительных свойств информационных элементов, информацию о подгруппах которой необходимо получить.

       по умолчанию равен false - получаем информацию о всех группах дополнительных свойств информационных элементов.

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_systems_id = 1;
        5.

      5.
        6.

      6.  $resource = $InformationSystem->GetAllPropertysItemsDirForInformationSystem($information_systems_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

    Возвращает

    resource или false

    [ Наверх ]

    InformationSystem::GetComment

GetComment(
int
$comment_id );

    Описание

    Получение информации о комментарии к информационному элементу

    Принимаемые параметры

    $comment_id

    идентификатор комментария
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $comment_id = 14;
      5.

    5.
      6.

    6.  $row = $InformationSystem->GetComment($comment_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о комментарии или false

    [ Наверх ]

    InformationSystem::GetCommentInformationSystemItem

GetCommentInformationSystemItem(
$param
$param );

    Описание

    Получение комментариев информационных элементов

    Принимаемые параметры

    $param

    массив атрибутов
    • $param['information_items_id'] идентификатор информационного элемента или false при выборе всех комментариев
    • $param['information_systems_id'] идентификатор информационной системы (при указании information_items_id = false)
    • $param['comment_parent_id'] идентификатор родительского комментария. Для корневого раздела указывается 0
    • $param['comment_status'] статус активности отбираемых комментариев. Возможные значения:

      0 - неактивные

      1 - активные (по умолчанию)

      false - все
    • $param['begin'] комментарий, с которого начинать выбор - по умолчанию 0.
    • $param['count'] количество отбираемых комментариев, по умолчанию выбираются все комментарии
    • $param['CommentOrderField'] поле сортировки, по умолчанию comment_date
    • $param['CommentOrder'] направление сортировки, по умолчанию DESC

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $param['information_items_id'] = 1;
        5.

      5.  $param['comment_status'] = 1;
        6.

      6.
        7.

      7.  $row = $InformationSystem->GetCommentInformationSystemItem($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r($row);
        11.

      11.  ?>
        12.

    Возвращает

    массив со строками - комментариями, false в случае отсутствия комментариев к информационному элементу

    [ Наверх ]

    InformationSystem::GetCountCommentInformationItem

GetCountCommentInformationItem(
int
$information_items_id, [int
$status = 1] );

    Описание

    Определение числа комментариев для информационного элемента

    Принимаемые параметры

    $information_items_id

    $status

    статус комментариев, участвующих в подсчете может принимать значения
    false - все комментарии,
    0 - неактиные комментарии,
    1 - активные комментарии,
    Значение по умолчанию равно 1.
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_items_id = 106;
      5.

    5.  $status = 1;
      6.

    6.
      7.

    7.  $result = $InformationSystem->GetCountCommentInformationItem($information_items_id, $status);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    целое значение, false в случае ошибки

    [ Наверх ]

    InformationSystem::GetCountComments

GetCountComments(
[mixed
$information_item_id = false], [mixed
$is_active = 1] );

    Описание

    Получение числа комментариев к информационным элементам

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента, для которого необходимо получить число комментариев. Если $information_item_id равен false (по умолчанию), то получаем число комментариев для всех элементов всех инфосистем

    $is_active

    статус активности отбираемых комментариев. Возможные значения:
    • 0 - неактивные

      1 - активные
    • false - все

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_id = false;
        5.

      5.  $is_active = 1;
        6.

      6.
        7.

      7.  $count_comments = $InformationSystem->GetCountComments($information_item_id, $is_active);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $count_comments;
        11.

      11.  ?>
        12.

    Возвращает

    число комментариев в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    InformationSystem::GetCountInformationSystem

GetCountInformationSystem(
[int
$site_id = CURRENT_SITE] );

    Описание

    Определение количества инфосистем

    Принимаемые параметры

    $site_id

    идентификатор сайта, если 0 - для всех сайтов
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $result = $InformationSystem->GetCountInformationSystem($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    количество инфосистем

    [ Наверх ]

    InformationSystem::GetCountInformationSystemItem

    GetCountInformationSystemItem(
[mixed
$information_system_id = false], [mixed
$information_group_id = false], [array
$property = array()] );

    Описание

    Получение количества элементов информационной системы

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы, по умолчанию - false

    $information_group_id

    идентификатор группы информационной системы, по умолчанию - false

    $property

    дополнительные атрибуты
    • $property['cache'] - использование кэширования, по умолчанию true

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  // Получаем число информационных элементов, находящихся в корневой группе
        5.

      5.  // информационной системы с идентификатором 1
        6.

      6.  $information_system_id = 1;
        7.

      7.  $information_group_id = 0;
        8.

      8.
        9.

      9.  $row = $InformationSystem->GetCountInformationSystemItem($information_system_id, $information_group_id);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  print_r ($row);
        13.

      13.  ?>
        14.

    Возвращает

    количество элементов информационной системы или false в случае ошибки

    [ Наверх ]

    InformationSystem::GetCountItemsAndGroups

GetCountItemsAndGroups(
int
$parent_group_id, int
$information_system_id, [boolean
$sub = true], [int
$site_user_id = 0], [array
$param = array()] );

    Описание

    Получение числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()

    Принимаемые параметры

    $parent_group_id

    идентификатор группы, для которой необходимо получить число
    элементов и групп.

    $information_system_id

    идентификатор информационной системы, к которой принадлежит группа

    $sub

    параметр, определяющий будут ли учитываться подгруппы данной
    группы при подсчете элементов и групп (true - подгруппы учитываются, false - не учитываются).  по умолчанию $sub = true

    $site_user_id

    идентификатор пользователя сайта, необязательный параметр. по умолчанию = 0.

    $param

    массив дополнительных параметров
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $parent_group_id = 2;
      5.

    5.  $information_system_id = 1;
      6.

    6.
      7.

    7.  $row = $InformationSystem->GetCountItemsAndGroups($parent_group_id, $information_system_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив из 4-х элементов
    • $mas['count_items'] число элементов в группе без учета элементов в подгруппах

      $mas['count_all_items'] число элементов в группе с учетом элементов в подгруппах

      $mas['count_groups'] число групп в данной группе без учета вложенности подгрупп

      $mas['count_all_groups'] число групп в данной группе с учетом вложенности подгрупп

    [ Наверх ]

    InformationSystem::GetCountProperty4InformationSystem

GetCountProperty4InformationSystem(
int
$information_system_id );

    Описание

    Получение числа свойств информационных элементов информационной системы

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_system_id = 1;
      5.

    5.
      6.

    6.  $result = $InformationSystem->GetCountProperty4InformationSystem($information_system_id);
      7.

    7.  // Распечатаем результат
      8.

    8.  echo $result;
      9.

    9.  ?>
      10.

    Возвращает

    число свойств информационной системы

    [ Наверх ]

    InformationSystem::GetDelimitedGroups

GetDelimitedGroups(
int
$information_propertys_groups_dir_parent_id, int
$information_systems_id, [str
$separator = ''], [int
$information_propertys_groups_dir_id = false] );

    Описание

    Получение иерархического списка групп дополнительнгых свойств групп информационных элементов

    Принимаемые параметры

    $information_propertys_groups_dir_parent_id

    Идентификатор родительской группы

    $information_systems_id

    Идентификатор информационной системы

    $separator

    Разделитель

    $information_propertys_groups_dir_id

    Идентификатор группы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_groups_dir_parent_id = 2;
      5.

    5.  $information_systems_id = 1;
      6.

    6.  $separator='';
      7.

    7.
      8.

    8.  $row = $InformationSystem->GetDelimitedGroups($information_propertys_groups_dir_parent_id, $information_systems_id, $separator);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    Возвращает

    массив групп, разделенных строкой-разделителем в иерархическом порядке

    [ Наверх ]

    InformationSystem::GetDelimitedGroupsExtProperty

GetDelimitedGroupsExtProperty(
int
$information_propertys_items_dir_parent_id, int
$information_systems_id, [string
$separator = ''], [
$information_propertys_item_dir_id = false], int
$information_propertys_items_dir_id );

    Описание

    Формирование дерева групп для информационной системы

    Принимаемые параметры

    $information_propertys_items_dir_parent_id

    идентификатор группы, относительно которой строится дерево групп

    $information_systems_id

    идентификатор информационной системы, для которой строится дерево групп

    $separator

    символ, отделяющий группу нижнего уровня от родительской группы

    $information_propertys_items_dir_id

    идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы
    1.  <?php
      2.

    2.  $InformationSystem = new InformationSystem();
      3.

    3.
      4.

    4.  $information_propertys_items_dir_parent_id = 3;
      5.

    5.  $information_systems_id = 1;
      6.

    6.  $separator = '';
      7.

    7.
      8.

    8.  $row = $InformationSystem->GetDelimitedGroupsExtProperty($information_propertys_items_dir_parent_id, $information_systems_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    $information_propertys_item_dir_id

    Возвращает

    двумерный массив, содержащий дерево подгрупп.

    [ Наверх ]

    InformationSystem::GetExternalInformationSystemItem

GetExternalInformationSystemItem(
[array
$select = array()], [array
$param = array()] );

    Описание

    Получение элементов информационной системы. Переименован с GetInformationSystemItem

    Принимаемые параметры

    $select

    параметр, определяющий параметры для отбора информационных элементов

    $param

      • $param['OrderField'] поле сортировки информационных элементов, если случайная сортировка, то записать RAND()

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  // Получаем информацию об информационных элементах, находящихся в корне
          5.

        5.  // информационной системы с идентификатором 1
          6.

        6.  $param_select = array();
          7.

        7.  $infsys_id = 1;
          8.

        8.  $information_group_id = 0;
          9.

        9.  $param_select['information_systems_id'] = $infsys_id;
          10.

        10.  $param_select['information_groups_id'] = $information_group_id;
          11.

        11.
          12.

        12.  $resource = $InformationSystem->GetExternalInformationSystemItem($param_select);
          13.

        13.
          14.

        14.  // Распечатаем результат
          15.

        15.  while($row = mysql_fetch_assoc($resource))
          16.

        16.  {
          17.

        17.      print_r($row);
          18.

        18.  }
          19.

        19.  ?>
          20.

      [ Наверх ]

      InformationSystem::GetGradeInformationSystemItem

GetGradeInformationSystemItem(
int
$information_item_id );

      Описание

      Получение информации об оценке информационного элемента

      Принимаемые параметры

      $information_item_id

      идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_id = 107;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetGradeInformationSystemItem($information_item_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      в случае успешного выполнения - ассоциативный массив с информацией об  оценке элемента:
        элемент с индексом 'count_grads'  - число оценок элемента;
        'sum_grade' - суммарная оценка;
        'avg_grade'  - средняя оценка;
        'round_avg_grade' - округленая средняя оценка.

      [ Наверх ]

      InformationSystem::GetGroupsInformationSystem

GetGroupsInformationSystem(
int
$information_groups_parent_id, int
$InformationSystem_id, [string
$separator = ''], [int
$information_grops_id = false], [array
$property = array()] );

      Описание

      Формирование дерева групп информационной системы

      Принимаемые параметры

      $information_groups_parent_id

      идентификатор группы, относительно которой строится дерево групп

      $InformationSystem_id

      идентификатор информационной системы, для которой строится дерево групп

      $separator

      символ, отделяющий группу нижнего уровня от родительской группы

      $information_grops_id

      идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы.

      $property

      дополнительные атрибуты
      • $property['cache'] - использование кэширования, по умолчанию true
      • $property['array'] - служебный элемент
      • $property['sum_separator'] - служебный элемент

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $information_groups_parent_id = 0;
          5.

        5.  $InformationSystem_id = 15;
          6.

        6.  $separator = '';
          7.

        7.
          8.

        8.  $row = $InformationSystem->GetGroupsInformationSystem($information_groups_parent_id, $InformationSystem_id, $separator);
          9.

        9.
          10.

        10.  // Распечатаем результат
          11.

        11.  print_r($row);
          12.

        12.  ?>
          13.

      Возвращает

      двумерный массив, содержащий дерево подгрупп

      [ Наверх ]

      InformationSystem::GetIdInformationItem

GetIdInformationItem(
string
$information_item_url, int
$information_group_id, [int
$information_system_id = 0] );

      Описание

      Определение идентификатора информационного элемента по URI элемента и идентификатору информационной группы

      Принимаемые параметры

      $information_item_url

      URL информационного элемента

      $information_group_id

      идентификатор информационной группы

      $information_system_id

      идентификатор информационной системы, к которой принадлежит информационный элемент, идентификатор которого надо определить
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_url = 'news1';
        5.

      5.  $information_group_id= 2;
        6.

      6.  $information_system_id = 1;
        7.

      7.
        8.

      8.  $newid = $InformationSystem->GetIdInformationItem($information_item_url, $information_group_id, $information_system_id);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

      Возвращает

      идентификатор информационного элемента или false

      [ Наверх ]

      InformationSystem::GetInformationFromPath

GetInformationFromPath(
int
$InformationSystem_id, [array
$path_array = ''], [bool
$break_if_path_not_found = true], [array
$param = array()] );

      Описание

      Определение идентификатора информационной группы и идентификатора информационного элемента по значению URI

      Принимаемые параметры

      $InformationSystem_id

      идентификатор информационной системы, к которой принадлежит данный информационный элемент

      $path_array

      массив, содержащий все элементы URL

      $break_if_path_not_found

      прерывает поиск пути, если очередной элемент не был найден, по умолчанию true

      $param

      массив дополнительных параметров
      • array $param['information_groups_activity'] массив параметров активности информационной группы, по умолчанию только активные
      • array $param['information_items_status'] массив параметров активности информационного элемента, по умолчанию только активные

      Возвращает

      ассоциативный массив, содержащий идентификатор информационной группы и путь к информационному элементу в случае успешного выполнения, false в противном случае

      [ Наверх ]

      InformationSystem::GetInformationGroup

GetInformationGroup(
int
$group_id, [array
$property = array()] );

      Описание

      Получение информации о группе. Использует кэш "INF_SYS_GROUP"

      Принимаемые параметры

      $group_id

      идентификатор группы

      $property

      массив дополнительных параметров
      • $property['sql_from_select_groups'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.
      • $property ['select_groups'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных групп (пример использования данного свойства смотрите в методе GetAllInformationGroups())

      • $element['type'] определяет, является ли поле основным свойством информационной группы или дополнительным (0 - основное, 1 - дополнительное)
      • $element['prefix'] префикс - строка, размещаемая перед условием
      • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
      • $element['property_id'] идентификатор дополнительногого свойства информационных групп
      • $element['if'] строка, содержащая условный оператор
      • $element['value'] значение поля (или параметра)
      • $element['sufix'] суффикс - строка, размещаемая после условия

      Возвращает

      массив с данными о группе или false

      see

      GetAllInformationGroups()

 <code>
 <?php
 $InformationSystem = new InformationSystem();

 $group_id = 2;

 $row = $InformationSystem->GetInformationGroup($group_id);

 // Распечатаем результат
 print_r($row);
 ?>
 </code>

      [ Наверх ]

      InformationSystem::GetInformationGroupDir

GetInformationGroupDir(
$information_group_id
$information_group_id );

      Описание

      Получение пути хранения файлов информационной группы

      Принимаемые параметры

      $information_group_id

      идентификатор информационной группы

      Возвращает

      путь к папке информационной группы или ложь, если информацтонной группы не существует

      [ Наверх ]

      InformationSystem::GetInformationGroupName

GetInformationGroupName(
int
$information_groups_id );

      Описание

      Получение имени информационной группы

      Принимаемые параметры

      $information_groups_id

      идентификатор информационной группы, имя которой необходимо получить
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 2;
        5.

      5.
        6.

      6.  $result = $InformationSystem->GetInformationGroupName($information_groups_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $result;
        10.

      10.  ?>
        11.

      Возвращает

      название группы информационной системы. Если группы с таким идентификатором нет, то возвращает false

      [ Наверх ]

      InformationSystem::GetInformationGroupsPathArray

GetInformationGroupsPathArray(
int
$information_group_id, int
$information_system_id, [array
$return_path_array = array()] );

      Описание

      Построение массива пути от текущей группы к корневой

      Принимаемые параметры

      $information_group_id

      идентификатор информационной группы, для которой необходимо построить путь

      $information_system_id

      идентификатор информационной системы, к которой принадлежит группа.

      $return_path_array

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_group_id = 12;
        5.

      5.  $information_system_id = 1;
        6.

      6.
        7.

      7.  $row = $InformationSystem->GetInformationGroupsPathArray($information_group_id, $information_system_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r($row);
        11.

      11.  ?>
        12.

      Возвращает

      ассоциативный массив, элементы которого содержат информацию о группах, составляющих путь от текущей группы до корневой

      [ Наверх ]

      InformationSystem::GetInformationGroupsPropertys

GetInformationGroupsPropertys(
int
$information_propertys_groups_id );

      Описание

      Получение данных о дополнительном свойстве групп информационной системы

      Принимаемые параметры

      $information_propertys_groups_id

      идентификатор связи таблицы свойства информационной группы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_propertys_groups_id = 9;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetInformationGroupsPropertys($information_propertys_groups_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      массив с информацией о дополнительном свойстве информационных групп

      [ Наверх ]

      InformationSystem::GetInformationGroupsPropertyValue

GetInformationGroupsPropertyValue(
int
$information_groups_property_value_id );

      Описание

      Получение информации о значении дополнительного свойства информационных групп

      Принимаемые параметры

      $information_groups_property_value_id

      идентификатор значения дополнительного свойства
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_property_value_id = 31;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetInformationGroupsPropertyValue($information_groups_property_value_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      ассоциативный массив с данными о  значении дополнительного свойства информационных групп в случае успешного выполнения, false - в противном случае

      [ Наверх ]

      InformationSystem::GetInformationItemDir

GetInformationItemDir(
$information_item_id
$information_item_id, [$information_item_row
$information_item_row = false] );

      Описание

      Получение пути хранения файлов информационного элемента

      Принимаемые параметры

      $information_item_id

      идентификатор информационного элемента

      $information_item_row

      массив с данными об информационном элементе

      Возвращает

      путь к папке информационного элемента или ложь, если информационного элемента не существует

      [ Наверх ]

      InformationSystem::GetInformationItemPropertyValue

GetInformationItemPropertyValue(

$information_items_id,
$information_propertys_id, int
$information_propertys_items_id );

      Описание

      Получение информации о значении дополнительного свойства информационного элемента

      Принимаемые параметры

      $information_propertys_items_id

      идентификатор значения дополнительного свойства
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_items_id = 123;
        5.

      5.  $information_propertys_id = 3;
        6.

      6.
        7.

      7.  $row = $InformationSystem->GetInformationItemPropertyValue($information_items_id, $information_propertys_id);
        8.

      8.
        9.

      9.   // Распечатаем результат
        10.

      10.  print_r ($row);
        11.

      11.  ?>
        12.

      $information_items_id

      $information_propertys_id

      Возвращает

      ассоциативный массив с данными о значении дополнительного свойства информационного элемента или false

      [ Наверх ]

      InformationSystem::GetInformationItemsFromGroup

GetInformationItemsFromGroup(
int
$information_groups_id, [int
$information_systems_id = false], [array
$param = array()] );

      Описание

      Получение информации об элементах, находящихся в информационной группе

      Принимаемые параметры

      $information_groups_id

      идентификатор информационной группы

      $information_systems_id

      идентификатор информационной системы

      $param

      массив дополнительных параметров
      • $param['OrderField'] поле сортировки
      • $param['Order'] направление сортировки

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 2;
        5.

      5.  $information_systems_id = 1;
        6.

      6.
        7.

      7.  // Сортируем элементы по убыванию порядкового номера
        8.

      8.  $param = array();
        9.

      9.  $param['OrderField'] = 'information_items_order';
        10.

      10.  $param['Order'] = 'DESC';
        11.

      11.
        12.

      12.  $resource = $InformationSystem->GetInformationItemsFromGroup($information_groups_id, $information_systems_id, $param);
        13.

      13.
        14.

      14.  // Распечатаем результат
        15.

      15.  while($row = mysql_fetch_assoc($resource))
        16.

      16.  {
        17.

      17.          print_r($row);
        18.

      18.  }
        19.

      19.  ?>
        20.

      [ Наверх ]

      InformationSystem::GetInformationItemsPropertyValue

GetInformationItemsPropertyValue(
int
$information_propertys_items_id );

      Описание

      Получение информации о значении дополнительного свойства информационного элемента по ID связи таблицы information_propertys_items_table

      Принимаемые параметры

      $information_propertys_items_id

      идентификатор значения дополнительного свойства
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_propertys_items_id = 99;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetInformationItemsPropertyValue($information_propertys_items_id);
        7.

      7.
        8.

      8.   // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      ассоциативный массив с данными о значении дополнительного свойства информационного элемента или false

      [ Наверх ]

      InformationSystem::GetInformationSystem

GetInformationSystem(
int
$InformationSystem_id, [boolean
$use_cache = true], [array
$param = array()] );

      Описание

      Получение данных об информационной системе

      Принимаемые параметры

      $InformationSystem_id

      идентификатор информационной системы

      $use_cache

      параметр, определяющий использовать кэш в памяти или нет (по умолчанию истина)

      $param

      ассоциативный массив параметров
      • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $InformationSystem_id = 1;
          5.

        5.
          6.

        6.  $row = $InformationSystem->GetInformationSystem($InformationSystem_id);
          7.

        7.
          8.

        8.  // Распечатаем результат
          9.

        9.  print_r ($row);
          10.

        10.  ?>
          11.

      Возвращает

      ассоциативный массив с данными об информационной системе или false, если информационная система не найдена

      [ Наверх ]

      InformationSystem::GetInformationSystemByStructureId

GetInformationSystemByStructureId(
int
$structure_id );

      Описание

      Получение информации об информационной системе, связанной с узлом структуры

      Принимаемые параметры

      $structure_id

      идентификатор узла структуры
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $structure_id = 16;
        5.

      5.
        6.

      6.  $information_systems_id = $InformationSystem->GetInformationSystemByStructureId($structure_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $information_systems_id;
        10.

      10.  ?>
        11.

      Возвращает

      идентификатор информационной системе или false

      [ Наверх ]

      InformationSystem::GetInformationSystemGroupAccess

GetInformationSystemGroupAccess(
int
$information_group_id, [int
$information_system_id = 0], [array
$row_group = array()], [
$param = array()] );

      Описание

      Определения уровня доступности информационной группы

      Принимаемые параметры

      $information_group_id

      идентификатор информационной группы

      $information_system_id

      идентификатор информационной системы

      $row_group

      ассоциативный массив с информацией о группе, по умолчанию пустой
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_group_id = 2;
        5.

      5.  $information_system_id = 1;
        6.

      6.
        7.

      7.  $result = $InformationSystem->GetInformationSystemGroupAccess($information_group_id, $information_system_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $result;
        11.

      11.  ?>
        12.

      $param

      Возвращает

      уровень (группа) доступа пользователя к информационной группе, 0 - доступ разрешен всем

      [ Наверх ]

      InformationSystem::GetInformationSystemItem

GetInformationSystemItem(
int
$information_items_id, [array
$param = array()] );

      Описание

      Получение данных об информационном элементе

      Принимаемые параметры

      $information_items_id

      идентификатор информационного элемента

      $param

      массив дополнительных параметров
      • $param['cache_off'] использовать кэш, по умолчанию не объявлен

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $information_items_id = 1;
          5.

        5.
          6.

        6.  $row = $InformationSystem->GetInformationSystemItem($information_items_id);
          7.

        7.
          8.

        8.  // Распечатаем результат
          9.

        9.  print_r($row);
          10.

        10.  ?>
          11.

      Возвращает

      ассоциативный массив с данными об информационном элементе или ложь, если элемент не найден

      [ Наверх ]

      InformationSystem::GetInformationSystemItemAccess

GetInformationSystemItemAccess(
int
$information_items_id, [
$param = array()] );

      Описание

      Определение уровня доступности информационного элемента

      Принимаемые параметры

      $information_items_id

      идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_items_id = 1;
        5.

      5.
        6.

      6.  $result = $InformationSystem->GetInformationSystemItemAccess($information_items_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $result;
        10.

      10.  ?>
        11.

      $param

      Возвращает

      уровень (группа) доступа пользователя к информационной группе, 0 - доступ разрешен всем

      [ Наверх ]

      InformationSystem::GetInformationSystemItemProperty

GetInformationSystemItemProperty(
int
$information_propertys_id );

      Описание

      Получение данных о дополнительных свойствах элементов

      информационной системы

      Принимаемые параметры

      $information_propertys_id

      идентификатор свойства
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_propertys_id = 8;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetInformationSystemItemProperty($information_propertys_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      массив с информацией о свойстве или false

      [ Наверх ]

      InformationSystem::GetInformationSystemItems

GetInformationSystemItems(
int
$information_item_id );

      Описание

      Получение информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит

      Принимаемые параметры

      $information_item_id

      идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_id = 1;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetInformationSystemItems($information_item_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      ассоциативный массив с именами информационного элемента, информационной группы и системы, к которым он принадлежит, false - в том случае если данный элемент отсутствует

      [ Наверх ]

      InformationSystem::GetInformationSystemsDir

GetInformationSystemsDir(

$information_systems_dir_id );

      Принимаемые параметры

      $information_systems_dir_id

      [ Наверх ]

      InformationSystem::GetInformationSystemsDirPathArray

GetInformationSystemsDirPathArray(
int
$information_systems_dir_id, [array
$return_path_array = array()] );

      Описание

      Построение массива пути от текущего раздела информационных систем к корневому

      Принимаемые параметры

      $information_systems_dir_id

      идентификатор раздела информационных систем, для которого необходимо построить путь

      $return_path_array

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_systems_dir_id = 12;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetInformationSystemsDirPathArray($information_systems_dir_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

      Возвращает

      ассоциативный массив, элементы которого содержат информацию о разделах, составляющих путь от текущего раздела до корневого

      [ Наверх ]

      InformationSystem::GetInformationSystemsDirs

GetInformationSystemsDirs(
[array
$param = array()] );

      Описание

      Формирование дерева разделов информационных систем

      Принимаемые параметры

      $param

      массив параметров
      • $param['information_systems_dir_parent_id'] идентификатор раздела, относительно которого строится дерево групп. По умолчанию равен 0.
      • $param['site_id'] идентификатор сайта, для которого строится дерево разделов. По умолчанию равен CURRENT_SITE
      • $param['separator'] символ, отделяющий раздел нижнего уровня от родительского раздела
      • $param['information_systems_dir_id'] идентификатор раздела, который вместе с его подразделами не нужно включать в дерево разделов, если равен false или не передан, то включать в дерево разделов все разделы.
      • $param['array'] - служебный параметр
      • $param['sum_separator'] - служебный параметр

      Возвращает

      двумерный массив, содержащий дерево подгрупп

      [ Наверх ]

      InformationSystem::GetMasGroup

GetMasGroup(
 );

      Описание

      Получение массива информационных групп

      Возвращает

      ассоциативный массив с данными об информационных группах

      [ Наверх ]

      InformationSystem::GetPathGroup

GetPathGroup(
int
$information_groups_id, [string
$path = ''], [
$param = array()] );

      Описание

      Формирование пути по информационным группам

      Принимаемые параметры

      $information_groups_id

      идентификатор информационной группы, для которой надо сформировать путь

      $path

      служебный параметр, используемый при формировании пути по группам
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 2;
        5.

      5.
        6.

      6.  $newpath = $InformationSystem->GetPathGroup($information_groups_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $newpath;
        10.

      10.  ?>
        11.

      $param

      Возвращает

      путь по группам от корневой до данной или false, если путь для группы не удается определить

      [ Наверх ]

      InformationSystem::GetPathItem

GetPathItem(
int
$information_items_id, string
$path, [array
$row = ''], [
$param = array()] );

      Описание

      Формирование пути к данному информационному элементу

      Принимаемые параметры

      $information_items_id

      идентификатор информационного элемента

      $path

      параметр для хранения пути к данному информационному элементу

      $row

      ассоциативный массив, содержащий информацию об информационном элементе
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_items_id= 1;
        5.

      5.  $path = '';
        6.

      6.
        7.

      7.  $path = $InformationSystem->GetPathItem($information_items_id, $path);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $path;
        11.

      11.  ?>
        12.

      $param

      Возвращает

      путь к информационному элементу относительно информационной системы.  Путь к информационной системе в результирующую строку не входит.

      [ Наверх ]

      InformationSystem::GetPropertiesGroup

GetPropertiesGroup(
int
$information_groups_id, int
$information_system_id );

      Описание

      Получение данных о дополнительных свойствах информационной группы и их значениях .

      Рекомендуется использоваться совместно с FillMemCachePropertysGroup() при выборе свойств всех групп информационной системы.

      Принимаемые параметры

      $information_groups_id

      идентификатор группы

      $information_system_id

      идентификатор информационной системы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 2;
        5.

      5.  $information_system_id = 1;
        6.

      6.
        7.

      7.  $row = $InformationSystem->GetPropertiesGroup($information_groups_id, $information_system_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r ($row);
        11.

      11.  ?>
        12.

      Возвращает

      массив с информацией о дополнительных свойствах

      [ Наверх ]

      InformationSystem::GetPropertyError

GetPropertyError(
 );

      Описание

      Метод возвращающий код ошибки, возникающей при работе с методами класса

      [ Наверх ]

      InformationSystem::GetPropertyGroupsDir

GetPropertyGroupsDir(
int
$information_propertys_groups_dir_id );

      Описание

      Получение информации о группе дополнительных свойств групп информационной системы

      Принимаемые параметры

      $information_propertys_groups_dir_id

      Идентификатор группы дополнительных свойств групп информационных систем
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_propertys_groups_dir_id = 3;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetPropertyGroupsDir($information_propertys_groups_dir_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      массив с информацией о группе дополнительных свойств информационных групп

      [ Наверх ]

      InformationSystem::GetPropertySectionPath

GetPropertySectionPath(
 );

      Описание

      Получение значения свойтва, содержащего пути по группам

      [ Наверх ]

      InformationSystem::GetPropertysInformationSystemItem

GetPropertysInformationSystemItem(
int
$information_items_id, [int
$param = array()] );

      Описание

      Получение списка дополнительных свойств и их значений для информационного элемента

      Принимаемые параметры

      $information_items_id

      идентификатор информационного элемента

      $param

      массив дополнительных параметров
      • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $information_items_id = 1;
          5.

        5.
          6.

        6.  $row = $InformationSystem->GetPropertysInformationSystemItem($information_items_id);
          7.

        7.
          8.

        8.  // Распечатаем результат
          9.

        9.  print_r ($row);
          10.

        10.  ?>
          11.

      Возвращает

      массив с данными о свойствах информационного элемента или false - в случае отсутствия дополнительных свойств у элементов данной информационной системы

      [ Наверх ]

      InformationSystem::GetPropertysItemsDir

GetPropertysItemsDir(
int
$information_propertys_items_dir_id );

      Описание

      Получение информации о группе дополнительных свойств информационных элементов

      Принимаемые параметры

      $information_propertys_items_dir_id

      Идентификатор группы информационных элементов
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_propertys_items_dir_id = 3;
        5.

      5.
        6.

      6.  $row = $InformationSystem->GetPropertysItemsDir($information_propertys_items_dir_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

      Возвращает

      Массив данных, либо False

      [ Наверх ]

      InformationSystem::GetSiteUsersGroupsForUser

GetSiteUsersGroupsForUser(
int
$site_user_id );

      Описание

      Получение списка групп пользователий, в которых содержится пользователь сайта

      Принимаемые параметры

      $site_user_id

      идентификатор пользователя сайтов
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $site_user_id = 1;
        5.

      5.
        6.

      6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        7.

      7.  if (class_exists('SiteUsers'))
        8.

      8.  {
        9.

      9.      $SiteUsers = & singleton('SiteUsers');
        10.

      10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        11.

      11. }
        12.

      12.
        13.

      13.  else
        14.

      14.  {
        15.

      15.     $site_users_id = 0;
        16.

      16. }
        17.

      17.
        18.

      18.  $row = $InformationSystem->GetSiteUsersGroupsForUser($site_user_id);
        19.

      19.
        20.

      20.  // Распечатаем результат
        21.

      21.  print_r ($row);
        22.

      22.  ?>
        23.

      Возвращает

      массив групп пользователей

      [ Наверх ]

      InformationSystem::GetTopParentInformationGroup

GetTopParentInformationGroup(
int
$information_group_id );

      Описание

      Получение родительской группы находящейся в корне для информационной группы

      Принимаемые параметры

      $information_group_id

      идентификатор информационной группы

      Возвращает

      информацию о родительской группы или false (информационная группа с переданным идентификатором не существует)

      [ Наверх ]

      InformationSystem::GetXml4Tags

GetXml4Tags(
int
$InformationSystemId, array
$property );

      Описание

      Генерация XML для облака тегов информационной системы

      Принимаемые параметры

      $InformationSystemId

      идентификатор информационной системы

      $property

      массив дополнительных атрибутов
      • $property['begin'] начальная позиция отображения тегов (по умолчанию 0)
      • $property['count'] количество отображаемых тегов
      • $property['mas_groups_id'] массив идентификаторов информационных групп, используемые для получения списка тегов элементов, входящих в группы
      • $property['TagsOrder'] параметр, определяющий порядок сортировки тегов. Принимаемые значения: ASC - по возрастанию (по умолчанию), DESC - по убыванию
      • $property['TagsOrderField'] поле сортировки тегов, если случайная сортировка, то записать RAND(). по умолчанию теги сортируются по названию.
      • $property['tags_group_id'] идентификатор или массив идентификаторов групп тегов, из которых необходимо вести отбор тегов

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $InformationSystemId = 1;
          5.

        5.  $property['count'] = 10;
          6.

        6.
          7.

        7.  $xml = $InformationSystem->GetXml4Tags($InformationSystemId, $property);
          8.

        8.
          9.

        9.  // Распечатаем результат
          10.

        10.  echo htmlspecialchars($xml);
          11.

        11.  ?>
          12.

      [ Наверх ]

      InformationSystem::GetXmlForInformatioItem

GetXmlForInformatioItem(

$information_item_id, [
$property = array (
    'is_get_information_for_property' => false,
    'show_text' => true)] );

      Принимаемые параметры

      $information_item_id

      $property

      [ Наверх ]

      InformationSystem::GetXmlForInformatioItemComments

GetXmlForInformatioItemComments(
array
$param );

      Описание

      Создает XML для комметариев

      Принимаемые параметры

      $param

      массив атрибутов
      • $param['information_items_id'] mixed идентификатор информационного элемента,
       для которого получаем комментарии, если false - выбираются все комментарии
      • $param['begin'] номер комментария, с которого начинать вывод
      • $param['count'] количество отбираемых комментариев

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $param['information_items_id'] = 1;
          5.

        5.  $param['begin'] = 13;
          6.

        6.  $param['count'] = 2;
          7.

        7.
          8.

        8.  $newxml = $InformationSystem->GetXmlForInformatioItemComments($param);
          9.

        9.
          10.

        10.  // Распечатаем результат
          11.

        11.  echo nl2br(htmlspecialchars($newxml));
          12.

        12.  ?>
          13.

      [ Наверх ]

      InformationSystem::GetXmlForInformationItem

GetXmlForInformationItem(
int
$information_item_id, [array
$property = array (
    'is_get_information_for_property' => false,
    'show_text' => true)] );

      Описание

      Формирование XML для отображения информационного элемента

      Принимаемые параметры

      $information_item_id

      идентификатор информационного элемента, который необходимо отобразить

      $property

      массив дополнительных параметров
      • $property['part'] номер части документа, подлежащей отображению.
       Документ может быть разделен с помощью разделителя <!-- pagebreak -->.  Нумерация разделителя ведется с 1. Если передан 0 - разделение не производится. по умолчанию имеет значение 1.
      • $property['is_get_information_for_property'] параметр, исключающий рекурсию, возникающую при вызове свойства типа "Информационная система" для элемента, имеющего также свойство типа "Информационная система" (эффект зазеркаливания), по умолчанию false
      • $property['show_text'] параметр, указывающий включать в XML текст информационного элемента или нет, по умолчанию равен true. Если этот параметр не указан, то текст элемента включается в XML.
      • $property['xml_show_item_comment'] параметр, разрешающий добавление в XML информации о комментариях информационного элемента (true (по умолчанию) комментарии добавляеются, false - не добавляются)
      • $property['xml_show_item_property'] параметр, разрешающий добавление в XML информации о дополнительных свойствах информационного элемента (true (по умолчанию) дополнительные свойства добавляеются, false - не добавляются)
      • $property['xml_show_external_property'] параметр, разрешающий передачу в XML информации о дополнительных свойствах пользователя, по умолчанию false

      Замечание: перед вызовом необходимо заполнить массив групп для конкретной информационной системы, например $InformationSystem->FillMasGroup($information_system_id);
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_id = 1;
        5.

      5.
        6.

      6.  $xml = $InformationSystem->GetXmlForInformationItem($information_item_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo nl2br(htmlspecialchars($xml));
        10.

      10.  ?>
        11.

      Возвращает

      метод, формирующий XML для отображения информационного элемента

      [ Наверх ]

      InformationSystem::GetXmlForOneComment

GetXmlForOneComment(
int
$comment_id, [array
$param = array()], [
$external_propertys = array()] );

      Описание

      Генерация XML для комментария и всех его дочерних комментариев.

      Для генерации должны быть заполнены массивы $this->cm

      Принимаемые параметры

      $comment_id

      идентификатор комментария

      $param

      массив дополнительных параметров
      • $param['xml_show_external_property'] параметр, разрешающий передачу в XML информации о дополнительных свойствах пользователя, по умолчанию false
      • $param['GenXml_type'] тип генерации XML для метода GenXml() при обработке $external_propertys

      $external_propertys

      [ Наверх ]

      InformationSystem::get_information_groups_path

get_information_groups_path(
int
$information_groups_id, int
$InformationSystem_id );

      Описание

      Формирование пути по дереву информационных групп

      Принимаемые параметры

      $information_groups_id

      идентификатор информационной группы, для которой необходимо построить путь

      $InformationSystem_id

      идентификатор информационной системы, к которой принадлежит группа.
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 20;
        5.

      5.  $InformationSystem_id = 1;
        6.

      6.  $row = $InformationSystem->get_information_groups_path($information_groups_id, $InformationSystem_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $InformationSystem->section_path;
        10.

      10.  ?>
        11.

      [ Наверх ]

      InformationSystem::get_mas_information_groups_for_xml

get_mas_information_groups_for_xml(
 );

      Описание

      Метод возвращает XML для информационных групп

      [ Наверх ]

      InformationSystem::GroupIsParent

GroupIsParent(
int
$group_id, int
$group_parent_id );

      Описание

      Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id

      Принимаемые параметры

      $group_id

      идентификатор группы-потомка

      $group_parent_id

      идентификатор группы-родителя
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $group_id = 14;
        5.

      5.  $group_parent_id = 2;
        6.

      6.
        7.

      7.  $result = $InformationSystem->GroupIsParent($group_id, $group_parent_id);
        8.

      8.
        9.

      9.  if ($result)
        10.

      10.  {
        11.

      11.      echo "Группа является потомком";
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      echo "Группа не является потомком";
        16.

      16.  }
        17.

      17.  ?>
        18.

      [ Наверх ]

      InformationSystem::InformationItemIncShowCount

InformationItemIncShowCount(
int
$information_item_id );

      Описание

      Инкрементирование счетчика показов информационного элемента

      Принимаемые параметры

      $information_item_id

      идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_id = 1;
        5.

      5.
        6.

      6.  $result = $InformationSystem->InformationItemIncShowCount($information_item_id);
        7.

      7.
        8.

      8.  if ($result)
        9.

      9.  {
        10.

      10.      echo 'Счетчик показов информационного элемента инкрементирован';
        11.

      11.  }
        12.

      12.  else
        13.

      13.  {
        14.

      14.      echo 'Ошибка! Счетчик показов информационного элемента не инкрементирован!';
        15.

      15.  }
        16.

      16.
        17.

      17.  ?>
        18.

      [ Наверх ]

      InformationSystem::InformationSystemItemAccess

InformationSystemItemAccess(
int
$site_users_id, int
$information_item_id );

      Описание

      Определение доступности информационного элемента для пользователя

      Принимаемые параметры

      $site_users_id

      идентификатор пользователя

      $information_item_id

      идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  // Получим текущего пользователя
        5.

      5.  $SiteUsers = new SiteUsers();
        6.

      6.  $site_users_id = $SiteUsers->GetCurrentSiteUser();
        7.

      7.
        8.

      8.  $information_item_id = 1;
        9.

      9.
        10.

      10.  $result = $InformationSystem->InformationSystemItemAccess($site_users_id, $information_item_id);
        11.

      11.
        12.

      12.  if ($result)
        13.

      13.  {
        14.

      14.      echo "Элемент доступен";
        15.

      15.  }
        16.

      16.  else
        17.

      17.  {
        18.

      18.      echo "Элемент недоступен";
        19.

      19.  }
        20.

      20.  ?>
        21.

      Возвращает

      true - элемент доступен, false - элемент недоступен

      [ Наверх ]

      InformationSystem::InsertInformationGroup

InsertInformationGroup(
array
$param );

      Описание

      Вставка/обновление информации об информационной группе

      Принимаемые параметры

      $param

      массив параметров
      • $param['information_groups_id'] идентификатор обновляемой информационной группы
      • $param['information_system_id'] идентификатор информационной системы, к которой принадлежит группа
      • $param['information_groups_parent_id'] идентификатор родительской группы данной информационной группы
      • $param['information_groups_name'] название информационной группы
      • $param['information_groups_description'] описание информационной группы
      • $param['information_groups_order'] порядковый номер группы в родительской группе
      • $param['information_groups_path'] элемент URL информационной системы для данной группы
      • $param['information_groups_image'] имя файла большого изображения для информационной группы
      • $param['information_groups_small_image'] имя файла малого изображения для информационной группы
      • $param['information_groups_allow_indexation'] параметр, определяющий индексировать данную информационную группу или нет (1- индексировать, 0 - неиндексировать)
      • $param['information_groups_seo_title'] параметр, используемый для задания заголовка страницы
      • $param['information_groups_seo_description'] параметр, используемый для задания значения мета-тега description страницы
      • $param['information_groups_seo_keywords'] параметр, используемый для задания значения мета-тега keywords страницы
      • $param['information_groups_access'] параметр, определяющий тип доступа для данной информационной группы (0 - доступна всем, -1 - доступ как у родителя)
      • $param['site_users_id'] идентификатор пользователя сайта, которому принадлежит информационная группа
      • $param['information_groups_activity'] параметр, определяющий доступность группы и ее дочерних групп, и элементов (1 (по умолчанию) - доступна, 0 - не доступна)
      • $param['sns_type_id'] идентификатор типа блога
      • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $param = array();
        5.

      5.
        6.

      6.  $param['information_system_id'] = 1;
        7.

      7.  $param['information_groups_parent_id'] = 0;
        8.

      8.  $param['information_groups_name'] = 'Тестовая группа';
        9.

      9.  $param['information_groups_description'] = 'Описание группы';
        10.

      10.  $param['information_groups_order'] = 10;
        11.

      11.  $param['information_groups_path'] = 'test-group';
        12.

      12.
        13.

      13.  // Если для добавляемой/редактируемой инфорационной группы необходимо загрузить
        14.

      14.  // изображение, то перед вызовом метода вставки/обновления информационной группы
        15.

      15.  // необходимо загрузить данное изображение используя метод AdminLoadFiles класса kernel
        16.

      16.  $kernel = & singleton('kernel');
        17.

      17.
        18.

      18.  $param_load_files = array();
        19.

      19.
        20.

      20.
        21.

      21.  $param_load_files['path_source_big_image'] = 'C:\test\test_big_image1.jpg'; // путь к файлу-источнику большого изображения
        22.

      22.  $param_load_files['path_source_small_image'] = ''; // путь к файлу-источнику малого изображения
        23.

      23.  $param_load_files['original_file_name_big_image'] = 'test_big_image1.jpg'; // оригинальное имя файла большого изображения
        24.

      24.
        25.

      25.  $sufix = date('U');
        26.

      26.
        27.

      27.  $param_load_files['path_target_big_image'] = CMS_FOLDER . UPLOADDIR . 'information_items_' . $sufix . '.jpg'; // путь к создаваемому файлу большого изображения
        28.

      28.  $param_load_files['path_target_small_image'] =CMS_FOLDER . UPLOADDIR . 'small_information_items_' . $sufix . '.jpg'; // путь к создаваемому файлу малого изображения
        29.

      29.  $param_load_files['original_file_name_small_image'] = ''; // оригинальное имя файла малого изображения
        30.

      30.  $param_load_files['use_big_image'] = true; //  использовать большое изображение для создания малого (true - использовать (по умолчанию), false - не использовать)
        31.

      31.  $param_load_files['max_width_big_image'] = 900; // значение максимальной ширины большого изображения
        32.

      32.  $param_load_files['max_height_big_image'] = 900; // значение максимальной высоты большого изображения
        33.

      33.  $param_load_files['max_width_small_image'] = 100; // значение максимальной ширины малого изображения;
        34.

      34.  $param_load_files['max_height_small_image'] = 100; // значение максимальной высоты малого изображения;
        35.

      35.
        36.

      36.  $result = $kernel->AdminLoadFiles($param_load_files);
        37.

      37.
        38.

      38.  if ($result['big_image'])
        39.

      39.  {
        40.

      40.          $param['information_groups_image'] = basename($param['path_target_big_image']);
        41.

      41.  }
        42.

      42.  else
        43.

      43.  {
        44.

      44.          $param['information_groups_image'] = '';
        45.

      45.  }
        46.

      46.
        47.

      47.  if ($result['small_image'])
        48.

      48.  {
        49.

      49.          $param['information_groups_small_image'] = basename($param['path_target_small_image']);
        50.

      50.  }
        51.

      51.  else
        52.

      52.  {
        53.

      53.          $param['information_groups_small_image'] = '';
        54.

      54.  }
        55.

      55.
        56.

      56.  $param['information_groups_allow_indexation'] = 1;
        57.

      57.  $param['information_groups_seo_title'] = 'Тестовая группа';
        58.

      58.  $param['information_groups_seo_description'] = 'Тестовая группа';
        59.

      59.  $param['information_groups_seo_keywords'] = 'Тестовая группа';
        60.

      60.  $param['information_groups_access'] = -1;
        61.

      61.
        62.

      62.  if ($InformationSystem->InsertInformationGroup($param))
        63.

      63.  {
        64.

      64.          echo 'Группа добавлена';
        65.

      65.  }
        66.

      66.  else
        67.

      67.  {
        68.

      68.          echo 'Ошибка! Группа не добавлена!';
        69.

      69.  }
        70.

      70.  ?>
        71.

      Возвращает

      идентификатор добаленной/обновленной группы, в случае ошибки возвращает 0

      see

      AdminLoadFiles()

      [ Наверх ]

      InformationSystem::InsertInformationGroups

InsertInformationGroups(
int
$type, int
$information_groups_id, int
$InformationSystem_id, int
$information_groups_parent_id, string
$information_groups_name, string
$information_groups_description, int
$information_groups_order, string
$information_groups_path, string
$information_groups_image, [int
$information_groups_allow_indexation = 1], [string
$information_groups_seo_title = ''], [string
$information_groups_seo_description = ''], [string
$information_groups_seo_keywords = ''], [int
$information_groups_access = -1], [int
$users_id = false], [array
$param = array()] );

      Описание

      Вставка/обновление данных об информационной группе. Устаревший метод

      Принимаемые параметры

      $type

      параметр, определяющий будет производиться вставка или обновление данных об информационной группе (0 – вставка, 1 - обновление)

      $information_groups_id

      идентификатор обновляемой информационной группы (при вставке равен 0)

      $InformationSystem_id

      идентификатор информационной системы, к которой принадлежит группа

      $information_groups_parent_id

      идентификатор родительской группы данной информационной группы

      $information_groups_name

      название информационной группы

      $information_groups_description

      описание информационной группы

      $information_groups_order

      порядковый номер группы в родительской группе

      $information_groups_path

      элемент URL информационной системы для данной группы

      $information_groups_image

      имя файла с изображением для информационной группы

      $information_groups_allow_indexation

      параметр, определяющий индексировать данную информационную группу или нет (1- индексировать, 0 - неиндексировать)

      $information_groups_seo_title

      параметр, используемый для задания заголовка страницы

      $information_groups_seo_description

      параметр, используемый для задания значения мета-тега description страницы

      $information_groups_seo_keywords

      параметр, используемый для задания значения мета-тега keywords страницы

      $information_groups_access

      параметр, определяющий тип доступа для данной информационной группы (0 - доступна всем, -1 - доступ как у родителя)

      $users_id

      идентификатор пользователя, если false - берется текущий пользователь.

      $param

      массив параметров
      • $param['information_groups_small_image'] имя файла с малым изображением для информационной группы
      • $param['site_users_id'] идентификатор пользователя сайта, которому принадлежит информационная группа
      • $param['information_groups_activity'] параметр, определяющий доступность группы и ее дочерних групп, и элементов (1 (по умолчанию) - доступна, 0 - не доступна)

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $type = 0; // Добавляем группу
          5.

        5.  $information_groups_id = 0;
          6.

        6.  $InformationSystem_id = 1; // Идентификатор информационной системы
          7.

        7.  $information_groups_parent_id = 0; // Добавляем в корневую группу
          8.

        8.  $information_groups_name = 'Тестовая группа'; // Название группы
          9.

        9.  $information_groups_description = 'Описание группы Тестовая группа';
          10.

        10.  $information_groups_order = 10;
          11.

        11.  $information_groups_path = 'test-group';
          12.

        12.  $information_groups_image = ''; // Нет изображения
          13.

        13.  $information_groups_allow_indexation = 1; // Индексируем групу
          14.

        14.  $information_groups_seo_title = 'Тестовая группа';
          15.

        15.  $information_groups_seo_description = 'Тестовая группа';
          16.

        16.  $information_groups_seo_keywords = 'Тестовая группа';
          17.

        17.  $information_groups_access = -1; // Доступ как у родителя, т.е. в данном случае как у информационной системы с идентификатором 1
          18.

        18.
          19.

        19.  $InformationSystem->InsertInformationGroups($type, $information_groups_id, $InformationSystem_id,
          20.

        20.  $information_groups_parent_id, $information_groups_name, $information_groups_description, $information_groups_order,
          21.

        21.  $information_groups_path, $information_groups_image, $information_groups_allow_indexation = 1,
          22.

        22.  $information_groups_seo_title = '', $information_groups_seo_description = '', $information_groups_seo_keywords = '',
          23.

        23.  $information_groups_access = -1);
          24.

        24.
          25.

        25.  ?>
          26.

      Возвращает

      идентификатор вставленной/обновленной информационной группы

      [ Наверх ]

      InformationSystem::InsertInformationItem

InsertInformationItem(
array
$param );

      Описание

      Вставка/обновление данных об информационном элементе

      Принимаемые параметры

      $param

      массив параметров
      • int $param['information_items_id'] идентификатор обновляемого информационного элемента
      • int $param['information_systems_id'] идентификатор информационной системы, к которой принадлежит элемент
      • int $param['information_groups_id'] идентификатор информационной группы, к которой принадлежит элемент
      • int $param['information_items_shortcut_id'] идентификатор информационного элемента, на который ссылается ярлык. По умолчанию равен 0.
      • string $param['information_items_date'] дата добавления/обновления информационного элемента
      • string $param['information_items_name'] название информационного элемента
      • string $param['information_items_description'] описание информационного элемента
      • string $param['information_items_text'] текст информационного элемента
      • int $param['information_items_status'] параметр, определяющий активность информационного элемента (0 – неактивен, 1 -активен)
      • string $param['information_items_image'] название файла изображения для информационного элемента
      • int $param['information_items_order'] порядковый номер информационного элемента
      • string $param['information_items_ip'] ip-адрес компьтера, с которого был добавлен инфорнмационный элемент
      • string $param['information_items_url'] название информационного элемента в URL
      • int $param['information_items_allow_indexation'] параметр, определяющий индексировать информационный элемент или нет (0 неиндексировать, 1- индексировать)
      • string $param['information_items_seo_title'] параметр, определяющий заголовок страницы при отображении информационного элемента
      • string $param['information_items_seo_description'] параметр, определяющий значение мета-тега description страницы, на которой отображается содержимое информационного элемента
      • string $param['information_items_seo_keywords'] параметр, определяющий значение мета-тега keywords страницы, на которой отображается содержимое информационного элемента
      • int $param['information_items_access'] параметр, определяющий тип доступа для данного информационного элемента (0 доступна всем, -1 доступ как у родителя, 6 доступно пользователю, 7 недоступно всем, 8 доступно модераторам)
      • string $param['information_items_putoff_date'] дата начала публикации, по умолчанию текущее значение даты
      • string $param['information_items_putend_date'] дата окончания публикации, по умолчанию отсутствует
      • string $param['information_items_small_image'] название файла малого изображения для информационного элемента
      • int $param['site_users_id'] идентификатор пользователя сайта, добавившего информационный элемент. Если не передан - определяется автоматически.
      • int $param['information_items_show_count'] число просмотров информационного элемента
      • mixed $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
      • bool $param['search_event_indexation'] использовать ли событийную индексацию при вставке элемента, по умолчанию true

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $param = array();
        5.

      5.
        6.

      6.  $param['information_systems_id'] = 1;
        7.

      7.  $param['information_groups_id'] = 0;
        8.

      8.  $param['information_items_date'] = '2008-03-14 11:28:12';
        9.

      9.  $param['information_items_name'] = 'Тестовый элемент';
        10.

      10.  $param['information_items_description'] = 'Описание тестового элемента ...';
        11.

      11.  $param['information_items_text'] = 'Текст тестового элемента ...';
        12.

      12.  $param['information_items_status'] = 1;
        13.

      13.  $param['information_items_order'] = 10;
        14.

      14.  $param['information_items_ip'] = '195.178.0.2';
        15.

      15.  $param['information_items_url'] = 'test_item';
        16.

      16.  $param['information_items_allow_indexation'] = 1;
        17.

      17.  $param['information_items_seo_title'] = 'Тестовый элемент';
        18.

      18.  $param['information_items_seo_description'] =  'Тестовый элемент';
        19.

      19.  $param['information_items_seo_keywords'] = 'Тестовый элемент';
        20.

      20.  $param['information_items_access'] = -1;
        21.

      21.  $param['information_items_putoff_date'] = '2008-03-14 11:28:12';
        22.

      22.  $param['information_items_putend_date'] = '2008-10-16 15:46:00';
        23.

      23.
        24.

      24.  // Загрузка изображения для информационного элемента осуществляется аналогично загрузке
        25.

      25.  // изображения при добавлении/редактировании информационной группы
        26.

      26.
        27.

      27.  if ($InformationSystem->InsertInformationItem($param))
        28.

      28.  {
        29.

      29.          echo 'Элемент добавлен';
        30.

      30.  }
        31.

      31.  else
        32.

      32.  {
        33.

      33.          echo 'Ошибка! Элемент не добавлен!'
        34.

      34.  }
        35.

      35.  ?>
        36.

      Возвращает

      идентификатор вставленного/обновленного  элемента информационной системы

      [ Наверх ]

      InformationSystem::InsertInformationItems

InsertInformationItems(
int
$type, int
$information_items_id, int
$InformationSystem_id, int
$information_groups_id, string
$information_items_date, string
$information_items_name, string
$information_items_description, int
$information_items_status, string
$information_items_text, string
$information_items_image, int
$information_items_order, string
$information_items_ip, [string
$information_items_url = ''], [int
$information_items_allow_indexation = 1], [string
$information_items_seo_title = ''], [string
$information_items_seo_description = ''], [string
$information_items_seo_keywords = ''], [int
$information_items_access = -1], [array
$param = array()], [int
$users_id = false] );

      Описание

      Вставка/обновление данных об информационном элементе. Устаревший метод

      Принимаемые параметры

      $type

      параметр, определяющий производится вставка или обновление данных об информационном элементе (0 – вставка, 1 обновление)

      $information_items_id

      идентификатор обновляемого информационного элемента (при вставке равен 0)

      $InformationSystem_id

      идентификатор информационной системы, к которой принадлежит элемент

      $information_groups_id

      идентификатор информационной группы, к которой принадлежит элемент

      $information_items_date

      дата добавления/обновления информационного элемента;

      $information_items_name

      название информационного элемента

      $information_items_description

      описание информационного элемента

      $information_items_status

      параметр, определяющий активность информационного элемента (0 – неактивен, 1 -активен)

      $information_items_text

      текст информационного элемента

      $information_items_image

      название файла изображения для информационного элемента

      $information_items_order

      порядковый номер информационного элемента

      $information_items_ip

      ip-адрес компьтера, с которого был добавлен инфорнмационный элемент

      $information_items_url

      название информационного элемента в URL

      $information_items_allow_indexation

      параметр, определяющий индексировать информационный элемент или нет (0 неиндексировать, 1- индексировать)

      $information_items_seo_title

      параметр, определяющий заголовок страницы при отображении информационного элемента

      $information_items_seo_description

      параметр, определяющий значение мета-тега description страницы, на которой отображается содержимое информационного элемента

      $information_items_seo_keywords

      параметр, определяющий значение мета-тега keywords страницы, на которой отображается содержимое информационного элемента

      $information_items_access

      параметр, определяющий тип доступа для данного информационного элемента (0 доступна всем, -1 доступ как у родителя, 6 доступно пользователю, 7 недоступно всем, 8 доступно модераторам)

      $param

      массив дополнительных параметров
      • $param['putoff_date'] дата начала публикации, по умолчанию текущее значение даты
      • $param['putend_date'] дата окончания публикации, по умолчанию отсутствует
      • $param['information_items_small_image'] название файла малого изображения для информационного элемента
      • $param['indexation'] параметр, определяющий индексировать информационный элемент или нет
      • $param['site_users_id'] идентификатор пользователя сайта, добавившего информационный элемент. Если не передан - определяется автоматически.
      • $param['show_count'] число просмотров информационного элемента

      $users_id

      идентификатор пользователя, если false - берется текущий пользователь.

      Возвращает

      идентификатор вставленного/обновленного  элемента информационной системы

      [ Наверх ]

      InformationSystem::InsertInformationItemTags

InsertInformationItemTags(
array
$array );

      Описание

      Вставка тегов для информационных элементов

      Принимаемые параметры

      $array

      массив атрибутов
      str $array['tags'] - теги для информационного элемента с разделителем 'запятая'
      str $array['information_items_id'] - идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $array['tags'] = 'newtag';
        5.

      5.  $array['information_items_id'] = 1;
        6.

      6.
        7.

      7.  $result = $InformationSystem->InsertInformationItemTags($array);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $result;
        11.

      11.  ?>
        12.

      [ Наверх ]

      InformationSystem::InsertInformationPropertys

InsertInformationPropertys(
array
$param );

      Описание

      Вставка/обновление информации о дополнительном свойстве информационных элементов

      Принимаемые параметры

      $param

      массив параметров
      • $param['information_propertys_id'] идентификатор обновляемого свойства (при вставке равен 0);
      • $param['information_system_id'] идентификатор информационной системы, к которой принадлежит свойство
      • $param['information_propertys_name'] название свойства информационной системы
      • $param['information_propertys_type'] код типа свойства информационной системы (0 - число, 1 - строка, 2 - файл, 3 - список, 4 - большое текстовое поле, 5 - информационная система, 6 - визуальный редактор)
      • $param['information_propertys_order'] порядковый номер свойства информационной системы
      • $param['information_propertys_define_value'] значение свойства информационной системы по умолчанию
      • $param['information_propertys_xml_name'] имя XML тега для данного свойства информационной системы
      • $param['information_propertys_lists_id'] идентификатор списка, который указывается в качестве свойства информационной системы
      • $param['information_propertys_information_systems_id'] идентификатор информационной системы, которая указывается в качестве свойства данной информационной системы
      • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $param['information_propertys_id'] = 0;
          5.

        5.  $param['information_system_id'] = 15;
          6.

        6.  $param['information_propertys_name'] = 'Новое свойство';
          7.

        7.  $param['information_propertys_type'] = 4;
          8.

        8.  $param['information_propertys_xml_name'] = 'newproperty';
          9.

        9.
          10.

        10.  $newid = $InformationSystem->InsertInformationPropertys($param);
          11.

        11.
          12.

        12.  // Распечатаем результат
          13.

        13.  echo $newid;
          14.

        14.  ?>
          15.

      Возвращает

      идентификатор вставленного/обновленного свойства информационных элементов

      [ Наверх ]

      InformationSystem::InsertInformationPropertysGroups

InsertInformationPropertysGroups(
array
$param );

      Описание

      Вставка/редактирование информации о дополнительном свойстве групп информационной системы

      Принимаемые параметры

      $param

      массив параметров
      • $param['information_propertys_groups_id'] идентификатор дополнительного свойства информационных групп
      • $param['information_system_id'] идентификатор информационной системы
      • $param['information_propertys_groups_name'] название дополнительного свойства информационных групп
      • $param['information_propertys_groups_type'] тип дополнительного свойства информационных групп (0 - число, 1 - строка, 2- файл, 3 - список, 4 - большое текстовое поле, 5 - информационная система, 6 - визуальный редактор)
      • $param['information_propertys_groups_order'] порядковый номер информационных групп
      • $param['information_propertys_groups_default_value'] значение дополнительного свойства информационных групп по умолчанию
      • $param['information_propertys_groups_xml_name'] название xml-тега, соответсвующего данному дополнительному свойству информационных групп
      • $param['information_propertys_groups_lists_id'] идентификатор списка, который указывается в качестве дополнительного свойства информационных групп
      • $param['information_propertys_groups_information_system_id'] идентификатор информационной системы, используемой в качестве дополнительного свойства информационных группы
      • $param['information_propertys_groups_dir_id'] идентификатор родительского раздела свойства
      • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $param['information_propertys_groups_id'] = 0;
          5.

        5.  $param['information_system_id'] = 15;
          6.

        6.  $param['information_propertys_groups_name'] = 'Свойство 1';
          7.

        7.  $param['information_propertys_groups_type'] = 4;
          8.

        8.  $param['information_propertys_groups_default_value'] = '';
          9.

        9.  $param['information_propertys_groups_xml_name'] = 'svoystvo1';
          10.

        10.  $param['information_propertys_groups_lists_id'] = '';
          11.

        11.  $param['information_propertys_groups_information_system_id'] = '';
          12.

        12.
          13.

        13.  $newid = $InformationSystem->InsertInformationPropertysGroups($param);
          14.

        14.
          15.

        15.  // Распечатаем результат
          16.

        16.  echo $newid;
          17.

        17.  ?>
          18.

      Возвращает

      идентификатор вставленного/обновленного дополнительного свойства информационных групп

      [ Наверх ]

      InformationSystem::InsertInformationPropertysGroupsValue

InsertInformationPropertysGroupsValue(
int
$type, int
$information_propertys_groups_value_id, int
$information_groups_id, int
$information_propertys_groups_id, string
$information_propertys_groups_value_value, [
$information_propertys_groups_value_file = ''], [
$remove_xss = false], [
$information_propertys_groups_value_value_small = ''], [
$information_propertys_groups_value_file_small = ''] );

      Описание

      Вставка/обновление значения свойства информационной группы

      Принимаемые параметры

      $type

      параметр, определяющий будет производиться вставка или обновление значения дополнительного свойства информационной группы (0 - вставка, 1 - обновление)

      $information_propertys_groups_value_id

      идентификатор дополнительного свойства информационной группы (при вставке равен 0)

      $information_groups_id

      идентификатор информационной группы

      $information_propertys_groups_id

      идентификатор дополнительного свойства группы

      $information_propertys_groups_value_value

      значение дополнительного свойства информационной группы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $type = 0;
        5.

      5.  $information_propertys_groups_value_id = 0;
        6.

      6.  $information_groups_id = 12;
        7.

      7.  $information_propertys_groups_id = 9;
        8.

      8.  $information_propertys_groups_value_value = 'Значение свойства';
        9.

      9.
        10.

      10.  $newid = $InformationSystem->InsertInformationPropertysGroupsValue($type, $information_propertys_groups_value_id, $information_groups_id, $information_propertys_groups_id, $information_propertys_groups_value_value);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  echo $newid;
        14.

      14.  ?>
        15.

      $information_propertys_groups_value_file

      $remove_xss

      $information_propertys_groups_value_value_small

      $information_propertys_groups_value_file_small

      Возвращает

      идентификатор добавленнного/обновленного значения дополнительного свойства информационной группы

      [ Наверх ]

      InformationSystem::InsertInformationPropertysItems

InsertInformationPropertysItems(
int
$type, int
$information_propertys_items_id, int
$information_propertys_id, int
$information_items_id, string
$information_propertys_items_value, [string
$information_propertys_items_file = ''], [string
$information_propertys_items_value_small = ''], [string
$information_propertys_items_file_small = ''] );

      Описание

      Вставка/обновление значения свойства элемента информационной системы

      Принимаемые параметры

      $type

      параметр, определяющий будет производиться вставка или обновление значения свойства информационной системы (0 - вставка, 1 - обновление)

      $information_propertys_items_id

      идентификатор значения свойства информационной системы для конкретного элемента информационной системы (при вставке равен 0)  Можно указать при обновлении 0, тогда будет осуществлен поиск по другим параметрам

      $information_propertys_id

      идентификатор свойства информационной системы

      $information_items_id

      идентификатор элемента информационной системы

      $information_propertys_items_value

      значение элемента информационной системы

      $information_propertys_items_file

      имя хранящегося на сервере файла - значения дополнительного свойства

      $information_propertys_items_value_small

      оригинальное имя файла малого изображения

      $information_propertys_items_file_small

      имя хранящегося на сервере файла малого изображения
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $type = 0;
        5.

      5.  $information_propertys_items_id = 0;
        6.

      6.  $information_propertys_id = 23;
        7.

      7.  $information_items_id = 106;
        8.

      8.  $information_propertys_items_value = '';
        9.

      9.
        10.

      10.  $newid = $InformationSystem->InsertInformationPropertysItems($type, $information_propertys_items_id, $information_propertys_id, $information_items_id, $information_propertys_items_value);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  echo $newid;
        14.

      14.  ?>
        15.

      Возвращает

      идентификатор вставленного/обновленного значения свойства информационного элемента

      [ Наверх ]

      InformationSystem::InsertInformationSystemsDir

InsertInformationSystemsDir(
array
$param );

      Описание

      Добавление/обновление раздела информационных систем

      Принимаемые параметры

      $param

      масcив параметров
      • $param['information_systems_dir_id'] идентификатор редактируемого раздела информационных систем
      • $param['information_systems_dir_parent_id'] идентификатор родительского раздела информационных систем
      • $param['information_systems_dir_name'] название раздела информационных систем
      • $param['information_systems_dir_description'] описание раздела информационных систем
      • $param['site_id'] идентификатор сайта
      • $param['users_id'] идентификатор пользователя центра администрирования, если false - берется текущий пользователь.

      Возвращает

      идентификатор добавленного/обновленного раздела информационных систем в случае успешного выполнения,  false - в противном случае

      [ Наверх ]

      InformationSystem::InsertInfotmationSystem

InsertInfotmationSystem(
array
$param );

      Описание

      Вставка/обновление данных об информационной системе

      Принимаемые параметры

      $param

      - $param['type'] элемент, определяющий будет производиться вставка или обновление данных об информационной системе (0 – вставка, 1 - обновление);
      • $param['id'] идентификатор обновляемой информационной системы (при вставке равен 0)
      • $param['information_systems_dir_id'] идентификатор раздела информационных систем
      • $param['site_id'] идентификатор сайта, к которому принадлежит информационная система
      • $param['name'] название информационной системы
      • $param['description']  описание информационной системы
      • $param['items_order_field'] поле сортировки элементов данной информационной системы
      • $param['items_order_type'] направление сортировки элементов информационной системы
      • $param['information_systems_access'] параметр, определяющий группу пользователей, имеющих доступ к информационной системе (0 - доступна всем)
      • $param['information_systems_group_items_order_field'] поле сортировки групп данной информационной системы
      • $param['information_systems_group_items_order_type'] направление сортировки элементов информационной системы
      • $param['information_systems_captcha_used'] использовать автоматизированный тест Тьюринга разделения людей и компьютеров (1 - использовать, 0 - не использовать). по умолчанию используется
      • $param['watermark_file'] - файл марки для наложения на изображения
      • $param['watermark_file_expantion'] - расширение файла марки для наложения
      • $param['watermark_default_used'] - параметр, определяющий используется ли файл марки по умолчанию (1 - используется, 0 - не используется).
      • $param['watermark_default_used_small'] - параметр, определяющий используется ли файл марки по умолчанию для малых изображений(1 - используется, 0 - не используется).
      • $param['structure_id'] - параметр определяющий идентификатор узла структуры, где будет отображаться данный элемент
      • $param['information_systems_format_date'] формат даты
      • $param['information_systems_format_datetime'] формат дата/время
      • $param['information_systems_image_big_max_width'] максимальная ширина «большого» варианта изображения при уменьшении загружаемого изображения элемента информационной системы
      • $param['information_systems_image_big_max_height'] максимальная высота «большого» варианта изображения при уменьшении загружаемого изображения элемента информационной системы
      • $param['information_systems_image_small_max_width'] максимальная ширина «маленького» варианта изображения при уменьшении загружаемого изображения элемента информационной системы
      • $param['information_systems_image_small_max_height'] максимальная высота «маленького» варианта изображения при уменьшении загружаемого изображения элемента информационной системы. по умолчанию - используется.
      • $param['watermark_default_position_x'] позиция изображения по оси X по умолчанию. по умолчанию равна 50%.
      • $param['watermark_default_position_y'] позиция изображения по оси Y по умолчанию. по умолчанию равна 100%.
      • $param['information_systems_default_save_proportions'] флаг, определющий, сохранять ли пропорции изображений
      • $param['items_on_page'] число информационных элементов выводимых на страницу
      • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
      • $param['information_systems_url_type'] параметр, определяющий тип формирования URL для элементов информационной системы
      • 0 (по умолчанию) - по идентификатору информационного элемента;
      • 1 - по транслитерации от названия информационного элемента.
      • $param['information_systems_typograph_item'] параметр, определяющий использование типографирования по умолчанию для информационных элементов,

        1 - применять типографирование (по умолчанию), 0 - не применять
      • $param['information_systems_typograph_group'] параметр, определяющий использование типографирования по умолчанию для информационных групп,

        1 - применять типографирование (по умолчанию), 0 - не применять
      • $param['information_systems_apply_tags_automatic'] параметр, определяющий будут при добавлении информационных элементов в случае отсутствия тегов автоматически формироваться теги для данных информационных элементов из их названия, описания и текста

         1 - теги формируются автоматически (по умолчанию), 0 - не формируюся автоматически
      • 0 - названия файлов не преобразуются, 1 - преобразуются (по умолчанию)

        1. <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $param = array()
          5.

        5.
          6.

        6.  $param['type'] = 0;
          7.

        7.  $param['id'] = 1;
          8.

        8.  $param['site_id'] = 1;
          9.

        9.  $param['name'] = 'Статьи';
          10.

        10.  $param['description'] = 'Описание информационной системы Статьи...';
          11.

        11.  $param['items_order_field'] = 0;
          12.

        12.  $param['items_order_type'] = 1;
          13.

        13.  $param['information_systems_access'] = 0;
          14.

        14.  $param['information_systems_captcha_used'] = 1;
          15.

        15.  $param['watermark_file'] = '';
          16.

        16.  $param['watermark_file_expantion'] = '';
          17.

        17.  $param['watermark_default_used'] = 1;
          18.

        18.  $param['watermark_default_used_small'] = 1;
          19.

        19.  $param['watermark_default_position_x'] = '50%';
          20.

        20.  $param['watermark_default_position_y'] = '100%';
          21.

        21.  $param['structure_id'] = 7;
          22.

        22.  $param['items_on_page'] = 3;
          23.

        23.  $param['information_systems_group_items_order_field'] = 0;
          24.

        24.  $param['information_systems_group_items_order_type'] = 0;
          25.

        25.  $param['information_systems_format_date'] = '%d.%m.%Y';
          26.

        26.  $param['information_systems_format_datetime'] = '%d.%m.%Y %H:%M:%S';
          27.

        27.  $param['information_systems_image_big_max_width'] = 900;
          28.

        28.  $param['information_systems_image_big_max_height'] = 900;
          29.

        29.  $param['information_systems_image_small_max_width'] = 100;
          30.

        30.  $param['information_systems_image_small_max_height'] = 100;
          31.

        31.  $param['information_systems_url_type'] = 0;
          32.

        32.  $param['information_systems_typograph_item'] = 1;
          33.

        33.  $param['information_systems_typograph_group'] = 1;
          34.

        34.
          35.

        35.  $information_system_id = $InformationSystem->InsertInfotmationSystem($param);
          36.

        36.
          37.

        37.  ?>
          38.

      Возвращает

      идентификатор вставленной/обновленной информационной системы

      [ Наверх ]

      InformationSystem::InsertPropertyGroupsDir

InsertPropertyGroupsDir(
array
$param );

      Описание

      Добавление информации о группе дополнительных свойств групп информационной системы

      Принимаемые параметры

      $param

      Массив параметров
      • array['information_propertys_groups_dir_id'] идентификатор группы дополнительных свойств групп информационных систем
      • array['information_systems_id'] идентификатор информационной системы
      • array['information_propertys_groups_dir_parent_id'] идентификатор информационной родительской группы дополнительных свойств
      • array['information_propertys_groups_dir_name'] название группы дополнительных свойств
      • array['information_propertys_groups_dir_description'] описание группы дополнительных свойств
      • array['information_propertys_groups_dir_order'] порядок сортировки группы дополнительных свойств

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $param['information_systems_id'] = 1;
          5.

        5.  $param['information_propertys_items_dir_parent_id'] = 3;
          6.

        6.  $param['information_propertys_groups_dir_name'] = 'Новая группа';
          7.

        7.  $param['information_propertys_groups_dir_description'] = 'Описание группы дополнительных свойств';
          8.

        8.  $param['information_propertys_groups_dir_order'] = 10;
          9.

        9.
          10.

        10.  $newid = $InformationSystem->InsertPropertysItemsDir($param);
          11.

        11.
          12.

        12.  // Распечатаем результат
          13.

        13.  if ($newid)
          14.

        14.  {
          15.

        15.      echo 'Группа дополнительных свойств информационных групп добавлена';
          16.

        16.  }
          17.

        17.  else
          18.

        18.  {
          19.

        19.      echo 'Ошибка! Группа дополнительных свойств информационных групп не добавлена!';
          20.

        20.  }
          21.

        21.  ?>
          22.

      Возвращает

      идентификатор вставленной записи, либо false

      [ Наверх ]

      InformationSystem::InsertPropertysItemsDir

InsertPropertysItemsDir(
array
$param );

      Описание

      Добавление информации о группе дополнительных свойств информационных элементов

      Принимаемые параметры

      $param

      Массив параметров
      • $param['information_propertys_items_dir_id'] Идентификатор группы дополнительных свойств информационных элементов
      • $param['information_systems_id'] Идентификатор информационной системы
      • $param['information_propertys_items_dir_parent_id'] Идентификатор родительской группы дополнительных свойств информационных элементов
      • $param['information_propertys_items_dir_name'] Название группы дополнительных свойств информационных элементов
      • $param['information_propertys_items_dir_description'] Описание группы дополнительных свойств информационных элементов
      • $param['information_propertys_items_dir_order'] Порядок сортировки группы дополнительных свойств информационных элементов
      • $param['users_id'] Идентификатор пользователя центра администрирования, создавшего элемент

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $param['information_systems_id'] = 1;
          5.

        5.  $param['information_propertys_items_dir_parent_id'] = 3;
          6.

        6.  $param['information_propertys_items_dir_name'] = 'Новая группа';
          7.

        7.  $param['information_propertys_items_dir_description'] = 'Описание группы дополнительных свойств информационных элементов';
          8.

        8.  $param['information_propertys_items_dir_description'] = 'Описание группы дополнительных свойств информационных элементов';
          9.

        9.  $param['information_propertys_items_dir_order'] = 10;
          10.

        10.
          11.

        11.  $newid = $InformationSystem->InsertPropertysItemsDir($param);
          12.

        12.
          13.

        13.  // Распечатаем результат
          14.

        14.  if ($newid)
          15.

        15.  {
          16.

        16.      echo 'Группа дополнительных свойств информационных элементов добавлена';
          17.

        17.  }
          18.

        18.  else
          19.

        19.  {
          20.

        20.      echo 'Ошибка! Группа дополнительных свойств информационных элементов не добавлена!';
          21.

        21.  }
          22.

        22.  ?>
          23.

      Возвращает

      идентификатор вставленной записи, либо False

      [ Наверх ]

      InformationSystem::IssetAccessForInformationSystemGroup

IssetAccessForInformationSystemGroup(
int
$site_users_id, int
$information_group_id, [int
$information_system_id = 0], [array
$row_group = array()], [array
$property = array('cache' => true)] );

      Описание

      Проверка возможности доступа пользователя к информационной группе

      Принимаемые параметры

      $site_users_id

      идентификатор пользователя

      $information_group_id

      идентификатор информационной группы

      $information_system_id

      идентификатор информационной системы, не обязательный параметр, по умолчанию 0

      $row_group

      ассоциативный массив с информацией о группе, по умолчанию пустой

      $property

      ассоциативный массив с параметрами
      • $property['cache'] - использовать кэширование, по умолчанию true

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  // Получим текущего пользователя
          5.

        5.  $SiteUsers = new SiteUsers();
          6.

        6.  $site_users_id = $SiteUsers->GetCurrentSiteUser();
          7.

        7.
          8.

        8.  $information_group_id = 2;
          9.

        9.  $information_system_id = 1;
          10.

        10.
          11.

        11.  $result = $InformationSystem->IssetAccessForInformationSystemGroup($site_users_id, $information_group_id, $information_system_id);
          12.

        12.
          13.

        13.  // Распечатаем результат
          14.

        14.  if ($result)
          15.

        15.  {
          16.

        16.      echo 'Информационная группа доступна пользователю';
          17.

        17.  }
          18.

        18.  else
          19.

        19.  {
          20.

        20.      echo 'Информационная группа не доступна пользователю';
          21.

        21.  }
          22.

        22.  ?>
          23.

      [ Наверх ]

      InformationSystem::IssetGroup

IssetGroup(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$information_groups_path, [int
$edit_mode = 0], [int
$information_groups_id = 0] );

      Описание

      Проверка наличия среди подгрупп данной группы подгруппы с таким же URL как и у вставляемой/редактируемой группы

      Принимаемые параметры

      $information_groups_parent_id

      идентификатор родительской группы

      $InformationSystem_id

      идентификатор информационной системы

      $information_groups_path

      URL вставляемой/обновляемой группы

      $edit_mode

      параметр, указывающий производится вставка или обновление группы (0 –вставка, 1 – обновление)

      $information_groups_id

      идентификатор редактируемой информационной группы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_parent_id = 2;
        5.

      5.  $InformationSystem_id = 1;
        6.

      6.  $information_groups_path = 'films2';
        7.

      7.  $edit_mode = 0;
        8.

      8.  $information_groups_id = 15;
        9.

      9.
        10.

      10.  $result = $InformationSystem->IssetGroup($information_groups_parent_id, $InformationSystem_id, $information_groups_path, $edit_mode, $information_groups_id);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  if ($result)
        14.

      14.  {
        15.

      15.      echo 'В данной группе есть подгруппа, которая имеет такой же URL как и вставляемая/редактируемая подгруппа';
        16.

      16.  }
        17.

      17.  else
        18.

      18.  {
        19.

      19.      echo 'В данной группе отсутствует подгруппа, которая имеет такой же URL как и вставляемая/редактируемая подгруппа';
        20.

      20.  }
        21.

      21.  ?>
        22.

      Возвращает

      true – в данной группе есть подгруппа, которая имеет такой же URL как и вставляемая/редактируемая подгруппа. В противном случае возвращает false

      [ Наверх ]

      InformationSystem::IssetGroupItemInsertUpdate

IssetGroupItemInsertUpdate(
int
$information_groups_id, int
$InformationSystem_id, string
$information_items_url );

      Описание

      Проверка наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента

      Принимаемые параметры

      $information_groups_id

      идентификатор информационной группы, в которой осуществляется поиск

      $InformationSystem_id

      идентификатор информационной системы, к которой относится группа

      $information_items_url

      URL информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 2;
        5.

      5.  $InformationSystem_id = 1;
        6.

      6.  $information_items_url = 'news1';
        7.

      7.
        8.

      8.  $result = $InformationSystem->IssetGroupItemInsertUpdate($information_groups_id, $InformationSystem_id, $information_items_url);
        9.

      9.  // Распечатаем результат
        10.

      10.  if ($result)
        11.

      11.  {
        12.

      12.      echo 'В данной группе есть подгруппа, URL которой совпадает с URL информационного элемента';
        13.

      13.  }
        14.

      14.  else
        15.

      15.  {
        16.

      16.      echo 'В данной группе отсутствует подгруппа, URL которой совпадает с URL информационного элемента';
        17.

      17.  }
        18.

      18.  ?>
        19.

      Возвращает

      true - в данной группе есть подгруппа, URL которой совпадает с URL информационного элемента, относящегося к данной группе. В противном случае возвращает false

      [ Наверх ]

      InformationSystem::IssetItem

IssetItem(
int
$information_groups_id, int
$InformationSystem_id, string
$information_items_url, [int
$information_items_id = 0], [int
$edit_mode = 0] );

      Описание

      Проверка наличия элемента с конкретным URL среди информационных элементов данной группы

      Принимаемые параметры

      $information_groups_id

      идентификатор информационной группы, среди элементов которой проводится проверка

      $InformationSystem_id

      идентификатор информационной системы, среди элементов которой проводится проверка

      $information_items_url

      URL информационного элемента, для которого ищем совпадения среди URL других элементов данной информационной группы

      $information_items_id

      идентификатор редактируемого информационного элемента, при добавлении $information_items_id = 0

      $edit_mode

      параметр, определяющий  режим вставки или добавления элемента (0 – вставка, 1- редактирование)
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_id = 2;
        5.

      5.  $InformationSystem_id = 1;
        6.

      6.  $information_items_url = 'news1';
        7.

      7.
        8.

      8.  $result = $InformationSystem->IssetItem($information_groups_id, $InformationSystem_id, $information_items_url);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  if ($result)
        12.

      12.  {
        13.

      13.      echo 'В данной информационной группе есть элемент с таким URL';
        14.

      14.  }
        15.

      15.  else
        16.

      16.  {
        17.

      17.      echo 'В данной информационной группе отсутствует элемент с таким URL';
        18.

      18.  }
        19.

      19.  ?>
        20.

      Возвращает

      true – в информационной группе уже существует информационный элемент с таким же URL как и у данного элемента, false – в информационной группе не существует элементов с таким URL

      [ Наверх ]

      InformationSystem::IssetItemGroupInsertUpdate

IssetItemGroupInsertUpdate(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$information_groups_path );

      Описание

      Проверка наличия среди информационных элементов данной группы такого, у которого URL совпадает с URL добавляемой/редактируемой информационной группы

      Принимаемые параметры

      $information_groups_parent_id

      идентификатор родительской группы

      $InformationSystem_id

      идентификатор информационной системы

      $information_groups_path

      URL вставляемой/редактируемой группы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_groups_parent_id = 2;
        5.

      5.  $InformationSystem_id = 1;
        6.

      6.  $information_groups_path = 'films1';
        7.

      7.
        8.

      8.  $result = $InformationSystem->IssetItemGroupInsertUpdate($information_groups_parent_id, $InformationSystem_id, $information_groups_path);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  if ($result)
        12.

      12.  {
        13.

      13.      echo 'В данной группе есть информационный элемент, URL которого совпадает с URL добавляемой/редактируемой группы';
        14.

      14.  }
        15.

      15.  else
        16.

      16.  {
        17.

      17.      echo 'В данной группе отсутствует информационный элемент, URL которого совпадает с URL добавляемой/редактируемой группы';
        18.

      18.  }
        19.

      19.  ?>
        20.

      Возвращает

      true – в данной группе есть информационный элемент, URL которого совпадает с URL добавляемой/редактируемой группы. В противном случае возвращает false

      [ Наверх ]

      InformationSystem::IssetSiteUserInUsersGroupInformationGroup

IssetSiteUserInUsersGroupInformationGroup(
array
$param );

      Описание

      Проверка вхождения пользователя сайта в группу пользователей, связанную с информационной группой

      Принимаемые параметры

      $param

      массив параметров
      • $param['site_user_id'] идентификатор пользователя сайта
      • $param['site_users_group_id'] идентификатор группы пользователей сайта
      • $param['information_group_id'] идентификатор информационной группы

      [ Наверх ]

      InformationSystem::SearchIndexing

SearchIndexing(
$limit
$limit, $on_step
$on_step );

      Описание

      Функция обратного вызова для поисковой индексации данных модуля

      Принимаемые параметры

      $limit

      текущая позиция

      $on_step

      шаг

      [ Наверх ]

      InformationSystem::SelectInformationGroups

SelectInformationGroups(
int
$information_groups_id, [int
$information_system_id = false], [array
$param = array()] );

      Описание

      Получение информации об информационных группах  Устаревший метод, ОСТАВЛЕН ДЛЯ СОВМЕСТИМОСТИ.

      Принимаемые параметры

      $information_groups_id

      идентификатор выбираемой информационной группы, если $information_groups_id = -1 – выбираются все группы данной информационной системы

      $information_system_id

      идентификатотр информационной системы

      $param

      массив дополнительных параметров
      • $param['OrderGroup'] = ASC/DESC порядок сортировки информационных групп
      • $param['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()
      • $param['NotInGroup'] строка с идентификаторами информационных групп (через запятую), которые (группы) необходимо исключить из результатов. Не влияет на выборку информационных элементов.
      • $param['groups_parent_id'] идентификатор родительской группы, необязательный параметр, по умолчанию false
      • $param['groups_on_page'] число информационных групп, отображаемых на странице
      • $param['groups_begin'] номер, начиная с которого выводить информационные группы
      • $param['groups_activity'] параметр, учитывающий активность групп при выборке. 1 - получаем информацию только об активных группах, если не задан, то активность группы не учитывается
      • $param['sql_from_select_groups'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.
      • $param['select_groups'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных групп

      • $element['type'] определяет, является ли поле основным свойством информационной группы или дополнительным (0 - основное, 1 - дополнительное)
      • $element['prefix'] префикс - строка, размещаемая перед условием
      • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
      • $element['property_id'] идентификатор дополнительногого свойства информационных групп
      • $element['if'] строка, содержащая условный оператор
      • $element['value'] значение поля (или параметра)
      • $element['sufix'] суффикс - строка, размещаемая после условия

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  // Получаем информацию об информационных группах, находящихся в корне информационной системы с идентификатором 1, при этом отсортированных по убыванию порядкового номера
        5.

      5.  $information_groups_id = -1;
        6.

      6.  $information_system_id = 1;
        7.

      7.
        8.

      8.  $param['OrderGroup'] = 'DESC';
        9.

      9.  $param['OrderGroupField'] = 'information_groups_order';
        10.

      10.
        11.

      11.
        12.

      12.  // Формируем дополнительные условия отбора информационных групп
        13.

      13.  $element['type'] = 0;
        14.

      14.  $element['prefix'] = ' AND';
        15.

      15.  $element['name'] = 'information_groups_parent_id';
        16.

      16.  $element['if'] = '=';
        17.

      17.  $element['value'] = '0';
        18.

      18.  $element['sufix'] = '';
        19.

      19.  $param['select_groups'][] = $element;
        20.

      20.
        21.

      21.  $resource = $InformationSystem->SelectInformationGroups($information_groups_id, $information_system_id, $param);
        22.

      22.
        23.

      23.  // Распечатаем результат
        24.

      24.  while($row = mysql_fetch_assoc($resource))
        25.

      25.  {
        26.

      26.     print_r($row);
        27.

      27.  }
        28.

      28.  ?>
        29.

      [ Наверх ]

      InformationSystem::SelectInformationSystem

SelectInformationSystem(
int
$information_systems_id );

      Описание

      Получение информации об информационной системе

      Принимаемые параметры

      $information_systems_id

      идентификатор информационной системы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_systems_id = 1;
        5.

      5.
        6.

      6.  $resource = $InformationSystem->SelectInformationSystem($information_systems_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  $row = mysql_fetch_assoc($resource);
        10.

      10.
        11.

      11.  print_r($row);
        12.

      12.
        13.

      13.  ?>
        14.

      [ Наверх ]

      InformationSystem::SelectListInformationGroupPropertys

SelectListInformationGroupPropertys(
int
$InformationSystem_id );

      Описание

      Получение списка дополнительных свойств информационных группы информационной системы

      Принимаемые параметры

      $InformationSystem_id

      идентификатор информационной системы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $InformationSystem_id = 1;
        5.

      5.
        6.

      6.  $resource = $InformationSystem->SelectListInformationGroupPropertys($InformationSystem_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

      [ Наверх ]

      InformationSystem::SelectPropertysGroupsByDirParentId

SelectPropertysGroupsByDirParentId(
int
$propertys_groups_dir_parent_id, [int
$information_system_id = 0] );

      Описание

      Получение списка дополнительных свойств информационных групп по идентификатору группы дополнительных свойств

      Принимаемые параметры

      $propertys_groups_dir_parent_id

      идентификатор группы дополнительных свойств информационных групп

      $information_system_id

      идентификатор информационной системы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $propertys_groups_dir_parent_id = 7;
        5.

      5.
        6.

      6.  $resource = $InformationSystem->SelectPropertysGroupsByDirParentId($propertys_groups_dir_parent_id);
        7.

      7.
        8.

      8.  while ($row = mysql_fetch_assoc($resource))
        9.

      9.  {
        10.

      10.          print_r($row);
        11.

      11.  }
        12.

      12.  ?>
        13.

      [ Наверх ]

      InformationSystem::SelectPropertysItemsByDirParentId

SelectPropertysItemsByDirParentId(
int
$propertys_items_dir_parent_id, [int
$information_system_id = 0] );

      Описание

      Получение списка дополнительных свойств информационных элементов по идентификатору группы дополнительных свойств

      Принимаемые параметры

      $propertys_items_dir_parent_id

      идентификатор группы дополнительных свойств информационных элементов

      $information_system_id

      идентификатор информационной системы
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $propertys_items_dir_parent_id = 7;
        5.

      5.  $resource = $InformationSystem->SelectPropertysItemsByDirParentId($propertys_items_dir_parent_id)
        6.

      6.
        7.

      7.  $row = mysql_fetch_assoc($resource);
        8.

      8.
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

      [ Наверх ]

      InformationSystem::select_comments

select_comments(
int
$comment_id, int
$information_items_id );

      Описание

      Получение комментариев к информационному элементу

      Принимаемые параметры

      $comment_id

      идентификатор комментария (если  равен -1 - получаем информацию о всех комментариях информационного элемента)

      $information_items_id

      идентификатор информационного элемента
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $comment_id = 9;
        5.

      5.  $information_items_id = 106;
        6.

      6.
        7.

      7.  $resource = $InformationSystem->select_comments($comment_id, $information_items_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  $row = mysql_fetch_assoc($resource);
        11.

      11.  print_r($row);
        12.

      12.  ?>
        13.

      [ Наверх ]

      InformationSystem::select_information_items

select_information_items(
int
$information_items_id, [int
$information_groups_id = false], [int
$information_system_id = false] );

      Описание

      Устаревший метод получения данных об информационном элементе. Рекомендуется использовать GetInformationSystemItem

      Принимаемые параметры

      $information_items_id

      идентификатор выбираемого информационного элемента, если $information_items_id = false – выбираем все информационные элементы данной информационной системы

      $information_groups_id

      идентификатор информационной группы, элементы которой необходимо выбрать, если $information_items_id = false (по умолчанию), то выбираются все элементы данной информационной системы

      $information_system_id

      идентификатор информационной системы

      see

      InformationSystem::GetExternalInformationSystemItem()

      [ Наверх ]

      InformationSystem::SetPathArrayGetInformationFromPath

SetPathArrayGetInformationFromPath(
array
$array );

      Описание

      Устаналивает свойство $this->PathArrayGetInformationFromPath

      Принимаемые параметры

      $array

      [ Наверх ]

      InformationSystem::ShowAddComment

ShowAddComment(
string
$xslname, [array
$param = array (
    'confirm_comment' => false,
    'status' => 0,
    'comment_mail_type' => 1
    )] );

      Описание

      Добавление комментария к элементу информационной системы

      Принимаемые параметры

      $xslname

      имя XSL шаблона для отображения информации о добавлении комментария

      $param

      массив дополнительных параметров

      Возвращает

      false в случае отсутствия данного информационного элемента

      [ Наверх ]

      InformationSystem::ShowInformationSystem

ShowInformationSystem(
mixed
$InformationSystemIdArray, int
$information_groups_id, string
$xsl_name, int
$items_on_page, int
$items_begin, [array
$external_propertys = array()], [array
$property = array()] );

      Описание

      Отображение групп и элементов информационной системы

      Принимаемые параметры

      $InformationSystemIdArray

      массив идентификаторов или идентификатор информационной системы

      $information_groups_id

      идентификатор информационной группы, подгруппы и элементы которой необходимо показать. Для выбора элеменов из всех групп указывается false

      $xsl_name

      имя XSL шаблона для отображения групп и элементов информационной системы

      $items_on_page

      число информационных элементов, отображаемых на странице

      $items_begin

      номер, начиная с которого выводить информационные элементы

      $external_propertys

      массив дополнительных свойств для включения в XML

      $property

      массив дополнительных параметров
      • $property['Order'] = ASC/DESC порядок сортировки информационных элементов
      • $property['OrderField'] поле сортировки информационных элементов, если случайная сортировка, то записать RAND(). При сортировке по средней оценке информационного элемента указывается поле 'information_items_comment_grade'
      • $property['SelectPropertyInQuery'] указывает на необходимость выборки дополнительных свойств элементов в SQL-запросе, по умолчанию true
      • $property['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
      • $property['OrderGroup'] направление сортировки группы (ASC - по возрастанию, DESC - по убыванию)
      • $property['OrderGroupField'] поле сортировки группы, если случайная сортировка, то записать RAND()
      • $property['NotInGroup'] строка с идентификаторами информационных групп (через запятую), которые (группы) необходимо исключить из результатов. Не влияет на выборку информационных элементов.
      • $property['cache'] разрешение кэширования, по умолчанию true
      • $property['cache_off'] запрещает кэшировани в память различных фрагментов информационных систем
      • $property['GenXml_type'] тип генерации XML для метода GenXml() при обработке $external_propertys
      • $property['sql_from'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.
      • $property['sql_from_select_groups'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.
      • $property['show_item_type'] array массив типов информационных элементов, которые должны отображаться. Может содержать следующие элементы:

      • active - активные элементы (внесен по умолчанию, если $property['show_item_type'] не задан);
      • inactive - неактивные элементы;
      • putend_date - элементы, у которых значение поля putend_date меньше текущей даты;
      • putoff_date - элементы, у которых значение поля putoff_date превышает текущую дату;
        </li>  </ul>
      • $property['groups_activity'] тип информационных групп, которые должны отображаться. 1 - активные группы, 2 - все группы (по умолчанию 1)
      • $property['xml_show_item_comment'] разрешает указание в XML комментариев информационного элемента, по умолчанию true
      • $property['xml_show_item_property'] разрешает указание в XML значений свойств информационного элемента, по умолчанию true
      • $property['xml_show_group_property'] разрешает указание в XML значений свойств информационной группы, по умолчанию true
      • $property['xml_show_group_property_id'] массив идентификаторов дополнительных свойств для отображения в XML. Если не передан - отображаются все св-ва для текущей группы и групп в корне.
      • $property['xml_show_group_id'] массив идентификаторов групп для отображения в XML. Если не не передано - выводятся все группы
      • $property['xml_show_group_type'] тип генерации XML групп, может принимать значения (по умолчанию 'tree'):

        • all - все группы всех уровней;
        • current - группы только текущего уровня;
        • tree - будет выбрана текущая группа, все группы, находящиеся на одном уровне с ней, непосредственные потомки текущей группы, а также все группы, являющиеся предками для текущей
        • one_group - только текущая группа;
        • none - не выбирать группы.

      • $property['xml_show_tags'] разрешает генерацию в XML облака тегов информационной системы, по умолчанию false
      • $property['xml_show_all_count_items_and_groups'] разрешает отображение в XML информации об обще количестве элементов

      • $property['show_text'] параметр, указывающий включать в XML текст информационного элемента или нет, по умолчанию равен true
      • $property['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа
      • $property['select_fields'] строка, содержащая дополнительные значения для области select запроса выбора элементов информационной системы
      • $property['select'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных элементов

        • $element['type'] определяет, является ли поле основным свойством информационного элемента или дополнительным (0 - основное, 1 - дополнительное)
        • $element['prefix'] префикс - строка, размещаемая перед условием
        • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
        • $element['property_id'] идентификатор дополнительногого свойства информационных элементов
        • $element['group_property_id'] идентификатор дополнительногого свойства информационных групп
        • $element['if'] строка, содержащая условный оператор
        • $element['value'] значение поля (или параметра)
        • $element['sufix'] суффикс - строка, размещаемая после условия
      • $property['groups_on_page'] число информационных групп, отображаемых на странице
      • $property['groups_begin'] номер, начиная с которого выводить информационные группы

      • $property['show_group'] содержит массив групп системы для показа
      • $property['TagsOrder'] параметр, определяющий порядок сортировки тегов. Принимаемые значения: ASC - по возрастанию (по умолчанию), DESC - по убыванию
      • $property['TagsOrderField'] поле сортировки тегов, если случайная сортировка, то записать RAND(). по умолчанию теги сортируются по названию.
      • $property['tags'] массив идентификаторов тегов, по которым необходим фильтрация информационных элементов
        Пример использования:
      1.  <?php
        2.

      2.  $InformationSystem = & singleton('InformationSystem');
        3.

      3.  $external_propertys = array();
        4.

      4.  $external_propertys['ПоказыватьСсылкиНаДругиеСтраницы'] = 1;
        5.

      5.
        6.

      6.  $property = array();
        7.

      7.  // Заполняем первое условие
        8.

      8.  $element['type'] = 0;
        9.

      9.  $element['prefix'] = ' and (';
        10.

      10.  $element['name'] = 'information_items_date';
        11.

      11.  $element['if'] = '>';
        12.

      12.  $element['value'] = '2005-12-23 00:00:00';
        13.

      13.  $element['sufix'] = '';
        14.

      14.  $property['select'][] = $element;
        15.

      15.
        16.

      16.  // Заполняем второе условие, в данном случае по значению дополнительного св-ва
        17.

      17.  $element['type'] = 1;
        18.

      18.  $element['prefix'] = 'and';
        19.

      19.  $element['property_id'] = 17;
        20.

      20.  $element['if'] = '>';
        21.

      21.  $element['value'] = '2005-12-23 00:00:00';
        22.

      22.  $element['sufix'] = ')';
        23.

      23.  $property['select'][] = $element;
        24.

      24.  // Выводим элементы
        25.

      25.  $InformationSystem->ShowInformationSystem(1, 0, 'СписокНовостей', 10, 0, $external_propertys, $property);
        26.

      26.  ?>
        27.

      Обратите внимание, при фильтрации по нескольким дополнительным свойствам они должны указываться
 через условие OR и должен быть добавлен параметр HAVING, в условие которого количество полей ДОПОЛНИТЕЛЬНЫХ свойств,
 по которым идет фильтрация (в примере дано значение 2):
      1.  $count_condition = 2;
        2.

      2.  $having_count= ' HAVING COUNT(information_propertys_items_table.information_propertys_items_id)= '.$count_condition;
        3.

      3.  $element['sufix']=' ) GROUP BY information_propertys_items_table.information_items_id '.$having_count;
        4.

      Пример сортировки по значению дополнительного поля:
      1.  <?php
        2.

      2.  $InformationSystem = & singleton('InformationSystem');
        3.

      3.  $external_propertys = array();
        4.

      4.  $external_propertys['ПоказыватьСсылкиНаДругиеСтраницы'] = 1;
        5.

      5.
        6.

      6.  $property=array();
        7.

      7.
        8.

      8.  $property_id = 4154;
        9.

      9.
        10.

      10.  $element['type'] = 0;
        11.

      11.  $element['prefix'] = ' and ('; // префикс
        12.

      12.  $element['name'] = 'information_propertys_table.information_propertys_id';
        13.

      13.  $element['if'] = '='; // Условие
        14.

      14.  // Здесь указывается ID доп. св-ва, по которому производится сортировка
        15.

      15.  $element['value'] = $property_id; // ID дополнительного св-ва, по которому сортируем
        16.

      16.  $element['sufix'] = '  OR information_propertys_table.information_propertys_id IS NULL )';
        17.

      17.  $property['select'][] = $element;
        18.

      18.
        19.

      19.  // Фиктивное условие для подключения таблицы доп. свойств
        20.

      20.  $element['type'] = 1;
        21.

      21.  $element['prefix'] = 'or';
        22.

      22.  $element['property_id'] = 9999;
        23.

      23.  $element['if'] = '!=';
        24.

      24.  $element['value'] = '0';
        25.

      25.  $element['sufix'] = '';
        26.

      26.  $property['select'][] = $element;
        27.

      27.
        28.

      28.  // Указываем, что мы сортируем по значениям дополнительных полей
        29.

      29.  $property['OrderField'] = 'information_propertys_items_value';
        30.

      30.
        31.

      31.  // Если сортировка по значению св-ва, а по остальным случайная,
        32.

      32.  // то закомментируйте строку $property['OrderField'] и раскомментируйте строки:
        33.

      33.  //$property['OrderField'] = 'information_propertys_items_value DESC, RAND()';
        34.

      34.  //$property['Order'] = '';
        35.

      35.
        36.

      36.  // Выводим элементы
        37.

      37.  $InformationSystem->ShowInformationSystem(1, 0, 'СписокНовостей', 10, 0, $external_propertys, $property);
        38.

      38.
        39.

      39.  ?>
        40.

      Если Вы создали дополнительное свойство после заполнения информационной системы,  то при сортировке по дополнительному свойству будут показаны ТОЛЬКО те элементы,  которые имеют установленные значения этого дополнительного свойства. Для решения  указанной проблемы необходимо выполнить следующий запрос
      1.  INSERT INTO information_propertys_items_table( information_propertys_id, information_items_id, information_propertys_items_value )
        2.

      2.  SELECT 1111, information_items_table.information_items_id, 0
        3.

      3.  FROM information_items_table
        4.

      4.  LEFT JOIN information_propertys_items_table ON information_items_table.information_items_id = information_propertys_items_table.information_items_id
        5.

      5.  AND information_propertys_id = 1111
        6.

      6.  WHERE information_propertys_items_value IS NULL
        7.

      7.  AND information_groups_id = 2222 AND information_systems_id = 3333
        8.

      В этом примере:  1111 - идентификатор дополнительного свойства, по которому идет сортировка
      1. -  значение по умолчанию, дополнительного свойства, присваиваемое тем
       элементам, для которых не задано значение данного дополнительного свойства  2222 - идентификатор группы, к которой принадлежат элементы, для которых  необходимо задать значение по умолчанию.  Если необходимо задать несколько групп, то вместо information_groups_id = 2222  укажите "information_groups_id IN (идентификатор группы 1, идентификатор группы 2, ...)".  Если необходимо задать значение дополнительного свойства для всех элементов информационной системы, то  из запроса уберите "AND information_groups_id = 2222".  3333 - идентификатор информационной системы.
      Пример сортировки по значению дополнительного поля, имеющего строковый тип, по принципу сортировки целочисленных полей
      1.  <?php
        2.

      2.  $InformationSystem = & singleton('InformationSystem');
        3.

      3.
        4.

      4.  $external_propertys = array();
        5.

      5.  $external_propertys['ПоказыватьСсылкиНаДругиеСтраницы'] = 1;
        6.

      6.
        7.

      7.  $property=array();
        8.

      8.
        9.

      9.  // Идентификатор доп. свойства
        10.

      10.  $property_id = 144;
        11.

      11.
        12.

      12.  $element['type'] = 0;
        13.

      13.  $element['prefix'] = ' and ('; // префикс
        14.

      14.  $element['name'] = 'information_propertys_table.information_propertys_id';
        15.

      15.  $element['if'] = '='; // Условие
        16.

      16.  // Здесь указывается ID доп. св-ва, по которому производится сортировка
        17.

      17.  $element['value'] = $property_id; // ID дополнительного св-ва, по которому сортируем
        18.

      18.  $element['sufix'] = '  OR information_propertys_table.information_propertys_id IS NULL )';
        19.

      19.  $property['select'][] = $element;
        20.

      20.
        21.

      21.  // Фиктивное условие для подключения таблицы доп. свойств
        22.

      22.  $element['type'] = 1;
        23.

      23.  $element['prefix'] = 'or';
        24.

      24.  $element['property_id'] = 9999;
        25.

      25.  $element['if'] = '!=';
        26.

      26.  $element['value'] = '0';
        27.

      27.  $element['sufix'] = '';
        28.

      28.  $property['select'][] = $element;
        29.

      29.
        30.

      30.  // Указываем, что мы сортируем по значениям дополнительных полей, приведенных к числовому типу
        31.

      31.  $property['OrderField'] = ' convert( `information_propertys_items_value` , UNSIGNED ) ';
        32.

      32.  // Выводим элементы
        33.

      33.  $InformationSystem->ShowInformationSystem(1, 0, 'СписокНовостей', 10, 0, $external_propertys, $property);
        34.

      34.  ?>
        35.

      Пример фильтрации по значению дополнительного поля, имеющего строковый тип, как полей с плавающей точкой
      1.  <?php
        2.

      2.  $InformationSystem = & singleton('InformationSystem');
        3.

      3.  $external_propertys=array();
        4.

      4.  $external_propertys['ПоказыватьСсылкиНаДругиеСтраницы'] = 1;
        5.

      5.  $property=array();
        6.

      6.   $property_id = 144;
        7.

      7.  // Заполняем первое условие
        8.

      8.  $element['type'] = 1;
        9.

      9.  $element['property_id'] = $property_id;
        10.

      10.  $element['prefix'] = ' AND ';
        11.

      11.  $element['if'] = '!=';
        12.

      12.  // Указываем идентификатор информационной системы, для которой производится отбор элементов
        13.

      13.  $element['value'] = '';
        14.

      14.  // Указываем идентификатор дополнительного свойства, по значениям которого производиться отбор записей,
        15.

      15.  // а также верхняя и нижняя границы допустимых значений дополнительного свойства
        16.

      16.  $element['sufix'] = " AND information_propertys_table.information_propertys_id='7' and (REPLACE(information_propertys_items_table.information_propertys_items_value, ',', '.') + 0.0 ) >= 2.1 AND (REPLACE(information_propertys_items_table.information_propertys_items_value, ',', '.') + 0.0 ) <= 30.7 ";
        17.

      17.  $property['select'][] = $element;
        18.

      18.
        19.

      19.  // Указываем, что мы сортируем по значениям дополнительных полей, приведенных к числовому типу
        20.

      20.  $property['OrderField'] = ' convert(`information_propertys_items_value` , UNSIGNED) ';
        21.

      21.  // Выводим элементы
        22.

      22.  $InformationSystem->ShowInformationSystem(1, 0, 'СписокНовостей', 10, 0, $external_propertys, $property);
        23.

      23.  ?>
        24.

            *
      Пример фильтрации по значению дополнительного поля, имеющего тип "Дата"
      1.  <?php
        2.

      2.  $InformationSystem = & singleton('InformationSystem');
        3.

      3.  $external_propertys=array();
        4.

      4.  $external_propertys['ПоказыватьСсылкиНаДругиеСтраницы'] = 1;
        5.

      5.  $property=array();
        6.

      6.   $property_id = 144;
        7.

      7.  // Заполняем первое условие
        8.

      8.  $element['type'] = 1;
        9.

      9.  $element['property_id'] = $property_id;
        10.

      10.  $element['prefix'] = ' AND ';
        11.

      11.  $element['if'] = '!=';
        12.

      12.  $element['value'] = '';
        13.

      13.  $element['sufix'] = " AND CONVERT(CONCAT(SUBSTR(information_propertys_items_value, 7, 4), CHAR(45), SUBSTR(information_propertys_items_value, 4, 2), CHAR(45), SUBSTR(information_propertys_items_value, 1, 2)),  DATE) > CURDATE()";
        14.

      14.  $property['select'][] = $element;
        15.

      15.
        16.

      16.  // Выводим элементы
        17.

      17.  $InformationSystem->ShowInformationSystem(1, 0, 'СписокНовостей', 10, 0, $external_propertys, $property);
        18.

      18.  ?>
        19.

      $property['select_groups'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных групп
        • $element['type'] определяет, является ли поле основным свойством информационной группы или дополнительным (0 - основное, 1 - дополнительное)
        • $element['prefix'] префикс - строка, размещаемая перед условием
        • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
        • $element['property_id'] идентификатор дополнительногого свойства информационных групп
        • $element['if'] строка, содержащая условный оператор
        • $element['value'] значение поля (или параметра)
        • $element['sufix'] суффикс - строка, размещаемая после условия
      Пример использования:
      1.  <?php
        2.

      2.  $InformationSystem = & singleton('InformationSystem');
        3.

      3.
        4.

      4.  $property = array();
        5.

      5.  // Заполняем первое условие
        6.

      6.  $element['type'] = 0;
        7.

      7.  $element['prefix'] = ' and ';
        8.

      8.  $element['name'] = 'information_groups_order';
        9.

      9.  $element['if'] = '>';
        10.

      10.  $element['value'] = '10';
        11.

      11.  $element['sufix'] = '';
        12.

      12.  $property['select_groups'][] = $element;
        13.

      13.  // Заполняем второе условие, в данном случае по значению дополнительного св-ва
        14.

      14.  $element['type'] = 1;
        15.

      15.  $element['prefix'] = 'and';
        16.

      16.  $element['property_id'] = 7;
        17.

      17.  $element['if'] = '=';
        18.

      18.  $element['value'] = '10';
        19.

      19.  $element['sufix'] = '';
        20.

      20.  $property['select_groups'][] = $element;
        21.

      21.  // Выводим элементы
        22.

      22.  $InformationSystem->ShowInformationSystem(1, 0, 'СписокЭлементовИнфосистемы', 10, 0, array(), $property);
        23.

      23.  ?>
        24.

      Возвращает

      двумерный массив с идентификаторами показанных информационных элементов.

      [ Наверх ]

      InformationSystem::ShowInformationSystemItem

ShowInformationSystemItem(
int
$information_item_id, string
$xsl_name, [array
$external_propertys = array()], [array
$property = array()] );

      Описание

      Отображение информации об информационном элементе

      Принимаемые параметры

      $information_item_id

      идентификатор, отображаемого информационного элемента

      $xsl_name

      имя XSL-шаблона, применяемого для отображения информационного элемента

      $external_propertys

      массив дополнительных свойств, индексы массива - имена дополнительных XML-тегов, элементы массива - значения этих тегов

      $property

      массив дополнительных свойств
      • $property['part'] номер части документа, подлежащей отображению.
       Документ может быть разделен с помощью разделителя <!-- pagebreak -->.  Нумерация разделителя ведется с 1. Если передан 0 - разделение не производится. по умолчанию имеет значение 1.
      • $property['xml_show_group_property'] разрешает указание в XML значений свойст информационной группы, по умолчанию true
      • $property['xml_show_group_property_id'] массив идентификаторов дополнительных свойств для отображения в XML. Если не не передано - выводятся все свойства
      • $property['cache'] - разрешает кэширование, по умолчанию true
      • $property['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа
      • $property['show_item_type'] array массив ограничений для элемента. Может содержать следующие элементы:

      • active - активный (внесен по умолчанию, если $property['show_item_type'] не задан);
      • inactive - неактивный;
      • putend_date - не учитываем дату окончания публикации;
      • putoff_date - не учитываем дата начала публикации;

      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $information_item_id = 1;
        5.

      5.  $xsl_name = 'ВыводЕдиницыИнформационнойСистемы';
        6.

      6.
        7.

      7.  $InformationSystem->ShowInformationSystemItem($information_item_id, $xsl_name);
        8.

      8.
        9.

      9.  ?>
        10.

      Возвращает

      true

      [ Наверх ]

      InformationSystem::ShowInformationSystemPageConfig

ShowInformationSystemPageConfig(
int
$InformationSystem_id, int
$items_on_page, [array
$property = array()], array
3 );

      Описание

      Вызов настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы

      Принимаемые параметры

      $InformationSystem_id

      идентификатор информационной системы

      $items_on_page

      количество элементов на страницу

      $property

      массив дополнительных параметров
        $property['page'] текстовая информация для указания номера страницы, например "страница"  $property['separator'] разделитель, по умолчанию ' /'
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $InformationSystem_id = 1;
        5.

      5.  $items_on_page = 5;
        6.

      6.
        7.

      7.  $row = $InformationSystem->ShowInformationSystemPageConfig($InformationSystem_id, $items_on_page);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r ($row);
        11.

      11.  ?>
        12.

      3

      массив с настройками информационной системы

      [ Наверх ]

      InformationSystem::ShowInformationSystemPageContent

ShowInformationSystemPageContent(
int
$InformationSystem_id, string
$xsl_list, string
$xsl_item, [array
$property = array()], [array
$external_propertys = array()], [array
$infsys_property = array()] );

      Описание

      Вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы

      Принимаемые параметры

      $InformationSystem_id

      $xsl_list

      XSL шаблон для вывода спсика инфорамционных элементов

      $xsl_item

      XSL шаблон для вывода одного элемента

      $property

      массив дополнительных параметров
        $property['items_on_page'] число элементов на страницу, по умолчанию 10  $property['items_begin'] элемент, с которого начинать вывод, по умолчанию 0

      $external_propertys

      внешние параметры, передаваемые в XML

      $infsys_property

      дополнительные свойства для показа информационной системы, см. ShowInformationSystem
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $InformationSystem_id = 3;
        5.

      5.  $xsl_list = 'СписокЭлементовИнфосистемы';
        6.

      6.  $xsl_item = 'ВыводЕдиницыИнформационнойСистемы';
        7.

      7.
        8.

      8.  $InformationSystem->ShowInformationSystemPageContent($InformationSystem_id, $xsl_list, $xsl_item);
        9.

      9.  ?>
        10.

      [ Наверх ]

      InformationSystem::ShowInformationSystemRss

ShowInformationSystemRss(
int
$InformationSystem_id, mixed
$information_groups_id, [int
$items_on_page = 10], [int
$items_begin = 0], [array
$property = array()] );

      Описание

      Отображение RSS ленты

      Принимаемые параметры

      $InformationSystem_id

      идентификатор информационной системы

      $information_groups_id

      идентификатор информационной группы, если все группы – то false

      $items_on_page

      количество выводимых записей в ленте

      $items_begin

      параметр, определяющий с какой записи начинать вывод

      $property

      массив дополнительных параметров
      • $property['title'] string Заголовок канала
      • $property['description'] string Краткое описание RSS-канала
      • $property['link'] string Ссылка на сайт
      • $property['image'] Картинка для представления канала (необязательный элемент)
      • $property['image']['url'] string Ссылка на файл изображения
      • $property['image']['title'] string Заменяющий текст для изображения
      • $property['image']['link'] string Ссылка для перехода при щелчке по изображению
      • $property['yandex:full-text'] bool Вывод полного текста для Яндекс, по умолчанию false
      • $property['strip-tags'] bool Указывает на необходимость удаления тегов из содержания RSS, по умолчанию false
      • $property['show-image'] bool Разрешает передачу картинки для информационного элемента в теге enclosure

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $InformationSystem_id = 2;
          5.

        5.  $information_groups_id = 1;
          6.

        6.  $property['title'] = '';
          7.

        7.  $property['description'] = '';
          8.

        8.  $property['link'] = '';
          9.

        9.  $items_on_page=5;
          10.

        10.  $items_begin=1;
          11.

        11.
          12.

        12.  $InformationSystem->ShowInformationSystemRss($InformationSystem_id, $information_groups_id, $items_on_page, $items_begin);
          13.

        13.  ?>
          14.

      [ Наверх ]

      InformationSystem::ShowTagsCloud

ShowTagsCloud(
int
$InformationSystemId, str
$xsl_name, [array
$property = array()], [array
$external_propertys = array()] );

      Описание

      Показ облака тегов для информационной системы

      Принимаемые параметры

      $InformationSystemId

      Идентификатор информационной системы

      $xsl_name

      имя XSL-шаблона

      $property

      массив дополнительных атрибутов
      • $property['begin'] начальная позиция отображения тегов (по умолчанию 0)
      • $property['count'] количество отображаемых тегов
      • $property['mas_groups_id'] массив идентификаторов информационных групп, используемые для получения списка тегов элементов, входящих в группы
      • $property['TagsOrder'] параметр, определяющий порядок сортировки тегов. Принимаемые значения: ASC - по возрастанию (по умолчанию), DESC - по убыванию
      • $property['TagsOrderField'] поле сортировки тегов, если случайная сортировка, то записать RAND(). по умолчанию теги сортируются по названию.
      • $property['tags_group_id'] идентификатор или массив идентификаторов групп тегов, из которых необходимо вести отбор тегов

      $external_propertys

      массив дополнительных свойств для включения в XML
      1.  <?php
        2.

      2.  $InformationSystem = new InformationSystem();
        3.

      3.
        4.

      4.  $InformationSystemId= 1;
        5.

      5.  $xsl_name = 'ОблакотеговИнформационнойСистемы';
        6.

      6.
        7.

      7.  $InformationSystem->ShowTagsCloud($InformationSystemId, $xsl_name);
        8.

      8.  ?>
        9.

      [ Наверх ]

      InformationSystem::UserCanAddComment

UserCanAddComment(
string
$date,
$ip, [array
$param = array()], string
$comment_ip );

      Описание

      Определение возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY

      Принимаемые параметры

      $date

      дата и время (в Unix-формате) добавления комментария

      $comment_ip

      ip-адрес компьютера пользователя, добавляющего комментарий

      $param

      массив параметров
      • $param['information_system_id'] идентификатор информационной системы

        1.  <?php
          2.

        2.  $InformationSystem = new InformationSystem();
          3.

        3.
          4.

        4.  $date = time();
          5.

        5.  $ip = '192.169.0.4';
          6.

        6.
          7.

        7.  $result = $InformationSystem->UserCanAddComment($date, $ip);
          8.

        8.
          9.

        9.  // Распечатаем результат
          10.

        10.  if ($result)
          11.

        11.  {
          12.

        12.      echo 'Пользователь может добавить комментарий';
          13.

        13.  }
          14.

        14.  else
          15.

        15.  {
          16.

        16.      echo 'Пользователь не может добавить комментарий';
          17.

        17.  }
          18.

        18.  ?>
          19.

      $ip

      Возвращает

      true - пользователь может отправлять комментарий, false - не может отправлять комментарий

      [ Наверх ]

      InformationSystem::_CallbackSearch

_CallbackSearch(
array
$row );

      Описание

      Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

      Принимаемые параметры

      $row

      массив с информацией о странице

      Возвращает

      дополнительный XML, включаемый в результат поиска

      [ Наверх ]

    Описания переменных

    • $CommentMass = array() [Строка 107]
      •

    • Data type: array
      •

      Описание

      Кэш с данными о комментариях

    • $ItemMass = array() [Строка 100]
      •

    • Data type: array
      •

      Описание

      Кэш с данными об элементах

    • $MasGroup = array() [Строка 137]
      •

    • Data type: array
      •

      Описание

      Массив групп

    • $PathArrayGetInformationFromPath = array() [Строка 251]
      •

    • Data type: array
      •

      Описание

      Массив имен узлов, для которых необходимо в результирующем массиве метода GetInformationFromPath() указать наличие этих узлов.

      Наиболее часто используется при работе с блогами для передачи имен таких узлов, как:  community, sns, my_community, my_sns и т.д.  Если имя узла совпадает с элементом переданного массива, в резльтирующем массиве, возвращаемом методом GetInformationFromPath(), будет индекс с именем этого узла и значением true

    • $PropertyGroupMass = array() [Строка 121]
      •

    • Data type: array
      •

      Описание

      Кэш с данными о дополнительных свойствах информационных групп

    • $PropertyMass = array() [Строка 114]
      •

    • Data type: array
      •

      Описание

      Кэш с данными о свойствах инфоррмационных элементов

    Описание констант класса

    Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class ip

Class ip

[Строка 14]

Размещен: /ip/ip.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "IP-адреса".
Файл: /modules/ip/ip.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • resource DelIp()

    Удаление информации об IP-адресе

  • mixed GetIp()

    Получение информации об IP-адресе

  • mixed GetIpInfo()

    Получение информации о запретах для переданного ip-адреса

  • int InsertIp()

    Вставка/обновление информации об IP-адресе

  • resource SelectIp()

    Получение информации об IP-адресах

Унаследованные методы

Описания методов

    ip::DelIp

DelIp(
int
$ip_id );

    Описание

    Удаление информации об IP-адресе

    Принимаемые параметры

    $ip_id

    идентификатор IP-адреса
    1.  <?php
      2.

    2.  $ip = new ip();
      3.

    3.
      4.

    4.  $ip_id = 9;
      5.

    5.
      6.

    6.  $resource = $ip->DelIp($ip_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($resource)
      10.

    10.  {
      11.

    11.      echo 'IP-адрес удален';
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo 'Ошибка! IP-адрес не удален';
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    ip::GetIp

GetIp(
int
$ip_id );

    Описание

    Получение информации об IP-адресе

    Принимаемые параметры

    $ip_id

    идентификатор IP-адреса
    1.  <?php
      2.

    2.  $ip = new ip();
      3.

    3.
      4.

    4.  $ip_id = 1;
      5.

    5.
      6.

    6.  $resource = $ip->GetIp($ip_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($resource);
      10.

    10.  ?>
      11.

    Возвращает

    массив с данными об IP-адресе или false

    [ Наверх ]

    ip::GetIpInfo

GetIpInfo(
string
$ip_ip, [array
$param = array()] );

    Описание

    Получение информации о запретах для переданного ip-адреса

    Принимаемые параметры

    $ip_ip

    IP-адрес

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $ip = new ip();
        3.

      3.
        4.

      4.  $ip_ip = '192.168.0.1';
        5.

      5.
        6.

      6.  $row = $ip->GetIpInfo($ip_ip);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    массив с информацией о запретах для IP-адреса, или false, если запретов нет

    [ Наверх ]

    ip::InsertIp

InsertIp(
array
$fields );

    Описание

    Вставка/обновление информации об IP-адресе

    Принимаемые параметры

    $fields

    массив парметров
    int $fields['ip_id'] - идентификатор обновляемой записи
    str $fields['ip_ip'] - IP-адрес
    int $fields['ip_deny_access'] - запретить доступ к сайту, по умолчанию 1
    int $fields['ip_no_statistic'] - не учитывать в статистике, по умолчанию 1
    str $fields['ip_comment'] - комментарий
    1.  <?php
      2.

    2.  $ip = new ip();
      3.

    3.
      4.

    4.  $fields['ip_id'] = '';
      5.

    5.  $fields['ip_ip'] = '192.168.0.1';
      6.

    6.
      7.

    7.  $newip = $ip->InsertIp($fields);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $newip;
      11.

    11.  ?>
      12.

    Возвращает

    идентификатор вставленной/обновленной записи

    [ Наверх ]

    ip::SelectIp

SelectIp(
int
$ip_id );

    Описание

    Получение информации об IP-адресах

    Принимаемые параметры

    $ip_id

    идентификатор IP-адреса, о котором необходимо получить информацию, если false, то получаем информацию обо всех IP-адресах
    1.  <?php
      2.

    2.  $ip = new ip();
      3.

    3.
      4.

    4.  $ip_id = 1;
      5.

    5.
      6.

    6.  $resource = $ip->SelectIp($ip_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  $row = mysql_fetch_assoc($resource);
      10.

    10.
      11.

    11.  print_r($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class JsHttpRequest

Class JsHttpRequest

[Строка 21]

Размещен: /Kernel/ajax/JsHttpRequest.php

Описание

JsHttpRequest: PHP backend for JavaScript DHTML loader.

(C) Dmitry Koterov, http://en.dklab.ru
This library is free software; you can redistribute it and/or  modify it under the terms of the GNU Lesser General Public  License as published by the Free Software Foundation; either  version 2.1 of the License, or (at your option) any later version.  See http://www.gnu.org/copyleft/lesser.html
Do not remove this comment if you want to use the script!  Не удаляйте данный комментарий, если вы хотите использовать скрипт!
This backend library also supports POST requests additionally to GET.

author

Dmitry Koterov

version

5.x $Id$

Свойства класса

  • $ID =  null

  • $LOADER =  null

  • $SCRIPT_DECODE_MODE =  ''

  • $SCRIPT_ENCODING =  "UTF-8"

  • $_contentTypes = array(

   "script" => "text/javascript",

   "xml"    => "text/plain", // In XMLHttpRequest mode we must return text/plain - stupid Opera 8.0. :(

   "form"   => "text/html",

   ""       => "text/plain", // for unknown loader

   )

  • $_emergBuffer =  null

  • $_encTables = array(

   'windows-1251' => array(

   0x0402, 0x0403, 0x201A, 0x0453, 0x201E, 0x2026, 0x2020, 0x2021,

   0x20AC, 0x2030, 0x0409, 0x2039, 0x040A, 0x040C, 0x040B, 0x040F,

   0x0452, 0x2018, 0x2019, 0x201C, 0x201D, 0x2022, 0x2013, 0x2014,

   0x0098, 0x2122, 0x0459, 0x203A, 0x045A, 0x045C, 0x045B, 0x045F,

   0x00A0, 0x040E, 0x045E, 0x0408, 0x00A4, 0x0490, 0x00A6, 0x00A7,

   0x0401, 0x00A9, 0x0404, 0x00AB, 0x00AC, 0x00AD, 0x00AE, 0x0407,

   0x00B0, 0x00B1, 0x0406, 0x0456, 0x0491, 0x00B5, 0x00B6, 0x00B7,

   0x0451, 0x2116, 0x0454, 0x00BB, 0x0458, 0x0405, 0x0455, 0x0457,

   0x0410, 0x0411, 0x0412, 0x0413, 0x0414, 0x0415, 0x0416, 0x0417,

   0x0418, 0x0419, 0x041A, 0x041B, 0x041C, 0x041D, 0x041E, 0x041F,

   0x0420, 0x0421, 0x0422, 0x0423, 0x0424, 0x0425, 0x0426, 0x0427,

   0x0428, 0x0429, 0x042A, 0x042B, 0x042C, 0x042D, 0x042E, 0x042F,

   0x0430, 0x0431, 0x0432, 0x0433, 0x0434, 0x0435, 0x0436, 0x0437,

   0x0438, 0x0439, 0x043A, 0x043B, 0x043C, 0x043D, 0x043E, 0x043F,

   0x0440, 0x0441, 0x0442, 0x0443, 0x0444, 0x0445, 0x0446, 0x0447,

   0x0448, 0x0449, 0x044A, 0x044B, 0x044C, 0x044D, 0x044E, 0x044F,

   ),'koi8-r'=>array(0x2500,0x2502,0x250C,0x2510,0x2514,0x2518,0x251C,0x2524,0x252C,0x2534,0x253C,0x2580,0x2584,0x2588,0x258C,0x2590,0x2591,0x2592,0x2593,0x2320,0x25A0,0x2219,0x221A,0x2248,0x2264,0x2265,0x00A0,0x2321,0x00B0,0x00B2,0x00B7,0x00F7,0x2550,0x2551,0x2552,0x0451,0x2553,0x2554,0x2555,0x2556,0x2557,0x2558,0x2559,0x255A,0x255B,0x255C,0x255d,0x255E,0x255F,0x2560,0x2561,0x0401,0x2562,0x2563,0x2564,0x2565,0x2566,0x2567,0x2568,0x2569,0x256A,0x256B,0x256C,0x00A9,0x044E,0x0430,0x0431,0x0446,0x0434,0x0435,0x0444,0x0433,0x0445,0x0438,0x0439,0x043A,0x043B,0x043C,0x043d,0x043E,0x043F,0x044F,0x0440,0x0441,0x0442,0x0443,0x0436,0x0432,0x044C,0x044B,0x0437,0x0448,0x044d,0x0449,0x0447,0x044A,0x042E,0x0410,0x0411,0x0426,0x0414,0x0415,0x0424,0x0413,0x0425,0x0418,0x0419,0x041A,0x041B,0x041C,0x041d,0x041E,0x041F,0x042F,0x0420,0x0421,0x0422,0x0423,0x0416,0x0412,0x042C,0x042B,0x0417,0x0428,0x042d,0x0429,0x0427,0x042A),)

        UCS-2BE -> 1-byte encodings (from #128).

  • $_magic =  14623

  • $_nonAsciiChars =  ''

  • $_prevDisplayErrors =  null

  • $_toUtfFailed =  false

  • $_unicodeConvMethod =  null

  • $_uniqHash =

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • JsHttpRequest JsHttpRequest()

    Constructor.

  • void getJsCode()

    string getJsCode()

  • boolean isActive()

    Static function.

  • string php2js()

    Convert a PHP scalar, array or hash to JS scalar/array/hash. This function is  an analog of json_encode(), but it can work with a non-UTF8 input and does not  analyze the passed data. Output format must be fully JSON compatible.

  • void quoteInput()

    string quoteInput(string $input)

  • void setEncoding()

    void setEncoding(string $encoding)

  • void _correctSuperglobals()

    Parse & decode QUERY_STRING.

  • void _decUcs2Decode()

    Convert FROM UCS-2BE decimal to $toEnc.

  • void _obHandler()

    Called in case of error too!

  • void _toUtf8_callback()

    Internal function, used in array_walk_recursive() before json_encode() call.

  • void _ucs2EntitiesDecode()

    Decode all %uXXXX entities in string or array (recurrent).

  • void _ucs2EntitiesDecodeCallback()

    Decode one %uXXXX entity (RE callback).

  • void _unicodeConv()

    Wrapper for iconv() or mb_convert_encoding() functions.

Унаследованные методы

Описания методов

    JsHttpRequest::JsHttpRequest

JsHttpRequest(

$enc );

    Описание

    Constructor.

    Create new JsHttpRequest backend object and attach it  to script output buffer. As a result - script will always return  correct JavaScript code, even in case of fatal errors.
    QUERY_STRING is in form of: PHPSESSID=<sid>&a=aaa&b=bbb&JsHttpRequest=<id>-<loader>  WHERE <id> is a request ID, <loader> is a loader name, <sid> - a session ID (if present),  PHPSESSID - session parameter name (by default = "PHPSESSID").
    If an object is created WITHOUT an active AJAX query, it is simply marked as  non-active. Use statuc method isActive() to check.

    Принимаемые параметры

    $enc

    [ Наверх ]

    JsHttpRequest::getJsCode

getJsCode(
 );

    Описание

    string getJsCode()

    Return JavaScript part of the library.

    [ Наверх ]

    JsHttpRequest::isActive

isActive(
 );

    Описание

    Static function.

    Returns true if JsHttpRequest output processor is currently active.

    Возвращает

    True if the library is active, false otherwise.

    [ Наверх ]

    JsHttpRequest::php2js

php2js(
[mixed
$a = false] );

    Описание

    Convert a PHP scalar, array or hash to JS scalar/array/hash. This function is  an analog of json_encode(), but it can work with a non-UTF8 input and does not  analyze the passed data. Output format must be fully JSON compatible.

    Принимаемые параметры

    $a

    Any structure to convert to JS.

    Возвращает

    JavaScript equivalent structure.

    [ Наверх ]

    JsHttpRequest::quoteInput

quoteInput(

$s );

    Описание

    string quoteInput(string $input)

    Quote a string according to the input decoding mode.  If entities are used (see setEncoding()), no '&' character is quoted,  only '"', '>' and '<' (we presume that '&' is already quoted by  an input reader function).
    Use this function INSTEAD of htmlspecialchars() for $_GET data  in your scripts.

    Принимаемые параметры

    $s

    [ Наверх ]

    JsHttpRequest::setEncoding

setEncoding(

$enc );

    Описание

    void setEncoding(string $encoding)

    Set an active script encoding & correct QUERY_STRING according to it.  Examples:    "windows-1251"          - set plain encoding (non-windows characters,                              e.g. hieroglyphs, are totally ignored)    "windows-1251 entities" - set windows encoding, BUT additionally replace:                              "&"         ->  "&amp;"                              hieroglyph  ->  &#XXXX; entity

    Принимаемые параметры

    $enc

    [ Наверх ]

    JsHttpRequest::_correctSuperglobals

_correctSuperglobals(
 );

    Описание

    Parse & decode QUERY_STRING.

    [ Наверх ]

    JsHttpRequest::_decUcs2Decode

_decUcs2Decode(

$code,
$toEnc );

    Описание

    Convert FROM UCS-2BE decimal to $toEnc.

    Принимаемые параметры

    $code

    $toEnc

    [ Наверх ]

    JsHttpRequest::_obHandler

_obHandler(

$text );

    Описание

    Called in case of error too!

    Принимаемые параметры

    $text

    [ Наверх ]

    JsHttpRequest::_toUtf8_callback

_toUtf8_callback(

&$v,
$k,
$fromEnc );

    Описание

    Internal function, used in array_walk_recursive() before json_encode() call.

    If a key contains non-ASCII characters, this function sets $this->_toUtfFailed = true,  becaues array_walk_recursive() cannot modify array keys.

    Принимаемые параметры

    &$v

    $k

    $fromEnc

    [ Наверх ]

    JsHttpRequest::_ucs2EntitiesDecode

_ucs2EntitiesDecode(

$data );

    Описание

    Decode all %uXXXX entities in string or array (recurrent).

    String must not contain %XX entities - they are ignored!

    Принимаемые параметры

    $data

    [ Наверх ]

    JsHttpRequest::_ucs2EntitiesDecodeCallback

_ucs2EntitiesDecodeCallback(

$p );

    Описание

    Decode one %uXXXX entity (RE callback).

    Принимаемые параметры

    $p

    [ Наверх ]

    JsHttpRequest::_unicodeConv

_unicodeConv(

$fromEnc,
$toEnc,
$v );

    Описание

    Wrapper for iconv() or mb_convert_encoding() functions.

    This function will generate fatal error if none of these functons available!

    Принимаемые параметры

    $fromEnc

    $toEnc

    $v

    see

    iconv()

    [ Наверх ]

Описания переменных

  • $ID =  null [Строка 26]
    •

  • Data type: mixed
    •

  • $LOADER =  null [Строка 25]
    •

  • Data type: mixed
    •

  • $SCRIPT_DECODE_MODE =  '' [Строка 24]
    •

  • Data type: mixed
    •

  • $SCRIPT_ENCODING =  "UTF-8" [Строка 23]
    •

  • Data type: mixed
    •

  • $_contentTypes = array(

   "script" => "text/javascript",

   "xml"    => "text/plain", // In XMLHttpRequest mode we must return text/plain - stupid Opera 8.0. :(

   "form"   => "text/html",

   ""       => "text/plain", // for unknown loader

   )     [Строка 35]
    •

  • Data type: mixed
    •

  • $_emergBuffer =  null [Строка 48]
    •

  • Data type: mixed
    •

  • $_encTables = array(

   'windows-1251' => array(

   0x0402, 0x0403, 0x201A, 0x0453, 0x201E, 0x2026, 0x2020, 0x2021,

   0x20AC, 0x2030, 0x0409, 0x2039, 0x040A, 0x040C, 0x040B, 0x040F,

   0x0452, 0x2018, 0x2019, 0x201C, 0x201D, 0x2022, 0x2013, 0x2014,

   0x0098, 0x2122, 0x0459, 0x203A, 0x045A, 0x045C, 0x045B, 0x045F,

   0x00A0, 0x040E, 0x045E, 0x0408, 0x00A4, 0x0490, 0x00A6, 0x00A7,

   0x0401, 0x00A9, 0x0404, 0x00AB, 0x00AC, 0x00AD, 0x00AE, 0x0407,

   0x00B0, 0x00B1, 0x0406, 0x0456, 0x0491, 0x00B5, 0x00B6, 0x00B7,

   0x0451, 0x2116, 0x0454, 0x00BB, 0x0458, 0x0405, 0x0455, 0x0457,

   0x0410, 0x0411, 0x0412, 0x0413, 0x0414, 0x0415, 0x0416, 0x0417,

   0x0418, 0x0419, 0x041A, 0x041B, 0x041C, 0x041D, 0x041E, 0x041F,

   0x0420, 0x0421, 0x0422, 0x0423, 0x0424, 0x0425, 0x0426, 0x0427,

   0x0428, 0x0429, 0x042A, 0x042B, 0x042C, 0x042D, 0x042E, 0x042F,

   0x0430, 0x0431, 0x0432, 0x0433, 0x0434, 0x0435, 0x0436, 0x0437,

   0x0438, 0x0439, 0x043A, 0x043B, 0x043C, 0x043D, 0x043E, 0x043F,

   0x0440, 0x0441, 0x0442, 0x0443, 0x0444, 0x0445, 0x0446, 0x0447,

   0x0448, 0x0449, 0x044A, 0x044B, 0x044C, 0x044D, 0x044E, 0x044F,

   ),'koi8-r'=>array(0x2500,0x2502,0x250C,0x2510,0x2514,0x2518,0x251C,0x2524,0x252C,0x2534,0x253C,0x2580,0x2584,0x2588,0x258C,0x2590,0x2591,0x2592,0x2593,0x2320,0x25A0,0x2219,0x221A,0x2248,0x2264,0x2265,0x00A0,0x2321,0x00B0,0x00B2,0x00B7,0x00F7,0x2550,0x2551,0x2552,0x0451,0x2553,0x2554,0x2555,0x2556,0x2557,0x2558,0x2559,0x255A,0x255B,0x255C,0x255d,0x255E,0x255F,0x2560,0x2561,0x0401,0x2562,0x2563,0x2564,0x2565,0x2566,0x2567,0x2568,0x2569,0x256A,0x256B,0x256C,0x00A9,0x044E,0x0430,0x0431,0x0446,0x0434,0x0435,0x0444,0x0433,0x0445,0x0438,0x0439,0x043A,0x043B,0x043C,0x043d,0x043E,0x043F,0x044F,0x0440,0x0441,0x0442,0x0443,0x0436,0x0432,0x044C,0x044B,0x0437,0x0448,0x044d,0x0449,0x0447,0x044A,0x042E,0x0410,0x0411,0x0426,0x0414,0x0415,0x0424,0x0413,0x0425,0x0418,0x0419,0x041A,0x041B,0x041C,0x041d,0x041E,0x041F,0x042F,0x0420,0x0421,0x0422,0x0423,0x0416,0x0412,0x042C,0x042B,0x0417,0x0428,0x042d,0x0429,0x0427,0x042A),)     [Строка 473]
    •

  • Data type: mixed
    •

    Описание

    UCS-2BE -> 1-byte encodings (from #128).

  • $_magic =  14623 [Строка 31]
    •

  • Data type: mixed
    •

  • $_nonAsciiChars =  '' [Строка 44]
    •

  • Data type: mixed
    •

  • $_prevDisplayErrors =  null [Строка 33]
    •

  • Data type: mixed
    •

  • $_toUtfFailed =  false [Строка 42]
    •

  • Data type: mixed
    •

  • $_unicodeConvMethod =  null [Строка 46]
    •

  • Data type: mixed
    •

  • $_uniqHash =  [Строка 29]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class kernel

Class kernel

[Строка 15]

Размещен: /Kernel/Kernel.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс ядра системы управления сайтом HostCMS.
Файл: /modules/Kernel/Kernel.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $aJs = array()

  • $available_extantions = array ('JPG','JPEG','GIF','PNG')

        Доступные для загрузки расширения файлов

  • $CURLOPT_HTTPPROXYTUNNEL =  false

        При установке этого параметра в true данные будут передаваться через прокси-сервер

  • $CURLOPT_PROXY =  false

        HTTP-прокси

  • $CURLOPT_PROXYAUTH =  false

        Метод HTTP-авторизации для использования при соединении с прокси.

  • $CURLOPT_PROXYPORT =  false

        Номер порта для соединения с прокси-сервером; используется совместно с CURLOPT_PROXY

  • $CURLOPT_PROXYTYPE =  false

        CURLPROXY_HTTP по умолчанию или CURLPROXY_SOCKS5

  • $CURLOPT_PROXYUSERPWD =  false

        Имя пользователя и пароль в формате "[username]:[password]" для использования при соединении с прокси

  • $icon_array = array (

   'sql' => 'sql.gif',

   'txt' => 'txt.gif',

   'htaccess' => 'config.gif',

   'css' => 'css.gif',

   'php' => 'php.gif',

   'php3' => 'php.gif',

   'jpg' => 'jpg.gif',

   'jpeg' => 'jpg.gif',

   'gif' => 'gif.gif',

   'bmp' => 'bmp.gif',

   'png' => 'png.gif',

   'ico' => 'image.gif', //

   'htm' => 'html.gif',

   'html' => 'html.gif',

   'xml' => 'xml.gif', //

   'xsl' => 'xsl.gif',

   'zip' => 'zip.gif',

   'gz' => 'zip.gif',

   '7z' => 'zip.gif',

   'rar' => 'rar.gif',

   'pdf' => 'pdf.gif',

   'doc' => 'doc.gif',

   'docx' => 'doc.gif',

   'cdr' => 'vector.gif',

   'ai' => 'vector.gif',

   'eps' => 'vector.gif',

   'rb' => 'rb.gif',

   'ppt' => 'ppt.gif',

   'pptx' => 'ppt.gif',

   'pptm' => 'ppt.gif',

   'mdb' => 'mdb.gif',

   'h' => 'h.gif',

   'fh1' => 'fh1.gif',

   'fh2' => 'fh2.gif',

   'fh3' => 'fh3.gif',

   'fh4' => 'fh4.gif',

   'fh5' => 'fh5.gif',

   'fh6' => 'fh6.gif',

   'fh7' => 'fh7.gif',

   'fh8' => 'fh8.gif',

   'fh9' => 'fh9.gif',

   'fla' => 'flash.gif',

   'swf' => 'flash.gif',

   'xls' => 'xls.gif',

   'cpp' => 'cpp.gif',

   'chm' => 'chm.gif'

   )

        Массив ассоциаций расширений и пиктограмм

  • $modules = array ()

        Информация о загруженных модулях системы

  • $resize_extension = array ('JPG','JPEG','GIF','PNG')

        Рашсирения графических файлов, доступные для уменьшения

  • $ShowXmlContent =  ''

  • $sModulesPath =  null

  • $useSmtp =  NULL

        Данные внешнего SMTP-сервера для отправки писем

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • kernel kernel()

  • bool AddInclude()

    Метод подключает файл по указанному адресу

  • void AddJs()

    Добавление внешнего JavaScript файла для подключения в центре администрирования

  • void AddModule()

    Метод подключения модуля

  • boolean AddModuleFile()

    Осуществляет добавление файла модуля в список файлов модулей для загрузки.

  • void AddXmlContent()

    Дописывает $xml к $this->ShowXmlContent

  • void add_modules_version()

    Метод добавления модуля в массив-список модулей

  • array AdminLoadFiles()

    Метод загрузки файлов в центре администрирования

  • bool AllowShowPanel()

    Определяет возможность отображения панели пользователю.

  • string code_ip()

    Метод для преобразования IP в HEX

  • int crc32()

    Вычисление crc32 в диапазоне от -2147483647 до 2147483647.

  • string declension()

    Получение существительного в форме, соответствующей числу

  • string decode_ip()

    Метод для декодирования IP из HEX

  • boolean function_enabled()

    Определение доступности php-функции

  • array GetAllJs()

    Получения списка внешних JavaScript файлов

  • void GetBit()

    Получить бит номер $bit_number числа $int

  • array GetColor()

    Создание цвета для некоторого идентификатора.

  • str GetCurrentLng()

    Получения текущего языка центра администрирования

  • int GetCurrentUser()

    Метод определения идентификатора текущего авторизированного пользователя раздела администрирования

  • int GetCurrentYear()

    Получение значения текущего года

  • string GetDBVersion()

    Метод определения версии MySQL

  • mixed GetDirPath()

    Получение пути к директории, используемой для решения проблемы с ограничением  количества поддиректорий в директории.

  • int GetExpires()

    Получение времени истечения актуальности страницы

  • string GetExtension()

    Метод возвращает расширение файла

  • string GetGDVersion()

    Метод определения версии GD библиотеки

  • int GetLastModified()

    Получение времени последнего изменения страницы

  • int getmicrotime()

    Получение значения времени

  • string GetMimeType()

    Метод определения MIME-типа файла

  • mixed GetTableFields()

    Получение структуры таблицы БД

  • mixed GetTableFieldSize()

    Получение размера в символах (не занимаемые байты) поля таблицы.

  • int GetTemplate()

    Получение текущего макета

  • int getTimestamp()

    Получение временной метки файла CSS-стиля для страницы

  • string GetUrl()

    Запрос URL

  • array GetUrlWithHeader()

    Запрос URL с возвращением заголовка и данных

  • int GetVersionTimestamp()

    Получения временной метки по текущей версии системы управления

  • string GetXmlContent()

    Возвращает $this->ShowXmlContent

  • string get_CSS()

    Получение CSS стиля для страницы

  • mixed get_current_page()

    Получение идентификатора текущего узла структуры

  • string get_current_page_path()

    Получение пути текущей страницы

  • string get_description()

    Получение описания страницы

  • string get_keywords()

    Получение ключевых слов страницы

  • int get_page_id()

    Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя

  • string get_title()

    Получение заголовка страницы

  • string Guid()

    Возвращает уникальный идентификатор GUID

  • string implode_array()

    Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно

  • boolean InitConstants()

    Метод инициализации констант сайта в соответствии с константой CURRENT_SITE

  • void LoadModuleFiles()

    Служебный метод

  • void LoadModules()

    Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS

  • void LoadModulesLngFile()

    Метод загрузки языкового файла для модуля

  • array my_array_multisort()

    Сортировка многомерного массива $array по полю $filed_name

  • числовое numeric_character_references()

    Метод преобразует сущности в их числовое представление, например &amp;nbsp; в &#160;

  • boolean PathMkdir()

    Создание директорий относительно корневой директории сайта

  • int phpversion()

    Метод возвращает номер версии PHP

  • array random_shuffle()

    Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.

  • string ReductionDescription()

    Укорачивает описание до определённого количества символов, оставляя целое число предлодений

  • void ResetBit()

    Установить бит числа в 0

  • bool SendMailWithFile()

    Метод отправки электронного письма с прикрепленным файлом

  • void serverParse()

  • void SetBit()

    Установить бит числа

  • void SetExpires()

    Метод установления времени истечения актуальности страницы

  • void SetLastModified()

    Метод установления времени последнего изменения страницы

  • void SetTemplate()

    Метод установления текущего макета

  • void setTimestamp()

    Изменение временной метки файла CSS-стиля для страницы

  • void set_CSS()

    Метод изменения адреса файла CSS-стиля для страницы

  • void set_current_page()

    Метод изменения адреса страницы

  • void set_current_page_data_template()

    Метод изменения шаблона страницы

  • void set_description()

    Метод изменения описания страницы

  • void set_keywords()

    Метод изменения ключевых слов страницы

  • void set_title()

    Метод изменения заголовока страницы

  • сгенерированный ShowFlyPanel()

    Формирование панели редактирования элементов ЦА в клиентской части

  • void show_CSS()

    Метод вывода CSS стиля для страницы

  • void show_current_page()

    Метод вывода установленной страницы

  • void show_current_template()

    Метод вывода текущего макета.

  • void show_description()

    Метод вывода описания страницы

  • void show_keywords()

    Метод вывода ключевых слов страницы

  • void show_title()

    Метод вывода заголовка страницы

  • void smtpMail()

  • void strips()

    Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag

  • boolean UseHttps()

    Используется ли HTTPS-доступ

  • string Utf8ToWindows1251()

    Преобразует текст из UTF-8 в Windows1251. В своей работе использует  iconv() при его наличии или kernel::utf8_win1251()

  • string utf8_win1251()

    Перевод из UTF-8 в Windows-1251, используется при отсутствии iconv()

  • string win1251_utf8()

    Перевод из Windows-1251 в UTF-8, используется при отсутствии iconv()

  • string Windows1251ToUtf8()

    Преобразует текст из Windows1251 в UTF-8. В своей работе использует  iconv() при его наличии или kernel::win1251_utf8()

  • void Xml2Array()

  • array Xml2Array2()

    Преобразование XML в массив

  • void _xml2Array()

Унаследованные методы

Описания методов

    kernel::kernel

kernel(
 );

    [ Наверх ]

    kernel::AddInclude

AddInclude(
string
$file );

    Описание

    Метод подключает файл по указанному адресу

    Принимаемые параметры

    $file

    адрес файла
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $file = 'file.txt';
      5.

    5.
      6.

    6.  $result = $kernel->AddInclude($file);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Подключение файла выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка подключения файла";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    kernel::AddJs

AddJs(
$path
$path );

    Описание

    Добавление внешнего JavaScript файла для подключения в центре администрирования

    Принимаемые параметры

    $path

    путь к внешнему JavaScript файлу
    1.  $kernel = & singleton('kernel');
      2.

    2.
      3.

    3.  $kernel->AddJs('/admin/js/my.js');
      4.

    [ Наверх ]

    kernel::AddModule

AddModule(
string
$modules_path, [
$load_module_files = true] );

    Описание

    Метод подключения модуля

    Принимаемые параметры

    $modules_path

    path-имя модуля, например Structure
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $modules_path = 'Structure';
      5.

    5.
      6.

    6.  $kernel->AddModule($modules_path);
      7.

    7.  ?>
      8.

    $load_module_files

    [ Наверх ]

    kernel::AddModuleFile

AddModuleFile(
string
$module_name, string
$file_path, [string
$class_name = false] );

    Описание

    Осуществляет добавление файла модуля в список файлов модулей для загрузки.

    Принимаемые параметры

    $module_name

    наименование модуля

    $file_path

    полный путь к файлу

    $class_name

    наименование класса, размещенного в файле модуля

    [ Наверх ]

    kernel::AddXmlContent

AddXmlContent(
string
$xml );

    Описание

    Дописывает $xml к $this->ShowXmlContent

    Принимаемые параметры

    $xml

    [ Наверх ]

    kernel::add_modules_version

add_modules_version(
string
$path, string
$version, [string
$date = ''] );

    Описание

    Метод добавления модуля в массив-список модулей

    Принимаемые параметры

    $path

    путь к модулю

    $version

    версия модуля

    $date

    дата
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $module_path_name = 'admin_forms';
      5.

    5.  $module_name = 'Формы центра управления системой';
      6.

    6.  $version = '5.2';
      7.

    7.  $date = '27.03.2009';
      8.

    8.
      9.

    9.  $kernel->add_modules_version($module_path_name,'5.6', '05.06.2009');
      10.

    10.  ?>
      11.

    [ Наверх ]

    kernel::AdminLoadFiles

AdminLoadFiles(
array
$param );

    Описание

    Метод загрузки файлов в центре администрирования

    Принимаемые параметры

    $param

    массив параметров
    • $param['path_source_big_image'] путь к файлу-источнику большого изображения
    • $param['path_source_small_image'] путь к файлу-источнику малого изображения
    • $param['original_file_name_big_image'] оригинальное имя файла большого изображения
    • $param['path_target_big_image'] путь к создаваемому файлу большого изображения
    • $param['path_target_small_image'] путь к создаваемому файлу малого изображения
    • $param['original_file_name_small_image'] оригинальное имя файла малого изображения
    • $param['use_big_image'] использовать большое изображение для создания малого (true - использовать (по умолчанию), false - не использовать)
    • $param['max_width_big_image'] значение максимальной ширины большого изображения
    • $param['max_height_big_image'] значение максимальной высоты большого изображения
    • $param['max_width_small_image'] значение максимальной ширины малого изображения
    • $param['max_height_small_image'] значение максимальной высоты малого изображения
    • $param['watermark_file_path'] путь к файлу с "водяным знаком", если водяной знак не должен накладываться, не передавайте этот параметр
    • $param['watermark_position_x'] позиция "водяного знака" по оси X
    • $param['watermark_position_y'] позиция "водяного знака" по оси Y
    • $param['used_watermark_big_image'] наложить "водяной знак" на большое изображение (true - наложить (по умолчанию), false - не наложить)
    • $param['used_watermark_small_image'] наложить "водяной знак" на малое изображение (true - наложить (по умолчанию), false - не наложить)
    • $param['isset_big_image'] существует ли большое изображение (true - существует, false - не существует (по умолчанию))
    • $param['preserve_aspect_ratio_for_big_image'] сохранять пропорции изображения для большого изображения (true - по умолчанию)
    • $param['preserve_aspect_ratio_for_small_image'] сохранять пропорции изображения для большого изображения (true - по умолчанию)

    Возвращает

    - $result['big_image'] = true в случае успешного создания большого изображения, false - в противном случае
    • $result['small_image'] = true в случае успешного создания малого изображения, false - в противном случае

    [ Наверх ]

    kernel::AllowShowPanel

AllowShowPanel(
 );

    Описание

    Определяет возможность отображения панели пользователю.

    [ Наверх ]

    kernel::code_ip

code_ip(
string
$ip );

    Описание

    Метод для преобразования IP в HEX

    Принимаемые параметры

    $ip

    ip-адрес
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $ip = $_SERVER['REMOTE_ADDR'];
      5.

    5.
      6.

    6.  $result = $kernel->code_ip($ip);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    ip-адрес, преобразованный в 16-ое значение для записи в базу

    [ Наверх ]

    kernel::crc32

crc32(
mixed
$value );

    Описание

    Вычисление crc32 в диапазоне от -2147483647 до 2147483647.

    Принимаемые параметры

    $value

    значение

    [ Наверх ]

    kernel::declension

declension(
int
$num, string
$word_stem, array
$ends_of_word, [string
$prefix = ''], [string
$postfix = ''] );

    Описание

    Получение существительного в форме, соответствующей числу

    Принимаемые параметры

    $num

    число, с которым связано существительное

    $word_stem

    основа слова

    $ends_of_word

    массив окончаний слова

    $prefix

    префикс

    $postfix

    постфикс
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $word_stem = 'новост';
      5.

    5.  $ends_of_word = array('ей', 'ь', 'и', 'и', 'и', 'ей', 'ей', 'ей', 'ей', 'ей');
      6.

    6.
      7.

    7.  for ($num = 0; $num < 100; $num++)
      8.

    8.  {
      9.

    9.     $result = $kernel->declension($num, $word_stem, $ends_of_word);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo "{$num} {$result} <br />";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    сформированная строка

    [ Наверх ]

    kernel::decode_ip

decode_ip(
srting
$ip );

    Описание

    Метод для декодирования IP из HEX

    Принимаемые параметры

    $ip

    ip-адрес в 16-ричном формате
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $ip = 'c0a80007';
      5.

    5.
      6.

    6.  $result = $kernel->decode_ip($ip);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    ip-адрес в обычном формате для вывода

    [ Наверх ]

    kernel::function_enabled

function_enabled(
string
$function_name );

    Описание

    Определение доступности php-функции

    Принимаемые параметры

    $function_name

    имя функции

    [ Наверх ]

    kernel::GetAllJs

GetAllJs(
 );

    Описание

    Получения списка внешних JavaScript файлов

    [ Наверх ]

    kernel::GetBit

GetBit(
int
$int, int
$bit_number );

    Описание

    Получить бит номер $bit_number числа $int

    Принимаемые параметры

    $int

    исходное число

    $bit_number

    номер бита, счет ведется с 0

    [ Наверх ]

    kernel::GetColor

GetColor(
$id
$id );

    Описание

    Создание цвета для некоторого идентификатора.

    Используется при создании уникального цвета фона для каждого пользователея.

    Принимаемые параметры

    $id

    идентификтаор

    Возвращает

    массив цветов из 3-х элементов R, G, B

    [ Наверх ]

    kernel::GetCurrentLng

GetCurrentLng(
 );

    Описание

    Получения текущего языка центра администрирования

    [ Наверх ]

    kernel::GetCurrentUser

GetCurrentUser(
 );

    Описание

    Метод определения идентификатора текущего авторизированного пользователя раздела администрирования

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->GetCurrentUser();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    Возвращает

    идентификатор пользователя или 0, если нет авторизированного пользователя

    [ Наверх ]

    kernel::GetCurrentYear

GetCurrentYear(
 );

    Описание

    Получение значения текущего года

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->GetCurrentYear();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    Возвращает

    текущий год

    [ Наверх ]

    kernel::GetDBVersion

GetDBVersion(
 );

    Описание

    Метод определения версии MySQL

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->GetDBVersion();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo htmlspecialchars($result);
      8.

    8.  ?>
      9.

    Возвращает

    версия MySQL

    [ Наверх ]

    kernel::GetDirPath

GetDirPath(
$id
$id, [$level
$level = 1], [$type
$type = 0] );

    Описание

    Получение пути к директории, используемой для решения проблемы с ограничением  количества поддиректорий в директории.

    Например, для сущности с кодом 17 и уровнем вложенности 3 в зависимости от  типа возвращаемого значения создается  строка 0/1/7 или массив из 3-х элементов - 0,1,7  Для сущности с кодом 23987 и уровнем вложенности 3 создается  строка 2/3/9 или массив из 3-х элементов - 2,3,9.

    Принимаемые параметры

    $id

    код(идентификатор) сущности

    $level

    уровень вложенности

    $type

    тип возвращаемого результата, 0 (по умолчанию) - строка, 1 - массив

    Возвращает

    строка или массив названий групп

    [ Наверх ]

    kernel::GetExpires

GetExpires(
 );

    Описание

    Получение времени истечения актуальности страницы

    Возвращает

    временная метка для страницы

    [ Наверх ]

    kernel::GetExtension

GetExtension(
string
$filename );

    Описание

    Метод возвращает расширение файла

    Принимаемые параметры

    $filename

    имя файла
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $filename = 'file.jpg';
      5.

    5.
      6.

    6.  $result = $kernel->GetExtension($filename);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    расширение файла

    [ Наверх ]

    kernel::GetGDVersion

GetGDVersion(
 );

    Описание

    Метод определения версии GD библиотеки

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->GetGDVersion();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo htmlspecialchars($result);
      8.

    8.  ?>
      9.

    Возвращает

    версия GD библиотеки

    [ Наверх ]

    kernel::GetLastModified

GetLastModified(
 );

    Описание

    Получение времени последнего изменения страницы

    Возвращает

    временная метка для страницы

    [ Наверх ]

    kernel::getmicrotime

getmicrotime(
 );

    Описание

    Получение значения времени

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->getmicrotime();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    Возвращает

    время

    [ Наверх ]

    kernel::GetMimeType

GetMimeType(
string
$filename );

    Описание

    Метод определения MIME-типа файла

    Принимаемые параметры

    $filename

    имя файла с расширением
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $filename = 'file.jpg';
      5.

    5.
      6.

    6.  $result = $kernel->GetMimeType($filename);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    mime-тип

    [ Наверх ]

    kernel::GetTableFields

GetTableFields(
string
$table_name, [string
$field_name = ''] );

    Описание

    Получение структуры таблицы БД

    Принимаемые параметры

    $table_name

    имя таблицы

    $field_name

    имя поля таблицы, если не указано или равно пустой строке - выбираются все поля таблицы
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $table_name = 'admin_forms_field_table';
      5.

    5.
      6.

    6.  $result = $kernel->GetTableFields($table_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($result);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о полях таблицы в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    kernel::GetTableFieldSize

GetTableFieldSize(
string
$table_name, string
$field_name );

    Описание

    Получение размера в символах (не занимаемые байты) поля таблицы.

    Например, для поля varchar(200) будет возвращено 200,  для поля text будет возвращено 65535.

    Принимаемые параметры

    $table_name

    имя таблицы

    $field_name

    имя поля таблицы

    Возвращает

    строка с длиной поля или false

    [ Наверх ]

    kernel::GetTemplate

GetTemplate(
 );

    Описание

    Получение текущего макета

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $resource = $kernel->GetTemplate();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo ($resource);
      8.

    8.  ?>
      9.

    Возвращает

    идентификатор макета

    [ Наверх ]

    kernel::getTimestamp

getTimestamp(
 );

    Описание

    Получение временной метки файла CSS-стиля для страницы

    [ Наверх ]

    kernel::GetUrl

GetUrl(
string
$url, [int
$port = 80], [int
$timeout = 10], [array
$param = array()] );

    Описание

    Запрос URL

    Принимаемые параметры

    $url

    адрес ресурса

    $port

    порт, по умолчанию 80

    $timeout

    таймаут, по умолчанию 10

    $param

    дополнительные параметры
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $url = 'http://www.hostcms.ru/';
      5.

    5.
      6.

    6.  $result = $kernel->GetUrl($url);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($result);
      10.

    10.  ?>
      11.

    see

    kernel::GetUrlWithHeader()

    [ Наверх ]

    kernel::GetUrlWithHeader

GetUrlWithHeader(
string
$url, [int
$port = 80], [int
$timeout = 10], [array
$param = array()] );

    Описание

    Запрос URL с возвращением заголовка и данных

    Принимаемые параметры

    $url

    адрес ресурса

    $port

    порт, по умолчанию 80

    $timeout

    таймаут, по умолчанию 10

    $param

    дополнительные параметры
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $url = 'http://www.hostcms.ru/';
      5.

    5.
      6.

    6.  $row = $kernel->GetUrlWithHeader($url);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ('header', 'data')

    [ Наверх ]

    kernel::GetVersionTimestamp

GetVersionTimestamp(
 );

    Описание

    Получения временной метки по текущей версии системы управления

    [ Наверх ]

    kernel::GetXmlContent

GetXmlContent(
 );

    Описание

    Возвращает $this->ShowXmlContent

    [ Наверх ]

    kernel::get_CSS

get_CSS(
[boolean
$is_external = true] );

    Описание

    Получение CSS стиля для страницы

    Принимаемые параметры

    $is_external

    необязательный параметр $is_external - true - ссылка на CSS, false - возвращение содержания CSS стиля

    Возвращает

    CSS-стиль для страницы

    [ Наверх ]

    kernel::get_current_page

get_current_page(
array
$param, [int
$site_id = CURRENT_SITE] );

    Описание

    Получение идентификатора текущего узла структуры

    Принимаемые параметры

    $param

    имена разделов от родителя к ребенку,  например Array ([0] => services[1] => guard_business_center)

    $site_id

    идентификатор сайта

    Возвращает

    идентификатор узла структуры или false

    [ Наверх ]

    kernel::get_current_page_path

get_current_page_path(
 );

    Описание

    Получение пути текущей страницы

    Возвращает

    абсолютный путь к текущей статичной странице

    [ Наверх ]

    kernel::get_description

get_description(
 );

    Описание

    Получение описания страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $title = 'test2';
      5.

    5.
      6.

    6.  $result = $kernel->set_title($title);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo ($result);
      10.

    10.  ?>
      11.

    Возвращает

    описание страницы

    [ Наверх ]

    kernel::get_keywords

get_keywords(
 );

    Описание

    Получение ключевых слов страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->get_keywords();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  print_r ($result);
      8.

    8.  ?>
      9.

    Возвращает

    ключевые слова, установленные для страницы

    [ Наверх ]

    kernel::get_page_id

get_page_id(
string
$name, int
$parent_id, int
$site_id );

    Описание

    Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя

    Принимаемые параметры

    $name

    имя узла стурктуры

    $parent_id

    идентификатор родителя

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $name = 'guestbook';
      5.

    5.  $parent_id = 78;
      6.

    6.  $site_id = CURRENT_SITE;
      7.

    7.
      8.

    8.  $resource = $kernel->get_page_id($name, $parent_id, $site_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $resource;
      12.

    12.  ?>
      13.

    Возвращает

    идентификатор узла структуры или false

    [ Наверх ]

    kernel::get_title

get_title(
 );

    Описание

    Получение заголовка страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->get_title();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    Возвращает

    значение заголовка страницы

    [ Наверх ]

    kernel::Guid

Guid(
 );

    Описание

    Возвращает уникальный идентификатор GUID

    [ Наверх ]

    kernel::implode_array

implode_array(
array
$array, [array
$separator = ''] );

    Описание

    Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно

    Принимаемые параметры

    $array

    массив

    $separator

    разделитель
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $array = array('field1', 'field2');
      5.

    5.  $separator = '';
      6.

    6.
      7.

    7.  $result = $kernel->implode_array($array, $separator);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    строка

    [ Наверх ]

    kernel::InitConstants

InitConstants(
 );

    Описание

    Метод инициализации констант сайта в соответствии с константой CURRENT_SITE

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->InitConstants();
      5.

    5.
      6.

    6.  if ($result)
      7.

    7.  {
      8.

    8.      echo "Инициализации констант выполнена успешно";
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.     echo "Ошибка инициализации констант";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    true в случае успеха, false - данные о сайте отсутствуют

    [ Наверх ]

    kernel::LoadModuleFiles

LoadModuleFiles(
string
$module_name );

    Описание

    Служебный метод

    Принимаемые параметры

    $module_name

    [ Наверх ]

    kernel::LoadModules

LoadModules(
[bool
$load_all_active_module = true] );

    Описание

    Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS

    Принимаемые параметры

    $load_all_active_module

    необязательный параметр, указывает на обязательную загрузку всех активных модулей (для PHP 5 и выше), по умолчанию true
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $load_all_active_module = true;
      5.

    5.
      6.

    6.  $kernel->LoadModules($load_all_active_module);
      7.

    7.  ?>
      8.

    [ Наверх ]

    kernel::LoadModulesLngFile

LoadModulesLngFile(
string
$module_path_name, string
$modules_name );

    Описание

    Метод загрузки языкового файла для модуля

    Принимаемые параметры

    $module_path_name

    имя в пути модуля, например Document

    $modules_name

    текстовое имя модуля, например "Документы"
    1.  <?php
      2.

    2.  <?php
      3.

    3.
      4.

    4.  $kernel = & singleton('kernel');
      5.

    5.
      6.

    6.  $module_path_name = 'Documents';
      7.

    7.  $modules_name = 'Документы';
      8.

    8.
      9.

    9.  $kernel->LoadModulesLngFile($module_path_name, $modules_name);
      10.

    10.  ?>
      11.

    [ Наверх ]

    kernel::my_array_multisort

my_array_multisort(

&$array, string
$filed_name, [int
$type = SORT_ASC], array
$array );

    Описание

    Сортировка многомерного массива $array по полю $filed_name

    Принимаемые параметры

    $array

    многомерный массив

    $filed_name

    название поля, по котормоу производится сортировка

    $type

    направление сортировки, SORT_ASC или SORT_DESC, по умолчанияю SORT_ASC

    &$array

    [ Наверх ]

    kernel::numeric_character_references

numeric_character_references(
string
$html );

    Описание

    Метод преобразует сущности в их числовое представление, например &amp;nbsp; в &#160;

    Принимаемые параметры

    $html

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $html = '&amp;nbsp;';
      5.

    5.
      6.

    6.  $result = $kernel->numeric_character_references($html);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($result);
      10.

    10.  ?>
      11.

    Возвращает

    значение

    [ Наверх ]

    kernel::PathMkdir

PathMkdir(
$path
$path, [$chmod
$chmod = false] );

    Описание

    Создание директорий относительно корневой директории сайта

    Принимаемые параметры

    $path

    путь к директории относительно корневой директории сайта

    $chmod

    права доступа к создаваемой директории.
     по умолчанию равен false - используются права доступа, заданные в константе CHMOD.

    [ Наверх ]

    kernel::phpversion

phpversion(
 );

    Описание

    Метод возвращает номер версии PHP

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->phpversion();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    Возвращает

    номер версии PHP, например 4 или 5

    [ Наверх ]

    kernel::random_shuffle

random_shuffle(
array
$array, [int
$hash = false] );

    Описание

    Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.

    Принимаемые параметры

    $array

    массив

    $hash

    некое числовое значение
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $array = array('field1', 'field2', 'field3');
      5.

    5.  $hash = 10;
      6.

    6.
      7.

    7.  $row = $kernel->random_shuffle($array, $hash);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    перемешанный массив

    [ Наверх ]

    kernel::ReductionDescription

ReductionDescription(
string
$text, [int
$max_lenght = 255] );

    Описание

    Укорачивает описание до определённого количества символов, оставляя целое число предлодений

    Принимаемые параметры

    $text

    - текст описания

    $max_lenght

    - длина описания
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $text = 'Текст описания, который необходимо укоротить';
      5.

    5.  $max_lenght = 20;
      6.

    6.
      7.

    7.  $result = $kernel->ReductionDescription($text, $max_lenght);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    часть описания

    [ Наверх ]

    kernel::ResetBit

ResetBit(
int
$int, int
$bit_number );

    Описание

    Установить бит числа в 0

    Принимаемые параметры

    $int

    исходное число

    $bit_number

    номер бита, счет ведется с 0

    [ Наверх ]

    kernel::SendMailWithFile

SendMailWithFile(
string
$to, string
$from, string
$subject, string
$text, [array
$file_path_name = array()], [string
$ContentType = 'text/plain'], [array
$param = array ()], [
$config = NULL] );

    Описание

    Метод отправки электронного письма с прикрепленным файлом

    Принимаемые параметры

    $to

    адрес получателя письма

    $from

    адрес отправителя письма

    $subject

    тема письма

    $text

    текст письма

    $file_path_name

    ассоциативный массив, содержащий пути к прикрепляемым файлам и их именам, например
    • $file_path_name[0]['filepath'] = "C:\file1.txt";
    • $file_path_name[0]['filename'] = "file1.txt";
    • $file_path_name[0]['Content-ID'] = "123456";
    • $file_path_name[0]['Content-Disposition'] = "attachment"; // attachment или inline
    • $file_path_name[0]['Content-Type'] = "application/octet-stream";

    $ContentType

    по умолчанию text/plain

    $param

    массив дополнительных параметров
    • $param['sender_name'] - текстовое имя отправителя
    • $param['bound'] - граница прикрепляемого файла. Если не передан, создается автоматически
    • $param['header'] - массив дополнительных заголовков письма, например, array('XHostMakeReason' => 'Order');

      1.  <?php
        2.

      2.  $kernel = & singleton('kernel');
        3.

      3.
        4.

      4.  $to = 'xyz@localhost.ru';
        5.

      5.  $from = 'admin@localhost.ru';
        6.

      6.  $subject = 'Тема письма';
        7.

      7.  $text = 'Текст письма';
        8.

      8.  $file_path_name = array();
        9.

      9.  $file_path_name[0]['filepath'] = CMS_FOLDER . 'file.jpg';
        10.

      10.  $file_path_name[0]['filename'] = "file.jpg";
        11.

      11.  $file_path_name[0]['Content-ID'] = "123456";
        12.

      12.  $file_path_name[0]['Content-Disposition'] = "attachment"; // attachment или inline
        13.

      13.  $file_path_name[0]['Content-Type'] = "application/octet-stream";
        14.

      14.
        15.

      15.  $param = array();
        16.

      16.  $param['sender_name'] = "Имя отправителя";
        17.

      17.
        18.

      18.  $result = $kernel->SendMailWithFile($to, $from, $subject, $text, $file_path_name, 'text/plain', $param);
        19.

      19.
        20.

      20.  if ($result)
        21.

      21.  {
        22.

      22.      echo "Отправка письма выполнена успешно";
        23.

      23.  }
        24.

      24.  else
        25.

      25.  {
        26.

      26.      echo "Ошибка отправки письма";
        27.

      27.  }
        28.

      28.  ?>
        29.

    $config

    Возвращает

    true - письмо отправлено успешно, false - неуспешно

    [ Наверх ]

    kernel::serverParse

serverParse(

$socket,
$response );

    Принимаемые параметры

    $socket

    $response

    [ Наверх ]

    kernel::SetBit

SetBit(
int
$int, int
$bit_number, [int
$value = 1] );

    Описание

    Установить бит числа

    Принимаемые параметры

    $int

    исходное число

    $bit_number

    номер бита, счет ведется с 0

    $value

    значение бита (0, 1). по умолчанию значение 1

    [ Наверх ]

    kernel::SetExpires

SetExpires(
int
$time );

    Описание

    Метод установления времени истечения актуальности страницы

    Принимаемые параметры

    $time

    временная метка

    [ Наверх ]

    kernel::SetLastModified

SetLastModified(
int
$time );

    Описание

    Метод установления времени последнего изменения страницы

    Принимаемые параметры

    $time

    временная метка

    [ Наверх ]

    kernel::SetTemplate

SetTemplate(
int
$template_id );

    Описание

    Метод установления текущего макета

    Принимаемые параметры

    $template_id

    идентификатор макета
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $template_id = 1;
      5.

    5.
      6.

    6.  $kernel->SetTemplate($template_id);
      7.

    7.  ?>
      8.

    [ Наверх ]

    kernel::setTimestamp

setTimestamp(

$timestamp, string
$CSS );

    Описание

    Изменение временной метки файла CSS-стиля для страницы

    Принимаемые параметры

    $CSS

    код стилей

    $timestamp

    [ Наверх ]

    kernel::set_CSS

set_CSS(
string
$CSS );

    Описание

    Метод изменения адреса файла CSS-стиля для страницы

    Принимаемые параметры

    $CSS

    код стилей

    [ Наверх ]

    kernel::set_current_page

set_current_page(
string
$page );

    Описание

    Метод изменения адреса страницы

    Принимаемые параметры

    $page

    абсолютный адрес файла статичного документа

    [ Наверх ]

    kernel::set_current_page_data_template

set_current_page_data_template(
string
$data_template_id );

    Описание

    Метод изменения шаблона страницы

    Принимаемые параметры

    $data_template_id

    идентификатор шаблона страницы
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $data_template_id = 3;
      5.

    5.
      6.

    6.  $kernel->set_current_page_data_template($data_template_id);
      7.

    7.  ?>
      8.

    [ Наверх ]

    kernel::set_description

set_description(
string
$description );

    Описание

    Метод изменения описания страницы

    Принимаемые параметры

    $description

    описание страницы
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $description = 'Новое описание';
      5.

    5.
      6.

    6.  $kernel->set_description($description);
      7.

    7.  ?>
      8.

    [ Наверх ]

    kernel::set_keywords

set_keywords(
string
$keywords );

    Описание

    Метод изменения ключевых слов страницы

    Принимаемые параметры

    $keywords

    ключевые слова
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $keywords = 'Новые ключевые слова';
      5.

    5.
      6.

    6.  $kernel->set_keywords($keywords);
      7.

    7.  ?>
      8.

    [ Наверх ]

    kernel::set_title

set_title(
string
$title );

    Описание

    Метод изменения заголовока страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $title = 'test2';
      5.

    5.
      6.

    6.  $kernel->set_title($title);
      7.

    7.
      8.

    8.  ?>
      9.

    Принимаемые параметры

    $title

    текст заголовка страницы

    [ Наверх ]

    kernel::ShowFlyPanel

ShowFlyPanel(
array
$param );

    Описание

    Формирование панели редактирования элементов ЦА в клиентской части

    Принимаемые параметры

    $param

    Массив добавляемых элементов на панель
    • array $param['attributes'] - дополнительные атрибуты панели
    • str $param[0]['type'] тип, 0 - графическая кнопка, 1 - текст "как есть"
    • str $param[0]['image_path'] Путь к изображению
    • str $param[0]['href'] содержимое атибута href
    • str $param[0]['onclick'] содержимое атибута onclick
    • str $param[0]['alt'] alt к изображению

    Возвращает

    код

    [ Наверх ]

    kernel::show_CSS

show_CSS(
[boolean
$is_external = true] );

    Описание

    Метод вывода CSS стиля для страницы

    Принимаемые параметры

    $is_external

    true - ссылка на CSS, false - вывод содержания CSS стиля

    [ Наверх ]

    kernel::show_current_page

show_current_page(
 );

    Описание

    Метод вывода установленной страницы

    [ Наверх ]

    kernel::show_current_template

show_current_template(
 );

    Описание

    Метод вывода текущего макета.

    [ Наверх ]

    kernel::show_description

show_description(
 );

    Описание

    Метод вывода описания страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $kernel->show_description();
      5.

    5.
      6.

    6.  ?>
      7.

    [ Наверх ]

    kernel::show_keywords

show_keywords(
 );

    Описание

    Метод вывода ключевых слов страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  echo $kernel->show_keywords();
      5.

    5.  ?>
      6.

    [ Наверх ]

    kernel::show_title

show_title(
 );

    Описание

    Метод вывода заголовка страницы

    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $result = $kernel->show_title();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $result;
      8.

    8.  ?>
      9.

    [ Наверх ]

    kernel::smtpMail

smtpMail(

$to,
$subject,
$message, [
$additional_headers = ''], [
$config = NULL] );

    Принимаемые параметры

    $to

    $subject

    $message

    $additional_headers

    $config

    [ Наверх ]

    kernel::strips

strips(
 );

    Описание

    Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag

    [ Наверх ]

    kernel::UseHttps

UseHttps(
 );

    Описание

    Используется ли HTTPS-доступ

    [ Наверх ]

    kernel::Utf8ToWindows1251

Utf8ToWindows1251(
string
$utf8 );

    Описание

    Преобразует текст из UTF-8 в Windows1251. В своей работе использует  iconv() при его наличии или kernel::utf8_win1251()

    Принимаемые параметры

    $utf8

    [ Наверх ]

    kernel::utf8_win1251

utf8_win1251(
string
$text );

    Описание

    Перевод из UTF-8 в Windows-1251, используется при отсутствии iconv()

    Принимаемые параметры

    $text

    [ Наверх ]

    kernel::win1251_utf8

win1251_utf8(
string
$text );

    Описание

    Перевод из Windows-1251 в UTF-8, используется при отсутствии iconv()

    Принимаемые параметры

    $text

    [ Наверх ]

    kernel::Windows1251ToUtf8

Windows1251ToUtf8(
string
$windows1251 );

    Описание

    Преобразует текст из Windows1251 в UTF-8. В своей работе использует  iconv() при его наличии или kernel::win1251_utf8()

    Принимаемые параметры

    $windows1251

    [ Наверх ]

    kernel::Xml2Array

Xml2Array(

$xml );

    Принимаемые параметры

    $xml

    [ Наверх ]

    kernel::Xml2Array2

Xml2Array2(
string
$xml );

    Описание

    Преобразование XML в массив

    Принимаемые параметры

    $xml

    исходный XML
    1.  <?php
      2.

    2.  $kernel = & singleton('kernel');
      3.

    3.
      4.

    4.  $xml = <?xml version="1.0" encoding="utf-8"?>
      5.

    5.
      6.

    6.  $result = $kernel->Xml2Array($xml);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($result);
      10.

    10.  ?>
      11.

    Возвращает

    XML-дерево в виде массива

    [ Наверх ]

    kernel::_xml2Array

_xml2Array(

$xml );

    Принимаемые параметры

    $xml

    [ Наверх ]

Описания переменных

  • $aJs = array() [Строка 224]
    •

  • Data type: mixed
    •

  • $available_extantions = array ('JPG','JPEG','GIF','PNG') [Строка 173]
    •

  • Data type: array
    •

    Описание

    Доступные для загрузки расширения файлов

  • $CURLOPT_HTTPPROXYTUNNEL =  false [Строка 222]
    •

  • Data type: bool
    •

    Описание

    При установке этого параметра в true данные будут передаваться через прокси-сервер

  • $CURLOPT_PROXY =  false [Строка 187]
    •

  • Data type: string
    •

    Описание

    HTTP-прокси

  • $CURLOPT_PROXYAUTH =  false [Строка 202]
    •

  • Data type: string
    •

    Описание

    Метод HTTP-авторизации для использования при соединении с прокси.

    Для прокси-авторизации доступны только CURLAUTH_BASIC и CURLAUTH_NTLM

  • $CURLOPT_PROXYPORT =  false [Строка 209]
    •

  • Data type: int
    •

    Описание

    Номер порта для соединения с прокси-сервером; используется совместно с CURLOPT_PROXY

  • $CURLOPT_PROXYTYPE =  false [Строка 215]
    •

  • Data type: string
    •

    Описание

    CURLPROXY_HTTP по умолчанию или CURLPROXY_SOCKS5

  • $CURLOPT_PROXYUSERPWD =  false [Строка 194]
    •

  • Data type: string
    •

    Описание

    Имя пользователя и пароль в формате "[username]:[password]" для использования при соединении с прокси

  • $icon_array = array (

   'sql' => 'sql.gif',

   'txt' => 'txt.gif',

   'htaccess' => 'config.gif',

   'css' => 'css.gif',

   'php' => 'php.gif',

   'php3' => 'php.gif',

   'jpg' => 'jpg.gif',

   'jpeg' => 'jpg.gif',

   'gif' => 'gif.gif',

   'bmp' => 'bmp.gif',

   'png' => 'png.gif',

   'ico' => 'image.gif', //

   'htm' => 'html.gif',

   'html' => 'html.gif',

   'xml' => 'xml.gif', //

   'xsl' => 'xsl.gif',

   'zip' => 'zip.gif',

   'gz' => 'zip.gif',

   '7z' => 'zip.gif',

   'rar' => 'rar.gif',

   'pdf' => 'pdf.gif',

   'doc' => 'doc.gif',

   'docx' => 'doc.gif',

   'cdr' => 'vector.gif',

   'ai' => 'vector.gif',

   'eps' => 'vector.gif',

   'rb' => 'rb.gif',

   'ppt' => 'ppt.gif',

   'pptx' => 'ppt.gif',

   'pptm' => 'ppt.gif',

   'mdb' => 'mdb.gif',

   'h' => 'h.gif',

   'fh1' => 'fh1.gif',

   'fh2' => 'fh2.gif',

   'fh3' => 'fh3.gif',

   'fh4' => 'fh4.gif',

   'fh5' => 'fh5.gif',

   'fh6' => 'fh6.gif',

   'fh7' => 'fh7.gif',

   'fh8' => 'fh8.gif',

   'fh9' => 'fh9.gif',

   'fla' => 'flash.gif',

   'swf' => 'flash.gif',

   'xls' => 'xls.gif',

   'cpp' => 'cpp.gif',

   'chm' => 'chm.gif'

   )     [Строка 119]
    •

  • Data type: array
    •

    Описание

    Массив ассоциаций расширений и пиктограмм

  • $modules = array () [Строка 102]
    •

  • Data type: array
    •

    Описание

    Информация о загруженных модулях системы

  • $resize_extension = array ('JPG','JPEG','GIF','PNG') [Строка 180]
    •

  • Data type: array
    •

    Описание

    Рашсирения графических файлов, доступные для уменьшения

  • $ShowXmlContent =  '' [Строка 104]
    •

  • Data type: mixed
    •

  • $sModulesPath =  null [Строка 226]
    •

  • Data type: mixed
    •

  • $useSmtp =  NULL [Строка 237]
    •

  • Data type: mixed
    •

    Описание

    Данные внешнего SMTP-сервера для отправки писем

    array( 		'smtp_username' => 'address@domain.com', 		'smtp_port' => '25', // для SSL порт 465 		'smtp_host' => 'smtp.server.com', // для SSL используйте ssl://smtp.gmail.com 		'smtp_password' => '' 	);

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Session

Class Session

[Строка 404]

Размещен: /Kernel/Kernel.php

Свойства класса

  • $GET_LOCK_timeout =  1

        Таймаут для GET_LOCK, в секундах

  • $lockPrefix =  NULL

        Префикс для блокировки

  • $lockTimeout =  10

        Таймаут попытки заблокировать сессию, в секундах.

  • $nextStepDelay =  500000

        Время задержки перед повторной блокировкой, в мс.

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • Session Session()

  • void sessionClose()

  • void sessionDestroyer()

  • void sessionGc()

  • void sessionOpen()

  • void sessionRead()

  • void sessionWrite()

  • void _lock()

  • void _unlock()

Унаследованные методы

Описания методов

    Session::Session

Session(
 );

    [ Наверх ]

    Session::sessionClose

sessionClose(
 );

    [ Наверх ]

    Session::sessionDestroyer

sessionDestroyer(

$session_id );

    Принимаемые параметры

    $session_id

    [ Наверх ]

    Session::sessionGc

sessionGc(

$maxlifetime );

    Принимаемые параметры

    $maxlifetime

    [ Наверх ]

    Session::sessionOpen

sessionOpen(

$save_path,
$session_name );

    Принимаемые параметры

    $save_path

    $session_name

    [ Наверх ]

    Session::sessionRead

sessionRead(

$session_id );

    Принимаемые параметры

    $session_id

    [ Наверх ]

    Session::sessionWrite

sessionWrite(

$session_id,
$session_value );

    Принимаемые параметры

    $session_id

    $session_value

    [ Наверх ]

    Session::_lock

_lock(

$session_id );

    Принимаемые параметры

    $session_id

    [ Наверх ]

    Session::_unlock

_unlock(

$session_id );

    Принимаемые параметры

    $session_id

    [ Наверх ]

Описания переменных

  • $GET_LOCK_timeout =  1 [Строка 418]
    •

  • Data type: int
    •

    Описание

    Таймаут для GET_LOCK, в секундах

  • $lockPrefix =  NULL [Строка 411]
    •

  • Data type: string
    •

    Описание

    Префикс для блокировки

  • $lockTimeout =  10 [Строка 433]
    •

  • Data type: int
    •

    Описание

    Таймаут попытки заблокировать сессию, в секундах.

  • $nextStepDelay =  500000 [Строка 426]
    •

  • Data type: int
    •

    Описание

    Время задержки перед повторной блокировкой, в мс.

    Значение по умолчанию 0,5 секунды - 500000

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class lib

Class lib

[Строка 14]

Размещен: /lib/lib.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Типовые динамические страницы".
Файл: /modules/lib/lib.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $mas_lib_dir = array()

  • $section_path =  ''

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void ConvertSqlProperty()

    Конвертирование SQL-запроса, введенного для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.

  • boolean CopyLib()

    Создание копии типовой динамической страницы

  • mixed DeleteLib()

    Удаление типовой динамической страницы из библиотеки страниц

  • boolean DeleteLibDir()

    Рекурсивное удаление раздела типовых динамической страниц со всеми его подразделами

  • mixed DeleteLibProperty()

    Удаление параметра типовой динамической страницы

  • результат DeleteLibPropertyListItem()

    Удаление элемента списка параметра типовой динамической страницы типа "Список"

  • mixed GetAllLibDirs()

    Получение списка директорий типовых дин. страниц

  • mixed GetAllLibProperties()

    Получение списка всех дополнительных параметров типовой динамической страницы

  • mixed GetAllLibPropertyListItems()

    Получение списка элеметов параметра типовой динамической страницы типа "Список"

  • mixed GetAllLibs()

    Получение списка типовых динамических страниц

  • mixed GetLib()

    Получение типовой динамической страницы по её идентификатору

  • mixed GetLibDir()

    Получение информации о директории типовых дин. страниц

  • array GetLibDirTree()

    Формирование дерева разделов

  • string GetLibPath()

    Получение пути к директории lib

  • array GetLibPathArray()

    Получение пути от текущего каталога типовых динамических страниц до корневого

  • mixed GetLibProperty()

    Получение информации о параметре типовой динамической страницы

  • void GetSectionPath()

    Внутренний метод возвращает путь к типовой дин. странице

  • mixed InsertLib()

    Вставка информации о типовой динамической странице

  • mixed InsertLibDir()

    Вставка/обновление информации о разделе типовых динамических страниц

  • mixed InsertLibProperty()

    Вставка информации о параметре типовой динамической страницы

  • mixed InsertLibPropertyListItem()

    Вставка/обновление элемента списка для параметра типовой динамической страницы

  • array LoadLibPropertiesValue()

    Загрузка значений параметров типовой дин. страницы для структуры

  • bool SaveLibPropertiesValue()

    Сохранение настроек типовой динамической страницы для стурктуры в файл

  • результат UpdateLibPropertyOrder()

    Обновление порядка сортировки параметра типовой дин. страницы

Унаследованные методы

Описания методов

    lib::ConvertSqlProperty

ConvertSqlProperty(
string
$sql );

    Описание

    Конвертирование SQL-запроса, введенного для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.

    Список замен:
    {SITE_ID} - идентификатор текущего выбранного сайта

    Принимаемые параметры

    $sql

    [ Наверх ]

    lib::CopyLib

CopyLib(
int
$lib_id );

    Описание

    Создание копии типовой динамической страницы

    Принимаемые параметры

    $lib_id

    идентификатор типовой дин. страницы
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_id = 1;
      5.

    5.
      6.

    6.  $copy_result = $lib->CopyLib($lib_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($copy_result)
      10.

    10.  {
      11.

    11.      echo 'Типовая динамическая страница скопирована';
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo 'Ошибка! Типовая динамическая страница не скопирована!';
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    lib::DeleteLib

DeleteLib(
int
$lib_id );

    Описание

    Удаление типовой динамической страницы из библиотеки страниц

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_id = 33;
      5.

    5.
      6.

    6.  $result = $lib->DeleteLib($lib_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    lib::DeleteLibDir

DeleteLibDir(
int
$lib_dir_id );

    Описание

    Рекурсивное удаление раздела типовых динамической страниц со всеми его подразделами

    Принимаемые параметры

    $lib_dir_id

    идентификатор раздела
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_dir_id = 28;
      5.

    5.
      6.

    6.  $result = $lib->DeleteLibDir($lib_dir_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    lib::DeleteLibProperty

DeleteLibProperty(
int
$lib_property_id );

    Описание

    Удаление параметра типовой динамической страницы

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра типовой динамической страницы
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_property_id = 426;
      5.

    5.
      6.

    6.  $result = $lib->DeleteLibProperty($lib_property_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Параметр типовой динамической страницы удален";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка! Параметр типовой динамической страницы не удален!";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    lib::DeleteLibPropertyListItem

DeleteLibPropertyListItem(
int
$lib_property_list_id );

    Описание

    Удаление элемента списка параметра типовой динамической страницы типа "Список"

    Принимаемые параметры

    $lib_property_list_id

    идентификатор элемента списка
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_property_list_id = 33;
      5.

    5.
      6.

    6.  $result = $lib->DeleteLibPropertyListItem($lib_property_list_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    выполнения запроса

    [ Наверх ]

    lib::GetAllLibDirs

GetAllLibDirs(
[int
$lib_dir_parent_id = false] );

    Описание

    Получение списка директорий типовых дин. страниц

    Принимаемые параметры

    $lib_dir_parent_id

    идентификатор родительской директории, если false, то отображаются все директории
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_dir_parent_id = false;
      5.

    5.
      6.

    6.  $resource = $lib->GetAllLibDirs($lib_dir_parent_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    lib::GetAllLibProperties

GetAllLibProperties(
int
$lib_id );

    Описание

    Получение списка всех дополнительных параметров типовой динамической страницы

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_id = 1;
      5.

    5.
      6.

    6.  $resource = $lib->GetAllLibProperties($lib_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    lib::GetAllLibPropertyListItems

GetAllLibPropertyListItems(
[int
$lib_property_id = false] );

    Описание

    Получение списка элеметов параметра типовой динамической страницы типа "Список"

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра типовой динамическойстраницы типа "Список", если равен false - получаем список элементов всех парметров типовых динамических страниц типа "Список"
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_property_id = 81;
      5.

    5.
      6.

    6.  $resource = $lib->GetAllLibPropertyListItems($lib_property_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    lib::GetAllLibs

GetAllLibs(
[int
$lib_dir_id = false] );

    Описание

    Получение списка типовых динамических страниц

    Принимаемые параметры

    $lib_dir_id

    идентификатор родительской директории, если false, то отображаются все директории
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_dir_id = false;
      5.

    5.
      6.

    6.  $resource = $lib->GetAllLibs($lib_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    lib::GetLib

GetLib(
int
$lib_id );

    Описание

    Получение типовой динамической страницы по её идентификатору

    Принимаемые параметры

    $lib_id

    идентификатор типовой страницы
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_id = 33;
      5.

    5.
      6.

    6.  $row = $lib->GetLib($lib_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о типовой  динамической странице или false

    [ Наверх ]

    lib::GetLibDir

GetLibDir(
int
$lib_dir_id );

    Описание

    Получение информации о директории типовых дин. страниц

    Принимаемые параметры

    $lib_dir_id

    идентификатор директории
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_dir_id = 15;
      5.

    5.
      6.

    6.  $row = $lib->GetLibDir($lib_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о директории или false

    [ Наверх ]

    lib::GetLibDirTree

GetLibDirTree(
int
$lib_dir_parent_id, string
$separator, [int
$lib_dir_id_not_set = false] );

    Описание

    Формирование дерева разделов

    Принимаемые параметры

    $lib_dir_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    $lib_dir_id_not_set

    lib_dir_id_not_set - идентификатор группы, которая не включается в дерево вместе с потомками. Необязательный параметр.
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_dir_parent_id = 15;
      5.

    5.  $separator = '';
      6.

    6.
      7.

    7.  $row = $lib->GetLibDirTree($lib_dir_parent_id, $separator);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив с данными о дереве разделов типовых дин. страниц

    [ Наверх ]

    lib::GetLibPath

GetLibPath(
int
$lib_id );

    Описание

    Получение пути к директории lib

    Принимаемые параметры

    $lib_id

    Идентификатор типовой динамической страницы

    Возвращает

    путь к файлу

    [ Наверх ]

    lib::GetLibPathArray

GetLibPathArray(
int
$lib_dir_id, [
$first_call = true] );

    Описание

    Получение пути от текущего каталога типовых динамических страниц до корневого

    Принимаемые параметры

    $lib_dir_id

    идентификатор узла
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_dir_id = 28;
      5.

    5.
      6.

    6.  $row = $lib->GetLibPathArray($lib_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    $first_call

    Возвращает

    массив каталогов, от текущего до корневого каталога

    [ Наверх ]

    lib::GetLibProperty

GetLibProperty(
int
$lib_property_id );

    Описание

    Получение информации о параметре типовой динамической страницы

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_property_id = 95;
      5.

    5.
      6.

    6.  $row = $lib->GetLibProperty($lib_property_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    информация о параметре типовой динамической страниы или false

    [ Наверх ]

    lib::GetSectionPath

GetSectionPath(
int
$lib_dir_id );

    Описание

    Внутренний метод возвращает путь к типовой дин. странице

    Принимаемые параметры

    $lib_dir_id

    идентификатор директории или типовой дин. страницы

    [ Наверх ]

    lib::InsertLib

InsertLib(
array
$param );

    Описание

    Вставка информации о типовой динамической странице

    Принимаемые параметры

    $param

    список доп. параметров
    • int $param['lib_id'] идентификатор динамической страницы
    • int $param['lib_dir_id'] идентификатор раздела динамической страницы
    • string $param['lib_name'] название страницы
    • string $param['lib_description'] описание страницы
    • string $param['lib_module'] код динамической страницы (берем из файла)
    • string $param['lib_module_config'] код настроек динамической страницы (берем из файла)
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $lib = new lib();
        3.

      3.
        4.

      4.  $param['lib_dir_id'] = 27;
        5.

      5.  $param['lib_name'] = 'newlib';
        6.

      6.  $param['lib_description'] = 'Тестовая типовая динамическая страница';
        7.

      7.
        8.

      8.  $newid = $lib->InsertLib($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор вставленной страницы или false

    [ Наверх ]

    lib::InsertLibDir

InsertLibDir(
array
$param );

    Описание

    Вставка/обновление информации о разделе типовых динамических страниц

    Принимаемые параметры

    $param

    массив параметров
    • int $param['lib_dir_id'] идентификатор раздела динамической страницы
    • int $param['lib_dir_parent_id'] идентификатор родителя раздела динамической страницы
    • int $param['lib_dir_name'] название раздела
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $lib = new lib();
        3.

      3.
        4.

      4.  $param['lib_dir_parent_id'] = 15;
        5.

      5.  $param['lib_dir_name'] = 'New';
        6.

      6.
        7.

      7.  $newid = $lib->InsertLibDir($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  if ($newid)
        11.

      11.  {
        12.

      12.      echo 'Раздел типовых динамических страниц добавлен';
        13.

      13.  }
        14.

      14.  else
        15.

      15.  {
        16.

      16.      echo 'Ошибка! Раздел типовых динамических страниц не добавлен!';
        17.

      17.  }
        18.

      18.  ?>
        19.

    Возвращает

    идентификатор раздела типовых динамических страниц или false

    [ Наверх ]

    lib::InsertLibProperty

InsertLibProperty(
array
$param );

    Описание

    Вставка информации о параметре типовой динамической страницы

    Принимаемые параметры

    $param

    список доп. параметров
    • int $param['lib_property_id'] идентификатор параметра динамической страницы
    • int $param['lib_id'] идентификатор динамической страницы
    • string $param['lib_property_name'] название параметра динамической страницы
    • string $param['lib_property_description'] описание параметра динамической страницы
    • string $param['lib_property_varible_name'] название переменной параметра динамической страницы
    • int $param['lib_property_type'] тип свойства параметра динамической страницы
    • string $param['lib_property_default_value'] значение по умолчанию параметра динамической страницы
    • int $param['lib_property_order'] порядок сортировки параметра динамической страницы
    • int $param['lib_property_sql_request'] параметр типовой дин. страницы - SQL запрос, текст запроса
    • int $param['lib_property_sql_caption_field'] параметр типовой дин. страницы - SQL запрос, поле заголовка
    • int $param['lib_property_sql_value_field'] параметр типовой дин. страницы - SQL запрос, поле значения
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $lib = new lib();
        3.

      3.
        4.

      4.  $param['lib_id'] = 34;
        5.

      5.  $param['lib_property_name'] = 'Новый параметр';
        6.

      6.  $param['lib_property_varible_name'] = 'test_param';
        7.

      7.  $param['lib_property_type'] = 0;
        8.

      8.  $param['lib_property_default_value'] = 'Значение по умолчанию';
        9.

      9.  $param['lib_property_order'] = 10;
        10.

      10.
        11.

      11.  $newid = $lib->InsertLibProperty($param);
        12.

      12.
        13.

      13.  // Распечатаем результат
        14.

      14.  echo $newid;
        15.

      15.  ?>
        16.

    Возвращает

    идентификатор вставленного параметра или false

    [ Наверх ]

    lib::InsertLibPropertyListItem

InsertLibPropertyListItem(
array
$param );

    Описание

    Вставка/обновление элемента списка для параметра типовой динамической страницы

    Принимаемые параметры

    $param

    массив с параметрами элемента списка
    • int $param['lib_property_id'] идентификатор параметра типовой дин. страницы
    • int $param['lib_property_list_id'] идентификатор элемента списка
    • string $param['lib_property_list_name'] название элемента списка
    • string $param['lib_property_list_value'] значение элемента списка
    • int $param['$lib_property_list_order'] порядок сортировки элемента списка
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $lib = new lib();
        3.

      3.
        4.

      4.  $param['lib_property_id'] = 439;
        5.

      5.  $param['lib_property_list_name'] = 'Вариант 1';
        6.

      6.  $param['lib_property_list_value'] = '1';
        7.

      7.
        8.

      8.  $param['$lib_property_list_order'] = 0;
        9.

      9.
        10.

      10.  $newid = $lib->InsertLibPropertyListItem($param);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  if ($newid)
        14.

      14.  {
        15.

      15.      echo 'Элемент списка для параметра типовой динамической страницы добавлен';
        16.

      16.  }
        17.

      17.  else
        18.

      18.  {
        19.

      19.      echo 'Ошибка! Элемент списка для параметра типовой динамической страницы не добавлен!';
        20.

      20.  }
        21.

      21.  ?>
        22.

    Возвращает

    идентификатор вставленного/обновленного элемента или false

    [ Наверх ]

    lib::LoadLibPropertiesValue

LoadLibPropertiesValue(
int
$lib_id, int
$structure_id );

    Описание

    Загрузка значений параметров типовой дин. страницы для структуры

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы

    $structure_id

    идентификатор структуры

    Возвращает

    массив с данными в виде 'Имя_переменной' => 'значение'

    [ Наверх ]

    lib::SaveLibPropertiesValue

SaveLibPropertiesValue(
int
$lib_id, int
$structure_id, array
$values );

    Описание

    Сохранение настроек типовой динамической страницы для стурктуры в файл

    Принимаемые параметры

    $lib_id

    идентификатор типовой динамической страницы

    $structure_id

    идентификатор структуры

    $values

    массив с данными в виде 'Имя_переменной' => 'значение'

    [ Наверх ]

    lib::UpdateLibPropertyOrder

UpdateLibPropertyOrder(
int
$lib_property_id, int
$lib_property_order );

    Описание

    Обновление порядка сортировки параметра типовой дин. страницы

    Принимаемые параметры

    $lib_property_id

    идентификатор параметра типовой дин. страницы

    $lib_property_order

    порядок сортировки
    1.  <?php
      2.

    2.  $lib = new lib();
      3.

    3.
      4.

    4.  $lib_property_id = 91;
      5.

    5.  $lib_property_order = 65;
      6.

    6.
      7.

    7.  $result = $lib->UpdateLibPropertyOrder($lib_property_id, $lib_property_order);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo 'Порядок сортировки параметра типовой динамической страницы изменен';
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo 'Ошибка! Порядок сортировки параметра типовой динамической страницы не изменен!';
      17.

    17.  }
      18.

    18.  ?>
      19.

    Возвращает

    запроса

    [ Наверх ]

Описания переменных

  • $mas_lib_dir = array() [Строка 17]
    •

  • Data type: mixed
    •

  • $section_path =  '' [Строка 16]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class lists

Class lists

[Строка 23]

Размещен: /Lists/Lists.class.php

Описание

Класс модуля "Списки"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean CopyList()

    Копирование списка

  • int CopyListItem()

    Копирование элемента списка

  • void DeleteListDir()

    Удаление раздела списков

  • boolean del_lists()

    Удаление списка

  • boolean del_lists_items()

    Удаление элемента списка

  • string GenXml4ListItems()

    Генерация XML для всех элементов списка

  • resource GetAllListDirs()

    Получение информации о разделах списков

  • resource GetAllListsForSite()

    Получение списков определенного сайта

  • resource GetList()

    Получение данных о списках

  • mixed GetListDir()

    Получение информации о разделе списков

  • array GetListDirPathArray()

    Построение массива пути от текущего раздела к корневому

  • array GetListDirsTree()

    Формирование дерева разделов списков

  • mixed GetListItem()

    Получение данных об элементе списка

  • mixed GetListItemIfIssetValue()

    Проверка наличия значения в списке

  • array GetListItemsById()

    Получение элементов списка в виде массива

  • resource GetListItemsValuesById()

    Получение элементов списка в виде resource.

  • array GetListsItems()

    Получение данных об элементах списка

  • int InsertList()

    Вставка/обновление данных о списке

  • int InsertListDir()

    Добавление/редактирование раздела списков

  • int InsertListItem()

    Вставка/обновление данных об элементе списка

  • int insert_lists()

    Устаревший метод. Вставка/обновление данных о списке

  • int insert_lists_items()

    Устаревший метод. Вставка/обновление данных об элементе списка

  • mixed SelectList()

    Получение данных о списке

  • resource SelectListsItems()

    Получение данных об элементах списка

  • resource select_lists_items()

    Получение данных об элементе списка

  • void ShowList()

    Отображение элементов списка. Внутренний метод

Унаследованные методы

Описания методов

    lists::CopyList

CopyList(
int
$lists_id, [int
$site_id = false] );

    Описание

    Копирование списка

    Принимаемые параметры

    $lists_id

    идентификатор копируемого списка

    $site_id

    идентификатор сайта, на который следует перенести скопированный список, если не передан, используется текущий
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 2;
      5.

    5.
      6.

    6.  $result = $lists->CopyList($lists_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Копирование выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка копирования";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    lists::CopyListItem

CopyListItem(
int
$list_item_id );

    Описание

    Копирование элемента списка

    Принимаемые параметры

    $list_item_id

    идентификатор копируемого элемента списка
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $list_item_id = 8;
      5.

    5.
      6.

    6.  $newid = $lists->CopyListItem($list_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if ($newid)
      10.

    10.  {
      11.

    11.      echo 'Элемент списка скопирован';
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo 'Ошибка! Элемент списка не скопирован!';
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    идентификатор копии элемента списка в случае успешного завершения, false - в противном случае

    [ Наверх ]

    lists::DeleteListDir

DeleteListDir(
$list_dir_id
$list_dir_id );

    Описание

    Удаление раздела списков

    Принимаемые параметры

    $list_dir_id

    идентификатор раздела списков

    [ Наверх ]

    lists::del_lists

del_lists(
int
$lists_id );

    Описание

    Удаление списка

    Принимаемые параметры

    $lists_id

    идентификатор удаляемого списка
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 5;
      5.

    5.
      6.

    6.  $result = $lists->del_lists($lists_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    lists::del_lists_items

del_lists_items(
int
$lists_items_id );

    Описание

    Удаление элемента списка

    Принимаемые параметры

    $lists_items_id

    идентификатор удаляемого элемента списка
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_items_id = 71;
      5.

    5.
      6.

    6.  $result = $lists->del_lists_items($lists_items_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    lists::GenXml4ListItems

GenXml4ListItems(
int
$lists_id );

    Описание

    Генерация XML для всех элементов списка

    Принимаемые параметры

    $lists_id

    идентификатор списка
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 8;
      5.

    5.
      6.

    6.  $xml = $lists->GenXml4ListItems($lists_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo nl2br(htmlspecialchars($xml));
      10.

    10.  ?>
      11.

    Возвращает

    строка с XML или пустая строка

    [ Наверх ]

    lists::GetAllListDirs

GetAllListDirs(
$list_dir_parent_id
$list_dir_parent_id, [$site_id
$site_id = CURRENT_SITE] );

    Описание

    Получение информации о разделах списков

    Принимаемые параметры

    $list_dir_parent_id

    идентификатор родительского раздела

    $site_id

    идентификатор сайта, если равен false - идентификатор сайта не учитывается

    [ Наверх ]

    lists::GetAllListsForSite

GetAllListsForSite(
int
$site_id );

    Описание

    Получение списков определенного сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $resource = $lists->GetAllListsForSite($site_id);
      7.

    7.
      8.

    8.   // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    lists::GetList

GetList(
mixed
$lists_id );

    Описание

    Получение данных о списках

    Принимаемые параметры

    $lists_id

    идентификатор выбираемого списка, если идентификатор равен false, то производится выбор информации о всех списках
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 4;
      5.

    5.
      6.

    6.  $resource = $lists->GetList($lists_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  $row = mysql_fetch_assoc($resource);
      10.

    10.
      11.

    11.  print_r($row);
      12.

    12.  ?>
      13.

    Возвращает

    с данными о выбранных списках

    see

    lists::SelectList()

    [ Наверх ]

    lists::GetListDir

GetListDir(
$list_dir_id
$list_dir_id );

    Описание

    Получение информации о разделе списков

    Принимаемые параметры

    $list_dir_id

    идентификатор раздела списков

    Возвращает

    массив с информацией о разделе списков, если раздел существует или false в противном случае

    [ Наверх ]

    lists::GetListDirPathArray

GetListDirPathArray(
int
$list_dir_id, [array
$return_path_array = array()] );

    Описание

    Построение массива пути от текущего раздела к корневому

    Принимаемые параметры

    $list_dir_id

    идентификатор раздела списков, для которого необходимо построить путь

    $return_path_array

    служебный параметр

    Возвращает

    ассоциативный массив, элементы которого содержат информацию о разделах, составляющих путь от текущего до корневого

    [ Наверх ]

    lists::GetListDirsTree

GetListDirsTree(
int
$list_dir_parent_id, [int
$site_id = CURRENT_SITE], [string
$separator = ''], [int
$list_dir_id = false], [array
$param = array()] );

    Описание

    Формирование дерева разделов списков

    Принимаемые параметры

    $list_dir_parent_id

    идентификатор раздела, относительно которого строится дерево разделов

    $site_id

    идентификатор сайта

    $separator

    символ, отделяющий раздел нижнего уровня от родительского раздела

    $list_dir_id

    идентификатор раздела, который вместе с его подразделами не нужно включать в дерево разделов, если id = false, то включать в дерево разделов все подразделы.

    $param

    дополнительные параметры
    • $param['array'] - служебный элемент
    • $param['sum_separator'] - служебный элемент

    Возвращает

    двумерный массив, содержащий дерево разделов

    [ Наверх ]

    lists::GetListItem

GetListItem(
int
$lists_items_id, [array
$param = array()] );

    Описание

    Получение данных об элементе списка

    Принимаемые параметры

    $lists_items_id

    идентификатор элемента списка

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $lists = & singleton('lists');
        3.

      3.
        4.

      4.  $lists_items_id = 4;
        5.

      5.
        6.

      6.  $row = $lists->GetListItem($lists_items_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с данными об элементе списка или false, если элемент не найден

    [ Наверх ]

    lists::GetListItemIfIssetValue

GetListItemIfIssetValue(
int
$lists_id, string
$list_item_value );

    Описание

    Проверка наличия значения в списке

    Принимаемые параметры

    $lists_id

    идентификатор списка

    $list_item_value

    значение элемента списка
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 4;
      5.

    5.  $list_item_value = 'Значение элемента';
      6.

    6.
      7.

    7.  $row = $lists->GetListItemIfIssetValue($lists_id, $list_item_value);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    информация об элементе списка с таким значением или false, если элемента с данным значением не существует

    [ Наверх ]

    lists::GetListItemsById

GetListItemsById(
int
$lists_id, [array
$param = array()] );

    Описание

    Получение элементов списка в виде массива

    Принимаемые параметры

    $lists_id

    идентификатор списка

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются
    • array $param['item_activity'] array массив значений активности элементов. Может содержать следующие элементы:

    • active - активные элементы (по умолчанию);
    • inactive - неактивные элементы;

    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 8;
      5.

    5.
      6.

    6.  $array = $lists->GetListItemsById($lists_id);
      7.

    7.
      8.

    8.  if (is_array($array) && count($array) > 0)
      9.

    9.  {
      10.

    10.      // Распечатаем результат
      11.

    11.      foreach ($array as $row)
      12.

    12.      {
      13.

    13.          print_r($row);
      14.

    14.      }
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    массив с элементами

    [ Наверх ]

    lists::GetListItemsValuesById

GetListItemsValuesById(
int
$lists_id, [
$param = array()] );

    Описание

    Получение элементов списка в виде resource.

    Принимаемые параметры

    $lists_id

    идентификатор списка
    • array $param['item_activity'] array массив значений активности элементов. Может содержать следующие элементы:

    • active - активные элементы (по умолчанию);
    • inactive - неактивные элементы;

    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 8;
      5.

    5.
      6.

    6.  $resource = $lists->GetListItemsValuesById($lists_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    $param

    Возвращает

    с элементами списка или false

    see

    lists::GetListItemsById()

    [ Наверх ]

    lists::GetListsItems

GetListsItems(
int
$lists_id, [array
$property = array()] );

    Описание

    Получение данных об элементах списка

    Принимаемые параметры

    $lists_id

    идентификатор списка

    $property

    дополнительные свойства
    • $property['orderfield'] - поле сортировки, по умолчанию lists_items_order
    • $property['ordertype'] - направление сортировки, по умолчанию по возрастанию
    • $property['item_activity'] array массив значений активности элементов. Может содержать следующие элементы:

    • active - активные элементы (по умолчанию);
    • inactive - неактивные элементы;

    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 4;
      5.

    5.
      6.

    6.  $rows = $lists->GetListsItems($lists_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($rows);
      10.

    10.
      11.

    11.  ?>
      12.

    Возвращает

    данных об элементах списка

    [ Наверх ]

    lists::InsertList

InsertList(
$param
$param );

    Описание

    Вставка/обновление данных о списке

    Принимаемые параметры

    $param

    массив параметров
    • $param['lists_id'] идентификатор редактируемого списка
    • $param['list_dir_id'] идентификатор раздела
    • $param['lists_name'] название списка
    • $param['lists_description'] описание списка
    • $param['site_id'] идентификатор сайта, к которому относится список. По умолчанию - текущий сайт
    • $param['users_id'] идентификатор пользователя центра администрирования, если false (по умолчанию) - берется текущий пользователь.

    Возвращает

    идентификатор добавленного/измененного списка    или код ошибки.
    Коды ошибок:  -1 - не задано название списка  -2 - сайту уже принадлежит список с переданным названием

    [ Наверх ]

    lists::InsertListDir

InsertListDir(
array
$param );

    Описание

    Добавление/редактирование раздела списков

    Принимаемые параметры

    $param

    массив параметров
    • $param['list_dir_id'] идентификатор изменяемого раздела списков
    • $param['list_dir_parent_id'] идентификатор родительского раздела списков
    • $param['list_dir_name'] название раздела списков
    • $param['list_dir_description'] описание раздела списков
    • $param['site_id'] идентификатор сайта
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

    Возвращает

    идентификатор вставленного/обновленного раздела списков

    [ Наверх ]

    lists::InsertListItem

InsertListItem(
array
$param );

    Описание

    Вставка/обновление данных об элементе списка

    Принимаемые параметры

    $param

    массив параметров
    • $param['lists_items_id'] идентификатор изменяемого элемента списка
    • $param['lists_id'] идетификатор списка, к которому относится вставляемый/обновляемый элемент
    • $param['lists_items_value'] значение элемента списка
    • $param['lists_items_order'] порядок сортировки элемента списка
    • $param['lists_items_description'] описание элемента списка
    • $param['lists_items_active'] активность элемента списка (0 - неактивен, 1 - активен). По умолчанию активен
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $lists = & singleton('lists');
        3.

      3.
        4.

      4.  $param['lists_id'] = 18;
        5.

      5.  $param['lists_items_value'] = 'Значение списка';
        6.

      6.  $param['lists_items_order'] = 10;
        7.

      7.  $param['lists_items_description'] = 'Описание элемента списка';
        8.

      8.
        9.

      9.  $newid = $lists->InsertListItem($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  if ($newid)
        13.

      13.  {
        14.

      14.      echo 'Элемент списка добавлен';
        15.

      15.  }
        16.

      16.  else
        17.

      17.  {
        18.

      18.      echo 'Ошибка! Элемент списка не добавлен!';
        19.

      19.  }
        20.

      20.  ?>
        21.

    Возвращает

    идентификатор вставленного/обновленного элемента списка

    [ Наверх ]

    lists::insert_lists

insert_lists(
int
$type, $lists_id
$lists_id, string
$lists_name, string_type
$lists_description, [int
$users_id = false], [
$site_id = false] );

    Описание

    Устаревший метод. Вставка/обновление данных о списке

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных о списке (0 – вставка, 1 - обновление)

    $lists_name

    название списка

    $lists_description

    описание списка

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $lists_id = 0;
      6.

    6.  $lists_name = 'Новый список';
      7.

    7.  $lists_description = 'Описание списка';
      8.

    8.
      9.

    9.  $newid = $lists->insert_lists($type, $lists_id, $lists_name, $lists_description);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  if ($newid)
      13.

    13.  {
      14.

    14.      echo 'Список добавлен';
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    $lists_id

    идентификатор списка, для которого обновляется информация. При вставке $lists_id = 0

    $site_id

    Возвращает

    идентификатор вставленного/обновленного списка

    see

    lists::InsertList()

    [ Наверх ]

    lists::insert_lists_items

insert_lists_items(
int
$type, int
$lists_items_id, int
$lists_id, int
$lists_items_value, [int
$lists_items_order = 0], [
$lists_items_description = ''], [int
$users_id = false] );

    Описание

    Устаревший метод. Вставка/обновление данных об элементе списка

    Принимаемые параметры

    $type

    параметр, определяющий будет производится вставка или обновление данных об элементе списка (0 – вставка, 1 - обновление)

    $lists_items_id

    идентификатор элемента списка, для которого обновляется информация

    $lists_id

    идетификатор списка, к которому относится вставляемый/обновляемый элемент

    $lists_items_value

    значение элемента списка

    $lists_items_order

    порядок сортировки для элемента списка

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $lists_items_id = 0;
      6.

    6.  $lists_id = 18;
      7.

    7.  $lists_items_value = 'Значение списка';
      8.

    8.  $lists_items_order = 10;
      9.

    9.  $lists_items_description = 'Описание элемента списка';
      10.

    10.
      11.

    11.  $newid = $lists->insert_lists_items($type, $lists_items_id, $lists_id, $lists_items_value, $lists_items_order, $lists_items_description);
      12.

    12.
      13.

    13.  // Распечатаем результат
      14.

    14.  if ($newid)
      15.

    15.  {
      16.

    16.      echo 'Элемент списка добавлен';
      17.

    17.  }
      18.

    18.  else
      19.

    19.  {
      20.

    20.      echo 'Ошибка! Элемент списка не добавлен!';
      21.

    21.  }
      22.

    22.  ?>
      23.

    $lists_items_description

    Возвращает

    идентификатор вставленного/обновленного элемента списка

    see

    lists::InsertListItem()

    [ Наверх ]

    lists::SelectList

SelectList(
mixed
$lists_id, [array
$param = array()] );

    Описание

    Получение данных о списке

    Принимаемые параметры

    $lists_id

    идентификатор выбираемого списка

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $lists = & singleton('lists');
        3.

      3.
        4.

      4.  $lists_id = 4;
        5.

      5.
        6.

      6.  $row = $lists->SelectList($lists_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    массив с данными о списке или false

    [ Наверх ]

    lists::SelectListsItems

SelectListsItems(
int
$lists_id, [array
$property = array()] );

    Описание

    Получение данных об элементах списка

    Принимаемые параметры

    $lists_id

    идентификатор списка

    $property

    дополнительные свойства
    • $property['orderfield'] - поле сортировки, по умолчанию lists_items_order
    • $property['ordertype'] - направление сортировки, по умолчанию по возрастанию
    • $property['item_activity'] array массив значений активности элементов. Может содержать следующие элементы:

    • active - активные элементы (по умолчанию);
    • inactive - неактивные элементы;

    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_id = 4;
      5.

    5.
      6.

    6.  $resource = $lists->SelectListsItems($lists_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    данных об элементах списка

    [ Наверх ]

    lists::select_lists_items

select_lists_items(
mixed
$lists_items_id );

    Описание

    Получение данных об элементе списка

    Принимаемые параметры

    $lists_items_id

    идентификатор выбираемого элемента. Если идетификатор = false или идентификатор = -1 - выбираются все элементы
    1.  <?php
      2.

    2.  $lists = & singleton('lists');
      3.

    3.
      4.

    4.  $lists_items_id = 4;
      5.

    5.
      6.

    6.  $resource = $lists->select_lists_items($lists_items_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  $row = mysql_fetch_assoc($resource);
      10.

    10.
      11.

    11.  print_r($row);
      12.

    12.
      13.

    13.  ?>
      14.

    Возвращает

    данные об элементе списка

    [ Наверх ]

    lists::ShowList

ShowList(
int
$lists_id, string
$xsl_name, [array
$external_propertys = array()] );

    Описание

    Отображение элементов списка. Внутренний метод

    Принимаемые параметры

    $lists_id

    идентификатор списка, элементы которого необходимо отобразить

    $xsl_name

    название XSL-шаблона, используемого для отображения списка

    $external_propertys

    массив дополнительных парметров, добавляемых в XML

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Mail

Class Mail

[Строка 14]

Размещен: /Kernel/Mail.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, Класс "Mail" для получения писем с почтовых серверов.
Файл: /modules/Kernel/Mail.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $email_login =  'hostcms-test'

        Имя ящика (Логин)

  • $email_password =  '346500'

        Пароль ящика пользователя

  • $headers_string =  ''

        Заголовки письма

  • $host =  'pop.yandex.ru'

        Имя хоста

  • $letters = array()

        Массив, содержащий письма

  • $mail_box =  ''

        Почтовый ящик, к которому выполняется доступ

  • $port =  110

        Порт

  • $protocol =  'email_imap'

        Протокол соединения

  • $stream =  ''

        Идентификатор открытого соединения с почтовым сервером

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • str BodyDecode()

    Перекодировщик тела письма

  • void DeleteMessages()

    Удаление всех писем из почтового ящика

  • void GetMailBox()

    Формирование имени почтового ящика

  • array GetMsgList()

    Получение списка писем

  • str HeaderDecode()

    Перекодировщик из кодировки письма в кодировку системы

  • str IconvText()

    Перекодирование текста из кодировки письма в кодировку системы

  • boolean IsBase64Encoded()

    Проверка строки на то, является ли она закодированной base64

  • array ParseHeaderAndBody()

    Разбор тела сообщения

  • void ParseMessage()

    Разбор сообщения по частям

  • str SaveHeaders()

    Сохранение заголовков письма

  • str SaveStructure()

    Сохранение структуры сообщения

  • array StructureToArray()

    Разбор структуры сообщения и сохранение результата в массив

Унаследованные методы

Описания методов

    Mail::BodyDecode

BodyDecode(
str
$str, [str
$encoding_type = ''] );

    Описание

    Перекодировщик тела письма

    Принимаемые параметры

    $str

    Закодированная строка

    $encoding_type

    Тип кодировки

    Возвращает

    Раскодированная строка

    [ Наверх ]

    Mail::DeleteMessages

DeleteMessages(
int
$stream );

    Описание

    Удаление всех писем из почтового ящика

    Принимаемые параметры

    $stream

    Идентификатор открытого соединения с почтовым сервером

    [ Наверх ]

    Mail::GetMailBox

GetMailBox(
[array
$param = array()] );

    Описание

    Формирование имени почтового ящика

    Принимаемые параметры

    $param

    Массив параметров
    • $param['email_pop3'] str Адрес хоста для подключения по протоколу POP3
    • $param['email_imap'] str Адрес хоста для подключения по протоколу IMAP
    • $param['email_login'] str Имя почтового ящика пользователя
    • $param['email_password'] str Пароль к почтовому ящику пользователя
    • $param['secury'] bool Флаг, является ли подключение безопасным

    [ Наверх ]

    Mail::GetMsgList

GetMsgList(
[array
$param = array()] );

    Описание

    Получение списка писем

    Принимаемые параметры

    $param

    Массив параметров
    • $param['email_pop3'] str Адрес хоста для подключения по протоколу POP3
    • $param['email_imap'] str Адрес хоста для подключения по протоколу IMAP
    • $param['email_login'] str Имя почтового ящика пользователя
    • $param['email_password'] str Пароль к почтовому ящику пользователя
    • $param['delete'] bool  Флаг, удалять ли письма после просмотра
    • $param['secury'] bool Флаг, является ли подключение безопасным

    Возвращает

    Массив писем

    [ Наверх ]

    Mail::HeaderDecode

HeaderDecode(
str
$str, [str
$code = ''] );

    Описание

    Перекодировщик из кодировки письма в кодировку системы

    Принимаемые параметры

    $str

    Закодированная строка

    $code

    Тип кодировки

    [ Наверх ]

    Mail::IconvText

IconvText(
str
$text, str
$code );

    Описание

    Перекодирование текста из кодировки письма в кодировку системы

    Принимаемые параметры

    $text

    Текст

    $code

    Исходная кодировка

    [ Наверх ]

    Mail::IsBase64Encoded

IsBase64Encoded(
$string
$string );

    Описание

    Проверка строки на то, является ли она закодированной base64

    Принимаемые параметры

    $string

    строка

    [ Наверх ]

    Mail::ParseHeaderAndBody

ParseHeaderAndBody(
str
$body_letter, str
$bound, array
$part_structure );

    Описание

    Разбор тела сообщения

    Принимаемые параметры

    $body_letter

    Тело сообщения

    $bound

    Разделитель между частями сообщения

    $part_structure

    Структура сообщения

    Возвращает

    Массив с заголовками и телом частей сообщения

    [ Наверх ]

    Mail::ParseMessage

ParseMessage(
int
$i, str
$body_letter, str
$bound, [
$is_first = 0] );

    Описание

    Разбор сообщения по частям

    Принимаемые параметры

    $i

    Порядковый номер письма в ящике

    $body_letter

    Тело сообщения

    $bound

    Разделитель между различными частями тела сообщения

    $is_first

    [ Наверх ]

    Mail::SaveHeaders

SaveHeaders(

$headers,
$code, array
$header );

    Описание

    Сохранение заголовков письма

    Принимаемые параметры

    $header

    Объект, или массив заголовков

    $headers

    $code

    Возвращает

    Строка заголовков

    [ Наверх ]

    Mail::SaveStructure

SaveStructure(
array
$part_structure );

    Описание

    Сохранение структуры сообщения

    Принимаемые параметры

    $part_structure

    Массив со структурой

    [ Наверх ]

    Mail::StructureToArray

StructureToArray(
array
$structure );

    Описание

    Разбор структуры сообщения и сохранение результата в массив

    Принимаемые параметры

    $structure

    Массив со структурой сообщения

    [ Наверх ]

Описания переменных

  • $email_login =  'hostcms-test' [Строка 42]
    •

  • Data type: str
    •

    Описание

    Имя ящика (Логин)

  • $email_password =  '346500' [Строка 49]
    •

  • Data type: str
    •

    Описание

    Пароль ящика пользователя

  • $headers_string =  '' [Строка 77]
    •

  • Data type: str
    •

    Описание

    Заголовки письма

  • $host =  'pop.yandex.ru' [Строка 21]
    •

  • Data type: str
    •

    Описание

    Имя хоста

  • $letters = array() [Строка 70]
    •

  • Data type: array
    •

    Описание

    Массив, содержащий письма

  • $mail_box =  '' [Строка 63]
    •

  • Data type: str
    •

    Описание

    Почтовый ящик, к которому выполняется доступ

  • $port =  110 [Строка 35]
    •

  • Data type: int
    •

    Описание

    Порт

  • $protocol =  'email_imap' [Строка 28]
    •

  • Data type: str
    •

    Описание

    Протокол соединения

  • $stream =  '' [Строка 56]
    •

  • Data type: int
    •

    Описание

    Идентификатор открытого соединения с почтовым сервером

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Maillist

Class Maillist

[Строка 25]

Размещен: /Maillist/Maillist.class.php

Описание

Класс модуля "Почтовые рассылки"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string ApplyMailTemplate()

    Метод осуществляющий шаблонную подстановку в текст письма информации о пользоваетеле сайта

  • boolean CopyFascicle()

    Метод копирования выпуска рассылки

  • mixed CopyMaillist()

    Копирование почтовой рассылки

  • mixed CopyMaillistUsers()

    Копирование связи пользователя с почтовой рассылкой

  • mixed CopyMaillistUsersGroup()

    Копирование связи почтовой рассылки с группой пользователей

  • boolean DeleteFascicleFiles()

    Метод, осуществляющий удаление файла выпуска рассылки

  • resource DeleteUsers()

    Метод снятия подписки с подписчика по его идентификатору пользователя сайта  (УСТАРЕВШИЙ МЕТОД!)

  • resource DeleteUsersFascicle()

    Метод снятия подписки с подписчика по его идентификатору подписчика

  • boolean DeleteUsersGroupFromMaillist()

    Метод закрывающий доступ к рассылке определенной группе пользователей

  • результат DelFascicle()

    Удаление выпуска рассылки

  • результат DelMaillist()

    Удаление рассылки

  • mixed GetAllFascicle()

    Получение списка всех выпусков рассылки

  • resource GetAllFascicleFiles()

    Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки

  • mixed GetAllMaillistsForSite()

    Получение списка почтовых рассылок заданного сайта

  • mixed GetAllMaillistUsers()

    Получение списка связей пользователей с рассылкой

  • mixed GetAllMaillistUsersGroup()

    Получение списка групп пользователей, подписанных на рассылку

  • array GetFascicle()

    Метод возвращает информацию о почтовой рассылке

  • array GetFascicleFiles()

    Метод возвращает информацию о файле выпуска почтовой рассылки

  • array GetMaillist()

    Метод возвращает ассоциативный массив с информацией о списке рассылок

  • выводит GetMaillistXML()

    Устаревший метод генерирующий XML для состояния подписки конкретного пользователя сайта

  • string GetXML4Maillist()

    Генерация XML для почтовой рассылки

  • str HtmlToText()

    Преобразование html в текст

  • mixed InsertFascicle()

    Добавление/редактирование выпуска рассылки

  • int InsertFascicleFiles()

    Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки

  • результат InsertMaillist()

    Добавление/редактирование информации о рассылке

  • boolean InsertUsers()

    Метод добавления/редактирования информации о подписчике

  • boolean InsertUsersGroup()

    Метод, открывающий доступ группе пользователей сайта к рассылке

  • boolean RenewMaillist()

    Метод обновления информации о подписке для конкретного подписчика

  • void ReplaceMacro()

    Производит замену макроподстановки %TEXT в $template_text на переданный текст в $param['text']

  • resource SelectFascicle()

    Получение данных о выпуске рассылки

  • resource SelectMaillist()

    Получение данных о рассылке

  • mixed SelectUser()

    Получение информации о состоянии подписки подписчика на рассылку

  • mixed SendFascicle()

    Метод отправки выпуска всем подписчикам рассылки

  • void ShowMaillist()

    Метод отображения списка почтовых расслок пользователя

Унаследованные методы

Описания методов

    Maillist::ApplyMailTemplate

ApplyMailTemplate(
string
$source_string, array
$site_user_row );

    Описание

    Метод осуществляющий шаблонную подстановку в текст письма информации о пользоваетеле сайта

    Принимаемые параметры

    $source_string

    исходная строка

    $site_user_row

    информация о пользователе сайта
    • Список подстановок:
    • {USER_ID} логин
    • {USER_LOGIN} логин
    • {USER_NAME} имя
    • {USER_SURNAME} фамилия
    • {USER_PATRONYMIC} отчество
    • {USER_EMAIL} e-mail
    • {USER_PHONE} телефон
    • {USER_FAX} факс
    • {USER_SITE} сайт
    • {USER_ICQ} ICQ
    • {USER_COUNTRY} страна
    • {USER_CITY} город
    • {USER_ADDRESS} адрес
    • {USER_POSTCODE} почтовый индекс
    • {USER_DATE_REGISTRATION} дата регистрации

    Возвращает

    результат

    [ Наверх ]

    Maillist::CopyFascicle

CopyFascicle(
int
$fascicle_id, [array
$param = array ()] );

    Описание

    Метод копирования выпуска рассылки

    Принимаемые параметры

    $fascicle_id

    идентификатор выпуска рассылки

    $param

    Массив дополнительных параметров
    • int $param['maillist_id'] Идентификатор рассылки, к которой нужно отнести скопированный выпуск (не обязательный параметр)
    • bool $param['add_copy_info'] Флаг, указывающий, нужно ли к теме выпуска добавлять дату копирования (не обязательный параметр. по умолчанию - true)

      1.  <?php
        2.

      2.  $Maillist = new Maillist();
        3.

      3.
        4.

      4.  $fascicle_id = 1;
        5.

      5.
        6.

      6.  $result = $Maillist->CopyFascicle($fascicle_id);
        7.

      7.
        8.

      8.  if ($result)
        9.

      9.  {
        10.

      10.      echo "Копирование выполнено успешно";
        11.

      11.  }
        12.

      12.  else
        13.

      13.  {
        14.

      14.      echo "Ошибка копирования";
        15.

      15.  }
        16.

      16.  ?>
        17.

    Возвращает

    результат выполнения запроса на добавление

    [ Наверх ]

    Maillist::CopyMaillist

CopyMaillist(
int
$maillist_id, [int
$new_site_id = false] );

    Описание

    Копирование почтовой рассылки

    Принимаемые параметры

    $maillist_id

    Идентификатор копируемой рассылки

    $new_site_id

    Идентификатор сайта, на который следует переместить скопированную почтовую рассылку

    Возвращает

    Идентификатор скопированной рассылки, или false

    [ Наверх ]

    Maillist::CopyMaillistUsers

CopyMaillistUsers(
int
$maillist_users_id, [array
$param = array ()] );

    Описание

    Копирование связи пользователя с почтовой рассылкой

    Принимаемые параметры

    $maillist_users_id

    Идентификатор связи пользователя с почтовой рассылкой

    $param

    Массив дополнительных параметров
    • int $param['maillist_id'] Идентификатор рассылки, к которой нужно отнести скопированную связь (не обязательный параметр)

    Возвращает

    Идентификатор скопированной связи, или false

    [ Наверх ]

    Maillist::CopyMaillistUsersGroup

CopyMaillistUsersGroup(
int
$maillist_users_group_id, [array
$param = array ()] );

    Описание

    Копирование связи почтовой рассылки с группой пользователей

    Принимаемые параметры

    $maillist_users_group_id

    Идентификатор связи группы пользователей с почтовой рассылкой

    $param

    Массив дополнительных параметров
    • int $param['maillist_id'] Идентификатор рассылки, к которой нужно отнести скопированную связь (не обязательный параметр)

    Возвращает

    Идентификатор скопированной связи, или false

    [ Наверх ]

    Maillist::DeleteFascicleFiles

DeleteFascicleFiles(
int
$maillist_fascicle_files_id );

    Описание

    Метод, осуществляющий удаление файла выпуска рассылки

    Принимаемые параметры

    $maillist_fascicle_files_id

    идентификатор файла выпуска рассылки

    Возвращает

    логическое значение, TRUE в случае успешного удаления и FALSE в случае ошибки

    [ Наверх ]

    Maillist::DeleteUsers

DeleteUsers(
int
$user_id, int
$maillist_id );

    Описание

    Метод снятия подписки с подписчика по его идентификатору пользователя сайта  (УСТАРЕВШИЙ МЕТОД!)

    Принимаемые параметры

    $user_id

    идентификатор пользователя сайта

    $maillist_id

    идентификатор

    [ Наверх ]

    Maillist::DeleteUsersFascicle

DeleteUsersFascicle(
int
$user_id, int
$maillist_id );

    Описание

    Метод снятия подписки с подписчика по его идентификатору подписчика

    Принимаемые параметры

    $user_id

    идентификатор подписчика

    $maillist_id

    идентификатор
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 1;
      5.

    5.
      6.

    6.  $result = $Maillist->DeleteUsersFascicle($user_id, $maillist_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Подписка пользователя удалена";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления подписки пользователя на рассылку";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Maillist::DeleteUsersGroupFromMaillist

DeleteUsersGroupFromMaillist(
integer
$maillist_users_group_id );

    Описание

    Метод закрывающий доступ к рассылке определенной группе пользователей

    Принимаемые параметры

    $maillist_users_group_id

    идентификатор группы пользователей
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_users_group_id = 7;
      5.

    5.
      6.

    6.  $result = $Maillist->DeleteUsersGroupFromMaillist($maillist_users_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Доступ закрыт";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка выполнения запроса";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запросов на удаление

    [ Наверх ]

    Maillist::DelFascicle

DelFascicle(
int
$maillist_fascicle_id );

    Описание

    Удаление выпуска рассылки

    Принимаемые параметры

    $maillist_fascicle_id

    идентификатор выпуска рассылки
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_fascicle_id = 2;
      5.

    5.
      6.

    6.  $result = $Maillist->DelFascicle($maillist_fascicle_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    выполнения запроса на удаление

    [ Наверх ]

    Maillist::DelMaillist

DelMaillist(
int
$maillist_id );

    Описание

    Удаление рассылки

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 3;
      5.

    5.
      6.

    6.  $result = $Maillist->DelMaillist($maillist_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удалене выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    выполнения запросов на удаление

    [ Наверх ]

    Maillist::GetAllFascicle

GetAllFascicle(
int
$maillist_id );

    Описание

    Получение списка всех выпусков рассылки

    Принимаемые параметры

    $maillist_id

    Идентификатор почтовой рассылки

    Возвращает

    resource в случае успешного выполнения, или false

    [ Наверх ]

    Maillist::GetAllFascicleFiles

GetAllFascicleFiles(
int
$maillist_fascicle_id );

    Описание

    Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки

    Принимаемые параметры

    $maillist_fascicle_id

    идентификатор выпуска почтовой рассылки

    Возвращает

    ответ базы

    [ Наверх ]

    Maillist::GetAllMaillistsForSite

GetAllMaillistsForSite(
int
$site_id );

    Описание

    Получение списка почтовых рассылок заданного сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    resource или False

    [ Наверх ]

    Maillist::GetAllMaillistUsers

GetAllMaillistUsers(
int
$maillist_id );

    Описание

    Получение списка связей пользователей с рассылкой

    Принимаемые параметры

    $maillist_id

    Идентификатор почтовой рассылки

    Возвращает

    resource в случае успешного выполнения, или false

    [ Наверх ]

    Maillist::GetAllMaillistUsersGroup

GetAllMaillistUsersGroup(
int
$maillist_id );

    Описание

    Получение списка групп пользователей, подписанных на рассылку

    Принимаемые параметры

    $maillist_id

    Идентификатор почтовой рассылки

    Возвращает

    resource в случае успешного выполнения, или false

    [ Наверх ]

    Maillist::GetFascicle

GetFascicle(
int
$maillist_fascicle_id );

    Описание

    Метод возвращает информацию о почтовой рассылке

    Принимаемые параметры

    $maillist_fascicle_id

    идентификатор рассылки
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_fascicle_id = 1;
      5.

    5.
      6.

    6.  $row = $Maillist->GetFascicle($maillist_fascicle_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    с информацией о рассылке или false

    [ Наверх ]

    Maillist::GetFascicleFiles

GetFascicleFiles(
int
$maillist_fascicle_files_id );

    Описание

    Метод возвращает информацию о файле выпуска почтовой рассылки

    Принимаемые параметры

    $maillist_fascicle_files_id

    идентификатор файла почтовой рассылки

    Возвращает

    с информацией о файле или false

    [ Наверх ]

    Maillist::GetMaillist

GetMaillist(
int
$maillist_id );

    Описание

    Метод возвращает ассоциативный массив с информацией о списке рассылок

    Принимаемые параметры

    $maillist_id

    идентификатор списка рассылок
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 1;
      5.

    5.
      6.

    6.  $row = $Maillist->GetMaillist($maillist_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    с результатом выборки или false

    [ Наверх ]

    Maillist::GetMaillistXML

GetMaillistXML(
int
$site_user_id, string
$xslname, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Устаревший метод генерирующий XML для состояния подписки конкретного пользователя сайта

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя сайта

    $xslname

    имя XSL шаблона

    $param

    массив дополнительных параметров
    • $param['site_id'] идентификатор сайта, для которого выбираюттся рассылки. Если не указан - выбираются с текущего сайта.

    $external_propertys

    внешние параметры, передаваемы в XML

    Возвращает

    на экран HTML код

    [ Наверх ]

    Maillist::GetXML4Maillist

GetXML4Maillist(
int
$site_user_id, [int
$external_propertys = array ()], [array
$param = array ()] );

    Описание

    Генерация XML для почтовой рассылки

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя сайта

    $external_propertys

    массив дополнительных параметров

    $param

    массив дополнительных параметров
    • $param['site_id'] идентификатор сайта, для которого выбираюттся рассылки. Если не указан - выбираются с текущего сайта.

      1.  <?php
        2.

      2.  $Maillist = new Maillist();
        3.

      3.
        4.

      4.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        5.

      5.  if (class_exists('SiteUsers'))
        6.

      6.  {
        7.

      7.      $SiteUsers = & singleton('SiteUsers');
        8.

      8.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        9.

      9.  }
        10.

      10.  else
        11.

      11.  {
        12.

      12.      $site_users_id = 0;
        13.

      13.  }
        14.

      14.
        15.

      15.  $xml = $Maillist->GetXML4Maillist($site_users_id);
        16.

      16.
        17.

      17.  echo htmlspecialchars($xml);
        18.

      18.  ?>
        19.

    [ Наверх ]

    Maillist::HtmlToText

HtmlToText(
str
$str_html );

    Описание

    Преобразование html в текст

    Принимаемые параметры

    $str_html

    html текст

    Возвращает

    строка в текстовом формате

    [ Наверх ]

    Maillist::InsertFascicle

InsertFascicle(
int
$maillist_id, int
$maillist_fascicle_id, int
$maillist_htmltotext, string
$maillist_fascicle_theme, string
$maillist_fascicle_text, string
$maillist_fascicle_html, int
$maillist_fascicle_edited, [int
$users_id = false] );

    Описание

    Добавление/редактирование выпуска рассылки

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $maillist_fascicle_id

    идентификатор выпуска рассылки, если вставка, то 0

    $maillist_htmltotext

    строить ли текстовую версию на основе HTML

    $maillist_fascicle_theme

    тема выпуска

    $maillist_fascicle_text

    текстовая версия выпуска

    $maillist_fascicle_html

    HTML версия выпуска

    $maillist_fascicle_edited

    рассылка отредактирована

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 2;
      5.

    5.  $maillist_fascicle_id = 1;
      6.

    6.  $maillist_htmltotext = 0;
      7.

    7.  $maillist_fascicle_theme = 'Тема рассылки';
      8.

    8.  $maillist_fascicle_text = 'HTML-текст рассылки';
      9.

    9.  $maillist_fascicle_html = 'Текстовая версия рассылки';
      10.

    10.  $maillist_fascicle_html = 'Текстовая версия рассылки';
      11.

    11.  $maillist_fascicle_edited = 0;
      12.

    12.
      13.

    13.  $newid = $Maillist->InsertFascicle($maillist_id, $maillist_fascicle_id,
      14.

    14.  $maillist_htmltotext, $maillist_fascicle_theme, $maillist_fascicle_text,
      15.

    15.  $maillist_fascicle_html, $maillist_fascicle_edited);
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  if ($newid)
      19.

    19.  {
      20.

    20.      echo 'Выпуск рассылки изменен';
      21.

    21.  }
      22.

    22.  else
      23.

    23.  {
      24.

    24.      echo 'Ошибка! Выпуск рассылки не изменен!';
      25.

    25.  }
      26.

    26.  ?>
      27.

    Возвращает

    результат выполнение запроса:
      int идентификатор добавленного выпуска;
      boolean результат выполнения запроса на обновление

    [ Наверх ]

    Maillist::InsertFascicleFiles

InsertFascicleFiles(
array
$param );

    Описание

    Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['maillist_fascicle_files_id'] идентификатор обновляемой записи
    • int $param['maillist_fascicle_id'] идентификатор выпуска почтовой рассылки
    • int $param['maillist_fascicle_files_name'] Название файла
    • int $param['users_id'] идентификатор владельца записи (пользователь центра администрирования, используется только при добавлении данных)

    Возвращает

    идентификатор вставленного товара в заказ

    [ Наверх ]

    Maillist::InsertMaillist

InsertMaillist(
$param
$param );

    Описание

    Добавление/редактирование информации о рассылке

    Принимаемые параметры

    $param

    массив парметров
    • int $param['maillist_id'] идентификатор рассылки
    • string $param['maillist_name'] имя рассылки
    • string $param['maillist_description'] описание рассылки
    • string $param['$maillist_sender_email'] почтовый адрес рассылки
    • int $param['maillist_order'] порядок сортировки
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
    • int $param['maillist_sender_name'] название отправителя

      1.  <?php
        2.

      2.  $Maillist = new Maillist();
        3.

      3.
        4.

      4.  $param['maillist_name'] = 'Новая рассылка';
        5.

      5.  $param['maillist_description'] = 'Описание рассылки';
        6.

      6.  $param['$maillist_sender_email'] = 'admin@site.ru';
        7.

      7.  $param['maillist_order'] = 10;
        8.

      8.
        9.

      9.  $result = $Maillist->InsertMaillist($param);
        10.

      10.
        11.

      11.  if ($result)
        12.

      12.  {
        13.

      13.      echo "Рассылка создана";
        14.

      14.  }
        15.

      15.  else
        16.

      16.  {
        17.

      17.      echo "Ошибка создания рассылки";
        18.

      18.  }
        19.

      19.  ?>
        20.

    Возвращает

    выполнения запроса

    [ Наверх ]

    Maillist::InsertUsers

InsertUsers(
int
$maillist_id, int
$site_user_id, int
$value );

    Описание

    Метод добавления/редактирования информации о подписчике

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $site_user_id

    идентификатор пользователя сайта

    $value

    тип подписки (0 - текст, 1 - HTML)
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 1;
      5.

    5.  $site_user_id = '';
      6.

    6.  $value = 0;
      7.

    7.
      8.

    8.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      9.

    9.  if (class_exists('SiteUsers'))
      10.

    10.  {
      11.

    11.      $SiteUsers = & singleton('SiteUsers');
      12.

    12.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      $site_users_id = 0;
      17.

    17.  }
      18.

    18.
      19.

    19.  $result = $Maillist->InsertUsers($maillist_id, $site_user_id, $value);
      20.

    20.
      21.

    21.  if ($result)
      22.

    22.  {
      23.

    23.      echo "Запрос выполнен успешно";
      24.

    24.  }
      25.

    25.  else
      26.

    26.  {
      27.

    27.      echo "Ошибка выполнения запроса";
      28.

    28.  }
      29.

    29.  ?>
      30.

    Возвращает

    результат выполнения запроса на добавление/редактирование

    [ Наверх ]

    Maillist::InsertUsersGroup

InsertUsersGroup(
int
$maillist_id, int
$site_users_group_id );

    Описание

    Метод, открывающий доступ группе пользователей сайта к рассылке

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $site_users_group_id

    идентификатор группы пользователей
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 1;
      5.

    5.  $site_users_group_id = 7;
      6.

    6.
      7.

    7.  $result = $Maillist->InsertUsersGroup($maillist_id, $site_users_group_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.     echo "Доступ открыт";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка выполнения запроса";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    результат выполнения запроса на вставку

    [ Наверх ]

    Maillist::RenewMaillist

RenewMaillist(
int
$site_users_id, array
$array );

    Описание

    Метод обновления информации о подписке для конкретного подписчика

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $array

    массив значений состояния подписки:
      $array['value'.$maillist_id] int тип подписки (0 - текст, 1 - HTML)

    Возвращает

    результат обновления состояния подписки

    [ Наверх ]

    Maillist::ReplaceMacro

ReplaceMacro(
str
$template_text, [array
$param = array()] );

    Описание

    Производит замену макроподстановки %TEXT в $template_text на переданный текст в $param['text']

    Принимаемые параметры

    $template_text

    шаблон

    $param

    массив замен
    • str $param['text'] текст

    [ Наверх ]

    Maillist::SelectFascicle

SelectFascicle(
int
$maillist_fascicle_id );

    Описание

    Получение данных о выпуске рассылки

    Принимаемые параметры

    $maillist_fascicle_id

    идентификатор выпуска рассылки
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_fascicle_id = 1;
      5.

    5.
      6.

    6.  $resource = $Maillist->SelectFascicle($maillist_fascicle_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выполнения запроса на выборку

    [ Наверх ]

    Maillist::SelectMaillist

SelectMaillist(
int
$maillist_id, [array
$param = array()] );

    Описание

    Получение данных о рассылке

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки (-1 или false - выбрать все рассылки)

    $param

    массив дополнительных параметров
    • int $param['site_id'] идентификатор сайта, рассылки которого необходимо выбрать

      1.  <?php
        2.

      2.  $Maillist = new Maillist();
        3.

      3.
        4.

      4.  $maillist_id = 1;
        5.

      5.
        6.

      6.  $resource = $Maillist->SelectMaillist($maillist_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  $row = mysql_fetch_assoc($resource);
        10.

      10.
        11.

      11.  print_r($row);
        12.

      12.
        13.

      13.  ?>
        14.

    Возвращает

    результат выполнения запроса на выборку

    [ Наверх ]

    Maillist::SelectUser

SelectUser(
int
$site_users_id, int
$maillist_id );

    Описание

    Получение информации о состоянии подписки подписчика на рассылку

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $maillist_id

    идентификатор рассылки
    1.  <?php
      2.

    2.  $Maillist = new Maillist();
      3.

    3.
      4.

    4.  $maillist_id = 1;
      5.

    5.
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      $site_users_id = 0;
      15.

    15.  }
      16.

    16.
      17.

    17.  $row = $Maillist->SelectUser($site_users_id, $maillist_id);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  print_r ($row);
      21.

    21.  ?>
      22.

    Возвращает

    результат запроса на выборку:
      array массив данных о состоянии подписки  $result[0] Ф.И.О подписчика  $result[1] тип подписки (0 - текст, 1 - HTML)  $result[2] логин пользователя  boolean false если информация не найдена

    [ Наверх ]

    Maillist::SendFascicle

SendFascicle(
int
$fascicle_id, [array
$param = array ()] );

    Описание

    Метод отправки выпуска всем подписчикам рассылки

    Принимаемые параметры

    $fascicle_id

    идентификатор выпуска рассылки

    $param

    массив с доп. параметрами
    • int $param['test'] рассылка тестовая и отправляется автору
    • int $param['from'] выборка подписчиков с from номера
    • int $param['count'] количество результатов запроса

      1.  <?php
        2.

      2.  $Maillist = new Maillist();
        3.

      3.
        4.

      4.  $fascicle_id = 1;
        5.

      5.
        6.

      6.  $row = $Maillist->SendFascicle($fascicle_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    результат отправки писем
      array результат успешной отправки:  $result[0] количество подписчиков;
      $result[1] количество успешных отправок  boolean false результат неудачной отправки

    [ Наверх ]

    Maillist::ShowMaillist

ShowMaillist(
string
$xslname, [int
$site_user_id = false], [array
$external_propertys = array ()], [array
$param = array ()] );

    Описание

    Метод отображения списка почтовых расслок пользователя

    Принимаемые параметры

    $xslname

    имя XSL-шаблона

    $site_user_id

    идентификатор пользователя сайта, по умолчанию false - определяется вручную

    $external_propertys

    внешние параметры, передаваемы в XML

    $param

    - $param['site_id'] идентификатор сайта, для которого выбираюттся рассылки. Если не указан - выбираются с текущего сайта.

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class messages

Class messages

[Строка 2]

Размещен: /messages/messages.class.php

Свойства класса

  • $CacheMessages = array()

        Кэш сообщений

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean AccessSiteUserToMessage()

    Проверка доступа пользователя сайта к сообщению

  • boolean ChangeMessagesReadStatus()

    Метод изменения статуса сообщения "прочитано"/"не прочитано"

  • resource DeleteSiteUsersMail()

    Удаление сообщения

  • int GetCountUnreadMessages()

    Получение количества не прочитанных сообщений

  • mixed GetMessage()

    Получение информации о сообщении

  • mixed GetXMLForMessage()

    Формирование XML сообщения

  • mixed InsertSiteUsersMail()

    Вставка/обновление сообщения

  • boolean MarkEraseSiteUsersMail()

    Удаление сообщения пользователем сайта

  • boolean RecalcMessagesInfo()

    Метод пересчёта информации о дереве сообщений

  • boolean ShowMessages()

    Вывод личных сообщений пользователя сайта

Унаследованные методы

Описания методов

    messages::AccessSiteUserToMessage

AccessSiteUserToMessage(
int
$site_users_mail_id, int
$site_user_id );

    Описание

    Проверка доступа пользователя сайта к сообщению

    Принимаемые параметры

    $site_users_mail_id

    идентификатор родительского сообщения

    $site_user_id

    идентификатор пользователя сайта

    Возвращает

    TRUE если пользователь имеет доступ к сообщению, иначе NULL

    [ Наверх ]

    messages::ChangeMessagesReadStatus

ChangeMessagesReadStatus(
int
$site_users_mail_id, [array
$param = array('read_status' => 1)] );

    Описание

    Метод изменения статуса сообщения "прочитано"/"не прочитано"

    Принимаемые параметры

    $site_users_mail_id

    идентификатор сообщения

    $param

    массив параметров
    • int $param['read_status'] статус сообщения 0 - "не прочитано", 1 - "прочитано" (по умолчанию)
    • int $param['all'] параметр определяем изменение статуса. Если 0 - для одного сообщения(по умолчанию), 1 - всех сообщения в переписке
    • int $param['site_users_id'] идентификатор пользователя сайта, которым просмотрено сообщение. Если не передан определяется автоматически.

    Возвращает

    true - в случае удачного выполнения, иначе null

    [ Наверх ]

    messages::DeleteSiteUsersMail

DeleteSiteUsersMail(
int
$site_users_mail_id );

    Описание

    Удаление сообщения

    Принимаемые параметры

    $site_users_mail_id

    идентификатор сообщения

    [ Наверх ]

    messages::GetCountUnreadMessages

GetCountUnreadMessages(
int
$site_users_mail_id, int
$site_user_id );

    Описание

    Получение количества не прочитанных сообщений

    Принимаемые параметры

    $site_users_mail_id

    идентификатор родительского сообщения

    $site_user_id

    идентификатор пользователя сайта

    Возвращает

    количество не прочитанных сообщений

    [ Наверх ]

    messages::GetMessage

GetMessage(
int
$site_users_mail_id );

    Описание

    Получение информации о сообщении

    Принимаемые параметры

    $site_users_mail_id

    идентификатор сообщения

    Возвращает

    массив данных, либо null если сообщения не существует

    [ Наверх ]

    messages::GetXMLForMessage

GetXMLForMessage(
int
$site_users_mail_id );

    Описание

    Формирование XML сообщения

    Принимаемые параметры

    $site_users_mail_id

    идентификатор сообщения

    Возвращает

    XML сообщения, либо NULL если сообщения не существует

    [ Наверх ]

    messages::InsertSiteUsersMail

InsertSiteUsersMail(
array
$param );

    Описание

    Вставка/обновление сообщения

    Принимаемые параметры

    $param

    массив параметров
    • int $param['site_users_mail_id'] идентификатор сообщения
    • str $param['site_users_mail_datetime'] время сообщения, если не передано - берется текущее время сервера
    • int $param['site_users_mail_from_id'] идентификатор пользователя (отправитель)
    • int $param['site_users_mail_to_id'] идентификатор пользователя (получатель)
    • str $param['site_users_mail_subject'] тема сообщения
    • str $param['site_users_mail_text'] текст сообщения
    • int $param['site_users_mail_read'] прочитано ли сообщение (1 - прочитано, 0 - не прочитано)
    • int $param['site_users_mail_deleted_by_sender'] сообщение удалено отправителем (1 - удалено, 0 - не удалено)
    • int $param['site_users_mail_deleted_by_recipient'] сообщение удалено получателем (1 - удалено, 0 - не удалено)
    • int $param['site_users_mail_answer_to_mail_id'] идентификатор родительского сообщения

    Возвращает

    идентификатор вставленной/обновленной записи, либо NULL

    [ Наверх ]

    messages::MarkEraseSiteUsersMail

MarkEraseSiteUsersMail(
int
$site_users_mail_id, int
$site_users_id );

    Описание

    Удаление сообщения пользователем сайта

    Принимаемые параметры

    $site_users_mail_id

    идентификатор сообщения

    $site_users_id

    идентификатор пользователя

    [ Наверх ]

    messages::RecalcMessagesInfo

RecalcMessagesInfo(
int
$site_users_mail_id, [array
$param = array()] );

    Описание

    Метод пересчёта информации о дереве сообщений

    Принимаемые параметры

    $site_users_mail_id

    идентификатор сообщения

    $param

    массив параметров
    • bool $param['undelete'] если true - отменяет удаление переписки, по умолчанию false

    Возвращает

    true - в случае удачного выполнения, иначе null

    [ Наверх ]

    messages::ShowMessages

ShowMessages(
array
$param );

    Описание

    Вывод личных сообщений пользователя сайта

    Принимаемые параметры

    $param

    масиив параметров
    • int $param['site_users_mail_id'] идентификатор сообщения, если 0 - выводится список диалогов
    • int $param['site_users_id'] идентификатор пользователя сайта
    • bool $param['show_external_property_for_user'] выводить в XML информацию о дополнительных свойствах пользователя сайта(true - выводить, false - не выводить). По умолчанию - false.
    • int $param['after_message_id'] идентификатор сообщения, выводить в XML информацию только о сообщениях отправленных после переданного
    • int $param['limit_from'] порядковый номер сообщения, с которого начинать вывод сообщений
    • int $param['limit_count'] количество выводимых сообщений. По умолчанию 15.
    • array $param['external_properties'] массив параметров для передачи в XML

    [ Наверх ]

Описания переменных

  • $CacheMessages = array() [Строка 9]
    •

  • Data type: array
    •

    Описание

    Кэш сообщений

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class modules

Class modules

[Строка 27]

Размещен: /Modules/Modules.class.php

Описание

Класс модуля "Управление модулями"

Свойства класса

  • $error =

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • resource del_module()

    Метод удаления информации о модуле

  • array GetModule()

    Получение информации о модуле

  • int insert_module()

    Метод вставки/обновления информации о модуле

  • boolean IssetModule()

    Метод проверки наличия активного модуля

  • resource select_modules()

    Получение информации о модуле

Унаследованные методы

Описания методов

    modules::del_module

del_module(
int
$modules_id );

    Описание

    Метод удаления информации о модуле

    Принимаемые параметры

    $modules_id

    идентификатор удаляемого модуля
    1.  <?php
      2.

    2.  $modules = & singleton('modules');
      3.

    3.
      4.

    4.  $modules_id = 78;
      5.

    5.
      6.

    6.  $result = $modules->del_module($modules_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат запроса на удаление модуля

    [ Наверх ]

    modules::GetModule

GetModule(
int
$modules_id );

    Описание

    Получение информации о модуле

    Принимаемые параметры

    $modules_id

    – идентификатор модуля
    1.  <?php
      2.

    2.  $modules = & singleton('modules');
      3.

    3.
      4.

    4.  $modules_id = 63;
      5.

    5.
      6.

    6.  $row = $modules->GetModule($modules_id);
      7.

    7.
      8.

    8.  print_r($row);
      9.

    9.  ?>
      10.

    Возвращает

    информация о модуле

    [ Наверх ]

    modules::insert_module

insert_module(
int
$type, int
$modules_id, string
$modules_name, string
$modules_description, string
$modules_status, string
$modules_path, int
$modules_order, [int
$users_id = false] );

    Описание

    Метод вставки/обновления информации о модуле

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации о модуле (0 – вставка, 1 - обновление)

    $modules_id

    – идентификатор обновляемого модуля (при вставке равен 0)

    $modules_name

    - название модуля

    $modules_description

    – описание модуля

    $modules_status

    - флаг активности (доступности) модуля (1 – модуль активен (доступен), 0 – модуль неактивен)

    $modules_path

    – директория размещения модуля

    $modules_order

    – порядковый номер модуля в списке сортировки модулей

    $users_id

    – идентификатор пользователя центра администрирования, котрый добавил элемент
    1.  <?php
      2.

    2.  $modules = & singleton('modules');
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $modules_id = 0;
      6.

    6.  $modules_name = 'Новый модуль';
      7.

    7.  $modules_description = 'Описание модуля';
      8.

    8.  $modules_status = 0;
      9.

    9.  $modules_path = 'newmodul';
      10.

    10.  $modules_order = 0;
      11.

    11.
      12.

    12.  $newid = $modules->insert_module($type, $modules_id, $modules_name, $modules_description, $modules_status, $modules_path, $modules_order);
      13.

    13.
      14.

    14.  // Распечатаем результат
      15.

    15.  echo ($newid);
      16.

    16.  ?>
      17.

    Возвращает

    идентификатор добавляемого/редактируемого модуля

    [ Наверх ]

    modules::IssetModule

IssetModule(
string
$module_path );

    Описание

    Метод проверки наличия активного модуля

    Принимаемые параметры

    $module_path

    – название модуля, например Search
    1.  <?php
      2.

    2.  $modules = & singleton('modules');
      3.

    3.
      4.

    4.  $module_path = 'Site_users';
      5.

    5.
      6.

    6.  $result = $modules->IssetModule($module_path);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Модуль существует и активен";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Модуль не существует или он не активен";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true - модуль существует и активен, false – модуль не существует или он не активен.

    [ Наверх ]

    modules::select_modules

select_modules(
int
$modules_id );

    Описание

    Получение информации о модуле

    Принимаемые параметры

    $modules_id

    – идентификатор модуля (если $modules_id = -1 получаем информацию о всех модулях системы)
    1.  <?php
      2.

    2.  $modules = & singleton('modules');
      3.

    3.
      4.

    4.  $modules_id = 63;
      5.

    5.
      6.

    6.  $resource = $modules->select_modules($modules_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    информация о модуле (модулях)

    [ Наверх ]

Описания переменных

  • $error =  [Строка 29]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class DataBase

Class DataBase

[Строка 34]

Размещен: /Kernel/Mysql.class.php

Описание

Ядро, класс для работы с СУБД

Свойства класса

  • $count_row =

        Количество выбранных строк в последнем запросе

  • $db_connect =  false

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void __destruct()

  • void db_close()

    Закрывает соединение $this->db_connect

  • boolean db_connect()

    Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.

  • resource Delete()

    Удаление записей из таблиц.

  • unknown GetLastInsertId()

    Возвращает ID, сгенерированный колонкой с AUTO_INCREMENT последним запросом INSERT к серверу

  • int get_count_row()

    Метод возвращает количество строк в последнем запросе

  • void HighlightSql()

  • resource Insert()

    Вставка записи в таблицу.

  • resource query()

    Метод выполнения SQL-запроса

  • resource select()

    Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()

  • resource Update()

    Обновление записей в таблицах.

Унаследованные методы

Описания методов

    DataBase::__destruct

__destruct(
 );

    [ Наверх ]

    DataBase::db_close

db_close(
 );

    Описание

    Закрывает соединение $this->db_connect

    [ Наверх ]

    DataBase::db_connect

db_connect(
 );

    Описание

    Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.

    1.  <?php
      2.

    2.  $DataBase = & singleton('DataBase');
      3.

    3.
      4.

    4.  $result = $DataBase->db_connect();
      5.

    5.
      6.

    6.  if ($result)
      7.

    7.  {
      8.

    8.      echo "Соединение с БД прошло успешно";
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Соединение с БД не выполнено";
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    DataBase::Delete

Delete(
string
$table, [string
$expr = ''] );

    Описание

    Удаление записей из таблиц.

    Пример использования:
    1.  <?php
      2.

    2.
      3.

    3.  $DataBase = & singleton('DataBase');
      4.

    4.  $DataBase->Delete('my_table', "`my_table_field3` = '777'");
      5.

    5.
      6.

    6.  // В результате будет выполнен следующий запрос:
      7.

    7.  // DELETE FROM `my_table` WHERE `my_table_field3` = '777'
      8.

    8.
      9.

    9.  ?>
      10.

    Принимаемые параметры

    $table

    имя таблицы

    $expr

    условие для WHERE

    [ Наверх ]

    DataBase::GetLastInsertId

GetLastInsertId(
 );

    Описание

    Возвращает ID, сгенерированный колонкой с AUTO_INCREMENT последним запросом INSERT к серверу

    [ Наверх ]

    DataBase::get_count_row

get_count_row(
 );

    Описание

    Метод возвращает количество строк в последнем запросе

    1.  <?php
      2.

    2.  $DataBase = & singleton('DataBase');
      3.

    3.
      4.

    4.  $count = $DataBase->get_count_row();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    кличество строк, возвращенных последним запросом, выполненным методом select()

    [ Наверх ]

    DataBase::HighlightSql

HighlightSql(

$sql );

    Принимаемые параметры

    $sql

    [ Наверх ]

    DataBase::Insert

Insert(
string
$table, array
$fields );

    Описание

    Вставка записи в таблицу.

    Пример использования:
    1.  <?php
      2.

    2.
      3.

    3.  $DataBase = & singleton('DataBase');
      4.

    4.
      5.

    5.  $DataBase->Insert('my_table', array('my_table_field1' => 123, 'my_table_field2' => 'Значение "второго" поля'));
      6.

    6.
      7.

    7.  // В результате будет выполнен следующий запрос:
      8.

    8.  // INSERT INTO `my_table` (`my_table_field1`,`my_table_field2`) VALUES ('123', 'Значение \"второго\" поля')
      9.

    9.
      10.

    10.  ?>
      11.

    Принимаемые параметры

    $table

    имя таблицы

    $fields

    массив полей, при этом кючи массива - имена полей, значения - значения полей

    [ Наверх ]

    DataBase::query

query(
string
$query );

    Описание

    Метод выполнения SQL-запроса

    Принимаемые параметры

    $query

    SQL-запрос
    1.  <?php
      2.

    2.  $DataBase = & singleton('DataBase');
      3.

    3.
      4.

    4.  $query = "SELECT * FROM structure_table WHERE structure_id = ".CURRENT_STRUCTURE_ID;
      5.

    5.
      6.

    6.  $result = $DataBase->query($query);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      // Распечатаем результат
      11.

    11.      while($row = mysql_fetch_assoc($result))
      12.

    12.      {
      13.

    13.         print_r($row);
      14.

    14.      }
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Ошибка выполнения запроса";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    DataBase::select

select(
string
$query );

    Описание

    Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()

    Принимаемые параметры

    $query

    SQL-запрос
    1.  <?php
      2.

    2.  $DataBase = & singleton('DataBase');
      3.

    3.
      4.

    4.  $query = "SELECT * FROM structure_table WHERE structure_id = ".CURRENT_STRUCTURE_ID;
      5.

    5.
      6.

    6.  $result = $DataBase->select($query);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      // Распечатаем результат
      11.

    11.      while($row = mysql_fetch_assoc($result))
      12.

    12.      {
      13.

    13.         print_r($row);
      14.

    14.      }
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      echo "Ошибка выполнения запроса";
      19.

    19.  }
      20.

    20.  ?>
      21.

    [ Наверх ]

    DataBase::Update

Update(
string
$table, array
$fields, [string
$expr = ''] );

    Описание

    Обновление записей в таблицах.

    Пример использования:
    1.  <?php
      2.

    2.  $DataBase = & singleton('DataBase');
      3.

    3.
      4.

    4.  $DataBase->Update('my_table', array('my_table_field1' => 123, 'my_table_field2' => 'Значение "второго" поля'), "`my_table_field3` = '777'");
      5.

    5.
      6.

    6.  // В результате будет выполнен следующий запрос:
      7.

    7.  // UPDATE `my_table` SET `my_table_field1` = '123', `my_table_field2` = 'Значение \"второго\" поля' WHERE `my_table_field3` = '777'
      8.

    8.  ?>
      9.

    Принимаемые параметры

    $table

    имя таблицы

    $fields

    массив полей, при этом кючи массива - имена полей, значения - значения полей

    $expr

    условие для WHERE

    [ Наверх ]

Описания переменных

  • $count_row =  [Строка 41]
    •

  • Data type: int
    •

    Описание

    Количество выбранных строк в последнем запросе

  • $db_connect =  false [Строка 49]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class polls

Class polls

[Строка 22]

Размещен: /Polls/Polls.class.php

Описание

Класс модуля "Опросы"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed CopyPoll()

    Копирование опроса

  • mixed CopyPollGroup()

    Копирование группы опросов

  • mixed CopyPollReply()

    Копирование ответа на опрос

  • boolean DelPollsGroup()

    Метод удаления групп опросов

  • boolean del_poll()

    Метод удаления опроса

  • boolean del_poll_reply()

    Метод удаления варианта ответа

  • string GenXml4Poll()

    Формирование XML для опроса

  • resource GetAllPollReply()

    Получение списка всех ответов на опрос

  • array GetAllPolls()

    Получение информации обо всех опросах

  • array GetAllPollsGroups()

    Получение информации о всех группах опросов

  • int GetCountPolls()

    Получение числа опросов в группе

  • int GetCountPollsGroup()

    Получение числа групп опросов для одного или всех сайтов

  • array GetGroupPollsWithConditions()

    Метод для получения списка групп с запросами по условиям

  • mixed GetPoll()

    Метод возвращает данные об опросе

  • array GetPollsGroup()

    Получение информации о группе опросов

  • string get_polls_name()

    Получение названия опроса

  • bool IncPollReply()

    Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote

  • mixed InsertGroupPolls()

    Вставка информации о группе опросов

  • boolean InsertVote()

    Устаревший метод. Вставка ответа на опрос.

  • mixed insert_poll()

    Вставка и обновление опроса

  • int insert_poll_reply()

    Вставка и обновление вариантов ответов

  • resource SelectPollReply4Poll()

    Получение списка вариантов ответов на опрос по ID опроса

  • resource select_poll()

    Метод осуществляет выборку опросов

  • resource select_poll_reply()

    Метод выбора вариантов ответов по ID ответа

  • void ShowPoll()

    Метод отображения опроса

  • void ShowPollResult()

    Устаревший метод вывода результатов голосования

  • void ShowPolls()

    Устаревший метод! Метод отображения всех активных опросов

  • void ShowPollsGroup()

    Отображение групп опросов

  • mixed UpdateGroupPolls()

    Метод обновления информаци о группе опросов

  • void vote_result()

    Устаревший метод

Унаследованные методы

Описания методов

    polls::CopyPoll

CopyPoll(
int
$poll_id, [array
$param = array()] );

    Описание

    Копирование опроса

    Принимаемые параметры

    $poll_id

    Идентификатор опроса

    $param

    Массив дополнительных параметров
    • int $param['poll_group_id'] Идентификатор группы, к которой необходимо отнести скопированные опросы (Не обязательный параметр)
    • bool $param['add_copydate'] Флаг, указывающий, добавлять ли дату копирования к имени опроса. (Не обязательный параметр. По уполчанию - true)

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $poll_id = 1;
        5.

      5.
        6.

      6.  $newid = $polls->CopyPoll($poll_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $newid;
        10.

      10.  ?>
        11.

    Возвращает

    Идентификатор скопированной записи или false

    [ Наверх ]

    polls::CopyPollGroup

CopyPollGroup(
int
$poll_group_id, [int
$site_id = false], [int
$new_structure_id = false] );

    Описание

    Копирование группы опросов

    Принимаемые параметры

    $poll_group_id

    Идентификатор группы опросов

    $site_id

    идентификатор сайта, на который нужно скопировать группу опросов, если не передан, берется текущий

    $new_structure_id

    идентификатор структуры, которой будет присвоена скопированная группа опросов, если не передан, берется текущая
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_group_id = 1;
      5.

    5.
      6.

    6.  $newid = $polls->CopyPollGroup($poll_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    Возвращает

    Идентификатор скопированной записи или false

    [ Наверх ]

    polls::CopyPollReply

CopyPollReply(
int
$poll_reply_id, [array
$param = array()] );

    Описание

    Копирование ответа на опрос

    Принимаемые параметры

    $poll_reply_id

    $param

    Массив параметров
    • int $param['poll_id'] Идентификатор опроса, к которому нужно отнести скопированный ответ (Не обязательный параметр)
    • bool $param['add_copydate'] Флаг, указывающий, добавлять ли дату копирования к имени опроса. (Не обязательный параметр. По уполчанию - true)

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $poll_reply_id = 1;
        5.

      5.
        6.

      6.  $newid = $polls->CopyPollReply($poll_reply_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $newid;
        10.

      10.  ?>
        11.

    Возвращает

    Идентификатор скопированной записи или false

    [ Наверх ]

    polls::DelPollsGroup

DelPollsGroup(
int
$polls_group_id );

    Описание

    Метод удаления групп опросов

    Принимаемые параметры

    $polls_group_id

    идентификатор удаляемой группы опросов
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $polls_group_id = 1;
      5.

    5.
      6.

    6.  $result = $polls->DelPollsGroup($polls_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    polls::del_poll

del_poll(
int
$poll_id );

    Описание

    Метод удаления опроса

    Принимаемые параметры

    $poll_id

    – идентификатор удаляемого опроса
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_id = 3;
      5.

    5.
      6.

    6.  $result = $polls->del_poll($poll_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    polls::del_poll_reply

del_poll_reply(
int
$poll_reply_id );

    Описание

    Метод удаления варианта ответа

    Принимаемые параметры

    $poll_reply_id

    – идентификатор удаляемого варианта ответа
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_reply_id = 9;
      5.

    5.
      6.

    6.  $result = $polls->del_poll_reply($poll_reply_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    polls::GenXml4Poll

GenXml4Poll(
int
$poll_id, [array
$row = array()], [array
$param = array()] );

    Описание

    Формирование XML для опроса

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    $row

    ассоциативный массив с информацией о опросе    *

    $param

    ассоциативный массив параметров
    • int $param['order_field'] параметр, определяющий по какому полю будут сортироваться варианты ответа при отображении результатов голосования (0 - по полю сортировки, 1 - по названию вариантов ответов, 2 - по числу голосов за вариант ответа). по умолчанию равен 0
    • int $param['order_type'] параметр, определяющий направление сортировки вариантов ответов при отображении результатов голосования (0 - по возрастанию, 1 - по убыванию). по умолчанию равен 0

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $poll_id = 1;
        5.

      5.
        6.

      6.  $newxml = $polls->GenXml4Poll($poll_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo htmlspecialchars($newxml);
        10.

      10.  ?>
        11.

    Возвращает

    XML

    [ Наверх ]

    polls::GetAllPollReply

GetAllPollReply(
int
$poll_id );

    Описание

    Получение списка всех ответов на опрос

    Принимаемые параметры

    $poll_id

    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_id = 1;
      5.

    5.
      6.

    6.  $resource = $polls->GetAllPollReply($poll_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    polls::GetAllPolls

GetAllPolls(
[array
$param = array()] );

    Описание

    Получение информации обо всех опросах

    Принимаемые параметры

    $param

    массив с параметрами выборки
    • int $param['poll_group_id'] идентификатор группы опросов
    • bool $param['poll_visible'] видимость опроса
    • str $param['date'] дата, если указана, то будет проверятся на попадание в интервал, указанный в опросе
    • str $param['poll_end_date'] дата окончания опроса
    • int $param['poll_begin'] номер опроса, с которого начинать отображение
    • int $param['polls_on_page'] количество запросов

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $param['poll_group_id'] = 1;
        5.

      5.  $param['poll_begin'] = 1;
        6.

      6.  $param['polls_on_page'] = 2;
        7.

      7.
        8.

      8.  $row = $polls->GetAllPolls($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  print_r ($row);
        12.

      12.  ?>
        13.

    Возвращает

    массив с результатом выборки или false

    [ Наверх ]

    polls::GetAllPollsGroups

GetAllPollsGroups(
mixed
$site_id, [int
$structure_id = false] );

    Описание

    Получение информации о всех группах опросов

    Принимаемые параметры

    $site_id

    идентификатор сайта, для групп опросов которого необходимо

    $structure_id

    идентификатор узла структуры, если не передан учет структуры не происходит
    • получить информацию, если $site_id = false, то получаем информацию группах опросов всех сайтов

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $site_id = CURRENT_SITE;
        5.

      5.
        6.

      6.  $resource = $polls->GetAllPollsGroups($site_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

    [ Наверх ]

    polls::GetCountPolls

GetCountPolls(
int
$group_id );

    Описание

    Получение числа опросов в группе

    Принимаемые параметры

    $group_id

    идентификатор группы
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $group_id = 1;
      5.

    5.
      6.

    6.  $result = $polls->GetCountPolls($group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    число опросов в группе

    [ Наверх ]

    polls::GetCountPollsGroup

GetCountPollsGroup(
int
$site_id );

    Описание

    Получение числа групп опросов для одного или всех сайтов

    Принимаемые параметры

    $site_id

    идентификатор сайта, для которого необходимо получить число групп опросов,
    если $site_id = false, то получаем число групп опросов всех сайтов
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $result = $polls->GetCountPollsGroup($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    число групп опросов

    [ Наверх ]

    polls::GetGroupPollsWithConditions

GetGroupPollsWithConditions(
[array
$param = array()] );

    Описание

    Метод для получения списка групп с запросами по условиям

    Принимаемые параметры

    $param

    дополнительные условия

    Возвращает

    с результатом выборки или false

    [ Наверх ]

    polls::GetPoll

GetPoll(
int
$poll_id );

    Описание

    Метод возвращает данные об опросе

    Принимаемые параметры

    $poll_id

    – идентификатор опроса
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_id = 1;
      5.

    5.
      6.

    6.  $row = $polls->GetPoll($poll_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с данными об опросе или false, если опрос не найден

    [ Наверх ]

    polls::GetPollsGroup

GetPollsGroup(
int
$polls_group_id, [array
$param = array()] );

    Описание

    Получение информации о группе опросов

    Принимаемые параметры

    $polls_group_id

    идентификатор группы опросов, о которой необходимо получить данные

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $polls_group_id = 2;
        5.

      5.
        6.

      6.  $row = $polls->GetPollsGroup($polls_group_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с данными о группе опросов

    [ Наверх ]

    polls::get_polls_name

get_polls_name(
int
$poll_id );

    Описание

    Получение названия опроса

    Принимаемые параметры

    $poll_id

    – идентификатор опроса
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_id = 1;
      5.

    5.
      6.

    6.  $result = $polls->get_polls_name($poll_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    название опроса, если запрос с таким идентификатором существует, или слово «Опросы» в противном случае

    [ Наверх ]

    polls::IncPollReply

IncPollReply(
mixed
$poll_reply_id, int
$poll_id, [bool
$use_cookies = true] );

    Описание

    Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote

    Принимаемые параметры

    $poll_reply_id

    идентификатор ответа или массив идентификаторов ответов

    $poll_id

    идентификатор опроса

    $use_cookies

    использовать кукисы для защиты от повторного голосования
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_reply_id = 1;
      5.

    5.  $poll_id = 1;
      6.

    6.
      7.

    7.  $result = $polls->IncPollReply($poll_reply_id, $poll_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Голос принят";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Голос отвергнут";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    истина - голос принят, false - голос отвергнут

    [ Наверх ]

    polls::InsertGroupPolls

InsertGroupPolls(
array
$param );

    Описание

    Вставка информации о группе опросов

    Принимаемые параметры

    $param

    ассоциативный массив параметров метода
    • $param['site_id'] идентификатор сайта, которому принадлежит группа опросов
    • $param['structure_id'] идентификатор узла структуры, в котором содержится обработчик
    • $param['poll_group_name'] название группы опросов
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $param['site_id'] = CURRENT_SITE;
        5.

      5.  $param['structure_id'] = 33;
        6.

      6.  $param['poll_group_name'] = 'Группа опросов';
        7.

      7.
        8.

      8.  $newid = $polls->InsertGroupPolls($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор вставленной группы в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    polls::InsertVote

InsertVote(
int
$poll_id, mixed
$vote );

    Описание

    Устаревший метод. Вставка ответа на опрос.

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    $vote

    идентификатор ответа или массив с ответами на вопрос array(poll_reply_id['poll_reply_id3']=>'1',poll_reply_id['poll_reply_id5']=>'1')
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_id = 1;
      5.

    5.  $vote = 1;
      6.

    6.
      7.

    7.  $result = $polls->InsertVote($poll_id, $vote);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Вставка ответа выполнена успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка вставки";
      16.

    16.  }
      17.

    17.  ?>
      18.

    see

    polls::IncPollReply()

    [ Наверх ]

    polls::insert_poll

insert_poll(
int
$type, int
$poll_id,
$poll_group_id, string
$poll_name, string
$poll_description, int
$poll_type, int
$poll_vote_public, int
$poll_visible, string
$poll_begin_date, string
$poll_end_date, [int
$users_id = false], [int
$poll_voted = 0], int
$poll_group, int
$structure_id, int
$site_id );

    Описание

    Вставка и обновление опроса

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление опроса (0 – вставка, 1 - обновление)

    $poll_id

    идентификатор обновляемого опроса (при вставке нового опроса равен 0)

    $poll_group

    идентификатор группы опросов

    $poll_name

    название (заголовок) опроса

    $poll_description

    описание опроса

    $structure_id

    идентификатор структуры

    $site_id

    идентификатор сайта

    $poll_type

    тип опроса (0 – можно выбрать только один вариант ответа, 1- можно выбрать несколько вариантов ответа)

    $poll_vote_public

    параметр, определяющий показывать пользователю результаты голосования или нет (1 – показывать, 0 – не показывать)

    $poll_visible

    параметр, определяющий отображать опрос или нет (1 – отображать, 0 – не отображать)

    $poll_begin_date

    дата начала действия опроса

    $poll_end_date

    дата окончания действия опроса

    $poll_voted

    число голосований по опросу

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $poll_id = 0;
      6.

    6.  $poll_group_id = 1;
      7.

    7.  $poll_name = 'Новый опрос';
      8.

    8.  $poll_type = 1;
      9.

    9.  $poll_vote_public = 0;
      10.

    10.  $poll_visible = 1;
      11.

    11.  $poll_begin_date = date('Y-m-d H:i:s');
      12.

    12.  $poll_end_date = '2008-12-1 00:00:00';
      13.

    13.
      14.

    14.  $newid = $polls->insert_poll($type, $poll_id, $poll_group_id, $poll_name, $poll_type, $poll_vote_public ,$poll_visible, $poll_begin_date, $poll_end_date);
      15.

    15.
      16.

    16.  // Распечатаем результат
      17.

    17.  echo $newid;
      18.

    18.  ?>
      19.

    $poll_group_id

    Возвращает

    идентификатор вставленного или обновленного опроса в случае успешного выполнеия метода или false - в противном случае

    [ Наверх ]

    polls::insert_poll_reply

insert_poll_reply(
int
$type, int
$poll_reply_id, string
$poll_id, string
$poll_reply_text, int
$poll_reply_number, int
$poll_reply_order, int
$poll_reply_grade, [int
$users_id = false] );

    Описание

    Вставка и обновление вариантов ответов

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление варианта ответа

    $poll_reply_id

    идентификатор обновляемого варианта ответа (при вставке нового варианта ответа равен 0)

    $poll_id

    идентификатор опроса, к которому относится обновляемый/добавляемый вариант ответа

    $poll_reply_text

    текст варианта ответа

    $poll_reply_number

    количество голосов, отданных за данный вариант ответа

    $poll_reply_order

    порядковый номер варианта ответа

    $poll_reply_grade

    количество баллов, назначаемых ответу

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $poll_reply_id = 0;
      6.

    6.  $poll_id = 3;
      7.

    7.  $poll_reply_text = 'Текст ответа';
      8.

    8.  $poll_reply_number = 1;
      9.

    9.  $poll_reply_order = 1;
      10.

    10.
      11.

    11.  $newid = $polls->insert_poll_reply($type, $poll_reply_id, $poll_id,$poll_reply_text, $poll_reply_number, $poll_reply_order);
      12.

    12.
      13.

    13.  // Распечатаем результат
      14.

    14.  echo $newid;
      15.

    15.  ?>
      16.

    Возвращает

    or boolean идентификатор вставленного или обновленного варианта ответа в случае успешного выполнеия метода или false - в противном случае

    [ Наверх ]

    polls::SelectPollReply4Poll

SelectPollReply4Poll(
int
$poll_id, [array
$param = array()] );

    Описание

    Получение списка вариантов ответов на опрос по ID опроса

    Принимаемые параметры

    $poll_id

    идентификатор опроса

    $param

    ассоциативный массив параметров
    • int $param['order_field'] параметр, определяющий по какому полю будут сортироваться варианты ответа при отображении результатов голосования (0 - по полю сортировки, 1 - по названию вариантов ответов, 2 - по числу голосов за вариант ответа). по умолчанию равен 0
    • int $param['poll_reply_order_type'] параметр, определяющий направление сортировки вариантов ответов при отображении результатов голосования

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $poll_id = 1;
        5.

      5.
        6.

      6.  $resource = $polls->SelectPollReply4Poll($poll_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

    [ Наверх ]

    polls::select_poll

select_poll(
[mixed
$poll_id = false] );

    Описание

    Метод осуществляет выборку опросов

    Принимаемые параметры

    $poll_id

    идентификатор выбираемого опроса (по умолчанию равен false – выбираем все опросы)
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_id = 1;
      5.

    5.
      6.

    6.  $resource = $polls->select_poll($poll_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    polls::select_poll_reply

select_poll_reply(
[mixed
$poll_reply_id = false] );

    Описание

    Метод выбора вариантов ответов по ID ответа

    Принимаемые параметры

    $poll_reply_id

    – идентификатор выбираемого варианта ответа (по умолчанию равен false – выбираем все варианты ответов)
    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $poll_reply_id = 9;
      5.

    5.
      6.

    6.  $resource = $polls->select_poll_reply($poll_reply_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    polls::ShowPoll

ShowPoll(
string
$xsl_name, [mixed
$poll_id = false], [array
$external_propertys = array()], [array
$param = array()] );

    Описание

    Метод отображения опроса

    Принимаемые параметры

    $xsl_name

    имя XSL–шаблона для отображения опроса

    $poll_id

    идентификатор отображаемого опроса (по умолчанию равен false – опрос выбирается случайным образом)

    $external_propertys

    ассоциативный массив внешних параметров для XML

    $param

    ассоциативный массив параметров
    • int $param['order_field'] параметр, определяющий по какому полю будут сортироваться варианты ответа при отображении результатов голосования (0 - по полю сортировки, 1 - по названию вариантов ответов, 2 - по числу голосов за вариант ответа). по умолчанию равен 0
    • int $param['order_type'] параметр, определяющий направление сортировки вариантов ответов при отображении результатов голосования (0 - по возрастанию, 1 - по убыванию). по умолчанию равен 0

    1.  <?php
      2.

    2.  $polls = new polls();
      3.

    3.
      4.

    4.  $xsl_name = 'ОтображениеРезультатовОпроса';
      5.

    5.  $poll_id = 1;
      6.

    6.
      7.

    7.  $polls->ShowPoll($xsl_name, $poll_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    polls::ShowPollResult

ShowPollResult(

$poll_id,
$xsl_name );

    Описание

    Устаревший метод вывода результатов голосования

    Принимаемые параметры

    $poll_id

    $xsl_name

    [ Наверх ]

    polls::ShowPolls

ShowPolls(
string
$xsl_name, int
$polls_on_page, int
$poll_begin, [array
$external_propertys = array()], [int
$site_id = CURRENT_SITE] );

    Описание

    Устаревший метод! Метод отображения всех активных опросов

    Принимаемые параметры

    $xsl_name

    – название XSL – шаблона для отображения опросов

    $polls_on_page

    – число опросов на страницу

    $poll_begin

    – номер опроса, с которого начинать отображать опросы

    $external_propertys

    - дополнительные св-ва

    $site_id

    - идентификатор сайта, по умолчанию равен CURRENT_SITE

    [ Наверх ]

    polls::ShowPollsGroup

ShowPollsGroup(
mixed
$group_id,
$xsl_name, [array
$param = array()], [
$external_propertys = array()], string
$xsl );

    Описание

    Отображение групп опросов

    Принимаемые параметры

    $group_id

    идентификатор группы, опросы которой необходимо показать, false - необходимо показать опросы всех групп данного сайта

    $xsl

    имя XSL-шаблона

    $param

    массив дополнительных параметров
    • $param['order_field'] поле сортировки опросов
    • $param['order_type'] направление сортировки ('asc' - по возрастанию, 'desc' - по убыванию, 'RAND()' - в произвольном порядке), по умолчанию $param['order_type'] = 'RAND()';
    • $param['poll_begin'] порядковый номер опроса, с которого начинать показ списка опросов (по умолчанию $param['poll_begin'] = 0)
    • $param['poll_count'] число показываемых опросов (по умолчанию $param['poll_count'] = 1)

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $group_id = 1;
        5.

      5.  $xsl_name = 'ОтображениеОпросаБезРезультатов';
        6.

      6.
        7.

      7.  $polls->ShowPollsGroup($group_id, $xsl_name);
        8.

      8.  ?>
        9.

    $xsl_name

    $external_propertys

    [ Наверх ]

    polls::UpdateGroupPolls

UpdateGroupPolls(
array
$param );

    Описание

    Метод обновления информаци о группе опросов

    Принимаемые параметры

    $param

    ассоциативный массив параметров метода
    • $param['poll_group_id'] идентификатор группы опросов
    • $param['structure_id'] идентификатор узла структуры, в котором содержится обработчик
    • $param['site_id'] идентификатор сайта, которому принадлежит группа опросов
    • $param['poll_group_name'] название группы опросов

      1.  <?php
        2.

      2.  $polls = new polls();
        3.

      3.
        4.

      4.  $param['poll_group_id'] = 2;
        5.

      5.  $param['structure_id'] = 33;
        6.

      6.  $param['site_id'] = CURRENT_SITE;
        7.

      7.  $param['poll_group_name'] = 'Новая группа опросов';
        8.

      8.
        9.

      9.  $newid = $polls->UpdateGroupPolls($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $newid;
        13.

      13.  ?>
        14.

    Возвращает

    идентификатор обновленной группы в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    polls::vote_result

vote_result(
 );

    Описание

    Устаревший метод

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class RssRead

Class RssRead

[Строка 14]

Размещен: /Kernel/RssRead.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для чтения RSS.
Файл: /modules/Kernel/RssRead.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $encoding =  ''

        Внутренняя кодировка, используемая при работе с RSS

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • array ReadRSS()

    Метод чтения данных из RSS потока

Унаследованные методы

Описания методов

    RssRead::ReadRSS

ReadRSS(
string
$url, [array
$param = array()] );

    Описание

    Метод чтения данных из RSS потока

    Принимаемые параметры

    $url

    URL ресурса

    $param

    массив дополнительных параметров, необязательный параметр

    Возвращает

    ассоциативнй массив с инфомрацией о канале и элементах
    [chanel] => Array
    • (

      [title] =>

      [link] =>

      [description] =>

      [image] => Array

      (

      [title] =>

      [link] =>

      [url] =>

      )

      )

      [items] => Array

      (

      [] => Array

      (

      [title] =>

      [link] =>

      [desc] =>

      [category] =>

      [pubdate] =>

      [yandex:full-text] =>

      )

      )

      [error] => Текст ошибки, если была

    [ Наверх ]

Описания переменных

  • $encoding =  '' [Строка 22]
    •

  • Data type: string
    •

    Описание

    Внутренняя кодировка, используемая при работе с RSS

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class RssWrite

Class RssWrite

[Строка 27]

Размещен: /Kernel/RssWrite.class.php

Описание

Ядро, класс для генерации RSS.

Со спецификацией можно ознакомиться на сайте http://www.rssboard.org/rss-specification

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string CreateRSS()

    Метод формирования XML-файла в стандарте RSS

  • str str_for_rss()

    Преобразует строку для публикации в RSS, использует str_for_xml() и kernel::numeric_character_references()

Унаследованные методы

Описания методов

    RssWrite::CreateRSS

CreateRSS(
array
$rss_mas_header, array
$rss_mas_items, [array
$property = array()] );

    Описание

    Метод формирования XML-файла в стандарте RSS

    Принимаемые параметры

    $rss_mas_header

    массив, содержащий данные заголовка канала
    • $rss_mas_items - массив, содержащий данные новостных заголовков
    • $rss_mas_header['title'] - Заголовок канала
    • $rss_mas_header['link'] - Ссылка на сайт
    • $rss_mas_header['description'] - Краткое описание RSS-канала
    • $rss_mas_header['image'] - Картинка для представления канала (необязательный элемент)
    • $rss_mas_header['image']['url'] - Ссылка на файл изображения
    • $rss_mas_header['image']['title'] - Заменяющий текст для изображения
    • $rss_mas_header['image']['link'] - Ссылка для перехода при щелчке по изображению

    $rss_mas_items

    массив, соддержащий данные о элементах канала
    • $rss_mas_items[]['title'] - Название новости
    • $rss_mas_items[]['link'] - Ссылка на страничку, содержащую соответствующую новость
    • $rss_mas_items[]['description'] - Краткое описание новости
    • $rss_mas_items[]['pubDate'] - Дата публикации новости, ПРИНИМАЕТСЯ В ФОРМАТЕ SQL
    • $rss_mas_items[]['author'] - Автор
    • $rss_mas_items[]['category'] - Наименование категории, к которой относится элемент
    • $rss_mas_items[]['guid'] - Уникальный илентификатор элемента, наиболее часто знаение эквивалентно $rss_mas_items[]['link']
    • $rss_mas_items[]['enclosure'][0]['url'] - URL вложения
    • $rss_mas_items[]['enclosure'][0]['type'] - type вложения, если явно не указан - определяется автоматически
    • $rss_mas_items[]['enclosure'][0]['length'] - размер вложения в байтах, целое число

    $property

    массив дополнительных параметров
    • $property['yandex:full-text'] вывод полного текста для Яндекс, по умолчанию false

    Возвращает

    сгенерированный XML в формате RSS 2.0

    [ Наверх ]

    RssWrite::str_for_rss

str_for_rss(
string
$str );

    Описание

    Преобразует строку для публикации в RSS, использует str_for_xml() и kernel::numeric_character_references()

    Принимаемые параметры

    $str

    строка

    Возвращает

    обработанная строка

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Search

Class Search

[Строка 19]

Размещен: /Search/Search.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Поиск".
Файл: /modules/Search/Search.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $ModuleClass = array(0 => 'Structure',

   1 => 'InformationSystem',

   2 => 'Forums',

   3 => 'shop',

   4 => 'helpdesk',

   5 => 'SiteUsers')

        Массив соответствия идентификаторов модулей в таблице страниц модулям,

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • void DeleteSearchInfomationForSite()

    Удаление поисковой информации сайта

  • boolean Delete_search_words()

    Метод удаления из индекса страницы с указанным адресом

  • array GetLogStat()

    Метод для получения сгруппированной информации о поисковых запросах

  • void GetPageCount()

    Метод определения числа проиндексированных страниц

  • resource GetPageInfo()

    Получение информации о проиндексированных страницах

  • string GoSearch()

    Метод выводит результаты поиска запроса $query с помощью XSL-шаблона  $xslname в соответствии с дополнительными параметрами

  • mixed InsertSearchInQuery()

    Метод для вставки запроса в журнал поисковых запросов

  • boolean Insert_search_word()

    Метод формирует индекс для переданного блока страниц

  • mixed SearchWords()

    Поиск списка слов в индексе. Примеры использования см. в руководстве по интеграции.

Унаследованные методы

Описания методов

    Search::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    Search::DeleteSearchInfomationForSite

DeleteSearchInfomationForSite(
int
$site_id );

    Описание

    Удаление поисковой информации сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта

    [ Наверх ]

    Search::Delete_search_words

Delete_search_words(
string
$page_address, [
$site_id = NULL] );

    Описание

    Метод удаления из индекса страницы с указанным адресом

    Принимаемые параметры

    $page_address

    адрес удаляемой из индекса страницы

    $site_id

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    Search::GetLogStat

GetLogStat(
string
$date_from, string
$date_to,
$ext_param, [string
$limit = ''], [array
$param = array()] );

    Описание

    Метод для получения сгруппированной информации о поисковых запросах

    Принимаемые параметры

    $date_from

    дата, с которой начинать выборку

    $date_to

    дата, которой заканичивать выборку

    $limit

    ограничение

    $param

    ассоциативный массив параметров
    • $param['site_id'] идентификтор сайта, по которому выводить статистику, если не передан - статистика по всем сайтам

    $ext_param

    Возвращает

    с результатом выборки либо false

    [ Наверх ]

    Search::GetPageCount

GetPageCount(
[int
$site_id = false] );

    Описание

    Метод определения числа проиндексированных страниц

    Принимаемые параметры

    $site_id

    идентификатор сайта, по умолчанию false
    1.  <?php
      2.

    2.  $Search = new Search();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $count = $Search->GetPageCount($site_id);
      7.

    7.
      8.

    8.  echo $count;
      9.

    9.  ?>
      10.

    [ Наверх ]

    Search::GetPageInfo

GetPageInfo(
[int
$page_id = false] );

    Описание

    Получение информации о проиндексированных страницах

    Принимаемые параметры

    $page_id

    идентификатор страницы (если равен false, то возвращает информацию обо всех проиндексированных страницах)

    [ Наверх ]

    Search::GoSearch

GoSearch(
string
$query, string
$xslname, [array
$param = array()], [array
$external_propertys = array()] );

    Описание

    Метод выводит результаты поиска запроса $query с помощью XSL-шаблона  $xslname в соответствии с дополнительными параметрами

    Принимаемые параметры

    $query

    текст поискового запроса

    $xslname

    имя XSL шаблона

    $param

    массив дополнительных параметров
    • $param['site_user_id'] int идентификатор пользователя сайта для определения прав доступа;
    • $param['current_page'] int номер текущей страницы результатов поиска (счет с 1);
    • $param['items_on_page'] int количество записей на странице;
    • $param['len'] int максимальная длина поискового запроса, значение по умолчанию 200;
    • $param['site_id'] mixed идентификатор или массив идентификаторов сайтов, по которым производится поиск. Если необходим поиск по текущему сайту, укажите значение CURRENT_SITE
    • $param['search_page_module'] массив модулей, ключами которого являются номера модулей, а значениями — массив идентификаторов элементов или массив с дополнительными условиями отбора элементов модулей
    • $param['order_field'] int поле сортировки (0 - по релевантности, 1 - по дате). по умолчанию 0
    • $param['order_direction'] int направление сортировки (ASC, DESC). по умолчанию DESC
    • $param['search_page_is_inner'] int осуществлять поиск по внешним страницам (значение 0), внутреним (значение 1) или всем страницам (значение false). по умолчанию имеет значение 0

    $external_propertys

    массив дополнительных свойств для включения в XML
      Описание и примеры вызовов см. у метода SearchWords()
      Пример поиска по информационной системе с номером 5 и 7, а также по магазину с номером 17.
    1.  $Search = new Search();
      2.

    2.  $property['search_page_module'] = array(
      3.

    3.  1 => array (5, 7),
      4.

    4.  3 => array (17));
      5.

    5.
      6.

    6.  $Search->GoSearch($words, to_str($GLOBALS['LA']['xsl']), $property);
      7.

    Пример поиска по информационной системе с номером 5 и 7 (с дополнительным условием поиска только по информационным элементам), а также по магазину с номером 17.
    1.  $Search = new Search();
      2.

    2.
      3.

    3.  $property['search_page_module'] = array(
      4.

    4.      1 => array (5,
      5.

    5.         array('search_page_module_entity_id' => 7,
      6.

    6.         'search_page_module_value_type' => 2)),
      7.

    7.      3 => array (17));
      8.

    8.
      9.

    9.  $Search->GoSearch($words, to_str($GLOBALS['LA']['xsl']), $property);
      10.

    see

    Search::SearchWords()

    [ Наверх ]

    Search::InsertSearchInQuery

InsertSearchInQuery(
array
$param );

    Описание

    Метод для вставки запроса в журнал поисковых запросов

    Принимаемые параметры

    $param

    массив с доп. параметрами
    • int $param['search_log_text'] текст поискового запроса
    • int $param['site_users_id'] идентификатор пользователя сайта, сделавшего запрос, если не установлен - берется текущий пользователь
    • int $param['site_id'] идентификатор сайта, с которого произвели запрос, если не установлен - берется текущий сайт
    • int $param['search_log_datetime'] дата/время вставки запроса
    • int $param['search_log_ip'] IP-адрес с которого сделали запрос

    Возвращает

    идентификатор вставленного запроса либо false

    [ Наверх ]

    Search::Insert_search_word

Insert_search_word(
[array
$param = array()] );

    Описание

    Метод формирует индекс для переданного блока страниц

    Принимаемые параметры

    $param

    массив добавляемых страниц:
    • $param[$i][0] string имя страницы;
    • $param[$i][1] string адрес страницы;
    • $param[$i][2] string текст страницы;
    • $param[$i][3] float размер страницы;
    • $param[$i][4] int идентификатор сайта (0 - для всех сайтов);
    • $param[$i][5] array массив идентификаторов групп пользователей (0 - для всех групп)
    • $param[$i][6] string дата создания страницы
    • $param[$i][7] int search_page_module - модуль, которому принадлежит элемемент.

      Имеет значения:

      Структура сайта - 0,

      Информационные системы - 1,

      Форум - 2,

      Интернет-магазин - 3,

      HelpDesk - 4.

      Пользователи сайта - 5.
    • $param[$i][8] int search_page_module_entity_id - ID элемента модуля, которому принадлежит элемемент. Например, ID магазина, ID информационной системы и т.д.
    • $param[$i][9] int Флаг, указывающий, внутренний поиск (внутри ЦА), или внешний (0 - внешний, 1 - внутренний)
    • $param[$i][10] int search_page_module_value_type - тип индексируемого элемента. Может принимать целое значение. Например, 1 - группы, 2 - товары и т.д.
    • $param[$i][11] int search_page_module_value_id - ID индексируемого элемента. Может принимать целое значение. Например, 1 - группы, 2 - товары и т.д.

    Возвращает

    результат выполнения запроса на добавление записей

    [ Наверх ]

    Search::SearchWords

SearchWords(
string
$query, [array
$param = array('len' => 200)] );

    Описание

    Поиск списка слов в индексе. Примеры использования см. в руководстве по интеграции.

    Принимаемые параметры

    $query

    поисковой запрос

    $param

    массив дополнительных параметров:
    • $param['site_user_id'] int идентификатор пользователя сайта для определения прав доступа;
    • $param['current_page'] int номер текущей страницы результатов поиска (счет с 1);
    • $param['items_on_page'] int количество записей на странице;
    • $param['site_id'] mixed идентификатор или массив идентификаторов сайтов, по которым производится поиск. Если необходим поиск по текущему сайту, укажите значение CURRENT_SITE;
    • $param['search_page_module'] массив модулей, ключами которого являются номера модулей, а значениями — массив идентификаторов элементов или массив с дополнительными условиями отбора элементов модулей

      Имеет значения:

      Структура сайта - 0,

      Информационные системы - 1,

      Форум - 2,

      Интернет-магазин - 3,

      HelpDesk - 4,

      Пользователи сайта - 5.

    Пример поиска по информационной системе с номером 5 и 7, а также по магазину с номером 17.
    1.  $property['search_page_module'] = array(
      2.

    2.  1 => array (5, 7),
      3.

    3.  3 => array (17));
      4.

    Пример поиска по информационной системе с номером 5 и 7 (с дополнительным условием поиска только по информационным элементам), а также по магазину с номером 17.
    1.  $property['search_page_module'] = array(
      2.

    2.      1 => array (5,
      3.

    3.          array('search_page_module_entity_id' => 7,
      4.

    4.          'search_page_module_value_type' => 2)),
      5.

    5.      3 => array (17));
      6.

    При указании массива с дополнительными условиями он может принимать следующие аргументы:
    search_page_module_entity_id
    • целое число, ID сущности, например, магазин с кодом 7

      search_page_module_value_type - целое число или массив, ID типа, например, 1 - группа, 2 - элемент (или товар)

      search_page_module_value_id - целое число или массив, ID сущности указанного типа (например, ID товара или группы) при поиске только по ним.

    • $param['order_field'] int поле сортировки (0 - по релевантности, 1 - по дате). по умолчанию 0.
    • $param['order_direction'] int направление сортировки (ASC, DESC). по умолчанию DESC.
    • $param['search_page_is_inner'] int осуществлять поиск по внешним страницам (значение 0), внутреним (значение 1) или всем страницам (значение false). по умолчанию имеет значение 0.

    Возвращает

    результат поиска:
      array массив страниц:
      $result[$i]['search_page_name'] string название страницы;
      $result[$i]['search_page_address'] string адрес страницы;
      $result[$i]['search_page_date'] string дата индексации;
      $result[$i]['search_page_size'] float размер страницы;
      boolean false если ничего не найдено
    Пример поиска по информационной системе с номером 5 и 7, а также по магазину с номером 17.
    1.  $Search = new Search();
      2.

    2.  $property['search_page_module'] = array(
      3.

    3.      1 => array (5, 7),
      4.

    4.      3 => array (17));
      5.

    5.
      6.

    6.  $Search->GoSearch($words, to_str($GLOBALS['LA']['xsl']), $property);
      7.

    Пример поиска по информационной системе с номером 5 и 7 (с дополнительным условием поиска только по информационным элементам), а также по магазину с номером 17.
    1.  $Search = new Search();
      2.

    2.
      3.

    3.  $property['search_page_module'] = array(
      4.

    4.  1 => array (5,
      5.

    5.       array('search_page_module_entity_id' => 7, 'search_page_module_value_type' => 2)),
      6.

    6.  3 => array (17));
      7.

    7.
      8.

    8.  $Search->GoSearch($words, to_str($GLOBALS['LA']['xsl']), $property);
      9.

    [ Наверх ]

Описания переменных

  • $ModuleClass = array(0 => 'Structure',

   1 => 'InformationSystem',

   2 => 'Forums',

   3 => 'shop',

   4 => 'helpdesk',

   5 => 'SiteUsers')     [Строка 127]
    •

  • Data type: array
    •

    Описание

    Массив соответствия идентификаторов модулей в таблице страниц модулям,

    Structure = 0,  InformationSystem = 1,  Forums = 2,  shop = 3,  helpdesk = 4,  SiteUsers = 5  Используется при вызове функции обратного вызова для генерации информации об элементе при поиске.

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Seo

Class Seo

[Строка 14]

Размещен: /seo/seo.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Поисковой оптимизации".
Файл: /modules/seo/seo.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AllowYandexXml()

    Проверка возможности использования Яндекс.XML

  • array BuildMassReport()

    Игнорирование столбцов таблицы

  • void ClearCachePage()

    Очищает кэш запрошенных страниц в $this->CachePage

  • resource DeleteCharacteristic()

    Удаление характеристик страницы

  • resource DeletePositionSearch()

    Удаление позиции в поисковой системе из БД

  • resource DeleteQuery()

    Удаление запроса

  • void DrawStatusReport()

    Графическое отображение статуса наличия счетчиков и страницы в каталогах в отчете

  • int EdZero()

    Заменяет "млн" и "тыс" на соответствующее количество нулей

  • resourse GetAllQuery()

    Получение списка поисковых запросов

  • bool GetAportCatalog()

    Определение наличия страницы в каталоге Апорт

  • mixed GetCharacteristic()

    Получение характеристики

  • mixed GetCounterHotLog()

    Проверка наличия счетчика статистики HotLog

  • mixed GetCounterLiveInternet()

    Проверка наличия счетчика статистики LiveInternet

  • mixed GetCounterMail()

    Проверка наличия счетчика статистики Mail

  • mixed GetCounterRambler()

    Проверка наличия счетчика статистики Rambler

  • mixed GetCounterSpyLog()

    Проверка наличия счетчика статистики SpyLog

  • mixed GetCounterYandex()

    Проверка наличия счетчика статистики Yandex

  • bool GetDmozCatalog()

    Определение наличия страницы в каталоге Dmoz

  • int GetIndexAport()

    Определение количества проиндексированных странниц сервисом Апорт

  • int GetIndexGoogle()

    Определяет количество проиндексированных странниц сервисом Google

  • int GetIndexMsn()

    Определение количества проиндексированных странниц сервисом Bing.com

  • int GetIndexRambler()

    Определение количества проиндексированных странниц сервисом Rambler

  • int GetIndexYahoo()

    Определение количества проиндексированных странниц сервисом Yahoo

  • int GetIndexYandex()

    Определение количества проиндексированных странниц в Яндекс.ру

  • int GetLinksGoogle()

    Определение количества ссылающихся страниц с сервиса Google

  • int GetLinksMsn()

    Определение количества ссылающихся страниц с сервиса Bing.com

  • int GetLinksYahoo()

    Определение количества ссылающихся страниц с сервиса Yahoo

  • int GetLinksYandex()

    Определение количества ссылающихся страниц с сервиса Yandex

  • void GetLr()

  • bool GetMailCatalog()

    Определение наличия страницы в каталоге Mail.ru

  • int GetPageRank()

    Поиск значения Google PageRank. Основан на данных Google toolbar. Возвращает значение PageRank страницы

  • mixed GetPosAport()

    Определение позиции сайта в поисковой системе Апорт

  • mixed GetPosGogo()

    Определение позиции сайта в поисковой системе GoGo

  • mixed GetPosGoogle()

    Определение позиции сайта в поисковой системе Google

  • mixed GetPositionSearch()

    Получение списка позиций в поисковой системе из БД

  • mixed GetPosLivesearch()

    Определение позиции сайта в поисковой системе Bing.com

  • mixed GetPosRambler()

    Определение позиции сайта в поисковой системе Rambler

  • mixed GetPosYahoo()

    Определение позиции сайта в поисковой системе Yahoo

  • mixed GetPosYandex()

    Определение позиции сайта в поисковой системе Yandex

  • mixed GetQuery()

    Получение списка поисковых запросов из БД

  • bool GetRamblerCatalog()

    Определение наличия страницы в каталоге Rambler

  • str GetUrl()

    Поисковый запрос URL и сохранение полученной страницы в кэше

  • array GetYandexCatalog()

    Определения наличия страницы в каталоге Yandex, тИЦ, темы, страны и региона страницы

  • mixed InsertCharacteristic()

    Добавление характеристики страницы

  • mixed InsertPositionSearch()

    Добавление/обновление статистики по поисковым запросам в БД

  • mixed InsertQuery()

    Добавление/обновление поискового запроса в БД

  • void ParseGoogle()

  • void ParseYandex()

  • void ShowArrow()

    Отображение стрелочек динамики изменения значений

  • void ShowArrowQuery()

    Отображение стрелочек динамики изменения значений поисковых запросов

  • void ShowTableRow()

    Отображение строк таблицы в Отчете

  • void ShowTableTitleReport()

    Отображение шапки таблицы в отчете

  • str UrlWww()

    Обрезает "www" у домена

  • void YandexXmlRequest()

Унаследованные методы

Описания методов

    Seo::AllowYandexXml

AllowYandexXml(
 );

    Описание

    Проверка возможности использования Яндекс.XML

    [ Наверх ]

    Seo::BuildMassReport

BuildMassReport(
array
$report, str
$value_type );

    Описание

    Игнорирование столбцов таблицы

    Принимаемые параметры

    $report

    Массив данных

    $value_type

    Тип поля значений

    [ Наверх ]

    Seo::ClearCachePage

ClearCachePage(
 );

    Описание

    Очищает кэш запрошенных страниц в $this->CachePage

    [ Наверх ]

    Seo::DeleteCharacteristic

DeleteCharacteristic(
int
$seo_characteristic_id );

    Описание

    Удаление характеристик страницы

    Принимаемые параметры

    $seo_characteristic_id

    идентификатор характеристики, которую необходимо удалить

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $seo_characteristic_id = 1;
      5.

    5.
      6.

    6.  $resource = $Seo->DeleteCharacteristic($seo_characteristic_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $resource;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::DeletePositionSearch

DeletePositionSearch(

$seo_position_search_query_id, int
$seo_search_query_id );

    Описание

    Удаление позиции в поисковой системе из БД

    Принимаемые параметры

    $seo_search_query_id

    - идентификатор позиции в поисковой системе, которую необходимо удалить

    $seo_position_search_query_id

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $seo_position_search_query_id = 1;
      5.

    5.
      6.

    6.  $resource = $Seo->DeletePositionSearch($seo_position_search_query_id);
      7.

    7.
      8.

    8.  if ($resource)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Seo::DeleteQuery

DeleteQuery(
int
$seo_search_query_id );

    Описание

    Удаление запроса

    Принимаемые параметры

    $seo_search_query_id

    - идентификатор запроса, который необходимо удалить

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $seo_search_query_id = 3;
      5.

    5.
      6.

    6.  $resource = $Seo->DeleteQuery($seo_search_query_id);
      7.

    7.
      8.

    8.  if ($resource)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Seo::DrawStatusReport

DrawStatusReport(
bool
$value );

    Описание

    Графическое отображение статуса наличия счетчиков и страницы в каталогах в отчете

    Принимаемые параметры

    $value

    Наличие сайта в каталоге, либо счетчика на странице - true, false - иначе
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $value = true;
      5.

    5.
      6.

    6.  $Seo->DrawStatusReport($value);
      7.

    7.  ?>
      8.

    [ Наверх ]

    Seo::EdZero

EdZero(
string
$str );

    Описание

    Заменяет "млн" и "тыс" на соответствующее количество нулей

    Принимаемые параметры

    $str

    Строка с числом и наименованием разряда словами

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $str = '100 тыс.';
      5.

    5.
      6.

    6.  $result = $Seo->EdZero($str);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetAllQuery

GetAllQuery(
int
$site_id );

    Описание

    Получение списка поисковых запросов

    Принимаемые параметры

    $site_id

    Идентификатор сайта

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $resource = $Seo->GetAllQuery($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    Seo::GetAportCatalog

GetAportCatalog(
string
$domain );

    Описание

    Определение наличия страницы в каталоге Апорт

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetAportCatalog($domain);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Сайт присутствует в каталоге Апорт";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Сайт отсутствует в каталоге Апорт";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Seo::GetCharacteristic

GetCharacteristic(
int
$seo_characteristic_id );

    Описание

    Получение характеристики

    Принимаемые параметры

    $seo_characteristic_id

    идентификатор характеристики, которую необходимо получить

    Возвращает

    массив с информацией или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $seo_characteristic_id = 2;
      5.

    5.
      6.

    6.  $resource = $Seo->GetCharacteristic($seo_characteristic_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($resource);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetCounterHotLog

GetCounterHotLog(
string
$domain );

    Описание

    Проверка наличия счетчика статистики HotLog

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Номер счетчика, или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetCounterHotLog($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetCounterLiveInternet

GetCounterLiveInternet(
string
$domain );

    Описание

    Проверка наличия счетчика статистики LiveInternet

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Адрес на страницу со статистикой, или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetCounterLiveInternet($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetCounterMail

GetCounterMail(
string
$domain );

    Описание

    Проверка наличия счетчика статистики Mail

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Номер счетчика, или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetCounterMail($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetCounterRambler

GetCounterRambler(
string
$domain );

    Описание

    Проверка наличия счетчика статистики Rambler

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Номер счетчика, или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetCounterRambler($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetCounterSpyLog

GetCounterSpyLog(
string
$domain );

    Описание

    Проверка наличия счетчика статистики SpyLog

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    номер счетчика или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetCounterSpyLog($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetCounterYandex

GetCounterYandex(
string
$domain );

    Описание

    Проверка наличия счетчика статистики Yandex

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Адрес на страницу со статистикой, или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetCounterYandex($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetDmozCatalog

GetDmozCatalog(
string
$domain );

    Описание

    Определение наличия страницы в каталоге Dmoz

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetDmozCatalog($domain);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Сайт присутствует в каталоге Dmoz";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Сайт отсутствует в каталоге Dmoz";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Seo::GetIndexAport

GetIndexAport(
string
$domain );

    Описание

    Определение количества проиндексированных странниц сервисом Апорт

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    количество проиндексированных страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetIndexAport($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetIndexGoogle

GetIndexGoogle(
string
$domain );

    Описание

    Определяет количество проиндексированных странниц сервисом Google

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    количество проиндексированных страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetIndexGoogle($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetIndexMsn

GetIndexMsn(
string
$domain );

    Описание

    Определение количества проиндексированных странниц сервисом Bing.com

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    количество проиндексированных страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetIndexMsn($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetIndexRambler

GetIndexRambler(
string
$domain );

    Описание

    Определение количества проиндексированных странниц сервисом Rambler

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    количество проиндексированных страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetIndexRambler($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetIndexYahoo

GetIndexYahoo(
string
$domain );

    Описание

    Определение количества проиндексированных странниц сервисом Yahoo

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    количество проиндексированных страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetIndexYahoo($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetIndexYandex

GetIndexYandex(
string
$domain );

    Описание

    Определение количества проиндексированных странниц в Яндекс.ру

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    количество проиндексированных страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetIndexYandex($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetLinksGoogle

GetLinksGoogle(
string
$domain );

    Описание

    Определение количества ссылающихся страниц с сервиса Google

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Количество ссылающихся страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetLinksGoogle($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetLinksMsn

GetLinksMsn(
string
$domain );

    Описание

    Определение количества ссылающихся страниц с сервиса Bing.com

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Количество ссылающихся страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetLinksMsn($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetLinksYahoo

GetLinksYahoo(
string
$domain );

    Описание

    Определение количества ссылающихся страниц с сервиса Yahoo

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Количество ссылающихся страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetLinksYahoo($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetLinksYandex

GetLinksYandex(
string
$domain );

    Описание

    Определение количества ссылающихся страниц с сервиса Yandex

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Количество ссылающихся страниц
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetLinksYandex($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetLr

GetLr(
 );

    [ Наверх ]

    Seo::GetMailCatalog

GetMailCatalog(
string
$domain );

    Описание

    Определение наличия страницы в каталоге Mail.ru

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetMailCatalog($domain);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Сайт присутствует в каталоге Mail.ru";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Сайт отсутствует в каталоге Mail.ru";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Seo::GetPageRank

GetPageRank(
string
$url );

    Описание

    Поиск значения Google PageRank. Основан на данных Google toolbar. Возвращает значение PageRank страницы

    Принимаемые параметры

    $url

    Адрес сайта

    Возвращает

    PageRank значение
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $url = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $pr = $Seo->GetPageRank($url);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $pr;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetPosAport

GetPosAport(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе Апорт

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    Массив дополнительных параметров
    • $param['search_subdomain'] Искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] Количество просматриваемых страниц. по умолчанию 5

    Возвращает

    Номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosAport($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetPosGogo

GetPosGogo(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе GoGo

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    Массив дополнительных параметров
    • $param['search_subdomain'] Искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] Количество просматриваемых страниц. по умолчанию 5

    Возвращает

    Номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosGogo ($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetPosGoogle

GetPosGoogle(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе Google

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    Массив дополнительных параметров
    • $param['search_subdomain'] Искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] Количество просматриваемых страниц. по умолчанию 5

    Возвращает

    Номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosGoogle ($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetPositionSearch

GetPositionSearch(

$seo_position_search_query_id, int
$seo_characteristic_id );

    Описание

    Получение списка позиций в поисковой системе из БД

    Принимаемые параметры

    $seo_characteristic_id

    - идентификатор характеристики, которую необходимо получить

    $seo_position_search_query_id

    Возвращает

    массив с информацией или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $seo_position_search_query_id = 2;
      5.

    5.
      6.

    6.  $row = $Seo->GetPositionSearch($seo_position_search_query_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetPosLivesearch

GetPosLivesearch(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе Bing.com

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    Массив дополнительных параметров
    • $param['search_subdomain'] Искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] Количество просматриваемых страниц. по умолчанию 5

    Возвращает

    Номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosLivesearch ($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetPosRambler

GetPosRambler(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе Rambler

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    Массив дополнительных параметров
    • $param['search_subdomain'] Искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] Количество просматриваемых страниц. по умолчанию 5

    Возвращает

    Номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosRambler ($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetPosYahoo

GetPosYahoo(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе Yahoo

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    Массив дополнительных параметров
    • $param['search_subdomain'] Искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] Количество просматриваемых страниц. по умолчанию 5

    Возвращает

    Номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosYahoo ($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetPosYandex

GetPosYandex(
string
$domain, string
$text, [array
$param = array()] );

    Описание

    Определение позиции сайта в поисковой системе Yandex

    Принимаемые параметры

    $domain

    Адрес сайта

    $text

    Поисковый запрос

    $param

    массив дополнительных параметров
    • $param['search_subdomain'] искать ли поддомены переданного домена. по умолчанию true
    • $param['page_count'] количество просматриваемых страниц. по умолчанию 5

    Возвращает

    номер позиции или false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.  $text = 'cms';
      6.

    6.
      7.

    7.  $result = $Seo->GetPosYandex ($domain, $text);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    Seo::GetQuery

GetQuery(
int
$edit_query_id );

    Описание

    Получение списка поисковых запросов из БД

    Принимаемые параметры

    $edit_query_id

    Идентификатор запроса, который необходимо получить

    Возвращает

    Массив с записью БД, либо false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $edit_query_id = 1;
      5.

    5.
      6.

    6.  $row = $Seo->GetQuery($edit_query_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::GetRamblerCatalog

GetRamblerCatalog(
string
$domain );

    Описание

    Определение наличия страницы в каталоге Rambler

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->GetRamblerCatalog($domain);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Сайт присутствует в каталоге Rambler";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Сайт отсутствует в каталоге Rambler";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Seo::GetUrl

GetUrl(
str
$url, [boolean
$use_cache = true] );

    Описание

    Поисковый запрос URL и сохранение полученной страницы в кэше

    Принимаемые параметры

    $url

    URL-документа

    $use_cache

    использовать ли кэширование запрошенной страницы

    Возвращает

    контент документа

    [ Наверх ]

    Seo::GetYandexCatalog

GetYandexCatalog(
str
$domain );

    Описание

    Определения наличия страницы в каталоге Yandex, тИЦ, темы, страны и региона страницы

    Принимаемые параметры

    $domain

    Адрес сайта

    Возвращает

    Массив значений
    • $info['tyc'] int тИЦ страницы
    • $info['topic'] str Тема страницы
    • $info['country'] str Страна
    • $info['region'] str Регион

      1.  <?php
        2.

      2.  $Seo = new Seo();
        3.

      3.
        4.

      4.  $domain = 'www.hostcms.ru';
        5.

      5.
        6.

      6.  $row = $Seo->GetYandexCatalog($domain);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    [ Наверх ]

    Seo::InsertCharacteristic

InsertCharacteristic(
[array
$param = array()] );

    Описание

    Добавление характеристики страницы

    Принимаемые параметры

    $param

    Массив параметров
    • $param['seo_characteristic_date_time'] datetime Время и дата анализа страницы в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС
    • $param['seo_characteristic_yc_rubric'] str Рубрика в поисковой системе Яндекс.ru
    • $param['seo_characteristic_yc'] int Индекс цитирования
    • $param['site_id'] int Идентификатор сайта
    • $param['seo_characteristic_catalog_yandex'] bool Наличие в каталоге Яндекс.ru
    • $param['seo_characteristic_links_yandex'] int Ссылающиеся страницы по данным Яндекс.ru
    • $param['seo_characteristic_pr'] int Значение Google PageRank
    • $param['seo_characteristic_links_google'] int Ссылающиеся страницы по данным Googl.ru
    • $param['seo_characteristic_links_yahoo'] int Ссылающиеся страницы по данным Yahoo.com
    • $param['seo_characteristic_links_msn'] int Ссылающиеся страницы по данным Bing.com
    • $param['seo_characteristic_indexed_aport'] int Проиндексировано страниц сайта в Aport.ru
    • $param['seo_characteristic_indexed_yandex'] int Проиндексировано страниц сайта в Яндекс.ru
    • $param['seo_characteristic_indexed_yahoo'] int Проиндексированно страниц сайта в Yahoo.com
    • $param['seo_characteristic_indexed_msn'] int Проиндексировано страниц сайта в Bing.com
    • $param['seo_characteristic_indexed_rambler'] int Проиндексировано страниц сайта в Rambler.ru
    • $param['seo_characteristic_indexed_google'] int Проиндексировано страниц сайта в Google.ru
    • $param['seo_characteristic_catalog_rambler'] bool Наличие в каталоге Rambler.ru
    • $param['seo_characteristic_catalog_mail'] bool Наличие в каталоге Mail.ru
    • $param['seo_characteristic_catalog_dmoz'] bool Наличие в каталоге Dmoz.ru
    • $param['seo_characteristic_catalog_aport'] bool Наличие в каталоге Aport.ru
    • $param['seo_characteristic_catalog_yandex'] bool Наличие в каталоге Яндекс.ru
    • $param['seo_characteristic_counter_rambler'] bool Наличие счетчика Rambler's Top100
    • $param['seo_characteristic_counter_spylog'] bool Наличие счетчика SpyLog.ru
    • $param['seo_characteristic_counter_hotlog'] bool Наличие счетчика HotLog.ru
    • $param['seo_characteristic_counter_mail'] bool Наличие счетчика Mail.ru
    • $param['seo_characteristic_counter_liveinternet'] bool Наличие счетчика LiveInternet.ru

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $param['seo_characteristic_date_time'] = date('d.m.Y H:i:s');
      5.

    5.  $param['seo_characteristic_yc_rubric'] = 'Рубрика';
      6.

    6.  $param['seo_characteristic_yc'] = 1000;
      7.

    7.  $param['site_id'] = CURRENT_SITE;
      8.

    8.  $param['seo_characteristic_catalog_yandex'] = true;
      9.

    9.  $param['seo_characteristic_links_yandex'] = 15000;
      10.

    10.  $param['seo_characteristic_pr'] = 5;
      11.

    11.  $param['seo_characteristic_links_google'] = 14500;
      12.

    12.  $param['seo_characteristic_links_yahoo'] = 12000;
      13.

    13.  $param['seo_characteristic_links_msn'] = 12500;
      14.

    14.  $param['seo_characteristic_indexed_aport'] = 25000;
      15.

    15.  $param['seo_characteristic_indexed_yandex'] = 27000;
      16.

    16.  $param['seo_characteristic_indexed_yahoo'] = 25500;
      17.

    17.  $param['seo_characteristic_indexed_msn'] = 26000;
      18.

    18.  $param['seo_characteristic_indexed_rambler'] = 26500;
      19.

    19.  $param['seo_characteristic_indexed_google'] = 27000;
      20.

    20.  $param['seo_characteristic_catalog_rambler'] = true;
      21.

    21.  $param['seo_characteristic_catalog_mail'] = true;
      22.

    22.  $param['seo_characteristic_catalog_dmoz'] = true;
      23.

    23.  $param['seo_characteristic_catalog_aport'] = true;
      24.

    24.  $param['seo_characteristic_catalog_yandex'] = true;
      25.

    25.  $param['seo_characteristic_counter_rambler'] = false;
      26.

    26.  $param['seo_characteristic_counter_spylog'] = false;
      27.

    27.  $param['seo_characteristic_counter_hotlog'] = false;
      28.

    28.  $param['seo_characteristic_counter_mail'] = false;
      29.

    29.  $param['seo_characteristic_counter_liveinternet'] = true;
      30.

    30.
      31.

    31.  $newid = $Seo->InsertCharacteristic($param);
      32.

    32.
      33.

    33.  // Распечатаем результат
      34.

    34.  echo $newid;
      35.

    35.  ?>
      36.

    [ Наверх ]

    Seo::InsertPositionSearch

InsertPositionSearch(
[array
$param = array()] );

    Описание

    Добавление/обновление статистики по поисковым запросам в БД

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['seo_position_search_query_id'] Идентификатор позиции в поисковой системе
    • int $param['seo_search_query_id'] Идентификатор поискового запроса
    • datetime $param['seo_position_search_query_date_time'] Дата
    • int $param['seo_position_search_query_yandex'] позиция в яндекс
    • int $param['seo_position_search_query_rambler'] позиция в Rambler
    • int $param['seo_position_search_query_google'] позиция в Google
    • int $param['seo_position_search_query_aport'] позиция в Апорт
    • int $param['seo_position_search_query_gogo'] позиция в GoGo
    • int $param['seo_position_search_query_yahoo'] позиция в Yahoo
    • int $param['seo_position_search_query_livesearch'] позиция в Bing

    Возвращает

    Идентификатор вствленной записи, либо false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $param['seo_position_search_query_id'] = 0;
      5.

    5.  $param['seo_search_query_id'] = 1;
      6.

    6.  $param['seo_position_search_query_date_time'] = date('Y.m.d H:i:s');
      7.

    7.  $param['seo_position_search_query_yandex'] = 1;
      8.

    8.  $param['seo_position_search_query_rambler'] = 1;
      9.

    9.  $param['seo_position_search_query_google'] = 1;
      10.

    10.  $param['seo_position_search_query_aport'] = 1;
      11.

    11.  $param['seo_position_search_query_gogo'] = 1;
      12.

    12.  $param['seo_position_search_query_yahoo'] = 1;
      13.

    13.  $param['seo_position_search_query_livesearch'] = 1;
      14.

    14.
      15.

    15.  $newid = $Seo->InsertPositionSearch($param);
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  echo $newid;
      19.

    19.  ?>
      20.

    [ Наверх ]

    Seo::InsertQuery

InsertQuery(
[array
$param = array()] );

    Описание

    Добавление/обновление поискового запроса в БД

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['seo_search_query_id'] Идентификатор записи
    • int $param['site_id'] Идентификатор сайта
    • str $param['seo_search_query_value'] Ключевые слова

    Возвращает

    Идентификатор вставленной записи, либо false
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $param['seo_search_query_id'] = 0;
      5.

    5.  $param['site_id'] = CURRENT_SITE;
      6.

    6.  $param['seo_search_query_value'] = 'система управления контентом';
      7.

    7.
      8.

    8.  $newid = $Seo->InsertQuery($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    [ Наверх ]

    Seo::ParseGoogle

ParseGoogle(

$file );

    Принимаемые параметры

    $file

    [ Наверх ]

    Seo::ParseYandex

ParseYandex(

$file );

    Принимаемые параметры

    $file

    [ Наверх ]

    Seo::ShowArrow

ShowArrow(
int
$prev_value, int
$current_value );

    Описание

    Отображение стрелочек динамики изменения значений

    Принимаемые параметры

    $prev_value

    предыдущее значение

    $current_value

    текущее значение
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $prev_value = 1;
      5.

    5.  $current_value = 10;
      6.

    6.
      7.

    7.  $Seo->ShowArrow($prev_value, $current_value);
      8.

    8.  ?>
      9.

    [ Наверх ]

    Seo::ShowArrowQuery

ShowArrowQuery(
int
$prev_value, int
$current_value );

    Описание

    Отображение стрелочек динамики изменения значений поисковых запросов

    Принимаемые параметры

    $prev_value

    предыдущее значение

    $current_value

    текущее значение
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $prev_value = 1;
      5.

    5.  $current_value = 10;
      6.

    6.
      7.

    7.  $Seo->ShowArrowQuery($prev_value, $current_value);
      8.

    8.  ?>
      9.

    [ Наверх ]

    Seo::ShowTableRow

ShowTableRow(
array
$report, str
$field_name, str
$field_value, [array
$param = array()] );

    Описание

    Отображение строк таблицы в Отчете

    Принимаемые параметры

    $report

    Массив данных
    • $report[]['seo_characteristic_yc'] int тИЦ
    • $report[]['seo_characteristic_pr'] int PR
    • $report[]['seo_characteristic_links_google'] int Ссылающиеся страницы по данным Google
    • $report[]['seo_characteristic_links_yandex'] int Ссылающиеся страницы по данным Yandex
    • $report[]['seo_characteristic_links_yahoo'] int Ссылающиеся страницы по данным Yahoo
    • $report[]['seo_characteristic_links_msn'] int Ссылающиеся страницы по данным Bing.com
    • $report[]['seo_characteristic_indexed_aport'] int Индексированные страницы сервисом Aport
    • $report[]['seo_characteristic_indexed_yandex'] int Индексированные страницы сервисом Yandex
    • $report[]['seo_characteristic_indexed_yahoo'] int Индексированные страницы сервисом Yahoo
    • $report[]['seo_characteristic_indexed_msn'] int Индексированные страницы сервисом Bing.com
    • $report[]['seo_characteristic_indexed_rambler'] int Индексированные страницы сервисом Rambler
    • $report[]['seo_characteristic_indexed_google'] int Индексированные страницы сервисом Google
    • $report[]['seo_characteristic_catalog_yandex'] bool Наличие страницы в каталоге Yandex
    • $report[]['seo_characteristic_catalog_rambler'] bool Наличие страницы в каталоге Rambler
    • $report[]['seo_characteristic_catalog_mail'] bool Наличие страницы в каталоге Mail
    • $report[]['seo_characteristic_catalog_dmoz'] bool Наличие страницы в каталоге Dmoz
    • $report[]['seo_characteristic_catalog_aport'] bool Наличие страницы в каталоге Aport
    • $report[]['seo_characteristic_counter_rambler'] bool Наличие счетчика Rambler
    • $report[]['seo_characteristic_counter_spylog'] bool Наличие счетчика SpyLog
    • $report[]['seo_characteristic_counter_hotlog'] bool Наличие счетчика HotLog
    • $report[]['seo_characteristic_counter_mail'] bool Наличие счетчика Mail
    • $report[]['seo_characteristic_counter_liveinternet'] bool Наличие счетчика LiveInternet

    $param

    Массив дополнительных параметров
    • $param['arrow'] bool Отображение стрелочек динамики изменения значений
    • $param['status'] bool Графическое отображение статуса наличия счетчиков и страницы в каталогах
    • $param['inverse'] bool Инвертирование отображения динамики изменения значений
    • $param['count'] int Количество строк в массиве данных

    $field_name

    Название строки

    $field_value

    Название поля БД

    [ Наверх ]

    Seo::ShowTableTitleReport

ShowTableTitleReport(
array
$report,
$field_name, [array
$param = array()] );

    Описание

    Отображение шапки таблицы в отчете

    Принимаемые параметры

    $report

    Массив данных
    • $report[]['seo_characteristic_date_time'] str Дата
    • $report[]['seo_position_search_query_date_time'] str Дата

    $param

    Массив дополнительных параметров

    $field_name

    [ Наверх ]

    Seo::UrlWww

UrlWww(
str
$domain );

    Описание

    Обрезает "www" у домена

    Принимаемые параметры

    $domain

    Анализируемый адрес домена

    Возвращает

    Адрес домена без "www"
    1.  <?php
      2.

    2.  $Seo = new Seo();
      3.

    3.
      4.

    4.  $domain = 'www.hostcms.ru';
      5.

    5.
      6.

    6.  $result = $Seo->UrlWww ($domain);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    Seo::YandexXmlRequest

YandexXmlRequest(

$query, [
$page = 0] );

    Принимаемые параметры

    $query

    $page

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class shop

Class shop

[Строка 15]

Размещен: /shop/shop.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Интернет-магазин".
Файл: /modules/shop/shop.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheDiscountsForItem = array()

  • $CacheGetAllPricesForItem = array()

        Кэш для метода GetAllPricesForItem()

  • $CacheGetCatalogItemIdByCmlId = array ()

  • $CacheGetCity = array()

        Кэш для метода GetCity()

  • $CacheGetCityArea = array()

        Кэш для метода GetCityArea()

  • $CacheGetCountItemsAndGroups = array()

        Кэш для GetCountItemsAndGroups

  • $CacheGetCountry = array()

        Кэш для метода GetCountry()

  • $CacheGetCurrencyByLike = array ()

  • $CacheGetDiscount = array ()

        Кэш скидок для GetDiscount

  • $CacheGetItem = array ()

        Кэш товаров для метода GetItem

  • $CacheGetItemPropertyIdByCmlId = array ()

  • $CacheGetLocation = array()

        Кэш для метода GetLocation()

  • $CacheGetPriceByCmlId = array ()

  • $CacheGetPriceForItem = array()

        Кэш для метода GetPriceForItem()

  • $CacheGetSpecialPriceForItem = array()

        Кэш для метода GetSpecialPriceForItem()

  • $CacheGetSpecialPricesForItem = array()

        Кэш для метода GetSpecialPricesForItem()

  • $CacheGetTax = array()

        Кэш для метода GetTax()

  • $CacheModificationItems = array()

        Массив ID модификаций товара для товаров

  • $cache_mesure =

        Кэш информации о единицах измерений

  • $cache_producer =

        Кэш информации о производителях

  • $CartType =  0

        Тип сохранения корзины, 0 - COOKIES, 1 - СЕССИЯ.

  • $error =

  • $float_format =  "%.2f"

        Формат для this->Round()

  • $GetAllItemTotalCount =  0

        Свойство содержит информацию об общем количестве товаров, выбранных методом GetAllItems()

  • $GetAllProducersTotalCount =  0

        Свойство содержит информацию об общем количестве производителей, выбранных методом GetAllProducers()

  • $hidden =  ""

  • $iConvertPriceFractionalPart =  2

        Количество знаков после запятой при округлении методом ConvertPrice()

  • $item_catalog_price =  0

        Цена товара магазина

  • $MasGroup = array ()

  • $PropertyGroupMass = array ()

        Кэш с данными о дополнительных свойствах групп магазина

  • $setCookieSubdomain =  TRUE

        Устанавливать cookies для поддоменов.

  • $use_cookies_read_control =  false

        Использовать ли систему контроля корректности данных, принимаемых из cookies.

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • mixed AddIntoCart()

    Метод помещения товара в корзину

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • mixed AssignGroupImage()

    Метод для установки имени изображения для группы товаров

  • mixed AssignItemImage()

    Метод для установки имени изображения для товара

  • mixed AssignShopWatermark()

    Метод осуществляющий обновление данных о файле watermark'a для магазина

  • bool CancelOrder()

    Метод для отмены заказа (устанавливает поле shop_order_cancel = 1)

  • bool ChangeItemsOfOrderRest()

    Изменение остатка товаров в заказе

  • void ClearCookieAndSessionCart()

    Метод для очистки корзины кукисов и сессий

  • string ClearPath()

    Метод очищает путь от запрещенных символов

  • float ConvertPrice()

    Конвертирует цену в различных форматах к цене в формате xxxx.yy

  • void CopyAffiliats()

    Копирование парнерских программ

  • void CopyCondOfDelivery()

    Копирование условий типа доставки

  • void CopyCoupons()

    Копирование купонов магазина на скидку

  • void CopyDiscounts()

    Копирование скидок на товары

  • void CopyExternalPropertiesForItem()

    Копирование значений дополнительных свойств товара

  • mixed CopyGroupsItemsProperty()

    Копирование дополнительного свойства товаров

  • int CopyItem()

    Копирование товара

  • mixed CopyItemsProperty()

    Копирование дополнительного свойства товаров

  • void CopyOrderDiscounts()

    Копирование скидок от суммы заказа и их купонов

  • void CopyPrices()

    Копирование цен для магазина

  • void CopyProducers()

    Копирование производителей

  • void CopyPropertiesForGroup()

    Копирование дополнительных свойств групп товаров, включая группы дополнительных свойств групп

  • void CopyPropertiesForItem()

    Копирование дополнительных свойств товаров, включая подгруппы дополнительных свойств

  • void CopySallers()

    Копирование продавцов

  • mixed CopyShop()

    Копирование информации о магазине, а также дополнительных свойствах товаров, групп и групп этих свойств

  • void CopyShopDir()

  • void CopySystemsOfPay()

    Копирование платежных систем

  • void CopyTypesOfDelivery()

    Копирование типа доставки

  • array CorrectPropertiesGroup()

    Метод корректирует строку данных о дополнительном свойстве группы в соответствии с его типом.

  • array CorrectPropertiesItem()

    Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.

  • mixed CreateDirectory()

    Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает

  • boolean DeleteAllEItems()

    Метод удаляет все электронные товары заданного товара

  • void DeleteAllItemsCatalogAndGroups()

    Метод очистки таблиц товаров и групп

  • boolean DeleteAllModificationForItem()

    Метод удаления всех модификаций товара

  • boolean DeleteCart()

    Удаление товара из корзины

  • bool DeleteCity()

    Метод, осуществляющий удаление города

  • boolean DeleteCityArea()

    Метод удаления района города

  • mixed DeleteComment()

    Метод удаления информации об отзыве на товар

  • mixed DeleteCompany()

    Метод удаления информации об организации

  • array DeleteCondOfDelivery()

    Метод, осуществляющий удаление условия доставки

  • array DeleteCountry()

    Метод, осуществляющий удаление страны

  • mixed DeleteCoupon()

    Метод для удаления информации о купоне

  • mixed DeleteCurrency()

    Метод, осуществляющий удаление валюты

  • array DeleteDiscount()

    Метод, осуществляющий удаление скидки

  • void DeleteEItem()

    Метод удаления информации об электронном товаре

  • boolean DeleteGroup()

    Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)

  • array DeleteItem()

    Метод, осуществляющий удаление товара

  • resource DeleteItemDiscount()

    Метод удаления скики для товара

  • array DeleteLocation()

    Метод, осуществляющий удаление области

  • array DeleteMesure()

    Метод, осуществляющий удаление единицы измерения

  • resource DeleteOrder()

    Метод, осуществляющий удаление заказа

  • mixed DeleteOrderDiscount()

    Метод для удаления информации о скидке для заказов

  • array DeleteOrderItems()

    Метод, осуществляющий удаление товара в заказе

  • array DeleteOrderStatus()

    Метод, осуществляющий удаление статуса заказа

  • array DeletePrice()

    Метод, осуществляющий удаление типа цены

  • int DeletePriceForItem()

    Метод удаляет цену для элемента каталога

  • resource DeletePricesForAllItem()

    Метод удаляет все дополнительные цены для товара

  • boolean DeleteProducer()

    Метод, осуществляющий удаление производителя

  • resource DeletePropertiesGroupsDir()

    Удаление информации о группе дополнительных свойств групп товаров

  • mixed DeletePropertiesGroupValue()

    Удаление значения дополнительного свойства группы

  • boolean DeletePropertiesItem()

    Удаление значение дополнительного свойства товара

  • resource DeletePropertiesItemsDir()

    Удаление информации о группе дополнительных свойств товара

  • boolean DeletePropertyForGroup()

    Метод удаляет принадлежность дополнительного свойтсва группе товаров

  • bool DeletePropretyOfGroup()

    Удаление дополнительного свойства группы товаров

  • resource DeletePropretyOfItems()

    Метод, осуществляющий удаление свойства товара

  • mixed DeleteSeller()

    Метод, осуществляющий удаление продавца.

  • array DeleteShop()

    Метод, осуществляющий удаление магазина

  • boolean DeleteShopsDir()

    Удаление раздела интернет-магазинов. Магазины, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.

  • void DeleteShopWatermark()

  • boolean DeleteSiteUserAccountTransaction()

    Удаление транзакции

  • resource DeleteSpecialPrice()

    Удаление информации о специальной цене

  • array DeleteSystemOfPay()

    Метод, осуществляющий удаление платёжной системы

  • array DeleteTax()

    Метод, осуществляющий удаление налога

  • array DeleteTyingProducts()

    Метод удаления сопутствующих товаров

  • boolean DeleteTypeOfDelivery()

    Метод, осуществляющий удаление типа доставки

  • void ExecSystemsOfPayChangeStatus()

    Метод выполнения обработчика платежной системы для смены статуса заказа

  • void ExecSystemsOfPayHandler()

    Метод выполнения обработчика платежной системы

  • void FillMasGroup()

    Метод формирования массива групп верхнего уровня для данного магазина

  • array FillMasGroupDirExtProperty()

    Заполнение массива групп дополнительных свойств групп товаров

  • void FillMasGroupExtProperty()

    Метод формирования массива групп дополнительных свойств товара самого верхнего уровня для данного магазина

  • void FillMemCacheComments()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

  • void FillMemCacheCountItemsAndGroup()

    Внутренний метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.

  • void FillMemCacheDiscountsForItem()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.

  • void FillMemCacheGetAllPricesForItem()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  ценами для групп товаров. Заполнению подвергается массив  $this->CacheGetSpecialPricesForItem[$shop_items_catalog_item_id]

  • void FillMemCacheGoupsIdTree()

    Внутренний метод формирует дерево групп и подгрупп в массиве по их идентификаторам. Заполянется также в методе FillMasGroup()

  • void FillMemCacheItems()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  товаров. Заполнению подвергается массив  $this->CacheGetItem[$shop_items_catalog_item_id]

  • void FillMemCacheModificationItems()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

  • void FillMemCachePriceForItem()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  ценами для товаров. Заполнению подвергается массив  $this->CacheGetPriceForItem[$shop_list_of_prices_id . '_' . $shop_items_catalog_item_id]

  • void FillMemCachePropertiesItem()

    Внутренний метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.

  • void FillMemCachePropertysGroup()

    Метод формирует в памяти данные о свойствах групп магазина.

  • void FillMemCacheSpecialPricesForItem()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  специальными ценами. Заполнению подвергается массив  $this->CacheGetSpecialPricesForItem [$shop_items_catalog_item_id]

  • void FillMemCacheTyingProducts()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

  • void FormatGetCart()

    Преобразование массива корзины при извлечении

  • void FormatSetCart()

    Преобразование массива корзины при записи

  • string GenCmlId()

    Генерация идентификатора в формате CommerceML для группы товаров

  • string GenXml4Comment()

    Метод генерирующий XML для отзыва о товаре

  • string GenXml4Company()

    Метод генерирует XML для организации

  • str GenXml4CompareItems()

    Метод генерирует xml для товаров, выбранных для сравнения

  • void GenXML4Currency()

    Метод генерирует XML для указанной валюты

  • string GenXml4Item()

    Внутренний метод построения XML для товара, его свойств и сопутствующих товаров

  • int GenXml4ItemCatalogCommentAverageGrade()

    Метод возвращает XML со средней оценкой описания активных отзывов по товару.

  • string GenXml4ItemCatalogComments()

    Метод возвращает все комментарии, относящиеся к данному товару.

  • str GenXml4Mesures()

    Метод генерирует XML для единиц измерения

  • str GenXml4OrderStatus()

    Метод генерирует XML для статуса доставки

  • str GenXML4PriceForShop()

    Возвращает XML цены для группы пользователей.

  • string GenXml4Properties()

    Метод построения XML для свойств товаров, доступных группе.

  • str GenXml4Property()

    Возвращает XML свойства.

  • str GenXml4Saller()

    Возвращает XML продавца.

  • string GenXml4Sallers()

    Метод построения XML для продавцов.

  • string GenXml4Shop()

    Метод генерации XML для магазина

  • str GenXML4SpecialPrice()

    Формирование XML для специальных цен товара

  • str GenXml4Taxes()

    Формирование XML для налогов

  • void GenXmlForGroupsPropertyDir()

    Генерация XML для групп дополнительных свойств групп товаров

  • void GenXmlForItemsPropertyDir()

    Генерация XML для групп дополнительных свойств

  • string GenXmlForSystemOfPays()

    Генерация XML для списка всех платежных систем.

  • mixed GenXmlProducerList()

    Метод генерирует XML для списка продавцов магазина

  • boolean GetAccessShopItem()

    Определение доступности товара

  • array GetAdditionalPropertyDirPathArray()

    Получение пути от текущего каталога дополнительных свойств товара к корневому

  • array GetAdditionalPropertyPathArray()

    Получение пути от текущего каталога дополнительных свойств товара к корневому

  • resource GetAllCity()

    Получение списка городов

  • resource GetAllCityArea()

    Метод выборки всех районов города

  • array GetAllComments()

    Метод возвращает список всех комментариев

  • mixed GetAllCompanies()

    Метод для получения списка всех компаний

  • resource GetAllCondOfDelivery()

    Метод выборки всех условий доставки

  • array GetAllCountries()

    Метод, осуществляющий извлечение всех стран

  • resource GetAllCoupons()

    Метод возвращает список купонов по заданным условиям

  • mixed GetAllCurrency()

    Метод выборки информации обо всех валютах

  • resource GetAllDiscounts()

    Метод возвращает список всех скидок

  • mixed GetAllDiscountsForItem()

    Метод извлечения информации обо всех скидках для данного товара

  • array GetAllGroups()

    Получение всех групп магазина

  • mixed GetAllItems()

    Получение всех товаров заданного магазина и заданной группы товаров

  • mixed GetAllItemsForOrder()

    Получение заказанных товаров

  • resource GetAllListProperties()

    Получение всех дополнительных свойств для магазина

  • resource GetAllLocation()

    Получение списка всех областей (штатов)

  • resource GetAllMesures()

    Метод выборки всех единиц измерения

  • mixed GetAllModificationItems()

    Метод возвращает информацию обо всех модификациях данного товара

  • resource GetAllOrderDiscounts()

    Метод для извлечения информации обо всех скидках

  • mixed GetAllOrders()

    Метод выборки заказов для магазина

  • mixed GetAllOrderStatus()

    Получение информации обо всех статусах заказаов

  • mixed GetAllPricesForItem()

    Получение информации о ценах, заданных для товара

  • mixed GetAllPricesForShop()

    Получение списка цен для магазина

  • resource GetAllProducers()

    Получение информации обо всех производителях

  • mixed GetAllPropertiesGroup()

    Метод извлечения информации о дополнительных свойствах группы товаров

  • resource, GetAllPropertiesGroupsDirForDir()

    Получаем список всех групп дополнительных свойств групп товаров

  • mixed GetAllPropertiesGroupsDirForShop()

    Получение инфомации обо всех группах дополнительных свойств групп товаров конкретного магазина

  • mixed GetAllPropertiesItem()

    Метод извлечения информации о дополнительных свойствах заданного товара

  • resource GetAllPropertiesItemsDirForShop()

    Получение информации обо всех группах дополнительных свойств товара для конкретного магазина

  • resource GetAllPropertiesItemsForDir()

    Получение информации обо всех свойствах хранящихся в конкретной группе дополнительных свойств конкртеного магазина

  • resource GetAllPropretyOfGroup()

    Получение информации о ВСЕХ дополнительных свойствах групп магазина

  • resource GetAllSellers()

    Получение информации о всех продавцах магазина $shop_id, если $shop_id = false,  то о продавцах всех магазинов

  • resource GetAllShops()

    Метод для получения списка всех магазинов

  • void GetAllShopsDirs()

    Получение информации о разделах интернет-магазинов

  • resource GetAllShopsFromDir()

    Получение информации о интернет-магазинах раздела

  • mixed GetAllSiteUserAccountTransaction()

    Метод возвращает данные обо всех транзакциях пользователя сайта

  • mixed GetAllSpecialPricesForItem()

    Получение информации о всех специальных ценах товара

  • resource GetAllSystemOfPay()

    Получение всех активных платежных систем

  • resource GetAllTax()

    Получение информации о налогах

  • resource GetAllTypeOfDelivery()

    Метод выборки всех типов доставки для конкретного магазина

  • array GetCart()

    Извлечение корзины в зависимости от CartType.

  • mixed GetCatalogItemIdByCmlId()

    Метод возвращает данные о товаре по идентификатору товара стандарта CommerceML

  • mixed GetCity()

    Метод, осуществляющий извлечение города

  • mixed GetCityArea()

    Получение информации о районе города по идентификатору района

  • void GetCityAreaByName()

  • void GetCityByName()

  • array GetComment()

    Метод возвращает информацию о комментарии к товару

  • mixed GetCompany()

    Метод для получения информации об организации

  • array GetCondOfDelivery()

    Метод, осуществляющий извлечение условия доставки

  • mixed GetCondOfDeliveryXml()

    Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)

  • mixed GetCookie()

    Загрузка массива данных из cookies

  • void GetCookieCart()

    Получить содержимое корзины в cookies

  • void GetCookieExpires()

    Метод возвращает время истечения данных в корзине, хранящейся в кукисах.

  • int GetCountAllComments()

    Получение числа комментариев к товарам

  • mixed GetCountCity()

    Получение числа городов для области

  • mixed GetCountCityAreas()

    Получение числа районов города

  • mixed GetCountCondOfDelivery()

    Получение числа условий доставки для типа доставки

  • mixed GetCountCountry()

    Получение числа стран

  • mixed GetCountCurrency()

    Получение числа валют в справочнике

  • mixed GetCountDiscount()

    Получение числа скидок для магазина

  • array GetCountItemsAndGroups()

    Получение числа элементов и групп для переданной родительской группы

  • mixed GetCountItemsCatalog()

    Получение числа товаров в одном или во всех разделах магазина

  • mixed GetCountItemsWithConditions()

    Получение числа товаров, параметры которых удовлетворяют заданным условиям

  • mixed GetCountLocation()

    Получение числа областей (штатов) для страны

  • mixed GetCountMesures()

    Получение числа единиц измерения в справочнике

  • mixed GetCountOrder()

    Метод выборки количества заказов для магазина

  • mixed GetCountOrderStatus()

    Получение числа статусов заказа

  • mixed GetCountProducers()

    Получение числа производителей для данного магазина

  • mixed GetCountProperties()

    Получение числа свойств товаров конкретного магазина

  • array GetCountry()

    Метод, осуществляющий извлечение страны

  • void GetCountryByName()

  • mixed GetCountSellers()

    Получение числа продавцов в справочнике

  • mixed GetCountShops()

    Получение числа магазинов для одного или всех сайтов, обслуживаемых системой управления

  • mixed GetCountSystemOfPay()

    Получение числа систем оплаты

  • mixed GetCountTax()

    Получение числа налогов в справочнике

  • mixed GetCountTypeOfDelivery()

    Получение числа типов доставок для данного магазина

  • mixed GetCountTypePrices()

    Получение числа типов цен для магазина

  • mixed GetCoupon()

    Метод возвращает массив с информацией о купоне

  • mixed GetCouponByText()

    Возвращает информацию о купоне по его тексту

  • mixed GetCurrency()

    Метод, осуществляющий извлечение информации о валюте

  • mixed GetCurrencyByInternationalName()

    Метод для получения списка валют с указанным международным названием

  • mixed GetCurrencyByLike()

    Метод, возвращающий информацию о валюте из базы согласно имени $string используя оператор LIKE

  • float GetCurrencyCoefficientToShopCurrency()

    Метод определения коэффициента пересчета валюты товара в валюту магазина

  • mixed GetCurrencyForShop()

    Получение валюты, указанной по умолчанию для магазина

  • mixed GetCurrencyXml()

    Метод формирования xml для валюты

  • mixed GetDefaultCurrency()

    Получение информации о базовой валюте

  • mixer GetDefaultOrderStatus()

    Получение статуса заказа, установленного по умолчанию

  • array GetDelimitedGroups()

    Формирование дерева групп для магазина.

  • array GetDelimitedGroupsDirExtProperty()

    Метод формирования дерева групп дополнительных свойств групп товаров для магазина.

  • array GetDelimitedGroupsExtProperty()

    Метод формирования дерева групп для магазина.

  • array GetDiscount()

    Метод, осуществляющий извлечение информации о скидке

  • array GetEItem()

    Метод, осуществляющий извлечение информации об электронном товаре

  • int GetEitemCount()

    Получение количества оставшегося электронного товара

  • resource GetEitemsForItem()

    Метод получения данных об электронных товарах конкретного товара

  • mixed GetGroup()

    Получение информации о группе товаров

  • mixed GetGroupDir()

    Получение пути хранения файлов группы товаров

  • mixed GetGroupIdByCmlId()

    Внутренний метод возвращает данные о группе товаров по идентификатору группы товаров стандарта CommerceML

  • $resource GetGroups()

    Метод возвращает список групп магазина

  • resource GetGroupsByPropertyValue()

    Получение информации обо всех группах, по значению доп. свойства

  • array GetGroupsTree()

    Получение массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской

  • string GetGroupsXmlTree()

    Служебный метод построения дерева xml для групп.

  • mixed GetGroupWithPath()

    Получение информации о группе по пути, если такая существует в данной подгруппе магазина

  • mixed GetGroupWithValue()

    Получение информации о группе по наименованию, если такая существует в данной подгруппе магазина

  • array GetItem()

    Метод, осуществляющий извлечение информации о товаре

  • resource GetItemByParam()

    Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента

  • mixed GetItemDir()

    Получение пути хранения файлов товара

  • mixed GetItemDiscount()

    Получение информации о скидке на товар

  • array GetItemFromCart()

    Получение информации о товаре из корзины для пользователя

  • array GetItemPath()

    Метод определения идентификатора группы товаров и идентификатора товара по значению URL

  • mixed GetItemPropertyIdByCmlId()

    Метод возвращает данные о дополнительном свойстве товара по идентификатору дополнительного свойства формата CommerceML

  • mixed GetItemPropertyValueById()

    Метод получения информации о значении дополнительного свойства товара по идентификатору значения

  • array GetItemsFromCart()

    Получение товаров, находящихся в корзине

  • boolean GetItemsFromCookiesToCart()

    Устаревший метод. См. TransferFromCartIntoTable()

  • string GetItemsXmlTree()

    Метод построения XML для товаров

  • mixed GetItemXml()

    Метод формирования xml товара

  • array GetLocation()

    Метод, осуществляющий извлечение области

  • void GetLocationByName()

  • array GetMasGroupToRoot()

    Возвращает $this->mas_groups_to_root

  • str GetMd5CacheCountItemsAndGroup()

    Получение хэша для кэширвоания количества товаров и групп

  • array GetMesure()

    Метод, осуществляющий извлечение информации о единице измерения

  • mixed GetMesuresByLike()

    Метод, возвращающий информацию о мере измерения из базы согласно имени $string используя оператор LIKE

  • array GetOrder()

    Извлечение заказа по его ID

  • array GetOrderByGuid()

    Извлечение заказа по его GUID

  • mixed GetOrderDiscount()

    Метод возвращает информацию о скидке для заказов

  • float GetOrderDiscountForSum()

    Устаревший метод. Заменен на GetOrderDiscountForSumAndCount()  Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина

  • float GetOrderDiscountForSumAndCount()

    Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных для указанного магазина

  • resource GetOrderDiscountWithConditions()

    Метод возвращает список скидок на сумму заказа по заданным условиям

  • mixed GetOrderInfoArray()

    Метод формирования массива с информацией о заказе для вставки в заказы

  • array GetOrderItem()

    Метод, осуществляющий извлечение товара из заказа

  • resource GetOrderItems()

    Метод, осуществляющий извлечение товаров из заказа

  • array GetOrdersStatus()

    Метод, осуществляющий извлечение состояния заказа

  • int GetOrderSum()

    Расчет суммы заказа

  • string GetOrderXml()

    Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных

  • string GetPathGroup()

    Метод формирования пути по группам товара

  • string GetPathItem()

    Метод формирования пути к товару

  • result GetPathProducer()

    Метод формирования пути по производителю

  • array GetPrice()

    Метод, осуществляющий извлечение типа цены

  • mixed GetPriceByCmlId()

    Метод возвращает данные о цене по идентификатору цены формата CommerceML

  • array GetPriceForCondOfDelivery()

    Получение цены доставки с учетом указанного налога

  • array GetPriceForItem()

    Метод определения наличия указанной цены для заданного товара

  • array GetPriceForUser()

    Метод определения цены товара для заданного пользователя

  • array GetProducer()

    Метод, осуществляющий извлечение информации о производителе

  • mixed GetProducerByName()

    Метод для получения списка производителей по названию

  • mixed GetPropertiesGroupsDir()

    Получение информации о группе дополнительных свойств групп товаров

  • mixed GetPropertiesGroupValue()

    Получение данных о значении дополнительного свойства групп товаров

  • mixed GetPropertiesItemForGroups()

    Получение информации о принадлежности дополнительного свойства группе товаров

  • mixed GetPropertiesItemsDir()

    Получение данных о группе дополнительных свойств товара

  • array GetPropertiesOfGroup()

    Метод для получения списка идентификаторов свойств товаров для определенной группы.

  • mixed GetPropertiesOfGroupForXml()

    Возвращает список свойств, доступных для вывода в группе

  • array GetPropertysGroup()

    Получение данных о дополнительных свойствах группы магазина.

  • mixed GetPropretyOfGroup()

    Получение информации о дополнительном свойстве группы товаров

  • array GetPropretyOfItems()

    Метод, осуществляющий извлечение свойства товара по идентификатору свойства товара

  • str GetRealPath()

    Корректирует путь

  • array GetSeller()

    Получение информации о продавце по его идентификатору.

  • mixed GetSellerByName()

    Метод для получения списка продавцов по названию

  • void GetSessionCart()

    Получить содержимое корзины в session

  • array GetShop()

    Метод, осуществляющий извлечение информации о магазине

  • int GetShopByStructureId()

    Получение информации о магазине, связанном с узлом структуры

  • mixed GetShopCurrency()

    Получение информации о валюте магазина

  • resource GetShopDiscount()

    Получение списка скидок для магазина

  • int GetShopGroupAccess()

    Определение уровня доступности группы товаров

  • array GetShopGroupsToRoot()

    Получение массива с данными о каталогах магазина, начиная с данной и до корневой

  • int GetShopItemAccess()

    Определение уровня доступности товара

  • array GetShopPathArray()

    Получение пути от текущего каталога к корневому

  • void GetShopsDir()

  • array GetShopsDirPathArray()

    Построение массива пути от текущего раздела интернет-магазинов к корневому

  • array GetShopsDirs()

    Формирование дерева разделов интернет-магазинов

  • mixed GetShopWhithStructureId()

    Метод выбора информации о магазине данного узла структуры сайта

  • int GetSiteUserAccountSum()

    Метод возвращает сумму пользователя сайта в базовой валюте

  • mixed GetSiteUserAccountTransaction()

    Получение информации о транзакции

  • array GetSiteUsersGroupsForUser()

    Получение списка групп пользователий, в которых содержится пользователь сайта

  • mixed GetSpecialPrice()

    Получение информации о специальной цене

  • mixed GetSpecialPriceForItem()

    Получение информации о специальной цене (в зависимости от количества этого товара в корзине),  подходящей для товара.

  • mixed GetSpecialPricesForItem()

    Получение информации в виде массива о всех специальных ценах товара

  • mixed GetSpecialPriceValueForItem()

    Получение специальной цены (в зависимости от количества этого товара в корзине),  подходящей для товара.

  • mixed GetSystemOfPay()

    Метод, осуществляющий извлечение платёжной системы

  • array GetTax()

    Метод, осуществляющий извлечение налога

  • mixed GetTaxIdByCmlId()

    Внутренний метод возвращает данные о налоге по идентификатору налога формата CommerceML

  • array GetTyingProducts()

    Получение информации о сопутствующем товаре

  • array GetTyingProductsForItem()

    Получение ID сопутствующих товаров для заданного товара

  • array GetTypeOfDelivery()

    Метод, осуществляющий извлечение типа доставки

  • array GetTypeOfDeliveryForOrder()

    Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.

  • mixed GetValueItemProperty()

    Получение значения дополнительного свойства для товара

  • boolean GetXml4Tags()

    Генерация XML для облака тегов магазина

  • mixed GetXmlForItemsOrder()

    Метод формирования xml для товаров в заказе

  • string GetXmlForOrder()

    Метод формирования xml о заказе по идентификатору заказа

  • mixed GetXmlProducer()

    Метод генерирует XML для производителя в магазине

  • bool GroupIsParent()

    Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id

  • array ImportCML()

    Импорт из формата CommerceML

  • array IndexationShopItems()

    Индексация товаров

  • int InsertCity()

    Метод, осуществляющий вставку города

  • int InsertCityArea()

    Метод добавления/редактирования информации о районе города

  • mixed InsertComment()

    Метод добавления/обновления информации об отзыве на товар

  • mixed InsertCompany()

    Метод для вставки/обновления организации

  • int InsertCondOfDelivery()

    Метод, осуществляющий вставку условия доставки

  • int InsertCountry()

    Метод, осуществляющий вставку страны

  • mixed InsertCoupon()

    Метод для вставки/обновления информации о купоне

  • mixed InsertCurrency()

    Метод,осуществляющий вставку информации о валюте

  • возвращает InsertDiscount()

    Метод, осуществляющий вставку информации о скидке

  • mixed InsertEItem()

    Метод вставки/обновления информации об электронном товаре

  • mixed InsertGroup()

    Вставку/обновление группы товаров

  • int InsertItem()

    Вставка информации о товаре. Может принимать только часть параметров, при этом обновлены будут только переданные значения

  • mixed InsertItemDiscount()

    Метод вставки скидки для определенного товара

  • boolean InsertItemsCatalogTags()

    Вставка тегов для товаров

  • int InsertLocation()

    Метод, осуществляющий вставку области

  • возвращает InsertMesure()

    Метод, осуществляющий вставку  информации о единице измерения

  • int InsertOrder()

    Метод, осуществляющий вставку заказа

  • mixed InsertOrderDiscount()

    Метод для вставки/обновления информации о скидке для заказов

  • int InsertOrderItems()

    Метод, осуществляющий вставку товара в заказ

  • int InsertOrderStatus()

    Метод, осуществляющий вставку статуса заказа

  • void InsertOrderWithoutSystemOfPay()

    Метод вставки заказа, если платежная система не выбрана

  • int InsertPrice()

    Метод, осуществляющий вставку типа цены

  • mixed InsertPricesToItem()

    Метод вставки связи товара и цены из справочника цен

  • int InsertProducer()

    Метод, осуществляющий вставку производителя

  • mixed InsertPropertiesGroupsDir()

    Добавление информации о группе дополнительных свойств каталогов товаров

  • mixed InsertPropertiesGroupValue()

    Вставка значение дополнительного свойства групп товаров

  • int InsertPropertiesItem()

    Метод вставки значения дополнительного свойства товара

  • mixed InsertPropertiesItemsDir()

    Добавление информации о группе дополнительных свойств товара

  • mixed InsertPropertyForGroup()

    Установка принадлежности дополнительного свойства группе товаров

  • mixed InsertPropretyOfGroup()

    Вставка дополнительного свойства группы товаров

  • mixed InsertPropretyOfItems()

    Метод, осуществляющий вставку свойства товара

  • int InsertSeller()

    Метод, осуществляющий вставку или обновление продавца.

  • int InsertShop()

    Вставка информации о магазине

  • mixed InsertShopsDir()

    Добавление/обновление раздела иентернет-магазинов

  • mixed InsertSiteUserAccountTransaction()

    Вставка в базу данных транзакции по лицевому счету пользователя

  • mixed InsertSpecialPrice()

    Добавление информации о специальной цене

  • int InsertSystemOfPay()

    Метод, осуществляющий вставку платёжной системы

  • int InsertTax()

    Метод, осуществляющий вставку налога

  • mixed InsertToCart()

    Метод добавления информации о товаре в таблицу корзины

  • void InsertTreeGroup()

    Вставки дерева групп для CML v. 2.0x

  • mixed InsertTyingProducts()

    Метод добавления информации о сопутствующем товаре

  • int InsertTypeOfDelivery()

    Метод, осуществляющий вставку типа доставки

  • bool IsOrderOfThisSiteUser()

    Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта

  • bool IssetAccessForShopGroup()

    Проверка возможности доступа пользователя к группе товаров

  • boolean IssetPropertyForGroup()

    Определение принадлежности дополнительного свойства группе товаров

  • int ProcessOrder()

    Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты

  • string RamblerPokupki()

    Вывод данных для эксопрта в RamblerPokupki. Метод отправляет соответствующий заголовок и возвращает XML данные.

  • string Round()

    Округление цен к формату, приведенного в $this->float_format

  • array SearchIndexing()

    Функция обратного вызова для поисковой индексации данных модуля

  • array SelectAllItemsFromCartForUser()

    Получение суммы налога, количества элементов и их общей цены для заданного пользователя

  • void SelectAllItemsFromCookieCart()

    Получение общего количества товаров, их общей стоимости и веса из корзины

  • mixed SelectCityArea()

    Получение информации о районе города (обо всех районах при $city_area_id=-1)

  • resource SelectGroupsByName()

    Получение информации обо всех группах магазина, имеющих название $shop_groups_name

  • array SelectPrice()

    Метод определения цены для заданной группы пользователей

  • bool SendMailAboutOrder()

    Метод отправки писем о поступившем заказе пользователю и администратору

  • void SetCart()

    Сохранение корзины в зависимости от CartType

  • void SetCookie()

    Установка значения cookie

  • void SetCookieCart()

    Отправить в cookies содержимое корзины

  • void SetCountAllComments()

    Установление числа комментариев к товарам

  • bool SetOrderPaymentStatus()

    Изменение статуса оплаты заказа

  • void SetSessionCart()

    Отправить в session содержимое корзины

  • void SetUnload()

    Установка статуса выгрузки заказа

  • void ShowAddress()

    Метод показа адреса для заказчика

  • void ShowCart()

    Метод показа содержимого корзины

  • void ShowConfirmation()

    Метод вывода сообщения о необходимости подтвердить аккаунт

  • void ShowEnter()

    Метод вывода формы для авторизации пользователя

  • boolean ShowItem()

    Метод вывода информации о товаре

  • false ShowItemsCompare()

    Метод отображает сравнение выбранных товаров в магазине

  • void ShowPriceList()

  • bool ShowProducersList()

    Метод формирования xml для производителей

  • void ShowSaller()

    Метод для отображение информации о продавце в клиентской части

  • void ShowShop()

    Показ магазина (товаров и групп).

  • bool ShowShops()

    Показ списка магазинов

  • void ShowSiteUsersAccount()

    Отображение списка лицевых счетов пользователя

  • void ShowSiteUsersAccountTransaction()

    Отображение списка транзакций пользователя

  • void ShowSystemOfPay()

    Метод построения XML для платежных систем

  • mixed ShowTagsCloud()

    Показ облака тегов для магазина

  • void ShowTypeOfDelivery()

    Метод выбора и показа типов доставки

  • false ShowUserOrders()

    Отображение информации о заказах пользователя

  • boolean TransferFromCartIntoTable()

    Метод перемещения информации о заказанном товаре в таблицу корзины

  • boolean UnsetSiteUserAccountTransaction()

    Установка активности транзакции в 0 (делает неактивной)

  • mixed UpdateCart()

    Метод, осуществляющий обновление данных корзины

  • array UpdateCity()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление города

  • array UpdateCondOfDelivery()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки

  • array UpdateCountry()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление страны

  • mixed UpdateCurrency()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()

  • array UpdateDiscount()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке

  • mixed UpdateGroup()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары

  • boolean UpdateImageForItem()

    Метод обновления информации об изображении для товара

  • void UpdateItem()

    Устаревший метод, осуществляющий обновление информации о товаре. Заменен на InsertItem()

  • mixed UpdateItemDiscount()

    УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара

  • boolean UpdateItemPrice()

    Метод обновления связи товара и цены

  • array UpdateLocation()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление области

  • array UpdateMesure()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения

  • array UpdateOrder()

    УСТАРЕВШИЙ метод, осуществляющий обновление заказа. См. InsertOrder()

  • mixed UpdateOrderItems()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе

  • mixed UpdateOrderPropretyOfItems()

    Метод изменения порядка сортировки дополнительных свойств товара

  • array UpdatePrice()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены

  • mixed UpdatePricesToItem()

    Метод обновления дополнительной цены для элемента

  • array UpdateProducer()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе

  • int UpdatePropertiesItem()

    Метод обновления информации о дополнительных свойствах товара

  • mixed UpdatePropretyOfItems()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара

  • void UpdateShop()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине

  • array UpdateSystemOfPay()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы

  • возвращает UpdateTax()

    Метод, осуществляющий обновление налога. Рекомендуется использовать InsertTax()

  • array UpdateTyingProducts()

    УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах

  • array UpdateTypeOfDelivery()

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки

  • mixed YandexMarket()

    Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и выводит XML данные.

  • string _CallbackSearch()

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

Унаследованные методы

Описания методов

    shop::AddIntoCart

AddIntoCart(
array
$param );

    Описание

    Метод помещения товара в корзину

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • $param['shop_id'] int идентификатор магазина
    • $param['item_id'] int идентификатор товара
    • $param['user_id'] int идентификатор пользователя
    • $param['count'] int количество товара
    • $param['warehouse_id'] int идентификатор склада
    • $param['postpone'] int флаг, указывающия на то, является ли данный товар отложенным

    Возвращает

    идентификатор записи таблицы корзины, id товара, если пользователь не указан, ложь - в случае возникновения ошибки

    [ Наверх ]

    shop::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    shop::AssignGroupImage

AssignGroupImage(
int
$shop_groups_id, string
$shop_groups_image );

    Описание

    Метод для установки имени изображения для группы товаров

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы товаров

    $shop_groups_image

    название картинки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_groups_id = 599;
      5.

    5.  $shop_groups_image = '599.jpg';
      6.

    6.
      7.

    7.  $image = $shop->AssignGroupImage($shop_groups_id, $shop_groups_image);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $image;
      11.

    11.  ?>
      12.

    Возвращает

    название картинки или false

    [ Наверх ]

    shop::AssignItemImage

AssignItemImage(
int
$shop_items_catalog_item_id, string
$shop_items_catalog_image );

    Описание

    Метод для установки имени изображения для товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $shop_items_catalog_image

    название картинки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 170;
      5.

    5.  $shop_items_catalog_image = 'shop_items_catalog_image170.jpg';
      6.

    6.
      7.

    7.  $image = $shop->AssignItemImage($shop_items_catalog_item_id, $shop_items_catalog_image);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $image;
      11.

    11.  ?>
      12.

    Возвращает

    название картинки или false

    [ Наверх ]

    shop::AssignShopWatermark

AssignShopWatermark(
int
$shop_shops_id, [string
$shop_watermark_ext = false] );

    Описание

    Метод осуществляющий обновление данных о файле watermark'a для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $shop_watermark_ext

    имя расширения файла watermark'a, если false - очищаем имя файла
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $shop_watermark_ext = false;
      6.

    6.
      7.

    7.  $watermark = $shop->AssignShopWatermark($shop_shops_id, $shop_watermark_ext = false);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $watermark;
      11.

    11.  ?>
      12.

    Возвращает

    строку с именем файла или false

    [ Наверх ]

    shop::CancelOrder

CancelOrder(
int
$shop_order_id );

    Описание

    Метод для отмены заказа (устанавливает поле shop_order_cancel = 1)

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 38;
      5.

    5.
      6.

    6.  $shop->CancelOrder($shop_order_id);
      7.

    7.  ?>
      8.

    Возвращает

    результат выполнения функции

    [ Наверх ]

    shop::ChangeItemsOfOrderRest

ChangeItemsOfOrderRest(
int
$shop_order_id, [bool
$reduce_rest = false] );

    Описание

    Изменение остатка товаров в заказе

    Принимаемые параметры

    $shop_order_id

    Идентификатор заказа

    $reduce_rest

    Флаг, указывающий, списать товары со склада (true), или вернуть (false - по умолчанию)

    [ Наверх ]

    shop::ClearCookieAndSessionCart

ClearCookieAndSessionCart(
int
$shop_id );

    Описание

    Метод для очистки корзины кукисов и сессий

    Принимаемые параметры

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $shop->ClearCookieAndSessionCart($shop_id);
      7.

    7.  ?>
      8.

    [ Наверх ]

    shop::ClearPath

ClearPath(
string
$path );

    Описание

    Метод очищает путь от запрещенных символов

    Принимаемые параметры

    $path

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $path = 'g^r]o>up';
      5.

    5.
      6.

    6.  $path = $shop->ClearPath($path);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $path;
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::ConvertPrice

ConvertPrice(
string
$price );

    Описание

    Конвертирует цену в различных форматах к цене в формате xxxx.yy

    Принимаемые параметры

    $price

    цена
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $price = '100-123';
      5.

    5.
      6.

    6.  $newprice = $shop->ConvertPrice($price);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newprice;
      10.

    10.  ?>
      11.

    Возвращает

    отформатированная цена

    [ Наверх ]

    shop::CopyAffiliats

CopyAffiliats(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование парнерских программ

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopyAffiliats($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyCondOfDelivery

CopyCondOfDelivery(
int
$shop_type_of_delivery_id, int
$new_shop_type_of_delivery_id );

    Описание

    Копирование условий типа доставки

    Принимаемые параметры

    $shop_type_of_delivery_id

    идентификатор типа доставки

    $new_shop_type_of_delivery_id

    идентификатор скопированного типа доставки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_type_of_delivery_id = 2;
      5.

    5.  $new_shop_type_of_delivery_id = 12;
      6.

    6.
      7.

    7.  $shop->CopyCondOfDelivery($shop_type_of_delivery_id, $new_shop_type_of_delivery_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyCoupons

CopyCoupons(
int
$shop_order_discount_id, int
$new_shop_order_discount_id, int
$new_shop_shops_id );

    Описание

    Копирование купонов магазина на скидку

    Принимаемые параметры

    $shop_order_discount_id

    идентификатор скидки

    $new_shop_shops_id

    идентификатор скопированного магазина

    $new_shop_order_discount_id

    идентификатор скопированной скидки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_discount_id = 1;
      5.

    5.  $new_shop_order_discount_id = 3;
      6.

    6.  $new_shop_shops_id = 3;
      7.

    7.
      8.

    8.  $shop->CopyCoupons($shop_order_discount_id, $new_shop_order_discount_id, $new_shop_shops_id);
      9.

    9.  ?>
      10.

    [ Наверх ]

    shop::CopyDiscounts

CopyDiscounts(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование скидок на товары

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopyDiscounts($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyExternalPropertiesForItem

CopyExternalPropertiesForItem(
int
$shop_items_catalog_item_id, int
$shop_items_catalog_item_id_copy, int
$shop_shops_id );

    Описание

    Копирование значений дополнительных свойств товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор копируемого товара

    $shop_items_catalog_item_id_copy

    идентификатор копии товара

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.  $shop_items_catalog_item_id_copy = 159;
      6.

    6.  $shop_shops_id = 1;
      7.

    7.
      8.

    8.  $shop->CopyExternalPropertiesForItem($shop_items_catalog_item_id, $shop_items_catalog_item_id_copy, $shop_shops_id);
      9.

    9.  ?>
      10.

    [ Наверх ]

    shop::CopyGroupsItemsProperty

CopyGroupsItemsProperty(
$groups_items_property_id
$groups_items_property_id, [$shop_id
$shop_id = false] );

    Описание

    Копирование дополнительного свойства товаров

    Принимаемые параметры

    $groups_items_property_id

    идентификатор дополнительного свойства групп товаров

    $shop_id

    идентификатор магазина, в который будет скопировано дополнительное свойство.
    По умолчанию равен false - используется магазин, к которому принадлежит копируемое дополнительное свойство.

    Возвращает

    идентификатор копии дополнительного свойства групп товаров в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::CopyItem

CopyItem(
int
$item_catalog_id, [bool
$copy_external_properties = true], [bool
$property = array ()] );

    Описание

    Копирование товара

    Принимаемые параметры

    $item_catalog_id

    идентификатор копируемого товара

    $copy_external_properties

    флаг, указывающий, нужно ли копировать доп. свойства товара (по умолчанию true)

    $property

    Массив дополнительных параметров
    • bool $property['copy_original_name'] флаг, указывающий, нужно ли копировать оригинальное имя товара, не изменяя его, либо добавлять слово "копия" (по умолчанию false)

    Возвращает

    идентификатор копии товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $item_catalog_id = 158;
      5.

    5.
      6.

    6.  $newid = $shop->CopyItem($item_catalog_id);
      7.

    7.  // Распечатаем результат
      8.

    8.  echo $newid;
      9.

    9.  ?>
      10.

    [ Наверх ]

    shop::CopyItemsProperty

CopyItemsProperty(
$items_property_id
$items_property_id, [$shop_id
$shop_id = false] );

    Описание

    Копирование дополнительного свойства товаров

    Принимаемые параметры

    $items_property_id

    идентификатор дополнительного свойства товаров

    $shop_id

    идентификатор магазина, в который будет скопировано дополнительное свойство.
    По умолчанию равен false - используется магазин, к которому принадлежит копируемое дополнительное свойство.

    Возвращает

    идентификатор копии дополнительного свойства товаров в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::CopyOrderDiscounts

CopyOrderDiscounts(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование скидок от суммы заказа и их купонов

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopyOrderDiscounts($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyPrices

CopyPrices(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование цен для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopyPrices($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyProducers

CopyProducers(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование производителей

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopyProducers($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyPropertiesForGroup

CopyPropertiesForGroup(
int
$shop_properties_groups_dir_parent_id, [int
$shop_shops_id = 0], [int
$new_shop_properties_groups_dir_parent_id = 0], [int
$new_shop_shops_id = 0] );

    Описание

    Копирование дополнительных свойств групп товаров, включая группы дополнительных свойств групп

    Принимаемые параметры

    $shop_properties_groups_dir_parent_id

    идентификатор группы дополнительных свойств групп товаров

    $shop_shops_id

    идентификатор магазина

    $new_shop_properties_groups_dir_parent_id

    идентификатор скопированной группы дополнительных свойств групп товаров (параметр используется при рекурсии - передавать не нужно)

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_groups_dir_parent_id = 1;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.  $new_shop_properties_groups_dir_parent_id = 0;
      7.

    7.  $new_shop_shops_id = 3;
      8.

    8.
      9.

    9.  $shop->CopyPropertiesForGroup($shop_properties_groups_dir_parent_id, $shop_shops_id, $new_shop_properties_groups_dir_parent_id, $new_shop_shops_id);
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::CopyPropertiesForItem

CopyPropertiesForItem(

$shop_properties_items_dir_parent_id, [int
$shop_shops_id = 0], [
$new_shop_properties_items_dir_parent_id = 0], [int
$new_shop_shops_id = 0], int
$shop_properties_items_dir_id, int
$new_shop_properties_items_dir_id );

    Описание

    Копирование дополнительных свойств товаров, включая подгруппы дополнительных свойств

    Принимаемые параметры

    $shop_properties_items_dir_id

    идентификатор группы дополнительных свойств

    $shop_shops_id

    идентификатор магазина

    $new_shop_properties_items_dir_id

    идентификатор скопированной группы дополнительных свойств (параметр используется при рекурсии - передавать не нужно)

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_items_dir_parent_id = 3;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.  $new_shop_properties_items_dir_parent_id = 0;
      7.

    7.  $new_shop_shops_id = 3;
      8.

    8.
      9.

    9.  $shop->CopyPropertiesForItem($shop_properties_items_dir_parent_id, $shop_shops_id, $new_shop_properties_items_dir_parent_id, $new_shop_shops_id);
      10.

    10.  ?>
      11.

    $shop_properties_items_dir_parent_id

    $new_shop_properties_items_dir_parent_id

    [ Наверх ]

    shop::CopySallers

CopySallers(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование продавцов

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор магазина, в который помещаются скопированные продавцы
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopySallers($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CopyShop

CopyShop(
int
$shop_shops_id, [
$new_site_id = false], [
$structure_id = false], [
$shop_dir_id = false] );

    Описание

    Копирование информации о магазине, а также дополнительных свойствах товаров, групп и групп этих свойств

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_site_id

    $structure_id

    $shop_dir_id

    Возвращает

    идентификатор нового магазина, либо False
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id= 1;
      5.

    5.
      6.

    6.  $newid = $shop->CopyShop($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::CopyShopDir

CopyShopDir(

$param );

    Принимаемые параметры

    $param

    [ Наверх ]

    shop::CopySystemsOfPay

CopySystemsOfPay(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование платежных систем

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина из которого будет производиться копирование

    $new_shop_shops_id

    идентификатор магазина куда будет производиться копирование

    [ Наверх ]

    shop::CopyTypesOfDelivery

CopyTypesOfDelivery(
int
$shop_shops_id, int
$new_shop_shops_id );

    Описание

    Копирование типа доставки

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $new_shop_shops_id

    идентификатор скопированного магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $new_shop_shops_id = 3;
      6.

    6.
      7.

    7.  $shop->CopyTypesOfDelivery($shop_shops_id, $new_shop_shops_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::CorrectPropertiesGroup

CorrectPropertiesGroup(
array
$row, [
$param = array ()] );

    Описание

    Метод корректирует строку данных о дополнительном свойстве группы в соответствии с его типом.

    Принимаемые параметры

    $row

    данные о дополнительном свойстве

    $param

    Возвращает

    откорректированные данные

    [ Наверх ]

    shop::CorrectPropertiesItem

CorrectPropertiesItem(
array
$row, [
$param = array ()] );

    Описание

    Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.

    Принимаемые параметры

    $row

    данные о дополнительном свойстве

    $param

    Возвращает

    откорректированные данные

    [ Наверх ]

    shop::CreateDirectory

CreateDirectory(
int
$shop_shops_id, string
$dir_name, [bool
$link_path = false], [bool
$create = true] );

    Описание

    Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $dir_name

    директория, которую необходимо создать

    $link_path

    возвращает путь для отображения в ссылке (не используя CMS_FOLDER)

    $create

    создавать каталог, если он не существует
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $dir_name = 'Новая';
      6.

    6.
      7.

    7.  $dir = $shop->CreateDirectory($shop_shops_id, $dir_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $dir
      11.

    11.  ?>
      12.

    Возвращает

    созданая или уже существующая директория, либо false, если не удалось создать.

    [ Наверх ]

    shop::DeleteAllEItems

DeleteAllEItems(
integer
$shop_items_catalog_item_id, integer
$shop_shops_id );

    Описание

    Метод удаляет все электронные товары заданного товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    Идентификатор товара, для которого необходимо удалить все электронные товары

    $shop_shops_id

    Идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 171;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $result = $shop->DeleteAllEItems($shop_items_catalog_item_id, $shop_shops_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    shop::DeleteAllItemsCatalogAndGroups

DeleteAllItemsCatalogAndGroups(
int
$shop_shops_id );

    Описание

    Метод очистки таблиц товаров и групп

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 7;
      5.

    5.
      6.

    6.  $result = $shop->DeleteAllItemsCatalogAndGroups($shop_shops_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    shop::DeleteAllModificationForItem

DeleteAllModificationForItem(
int
$shop_items_catalog_item_id );

    Описание

    Метод удаления всех модификаций товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    Идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.
      6.

    6.  $result = $shop->DeleteAllModificationForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    shop::DeleteCart

DeleteCart(
array
$param );

    Описание

    Удаление товара из корзины

    Принимаемые параметры

    $param

    массив с данными
    • $param['shop_id'] - идентификатор магазина
    • $param['site_user_id'] - идентификатор пользователя сайта
    • $param['item_id'] - идентификатор элемента

      1.  <?php
        2.

      2.  Shop = new Shop();
        3.

      3.
        4.

      4.  $param['shop_id'] = 1;
        5.

      5.  $param['item_id'] = 24;
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.     $SiteUsers = & singleton('SiteUsers');
        11.

      11.     $param['site_user_id'] = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $param['site_user_id'] = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $shop->DeleteCart($param);
        19.

      19.  ?>
        20.

    [ Наверх ]

    shop::DeleteCity

DeleteCity(
int
$shop_city_id );

    Описание

    Метод, осуществляющий удаление города

    Принимаемые параметры

    $shop_city_id

    идентификационный города
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_city_id = 10;
      5.

    5.
      6.

    6.  $result = $shop->DeleteCity($shop_city_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    [ Наверх ]

    shop::DeleteCityArea

DeleteCityArea(
int
$shop_city_area_id );

    Описание

    Метод удаления района города

    Принимаемые параметры

    $shop_city_area_id

    идентификатор района
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_city_area_id = 3;
      5.

    5.
      6.

    6.  $result = $shop->DeleteCityArea($shop_city_area_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    shop::DeleteComment

DeleteComment(
int
$shop_comment_id );

    Описание

    Метод удаления информации об отзыве на товар

    Принимаемые параметры

    $shop_comment_id

    идентификатор отзыва
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_comment_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteComment($shop_comment_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    shop::DeleteCompany

DeleteCompany(
int
$shop_company_id );

    Описание

    Метод удаления информации об организации

    Принимаемые параметры

    $shop_company_id

    идентификатор организации
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_company_id = 2;
      5.

    5.
      6.

    6.  $result = $shop->DeleteCompany($shop_company_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    shop::DeleteCondOfDelivery

DeleteCondOfDelivery(
int
$shop_cond_of_delivery_id );

    Описание

    Метод, осуществляющий удаление условия доставки

    Принимаемые параметры

    $shop_cond_of_delivery_id

    идентификационный номер условия доставки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_cond_of_delivery_id = 2;
      5.

    5.
      6.

    6.  $result = $shop->DeleteCondOfDelivery($shop_cond_of_delivery_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления условия доставки

    [ Наверх ]

    shop::DeleteCountry

DeleteCountry(
int
$shop_country_id );

    Описание

    Метод, осуществляющий удаление страны

    Принимаемые параметры

    $shop_country_id

    идентификационный номер страны
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_country_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteCountry($shop_country_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления страны

    [ Наверх ]

    shop::DeleteCoupon

DeleteCoupon(
int
$shop_coupon_id );

    Описание

    Метод для удаления информации о купоне

    Принимаемые параметры

    $shop_coupon_id

    идентификатор купона
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_coupon_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteCoupon($shop_coupon_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    shop::DeleteCurrency

DeleteCurrency(
int
$shop_currency_id );

    Описание

    Метод, осуществляющий удаление валюты

    Принимаемые параметры

    $shop_currency_id

    идентификационный номер валюты
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_currency_id = 1;
      5.

    5.
      6.

    6.  $shop->DeleteCurrency($shop_currency_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    возвращает результат удаления валюты ( false при неудачном удалении)

    [ Наверх ]

    shop::DeleteDiscount

DeleteDiscount(
int
$shop_discount_id );

    Описание

    Метод, осуществляющий удаление скидки

    Принимаемые параметры

    $shop_discount_id

    идентификационный номер скидки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_discount_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteDiscount($shop_discount_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    возвращает результат удаления скидки

    [ Наверх ]

    shop::DeleteEItem

DeleteEItem(
integer
$shop_eitem_id, integer
$shop_shops_id, integer
$item_id );

    Описание

    Метод удаления информации об электронном товаре

    Принимаемые параметры

    $shop_eitem_id

    Идентификатор электронного товара

    $shop_shops_id

    Идентификатор магазина

    $item_id

    Идентификатор обычного товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_eitem_id = 4;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.  $item_id = 158;
      7.

    7.
      8.

    8.  $result = $shop->DeleteEItem($shop_eitem_id, $shop_shops_id, $item_id);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo "Удаление выполнено успешно";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Ошибка удаления";
      17.

    17.  }
      18.

    18.
      19.

    19.  ?>
      20.

    [ Наверх ]

    shop::DeleteGroup

DeleteGroup(
int
$shop_groups_id );

    Описание

    Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)

    Принимаемые параметры

    $shop_groups_id

    идентификтаор группы товаров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_groups_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteGroup($shop_groups_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    истину при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    shop::DeleteItem

DeleteItem(
int
$shop_items_catalog_item_id );

    Описание

    Метод, осуществляющий удаление товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификационный номер товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    возвращает результат удаления товара

    [ Наверх ]

    shop::DeleteItemDiscount

DeleteItemDiscount(
int
$shop_item_discount_id );

    Описание

    Метод удаления скики для товара

    Принимаемые параметры

    $shop_item_discount_id

    идентификатор удаляемой записи
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_item_discount_id = 1;
      5.

    5.
      6.

    6.  $shop->DeleteItemDiscount($shop_item_discount_id);
      7.

    7.
      8.

    8.  ?>
      9.

    Возвращает

    возвращает результат удаления

    [ Наверх ]

    shop::DeleteLocation

DeleteLocation(
int
$shop_location_id );

    Описание

    Метод, осуществляющий удаление области

    Принимаемые параметры

    $shop_location_id

    идентификационный номер области
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_location_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteLocation($shop_location_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления области

    [ Наверх ]

    shop::DeleteMesure

DeleteMesure(
int
$shop_mesures_id );

    Описание

    Метод, осуществляющий удаление единицы измерения

    Принимаемые параметры

    $shop_mesures_id

    идентификационный номер единицы измерения
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_mesures_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteMesure($shop_mesures_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления единицы измерения

    [ Наверх ]

    shop::DeleteOrder

DeleteOrder(
int
$shop_order_id );

    Описание

    Метод, осуществляющий удаление заказа

    Принимаемые параметры

    $shop_order_id

    идентификационный номер заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteOrder($shop_order_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    возвращает результат удаления заказа

    [ Наверх ]

    shop::DeleteOrderDiscount

DeleteOrderDiscount(
int
$shop_order_discount_id );

    Описание

    Метод для удаления информации о скидке для заказов

    Принимаемые параметры

    $shop_order_discount_id

    идентификатор скидки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_discount_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteOrderDiscount($shop_order_discount_id));
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    shop::DeleteOrderItems

DeleteOrderItems(
int
$shop_order_items_id );

    Описание

    Метод, осуществляющий удаление товара в заказе

    Принимаемые параметры

    $shop_order_items_id

    идентификационный номер товара в заказе
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_items_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteOrderItems($shop_order_items_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления товара в заказе

    [ Наверх ]

    shop::DeleteOrderStatus

DeleteOrderStatus(
int
$shop_order_status_id );

    Описание

    Метод, осуществляющий удаление статуса заказа

    Принимаемые параметры

    $shop_order_status_id

    идентификационный номер статуса заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_status_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteOrderStatus($shop_order_status_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления статуса заказа

    [ Наверх ]

    shop::DeletePrice

DeletePrice(
int
$shop_list_of_prices_id );

    Описание

    Метод, осуществляющий удаление типа цены

    Принимаемые параметры

    $shop_list_of_prices_id

    идентификационный номер типа цены
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_list_of_prices_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeletePrice($shop_list_of_prices_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления типа цены

    [ Наверх ]

    shop::DeletePriceForItem

DeletePriceForItem(

$shop_items_catalog_item_id, [int
$shop_list_of_prices_id = false], int
$shop_items_catalog_id );

    Описание

    Метод удаляет цену для элемента каталога

    Принимаемые параметры

    $shop_items_catalog_id

    $shop_list_of_prices_id

    (по умолчанию false)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeletePriceForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    $shop_items_catalog_item_id

    [ Наверх ]

    shop::DeletePricesForAllItem

DeletePricesForAllItem(
int
$shop_items_catalog_id );

    Описание

    Метод удаляет все дополнительные цены для товара

    Принимаемые параметры

    $shop_items_catalog_id

    идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeletePricesForAllItem($shop_items_catalog_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    [ Наверх ]

    shop::DeleteProducer

DeleteProducer(
int
$shop_producers_list_id );

    Описание

    Метод, осуществляющий удаление производителя

    Принимаемые параметры

    $shop_producers_list_id

    идентификационный номер производителя
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_producers_list_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteProducer($shop_producers_list_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::DeletePropertiesGroupsDir

DeletePropertiesGroupsDir(
int
$shop_properties_groups_dir_id,
$shop_shops_id );

    Описание

    Удаление информации о группе дополнительных свойств групп товаров

    Принимаемые параметры

    $shop_properties_groups_dir_id

    Идентификатор группы дополнительных свойств
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_groups_dir_id = 3;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $result = $shop->DeletePropertiesGroupsDir($shop_properties_groups_dir_id, $shop_shops_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.
      18.

    18.  ?>
      19.

    $shop_shops_id

    [ Наверх ]

    shop::DeletePropertiesGroupValue

DeletePropertiesGroupValue(
array
$param );

    Описание

    Удаление значения дополнительного свойства группы

    Принимаемые параметры

    $param

    массив параметров
    • int $param['shop_groups_id'] Идентификатор группы товаров
    • int $param['shop_properties_group_id'] Идентификатор дополнительного свойства

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_groups_id'] = 599;
        5.

      5.  $param['shop_properties_group_id'] = 1;
        6.

      6.
        7.

      7.  $result = $shop->DeletePropertiesGroupValue($param);
        8.

      8.
        9.

      9.  if ($result)
        10.

      10.  {
        11.

      11.      echo "Удаление выполнено успешно";
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      echo "Ошибка удаления";
        16.

      16.  }
        17.

      17.
        18.

      18.  ?>
        19.

    Возвращает

    Результат выполнения запроса удаления или false

    [ Наверх ]

    shop::DeletePropertiesItem

DeletePropertiesItem(
int
$shop_id, int
$shop_items_catalog_item_id, int
$shop_list_of_properties_id );

    Описание

    Удаление значение дополнительного свойства товара

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $shop_items_catalog_item_id

    идентификатор элемента

    $shop_list_of_properties_id

    идентификатор дополнительного свойства
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $shop_items_catalog_item_id = 158;
      6.

    6.  $shop_list_of_properties_id = 133;
      7.

    7.
      8.

    8.  $result = $shop->DeletePropertiesItem($shop_id, $shop_items_catalog_item_id, $shop_list_of_properties_id);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.      echo "Удаление выполнено успешно";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      echo "Ошибка удаления";
      17.

    17.  }
      18.

    18.
      19.

    19.  ?>
      20.

    Возвращает

    истина при удачном удалении, ложь в обратном случае

    [ Наверх ]

    shop::DeletePropertiesItemsDir

DeletePropertiesItemsDir(
int
$shop_properties_items_dir_id, [
$shop_shops_id = false] );

    Описание

    Удаление информации о группе дополнительных свойств товара

    Принимаемые параметры

    $shop_properties_items_dir_id

    Идентификатор группы дополнительных свойств
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_items_dir_id = 1;
      5.

    5.
      6.

    6.  $shop->DeletePropertiesItemsDir($shop_properties_items_dir_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    $shop_shops_id

    [ Наверх ]

    shop::DeletePropertyForGroup

DeletePropertyForGroup(
int
$shop_properties_item_for_groups_id );

    Описание

    Метод удаляет принадлежность дополнительного свойтсва группе товаров

    Принимаемые параметры

    $shop_properties_item_for_groups_id

    Идентификатор соответствия дополнительного свойства группе из таблицы shop_properties_item_for_groups_table
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_item_for_groups_id = 777;
      5.

    5.
      6.

    6.  $result = $shop->DeletePropertyForGroup($shop_properties_item_for_groups_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    [ Наверх ]

    shop::DeletePropretyOfGroup

DeletePropretyOfGroup(
int
$shop_properties_group_id );

    Описание

    Удаление дополнительного свойства группы товаров

    Принимаемые параметры

    $shop_properties_group_id

    Идентификатор дополнительного свойства
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_group_id = 2;
      5.

    5.
      6.

    6.  $result = $shop->DeletePropretyOfGroup($shop_properties_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    Результат выполнения запроса

    [ Наверх ]

    shop::DeletePropretyOfItems

DeletePropretyOfItems(
int
$shop_list_of_properties_id );

    Описание

    Метод, осуществляющий удаление свойства товара

    Принимаемые параметры

    $shop_list_of_properties_id

    идентификационный номер свойства товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_list_of_properties_id = 132;
      5.

    5.
      6.

    6.  $result = $shop->DeletePropretyOfItems($shop_list_of_properties_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    возвращает результат удаления свойства товара

    [ Наверх ]

    shop::DeleteSeller

DeleteSeller(
int
$seller_id );

    Описание

    Метод, осуществляющий удаление продавца.

    Принимаемые параметры

    $seller_id

    идентификационный номер продавца
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $seller_id = 8;
      5.

    5.
      6.

    6.  $result = $shop->DeleteSeller($seller_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления продавца

    [ Наверх ]

    shop::DeleteShop

DeleteShop(
int
$shop_shops_id );

    Описание

    Метод, осуществляющий удаление магазина

    Принимаемые параметры

    $shop_shops_id

    идентификационный номер магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $result = $shop->DeleteShop($shop_shops_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления магазина

    [ Наверх ]

    shop::DeleteShopsDir

DeleteShopsDir(
int
$shop_dir_id );

    Описание

    Удаление раздела интернет-магазинов. Магазины, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.

    Принимаемые параметры

    $shop_dir_id

    идентификатор раздела магазинов

    [ Наверх ]

    shop::DeleteShopWatermark

DeleteShopWatermark(

$shop_shops_id );

    Принимаемые параметры

    $shop_shops_id

    [ Наверх ]

    shop::DeleteSiteUserAccountTransaction

DeleteSiteUserAccountTransaction(
int
$shop_site_users_account_id );

    Описание

    Удаление транзакции

    Принимаемые параметры

    $shop_site_users_account_id

    Идентификатор транзакции
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_site_users_account_id = 9;
      5.

    5.
      6.

    6.  $result = $shop->DeleteSiteUserAccountTransaction($shop_site_users_account_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    [ Наверх ]

    shop::DeleteSpecialPrice

DeleteSpecialPrice(
int
$shop_special_prices_id );

    Описание

    Удаление информации о специальной цене

    Принимаемые параметры

    $shop_special_prices_id

    идентификатор специальной цены

    Возвращает

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_special_prices_id = 7;
      5.

    5.
      6.

    6.  $result = $shop->DeleteSpecialPrice($shop_special_prices_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.      else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    shop::DeleteSystemOfPay

DeleteSystemOfPay(
int
$shop_system_of_pay_id );

    Описание

    Метод, осуществляющий удаление платёжной системы

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_system_of_pay_id = 9;
      5.

    5.
      6.

    6.  $result = $shop->DeleteSystemOfPay($shop_system_of_pay_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Принимаемые параметры

    $shop_system_of_pay_id

    идентификационный номер платёжной системы

    Возвращает

    возвращает результат удаления платёжной системы

    [ Наверх ]

    shop::DeleteTax

DeleteTax(
int
$shop_tax_id );

    Описание

    Метод, осуществляющий удаление налога

    Принимаемые параметры

    $shop_tax_id

    идентификационный номер налога
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_tax_id = 3;
      5.

    5.
      6.

    6.  $result = $shop->DeleteTax($shop_tax_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    возвращает результат удаления налога

    [ Наверх ]

    shop::DeleteTyingProducts

DeleteTyingProducts(
int
$shop_intermediate_id );

    Описание

    Метод удаления сопутствующих товаров

    Принимаемые параметры

    $shop_intermediate_id

    идентификатор удаляемой записи о сопутствующих товарах
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_intermediate_id = 7;
      5.

    5.
      6.

    6.  $result = $shop->DeleteTyingProducts($shop_intermediate_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.
      17.

    17.  ?>
      18.

    Возвращает

    результат удаления

    [ Наверх ]

    shop::DeleteTypeOfDelivery

DeleteTypeOfDelivery(
int
$shop_type_of_delivery_id, int
$shop_shops_id );

    Описание

    Метод, осуществляющий удаление типа доставки

    Принимаемые параметры

    $shop_type_of_delivery_id

    идентификационный номер типа доставки

    $shop_shops_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_type_of_delivery_id = 3;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $result = $shop->DeleteTypeOfDelivery($shop_type_of_delivery_id, $shop_shops_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.
      18.

    18.  ?>
      19.

    Возвращает

    истина при удачном обновлении, ложь в обратном случае

    [ Наверх ]

    shop::ExecSystemsOfPayChangeStatus

ExecSystemsOfPayChangeStatus(
int
$system_of_pay_id, [array
$param = array()] );

    Описание

    Метод выполнения обработчика платежной системы для смены статуса заказа

    ChangeStatus()

    Принимаемые параметры

    $system_of_pay_id

    идентификатор платежной системы

    $param

    массив атрибутов
    • $param['shop_order_id'] идентификатор заказа

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $system_of_pay_id = 4;
        5.

      5.  $param['shop_order_id'] = '117';
        6.

      6.  $shop->ExecSystemsOfPayChangeStatus ($system_of_pay_id, $param);
        7.

      7.
        8.

      8.  ?>
        9.

    [ Наверх ]

    shop::ExecSystemsOfPayHandler

ExecSystemsOfPayHandler(
int
$system_of_pay_id );

    Описание

    Метод выполнения обработчика платежной системы

    Принимаемые параметры

    $system_of_pay_id

    идентификатор платежной системы
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $system_of_pay_id = 4;
      5.

    5.
      6.

    6.  $shop->ExecSystemsOfPayHandler($system_of_pay_id);
      7.

    7.
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::FillMasGroup

FillMasGroup(

$shop_shops_id, [array
$param = array ()], int
$shop_id );

    Описание

    Метод формирования массива групп верхнего уровня для данного магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина, для которого заполняем массив групп самого верхнего уровня

    $param

    массив дополнительных параметров
    • $param['cache_off']  - если параметр установлен - данные не кэшируются
    • $param['groups_activity'] параметр, учитывающий активность групп при выборке. 1 - получаем информацию только об активных группах, если не задан, то активность группы не учитывается

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id = 1;
        5.

      5.  $param = array();
        6.

      6.
        7.

      7.  $MasGroup = $shop->FillMasGroup($shop_shops_id, $param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r ($MasGroup);
        11.

      11.
        12.

      12.  ?>
        13.

    $shop_shops_id

    [ Наверх ]

    shop::FillMasGroupDirExtProperty

FillMasGroupDirExtProperty(
int
$shop_shops_id, [array
$param = array ()] );

    Описание

    Заполнение массива групп дополнительных свойств групп товаров

    Принимаемые параметры

    $shop_shops_id

    Идентификатор магазина

    $param

    Массив дополнительных параметров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->FillMasGroupDirExtProperty($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    Массив групп

    [ Наверх ]

    shop::FillMasGroupExtProperty

FillMasGroupExtProperty(

$shop_shops_id, [array
$param = array ()], int
$shop_id );

    Описание

    Метод формирования массива групп дополнительных свойств товара самого верхнего уровня для данного магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина, для которого заполняем массив групп самого верхнего уровня

    $param

    массив дополнительных параметров
    • $param['cache_off']  - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id =1;
        5.

      5.
        6.

      6.  $row = $shop->FillMasGroupExtProperty($shop_shops_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    $shop_shops_id

    [ Наверх ]

    shop::FillMemCacheComments

FillMemCacheComments(
array
$mas_items_in );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

    Заполнению подвергается массив $this->CacheComments[shop_items_catalog_item_id][]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FillMemCacheCountItemsAndGroup

FillMemCacheCountItemsAndGroup(
int
$shop_shops_id, [array
$param = array()] );

    Описание

    Внутренний метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.

    Информация сохраняется в массиве:
    для числа групп в группе $this->CacheCountGroupsAndItems[shop_shops_id][information_groups_id][1]
    для числа элементов в группе $this->CacheCountGroupsAndItems[shop_shops_id][information_groups_id][0]

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    массив дополнительных атрибутов

    [ Наверх ]

    shop::FillMemCacheDiscountsForItem

FillMemCacheDiscountsForItem(
array
$mas_items_in );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.

    Заполнению подвергается массив $this->CacheDiscountsForItem[shop_items_catalog_item_id][]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FillMemCacheGetAllPricesForItem

FillMemCacheGetAllPricesForItem(
array
$mas_items_in );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  ценами для групп товаров. Заполнению подвергается массив  $this->CacheGetSpecialPricesForItem[$shop_items_catalog_item_id]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FillMemCacheGoupsIdTree

FillMemCacheGoupsIdTree(
int
$shop_shops_id );

    Описание

    Внутренний метод формирует дерево групп и подгрупп в массиве по их идентификаторам. Заполянется также в методе FillMasGroup()

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    [ Наверх ]

    shop::FillMemCacheItems

FillMemCacheItems(
array
$mas_items_in );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  товаров. Заполнению подвергается массив  $this->CacheGetItem[$shop_items_catalog_item_id]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FillMemCacheModificationItems

FillMemCacheModificationItems(
array
$mas_items_in, [array
$param = array()] );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

    Заполнению подвергается массив $this->CacheModificationItems[shop_items_catalog_modification_id][]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    $param

    массив дополнительных параметров

    [ Наверх ]

    shop::FillMemCachePriceForItem

FillMemCachePriceForItem(
array
$mas_items_in,
$shop_shops_id );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  ценами для товаров. Заполнению подвергается массив  $this->CacheGetPriceForItem[$shop_list_of_prices_id . '_' . $shop_items_catalog_item_id]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    $shop_shops_id

    [ Наверх ]

    shop::FillMemCachePropertiesItem

FillMemCachePropertiesItem(
array
$mas_items_in );

    Описание

    Внутренний метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.

    Заполнению подвергается массив $this->CacheDiscountsForItem[shop_items_catalog_item_id][]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FillMemCachePropertysGroup

FillMemCachePropertysGroup(

$shop_shops_id, [array
$shop_properties_group_id_array = array ()], int
$shop_id );

    Описание

    Метод формирует в памяти данные о свойствах групп магазина.

    Рекомендуется использоваться совместно с GetPropertysGroup() при выборе свойств всех групп магазина.

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $shop_properties_group_id_array

    массив свойств, для которых осущестлвяется выборка,  если не передан (по умолчанию является пустым массивом) - выбираются все свойства  param

    $shop_shops_id

    [ Наверх ]

    shop::FillMemCacheSpecialPricesForItem

FillMemCacheSpecialPricesForItem(
array
$mas_items_in );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров  специальными ценами. Заполнению подвергается массив  $this->CacheGetSpecialPricesForItem [$shop_items_catalog_item_id]

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FillMemCacheTyingProducts

FillMemCacheTyingProducts(
array
$mas_items_in );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.

    Заполнению подвергается массив $this->CacheTyingProducts[shop_items_catalog_item_id][] = shop_items_catalog_item_id

    Принимаемые параметры

    $mas_items_in

    массив идентификаторов товаров

    [ Наверх ]

    shop::FormatGetCart

FormatGetCart(
array
$aContent );

    Описание

    Преобразование массива корзины при извлечении

    Принимаемые параметры

    $aContent

    содержимое корзины

    [ Наверх ]

    shop::FormatSetCart

FormatSetCart(
array
$aContent );

    Описание

    Преобразование массива корзины при записи

    Принимаемые параметры

    $aContent

    содержимое корзины

    [ Наверх ]

    shop::GenCmlId

GenCmlId(
int
$shop_groups_id );

    Описание

    Генерация идентификатора в формате CommerceML для группы товаров

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы товаров

    Возвращает

    идентификатор группы товаров в формате CommerceML

    [ Наверх ]

    shop::GenXml4Comment

GenXml4Comment(
int
$shop_comment_id, [array
$comment_row = false] );

    Описание

    Метод генерирующий XML для отзыва о товаре

    Принимаемые параметры

    $shop_comment_id

    идентификатор отзыва о товаре, может быть 0, если указан $comment_row

    $comment_row

    массив с данными о  комментарии или false (тогда должен быть указан $shop_comment_id)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_comment_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Comment($shop_comment_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    XML текс с данными об отзыве

    [ Наверх ]

    shop::GenXml4Company

GenXml4Company(
int
$shop_company_id, [array
$company_row = false] );

    Описание

    Метод генерирует XML для организации

    Принимаемые параметры

    $shop_company_id

    идентификатор организации

    $company_row

    массив с параметрами, может быть указан вместо $shop_company_id
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_company_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Company($shop_company_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    с XML

    [ Наверх ]

    shop::GenXml4CompareItems

GenXml4CompareItems(
 );

    Описание

    Метод генерирует xml для товаров, выбранных для сравнения

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $xmlData = $shop->GenXml4CompareItems();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo htmlspecialchars($xmlData);
      8.

    8.
      9.

    9.  ?>
      10.

    Возвращает

    сгенерированный XML

    [ Наверх ]

    shop::GenXML4Currency

GenXML4Currency(
int
$shop_currency_id, [int
$shop_id = false] );

    Описание

    Метод генерирует XML для указанной валюты

    Принимаемые параметры

    $shop_currency_id

    идентификатор валюты

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_currency_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXML4Currency($shop_currency_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.
      11.

    11.  ?>
      12.

    [ Наверх ]

    shop::GenXml4Item

GenXml4Item(
int
$root, array
$row, [int
$site_users_id = 0], [array
$param = array ()] );

    Описание

    Внутренний метод построения XML для товара, его свойств и сопутствующих товаров

    Принимаемые параметры

    $root

    параметр, определяющий, является ли данный товар сопутствующим (0-основной, 1 - сопутствующий или модификация)

    $row

    информация о товаре

    $site_users_id

    идентификатор пользователя

    $param

    дополнительные параметры
    • $param['xml_show_tying_products'] разрешает указание в XML сопутствующих товаров, по умолчанию true
    • $param['xml_show_modification'] разрешает указание в XML модификаций товаров, по умолчанию true
    • $param['xml_show_comments'] разрешает добавление в XML отзывов о товаре, по умолчанию true

    Возвращает

    XML для свойств товара

    [ Наверх ]

    shop::GenXml4ItemCatalogCommentAverageGrade

GenXml4ItemCatalogCommentAverageGrade(
int
$shop_items_catalog_item_id );

    Описание

    Метод возвращает XML со средней оценкой описания активных отзывов по товару.

    Принимаемые параметры

    $shop_items_catalog_item_id

    метод генерирующий XML активных отзывов для данного товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4ItemCatalogCommentAverageGrade($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    среднея оценка

    [ Наверх ]

    shop::GenXml4ItemCatalogComments

GenXml4ItemCatalogComments(
int
$shop_items_catalog_item_id, [array
$param = array ()] );

    Описание

    Метод возвращает все комментарии, относящиеся к данному товару.

    Принимаемые параметры

    $shop_items_catalog_item_id

    метод генерирующий XML отзывов для данного товара

    $param

    массив с доп. параметрами
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4ItemCatalogComments($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    XML с данными об отзывах

    [ Наверх ]

    shop::GenXml4Mesures

GenXml4Mesures(
int
$shop_mesures_id );

    Описание

    Метод генерирует XML для единиц измерения

    Принимаемые параметры

    $shop_mesures_id

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_mesures_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Mesures($shop_mesures_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::GenXml4OrderStatus

GenXml4OrderStatus(

$shop_order_status_id, int
$shop_delivery_id );

    Описание

    Метод генерирует XML для статуса доставки

    Принимаемые параметры

    $shop_delivery_id

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_status_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4OrderStatus($shop_order_status_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    $shop_order_status_id

    [ Наверх ]

    shop::GenXML4PriceForShop

GenXML4PriceForShop(
int
$shop_list_of_prices_id, [array
$list_of_price_row = false] );

    Описание

    Возвращает XML цены для группы пользователей.

    Принимаемые параметры

    $shop_list_of_prices_id

    идентификатор цены для группы пользователей

    $list_of_price_row

    информация о продавце, если false - получается автоматически

    Возвращает

    XML текст с информацией о цене для группы пользователей.

    [ Наверх ]

    shop::GenXml4Properties

GenXml4Properties(

$shop_shops_id, [int
$shop_groups_id = 0], [
$param = array()] );

    Описание

    Метод построения XML для свойств товаров, доступных группе.

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы, если 0, то XML генерируется для корневой группы.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $shop_groups_id = 589;
      6.

    6.
      7.

    7.  $xml = $shop->GenXml4Properties($shop_shops_id, $shop_groups_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo htmlspecialchars($xml);
      11.

    11.  ?>
      12.

    $shop_shops_id

    $param

    Возвращает

    XML для свойств

    [ Наверх ]

    shop::GenXml4Property

GenXml4Property(
int
$shop_list_of_properties_id, [array
$property_row = false] );

    Описание

    Возвращает XML свойства.

    Принимаемые параметры

    $shop_list_of_properties_id

    свойства

    $property_row

    информация о свойстве
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_list_of_properties_id = 133;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Property($shop_list_of_properties_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    XML текст с информацией о свойстве.

    [ Наверх ]

    shop::GenXml4Saller

GenXml4Saller(
int
$shop_sallers_id, [array
$shop_sallers_row = false] );

    Описание

    Возвращает XML продавца.

    Принимаемые параметры

    $shop_sallers_id

    идентификатор продавца

    $shop_sallers_row

    информация о продавце, если не false, то берется не из базы а отсюда.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_sallers_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Saller($shop_sallers_id = 0);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    XML текст с информацией о продавце.

    [ Наверх ]

    shop::GenXml4Sallers

GenXml4Sallers(
[int
$shop_id = 0], [array
$param = array()] );

    Описание

    Метод построения XML для продавцов.

    Принимаемые параметры

    $shop_id

    идентификатор магазина, если 0, то XML генерируется для всех магазинов

    $param

    массив дополнительных параметров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Sallers($shop_id = 0);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);*
      10.

    10.  ?>
      11.

    Возвращает

    XML для продавцов

    [ Наверх ]

    shop::GenXml4Shop

GenXml4Shop(

$shop_id, [
$shop_row = false], int
$shop_id;, array
$shop_row; );

    Описание

    Метод генерации XML для магазина

    Принимаемые параметры

    $shop_id;

    $shop_row;

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GenXml4Shop($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    $shop_id

    $shop_row

    [ Наверх ]

    shop::GenXML4SpecialPrice

GenXML4SpecialPrice(
int
$shop_special_prices_id );

    Описание

    Формирование XML для специальных цен товара

    Принимаемые параметры

    $shop_special_prices_id

    идентификатор специальной цены

    Возвращает

    XML данные
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_special_prices_id= 8;
      5.

    5.
      6.

    6.  $newxml = $shop->GenXML4SpecialPrice($shop_special_prices_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($newxml);
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::GenXml4Taxes

GenXml4Taxes(
 );

    Описание

    Формирование XML для налогов

    Возвращает

    XML для налогов

    [ Наверх ]

    shop::GenXmlForGroupsPropertyDir

GenXmlForGroupsPropertyDir(
int
$shop_shops_id, [int
$shop_properties_groups_dir_parent_id = 0] );

    Описание

    Генерация XML для групп дополнительных свойств групп товаров

    Принимаемые параметры

    $shop_shops_id

    Идентификатор магазина

    $shop_properties_groups_dir_parent_id

    Идентификатор родительской директории

    [ Наверх ]

    shop::GenXmlForItemsPropertyDir

GenXmlForItemsPropertyDir(
int
$shop_shops_id, [int
$shop_properties_items_dir_parent_id = 0] );

    Описание

    Генерация XML для групп дополнительных свойств

    Принимаемые параметры

    $shop_shops_id

    Идентификатор магазина

    $shop_properties_items_dir_parent_id

    Идентификатор родительской директории

    [ Наверх ]

    shop::GenXmlForSystemOfPays

GenXmlForSystemOfPays(
[
$shop_shops_id = false] );

    Описание

    Генерация XML для списка всех платежных систем.

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $xmlData = $shop->GenXmlForSystemOfPays();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo htmlspecialchars($xmlData);
      8.

    8.
      9.

    9.  ?>
      10.

    Принимаемые параметры

    $shop_shops_id

    [ Наверх ]

    shop::GenXmlProducerList

GenXmlProducerList(
array
$param, [array
$external_propertys = array ()] );

    Описание

    Метод генерирует XML для списка продавцов магазина

    Принимаемые параметры

    $param

    массив дополнительных параметров
    • $param['shop_id'] идентификатор магазина
    • $param['current_group_id'] идентификатор или группа идентификаторов группы магазина, для товаров из которой необходимо получить производителей. Необязательно для заполнения
    • $param['begin'] начальная позиция выбора производителей
    • $param['count'] количество отображаемых производителей
    • $param['show_shop_xml'] вносить информацию в XML о магазине, по умолчанию true

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_id'] = 1;
      5.

    5.  $param['current_group_id'] =589;
      6.

    6.
      7.

    7.  $xmlData = $shop->GenXmlProducerList($param);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo htmlspecialchars($xmlData);
      11.

    11.  ?>
      12.

    Возвращает

    XML или false в случае отсутствия продавцов

    [ Наверх ]

    shop::GetAccessShopItem

GetAccessShopItem(
int
$site_user_id, int
$shop_item_id, [array
$row_item = array()], int
$parent );

    Описание

    Определение доступности товара

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    $shop_item_id

    идентификатор инфоэлемента

    $parent

    параметр, определяющий наследует ли информационный элемент тип доступа от родителя (1 - наследует, 0 - не наследует)

    $row_item

    ассоциативный массив свойств информационного элемента

    Возвращает

    true - товар доступен пользователю, false - не доступен

    [ Наверх ]

    shop::GetAdditionalPropertyDirPathArray

GetAdditionalPropertyDirPathArray(

$shop_properties_groups_dir_id, [boolean
$first_call = true], integer
$shop_properties_items_dir_id );

    Описание

    Получение пути от текущего каталога дополнительных свойств товара к корневому

    Принимаемые параметры

    $shop_properties_items_dir_id

    идентификатор текущего каталога

    $first_call

    первый ли это вызов функции
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_groups_dir_id =7;
      5.

    5.
      6.

    6.  $row = $shop->GetAdditionalPropertyDirPathArray($shop_properties_groups_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    $shop_properties_groups_dir_id

    Возвращает

    массив данных

    [ Наверх ]

    shop::GetAdditionalPropertyPathArray

GetAdditionalPropertyPathArray(
integer
$shop_properties_items_dir_id, [boolean
$first_call = true] );

    Описание

    Получение пути от текущего каталога дополнительных свойств товара к корневому

    Принимаемые параметры

    $shop_properties_items_dir_id

    идентификатор текущего каталога

    $first_call

    первый ли это вызов функции
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_items_dir_id = 3;
      5.

    5.
      6.

    6.  $row = $shop->GetAdditionalPropertyPathArray($shop_properties_items_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив данных

    [ Наверх ]

    shop::GetAllCity

GetAllCity(
[int
$shop_location_id = 0] );

    Описание

    Получение списка городов

    Принимаемые параметры

    $shop_location_id

    идентификатор местоположения, если 0, то выбираются все города
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_location_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetAllCity($shop_location_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    shop::GetAllCityArea

GetAllCityArea(
[
$shop_city_id = 0] );

    Описание

    Метод выборки всех районов города

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_city_id = 0;
      5.

    5.
      6.

    6.  $row = $shop->GetAllCityArea($shop_city_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Принимаемые параметры

    $shop_city_id

    [ Наверх ]

    shop::GetAllComments

GetAllComments(
int
$shop_items_catalog_item_id, [array
$param = array ()] );

    Описание

    Метод возвращает список всех комментариев

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара, если не равен false, то метод  вернет список комментариев, относящихся только к данному товару

    $param

    массив дополнительных параметров
    • $param['shop_id'] идентификатор интернет-магазина
    • $param['shop_comment_active'] статус активности выбираемых элементов (0/1). Параметр может быть не задан.
    • $param['comments_begin'] параметр, определяющий порядковый номер комментария, с которого отображать комментарии (по умолчанию 0)
    • $param['comments_count'] параметр, определяющий число отображаемых комментариев
    • $param['comments_sort_field'] поле сортировки комментариев (по умолчанию shop_comment_date_time)
    • $param['comments_sort_order'] направление сортировки комментариев. 'ASC' - сортировка по возрастанию, 'DESC' (по умолчанию) - по убыванию, 'RAND()' - в произвольном порядке

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_items_catalog_item_id = 158;
        5.

      5.
        6.

      6.  $resource = $shop->GetAllComments($shop_items_catalog_item_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($resource);
        10.

      10.  ?>
        11.

    Возвращает

    или false - результат выборки

    [ Наверх ]

    shop::GetAllCompanies

GetAllCompanies(
 );

    Описание

    Метод для получения списка всех компаний

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllCompanies();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    ресурс или false

    [ Наверх ]

    shop::GetAllCondOfDelivery

GetAllCondOfDelivery(
[array
$param = array ()] );

    Описание

    Метод выборки всех условий доставки

    Принимаемые параметры

    $param

    массив дополнительных параметров, влияющих на выборку
    $param['type_of_delivery_id'] int идентификатор типа доставок, для которого необходимо выбрать все условия
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllCondOfDelivery($param=array());
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    результат выборки условий доставки

    [ Наверх ]

    shop::GetAllCountries

GetAllCountries(
 );

    Описание

    Метод, осуществляющий извлечение всех стран

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllCountries();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.
      12.

    12.  ?>
      13.

    [ Наверх ]

    shop::GetAllCoupons

GetAllCoupons(
array
$param );

    Описание

    Метод возвращает список купонов по заданным условиям

    Принимаемые параметры

    $param

    список дополнительных параметров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param = array();
      5.

    5.
      6.

    6.  $resource = $shop->GetAllCoupons($param);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    ресурс с данными выборки

    [ Наверх ]

    shop::GetAllCurrency

GetAllCurrency(
 );

    Описание

    Метод выборки информации обо всех валютах

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllCurrency();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    информация обо всех валютах (результат запроса), ложь в случае возникновения ошибки (или если не существует ни одной валюты)

    [ Наверх ]

    shop::GetAllDiscounts

GetAllDiscounts(
[int
$shop_shops_id = false], [array
$param = array()] );

    Описание

    Метод возвращает список всех скидок

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    ассоциативный массив параметров
    • $param['shop_discount_is_active'] int активность скидки
    • $param['shop_discount_is_hold'] bool выбирать только действующие скидки

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $resource = $resource = $shop->GetAllDiscounts($shop_shops_id = false);
        5.

      5.
        6.

      6.  // Распечатаем результат
        7.

      7.  while($row = mysql_fetch_assoc($resource))
        8.

      8.  {
        9.

      9.      print_r($row);
        10.

      10.  }
        11.

      11.  ?>
        12.

    [ Наверх ]

    shop::GetAllDiscountsForItem

GetAllDiscountsForItem(
int
$shop_items_catalog_item_id );

    Описание

    Метод извлечения информации обо всех скидках для данного товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.
      6.

    6.  $row = $shop->GetAllDiscountsForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив идентификаторов скидок или false

    [ Наверх ]

    shop::GetAllGroups

GetAllGroups(
int
$shop_id, [array
$param = array ()] );

    Описание

    Получение всех групп магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $param

    массив дополнительных параметров для выборки
    • $param['shop_groups_parent_id'] идентификатор или массив идентификаторов родительской группы
    • $param['group_field_order'] поле сортировки группы
    • $param['group_order'] направление сортировки группы ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)
    • $param['cache_off']  - если параметр установлен - данные не кэшируются
    • $param['groups_activity'] параметр, учитывающий активность групп при выборке. 1 - получаем информацию только об активных группах, если не задан, то активность группы не учитывается
    • $param['xml_show_group_id'] массив ID групп для выборки

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_id = 1;
        5.

      5.  $param['shop_groups_parent_id'] = 589;
        6.

      6.  $param['group_order'] = 'Asc';
        7.

      7.
        8.

      8.  $rows = $shop->GetAllGroups($shop_id, $param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  print_r($rows);
        12.

      12.  ?>
        13.

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetAllItems

GetAllItems(
int
$shop_id, [mixed
$group_id = false], [array
$param = array ()] );

    Описание

    Получение всех товаров заданного магазина и заданной группы товаров

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $group_id

    идентификатор группы товаров, если $group_id = false, то получаем информацию о товарах всех групп

    $param

    массив дополнительных параметров  $param['items_begin'] номер товара в выборке, с которого начинать отображение товаров магазина  $param['items_on_page'] число товаров, отображаемых на странице  $param['items_field_order'] поле сортировки  $param['shop_items_catalog_is_active'] активность товара (если 2, выбираем и активные и неактивные параметры, если 0 выбираем только неактивные товары, если не передан выбираем только активные товары)  $param['items_order'] направление сортировки ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)  $param['FillMemCacheTyingProducts'] указывает на необходимость заполнения кэша сопутствующих товаров для выбранных товаров. по умолчанию false  $param['FillMemCacheDiscountsForItem'] указывает на необходимость заполнения кэша скидок для выбранных товаров. по умолчанию true  $param['FillMemCacheComments'] указывает на необходимость заполнения кэша комментариев для выбранных товаров. по умолчанию false  $param['FillMemCachePropertiesItem'] указывает на необходимость заполнения кэша дополнительных свойств для выбранных товаров. по умолчанию false  $param['sql_from'] дополнения для SQL-запроса выборки в секции FROM. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.  $param['sql_having'] дополнения для SQL-запроса выборки в секции HAVING. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.  $param['sql_group_by'] дополнения для SQL-запроса выборки в секции GROUP BY. При использовании параметра не забывайте о необходимости их фильтрации для защиты от SQL-инъекций.  $param['sql_select_modification'] указывает на необходимость ограничения. Если указано true, то модификации исключаются из выборки  $param['cache_off'] флаг, запрещающий кеширование (по умолчанию false)  $param['select'] массив внешних условий для выборки, например
    • $param['select'][0]['type'] = 0;
    • $param['select'][0]['prefix'] = 'AND';
    • $param['select'][0]['name'] = 'shop_items_catalog_yandex_market_allow';
    • $param['select'][0]['if'] = '=';
    • $param['select'][0]['value'] = '1';
    • $param['select'][0]['sufix'] = '';
     $param['show_catalog_item_type'] array массив типов товаров, которые должны отображаться.  Может содержать следующие элементы:
    active - активные элементы (внесен по умолчанию, если $param['show_catalog_item_type'] не задан;
    inactive - неактивные элементы;
    putend_date - элементы, у которых значение поля putend_date меньше текущей даты;
    putoff_date - элементы, у которых значение поля putoff_date превышает текущую дату;  $param['sql_external_select'] параметр, задающий список дополнительных полей в оператор SELECT выборки товаров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetAllItems($shop_id, $group_id, $param);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив или false

    [ Наверх ]

    shop::GetAllItemsForOrder

GetAllItemsForOrder(
int
$shop_order_id );

    Описание

    Получение заказанных товаров

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 38;
      5.

    5.
      6.

    6.  $array = $shop->GetAllItemsForOrder($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($array))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки в случае, если выбрана хотя бы одна запись, ложь - если нет ни одной записи

    [ Наверх ]

    shop::GetAllListProperties

GetAllListProperties(
int
$shop_shops_id, [array
$param = array ()] );

    Описание

    Получение всех дополнительных свойств для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    массив дополнительных параметров
    • $param['order'] поле сортировки
    • $param['where'] дополнительное условие для where

    Возвращает

    информация о дополнительных свойств для магазина (результат выполнения запроса)

    [ Наверх ]

    shop::GetAllLocation

GetAllLocation(
[
$country_id = 0], int
$county_id );

    Описание

    Получение списка всех областей (штатов)

    Принимаемые параметры

    $county_id

    идентификатор страны, для которой выбираем области (при =0 - выбираем все области)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $array = $shop->GetAllLocation($country_id = 0);
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($array))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    $country_id

    Возвращает

    информация об областях (штатах)

    [ Наверх ]

    shop::GetAllMesures

GetAllMesures(
 );

    Описание

    Метод выборки всех единиц измерения

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $array = $shop->GetAllMesures();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($array))
      8.

    8.  {
      9.

    9.     print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    результат выборки единиц измерения

    [ Наверх ]

    shop::GetAllModificationItems

GetAllModificationItems(
int
$shop_items_catalog_item_id, [array
$param = array ()] );

    Описание

    Метод возвращает информацию обо всех модификациях данного товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $param

    массив дополнительных параметров
    • $param['shop_items_catalog_is_active'] статус активности выбираемых элементов (0/1). Параметр может быть не задан.
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    ассоциативный массив с информацией о модификации товаров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.
      6.

    6.  $array = $shop->GetAllModificationItems($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($array);
      10.

    10.
      11.

    11.  ?>
      12.

    [ Наверх ]

    shop::GetAllOrderDiscounts

GetAllOrderDiscounts(
[int
$shop_shops_id = false] );

    Описание

    Метод для извлечения информации обо всех скидках

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetAllOrderDiscounts($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetAllOrders

GetAllOrders(
int
$shop_shops_id, [array
$param = array ()] );

    Описание

    Метод выборки заказов для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    массив дополнительных параметров для выборки
    • $param['order'] поле, по которому осуществляем сортировку
    • $param['order_sort'] порядок сортировки (ASC - прямой, DESC - обратный)
    • $param['user_id'] идентификатор пользователя сайта (если необходимо выбрать заказы для пользователя)
    • $param['limit_from'] номер записи, с которой начинаем выборку (нумерация записей с 0)
    • $param['limit_count'] количество выбираемых записей

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id = 1;
        5.

      5.  $param['order_sort'] = 'ASC';
        6.

      6.  $param['user_id'] = '';
        7.

      7.  $param['limit_from'] = 0;
        8.

      8.  $param['limit_count'] = '';
        9.

      9.
        10.

      10.  $resource = $shop->GetAllOrders($shop_shops_id, $param);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  while($row = mysql_fetch_assoc($resource))
        14.

      14.  {
        15.

      15.      print_r($row);
        16.

      16.  }
        17.

      17.  ?>
        18.

    Возвращает

    результат выборки запроса

    [ Наверх ]

    shop::GetAllOrderStatus

GetAllOrderStatus(
 );

    Описание

    Получение информации обо всех статусах заказаов

    Возвращает

    информация о статусах заказа (результат выборки)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllOrderStatus();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    shop::GetAllPricesForItem

GetAllPricesForItem(
int
$shop_items_catalog_item_id );

    Описание

    Получение информации о ценах, заданных для товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 159;
      5.

    5.
      6.

    6.  $row = $shop->GetAllPricesForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    информация о ценах товара (массив с данными о ценах), ложь, если возникла ошибка или нет ни одной цены

    [ Наверх ]

    shop::GetAllPricesForShop

GetAllPricesForShop(
int
$shop_shops_id );

    Описание

    Получение списка цен для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetAllPricesForShop($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    информация о ценах для магазина при успешной выборке, ложь, если возникла ошибка или нет ни одной цены

    [ Наверх ]

    shop::GetAllProducers

GetAllProducers(
[array
$param = array ()] );

    Описание

    Получение информации обо всех производителях

    Принимаемые параметры

    $param

    массив дополнительных условий для выборки
    • $param['shop_id'] int идентификатор магазина
    • $param['current_group_id'] int идентификатор или группа идентификаторов группы магазина, для товаров из которой необходимо получить производителей. Необязательно для заполнения
    • $param['xml_show_all_producers'] bool отображать всех производителей магазина
    • $param['begin'] начальная позиция выбора производителей
    • $param['count'] количество отображаемых производителей

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_id'] = 1;
        5.

      5.  $param['current_group_id'] = 589;
        6.

      6.  $param['begin'] = 0;
        7.

      7.  $param['count'] = 10;
        8.

      8.
        9.

      9.  $resource = $shop->GetAllProducers($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  while($row = mysql_fetch_assoc($resource))
        13.

      13.  {
        14.

      14.      print_r($row);
        15.

      15.  }
        16.

      16.  ?>
        17.

    Возвращает

    информация о производителях (результат запроса)

    [ Наверх ]

    shop::GetAllPropertiesGroup

GetAllPropertiesGroup(
int
$shop_groups_id, [array
$param = array()] );

    Описание

    Метод извлечения информации о дополнительных свойствах группы товаров

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы

    $param

    массив дополнительных свойств
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_groups_id = 158;
        5.

      5.  $param = array();
        6.

      6.  $resource = $shop->GetAllPropertiesItem($shop_groups_id, $param);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($resource);
        10.

      10.
        11.

      11.  ?>
        12.

    Возвращает

    массив дополнительных свойств для товара, ложь - если не задано ни одного свойства для товара

    [ Наверх ]

    shop::GetAllPropertiesGroupsDirForDir

GetAllPropertiesGroupsDirForDir(
int
$shop_properties_groups_dir_id, int
$shop_shops_id );

    Описание

    Получаем список всех групп дополнительных свойств групп товаров

    Принимаемые параметры

    $shop_properties_groups_dir_id

    Идентификатор группы дополнительных свойств групп товаров

    $shop_shops_id

    Идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_groups_dir_id = 9;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $resource = $shop->GetAllPropertiesGroupsDirForDir($shop_properties_groups_dir_id, $shop_shops_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($resource))
      11.

    11.  {
      12.

    12.      print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    либо False

    [ Наверх ]

    shop::GetAllPropertiesGroupsDirForShop

GetAllPropertiesGroupsDirForShop(
int
$shop_shops_id, [array
$param = array()] );

    Описание

    Получение инфомации обо всех группах дополнительных свойств групп товаров конкретного магазина

    Принимаемые параметры

    $shop_shops_id

    Идентификатор магазина

    $param

    массив параметров
    • $param['parent_properties_groups_dir_id'] идентификатор группы дополнительных свойств групп товаров, информацию о подгруппах которой необходимо получить.

       по умолчанию равен false - получаем информацию о всех группах дополнительных свойств групп товаров.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id = 1;
        5.

      5.
        6.

      6.  $resource = $shop->GetAllPropertiesGroupsDirForShop($shop_shops_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

    Возвращает

    Resource или False

    [ Наверх ]

    shop::GetAllPropertiesItem

GetAllPropertiesItem(
int
$item_id, [array
$param = array ()] );

    Описание

    Метод извлечения информации о дополнительных свойствах заданного товара

    Принимаемые параметры

    $item_id

    идентификатор товара

    $param

    массив дополнительных свойств
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $item_id = 158;
        5.

      5.  $param = array();
        6.

      6.  $resource = $shop->GetAllPropertiesItem($item_id, $param);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($resource);
        10.

      10.
        11.

      11.  ?>
        12.

    Возвращает

    массив дополнительных свойств для товара, ложь - если не задано ни одного свойства для товара

    [ Наверх ]

    shop::GetAllPropertiesItemsDirForShop

GetAllPropertiesItemsDirForShop(
int
$shop_shops_id, [array
$param = array()] );

    Описание

    Получение информации обо всех группах дополнительных свойств товара для конкретного магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $param

    массив параметров
    • $param['parent_properties_items_dir_id'] идентификатор группы дополнительных свойств товаров, информацию о подгруппах которой необходимо получить.

       по умолчанию равен false - получаем информацию о всех группах дополнительных свойств товаров.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id = 1;
        5.

      5.
        6.

      6.  $resource = $shop->GetAllPropertiesItemsDirForShop($shop_shops_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  while($row = mysql_fetch_assoc($resource))
        10.

      10.  {
        11.

      11.      print_r($row);
        12.

      12.  }
        13.

      13.  ?>
        14.

    [ Наверх ]

    shop::GetAllPropertiesItemsForDir

GetAllPropertiesItemsForDir(
array
$param );

    Описание

    Получение информации обо всех свойствах хранящихся в конкретной группе дополнительных свойств конкртеного магазина

    Принимаемые параметры

    $param

    Массив параметров
    • $param['shop_shops_id'] Идентификатор магазина
    • $param['shop_properties_items_dir_id'] Идентификатор группы дополнительных свойств товара

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['shop_properties_items_dir_id'] = 3;
        6.

      6.
        7.

      7.  $resource = $shop->GetAllPropertiesItemsForDir($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  while($row = mysql_fetch_assoc($resource))
        11.

      11.  {
        12.

      12.      print_r($row);
        13.

      13.  }
        14.

      14.  ?>
        15.

    Возвращает

    Ответ базы

    [ Наверх ]

    shop::GetAllPropretyOfGroup

GetAllPropretyOfGroup(
int
$shop_shops_id, [
$shop_properties_groups_dir_id = false] );

    Описание

    Получение информации о ВСЕХ дополнительных свойствах групп магазина

    Принимаемые параметры

    $shop_shops_id

    Идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetAllPropretyOfGroup($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    $shop_properties_groups_dir_id

    Возвращает

    Результат выборки из базы

    [ Наверх ]

    shop::GetAllSellers

GetAllSellers(
[int
$shop_id = false], [array
$param = array()] );

    Описание

    Получение информации о всех продавцах магазина $shop_id, если $shop_id = false,  то о продавцах всех магазинов

    Принимаемые параметры

    $shop_id

    - идентификатор магазина

    $param

    массив дополнительных параметров
    • $param['xml_show_all_sellers'] отображать всех продавцов магазина

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $resource = $shop->GetAllSellers($shop_id = false);
        5.

      5.
        6.

      6.  // Распечатаем результат
        7.

      7.  while($row = mysql_fetch_assoc($resource))
        8.

      8.  {
        9.

      9.      print_r($row);
        10.

      10.  }
        11.

      11.  ?>
        12.

    Возвращает

    информация о продавцах

    [ Наверх ]

    shop::GetAllShops

GetAllShops(
int
$site_id );

    Описание

    Метод для получения списка всех магазинов

    Принимаемые параметры

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetAllShops($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetAllShopsDirs

GetAllShopsDirs(
[array
$param = array()] );

    Описание

    Получение информации о разделах интернет-магазинов

    Принимаемые параметры

    $param

    массив параметров
    • $param['shop_dir_parent_id'] идентификатор родительского раздела магазинов. По умолчанию равен 0.
    • $param['site_id'] идентификатор сайта. По умолчанию имеет значение идентификатора текущего сайта.    *

    [ Наверх ]

    shop::GetAllShopsFromDir

GetAllShopsFromDir(
int
$shop_dir_id );

    Описание

    Получение информации о интернет-магазинах раздела

    Принимаемые параметры

    $shop_dir_id

    идентификатор раздела магазинов

    [ Наверх ]

    shop::GetAllSiteUserAccountTransaction

GetAllSiteUserAccountTransaction(
int
$site_users_id, [int
$shop_shops_id = false] );

    Описание

    Метод возвращает данные обо всех транзакциях пользователя сайта

    Принимаемые параметры

    $site_users_id

    Идентификатор пользователя сайта

    $shop_shops_id

    Идентификатор магазина, необязательный параметр, по умолчанию false
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      5.

    5.  if (class_exists('SiteUsers'))
      6.

    6.  {
      7.

    7.      $SiteUsers = & singleton('SiteUsers');
      8.

    8.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      9.

    9.  }
      10.

    10.      else
      11.

    11.  {
      12.

    12.      $site_users_id = 0;
      13.

    13.  }
      14.

    14.
      15.

    15.  $resource = $shop->GetAllSiteUserAccountTransaction($site_users_id);
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  while($row = mysql_fetch_assoc($resource))
      19.

    19.  {
      20.

    20.      print_r($row);
      21.

    21.  }
      22.

    22.  ?>
      23.

    Возвращает

    Результат выборки базы или false

    [ Наверх ]

    shop::GetAllSpecialPricesForItem

GetAllSpecialPricesForItem(
mixed
$shop_items_catalog_item_id );

    Описание

    Получение информации о всех специальных ценах товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор или массив идентификаторов товаров

    Возвращает

    Resource или False
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 159;
      5.

    5.
      6.

    6.  $resource = $shop->GetAllSpecialPricesForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    shop::GetAllSystemOfPay

GetAllSystemOfPay(
[int
$shop_shops_id = false] );

    Описание

    Получение всех активных платежных систем

    Принимаемые параметры

    $shop_shops_id

    идентификатор идентификатор магазина (по умолчанию равен FALSE)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllSystemOfPay();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    возвращает результат выборки

    [ Наверх ]

    shop::GetAllTax

GetAllTax(
 );

    Описание

    Получение информации о налогах

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $resource = $shop->GetAllTax();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    информация о налогах (результат запроса)

    [ Наверх ]

    shop::GetAllTypeOfDelivery

GetAllTypeOfDelivery(
int
$shop_shops_id );

    Описание

    Метод выборки всех типов доставки для конкретного магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    Возвращает

    список типов доставки (результат запроса)

    [ Наверх ]

    shop::GetCart

GetCart(
 );

    Описание

    Извлечение корзины в зависимости от CartType.

    Для универсального извлечения данных корзины используйте GetItemsFromCart()

    Возвращает

    содержимое корзины

    see

    shop::GetItemsFromCart()

    [ Наверх ]

    shop::GetCatalogItemIdByCmlId

GetCatalogItemIdByCmlId(
string
$shop_items_cml_id,
$shop_shops_id );

    Описание

    Метод возвращает данные о товаре по идентификатору товара стандарта CommerceML

    Принимаемые параметры

    $shop_items_cml_id

    Идентификатор товара при импорте из CommerceML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_cml_id = 'ID12345678';
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetCatalogItemIdByCmlId($shop_items_cml_id, $shop_shops_id);
      8.

    8.
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    $shop_shops_id

    Возвращает

    результат выборки базы или false

    [ Наверх ]

    shop::GetCity

GetCity(
int
$shop_city_id );

    Описание

    Метод, осуществляющий извлечение города

    Принимаемые параметры

    $shop_city_id

    идентификационный номер города
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_city_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetCity($shop_city_id);
      7.

    7.
      8.

    8.  //Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с данными или false, если город не найден

    [ Наверх ]

    shop::GetCityArea

GetCityArea(
int
$city_area_id );

    Описание

    Получение информации о районе города по идентификатору района

    Принимаемые параметры

    $city_area_id

    идентификатор района города
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $city_area_id = 3;
      5.

    5.
      6.

    6.  $row = $shop->GetCityArea($city_area_id);
      7.

    7.
      8.

    8.  //Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о районе города в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCityAreaByName

GetCityAreaByName(

$shop_city_area_name );

    Принимаемые параметры

    $shop_city_area_name

    [ Наверх ]

    shop::GetCityByName

GetCityByName(

$shop_city_name );

    Принимаемые параметры

    $shop_city_name

    [ Наверх ]

    shop::GetComment

GetComment(
int
$shop_comment_id, [array
$param = array ()] );

    Описание

    Метод возвращает информацию о комментарии к товару

    Принимаемые параметры

    $shop_comment_id

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_comment_id = 3;
        5.

      5.
        6.

      6.  $row = $shop->GetComment($shop_comment_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    с информацией о комментарии или false

    [ Наверх ]

    shop::GetCompany

GetCompany(
int
$shop_company_id );

    Описание

    Метод для получения информации об организации

    Принимаемые параметры

    $shop_company_id

    идентификатор организации
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_company_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetCompany($shop_company_id);
      7.

    7.
      8.

    8.  //Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией об организации или false

    [ Наверх ]

    shop::GetCondOfDelivery

GetCondOfDelivery(
int
$shop_cond_of_delivery_id, [boolean
$select_delivery_type = false] );

    Описание

    Метод, осуществляющий извлечение условия доставки

    Принимаемые параметры

    $shop_cond_of_delivery_id

    идентификационный номер условия доставки

    $select_delivery_type

    флаг, указывающий на необходимость получить информацию о типе доставки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_cond_of_delivery_id = 1;
      5.

    5.  $select_delivery_type = true;
      6.

    6.
      7.

    7.  $row = $shop->GetCondOfDelivery($shop_cond_of_delivery_id, $select_delivery_type);
      8.

    8.
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    результат выборки условия доставки (+ информация о типе доставки при установленном флаге)

    [ Наверх ]

    shop::GetCondOfDeliveryXml

GetCondOfDeliveryXml(
int
$shop_cond_of_delivery_id );

    Описание

    Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)

    Принимаемые параметры

    $shop_cond_of_delivery_id

    идентификатор условия доставки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_cond_of_delivery_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GetCondOfDeliveryXml($shop_cond_of_delivery_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    xml для условия доставки, ложь, если информация не выбрана

    [ Наверх ]

    shop::GetCookie

GetCookie(
str
$cookie_name );

    Описание

    Загрузка массива данных из cookies

    Принимаемые параметры

    $cookie_name

    наименование cookie

    [ Наверх ]

    shop::GetCookieCart

GetCookieCart(
 );

    Описание

    Получить содержимое корзины в cookies

    see

    shop::GetCart()

    [ Наверх ]

    shop::GetCookieExpires

GetCookieExpires(
 );

    Описание

    Метод возвращает время истечения данных в корзине, хранящейся в кукисах.

    Метод работает на основе значение константы SHOP_COOKIE_EXPIRES, если она задана.  Значение = 0 означает хранение данных до закрытия браузера.  При отсутствии заданной константы данные в кукисах хранятся 365 дней (31536000 секунд). Значение константы задается в секундах.

    [ Наверх ]

    shop::GetCountAllComments

GetCountAllComments(
 );

    Описание

    Получение числа комментариев к товарам

    Возвращает

    число комментариев

    [ Наверх ]

    shop::GetCountCity

GetCountCity(
[int
$shop_location_id = 0] );

    Описание

    Получение числа городов для области

    Принимаемые параметры

    $shop_location_id

    идентификатор области
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_location_id = 0;
      5.

    5.
      6.

    6.  $count = $shop->GetCountCity($shop_location_id = 0);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число стран в справочнике в случае удачного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountCityAreas

GetCountCityAreas(
[int
$shop_city_id = 0] );

    Описание

    Получение числа районов города

    Принимаемые параметры

    $shop_city_id

    идентификатор города
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_city_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountCityAreas($shop_city_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число районов в городе или false

    [ Наверх ]

    shop::GetCountCondOfDelivery

GetCountCondOfDelivery(
[int
$shop_type_of_delivery_id = 0] );

    Описание

    Получение числа условий доставки для типа доставки

    Принимаемые параметры

    $shop_type_of_delivery_id

    идентификатор типа доставки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_type_of_delivery_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountCondOfDelivery($shop_type_of_delivery_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число условий доставок или false

    [ Наверх ]

    shop::GetCountCountry

GetCountCountry(
 );

    Описание

    Получение числа стран

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountCountry();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    число стран в справочнике в случае удачного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountCurrency

GetCountCurrency(
 );

    Описание

    Получение числа валют в справочнике

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountCurrency();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    число валют в справочнике в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountDiscount

GetCountDiscount(
int
$shop_id );

    Описание

    Получение числа скидок для магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountDiscount($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число скидок для магазина в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountItemsAndGroups

GetCountItemsAndGroups(
int
$parent_group_id, int
$shop_shops_id, [boolean
$sub = true], [array
$param = array ()] );

    Описание

    Получение числа элементов и групп для переданной родительской группы

    Принимаемые параметры

    $parent_group_id

    идентификатор группы, для которой необходимо получить число элементов и групп.

    $shop_shops_id

    идентификатор магазина, к которому принадлежит группа.

    $sub

    параметр, определяющий будут ли учитываться подгруппы данной группы при подсчете элементов и групп (true - подгруппы учитываются, false - не учитываются). по умолчанию $sub = true

    $param

    массив дополнительных атрибутов
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $parent_group_id = 589;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetCountItemsAndGroups($parent_group_id, $shop_shops_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив из 4-х элементов
    • $mas['count_items'] число элементов в группе без учета элементов в подгруппах
    • $mas['count_all_items'] число элементов в группе с учетом элементов в подгруппах
    • $mas['count_groups'] число групп в данной группе без учета вложенности подгрупп
    • $mas['count_all_groups'] число групп в данной группе с учетом вложенности подгрупп

    [ Наверх ]

    shop::GetCountItemsCatalog

GetCountItemsCatalog(
int
$shop_id, mixed
$group_id, [array
$param = array()] );

    Описание

    Получение числа товаров в одном или во всех разделах магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазиа

    $group_id

    идентификатор раздела магазина, или false - если необходимо получить число всех товаров магазина

    $param

    массив дополнительных параметров  $param['shop_items_catalog_is_active'] активность товара (если 2, выбираем и активные и неактивные параметры, если 0 выбираем только неактивные товары, если не передан выбираем только активные товары)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $group_id = 589;
      6.

    6.
      7.

    7.  $count = $shop->GetCountItemsCatalog($shop_id, $group_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $count;
      11.

    11.  ?>
      12.

    Возвращает

    число товаров одного или всех разделов магазина в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    shop::GetCountItemsWithConditions

GetCountItemsWithConditions(
int
$shop_id, [mixed
$group_id = false], [array
$param = array ()] );

    Описание

    Получение числа товаров, параметры которых удовлетворяют заданным условиям

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $group_id

    идентификатор группы товаров, если $group_id = false, то получаем информацию о товарах всех групп, если $group_id равен строке с перечислением идентификаторов - '1,2,10,12,17', то возвращаются данные о товарах из указанных групп

    $param

    массив дополнительных параметров
    • $param['OrderField'] поле сортировки, если случайная сортировка, то записать RAND()
    • $param['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
    • $param['select'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора товаров
    • $element['type'] определяет, является ли поле основным свойством товара или дополнительным (0 - основное, 1 - дополнительное)
    • $element['prefix'] префикс - строка, размещаемая перед условием
    • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    • $element['property_id'] идентификатор дополнительногого свойства
    • $element['if'] строка, содержащая условный оператор
    • $elemenr['value'] значение поля (или параметра)
    • $element['sufix'] суффикс - строка, размещаемая после условия

      Например
    • $element['type']=1; // 0 - основное св-во, 1 - дополнительное
    • $element['prefix'] = 'and'; // префикс
    • $element['property_id'] = 26; // ID дополнительного св-ва, указывается если тип = 1
    • $element['if'] = '='; // Условие
    • $element['value'] = '10';
    • $element['sufix'] = '';
    • $param['select'][]=$element;
    • $element['type']=1; // 0 - основное св-во, 1 - дополнительное
    • $element['prefix'] = 'and'; // префикс
    • $element['property_id'] = 28; // ID дополнительного св-ва, указывается если тип = 1
    • $element['if'] = '='; // Условие
    • $element['value'] = 1;
    • $element['sufix'] = '';
     $param['select'][]=$element;
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountItemsWithConditions($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число товаров в случае успешного выполнения, false в противном случае

    [ Наверх ]

    shop::GetCountLocation

GetCountLocation(
[
$shop_country_id = 0] );

    Описание

    Получение числа областей (штатов) для страны

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountLocation($shop_country_id = 0);
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Принимаемые параметры

    $shop_country_id

    Возвращает

    число областей в справочнике в случае удачного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountMesures

GetCountMesures(
 );

    Описание

    Получение числа единиц измерения в справочнике

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountMesures();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    число единиц измерения в справочнике в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountOrder

GetCountOrder(
int
$shop_shops_id );

    Описание

    Метод выборки количества заказов для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина+
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetCountOrder($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    количество заказов для магазина или ложь при возникновении ошибки

    [ Наверх ]

    shop::GetCountOrderStatus

GetCountOrderStatus(
 );

    Описание

    Получение числа статусов заказа

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountOrderStatus();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    число статусов заказа в справочнике в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountProducers

GetCountProducers(
int
$shop_id );

    Описание

    Получение числа производителей для данного магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountProducers($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число производителей для данного магазина в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountProperties

GetCountProperties(
int
$shop_id );

    Описание

    Получение числа свойств товаров конкретного магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountProperties($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число свойств товаров магазина в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountry

GetCountry(
int
$shop_country_id );

    Описание

    Метод, осуществляющий извлечение страны

    Принимаемые параметры

    $shop_country_id

    идентификационный номер страны
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_country_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetCountry($shop_country_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки страны

    [ Наверх ]

    shop::GetCountryByName

GetCountryByName(

$shop_country_name );

    Принимаемые параметры

    $shop_country_name

    [ Наверх ]

    shop::GetCountSellers

GetCountSellers(
 );

    Описание

    Получение числа продавцов в справочнике

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountSellers();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    число продавцов в справочнике в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountShops

GetCountShops(
mixed
$site_id );

    Описание

    Получение числа магазинов для одного или всех сайтов, обслуживаемых системой управления

    Принимаемые параметры

    $site_id

    идентификатор сайта, для которого необходимо получить магазинов или false, если необходимо получить число магазинов для всех сайтов
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountShops($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число магазинов для одного или всех сайтов в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    shop::GetCountSystemOfPay

GetCountSystemOfPay(
[
$shop_shops_id = false] );

    Описание

    Получение числа систем оплаты

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountSystemOfPay();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Принимаемые параметры

    $shop_shops_id

    Возвращает

    число систем оплаты в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    shop::GetCountTax

GetCountTax(
 );

    Описание

    Получение числа налогов в справочнике

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $count = $shop->GetCountTax();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $count;
      8.

    8.  ?>
      9.

    Возвращает

    число налогов в справочнике в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountTypeOfDelivery

GetCountTypeOfDelivery(
int
$shop_id );

    Описание

    Получение числа типов доставок для данного магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountTypeOfDelivery($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число типов доставок для магазина в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCountTypePrices

GetCountTypePrices(
int
$shop_id );

    Описание

    Получение числа типов цен для магазина

    Принимаемые параметры

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $count = $shop->GetCountTypePrices($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $count;
      10.

    10.  ?>
      11.

    Возвращает

    число типов цен для магазина в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetCoupon

GetCoupon(
int
$shop_coupon_id );

    Описание

    Метод возвращает массив с информацией о купоне

    Принимаемые параметры

    $shop_coupon_id

    идентификатор купона
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_coupon_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetCoupon($shop_coupon_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    данные о купоне или false

    [ Наверх ]

    shop::GetCouponByText

GetCouponByText(
string
$shop_coupon_text, [bool
$shop_coupon_active = false], [array
$param = array()] );

    Описание

    Возвращает информацию о купоне по его тексту

    Принимаемые параметры

    $shop_coupon_text

    текст купона

    $shop_coupon_active

    активность купона, false - все купоны, т.е. активные и не активные

    $param

    массив дополнительных свойств
    • $param['shop_shops_id'] идентификатор магазина

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_coupon_text = '868-570-864-820';
        5.

      5.
        6.

      6.  $row = $shop->GetCouponByText($shop_coupon_text);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    результат выборки в виде ассоциативного массива или false

    [ Наверх ]

    shop::GetCurrency

GetCurrency(
int
$shop_currency_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение информации о валюте

    Принимаемые параметры

    $shop_currency_id

    идентификационный номер валюты

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_currency_id = 1;
        5.

      5.
        6.

      6.  $row = $shop->GetCurrency($shop_currency_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки валюты ( false при неудачной выборке)

    [ Наверх ]

    shop::GetCurrencyByInternationalName

GetCurrencyByInternationalName(
string
$shop_currency_international_name );

    Описание

    Метод для получения списка валют с указанным международным названием

    Принимаемые параметры

    $shop_currency_international_name

    международное название валюты, к примеру - RUR, USD и т.д.
    1.  <?php
      2.

    2.
      3.

    3.  $shop = new shop();
      4.

    4.
      5.

    5.  $shop_currency_international_name = 'RUR';
      6.

    6.
      7.

    7.  $row = $shop->GetCurrencyByInternationalName($shop_currency_international_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив с выбранными валютами или false

    [ Наверх ]

    shop::GetCurrencyByLike

GetCurrencyByLike(
string
$string );

    Описание

    Метод, возвращающий информацию о валюте из базы согласно имени $string используя оператор LIKE

    Принимаемые параметры

    $string

    Строка с именем вылюты
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $string = 'руб';
      5.

    5.
      6.

    6.  $row = $shop->GetCurrencyByLike($string);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    строка с данными о мере измерения или false

    [ Наверх ]

    shop::GetCurrencyCoefficientToShopCurrency

GetCurrencyCoefficientToShopCurrency(
float
$item_shop_currency_id, float
$shop_currency_id );

    Описание

    Метод определения коэффициента пересчета валюты товара в валюту магазина

    Принимаемые параметры

    $item_shop_currency_id

    идентифкатор валюты товара

    $shop_currency_id

    идентифкатор валюты магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $item_shop_currency_id = 2;
      5.

    5.  $shop_currency_id = 1;
      6.

    6.
      7.

    7.  $round = $shop->GetCurrencyCoefficientToShopCurrency($item_shop_currency_id, $shop_currency_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $round;
      11.

    11.  ?>
      12.

    Возвращает

    коэффициент пересечета валюты товара в валюту магазина

    [ Наверх ]

    shop::GetCurrencyForShop

GetCurrencyForShop(
int
$shop_shops_id );

    Описание

    Получение валюты, указанной по умолчанию для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetCurrencyForShop($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    результат выборки или ложь, если запись не выбрана

    [ Наверх ]

    shop::GetCurrencyXml

GetCurrencyXml(
int
$currency_id );

    Описание

    Метод формирования xml для валюты

    Принимаемые параметры

    $currency_id

    идентификатор валюты
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $currency_id = 1;
      5.

    5.
      6.

    6.  $xmlData = $shop->GetCurrencyXml($currency_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    xml для валюты магазина, ложь, если такой валюты не существует

    [ Наверх ]

    shop::GetDefaultCurrency

GetDefaultCurrency(
 );

    Описание

    Получение информации о базовой валюте

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $row = $shop->GetDefaultCurrency();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  print_r ($row);
      8.

    8.  ?>
      9.

    Возвращает

    информация о базовой валюте или ложь, если базовой валюты не существует

    [ Наверх ]

    shop::GetDefaultOrderStatus

GetDefaultOrderStatus(
int
$shop_id );

    Описание

    Получение статуса заказа, установленного по умолчанию

    Принимаемые параметры

    $shop_id

    идентфикатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetDefaultOrderStatus($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetDelimitedGroups

GetDelimitedGroups(
int
$shop_parent_group_id, int
$shop_id, [string
$separator = ''], [int
$shop_groups_id = false], [array
$param = array()] );

    Описание

    Формирование дерева групп для магазина.

    Принимаемые параметры

    $shop_parent_group_id

    идентификатор группы, относительно которой строится дерево групп.

    $shop_id

    идентификатор магазина, для которого строится дерево групп.

    $separator

    символ, отделяющий группу нижнего уровня от родительской группы.

    $shop_groups_id

    идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы.

    $param

    дополнительные параметры
    • $param['sum_separator'] - служебный элемент

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_id = 1;
        5.

      5.  $shop_parent_group_id = 586;
        6.

      6.
        7.

      7.  $row = $shop->GetDelimitedGroups($shop_parent_group_id, $shop_id , $separator='');
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r ($row);
        11.

      11.  ?>
        12.

    Возвращает

    двумерный массив, содержащий дерево подгрупп.

    [ Наверх ]

    shop::GetDelimitedGroupsDirExtProperty

GetDelimitedGroupsDirExtProperty(
int
$shop_properties_groups_dir_parent_id, int
$shop_shops_id, [int
$separator = ''], [int
$shop_properties_groups_dir_id = false] );

    Описание

    Метод формирования дерева групп дополнительных свойств групп товаров для магазина.

    Принимаемые параметры

    $shop_properties_groups_dir_parent_id

    Идентификатор директории с которой начинать построение дерева

    $shop_shops_id

    Идентификатор магазина

    $separator

    Разделитель между двумя разными уровнями вложения

    $shop_properties_groups_dir_id

    Идентификатор группы дополнительных свойств групп товаров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_groups_dir_parent_id = 9;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetDelimitedGroupsDirExtProperty($shop_properties_groups_dir_parent_id,$shop_shops_id , $separator='');
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    двумерный массив, содержащий дерево подгрупп.

    [ Наверх ]

    shop::GetDelimitedGroupsExtProperty

GetDelimitedGroupsExtProperty(

$shop_properties_items_dir_parent_id,
$shop_shops_id, [string
$separator = ''], [
$shop_properties_items_dir_id = false], int
$shop_parent_group_id, int
$shop_id, int
$shop_groups_id );

    Описание

    Метод формирования дерева групп для магазина.

    Принимаемые параметры

    $shop_parent_group_id

    идентификатор группы, относительно которой строится дерево групп.

    $shop_id

    идентификатор магазина, для которого строится дерево групп.

    $separator

    символ, отделяющий группу нижнего уровня от родительской группы.

    $shop_groups_id

    идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_items_dir_parent_id = 0;
      5.

    5.  $shop_shops_id = 1;
      6.

    6.  $separator = '';
      7.

    7.
      8.

    8.  $row = $shop->GetDelimitedGroupsExtProperty($shop_properties_items_dir_parent_id, $shop_shops_id , $separator='');
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r($row);
      12.

    12.  ?>
      13.

    $shop_properties_items_dir_parent_id

    $shop_shops_id

    $shop_properties_items_dir_id

    Возвращает

    двумерный массив, содержащий дерево подгрупп.

    [ Наверх ]

    shop::GetDiscount

GetDiscount(
int
$shop_discount_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение информации о скидке

    Принимаемые параметры

    $shop_discount_id

    идентификационный номер скидки

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_discount_id = 2;
        5.

      5.
        6.

      6.  $row = $shop->GetDiscount($shop_discount_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки скидки

    [ Наверх ]

    shop::GetEItem

GetEItem(
int
$shop_eitem_id );

    Описание

    Метод, осуществляющий извлечение информации об электронном товаре

    Принимаемые параметры

    $shop_eitem_id

    идентификационный номер товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_eitem_id = 7;
      5.

    5.
      6.

    6.  $row = $shop->GetEItem($shop_eitem_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвраает результат выборки товара

    [ Наверх ]

    shop::GetEitemCount

GetEitemCount(
int
$shop_items_catalog_item_id );

    Описание

    Получение количества оставшегося электронного товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор электронного товара

    Возвращает

    количество

    [ Наверх ]

    shop::GetEitemsForItem

GetEitemsForItem(
int
$shop_item_id );

    Описание

    Метод получения данных об электронных товарах конкретного товара

    Принимаемые параметры

    $shop_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_item_id = 159;
      5.

    5.
      6.

    6.  $resource = $shop->GetEitemsForItem($shop_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    shop::GetGroup

GetGroup(
int
$shop_groups_id, [array
$param = array ()] );

    Описание

    Получение информации о группе товаров

    Принимаемые параметры

    $shop_groups_id

    идентификационный номер группы

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_groups_id = 589;
        5.

      5.
        6.

      6.  $row = $shop->GetGroup($shop_groups_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки группы

    [ Наверх ]

    shop::GetGroupDir

GetGroupDir(
$shop_groups_id
$shop_groups_id );

    Описание

    Получение пути хранения файлов группы товаров

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы товаров

    Возвращает

    путь к папке группы товаров или ложь, если группы товаров не существует

    [ Наверх ]

    shop::GetGroupIdByCmlId

GetGroupIdByCmlId(

$shop_groups_cml_id,
$shop_shops_id, string
$cml_id );

    Описание

    Внутренний метод возвращает данные о группе товаров по идентификатору группы товаров стандарта CommerceML

    Принимаемые параметры

    $cml_id

    Идентификатор группы товаров при импорте из CommerceML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_groups_cml_id = 'ID00000034';
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetGroupIdByCmlId($shop_groups_cml_id, $shop_shops_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    $shop_groups_cml_id

    $shop_shops_id

    Возвращает

    результат выборки базы или false

    [ Наверх ]

    shop::GetGroups

GetGroups(
$shop_id
$shop_id, [$shop_groups_parent_id
$shop_groups_parent_id = false] );

    Описание

    Метод возвращает список групп магазина

    Принимаемые параметры

    $shop_id

    int идентификатор магазина

    $shop_groups_parent_id

    int идентификатор родительской группы, по умолчанию не задан.  При задании идентификатора родительской группы выбираются только непосредственные потомки указанного родителя.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetGroups($shop_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    shop::GetGroupsByPropertyValue

GetGroupsByPropertyValue(
int
$shop_properties_group_id, str
$value );

    Описание

    Получение информации обо всех группах, по значению доп. свойства

    Принимаемые параметры

    $shop_properties_group_id

    Идентификатор доп. свойства группы

    $value

    Значение доп. свойства группы

    [ Наверх ]

    shop::GetGroupsTree

GetGroupsTree(
int
$shop_current_group_id, int
$shop_id, [array
$mass = array ()] );

    Описание

    Получение массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской

    Принимаемые параметры

    $shop_current_group_id

    идентификатор родительской группы

    $shop_id

    идентификатор магазина

    $mass

    массив идентификаторов подгрупп, служебное поле. Не передается, по умолчанию array()
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $shop_current_group_id = 586;
      6.

    6.
      7.

    7.  $row = $shop->GetGroupsTree($shop_current_group_id, $shop_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив идетификаторов подгрупп

    [ Наверх ]

    shop::GetGroupsXmlTree

GetGroupsXmlTree(
int
$shop_id, array
$param );

    Описание

    Служебный метод построения дерева xml для групп.

    Перед вызовом необходимо заполнить кэши методом FillMasGroup

    Принимаемые параметры

    $shop_id

    $param

    - int $param['parent_group_id'] идентификатор родительской группы
    • $param['xml_show_group_property'] разрешает указание в XML значений свойств групп магазина, по умолчанию true
    • $param['xml_show_group_id'] массив идентификаторов групп для отображения в XML. Если не не передано - выводятся все группы
    • $param['xml_show_items_property_dir'] разрешает генерацию в XML групп свойств товаров, по умолчанию true
    • $param['xml_show_group_type'] тип генерации XML для групп, может принимать значения (по умолчанию 'tree'):

      • all - все группы всех уровней;
      • current - группы только текущего уровня;
      • tree - группы, находящиеся выше по дереву;
      • none - не выбирать группы.

    [ Наверх ]

    shop::GetGroupWithPath

GetGroupWithPath(
string
$group_path, int
$group_parent_id, int
$shop_shops_id );

    Описание

    Получение информации о группе по пути, если такая существует в данной подгруппе магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $group_parent_id

    идентификатор родительской группы

    $group_path

    путь к группе
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $group_path = 'group';
      5.

    5.  $group_parent_id = 586;
      6.

    6.  $shop_shops_id = 1;
      7.

    7.
      8.

    8.  $row = $shop->GetGroupWithPath($group_path, $group_parent_id, $shop_shops_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r($row);
      12.

    12.  ?>
      13.

    Возвращает

    информация о группе с таким путем в данной подгруппе для магазина, ложь, если такой группы нет

    [ Наверх ]

    shop::GetGroupWithValue

GetGroupWithValue(
string
$groups_name, int
$groups_parent_id, int
$shop_shops_id, [array
$param = array ()] );

    Описание

    Получение информации о группе по наименованию, если такая существует в данной подгруппе магазина

    Принимаемые параметры

    $groups_name

    наименование группы

    $groups_parent_id

    идентификатор родительской группы

    $shop_shops_id

    идентификатор магазина

    $param

    список доп. параметров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $groups_name = 'group';
      5.

    5.  $groups_parent_id = 586;
      6.

    6.  $shop_shops_id = 1;
      7.

    7.
      8.

    8.  $row = $shop->GetGroupWithValue($groups_name, $groups_parent_id, $shop_shops_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r($row);
      12.

    12.  ?>
      13.

    Возвращает

    информация о группе, ложь - если не существует группы с таким наименованием

    [ Наверх ]

    shop::GetItem

GetItem(
int
$shop_items_catalog_item_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение информации о товаре

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификационный номер товара

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_items_catalog_item_id = 158;
        5.

      5.
        6.

      6.  $row = $shop->GetItem($shop_items_catalog_item_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвраает результат выборки товара

    [ Наверх ]

    shop::GetItemByParam

GetItemByParam(
$param
$param );

    Описание

    Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента

    Принимаемые параметры

    $param

    массив с параметрами для условий
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_items_catalog_item_id'] = 158;
      5.

    5.
      6.

    6.  $resource = $shop->GetItemByParam($param);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    ресурс или false

    [ Наверх ]

    shop::GetItemDir

GetItemDir(
$shop_items_catalog_item_id
$shop_items_catalog_item_id, [$shop_item_row
$shop_item_row = false] );

    Описание

    Получение пути хранения файлов товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор информационного элемента

    $shop_item_row

    массив с данными о товаре

    Возвращает

    путь к папке товара или ложь, если товара не существует

    [ Наверх ]

    shop::GetItemDiscount

GetItemDiscount(
int
$shop_item_discount_id, [array
$param = array ()] );

    Описание

    Получение информации о скидке на товар

    Принимаемые параметры

    $shop_item_discount_id

    идентификатор извлекаемой записи

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_item_discount_id = 17;
        5.

      5.
        6.

      6.  $row = $shop->GetItemDiscount($shop_item_discount_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает информацию о скидке на товар, если записи с таким идентификатором нет, то false

    [ Наверх ]

    shop::GetItemFromCart

GetItemFromCart(
int
$shop_id, int
$site_users_id, int
$item_id );

    Описание

    Получение информации о товаре из корзины для пользователя

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя

    $item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $site_users_id = 19;
      6.

    6.  $item_id = 24;
      7.

    7.
      8.

    8.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      9.

    9.  if (class_exists('SiteUsers'))
      10.

    10.  {
      11.

    11.      $SiteUsers = & singleton('SiteUsers');
      12.

    12.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.      $site_users_id = 0;
      17.

    17.  }
      18.

    18.
      19.

    19.  $row = $shop->GetItemFromCart($shop_id, $site_users_id, $item_id);
      20.

    20.
      21.

    21.  // Распечатаем результат
      22.

    22.  print_r ($row);
      23.

    23.  ?>
      24.

    Возвращает

    or false

    [ Наверх ]

    shop::GetItemPath

GetItemPath(
int
$shop_id, [array
$param1 = ''], [bool
$break_if_path_not_found = true], [array
$param = array()] );

    Описание

    Метод определения идентификатора группы товаров и идентификатора товара по значению URL

    Принимаемые параметры

    $shop_id

    - идентификатор магазина, к которому принадлежит данный товар

    $param1

    - массив, содержащий все элементы URL

    $break_if_path_not_found

    прерывает поиск пути, если очередной элемент не был найден, по умолчанию true

    $param

    массив дополнительных параметров
    • array $param['shop_items_groups_activity'] массив параметров активности группы товаров, по умолчанию только активные
    • array $param['shop_items_activity'] массив параметров активности товара, по умолчанию только активные

    Возвращает

    or boolean - возвращает ассоциативный массив, содержащий идентификатор группы товаров и идентификатор товара

    [ Наверх ]

    shop::GetItemPropertyIdByCmlId

GetItemPropertyIdByCmlId(
string
$item_property_cml_id,
$shop_shops_id );

    Описание

    Метод возвращает данные о дополнительном свойстве товара по идентификатору дополнительного свойства формата CommerceML

    Принимаемые параметры

    $item_property_cml_id

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $item_property_cml_id = 'ID00000555';
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetItemPropertyIdByCmlId($item_property_cml_id, $shop_shops_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    $shop_shops_id

    Возвращает

    результат выборки базы или false

    [ Наверх ]

    shop::GetItemPropertyValueById

GetItemPropertyValueById(
int
$shop_properties_items_id );

    Описание

    Метод получения информации о значении дополнительного свойства товара по идентификатору значения

    Принимаемые параметры

    $shop_properties_items_id

    идентификатор значения дополнительного свойства
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_items_id = 40;
      5.

    5.
      6.

    6.  $row = $shop->GetItemPropertyValueById($shop_properties_items_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с информацией о значении дополнительного свойства в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    shop::GetItemsFromCart

GetItemsFromCart(
int
$site_users_id, int
$shop_id, [bool
$always_use_cookies_cart = true] );

    Описание

    Получение товаров, находящихся в корзине

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $shop_id

    идентификатор магазина

    $always_use_cookies_cart

    использовать корзину кукисов, если $site_users_id = false
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $site_users_id = '';
      5.

    5.  $shop_id = 1;
      6.

    6.
      7.

    7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      8.

    8.  if (class_exists('SiteUsers'))
      9.

    9.  {
      10.

    10.      $SiteUsers = & singleton('SiteUsers');
      11.

    11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      $site_users_id = 0;
      16.

    16.  }
      17.

    17.
      18.

    18.  $a_row = $shop->GetItemsFromCart($site_users_id, $shop_id);
      19.

    19.
      20.

    20.  // Распечатаем результат
      21.

    21.  print_r ($a_row);
      22.

    22.  ?>
      23.

    Возвращает

    массив товаров и их свойств

    [ Наверх ]

    shop::GetItemsFromCookiesToCart

GetItemsFromCookiesToCart(
int
$site_users_id );

    Описание

    Устаревший метод. См. TransferFromCartIntoTable()

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    see

    shop::TransferFromCartIntoTable()

    [ Наверх ]

    shop::GetItemsXmlTree

GetItemsXmlTree(
int
$shop_id, [mixed
$group_id = false], [array
$param = array ()] );

    Описание

    Метод построения XML для товаров

    Принимаемые параметры

    $shop_id

    идентификатор Internet-магазина

    $group_id

    идентификатор раздела каталога, если $group_id=false, то генерируем XML для товаров из всех разделов

    $param

    массив дополнительных параметров
    • $param['items_begin'] номер товара в выборке, с которого начинать отображение товаров магазина
    • $param['items_on_page'] число товаров, отображаемых на странице
    • $param['items_field_order'] поле сортировки
    • $param['items_order'] направление сортировки ('Asc' - по возрастанию, 'Desc' - по убываниюб , 'Rand' - произвольный порядок)
    • $param['show_catalog_item_type'] array массив типов товаров, которые должны отображаться.
     Может содержать следующие элементы:
    active - активные элементы (внесен по умолчанию, если $param['show_catalog_item_type'] не задан;
    inactive - неактивные элементы;
    putend_date - элементы, у которых значение поля putend_date меньше текущей даты;
    putoff_date - элементы, у которых значение поля putoff_date превышает текущую дату;
    • $param['cache_off'] - Флаг, разрешающий кеширование данных (по умолчанию true)

    Возвращает

    XML с данными о товарах

    [ Наверх ]

    shop::GetItemXml

GetItemXml(
int
$item_id, [int
$site_users_id = 0] );

    Описание

    Метод формирования xml товара

    Принимаемые параметры

    $item_id

    идентификатор товара

    $site_users_id

    идентификатор пользователя
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $item_id = 158;
      5.

    5.
      6.

    6.  $xmlData = $shop->GetItemXml($item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    xml для товара (информация о товаре + дополнительные свойства + сопуствующие товары и т.д.), ложь - если запись не выбрана

    [ Наверх ]

    shop::GetLocation

GetLocation(
int
$shop_location_id );

    Описание

    Метод, осуществляющий извлечение области

    Принимаемые параметры

    $shop_location_id

    идентификационный номер области
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_location_id = 923;
      5.

    5.
      6.

    6.  $row = $shop->GetLocation($shop_location_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки области

    [ Наверх ]

    shop::GetLocationByName

GetLocationByName(

$shop_location_name );

    Принимаемые параметры

    $shop_location_name

    [ Наверх ]

    shop::GetMasGroupToRoot

GetMasGroupToRoot(
 );

    Описание

    Возвращает $this->mas_groups_to_root

    [ Наверх ]

    shop::GetMd5CacheCountItemsAndGroup

GetMd5CacheCountItemsAndGroup(
$param
$param );

    Описание

    Получение хэша для кэширвоания количества товаров и групп

    Принимаемые параметры

    $param

    массив параметров

    Возвращает

    md5

    [ Наверх ]

    shop::GetMesure

GetMesure(
int
$shop_mesures_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение информации о единице измерения

    Принимаемые параметры

    $shop_mesures_id

    идентификационный номер единицы измерения

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_mesures_id = 1;
        5.

      5.
        6.

      6.  $row = $shop->GetMesure($shop_mesures_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки единицы измерения

    [ Наверх ]

    shop::GetMesuresByLike

GetMesuresByLike(
string
$string );

    Описание

    Метод, возвращающий информацию о мере измерения из базы согласно имени $string используя оператор LIKE

    Принимаемые параметры

    $string

    Строка с именем меры измерения
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $string = 'м';
      5.

    5.
      6.

    6.  $row = $shop->GetMesuresByLike($string);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    строка с данными о мере измерения или false

    [ Наверх ]

    shop::GetOrder

GetOrder(
int
$shop_order_id );

    Описание

    Извлечение заказа по его ID

    Принимаемые параметры

    $shop_order_id

    идентификационный номер заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 46;
      5.

    5.
      6.

    6.  $row = $shop->GetOrder($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки заказа

    [ Наверх ]

    shop::GetOrderByGuid

GetOrderByGuid(
int
$shop_order_guid );

    Описание

    Извлечение заказа по его GUID

    Принимаемые параметры

    $shop_order_guid

    идентификационный номер заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_guid = '22345200-abe8-4f60-90c8-0d43c5f6c0f6';
      5.

    5.
      6.

    6.  $row = $shop->GetOrderByGuid($shop_order_guid);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки заказа

    [ Наверх ]

    shop::GetOrderDiscount

GetOrderDiscount(
int
$shop_order_discount_id, [array
$param = array ()] );

    Описание

    Метод возвращает информацию о скидке для заказов

    Принимаемые параметры

    $shop_order_discount_id

    идентификатор скидки для заказов

    $param

    ассоциативный массив параметрв
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_order_discount_id = 1;
        5.

      5.
        6.

      6.  $row = $shop->GetOrderDiscount($shop_order_discount_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с результатом выборки или false

    [ Наверх ]

    shop::GetOrderDiscountForSum

GetOrderDiscountForSum(
int
$shop_shops_id, float
$sum, [string
$shop_coupon_text = ''] );

    Описание

    Устаревший метод. Заменен на GetOrderDiscountForSumAndCount()  Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $sum

    сумма заказа

    $shop_coupon_text

    текст купона, если таковой есть
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $sum = 1500;
      6.

    6.
      7.

    7.  $discount = $shop->GetOrderDiscountForSum($shop_shops_id, $sum);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $discount;
      11.

    11.  ?>
      12.

    Возвращает

    величина скидки, -1 в случае ошибки

    [ Наверх ]

    shop::GetOrderDiscountForSumAndCount

GetOrderDiscountForSumAndCount(
int
$shop_shops_id, float
$sum, int
$count, [string
$shop_coupon_text = ''] );

    Описание

    Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных для указанного магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $sum

    сумма заказа

    $count

    количество товаров в заказе

    $shop_coupon_text

    текст купона, если таковой есть
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $sum = 1500;
      6.

    6.
      7.

    7.  $discount = $shop->GetOrderDiscountForSumAndCount($shop_shops_id, $sum);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $discount;
      11.

    11.  ?>
      12.

    Возвращает

    величина скидки, -1 в случае ошибки

    [ Наверх ]

    shop::GetOrderDiscountWithConditions

GetOrderDiscountWithConditions(
array
$param );

    Описание

    Метод возвращает список скидок на сумму заказа по заданным условиям

    Принимаемые параметры

    $param

    массив с дополнительными параметрами
    • int $param['shop_shops_id'] идентификатор магазина
    • int $param['shop_order_discount_active'] активность неактивность скидки
    • int $param['date'] дата, должна быть в интервале действия скидки
    • int $param['shop_order_discount_is_coupon'] скидка для купона

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['shop_order_discount_active'] = 1;
        6.

      6.  $param['date'] = date('Y-m-d H:i:s');
        7.

      7.
        8.

      8.  $resource = $shop->GetOrderDiscountWithConditions($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  while($row = mysql_fetch_assoc($resource))
        12.

      12.  {
        13.

      13.      print_r($row);
        14.

      14.  }
        15.

      15.  ?>
        16.

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetOrderInfoArray

GetOrderInfoArray(
int
$shop_id, int
$site_users_id );

    Описание

    Метод формирования массива с информацией о заказе для вставки в заказы

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя сайта
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $site_users_id = 19;
      6.

    6.
      7.

    7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      8.

    8.  if (class_exists('SiteUsers'))
      9.

    9.  {
      10.

    10.      $SiteUsers = & singleton('SiteUsers');
      11.

    11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      $site_users_id = 0;
      16.

    16.  }
      17.

    17.
      18.

    18.  $row = $shop->GetOrderInfoArray($shop_id, $site_users_id);
      19.

    19.
      20.

    20.  // Распечатаем результат
      21.

    21.  print_r ($row);
      22.

    22.  ?>
      23.

    Возвращает

    массив с данными заказа, ложь - если магазина нет

    [ Наверх ]

    shop::GetOrderItem

GetOrderItem(
int
$shop_order_items_id );

    Описание

    Метод, осуществляющий извлечение товара из заказа

    Принимаемые параметры

    $shop_order_items_id

    идентификационный номер товара в заказе
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_items_id = 99;
      5.

    5.
      6.

    6.  $row = $shop->GetOrderItem($shop_order_items_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.
      11.

    11.  ?>
      12.

    Возвращает

    возвращает результат выборки товара в заказе

    [ Наверх ]

    shop::GetOrderItems

GetOrderItems(
int
$shop_order_id, [
$limit1 = false], [
$limit2 = false] );

    Описание

    Метод, осуществляющий извлечение товаров из заказа

    Принимаемые параметры

    $shop_order_id

    идентификационный номер заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 47;
      5.

    5.
      6.

    6.  $resource = $shop->GetOrderItems($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    $limit1

    $limit2

    Возвращает

    ресурс с элементами заказа

    [ Наверх ]

    shop::GetOrdersStatus

GetOrdersStatus(
int
$shop_order_status_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение состояния заказа

    Принимаемые параметры

    $shop_order_status_id

    идентификационный номер состояния заказа

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_order_status_id = 1;
        5.

      5.
        6.

      6.  $row = $shop->GetOrdersStatus($shop_order_status_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки статуса заказа

    [ Наверх ]

    shop::GetOrderSum

GetOrderSum(
int
$shop_order_id );

    Описание

    Расчет суммы заказа

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 46;
      5.

    5.
      6.

    6.  $sum = $shop->GetOrderSum($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $sum;
      10.

    10.  ?>
      11.

    Возвращает

    сумма заказа

    [ Наверх ]

    shop::GetOrderXml

GetOrderXml(
array
$param, array
$param_item, [string
$xsl_name = ''] );

    Описание

    Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных

    Принимаемые параметры

    $param

    массив с данными о заказе

    $param_item

    массив с данными о заказанных товарах

    $xsl_name

    наименование xsl шаблона (не обязательный параметр, если не указан метод возврщает xml)

    Возвращает

    дерево xml с данными о заказе

    [ Наверх ]

    shop::GetPathGroup

GetPathGroup(
int
$shop_groups_id, [string
$path = ''], [
$level = 0], [
$param = array()] );

    Описание

    Метод формирования пути по группам товара

    Принимаемые параметры

    $shop_groups_id

    - идентификатор группы, для которой надо сформировать путь

    $path

    - параметр, используемый при формировании пути по группам
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_groups_id = 586;
      5.

    5.
      6.

    6.  $path = $shop->GetPathGroup($shop_groups_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $path;
      10.

    10.  ?>
      11.

    $level

    $param

    Возвращает

    - путь по группам от корневой до данной

    [ Наверх ]

    shop::GetPathItem

GetPathItem(
int
$shop_items_catalog_item_id, [
$param = array()] );

    Описание

    Метод формирования пути к товару

    Принимаемые параметры

    $shop_items_catalog_item_id

    - идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 123;
      5.

    5.
      6.

    6.  $path = $shop->GetPathItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $path;
      10.

    10.  ?>
      11.

    $param

    Возвращает

    - путь по группам от корневой до данной

    [ Наверх ]

    shop::GetPathProducer

GetPathProducer(
string
$path, [int
$shop_id = false] );

    Описание

    Метод формирования пути по производителю

    Принимаемые параметры

    $path

    путь производителя

    $shop_id

    идентификатор магазина, необязательное поле

    Возвращает

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $path = 'hostcms';
      5.

    5.
      6.

    6.  $result = $shop->GetPathProducer($path);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($result);
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::GetPrice

GetPrice(
int
$shop_list_of_prices_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение типа цены

    Принимаемые параметры

    $shop_list_of_prices_id

    идентификационный номер типа цены

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_list_of_prices_id = 8;
        5.

      5.
        6.

      6.  $row = $shop->GetPrice($shop_list_of_prices_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки типа цены

    [ Наверх ]

    shop::GetPriceByCmlId

GetPriceByCmlId(
string
$shop_list_of_prices_cml_id,
$shop_shops_id );

    Описание

    Метод возвращает данные о цене по идентификатору цены формата CommerceML

    Принимаемые параметры

    $shop_list_of_prices_cml_id

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_list_of_prices_cml_id = 'ID00000555';
      5.

    5.  $shop_shops_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetPriceByCmlId($shop_list_of_prices_cml_id, $shop_shops_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    $shop_shops_id

    Возвращает

    результат выборки базы или false

    [ Наверх ]

    shop::GetPriceForCondOfDelivery

GetPriceForCondOfDelivery(
int
$shop_cond_of_delivery_id );

    Описание

    Получение цены доставки с учетом указанного налога

    Принимаемые параметры

    $shop_cond_of_delivery_id

    идентификатор условия доставки

    Возвращает

    возвращает массив значений цен для данного пользователя
    • $price['price'] цена с учетом валюты
    • $price['price_tax'] цена с учетом налога

    [ Наверх ]

    shop::GetPriceForItem

GetPriceForItem(
int
$shop_list_of_prices_id, int
$shop_items_catalog_item_id, [array
$param = array()] );

    Описание

    Метод определения наличия указанной цены для заданного товара

    Принимаемые параметры

    $shop_list_of_prices_id

    идентификатор цены

    $shop_items_catalog_item_id

    идентификатор товара

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_list_of_prices_id = 8;
        5.

      5.  $shop_items_catalog_item_id = 159;
        6.

      6.
        7.

      7.  $row = $shop->GetPriceForItem($shop_list_of_prices_id, $shop_items_catalog_item_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r ($row);
        11.

      11.  ?>
        12.

    Возвращает

    or false результат выборки

    [ Наверх ]

    shop::GetPriceForUser

GetPriceForUser(
int
$site_users_id, int
$shop_items_catalog_item_id, [int
$item_row = array ()], [array
$param = array ()] );

    Описание

    Метод определения цены товара для заданного пользователя

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $shop_items_catalog_item_id

    идентификатор товара

    $item_row

    строка даных о товаре, необязательное поле

    $param

    массив дополнительных параметров
    • $param['item_count'] количество товара, для которого необходимо расчитать цену, используется при определении цены для специальных цен в зависимости от партии
    • $param['shop_special_prices_id'] идентификатор специальной цены, которую необходимо применить при расчете

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $site_users_id = 19;
        5.

      5.  $shop_items_catalog_item_id = 159;
        6.

      6.
        7.

      7.  $row = $shop->GetPriceForUser($site_users_id, $shop_items_catalog_item_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r ($row);
        11.

      11.  ?>
        12.

    Возвращает

    возвращает массив значений цен для данного пользователя
    • $price['tax'] сумма налога
    • $price['price'] цена с учетом валюты без налога
    • $price['price_tax'] цена с учетом налога
    • $price['price_discount'] цена с учетом налога и со скидкой

    [ Наверх ]

    shop::GetProducer

GetProducer(
int
$shop_producers_list_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение информации о производителе

    Принимаемые параметры

    $shop_producers_list_id

    идентификационный номер производителя

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_producers_list_id = 2;
        5.

      5.
        6.

      6.  $row = $shop->GetProducer($shop_producers_list_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки производителя

    [ Наверх ]

    shop::GetProducerByName

GetProducerByName(
string
$shop_producers_list_name, [int
$shop_id = false] );

    Описание

    Метод для получения списка производителей по названию

    Принимаемые параметры

    $shop_producers_list_name

    название производителя

    $shop_id

    идентификатор магазина, необязательное поле
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_producers_list_name = 'HostCMS';
      5.

    5.
      6.

    6.  $row = $shop->GetProducerByName($shop_producers_list_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с выбранными производителями или false

    [ Наверх ]

    shop::GetPropertiesGroupsDir

GetPropertiesGroupsDir(
int
$shop_properties_groups_dir_id );

    Описание

    Получение информации о группе дополнительных свойств групп товаров

    Принимаемые параметры

    $shop_properties_groups_dir_id

    Идентификатор группы дополнительных свойств групп товаров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_groups_dir_id = 7;
      5.

    5.
      6.

    6.  $row = $shop->GetPropertiesGroupsDir($shop_properties_groups_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    Массив данных, либо False

    [ Наверх ]

    shop::GetPropertiesGroupValue

GetPropertiesGroupValue(
array
$param );

    Описание

    Получение данных о значении дополнительного свойства групп товаров

    Принимаемые параметры

    $param

    массив параметров
    • int $param['shop_groups_id'] Идентификатор группы товаров
    • int $param['shop_properties_group_id'] Идентификатор дополнительного свойства

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_groups_id'] = 586;
        5.

      5.  $param['shop_properties_group_id'] = 12;
        6.

      6.
        7.

      7.  $row = $shop->GetPropertiesGroupValue($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r($row);
        11.

      11.  ?>
        12.

    Возвращает

    Массив с данными, или false

    [ Наверх ]

    shop::GetPropertiesItemForGroups

GetPropertiesItemForGroups(
int
$shop_properties_item_for_groups_id );

    Описание

    Получение информации о принадлежности дополнительного свойства группе товаров

    Принимаемые параметры

    $shop_properties_item_for_groups_id

    Идентификатор принадлежности дополнительного свойства группе товаров

    Возвращает

    массив данных, либо False
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_item_for_groups_id = 2;
      5.

    5.
      6.

    6.  $row = $shop->GetPropertiesItemForGroups($shop_properties_item_for_groups_id);
      7.

    7.  // Распечатаем результат
      8.

    8.  print_r ($row);
      9.

    9.  ?>
      10.

    [ Наверх ]

    shop::GetPropertiesItemsDir

GetPropertiesItemsDir(
int
$shop_properties_items_dir_id );

    Описание

    Получение данных о группе дополнительных свойств товара

    Принимаемые параметры

    $shop_properties_items_dir_id

    Идентификатор группы дополнительных свойств товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_items_dir_id = 3;
      5.

    5.
      6.

    6.  $row = $shop->GetPropertiesItemsDir($shop_properties_items_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    Массив данных, либо False

    [ Наверх ]

    shop::GetPropertiesOfGroup

GetPropertiesOfGroup(
int
$shop_groups_id, [int
$shop_items_catalog_item_id = false], [int
$shop_shops_id = false] );

    Описание

    Метод для получения списка идентификаторов свойств товаров для определенной группы.

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы

    $shop_items_catalog_item_id

    идентификатор товара, необязательное поле, по умолчанию false

    $shop_shops_id

    идентификатор магазина, необязательное поле, по умолчанию false
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_groups_id = 586;
      5.

    5.
      6.

    6.  $row = $shop->GetPropertiesOfGroup($shop_groups_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив со списком

    [ Наверх ]

    shop::GetPropertiesOfGroupForXml

GetPropertiesOfGroupForXml(

$shop_shops_id, [int
$shop_groups_id = 0], [
$param = array()] );

    Описание

    Возвращает список свойств, доступных для вывода в группе

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы, если 0, то возвращает свойства, разрешенные для корневой группы

    $shop_shops_id

    $param

    Возвращает

    resource или fasle

    [ Наверх ]

    shop::GetPropertysGroup

GetPropertysGroup(
int
$shop_groups_id, int
$shop_shops_id );

    Описание

    Получение данных о дополнительных свойствах группы магазина.

    Рекомендуется использоваться совместно с FillMemCachePropertysGroup() при выборе свойств всех групп магазина.

    Принимаемые параметры

    $shop_groups_id

    идентификатор группы

    $shop_shops_id

    идентификатор магазина

    Возвращает

    массив с информацией о дополнительных свойствах

    [ Наверх ]

    shop::GetPropretyOfGroup

GetPropretyOfGroup(
int
$shop_properties_group_value_id );

    Описание

    Получение информации о дополнительном свойстве группы товаров

    Принимаемые параметры

    $shop_properties_group_value_id

    Идентификатор дополнительного свойства группы товаров
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_properties_group_value_id = 11;
      5.

    5.
      6.

    6.  $row = $shop->GetPropretyOfGroup($shop_properties_group_value_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    Массив с данными или false

    [ Наверх ]

    shop::GetPropretyOfItems

GetPropretyOfItems(
int
$shop_list_of_properties_id );

    Описание

    Метод, осуществляющий извлечение свойства товара по идентификатору свойства товара

    Принимаемые параметры

    $shop_list_of_properties_id

    идентификационный номер свойства товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_list_of_properties_id = 137;
      5.

    5.
      6.

    6.  $row = $shop->GetPropretyOfItems($shop_list_of_properties_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки свойства товара

    [ Наверх ]

    shop::GetRealPath

GetRealPath(
$images_path
$images_path );

    Описание

    Корректирует путь

    Принимаемые параметры

    $images_path

    путь к директории к файлу картинки (без CMS_FOLDER)

    [ Наверх ]

    shop::GetSeller

GetSeller(
int
$seller_id, [array
$param = array ()] );

    Описание

    Получение информации о продавце по его идентификатору.

    Принимаемые параметры

    $seller_id

    Идентификатор продавца

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $seller_id = 1;
        5.

      5.
        6.

      6.  $row = $shop->GetSeller($seller_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

    Возвращает

    ассоциативный массив с информацией о продавце

    [ Наверх ]

    shop::GetSellerByName

GetSellerByName(
string
$shop_saller_name, [int
$shop_id = false] );

    Описание

    Метод для получения списка продавцов по названию

    Принимаемые параметры

    $shop_saller_name

    название продавца

    $shop_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_saller_name = 'HostCMS';
      5.

    5.
      6.

    6.  $row = $shop->GetSellerByName($shop_saller_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с выбранными продавцами или false

    [ Наверх ]

    shop::GetSessionCart

GetSessionCart(
 );

    Описание

    Получить содержимое корзины в session

    see

    shop::GetCart()

    [ Наверх ]

    shop::GetShop

GetShop(
int
$shop_shops_id, [array
$param = array ()] );

    Описание

    Метод, осуществляющий извлечение информации о магазине

    Принимаемые параметры

    $shop_shops_id

    идентификационный номер магазине

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id = 1;
        5.

      5.
        6.

      6.  $row = $shop->GetShop($shop_shops_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    возвращает результат выборки магазина

    [ Наверх ]

    shop::GetShopByStructureId

GetShopByStructureId(
int
$structure_id );

    Описание

    Получение информации о магазине, связанном с узлом структуры

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    Возвращает

    идентификатор магазина или false

    [ Наверх ]

    shop::GetShopCurrency

GetShopCurrency(
int
$shop_shops_id );

    Описание

    Получение информации о валюте магазина

    Принимаемые параметры

    $shop_shops_id

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetShopCurrency($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    информация о валюте или ложь, если магазина не существует

    [ Наверх ]

    shop::GetShopDiscount

GetShopDiscount(
int
$shop_shops_id );

    Описание

    Получение списка скидок для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $resource = $shop->GetShopDiscount($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    ресурс в данными о скидке

    [ Наверх ]

    shop::GetShopGroupAccess

GetShopGroupAccess(
int
$shop_group_id, [int
$shop_id = 0], [array
$row_group = array()] );

    Описание

    Определение уровня доступности группы товаров

    Принимаемые параметры

    $shop_group_id

    идентификатор группы товаров

    $shop_id

    идентификатор интернет-магазина

    $row_group

    ассоциативный массив с информацией о группе, по умолчанию пустой

    Возвращает

    уровень (группа) доступа пользователя к группе товаров, 0 - доступ разрешен всем

    [ Наверх ]

    shop::GetShopGroupsToRoot

GetShopGroupsToRoot(
int
$group_id, [int
$shop_id = false] );

    Описание

    Получение массива с данными о каталогах магазина, начиная с данной и до корневой

    Принимаемые параметры

    $group_id

    идентификатор группы

    $shop_id

    идентификатор магазина,
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $group_id = 600;
      6.

    6.
      7.

    7.  $row = $shop->GetShopGroupsToRoot($group_id, $shop_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    ассоциативный массив с данными о каталогах магазина

    [ Наверх ]

    shop::GetShopItemAccess

GetShopItemAccess(
int
$shop_item_id );

    Описание

    Определение уровня доступности товара

    Принимаемые параметры

    $shop_item_id

    shop_item_id идентификатор товара

    Возвращает

    уровень (группа) доступа пользователя к товару, 0 - доступ разрешен всем

    [ Наверх ]

    shop::GetShopPathArray

GetShopPathArray(
integer
$dir_id, [boolean
$first_call = true] );

    Описание

    Получение пути от текущего каталога к корневому

    Принимаемые параметры

    $dir_id

    идентификатор текущего каталога

    $first_call

    первый ли это вызов функции
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $dir_id = 600;
      5.

    5.
      6.

    6.  $row = $shop->GetShopPathArray($dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив данных

    [ Наверх ]

    shop::GetShopsDir

GetShopsDir(

$shop_dir_id );

    Принимаемые параметры

    $shop_dir_id

    [ Наверх ]

    shop::GetShopsDirPathArray

GetShopsDirPathArray(
int
$shop_dir_id, [array
$return_path_array = array()] );

    Описание

    Построение массива пути от текущего раздела интернет-магазинов к корневому

    Принимаемые параметры

    $shop_dir_id

    идентификатор раздела магазинов, для которого необходимо построить путь

    $return_path_array

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_dir_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetShopsDirPathArray($shop_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив, элементы которого содержат информацию о разделах, составляющих путь от текущего раздела до корневого

    [ Наверх ]

    shop::GetShopsDirs

GetShopsDirs(
[array
$param = array()] );

    Описание

    Формирование дерева разделов интернет-магазинов

    Принимаемые параметры

    $param

    массив параметров
    • $param['shop_dir_parent_id'] идентификатор раздела, относительно которого строится дерево групп. По умолчанию равен 0.
    • $param['site_id'] идентификатор сайта, для которого строится дерево разделов. По умолчанию равен CURRENT_SITE
    • $param['separator'] символ, отделяющий раздел нижнего уровня от родительского раздела
    • $param['shop_dir_id'] идентификатор раздела, который вместе с его подразделами не нужно включать в дерево разделов, если равен false или не передан, то включать в дерево разделов все разделы.
    • $param['array'] - служебный параметр
    • $param['sum_separator'] - служебный параметр

    Возвращает

    двумерный массив, содержащий дерево подгрупп

    [ Наверх ]

    shop::GetShopWhithStructureId

GetShopWhithStructureId(
int
$structure_id, [int
$site_id = 0], [int
$shop_shops_id = 0] );

    Описание

    Метод выбора информации о магазине данного узла структуры сайта

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    $site_id

    идентификатор сайта

    $shop_shops_id

    идентификатор магазина, который не включать в условие (по умолчанию 0 - не ограничиваем по id магазина)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $structure_id = 42;
      5.

    5.  $site_id = 1;
      6.

    6.
      7.

    7.  $row = $shop->GetShopWhithStructureId($structure_id, $site_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    информация о магазине или ложь, если нет магазина с таким узлом структуры для сайта

    [ Наверх ]

    shop::GetSiteUserAccountSum

GetSiteUserAccountSum(
int
$site_users_id,
$shop_shops_id );

    Описание

    Метод возвращает сумму пользователя сайта в базовой валюте

    Принимаемые параметры

    $site_users_id

    Идентификатор пользователя сайта
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $site_users_id = '';
      5.

    5.  $shop_shops_id = 1;
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      $site_users_id = 0;
      15.

    15.  }
      16.

    16.  $sum = $shop->GetSiteUserAccountSum($site_users_id, $shop_shops_id);
      17.

    17.
      18.

    18.  // Распечатаем результат
      19.

    19.  echo $sum;
      20.

    20.  ?>
      21.

    $shop_shops_id

    Возвращает

    Сумма

    [ Наверх ]

    shop::GetSiteUserAccountTransaction

GetSiteUserAccountTransaction(
int
$shop_site_users_account_id );

    Описание

    Получение информации о транзакции

    Принимаемые параметры

    $shop_site_users_account_id

    Идентификатор транзакции
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_site_users_account_id = 20;
      5.

    5.
      6.

    6.  $row = $shop->GetSiteUserAccountTransaction($shop_site_users_account_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    Массив с данными, либо false

    [ Наверх ]

    shop::GetSiteUsersGroupsForUser

GetSiteUsersGroupsForUser(
int
$site_user_id );

    Описание

    Получение списка групп пользователий, в которых содержится пользователь сайта

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя сайтов
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $site_user_id = 1;
      5.

    5.
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     $site_users_id = 0;
      15.

    15.  }
      16.

    16.
      17.

    17.  $row = $shop->GetSiteUsersGroupsForUser($site_user_id);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  print_r ($row);
      21.

    21.  ?>
      22.

    Возвращает

    массив групп пользователей

    [ Наверх ]

    shop::GetSpecialPrice

GetSpecialPrice(
int
$shop_special_prices_id );

    Описание

    Получение информации о специальной цене

    Принимаемые параметры

    $shop_special_prices_id

    идентификатор специальной цены

    Возвращает

    массив данных, либо False
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_special_prices_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->GetSpecialPrice($shop_special_prices_id);
      7.

    7.  // Распечатаем результат
      8.

    8.  print_r ($row);
      9.

    9.  ?>
      10.

    [ Наверх ]

    shop::GetSpecialPriceForItem

GetSpecialPriceForItem(
int
$shop_items_catalog_item_id, int
$item_count );

    Описание

    Получение информации о специальной цене (в зависимости от количества этого товара в корзине),  подходящей для товара.

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $item_count

    количество купленного товара

    Возвращает

    массив либо False
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 1;
      5.

    5.  $item_count = 10;
      6.

    6.
      7.

    7.  $price_row = $shop->GetSpecialPriceForItem($shop_items_catalog_item_id, $item_count);
      8.

    8.
      9.

    9.  if ($price_row)
      10.

    10.  {
      11.

    11.      print_r($price_row);
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Специальной цены нет";
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    shop::GetSpecialPricesForItem

GetSpecialPricesForItem(
int
$shop_items_catalog_item_id );

    Описание

    Получение информации в виде массива о всех специальных ценах товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    Возвращает

    Array или False
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 159;
      5.

    5.
      6.

    6.  $array = $shop->GetSpecialPricesForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  if($array)
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    shop::GetSpecialPriceValueForItem

GetSpecialPriceValueForItem(
int
$shop_items_catalog_item_id, int
$item_count );

    Описание

    Получение специальной цены (в зависимости от количества этого товара в корзине),  подходящей для товара.

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $item_count

    количество купленного товара

    Возвращает

    Цена для товара, либо False

    see

    GetSpecialPriceForItem()
 <code>
 <?php
 $shop = new shop();

 $shop_items_catalog_item_id = 1;
 $item_count = 10;

 $price = $shop->GetSpecialPriceValueForItem($shop_items_catalog_item_id, $item_count);

 if ($price)
 {
     echo $price;
 }
 else
 {
     echo "Специальной цены нет";
 }
 ?>
 </code>

    [ Наверх ]

    shop::GetSystemOfPay

GetSystemOfPay(
int
$shop_system_of_pay_id );

    Описание

    Метод, осуществляющий извлечение платёжной системы

    Принимаемые параметры

    $shop_system_of_pay_id

    идентификационный номер платёжной системы
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_system_of_pay_id = 4;
      5.

    5.
      6.

    6.  $row = $shop->GetSystemOfPay($shop_system_of_pay_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки платёжной системы или ложь, если запись не выбрана

    [ Наверх ]

    shop::GetTax

GetTax(
int
$shop_tax_id );

    Описание

    Метод, осуществляющий извлечение налога

    Принимаемые параметры

    $shop_tax_id

    идентификационный номер налога
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_tax_id = 2;
      5.

    5.
      6.

    6.  $row = $shop->GetTax($shop_tax_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки налога

    [ Наверх ]

    shop::GetTaxIdByCmlId

GetTaxIdByCmlId(

$shop_tax_cml_id, [
$shop_tax_rate = false], string
$cml_id );

    Описание

    Внутренний метод возвращает данные о налоге по идентификатору налога формата CommerceML

    Принимаемые параметры

    $cml_id

    Идентификатор налога при импорте из CommerceML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_tax_cml_id = 'ID00000034';
      5.

    5.
      6.

    6.  $row = $shop->GetTaxIdByCmlId($shop_tax_cml_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    $shop_tax_cml_id

    $shop_tax_rate

    Возвращает

    результат выборки базы или false

    [ Наверх ]

    shop::GetTyingProducts

GetTyingProducts(
int
$shop_intermediate_id, [array
$param = array ()] );

    Описание

    Получение информации о сопутствующем товаре

    Принимаемые параметры

    $shop_intermediate_id

    идентификатор записи о сопутствующем товаре

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetTyingProductsForItem

GetTyingProductsForItem(
int
$shop_items_catalog_item_id );

    Описание

    Получение ID сопутствующих товаров для заданного товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 159;
      5.

    5.
      6.

    6.  $row = $shop->GetTyingProductsForItem($shop_items_catalog_item_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.
      11.

    11.  ?>
      12.

    Возвращает

    массив идентификаторов сопутствующих товаров

    [ Наверх ]

    shop::GetTypeOfDelivery

GetTypeOfDelivery(
int
$shop_type_of_delivery_id );

    Описание

    Метод, осуществляющий извлечение типа доставки

    Принимаемые параметры

    $shop_type_of_delivery_id

    идентификационный номер типа доставки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_type_of_delivery_id = 5;
      5.

    5.
      6.

    6.  $row = $shop->GetTypeOfDelivery($shop_type_of_delivery_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    возвращает результат выборки типа доставки

    [ Наверх ]

    shop::GetTypeOfDeliveryForOrder

GetTypeOfDeliveryForOrder(
int
$shop_type_of_delivery_id, int
$country, int
$location, int
$city, int
$city_area, float
$weight, float
$price );

    Описание

    Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.

    Принимаемые параметры

    $shop_type_of_delivery_id

    идентификатор типа доставки

    $country

    идентификатор страны доставки

    $location

    идентификатор области доставки

    $city

    идентификатор города доставки

    $city_area

    идентификатор района доставки

    $weight

    вес заказа

    $price

    цена заказа

    Возвращает

    результат выборки

    [ Наверх ]

    shop::GetValueItemProperty

GetValueItemProperty(
int
$shop_items_catalog_item_id, int
$shop_list_of_properties_id );

    Описание

    Получение значения дополнительного свойства для товара

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара

    $shop_list_of_properties_id

    идентификатор дополнительного свойства
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 158;
      5.

    5.  $shop_list_of_properties_id = 137;
      6.

    6.
      7.

    7.  $row = $shop->GetValueItemProperty($shop_items_catalog_item_id, $shop_list_of_properties_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    информация о дополнительном свойстве товара или ложь - если свойство для товара не задано

    [ Наверх ]

    shop::GetXml4Tags

GetXml4Tags(
int
$shop_shops_id, array
$property );

    Описание

    Генерация XML для облака тегов магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $property

    массив дополнительных атрибутов
    • $property['begin'] начальная позиция отображения тегов (по умолчанию 0)
    • $property['count'] количество отображаемых тегов
    • $property['TagsOrder'] параметр, определяющий порядок сортировки тегов. Принимаемые значения: ASC - по возрастанию (по умолчанию), DESC - по убыванию
    • $property['TagsOrderField'] поле сортировки тегов, если случайная сортировка, то записать RAND(). по умолчанию теги сортируются по названию.
    • $property['tags_group_id'] идентификатор или массив идентификаторов групп тегов, из которых необходимо вести отбор тегов
    • $property['shop_groups_id'] идентификатор группы магазина, для которой необходимо вести отбор тегов
    • $property['NotIn'] строка идентификаторов товаров, исключаемых из выборки тегов
    • $property['In'] массив идентификаторов товаров, только для которых выбирать теги

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $shop_shops_id = 1;
        5.

      5.  $property['count'] = 10;
        6.

      6.
        7.

      7.  $xmlData = $shop->GetXml4Tags($shop_shops_id, $property);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo htmlspecialchars($xmlData);
        11.

      11.  ?>
        12.

    [ Наверх ]

    shop::GetXmlForItemsOrder

GetXmlForItemsOrder(
int
$shop_order_id );

    Описание

    Метод формирования xml для товаров в заказе

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 46;
      5.

    5.
      6.

    6.  $xmlData = $shop->GetXmlForItemsOrder($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    xml для товаров в заказе, ложь, если нет ни одного товара

    [ Наверх ]

    shop::GetXmlForOrder

GetXmlForOrder(
int
$shop_order_id, [array
$order_row = false], [bool
$need_user_info = true] );

    Описание

    Метод формирования xml о заказе по идентификатору заказа

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа

    $order_row

    массив с данными о заказе или false

    $need_user_info

    определяет, нужно ли добавить информацию о юзере в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 46;
      5.

    5.
      6.

    6.  $xmlData = $shop->GetXmlForOrder($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xmlData);
      10.

    10.  ?>
      11.

    Возвращает

    сформированный xml для заказа

    [ Наверх ]

    shop::GetXmlProducer

GetXmlProducer(
array
$select );

    Описание

    Метод генерирует XML для производителя в магазине

    Принимаемые параметры

    $select

    данные о производителе

    Возвращает

    XML или false в случае отсутствия производителя

    [ Наверх ]

    shop::GroupIsParent

GroupIsParent(
int
$group_id, int
$group_parent_id );

    Описание

    Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id

    Принимаемые параметры

    $group_id

    идентификатор группы-потомка

    $group_parent_id

    идентификатор группы-родителя
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $group_id = 600;
      5.

    5.  $group_parent_id = 586;
      6.

    6.
      7.

    7.  $result = $shop->GroupIsParent($group_id, $group_parent_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    [ Наверх ]

    shop::ImportCML

ImportCML(
int
$array_of_cml_data, int
$shop_shops_id, int
$import_price_action_items, int
$shop_groups_parent_id, [str
$images_path = ''], [
$nl2br = TRUE] );

    Описание

    Импорт из формата CommerceML

    Принимаемые параметры

    $array_of_cml_data

    массив с данными в формате CommerceML, полученный в результате работы метода Xml2Array класса kernel, выполненного на целевом XML файле, содержащим данные в формате CommerceML

    $shop_shops_id

    идентификатор интернет-магазина

    $import_price_action_items

    идентификатор действия с уже существующими товарами (0 - Удалить существующие товары (во всех группах), 1 - Обновить информацию для существующих товаров, 2 - Оставить без изменений)

    $shop_groups_parent_id

    идентификатор группы в которую выгружать данные из CommerceML

    $images_path

    путь к картинкам

    $nl2br

    Возвращает

    ассоциативный массив с данными о количестве обработанных данных
    • array['count_insert_item'] - количество вставленных товаров
    • array['count_update_item'] - количество обновленных товаров
    • array['count_dir'] - количество вставленных групп товаров

    [ Наверх ]

    shop::IndexationShopItems

IndexationShopItems(
int
$limit, int
$on_step, [int
$shop_items_catalog_item_id = 0] );

    Описание

    Индексация товаров

    Принимаемые параметры

    $limit

    $on_step

    $shop_items_catalog_item_id

    идентификатор товара, необязательное поле, передается только при событийной индексации

    [ Наверх ]

    shop::InsertCity

InsertCity(
array
$param );

    Описание

    Метод, осуществляющий вставку города

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['location_id'] идентификатор области
    • int $param['id'] идентификатор города
    • string $param['name'] название города
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['city_order'] порядок сортировки

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['name'] = 'Новый город';
        5.

      5.  $param['location_id'] = 923;
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.      $SiteUsers = & singleton('SiteUsers');
        11.

      11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $city_id = $shop->InsertCity($param);
        19.

      19.
        20.

      20.  // Распечатаем результат
        21.

      21.  echo $city_id;
        22.

      22.  ?>
        23.

    Возвращает

    идентификатор вставленного города

    [ Наверх ]

    shop::InsertCityArea

InsertCityArea(
int
$type, int
$city_area_id, int
$city_area_name, int
$city_id,
$shop_city_area_order, [int
$users_id = false], int
$city_area_order );

    Описание

    Метод добавления/редактирования информации о районе города

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $city_area_id

    идентификатор района

    $city_area_name

    название района

    $city_id

    идентификатор города, в котором находится район

    $city_area_order

    порядок сортировки элемента

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $city_area_name = 'Новый район';
      6.

    6.  $city_id = 10963;
      7.

    7.  $shop_city_area_order = 10;
      8.

    8.  $city_area_id = '';
      9.

    9.
      10.

    10.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      11.

    11.  if (class_exists('SiteUsers'))
      12.

    12.  {
      13.

    13.      $SiteUsers = & singleton('SiteUsers');
      14.

    14.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      15.

    15.  }
      16.

    16.  else
      17.

    17.  {
      18.

    18.      $site_users_id = 0;
      19.

    19.  }
      20.

    20.
      21.

    21.  $newid = $shop->InsertCityArea($type, $city_area_id, $city_area_name, $city_id, $shop_city_area_order);
      22.

    22.
      23.

    23.
      24.

    24.  // Распечатаем результат
      25.

    25.  echo $newid;
      26.

    26.  ?>
      27.

    $shop_city_area_order

    Возвращает

    идентификатор нового или редатируемого района(в зависимости от типа действия)

    [ Наверх ]

    shop::InsertComment

InsertComment(
array
$param );

    Описание

    Метод добавления/обновления информации об отзыве на товар

    Принимаемые параметры

    $param

    массив доп. параметров
    • int $param['shop_comment_id'] идентификатор комментария
    • int $param['shop_items_catalog_item_id'] идентификатор товара
    • int $param['shop_comment_active'] активность комментария
    • int $param['shop_comment_grade'] оценка
    • int $param['site_users_id'] идентификатор пользователя сайта
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
    • string $param['shop_comment_date_time'] дата/время комментария (в формате гггг-мм-дд чч:мм:сс)
    • string $param['shop_comment_user_name'] имя пользователя, оставившего комментарий
    • string $param['shop_comment_user_email'] e-mail пользователя, оставившего комментарий
    • string $param['shop_comment_subject'] тема комментария
    • string $param['shop_comment_text'] текст комментария

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_items_catalog_item_id'] = 1;
        5.

      5.  $param['shop_comment_active'] = 1;
        6.

      6.  $param['shop_comment_subject'] = 'Товар 1';
        7.

      7.  $param['shop_comment_text'] = 'Хороший товар';
        8.

      8.  $param['shop_comment_user_name'] = 'Петр Николаевич';
        9.

      9.  $param['shop_comment_user_email'] = 'petr@test.ru';
        10.

      10.  $param['shop_comment_date_time'] = '2008-08-20 15:16:00';
        11.

      11.
        12.

      12.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        13.

      13.  if (class_exists('SiteUsers'))
        14.

      14.  {
        15.

      15.      $SiteUsers = & singleton('SiteUsers');
        16.

      16.      $param['site_users_id'] = $SiteUsers->GetCurrentSiteUser();
        17.

      17.  }
        18.

      18.  else
        19.

      19.  {
        20.

      20.      $param['site_users_id'] = 0;
        21.

      21.  }
        22.

      22.
        23.

      23.  $newid = $shop->InsertComment($param);
        24.

      24.
        25.

      25.  // Распечатаем результат
        26.

      26.  echo $newid;
        27.

      27.  ?>
        28.

    Возвращает

    идентификатор комментария (отзыва) или false

    [ Наверх ]

    shop::InsertCompany

InsertCompany(
array
$param );

    Описание

    Метод для вставки/обновления организации

    Принимаемые параметры

    $param

    массив доп. параметров
    • int $param['shop_company_id'] идентификатор организации
    • string $param['shop_company_name'] название организации
    • string $param['shop_company_description'] описание организации
    • string $param['shop_company_inn'] ИНН организации
    • string $param['shop_company_kpp'] КПП организации
    • string $param['shop_company_ogrn'] ОГРН организации
    • string $param['shop_company_okpo'] ОКПО организации
    • string $param['shop_company_okved'] ОКВЕД организации
    • string $param['shop_company_bik'] БИК организации
    • string $param['shop_company_account'] счет организации
    • string $param['shop_company_corr_account'] корр. счет организации
    • string $param['shop_company_bank_name'] название банка
    • string $param['shop_company_bank_address'] адрес банка
    • string $param['shop_company_fio'] ФИО директора организации
    • string $param['shop_company_accountant_fio'] ФИО бухгалтера организации
    • string $param['shop_company_address'] адрес организации
    • string $param['shop_company_phone'] телефон организации
    • string $param['shop_company_fax'] факс организации
    • string $param['shop_company_site'] сайт организации
    • string $param['shop_company_email'] e-mail организации
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_company_name'] = 'Новая организация';
        5.

      5.
        6.

      6.  $newid = $shop->InsertCompany($param);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $newid;
        10.

      10.  ?>
        11.

    Возвращает

    идентификатор организации или false

    [ Наверх ]

    shop::InsertCondOfDelivery

InsertCondOfDelivery(
array
$param );

    Описание

    Метод, осуществляющий вставку условия доставки

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор условия доставки
    string $param['name'] название условия доставки
    int $param['type_of_delivery'] идентификатор типа доставки
    • $param['location'] идентификатор области

      double $param['weight_from'] вес от

      double $param['weight_to'] вес до

      double $param['price_from'] цена заказа от

      double $param['price_to'] цена заказа до

      string $param['description'] описание условия доставки

      double $param['price'] цена доставки

      int $param['currency] идентификатор валюты цены доставки

      int $param['shop_tax_id] идентификатор налога
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['name'] = 'Из офиса';
        5.

      5.  $param['type_of_delivery'] = 5;
        6.

      6.
        7.

      7.  $newid = $shop->InsertCondOfDelivery($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $newid;
        11.

      11.  ?>
        12.

    Возвращает

    идентификатор вставленного условия доставки

    [ Наверх ]

    shop::InsertCountry

InsertCountry(
array
$param );

    Описание

    Метод, осуществляющий вставку страны

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор страны
    • string $param['name'] название страны
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['name'] = 'Новая страна';
        5.

      5.
        6.

      6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        7.

      7.  if (class_exists('SiteUsers'))
        8.

      8.  {
        9.

      9.      $SiteUsers = & singleton('SiteUsers');
        10.

      10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        11.

      11.  }
        12.

      12.  else
        13.

      13.  {
        14.

      14.      $site_users_id = 0;
        15.

      15.  }
        16.

      16.
        17.

      17.  $country_id = $shop->InsertCountry($param);
        18.

      18.
        19.

      19.  // Распечатаем результат
        20.

      20.  echo $country_id;
        21.

    Возвращает

    идентификатор вставленной страны

    [ Наверх ]

    shop::InsertCoupon

InsertCoupon(
array
$param );

    Описание

    Метод для вставки/обновления информации о купоне

    Принимаемые параметры

    $param

    массив с данными о купоне
    • int $param['shop_coupon_id'] идентификатор купона
    • int $param['shop_order_discount_id'] идентификатор скидки на сумму заказа
    • int $param['shop_shops_id'] идентификатор магазина
    • str $param['shop_coupon_name'] название купона
    • int $param['shop_coupon_active'] активность купона
    • int $param['shop_coupon_count'] количество купонов
    • int $param['shop_coupon_text'] текст купона
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['shop_order_discount_id'] = 1;
        6.

      6.  $param['shop_coupon_name'] = 'Новый купон';
        7.

      7.  $param['shop_coupon_text'] = '868-570-864-822';
        8.

      8.  $param['shop_coupon_count'] = 11;
        9.

      9.  $param['shop_coupon_active'] = 1;
        10.

      10.
        11.

      11.  $newid = $shop->InsertCoupon($param);
        12.

      12.
        13.

      13.  // Распечатаем результат
        14.

      14.  echo $newid;
        15.

      15.  ?>
        16.

    Возвращает

    идентификатор вставленного/обновленного купона или false

    [ Наверх ]

    shop::InsertCurrency

InsertCurrency(
array
$param );

    Описание

    Метод,осуществляющий вставку информации о валюте

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    string $param['name'] параметр, определяющий название валюты
    string $param['currency_international_name'] интернациональное название валюты
    double $param['value_in_basic_currency'] значение курса валюты в базовой валюте
    boolean $param['is_default'] параметр, определяющий, является ли валюта базовой
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['name'] = 'Фунт';
        5.

      5.  $param['currency_international_name'] = 'GBP';
        6.

      6.  $param['value_in_basic_currency'] = 41.78;
        7.

      7.  $param['is_default'] = 0;
        8.

      8.
        9.

      9.  $newid = $shop->InsertCurrency($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $newid;
        13.

      13.  ?>
        14.

    Возвращает

    идентификатор вставленной валюты (false при неудачной вставке)

    [ Наверх ]

    shop::InsertDiscount

InsertDiscount(
array
$param );

    Описание

    Метод, осуществляющий вставку информации о скидке

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['shop_shops_id'] идентификационный номер магазина
    int $param['id'] идентификационный номер скидки
    string $param['name'] наименование скидки
    date $param['from'] с какого времени действует скидка
    string $param['to'] по какое время действует скидка
    int $param['is_active'] активна ли скидка в настоящий момент
    numeric $param['percent'] процент скидки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_shops_id'] = 1;
      5.

    5.  $param['name'] = 'new';
      6.

    6.  $param['from'] = '2008.08.20';
      7.

    7.  $param['to'] = '2026.08.20';
      8.

    8.  $param['is_active'] = 1;
      9.

    9.  $param['percent'] = 20;
      10.

    10.
      11.

    11.  $newid = $shop->InsertDiscount($param);
      12.

    12.
      13.

    13.  // Распечатаем результат
      14.

    14.  echo ($newid);
      15.

    15.  ?>
      16.

    Возвращает

    идентификационный номер вставленной скидки

    [ Наверх ]

    shop::InsertEItem

InsertEItem(
array
$param );

    Описание

    Метод вставки/обновления информации об электронном товаре

    Принимаемые параметры

    $param

    int $param['shop_eitem_id'] Идентификатор электронного товара, при добавлении не передается или равен 0.
    int $param['shop_items_catalog_item_id'] Идентификатор обычного товара, для которого добавляется эл. товар
    int $param['shop_eitem_name'] Описание электронного товара
    int $param['shop_eitem_value'] Текст электронного товара
    int $param['shop_eitem_filename'] Оригинальное имя файла, если нет файла - передается пустая строка.  Обратите внимание, что сам файл эл.товара необходимо размещать в директории отдельно после вставки записи в БД:
    1.  // ID магазина
      2.

    2.  $shop_shops_id = 1;
      3.

    3.
      4.

    4.  // ID товара
      5.

    5.  $item_id = 123;
      6.

    6.
      7.

    7.  $param['shop_items_catalog_item_id'] = $item_id;
      8.

    8.  $param['shop_eitem_name'] = to_str($_REQUEST['shop_eitem_name']);
      9.

    9.  $param['shop_eitem_value'] = to_str($_REQUEST['shop_eitem_value']);
      10.

    10.  $param['shop_eitem_count'] = to_int($_REQUEST['shop_eitem_count']);
      11.

    11.
      12.

    12.  // Оригинальное имя файла
      13.

    13.  $param['shop_eitem_filename'] = to_str($_FILES['shop_eitem_filename']['name']);
      14.

    14.
      15.

    15.  $eitem_id = $shop->InsertEItem($param);
      16.

    16.
      17.

    17.  // Прояверяем, существует ли каталог для файла
      18.

    18.  $dir_name = CMS_FOLDER . UPLOADDIR . 'shop_' . $shop_shops_id . '/eitems/item_catalog_' . $item_id;
      19.

    19.
      20.

    20.  if (!is_dir($dir_name))
      21.

    21.  {
      22.

    22.          if (!@mkdir($dir_name))
      23.

    23.          {
      24.

    24.              // Выводим ошибку
      25.

    25.          }
      26.

    26.  }
      27.

    27.
      28.

    28.  if (is_dir($dir_name))
      29.

    29.  {
      30.

    30.          // Получаем расширение файла
      31.

    31.          $exp = $kernel->GetExtension($_FILES['shop_eitem_filename']['name']);
      32.

    32.
      33.

    33.          if (!move_uploaded_file($_FILES['shop_eitem_filename']['tmp_name'], $dir_name . '/' . $eitem_id . '.' . $exp))
      34.

    34.          {
      35.

    35.              // Отображаем ошибку
      36.

    36.          }
      37.

    37.  }
      38.

    int $param['shop_eitem_count'] Количество копий электронного товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_items_catalog_item_id'] = 159;
      5.

    5.  $param['shop_eitem_value'] = 'Текст';
      6.

    6.  $param['shop_eitem_name'] = 'Электронный товар';
      7.

    7.  $param['shop_eitem_count'] = 5;
      8.

    8.
      9.

    9.  $newid = $shop->InsertEItem($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newid;
      13.

    13.  ?>
      14.

    Возвращает

    идентификатор вставленного элемента или false

    [ Наверх ]

    shop::InsertGroup

InsertGroup(
array
$param );

    Описание

    Вставку/обновление группы товаров

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['group_id'] идентификационный номер группы
    • string $param['shop_groups_name'] имя группы
    • int $param['shop_shops_id'] идентификатор магазина
    • string $param['shop_groups_description'] описание группы
    • string $param['shop_groups_image'] путь к изображению (логотипу) группы
    • string $param['groups_image_small'] путь к уменьшенному изображению (логотипу) группы
    • int $param['shop_groups_order'] порядок сортировки
    • int $param['shop_groups_parent_id'] идентификатор родительской группы
    • int $param['users_id'] идентификатор пользователя
    • int $param['shop_groups_indexation'] флаг индексации
    • int $param['shop_groups_activity'] параметр, определяющий доступность группы и ее дочерних групп и элементов (1 (по умолчанию) - доступна, 0 - не доступна)
    • int $param['shop_groups_access'] параметр, определяющий тип доступа для группы товаров (0 - доступна всем, -1 - доступ как у родителя)
    • string $param['shop_groups_path'] путь к группе
    • string $param['shop_groups_seo_title'] заголовок страницы
    • string $param['shop_groups_seo_description'] задание значения мета-тега description страницы
    • string $param['shop_groups_seo_keywords'] задание значения мета-тега keywords страницы
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
    • int $param ['shop_groups_big_image_width'] ширина большой картинки
    • int $param ['shop_groups_big_image_height'] высота большой картинки
    • int $param ['shop_groups_small_image_width'] ширина маленькой картинки
    • int $param ['shop_groups_small_image_height'] высота маленькой картинки
    • bool $param['search_event_indexation'] использовать ли событийную индексацию при вставке элемента, по умолчанию true

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_groups_name'] = 'Новая группа';
        5.

      5.  $param['shop_shops_id'] = 1;
        6.

      6.  $param['shop_groups_parent_id'] = 586;
        7.

      7.
        8.

      8.  $newid = $shop->InsertGroup($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    возвращает идентификатор вставленной группы (false при неудачной вставке)

    [ Наверх ]

    shop::InsertItem

InsertItem(
array
$param );

    Описание

    Вставка информации о товаре. Может принимать только часть параметров, при этом обновлены будут только переданные значения

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shops_id'] идентификационный номер магазина, обязательный параметр
    • int $param['item_id'] идентификационнный номер товара, указывается при обновлении информации о товаре
    • int $param['groups_id'] идентификатор группы, в которой расположен товар
    • int $param['shop_items_catalog_shortcut_id'] идентификатор товара, на который ссылается ярлык. По умолчанию равен 0, если не является ярлыком.
    • string $param['name'] наименование товара
    • string $param['marking'] артикул товара
    • string $param['description'] краткое описание товара
    • int $param['shop_items_catalog_type'] тип товара, 0 - обычный товар, 1 - электронный товар. по умолчанию 0.
    • string $param['shop_items_catalog_date_time'] датавремя добавления, в формате MySQL
    • string $param['shop_items_catalog_putoff_date'] датавремя начала публикации товара в каталоге, в формате MySQL. Необязательное поле.
    • string $param['shop_items_catalog_putend_date'] датавремя окончания публикации товара в каталоге, в формате MySQL. Необязательное поле.
    • string $param['text'] детальное описание товара
    • int $param['currency_id'] идентификатор валюты
    • double $param['weight'] вес товара
    • double $param['price'] цена товара для пользователя
    • int $param['tax_id'] идентификатор налога
    • int $param['is_active'] флаг доступности товара
    • int $param['shop_items_catalog_access'] параметр, определяющий группу пользователей, имеющих доступ к товару (0 - доступна всем, -1 - доступ как у родителя)
    • int $param['order'] порядок сортировки товара
    • int $param['indexation'] флаг индексации товара
    • string $param['path'] путь к товару
    • string $param['seo_title'] заголовок страницы товара
    • string $param['seo_description'] задание значения мета-тега description страницы товара
    • string $param['seo_keywords'] задание значения мета-тега keywords страницы товара
    • string $param['shop_items_cml_id'] идентификатор товара в CommerceML
    • string $param['shop_vendorcode'] код производителя для Яндекс.Маркет
    • bool $param['shop_items_catalog_yandex_market_allow'] разрешить экспорт в Яндекс.Маркет
    • int $param['shop_items_catalog_yandex_market_bid'] значение BID для экспорта в Яндекс.Маркет
    • int $param['shop_items_catalog_yandex_market_cid'] значение CID для экспорта в Яндекс.Маркет
    • string $param['shop_items_catalog_yandex_market_sales_notes'] описание особенностей заказа при экспорте в Яндекс.Маркет
    • bool $param['shop_items_catalog_rambler_pokupki_allow'] разрешить экспорт в Рамблер.Покупки
    • int $param['shop_sallers_id'] значение идентификатора продавца товара
    • int $param['producers_list_id'] идентификатор производителя
    • int $param['shop_items_catalog_modification_id'] идентификатор основного товара для модификации, указывается если данный товар является модификацией
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
    • int $param['site_users_id'] идентификатор пользователя сайта, добавившего товар
    • int $param['mesures_id'] идентификатор единицы измерения
    • string $param['path_source_big_image'] путь к файлу-источнику большого изображения;
    • string $param['path_source_small_image'] путь к файлу-источнику малого изображения;
    • int $param['shop_items_catalog_image'] имя большого изображения
    • int $param['shop_items_catalog_small_image'] имя малого изображения
    • int $param['shop_items_catalog_small_image_height'] высота малого изображения
    • int $param['shop_items_catalog_small_image_width'] ширина малого изображения
    • int $param['shop_items_catalog_big_image_height'] высота большого изображения
    • int $param['shop_items_catalog_big_image_width'] ширина большого изображения
    • string $param['original_file_name_big_image'] оригинальное имя файла большого изображения
    • string $param['original_file_name_small_image'] оригинальное имя файла малого изображения
    • bool $param['use_big_image'] использовать большое изображение для создания малого (true - использовать, false - не использовать)
    • int $param['max_width_big_image'] значение максимальной ширины большого изображения
    • int $param['max_height_big_image'] значение максимальной высоты большого изображения
    • int $param['max_width_small_image'] значение максимальной ширины малого изображения;
    • int $param['max_height_small_image'] значение максимальной высоты малого изображения;
    • string $param['watermark_file_path'] путь к файлу с "водяным знаком"
    • int $param['watermark_position_x'] позиция "водяного знака" по оси X
    • int $param['watermark_position_y'] позиция "водяного знака" по оси Y
    • bool $param['used_watermark_big_image'] наложить "водяной знак" на большое изображение (true - наложить (по умолчанию), false - не наложить);
    • bool $param['used_watermark_small_image'] наложить "водяной знак" на малое изображение (true - наложить (по умолчанию), false - не наложить);
    • int $param['shop_items_catalog_show_count'] счетчик просмотра товара
    • bool $param['search_event_indexation'] использовать ли событийную индексацию при вставке элемента, по умолчанию true

    Возвращает

    идентификационный номер вставленного товара, false или -1

    [ Наверх ]

    shop::InsertItemDiscount

InsertItemDiscount(
array
$param );

    Описание

    Метод вставки скидки для определенного товара

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['item_catalog_id'] идентификатор товара
    • int $param['shop_discount_id'] идентификатор скидки
    • int $param['shop_item_discount_id'] идентификатор обновляемой записи, если не указан, производится добавление скидки.
    • int $param['users_id'] идентификатор пользователя центра адмнистрирования который добавил элемент

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['item_catalog_id'] = 167;
        5.

      5.  $param['shop_discount_id'] = 2;
        6.

      6.
        7.

      7.  $newid = $shop->InsertItemDiscount($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $newid;
        11.

      11.  ?>
        12.

    Возвращает

    возвращает идентификатор вставленной записи

    [ Наверх ]

    shop::InsertItemsCatalogTags

InsertItemsCatalogTags(
array
$array );

    Описание

    Вставка тегов для товаров

    Принимаемые параметры

    $array

    массив атрибутов
    str $array['tags'] - теги для товара с разделителем запятая
    str $array['shop_items_catalog_item_id'] - идентификатор товара
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $array['tags'] = 'Tag';
      5.

    5.  $array['shop_items_catalog_item_id'] = 1;
      6.

    6.
      7.

    7.  $newtag = $shop->InsertItemsCatalogTags($array);
      8.

    8.
      9.

    9.  echo $newtag;
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::InsertLocation

InsertLocation(
array
$param );

    Описание

    Метод, осуществляющий вставку области

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор области
    • int $param['shop_country_id'] идентификатор страны
    • string $param['name'] название области
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['shop_location_order'] порядок сортировки области

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_country_id'] = 175;
        5.

      5.  $param['name'] = 'Новая область';
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.      $SiteUsers = & singleton('SiteUsers');
        11.

      11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $location_id = $shop->InsertLocation($param);
        19.

      19.
        20.

      20.  // Распечатаем результат
        21.

      21.  echo $location_id;
        22.

      22.  ?>
        23.

    Возвращает

    идентификатор вставленной области

    [ Наверх ]

    shop::InsertMesure

InsertMesure(
array
$param );

    Описание

    Метод, осуществляющий вставку  информации о единице измерения

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационнный номер единицы измерения
    string $param['name'] наименование единицы измерения
    string $param['description'] описание единицы измерения
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['id'] = 1;
      5.

    5.  $param['name'] = 'in';
      6.

    6.  $param['description'] = 'дюйм';
      7.

    7.
      8.

    8.  $newid = $shop->InsertMesure($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    Возвращает

    идентификационный номер вставленной единицы измерения

    [ Наверх ]

    shop::InsertOrder

InsertOrder(
array
$param );

    Описание

    Метод, осуществляющий вставку заказа

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор заказа
    • int $param['shop_shops_id'] идентификатор магазина
    • int $param['location_id'] идентификатор области
    • int $param['country_id'] идентификатор страны
    • int $param['shop_city_id'] идентификатор города
    • int $param['city_area_id'] идентификатор района
    • int $param['shop_cond_of_delivery_id'] идентификатор способа доставки
    • float $param['delivery_price'] стоимость доставки
    • int $param['site_user_id'] идентификатор пользователя
    • int $param['shop_order_status_id'] идентификатор статуса заказа
    • int $param['currency_id'] идентификатор валюты
    • int $param['shop_system_of_pay_id'] идентификатор платежной системы
    • str $param['order_date_time'] дата заказа
    • int $param['status_of_pay'] статус оплаты
    • str $param['date_of_pay'] дата оплаты
    • str $param['address'] адрес доставки
    • int $param['index'] почтовый индекс
    • str $param['phone'] телефон пользователя
    • str $param['description'] описание для заказа
    • int $param['shop_order_cancel'] заказ аннулирован пользователем
    • str $param['shop_order_users_name'] имя пользователя, сделавшего заказ
    • str $param['shop_order_users_surname'] фамилия пользователя, сделавшего заказ
    • str $param['shop_order_users_patronymic'] отчество пользователя, сделавшего заказ
    • str $param['shop_order_users_email'] электронный адрес пользователя, сделавшего заказ
    • str $param['shop_order_users_company'] название организации пользователя, сделавшего заказ
    • str $param['shop_order_users_fax'] факс пользователя, сделавшего заказ
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • str $param['change_status_date'] дата изменения статуса заказа
    • str $param['shop_order_guid'] GUID для заказа, если не передан генерируется автоматически
    • str $param['system_information'] Дополнительная информация о заказе
    • str $param['shop_order_sending_info'] Информация об отправлении
    • str $param['shop_order_ip'] IP-адрес заказчика
    • int $param['shop_order_unload'] статус выгрузки товара

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['order_date_time'] = '2008-08-20 17:53:47';
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.      $SiteUsers = & singleton('SiteUsers');
        11.

      11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $newid = $shop->InsertOrder($param);
        19.

      19.
        20.

      20.  // Распечатаем результат
        21.

      21.  echo $newid;
        22.

      22.  ?>
        23.

    Возвращает

    идентификатор вставленного заказа

    [ Наверх ]

    shop::InsertOrderDiscount

InsertOrderDiscount(
array
$param );

    Описание

    Метод для вставки/обновления информации о скидке для заказов

    Принимаемые параметры

    $param

    массив с параметрами скидки
    • int $param['shop_order_discount_id'] идентификатор скидки (указывается в случае обновления)
    • int $param['shop_shops_id'] идентификатор магазина
    • int $param['shop_currency_id'] идентификатор валюты
    • string $param['shop_order_discount_name'] название скидки
    • int $param['shop_order_discount_sum_from'] скидка активна для сумм товара начиная с данной
    • int $param['shop_order_discount_sum_to'] скидка активна для сумм товара не более данной
    • int $param['shop_order_discount_active'] активность скидки
    • int $param['shop_order_discount_active_from'] дата, начиная с которой данная скидка активна
    • int $param['shop_order_discount_active_to'] дата до которой активна скидка
    • int $param['shop_order_discount_type'] тип скидки (процент или фиксированная сумма)
    • int $param['shop_order_discount_value'] величина скидки
    • int $param['shop_order_discount_is_coupon'] применять скидку только к купонам - 1, обычная скидка - 0
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['shop_currency_id'] = 1;
        6.

      6.  $param['shop_order_discount_name'] = 'Новая скидка';
        7.

      7.  $param['shop_order_discount_active_from'] = '01.09.2008';
        8.

      8.  $param['shop_order_discount_active_to'] = '30.09.2008';
        9.

      9.
        10.

      10.  $newid = $shop->InsertOrderDiscount($param);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  echo $newid;
        14.

      14.  ?>
        15.

    Возвращает

    идентификатор вставленной/обновленной скидки или false

    [ Наверх ]

    shop::InsertOrderItems

InsertOrderItems(
array
$param );

    Описание

    Метод, осуществляющий вставку товара в заказ

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_order_items_id'] идентификатор обновляемой записи
    • int $param['shop_items_catalog_item_id'] идентификатор товара
    • int $param['shop_order_id'] идентификатор заказа, которому принадлежит товар
    • float $param['shop_order_items_quantity'] количество определенного товара в заказе
    • float $param['shop_order_items_price'] цена товара в заказе
    • string $param['shop_order_items_name'] наименование товара в заказе
    • string $param['shop_order_items_marking'] артикул товара в заказе
    • int $param['users_id'] идентификатор пользователя, создающего объект
    • int $param['shop_warehouse_id'] идентификатор склада
    • str $param['shop_order_items_eitem_resource'] уникальная ссылка для скачивания электронного товара
    • int $param['shop_eitem_id'] идентификатор сущности электронного товара. Указывается только для товаров магазина, имеющих тип "электронный товар"
    • int $param['shop_order_items_type'] флаг, указывающий тип товара (0 - обычный товар, 1 - доставка, 2 - пополнение счета)
    • int $param['shop_tax_rate'] сумма налога

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_items_catalog_item_id'] = 159;
        5.

      5.  $param['shop_order_id'] = 47;
        6.

      6.  $param['shop_order_items_quantity'] = 1;
        7.

      7.  $param['shop_order_items_price'] = 500;
        8.

      8.
        9.

      9.  $newid = $shop->InsertOrderItems($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo  $newid;
        13.

      13.
        14.

      14.  ?>
        15.

    Возвращает

    идентификатор вставленного товара в заказ

    [ Наверх ]

    shop::InsertOrderStatus

InsertOrderStatus(
array
$param );

    Описание

    Метод, осуществляющий вставку статуса заказа

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер статуса заказа
    string $param['name'] название состояния доставки
    string $param['description'] описание состояния доставки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['name'] = 'в пролете';
      5.

    5.
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      $site_users_id = 0;
      15.

    15.  }
      16.

    16.
      17.

    17.  $newid = $shop->InsertOrderStatus($param);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  echo $newid;
      21.

    21.  ?>
      22.

    Возвращает

    идентификатор вставленного состояния доставки

    [ Наверх ]

    shop::InsertOrderWithoutSystemOfPay

InsertOrderWithoutSystemOfPay(
int
$shop_id, int
$site_users_id, [array
$additional_param = array ()], [string
$xsl_name = false] );

    Описание

    Метод вставки заказа, если платежная система не выбрана

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя сайта

    $additional_param

    массив с дополнительными параметрами
      $additional_param['description'] string описание для заказа  $additional_param['system_information'] string системная информация для заказа

    $xsl_name

    название xsl-шаблона (не обязательный параметр, передается при необходимости - вывести данные о заказе)
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $site_users_id = 19;
      6.

    6.
      7.

    7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      8.

    8.  if (class_exists('SiteUsers'))
      9.

    9.  {
      10.

    10.      $SiteUsers = & singleton('SiteUsers');
      11.

    11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      $site_users_id = 0;
      16.

    16.  }
      17.

    17.
      18.

    18.  $order_id = $shop->InsertOrderWithoutSystemOfPay($shop_id, $site_users_id);
      19.

    19.
      20.

    20.  // Распечатаем результат
      21.

    21.  print_r ($order_id);
      22.

    22.  ?>
      23.

    [ Наверх ]

    shop::InsertPrice

InsertPrice(
array
$param );

    Описание

    Метод, осуществляющий вставку типа цены

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_shops_id'] идентификатор магазина
    • int $param['id'] идентификатор цены
    • string $param['name'] название цены
    • double $param['percent_to_basic'] процент по отношению к базовой цене
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • string $param['shop_list_of_prices_cml_id'] CML ID цены, если не передано, устанавливается равным пустой строке

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['name'] = 'Праздничная';
        6.

      6.  $param['percent_to_basic'] = 10;
        7.

      7.  $param['shop_list_of_prices_cml_id'] = '00001';
        8.

      8.
        9.

      9.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        10.

      10.  if (class_exists('SiteUsers'))
        11.

      11.  {
        12.

      12.      $SiteUsers = & singleton('SiteUsers');
        13.

      13.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        14.

      14.  }
        15.

      15.  else
        16.

      16.  {
        17.

      17.      $site_users_id = 0;
        18.

      18.  }
        19.

      19.
        20.

      20.  $price_id = $shop->InsertPrice($param);
        21.

      21.
        22.

      22.  // Распечатаем результат
        23.

      23.  echo $price_id;
        24.

      24.  ?>
        25.

    Возвращает

    идентификатор вставленного типа цены, -2 в случае указания заведомо неверного процента к базовой (больше или равно 100.00)

    [ Наверх ]

    shop::InsertPricesToItem

InsertPricesToItem(
array
$param );

    Описание

    Метод вставки связи товара и цены из справочника цен

    Принимаемые параметры

    $param

    $param['shop_items_catalog_item_id'] - идентификатор элемента каталога
      $param['shop_list_of_prices_id'] - идентификатор дополнительной цены
      $param['shop_prices_to_item_value'] - значение дополнительной цены
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_items_catalog_item_id'] = 159;
      5.

    5.  $param['shop_list_of_prices_id'] = 1;
      6.

    6.  $param['shop_prices_to_item_value'] = 300;
      7.

    7.
      8.

    8.  $newid = $shop->InsertPricesToItem($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.
      13.

    13.  ?>
      14.

    Возвращает

    идентификатор обновленной записи или false в случае ошибки

    [ Наверх ]

    shop::InsertProducer

InsertProducer(
array
$param );

    Описание

    Метод, осуществляющий вставку производителя

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shops_id'] идентификационный номер магазина
    • int $param['id'] идентификационный номер производителя
    • string $param['name'] имя (название) производителя
    • string $param['description'] краткая информация о производителе
    • string $param['image'] путь к логотипу производителя
    • string $param['small_image'] путь к малому логотипу производителя
    • int $param['order'] тип сортировки производителей
    • string $param['path'] путь к производителю
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • str $param['shop_producers_list_address'] адрес производителя
    • str $param['shop_producers_list_phone'] телефон производителя
    • str $param['shop_producers_list_fax'] факс производителя
    • str $param['shop_producers_list_site'] сайт производителя
    • str $param['shop_producers_list_email'] сайт производителя
    • str $param['shop_producers_list_kpp'] КПП производителя
    • str $param['shop_producers_list_ogrn'] ОГРН производителя
    • str $param['shop_producers_list_okved'] ОКВЭД производителя
    • str $param['shop_producers_list_bik'] БИК производителя
    • str $param['shop_producers_list_account'] Номер счета производителя
    • str $param['shop_producers_list_corr_account'] Номер корр. счета производителя
    • str $param['shop_producers_list_bank_name'] Название банка производителя
    • str $param['shop_producers_list_bank_address'] Адрес банка производителя
    • str $param['shop_producers_list_seo_title'] заголовок страницы
    • str $param['shop_producers_list_seo_description'] задание значения мета-тега description страницы
    • str $param['shop_producers_list_seo_keywords'] задание значения мета-тега keywords страницы

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shops_id'] = 1;
        5.

      5.  $param['name'] = 'newprod';
        6.

      6.
        7.

      7.  $newid = $shop->InsertProducer($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $newid;
        11.

      11.  ?>
        12.

    Возвращает

    идентификатор вставленного производителя

    [ Наверх ]

    shop::InsertPropertiesGroupsDir

InsertPropertiesGroupsDir(
array
$param );

    Описание

    Добавление информации о группе дополнительных свойств каталогов товаров

    Принимаемые параметры

    $param

    Массив параметров
    • int $param['shop_properties_groups_dir_id'] Идентификатор группы дополнительных свойств группы товаров
    • int $param['shop_shops_id'] Идентификатор магазина
    • int $param['shop_properties_groups_dir_parent_id'] Идентификатор родительской группы дополнительных свойств группы товаров
    • int $param['shop_properties_groups_dir_name'] Название группы дополнительных свойств группы товаров
    • int $param['shop_properties_groups_dir_description'] Описание группы дополнительных свойств группы товаров
    • int $param['shop_properties_groups_dir_order'] Порядок сортировки группы дополнительных свойств группы товаров

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_properties_groups_dir_id'] = '';
        5.

      5.  $param['shop_shops_id'] = 1;
        6.

      6.  $param['shop_properties_groups_dir_parent_id'] = 0;
        7.

      7.  $param['shop_properties_groups_dir_name'] = 'new';
        8.

      8.  $param['shop_properties_groups_dir_description'] = 'новая';
        9.

      9.  $param['shop_properties_groups_dir_order'] = 'ASC';
        10.

      10.
        11.

      11.  $newid = $shop->InsertPropertiesGroupsDir($param);
        12.

      12.
        13.

      13.  // Распечатаем результат
        14.

      14.  echo $newid;
        15.

      15.  ?>
        16.

    Возвращает

    Идентификатор вставленной записи, либо False

    [ Наверх ]

    shop::InsertPropertiesGroupValue

InsertPropertiesGroupValue(
array
$param );

    Описание

    Вставка значение дополнительного свойства групп товаров

    Принимаемые параметры

    $param

    Массив параметров
    • str $param['shop_properties_group_value_value'] Значение дополнительного свойства или оригинальное имя файла большого изображения)
    • str $param['shop_properties_group_value_value_small'] Оригинальное имя файла малого изображения
    • str $param['shop_properties_group_value_file'] Файл изображения
    • str $param['shop_properties_group_value_file_small']  Файла малого изображения

      int $param['shop_properties_group_id'] Идентификатор дополнительного свойства

      int $param['shop_groups_id'] Идентификатор группы товаров

      1.  $shop = new shop();
        2.

      2.
        3.

      3.  $param['shop_properties_group_value_value'] = 'Hello World!!!';
        4.

      4.  $param['shop_properties_group_value_value_small'] = '';
        5.

      5.  $param['shop_properties_group_value_file'] = '';
        6.

      6.  $param['shop_properties_group_value_file_small'] = '';
        7.

      7.  $param['shop_properties_group_id'] = 9;
        8.

      8.  $param['shop_groups_id'] = 589;
        9.

      9.
        10.

      10.  $newid = $shop->InsertPropertiesGroupValue($param);
        11.

      11.
        12.

      12.  //Распечатаем результат
        13.

      13.  echo $newid;
        14.

      14.  ?>
        15.

    [ Наверх ]

    shop::InsertPropertiesItem

InsertPropertiesItem(
array
$param );

    Описание

    Метод вставки значения дополнительного свойства товара

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вставляются свойства
    • int $param['shop_list_of_properties_id'] идентификатор свойства товара
    • string $param['shop_properties_items_value'] значение свойства товара (или оригинальное имя загружаемого изображения)
    • string $param['shop_properties_items_value_small'] оригинальное имя загружаемого малого файла изображения
    • string $param['shop_properties_items_file'] системное имя файла изображения
    • string $param['shop_properties_items_file_small'] системное имя малого файла изображения

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_items_catalog_item_id'] = 159;
        5.

      5.  $param['shop_list_of_properties_id'] = 141;
        6.

      6.  $param['shop_properties_items_value'] = 'тест';
        7.

      7.
        8.

      8.  $newid = $shop->InsertPropertiesItem($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор вставленной записи

    [ Наверх ]

    shop::InsertPropertiesItemsDir

InsertPropertiesItemsDir(
array
$param );

    Описание

    Добавление информации о группе дополнительных свойств товара

    Принимаемые параметры

    $param

    - int $param['shop_shops_id'] Идентификатор магазина
    • int $param['shop_properties_items_dir_id'] Идентификатор группы дополнительных свойств товара (указывается при редактировании группы)
    • str $param['shop_properties_items_dir_parent_id'] Идентификатор родительской группы
    • str $param['shop_properties_items_dir_name'] Название группы
    • int $param['shop_properties_items_dir_description'] Описание группы
    • str $param['shop_properties_items_dir_order'] Порядок сортировки группы
    • int $param['users_id'] Идентификатор пользователя центра администрирования, который создал группу. Если не передан - определяется автоматически.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['shop_properties_items_dir_parent_id'] = 0;
        6.

      6.  $param['shop_properties_items_dir_name'] = 'Новый раздел';
        7.

      7.  $param['shop_properties_items_dir_description'] = 'Описание раздела';
        8.

      8.  $param['shop_properties_items_dir_order'] = 0;
        9.

      9.
        10.

      10.  $newid = $shop->InsertPropertiesItemsDir($param);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  echo $newid;
        14.

      14.  ?>
        15.

    Возвращает

    Идентификатор вставленной записи, либо False

    [ Наверх ]

    shop::InsertPropertyForGroup

InsertPropertyForGroup(
array
$param );

    Описание

    Установка принадлежности дополнительного свойства группе товаров

    Принимаемые параметры

    $param

    массив атрибутов
    int $param['shop_groups_id'] Идентификатор каталога товаров
    int $param['shop_list_of_properties_id'] Идентификатор дополнительного свойства
    int $param['shop_shops_id'] Идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_groups_id'] = 589;
      5.

    5.  $param['shop_list_of_properties_id'] = 135;
      6.

    6.  $param['shop_shops_id'] = 1;
      7.

    7.
      8.

    8.  $newid = $shop->InsertPropertyForGroup($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    Возвращает

    идентификатор вставленной записи или false

    [ Наверх ]

    shop::InsertPropretyOfGroup

InsertPropretyOfGroup(
array
$param );

    Описание

    Вставка дополнительного свойства группы товаров

    Принимаемые параметры

    $param

    Массив параметров
    • $param['shop_properties_group_id'] Идентификатор дополнительного свойства, используется при обновлении (необязательное поле при вставке)
    • $param['shop_shops_id'] Идентификатор магазина
    • $param['shop_properties_groups_dir_id'] Идентификатор раздела, в котором размещается доп. св-во группы
    • $param['shop_mesures_id'] Идентификатор единицы измерения
    • $param['lists_id'] Идентификатор списка
    • $param['shop_properties_group_name'] Название дополнительного свойства
    • $param['shop_properties_group_xml_name'] Название XML-тега
    • $param['shop_properties_group_type'] Тип дополнительного свойства

      0 - Строка

      1 - Файл

      2 - Список

      3 - Большое текстовое поле

      4 - Визуальный редактор

      5 - Дата

      6 - ДатаВремя

      7 - Флажок
    • $param['shop_properties_group_default_value'] Значение дополнительного свойства по умолчанию
    • $param['shop_properties_group_order'] Порядок сортировки дополнительного свойства
    • $param['users_id'] Идентрификатор пользователя центра администрирования
    • $param['shop_properties_group_cml'] уникальный идентификатор

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['shop_properties_group_name'] = 'Новое свойство';
        6.

      6.  $param['shop_properties_groups_dir_id'] = 0; // Раздел корневой
        7.

      7.  $param['shop_properties_group_type'] = 4; // Тип
        8.

      8.
        9.

      9.  $newid = $shop->InsertPropretyOfGroup($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo ($newid);
        13.

      13.  ?>
        14.

    Возвращает

    идентификатор вставленного/обновленного свойства группы

    [ Наверх ]

    shop::InsertPropretyOfItems

InsertPropretyOfItems(
array
$param );

    Описание

    Метод, осуществляющий вставку свойства товара

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_shops_id'] идентификатор магазина
    • int $param['id'] идентификатор свойства товаров
    • int $param['mesures_id'] идентификатор единицы измерения товара
    • string $param['name'] название свойства товара
    • string $param['xml_name'] наименование xml-тега
    • string $param['shop_list_of_properties_description'] описание допсвойства
    • int $param['type'] тип свойства товара

      1 - Файл

      2 - Список

      3 - Большое текстовое поле

      4 - Визуальный редактор

      5 - Дата

      6 - ДатаВремя

      7 - Флажок
    • string $param['prefics'] префикс свойства товара (например: свыше, более, до ...)
    • string $param['default_value'] значение свойства товара, устанавливаемое по умолчанию
    • int $param['order'] порядок сортировки
    • int $param['list_id'] идентификатор списка, используемого для задания значениий доп. свойства
    • int $param['shop_list_of_properties_show_kind'] способ отображения в фильтре
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • string $param['shop_list_of_properties_cml_id'] идентификатор CommerceML

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['name'] = 'newprop';
        6.

      6.  $param['mesures_id'] = 28;
        7.

      7.  $param['order'] = 999;
        8.

      8.
        9.

      9.  $newid = $shop->InsertPropretyOfItems($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $newid;
        13.

      13.  ?>
        14.

    Возвращает

    идентификатор вставленного товара в случае успешной вставки, ложь при возникновении ошибки

    [ Наверх ]

    shop::InsertSeller

InsertSeller(
array
$param );

    Описание

    Метод, осуществляющий вставку или обновление продавца.

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • $param['shop_sallers_name'] имя (название) продавца
    • $param['shop_sallers_contact_person'] контактное лицо
    • $param['shop_sallers_comment'] комментарий к продавцу
    • $param['shop_sallers_address'] адрес продавца
    • $param['shop_sallers_phone'] телефон продавца
    • $param['shop_sallers_fax'] факс продавца
    • $param['shop_sallers_http'] сайт продавца
    • $param['site_users_id'] идентификатор пользователя сайта
    • $param['shop_sallers_email'] e-mail продавца
    • $param['shop_sallers_inn'] ИНН продавца
    • $param['shop_shops_id'] идентификатор магазина
    • $param['shop_sallers_id'] идентификатор продавца, указывается если нужно обновить информацию
    • $param['path_source_big_image'] путь к файлу-источнику большого изображения;
    • $param['path_source_small_image'] путь к файлу-источнику малого изображения;
    • $param['original_file_name_big_image'] оригинальное имя файла большого изображения
    • $param['original_file_name_small_image'] оригинальное имя файла малого изображения
    • $param['use_big_image'] использовать большое изображение для создания малого (true - использовать (по умолчанию), false - не использовать)
    • $param['max_width_big_image'] значение максимальной ширины большого изображения
    • $param['max_height_big_image'] значение максимальной высоты большого изображения
    • $param['max_width_small_image'] значение максимальной ширины малого изображения;
    • $param['max_height_small_image'] значение максимальной высоты малого изображения;
    • $param['watermark_file_path'] путь к файлу с "водяным знаком"
    • $param['watermark_position_x'] позиция "водяного знака" по оси X
    • $param['watermark_position_y'] позиция "водяного знака" по оси Y
    • $param['used_watermark_big_image'] наложить "водяной знак" на большое изображение (true - наложить (по умолчанию), false - не наложить);
    • $param['used_watermark_small_image'] наложить "водяной знак" на малое изображение (true - наложить (по умолчанию), false - не наложить);
     об уже существующем продавце.
    • $param  int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_sallers_name'] = 'Новый продавец';
        5.

      5.  $param['shop_shops_id'] = 1;
        6.

      6.
        7.

      7.  $newid = $shop->InsertSeller($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $newid;
        11.

      11.  ?>
        12.

    Возвращает

    идентификатор вставленного или обновленного продавца.

    [ Наверх ]

    shop::InsertShop

InsertShop(
array
$param );

    Описание

    Вставка информации о магазине

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_id'] идентификатор магазина (указывается при обновлении)
    • int $param['shop_dir_id'] идентификатор раздела
    • string $param['name'] наименование магазина
    • int $param['site_id'] идентификатор сайта
    • string $param['description'] описание магазина
    • int $param['shop_items_on_page'] число товаров отображаемых на странице
    • int $param['shop_country_id'] идентификатор страны по умолчанию
    • int $param['shop_currency_id'] идентификатор валюты по умолчанию
    • int $param['shop_order_status_id'] идентификатор состояния заказа по умолчанию
    • int $param['shop_mesures_id'] идентификатор единицы измерения
    • int $param['structure_id'] идентификатор узла структуры
    • int $param['shop_access'] параметр, определяющий группу пользователей, имеющих доступ к магазину (0 - доступна всем)
    • int $param['shop_shops_send_order_mail_admin'] флаг необходимости отправки письма о заказе администратору
    • int $param['shop_shops_send_order_mail_user'] флаг необходимости отправки письма о заказе пользователю (заказчику)
    • string $param['shop_shops_admin_mail'] адрес(а) куратора(ов) магазина
    • int $param['shop_sort_order_field'] поле сортировки товара
    • int $param['shop_sort_order_type'] тип сортировки товара
    • int $param['shop_group_sort_order_field'] поле сортировки групп товара
    • int $param['shop_group_sort_order_type'] тип сортировки групп товара
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['shop_comment_active'] активность комментария к товару
    • int $param['shop_company_id'] идентификатор компании
    • string $param['watermark_file'] - файл марки для наложения на изображения
    • string $param['watermark_file_expantion'] - расширение файла марки для наложения
    • int $param['watermark_default_used'] - параметр, определяющий используется ли файл марки по умолчанию (1 - используется, 0 - не используется).
    • int $param['watermark_default_used_small'] - параметр, определяющий используется ли файл марки по умолчанию для малых изображений(1 - используется, 0 - не используется).
    • string $param['watermark_default_position_x'] - позиция изображения по оси X по умолчанию. по умолчанию равна 50%
    • string $param['watermark_default_position_y'] - позиция изображения по оси Y по умолчанию. по умолчанию равна 100%
    • int $param['shop_image_small_max_width'] максимальная ширина маленькой картинки
    • int $param['shop_image_big_max_width'] максимальная ширина большой картинки
    • int $param['shop_image_small_max_heigh'] максимальная высота маленькой картинки
    • int $param['shop_image_big_max_height'] максимальная высота большой картинки
    • int $param['shop_shops_default_save_proportions'] флаг, указывающий на необходимость сохранения пропорций изображений в магазине по умолчанию
    • int $param['shop_image_small_max_width_group'] максимальная ширина маленькой картинки для группы товаров
    • int $param['shop_image_big_max_width_group'] максимальная ширина большой картинки для группы товаров
    • int $param['shop_image_small_max_height_group'] максимальная высота маленькой картинки для группы товаров
    • int $param['shop_image_big_max_height_group'] максимальная высота большой картинки для группы товаров
    • int $param['shop_shops_yandex_market_name_group'] название магазина
    • string $param['shop_yandex_market_sales_notes_default'] значение по умолчанию тега <sales_notes>
    • int $param['shop_shops_url_type'] тип формирования URL
    • int $param['shop_typograph_item_by_default'] типографировать товары по умолчанию
    • int $param['shop_typograph_group_by_default'] типографировать групы товаров по умолчанию
    • int $param['shop_shops_apply_tags_automatic'] параметр, определяющий будут ли при добавлении товаров в случае отсутствия тегов автоматически формироваться теги для товаров из их названия, описания и текста
    • bool $param['shop_shops_attach_eitem'] флаг, указывающий вкладывать в сообщение файл электронного товара, или ссылку на файл. (1 - файл, 0 - ссылка. по умолчанию - 1)
    • int $param['shop_shops_writeoff_payed_items'] параметр, определяющий будет ли при оплате товаров уменьшаться их количество

       1 - теги формируются автоматически (по умолчанию), 0 - не формируюся автоматически
    • 0 - названия файлов не преобразуются, 1 - преобразуются (по умолчанию)

    Возвращает

    or boolean возвращает идентификационный номер вставленного магазина в случае успешного выполнения запроса или false в противном случае

    [ Наверх ]

    shop::InsertShopsDir

InsertShopsDir(
array
$param );

    Описание

    Добавление/обновление раздела иентернет-магазинов

    Принимаемые параметры

    $param

    масcив параметров
    • $param['shop_dir_id'] идентификатор редактируемого раздела информационных систем
    • $param['shop_dir_parent_id'] идентификатор родительского раздела информационных систем
    • $param['shop_dir_name'] название раздела информационных систем
    • $param['shop_dir_description'] описание раздела информационных систем
    • $param['site_id'] идентификатор сайта
    • $param['users_id'] идентификатор пользователя центра администрирования, если false - берется текущий пользователь.

    Возвращает

    идентификатор добавленного/обновленного раздела информационных систем в случае успешного выполнения,  false - в противном случае

    [ Наверх ]

    shop::InsertSiteUserAccountTransaction

InsertSiteUserAccountTransaction(

$param );

    Описание

    Вставка в базу данных транзакции по лицевому счету пользователя

    array $param ассоциативный массив параметров
    int $param['shop_site_users_account_id'] Идентификатор транзакции, необязательное поле, указывается при обновлении транзакции
    int $param['shop_shops_id'] Идентификатор магазина
    int $param['site_users_id'] Идентификатор пользователя сайта
    int $param['shop_site_users_account_active'] Активность транзакции (1 - Активна, 0 - Неактивна), необязательное поле, по умолчанию 1 - активна
    str $param['shop_site_users_account_datetime'] Время проведения транзакции, необязательное поле, по умолчанию указывается текущая дата
    int $param['shop_site_users_account_sum'] Сумма транзакции
    int $param['shop_currency_id'] Идентификатор валюты
    int $param['shop_site_users_account_sum_in_base_currency'] Сумма транзакции в базовой валюте
    int $param['shop_order_id'] Идентификатор заказа (Необязательно)
    str $param['shop_site_users_account_description'] Описание транзакции
    int $param['users_id'] Идентификатор пользователя центра администрирования
    int $param['shop_site_users_account_type'] Тип транзакции, 0 -  обычная, 1 - бонусное начисление
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_shops_id'] = 1;
      5.

    5.  $param['shop_site_users_account_sum'] = 1000;
      6.

    6.  $param['shop_currency_id'] = 1;
      7.

    7.  $param['shop_site_users_account_sum_in_base_currency'] = 1000;
      8.

    8.  $param['shop_site_users_account_description'] = 'Новая транзакция';
      9.

    9.  $param['site_users_id'] = 1;
      10.

    10.
      11.

    11.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      12.

    12.  if (class_exists('SiteUsers'))
      13.

    13.  {
      14.

    14.      $SiteUsers = & singleton('SiteUsers');
      15.

    15.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      16.

    16.  }
      17.

    17.  else
      18.

    18.  {
      19.

    19.      $site_users_id = 0;
      20.

    20.  }
      21.

    21.
      22.

    22.  $newid = $shop->InsertSiteUserAccountTransaction($param);
      23.

    23.
      24.

    24.  // Распечатаем результат
      25.

    25.  echo $newid;
      26.

    26.  ?>
      27.

    Принимаемые параметры

    $param

    Возвращает

    Идентификатор вставленной записи или false

    [ Наверх ]

    shop::InsertSpecialPrice

InsertSpecialPrice(
arr
$param );

    Описание

    Добавление информации о специальной цене

    Принимаемые параметры

    $param

    массив параметров
    • int $param['shop_special_prices_id'] идентификатор специальной цены
    • int $param['shop_items_catalog_item_id'] идентификатор товара, которому принадлежит специальная цена
    • int $param['shop_special_prices_from'] минимальное количество товара, с которого начинает действовать специальная цена
    • int $param['shop_special_prices_to'] максимальное количество товара, с которого начинает действовать специальная цена
    • int $param['shop_special_prices_price'] значение цены за один товар
    • int $param['shop_special_prices_percent'] процент от базовой цены

    Возвращает

    Идентификатор вставленной записи, либо код ошибки:
    false = ошибка вставки информации в БД
    -1 = произошло пересечение множеств, на которых доступна цена редактируемой цены с существующими (в этом случае происходит удаление редактируемой цены)
    -2 произошло пересечение множеств, на которых доступна цена добавляемой цены с существующими
    -3 некорректно задан интервал количества товаров редактируемой цены (в этом случае происходит удаление редактируемой цены)
    -4 некорректно задан интервал количества товаров при добавлении
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_items_catalog_item_id'] = 159;
      5.

    5.  $param['shop_special_prices_from'] = 55;
      6.

    6.  $param['shop_special_prices_to'] = 75;
      7.

    7.  $param['shop_special_prices_price'] = 400;
      8.

    8.
      9.

    9.  $newid = $shop->InsertSpecialPrice($param);
      10.

    10.
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    [ Наверх ]

    shop::InsertSystemOfPay

InsertSystemOfPay(
array
$param );

    Описание

    Метод, осуществляющий вставку платёжной системы

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор платёжной системы
    • string $param['name'] название платёжной системы
    • string $param['description'] описание платёжной системы
    • int $param['shop_shops_id'] идентификатор родительского магазина
    • int $param['is_active'] активна ли платёжная система
    • string  $param['handler'] обработчик платёжной системы
    • int $param['currency_id'] номер валюты
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['shop_system_of_pay_order'] Порядок сортировки

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['name'] = 'New';
        5.

      5.
        6.

      6.  $system_of_pay_id = $shop->InsertSystemOfPay($param);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $system_of_pay_id;
        10.

      10.  ?>
        11.

    Возвращает

    идентификатор вставленной платёжной системы

    [ Наверх ]

    shop::InsertTax

InsertTax(
array
$param );

    Описание

    Метод, осуществляющий вставку налога

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_tax_id'] идентификационный номер налога
    • string $param['shop_tax_name'] название налога
    • double $param['shop_tax_rate'] ставка налога
    • int $param['shop_tax_is_in_price'] входит ли налог в цену (0 - не входит, 1 - входит)
    • int $param['shop_tax_cml_id'] CML идентификатор налога, необязательный параметр
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_tax_name'] = 'Новый налог';
        5.

      5.  $param['shop_tax_rate'] = '18';
        6.

      6.
        7.

      7.  $newid = $shop->InsertTax($param);
        8.

      8.
        9.

      9.  // Распечатаем ID нового налога
        10.

      10.  echo $newid;
        11.

      11.  ?>
        12.

    Возвращает

    идентификатор вставленного налога

    [ Наверх ]

    shop::InsertToCart

InsertToCart(
array
$param );

    Описание

    Метод добавления информации о товаре в таблицу корзины

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • $param['user_id'] int идентификатор пользователя (при значение 0 или false - данные вставляем в кукисы)
    • $param['shop_id'] int идентификатор магазина
    • $param['item_id'] int идентификатор товара
    • $param['postpone'] int флаг, указывающий на то является ли данный товар отложенным
    • $param['count'] int колитчество заказываемого товара
    • $param['warehouse_id'] int идентификатор склада
    • $param['get_info_isset_shop'] boolean флаг необходимости проверки наличия магазина

    Возвращает

    идентификатор вставленной записи или идентификатор единицы каталога, если вставка осуществлялась в кукисы, возвращает ложь в случае возникновения ошибки

    [ Наверх ]

    shop::InsertTreeGroup

InsertTreeGroup(
$parant_group_id
$cur_parent_id, $array
$shop_shops_id,
&$metadata );

    Описание

    Вставки дерева групп для CML v. 2.0x

    Принимаемые параметры

    $cur_parent_id

    родительская группа

    $shop_shops_id

    массив с иерархической структурой групп

    &$metadata

    [ Наверх ]

    shop::InsertTyingProducts

InsertTyingProducts(
array
$param );

    Описание

    Метод добавления информации о сопутствующем товаре

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_intermediate_id'] идетификатор записи о сопутствующем товаре
    • int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вводится сопутствующий товар
    • int $param['sho_shop_items_catalog_item_id'] идентификатор сопутствующего товара

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_items_catalog_item_id'] = 159;
        5.

      5.  $param['sho_shop_items_catalog_item_id'] = 167;
        6.

      6.  $param['shop_intermediate_count'] = 1;
        7.

      7.
        8.

      8.  $newid = $shop->InsertTyingProducts($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.
        13.

      13.  ?>
        14.

    [ Наверх ]

    shop::InsertTypeOfDelivery

InsertTypeOfDelivery(
array
$param );

    Описание

    Метод, осуществляющий вставку типа доставки

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_shops_id'] идентификатор магазина
    • int $param['id'] идентификатор типа доставки
    • string $param['name'] название типа доставки
    • string $param['description'] описание типа доставки
    • string $param['image'] путь к логотипу службы доставки
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['shop_type_of_delivery_order'] порядок сортировки элемента

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['name'] = 'Самовывоз';
        5.

      5.  $param['shop_shops_id'] = 1;
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.      $SiteUsers = & singleton('SiteUsers');
        11.

      11.     $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12. }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $newid = $shop->InsertTypeOfDelivery($param);
        19.

      19.
        20.

      20.  // Распечатаем результат
        21.

      21.  echo $newid;
        22.

      22.  ?>
        23.

    Возвращает

    идентификатор вставленного типа доставки

    [ Наверх ]

    shop::IsOrderOfThisSiteUser

IsOrderOfThisSiteUser(
int
$shop_order_id, int
$site_users_id );

    Описание

    Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта

    Принимаемые параметры

    $shop_order_id

    идентификатор заказа

    $site_users_id

    идентификатор пользователя
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 48;
      5.

    5.
      6.

    6.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      7.

    7.  if (class_exists('SiteUsers'))
      8.

    8.  {
      9.

    9.      $SiteUsers = & singleton('SiteUsers');
      10.

    10.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      $site_users_id = 0;
      15.

    15.  }
      16.

    16.
      17.

    17.  $row = $shop->IsOrderOfThisSiteUser($shop_order_id, $site_users_id);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  print_r ($row);
      21.

    21.  ?>
      22.

    [ Наверх ]

    shop::IssetAccessForShopGroup

IssetAccessForShopGroup(
array
$param );

    Описание

    Проверка возможности доступа пользователя к группе товаров

    Принимаемые параметры

    $param

    ассоциативный массив с параметров
    • $param['site_users_id'] идентификатор пользователя
    • $param['shop_group_id'] идентификатор группы товаров
    • $param['shop_id'] идентификатор магазина, не обязательный параметр, по умолчанию 0
    • $param['shop_group_info'] ассоциативный массив с информацией о группе, по умолчанию пустой
    • $param['cache'] использовать кэширование, по умолчанию true

    [ Наверх ]

    shop::IssetPropertyForGroup

IssetPropertyForGroup(
array
$param );

    Описание

    Определение принадлежности дополнительного свойства группе товаров

    Принимаемые параметры

    $param

    массив атрибутов
    int $param['shop_groups_id'] Идентификатор каталога товаров
    int $param['shop_list_of_properties_id'] Идентификатор дополнительного свойства
    int $param['shop_shops_id'] Идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $param['shop_groups_id'] = 589;
      5.

    5.  $param['shop_list_of_properties_id'] = 135;
      6.

    6.  $param['shop_shops_id'] = 1;
      7.

    7.
      8.

    8.  $row = $shop->IssetPropertyForGroup($param);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

    shop::ProcessOrder

ProcessOrder(
int
$shop_id, int
$site_users_id, int
$system_of_pay_id, array
&$order_row, [array
$param = array()] );

    Описание

    Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя сайта, если false - определяем внутри метода

    $system_of_pay_id

    идентификатор системы оплаты

    &$order_row

    ВОЗВРАЩАЕТ информацию о заказе, в случае успешной вставки, иначе - false  Может принимать значения:
    $order_row['status_of_pay'] - статус платежа, по умолчанию 0;
    $order_row['date_of_pay'] - дата платежа, по умолчанию пустая строка;
    $order_row['description'] - описание и системная информация, по умолчанию пустая строка.

    $param

    массив дополнительных параметров
    • $param['ignore_delivery_price'] игнорировать нулевую цену доставки и добавлять ее в любом случае
    • $param['discount_name'] наименование скидки для включения в товары заказа, если не указано, то используется "Скидка"

    Возвращает

    результат выполнения метода,
    • идентификатор добавленного заказа в случае успеха
    • -1 ошибка вставки в БД
    • -2 возможно не найден магазин
    • -3 корзина пуста

    [ Наверх ]

    shop::RamblerPokupki

RamblerPokupki(
int
$shop_shops_id, [array
$external_properties = array ()] );

    Описание

    Вывод данных для эксопрта в RamblerPokupki. Метод отправляет соответствующий заголовок и возвращает XML данные.

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $external_properties

    массив с внешними свойствами
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $xml = $shop->RamblerPokupki($shop_shops_id);
      7.

    7.
      8.

    8.  echo $xml;
      9.

    9.
      10.

    10.  exit();
      11.

    11.  ?>
      12.

    Возвращает

    данные в формате XML

    [ Наверх ]

    shop::Round

Round(
float
$float );

    Описание

    Округление цен к формату, приведенного в $this->float_format

    Принимаемые параметры

    $float

    цена

    [ Наверх ]

    shop::SearchIndexing

SearchIndexing(
$limit
$limit, $on_step
$on_step );

    Описание

    Функция обратного вызова для поисковой индексации данных модуля

    Принимаемые параметры

    $limit

    текущая позиция

    $on_step

    шаг

    [ Наверх ]

    shop::SelectAllItemsFromCartForUser

SelectAllItemsFromCartForUser(
int
$shop_id, int
$site_users_id );

    Описание

    Получение суммы налога, количества элементов и их общей цены для заданного пользователя

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $site_users_id = 19;
      6.

    6.
      7.

    7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
      8.

    8.  if (class_exists('SiteUsers'))
      9.

    9.  {
      10.

    10.      $SiteUsers = & singleton('SiteUsers');
      11.

    11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.     $site_users_id = 0;
      16.

    16.  }
      17.

    17.
      18.

    18.  $row = $shop->SelectAllItemsFromCartForUser($shop_id, $site_users_id);
      19.

    19.
      20.

    20.  // Распечатаем результат
      21.

    21.  print_r ($row);
      22.

    22.  ?>
      23.

    Возвращает

    ассоциативный массив, где элемент с индексом 'price' - общая цена товаров, а элемент с индексом 'quantity' - общее число товаров

    [ Наверх ]

    shop::SelectAllItemsFromCookieCart

SelectAllItemsFromCookieCart(
int
$shop_shops_id );

    Описание

    Получение общего количества товаров, их общей стоимости и веса из корзины

    (в случае, когда пользователь не задан и данные корзины хранятся в кукисах)

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $row = $shop->SelectAllItemsFromCookieCart($shop_shops_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::SelectCityArea

SelectCityArea(
int
$city_area_id, [int
$city_id = 0] );

    Описание

    Получение информации о районе города (обо всех районах при $city_area_id=-1)

    Принимаемые параметры

    $city_area_id

    идентификатор района (при $city_area_id=-1 выбираем все районы)

    $city_id

    идентификатор города
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $city_area_id = -1;
      5.

    5.  $city_id = 1;
      6.

    6.
      7.

    7.  $result = $shop->SelectCityArea($city_area_id, $city_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($result))
      11.

    11.  {
      12.

    12.      print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    информация о выбранных районах города (результат запроса) или ложь в случае возникновения ошибки

    [ Наверх ]

    shop::SelectGroupsByName

SelectGroupsByName(
int
$shop_shops_id, str
$shop_groups_name, [int
$shop_groups_parent_id = false] );

    Описание

    Получение информации обо всех группах магазина, имеющих название $shop_groups_name

    Принимаемые параметры

    $shop_shops_id

    Идентификатор магазина

    $shop_groups_name

    Название группы

    $shop_groups_parent_id

    Идентификатор родительской группы (не обязательный параметр)

    [ Наверх ]

    shop::SelectPrice

SelectPrice(
int
$user_group_id, int
$shop_shops_id );

    Описание

    Метод определения цены для заданной группы пользователей

    Принимаемые параметры

    $user_group_id

    идентификатор группы пользователей

    $shop_shops_id

    идентификатор интернет-магазина

    Возвращает

    or false массив информации о цене

    [ Наверх ]

    shop::SendMailAboutOrder

SendMailAboutOrder(
int
$shop_id, int
$shop_order_id, int
$site_user_id, [string
$xsl_name_for_admin = ''], [string
$xsl_name_for_user = ''], [string
$custom_email = false], [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Метод отправки писем о поступившем заказе пользователю и администратору

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $shop_order_id

    идентификатор заказа

    $site_user_id

    идентификатор пользователя

    $xsl_name_for_admin

    имя XSL шаблона для письма администратору

    $xsl_name_for_user

    имя XSL шаблона для письма пользователю

    $custom_email

    e-mail заказчика, если задан, то берется из этого параметра, а не из БД

    $param

    массив дополнительных атрибутов
    • $param['admin-content-type'] - Content-Type для письма администратору. Возможные варианты: text и html, по умолчанию text.
    • $param['user-content-type'] - Content-Type для письма пользователю. Возможные варианты: text и html, по умолчанию text.
    • $param['admin-subject'] - тема письма администратору, по умолчанию "В Интернет магазин поступил заказ"
    • $param['user-subject'] - тема письма пользователю, по умолчанию "Информация о заказе"
    • $param['email_to'] - электронный адрес получателя (можно указать несколько адресов через запятую). Не обязательный параметр, по умолчанию - адрес куратора магазина.
    • $param['email_from'] - электронный адрес отправителя для письма пользователю (можно указать несколько адресов через запятую). Не обязательный параметр, по умолчанию - адрес куратора магазина.
    • $param['email_from_admin'] - электронный адрес отправителя для письма администратору (можно указать несколько адресов через запятую). Не обязательный параметр, по умолчанию - адрес куратора магазина.
    • $param['header'] - массив дополнительных заголовков для метода отправки письма kernel::SendMailWithFile()
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа
    • $param['array_of_files'] - массив файлов для отправки методом kernel::SendMailWithFile

    $external_propertys

    массив внешних данных для включения в XML

    [ Наверх ]

    shop::SetCart

SetCart(
array
$CART );

    Описание

    Сохранение корзины в зависимости от CartType

    Принимаемые параметры

    $CART

    содержимое корзины

    [ Наверх ]

    shop::SetCookie

SetCookie(
string
$name, string
$value, int
$expire, [string
$path = '/'] );

    Описание

    Установка значения cookie

    Принимаемые параметры

    $name

    наименование cookie

    $value

    значение

    $expire

    период действия

    $path

    путь

    [ Наверх ]

    shop::SetCookieCart

SetCookieCart(
string
$value, int
$expire, [string
$path = '/'] );

    Описание

    Отправить в cookies содержимое корзины

    Принимаемые параметры

    $value

    значение

    $expire

    период действия

    $path

    путь

    [ Наверх ]

    shop::SetCountAllComments

SetCountAllComments(
int
$count_comments );

    Описание

    Установление числа комментариев к товарам

    Принимаемые параметры

    $count_comments

    общее число комментариев к товарам

    [ Наверх ]

    shop::SetOrderPaymentStatus

SetOrderPaymentStatus(
int
$shop_order_id );

    Описание

    Изменение статуса оплаты заказа

    Принимаемые параметры

    $shop_order_id

    Идентификатор заказа

    Возвращает

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_order_id = 38;
      5.

    5.
      6.

    6.  $newid = $shop->SetOrderPaymentStatus($shop_order_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::SetSessionCart

SetSessionCart(
string
$value );

    Описание

    Отправить в session содержимое корзины

    Принимаемые параметры

    $value

    значение

    [ Наверх ]

    shop::SetUnload

SetUnload(
int
$order_id, int
$status );

    Описание

    Установка статуса выгрузки заказа

    Принимаемые параметры

    $order_id

    идентификатор заказа

    $status

    (0 или 1) статус

    [ Наверх ]

    shop::ShowAddress

ShowAddress(
string
$xsl_name, int
$shop_id, [array
$param = array()], [array
$external_propertys = array()] );

    Описание

    Метод показа адреса для заказчика

    Принимаемые параметры

    $xsl_name

    имя XSL-шаблона

    $shop_id

    идентификатор магазина

    $param

    массив допольнительных параметров
    • $param['show_country'] добавлять в XML список стран, по умолчанию true
    • $param['show_location'] добавлять в XML список областей, по умолчанию true
    • $param['show_city'] добавлять в XML список городов, по умолчанию true
    • $param['show_city_area'] добавлять в XML список районов городов, по умолчанию true
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа

    $external_propertys

    массив внешних данных для включения в XML

    [ Наверх ]

    shop::ShowCart

ShowCart(
int
$shop_id, [int
$site_users_id = false], string
$xsl_name, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Метод показа содержимого корзины

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $site_users_id

    идентификатор пользователя, если false - определяем пользователя внутри метода.

    $xsl_name

    имя XSL-шаблона

    $param

    массив дополнительных параметров
    • $param['shop_coupon_text'] - текст купона
    • $param['xml_show_group_type'] - метод отображения групп товаров, по умолчанию 'none'
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа
    • $param другие параметры, указанные для GetGroupsXmlTree()

    $external_propertys

    массив внешних данных для включения в XML

    see

    shop::GetGroupsXmlTree()

    [ Наверх ]

    shop::ShowConfirmation

ShowConfirmation(
string
$xsl_name, [array
$external_propertys = array ()] );

    Описание

    Метод вывода сообщения о необходимости подтвердить аккаунт

    Принимаемые параметры

    $xsl_name

    наименование xsl-шаблона

    $external_propertys

    массив внешних данных для включения в XML

    [ Наверх ]

    shop::ShowEnter

ShowEnter(
string
$xsl_name, [array
$external_propertys = array ()] );

    Описание

    Метод вывода формы для авторизации пользователя

    Принимаемые параметры

    $xsl_name

    наименование xsl-шаблона в соответствии, с которым выводим данные

    $external_propertys

    массив внешних данных для включения в XML

    [ Наверх ]

    shop::ShowItem

ShowItem(
int
$item_id, string
$xsl_name, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Метод вывода информации о товаре

    Принимаемые параметры

    $item_id

    идентификатор товара

    $xsl_name

    название XSL шаблона

    $param

    доп. параметры
    • $param['cache'] Флаг, указывающий, можно ли брать информацию с кэша (по умолчанию - true)
    • $param['current_group_id'] mixed идентификатор раздела магазина или массив идентификаторов
    • $param['user_id'] идентификатор пользователя
    • $param['group_field_order'] поле сортировки группы
    • $param['group_order'] направление сортировки группы ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)
    • $param['xml_show_group_property'] разрешает указание в XML значений свойств групп магазина, по умолчанию true
    • $param['show_text'] параметр, указывающий включать в XML текст товара или нет, по умолчанию равен true
    • $param['xml_show_tying_products'] разрешает указание в XML сопутствующих товаров, по умолчанию true
    • $param['xml_show_modification'] разрешает указание в XML модификаций товаров, по умолчанию true
    • $param['xml_show_group_property_id'] массив идентификаторов дополнительных свойств для отображения в XML. Если не не передано - выводятся все свойства
    • $param['xml_show_comments'] разрешает добавление в XML отзывов о товаре, по умолчанию true
    • $param['xml_show_items_property_dir'] разрешает генерацию в XML групп свойств товаров, по умолчанию true
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа
    • $param['xml_show_group_type'] тип генерации XML для групп, может принимать значения (по умолчанию 'tree'):

      • all - все группы всех уровней;
      • current - группы только текущего уровня;
      • tree - группы, находящиеся выше по дереву;
      • none - не выбирать группы.

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $item_id = 159;
      5.

    5.  $xsl_name = 'МагазинТовар';
      6.

    6.
      7.

    7.  $shop->ShowItem($item_id, $xsl_name);
      8.

    8.
      9.

    9.  ?>
      10.

    [ Наверх ]

    shop::ShowItemsCompare

ShowItemsCompare(
int
$shop_id, string
$xsl_name, [$param
$param = array()], [array
$external_propertys = array ()] );

    Описание

    Метод отображает сравнение выбранных товаров в магазине

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $xsl_name

    имя XSL-шаблона

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $xsl_name= 'СравнениеТоваров';
      6.

    6.
      7.

    7.  $shop->ShowItemsCompare($shop_id, $xsl_name);
      8.

    8.  ?>
      9.

    $param

    массив дополнительных параметров
    • $param['xml_show_group_property'] разрешает указание в XML значений свойств групп магазина, по умолчанию true
    • $param['xml_show_item_property'] разрешает указание в XML значений свойств товаров магазина, по умолчанию true
    • $param['xml_show_group_type'] тип генерации XML для групп, может принимать значения (по умолчанию 'tree'):

    Возвращает

    в случае неудачи

    [ Наверх ]

    shop::ShowPriceList

ShowPriceList(

$shop_id );

    Принимаемые параметры

    $shop_id

    [ Наверх ]

    shop::ShowProducersList

ShowProducersList(
string
$xsl_name, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Метод формирования xml для производителей

    Принимаемые параметры

    $xsl_name

    имя XSL шаблона

    $param

    массив дополнительных параметров

    • $param['shop_id'] идентификатор магазина
    • $param['current_group_id'] идентификатор или группа идентификаторов группы магазина, для товаров из которой необходимо получить производителей. Необязательно для заполнения
    • $param['begin'] начальная позиция выбора производителей
    • $param['count'] количество отображаемых производителей

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $xsl_name = 'МагазинСписокПроизводителей';
      5.

    5.  $param['shop_id'] = 1;
      6.

    6.
      7.

    7.  $shop->ShowProducersList($xsl_name, $param);
      8.

    8.
      9.

    9.  ?>
      10.

    see

    shop::GenXmlProducerList()

    [ Наверх ]

    shop::ShowSaller

ShowSaller(
int
$shop_sallers_id, string
$xsl_name );

    Описание

    Метод для отображение информации о продавце в клиентской части

    Принимаемые параметры

    $shop_sallers_id

    идентификатор продавца

    $xsl_name

    имя XSL шаблона

    [ Наверх ]

    shop::ShowShop

ShowShop(
int
$shop_id, string
$xsl_name, [array
$param = array()], [array
$external_propertys = array()] );

    Описание

    Показ магазина (товаров и групп).

    Принимаемые параметры

    $shop_id

    идентификатор магазина

    $xsl_name

    имя XSL-шаблона

    $param

    ассоциативный массив параметров
    • $param['current_group_id'] mixed идентификатор раздела магазина или массив идентификаторов, товары которого отображаются, если $param['current_group_id'] = false, то отображаются элементы всех групп
    • $param['shop_groups_parent_id'] идентификатор или массив идентификаторов родительской группы, влияющее на ограничние выборки групп магазина
    • $param['items_begin'] номер товара в выборке, с которого начинать отображение товаров магазина
    • $param['items_on_page'] число товаров, отображаемых на странице
    • $param['items_field_order'] поле сортировки товаров каталога, при сортировке по средней оценке товара указывается поле 'shop_comment_grade' (начиная с версии 5.1.2)
    • $param['items_order'] направление сортировки ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)
    • $param['user_id'] идентификатор пользователя
    • $param['group_field_order'] поле сортировки группы
    • $param['group_order'] направление сортировки группы ('Asc' - по возрастанию, 'Desc' - по убыванию, 'Rand' - произвольный порядок)
    • $param['dec_reques_number'] использовать режим снижения количесва запросов, актуален для больших выборок
    • $param['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
    • $param['select_discount'] массив ID скидок, с учетом которых должны выбираться товары из каталога
    • $param['cache'] разрешение кэширования, по умолчанию true
    • $param['select'] массив массивов $element, каждый из которых задает дополнительные условия отбора товаров
    • $param['show_text'] параметр, указывающий включать в XML текст товара или нет, по умолчанию равен true
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа
    • $param['xml_show_all_producers'] отображать всех производителей магазина
    • $param['xml_show_producers'] отображать производителей магазина, по умолчанию true
    • $param['xml_show_all_sellers'] отображать всех продавцов магазина
    • $param['xml_show_tying_products'] разрешает указание в XML сопутствующих товаров, по умолчанию true
    • $param['xml_show_modification'] разрешает указание в XML модификаций товаров, по умолчанию true
    • $param['xml_show_group_property'] разрешает указание в XML значений свойств групп магазина, по умолчанию true
    • $param['xml_show_group_property_id'] массив идентификаторов дополнительных свойств групп для отображения в XML. Если не не передано - выводятся все свойства
    • $param['xml_show_item_property'] разрешает указание в XML значений свойств товаров магазина, по умолчанию true
    • $param['xml_show_item_property_id'] массив идентификаторов дополнительных свойств товара для отображения в XML. Если не не передано - выводятся все свойства
    • $param['xml_show_tags'] разрешает генерацию в XML облака тегов магазина, по умолчанию false
    • $param['xml_show_group_id'] массив идентификаторов групп для отображения в XML. Если не не передано - выводятся все группы
    • $param['xml_show_items_property_dir'] разрешает генерацию в XML групп свойств товаров, по умолчанию true
    • $param['xml_show_group_type'] тип генерации XML для групп, может принимать значения (по умолчанию 'tree'):

      • all - все группы всех уровней;
      • current - только непосредственные подгруппы текущей группы;
      • tree - группы, находящиеся от текущей выше и ниже по дереву;
      • none - не выбирать группы.

    • $element['type'] определяет, является ли поле основным свойством товара или дополнительным (0 - основное, 1 - дополнительное)
    • $element['prefix'] префикс - строка, размещаемая перед условием
    • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    • $element['property_id'] идентификатор дополнительногого свойства
    • $element['if'] строка, содержащая условный оператор
    • $elemenr['value'] значение поля (или параметра)
    • $element['sufix'] суффикс - строка, размещаемая после условия

      Например:

      1. $element = array();
        2.

      2.  $element['type']=1; // 0 - основное св-во, 1 - дополнительное
        3.

      3.  $element['prefix'] = 'and'; // префикс
        4.

      4.  $element['property_id'] = 26; // ID дополнительного св-ва, указывается если тип = 1
        5.

      5.  $element['if'] = '='; // Условие
        6.

      6.  $element['value'] = '10';
        7.

      7.  $element['sufix'] = '';
        8.

      8.  $param['select'][]=$element; // Указываем очередное ограничение, введенное выше
        9.

      9.
        10.

      10.  $element = array();
        11.

      11.  $element['type']=1; // 0 - основное св-во, 1 - дополнительное
        12.

      12.  $element['prefix'] = 'and'; // префикс
        13.

      13.  $element['property_id'] = 28; // ID дополнительного св-ва, указывается если тип = 1
        14.

      14.  $element['if'] = '='; // Условие
        15.

      15.  $element['value'] = 1;
        16.

      16.  $element['sufix'] = '';
        17.

    • $param['select'][]=$element; // Указываем очередное ограничение, введенное выше
    • $param['show_catalog_item_type'] array массив типов товаров, которые должны отображаться.
     Может содержать следующие элементы:
      • active - активные элементы (внесен по умолчанию, если $param['show_catalog_item_type'] не задан;
      • inactive - неактивные элементы;
      • putend_date - элементы, у которых значение поля putend_date меньше текущей даты;
      • putoff_date - элементы, у которых значение поля putoff_date превышает текущую дату;
    $param['select_groups'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора групп магазина
      • $element['type'] определяет, является ли поле основным свойством группы магазина или дополнительным (0 - основное, 1 - дополнительное)
      • $element['prefix'] префикс - строка, размещаемая перед условием
      • $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
      • $element['property_id'] идентификатор дополнительногого свойства групп магазина
      • $element['if'] строка, содержащая условный оператор
      • $element['value'] значение поля (или параметра)
      • $element['sufix'] суффикс - строка, размещаемая после условия

    • $param['TagsOrder'] параметр, определяющий порядок сортировки тегов. Принимаемые значения: ASC - по возрастанию (по умолчанию), DESC - по убыванию
    • $param['TagsOrderField'] поле сортировки тегов, если случайная сортировка, то записать RAND(). по умолчанию теги сортируются по названию.
    • $param['sql_external_select'] параметр, задающий список дополнительных полей в оператор SELECT выборки товаров
      Пример ограничения выборки групп:
    1.  <?php
      2.

    2.  $shop= & singleton('shop');
      3.

    3.
      4.

    4.  $param = array();
      5.

    5.  // Заполняем первое условие
      6.

    6.  $element['type'] = 0;
      7.

    7.  $element['prefix'] = ' and ';
      8.

    8.  $element['name'] = 'shop_groups_order';
      9.

    9.  $element['if'] = '>';
      10.

    10.  $element['value'] = '30';
      11.

    11.  $element['sufix'] = '';
      12.

    12.  $param['select_groups'][] = $element;
      13.

    13.
      14.

    14.  // Заполняем второе условие, в данном случае по значению дополнительного св-ва. Используется, если условие не должно содержать диапазона допустимых значений доп. свойства.
      15.

    15.  $element['type'] = 1;
      16.

    16.  $element['prefix'] = 'and';
      17.

    17.  $element['property_id'] = 7;
      18.

    18.  $element['if'] = '=';
      19.

    19.  $element['value'] = '10';
      20.

    20.  $element['sufix'] = '';
      21.

    21.  $param['select_groups'][] = $element;
      22.

    22.
      23.

    23.  // Если во втором условии используется доп. свойство, содержащее числовые значения и в условии необходимо указать
      24.

    24.  // диапазон значений, то вместо приведенной выше конструкции в качестве второго условия необходимо использовать следующий код
      25.

    25.  // Ограниение для дополнительного свойства содержащего числовые значения целого и/или вещественного типа
      26.

    26.  $element['property_id'] = 7;
      27.

    27.  $element['type'] = 1;
      28.

    28.  $element['prefix'] = ' AND';
      29.

    29.  $element['if'] = '!=';
      30.

    30.  // Указываем идентификатор магазина, для которого производится отбор товаров
      31.

    31.  $element['value'] = '';
      32.

    32.  // Указываем идентификатор дополнительного свойства, по значениям которого производиться отбор записей,
      33.

    33.  // а также нижняя границы допустимых значений дополнительного свойства
      34.

    34.  $element['sufix'] = " AND shop_list_of_properties_table.shop_list_of_properties_id='". $element['property_id'] ."' AND (REPLACE(shop_properties_items_table.shop_properties_items_value, ',', '.') + 0.0) >= 3 AND (REPLACE(shop_properties_items_table.shop_properties_items_value, ',', '.') + 0.0) <= 40.5";
      35.

    35.  $param['select'][] = $element;
      36.

    36.
      37.

    37.  $param['current_group_id'] = 0;
      38.

    38.  $param['items_begin'] = 0;
      39.

    39.  $param['items_on_page'] = 10;
      40.

    40.  // Выводим элементы
      41.

    41.  $shop->ShowShop(1, 'МагазинКаталогТоваров',  $param);
      42.

    42.  ?>
      43.

    Пример использования ограничения по 2-м дополнительным свойствам товара:
    1.  <?php
      2.

    2.  $shop = & singleton('shop');
      3.

    3.  $param = array()
      4.

    4.
      5.

    5.  // Ограничение по цвету
      6.

    6.  $element['type'] = 1; // 0 - основное св-во, 1 - дополнительное
      7.

    7.  $element['property_id'] = 159;
      8.

    8.  $element['prefix'] = ' AND ('; // префикс
      9.

    9.  $element['if'] = '='; // Условие
      10.

    10.  $element['value'] = '10';  //
      11.

    11.  $element['sufix'] = '';
      12.

    12.  $param['select'][] = $element;
      13.

    13.  // Ограничение по флажку
      14.

    14.  $element['type'] = 1; // 0 - основное св-во, 1 - дополнительное
      15.

    15.  $element['property_id'] = 183;
      16.

    16.  $element['prefix'] = ' OR '; // префикс
      17.

    17.  $element['if'] = '='; // Условие
      18.

    18.  $element['value'] = '1';  //
      19.

    19.  $element['sufix'] = ' ) ';
      20.

    20.  $param['select'][] = $element;
      21.

    21.
      22.

    22.  $param['sql_group_by'] = "GROUP BY shop_items_catalog_table.shop_items_catalog_item_id ";
      23.

    23.  $param['sql_having'] = "HAVING COUNT(shop_properties_items_table.shop_properties_items_id) = 2";
      24.

    24.
      25.

    25.  $shop->ShowShop(1,'МагазинКаталогТоваров', $param);
      26.

    26.  ?>
      27.

    Пример использования сортировки товара по значению дополнительнго свойства:
    1.  <?php
      2.

    2.  $shop = & singleton('shop');
      3.

    3.
      4.

    4.  $param = array();
      5.

    5.  $external_propertys = array();
      6.

    6.
      7.

    7.  $param['current_group_id'] = false;
      8.

    8.  $param['xml_show_group_type'] = 'all';
      9.

    9.  $param['items_on_page'] = 10;
      10.

    10.   // Ограничение по дате
      11.

    11.  $element['type'] = 1; // 0 - основное св-во, 1 - дополнительное
      12.

    12.  $element['property_id'] = 194;
      13.

    13.  $element['prefix'] = ' AND '; // префикс
      14.

    14.  $element['if'] = '!='; // Условие
      15.

    15.  $element['value'] = "''";  //
      16.

    16.  $element['sufix'] = '';
      17.

    17.  $param['select'][] = $element;
      18.

    18.  // Сортируем как строку
      19.

    19.  //$param['items_field_order'] = ' shop_properties_items_table.shop_properties_items_value';
      20.

    20.  // Сортируем как число
      21.

    21.  //$param['items_field_order'] = ' CONVERT(shop_properties_items_table.shop_properties_items_value, UNSIGNED)';
      22.

    22.  // Сортируем как ДатуВремя
      23.

    23.  //$param['items_field_order'] = " CONVERT(CONCAT(SUBSTRING(shop_properties_items_value, 7, 4), CHAR(45), SUBSTRING(shop_properties_items_value, 4, 2), CHAR(45), SUBSTRING(shop_properties_items_value, 1, 2), CHAR(32), SUBSTRING(shop_properties_items_value, 12, 8)) , DATETIME)";
      24.

    24.  // Сортируем как Дату
      25.

    25.  $param['items_field_order'] = " CONVERT(CONCAT(SUBSTRING(shop_properties_items_value, 7, 4), CHAR(45), SUBSTRING(shop_properties_items_value, 4, 2), CHAR(45), SUBSTRING(shop_properties_items_value, 1, 2)),  DATE)";
      26.

    26.  $param['items_order'] = 'ASC';
      27.

    27.
      28.

    28.  $shop->ShowShop(1,'МагазинКаталогТоваров', $param);
      29.

    29.  ?>
      30.

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $xsl_name = 'МагазинКаталогТоваров';
      6.

    6.
      7.

    7.  $shop->ShowShop($shop_id, $xsl_name);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::ShowShops

ShowShops(
int
$site_id, str
$xsl_name, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Показ списка магазинов

    Принимаемые параметры

    $site_id

    Идентификатор сайта

    $xsl_name

    Имя xsl шаблона

    $param

    массив параметров

    $external_propertys

    массив внешних данных для включения в XML

    Возвращает

    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.  $xsl_name = 'СписокМагазинов';
      6.

    6.
      7.

    7.  $shop->ShowShops($site_id, $xsl_name);
      8.

    8.  ?>
      9.

    [ Наверх ]

    shop::ShowSiteUsersAccount

ShowSiteUsersAccount(
array
$param );

    Описание

    Отображение списка лицевых счетов пользователя

    Принимаемые параметры

    $param

    массив атрибутов
    • $param['site_users_id'] идентификатор пользователя, необязательный параметр. Если не передан - определяется автоматически.
    • $param['site_id'] идентификатор сайта, необязательный параметр. Если не передан - определяется автоматически.
    • $param['xsl_name'] наименование XSL-шаблона

      1.  $shop = new shop();
        2.

      2.
        3.

      3.  $param['site_users_id'] = 1;
        4.

      4.  $param['site_id'] = 1;
        5.

      5.  $param['xsl_name'] = 'СписокЛицевыхСчетов ';
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.      $SiteUsers = & singleton('SiteUsers');
        11.

      11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $shop->ShowSiteUsersAccount($param);
        19.

      19.  ?>
        20.

    [ Наверх ]

    shop::ShowSiteUsersAccountTransaction

ShowSiteUsersAccountTransaction(
array
$param );

    Описание

    Отображение списка транзакций пользователя

    Принимаемые параметры

    $param

    массив атрибутов
    • $param['site_users_id'] идентификатор пользователя, необязательный параметр. Если не передан - определяется автоматически.
    • $param['shop_shops_id'] идентификатор магазина
    • $param['xsl_name'] наименование XSL-шаблона

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_shops_id'] = 1;
        5.

      5.  $param['xsl_name'] = 'ДвиженияПоЛицевомуСчету';
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.      $SiteUsers = & singleton('SiteUsers');
        11.

      11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.     $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $shop->ShowSiteUsersAccountTransaction($param);
        19.

      19.  ?>
        20.

    [ Наверх ]

    shop::ShowSystemOfPay

ShowSystemOfPay(
string
$xsl_name, [array
$external_propertys = array ()], [array
$param = array()] );

    Описание

    Метод построения XML для платежных систем

    Принимаемые параметры

    $xsl_name

    имя XSL шаблона

    $external_propertys

    массив внешних данных для включения в XML

    $param

    массив дополнительных  параметров
    • $param['shop_shops_id'] int Идентификатор магазина для выбора платежных систем
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $xsl_name = 'МагазинПлатежнаяСистема';
        5.

      5.
        6.

      6.  $shop->ShowSystemOfPay($xsl_name);
        7.

      7.
        8.

      8.  ?>
        9.

    [ Наверх ]

    shop::ShowTagsCloud

ShowTagsCloud(
int
$shop_id, str
$xsl_name, [array
$property = array ()], [array
$external_propertys = array ()] );

    Описание

    Показ облака тегов для магазина

    Принимаемые параметры

    $shop_id

    Идентификатор магазина

    $xsl_name

    имя XSL-шаблона

    $property

    массив дополнительных атрибутов
    • $property['begin'] начальная позиция отображения тегов (по умолчанию 0)
    • $property['count'] количество отображаемых тегов
    • $property['TagsOrder'] параметр, определяющий порядок сортировки тегов. Принимаемые значения: ASC - по возрастанию (по умолчанию), DESC - по убыванию
    • $property['TagsOrderField'] поле сортировки тегов, если случайная сортировка, то записать RAND(). по умолчанию теги сортируются по названию.
    • $property['tags_group_id'] идентификатор или массив идентификаторов групп тегов, из которых необходимо вести отбор тегов
    • $property['shop_groups_id'] идентификатор группы магазина, для которой необходимо вести отбор тегов
    • $property['NotIn'] строка идентификаторов товаров, исключаемых из выборки тегов
    • $property['In'] массив идентификаторов товаров, только для которых выбирать теги

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_id = 1;
      5.

    5.  $xsl_name = 'ОблакотеговМагазин';
      6.

    6.
      7.

    7.  $row = $shop->ShowTagsCloud($shop_id, $xsl_name);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    [ Наверх ]

    shop::ShowTypeOfDelivery

ShowTypeOfDelivery(

$shop_shops_id, int
$country, int
$location, int
$city, int
$city_area, float
$weight, float
$price, string
$xsl_name, array
$param, [array
$external_propertys = array ()], int
$currency );

    Описание

    Метод выбора и показа типов доставки

    Принимаемые параметры

    $country

    идентификатор страны (0-любая страна)

    $location

    идентификатор местоположения (области) (0-любая область)

    $city

    идентификатор города (0-любой город)

    $city_area

    идентификатор района (0-любой район)

    $weight

    вес корзины

    $price

    цена корзины

    $currency

    идентификатор валюты

    $xsl_name

    имя XSL-шаблона

    $param

    массив с доп. параметрами
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа

    $external_propertys

    массив внешних данных для включения в XML
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.  $country = 175;
      6.

    6.  $location = 58;
      7.

    7.  $city = 2005;
      8.

    8.  $city_area = 8;
      9.

    9.  $weight = 10;
      10.

    10.  $price = 1000;
      11.

    11.  $xsl_name = 'МагазинДоставки';
      12.

    12.
      13.

    13.  $result = $shop->ShowTypeOfDelivery($shop_shops_id, $country, $location, $city, $city_area, $weight, $price, $xsl_name, $external_propertys = array());
      14.

    14.
      15.

    15.  ?>
      16.

    $shop_shops_id

    [ Наверх ]

    shop::ShowUserOrders

ShowUserOrders(
int
$site_users_id, string
$xsl_name, [array
$param = array()] );

    Описание

    Отображение информации о заказах пользователя

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $xsl_name

    имя XSL шаблонав

    $param

    массив дополнительных параметров
    • $param['shop_shops_id'] идентификатор магазина, для которого осуществляется показ заказов
    • $param['orders_begin'] номер заказа в выборке, с которого начинать отображение
    • $param['orders_on_page'] число заказов, отображаемых на странице

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $site_users_id = 19;
        5.

      5.  $xsl_name = 'СписокЗаказов';
        6.

      6.
        7.

      7.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        8.

      8.  if (class_exists('SiteUsers'))
        9.

      9.  {
        10.

      10.     $SiteUsers = & singleton('SiteUsers');
        11.

      11.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      $site_users_id = 0;
        16.

      16.  }
        17.

      17.
        18.

      18.  $shop->ShowUserOrders($site_users_id, $xsl_name);
        19.

      19.
        20.

      20.  ?>
        21.

    Возвращает

    в случае неудачи

    [ Наверх ]

    shop::TransferFromCartIntoTable

TransferFromCartIntoTable(
int
$site_users_id );

    Описание

    Метод перемещения информации о заказанном товаре в таблицу корзины

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    [ Наверх ]

    shop::UnsetSiteUserAccountTransaction

UnsetSiteUserAccountTransaction(
int
$shop_site_users_account_id );

    Описание

    Установка активности транзакции в 0 (делает неактивной)

    Принимаемые параметры

    $shop_site_users_account_id

    Идентификатор транзакции
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_site_users_account_id = 19;
      5.

    5.
      6.

    6.  $result = $shop->UnsetSiteUserAccountTransaction($shop_site_users_account_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    [ Наверх ]

    shop::UpdateCart

UpdateCart(
array
$param );

    Описание

    Метод, осуществляющий обновление данных корзины

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • $param['user_id'] int идентификатор пользователя (если передан 0 или ложь - работаем с кукисами)
    • $param['shop_id'] int идентификатор магазина
    • $param['item_id'] int идентификатор товара
    • $param['cart_id'] int идентификатор корзины
    • $param['count'] int количество товара в корзине
    • $param['warehouse_id'] int идентификатор склада
    • $param['postpone'] int отложить ли товар для следующей покупки
    • $param['get_info_isset_shop'] boolean флаг необходимости проверки наличия магазина

    Возвращает

    идентификатор отредактрованной записи или ложь в случае возникновения ошибки

    [ Наверх ]

    shop::UpdateCity

UpdateCity(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление города

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор города
    • string $param['name'] название города
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления города

    [ Наверх ]

    shop::UpdateCondOfDelivery

UpdateCondOfDelivery(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор условия доставки
    string $param['name'] название условия доставки
    int $param['type_of_delivery'] идентификатор типа доставки
    • $param['location'] идентификатор области

      double $param['weight_from] вес от

      double $param['weight_to'] вес до

      double $param['price_from'] цена заказа от

      double $param['price_to'] цена заказа до

      string $param['description'] описание условия доставки

      double $param['price'] цена доставки

      int $param['currency] идентификатор валюты цены доставки

      string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления условия доставки

    [ Наверх ]

    shop::UpdateCountry

UpdateCountry(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление страны

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор страны
    • string $param['name'] название страны
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления страны

    [ Наверх ]

    shop::UpdateCurrency

UpdateCurrency(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор обновляемого запроса
    string $param['name'] параметр, определяющий название валюты
    double $param['value_in_basic_currency'] значение курса валюты в базовой валюте
    boolean $param['is_default'] параметр, определяющий, является ли валюта базовой

    Возвращает

    возвращает результат обновления валюты ( false при неудачном обновлении)

    [ Наверх ]

    shop::UpdateDiscount

UpdateDiscount(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер скидки
    string $param['name'] наименование скидки
    string $param['from'] с какого времени действует скидка
    string $param['to'] по какое время действует скидка
    boolean $param['is_active'] активна ли скидка в настоящий момент
    numeric $param['percent'] процент скидки
    string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления информации о скидке

    [ Наверх ]

    shop::UpdateGroup

UpdateGroup(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер группы
    int $param['shop_shops_id'] идентификатор магазина
    string $param['name'] имя группы
    string $param['parent_id'] идентификатор родителя группы (в корне - 0)
    string $param['description'] описание группы
    string $param['image'] путь к изображению (логотипу) группы
    int $param['order'] порядок сортировки
    int $param['indexation'] флаг индексации
    string $param['path'] путь к группе
    string $param['seo_title'] заголовок страницы
    string $param['seo_description'] задание значения мета-тега description страницы
    string $param['seo_keywords'] задание значения мета-тега keywords страницы
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает идентификатор обновленной группы (false при неудачном обновлении)

    [ Наверх ]

    shop::UpdateImageForItem

UpdateImageForItem(

$shop_id,
$shop_items_catalog_id,
$shop_items_catalog_image, [
$shop_items_catalog_image_small = false], string
$item_image );

    Описание

    Метод обновления информации об изображении для товара

    Принимаемые параметры

    $item_image

    наименование файла изображения для товара

    $shop_id

    $shop_items_catalog_id

    $shop_items_catalog_image

    $shop_items_catalog_image_small

    Возвращает

    истина в случае удачного обновления, ложь в обратном случае

    [ Наверх ]

    shop::UpdateItem

UpdateItem(

$param );

    Описание

    Устаревший метод, осуществляющий обновление информации о товаре. Заменен на InsertItem()

    Принимаемые параметры

    $param

    see

    shop::InsertItem()

    [ Наверх ]

    shop::UpdateItemDiscount

UpdateItemDiscount(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_item_discount_id'] идентификатор обновляемой записи
    • int $param['item_catalog_id'] идентификатор товара
    • int $param['shop_discount_id'] идентификатор скидки

    Возвращает

    возвращает идентификатор обновленной валюты ( false при неудачном обновлении)

    [ Наверх ]

    shop::UpdateItemPrice

UpdateItemPrice(
array
$param );

    Описание

    Метод обновления связи товара и цены

    Принимаемые параметры

    $param

    массив параметров
    • int $param['shop_items_catalog_item_id'] Идентификатор товара
    • int $param['shop_list_of_prices_id'] Идентификатор цены
    • float $param['shop_prices_to_item_value'] Значение дополнительной цены

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_items_catalog_item_id'] = 159;
        5.

      5.  $param['shop_list_of_prices_id'] = 1;
        6.

      6.  $param['shop_prices_to_item_value'] = 333;
        7.

      7.
        8.

      8.  $newid = $shop->UpdateItemPrice($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    [ Наверх ]

    shop::UpdateLocation

UpdateLocation(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление области

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    string $param['name'] название области
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления области

    [ Наверх ]

    shop::UpdateMesure

UpdateMesure(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационнный номер единицы измерения
    string $param['name'] наименование единицы измерения
    string $param['description'] описание единицы измерения
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления информации о единице измерения

    [ Наверх ]

    shop::UpdateOrder

UpdateOrder(
array
$param );

    Описание

    УСТАРЕВШИЙ метод, осуществляющий обновление заказа. См. InsertOrder()

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • $param int $param['id'] идентификатор заказа
    • $param int $param['shops_id'] идентификатор магазина
    • $param int $param['location_id'] идентификатор области
    • $param int $param['country_id'] идентификатор страны
    • $param int $param['city_id'] идентификатор города
    • $param int $param['city_area_id'] идентификатор района
    • $param int $param['cond_of_delivery_id'] идентификатор способа доставки
    • $param float $param['delivery_price'] стоимость доставки
    • $param int $param['users_id'] идентификатор пользователя
    • $param int $param['currency_id'] идентификатор валюты
    • $param int $param['system_of_pay_id'] идентификатор платежной системы
    • $param string $param['date_time'] дата заказа
    • $param int $param['status_of_pay'] статус оплаты
    • $param string $param['date_of_pay'] дата оплаты
    • $param string $param['address'] адрес доставки
    • $param int $param['index'] почтовый индекс
    • $param string $param['phone'] телефон пользователя
    • $param string $param['description'] описание для заказа
    • $param string $param['system_information'] системная информация для заказа
    • $param int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления заказа

    see

    shop::InsertOrder()

    [ Наверх ]

    shop::UpdateOrderItems

UpdateOrderItems(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • $param  int $param['shop_order_items_id'] идентификатор обновляемой записи
    • $param  int $param['shop_items_catalog_item_id'] идентификатор товара
    • $param  int $param['shop_order_id'] идентификатор заказа, которому принадлежит товар
    • $param  int $param['shop_order_items_quantity'] количество определенного товара в заказе
    • $param  float $param['shop_order_items_price'] цена товара в заказе
    • $param  string $param['shop_order_items_name'] наименование товара в заказе
    • $param  string $param['shop_order_items_marking'] артикул товара в заказе

    Возвращает

    идентификатор обновленного заказа или false в случае неудачи

    [ Наверх ]

    shop::UpdateOrderPropretyOfItems

UpdateOrderPropretyOfItems(
int
$list_of_properties_id, int
$list_of_properties_order );

    Описание

    Метод изменения порядка сортировки дополнительных свойств товара

    Принимаемые параметры

    $list_of_properties_id

    идентификатор дополнительного свойства

    $list_of_properties_order

    порядок сортировки
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $list_of_properties_id = 137;
      5.

    5.  $list_of_properties_order = 900;
      6.

    6.
      7.

    7.  $properties_id = $shop->UpdateOrderPropretyOfItems($list_of_properties_id,$list_of_properties_order);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $properties_id;
      11.

    11.  ?>
      12.

    Возвращает

    идентификатор записи, если обновление прошло успешно, иначе - ложь

    [ Наверх ]

    shop::UpdatePrice

UpdatePrice(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор цены
    • string $param['name'] название цены
    • double $param['percent_to_basic'] процент по отношению к базовой цене
    • string $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления типа цены

    [ Наверх ]

    shop::UpdatePricesToItem

UpdatePricesToItem(
array
$param );

    Описание

    Метод обновления дополнительной цены для элемента

    Принимаемые параметры

    $param

    массив параметров
    • $param['shop_prices_to_item_id'] - идентификатор из таблицы связи элементов каталога и значений дополнительных цен (не обязательное поле)
    • $param['shop_items_catalog_item_id'] - идентификатор элемента каталога
    • $param['shop_list_of_prices_id'] - идентификатор дополнительной цены
    • $param['shop_prices_to_item_value'] - значение дополнительной цены

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_items_catalog_item_id'] = 159;
        5.

      5.  $param['shop_list_of_prices_id'] = 1;
        6.

      6.  $param['shop_prices_to_item_value'] = 355;
        7.

      7.
        8.

      8.  $newid = $shop->UpdatePricesToItem($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор обновленной записи или false в случае ошибки

    [ Наверх ]

    shop::UpdateProducer

UpdateProducer(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификационный номер производителя
    string $param['name'] имя (название) производителя
    string $param['description'] краткая информация о производителе
    string $param['image'] путь к логотипу производителя
    int $param['order'] порядок сортировки производителя
    string $param['path'] путь к производителю
    • $param  int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления информации о производителе

    [ Наверх ]

    shop::UpdatePropertiesItem

UpdatePropertiesItem(
array
$param );

    Описание

    Метод обновления информации о дополнительных свойствах товара

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_properties_items_id'] идентификатор обновляемой записи
    • int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вставляются свойства
    • int $param['shop_list_of_properties_id'] идентификатор свойства товара
    • int $param['shop_properties_items_value'] значение свойства товара  (или оригинальное имя загружаемого изображения)
    • string $param['shop_properties_items_value_small'] оригинальное имя загружаемого малого файла изображения
    • string $param['shop_properties_items_file'] системное имя файла изображения
    • string $param['shop_properties_items_file_small'] системное имя малого файла изображения

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_properties_items_id'] = 189;
        5.

      5.  $param['shop_items_catalog_item_id'] = 159;
        6.

      6.  $param['shop_list_of_properties_id'] = 141;
        7.

      7.  $param['shop_properties_items_value'] = 'test';
        8.

      8.
        9.

      9.  $newid = $shop->UpdatePropertiesItem($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $newid;
        13.

      13.  ?>
        14.

    Возвращает

    идентификатор обновленной записи

    [ Наверх ]

    shop::UpdatePropretyOfItems

UpdatePropretyOfItems(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    int $param['id'] идентификатор свойства товаров
    string $param['name'] название свойства товара
    string $param['xml_name'] наименование xml-тега
    int $param['order'] порядок сортировки
    int $param['type'] тип свойства товара
    int $param['type'] тип свойства товара
    string $param['prefics'] префикс свойства товара (например: свыше, более, до ...)
    string $param['default_value'] значение свойства товара, устанавливаемое по умолчанию
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор обновленной записи, ложь - если обновление не произведено

    [ Наверх ]

    shop::UpdateShop

UpdateShop(

$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине

    Принимаемые параметры

    $param

    [ Наверх ]

    shop::UpdateSystemOfPay

UpdateSystemOfPay(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор платёжной системы
    • string $param['name'] название платёжной системы
    • string $param['description'] описание платёжной системы
    • int $param['is_active'] активна ли платёжная система
    • string $param['handler'] обработчик платёжной системы
    • $param  int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления платёжной системы

    [ Наверх ]

    shop::UpdateTax

UpdateTax(
array
$param );

    Описание

    Метод, осуществляющий обновление налога. Рекомендуется использовать InsertTax()

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_tax_id'] идентификационный номер налога
    • string $param['shop_tax_name'] название налога
    • double $param['shop_tax_rate'] ставка налога
    • int $param['shop_tax_is_in_price'] входит ли налог в цену
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $shop = new shop();
        3.

      3.
        4.

      4.  $param['shop_tax_id'] = 123;
        5.

      5.  $param['shop_tax_rate'] = 10;
        6.

      6.
        7.

      7.  $newid = $shop->UpdateTax($param);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $newid;
        11.

      11.  ?>
        12.

    Возвращает

    результат обновления налога

    see

    shop::InsertTax()

    [ Наверх ]

    shop::UpdateTyingProducts

UpdateTyingProducts(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['shop_intermediate_id'] идетификатор записи о сопутствующем товаре
    • int $param['shop_items_catalog_item_id'] идентификатор товара, для которого вводится сопутствующий товар
    • int $param['sho_shop_items_catalog_item_id'] идентификатор сопутствующего товара

    Возвращает

    идентификатор результата обновления

    [ Наверх ]

    shop::UpdateTypeOfDelivery

UpdateTypeOfDelivery(
array
$param );

    Описание

    УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['id'] идентификатор типа доставки
    • string $param['name'] название типа доставки
    • string $param['description'] описание типа доставки
    • string $param['image'] путь к логотипу службы доставки
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    возвращает результат обновления типа доставки

    [ Наверх ]

    shop::YandexMarket

YandexMarket(
int
$shop_shops_id, [
$external_properties = array ()], array
$external_properties['all_items'] );

    Описание

    Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и выводит XML данные.

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина

    $external_properties['all_items']

    массив с внешними свойствами
    1.  <?php
      2.

    2.  $shop = new shop();
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  $xml = $shop->YandexMarket($shop_shops_id);
      7.

    7.
      8.

    8.  echo $xml;
      9.

    9.
      10.

    10.  exit();
      11.

    11.  ?>
      12.

    $external_properties

    Возвращает

    данные в формате XML или false

    [ Наверх ]

    shop::_CallbackSearch

_CallbackSearch(
array
$row );

    Описание

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

    Принимаемые параметры

    $row

    массив с информацией о странице

    Возвращает

    дополнительный XML, включаемый в результат поиска

    [ Наверх ]

Описания переменных

  • $CacheDiscountsForItem = array() [Строка 78]
    •

  • Data type: mixed
    •

  • $CacheGetAllPricesForItem = array() [Строка 240]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetAllPricesForItem()

  • $CacheGetCatalogItemIdByCmlId = array () [Строка 178]
    •

  • Data type: mixed
    •

  • $CacheGetCity = array() [Строка 341]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetCity()

  • $CacheGetCityArea = array() [Строка 347]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetCityArea()

  • $CacheGetCountItemsAndGroups = array() [Строка 365]
    •

  • Data type: array
    •

    Описание

    Кэш для GetCountItemsAndGroups

  • $CacheGetCountry = array() [Строка 329]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetCountry()

  • $CacheGetCurrencyByLike = array () [Строка 184]
    •

  • Data type: mixed
    •

  • $CacheGetDiscount = array () [Строка 219]
    •

  • Data type: array
    •

    Описание

    Кэш скидок для GetDiscount

  • $CacheGetItem = array () [Строка 212]
    •

  • Data type: array
    •

    Описание

    Кэш товаров для метода GetItem

  • $CacheGetItemPropertyIdByCmlId = array () [Строка 180]
    •

  • Data type: mixed
    •

  • $CacheGetLocation = array() [Строка 335]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetLocation()

  • $CacheGetPriceByCmlId = array () [Строка 182]
    •

  • Data type: mixed
    •

  • $CacheGetPriceForItem = array() [Строка 124]
    •

  • Data type: unknown_type
    •

    Описание

    Кэш для метода GetPriceForItem()

  • $CacheGetSpecialPriceForItem = array() [Строка 323]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetSpecialPriceForItem()

  • $CacheGetSpecialPricesForItem = array() [Строка 233]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetSpecialPricesForItem()

  • $CacheGetTax = array() [Строка 226]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetTax()

  • $CacheModificationItems = array() [Строка 117]
    •

  • Data type: array
    •

    Описание

    Массив ID модификаций товара для товаров

  • $cache_mesure =  [Строка 269]
    •

  • Data type: array
    •

    Описание

    Кэш информации о единицах измерений

  • $cache_producer =  [Строка 262]
    •

  • Data type: array
    •

    Описание

    Кэш информации о производителях

  • $CartType =  0 [Строка 353]
    •

  • Data type: int
    •

    Описание

    Тип сохранения корзины, 0 - COOKIES, 1 - СЕССИЯ.

  • $error =  [Строка 126]
    •

  • Data type: mixed
    •

  • $float_format =  "%.2f" [Строка 285]
    •

  • Data type: string
    •

    Описание

    Формат для this->Round()

    see

    shop::Round()

  • $GetAllItemTotalCount =  0 [Строка 198]
    •

  • Data type: int
    •

    Описание

    Свойство содержит информацию об общем количестве товаров, выбранных методом GetAllItems()

  • $GetAllProducersTotalCount =  0 [Строка 205]
    •

  • Data type: int
    •

    Описание

    Свойство содержит информацию об общем количестве производителей, выбранных методом GetAllProducers()

  • $hidden =  "" [Строка 136]
    •

  • Data type: mixed
    •

  • $iConvertPriceFractionalPart =  2 [Строка 359]
    •

  • Data type: int
    •

    Описание

    Количество знаков после запятой при округлении методом ConvertPrice()

  • $item_catalog_price =  0 [Строка 168]
    •

  • Data type: float
    •

    Описание

    Цена товара магазина

  • $MasGroup = array () [Строка 139]
    •

  • Data type: mixed
    •

  • $PropertyGroupMass = array () [Строка 247]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о дополнительных свойствах групп магазина

  • $setCookieSubdomain =  TRUE [Строка 28]
    •

  • Data type: mixed
    •

    Описание

    Устанавливать cookies для поддоменов.

  • $use_cookies_read_control =  false [Строка 293]
    •

  • Data type: bool
    •

    Описание

    Использовать ли систему контроля корректности данных, принимаемых из cookies.

    Значение по уолчанию = false. Рекомендуется указывать true.

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class site

Class site

[Строка 14]

Размещен: /Site/Site.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Сайты".
Файл: /modules/Site/Site.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheSite =

        Кэш данных о сайтах

  • $current_alias_cache =

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • unknown CopySite()

    Копирование сайта

  • true current_alias()

    Метод установки алиаса (домена) сайта в статус "основной"

  • bool del_alias()

    Метод преобразования алиаса (домена) сайта в основной

  • resource del_site()

    Удаление информации о сайте

  • mixed GetAlias()

    Получение данных об алиасе сайта

  • mixed GetAliasById()

    Метод возвращает информацию об алиасе (домене)

  • resource GetAllAlias()

    Метод возвращает информацию обо всех доменах

  • string GetCurrentAlias()

    Определение основного алиаса сайта

  • array GetSite()

    Получение данных о сайте по его идентификатору

  • string GetXmlForSite()

    Создание XML с информацией о сайте и алиасах

  • int insert_alias()

    Метод вставки/обновления информации об алиасе (домене) сайта

  • int insert_site()

    Вставка/обновление информации о сайте

  • string ReplaceMask()

    Удаляет маску "*." из адреса домена

  • resource SelectSites()

    Выбор всех сайтов, поддерживаемых системой управления

  • resource select_alias()

    Получение информации об алиасе (домене) сайта

  • resource select_site()

    Получение данных о сайте

Унаследованные методы

Описания методов

    site::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    site::CopySite

CopySite(
int
$site_id );

    Описание

    Копирование сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта

    [ Наверх ]

    site::current_alias

current_alias(
int
$site_id, int
$alias_id );

    Описание

    Метод установки алиаса (домена) сайта в статус "основной"

    Принимаемые параметры

    $site_id

    – идентификатор сайта

    $alias_id

    – идентификатор алиаса сайта, который необходимо сделать основным
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $alias_id = 8;
      5.

    5.  $site_id = 1;
      6.

    6.
      7.

    7.  $site->current_alias($site_id, $alias_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    site::del_alias

del_alias(
int
$alias_id );

    Описание

    Метод преобразования алиаса (домена) сайта в основной

    Принимаемые параметры

    $alias_id

    – – идентификатор алиаса сайта, который необходимо сделать основным
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $alias_id = 7;
      5.

    5.
      6.

    6.  $site->del_alias($alias_id);
      7.

    7.  ?>
      8.

    Возвращает

    результат работы ф-ции

    [ Наверх ]

    site::del_site

del_site(
int
$site_id );

    Описание

    Удаление информации о сайте

    Принимаемые параметры

    $site_id

    – идентификатор удаляемого сайта
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $site_id = 2;
      5.

    5.
      6.

    6.  $resource = $site->del_site($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    рузельтат выполнения запроса

    [ Наверх ]

    site::GetAlias

GetAlias(
string
$alias_name, [array
$param = array()] );

    Описание

    Получение данных об алиасе сайта

    Принимаемые параметры

    $alias_name

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются
    • bool $param['use_star'] - использовать ли подставновки *.site.ru, по умолчанию true

      1.  <?php
        2.

      2.  $site = new site();
        3.

      3.
        4.

      4.  $alias_name = 'test3';
        5.

      5.
        6.

      6.  $row = $site->GetAlias($alias_name);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    array данные об алиасе, false - если алиас не найден

    [ Наверх ]

    site::GetAliasById

GetAliasById(
int
$alias_id );

    Описание

    Метод возвращает информацию об алиасе (домене)

    Принимаемые параметры

    $alias_id

    идентификатор домена
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $alias_id = 2;
      5.

    5.
      6.

    6.  $row = $site->GetAliasById($alias_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с информацией об алиасе или false

    [ Наверх ]

    site::GetAllAlias

GetAllAlias(
[int
$site_id = false] );

    Описание

    Метод возвращает информацию обо всех доменах

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит домен, если false - учитываются все сайты
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $row = $site->GetAllAlias($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    с информацией о доменах (алиасах)

    [ Наверх ]

    site::GetCurrentAlias

GetCurrentAlias(
int
$site_id );

    Описание

    Определение основного алиаса сайта

    Принимаемые параметры

    $site_id

    – идентификатор сайта
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $result = $site->GetCurrentAlias($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    имя основного алиаса сайта или false – в случае если основной алиас не найден

    [ Наверх ]

    site::GetSite

GetSite(
[int
$site_id = CURRENT_SITE], [array
$param = array()] );

    Описание

    Получение данных о сайте по его идентификатору

    Принимаемые параметры

    $site_id

    – идентификатор сайта (по умолчанию равен идентификатору текущего сайта)

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $site = new site();
        3.

      3.
        4.

      4.  $site_id = 1;
        5.

      5.
        6.

      6.  $row = $site->GetSite($site_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с информацией о сайте, если такой сайт существует или false – в противном случае

    [ Наверх ]

    site::GetXmlForSite

GetXmlForSite(
int
$site_id );

    Описание

    Создание XML с информацией о сайте и алиасах

    Принимаемые параметры

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $xml = $site->GetXmlForSite($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xml);
      10.

    10.  ?>
      11.

    Возвращает

    созданный XML

    [ Наверх ]

    site::insert_alias

insert_alias(
int
$type, int
$alias_id, int
$site_id, string
$alias_name, int
$alias_current, [int
$users_id = false] );

    Описание

    Метод вставки/обновления информации об алиасе (домене) сайта

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации об алиасе сайта (0 – вставка, 1 - обновление)

    $alias_id

    – идентификатор обновляемого алиаса сайта (при вставке алиаса равен 0)

    $site_id

    – идентификатор сайта, для которого добавляется/обновляется алиас

    $alias_name

    – название алиаса сайта

    $alias_current

    – параметр, указывающий является ли алиас сайта основным (1 – основной, 0 - неосновной)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $site_id = 4;
      6.

    6.  $alias_id = 0;
      7.

    7.  $alias_current = 1;
      8.

    8.  $alias_name = 'Новый алиас';
      9.

    9.
      10.

    10.  $newid = $site->insert_alias($type, $alias_id, $site_id, $alias_name, $alias_current, $users_id = false);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    Возвращает

    идентификатор добавляемого/обновляемого алиаса сайта

    [ Наверх ]

    site::insert_site

insert_site(
array
$param );

    Описание

    Вставка/обновление информации о сайте

    Принимаемые параметры

    $param

    массив параметров сайта
    • $param['site_id'] идентификатор сайта, информация о котором обновляется
    • $param['site_name'] название добавляемого/обновляемого сайта
    • $param['site_is_active'] параметр, определяющий  активность (доступность) сайта (0 - неактивен (по умолчанию), 1 – активен)
    • $param['site_coding'] кодировка, используемая сайтом
    • $param['site_order'] порядок сортировки сайта в административной части
    • $param['site_locale'] используемая локаль
    • $param['site_timezone'] часовой пояс
    • $param['site_max_size_load_image'] максимальный размер малых изображений загружаемых на сайт
    • $param['site_max_size_load_image_big'] максимальный размер больших картинок загружаемых на сайт
    • $param['site_admin_email'] электронный адрес администратора сайта
    • $param['site_chmod'] права доступа к файлам
    • $param['site_files_chmod'] права доступа к файлам
    • $param['site_date_format'] формат даты
    • $param['site_date_time_format'] формат даты-времени
    • $param['site_error'] режим вывода ошибок
    • $param['site_error404'] страница, отображаемая при возникновении 404 ошибки (страница не найдена),  если страница не указана, производится редирект на главную страницу
    • $param['site_access_denied'] страница, отображаемая при попытке доступа пользователя, не имеющего права доступа
    • $param['site_robots'] содержимое файла robots.txt для данного сайта
    • $param['site_key'] регистрационный ключ
    • $param['site_is_close'] идентификатор узла структуры, содержащего страницу, отображаемую при отключении сайта администратором
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • $param['site_safe_email'] параметр, определяющий защищен e-mail на страницах сайта от просмотра спам-ботами или нет (1 - защищен (по умолчанию), 0 - не защищен)
    • $param['site_html_cache_use'] использовать ли кэш на сайте
    • $param['site_html_cache_with'] список страниц которые должны кэшироваться
    • $param['site_html_cache_without'] список страниц которые не должны кэшироваться
    • $param['site_html_cache_clear_probability'] параметр, определяющий вероятность очистки кэша
    • $param['site_send_attendance_report'] параметр, устанавливающий ежедневную отправку отчета о посещаемости сайта (1 - отправлять отчет (по умолчанию), 0 - не отправлять)
    • $param['site_uploaddir'] параметр, определяющий путь к разделу, в котором будут сохраняться загруженные файлы. Первым символом значения параметра не может быть символ '/', данным символом обязательно должно заканчиваться значение. Значение по умолчанию 'UPLOAD/'.
    • $param['site_nesting_level'] число уровней вложенности директорий для хранения файлов сущностей системы (основных и дополнительных свойств типа "Файл" информационных элементов, основных и дополнительных свойств типа "Файл" информационных групп, дополнительных свойств типа "Файл" узлов структуры).

       по умолчанию равен 3.

    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $param['site_name'] = 'Новый сайт';
      5.

    5.
      6.

    6.  $newid = $site->insert_site($param);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    Возвращает

    идентификатор добавленного или обновленного сайта

    [ Наверх ]

    site::ReplaceMask

ReplaceMask(
string
$str );

    Описание

    Удаляет маску "*." из адреса домена

    Принимаемые параметры

    $str

    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $str = '*.test3';
      5.

    5.
      6.

    6.  echo $site->ReplaceMask($str);
      7.

    7.  ?>
      8.

    [ Наверх ]

    site::SelectSites

SelectSites(
[array
$param = array()] );

    Описание

    Выбор всех сайтов, поддерживаемых системой управления

    Принимаемые параметры

    $param

    массив дополнительных параметров, необязательный параметр
    • $param['limit0'] - с какого совпадения начинать отбор, по умолчанию 0
    • $param['limit1'] - число элементов для выбора, по умолчанию не ограничено
    • $param['users_type_id'] - группа пользователей центра администрирования, для которой выбираются доступные сайты

      1.  <?php
        2.

      2.  $site = new site();
        3.

      3.
        4.

      4.  $resource = $site->SelectSites();
        5.

      5.
        6.

      6.  // Распечатаем результат
        7.

      7.  while($row = mysql_fetch_assoc($resource))
        8.

      8.  {
        9.

      9.      print_r($row);
        10.

      10.  }
        11.

      11.  ?>
        12.

    [ Наверх ]

    site::select_alias

select_alias(
int
$alias_id );

    Описание

    Получение информации об алиасе (домене) сайта

    Принимаемые параметры

    $alias_id

    – идентификатор алиаса, о котором необходимо получить информацию, -1 - выбрать все
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $alias_id = 2;
      5.

    5.
      6.

    6.  $resource = $site->select_alias($alias_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    данные об алиасе сайта

    [ Наверх ]

    site::select_site

select_site(
int
$site_id );

    Описание

    Получение данных о сайте

    Принимаемые параметры

    $site_id

    - идентификатор сайта, -1 выбрать все
    1.  <?php
      2.

    2.  $site = new site();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.
      6.

    6.  $resource = $site->select_site($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

Описания переменных

  • $CacheSite =  [Строка 23]
    •

  • Data type: string
    •

    Описание

    Кэш данных о сайтах

  • $current_alias_cache =  [Строка 16]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class SiteTemplate

Class SiteTemplate

[Строка 14]

Размещен: /Site/SiteTemplate.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Шаблоны дизайна для сайтов".
Файл: /modules/Site/SiteTemplate.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $chmod_file =  null

  • $kernel =  null

  • $sTemplatesUrlServer =  'http://www.hostcms.ru'

  • $template_content_filename =  'template.xml'

  • $template_filename =  'templates.xml'

  • $template_path =  null

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • SiteTemplate SiteTemplate()

  • void GetChmodFile()

    Получение прав доступа к создаваемым объектом файлов

  • void GetFields()

  • void GetFileExtension()

    Определение расширения файла по его названию без расширения

  • void GetTemplateContentFilePath()

  • void GetTemplateContentXml()

  • void GetTemplateFilePath()

  • void GetTemplatePath()

  • void GetTemplatesUrlServer()

  • void GetTemplateXml()

  • void LoadFile()

  • void MacroReplace()

  • void MoveInfGroupImage()

    Копирование изображений для ИГ

  • void MoveInfItemImage()

    Копирование изображений для ИЭ

  • void MoveInfItemPropertyImage()

    Копирование изображений для доп. свойств ИЭ

  • void MoveShopGroupImage()

    Копирование изображений для группы товаров

  • void MoveShopItemImage()

    Копирование изображений для товара

  • void MoveShopItemPropertyImage()

    Копирование изображений для доп. свойств товара

  • void MoveStructureItemPropertyImage()

    Копирование значения доп. свойства типа "Файл" узла структуры

  • void ReplaceFile()

    Заменяет макросы в уже существующем файле

  • void SetChmodFile()

    Установка прав доступа к создаваемых объектом файлов

  • void SetTemplatePath()

  • void SetTemplatesUrlServer()

Унаследованные методы

Описания методов

    SiteTemplate::SiteTemplate

SiteTemplate(
 );

    [ Наверх ]

    SiteTemplate::GetChmodFile

GetChmodFile(
 );

    Описание

    Получение прав доступа к создаваемым объектом файлов

    [ Наверх ]

    SiteTemplate::GetFields

GetFields(

$array );

    Принимаемые параметры

    $array

    [ Наверх ]

    SiteTemplate::GetFileExtension

GetFileExtension(
$path_file_without_extension
$path_file_without_extension );

    Описание

    Определение расширения файла по его названию без расширения

    Принимаемые параметры

    $path_file_without_extension

    - путь к файлу без расширения

    [ Наверх ]

    SiteTemplate::GetTemplateContentFilePath

GetTemplateContentFilePath(
 );

    [ Наверх ]

    SiteTemplate::GetTemplateContentXml

GetTemplateContentXml(
 );

    [ Наверх ]

    SiteTemplate::GetTemplateFilePath

GetTemplateFilePath(
 );

    [ Наверх ]

    SiteTemplate::GetTemplatePath

GetTemplatePath(
 );

    [ Наверх ]

    SiteTemplate::GetTemplatesUrlServer

GetTemplatesUrlServer(
 );

    [ Наверх ]

    SiteTemplate::GetTemplateXml

GetTemplateXml(
 );

    [ Наверх ]

    SiteTemplate::LoadFile

LoadFile(

$filename, [
$aReplace = array()] );

    Принимаемые параметры

    $filename

    $aReplace

    [ Наверх ]

    SiteTemplate::MacroReplace

MacroReplace(

$str,
$aReplace );

    Принимаемые параметры

    $str

    $aReplace

    [ Наверх ]

    SiteTemplate::MoveInfGroupImage

MoveInfGroupImage(
$is_group_id
$is_group_id, $copy_is_id
$copy_is_id, $copy_group_id
$copy_group_id );

    Описание

    Копирование изображений для ИГ

    Принимаемые параметры

    $is_group_id

    - идентификатор новой созданной ИГ

    $copy_is_id

    - идентификатор копирумой ИС

    $copy_group_id

    - идентификатор копируемой ИГ

    [ Наверх ]

    SiteTemplate::MoveInfItemImage

MoveInfItemImage(
$is_item_id
$is_item_id, $copy_is_id
$copy_is_id, $copy_item_id
$copy_item_id );

    Описание

    Копирование изображений для ИЭ

    Принимаемые параметры

    $is_item_id

    - идентификатор нового созданого ИЭ

    $copy_is_id

    - идентификатор копирумой ИС

    $copy_item_id

    - идентификатор копируемого ИЭ

    [ Наверх ]

    SiteTemplate::MoveInfItemPropertyImage

MoveInfItemPropertyImage(
$is_item_id
$is_item_id, $is_item_property_id
$is_item_property_id, $copy_is_id
$copy_is_id, $copy_is_item_id
$copy_is_item_id, $copy_is_item_property_value_id
$copy_is_item_property_value_id );

    Описание

    Копирование изображений для доп. свойств ИЭ

    Принимаемые параметры

    $is_item_id

    - Идентификатор нового ИЭ

    $is_item_property_id

    - Идентификатор нового доп. свойства типа "Файл"

    $copy_is_id

    - Идентификатор копирумой ИС

    $copy_is_item_id

    - Идентификатор копируемого ИЭ

    $copy_is_item_property_value_id

    - Идентификатор значения доп. свойства типа "Файл" копируемого ИЭ

    [ Наверх ]

    SiteTemplate::MoveShopGroupImage

MoveShopGroupImage(
$shop_group_id
$shop_group_id, $copy_shop_id
$copy_shop_id, $copy_group_id
$copy_group_id );

    Описание

    Копирование изображений для группы товаров

    Принимаемые параметры

    $shop_group_id

    - идентификатор новой созданной группы магазина

    $copy_shop_id

    - идентификатор копирумого магазина

    $copy_group_id

    - идентификатор копируемой группы товаров

    [ Наверх ]

    SiteTemplate::MoveShopItemImage

MoveShopItemImage(
$shop_item_id
$shop_item_id, $copy_shop_id
$copy_shop_id, $copy_shop_item_id
$copy_shop_item_id );

    Описание

    Копирование изображений для товара

    Принимаемые параметры

    $shop_item_id

    - Идентификатор нового созданого товара

    $copy_shop_id

    - Идентификатор копирумого магазина

    $copy_shop_item_id

    - Идентификатор копируемого товара

    [ Наверх ]

    SiteTemplate::MoveShopItemPropertyImage

MoveShopItemPropertyImage(
$shop_item_id
$shop_item_id, $copy_shop_id
$shop_item_property_id, $copy_shop_item_id
$copy_shop_id, $copy_shop_item_property_id
$copy_shop_item_id,
$copy_shop_item_property_id );

    Описание

    Копирование изображений для доп. свойств товара

    Принимаемые параметры

    $shop_item_id

    - Идентификатор нового созданого товара

    $shop_item_property_id

    - Идентификатор копирумого магазина

    $copy_shop_id

    - Идентификатор копируемого товара

    $copy_shop_item_id

    - Идентификатор доп. свойства типа "Файл" копируемого товара

    $copy_shop_item_property_id

    [ Наверх ]

    SiteTemplate::MoveStructureItemPropertyImage

MoveStructureItemPropertyImage(
$structure_id
$structure_id, $structure_property_image_id
$structure_property_image_id, $copy_site_id
$copy_site_id, $copy_structure_id
$copy_structure_id, $copy_structure_property_value_id
$copy_structure_property_value_id );

    Описание

    Копирование значения доп. свойства типа "Файл" узла структуры

    Принимаемые параметры

    $structure_id

    - Идентификатор нового созданого узла структуры

    $structure_property_image_id

    - Идентификатор нового созданного доп. свойства

    $copy_site_id

    - Идентификатор сайта, которому принадлежит копируемая структура

    $copy_structure_id

    - Идентификатор копируемого узла структуры

    $copy_structure_property_value_id

    - Идентификатор значения доп. свойства, значение которого копируется

    [ Наверх ]

    SiteTemplate::ReplaceFile

ReplaceFile(
$filename
$filename, [$aReplace
$aReplace = array()] );

    Описание

    Заменяет макросы в уже существующем файле

    Принимаемые параметры

    $filename

    путь к файлу

    $aReplace

    массив замен

    [ Наверх ]

    SiteTemplate::SetChmodFile

SetChmodFile(
int
$chmod_file );

    Описание

    Установка прав доступа к создаваемых объектом файлов

    Принимаемые параметры

    $chmod_file

    права доступа к создаваемых файлам, например, 0644

    [ Наверх ]

    SiteTemplate::SetTemplatePath

SetTemplatePath(

$template_path );

    Принимаемые параметры

    $template_path

    [ Наверх ]

    SiteTemplate::SetTemplatesUrlServer

SetTemplatesUrlServer(

$sTemplatesUrlServer );

    Принимаемые параметры

    $sTemplatesUrlServer

    [ Наверх ]

Описания переменных

  • $chmod_file =  null [Строка 25]
    •

  • Data type: mixed
    •

  • $kernel =  null [Строка 23]
    •

  • Data type: mixed
    •

  • $sTemplatesUrlServer =  'http://www.hostcms.ru' [Строка 16]
    •

  • Data type: mixed
    •

  • $template_content_filename =  'template.xml' [Строка 19]
    •

  • Data type: mixed
    •

  • $template_filename =  'templates.xml' [Строка 18]
    •

  • Data type: mixed
    •

  • $template_path =  null [Строка 21]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class SiteUsers

Class SiteUsers

[Строка 31]

Размещен: /Site_users/Site_users.class.php

Описание

Класс модуля "Пользователи сайта"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void AdminMainPage()

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

  • boolean CopyExtraProperty()

    Метод копирования дополнительного параметра

  • true DeleteExternalPropertyValue()

    Метод удаления значения доплнительного параметра пользователя сайта

  • boolean DeleteExtraProperty()

    Удаление дополнительного параматра

  • boolean DeleteSiteUser()

    Метод удаления пользователя из системы

  • boolean DelGroupUser()

    Удаление пользователя из группы

  • boolean DelUserGroup()

    Удаление группы пользователей заданной идентификатором

  • resource GetAllUsers()

    Получение информации о всех пользователях сайта

  • int GetCurrentSiteUser()

    Метод определения идентификатора текущего пользователя сайта.

  • mixed:
     GetDefaultGroup()

    Получение id группы используемой по умолчанию

  • array GetExtraProperties()

    Получение дополнительных свойств по их идентификатору

  • mixed GetExtraProperty()

    Получение значения свойств дополнительного параметра

  • array GetGroupsForUser()

    Определение идентификаторов групп, в которые входит пользователь

  • array GetListExtraProperties()

    Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором

  • mixed GetListPrimaryProperties()

    УСТАРЕВШИЙ Получение основных данных о пользователе

  • mixed GetSiteUser()

    Получение информации о пользователе сайта

  • mixed GetSiteUserByLogin()

    Получение информации о пользователе сайта по его логину

  • mixed GetSiteUsersGroup()

    Получение информации о группе пользователей сайта

  • mixed GetSiteUsersGroupList()

    Получение данных соответствия, пользователя группе пользователей, по идентификатору соответствия

  • string GetSiteUsersGroupsXml()

    Формирование XML для группы пользователей

  • string GetSiteUserXml()

    Метод формирования XML с данными о пользователе

  • string GetUserDir()

    Метод возвращает абсолютный путь к директории пользователя сайта

  • array GetUserGroups()

    УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.

  • string GetUsersDir()

    Метод возвращает абсолютный путь к директории для хранения файлов пользователей

  • mixed: GetValueExtraProperty()

    Получение значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра

  • array IndexationUser()

    Метод индексации пользователей сайта

  • int InsertExtraProperty()

    Добавление/редактирование дополнительного параметра

  • int InsertSiteUser()

    Добавление/обновление информации о пользователе сайта

  • int InsertUserGroup()

    Вставки/обновление информации о группе пользователей

  • boolean InsertUsers()

    Добавление пользователя в группу

  • boolean OrderExtraProperty()

    Метод обновления коэффициентов порядка сортировки

  • void PrivateOfficeXML()

    УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.

  • array SearchIndexing()

    Функция обратного вызова для поисковой индексации данных модуля

  • resource SelectExtraProperties()

    Получение всех дополнительных свойств

  • resource SelectSiteUsersGroups()

    Получение данных о всех группах пользователей сайта

  • resource SelectUserType()

    Метод возвращает параметры группы пользователя

  • boolean SendNewPassword()

    Метод отправки нового пароля на почтовый ящик пользователю

  • boolean SendRegistInf()

    Метод отправки пользователю регистрационной информации

  • mixed SetConfirmation()

    Установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)

  • bool SetConfirmationID()

    Метод установки/снятия подтверждения регистрации пользователя определяемого  по идентификатору

  • void SetCurrentSiteUser()

    Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток

  • boolean SetDefaultGroup()

    Установка группы пользователей по умолчанию

  • boolean SetValueExtraProperty()

    Установка значения дополнительного параметра пользователя

  • void ShowSiteUserRegistartion()

    Вывод формы регистрации для пользователя сайта

  • void ShowUserOffice()

    Метод отображения кабинета пользователя

  • boolean Unregistration()

    Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя

  • void UnsetCurrentSiteUser()

    Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из

  • mixed:
     UpdateSiteUser()

    Обновление анкетных данных пользователя. Рекомендуется использовать InsertSiteUser().

  •  ValidUser()

    Метод возвращает идентификатор пользователя по его логину и паролю

  • string _CallbackSearch()

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

Унаследованные методы

Описания методов

    SiteUsers::AdminMainPage

AdminMainPage(
 );

    Описание

    Функция обратного вызова для отображения блока  на основной странице центра администрирования.

    [ Наверх ]

    SiteUsers::CopyExtraProperty

CopyExtraProperty(
int
$extraproperty_id );

    Описание

    Метод копирования дополнительного параметра

    Принимаемые параметры

    $extraproperty_id

    идентификатор копируемого дополнительного параметра
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $extraproperty_id = 15;
      5.

    5.
      6.

    6.  $result = $SiteUsers->CopyExtraProperty($extraproperty_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Копирование выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка копирования";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::DeleteExternalPropertyValue

DeleteExternalPropertyValue(
int
$external_property_value_id );

    Описание

    Метод удаления значения доплнительного параметра пользователя сайта

    Принимаемые параметры

    $external_property_value_id

    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $external_property_value_id = 15;
      5.

    5.
      6.

    6.  $result = $SiteUsers->DeleteExternalPropertyValue($external_property_value_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление значения свойства выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления значения свойства";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    SiteUsers::DeleteExtraProperty

DeleteExtraProperty(
int
$extraproperty_id );

    Описание

    Удаление дополнительного параматра

    Принимаемые параметры

    $extraproperty_id

    идентификатор дополнительного параметра
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $extraproperty_id = 14;
      5.

    5.
      6.

    6.  $result = $SiteUsers->DeleteExtraProperty($extraproperty_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление свойства выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления свойства";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::DeleteSiteUser

DeleteSiteUser(
int
$site_users_id );

    Описание

    Метод удаления пользователя из системы

    Принимаемые параметры

    $site_users_id

    - идентификатор удаляемого пользователя
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 4;
      5.

    5.
      6.

    6.  $result = $SiteUsers->DeleteSiteUser($site_users_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::DelGroupUser

DelGroupUser(
int
$site_users_id, [int
$site_users_group_id = -1], [
$information_groups_id = 0] );

    Описание

    Удаление пользователя из группы

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $site_users_group_id

    = -1 идентификатор группы пользователей сайта(-1 исключаем пользователя из всех групп)
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 1;
      5.

    5.  $site_users_group_id = 6;
      6.

    6.
      7.

    7.  $result = $SiteUsers->DelGroupUser($site_users_id, $site_users_group_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление пользователя из группы выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления пользователя";
      16.

    16.  }
      17.

    17.  ?>
      18.

    $information_groups_id

    [ Наверх ]

    SiteUsers::DelUserGroup

DelUserGroup(
int
$site_users_group_id );

    Описание

    Удаление группы пользователей заданной идентификатором

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы пользователей
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_group_id = 14;
      5.

    5.
      6.

    6.  $result = $SiteUsers->DelUserGroup($site_users_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::GetAllUsers

GetAllUsers(
[array
$param = array()] );

    Описание

    Получение информации о всех пользователях сайта

    Принимаемые параметры

    $param

    массив дополнительных ограничений для выборки
    • $param['site_users_group_id'] int идентификатор группы пользователей
    • $param['site_id'] int идентификатор сайта, если не передан - используется текущий, если false - все сайты
    • $param['information_groups_id'] int идентификатор информационной группы

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $resource = $SiteUsers->GetAllUsers();
        5.

      5.
        6.

      6.  // Распечатаем результат
        7.

      7.  while($row = mysql_fetch_assoc($resource))
        8.

      8.  {
        9.

      9.      print_r($row);
        10.

      10.  }
        11.

      11.  ?>
        12.

    Возвращает

    результат выборки пользователей

    [ Наверх ]

    SiteUsers::GetCurrentSiteUser

GetCurrentSiteUser(
 );

    Описание

    Метод определения идентификатора текущего пользователя сайта.

    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_user_id = $SiteUsers->GetCurrentSiteUser();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $site_user_id;
      8.

    8.  ?>
      9.

    Возвращает

    идентификатор текущего пользователя сайта (пользователь не задан - 0)

    [ Наверх ]

    SiteUsers::GetDefaultGroup

GetDefaultGroup(
[int
$site_id = CURRENT_SITE] );

    Описание

    Получение id группы используемой по умолчанию

    Принимаемые параметры

    $site_id

    идентификатор сайта. По умолчанию равен идентификатору текущего сайта
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $result = $SiteUsers->GetDefaultGroup();
      5.

    5.
      6.

    6.  echo $result;
      7.

    7.  ?>
      8.

    Возвращает

    int идентификатор группы используемой по умолчанию,
      boolean false если запись не найдена

    [ Наверх ]

    SiteUsers::GetExtraProperties

GetExtraProperties(
int
$site_users_extra_property_id );

    Описание

    Получение дополнительных свойств по их идентификатору

    Принимаемые параметры

    $site_users_extra_property_id

    идентификатор дополнительных свойств
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_extra_property_id = 15;
      5.

    5.
      6.

    6.  $row = $SiteUsers->GetExtraProperties($site_users_extra_property_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив данных

    [ Наверх ]

    SiteUsers::GetExtraProperty

GetExtraProperty(
string
$site_users_extra_property_name, [int
$site_id = false] );

    Описание

    Получение значения свойств дополнительного параметра

    Принимаемые параметры

    $site_users_extra_property_name

    имя дополнительного параметра

    $site_id

    идентификатор сайта, если false, то берется текущий сайт. Необязательный параметр
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_extra_property_name = 'property1';
      5.

    5.
      6.

    6.  $row = $SiteUsers->GetExtraProperty($site_users_extra_property_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    данные о свойстве

    [ Наверх ]

    SiteUsers::GetGroupsForUser

GetGroupsForUser(
int
$site_users_id, [array
$param = array()] );

    Описание

    Определение идентификаторов групп, в которые входит пользователь

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $param

    массив параметров
    • int $param['information_groups_id'] идентификатор информационной группы

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $site_users_id = 5;
        5.

      5.
        6.

      6.  $row = $SiteUsers->GetGroupsForUser($site_users_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с идентификаторами групп.

    [ Наверх ]

    SiteUsers::GetListExtraProperties

GetListExtraProperties(
int
$site_users_id, [int
$site_id = CURRENT_SITE] );

    Описание

    Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $site_id

    идентификатор сайта (по умолчанию принимает идентификатор текущего сайта )
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 1;
      5.

    5.
      6.

    6.  $row = $SiteUsers->GetListExtraProperties($site_users_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив характеристик дополнительных параметров:
      $result[$i]['site_users_extra_property_id'] int идентификатор;
      $result[$i]['site_users_extra_property_name'] string имя;
      $result[$i]['site_users_extra_property_title'] string название;
      $result[$i]['site_users_extra_property_type'] string тип;
      $result[$i]['site_users_extra_property_size'] int размер значения;
      $result[$i]['site_users_extra_property_rows'] int количество строк;
      $result[$i]['site_users_extra_property_cols'] int количество столбцов;
      $result[$i]['site_users_extra_property_checked'] int выбран(1) или нет(0);
      $result[$i]['site_users_extra_property_default_value'] mixed значение по умолчанию;
      $result[$i]['site_users_extra_property_order'] int порядок сортировки;
      $result[$i]['site_users_extra_property_comment'] string коментарий;
      $result[$i]['lists_id'] int идентификатор списка;
      $result[$i]['site_users_property_value'] mixed значение

    [ Наверх ]

    SiteUsers::GetListPrimaryProperties

GetListPrimaryProperties(
int
$site_users_id );

    Описание

    УСТАРЕВШИЙ Получение основных данных о пользователе

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    Возвращает

    ассоциативный массив с данными или false если пользователь не найден

    [ Наверх ]

    SiteUsers::GetSiteUser

GetSiteUser(
int
$site_users_id, [array
$param = array()] );

    Описание

    Получение информации о пользователе сайта

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $site_users_id = 5;
        5.

      5.
        6.

      6.  $row = $SiteUsers->GetSiteUser($site_users_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    информация о пользователе, если пользователь есть в базе, иначе - ложь

    [ Наверх ]

    SiteUsers::GetSiteUserByLogin

GetSiteUserByLogin(
str
$site_user_login, [int
$site_id = false] );

    Описание

    Получение информации о пользователе сайта по его логину

    Принимаемые параметры

    $site_user_login

    логин пользователя

    $site_id

    идентификатор сайта, если false, то берется текущий сайт. Необязательный параметр
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_user_login = 'admin';
      5.

    5.
      6.

    6.  $row = $SiteUsers->GetSiteUserByLogin($site_user_login);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    информация о пользователе, если пользователь есть в базе, иначе - ложь

    [ Наверх ]

    SiteUsers::GetSiteUsersGroup

GetSiteUsersGroup(
int
$site_users_group_id, [array
$param = array()] );

    Описание

    Получение информации о группе пользователей сайта

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы пользователей сайта

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $site_users_group_id = 6;
        5.

      5.
        6.

      6.  $row = $SiteUsers->GetSiteUsersGroup($site_users_group_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с данными о группе пользователей сайта в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    SiteUsers::GetSiteUsersGroupList

GetSiteUsersGroupList(
int
$site_users_group_list_id );

    Описание

    Получение данных соответствия, пользователя группе пользователей, по идентификатору соответствия

    Принимаемые параметры

    $site_users_group_list_id

    идентификатор соответствия
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_group_list_id = 1;
      5.

    5.
      6.

    6.  $row = $SiteUsers->GetSiteUsersGroupList($site_users_group_list_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив данных, либо False

    [ Наверх ]

    SiteUsers::GetSiteUsersGroupsXml

GetSiteUsersGroupsXml(
array
$param );

    Описание

    Формирование XML для группы пользователей

    Принимаемые параметры

    $param

    массив параметров
    • array $param['array_site_users_groups_id'] массив идентификаторов групп пользователей
    • bool $param['show_site_users'] параметр, определяющий добавление информации о пользователях. По умолчанию равен true - информация о пользователях добавляется
    • int $param['information_groups_id'] идентификатор информационной группы
    • bool $param['xml_show_external_property'] - разрешает передачу в XML информации о дополнительных свойствах пользователя, по умолчанию true
 Парметры, применяемые в социальных сетях
    • int $param['change_access_action_site_user_id'] идентификатор пользователя сайта, для которого проверяем право изменения доступа к действию группам пользователей из $param['array_site_users_groups_id']
    • int $param['information_items_id'] идентификатор информационного элемента
    • bool $param['show_access_actions'] параметр, определяющий добавление информации о действиях социальной сети, доступных для группы пользователей. По умолчанию false - не добавляем информацию о доступных действиях
    • int $param['sns_id'] идентификатор социальной сети
    • mixed $param['sns_type_id'] массив идентификаторов типов социальной сети. По умолчанию равен false - не учитывается тип блога
    • mixed $param['social_network_service_action_parent_id'] идентификатор родительского действия. По умолчанию равен false - получаем все действия блогосистемы.
    • mixed $param['show_children_actions'] параметр, определяющий построение XML для дочерних действий всех подуровней. По умолчанию false - не строим XML для дочерних действий

    Возвращает

    сформированный xml для группы пользователей

    [ Наверх ]

    SiteUsers::GetSiteUserXml

GetSiteUserXml(
int
$site_users_id, [array
$external_property = array()], [array
$default_property = array()], [array
$param = array()] );

    Описание

    Метод формирования XML с данными о пользователе

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $external_property

    массив дополнительных параметров

    $default_property

    введенные значения

    $param

    дополонительные параметры
    • bool $param['cache_off'] - если параметр установлен, то данные не кэшируются
    • bool $param['xml_show_external_property'] разрешает передачу в XML информации о дополнительных свойствах пользователя, по умолчанию true

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  // Если есть модуль "Пользователи сайта", получим текущего пользователя
        5.

      5.  if (class_exists('SiteUsers'))
        6.

      6.  {
        7.

      7.      $SiteUsers = & singleton('SiteUsers');
        8.

      8.      $site_users_id = $SiteUsers->GetCurrentSiteUser();
        9.

      9.  }
        10.

      10.  else
        11.

      11.  {
        12.

      12.      $site_users_id = 0;
        13.

      13.  }
        14.

      14.
        15.

      15.  $newxml = $SiteUsers->GetSiteUserXml($site_users_id);
        16.

      16.
        17.

      17.  // Распечатаем результат
        18.

      18.  echo $newxml;
        19.

      19.  ?>
        20.

    Возвращает

    сформированный xml для регистрации

    [ Наверх ]

    SiteUsers::GetUserDir

GetUserDir(
int
$site_users_id );

    Описание

    Метод возвращает абсолютный путь к директории пользователя сайта

    Принимаемые параметры

    $site_users_id

    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 5;
      5.

    5.
      6.

    6.  $path = $SiteUsers->GetUserDir($site_users_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $path;
      10.

    10.  ?>
      11.

    [ Наверх ]

    SiteUsers::GetUserGroups

GetUserGroups(
int
$site_users_id );

    Описание

    УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.

    Вместо него рекомендуется использовать GetGroupsForUser($site_users_id)

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    Возвращает

    ассоциативный массив, индексы которого - идентификаторы групп, а значения единицы

    see

    SiteUsers::GetGroupsForUser()

    [ Наверх ]

    SiteUsers::GetUsersDir

GetUsersDir(
 );

    Описание

    Метод возвращает абсолютный путь к директории для хранения файлов пользователей

    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $path = $SiteUsers->GetUsersDir();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  echo $path;
      8.

    8.  ?>
      9.

    [ Наверх ]

    SiteUsers::GetValueExtraProperty

GetValueExtraProperty(
int
$site_users_id, string
$name_extra_property, [int
$site_id = false] );

    Описание

    Получение значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $name_extra_property

    наименование дополнительного параметра

    $site_id

    идентификатор сайта, если false, то берется текущий сайт. Необязательный параметр
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 1;
      5.

    5.  $name_extra_property = 'param';
      6.

    6.
      7.

    7.  $result = $SiteUsers->GetValueExtraProperty($site_users_id, $name_extra_property);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    string значение дополнительного параметра,
    boolean false если операция не выполнена

    [ Наверх ]

    SiteUsers::IndexationUser

IndexationUser(
int
$limit, int
$on_step, [array
$parameters = array ()] );

    Описание

    Метод индексации пользователей сайта

    Принимаемые параметры

    $limit

    ограничение(по сколько элементов индексировать)

    $on_step

    шаг для индексации

    $parameters

    массив дополнительных параметров
    • $parameters['site_users_id'] - идентификатор индексируемого пользователя сайта при событийной индексации

     Пример использования:
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $limit = 5;
      5.

    5.  $on_step = 10;
      6.

    6.
      7.

    7.  $row = $SiteUsers->IndexationUser($limit, $on_step);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив с данными о проиндексированных элементах

    [ Наверх ]

    SiteUsers::InsertExtraProperty

InsertExtraProperty(
int
$site_users_extra_property_id, string
$property_name, string
$property_type, string
$property_title, int
$property_size, int
$property_rows, int
$property_cols, int
$property_checked, string
$property_default_value, int
$property_order, string
$property_comment, int
$lists_id, [int
$users_id = false], [int
$site_id = CURRENT_SITE] );

    Описание

    Добавление/редактирование дополнительного параметра

    Принимаемые параметры

    $site_users_extra_property_id

    идентификатор дополнительного параметра

    $property_name

    имя

    $property_type

    тип

    $property_title

    название

    $property_size

    размер

    $property_rows

    кол-во строк (для большого текстового поля)

    $property_cols

    ширина (для большого текстового поля)

    $property_checked

    значение свойства 'selected' тега элемента формы

    $property_default_value

    значение по умолчанию

    $property_order

    порядок сортировки

    $property_comment

    комментарий

    $lists_id

    id списка

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    $site_id

    идентификатор сайта (по умолчанию принимает значение идентификатора текущего сайта)
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_extra_property_id = 0;
      5.

    5.  $property_name = 'param';
      6.

    6.  $property_type = 1;
      7.

    7.  $property_title = 'param_title';
      8.

    8.  $property_size = '';
      9.

    9.  $property_rows = '';
      10.

    10.  $property_cols = '';
      11.

    11.  $property_checked = '';
      12.

    12.  $property_default_value = '';
      13.

    13.  $property_order = '';
      14.

    14.  $property_comment = '';
      15.

    15.  $lists_id = '';
      16.

    16.
      17.

    17.  $newid = $SiteUsers->InsertExtraProperty($site_users_extra_property_id, $property_name, $property_type, $property_title, $property_size, $property_rows, $property_cols, $property_checked, $property_default_value, $property_order, $property_comment, $lists_id);
      18.

    18.
      19.

    19.  // Распечатаем результат
      20.

    20.  echo $newid;
      21.

    21.  ?>
      22.

    Возвращает

    результат выполнения:
      -1 - если неверно задано имя параметра или оно дублируется,

    1. - произошла ошибка выполнения запроса,
    2. - функция выполнена успешно

    [ Наверх ]

    SiteUsers::InsertSiteUser

InsertSiteUser(
array
$param );

    Описание

    Добавление/обновление информации о пользователе сайта

    Принимаемые параметры

    $param

    - $param['site_users_id'] идентификатор пользователя, необязательный параметр, указывается при обновлении данных о пользователе
    • $param['site_id'] идентификатор сайта
    • $param['site_users_group_id'] группа пользователей, необязательный параметр
    • $param['site_users_login'] логин
    • $param['site_users_password'] пароль
    • $param['site_users_email'] эл.почта
    • $param['site_users_name'] имя
    • $param['site_users_surname'] фамилия
    • $param['site_users_patronymic'] отчество
    • $param['site_users_company'] название компании
    • $param['site_users_phone'] телефон
    • $param['site_users_fax'] факс
    • $param['site_users_site'] сайт
    • $param['site_users_icq'] ICQ
    • $param['site_users_country'] страна
    • $param['site_users_postcode'] почтовый индекс
    • $param['site_users_city'] город
    • $param['site_users_date_registration'] дата регистрации, необязательное поле
    • $param['site_users_ip'] IP адрес, необязательное поле
    • $param['site_users_confirmation'] параметр, подтверждающий регистрацию пользователя (0 - не подтверждать регистрацию (по умолчанию), 1- подтверждить регистрацию)
    • $param['allow_access'] bool авторизировать пользователя сразу после регистрации;
    • $param['location'] string путь к странице, на которую перейдет пользователь при подтверждении регистрации
    • $param['not_send_mail_confirm'] bool флаг, указывающий на то, что письмо с подтверждением отправлять не надо
    • $param['xslname'] string XSL шаблон для отправки сообщения о регистрации
    • $param['users_id'] int идентификатор пользователя, если false - берется текущий пользователь.
    • $param['subject'] string тема письма с подтверждением регистрации.

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $param['site_users_name'] = 'Вася';
        5.

      5.  $param['site_users_surname'] = 'Пупкин';
        6.

      6.  $param['site_users_login'] = 'newlogin';
        7.

      7.  $param['site_users_password'] = '123456';
        8.

      8.  $param['site_users_email'] = 'admin@site.ru';
        9.

      9.  $param['users_id'] = false;
        10.

      10.
        11.

      11.  $newid = $SiteUsers->InsertSiteUser($param);
        12.

      12.
        13.

      13.  // Распечатаем результат
        14.

      14.  echo $newid;
        15.

      15.  ?>
        16.

    Возвращает

    идентификатор вставленной записи. Возможные коды ошибок:
    -4 - Не задан логин или пароль
    -3 - Дублирующийся логин
    -2 - Дублирующийся e-mail
    -1 - Некорректный e-mail

    [ Наверх ]

    SiteUsers::InsertUserGroup

InsertUserGroup(
int
$site_users_group_id, string
$site_users_group_name, string
$site_users_group_comment, [int
$users_id = false], [
$site_users_group_default = 0], [
$site_id = false] );

    Описание

    Вставки/обновление информации о группе пользователей

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы (если 0, то добавление, в противном случае - редактирование)

    $site_users_group_name

    имя группы

    $site_users_group_comment

    коментарий к группе

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_group_id = 0;
      5.

    5.  $site_users_group_name = 'Группа пользователей';
      6.

    6.  $site_users_group_comment = 'коментарий к группе';
      7.

    7.
      8.

    8.  $newid = $SiteUsers->InsertUserGroup($site_users_group_id, $site_users_group_name, $site_users_group_comment);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  echo $newid;
      12.

    12.  ?>
      13.

    $site_users_group_default

    $site_id

    Возвращает

    идентификатор вставленной/обновленной записи

    [ Наверх ]

    SiteUsers::InsertUsers

InsertUsers(
int
$site_users_group_id, int
$site_users_id, [int
$information_groups_id = 0] );

    Описание

    Добавление пользователя в группу

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы

    $site_users_id

    идентификатор пользователя сайта

    $information_groups_id

    идентификатор информационной группы, по умолчанию 0
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_group_id = 7;
      5.

    5.  $site_users_id = 5;
      6.

    6.
      7.

    7.  $result = $SiteUsers->InsertUsers($site_users_group_id, $site_users_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Добавление пользователя выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка добавления пользователя";
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    SiteUsers::OrderExtraProperty

OrderExtraProperty(
array
$mas_orders );

    Описание

    Метод обновления коэффициентов порядка сортировки

    Принимаемые параметры

    $mas_orders

    массив коэффициентов
      $mas_orders['order<идентификатор параметра>']

    [ Наверх ]

    SiteUsers::PrivateOfficeXML

PrivateOfficeXML(
string
$title, array
$links, string
$xslname, [int
$sire_users_id = false] );

    Описание

    УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.

    Принимаемые параметры

    $title

    заголовок

    $links

    массив с информацией о ссылке:
      $link[$i][0] string текст ссылки,
      $link[$i][1] string адрес ссылки

    $xslname

    наименование xsl шаблона

    $sire_users_id

    идентификатор пользователя

    [ Наверх ]

    SiteUsers::SearchIndexing

SearchIndexing(
$limit
$limit, $on_step
$on_step );

    Описание

    Функция обратного вызова для поисковой индексации данных модуля

    Принимаемые параметры

    $limit

    текущая позиция

    $on_step

    шаг

    [ Наверх ]

    SiteUsers::SelectExtraProperties

SelectExtraProperties(
[
$site_id = CURRENT_SITE] );

    Описание

    Получение всех дополнительных свойств

    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $resource = $SiteUsers->SelectExtraProperties();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Принимаемые параметры

    $site_id

    Возвращает

    результат запроса к базе данных

    [ Наверх ]

    SiteUsers::SelectSiteUsersGroups

SelectSiteUsersGroups(
[$param
$param = array()] );

    Описание

    Получение данных о всех группах пользователей сайта

    Принимаемые параметры

    $param

    массив параметров
    • $param['site_id'] int идентификатор сайта, если не передан - используется текущий, если false - все сайты
    • $param['order_field'] поле сортировки (по умолчанию сортировка по названию группы)
    • $param['order_direction'] направление сортировки (asc (по умолчанию) по возрастанию, desc - по убыванию)

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $resource = $SiteUsers->SelectSiteUsersGroups();
        5.

      5.
        6.

      6.  // Распечатаем результат
        7.

      7.  while($row = mysql_fetch_assoc($resource))
        8.

      8.  {
        9.

      9.      print_r($row);
        10.

      10.  }
        11.

      11.  ?>
        12.

    Возвращает

    в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    SiteUsers::SelectUserType

SelectUserType(
int
$site_users_group_id );

    Описание

    Метод возвращает параметры группы пользователя

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы пользователей (-1 выбрать все)
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_group_id = 7;
      5.

    5.
      6.

    6.  $resource = $SiteUsers->SelectUserType($site_users_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат запроса на выборку по идентификатору

    [ Наверх ]

    SiteUsers::SendNewPassword

SendNewPassword(
string
$login, string
$email, [
$xslname = ''], [array
$param = array()], string
$xslname='' );

    Описание

    Метод отправки нового пароля на почтовый ящик пользователю

    Принимаемые параметры

    $login

    логин пользователя

    $email

    e-mail пользователя

    $xslname=''

    xsl-шаблон для письма

    $param

    дополнительные параметры
    • $param['site_id'] идентификатор сайта, если не передан - используется текущий
    • $param['subject'] тема письма, по умолчанию 'Восстановление пароля'
    • $param['mail_type'] тип письма, по умолчанию 'text/plain'

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $login = 'tygra';
        5.

      5.  $email = 'tygra@localhost.ru';
        6.

      6.  $xslname = 'ПисьмоВосстановлениеПароля';
        7.

      7.
        8.

      8.  $result = $SiteUsers->SendNewPassword($login, $email, $xslname);
        9.

      9.
        10.

      10.  if ($result)
        11.

      11.  {
        12.

      12.      echo "Отправка пароля выполнена успешно";
        13.

      13.  }
        14.

      14.  else
        15.

      15.  {
        16.

      16.      echo "Ошибка отправки";
        17.

      17.  }
        18.

      18.  ?>
        19.

    $xslname

    [ Наверх ]

    SiteUsers::SendRegistInf

SendRegistInf(
array
$param );

    Описание

    Метод отправки пользователю регистрационной информации

    Принимаемые параметры

    $param

    массив параметров, содержит следующие элементы:

    • $param['site_user_id'] int идентификатор пользователя,
       $param
    • $param['xslname'] string шаблон письма пользователю,
       $param
    • $param['site_users_password'] string пароль пользователя, передается
     явно, т. к. не может быть получен из хэша пароля
    • $param['subject'] string тема письма
    • $param['mail_type'] тип письма - текст или HTML (по умолчанию - text/plain)
    • $param ['location'] string указатель на страницу перехода после
     подтверждения регистрации.
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $param['site_user_id'] = 3;
      5.

    5.  $param['site_users_password'] = 'tygra';
      6.

    6.  $param['mail_type'] = 'text/plain';
      7.

    7.  $param['subject'] = '';
      8.

    8.  $param['location'] = '';
      9.

    9.  $param['xslname'] = 'ПисьмоПодтверждениеРегистрации';
      10.

    10.
      11.

    11.  $result = $SiteUsers->SendRegistInf($param);
      12.

    12.
      13.

    13.  if ($result)
      14.

    14.  {
      15.

    15.      echo "Отправка данных выполнена успешно";
      16.

    16.  }
      17.

    17.  else
      18.

    18.  {
      19.

    19.      echo "Ошибка отправки";
      20.

    20.  }
      21.

    21.  ?>
      22.

    [ Наверх ]

    SiteUsers::SetConfirmation

SetConfirmation(
string
$site_user_index );

    Описание

    Установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)

    Принимаемые параметры

    $site_user_index

    индекс пользователя сайта

    Возвращает

    идентификатор пользователя, прошедшего подтверждение регистрации или false в противном случае

    [ Наверх ]

    SiteUsers::SetConfirmationID

SetConfirmationID(
int
$site_users_id );

    Описание

    Метод установки/снятия подтверждения регистрации пользователя определяемого  по идентификатору

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 6;
      5.

    5.
      6.

    6.  $result = $SiteUsers->SetConfirmationID($site_users_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Регистрация подтверждена";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка регистрации";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::SetCurrentSiteUser

SetCurrentSiteUser(
int
$site_users_id, [int
$expires = 2678400] );

    Описание

    Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя, должен быть больше 0

    $expires

    время в секундах, в течении которого авторизация пользователя активна.  по умолчанию = 2678400 (месяц)

    [ Наверх ]

    SiteUsers::SetDefaultGroup

SetDefaultGroup(
int
$site_users_group_id, [int
$site_id = false] );

    Описание

    Установка группы пользователей по умолчанию

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы по умолчанию

    $site_id

    идентификатор сайта, если false, то берется текущий сайт. Необязательный параметр
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_group_id = 6;
      5.

    5.
      6.

    6.  $result = $SiteUsers->SetDefaultGroup($site_users_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Группа установлена по умолчанию";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка выполнения операции";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::SetValueExtraProperty

SetValueExtraProperty(
int
$site_users_id, mixed
$extra_property_value, array
$param );

    Описание

    Установка значения дополнительного параметра пользователя

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $extra_property_value

    значение дополнительнго параметра

    $param

    массив дополнительных параметров, позволяющий задать дополнительное свойство как идентификатором array('id' => 1), так и именем array('name' => 'myname')
    • $param['id'] идентификатор свойства (site_users_extra_property_id)
    • $param['property_max_width'] максимальная ширина загружаемого изображения
    • $param['property_max_height'] максимальная высота загружаемого изображения
    • $param['avatar_max_width'] максимальная ширина аватара пользователя сайта
    • $param['avatar_max_height'] максимальная высота аватара пользователя сайта

      1.  <?php
        2.

      2.  $SiteUsers = new SiteUsers();
        3.

      3.
        4.

      4.  $param = array();
        5.

      5.  $param['id'] = 123;
        6.

      6.  $site_users_id = 1;
        7.

      7.  $extra_property_value = 'value';
        8.

      8.
        9.

      9.  $result = $SiteUsers->SetValueExtraProperty($site_users_id, $extra_property_value, $param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $result;
        13.

      13.  ?>
        14.

    [ Наверх ]

    SiteUsers::ShowSiteUserRegistartion

ShowSiteUserRegistartion(
int
$site_users_id, string
$xslname, [array
$external_property = array()], [array
$default_property = array()], [array
$param = array()] );

    Описание

    Вывод формы регистрации для пользователя сайта

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    наименование xsl-шаблона

    $external_property

    массив внешних параметров для XML

    $default_property

    массив дополнительных значений (заменяет введенные значения для полей пользователя)

    $param

    массив дополнительных параметров
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_users_id = 0;
      5.

    5.  $xslname = 'РегистрацияПользователя';
      6.

    6.
      7.

    7.  $newxml = $SiteUsers->ShowSiteUserRegistartion($site_users_id, $xslname);
      8.

    8.  ?>
      9.

    [ Наверх ]

    SiteUsers::ShowUserOffice

ShowUserOffice(
string
$xslname,
$external_propertys, [int
$sire_users_id = false], array
$external_property );

    Описание

    Метод отображения кабинета пользователя

    Принимаемые параметры

    $xslname

    $external_property

    массив внешних параметров, формат:
    • $external_property[0]['xml_name'] = 'xml_name';
    • $external_property[0]['value'] = 'value';

    $sire_users_id

    идентификатор пользователя, если не указан - берется текущий авторизированный пользователь, если есть
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $xslname = 'ЛичныйКабинетПользователя';
      5.

    5.
      6.

    6.  $SiteUsers->ShowUserOffice($xslname);
      7.

    7.  ?>
      8.

    $external_propertys

    [ Наверх ]

    SiteUsers::Unregistration

Unregistration(
string
$site_user_index );

    Описание

    Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя

    Принимаемые параметры

    $site_user_index

    индекс пользователя
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $site_user_index = '0c5379c156ce38088351810374204d19';
      5.

    5.
      6.

    6.  $result = $SiteUsers->Unregistration($site_user_index);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.  echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    SiteUsers::UnsetCurrentSiteUser

UnsetCurrentSiteUser(
 );

    Описание

    Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из

    кабинета пользователя

    [ Наверх ]

    SiteUsers::UpdateSiteUser

UpdateSiteUser(
int
$site_users_id, array
$param );

    Описание

    Обновление анкетных данных пользователя. Рекомендуется использовать InsertSiteUser().

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $param

    массив дополнительных параметров
    • $param['site_id'] идентификатор сайта (по умолчанию принимает значение идентификатора текущего сайта)
    • $param['site_user_login'] логин
    • $param['site_user_password'] пароль
    • $param['site_user_email'] e-mail
    • $param['site_users_name'] имя
    • $param['site_users_surname'] фамилия
    • $param['site_users_patronymic'] отчество
    • $param['site_users_company'] компания
    • $param['site_users_phone'] телефон
    • $param['site_users_fax'] факс
    • $param['site_users_site'] сайт
    • $param['site_users_icq'] аська
    • $param['site_users_country'] страна
    • $param['site_users_postcode'] почтовый индекс
    • $param['site_users_city'] город
    • $param['site_users_address'] адрес
    • $param['site_users_date_registration'] дата регистрации (не обязательное)
    • $param['site_users_ip'] IP (не обязательное)
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • $param['site_users_confirmation'] параметр, подтверждающий регистрацию пользователя (0 - не подтверждать регистрацию (по умолчанию), 1- подтверждить регистрацию)

    Возвращает

    boolean true при успешном обновлении,
      int 0, -1, -2, -3 - в случае возникновения раличного рода ошибок
      (0 - ошибка выполнения запроса, -1 - некорректный e-mail, -2 - дублирующийся e-mail, -3 - дублирующийся логин)

    see

    SiteUsers::InsertSiteUser()

    [ Наверх ]

    SiteUsers::ValidUser

ValidUser(
string
$login, string
$password, [int
$site_id = false] );

    Описание

    Метод возвращает идентификатор пользователя по его логину и паролю

    Принимаемые параметры

    $login

    логин пользователя

    $password

    пароль пользователя

    $site_id

    идентификатор сайта, если false, то берется текущий сайт. Необязательный параметр
    1.  <?php
      2.

    2.  $SiteUsers = new SiteUsers();
      3.

    3.
      4.

    4.  $login = 'admin';
      5.

    5.  $password = 'admin';
      6.

    6.
      7.

    7.  $result = $SiteUsers->ValidUser($login, $password);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $result;
      11.

    11.  ?>
      12.

    Возвращает

    int идентификатор пользователя, если пользователь зарегистрирован,

    1. - пользователь не зарегистрирован,
     -1 - если пользователь зарегистрирован, но не подтвердил свою регистрацию

    [ Наверх ]

    SiteUsers::_CallbackSearch

_CallbackSearch(
array
$row );

    Описание

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

    Принимаемые параметры

    $row

    массив с информацией о странице

    Возвращает

    дополнительный XML, включаемый в результат поиска

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Structure

Class Structure

[Строка 15]

Размещен: /Structure/Structure.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Структура".
Файл: /modules/Structure/Structure.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $a_count_property =

        Ассоциативный массив-Кэш количества свойств для разных сайтов

  • $cache_structure_property = array()

        Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.

  • $level =

        Максимальный уровень структуры

  • $menu_id =

        Идентификатор раздела меню

  • $parent_id =

        Идентификатор родительского узла элемента структуры

  • $separator =  ''

        Разделитель для уровней

  • $StructureMass = array ()

        Массив с элементами структуры

  • $StructureParentMass = array ()

        Массив родительских разделов

  • $structure_propertys_list =

        Хранит результат запроса на выборку дополнительных свойств структуры

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • void ClearStructure()

    Метод очистки кэша($this->structure_mass)

  • mixed CopyStructure()

    Копирование узла структуры

  • mixed CopyStructureProperty()

    Копирование дополнительного свойства узлов структуры

  • resource DeletePropertyValue()

    Метод для удаления значения свойства узла структуры

  • mixed DeleteStructure()

    Метод для удлаения узла структуры с его дочерними узлами

  • boolean delete_page()

    Устаревший метод удаления страницы. Рекомендуется использовать $this->DeleteStructure($structure_id);

  • истина DelStructurePropertys()

    Метод удаления дополнительного свойства

  • bool DelStructurePropertysValue()

    Метод удаления значений дополнительных свойств из таблицы связи

  • string GenXML4InfSys()

    Внутренний метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры. В своей работе использует массивы $this->MassIG, $this->MassII.

  • string GenXML4Shop()

    Внутренний метод построения XML для групп товаров и товаров интернет-магазина при отображении структуры. Использует в своей работе $this->MassShopGroups, $this->MassShopItems

  • string GenXml4StructureLevelMass()

    Внутренний метод генерации части XML-а для записей указанного уровня

  • resource GetAllStructure()

    Метод для получения списка всех узлов структуры сайта

  • resource GetAllStructureProperties()

    Метод для получения списка всех доп. свойств структуры

  • resource GetAllStructurePropertyValuesOfProperty()

    Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства

  • mixed GetCountProperty4Structure()

    Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют

  • array GetPropertyACountProperty()

    Получение количества свойств для разных сайтов

  • int GetPropertyLevel()

    Получение информации о максимальном уровне($this->level)

  • int GetPropertyMenuId()

    Получение информации о текущем разделе меню($this->menu_id)

  • string GetPropertySeparator()

    Получение информации о разделителе($this->separator)

  • array GetPropertyStructureMass()

    Получение информации об элементах структуры

  • array GetPropertyStructureParentMass()

    Получение информации о родительских разделах элемента структуры($this->StructureParentMass)

  • resource GetPropertyStructurePropertysList()

    Получение дополнительных свойств структуры

  • array GetPropertyValue()

    Метод для получения информации о значении свойства структуры

  • array GetStructure()

    Метод выборки всех страниц структуры

  • int GetStructureAccess()

    Получение информации о доступе к узлу элементов структуры

  • string GetStructureFilesPath()

    Получение пути к директории lib

  • boolean GetStructureForParent()

    Получение дочерних узлов структуры для узла структуры.

  • mixed GetStructureItem()

    Получение данных об элементе структуры. Идентификатор текущего узла структуры содержится в константе CURRENT_STRUCTURE_ID

  • mixed GetStructureItemDir()

    Получение пути хранения файлов узла структуры

  • mixed GetStructurePath()

    Определение полного пути к странице

  • array GetStructurePathArray()

    Получение пути от текущего узла к корневому

  • array GetStructureProperty()

    Метод возвращает заполненные св-ва узлов структуры

  • mixed GetStructurePropertyValue()

    Получение значения свойства узла структуры по идентификатору узла структуры и идентификатору свойства

  • string GetStructureXml()

    XML для узла структуры. Перед вызовом очистите $Structure->XmlDataFromGenXml4StructureLevelMass

  • string GetXml4StructurePropertys()

    Получение XML для свойств структуры. Перед вызовом метода необходимо вызвать $this->GetStructureProperty(array()); и передать массив ID узлов, для которых геренируются св-ва

  • array IndexationStructure()

    Метод индексации элементов структуры

  • mixed InsertStructure()

    Метод добавления/редактирования узла структуры

  • int InsertStructurePropertys()

    Метод вставки и редактирования дополнительного свойства для структуры

  • int InsertStructurePropertysValue()

    Метод вставки и редактирования значения дополнительного свойства в таблице связи

  • mixed IssetPath()

    Метод определения наличия пути

  • boolean NodeIsParent()

    Метод определения принадлежности узла структуры вышестоящему родителю

  • array SearchIndexing()

    Функция обратного вызова для поисковой индексации данных модуля

  • resource SelectStructureForParent()

    Получение информации об узлах структуры конкрентного уровня

  • resource SelectStructurePropertys()

    Метод выбора дополнительного свойства структуры определенного сайта(false - выбор всех)

  • boolean ShowStructure()

    Метод для отображения структуры в клиентском разделе сайта

  • array SortStructureMass()

    Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией

  • void UpdateSubDir()

    Метод обновления идентификатора меню у подразделов определенного раздела

  • string _CallbackSearch()

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

Унаследованные методы

Описания методов

    Structure::ClearStructure

ClearStructure(
 );

    Описание

    Метод очистки кэша($this->structure_mass)

    [ Наверх ]

    Structure::CopyStructure

    CopyStructure(
int
$structure_id, [int
$site_id = false], [
$new_structure_id = false], [array
$array_document_ids = array ()], [int
$array_menu_ids = array()], [array
$array_datatemplate_ids = array()], [array
$array_template_ids = array()], [
$is_assign_arr = array()], [
$shop_assign_arr = array()] );

    Описание

    Копирование узла структуры

    Принимаемые параметры

    $structure_id

    идентификатор копируемого узла структуры

    $site_id

    идентификатор сайта, в который нужно скопировать структуру (если False, то в текущий сайт)

    $array_document_ids

    Массив с идентификаторами старых и новых документов
    • int $array_document_ids['old_id'] = $new_id Идентификатор документа, который необходимо сопоставить со скопированной структурой (по умолчанию в соответствие ставится идентификатор документа копируемого узла структуры)

    $array_menu_ids

    Массив соответствий старых и новых идентификаторов меню, к которым необходимо отнести скопированный узел структуры (если не передан, то к тому же, что и копируемый узел)

    $array_datatemplate_ids

    Массив соответствий старых и новых идентификаторов шаблонов, с которыми необходимо связать скопированный узел структуры (если не передан, то к тому же, что и копируемый узел)

    $array_template_ids

    Массив соответствий старых и новых идентификаторов макетов, с которыми необходимо связать скопированный узел структуры (если не передан, то к тому же, что и копируемый узел)
    1.  <?php
      2.

    2.  $Structure = new Structure();
      3.

    3.
      4.

    4.  $structure_id = 22;
      5.

    5.
      6.

    6.  $newid = $Structure->CopyStructure($structure_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    $new_structure_id

    $is_assign_arr

    $shop_assign_arr

    Возвращает

    идентификатор копии узла структуры в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Structure::CopyStructureProperty

CopyStructureProperty(
$structure_property_id
$structure_property_id, [
$site_id = CURRENT_SITE] );

    Описание

    Копирование дополнительного свойства узлов структуры

    Принимаемые параметры

    $structure_property_id

    $site_id

    Возвращает

    идентификатор копии дополнительного свойства узлов структуры в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Structure::DeletePropertyValue

DeletePropertyValue(
int
$structure_propertys_values_id, [array
$param = array ()] );

    Описание

    Метод для удаления значения свойства узла структуры

    Принимаемые параметры

    $structure_propertys_values_id

    идентификатор значения свойства, которое нужно удалить

    $param

    массив дополнительных параметров
    • $param['del_big_image'] параметр, определяющий удалять файл большого изображения или нет(true - удалять (по умолчанию), false - не удалять)
    • $param['del_small_image'] параметр, определяющий удалять файл малого изображения или нет(true - удалять (по умолчанию), false - не удалять)

      Пример использования:

      1.  <?php
        2.

      2.  $structure = new Structure();
        3.

      3.
        4.

      4.  // Идентификатор удаляемого значения свойства узла структуры
        5.

      5.  $structure_property_value_id = 133;
        6.

      6.
        7.

      7.  $result = $structure->DeletePropertyValue($structure_property_value_id);
        8.

      8.
        9.

      9.  if ($result)
        10.

      10.  {
        11.

      11.      echo "Удаление выполнено успешно";
        12.

      12.  }
        13.

      13.  else
        14.

      14.  {
        15.

      15.      echo "Ошибка удаления";
        16.

      16.  }
        17.

      17.  ?>
        18.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    Structure::DeleteStructure

DeleteStructure(
int
$structure_id );

    Описание

    Метод для удлаения узла структуры с его дочерними узлами

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор удаляемого узла структуры
      5.

    5.  $structure_id = 82;
      6.

    6.
      7.

    7.  $result = $structure->DeleteStructure($structure_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    результат выполнения запроса

    [ Наверх ]

    Structure::delete_page

delete_page(
int
$structure_id );

    Описание

    Устаревший метод удаления страницы. Рекомендуется использовать $this->DeleteStructure($structure_id);

    Принимаемые параметры

    $structure_id

    идентификатор страницы

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    see

    Structure::DeleteStructure()

    [ Наверх ]

    Structure::DelStructurePropertys

DelStructurePropertys(
int
$structure_propertys_id );

    Описание

    Метод удаления дополнительного свойства

    Принимаемые параметры

    $structure_propertys_id

    идентификатор удаляемого дополнительного свойства
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор удаляемого дополнительного свойства структуры
      5.

    5.  $structure_propertys_id = 8;
      6.

    6.
      7.

    7.  $result = $structure->DelStructurePropertys($structure_propertys_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    Structure::DelStructurePropertysValue

DelStructurePropertysValue(
int
$structure_id );

    Описание

    Метод удаления значений дополнительных свойств из таблицы связи

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор структуры для удаляемых дополнительных свойств
      5.

    5.  $structure_id = 84;
      6.

    6.
      7.

    7.  $result = $structure->DelStructurePropertysValue($structure_id);
      8.

    8.
      9.

    9.  if ($result)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    Structure::GenXML4InfSys

GenXML4InfSys(
int
$inf_sys_id, int
$menu_id, int
$level, int
$inf_group_id, string
$full_path, [array
$param = array ()] );

    Описание

    Внутренний метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры. В своей работе использует массивы $this->MassIG, $this->MassII.

    Принимаемые параметры

    $inf_sys_id

    идентификатор информационной системы

    $menu_id

    идентификатор меню

    $level

    текущий уровень вложенности

    $inf_group_id

    идентификатор группы элементов информационной системы

    $full_path

    полный путь к текущей группе элементов информационной системы

    $param

    ассоциативный массив включающий следующие параметры:  $param['show_groups'] - отображать ли группы элементов инфосистемы  $param['show_items'] - отображать ли элементы инфосистемы  $param['hidden_groups'] - массив групп информационных систем, скрытых для показа в текущем меню

    Возвращает

    XML для отображения элементов и групп элементов инфосистем при отображении структуры

    [ Наверх ]

    Structure::GenXML4Shop

GenXML4Shop(
int
$shop_shops_id, int
$menu_id, int
$level, int
$shop_groups_id, string
$full_path, [array
$param = array ()] );

    Описание

    Внутренний метод построения XML для групп товаров и товаров интернет-магазина при отображении структуры. Использует в своей работе $this->MassShopGroups, $this->MassShopItems

    Принимаемые параметры

    $shop_shops_id

    $menu_id

    $level

    $shop_groups_id

    $full_path

    $param

    Возвращает

    XML для отображения элементов и групп элементов инфосистем при отображении структуры

    [ Наверх ]

    Structure::GenXml4StructureLevelMass

GenXml4StructureLevelMass(
int
$parent_id, array
$access, [int
$level = 0], [array
$param = array ()] );

    Описание

    Внутренний метод генерации части XML-а для записей указанного уровня

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $access

    массив с правами доступа

    $level

    текущий уровень, по умолчанию 0

    $param

    ассоциативный массив включающий следующие параметры:
    • $param['show_groups'] - отображать ли группы элементов инфосистемы
    • $param['show_items'] - отображать ли элементы инфосистемы
    • $param['hidden_groups'] - массив групп информационных элементов, скрытых для показа в текущем меню
    • $param['hidden_groups_shop'] - массив групп магазинов, скрытых для показа в текущем меню
    • $param['show_shop_groups'] - отображать ли группы товаров
    • $param['show_shop_items'] - отображать ли товары
    • $param['hidden_shop_groups'] - массив групп, скрытых для показа в текущем меню
    • $param['show_document_content'] - отображать содержимое статичной страницы, по умолчанию false
    • $param['xml_show_structure_property'] разрешает указание в XML значений свойств узлов структуры, по умолчанию true

    Возвращает

    часть XML-а для записей указанного уровня

    [ Наверх ]

    Structure::GetAllStructure

GetAllStructure(
[int
$site_id = false] );

    Описание

    Метод для получения списка всех узлов структуры сайта

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит узел структуры, если false - учитываются все сайты
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.  // Идентификатор сайта
      4.

    4.  $site_id = 1;
      5.

    5.  $resource = $structure->GetAllStructure($site_id);
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    Возвращает

    с информацией об узлах структуры

    [ Наверх ]

    Structure::GetAllStructureProperties

GetAllStructureProperties(
[int
$site_id = false] );

    Описание

    Метод для получения списка всех доп. свойств структуры

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит свойство, если false - учитываются все сайты
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор сайта
      5.

    5.  $site_id = 1;
      6.

    6.
      7.

    7.  $resource = $structure->GetAllStructureProperties($site_id);
      8.

    8.
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    с информацией о свойстве

    [ Наверх ]

    Structure::GetAllStructurePropertyValuesOfProperty

GetAllStructurePropertyValuesOfProperty(
[int
$structure_propertys_id = false] );

    Описание

    Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства

    Принимаемые параметры

    $structure_propertys_id

    свойства, которому принадлежит значение свойства, если false-учитываются все свойства
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор свойства
      5.

    5.  $structure_propertys_id = 7;
      6.

    6.
      7.

    7.  $resource = $structure->GetAllStructurePropertyValuesOfProperty($structure_propertys_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($resource))
      11.

    11.  {
      12.

    12.      print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    с информацией о значениях свойств

    [ Наверх ]

    Structure::GetCountProperty4Structure

GetCountProperty4Structure(
int
$site_id );

    Описание

    Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют

    Принимаемые параметры

    $site_id

    идентификатор сайта
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор сайта
      5.

    5.  $site_id = 1;
      6.

    6.
      7.

    7.  $count = $structure->GetCountProperty4Structure($site_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  echo $count;
      11.

    11.  ?>
      12.

    Возвращает

    число свойств раздела сайта или false, если свойства отсутствуют

    [ Наверх ]

    Structure::GetPropertyACountProperty

GetPropertyACountProperty(
 );

    Описание

    Получение количества свойств для разных сайтов

    Возвращает

    ассоциативный массив-Кэш количества свойств для разных сайтов

    [ Наверх ]

    Structure::GetPropertyLevel

GetPropertyLevel(
 );

    Описание

    Получение информации о максимальном уровне($this->level)

    Возвращает

    значение максимального уровня

    [ Наверх ]

    Structure::GetPropertyMenuId

GetPropertyMenuId(
 );

    Описание

    Получение информации о текущем разделе меню($this->menu_id)

    Возвращает

    идентификатор текущего раздела

    [ Наверх ]

    Structure::GetPropertySeparator

GetPropertySeparator(
 );

    Описание

    Получение информации о разделителе($this->separator)

    Возвращает

    разделитель для уровней

    [ Наверх ]

    Structure::GetPropertyStructureMass

GetPropertyStructureMass(
 );

    Описание

    Получение информации об элементах структуры

    Возвращает

    массив с элементами структуры

    [ Наверх ]

    Structure::GetPropertyStructureParentMass

GetPropertyStructureParentMass(
 );

    Описание

    Получение информации о родительских разделах элемента структуры($this->StructureParentMass)

    Возвращает

    информация о родительских разделах

    [ Наверх ]

    Structure::GetPropertyStructurePropertysList

GetPropertyStructurePropertysList(
 );

    Описание

    Получение дополнительных свойств структуры

    Возвращает

    результат запроса на выборку дополнительных свойств структуры

    [ Наверх ]

    Structure::GetPropertyValue

GetPropertyValue(
int
$structure_propertys_values_id );

    Описание

    Метод для получения информации о значении свойства структуры

    Принимаемые параметры

    $structure_propertys_values_id

    идентификатор значения свойства
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  // Идентификатор значения свойства структуры сайта
      5.

    5.  $structure_propertys_values_id = 9;
      6.

    6.
      7.

    7.  $row = $structure->GetPropertyValue($structure_propertys_values_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    с информацией о значении свойства или false

    [ Наверх ]

    Structure::GetStructure

GetStructure(
string
$separator, int
$site_id, int
$menu_id, int
$level, int
$parent_id, [int
$edit_id = false], [array
$param = false] );

    Описание

    Метод выборки всех страниц структуры

    Принимаемые параметры

    $separator

    разделитель для уровней

    $menu_id

    идентификатор раздела меню(если не задан - все разделы меню)

    $level

    максимальный уровень

    $parent_id

    идентификатор родительского узла

    $edit_id

    идентификатор редактируемой записи(необязательный параметр), для того, чтобы убрать редактируемую запись из списка возможных род. разделов

    $param

    массив дополнительных параметров
    • $param['select_structure_property'] разрешает заполнение кэша значений свойств узлов структуры, по умолчанию true

      Пример использования:

      1.  <?php
        2.

      2.  $structure = new Structure();
        3.

      3.
        4.

      4.  $separator = '&nbsp';
        5.

      5.  $menu_id = 1;
        6.

      6.  $level = 0;
        7.

      7.  $parent_id = 0;
        8.

      8.  $site_id = 1;
        9.

      9.
        10.

      10.  $array = $structure->GetStructure($separator, $site_id, $menu_id, $level, $parent_id);
        11.

      11.
        12.

      12.  // Распечатаем результат
        13.

      13.  print_r($array);
        14.

      14.  ?>
        15.

    $site_id

    or boolean $site_id идентификатор сайта, если равен 0 или false - то сайт игнорируется

    Возвращает

    информация об узлах структуры сайта

    [ Наверх ]

    Structure::GetStructureAccess

GetStructureAccess(
int
$structure_id );

    Описание

    Получение информации о доступе к узлу элементов структуры

    Принимаемые параметры

    $structure_id

    идентификатор страницы структуры
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $structure_id = CURRENT_STRUCTURE_ID;
      5.

    5.
      6.

    6.  $result = $structure->GetStructureAccess($structure_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    Возвращает

    ID группы пользователей сайта, которой доступен узел.
    1. - доступно всем, -1 - узел (или один из родительских узлов) не найден.

    [ Наверх ]

    Structure::GetStructureFilesPath

GetStructureFilesPath(
int
$lib_id );

    Описание

    Получение пути к директории lib

    Принимаемые параметры

    $lib_id

    Идентификатор типовой динамической страницы

    Возвращает

    путь к файлу

    [ Наверх ]

    Structure::GetStructureForParent

GetStructureForParent(
int
$parent_id, string
$separator, int
$current_level );

    Описание

    Получение дочерних узлов структуры для узла структуры.

    Результирующий массив размещается в $this->StructureMass  Перед вызовом метода должен быть заполнен $this->StructureParentMass с помощью метода $this->GetStructure()

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $separator

    разделитель для уровней

    $current_level

    текущий уровень вложенности. Для корневого раздела указывается 0.

    Возвращает

    формирует массив с информацией о подразделах, а в случае ошибки возвращает ложь

    see

    Structure::GetStructure()

    [ Наверх ]

    Structure::GetStructureItem

GetStructureItem(
int
$structure_id, [array
$param = array ()] );

    Описание

    Получение данных об элементе структуры. Идентификатор текущего узла структуры содержится в константе CURRENT_STRUCTURE_ID

    Принимаемые параметры

    $structure_id

    идетификатор структуры

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      Пример использования:

      1.  <?php
        2.

      2.  $structure = new Structure();
        3.

      3.
        4.

      4.  // Воспользуемся Идентификатором текущего узла структуры сайта
        5.

      5.  $structure_id = CURRENT_STRUCTURE_ID;
        6.

      6.
        7.

      7.  $row = $structure->GetStructureItem($structure_id);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r($row);
        11.

      11.  ?>
        12.

    Возвращает

    ассоциативный массив с данными об узле структуры или false, если узел не найден

    [ Наверх ]

    Structure::GetStructureItemDir

GetStructureItemDir(
$structure_id
$structure_id );

    Описание

    Получение пути хранения файлов узла структуры

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    Возвращает

    путь к узлу структуры или ложь, если такого узла структуры не существует

    [ Наверх ]

    Structure::GetStructurePath

GetStructurePath(
int
$structure_id, [int
$type = 0], [mixed
$path = ''] );

    Описание

    Определение полного пути к странице

    Принимаемые параметры

    $structure_id

    идентификатор раздела, для него определяется полный пути снизу вверх

    $type

    тип результата(строка -- 0 или масссив -- 1). по умолчанию 0

    $path

    переменная, в которую возвращается результат(строка, либо массив)
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $structure_id = CURRENT_STRUCTURE_ID;
      5.

    5.  $type = 0;
      6.

    6.  $path = $structure->GetStructurePath($structure_id, $type);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $path;
      10.

    10.  ?>
      11.

    Возвращает

    полный путь к странице(в виде строки или массива)

    [ Наверх ]

    Structure::GetStructurePathArray

GetStructurePathArray(
integer
$dir_id, [boolean
$first_call = true] );

    Описание

    Получение пути от текущего узла к корневому

    Принимаемые параметры

    $dir_id

    идентификатор текущего узла

    $first_call

    первый ли это вызов функции
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  //Идентификатор текущего узла структуры сайта
      5.

    5.  $dir_id = 86;
      6.

    6.
      7.

    7.  $row = $structure->GetStructurePathArray($dir_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив данных

    [ Наверх ]

    Structure::GetStructureProperty

GetStructureProperty(
array
$propertylist );

    Описание

    Метод возвращает заполненные св-ва узлов структуры

    (также метод заполняет значение кэша $this->cache_structure_property)

    Принимаемые параметры

    $propertylist

    массив ID узлов структуры, например $propertylist[] = 80;
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $propertylist = array();
      5.

    5.  $propertylist[] = 80;
      6.

    6.
      7.

    7.  $row = $structure->GetStructureProperty($propertylist);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив свойств элемента

    [ Наверх ]

    Structure::GetStructurePropertyValue

GetStructurePropertyValue(
int
$structure_id, int
$structure_propertys_id );

    Описание

    Получение значения свойства узла структуры по идентификатору узла структуры и идентификатору свойства

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    $structure_propertys_id

    идентификатор дополнительного свойства
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $structure_id = CURRENT_STRUCTURE_ID;
      5.

    5.  $structure_propertys_id = 10;
      6.

    6.
      7.

    7.  $row = $structure->GetStructurePropertyValue($structure_id, $structure_propertys_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    ассоциативный массив с информацией о значении дополнительного свойства узла структуры в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Structure::GetStructureXml

GetStructureXml(
$structure_id
$structure_id, [$param
$param = array()] );

    Описание

    XML для узла структуры. Перед вызовом очистите $Structure->XmlDataFromGenXml4StructureLevelMass

    Принимаемые параметры

    $structure_id

    идентификатор узла структуры

    $param

    - $param['level'] уровень вложенности, который необходимо генерировать

    Возвращает

    XML

    [ Наверх ]

    Structure::GetXml4StructurePropertys

GetXml4StructurePropertys(
int
$structure_id );

    Описание

    Получение XML для свойств структуры. Перед вызовом метода необходимо вызвать $this->GetStructureProperty(array()); и передать массив ID узлов, для которых геренируются св-ва

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $structure_id = CURRENT_STRUCTURE_ID;
      5.

    5.
      6.

    6.  $xml = $structure->GetXml4StructurePropertys($structure_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo htmlspecialchars($xml);
      10.

    10.  ?>
      11.

    Возвращает

    XML для свойств структуры

    [ Наверх ]

    Structure::IndexationStructure

IndexationStructure(
int
$limit, int
$on_step, [array
$parameters = array ()] );

    Описание

    Метод индексации элементов структуры

    Принимаемые параметры

    $limit

    ограничение(по сколько элементов индексировать)

    $on_step

    шаг для индексации

    $parameters

    массив дополнительных параметров
    • $parameters['document_id'] - идентификатор индексируемого документа при событийной индексации
    • $parameters['structure_id'] - идентификатор индексируемого узла структуры при событийной индексации

      Пример использования:

      1.  <?php
        2.

      2.  $structure = new Structure();
        3.

      3.
        4.

      4.  $limit = 5;
        5.

      5.  $on_step = 10;
        6.

      6.
        7.

      7.  $row = $structure->IndexationStructure($limit, $on_step);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  print_r($row);
        11.

      11.  ?>
        12.

    Возвращает

    массив с данными о проиндексированных элементах

    [ Наверх ]

    Structure::InsertStructure

InsertStructure(
array
$param );

    Описание

    Метод добавления/редактирования узла структуры

    Принимаемые параметры

    $param

    массив параметров
    • int $param['structure_id'] идентификатор узла структуры
    • int $param['menu_id'] идентификатор раздела меню
    • int $param['templates_id'] идентификатор макета
    • int $param['data_templates_id'] идентификатор шаблона страниц
    • int $param['site_id'] идентификатор сайта
    • int $param['documents_id'] идентификатор документа
    • int $param['structure_parent_id'] идентификатор родительского раздела
    • int $param['structure_show'] флаг вывода элемента структуры
    • string $param['structure_menu_name'] название раздела в меню
    • string $param['structure_title'] заголовок для раздела
    • string $param['structure_description'] описание раздела
    • string $param['structure_keywords'] ключевые фразы
    • string $param['structure_external_link'] внешняя ссылка для раздела
    • int $param['structure_order'] порядок сортировки
    • string $param['structure_path_name'] название раздела
    • int $param['structure_type'] тип раздела. 0 - Страница, 1 - Динамическая страница, 2 - Типовая динамическая страница
    • string $param['module'] значение для динамической страницы
    • string $param['module_config'] нстройки для динамической страницы
    • int $param['structure_activity'] параметр, определяющий активность узла структуры(1 по умолчанию) - узел активен, 0 - неактивен)
    • int $param['structure_access'] параметр, определяющий группу пользователей сайта, имеющих право доступа к узлу структуры.
     Значения 0 (узел доступен всем, по умолчанию), -1 - как у родителя, другое значение - идентификатор группы пользователей сайта)
    • int $param['structure_access_protocol'] параметр, определяющий протокол, используемый для доступа к узлу структуры. 0 - HTTP, 1 - HTTPS
    • int $param['structure_allow_indexation'] параметр, определяющий индексировать узел структуры или нет(1 по умолчанию) - индексировать, 0 - не индексировать)
    • int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    • int $param['lib_id'] идентификатор типовой динамической страницы

      Пример использования:

      1.  <?php
        2.

      2.  $structure = new Structure();
        3.

      3.
        4.

      4.  $param = array();
        5.

      5.
        6.

      6.  $param['structure_id'] = '';
        7.

      7.  $param['menu_id'] = 1;
        8.

      8.  $param['templates_id'] = 1;
        9.

      9.  $param['data_templates_id']= 1;
        10.

      10.  $param['site_id'] = 1;
        11.

      11.  $param['documents_id'] = 55;
        12.

      12.  $param['structure_parent_id'] = 0;
        13.

      13.  $param['structure_show'] = 1;
        14.

      14.  $param['structure_menu_name'] = 'Название в меню';
        15.

      15.  $param['structure_title'] = 'SEO - заголовок';
        16.

      16.  $param['structure_description'] = 'SEO - описание';
        17.

      17.  $param['structure_keywords'] = 'SEO - ключевые слова';
        18.

      18.  $param['structure_order'] = 50;
        19.

      19.  $param['structure_path_name'] = 'page';
        20.

      20.  $param['structure_type'] = 2;
        21.

      21.  $param['module'] = '';
        22.

      22.  $param['module_config'] = '';
        23.

      23.  $param['structure_access'] = 0;
        24.

      24.  $param['structure_activity'] = 1;
        25.

      25.  $param['structure_allow_indexation'] = 1;
        26.

      26.  $param['lib_id'] = 9;
        27.

      27.
        28.

      28.  $new_structure_id = $structure->InsertStructure($param);
        29.

      29.
        30.

      30.  // Распечатаем результат
        31.

      31.  echo $new_structure_id;
        32.

      32.  ?>
        33.

    Возвращает

    идентификатор добавленного/измененного узла структуры в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    Structure::InsertStructurePropertys

InsertStructurePropertys(
int
$type, int
$structure_propertys_id, int
$site_id, string
$structure_propertys_name, int
$structure_propertys_type, int
$structure_propertys_order, string
$structure_propertys_define_value, string
$structure_propertys_xml_name, int
$structure_propertys_lists_id, int
$structure_propertys_information_systems_id, [int
$users_id = false] );

    Описание

    Метод вставки и редактирования дополнительного свойства для структуры

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_propertys_id

    идентификатор дополнительного свойства

    $site_id

    идентификатор сайта

    $structure_propertys_name

    наименование дополнительного свойства

    $structure_propertys_type

    тип дополнительного свойства

    $structure_propertys_order

    порядок сортировки

    $structure_propertys_define_value

    значение по умолчанию для дополнительного свойства

    $structure_propertys_xml_name

    имя xml тега для дополнительного свойства

    $structure_propertys_lists_id

    идентификатор списка(если тип свойства - список)

    $structure_propertys_information_systems_id

    идентификатор информационной системы(для типа информационная система)

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $structure_propertys_id = '';
      6.

    6.  $site_id = 1;
      7.

    7.  $structure_propertys_name = 'свойство';
      8.

    8.  $structure_propertys_type = 0;
      9.

    9.  $structure_propertys_order = 50;
      10.

    10.  $structure_propertys_define_value = '';
      11.

    11.  $structure_propertys_xml_name = 'myname';
      12.

    12.  $structure_propertys_lists_id = '';
      13.

    13.  $structure_propertys_information_systems_id = 0;
      14.

    14.
      15.

    15.  $new_structure_propertys_id = $structure->InsertStructurePropertys($type, $structure_propertys_id, $site_id, $structure_propertys_name, $structure_propertys_type, $structure_propertys_order, $structure_propertys_define_value, $structure_propertys_xml_name, $structure_propertys_lists_id, $structure_propertys_information_systems_id);
      16.

    16.
      17.

    17.  // Распечатаем результат
      18.

    18.  echo $new_structure_propertys_id;
      19.

    19.  ?>
      20.

    Возвращает

    идентификатор отредактированного(вставленного) дополнительного свойства

    [ Наверх ]

    Structure::InsertStructurePropertysValue

InsertStructurePropertysValue(
int
$type, int
$structure_propertys_values_id, int
$structure_id, int
$structure_propertys_id, string
$structure_propertys_values_value, [
$structure_propertys_values_file = ''], [
$structure_propertys_values_value_small = ''], [
$structure_propertys_values_file_small = ''] );

    Описание

    Метод вставки и редактирования значения дополнительного свойства в таблице связи

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_propertys_values_id

    идентификатор значения дополнительного свойства

    $structure_id

    идентификатор раздела структуры

    $structure_propertys_id

    идентификатор дополнительного свойства

    $structure_propertys_values_value

    значение дополнительного свойства

    $structure_propertys_values_file

    $structure_propertys_values_value_small

    $structure_propertys_values_file_small

    Возвращает

    идентификатор отредактированной(добавленной) записи

    [ Наверх ]

    Structure::IssetPath

IssetPath(
array
$path_array, int
$menu_id );

    Описание

    Метод определения наличия пути

    Принимаемые параметры

    $path_array

    массив с элементами пути, ID меню

    $menu_id

    идентификатор раздела меню

    Возвращает

    идентификатор родительского раздела - при наличии у данного меню страницы с аналогичным путем, false при ее отсутствии

    [ Наверх ]

    Structure::NodeIsParent

NodeIsParent(
int
$children_node_id, int
$parent_node_id );

    Описание

    Метод определения принадлежности узла структуры вышестоящему родителю

    Принимаемые параметры

    $children_node_id

    идентификатор дочернего узла

    $parent_node_id

    идетификатор узла - возможного родителя
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $children_node_id = 88;
      5.

    5.  $parent_node_id = 80;
      6.

    6.
      7.

    7.  if ($structure->NodeIsParent($children_node_id, $parent_node_id))
      8.

    8.  {
      9.

    9.      echo "Узел {$children_node_id} является дочерним для узла {$parent_node_id}\n";
      10.

    10.  }
      11.

    11.  else
      12.

    12.  {
      13.

    13.      echo "Узел {$children_node_id} не является дочерним для узла {$parent_node_id}\n";
      14.

    14.  }
      15.

    15.  ?>
      16.

    Возвращает

    истина, если узел принадлежит родителю, иначе ложь

    [ Наверх ]

    Structure::SearchIndexing

SearchIndexing(
$limit
$limit, $on_step
$on_step );

    Описание

    Функция обратного вызова для поисковой индексации данных модуля

    Принимаемые параметры

    $limit

    текущая позиция

    $on_step

    шаг

    [ Наверх ]

    Structure::SelectStructureForParent

SelectStructureForParent(
int
$structure_parent_id, [int
$menu_id = false], [int
$site_id = false] );

    Описание

    Получение информации об узлах структуры конкрентного уровня

    Принимаемые параметры

    $structure_parent_id

    идентификатор родительского раздела

    $menu_id

    идентификатор меню

    $site_id

    идентификатор сайта

    Возвращает

    Ответ базы

    [ Наверх ]

    Structure::SelectStructurePropertys

SelectStructurePropertys(
int
$site_id, [int
$structure_propertys_id = false] );

    Описание

    Метод выбора дополнительного свойства структуры определенного сайта(false - выбор всех)

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $structure_propertys_id

    идентификатор дополнительного свойства
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $site_id = 1;
      5.

    5.  $structure_propertys_id = 10;
      6.

    6.
      7.

    7.  $resource = $structure->SelectStructurePropertys($site_id, $structure_propertys_id);
      8.

    8.
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    результат выборки информации о дополнительном свойстве(обо всех дополнительных свойствах)

    [ Наверх ]

    Structure::ShowStructure

ShowStructure(
int
$menu_id, string
$xsl, [array
$param = array ()], [array
$external_propertys = array ()] );

    Описание

    Метод для отображения структуры в клиентском разделе сайта

    Принимаемые параметры

    $menu_id

    ID меню для отображения

    $xsl

    имя XSL шаблона для отображения

    $param

    содержит дополнительные параметры
    • $param['parent_id'] - ID родительского узла
    • $param['cache'] - разрешение кэширования, по умолчанию true
    • $param['show_groups'] - отображать ли группы элементов инфосистемы, по умолчанию false
    • $param['show_items'] - отображать ли элементы инфосистемы, может принимать значение true, false или массив идентификаторов элементов, подлежащих отображению. по умолчанию false
    • $param['level'] - уровень, до которого выбирать узлы в дереве структуры. по умолчанию равен -1.
    • $param['show_information_systems'] - отображать ли элементы указанных инфосистемы(массив)
    • $param['do_not_show_information_systems'] - отображать ли элементы указанных инфосистемы(массив)
    • $param['hidden_groups'] - массив групп инфосистем, скрытых для показа в текущем меню
    • $param['hidden_groups_shop'] - массив групп товаров, скрытых для показа в текущем меню
    • $param['site_id'] - ID сайта, для которого отображается структура, по умолчанию равен текущему сайту
    • $param['show_shop_groups'] - отображать ли группы товаров, по умолчанию false
    • $param['show_shop_items'] - отображать ли товары, может принимать значение true, false или массив идентификаторов товаров, подлежащих отображению. по умолчанию false
    • $param['show_shops'] - массив идентификаторов магазинов, подлежащих отображению
    • $param['do_not_show_shops'] - массив идентификаторов магазинов, исключаемых из отображения
    • $param['xml_show_structure_property'] разрешает указание в XML значений свойств узлов структуры, по умолчанию true
    • $param['external_xml'] - внешний XML в документ. Внешний XML отличается от параметров $external_propertys тем, что добавляется блоком в начало документа

    $external_propertys

    многомерный массив дополнительных свойств для включения в исходный XML код
    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $xsl = 'Картасайта';
      5.

    5.  $menu_id = false;
      6.

    6.
      7.

    7.  // Необязательные параметры
      8.

    8.  $param = array();
      9.

    9.  $param['parent_id'] = 0;
      10.

    10.
      11.

    11.  // Внешние параметры для передачи в XML
      12.

    12.  $external_propertys = array();
      13.

    13.  $external_propertys['некий_внешний_параметр'] = "некое значение";
      14.

    14.
      15.

    15.  $structure->ShowStructure($menu_id, $xsl, $param, $external_propertys);
      16.

    16.  ?>
      17.

    Возвращает

    истину при успешном отображении меню

    [ Наверх ]

    Structure::SortStructureMass

SortStructureMass(
int
$parent_id, [array
$mass = array ()] );

    Описание

    Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $mass

    массив с элементами структуры
    Пример использования:
    1.  <?php
      2.

    2.  $Structure = new Structure();
      3.

    3.
      4.

    4.  $parent_id = 0;
      5.

    5.
      6.

    6.  $row = $Structure->SortStructureMass($parent_id, $mass=array());
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    отсортированный массив

    [ Наверх ]

    Structure::UpdateSubDir

UpdateSubDir(
int
$structure_id, int
$menu_id );

    Описание

    Метод обновления идентификатора меню у подразделов определенного раздела

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры

    $menu_id

    идентификатор раздела меню

    Пример использования:
    1.  <?php
      2.

    2.  $structure = new Structure();
      3.

    3.
      4.

    4.  $structure_id = CURRENT_STRUCTURE_ID;
      5.

    5.  $menu_id = 2;
      6.

    6.
      7.

    7.  $structure->UpdateSubDir($structure_id, $menu_id);
      8.

    8.  ?>
      9.

    [ Наверх ]

    Structure::_CallbackSearch

_CallbackSearch(
array
$row );

    Описание

    Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска

    Принимаемые параметры

    $row

    массив с информацией о странице

    Возвращает

    дополнительный XML, включаемый в результат поиска

    [ Наверх ]

Описания переменных

  • $a_count_property =  [Строка 75]
    •

  • Data type: array
    •

    Описание

    Ассоциативный массив-Кэш количества свойств для разных сайтов

  • $cache_structure_property = array() [Строка 63]
    •

  • Data type: array
    •

    Описание

    Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.

  • $level =  [Строка 27]
    •

  • Data type: int
    •

    Описание

    Максимальный уровень структуры

  • $menu_id =  [Строка 39]
    •

  • Data type: int
    •

    Описание

    Идентификатор раздела меню

  • $parent_id =  [Строка 21]
    •

  • Data type: int
    •

    Описание

    Идентификатор родительского узла элемента структуры

  • $separator =  '' [Строка 33]
    •

  • Data type: string
    •

    Описание

    Разделитель для уровней

  • $StructureMass = array () [Строка 57]
    •

  • Data type: array
    •

    Описание

    Массив с элементами структуры

  • $StructureParentMass = array () [Строка 51]
    •

  • Data type: array
    •

    Описание

    Массив родительских разделов

  • $structure_propertys_list =  [Строка 69]
    •

  • Data type: resource
    •

    Описание

    Хранит результат запроса на выборку дополнительных свойств структуры

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Support

Class Support

[Строка 23]

Размещен: /Support/Support.class.php

Описание

Класс модуля "Техническая поддержка"

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean SupportMail()

    Метод отправки письма с просьбой о технической поддержке

Унаследованные методы

Описания методов

    Support::SupportMail

SupportMail(
string
$name, string
$mail, string
$phone, string
$number, string
$pin_code, string
$text, string
$sections, string
$priority, string
$subject, [string
$page = ''], [
$file_path_name = array()], string
$filename );

    Описание

    Метод отправки письма с просьбой о технической поддержке

    Принимаемые параметры

    $name

    ФИО пользователя

    $mail

    e-mail пользователя

    $phone

    телефон пользователя

    $number

    номер договора

    $pin_code

    пин-код

    $text

    текст сообщения

    $sections

    отдел, в который необходимо направить письмо

    $priority

    приоритет сообщения

    $subject

    тема сообщения

    $page

    тема сообщения

    $filename

    путь к прикрепляемому файлу
    1.  <?php
      2.

    2.  $Support = new Support();
      3.

    3.
      4.

    4.  $name = 'ФИО пользователя';
      5.

    5.  $mail = 'admin@site.ru';
      6.

    6.  $phone = '';
      7.

    7.  $number = '';
      8.

    8.  $pin_code = '';
      9.

    9.  $text = 'Текст сообщения';
      10.

    10.  $sections = 'Отдел технической поддержки';
      11.

    11.  $priority = 'Приоритет сообщения';
      12.

    12.  $subject = 'Тема сообщения';
      13.

    13.  $page = '';
      14.

    14.
      15.

    15.  $result = $Support->SupportMail($name, $mail, $phone, $number, $pin_code, $text, $sections, $priority, $subject, $page);
      16.

    16.
      17.

    17.  if ($result)
      18.

    18.  {
      19.

    19.      echo "Отправка сообщения выполнена успешно";
      20.

    20.  }
      21.

    21.  else
      22.

    22.  {
      23.

    23.     echo "Ошибка отправки сообщения";
      24.

    24.  }
      25.

    25.  ?>
      26.

    $file_path_name

    Возвращает

    истина при удачной отправке письма, ложь - в обратном случае

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class Tag

Class Tag

[Строка 14]

Размещен: /tag/tag.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, методы работы с тегами.
Файл: /modules/tag/tag.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheGetTag = array()

        mem-cache для GetTag()

  • $CacheGetTagRelation = array()

        mem-cache для GetTagRelation()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean DeleteTag()

    Удаление тега

  • boolean DeleteTagRelation()

    Список соответствий тега

  • boolean DeleteTagsGroup()

    Удаление группы тегов

  • void FillMemCacheGetTagRelation()

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров соответствиями тегов.

  • mixed GenXmlForTag()

    Генерация XML для тега

  • resource GetAllTags()

    Получение информации о тегах

  • mixed GetAllTagsGroups()

    Получение информации о группах меток

  • array GetTag()

    Получение информации о теге

  • array GetTagByName()

    Получение информации о теге по его имени

  • array GetTagByPath()

    Получение информации о теге по его пути

  • mixed GetTagRelation()

    Список соответствий тега

  • array GetTags()

    Получение информации о тегах

  • mixed GetTagsGroup()

    Получение информации о группе меток

  • array GetTagsGroupsPathArray()

    Построение массива пути от текущей группы меток к корневой

  • array GetTagsGroupsTree()

    Формирование дерева групп меток

  • mixed InsertTag()

    Вставка/обновление тега

  • int InsertTagRelation()

    Вставка соответствия тега элементам контента

  • mixed InsertTagsGroup()

    Вставка/обновление группы тегов

  • boolean JoinTags()

    Объединение тегов, теги объединяются по наименьшему идентификатору, тег с наименьшим идентификатором получает данные всех остальных тегов, остальные теги удаляются

Унаследованные методы

Описания методов

    Tag::DeleteTag

DeleteTag(
int
$tag_id );

    Описание

    Удаление тега

    Принимаемые параметры

    $tag_id

    идентификатор тега
    1.  <?php
      2.

    2.  $Tag = new Tag();
      3.

    3.
      4.

    4.  $tag_id = 104;
      5.

    5.
      6.

    6.  $result = $Tag->DeleteTag($tag_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    Tag::DeleteTagRelation

DeleteTagRelation(
array
$array );

    Описание

    Список соответствий тега

    Принимаемые параметры

    $array

    массив атрибутов
    • $array['information_items_id'] - идентификатор информационного элемента
    • $array['shop_items_catalog_item_id'] идентификатор товара
    • $array['tag_id'] - идентификатор тега

      1.  <?php
        2.

      2.  $Tag = new Tag();
        3.

      3.
        4.

      4.  $array['information_items_id'] = 1;
        5.

      5.  $array['tag_id'] = 27;
        6.

      6.
        7.

      7.  $result = $Tag->DeleteTagRelation($array);
        8.

      8.
        9.

      9.  // Распечатаем результат
        10.

      10.  echo $result;
        11.

      11.  ?>
        12.

    [ Наверх ]

    Tag::DeleteTagsGroup

DeleteTagsGroup(
int
$tags_group_id );

    Описание

    Удаление группы тегов

    Принимаемые параметры

    $tags_group_id

    идентификатор группы тегов     *

    [ Наверх ]

    Tag::FillMemCacheGetTagRelation

FillMemCacheGetTagRelation(
array
$param );

    Описание

    Метод заполняет mem-кэш для переданного списка идентификаторов товаров соответствиями тегов.

    Заполнению подвергается массив $this->CacheGetTagRelation[X][shop_items_catalog_item_id][] = $row  где X = information_items_id для ИС, = shop_items_catalog_item_id для товаров

    Принимаемые параметры

    $param

    массив атрибутов
    • $param['information_items_id'] массив идентификаторов информационных элементов
    • $param['shop_items_catalog_item_id'] массив идентификаторов товаров

    [ Наверх ]

    Tag::GenXmlForTag

GenXmlForTag(
int
$tag_id, [array
$tag_row = false], [
$count = false] );

    Описание

    Генерация XML для тега

    Принимаемые параметры

    $tag_id

    Идентификатор тега

    $tag_row

    массив с данными о теге (не обязательное поле), по умолчанию false
    1.  <?php
      2.

    2.  $Tag = new Tag();
      3.

    3.
      4.

    4.  $tag_id = 27;
      5.

    5.
      6.

    6.  $result = $Tag->GenXmlForTag($tag_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $result;
      10.

    10.  ?>
      11.

    $count

    Возвращает

    строка с XML или false, если тег не найден

    [ Наверх ]

    Tag::GetAllTags

GetAllTags(
[$param
$param = array()] );

    Описание

    Получение информации о тегах

    Принимаемые параметры

    $param

    array массив дополнительных параметров
    • $param['tags_group_id'] идентификатор группы, для которой необходимо получить список тегов

    [ Наверх ]

    Tag::GetAllTagsGroups

GetAllTagsGroups(
array
$param );

    Описание

    Получение информации о группах меток

    Принимаемые параметры

    $param

    массив параметров
    • $param['tags_group_parent_id'] идентификатор родительской группы

    Возвращает

    resource с данными о группах тегов или false

    [ Наверх ]

    Tag::GetTag

GetTag(
int
$tag_id, [array
$param = array()] );

    Описание

    Получение информации о теге

    Принимаемые параметры

    $tag_id

    идентификатор тега

    $param

    массив параметров
    • $param['cache'] кэшировать данные, по умолчанию true

      1.  <?php
        2.

      2.  $Tag = new Tag();
        3.

      3.
        4.

      4.  $tag_id = 1;
        5.

      5.
        6.

      6.  $row = $Tag->GetTag($tag_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    массив с данными о теге

    [ Наверх ]

    Tag::GetTagByName

GetTagByName(
int
$tag_name );

    Описание

    Получение информации о теге по его имени

    Принимаемые параметры

    $tag_name

    имя тега
    1.  <?php
      2.

    2.  $Tag = new Tag();
      3.

    3.
      4.

    4.  $tag_name = 'CMS';
      5.

    5.
      6.

    6.  $row = $Tag->GetTagByName($tag_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с данными о теге

    [ Наверх ]

    Tag::GetTagByPath

GetTagByPath(

$tag_path, int
$tag_name );

    Описание

    Получение информации о теге по его пути

    Принимаемые параметры

    $tag_name

    имя тега
    1.  <?php
      2.

    2.  $Tag = new Tag();
      3.

    3.
      4.

    4.  $tag_path = 'CMS';
      5.

    5.
      6.

    6.  $row = $Tag->GetTagByPath($tag_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    $tag_path

    Возвращает

    массив с данными о теге

    [ Наверх ]

    Tag::GetTagRelation

GetTagRelation(
array
$array );

    Описание

    Список соответствий тега

    Принимаемые параметры

    $array

    массив атрибутов
    • $array['information_items_id'] идентификатор информационного элемента
    • $array['shop_items_catalog_item_id'] идентификатор товара

      1.  <?php
        2.

      2.  $Tag = new Tag();
        3.

      3.
        4.

      4.  $array['information_items_id'] = 1;
        5.

      5.
        6.

      6.  $row = $Tag->GetTagRelation($array);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    массив с данными или false

    [ Наверх ]

    Tag::GetTags

GetTags(
int
$aTags, [array
$param = array()] );

    Описание

    Получение информации о тегах

    Принимаемые параметры

    $aTags

    массив идентификатор тегов

    $param

    массив параметров
    • $param['cache'] кэшировать данные, по умолчанию true

      1.  <?php
        2.

      2.  $Tag = new Tag();
        3.

      3.
        4.

      4.  $aTags = array(1, 2, 5, 7, 19);
        5.

      5.
        6.

      6.  $rows = $Tag->GetTags($aTags);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($rows);
        10.

      10.  ?>
        11.

    Возвращает

    массив с данными о тегах

    [ Наверх ]

    Tag::GetTagsGroup

GetTagsGroup(
int
$tags_group_id );

    Описание

    Получение информации о группе меток

    Принимаемые параметры

    $tags_group_id

    идентификатор группы блогов

    Возвращает

    массив с данными о группе тегов или false

    [ Наверх ]

    Tag::GetTagsGroupsPathArray

GetTagsGroupsPathArray(
int
$tags_group_id, [array
$return_path_array = array()] );

    Описание

    Построение массива пути от текущей группы меток к корневой

    Принимаемые параметры

    $tags_group_id

    идентификатор группы меток, для которой необходимо построить путь

    $return_path_array

    служебный параметр

    Возвращает

    ассоциативный массив, элементы которого содержат информацию о группах тегов, составляющих путь от текущей группы до корневой

    [ Наверх ]

    Tag::GetTagsGroupsTree

GetTagsGroupsTree(
array
$param );

    Описание

    Формирование дерева групп меток

    Принимаемые параметры

    $param

    массив параметров
    • $param['tags_group_parent_id'] идентификатор группы меток, относительно которой строится дерево групп
    • $param['separator'] символ, отделяющий группу нижнего уровня от родительской группы
    • $param['tags_group_id'] идентификатор группы, которую вместе с ее
     подгруппами не нужно включать в дерево групп, если равен false, то  включать в дерево групп все подгруппы. - $param['array'] служебный  элемент

    Возвращает

    двумерный массив, содержащий дерево подгрупп

    [ Наверх ]

    Tag::InsertTag

InsertTag(
array
$array );

    Описание

    Вставка/обновление тега

    Принимаемые параметры

    $array

    массив атрибутов
    • $array['tag_name'] имя тега
    • $array['tag_path'] имя тега в URL. по умолчанию используется имя тега.
    • $array['tag_description'] описание тега
    • $array['tag_id'] идентификатор тега, необязательный параметр, указывается при редактировании тега
    • $array['tags_group_id'] идентификатор группы тегов
    • $array['users_id'] идентификатор пользователя центра администрирования

      1.  <?php
        2.

      2.  $Tag = new Tag();
        3.

      3.
        4.

      4.  $array['tag_name'] = 'NewTag';
        5.

      5.
        6.

      6.  $newid = $Tag->InsertTag($array);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  echo $newid;
        10.

      10.  ?>
        11.

    Возвращает

    0 - передано пустое имя тега,
    false - ошибка вставки/обновления,
    положительноче число - идентификатор вставленного/обновленного тега

    [ Наверх ]

    Tag::InsertTagRelation

InsertTagRelation(
array
$array );

    Описание

    Вставка соответствия тега элементам контента

    Принимаемые параметры

    $array

    массив атрибутов
    • $array['tag_id'] - идентификатор тега
    • $array['information_items_id'] - идентификатор информационного элемента
    • $array['site_id'] - идентификатор сайт, не обязательное поле. Если не указано - определяется автоматически.
    • $array[''] -

      1.  <?php
        2.

      2.  $Tag = new Tag();
        3.

      3.
        4.

      4.  $array['tag_id'] = 27;
        5.

      5.  $array['information_items_id'] = 1;
        6.

      6.  $array['site_id'] = CURRENT_SITE;
        7.

      7.
        8.

      8.  $newid = $Tag->InsertTagRelation($array);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор вставленной/обновленной записи или 0

    [ Наверх ]

    Tag::InsertTagsGroup

InsertTagsGroup(
array
$param );

    Описание

    Вставка/обновление группы тегов

    Принимаемые параметры

    $param

    массив параметров
    • $param['tags_group_id'] идентификатор редактируемой группы тегов
    • $param['tags_group_parent_id'] идентификатор родительской группы тегов
    • $param['tags_group_name'] название группы тегов
    • $param['tags_group_description'] описание группы тегов
    • $param['tags_group_order'] порядковый номер группы
    • $param['users_id'] идентификатор пользователя центра администрирования, создавшего группу тегов

    Возвращает

    идентификатор добавленной/измененной группы или false

    [ Наверх ]

    Tag::JoinTags

JoinTags(
array
$tags_array );

    Описание

    Объединение тегов, теги объединяются по наименьшему идентификатору, тег с наименьшим идентификатором получает данные всех остальных тегов, остальные теги удаляются

    Принимаемые параметры

    $tags_array

    массив тегов, подлежащих удалению

    Возвращает

    TRUE в случае успеха объединения, FALSE в случае невозможности объединения

    [ Наверх ]

Описания переменных

  • $CacheGetTag = array() [Строка 28]
    •

  • Data type: array
    •

    Описание

    mem-cache для GetTag()

  • $CacheGetTagRelation = array() [Строка 21]
    •

  • Data type: array
    •

    Описание

    mem-cache для GetTagRelation()

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class templates

Class templates

[Строка 14]

Размещен: /Templates/Templates.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Шаблоны и макеты".
Файл: /modules/Templates/Templates.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $array_template_ids = array()

  • $error =

  • $mas_data_templates_dir = array()

  • $path_array = array()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int CopyDataTemplate()

    Метод копирования шаблона страниц

  • void CopyDataTemplatesDir()

    Копирование групп шаблонов с шаблонами и подгруппами

  • int CopyTemplate()

    Метод копирования макета

  • void CopyTemplatesDir()

    Копирование групп макетов с макетами и подгруппами

  • boolean DelDataTemplatesGroup()

    Метод удаления группы шаблонов данных

  • void DelTemplatesGroup()

    Метод удаления группы макетов

  • boolean del_data_templates()

    Метод удаления шаблона страниц

  • boolean del_templates()

    Метод удаления макета

  • array GetAllDataTemplates()

    Метод для получения списка шаблонов страниц текущего сайта

  • array GetAllDataTemplatesGroups()

    Метод для получения информации обо всех группах шаблонов сайта

  • array GetAllTemplates()

    Метод для получения списка макетов текущего сайта

  • resorce GetAllTemplatesGroups()

    Получение информации о всех группах макетов

  • void GetChildrenItemMasDataTemplatesGroup()

    Метод построения поддерева узла дерева

  • void GetChildrenItemMasTemplatesGroup()

    Метод построения поддерева узла дерева

  • array GetDataTemplateDirTree()

    Метод формирования дерева шаблонов.

  • string GetDataTemplatePath()

    Получение пути к файлу шаблона

  • array GetDataTemplatePathArray()

    Метод для построения массива пути от текущего узла к корневому

  • mixed GetDataTemplatesGroup()

    Получение информации о группе шаблонов данных

  • mixed GetDataTemplatesTree()

    Метод построения дерева шаблонов сайта

  • void GetPathDataTemplatesGroupCurrentToRoot()

    Метод построения пути от заданного узла дерева групп шаблонов страниц до корневого

  • void GetPathTemplatesGroupCurrentToRoot()

    Метод построения пути от заданного узла дерева групп макетов страниц до корневого

  • mixed GetTemplate()

    Получение информации о макете

  • array GetTemplateDirTree()

    Метод формирования дерева макетов.

  • array GetTemplatePathArray()

    Метод для построения массива пути от текущего узла к корневому

  • mixed GetTemplatesGroup()

    Получение информации о группе макетов

  • mixed GetTemplatesTree()

    Метод построения дерева макетов сайта

  • mixed InsertDataTemplatesGroup()

    Метод добавления/обновления группы шаблонов данных

  • int InsertTemplate()

    Метод добавления макета

  • mixed InsertTemplatesGroup()

    Метод добавления/обновления группы макетов

  • mixed insert_data_templates()

    Методы добавления (редактирования) шаблонов страниц

  • resource select_data_templates()

    Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $data_templates_id = -1)

  • mixed UpdateDataTemplatesGroup()

    Метод обновления информации о группе шаблонов данных

Унаследованные методы

Описания методов

    templates::CopyDataTemplate

CopyDataTemplate(
int
$data_template_id, [
$site_id = false], [int
$new_data_templates_group_parent_id = -1] );

    Описание

    Метод копирования шаблона страниц

    Принимаемые параметры

    $data_template_id

    идентификатор копируемого шаблона страниц

    $new_data_templates_group_parent_id

    Идентификатор группы, к которой необходимо отнести скопированный шаблон (если не указан, или имеет значение -1, то относится к той же группе, что и копируемый. по умолчанию -1)
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_template_id = 11;
      5.

    5.
      6.

    6.  $newid = $template->CopyDataTemplate($data_template_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    $site_id

    Возвращает

    идентификатор нового добавленного шаблона страниц

    [ Наверх ]

    templates::CopyDataTemplatesDir

CopyDataTemplatesDir(
int
$data_templates_group_parent_id, int
$new_data_templates_group_parent_id, int
$site_id, int
$new_site_id );

    Описание

    Копирование групп шаблонов с шаблонами и подгруппами

    Принимаемые параметры

    $data_templates_group_parent_id

    идентификатор родительской группы

    $new_data_templates_group_parent_id

    идентификатор скопированной родительской группы

    $site_id

    идентификатор сайта

    $new_site_id

    идентификатор скопированного сайта

    [ Наверх ]

    templates::CopyTemplate

CopyTemplate(
int
$template_id, [
$site_id = false], [int
$new_templates_group_parent_id = -1] );

    Описание

    Метод копирования макета

    Принимаемые параметры

    $template_id

    идентификатор копируемого макета

    $new_templates_group_parent_id

    Идентификатор группы, в которую необходимо положить скопированный макет (если не указан, или имеет значение -1, то относится к той же группе, что и копируемый, по умолчанию -1)
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $template_id = 6;
      5.

    5.
      6.

    6.  $newid = $template->CopyTemplate($template_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    $site_id

    Возвращает

    идентификатор нового добавленного макета

    [ Наверх ]

    templates::CopyTemplatesDir

CopyTemplatesDir(
int
$templates_group_parent_id, int
$new_templates_group_parent_id, int
$site_id, int
$new_site_id, [
$return_array_ids = false] );

    Описание

    Копирование групп макетов с макетами и подгруппами

    Принимаемые параметры

    $templates_group_parent_id

    идентификатор родительской группы

    $new_templates_group_parent_id

    идентификатор скопированной родительской группы

    $site_id

    идентификатор сайта

    $new_site_id

    идентификатор скопированного сайта

    $return_array_ids

    [ Наверх ]

    templates::DelDataTemplatesGroup

DelDataTemplatesGroup(
int
$data_templates_group_id );

    Описание

    Метод удаления группы шаблонов данных

    Принимаемые параметры

    $data_templates_group_id

    идентификатор группы шаблонов данных
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_group_id = 1;
      5.

    5.
      6.

    6.  $result = $template->DelDataTemplatesGroup($data_templates_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    templates::DelTemplatesGroup

DelTemplatesGroup(
int
$templates_group_id );

    Описание

    Метод удаления группы макетов

    Принимаемые параметры

    $templates_group_id

    идентификатор группы макетов
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_group_id = 4;
      5.

    5.
      6.

    6.  $result = $template->DelTemplatesGroup($templates_group_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    templates::del_data_templates

del_data_templates(
int
$data_templates_id );

    Описание

    Метод удаления шаблона страниц

    Принимаемые параметры

    $data_templates_id

    идентификатор удаляемого шаблона
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_id = 13;
      5.

    5.
      6.

    6.  $result = $template->del_data_templates($data_templates_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    templates::del_templates

del_templates(
int
$templates_id );

    Описание

    Метод удаления макета

    Принимаемые параметры

    $templates_id

    идентификатор удаляемого макета
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_id = 29;
      5.

    5.
      6.

    6.  $result = $template->del_templates($templates_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    [ Наверх ]

    templates::GetAllDataTemplates

GetAllDataTemplates(
[int
$data_templates_group_id = false], [int
$site_id = false] );

    Описание

    Метод для получения списка шаблонов страниц текущего сайта

    Принимаемые параметры

    $data_templates_group_id

    идентификатор группы макетов, если false - извлекается информация обо всех макетах

    $site_id

    идентификатор сайта, если не передан - используется текущий сайт
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_group_id = false;
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.
      7.

    7.  $row = $template->GetAllDataTemplates($data_templates_group_id, $site_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив с данными о макетах

    [ Наверх ]

    templates::GetAllDataTemplatesGroups

GetAllDataTemplatesGroups(
[int
$data_templates_group_parent_id = false], [int
$site_id = false] );

    Описание

    Метод для получения информации обо всех группах шаблонов сайта

    Принимаемые параметры

    $data_templates_group_parent_id

    идентификатор родительской группы, если false - информация о всех группах

    $site_id

    идентификатор сайта, если не передан - используется текущий сайт
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_group_parent_id = false;
      5.

    5.
      6.

    6.  $row = $template->GetAllDataTemplatesGroups($data_templates_group_parent_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив со списком групп шаблонов

    [ Наверх ]

    templates::GetAllTemplates

GetAllTemplates(
[int
$templates_group_id = false], [int
$site_id = false] );

    Описание

    Метод для получения списка макетов текущего сайта

    Принимаемые параметры

    $templates_group_id

    идентификатор группы макетов, если false - извлекается информация обо всех макетах

    $site_id

    идентификатор сайта, если не передан - используется текущий сайт
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_group_id = false;
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.
      7.

    7.  $row = $template->GetAllTemplates($templates_group_id, $site_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив с данными о макетах

    [ Наверх ]

    templates::GetAllTemplatesGroups

GetAllTemplatesGroups(
[int
$templates_group_parent_id = false], [int
$site_id = false] );

    Описание

    Получение информации о всех группах макетов

    Принимаемые параметры

    $templates_group_parent_id

    идентификатор группы макетов, если false - извлекается информация обо всех макетах

    $site_id

    идентификатор сайта, если не передан - используется текущий сайт
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_group_parent_id = false;
      5.

    5.  $site_id = CURRENT_SITE;
      6.

    6.
      7.

    7.  $row = $template->GetAllTemplatesGroups($templates_group_parent_id, $site_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    Возвращает

    в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    templates::GetChildrenItemMasDataTemplatesGroup

GetChildrenItemMasDataTemplatesGroup(
$mas_groups_tree
$mas_groups_tree, $mas_item_key
$mas_item_key, [$target_mas_groups
$target_mas_groups = array()] );

    Описание

    Метод построения поддерева узла дерева

    Принимаемые параметры

    $target_mas_groups

    массив, в котором содержится часть поддерева данного узла

    $mas_groups_tree

    исходный массив, содержащий информацию о группах

    $mas_item_key

    идентификатор узла,  для которого необходимо построить поддерево

    [ Наверх ]

    templates::GetChildrenItemMasTemplatesGroup

GetChildrenItemMasTemplatesGroup(
$mas_groups_tree
$mas_groups_tree, $mas_item_key
$mas_item_key, [$target_mas_groups
$target_mas_groups = array()] );

    Описание

    Метод построения поддерева узла дерева

    Принимаемые параметры

    $target_mas_groups

    массив, в котором содержится часть поддерева данного узла

    $mas_groups_tree

    исходный массив, содержащий информацию о группах

    $mas_item_key

    идентификатор узла,  для которого необходимо построить поддерево

    [ Наверх ]

    templates::GetDataTemplateDirTree

GetDataTemplateDirTree(
int
$data_templates_group_parent_id, [string
$separator = ''], [
$current_group_id = false], [bool
$first_call = true], [
$site_id = false] );

    Описание

    Метод формирования дерева шаблонов.

    Принимаемые параметры

    $data_templates_group_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    $first_call

    первый вызов ф-ции, по умолчанию - true
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_group_parent_id = 5;
      5.

    5.  $separator= '';
      6.

    6.
      7.

    7.  $row = $template->GetDataTemplateDirTree($data_templates_group_parent_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    $current_group_id

    $site_id

    Возвращает

    массив с данными о дереве шаблонов

    [ Наверх ]

    templates::GetDataTemplatePath

GetDataTemplatePath(
int
$data_templates_id );

    Описание

    Получение пути к файлу шаблона

    Принимаемые параметры

    $data_templates_id

    Идентификатор шаблона

    Возвращает

    путь к файлу

    [ Наверх ]

    templates::GetDataTemplatePathArray

GetDataTemplatePathArray(
int
$data_templates_group_id, [bool
$first_call = true] );

    Описание

    Метод для построения массива пути от текущего узла к корневому

    Принимаемые параметры

    $data_templates_group_id

    идентификатор текущего узла

    $first_call

    первый вызов ф-ции, по умолчанию - true
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_group_id = 6;
      5.

    5.
      6.

    6.  $row = $template->GetDataTemplatePathArray($data_templates_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с элементами пути группы

    [ Наверх ]

    templates::GetDataTemplatesGroup

GetDataTemplatesGroup(
int
$data_templates_group_id );

    Описание

    Получение информации о группе шаблонов данных

    Принимаемые параметры

    $data_templates_group_id

    идентификатор шаблона данных
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_group_id = 5;
      5.

    5.
      6.

    6.  $row = $template->GetDataTemplatesGroup($data_templates_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с данными о группе шаблонов данных в случае успешного выполнения, false - в случае возникновения ошибки

    [ Наверх ]

    templates::GetDataTemplatesTree

GetDataTemplatesTree(
int
$parent_data_templates_group_id, [array
$param = array()] );

    Описание

    Метод построения дерева шаблонов сайта

    Принимаемые параметры

    $parent_data_templates_group_id

    идентификатор группы, начиная с которой необходимо стороить дерево

    $param

    массив параметров
    • $param['data_templates_group_separator'] строка, используемая в качестве префикса имен групп шаблонов сайта
    • $param['data_templates_separator'] строка, используемая в качестве префикса имен шаблонов сайта
    • $param['sort_field_data_templates_groups'] поле сортировки групп шаблонов сайта, по умолчанию сортировка по названию
    • $param['sort_field_data_templates'] поле сортировки шаблонов сайта, по умолчанию сортировка по названию
    • $param['order_data_templates_groups'] направление сортировки групп шаблонов сайта, asc - по возрастанию (по умолчанию), desc - по убыванию;
    • $param['order_data_templates'] напрвление сортировки шаблонов сайта, asc - по возрастанию (по умолчанию), desc - по убыванию;
    • $param['site_id'] идентификатор сайта, для которого необходимо получитб дерево шаблонов.
    • по умолчанию используется идентификатор текущего сайта.
    • Если $param['site_id'] = false, сайт не учитывается.

      1.  <?php
        2.

      2.  $template = new templates();
        3.

      3.
        4.

      4.  $parent_data_templates_group_id = 0;
        5.

      5.  $param['data_templates_group_separator'] = '';
        6.

      6.  $param['data_templates_separator'] = '';
        7.

      7.  $param['site_id'] = CURRENT_SITE;
        8.

      8.
        9.

      9.  $row = $template->GetDataTemplatesTree($parent_data_templates_group_id);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  print_r ($row);
        13.

      13.  ?>
        14.

    Возвращает

    массив, содержащий

    [ Наверх ]

    templates::GetPathDataTemplatesGroupCurrentToRoot

GetPathDataTemplatesGroupCurrentToRoot(
int
$data_templates_group_id, array
$mas_data_templates_groups, [
$path_data_templates_groups = ''], [string
$separator = ' - '] );

    Описание

    Метод построения пути от заданного узла дерева групп шаблонов страниц до корневого

    Принимаемые параметры

    $data_templates_group_id

    идентификатор узла дерева групп шаблонов страниц

    $mas_data_templates_groups

    массив, содержащий дерево групп шаблонов страниц

    $separator

    строка, разделяющая названия групп шаблонов страниц

    $path_data_templates_groups

    [ Наверх ]

    templates::GetPathTemplatesGroupCurrentToRoot

GetPathTemplatesGroupCurrentToRoot(
int
$templates_group_id, array
$mas_templates_groups, [
$path_templates_groups = ''], [string
$separator = ' - '] );

    Описание

    Метод построения пути от заданного узла дерева групп макетов страниц до корневого

    Принимаемые параметры

    $templates_group_id

    идентификатор узла дерева групп макетов страниц

    $mas_templates_groups

    массив, содержащий дерево групп макетов страниц

    $separator

    строка, разделяющая названия групп макетов страниц

    $path_templates_groups

    [ Наверх ]

    templates::GetTemplate

GetTemplate(
int
$templates_id, [array
$param = array()] );

    Описание

    Получение информации о макете

    Принимаемые параметры

    $templates_id

    идентификатор макета

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $template = new templates();
        3.

      3.
        4.

      4.  $templates_id = 1;
        5.

      5.
        6.

      6.  $row = $template->GetTemplate($templates_id);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($row);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с информацией о макете в случае удачной выборки, ложь - если макет не выбран

    [ Наверх ]

    templates::GetTemplateDirTree

GetTemplateDirTree(

$templates_group_parent_id, string
$separator, [
$current_group_id = false], [bool
$first_call = true], [int
$site_id = false], int
$data_templates_group_parent_id );

    Описание

    Метод формирования дерева макетов.

    Принимаемые параметры

    $data_templates_group_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    $first_call

    первый вызов ф-ции, по умолчанию - true

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_group_parent_id = 2;
      5.

    5.  $separator = '';
      6.

    6.
      7.

    7.  $row = $template->GetTemplateDirTree($templates_group_parent_id, $separator);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r ($row);
      11.

    11.  ?>
      12.

    $templates_group_parent_id

    $current_group_id

    Возвращает

    массив с данными о дереве макетов

    [ Наверх ]

    templates::GetTemplatePathArray

GetTemplatePathArray(
int
$templates_group_id, [bool
$first_call = true] );

    Описание

    Метод для построения массива пути от текущего узла к корневому

    Принимаемые параметры

    $templates_group_id

    идентификатор текущего узла

    $first_call

    первый вызов ф-ции, по умолчанию - true
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_group_id = 5;
      5.

    5.
      6.

    6.  $row = $template->GetTemplatePathArray($templates_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    массив с элементами пути группы

    [ Наверх ]

    templates::GetTemplatesGroup

GetTemplatesGroup(
int
$templates_group_id );

    Описание

    Получение информации о группе макетов

    Принимаемые параметры

    $templates_group_id

    идентификатор группы макетов
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $templates_group_id = 4;
      5.

    5.
      6.

    6.  $row = $template->GetTemplatesGroup($templates_group_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    Возвращает

    ассоциативный массив с данными о группе макетов в случае успешного выполнения, false - в случае возникновения ошибки

    [ Наверх ]

    templates::GetTemplatesTree

GetTemplatesTree(
int
$parent_templates_group_id, [array
$param = array()] );

    Описание

    Метод построения дерева макетов сайта

    Принимаемые параметры

    $parent_templates_group_id

    идентификатор группы, начиная с которой необходимо стороить дерево

    $param

    массив параметров
    • $param['templates_group_separator'] строка, используемая в качестве префикса имен групп макетов сайта
    • $param['templates_separator'] строка, используемая в качестве префикса имен макетов сайта
    • $param['sort_field_templates_groups'] поле сортировки групп макетов сайта, по умолчанию сортировка по названию
    • $param['sort_field_templates'] поле сортировки макетов сайта, по умолчанию сортировка по названию
    • $param['order_templates_groups'] направление сортировки групп макетов сайта, asc - по возрастанию (по умолчанию), desc - по убыванию;
    • $param['order_templates'] напрвление сортировки макетов сайта, asc - по возрастанию (по умолчанию), desc - по убыванию;
    • $param['site_id'] идентификатор сайта, для которого необходимо получитб дерево макетов.
    • по умолчанию используется идентификатор текущего сайта.
    • Если $param['site_id'] = false, сайт не учитывается.

      1.  <?php
        2.

      2.  $template = new templates();
        3.

      3.
        4.

      4.  $parent_data_templates_group_id = 0;
        5.

      5.  $param['templates_group_separator'] = '';
        6.

      6.  $param['templates_separator'] = '';
        7.

      7.  $param['site_id'] = CURRENT_SITE;
        8.

      8.
        9.

      9.  $row = $template->GetTemplatesTree($parent_templates_group_id, $param = array());
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  print_r ($row);
        13.

      13.  ?>
        14.

    Возвращает

    массив, содержащий

    [ Наверх ]

    templates::InsertDataTemplatesGroup

InsertDataTemplatesGroup(
array
$param );

    Описание

    Метод добавления/обновления группы шаблонов данных

    Принимаемые параметры

    $param

    массив параметров
    • $param['data_templates_group_id'] идентификатор группы
    • $param['data_templates_group_parent_id'] идентификатор родительской группы
    • $param['data_templates_group_name'] имя группы

      int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $template = new templates();
        3.

      3.
        4.

      4.  $param['data_templates_group_parent_id'] = '';
        5.

      5.  $param['data_templates_group_name'] = 'Группа шаблонов';
        6.

      6.  $param['site_id'] = CURRENT_SITE;
        7.

      7.
        8.

      8.  $newid = $template->InsertDataTemplatesGroup($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор добавленной группы в случае успешного выполнения, false - при возникновении ошибки

    [ Наверх ]

    templates::InsertTemplate

InsertTemplate(
array
$param );

    Описание

    Метод добавления макета

    Принимаемые параметры

    $param

    массив параметров
    int $param['templates_id'] идентификатор макета
    int $param['templates_group_id'] идентификатор группы макетов
    string $param['templates_name'] наименование макета
    int $param['templates_order'] порядковый номер
    string $param['template'] исходный текст макета
    string $param['css'] CSS макета
    int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $param['templates_group_id'] = 0;
      5.

    5.  $param['templates_name'] = 'Макет 1';
      6.

    6.  $param['template'] = '';
      7.

    7.  $param['css'] = '';
      8.

    8.  $param['site_id'] = CURRENT_SITE;
      9.

    9.
      10.

    10.  $newid = $template->InsertTemplate($param);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    Возвращает

    идентификатор нового или редатируемого макета (в зависимости от типа действия)

    [ Наверх ]

    templates::InsertTemplatesGroup

InsertTemplatesGroup(
array
$param );

    Описание

    Метод добавления/обновления группы макетов

    Принимаемые параметры

    $param

    массив параметров
    • $param['templates_group_id'] идентификатор группы макетов
    • $param['templates_group_parent_id'] идентификатор родительской группы
    • $param['templates_group_name'] название группы

      int $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь

      1.  <?php
        2.

      2.  $template = new templates();
        3.

      3.
        4.

      4.  $param['templates_group_parent_id'] = 0;
        5.

      5.  $param['templates_group_name'] = 'Группа макетов';
        6.

      6.  $param['site_id'] = CURRENT_SITE;
        7.

      7.
        8.

      8.  $newid = $template->InsertTemplatesGroup($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор добавленной/обновленной группы в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    templates::insert_data_templates

insert_data_templates(
int
$type, int
$data_templates_id,
$data_templates_group_id, string
$data_templates_value, string
$data_templates_name, string
$data_templates_description, int
$data_templates_order, [int
$users_id = false], [
$site_id = false] );

    Описание

    Методы добавления (редактирования) шаблонов страниц

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $data_templates_id

    идентификатор шаблона страниц

    $data_templates_value

    шаблон

    $data_templates_name

    наименование шаблона страниц

    $data_templates_description

    описание шаблона страниц

    $data_templates_order

    порядок сортировки

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $type = 0;
      5.

    5.  $data_templates_group_id = '';
      6.

    6.  $data_templates_value = '';
      7.

    7.  $data_templates_name = 'Шаблон 1';
      8.

    8.  $data_templates_description = '';
      9.

    9.  $data_templates_order = 10;
      10.

    10.
      11.

    11.  $newid = $template->insert_data_templates($type, $data_templates_id, $data_templates_group_id, $data_templates_value, $data_templates_name, $data_templates_description, $data_templates_order);
      12.

    12.
      13.

    13.  // Распечатаем результат
      14.

    14.  echo $newid;
      15.

    15.  ?>
      16.

    $data_templates_group_id

    $site_id

    Возвращает

    идентификатор добавленного (отредактированного) шаблона в случае успешной операции, ложь - при возникновении ошибки

    [ Наверх ]

    templates::select_data_templates

select_data_templates(
int
$data_templates_id );

    Описание

    Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $data_templates_id = -1)

    Принимаемые параметры

    $data_templates_id

    идентификатор шаблона
    1.  <?php
      2.

    2.  $template = new templates();
      3.

    3.
      4.

    4.  $data_templates_id = 1;
      5.

    5.
      6.

    6.  $resource = $template->select_data_templates($data_templates_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.     print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    информация о шаблоне (обо всех щаблонах)

    [ Наверх ]

    templates::UpdateDataTemplatesGroup

UpdateDataTemplatesGroup(
array
$param );

    Описание

    Метод обновления информации о группе шаблонов данных

    Принимаемые параметры

    $param

    массив параметров
    • $param['data_templates_group_id'] идентификатор группы
    • $param['data_templates_group_parent_id'] идентификатор родительской группы
    • $param['data_templates_group_name'] имя группы

      1.  <?php
        2.

      2.  $template = new templates();
        3.

      3.
        4.

      4.  $param['data_templates_group_id'] = 1;
        5.

      5.  $param['data_templates_group_parent_id'] = 5;
        6.

      6.  $param['data_templates_group_name'] = 'Группа шаблонов2';
        7.

      7.
        8.

      8.  $newid = $template->UpdateDataTemplatesGroup($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newid;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор группы в случае успешного выполнения, false - в случае возникновения ошибки

    [ Наверх ]

Описания переменных

  • $array_template_ids = array() [Строка 24]
    •

  • Data type: array
    •

    var

    массив соответствий старых и новых идентификаторов скопированных шаблонов

  • $error =  [Строка 16]
    •

  • Data type: mixed
    •

  • $mas_data_templates_dir = array() [Строка 18]
    •

  • Data type: mixed
    •

  • $path_array = array() [Строка 19]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class typograph

Class typograph

[Строка 14]

Размещен: /typograph/typograph.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Типограф".
Файл: /modules/typograph/typograph.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string EraseOpticalAlignment()

    Метод для удаления тегов предыдущего оптического выравнивания

  • результат ProcessTypographic()

    Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.

  • str ReplaceWithoutTagAttribute()

    Производит замену массива подстрок $search на массив подстрок $replace в тексте $html, исключая замену в атрибутах HTML-тегов

Унаследованные методы

Описания методов

    typograph::EraseOpticalAlignment

EraseOpticalAlignment(
string
$source_string );

    Описание

    Метод для удаления тегов предыдущего оптического выравнивания

    Принимаемые параметры

    $source_string

    исходная строка
    1.  <?php
      2.

    2.  $typograph = new typograph();
      3.

    3.
      4.

    4.  $source_string = '<span style="margin-right: 0.3em"> </span> <span style="margin-left: -0.3em">&laquo;Типограф</span>&raquo;&nbsp;&mdash; удобный инструмент для&nbsp;автоматического типографирования в&nbsp;соответствии с&nbsp;правилами, принятыми для&nbsp;экранной типографики. Может применяться как&nbsp;для&nbsp;обычного текста, так&nbsp;и&nbsp;HTML-кода.';
      5.

    5.
      6.

    6.  $newstr = $typograph->EraseOpticalAlignment($source_string);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newstr;
      10.

    10.  ?>
      11.

    Возвращает

    строка с вырезанными тегами отического выравнивания

    [ Наверх ]

    typograph::ProcessTypographic

ProcessTypographic(

$source_string, [
$use_trailing_punctuation = false] );

    Описание

    Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.

    Принимаемые параметры

    $source_string

    $use_trailing_punctuation

    Возвращает

    работы ф-ции в виде строки.

    [ Наверх ]

    typograph::ReplaceWithoutTagAttribute

ReplaceWithoutTagAttribute(
mixed
$search, mixed
$replace, str
$html );

    Описание

    Производит замену массива подстрок $search на массив подстрок $replace в тексте $html, исключая замену в атрибутах HTML-тегов

    Принимаемые параметры

    $search

    строка или массив строк

    $replace

    строка или массив строк

    $html

    исходная строка

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class update

Class update

[Строка 14]

Размещен: /update/update.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "Обновление".
Файл: /modules/update/update.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string GetUpdatePath()

    Получение пути к директории update

Унаследованные методы

Описания методов

    update::GetUpdatePath

GetUpdatePath(
 );

    Описание

    Получение пути к директории update

    Возвращает

    путь к файлу

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class url

Class url

[Строка 14]

Размещен: /Kernel/Url.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс для работы с адресной строкой.
Файл: /modules/Kernel/url.class.php

author

Hostmake LLC

version

5.x

Свойства класса

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string CutWordLen()

    Уменьшает длину слов в строке, имеющий длину больше $max_word_len

  • string link_len()

    Метод сокращения длины строки

  • string translit_lower()

    Метод транслитерации с переводом символам исходного текста к прописным

Унаследованные методы

Описания методов

    url::CutWordLen

CutWordLen(
string
$str, int
$max_word_len );

    Описание

    Уменьшает длину слов в строке, имеющий длину больше $max_word_len

    Принимаемые параметры

    $str

    строка

    $max_word_len

    максимальная длина слова
    1.  <?php
      2.

    2.  $url = new url();
      3.

    3.
      4.

    4.  $str = 'Строка с тестовым текстом';
      5.

    5.  $max_word_len = 5;
      6.

    6.
      7.

    7.  $newstr= $url->CutWordLen($str, $max_word_len);
      8.

    8.
      9.

    9.  echo $newstr;
      10.

    10.  ?>
      11.

    Возвращает

    строка

    [ Наверх ]

    url::link_len

link_len(
string
$str, int
$max_lenght );

    Описание

    Метод сокращения длины строки

    Принимаемые параметры

    $str

    строка

    $max_lenght

    максимальная длина строки
    1.  <?php
      2.

    2.  $url = new url();
      3.

    3.
      4.

    4.  $str = 'Тестовая строка с текстом';
      5.

    5.  $max_lenght = 19;
      6.

    6.
      7.

    7.  $newstr= $url->link_len($str, $max_lenght);
      8.

    8.
      9.

    9.  echo $newstr;
      10.

    10.  ?>
      11.

    Возвращает

    сокращенная строка

    [ Наверх ]

    url::translit_lower

translit_lower(
string
$string );

    Описание

    Метод транслитерации с переводом символам исходного текста к прописным

    Принимаемые параметры

    $string

    1.  <?php
      2.

    2.  $url = new url();
      3.

    3.
      4.

    4.  $string = 'Строка с тестовым текстом';
      5.

    5.
      6.

    6.  $newstr= $url->translit_lower($string);
      7.

    7.
      8.

    8.  echo $newstr;
      9.

    9.  ?>
      10.

    [ Наверх ]

Описания переменных

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class user_access

Class user_access

[Строка 23]

Размещен: /UserAccess/UserAccess.class.php

Свойства класса

  • $CacheGetUser = array()

        Кэш для метода GetUser()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • int CopyUserType()

    Копирование информации о группе пользователей центра администрирования

  • resource DeleteUserDeniedAccessBefore()

    Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд

  • resource DeleteUserDeniedAccessIP()

    Метод удаления неудачных попыток входа в BackOffice для заданного IP-адреса

  • boolean del_user()

    Метод удаления пользователя

  • boolean del_user_type()

    Метод удаления типа пользователей

  • resource GetAllUsers()

    Получение данных о всех пользователях центра администрирования

  • resource GetAllUserTypes()

    Метод возвращает список типов пользователей

  • mixed GetUser()

    Получение информации о пользователе

  • mixed GetUserByName()

    Получение информации о пользователе по его имени

  • mixed GetUsersSuccess()

    Определение информации о правах доступа пользователя к модулю

  • mixed GetUsersSuccessEvent()

    Определение информации о правах доступа пользователя к действию

  • mixed GetUserType()

    Метод возвращает данные о группе пользователей центр администрирования

  • int InsertUser()

    Метод вставки и обновления информации о пользователе

  • resource InsertUserDeniedAccess()

    Метод записи в базу информации о неудачной попытке входа в BackOffice

  • mixed insert_user_type()

    Метод вставки и обновления информации о типе пользователей

  • boolean IssetUserAccessForObject()

    Определене возможности доступа пользователя к управлению объектом

  • void IssetUserEventAccess()

    Определение доступности действия формы центра администрирования для пользователя

  • void IssetUsersTypeEventAccess()

    Определение доступности действия формы центра администрирования для группы пользователей

  • void MessageOnlyOwn()

  • resource SelectUserDeniedAccess()

    Получение списка неудачных доступов к BackOffice для конкретного ip-адреса

  • mixed select_user()

    УСТАРЕВШИЙ. Получение информации о пользователе

  • mixed select_user_access()

    Получение нформации о типах доступа пользователей

  • mixed select_user_type()

    УСТАРЕВШИЙ. Метод выбора типа пользователей

  • mixed SetUsersTypeAccess()

    Метод вставки/обновления информации о доступе группы пользователей к модулю

  • void SetUsersTypeAccessFormEvents()

    Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования

  • void SetUsersTypeEventAccess()

    Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования

Унаследованные методы

Описания методов

    user_access::CopyUserType

CopyUserType(
int
$users_type_id, [int
$site_id = false] );

    Описание

    Копирование информации о группе пользователей центра администрирования

    Принимаемые параметры

    $users_type_id

    идентификатор группы пользователей центра администрирования

    $site_id

    идентификатор сайта, если не передан, используется текущий сайт

    Возвращает

    идентификатор скопированного элемента

    [ Наверх ]

    user_access::DeleteUserDeniedAccessBefore

DeleteUserDeniedAccessBefore(
string
$current_date, [int
$delta_time = 86400] );

    Описание

    Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд

    Принимаемые параметры

    $current_date

    текущая дата

    $delta_time

    число секунд, по умолчанию сутки, от текущего момента времени

    Возвращает

    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $current_date = time();
      5.

    5.  $delta_time = 86400;
      6.

    6.
      7.

    7.  $resource = $user_access->DeleteUserDeniedAccessBefore($current_date, $delta_time);
      8.

    8.
      9.

    9.  if ($resource)
      10.

    10.  {
      11.

    11.      echo "Удаление выполнено успешно";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка удаления";
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    user_access::DeleteUserDeniedAccessIP

DeleteUserDeniedAccessIP(
string
$ip );

    Описание

    Метод удаления неудачных попыток входа в BackOffice для заданного IP-адреса

    Принимаемые параметры

    $ip

    IP-адрес

    Возвращает

    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $ip = $_SERVER['REMOTE_ADDR'];
      5.

    5.
      6.

    6.  $resource = $user_access->DeleteUserDeniedAccessIP($ip);
      7.

    7.
      8.

    8.  if ($resource)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    user_access::del_user

del_user(
int
$users_id );

    Описание

    Метод удаления пользователя

    Принимаемые параметры

    $users_id

    - идентификатор удаляемого пользователя

    Возвращает

    true в случае успешного выполнения, false в противном случае
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_id = 22;
      5.

    5.
      6.

    6.  $result = $user_access->del_user($users_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.      echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    user_access::del_user_type

del_user_type(
int
$users_type_id );

    Описание

    Метод удаления типа пользователей

    Принимаемые параметры

    $users_type_id

    - идентификатор типа пользователей

    Возвращает

    true в случае успешного выполнения, false в противном случае
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_type_id = 6;
      5.

    5.
      6.

    6.  $result = $user_access->del_user_type($users_type_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    [ Наверх ]

    user_access::GetAllUsers

GetAllUsers(
 );

    Описание

    Получение данных о всех пользователях центра администрирования

    Возвращает

    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $resource = $user_access->GetAllUsers();
      5.

    5.
      6.

    6.  // Распечатаем результат
      7.

    7.  while($row = mysql_fetch_assoc($resource))
      8.

    8.  {
      9.

    9.      print_r($row);
      10.

    10.  }
      11.

    11.  ?>
      12.

    [ Наверх ]

    user_access::GetAllUserTypes

GetAllUserTypes(
int
$site_id );

    Описание

    Метод возвращает список типов пользователей

    Принимаемые параметры

    $site_id

    идентификатор сайта, которому принадлежит тип пользователей, если false - учитываются все сайты

    Возвращает

    с информацией о типах пользователей
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $site_id = CURRENT_SITE;
      5.

    5.
      6.

    6.  $resource = $user_access->GetAllUserTypes($site_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    [ Наверх ]

    user_access::GetUser

GetUser(
int
$users_id );

    Описание

    Получение информации о пользователе

    Принимаемые параметры

    $users_id

    идентификатор пользователя центра администрирования

    Возвращает

    массив с данными или false, если пользователь не найден
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_id = 19;
      5.

    5.
      6.

    6.  $row = $user_access->GetUser($users_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    user_access::GetUserByName

GetUserByName(
int
$users_name );

    Описание

    Получение информации о пользователе по его имени

    Принимаемые параметры

    $users_name

    имя пользователя центра администрирования

    Возвращает

    массив с данными или false, если пользователь не найден
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_name = 'admin';
      5.

    5.
      6.

    6.  $row = $user_access->GetUserByName($users_name);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    user_access::GetUsersSuccess

GetUsersSuccess(
int
$users_type_id, int
$modules_id, [int
$site_id = false] );

    Описание

    Определение информации о правах доступа пользователя к модулю

    Принимаемые параметры

    $users_type_id

    индентификатор группы пользователей центра администрирования

    $modules_id

    идентификатор модуля

    $site_id

    идентификатор сайта, если не передан, определяется автоматически

    Возвращает

    массив с данными или false
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_type_id = 5;
      5.

    5.  $modules_id = 54;
      6.

    6.  $site_id = CURRENT_SITE;
      7.

    7.
      8.

    8.  $result = $user_access->GetUsersSuccess($users_type_id, $modules_id, $site_id);
      9.

    9.
      10.

    10.  if ($result)
      11.

    11.  {
      12.

    12.     echo "Пользователь имеет доступ к модулю";
      13.

    13.  }
      14.

    14.  else
      15.

    15.  {
      16.

    16.     echo "Пользователь не имеет доступ к модулю";
      17.

    17.  }
      18.

    18.  ?>
      19.

    [ Наверх ]

    user_access::GetUsersSuccessEvent

GetUsersSuccessEvent(
int
$users_type_id, int
$admin_forms_events_id, [int
$site_id = false] );

    Описание

    Определение информации о правах доступа пользователя к действию

    Принимаемые параметры

    $users_type_id

    индентификатор группы пользователей центра администрирования

    $admin_forms_events_id

    идентификатор действия

    $site_id

    идентификатор сайта, если не передан, определяется автоматически

    Возвращает

    массив с данными или false
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_type_id = 5;
      5.

    5.  $admin_forms_events_id = 207;
      6.

    6.  $site_id = CURRENT_SITE;
      7.

    7.
      8.

    8.  $row = $user_access->GetUsersSuccessEvent($users_type_id, $admin_forms_events_id, $site_id);
      9.

    9.
      10.

    10.  // Распечатаем результат
      11.

    11.  print_r ($row);
      12.

    12.  ?>
      13.

    [ Наверх ]

    user_access::GetUserType

GetUserType(
int
$users_type_id );

    Описание

    Метод возвращает данные о группе пользователей центр администрирования

    Принимаемые параметры

    $users_type_id

    идентификатор группы пользователй центра администрирования

    Возвращает

    массив с данными о группе или false в случае неудачи
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_type_id = 5;
      5.

    5.
      6.

    6.  $row = $user_access->GetUserType($users_type_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r ($row);
      10.

    10.  ?>
      11.

    [ Наверх ]

    user_access::InsertUser

InsertUser(
array
$param );

    Описание

    Метод вставки и обновления информации о пользователе

    Принимаемые параметры

    $param

    массив параметров
    • int $param['users_id'] идентификатор пользователя
    • int $param['users_type_id'] идентификатор группы пользователей
    • string $param['users_name'] логин пользоваетля (логин)
    • string $param['users_password'] пароль
    • int $param['users_superuser'] пользователь - супер-юзер
    • int $param['users_settings'] целое число с настройками пользователя
    • str $param['users_name_text'] имя пользователя
    • str $param['users_surname'] фамилия пользователя
    • str $param['users_patronymic'] отчество пользователя
    • str $param['users_email'] электронный адрес пользователя
    • str $param['users_position'] должность пользователя
    • str $param['users_icq'] номер icq пользователя
    • str $param['users_site'] сайт пользователя
    • int $param['users_only_own'] доступ пользователя только к тем элементам, которые он создал
    • int $param['users_own_id'] пользователь, создавший пользователя

    Возвращает

    идентификатор вставленного/обновленного пользователя
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $param['users_type_id'] = 5;
      5.

    5.  $param['users_name'] = 'vasya2';
      6.

    6.  $param['users_password'] = 'vasya';
      7.

    7.  $param['users_superuser'] = 0;
      8.

    8.  $param['users_settings'] = 0;
      9.

    9.  $param['users_name_text'] = 'Вася';
      10.

    10.  $param['users_surname'] = 'Пупкин';
      11.

    11.  $param['users_own_id'] = 0;
      12.

    12.
      13.

    13.  $newid = $user_access->InsertUser($param);
      14.

    14.
      15.

    15.  // Распечатаем результат
      16.

    16.  echo $newid;
      17.

    17.  ?>
      18.

    [ Наверх ]

    user_access::InsertUserDeniedAccess

InsertUserDeniedAccess(
string
$user_ip, string
$current_date );

    Описание

    Метод записи в базу информации о неудачной попытке входа в BackOffice

    Принимаемые параметры

    $user_ip

    IP-адрес пользователя

    $current_date

    текущая дата в формате UNIX Timestamp

    Возвращает

    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $user_ip = $_SERVER['REMOTE_ADDR'];
      5.

    5.  $current_date = time();
      6.

    6.
      7.

    7.  $resource = $user_access->InsertUserDeniedAccess($user_ip, $current_date);
      8.

    8.
      9.

    9.  if ($resource)
      10.

    10.  {
      11.

    11.      echo "Информация записана";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.     echo "Информация не записана";
      16.

    16.  }
      17.

    17.  ?>
      18.

    [ Наверх ]

    user_access::insert_user_type

insert_user_type(
array
$param );

    Описание

    Метод вставки и обновления информации о типе пользователей

    Принимаемые параметры

    $param

    массив параметров
    • $param['users_type_id'] идентификатор типа пользователей
    • $param['site_id'] идентификатор сайта, к которому принадлежит тип пользователей
    • $param['users_type_name'] название типа пользователей
    • $param['users_type_comment'] описание типа пользователей
    • $param['users_type_root_dir'] название корневой директории, выше которой не могут подниматься пользователи данного типа

    Возвращает

    идентификатор добавленной/обновленной информации о типе пользователей в случае успешного выполнения или false в противном случае
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $param['users_type_id'] = 0;
      5.

    5.  $param['site_id'] = CURRENT_SITE;
      6.

    6.  $param['users_type_name'] = 'new_users';
      7.

    7.  $param['users_type_comment'] = 'описание типа пользователей';
      8.

    8.  $param['users_type_root_dir'] ='/images/';
      9.

    9.
      10.

    10.  $newid = $user_access->insert_user_type($param);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo $newid;
      14.

    14.  ?>
      15.

    [ Наверх ]

    user_access::IssetUserAccessForObject

IssetUserAccessForObject(
int
$object_user_id, [int
$users_id = false] );

    Описание

    Определене возможности доступа пользователя к управлению объектом

    Принимаемые параметры

    $object_user_id

    идентификатор пользователя, которому принадлежит объект

    $users_id

    идентификатор текущего пользователя, если не передан - определяется автоматически

    Возвращает

    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.  $InformationSystem = new InformationSystem();
      4.

    4.
      5.

    5.  $group_id = 2;
      6.

    6.
      7.

    7.  $row = $InformationSystem->GetInformationGroup($group_id);
      8.

    8.  $object_user_id = $row['users_id'];
      9.

    9.
      10.

    10.  $kernel = new kernel();
      11.

    11.  $users_id = $kernel->GetCurrentUser();
      12.

    12.
      13.

    13.  $result = $user_access->IssetUserAccessForObject($object_user_id, $users_id);
      14.

    14.
      15.

    15.  if ($result)
      16.

    16.  {
      17.

    17.      echo "Пользователь имеет доступ к объекту";
      18.

    18.  }
      19.

    19.  else
      20.

    20.  {
      21.

    21.      echo "Пользователь не имеет доступ к объекту";
      22.

    22.  }
      23.

    23.  ?>
      24.

    [ Наверх ]

    user_access::IssetUserEventAccess

IssetUserEventAccess(
array
$param );

    Описание

    Определение доступности действия формы центра администрирования для пользователя

    Принимаемые параметры

    $param

    массив параметров
    • $param['user_id'] идентификатор пользователя
    • $param['admin_form_event_id'] идентификатор действия формы
    • $param['site_id'] идентификатор сайта (по умолчанию используется идентификатор текущего сайта)

      1.  <?php
        2.

      2.  $user_access = new user_access();
        3.

      3.
        4.

      4.  $param['user_id'] = 21;
        5.

      5.  $param['admin_form_event_id'] = 207;
        6.

      6.  $param['site_id'] = CURRENT_SITE;
        7.

      7.
        8.

      8.  $result = $user_access->IssetUserEventAccess($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $result;
        12.

      12.  ?>
        13.

    [ Наверх ]

    user_access::IssetUsersTypeEventAccess

IssetUsersTypeEventAccess(
array
$param );

    Описание

    Определение доступности действия формы центра администрирования для группы пользователей

    Принимаемые параметры

    $param

    массив параметров
    • $param['users_type_id'] идентификатор группы пользователей
    • $param['admin_form_event_id'] идентификатор действия формы
    • $param['site_id'] идентификатор сайта (по умолчанию используется идентификатор текущего сайта)

      1.  <?php
        2.

      2.  $user_access = new user_access();
        3.

      3.
        4.

      4.  $param['users_type_id'] = 5;
        5.

      5.  $param['admin_form_event_id'] = 207;
        6.

      6.  $param['site_id'] = CURRENT_SITE;
        7.

      7.
        8.

      8.  $result = $user_access->IssetUsersTypeEventAccess($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $result;
        12.

      12.  ?>
        13.

    [ Наверх ]

    user_access::MessageOnlyOwn

MessageOnlyOwn(
 );

    [ Наверх ]

    user_access::SelectUserDeniedAccess

SelectUserDeniedAccess(
string
$user_ip, string
$current_date );

    Описание

    Получение списка неудачных доступов к BackOffice для конкретного ip-адреса

    Принимаемые параметры

    $user_ip

    IP-адрес пользователя

    $current_date

    текущая дата

    Возвращает

    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $user_ip = $_SERVER['REMOTE_ADDR'];
      5.

    5.  $current_date = time();
      6.

    6.
      7.

    7.  $resource = $user_access->SelectUserDeniedAccess($user_ip, $current_date);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  while($row = mysql_fetch_assoc($resource))
      11.

    11.  {
      12.

    12.      print_r($row);
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    user_access::select_user

select_user(
int
$users_id );

    Описание

    УСТАРЕВШИЙ. Получение информации о пользователе

    Принимаемые параметры

    $users_id

    - идентификатор пользователя

    Возвращает

    ассоциативный массив с информацией о пользователе в случае успешного выполнения, false в противном случае

    [ Наверх ]

    user_access::select_user_access

select_user_access(
mixed
$users_access_id );

    Описание

    Получение нформации о типах доступа пользователей

    Принимаемые параметры

    $users_access_id

    - идентификатор типа доступа пользователей, если $users_access_id равен false получаем информацию о всех типах доступа пользователей

    Возвращает

    result в случае успешного выполнения метода, false в противном случае
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $users_access_id = 1;
      5.

    5.
      6.

    6.  $row = $user_access->select_user_access($users_access_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  print_r (mysql_fetch_assoc($row));
      10.

    10.  ?>
      11.

    [ Наверх ]

    user_access::select_user_type

select_user_type(
int
$users_type_id );

    Описание

    УСТАРЕВШИЙ. Метод выбора типа пользователей

    Принимаемые параметры

    $users_type_id

    - идентификатор типа пользователей

    Возвращает

    result в случае успешного выполнения, false в противном случае

    version

    3.2.3

    [ Наверх ]

    user_access::SetUsersTypeAccess

SetUsersTypeAccess(
array
$param );

    Описание

    Метод вставки/обновления информации о доступе группы пользователей к модулю

    Принимаемые параметры

    $param

    ассоциативный массив параметров
    • int $param['users_type_id'] идентификатор группы пользователей
    • int $param['modules_id'] идентификатор модуля системы управления, для которого устанавливается доступ
    • int $param['site_id'] идентификатор сайта
    • int $param['users_id'] идентификатор пользователя

    Возвращает

    идентификатор доступа группы пользователей к модулю системы управления
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $param['users_type_id'] = 5;
      5.

    5.  $param['modules_id'] = 54;
      6.

    6.  $param['site_id'] = CURRENT_SITE;
      7.

    7.  $param['users_id'] = 21;
      8.

    8.
      9.

    9.  $result = $user_access->SetUsersTypeAccess($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $result;
      13.

    13.  ?>
      14.

    [ Наверх ]

    user_access::SetUsersTypeAccessFormEvents

SetUsersTypeAccessFormEvents(
int
$admin_forms_id, int
$users_type_id, int
$access_value, int
$site_id );

    Описание

    Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования

    Принимаемые параметры

    $admin_forms_id

    идентификатор формы центра администрирования

    $users_type_id

    идентификатор группы пользователей центра администрирования

    $access_value

    значение доступа группы пользователей к событию формы (0 - событие не доступно, 1 - событие доступно)

    $site_id

    идентификатор сайта
    1.  <?php
      2.

    2.  $user_access = new user_access();
      3.

    3.
      4.

    4.  $admin_forms_id = 104;
      5.

    5.  $users_type_id = 5;
      6.

    6.  $access_value = 1;
      7.

    7.  $site_id = CURRENT_SITE;
      8.

    8.
      9.

    9.  $user_access->SetUsersTypeAccessFormEvents($admin_forms_id, $users_type_id, $access_value, $site_id);
      10.

    10.  ?>
      11.

    [ Наверх ]

    user_access::SetUsersTypeEventAccess

SetUsersTypeEventAccess(
array
$param );

    Описание

    Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования

    Принимаемые параметры

    $param

    массив параметров
    • $param['access_value'] значение доступа группы пользователей к событию формы (0 - событие не доступно, 1 - событие доступно)
    • $param['users_type_id'] идентификатор группы пользователей центра администрирования
    • $param['admin_form_event_id'] идентификатор события формы центра администрирования
    • $param['site_id'] идентификатор сайта

      1.  <?php
        2.

      2.  $user_access = new user_access();
        3.

      3.
        4.

      4.  $param['access_value'] = 1;
        5.

      5.  $param['users_type_id'] = 5;
        6.

      6.  $param['admin_form_event_id'] = 207;
        7.

      7.  $param['site_id'] = CURRENT_SITE;
        8.

      8.
        9.

      9.  $result = $user_access->SetUsersTypeEventAccess($param);
        10.

      10.
        11.

      11.  // Распечатаем результат
        12.

      12.  echo $result;
        13.

      13.  ?>
        14.

    [ Наверх ]

Описания переменных

  • $CacheGetUser = array() [Строка 30]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetUser()

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class warehouse

Class warehouse

[Строка 15]

Размещен: /shop/warehouse.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "warehouse".
Файл: /modules/shop/warehouse.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheGetAllWarehousesForShop = array()

        Кэш для метода GetAllWarehousesForShop()

  • $CacheGetItemCountForWarehouse = array()

        Кэш для метода GetItemCountForWarehouse()

  • $CacheGetWarehouse = array()

        Кэш для метода GetWarehouse()

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • boolean AcceptTransaction()

    Списание с определенного склада определенное количество определенного товара

  • mixed CopyWarehouse()

    Копирование склада

  • resource DeleteWarehouse()

    Удаление информации о складе

  • resource DeleteWarehouseItem()

    Удаление информации о связи товара и склада

  • void FillItemCountForWarehouse()

  • mixed GetAllItemWarehouses()

    Получение всех складов, которым принадлежит товар

  • mixed GetAllWarehouseItems()

    Получение всех товаров склада

  • mixed GetAllWarehousesForShop()

    Получение всех складов магазина

  • mixed GetDefaultWarehouse()

    Получение склада по умолчанию для магазина

  • int GetItemCountForAllWarehouses()

    Получение количества определенного товара на всех складах

  • int GetItemCountForWarehouse()

    Получение количества определенного товара на определенном складе

  • mixed GetWarehouse()

    Получение информации о складе

  • mixed GetWarehouseItem()

    Получение информации об остатке товара на складе, получение возможно  по shop_warehouse_items_id или паре значений идентификатор склада и идентификатор товара

  • str GetWarehousesXml()

    Формирование XML для всех складов магазина

  • str GetWarehouseXml()

    Формирование XML для конкретного склада магазина

  • mixed InsertWarehouse()

    Вставка/обновление склада

  • mixed InsertWarehouseItems()

    Вставка/обновление количества товара на складе.

Унаследованные методы

Описания методов

    warehouse::AcceptTransaction

AcceptTransaction(

$shop_warehouse_id,
$shop_items_catalog_item_id,
$shop_warehouse_items_count, int
$shop_shops_id );

    Описание

    Списание с определенного склада определенное количество определенного товара

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 1;
      5.

    5.  $shop_items_catalog_item_id = 10;
      6.

    6.  $shop_warehouse_items_count = 100;
      7.

    7.
      8.

    8.  if($warehouse->AcceptTransaction($shop_warehouse_id, $shop_items_catalog_item_id, $shop_warehouse_items_count))
      9.

    9.  {
      10.

    10.      echo "Списание товара прошло успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.      echo "Ошибка списания товара!";
      15.

    15.  }
      16.

    16.  ?>
      17.

    $shop_warehouse_id

    $shop_items_catalog_item_id

    $shop_warehouse_items_count

    Возвращает

    результат выполнения операции

    [ Наверх ]

    warehouse::CopyWarehouse

CopyWarehouse(
int
$shop_warehouse_id, int
$shop_shops_id );

    Описание

    Копирование склада

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 1;
      5.

    5.  $shop_shops_id = 10;
      6.

    6.
      7.

    7.  if(($warehouse_copy_id = $warehouse->CopyWarehouse($shop_warehouse_id, $shop_shops_id)) !== false)
      8.

    8.  {
      9.

    9.      echo "Копирование прошло успешно, идентификатор новго склада - $warehouse_copy_id";
      10.

    10.  }
      11.

    11.  else
      12.

    12.  {
      13.

    13.      echo "Ошибка копирования склада!";
      14.

    14.  }
      15.

    15.  ?>
      16.

    Возвращает

    идентификатор нового склада, либо false

    [ Наверх ]

    warehouse::DeleteWarehouse

DeleteWarehouse(
int
$shop_warehouse_id );

    Описание

    Удаление информации о складе

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 10;
      5.

    5.
      6.

    6.  if($warehouse->DeleteWarehouse($shop_warehouse_id))
      7.

    7.  {
      8.

    8.      echo "Информация успешно удалена!";
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Ошибка удаления информации!";
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    warehouse::DeleteWarehouseItem

DeleteWarehouseItem(
int
$shop_warehouse_items_id );

    Описание

    Удаление информации о связи товара и склада

    Принимаемые параметры

    $shop_warehouse_items_id

    идентификатор связи из таблицы `shop_warehouse_items_table`
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_items_id = 1;
      5.

    5.
      6.

    6.  if($warehouse->DeleteWarehouseItem($shop_warehouse_items_id))
      7.

    7.  {
      8.

    8.      echo "Информация успешно удалена!";
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Ошибка удаления информации!";
      13.

    13.  }
      14.

    14.  ?>
      15.

    [ Наверх ]

    warehouse::FillItemCountForWarehouse

FillItemCountForWarehouse(

$shop_items_catalog_item_id );

    Принимаемые параметры

    $shop_items_catalog_item_id

    [ Наверх ]

    warehouse::GetAllItemWarehouses

GetAllItemWarehouses(
int
$shop_items_catalog_item_id );

    Описание

    Получение всех складов, которым принадлежит товар

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 101;
      5.

    5.
      6.

    6.  if(($item_warehouses_item_res = $warehouse->GetAllItemWarehouses($shop_items_catalog_item_id)) !== false)
      7.

    7.  {
      8.

    8.      while($item_warehouses_item_row = mysql_fetch_assoc($item_warehouses_item_res))
      9.

    9.      {
      10.

    10.          var_dump($item_warehouses_item_row);
      11.

    11.      }
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Данные отсутствуют";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    resource или false

    [ Наверх ]

    warehouse::GetAllWarehouseItems

GetAllWarehouseItems(
int
$shop_warehouse_id );

    Описание

    Получение всех товаров склада

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 1;
      5.

    5.
      6.

    6.  if(($warehouse_item_res = $warehouse->GetAllWarehouseItems($param)) !== false)
      7.

    7.  {
      8.

    8.      while($warehouse_item_row = mysql_fetch_assoc($warehouse_item_res))
      9.

    9.      {
      10.

    10.          var_dump($warehouse_item_row);
      11.

    11.      }
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Данные отсутствуют";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    resource или false

    [ Наверх ]

    warehouse::GetAllWarehousesForShop

GetAllWarehousesForShop(
int
$shop_shops_id );

    Описание

    Получение всех складов магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  if(($aWarehouses = $warehouse->GetAllWarehousesForShop($shop_shops_id)) !== false)
      7.

    7.  {
      8.

    8.    foreach ($aWarehouses as $shop_warehouses_row)
      9.

    9.      {
      10.

    10.          var_dump($shop_warehouses_row);
      11.

    11.      }
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Данные отсутствуют";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    массив или false

    [ Наверх ]

    warehouse::GetDefaultWarehouse

GetDefaultWarehouse(
int
$shop_shops_id );

    Описание

    Получение склада по умолчанию для магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  if(($default_warehouse_row = $warehouse->GetDefaultWarehouse($shop_shops_id)) !== false)
      7.

    7.  {
      8.

    8.      var_dump($default_warehouse_row);
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Склад \"По умолчанию\" не обнаружен!";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    массив с данными, либо false

    [ Наверх ]

    warehouse::GetItemCountForAllWarehouses

GetItemCountForAllWarehouses(
int
$shop_items_catalog_item_id );

    Описание

    Получение количества определенного товара на всех складах

    Принимаемые параметры

    $shop_items_catalog_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_items_catalog_item_id = 1;
      5.

    5.
      6.

    6.  if(($item_count = $warehouse->GetItemCountForAllWarehouses($shop_items_catalog_item_id)) > 0)
      7.

    7.  {
      8.

    8.      echo "Количество товара на всех складах: $item_count";
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Товар отсутствует на всех складах";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    количество товара на складах, либо 0, если товара на складах нет

    [ Наверх ]

    warehouse::GetItemCountForWarehouse

GetItemCountForWarehouse(
int
$shop_warehouse_id, int
$shop_items_catalog_item_id );

    Описание

    Получение количества определенного товара на определенном складе

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада

    $shop_items_catalog_item_id

    идентификатор товара
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 1;
      5.

    5.  $shop_items_catalog_item_id = 10;
      6.

    6.
      7.

    7.  if(($item_count = $warehouse->GetItemCountForWarehouse($shop_warehouse_id, $shop_items_catalog_item_id)) > 0)
      8.

    8.  {
      9.

    9.      echo "Количество товара на складе: $item_count";
      10.

    10.  }
      11.

    11.  else
      12.

    12.  {
      13.

    13.      echo "Товар на складе отсутствует";
      14.

    14.  }
      15.

    15.  ?>
      16.

    Возвращает

    количество товара на складе, либо 0, если товара на складе нет

    [ Наверх ]

    warehouse::GetWarehouse

GetWarehouse(
int
$shop_warehouse_id );

    Описание

    Получение информации о складе

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 1;
      5.

    5.
      6.

    6.  if(($warehouse_row = $warehouse->GetWarehouse($shop_warehouse_id)) !== false)
      7.

    7.  {
      8.

    8.      var_dump($warehouse_row);
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Ошибка получения данных о складе!";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    массив данных, либо false

    [ Наверх ]

    warehouse::GetWarehouseItem

GetWarehouseItem(
array
$param, int
$shop_warehouse_id );

    Описание

    Получение информации об остатке товара на складе, получение возможно  по shop_warehouse_items_id или паре значений идентификатор склада и идентификатор товара

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада

    $param

    массив параметров
    • int $param['shop_warehouse_items_id'] идентификатор связи
    • int $param['shop_warehouse_id'] идентификатор склада
    • int $param['shop_items_catalog_item_id'] идентификатор товара

    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $param = array();
      5.

    5.  $param['shop_warehouse_items_id'] = 1;
      6.

    6.
      7.

    7.  // либо, используя составной ключ, можно задать идентификаторы склада и товара
      8.

    8.  $param['shop_warehouse_id'] = 10;
      9.

    9.  $param['shop_items_catalog_item_id'] = 20;
      10.

    10.
      11.

    11.  if(($warehouse_item_row = $warehouse->GetWarehouseItem($param)) !== false)
      12.

    12.  {
      13.

    13.      var_dump($warehouse_item_row);
      14.

    14.  }
      15.

    15.  else
      16.

    16.  {
      17.

    17.      echo "Ошибка получения данных об остатке!";
      18.

    18.  }
      19.

    19.  ?>
      20.

    Возвращает

    массив данных, либо false

    [ Наверх ]

    warehouse::GetWarehousesXml

GetWarehousesXml(
int
$shop_shops_id );

    Описание

    Формирование XML для всех складов магазина

    Принимаемые параметры

    $shop_shops_id

    идентификатор магазина
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_shops_id = 1;
      5.

    5.
      6.

    6.  if(($warehouses_xml = $warehouse->GetWarehousesXml($shop_shops_id)) != '')
      7.

    7.  {
      8.

    8.      echo $warehouses_xml;
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Нет XML-данных о складах!";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    строка XML в случае успеха, либо пустая строка

    [ Наверх ]

    warehouse::GetWarehouseXml

GetWarehouseXml(
int
$shop_warehouse_id );

    Описание

    Формирование XML для конкретного склада магазина

    Принимаемые параметры

    $shop_warehouse_id

    идентификатор склада
    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $shop_warehouse_id = 1;
      5.

    5.
      6.

    6.  if(($warehouse_xml = $warehouse->GetWarehouseXml($shop_warehouse_id)) != '')
      7.

    7.  {
      8.

    8.      echo $warehouse_xml;
      9.

    9.  }
      10.

    10.  else
      11.

    11.  {
      12.

    12.      echo "Нет XML-данных о складе!";
      13.

    13.  }
      14.

    14.  ?>
      15.

    Возвращает

    строка XML в случае успеха, либо пустая строка

    [ Наверх ]

    warehouse::InsertWarehouse

InsertWarehouse(
array
$param );

    Описание

    Вставка/обновление склада

    Принимаемые параметры

    $param

    массив параметров
    • int $param['shop_warehouse_id'] идентификатор склада (для обновления)
    • int $param['shop_shops_id'] идентификатор магазина
    • str $param['shop_warehouse_name'] наименование склада
    • int $param['shop_warehouse_activity'] флажок активности склада
    • int $param['shop_country_id'] идентификатор страны
    • int $param['shop_location_id'] идентификатор области
    • int $param['shop_city_id'] идентификатор города
    • int $param['shop_city_area_id'] идентификатор района
    • str $param['shop_warehouse_address'] адрес склада
    • int $param['users_id'] идентификатор пользователя центра администрирования для установки владельца записи (используется только если $param['shop_warehouse_id'] == 0  или не передан)
    • int $param['shop_warehouse_order'] порядок сортировки склада
    • int $param['shop_warehouse_default'] флаг "склад по умолчанию" (с этим параметром обязательно должен быть передан параметр $param['shop_shops_id'])

    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $param = array();
      5.

    5.
      6.

    6.  $param['shop_warehouse_id'] = 1;
      7.

    7.  $param['shop_shops_id'] = 10;
      8.

    8.  $param['shop_warehouse_name'] = "Основной склад";
      9.

    9.  $param['shop_warehouse_activity'] = 1;
      10.

    10.  $param['shop_country_id'] = 1;
      11.

    11.  $param['shop_location_id'] = 1;
      12.

    12.  $param['shop_city_id'] = 1;
      13.

    13.  $param['shop_city_area_id'] = 1;
      14.

    14.  $param['shop_warehouse_address'] = "ул. Ленина 176";
      15.

    15.  $param['shop_warehouse_order'] = 10;
      16.

    16.  $param['shop_warehouse_default'] = 1;
      17.

    17.
      18.

    18.  if(($new_warehouse_id = $warehouse->InsertWarehouse($param)) !== false)
      19.

    19.  {
      20.

    20.      echo "Склад с идентификатором $new_warehouse_id успешно добавлен!";
      21.

    21.  }
      22.

    22.  else
      23.

    23.  {
      24.

    24.      echo "Ошибка добавления склада!";
      25.

    25.  }
      26.

    26.
      27.

    27.  ?>
      28.

    Возвращает

    идентификатор вставленной/обновленной записи, либо false

    [ Наверх ]

    warehouse::InsertWarehouseItems

InsertWarehouseItems(
array
$param );

    Описание

    Вставка/обновление количества товара на складе.

    Обновление ведется по идентификатору связи, либо по индентификатору склада и товара

    Принимаемые параметры

    $param

    массив параметров
    • int $param['shop_warehouse_items_id'] идентификатор связи (для обновления)
    • int $param['shop_warehouse_id'] идентификатор склада
    • int $param['shop_items_catalog_item_id'] идентификатор товара
    • float $param['shop_warehouse_items_count'] количество товара на складе
    • int $param['users_id'] идентификатор пользователя центра администрирования для установки владельца записи (используется только если $param['shop_warehouse_items_id'] == 0 или не передан)

    1.  <?php
      2.

    2.  $warehouse = & singleton('warehouse');
      3.

    3.
      4.

    4.  $param = array();
      5.

    5.  $param['shop_warehouse_id'] = 1;
      6.

    6.  $param['shop_items_catalog_item_id'] = 10;
      7.

    7.  $param['shop_warehouse_items_count'] = 100;
      8.

    8.
      9.

    9.  if(($new_warehouse_items_id = $warehouse->InsertWarehouseItems($param)) !== false)
      10.

    10.  {
      11.

    11.      echo "Отстаток товара с идентификатором $new_warehouse_items_id успешно добавлен!";
      12.

    12.  }
      13.

    13.  else
      14.

    14.  {
      15.

    15.      echo "Ошибка добавления остатка!";
      16.

    16.  }
      17.

    17.  ?>
      18.

    Возвращает

    идентификатор вставленной/обновленной записи, либо false

    [ Наверх ]

Описания переменных

  • $CacheGetAllWarehousesForShop = array() [Строка 33]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetAllWarehousesForShop()

  • $CacheGetItemCountForWarehouse = array() [Строка 27]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetItemCountForWarehouse()

  • $CacheGetWarehouse = array() [Строка 21]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetWarehouse()

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class wysiwyg

Class wysiwyg

[Строка 14]

Размещен: /Kernel/Wysiwyg.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Ядро, класс визуального редактора.
Файл: /modules/Kernel/wysiwyg.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $init = array()

        Массив настроек для tinyMCE.init, заполняется в конструкторе, пример:  $this->init['mode'] = "exact";

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • wysiwyg wysiwyg()

    Конструктор

  • void AddInit()

    Добавление записи в блок tinyMCE.init

  • void RemoveInit()

    Удаление записи из блока tinyMCE.init

  • void show_ws()

    Метод отображает визуальный редактор

Унаследованные методы

Описания методов

    wysiwyg::wysiwyg

wysiwyg(
 );

    Описание

    Конструктор

    [ Наверх ]

    wysiwyg::AddInit

AddInit(
string
$name, string
$value );

    Описание

    Добавление записи в блок tinyMCE.init

    1.  $wysiwyg = & singleton('wysiwyg');
      2.

    2.  $wysiwyg->AddInit('mode', '"exact"');
      3.

    Принимаемые параметры

    $name

    название параметра

    $value

    значение

    [ Наверх ]

    wysiwyg::RemoveInit

RemoveInit(
string
$name );

    Описание

    Удаление записи из блока tinyMCE.init

    1.  $wysiwyg = & singleton('wysiwyg');
      2.

    2.  $wysiwyg->RemoveInit('mode');
      3.

    Принимаемые параметры

    $name

    название параметра

    [ Наверх ]

    wysiwyg::show_ws

show_ws(
string
$main_text, [int
$templates_id = 0], [string
$ws_name = 'textarea'] );

    Описание

    Метод отображает визуальный редактор

    Принимаемые параметры

    $main_text

    - содержит текст, включаемый в редактор

    $templates_id

    - идентификатор шаблона

    $ws_name

    [ Наверх ]

Описания переменных

  • $init = array() [Строка 22]
    •

  • Data type: array
    •

    Описание

    Массив настроек для tinyMCE.init, заполняется в конструкторе, пример:  $this->init['mode'] = "exact";

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Docs For Class xsl

Class xsl

[Строка 14]

Размещен: /Xsl/Xsl.class.php

Описание

Система управления сайтом HostCMS v. 5.xx

Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
Класс модуля "XSL-шаблоны".
Файл: /modules/Xsl/Xsl.class.php

author

Hostmake LLC

version

5.x

Свойства класса

  • $CacheGetXsl = array()

        Кэш для метода GetXsl()

  • $mas_xsl_dir = array()

  • $mas_xsl_group_path = array()

        Массив с информацией о пути к каждому разделу XSL

  • $section_path =  ''

Константы класса

Унаследованные константы класса

Унаследованные свойства класса

Методы

  • string build()

    Метод обработки XML данных с помощью XSL шаблона

  • mixed CopyXsl()

    Метод копирования XSL-шаблона

  • boolean del_xsl()

    Метод удаления XSL-шаблона

  • boolean del_xsl_dir()

    Метод удаления XSL-раздела

  • array fill_xsl_dir()

    Метод формирования дерева разделов

  • string FormatXml()

    Форматирование XML-документа

  • array GetMasXslGroupPath()

    Получение массива с информацией о разделах, составляющих путь от текущего до корневого раздела

  • mixed GetXsl()

    Получение информаци об XSL-шаблоне по его имени

  • string GetXslPath()

    Получение пути к файлу xsl

  • void get_section_path()

    Получение пути по дереву разделов XSL. Устаревший метод

  • mixed InsertXsl()

    Метод вставки/обновления информации об XSL-шаблоне.

  • mixed InsertXslDir()

    Метод вставки и обновления XSL-рубрик

  • boolean insert_xsl()

    Метод вставки/обновления XSL. Устаревший метод

  • mixed insert_xsl_dir()

    Метод вставки и обновления XSL-рубрик. Устаревший метод

  • mixed select_xsl()

    Получение данных о XSL-шаблонах

  • mixed select_xsl_dir()

    Получение информации о XSL-разделах

Унаследованные методы

Описания методов

    xsl::build

build(
string
$xmlData, string
$xsl_name );

    Описание

    Метод обработки XML данных с помощью XSL шаблона

    Принимаемые параметры

    $xmlData

    - XML данные

    $xsl_name

    • название XSL шаблона для обработки XML данных

      1.  <?php
        2.

      2.  $xsl = new xsl();
        3.

      3.
        4.

      4.  $xmlData = '<?xml version="1.0" encoding="utf-8"?>
        5.

      5.  <source>
        6.

      6.  <title>XSL</title>
        7.

      7.  <author>John Smith</author>
        8.

      8.  </source>';
        9.

      9.
        10.

      10.  $xsl_name = 'ВыводЕдиницыИнформационнойСистемы';
        11.

      11.
        12.

      12.  $result = $xsl->build($xmlData, $xsl_name);
        13.

      13.
        14.

      14.  // Распечатаем результат
        15.

      15.  echo $result;
        16.

      16.  ?>
        17.

    Возвращает

    результат обработки XML данных XSL шаблоном

    [ Наверх ]

    xsl::CopyXsl

CopyXsl(
int
$xsl_id );

    Описание

    Метод копирования XSL-шаблона

    Принимаемые параметры

    $xsl_id

    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_id = 184;
      5.

    5.
      6.

    6.  $newid = $xsl->CopyXsl($xsl_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  echo $newid;
      10.

    10.  ?>
      11.

    Возвращает

    идентификатор копии XSL-шаблона в случае успешного выполнения, false - в противном случае

    [ Наверх ]

    xsl::del_xsl

del_xsl(
int
$xsl_id );

    Описание

    Метод удаления XSL-шаблона

    Принимаемые параметры

    $xsl_id

    - идентификатор XSL-шаблона
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_id = 183;
      5.

    5.
      6.

    6.  $result = $xsl->del_xsl($xsl_id);
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения метода, false в противном случае

    [ Наверх ]

    xsl::del_xsl_dir

del_xsl_dir(
int
$xsl_dir_id );

    Описание

    Метод удаления XSL-раздела

    Принимаемые параметры

    $xsl_dir_id

    - идентификатор XSL-заздела
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_dir_id = 81;
      5.

    5.
      6.

    6.  $result = $xsl->del_xsl_dir($xsl_dir_id);;
      7.

    7.
      8.

    8.  if ($result)
      9.

    9.  {
      10.

    10.     echo "Удаление выполнено успешно";
      11.

    11.  }
      12.

    12.  else
      13.

    13.  {
      14.

    14.     echo "Ошибка удаления";
      15.

    15.  }
      16.

    16.  ?>
      17.

    Возвращает

    true в случае успешного выполнения метода, false в противном случае

    [ Наверх ]

    xsl::fill_xsl_dir

fill_xsl_dir(
int
$xsl_dir_parent_id, string
$separator );

    Описание

    Метод формирования дерева разделов

    Принимаемые параметры

    $xsl_dir_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_dir_parent_id = 0;
      5.

    5.  $separator = '';
      6.

    6.
      7.

    7.  $row = $xsl->fill_xsl_dir($xsl_dir_parent_id, $separator);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    Возвращает

    массив с данными о дереве XSL-разделов

    [ Наверх ]

    xsl::FormatXml

FormatXml(
string
$file_content );

    Описание

    Форматирование XML-документа

    Принимаемые параметры

    $file_content

    текст форматируемого XML-документа
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xml = '<?xml version="1.0" encoding="utf-8"?>
      5.

    5.  <source>
      6.

    6.  <title>XSL</title>
      7.

    7.  <author>John Smith</author>
      8.

    8.  </source>';
      9.

    9.
      10.

    10.  $result = $xsl->FormatXml($xml);
      11.

    11.
      12.

    12.  // Распечатаем результат
      13.

    13.  echo "<pre>".htmlspecialchars($result)."<pre>";
      14.

    14.  ?>
      15.

    Возвращает

    отформатированный текст

    [ Наверх ]

    xsl::GetMasXslGroupPath

GetMasXslGroupPath(

$xsl_dir_parent_id, int
$xsl_dir_id );

    Описание

    Получение массива с информацией о разделах, составляющих путь от текущего до корневого раздела

    Принимаемые параметры

    $xsl_dir_id

    идентификатор раздела XSL
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_dir_parent_id = 0;
      5.

    5.  $xsl_dir_id = 3;
      6.

    6.
      7.

    7.  $row = $xsl->GetMasXslGroupPath($xsl_dir_parent_id, $xsl_dir_id);
      8.

    8.
      9.

    9.  // Распечатаем результат
      10.

    10.  print_r($row);
      11.

    11.  ?>
      12.

    $xsl_dir_parent_id

    Возвращает

    массив с информацией о разделах XSL, составляющих путь от данного раздела до корневого

    [ Наверх ]

    xsl::GetXsl

GetXsl(
string
$xsl_name, [array
$param = array()] );

    Описание

    Получение информаци об XSL-шаблоне по его имени

    Принимаемые параметры

    $xsl_name

    - имя XSL-шаблона

    $param

    ассоциативный массив параметров
    • bool $param['cache_off'] - если параметр установлен - данные не кэшируются

      1.  <?php
        2.

      2.  $xsl = new xsl();
        3.

      3.
        4.

      4.  $xsl_name = 'МагазинТовар';
        5.

      5.
        6.

      6.  $newxsl = $xsl->GetXsl($xsl_name);
        7.

      7.
        8.

      8.  // Распечатаем результат
        9.

      9.  print_r ($newxsl);
        10.

      10.  ?>
        11.

    Возвращает

    ассоциативный массив с информацией об XSL-шаблоне в случае успешного выполнения, false в противном случае

    [ Наверх ]

    xsl::GetXslPath

GetXslPath(
int
$xsl_id );

    Описание

    Получение пути к файлу xsl

    Принимаемые параметры

    $xsl_id

    Идентификатор XSL-шаблона

    Возвращает

    путь к файлу

    [ Наверх ]

    xsl::get_section_path

get_section_path(
int
$xsl_dir_id );

    Описание

    Получение пути по дереву разделов XSL. Устаревший метод

    Принимаемые параметры

    $xsl_dir_id

    [ Наверх ]

    xsl::InsertXsl

InsertXsl(
array
$param );

    Описание

    Метод вставки/обновления информации об XSL-шаблоне.

    Принимаемые параметры

    $param

    param массив параметров  param['xsl_id'] идентификатор обновляемого XSL шаблона (при вставке нового XSL шаблона не указывается или равен 0)  param['xsl_dir_id'] идентификатор раздела, к которому относится данный XSL шаблон  param['xsl_name'] имя XSL-шаблона  param['xsl_value'] текст XSL-шаблона  param['xsl_comment'] комментарий к XSL-шаблону  param['xsl_order'] порядковый номер XSL-шаблона в разделе шаблонов  param['xsl_format'] параметр, определяющий будет ли проводится форматирование XSL-шаблона  param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $param['xsl_dir_id'] = 0;
      5.

    5.  $param['xsl_name'] = 'Новый XSL';
      6.

    6.  $param['xsl_value'] = 'Текст XSL-шаблона';
      7.

    7.  $param['xsl_comment'] = 'Комментарий к XSL-шаблону';
      8.

    8.
      9.

    9.  $newxsl = $xsl->InsertXsl($param);
      10.

    10.
      11.

    11.  // Распечатаем результат
      12.

    12.  echo $newxsl;
      13.

    13.  ?>
      14.

    Возвращает

    идентификатор XSL-шаблона при успешном добавлении/обновлении XSL шаблона, false – в противном случае

    [ Наверх ]

    xsl::InsertXslDir

InsertXslDir(
array
$param );

    Описание

    Метод вставки и обновления XSL-рубрик

    Принимаемые параметры

    $param

    массив параметров
    • $param['type'] параметр, определяющий производится вставка или обновление информации
    • $param['xsl_dir_id']  идентификатор обновляемой рубрики (при вставке равен 0)
    • $param['xsl_dir_parent_id'] идентификатор родительской рубрики
    • $param['xsl_dir_name']  название рубрики
    • $param['xsl_dir_order'] порядковый номер рубрики
    • $param['users_id'] идентификатор пользователя, если false - берется текущий пользователь.

      1.  <?php
        2.

      2.  $xsl = new xsl();
        3.

      3.
        4.

      4.  $param['xsl_dir_parent_id'] = '';
        5.

      5.  $param['xsl_dir_name'] = 'Новая XSL-рубрика';
        6.

      6.  $param['xsl_dir_order'] = 10;
        7.

      7.
        8.

      8.  $newxsl = $xsl->InsertXslDir($param);
        9.

      9.
        10.

      10.  // Распечатаем результат
        11.

      11.  echo $newxsl;
        12.

      12.  ?>
        13.

    Возвращает

    идентификатор XSL-рубрики в случае успешного выполнения метода, false - в противном случае

    [ Наверх ]

    xsl::insert_xsl

insert_xsl(
int
$type, int
$xsl_id, int
$xsl_dir_id, string
$xsl_name, string
$xsl_value, string
$xsl_comment, [int
$users_id = false] );

    Описание

    Метод вставки/обновления XSL. Устаревший метод

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление XSL

    $xsl_id

    идентификатор обновляемого XSL шаблона (при вставке нового XSL шаблона равен 0)

    $xsl_dir_id

    идентификатор раздела, к которому относится данный XSL шаблон

    $xsl_name

    имя XSL шаблона

    $xsl_value

    текст XSL шаблона

    $xsl_comment

    комментарий к XSL шаблону

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    true при успешном добавлении/обновлении XSL шаблона, false – в противном случае

    [ Наверх ]

    xsl::insert_xsl_dir

insert_xsl_dir(
int
$type, int
$xsl_dir_id, int
$xsl_dir_parent_id, string
$xsl_dir_name, [int
$users_id = false] );

    Описание

    Метод вставки и обновления XSL-рубрик. Устаревший метод

    Принимаемые параметры

    $type

    - параметр, определяющий производится вставка или обновление информации

    $xsl_dir_id

    - идентификатор обновляемой рубрики (при вставке равен 0)

    $xsl_dir_parent_id

    - идентификатор родительской рубрики

    $xsl_dir_name

    - название рубрики

    $users_id

    идентификатор пользователя, если false - берется текущий пользователь.

    Возвращает

    идентификатор вставленной/обновленной рубрики в случае успешного выполнения, false в противном случае

    [ Наверх ]

    xsl::select_xsl

select_xsl(
int
$xsl_id, [int
$xsl_dir_id = false] );

    Описание

    Получение данных о XSL-шаблонах

    Принимаемые параметры

    $xsl_id

    - идентификатор XSL-шаблона, если необходимо получить информацию о конкретном XSL-шаблоне, -1 - получить информацию о всех XSL-шаблонах

    $xsl_dir_id

    - идентификатор директории XSL шаблона, если -1, то директория не учитывается
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_id = 3;
      5.

    5.
      6.

    6.  $resource = $xsl->select_xsl($xsl_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    result в случае успешного выполнения метода, false в противном случае

    [ Наверх ]

    xsl::select_xsl_dir

select_xsl_dir(
int
$xsl_dir_id );

    Описание

    Получение информации о XSL-разделах

    Принимаемые параметры

    $xsl_dir_id

    - идентификатор XSL-раздела, если необходимо получить информацию о конкретном разделе, -1 - получить информацию о всех XSL-разделах
    1.  <?php
      2.

    2.  $xsl = new xsl();
      3.

    3.
      4.

    4.  $xsl_dir_id = 2;
      5.

    5.
      6.

    6.  $resource = $xsl->select_xsl_dir($xsl_dir_id);
      7.

    7.
      8.

    8.  // Распечатаем результат
      9.

    9.  while($row = mysql_fetch_assoc($resource))
      10.

    10.  {
      11.

    11.      print_r($row);
      12.

    12.  }
      13.

    13.  ?>
      14.

    Возвращает

    resorce в случае успешного выполнения метода, false в противном случае

    [ Наверх ]

Описания переменных

  • $CacheGetXsl = array() [Строка 46]
    •

  • Data type: array
    •

    Описание

    Кэш для метода GetXsl()

  • $mas_xsl_dir = array() [Строка 16]
    •

  • Data type: mixed
    •

  • $mas_xsl_group_path = array() [Строка 37]
    •

  • Data type: array
    •

    Описание

    Массив с информацией о пути к каждому разделу XSL

    • $mas_xsl_group_path[<Идентификатор раздела XSL>][<Идентификатор родительского раздела>][array('xsl_dir_id'=><Идентификатор родительского раздела>, 'xsl_dir_parent_id'=><Идентификатор родительского узла родительского раздела>, 'xsl_dir_name'=>'<Название родительского раздела>', 'xsl_dir_order'=>'<Порядковый номер родительского раздела>')]
    • $mas_xsl_group_path[20][3]['xsl_dir_id'] = 3
    • $mas_xsl_group_path[20][3]['xsl_dir_parent_id'] = 1
    • $mas_xsl_group_path[20][3]['xsl_dir_name'] = 'Подгруппа группы1'
    • $mas_xsl_group_path[20][3]['xsl_dir_order'] = 5

    • $mas_xsl_group_path[20][1]['xsl_dir_id'] = 1
    • $mas_xsl_group_path[20][1]['xsl_dir_parent_id'] = 0
    • $mas_xsl_group_path[20][1]['xsl_dir_name'] = 'Группа1'
    • $mas_xsl_group_path[20][1]['xsl_dir_order'] = 10

    • $mas_xsl_group_path[20][0]['xsl_dir_id'] = 0
    • $mas_xsl_group_path[20][0]['xsl_dir_parent_id'] = ''
    • $mas_xsl_group_path[20][0]['xsl_dir_name'] = 'Корневая группа'
    • $mas_xsl_group_path[20][0]['xsl_dir_order'] = 0

  • $section_path =  '' [Строка 39]
    •

  • Data type: mixed
    •

Описание констант класса

Copyright © 2005—2010 ООО «Хостмэйк»


Element Index

Список всех элементов

Indexes by package:
HostCMS_5

$ a b c d e f g h i j k l m n o p q r s t u v w x y _
top
$
$row['constants_name'] | in file Kernel.php, constant $row['constants_name']
top
a
$AAction in file admin_forms.class.php, variable admin_forms::$AAction
Значение AAction, переданное DoLoadAjax
$AAdditionalParams in file admin_forms.class.php, variable admin_forms::$AAdditionalParams
Значение AAdditionalParams, переданное DoLoadAjax
$aJs | in file Kernel.class.php, variable kernel::$aJs
$allowed_symbols in file Captcha.class.php, variable Captcha::$allowed_symbols
Разрешенные символы. Исключены похожие по написанию o=0, 1=l, i=j, t=f:
$angle in file Graphic.class.php, variable graphic::$angle
Вращение диаграммы вокруг оси
$array_template_ids | in file Templates.class.php, variable templates::$array_template_ids
$available_extantions in file Kernel.class.php, variable kernel::$available_extantions
Доступные для загрузки расширения файлов
$a_count_property in file Structure.class.php, variable Structure::$a_count_property
Ассоциативный массив-Кэш количества свойств для разных сайтов
AcceptAffiliatePlanForSiteUsers in file affiliate.class.php, method affiliate::AcceptAffiliatePlanForSiteUsers()
Начисление пользователю сумм с заказа по партнеской программе
AcceptAffiliatePlanToShop in file affiliate.class.php, method affiliate::AcceptAffiliatePlanToShop()
Добавление/удаление ассоциации партнерской программы магазину
AcceptTransaction in file warehouse.class.php, method warehouse::AcceptTransaction()
Списание с определенного склада определенное количество определенного товара
AccessSiteUserToMessage in file messages.class.php, method messages::AccessSiteUserToMessage()
Проверка доступа пользователя сайта к сообщению
AccessToAttachment in file helpdesk.class.php, method helpdesk::AccessToAttachment()
Проверка доступа пользователя сайта к вложенным файлам
AddAdminMenuItem in file AdminMenu.class.php, method AdminMenu::AddAdminMenuItem()
Метод добавляет модуль в меню раздела администрирования
AddBanner in file Advertisement.class.php, method Advertisement::AddBanner()
Добавление/редактирование баннера
AddBbCode in file Forums.class.php, method Forums::AddBbCode()
Добавление правила BB-кодов
AddButton in file admin_forms_fields.class.php, method admin_forms_fields::AddButton()
Вставка кнопки в форму
AddComment in file InformationSystems.class.php, method InformationSystem::AddComment()
Вставка/обновление комментария для элемента информационной системы
AddCommentWithoutStriptags in file InformationSystems.class.php, method InformationSystem::AddCommentWithoutStriptags()
Вставка/обновление комментария без удаления тегов в передаваемых параметрах
AddEditConstants in file Constants.class.php, method Constants::AddEditConstants()
Добавление/редактирование данных о константе
AddEditInitialData in file Counter.class.php, method counter::AddEditInitialData()
Добавление/редактирование начальных данных для счетчика
AddEditTheme in file Forums.class.php, method Forums::AddEditTheme()
Добавление/редактирование темы
AddExternalHtml in file admin_forms_fields.class.php, method admin_forms_fields::AddExternalHtml()
Добавить внешний HTML для формы
AddExternalReplace in file admin_forms.class.php, method admin_forms::AddExternalReplace()
Добавление внешней подстановки
AddField in file admin_forms_fields.class.php, method admin_forms_fields::AddField()
Добавление элемента на форму.
AddInclude in file Kernel.class.php, method kernel::AddInclude()
Метод подключает файл по указанному адресу
AddInit in file Wysiwyg.class.php, method wysiwyg::AddInit()
Добавление записи в блок tinyMCE.init
AddIntoCart in file shop.class.php, method shop::AddIntoCart()
Метод помещения товара в корзину
AddJs in file Kernel.class.php, method kernel::AddJs()
Добавление внешнего JavaScript файла для подключения в центре администрирования
AddLanguage in file admin_forms.class.php, method admin_forms::AddLanguage()
Вставка/обновление информации о языке
AddMenu in file admin_forms_fields.class.php, method admin_forms_fields::AddMenu()
Добавление верхнего меню
AddModule in file Kernel.class.php, method kernel::AddModule()
Метод подключения модуля
AddModuleFile in file Kernel.class.php, method kernel::AddModuleFile()
Осуществляет добавление файла модуля в список файлов модулей для загрузки.
AddSeparator in file admin_forms_fields.class.php, method admin_forms_fields::AddSeparator()
Вставка разделителя
AddTab in file admin_forms_fields.class.php, method admin_forms_fields::AddTab()
Вставка новой закладки
AddUserMessage in file admin_forms.class.php, method admin_forms::AddUserMessage()
Добавление текста, выводимого перед формой
AddXmlContent in file Kernel.class.php, method kernel::AddXmlContent()
Дописывает $xml к $this->ShowXmlContent
add_modules_version in file Kernel.class.php, method kernel::add_modules_version()
Метод добавления модуля в массив-список модулей
Admin | in file Admin.class.php, method Admin::Admin()
Admin in file Admin.class.php, class Admin
Система управления сайтом HostCMS v. 5.xx
AdminLoadFiles in file Kernel.class.php, method kernel::AdminLoadFiles()
Метод загрузки файлов в центре администрирования
AdminMainPage in file InformationSystems.class.php, method InformationSystem::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Cache.class.php, method Cache::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Site.class.php, method site::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Site_users.class.php, method SiteUsers::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Search.class.php, method Search::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file shop.class.php, method shop::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMainPage in file Counter.class.php, method counter::AdminMainPage()
Функция обратного вызова для отображения блока на основной странице центра администрирования.
AdminMenu in file AdminMenu.class.php, class AdminMenu
Система управления сайтом HostCMS v. 5.xx
AdminSessionStart in file Admin.class.php, method Admin::AdminSessionStart()
Запуск сессии для центра администрирования
admin_datetime_format in file Date.class.php, method DateClass::admin_datetime_format()
Метод для центра администрирования, преобразует формат выводы даты из sql-формата в формат d.m.Y H:i:s
admin_date_format in file Date.class.php, method DateClass::admin_date_format()
Метод для центра администрирования, преобразует формат выводы даты из sql-формата в формат d.m.Y
admin_forms in file admin_forms.class.php, method admin_forms::admin_forms()
Конструктор, инициализирует значения свойств класса $this->AAction, $this->AAdditionalParams
admin_forms in file admin_forms.class.php, class admin_forms
Система управления сайтом HostCMS v. 5.xx
admin_forms.class.php | procedural page admin_forms.class.php
admin_forms.php | procedural page admin_forms.php
admin_forms_fields.class.php | procedural page admin_forms_fields.class.php
admin_forms_fields in file admin_forms_fields.class.php, class admin_forms_fields
Система управления сайтом HostCMS v. 5.xx
admin_forms_fields in file admin_forms_fields.class.php, method admin_forms_fields::admin_forms_fields()
Конструктор класса
admin_init in file Admin.class.php, method Admin::admin_init()
Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта
admin_session_valid in file Admin.class.php, method Admin::admin_session_valid()
Метод проверки авторизации пользователя
Advertisement in file Advertisement.class.php, class Advertisement
Класс модуля "Реклама"
Advertisement.class.php | procedural page Advertisement.class.php
Advertisement.php | procedural page Advertisement.php
affiliate in file affiliate.class.php, class affiliate
Система управления сайтом HostCMS v. 5.xx Copyright © 2005-2010 ООО "Хостмэйк" (Hostmake LLC), http://www.hostcms.ru
AlignTextSpace in file Counter.class.php, method counter::AlignTextSpace()
Выравнивание текста по центру с помощью пробелов
AllowShowPanel in file Kernel.class.php, method kernel::AllowShowPanel()
Определяет возможность отображения панели пользователю.
AllowYandexXml in file seo.class.php, method Seo::AllowYandexXml()
Проверка возможности использования Яндекс.XML
AnalizeForKeyWords in file helpdesk.class.php, method helpdesk::AnalizeForKeyWords()
Анализ сообщения на предмет содержания ключевых слов для стандартных ответов.
ApplyFormat in file admin_forms.class.php, method admin_forms::ApplyFormat()
Применяет формат отображения $format к строке $str.
ApplyMailTemplate in file Maillist.class.php, method Maillist::ApplyMailTemplate()
Метод осуществляющий шаблонную подстановку в текст письма информации о пользоваетеле сайта
ApplyTextFunctionWithoutCodeSection in file Forums.class.php, method Forums::ApplyTextFunctionWithoutCodeSection()
Применение функции к фрагментам текста, содержащихся во вне блоков [code]...[/code]
array_fill_keys | in file Kernel.php, function array_fill_keys()
array_intersect_key | in file Kernel.php, function array_intersect_key()
array_values_to_int in file Security.fns.php, function array_values_to_int()
Функция приведения значений одномерного массива к целому, ключи сохраняются
AssignGroupImage in file shop.class.php, method shop::AssignGroupImage()
Метод для установки имени изображения для группы товаров
AssignItemImage in file shop.class.php, method shop::AssignItemImage()
Метод для установки имени изображения для товара
AssignShopWatermark in file shop.class.php, method shop::AssignShopWatermark()
Метод осуществляющий обновление данных о файле watermark'a для магазина
Admin.class.php | procedural page Admin.class.php
AdminMenu.class.php | procedural page AdminMenu.class.php
admin_output.fns.php | procedural page admin_output.fns.php
affiliate.class.php | procedural page affiliate.class.php
top
b
$buttons | in file admin_forms_fields.class.php, variable admin_forms_fields::$buttons
Backup in file Backup.class.php, class Backup
Класс модуля "Резервное копирование"
Backup.class.php | procedural page Backup.class.php
Backup.php | procedural page Backup.php
BBcode2HTML in file Forums.class.php, method Forums::BBcode2HTML()
Замена BBcode на HTML.
bcpow | in file Kernel.php, function bcpow()
BodyDecode in file Mail.class.php, method Mail::BodyDecode()
Перекодировщик тела письма
build in file Xsl.class.php, method xsl::build()
Метод обработки XML данных с помощью XSL шаблона
BuildCapture in file Captcha.class.php, method Captcha::BuildCapture()
Метод для построения изображения CAPTCHA и помещения его текста в сессию
BuildMassReport in file seo.class.php, method Seo::BuildMassReport()
Игнорирование столбцов таблицы
BuildSubject in file helpdesk.class.php, method helpdesk::BuildSubject()
Формирование темы сообщения в соответствии с масками имени тикета и номера сообщения
build_counter in file Counter.class.php, method counter::build_counter()
Отображение счетчика
top
c
$CacheDiscountsForItem | in file shop.class.php, variable shop::$CacheDiscountsForItem
$CacheGetAdminFormsWord in file admin_forms.class.php, variable admin_forms::$CacheGetAdminFormsWord
Массив-кэш для метода GetAdminFormsWord()
$CacheGetAllPricesForItem in file shop.class.php, variable shop::$CacheGetAllPricesForItem
Кэш для метода GetAllPricesForItem()
$CacheGetAllWarehousesForShop in file warehouse.class.php, variable warehouse::$CacheGetAllWarehousesForShop
Кэш для метода GetAllWarehousesForShop()
$CacheGetAttachment in file helpdesk.class.php, variable helpdesk::$CacheGetAttachment
Кэш для метода GetAttachment()
$CacheGetCatalogItemIdByCmlId | in file shop.class.php, variable shop::$CacheGetCatalogItemIdByCmlId
$CacheGetCity in file shop.class.php, variable shop::$CacheGetCity
Кэш для метода GetCity()
$CacheGetCityArea in file shop.class.php, variable shop::$CacheGetCityArea
Кэш для метода GetCityArea()
$CacheGetConference in file Forums.class.php, variable Forums::$CacheGetConference
Кэш для метода GetConference()
$CacheGetCountItemsAndGroups in file shop.class.php, variable shop::$CacheGetCountItemsAndGroups
Кэш для GetCountItemsAndGroups
$CacheGetCountry in file shop.class.php, variable shop::$CacheGetCountry
Кэш для метода GetCountry()
$CacheGetCriticalLevel in file helpdesk.class.php, variable helpdesk::$CacheGetCriticalLevel
Кэш для метода GetCriticalLevel()
$CacheGetCurrencyByLike | in file shop.class.php, variable shop::$CacheGetCurrencyByLike
$CacheGetCurrentDocumentVersion in file Documents.class.php, variable documents::$CacheGetCurrentDocumentVersion
Кэш для метода GetCurrentDocumentVersion()
$CacheGetDiscount in file shop.class.php, variable shop::$CacheGetDiscount
Кэш скидок для GetDiscount
$CacheGetEmail in file helpdesk.class.php, variable helpdesk::$CacheGetEmail
Кэш для метода GetEmail()
$CacheGetFirstMessageTicket in file helpdesk.class.php, variable helpdesk::$CacheGetFirstMessageTicket
Кэш для метода GetFirstMessageTicket()
$CacheGetHelpdesk in file helpdesk.class.php, variable helpdesk::$CacheGetHelpdesk
Кэш для метода GetHelpdesk()
$CacheGetInfo4Messages in file helpdesk.class.php, variable helpdesk::$CacheGetInfo4Messages
Кэш для метода GetInfo4Messages()
$CacheGetItem in file shop.class.php, variable shop::$CacheGetItem
Кэш товаров для метода GetItem
$CacheGetItemCountForWarehouse in file warehouse.class.php, variable warehouse::$CacheGetItemCountForWarehouse
Кэш для метода GetItemCountForWarehouse()
$CacheGetItemPropertyIdByCmlId | in file shop.class.php, variable shop::$CacheGetItemPropertyIdByCmlId
$CacheGetLanguage in file admin_forms.class.php, variable admin_forms::$CacheGetLanguage
Массив кэш для GetLanguage()
$CacheGetLanguageByShortName in file admin_forms.class.php, variable admin_forms::$CacheGetLanguageByShortName
Массив-кэш для GetLanguageByShortName()
$CacheGetLocation in file shop.class.php, variable shop::$CacheGetLocation
Кэш для метода GetLocation()
$CacheGetMessage in file helpdesk.class.php, variable helpdesk::$CacheGetMessage
Кэш для метода GetMessage()
$CacheGetPriceByCmlId | in file shop.class.php, variable shop::$CacheGetPriceByCmlId
$CacheGetPriceForItem in file shop.class.php, variable shop::$CacheGetPriceForItem
Кэш для метода GetPriceForItem()
$CacheGetResponsible in file helpdesk.class.php, variable helpdesk::$CacheGetResponsible
Кэш для метода GetResponsible()
$CacheGetSiteUserByEmail in file helpdesk.class.php, variable helpdesk::$CacheGetSiteUserByEmail
Кэш для метода GetSiteUserByEmail()
$CacheGetSpecialPriceForItem in file shop.class.php, variable shop::$CacheGetSpecialPriceForItem
Кэш для метода GetSpecialPriceForItem()
$CacheGetSpecialPricesForItem in file shop.class.php, variable shop::$CacheGetSpecialPricesForItem
Кэш для метода GetSpecialPricesForItem()
$CacheGetStatus in file helpdesk.class.php, variable helpdesk::$CacheGetStatus
Кэш для метода GetStatus()
$CacheGetTag in file tag.class.php, variable Tag::$CacheGetTag
mem-cache для GetTag()
$CacheGetTagRelation in file tag.class.php, variable Tag::$CacheGetTagRelation
mem-cache для GetTagRelation()
$CacheGetTax in file shop.class.php, variable shop::$CacheGetTax
Кэш для метода GetTax()
$CacheGetTemplate in file helpdesk.class.php, variable helpdesk::$CacheGetTemplate
Кэш для метода GetTemplate()
$CacheGetTemplateDir in file helpdesk.class.php, variable helpdesk::$CacheGetTemplateDir
Кэш для метода GetTemplateDir()
$CacheGetTemplateKeyWords in file helpdesk.class.php, variable helpdesk::$CacheGetTemplateKeyWords
Кэш для метода GetTemplateKeyWords()
$CacheGetThemeLastMessage in file Forums.class.php, variable Forums::$CacheGetThemeLastMessage
Кэш для метода GetThemeLastMessage()
$CacheGetTicket in file helpdesk.class.php, variable helpdesk::$CacheGetTicket
Кэш для метода GetTicket()
$CacheGetTicketByName in file helpdesk.class.php, variable helpdesk::$CacheGetTicketByName
Кэш для метода GetTicketByName()
$CacheGetTicketCategory in file helpdesk.class.php, variable helpdesk::$CacheGetTicketCategory
Кэш для метода GetTicketCategory()
$CacheGetTicketFlags in file helpdesk.class.php, variable helpdesk::$CacheGetTicketFlags
Кэш для метода GetTicketFlags()
$CacheGetUser in file UserAccess.class.php, variable user_access::$CacheGetUser
Кэш для метода GetUser()
$CacheGetWarehouse in file warehouse.class.php, variable warehouse::$CacheGetWarehouse
Кэш для метода GetWarehouse()
$CacheGetWeekend in file helpdesk.class.php, variable helpdesk::$CacheGetWeekend
Кэш для метода GetWeekend()
$CacheGetWorkTime in file helpdesk.class.php, variable helpdesk::$CacheGetWorkTime
Кэш для метода GetWorkTime()
$CacheGetXsl in file Xsl.class.php, variable xsl::$CacheGetXsl
Кэш для метода GetXsl()
$CacheMessages in file messages.class.php, variable messages::$CacheMessages
Кэш сообщений
$CacheModificationItems in file shop.class.php, variable shop::$CacheModificationItems
Массив ID модификаций товара для товаров
$CacheSite in file Site.class.php, variable site::$CacheSite
Кэш данных о сайтах
$cache_dir_is_exist in file Cache.class.php, variable Cache::$cache_dir_is_exist
Флаг наличия директории для сохранения файлов кэша
$cache_mesure in file shop.class.php, variable shop::$cache_mesure
Кэш информации о единицах измерений
$cache_producer in file shop.class.php, variable shop::$cache_producer
Кэш информации о производителях
$cache_structure_property in file Structure.class.php, variable Structure::$cache_structure_property
Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.
$cache_systems in file Cache.class.php, variable Cache::$cache_systems
Массив доступных способов кэширования
$CallbackFunctionName in file admin_forms.class.php, variable admin_forms::$CallbackFunctionName
Наименование функции обратного вызова
$CartType in file shop.class.php, variable shop::$CartType
Тип сохранения корзины, 0 - COOKIES, 1 - СЕССИЯ.
$chmod_file | in file File.class.php, variable File::$chmod_file
$chmod_file | in file SiteTemplate.class.php, variable SiteTemplate::$chmod_file
$color in file Graphic.class.php, variable graphic::$color
Массив основных цветов
$CommentMass in file InformationSystems.class.php, variable InformationSystem::$CommentMass
Кэш с данными о комментариях
$CountDays4FirstWorkDay in file helpdesk.class.php, variable helpdesk::$CountDays4FirstWorkDay
Число дней до первого рабочего
$count_row in file Mysql.class.php, variable DataBase::$count_row
Количество выбранных строк в последнем запросе
$CURLOPT_HTTPPROXYTUNNEL in file Kernel.class.php, variable kernel::$CURLOPT_HTTPPROXYTUNNEL
При установке этого параметра в true данные будут передаваться через прокси-сервер
$CURLOPT_PROXY in file Kernel.class.php, variable kernel::$CURLOPT_PROXY
HTTP-прокси
$CURLOPT_PROXYAUTH in file Kernel.class.php, variable kernel::$CURLOPT_PROXYAUTH
Метод HTTP-авторизации для использования при соединении с прокси.
$CURLOPT_PROXYPORT in file Kernel.class.php, variable kernel::$CURLOPT_PROXYPORT
Номер порта для соединения с прокси-сервером; используется совместно с CURLOPT_PROXY
$CURLOPT_PROXYTYPE in file Kernel.class.php, variable kernel::$CURLOPT_PROXYTYPE
CURLPROXY_HTTP по умолчанию или CURLPROXY_SOCKS5
$CURLOPT_PROXYUSERPWD in file Kernel.class.php, variable kernel::$CURLOPT_PROXYUSERPWD
Имя пользователя и пароль в формате "[username]:[password]" для использования при соединении с прокси
$current_alias_cache | in file Site.class.php, variable site::$current_alias_cache
$c_dev in file Graphic.class.php, variable graphic::$c_dev
Отклонение углов сегментов
Cache in file Cache.class.php, class Cache
Класс модуля "Кэш"
Cache in file Cache.class.php, method Cache::Cache()
Конструктор
Cache.class.php | procedural page Cache.class.php
Cache.php | procedural page Cache.php
config.php | procedural page config.php
CACHE_INSTALL in file Cache.php, constant CACHE_INSTALL
Система управления сайтом HostCMS v. 5.xx
CallProbability in file Cache.class.php, method Cache::CallProbability()
Определяет необходимости удаления истекших элементов кэша
CancelOrder in file shop.class.php, method shop::CancelOrder()
Метод для отмены заказа (устанавливает поле shop_order_cancel = 1)
Captcha in file Captcha.class.php, class Captcha
Система управления сайтом HostCMS v. 5.xx
CdirCorrection in file FileManager.class.php, method FileManager::CdirCorrection()
Обработка (удаление имени файла, "лишних" слэшей и т.д) пути к директории
ChangeAssociateSiteUserWithUsersGroupInformationGroup in file InformationSystems.class.php, method InformationSystem::ChangeAssociateSiteUserWithUsersGroupInformationGroup()
Добавление/удаление связи пользователя с группой пользователей, связанной с информационной группой
ChangeItemsOfOrderRest in file shop.class.php, method shop::ChangeItemsOfOrderRest()
Изменение остатка товаров в заказе
ChangeMessagesReadStatus in file messages.class.php, method messages::ChangeMessagesReadStatus()
Метод изменения статуса сообщения "прочитано"/"не прочитано"
ChangeMySqlDate in file Date.class.php, method DateClass::ChangeMySqlDate()
Получение значения даты в формате MySQL путем изменения переданной на заданное число секунд
ChangeNormalDate in file Date.class.php, method DateClass::ChangeNormalDate()
Получение значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд
charset_koi_win in file Security.fns.php, function charset_koi_win()
Преобразует текст из KOI8-R в WIN-1251
CheckBot in file Counter.class.php, method counter::CheckBot()
Проверка user-agent на принадлежность к ботам
CheckSiteUserAffiliate in file affiliate.class.php, method affiliate::CheckSiteUserAffiliate()
Проеверка участия пользователя сайта в аффилиат программе в качестве привлеченного пользователя
CheckTypeGzip in file Compression.class.php, method compression::CheckTypeGzip()
Получение типа сжатия gzip
CheckUsersAccessToForum | in file Forums.class.php, method Forums::CheckUsersAccessToForum()
ClearAdvertisementList in file Advertisement.class.php, method Advertisement::ClearAdvertisementList()
Очищение списка показов, произошедших $count_days назад
ClearAllCache in file Cache.class.php, method Cache::ClearAllCache()
Очистка всех кэшей (не очищая кэш статичных файлов)
ClearCache in file Cache.class.php, method Cache::ClearCache()
Очистка кэша
ClearCachePage in file seo.class.php, method Seo::ClearCachePage()
Очищает кэш запрошенных страниц в $this->CachePage
ClearCookieAndSessionCart in file shop.class.php, method shop::ClearCookieAndSessionCart()
Метод для очистки корзины кукисов и сессий
ClearExpireItems in file Cache.class.php, method Cache::ClearExpireItems()
Удаление истекших элементов кэша
ClearPath in file shop.class.php, method shop::ClearPath()
Метод очищает путь от запрещенных символов
ClearStaticCache in file Cache.class.php, method Cache::ClearStaticCache()
Очистка кэша в статичных файлах
ClearStructure in file Structure.class.php, method Structure::ClearStructure()
Метод очистки кэша($this->structure_mass)
CloseForum in file Forums.class.php, method Forums::CloseForum()
Метод, закрывающий/открывающий форум
CloseOldTicket in file helpdesk.class.php, method helpdesk::CloseOldTicket()
Закрытие старых (ответ на которые дан более 10 дней назад) тикетов
CloseTheme in file Forums.class.php, method Forums::CloseTheme()
Открытие/закрытие темы для доступа
cml in file cml.class.php, class cml
Система управления сайтом HostCMS v. 5.xx
cms_error_handler in file Error.fns.php, function cms_error_handler()
Ядро, обработчики ошибок в HostCMS
code_ip in file Kernel.class.php, method kernel::code_ip()
Метод для преобразования IP в HEX
code_ip in file Counter.class.php, method counter::code_ip()
Преобразование IP в HEX
ColorAllocateFactor in file Graphic.class.php, method graphic::ColorAllocateFactor()
Метод возвращающий оттенок цвета
colors in file Graphic.class.php, method graphic::colors()
Метод возвращает идентификатор основного цвета
CombineTickets in file helpdesk.class.php, method helpdesk::CombineTickets()
Объединение тикетов
compression in file Compression.class.php, class compression
Класс модуля "Система сжатия (компрессия)"
Compression.class.php | procedural page Compression.class.php
Compression.php | procedural page Compression.php
COMPRESSION_INSTALL in file Compression.php, constant COMPRESSION_INSTALL
Система управления сайтом HostCMS v. 5.xx
com_create_guid | in file Kernel.php, function com_create_guid()
ConfirmGetForm in file Forms.class.php, method Forms::ConfirmGetForm()
Определение права пользователя отправлять форму
confirm_information_item in file InformationSystems.class.php, method InformationSystem::confirm_information_item()
Определение возможности пользователя добавлять информационный элемент
Constants in file Constants.class.php, class Constants
Система управления сайтом HostCMS v. 5.xx
Constants.class.php | procedural page Constants.class.php
Constants.php | procedural page Constants.php
ConvertPrice in file shop.class.php, method shop::ConvertPrice()
Конвертирует цену в различных форматах к цене в формате xxxx.yy
ConvertSqlProperty in file lib.class.php, method lib::ConvertSqlProperty()
Конвертирование SQL-запроса, введенного для свойства типовой динамической страницы, с учетом замены заранее определенных значенией.
convert_str_for_csv in file EventsJournal.class.php, method EventsJournal::convert_str_for_csv()
Подготовка строки к записи в CSV-файл
CopyAdminFormEvent in file admin_forms_fields.class.php, method admin_forms_fields::CopyAdminFormEvent()
Копирование события формы центра администрирования
CopyAdminFormField in file admin_forms_fields.class.php, method admin_forms_fields::CopyAdminFormField()
Копирование поля формы центра администрирования
CopyAdvertisement in file Advertisement.class.php, method Advertisement::CopyAdvertisement()
Копирование баннера
CopyAffiliats in file shop.class.php, method shop::CopyAffiliats()
Копирование парнерских программ
CopyBannersAndBannersGroupsFromSiteToSite in file Advertisement.class.php, method Advertisement::CopyBannersAndBannersGroupsFromSiteToSite()
Копирование всех групп баннеров и баннеров, а также их связей с одного сайта на другой
CopyComment in file InformationSystems.class.php, method InformationSystem::CopyComment()
Копирование комментария к информационному элементу
CopyCondOfDelivery in file shop.class.php, method shop::CopyCondOfDelivery()
Копирование условий типа доставки
CopyContextualWords in file Advertisement.class.php, method Advertisement::CopyContextualWords()
Копирование информации о контекстной фразе
CopyCoupons in file shop.class.php, method shop::CopyCoupons()
Копирование купонов магазина на скидку
CopyCriticalLevel in file helpdesk.class.php, method helpdesk::CopyCriticalLevel()
Копирование информации об уровне критичности
CopyCurrentDocumentVersion in file Documents.class.php, method documents::CopyCurrentDocumentVersion()
Копирование текущей версии документа
CopyDataTemplate in file Templates.class.php, method templates::CopyDataTemplate()
Метод копирования шаблона страниц
CopyDataTemplatesDir in file Templates.class.php, method templates::CopyDataTemplatesDir()
Копирование групп шаблонов с шаблонами и подгруппами
CopyDir in file File.class.php, method File::CopyDir()
Копирование директории
CopyDiscounts in file shop.class.php, method shop::CopyDiscounts()
Копирование скидок на товары
CopyDocuments in file Documents.class.php, method documents::CopyDocuments()
Метод копирования документа
CopyDocumentsDir in file Documents.class.php, method documents::CopyDocumentsDir()
Копирование групп документов с документами
CopyDocumentStatus in file Documents.class.php, method documents::CopyDocumentStatus()
Копирование статуса документа
CopyEmail in file helpdesk.class.php, method helpdesk::CopyEmail()
Копирование информации об электронном адресе службы поддержки
CopyExternalPropertiesForItem in file shop.class.php, method shop::CopyExternalPropertiesForItem()
Копирование значений дополнительных свойств товара
CopyExtraProperty in file Site_users.class.php, method SiteUsers::CopyExtraProperty()
Метод копирования дополнительного параметра
CopyFascicle in file Maillist.class.php, method Maillist::CopyFascicle()
Метод копирования выпуска рассылки
CopyForms in file Forms.class.php, method Forms::CopyForms()
Копирование структуры формы и ее полей
CopyFormsField in file Forms.class.php, method Forms::CopyFormsField()
Копирование структуры поля формы
CopyForum in file Forums.class.php, method Forums::CopyForum()
Копирование информации о форуме
CopyForumsConference in file Forums.class.php, method Forums::CopyForumsConference()
Копирование конференции, групп форумов, а так же форумов, входящих в данную конференцию
CopyForumsGroup in file Forums.class.php, method Forums::CopyForumsGroup()
Копирование информации о группе форумов
CopyGroupAdvertisement in file Advertisement.class.php, method Advertisement::CopyGroupAdvertisement()
Копирование группы баннеров
CopyGroupsItemsProperty in file shop.class.php, method shop::CopyGroupsItemsProperty()
Копирование дополнительного свойства товаров
CopyGroupsProperty in file InformationSystems.class.php, method InformationSystem::CopyGroupsProperty()
Копирование дополнительного свойства информационных групп
CopyHelpdesk in file helpdesk.class.php, method helpdesk::CopyHelpdesk()
Копирование службы поддержки
CopyImgWithWatermark in file Image.class.php, method Image::CopyImgWithWatermark()
Метод накладывает watermark на изображение. Если файл вартермарка не существует, метод скопирует исходное изображение в файл получателя
CopyInformationItem in file InformationSystems.class.php, method InformationSystem::CopyInformationItem()
Копирование информационного элемента
CopyInformationSystem in file InformationSystems.class.php, method InformationSystem::CopyInformationSystem()
Копирование информационной системы
CopyInformationSystemDir | in file InformationSystems.class.php, method InformationSystem::CopyInformationSystemDir()
CopyItem in file shop.class.php, method shop::CopyItem()
Копирование товара
CopyItemsProperty in file InformationSystems.class.php, method InformationSystem::CopyItemsProperty()
Копирование дополнительного свойства информационных элементов
CopyItemsProperty in file shop.class.php, method shop::CopyItemsProperty()
Копирование дополнительного свойства товаров
CopyLib in file lib.class.php, method lib::CopyLib()
Создание копии типовой динамической страницы
CopyList in file Lists.class.php, method lists::CopyList()
Копирование списка
CopyListItem in file Lists.class.php, method lists::CopyListItem()
Копирование элемента списка
CopyMaillist in file Maillist.class.php, method Maillist::CopyMaillist()
Копирование почтовой рассылки
CopyMaillistUsers in file Maillist.class.php, method Maillist::CopyMaillistUsers()
Копирование связи пользователя с почтовой рассылкой
CopyMaillistUsersGroup in file Maillist.class.php, method Maillist::CopyMaillistUsersGroup()
Копирование связи почтовой рассылки с группой пользователей
CopyOrderDiscounts in file shop.class.php, method shop::CopyOrderDiscounts()
Копирование скидок от суммы заказа и их купонов
CopyPoll in file Polls.class.php, method polls::CopyPoll()
Копирование опроса
CopyPollGroup in file Polls.class.php, method polls::CopyPollGroup()
Копирование группы опросов
CopyPollReply in file Polls.class.php, method polls::CopyPollReply()
Копирование ответа на опрос
CopyPrices in file shop.class.php, method shop::CopyPrices()
Копирование цен для магазина
CopyProducers in file shop.class.php, method shop::CopyProducers()
Копирование производителей
CopyPropertiesForGroup in file shop.class.php, method shop::CopyPropertiesForGroup()
Копирование дополнительных свойств групп товаров, включая группы дополнительных свойств групп
CopyPropertiesForItem in file shop.class.php, method shop::CopyPropertiesForItem()
Копирование дополнительных свойств товаров, включая подгруппы дополнительных свойств
CopyPropertysGroupsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::CopyPropertysGroupsDirForInformationSystem()
Копирование дочерних групп дополнительных свойств информационных групп
CopyPropertysItemsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::CopyPropertysItemsDirForInformationSystem()
Копирование дочерних групп дополнительных свойств информационных элементов
CopySallers in file shop.class.php, method shop::CopySallers()
Копирование продавцов
CopyShop in file shop.class.php, method shop::CopyShop()
Копирование информации о магазине, а также дополнительных свойствах товаров, групп и групп этих свойств
CopyShopDir | in file shop.class.php, method shop::CopyShopDir()
CopySite in file Site.class.php, method site::CopySite()
Копирование сайта
CopyStatus in file helpdesk.class.php, method helpdesk::CopyStatus()
Копирование статуса сообщения
CopyStructure in file Structure.class.php, method Structure::CopyStructure()
Копирование узла структуры
CopyStructureProperty in file Structure.class.php, method Structure::CopyStructureProperty()
Копирование дополнительного свойства узлов структуры
CopySystemsOfPay in file shop.class.php, method shop::CopySystemsOfPay()
Копирование платежных систем
CopyTemplate in file Templates.class.php, method templates::CopyTemplate()
Метод копирования макета
CopyTemplateKeyWords in file helpdesk.class.php, method helpdesk::CopyTemplateKeyWords()
Копирование ключевого слова
CopyTemplatesDir in file Templates.class.php, method templates::CopyTemplatesDir()
Копирование групп макетов с макетами и подгруппами
CopyTicketCategory in file helpdesk.class.php, method helpdesk::CopyTicketCategory()
Копирование категории тикетов
CopyTicketFlag in file helpdesk.class.php, method helpdesk::CopyTicketFlag()
Копирование флага тикетов
CopyTypesOfDelivery in file shop.class.php, method shop::CopyTypesOfDelivery()
Копирование типа доставки
CopyUserType in file UserAccess.class.php, method user_access::CopyUserType()
Копирование информации о группе пользователей центра администрирования
CopyWarehouse in file warehouse.class.php, method warehouse::CopyWarehouse()
Копирование склада
CopyXsl in file Xsl.class.php, method xsl::CopyXsl()
Метод копирования XSL-шаблона
CorrectPropertiesGroup in file shop.class.php, method shop::CorrectPropertiesGroup()
Метод корректирует строку данных о дополнительном свойстве группы в соответствии с его типом.
CorrectPropertiesItem in file shop.class.php, method shop::CorrectPropertiesItem()
Метод корректирует строку данных о дополнительном свойстве в соответствии с его типом.
CorrectText in file Graphic.class.php, method graphic::CorrectText()
Корректировка текста.
counter in file Counter.class.php, class counter
Класс модуля "Статистика посещаемости сайта"
config.php | procedural page config.php
Counter.class.php | procedural page Counter.class.php
Counter.php | procedural page Counter.php
COUNTER_BOT_COUNT in file config.php, constant COUNTER_BOT_COUNT
Система управления сайтом HostCMS v. 5.xx
COUNTER_INSTALL in file Counter.php, constant COUNTER_INSTALL
Система управления сайтом HostCMS v. 5.xx
crc32 in file Kernel.class.php, method kernel::crc32()
Вычисление crc32 в диапазоне от -2147483647 до 2147483647.
CreateBackup in file Backup.class.php, method Backup::CreateBackup()
Создание резевной копии базы данных
CreateDirectory in file shop.class.php, method shop::CreateDirectory()
Метод проверяет, существует ли поддиректория $dir_name в upload/shop, если нет - создает
CreateForm in file admin_forms.class.php, method admin_forms::CreateForm()
Прорисовка формы центра администрирования.
CreateGroupsXmlTree in file InformationSystems.class.php, method InformationSystem::CreateGroupsXmlTree()
Формирование XML дерева для информационных групп
CreateMainMenu | in file admin_forms.class.php, method admin_forms::CreateMainMenu()
CreateOptions in file admin_forms_fields.class.php, method admin_forms_fields::CreateOptions()
Создание тегов <option> для каждого элемента ассоциативного массива
CreateRSS in file RssWrite.class.php, method RssWrite::CreateRSS()
Метод формирования XML-файла в стандарте RSS
CreateWatermark in file Image.class.php, method Image::CreateWatermark()
Служебный метод для наложения водяного знака
current_alias in file Site.class.php, method site::current_alias()
Метод установки алиаса (домена) сайта в статус "основной"
CURRENT_VERSION | in file Kernel.php, constant CURRENT_VERSION
current_version in file Documents.class.php, method documents::current_version()
Метод для переобозначения текущей версии документа
CutQuotetion in file helpdesk.class.php, method helpdesk::CutQuotetion()
Удаление из текста сообщения цитаты
CutWordLen in file Url.class.php, method url::CutWordLen()
Уменьшает длину слов в строке, имеющий длину больше $max_word_len
config.php | procedural page config.php
Captcha.class.php | procedural page Captcha.class.php
config.php | procedural page config.php
cml.class.php | procedural page cml.class.php
top
d
$data_under_menu in file admin_forms.class.php, variable admin_forms::$data_under_menu
Код для вывода под меню
$db_connect | in file Mysql.class.php, variable DataBase::$db_connect
$debug in file admin_forms.class.php, variable admin_forms::$debug
Сообщения отладки
$default_cache_systems in file Cache.class.php, variable Cache::$default_cache_systems
Способ кэширования по умолчанию
$distortion_amplitude in file Captcha.class.php, variable Captcha::$distortion_amplitude
амплитуда искажения
$dividend in file Cache.class.php, variable Cache::$dividend
Максимальное значение, генерируемое для определения необходимости удаления истекших элементов кэша
$documents_id_array in file Documents.class.php, variable documents::$documents_id_array
Массив соответствия старых и новых идентификаторов скопированных документов
DataBase in file Mysql.class.php, class DataBase
Ядро, класс для работы с СУБД
DateClass in file Date.class.php, class DateClass
Система управления сайтом HostCMS v. 5.xx
DateSqlToUnix in file Date.class.php, method DateClass::DateSqlToUnix()
Метод преобразовывает дату в формате SQL в число секунд с начала эпохи
datetime_format in file Date.class.php, method DateClass::datetime_format()
Метод преобразует формат вывода даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT
datetime_format_sql in file Date.class.php, method DateClass::datetime_format_sql()
Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL
DateUnixToSQL in file Date.class.php, method DateClass::DateUnixToSQL()
Метод преобразовывает дату из числа секунд в формат SQL
date_format in file Date.class.php, method DateClass::date_format()
Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT
date_format_sql in file Date.class.php, method DateClass::date_format_sql()
Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат
db_close in file Mysql.class.php, method DataBase::db_close()
Закрывает соединение $this->db_connect
db_connect in file Mysql.class.php, method DataBase::db_connect()
Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.
declension in file Kernel.class.php, method kernel::declension()
Получение существительного в форме, соответствующей числу
decode_ip in file Counter.class.php, method counter::decode_ip()
Декодирование IP из HEX
decode_ip in file Kernel.class.php, method kernel::decode_ip()
Метод для декодирования IP из HEX
DelBannerGroup in file Advertisement.class.php, method Advertisement::DelBannerGroup()
Исключение баннера из группы
DelBannersGroup in file Advertisement.class.php, method Advertisement::DelBannersGroup()
Удаление группы баннеров
DelConstants in file Constants.class.php, method Constants::DelConstants()
Удаление константы
DelDataTemplatesGroup in file Templates.class.php, method templates::DelDataTemplatesGroup()
Метод удаления группы шаблонов данных
Delete in file Mysql.class.php, method DataBase::Delete()
Удаление записей из таблиц.
DeleteAdminForm in file admin_forms.class.php, method admin_forms::DeleteAdminForm()
Удаление формы центра администрирования
DeleteAdminFormsEvent in file admin_forms.class.php, method admin_forms::DeleteAdminFormsEvent()
Удаление события (дейтсвия) формы администрирования
DeleteAdminFormsField in file admin_forms.class.php, method admin_forms::DeleteAdminFormsField()
Удаление поля формы администрирования
DeleteAdminLanguage in file admin_forms.class.php, method admin_forms::DeleteAdminLanguage()
Удаление языка центра администрирования
DeleteAdvertisementFile in file Advertisement.class.php, method Advertisement::DeleteAdvertisementFile()
Удаление загруженного файл для элемента
DeleteAdvertisementSwfFile in file Advertisement.class.php, method Advertisement::DeleteAdvertisementSwfFile()
Удаление загруженного swf-файл для элемента
DeleteAffiliate in file affiliate.class.php, method affiliate::DeleteAffiliate()
Удаление информации об аффилиате
DeleteAffiliatePlans in file affiliate.class.php, method affiliate::DeleteAffiliatePlans()
Удаление информации о плане аффилиата
DeleteAffiliateValues in file affiliate.class.php, method affiliate::DeleteAffiliateValues()
Удаление информации о комиссии
DeleteAllEItems in file shop.class.php, method shop::DeleteAllEItems()
Метод удаляет все электронные товары заданного товара
DeleteAllItemsCatalogAndGroups in file shop.class.php, method shop::DeleteAllItemsCatalogAndGroups()
Метод очистки таблиц товаров и групп
DeleteAllModificationForItem in file shop.class.php, method shop::DeleteAllModificationForItem()
Метод удаления всех модификаций товара
DeleteAttachments in file helpdesk.class.php, method helpdesk::DeleteAttachments()
Удаление информации о вложенных файлах в сообщениях
DeleteBanner in file Advertisement.class.php, method Advertisement::DeleteBanner()
Удаление баннера
DeleteCacheItem in file Cache.class.php, method Cache::DeleteCacheItem()
Метод удаляет элемент с именем $item_name из кэша $cache_name
DeleteCart in file shop.class.php, method shop::DeleteCart()
Удаление товара из корзины
DeleteCharacteristic in file seo.class.php, method Seo::DeleteCharacteristic()
Удаление характеристик страницы
DeleteCity in file shop.class.php, method shop::DeleteCity()
Метод, осуществляющий удаление города
DeleteCityArea in file shop.class.php, method shop::DeleteCityArea()
Метод удаления района города
DeleteComment in file shop.class.php, method shop::DeleteComment()
Метод удаления информации об отзыве на товар
DeleteCompany in file shop.class.php, method shop::DeleteCompany()
Метод удаления информации об организации
DeleteCondOfDelivery in file shop.class.php, method shop::DeleteCondOfDelivery()
Метод, осуществляющий удаление условия доставки
DeleteConference in file Forums.class.php, method Forums::DeleteConference()
Метод удаления конференции вместе с принадлежащими ей группами форумов и т.п.
DeleteContextualWords in file Advertisement.class.php, method Advertisement::DeleteContextualWords()
Удаление информации о контекстной фразе
DeleteCountry in file shop.class.php, method shop::DeleteCountry()
Метод, осуществляющий удаление страны
DeleteCoupon in file shop.class.php, method shop::DeleteCoupon()
Метод для удаления информации о купоне
DeleteCriticalLevel in file helpdesk.class.php, method helpdesk::DeleteCriticalLevel()
Удаление информации об уровне критичности
DeleteCurrency in file shop.class.php, method shop::DeleteCurrency()
Метод, осуществляющий удаление валюты
DeleteDir in file File.class.php, method File::DeleteDir()
Метод удаления директории вместе с вложенными файлами и директориями.
DeleteDiscount in file shop.class.php, method shop::DeleteDiscount()
Метод, осуществляющий удаление скидки
DeleteEItem in file shop.class.php, method shop::DeleteEItem()
Метод удаления информации об электронном товаре
DeleteEmail in file helpdesk.class.php, method helpdesk::DeleteEmail()
Удаление информациии об электронном адресе
DeleteExternalPropertyValue in file Site_users.class.php, method SiteUsers::DeleteExternalPropertyValue()
Метод удаления значения доплнительного параметра пользователя сайта
DeleteExtraProperty in file Site_users.class.php, method SiteUsers::DeleteExtraProperty()
Удаление дополнительного параматра
DeleteFascicleFiles in file Maillist.class.php, method Maillist::DeleteFascicleFiles()
Метод, осуществляющий удаление файла выпуска рассылки
DeleteFile in file File.class.php, method File::DeleteFile()
Удаление файла с проверкой на его существованием
DeleteForum in file Forums.class.php, method Forums::DeleteForum()
Метод удаления форума
DeleteGroup in file shop.class.php, method shop::DeleteGroup()
Метод, осуществляющий удаление группы товаров (с подгруппами и товарами)
DeleteHelpdesk in file helpdesk.class.php, method helpdesk::DeleteHelpdesk()
Удаление информации о службе технической поддержки
DeleteInformationSystemsDir in file InformationSystems.class.php, method InformationSystem::DeleteInformationSystemsDir()
Удаление раздела информационных систем. Информационные системы, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.
DeleteItem in file shop.class.php, method shop::DeleteItem()
Метод, осуществляющий удаление товара
DeleteItemDiscount in file shop.class.php, method shop::DeleteItemDiscount()
Метод удаления скики для товара
DeleteLib in file lib.class.php, method lib::DeleteLib()
Удаление типовой динамической страницы из библиотеки страниц
DeleteLibDir in file lib.class.php, method lib::DeleteLibDir()
Рекурсивное удаление раздела типовых динамической страниц со всеми его подразделами
DeleteLibProperty in file lib.class.php, method lib::DeleteLibProperty()
Удаление параметра типовой динамической страницы
DeleteLibPropertyListItem in file lib.class.php, method lib::DeleteLibPropertyListItem()
Удаление элемента списка параметра типовой динамической страницы типа "Список"
DeleteListDir in file Lists.class.php, method lists::DeleteListDir()
Удаление раздела списков
DeleteLocation in file shop.class.php, method shop::DeleteLocation()
Метод, осуществляющий удаление области
DeleteMessage in file helpdesk.class.php, method helpdesk::DeleteMessage()
Удаление сообщения
DeleteMessages in file Mail.class.php, method Mail::DeleteMessages()
Удаление всех писем из почтового ящика
DeleteMesure in file shop.class.php, method shop::DeleteMesure()
Метод, осуществляющий удаление единицы измерения
DeleteOrder in file shop.class.php, method shop::DeleteOrder()
Метод, осуществляющий удаление заказа
DeleteOrderDiscount in file shop.class.php, method shop::DeleteOrderDiscount()
Метод для удаления информации о скидке для заказов
DeleteOrderItems in file shop.class.php, method shop::DeleteOrderItems()
Метод, осуществляющий удаление товара в заказе
DeleteOrderStatus in file shop.class.php, method shop::DeleteOrderStatus()
Метод, осуществляющий удаление статуса заказа
DeletePositionSearch in file seo.class.php, method Seo::DeletePositionSearch()
Удаление позиции в поисковой системе из БД
DeletePrice in file shop.class.php, method shop::DeletePrice()
Метод, осуществляющий удаление типа цены
DeletePriceForItem in file shop.class.php, method shop::DeletePriceForItem()
Метод удаляет цену для элемента каталога
DeletePricesForAllItem in file shop.class.php, method shop::DeletePricesForAllItem()
Метод удаляет все дополнительные цены для товара
DeleteProducer in file shop.class.php, method shop::DeleteProducer()
Метод, осуществляющий удаление производителя
DeletePropertiesGroupsDir in file shop.class.php, method shop::DeletePropertiesGroupsDir()
Удаление информации о группе дополнительных свойств групп товаров
DeletePropertiesGroupValue in file shop.class.php, method shop::DeletePropertiesGroupValue()
Удаление значения дополнительного свойства группы
DeletePropertiesItem in file shop.class.php, method shop::DeletePropertiesItem()
Удаление значение дополнительного свойства товара
DeletePropertiesItemsDir in file shop.class.php, method shop::DeletePropertiesItemsDir()
Удаление информации о группе дополнительных свойств товара
DeletePropertyForGroup in file shop.class.php, method shop::DeletePropertyForGroup()
Метод удаляет принадлежность дополнительного свойтсва группе товаров
DeletePropertyGroupsDir in file InformationSystems.class.php, method InformationSystem::DeletePropertyGroupsDir()
Удаление информации о группе дополнительных свойств групп информационной системы
DeletePropertysItemsDir in file InformationSystems.class.php, method InformationSystem::DeletePropertysItemsDir()
Удаление информации о группе дополнительных свойств информационных элементов
DeletePropertyValue in file Structure.class.php, method Structure::DeletePropertyValue()
Метод для удаления значения свойства узла структуры
DeletePropretyOfGroup in file shop.class.php, method shop::DeletePropretyOfGroup()
Удаление дополнительного свойства группы товаров
DeletePropretyOfItems in file shop.class.php, method shop::DeletePropretyOfItems()
Метод, осуществляющий удаление свойства товара
DeleteQuery in file seo.class.php, method Seo::DeleteQuery()
Удаление запроса
DeleteResponsible in file helpdesk.class.php, method helpdesk::DeleteResponsible()
Удаление ответственного пользователя
DeleteSearchInfomationForSite in file Search.class.php, method Search::DeleteSearchInfomationForSite()
Удаление поисковой информации сайта
DeleteSeller in file shop.class.php, method shop::DeleteSeller()
Метод, осуществляющий удаление продавца.
DeleteShop in file shop.class.php, method shop::DeleteShop()
Метод, осуществляющий удаление магазина
DeleteShopsDir in file shop.class.php, method shop::DeleteShopsDir()
Удаление раздела интернет-магазинов. Магазины, находящиеся в разделе не удаляютя, а переносятся в корневой раздел.
DeleteShopWatermark | in file shop.class.php, method shop::DeleteShopWatermark()
DeleteSiteUser in file Site_users.class.php, method SiteUsers::DeleteSiteUser()
Метод удаления пользователя из системы
DeleteSiteUserAccountTransaction in file shop.class.php, method shop::DeleteSiteUserAccountTransaction()
Удаление транзакции
DeleteSiteUsersMail in file messages.class.php, method messages::DeleteSiteUsersMail()
Удаление сообщения
DeleteSpecialPrice in file shop.class.php, method shop::DeleteSpecialPrice()
Удаление информации о специальной цене
DeleteStatus in file helpdesk.class.php, method helpdesk::DeleteStatus()
Удаление статуса сообщений
DeleteStructure in file Structure.class.php, method Structure::DeleteStructure()
Метод для удлаения узла структуры с его дочерними узлами
DeleteSupportWoktime in file helpdesk.class.php, method helpdesk::DeleteSupportWoktime()
Удаление рабочего дня службы технической поддержки
DeleteSystemOfPay in file shop.class.php, method shop::DeleteSystemOfPay()
Метод, осуществляющий удаление платёжной системы
DeleteTag in file tag.class.php, method Tag::DeleteTag()
Удаление тега
DeleteTagRelation in file tag.class.php, method Tag::DeleteTagRelation()
Список соответствий тега
DeleteTagsGroup in file tag.class.php, method Tag::DeleteTagsGroup()
Удаление группы тегов
DeleteTax in file shop.class.php, method shop::DeleteTax()
Метод, осуществляющий удаление налога
DeleteTemplate in file helpdesk.class.php, method helpdesk::DeleteTemplate()
Удаление стандартного ответа
DeleteTemplateDir in file helpdesk.class.php, method helpdesk::DeleteTemplateDir()
Удаление группы стандартных ответов
DeleteTemplateKeyWords in file helpdesk.class.php, method helpdesk::DeleteTemplateKeyWords()
Удаление ключевого слова
DeleteThemeUserSubscribe in file Forums.class.php, method Forums::DeleteThemeUserSubscribe()
Удаление подписки пользователя сайта на тему форума
DeleteTicket in file helpdesk.class.php, method helpdesk::DeleteTicket()
Удаление информациии об инциденте
DeleteTicketCategory in file helpdesk.class.php, method helpdesk::DeleteTicketCategory()
Удаление информации о категории инцидентов
DeleteTicketFlags in file helpdesk.class.php, method helpdesk::DeleteTicketFlags()
Удаление информации о флаге для тикетов
DeleteTyingProducts in file shop.class.php, method shop::DeleteTyingProducts()
Метод удаления сопутствующих товаров
DeleteTypeOfDelivery in file shop.class.php, method shop::DeleteTypeOfDelivery()
Метод, осуществляющий удаление типа доставки
DeleteUserDeniedAccessBefore in file UserAccess.class.php, method user_access::DeleteUserDeniedAccessBefore()
Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд
DeleteUserDeniedAccessIP in file UserAccess.class.php, method user_access::DeleteUserDeniedAccessIP()
Метод удаления неудачных попыток входа в BackOffice для заданного IP-адреса
DeleteUsers in file Maillist.class.php, method Maillist::DeleteUsers()
Метод снятия подписки с подписчика по его идентификатору пользователя сайта (УСТАРЕВШИЙ МЕТОД!)
DeleteUsersFascicle in file Maillist.class.php, method Maillist::DeleteUsersFascicle()
Метод снятия подписки с подписчика по его идентификатору подписчика
DeleteUsersGroupFromMaillist in file Maillist.class.php, method Maillist::DeleteUsersGroupFromMaillist()
Метод закрывающий доступ к рассылке определенной группе пользователей
DeleteWarehouse in file warehouse.class.php, method warehouse::DeleteWarehouse()
Удаление информации о складе
DeleteWarehouseItem in file warehouse.class.php, method warehouse::DeleteWarehouseItem()
Удаление информации о связи товара и склада
DeleteWeekend in file helpdesk.class.php, method helpdesk::DeleteWeekend()
Удаление информации о специальном рабочем/выходном дне
DeleteWord in file admin_forms.class.php, method admin_forms::DeleteWord()
Удаление слова и всех его значений
delete_old_version in file Documents.class.php, method documents::delete_old_version()
Метод удаления записей обо всех не текущих версиях
delete_page in file Structure.class.php, method Structure::delete_page()
Устаревший метод удаления страницы. Рекомендуется использовать $this->DeleteStructure($structure_id);
Delete_search_words in file Search.class.php, method Search::Delete_search_words()
Метод удаления из индекса страницы с указанным адресом
delete_status in file Documents.class.php, method documents::delete_status()
Метод удаления статуса документов
delete_version in file Documents.class.php, method documents::delete_version()
Метод удаления записей о версиях
DelFascicle in file Maillist.class.php, method Maillist::DelFascicle()
Удаление выпуска рассылки
DelFillForms in file Forms.class.php, method Forms::DelFillForms()
Удаление бланка заполненной формы
DelFillValues in file Forms.class.php, method Forms::DelFillValues()
Удаление значения одного из полей отправленной формы
DelForms in file Forms.class.php, method Forms::DelForms()
Удаление данных о форме
DelFormsFields in file Forms.class.php, method Forms::DelFormsFields()
Удаление поля формы
DelForumsGroup in file Forums.class.php, method Forums::DelForumsGroup()
Метод удаления группы форумов
DelGroupUser in file Site_users.class.php, method SiteUsers::DelGroupUser()
Удаление пользователя из группы
DelInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertys()
Удаление дополнительного свойства информационной группы
DelInformationGroupPropertysValue in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertysValue()
Удаление значений дополнительных свойств информационной группы по идентификатору дополнительного свойства и информационной группы
DelInformationGroupPropertyValue in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertyValue()
Удаление значения дополнительного свойства информационной группы по идентификатору значения дополнительного свойства
DelInformationItemPropertyValue in file InformationSystems.class.php, method InformationSystem::DelInformationItemPropertyValue()
Удаление значения дополнительного свойства информационного элемента
DelInformationSystem in file InformationSystems.class.php, method InformationSystem::DelInformationSystem()
Удаление информационной системы
DelIp in file ip.class.php, method ip::DelIp()
Удаление информации об IP-адресе
DelMaillist in file Maillist.class.php, method Maillist::DelMaillist()
Удаление рассылки
DelMessage in file Forums.class.php, method Forums::DelMessage()
Метод удаления сообщения темы
DelPollsGroup in file Polls.class.php, method polls::DelPollsGroup()
Метод удаления групп опросов
DelStatInfomationForSite in file Counter.class.php, method counter::DelStatInfomationForSite()
Удаление статистической информации для сайта
DelStructurePropertys in file Structure.class.php, method Structure::DelStructurePropertys()
Метод удаления дополнительного свойства
DelStructurePropertysValue in file Structure.class.php, method Structure::DelStructurePropertysValue()
Метод удаления значений дополнительных свойств из таблицы связи
DelTemplatesGroup in file Templates.class.php, method templates::DelTemplatesGroup()
Метод удаления группы макетов
DelTheme in file Forums.class.php, method Forums::DelTheme()
Удаление темы форума
DelUserGroup in file Site_users.class.php, method SiteUsers::DelUserGroup()
Удаление группы пользователей заданной идентификатором
del_alias in file Site.class.php, method site::del_alias()
Метод преобразования алиаса (домена) сайта в основной
del_comment in file InformationSystems.class.php, method InformationSystem::del_comment()
Удаление комментария к информационному элементу
del_data_templates in file Templates.class.php, method templates::del_data_templates()
Метод удаления шаблона страниц
del_dir in file FileManager.class.php, method FileManager::del_dir()
Удаление директории вместе с вложенными файлами и директориями.
del_documents in file Documents.class.php, method documents::del_documents()
Удаления документов
del_documents_dir in file Documents.class.php, method documents::del_documents_dir()
Удаление разделов документов
del_file in file FileManager.class.php, method FileManager::del_file()
Удаление файла или директории
del_information_groups in file InformationSystems.class.php, method InformationSystem::del_information_groups()
Удаление информационной группы
del_information_items in file InformationSystems.class.php, method InformationSystem::del_information_items()
Удаление элемента информационной системы
del_information_propertys in file InformationSystems.class.php, method InformationSystem::del_information_propertys()
Удаление дополнительного свойства элементов информационной системы
del_lists in file Lists.class.php, method lists::del_lists()
Удаление списка
del_lists_items in file Lists.class.php, method lists::del_lists_items()
Удаление элемента списка
del_module in file Modules.class.php, method modules::del_module()
Метод удаления информации о модуле
del_poll in file Polls.class.php, method polls::del_poll()
Метод удаления опроса
del_poll_reply in file Polls.class.php, method polls::del_poll_reply()
Метод удаления варианта ответа
del_site in file Site.class.php, method site::del_site()
Удаление информации о сайте
del_templates in file Templates.class.php, method templates::del_templates()
Метод удаления макета
del_user in file UserAccess.class.php, method user_access::del_user()
Метод удаления пользователя
del_user_type in file UserAccess.class.php, method user_access::del_user_type()
Метод удаления типа пользователей
del_xsl in file Xsl.class.php, method xsl::del_xsl()
Метод удаления XSL-шаблона
del_xsl_dir in file Xsl.class.php, method xsl::del_xsl_dir()
Метод удаления XSL-раздела
Diagramm in file Graphic.class.php, method graphic::Diagramm()
Метод для рисования диаграммы
DIAGRAMM_LIMIT | in file Counter.php, constant DIAGRAMM_LIMIT
DIAGRAMM_WIDTH | in file Counter.php, constant DIAGRAMM_WIDTH
DisableAffiliatePlanToShop in file affiliate.class.php, method affiliate::DisableAffiliatePlanToShop()
Удаление ассоциации партнерской программы магазину
DisableModule in file Cache.class.php, method Cache::DisableModule()
Служебный метод, вызываемый при отключении модуля.
documents in file Documents.class.php, class documents
Система управления сайтом HostCMS v. 5.xx
Documents.class.php | procedural page Documents.class.php
Documents.php | procedural page Documents.php
DoReplaces in file admin_forms.class.php, method admin_forms::DoReplaces()
Подстановка стандартных значений полей
Download in file File.class.php, method File::Download()
Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла
do_html_footer_admin in file admin_output.fns.php, function do_html_footer_admin()
Функция выводит "подвал" для страниц раздела администрирования
do_html_header_admin in file admin_output.fns.php, function do_html_header_admin()
Функция выводит "шапку" для страниц раздела администрирования
DrawAlphaPixel in file Graphic.class.php, method graphic::DrawAlphaPixel()
Метод для рисования точек с оттенком
DrawFilledRectangle in file Graphic.class.php, method graphic::DrawFilledRectangle()
Метод для рисования заполненного прямоугольника
DrawFilledRoundedRectangle in file Graphic.class.php, method graphic::DrawFilledRoundedRectangle()
Метод для рисования заполненного округленного прямоугольника
DrawLegend in file Graphic.class.php, method graphic::DrawLegend()
Метод для рисования легенды
DrawLegend_linear in file Graphic.class.php, method graphic::DrawLegend_linear()
Метод рисует легенду для линейной диаграммы
DrawLine in file Graphic.class.php, method graphic::DrawLine()
Метод для рисования линий поточечно
DrawPixel in file Graphic.class.php, method graphic::DrawPixel()
Метод для рисования точек
DrawRectangle in file Graphic.class.php, method graphic::DrawRectangle()
Метод для рисования незаполненого прямоугольника
DrawRoundedRectangle in file Graphic.class.php, method graphic::DrawRoundedRectangle()
Метод для рисования незаполненного округленного прямоугольника.
DrawStatusReport in file seo.class.php, method Seo::DrawStatusReport()
Графическое отображение статуса наличия счетчиков и страницы в каталогах в отчете
Date.class.php | procedural page Date.class.php
top
e
$email_login in file Mail.class.php, variable Mail::$email_login
Имя ящика (Логин)
$email_password in file Mail.class.php, variable Mail::$email_password
Пароль ящика пользователя
$encoding in file RssRead.class.php, variable RssRead::$encoding
Внутренняя кодировка, используемая при работе с RSS
$error | in file Modules.class.php, variable modules::$error
$error | in file shop.class.php, variable shop::$error
$error | in file Templates.class.php, variable templates::$error
$export_csv in file admin_forms.class.php, variable admin_forms::$export_csv
Флаг экспорта в CSV
$external_html in file admin_forms_fields.class.php, variable admin_forms_fields::$external_html
Свойство, содержащее html-код, дописываемый после отображения формы
$external_replaces in file admin_forms.class.php, variable admin_forms::$external_replaces
Массив внешнех подстановок, применяется в DoReplaces()
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
eacceleratorClearCache in file Cache.class.php, method Cache::eacceleratorClearCache()
Очистка кэша $cache_name и элемента $item_name в eAccelerator
eacceleratorGetCountItem in file Cache.class.php, method Cache::eacceleratorGetCountItem()
Определение количества элементов в кэше для eaccelerator
EdZero in file seo.class.php, method Seo::EdZero()
Заменяет "млн" и "тыс" на соответствующее количество нулей
email_encode_js in file Security.fns.php, function email_encode_js()
Публикует с помощью JavaScript ссылку на эл.почту, защищенную от индексации ботами
EnableAffiliatePlanToShop in file affiliate.class.php, method affiliate::EnableAffiliatePlanToShop()
Добавление ассоциации партнерской программы магазину
EraseOpticalAlignment in file typograph.class.php, method typograph::EraseOpticalAlignment()
Метод для удаления тегов предыдущего оптического выравнивания
EventsJournal in file EventsJournal.class.php, class EventsJournal
Система управления сайтом HostCMS v. 5.xx
EventsJournal.class.php | procedural page EventsJournal.class.php
EventsJournal.php | procedural page EventsJournal.php
en.php | procedural page en.php
EventsJournalAdmin in file EventsJournal.class.php, class EventsJournalAdmin
Класс модуля "Журнал событий"
EventsMail in file EventsJournal.class.php, method EventsJournalAdmin::EventsMail()
Метод отправки письма с отчетом
ExecDump in file ExecSqlQuery.class.php, method ExecSqlQuery::ExecDump()
Выполнение SQL-запроса
ExecSqlQuery in file ExecSqlQuery.class.php, class ExecSqlQuery
Система управления сайтом HostCMS v. 5.xx
ExecSqlQuery.class.php | procedural page ExecSqlQuery.class.php
ExecSqlQuery.php | procedural page ExecSqlQuery.php
en.php | procedural page en.php
ExecSystemsOfPayChangeStatus in file shop.class.php, method shop::ExecSystemsOfPayChangeStatus()
Метод выполнения обработчика платежной системы для смены статуса заказа
ExecSystemsOfPayHandler in file shop.class.php, method shop::ExecSystemsOfPayHandler()
Метод выполнения обработчика платежной системы
ExecuteUsersEvents in file admin_forms.class.php, method admin_forms::ExecuteUsersEvents()
Вызов пользовательских ф-ций (событий)
exif_imagetype | in file Kernel.php, function exif_imagetype()
ExternalXml in file ExternalXml.class.php, class ExternalXml
Система управления сайтом HostCMS v. 5.xx
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
Error.fns.php | procedural page Error.fns.php
EventsJournal.class.php | procedural page EventsJournal.class.php
ExternalXml.class.php | procedural page ExternalXml.class.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
en.php | procedural page en.php
top
f
$fields | in file admin_forms_fields.class.php, variable admin_forms_fields::$fields
$flag | in file ExternalXml.class.php, variable ExternalXml::$flag
$float_format in file shop.class.php, variable shop::$float_format
Формат для this->Round()
$fonts_dir in file Captcha.class.php, variable Captcha::$fonts_dir
Путь к шрифтам
$font_name in file Graphic.class.php, variable graphic::$font_name
Название шрифта
$font_path in file Graphic.class.php, variable graphic::$font_path
Путь к шрифту
$font_size in file Graphic.class.php, variable graphic::$font_size
Размер шрифта
$font_width in file Graphic.class.php, variable graphic::$font_width
Ширина одного символа в легенде
$form_params in file admin_forms.class.php, variable admin_forms::$form_params
Свойство с параметрами формы
$form_params in file admin_forms_fields.class.php, variable admin_forms_fields::$form_params
Свойство с параметрами формы
File in file File.class.php, class File
Система управления сайтом HostCMS v. 5.xx
FileClearCache in file Cache.class.php, method Cache::FileClearCache()
Очистка кэша в файле
FileDeleteCacheItem in file Cache.class.php, method Cache::FileDeleteCacheItem()
Метод удаляет элемент с именем $item_name из кэша $cache_name в файле
FileGetCountItem in file Cache.class.php, method Cache::FileGetCountItem()
Определение количества элементов в кэше для файлов
FileManager in file FileManager.class.php, class FileManager
Класс модуля "Файловый менеджер"
FileManager.class.php | procedural page FileManager.class.php
FileManager.php | procedural page FileManager.php
FillItemCountForWarehouse | in file warehouse.class.php, method warehouse::FillItemCountForWarehouse()
FillMasGroup in file InformationSystems.class.php, method InformationSystem::FillMasGroup()
Формирование массива групп для информационной системы (MasGroup) и массива дерева идентификаторов групп (FullCacheGoupsIdTree).
FillMasGroup in file shop.class.php, method shop::FillMasGroup()
Метод формирования массива групп верхнего уровня для данного магазина
FillMasGroupDirExtProperty in file shop.class.php, method shop::FillMasGroupDirExtProperty()
Заполнение массива групп дополнительных свойств групп товаров
FillMasGroupExtProperty in file shop.class.php, method shop::FillMasGroupExtProperty()
Метод формирования массива групп дополнительных свойств товара самого верхнего уровня для данного магазина
FillMasGroupExtProperty in file InformationSystems.class.php, method InformationSystem::FillMasGroupExtProperty()
Формирование массива групп дополнительных свойств информационных элементов самого верхнего уровня для данной информационной системы
FillMasGroupProperty in file InformationSystems.class.php, method InformationSystem::FillMasGroupProperty()
Заполнение массива групп дополнительных свойств групп информационных элементов
FillMemCacheComments in file shop.class.php, method shop::FillMemCacheComments()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCacheCountItemsAndGroup in file InformationSystems.class.php, method InformationSystem::FillMemCacheCountItemsAndGroup()
Определение числа подгрупп и элементов, содержащихся в группах информационной системы
FillMemCacheCountItemsAndGroup in file shop.class.php, method shop::FillMemCacheCountItemsAndGroup()
Внутренний метод производит расчет числа подгрупп и элементов, содержащихся в группах магазина.
FillMemCacheDiscountsForItem in file shop.class.php, method shop::FillMemCacheDiscountsForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров скидками.
FillMemCacheGetAllPricesForItem in file shop.class.php, method shop::FillMemCacheGetAllPricesForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров ценами для групп товаров. Заполнению подвергается массив $this->CacheGetSpecialPricesForItem[$shop_items_catalog_item_id]
FillMemCacheGetTagRelation in file tag.class.php, method Tag::FillMemCacheGetTagRelation()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров соответствиями тегов.
FillMemCacheGoupsIdTree in file shop.class.php, method shop::FillMemCacheGoupsIdTree()
Внутренний метод формирует дерево групп и подгрупп в массиве по их идентификаторам. Заполянется также в методе FillMasGroup()
FillMemCacheItems in file shop.class.php, method shop::FillMemCacheItems()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров товаров. Заполнению подвергается массив $this->CacheGetItem[$shop_items_catalog_item_id]
FillMemCacheModificationItems in file shop.class.php, method shop::FillMemCacheModificationItems()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemCachePriceForItem in file shop.class.php, method shop::FillMemCachePriceForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров ценами для товаров. Заполнению подвергается массив $this->CacheGetPriceForItem[$shop_list_of_prices_id . '_' . $shop_items_catalog_item_id]
FillMemCachePropertiesItem in file shop.class.php, method shop::FillMemCachePropertiesItem()
Внутренний метод заполняет mem-кэш для переданного списка идентификаторов товаров дополнительными свойствами товаров.
FillMemCachePropertysGroup in file shop.class.php, method shop::FillMemCachePropertysGroup()
Метод формирует в памяти данные о свойствах групп магазина.
FillMemCachePropertysGroup in file InformationSystems.class.php, method InformationSystem::FillMemCachePropertysGroup()
Формирование в памяти данных о свойствах групп информационной системы.
FillMemCacheSpecialPricesForItem in file shop.class.php, method shop::FillMemCacheSpecialPricesForItem()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров специальными ценами. Заполнению подвергается массив $this->CacheGetSpecialPricesForItem [$shop_items_catalog_item_id]
FillMemCacheTyingProducts in file shop.class.php, method shop::FillMemCacheTyingProducts()
Метод заполняет mem-кэш для переданного списка идентификаторов товаров сопутствующими товарами.
FillMemFullCacheGoupsIdTree in file InformationSystems.class.php, method InformationSystem::FillMemFullCacheGoupsIdTree()
Формирование дерева групп и подгрупп в массиве по их идентификаторам
fill_xsl_dir in file Xsl.class.php, method xsl::fill_xsl_dir()
Метод формирования дерева разделов
flush | in file File.class.php, method File::flush()
FormatGetCart in file shop.class.php, method shop::FormatGetCart()
Преобразование массива корзины при извлечении
FormatSetCart in file shop.class.php, method shop::FormatSetCart()
Преобразование массива корзины при записи
FormatXml in file Xsl.class.php, method xsl::FormatXml()
Форматирование XML-документа
Forms in file Forms.class.php, class Forms
Класс модуля "Формы"
Forms.class.php | procedural page Forms.class.php
Forms.php | procedural page Forms.php
Forums in file Forums.class.php, class Forums
Класс модуля "Форумы"
Forums | in file Forums.class.php, method Forums::Forums()
Forums.class.php | procedural page Forums.class.php
Forums.php | procedural page Forums.php
function_enabled in file Kernel.class.php, method kernel::function_enabled()
Определение доступности php-функции
File.class.php | procedural page File.class.php
top
g
$GetAllItemTotalCount in file shop.class.php, variable shop::$GetAllItemTotalCount
Свойство содержит информацию об общем количестве товаров, выбранных методом GetAllItems()
$GetAllProducersTotalCount in file shop.class.php, variable shop::$GetAllProducersTotalCount
Свойство содержит информацию об общем количестве производителей, выбранных методом GetAllProducers()
$GET_LOCK_timeout in file Kernel.php, variable Session::$GET_LOCK_timeout
Таймаут для GET_LOCK, в секундах
GenAddEditThemeXML in file Forums.class.php, method Forums::GenAddEditThemeXML()
УСТАРЕВШИЙ метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
GenCmlId in file shop.class.php, method shop::GenCmlId()
Генерация идентификатора в формате CommerceML для группы товаров
GenEditMessageXML in file Forums.class.php, method Forums::GenEditMessageXML()
УСТАРЕШИЙ Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
GenerateKeyString in file Captcha.class.php, method Captcha::GenerateKeyString()
Генерация строки CAPTCHA
GenGroupXmlTree in file InformationSystems.class.php, method InformationSystem::GenGroupXmlTree()
Формирование полного XML дерева информационных групп для информационной системы
GenMessageXML in file Forums.class.php, method Forums::GenMessageXML()
Устаревший метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном
GenSmilesXML in file Forums.class.php, method Forums::GenSmilesXML()
Метод возвращает XML для смайликов
GenUserInfoXML in file Forums.class.php, method Forums::GenUserInfoXML()
УСТАРЕВШИЙ Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном
GenXml in file ExternalXml.class.php, method ExternalXml::GenXml()
Генерация XML для переданного массива
GenXML4AffiliatePlan in file affiliate.class.php, method affiliate::GenXML4AffiliatePlan()
Генерация XML-данных для партнерских программ магазина
GenXML4AffiliateValues in file affiliate.class.php, method affiliate::GenXML4AffiliateValues()
Генерация XML для уровней партнерской программы
GenXml4Comment in file shop.class.php, method shop::GenXml4Comment()
Метод генерирующий XML для отзыва о товаре
GenXml4Company in file shop.class.php, method shop::GenXml4Company()
Метод генерирует XML для организации
GenXml4CompareItems in file shop.class.php, method shop::GenXml4CompareItems()
Метод генерирует xml для товаров, выбранных для сравнения
GenXML4Currency in file shop.class.php, method shop::GenXML4Currency()
Метод генерирует XML для указанной валюты
GenXml4Helpdesk in file helpdesk.class.php, method helpdesk::GenXml4Helpdesk()
Формирование XML для службы техподдержки
GenXml4InformationSystem in file InformationSystems.class.php, method InformationSystem::GenXml4InformationSystem()
Формирование XML для информационной системы
GenXML4InfSys in file Structure.class.php, method Structure::GenXML4InfSys()
Внутренний метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры. В своей работе использует массивы $this->MassIG, $this->MassII.
GenXml4InsertEditLetters in file Forums.class.php, method Forums::GenXml4InsertEditLetters()
Генерация XML для письма о вставке/редактировании
GenXml4Item in file shop.class.php, method shop::GenXml4Item()
Внутренний метод построения XML для товара, его свойств и сопутствующих товаров
GenXml4ItemCatalogCommentAverageGrade in file shop.class.php, method shop::GenXml4ItemCatalogCommentAverageGrade()
Метод возвращает XML со средней оценкой описания активных отзывов по товару.
GenXml4ItemCatalogComments in file shop.class.php, method shop::GenXml4ItemCatalogComments()
Метод возвращает все комментарии, относящиеся к данному товару.
GenXml4ListItems in file Lists.class.php, method lists::GenXml4ListItems()
Генерация XML для всех элементов списка
GenXML4Message in file Forums.class.php, method Forums::GenXML4Message()
Генерация XML для сообщения
GenXml4Message in file helpdesk.class.php, method helpdesk::GenXml4Message()
Формирование XML для сообщений
GenXml4Mesures in file shop.class.php, method shop::GenXml4Mesures()
Метод генерирует XML для единиц измерения
GenXml4OrderStatus in file shop.class.php, method shop::GenXml4OrderStatus()
Метод генерирует XML для статуса доставки
GenXml4Poll in file Polls.class.php, method polls::GenXml4Poll()
Формирование XML для опроса
GenXML4PriceForShop in file shop.class.php, method shop::GenXML4PriceForShop()
Возвращает XML цены для группы пользователей.
GenXml4Properties in file shop.class.php, method shop::GenXml4Properties()
Метод построения XML для свойств товаров, доступных группе.
GenXml4Property in file shop.class.php, method shop::GenXml4Property()
Возвращает XML свойства.
GenXml4Saller in file shop.class.php, method shop::GenXml4Saller()
Возвращает XML продавца.
GenXml4Sallers in file shop.class.php, method shop::GenXml4Sallers()
Метод построения XML для продавцов.
GenXML4Shop in file Structure.class.php, method Structure::GenXML4Shop()
Внутренний метод построения XML для групп товаров и товаров интернет-магазина при отображении структуры. Использует в своей работе $this->MassShopGroups, $this->MassShopItems
GenXml4Shop in file shop.class.php, method shop::GenXml4Shop()
Метод генерации XML для магазина
GenXML4SpecialPrice in file shop.class.php, method shop::GenXML4SpecialPrice()
Формирование XML для специальных цен товара
GenXml4StructureLevelMass in file Structure.class.php, method Structure::GenXml4StructureLevelMass()
Внутренний метод генерации части XML-а для записей указанного уровня
GenXml4Taxes in file shop.class.php, method shop::GenXml4Taxes()
Формирование XML для налогов
GenXml4Theme in file Forums.class.php, method Forums::GenXml4Theme()
Формирование XML для темы форума
GenXml4Ticket in file helpdesk.class.php, method helpdesk::GenXml4Ticket()
Формирование XML для тикета
GenXml4TicketCategory in file helpdesk.class.php, method helpdesk::GenXml4TicketCategory()
Формирование XML для категорий тикетов
GenXml4WorkTime in file helpdesk.class.php, method helpdesk::GenXml4WorkTime()
Формирование XML для режима работы службы техподдержки
GenXmlAffiliatTree | in file affiliate.class.php, method affiliate::GenXmlAffiliatTree()
GenXmlForGroup in file InformationSystems.class.php, method InformationSystem::GenXmlForGroup()
Генерация XML для группы
GenXmlForGroupsPropertyDir in file InformationSystems.class.php, method InformationSystem::GenXmlForGroupsPropertyDir()
Генерация XML для групп дополнительных свойств групп информационных элементов
GenXmlForGroupsPropertyDir in file shop.class.php, method shop::GenXmlForGroupsPropertyDir()
Генерация XML для групп дополнительных свойств групп товаров
GenXmlForItemsPropertyDir in file shop.class.php, method shop::GenXmlForItemsPropertyDir()
Генерация XML для групп дополнительных свойств
GenXmlForItemsPropertyDir in file InformationSystems.class.php, method InformationSystem::GenXmlForItemsPropertyDir()
Генерация XML для групп дополнительных свойств информационных элементов
GenXmlForSystemOfPays in file shop.class.php, method shop::GenXmlForSystemOfPays()
Генерация XML для списка всех платежных систем.
GenXmlForTag in file tag.class.php, method Tag::GenXmlForTag()
Генерация XML для тега
GenXmlProducerList in file shop.class.php, method shop::GenXmlProducerList()
Метод генерирует XML для списка продавцов магазина
GetAccessItem in file InformationSystems.class.php, method InformationSystem::GetAccessItem()
Определение доступности информационного элемента
GetAccessShopItem in file shop.class.php, method shop::GetAccessShopItem()
Определение доступности товара
GetAdditionalPropertyDirPathArray in file shop.class.php, method shop::GetAdditionalPropertyDirPathArray()
Получение пути от текущего каталога дополнительных свойств товара к корневому
GetAdditionalPropertyPathArray in file InformationSystems.class.php, method InformationSystem::GetAdditionalPropertyPathArray()
Построение пути от конкретной группы дополнительных свойств информационных элементов до корня
GetAdditionalPropertyPathArray in file shop.class.php, method shop::GetAdditionalPropertyPathArray()
Получение пути от текущего каталога дополнительных свойств товара к корневому
GetAdditionalPropertyPathArrayGroup in file InformationSystems.class.php, method InformationSystem::GetAdditionalPropertyPathArrayGroup()
Построение пути от конкретной группы дополнительных свойств информационных групп до корня
GetAdminForm in file admin_forms.class.php, method admin_forms::GetAdminForm()
Получение данных о форме центра управления.
GetAdminFormsEvent in file admin_forms.class.php, method admin_forms::GetAdminFormsEvent()
Получение информации о событии (действии) формы центра администрирования
GetAdminFormsEventByName in file admin_forms.class.php, method admin_forms::GetAdminFormsEventByName()
Получение информации о событии (действии) формы центра администрирования по идентификатору формы и псевдониму действия
GetAdminFormsField in file admin_forms.class.php, method admin_forms::GetAdminFormsField()
Извлечение информации о поле формы центра администрирования
GetAdminFormsWord in file admin_forms.class.php, method admin_forms::GetAdminFormsWord()
Получение названия и описания слова на выбранном языке
GetAdminFormsWordOrDefaultLanguageWord in file admin_forms.class.php, method admin_forms::GetAdminFormsWordOrDefaultLanguageWord()
Получение названия и описания слова на выбранном языке. Если для выбранного языка не найдено значение, получается значения для языка "по умолчанию".
GetAdvertisement in file Advertisement.class.php, method Advertisement::GetAdvertisement()
Получение данных об элементе (баннере, всплывающем окне и т.п.)
GetAffiliate in file affiliate.class.php, method affiliate::GetAffiliate()
Получение информации об аффилиате
GetAffiliatePlans in file affiliate.class.php, method affiliate::GetAffiliatePlans()
Получение информации о плане аффилиата
GetAffiliatePlansIdForShop in file affiliate.class.php, method affiliate::GetAffiliatePlansIdForShop()
Получение идентификаторов всех парнерских программ для магазина
GetAffiliateValues in file affiliate.class.php, method affiliate::GetAffiliateValues()
Получение информации о комисии
getAffiliatInnerLevelForUser | in file affiliate.class.php, method affiliate::getAffiliatInnerLevelForUser()
GetAffiliatsForUser in file affiliate.class.php, method affiliate::GetAffiliatsForUser()
Получение массива идентификаторов аффилиатов пользователя
GetAlias in file Site.class.php, method site::GetAlias()
Получение данных об алиасе сайта
GetAliasById in file Site.class.php, method site::GetAliasById()
Метод возвращает информацию об алиасе (домене)
GetAllAdminFormEvents in file admin_forms.class.php, method admin_forms::GetAllAdminFormEvents()
Получение списка всех событий формы администрирования
GetAllAdminFormFields in file admin_forms.class.php, method admin_forms::GetAllAdminFormFields()
Получение списка всех полей формы администрирования
GetAllAdvertisementForSite in file Advertisement.class.php, method Advertisement::GetAllAdvertisementForSite()
Получаем список всех групп баннеров заданного сайта
GetAllAffiliatePlans in file affiliate.class.php, method affiliate::GetAllAffiliatePlans()
Получение всех партнерских программ
GetAllAffiliateValuesForAffiliate in file affiliate.class.php, method affiliate::GetAllAffiliateValuesForAffiliate()
Получение всех уровней партнерской программы
GetAllAlias in file Site.class.php, method site::GetAllAlias()
Метод возвращает информацию обо всех доменах
GetAllAttachments in file helpdesk.class.php, method helpdesk::GetAllAttachments()
Получение вложенных файлов сообщения
GetAllBanners in file Advertisement.class.php, method Advertisement::GetAllBanners()
Получение информации обо всех баннерах сайта или обо всех баннерах
GetAllBlockedMessages in file helpdesk.class.php, method helpdesk::GetAllBlockedMessages()
Получение всех заблокированных сообщений тикета
GetAllCity in file shop.class.php, method shop::GetAllCity()
Получение списка городов
GetAllCityArea in file shop.class.php, method shop::GetAllCityArea()
Метод выборки всех районов города
GetAllComments in file shop.class.php, method shop::GetAllComments()
Метод возвращает список всех комментариев
GetAllCompanies in file shop.class.php, method shop::GetAllCompanies()
Метод для получения списка всех компаний
GetAllCondOfDelivery in file shop.class.php, method shop::GetAllCondOfDelivery()
Метод выборки всех условий доставки
GetAllConferences in file Forums.class.php, method Forums::GetAllConferences()
Получение информации о всех конференциях сайт.
GetAllConstants in file Constants.class.php, method Constants::GetAllConstants()
Получение данных обо всех константах
GetAllContextualWords in file Advertisement.class.php, method Advertisement::GetAllContextualWords()
Получение информации о контекстных фразах для баннера
GetAllCountries in file shop.class.php, method shop::GetAllCountries()
Метод, осуществляющий извлечение всех стран
GetAllCoupons in file shop.class.php, method shop::GetAllCoupons()
Метод возвращает список купонов по заданным условиям
GetAllCriticalLevel in file helpdesk.class.php, method helpdesk::GetAllCriticalLevel()
Получение информации обо всех уровнях критичности. Если передан параметр $helpdesk_id, то выбираются уровни критичности службы техподдержки с id $helpdesk_id
GetAllCurrency in file shop.class.php, method shop::GetAllCurrency()
Метод выборки информации обо всех валютах
GetAllDataTemplates in file Templates.class.php, method templates::GetAllDataTemplates()
Метод для получения списка шаблонов страниц текущего сайта
GetAllDataTemplatesGroups in file Templates.class.php, method templates::GetAllDataTemplatesGroups()
Метод для получения информации обо всех группах шаблонов сайта
GetAllDiscounts in file shop.class.php, method shop::GetAllDiscounts()
Метод возвращает список всех скидок
GetAllDiscountsForItem in file shop.class.php, method shop::GetAllDiscountsForItem()
Метод извлечения информации обо всех скидках для данного товара
GetAllEmail in file helpdesk.class.php, method helpdesk::GetAllEmail()
Получение информации обо всех электронных адресах службы техподдержки
GetAllEvents in file admin_forms.class.php, method admin_forms::GetAllEvents()
Получение списка всех событий формы центра администрирования
GetAllFascicle in file Maillist.class.php, method Maillist::GetAllFascicle()
Получение списка всех выпусков рассылки
GetAllFascicleFiles in file Maillist.class.php, method Maillist::GetAllFascicleFiles()
Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки
GetAllFlags in file helpdesk.class.php, method helpdesk::GetAllFlags()
Получение списка флагов
GetAllForms in file Forms.class.php, method Forms::GetAllForms()
Получение информации о всех формах
GetAllForums in file Forums.class.php, method Forums::GetAllForums()
Метод для получения всех форумов
GetAllForumsGroup in file Forums.class.php, method Forums::GetAllForumsGroup()
Метод для получения списка всех групп
GetAllGroups in file shop.class.php, method shop::GetAllGroups()
Получение всех групп магазина
GetAllHelpdesk in file helpdesk.class.php, method helpdesk::GetAllHelpdesk()
Получение информации обо всех службах техподдержки на конкретном сайте. Если параметр $site_id не передан, или равен false - выбирается информация обо всех службах техподдержки.
GetAllInformationGroups in file InformationSystems.class.php, method InformationSystem::GetAllInformationGroups()
Получение информации об информационных группах
GetAllInformationGroupsPropertys in file InformationSystems.class.php, method InformationSystem::GetAllInformationGroupsPropertys()
Получение данных о дополнительных свойствах информационных групп
GetAllInformationItemsPropertys in file InformationSystems.class.php, method InformationSystem::GetAllInformationItemsPropertys()
Получение данных о дополнительных свойствах элементов информационной системы
GetAllInformationSystems in file InformationSystems.class.php, method InformationSystem::GetAllInformationSystems()
Получение информации о инфосистемах
GetAllInformationSystemsDirs in file InformationSystems.class.php, method InformationSystem::GetAllInformationSystemsDirs()
Получение информации о разделах информационных систем
GetAllInformationSystemsFromDir in file InformationSystems.class.php, method InformationSystem::GetAllInformationSystemsFromDir()
Получение информации о информационных системах раздела
GetAllItems in file shop.class.php, method shop::GetAllItems()
Получение всех товаров заданного магазина и заданной группы товаров
GetAllItemsForOrder in file shop.class.php, method shop::GetAllItemsForOrder()
Получение заказанных товаров
GetAllItemWarehouses in file warehouse.class.php, method warehouse::GetAllItemWarehouses()
Получение всех складов, которым принадлежит товар
GetAllJs in file Kernel.class.php, method kernel::GetAllJs()
Получения списка внешних JavaScript файлов
GetAllLanguages in file admin_forms.class.php, method admin_forms::GetAllLanguages()
Извлечение всех языков
GetAllLibDirs in file lib.class.php, method lib::GetAllLibDirs()
Получение списка директорий типовых дин. страниц
GetAllLibProperties in file lib.class.php, method lib::GetAllLibProperties()
Получение списка всех дополнительных параметров типовой динамической страницы
GetAllLibPropertyListItems in file lib.class.php, method lib::GetAllLibPropertyListItems()
Получение списка элеметов параметра типовой динамической страницы типа "Список"
GetAllLibs in file lib.class.php, method lib::GetAllLibs()
Получение списка типовых динамических страниц
GetAllListDirs in file Lists.class.php, method lists::GetAllListDirs()
Получение информации о разделах списков
GetAllListProperties in file shop.class.php, method shop::GetAllListProperties()
Получение всех дополнительных свойств для магазина
GetAllListsForSite in file Lists.class.php, method lists::GetAllListsForSite()
Получение списков определенного сайта
GetAllLocation in file shop.class.php, method shop::GetAllLocation()
Получение списка всех областей (штатов)
GetAllMaillistsForSite in file Maillist.class.php, method Maillist::GetAllMaillistsForSite()
Получение списка почтовых рассылок заданного сайта
GetAllMaillistUsers in file Maillist.class.php, method Maillist::GetAllMaillistUsers()
Получение списка связей пользователей с рассылкой
GetAllMaillistUsersGroup in file Maillist.class.php, method Maillist::GetAllMaillistUsersGroup()
Получение списка групп пользователей, подписанных на рассылку
GetAllMessage in file helpdesk.class.php, method helpdesk::GetAllMessage()
Получение списка сообщений, относящихся к тикету с идентификатором $helpdesk_ticket_id. Если задан параметр $helpdesk_message_id, выбираются все сообщения, кроме сообщения с id $helpdesk_message_id.
GetAllMessages in file Forums.class.php, method Forums::GetAllMessages()
Метод для получения всех сообщений
GetAllMessageWithParentId in file helpdesk.class.php, method helpdesk::GetAllMessageWithParentId()
Получение списка сообщений, дочерних по отношению к сообщению с id $helpdesk_message_parent_id
GetAllMesures in file shop.class.php, method shop::GetAllMesures()
Метод выборки всех единиц измерения
GetAllModificationItems in file shop.class.php, method shop::GetAllModificationItems()
Метод возвращает информацию обо всех модификациях данного товара
GetAllOrderDiscounts in file shop.class.php, method shop::GetAllOrderDiscounts()
Метод для извлечения информации обо всех скидках
GetAllOrders in file shop.class.php, method shop::GetAllOrders()
Метод выборки заказов для магазина
GetAllOrderStatus in file shop.class.php, method shop::GetAllOrderStatus()
Получение информации обо всех статусах заказаов
GetAllPollReply in file Polls.class.php, method polls::GetAllPollReply()
Получение списка всех ответов на опрос
GetAllPolls in file Polls.class.php, method polls::GetAllPolls()
Получение информации обо всех опросах
GetAllPollsGroups in file Polls.class.php, method polls::GetAllPollsGroups()
Получение информации о всех группах опросов
GetAllPricesForItem in file shop.class.php, method shop::GetAllPricesForItem()
Получение информации о ценах, заданных для товара
GetAllPricesForShop in file shop.class.php, method shop::GetAllPricesForShop()
Получение списка цен для магазина
GetAllProducers in file shop.class.php, method shop::GetAllProducers()
Получение информации обо всех производителях
GetAllPropertiesGroup in file shop.class.php, method shop::GetAllPropertiesGroup()
Метод извлечения информации о дополнительных свойствах группы товаров
GetAllPropertiesGroupsDirForDir in file shop.class.php, method shop::GetAllPropertiesGroupsDirForDir()
Получаем список всех групп дополнительных свойств групп товаров
GetAllPropertiesGroupsDirForShop in file shop.class.php, method shop::GetAllPropertiesGroupsDirForShop()
Получение инфомации обо всех группах дополнительных свойств групп товаров конкретного магазина
GetAllPropertiesItem in file shop.class.php, method shop::GetAllPropertiesItem()
Метод извлечения информации о дополнительных свойствах заданного товара
GetAllPropertiesItemsDirForShop in file shop.class.php, method shop::GetAllPropertiesItemsDirForShop()
Получение информации обо всех группах дополнительных свойств товара для конкретного магазина
GetAllPropertiesItemsForDir in file shop.class.php, method shop::GetAllPropertiesItemsForDir()
Получение информации обо всех свойствах хранящихся в конкретной группе дополнительных свойств конкртеного магазина
GetAllPropertyGroupsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::GetAllPropertyGroupsDirForInformationSystem()
Получение информации о всех группах дополнительных свойств групп информационных элементов конкретной информационной системы
GetAllPropertysItemsDirForInformationSystem in file InformationSystems.class.php, method InformationSystem::GetAllPropertysItemsDirForInformationSystem()
Получение информации обо всех группах дополнительных свойств информационных элементов конкретной информационной системы
GetAllPropretyOfGroup in file shop.class.php, method shop::GetAllPropretyOfGroup()
Получение информации о ВСЕХ дополнительных свойствах групп магазина
GetAllQuery in file seo.class.php, method Seo::GetAllQuery()
Получение списка поисковых запросов
GetAllResponsible in file helpdesk.class.php, method helpdesk::GetAllResponsible()
Получение информации обо всех ответственных лицах
GetAllSellers in file shop.class.php, method shop::GetAllSellers()
Получение информации о всех продавцах магазина $shop_id, если $shop_id = false, то о продавцах всех магазинов
GetAllSession in file Counter.class.php, method counter::GetAllSession()
Определение числа сессий для сайта за весь период подсчета статистики. Метод использует кэш "COUNTER_SITE_SESSION"
GetAllShops in file shop.class.php, method shop::GetAllShops()
Метод для получения списка всех магазинов
GetAllShopsDirs in file shop.class.php, method shop::GetAllShopsDirs()
Получение информации о разделах интернет-магазинов
GetAllShopsFromDir in file shop.class.php, method shop::GetAllShopsFromDir()
Получение информации о интернет-магазинах раздела
GetAllSiteUserAccountTransaction in file shop.class.php, method shop::GetAllSiteUserAccountTransaction()
Метод возвращает данные обо всех транзакциях пользователя сайта
GetAllSpecialPricesForItem in file shop.class.php, method shop::GetAllSpecialPricesForItem()
Получение информации о всех специальных ценах товара
GetAllStatus in file helpdesk.class.php, method helpdesk::GetAllStatus()
Получение списка статусов. Если передан параметр $helpdesk_id, то выбираются сообщения, относящиеся к службе техподдержки с идентификатором $helpdesk_id
GetAllStructure in file Structure.class.php, method Structure::GetAllStructure()
Метод для получения списка всех узлов структуры сайта
GetAllStructureProperties in file Structure.class.php, method Structure::GetAllStructureProperties()
Метод для получения списка всех доп. свойств структуры
GetAllStructurePropertyValuesOfProperty in file Structure.class.php, method Structure::GetAllStructurePropertyValuesOfProperty()
Метод для получения списка всех значений доп. свойств структуры по идентификатору свойства
GetAllSystemOfPay in file shop.class.php, method shop::GetAllSystemOfPay()
Получение всех активных платежных систем
GetAllTags in file tag.class.php, method Tag::GetAllTags()
Получение информации о тегах
GetAllTagsGroups in file tag.class.php, method Tag::GetAllTagsGroups()
Получение информации о группах меток
GetAllTax in file shop.class.php, method shop::GetAllTax()
Получение информации о налогах
GetAllTemplate in file helpdesk.class.php, method helpdesk::GetAllTemplate()
Получение списка стандартных ответов службы техподдержки. Если передан параметр $helpdesk_letter_template_dir_id, выбираются все стандартные ответы, принадлежащие категории с этим идентификатором
GetAllTemplateDir in file helpdesk.class.php, method helpdesk::GetAllTemplateDir()
Получение списка групп стандартных ответов.
GetAllTemplateDirWithParentId in file helpdesk.class.php, method helpdesk::GetAllTemplateDirWithParentId()
Получение списка директорий стандартных ответов, вложенных в директорию с идентификатором $helpdesk_letter_template_dir_parent_id
GetAllTemplateKeyWords in file helpdesk.class.php, method helpdesk::GetAllTemplateKeyWords()
Получение списка всех ключевых слов, относящихся к шаблонному ответу с id $helpdesk_letter_template_id. Если $helpdesk_letter_template_id не задан, или равен 0, выбираются абсолютно все ключевые слова
GetAllTemplates in file Templates.class.php, method templates::GetAllTemplates()
Метод для получения списка макетов текущего сайта
GetAllTemplatesGroups in file Templates.class.php, method templates::GetAllTemplatesGroups()
Получение информации о всех группах макетов
GetAllTemplateWithDirId in file helpdesk.class.php, method helpdesk::GetAllTemplateWithDirId()
Получение списка стандартных ответов, относящихся к директории стандартных ответов с идентификатором $helpdesk_letter_template_dir_id
GetAllTicket in file helpdesk.class.php, method helpdesk::GetAllTicket()
Получение информации обо всех инцидентах конкретной службы техподдержки (если передан параметр $helpdesk_id), или конкретной категории (если передан параметр $helpdesk_ticket_category_id). Если параметры не переданы, выбирается информация обо всех инцидентах
GetAllTicketCategory in file helpdesk.class.php, method helpdesk::GetAllTicketCategory()
Получение информации о категориях инцидентов. Если передан параметр helpdesk_id, выбираются категории, принадлежащие службе техподдержки с id helpdesk_id. Если передан параметр $helpdesk_ticket_category_parent_id, выбираются категории вложенные в категорию с id $helpdesk_ticket_category_parent_id.
GetAllTicketFlag in file helpdesk.class.php, method helpdesk::GetAllTicketFlag()
Получение информации обо всех флагах тикетов
GetAllTypeOfDelivery in file shop.class.php, method shop::GetAllTypeOfDelivery()
Метод выборки всех типов доставки для конкретного магазина
GetAllUsers in file helpdesk.class.php, method helpdesk::GetAllUsers()
Получение информации обо всех пользователях центра администрирования данного сайта
GetAllUsers in file Site_users.class.php, method SiteUsers::GetAllUsers()
Получение информации о всех пользователях сайта
GetAllUsers in file UserAccess.class.php, method user_access::GetAllUsers()
Получение данных о всех пользователях центра администрирования
GetAllUsersForAffiliate in file affiliate.class.php, method affiliate::GetAllUsersForAffiliate()
Получение всех пользователей, привлеченных определенным аффилиатом
GetAllUserTypes in file UserAccess.class.php, method user_access::GetAllUserTypes()
Метод возвращает список типов пользователей
GetAllWarehouseItems in file warehouse.class.php, method warehouse::GetAllWarehouseItems()
Получение всех товаров склада
GetAllWarehousesForShop in file warehouse.class.php, method warehouse::GetAllWarehousesForShop()
Получение всех складов магазина
GetAllWeekends in file helpdesk.class.php, method helpdesk::GetAllWeekends()
Получение списка всех специальных рабочих/выходных днях
GetAllWordsByLanguage in file admin_forms.class.php, method admin_forms::GetAllWordsByLanguage()
Извлечения списка слов определенного языка
GetAnswerDate in file helpdesk.class.php, method helpdesk::GetAnswerDate()
Получение даты ответа для тикета
GetAportCatalog in file seo.class.php, method Seo::GetAportCatalog()
Определение наличия страницы в каталоге Апорт
GetArrayAttachment in file helpdesk.class.php, method helpdesk::GetArrayAttachment()
Получение массива с информацией обо всех вложениях сообщения
GetAttachment in file helpdesk.class.php, method helpdesk::GetAttachment()
Получение информации о вложенном файле
GetAttachmentPath in file helpdesk.class.php, method helpdesk::GetAttachmentPath()
Получение полного пути к вложенному файлу
GetBit in file Kernel.class.php, method kernel::GetBit()
Получить бит номер $bit_number числа $int
GetBotsInfo in file Counter.class.php, method counter::GetBotsInfo()
Получение данных о ботах и посещенных ими страницах
getBrowserName | in file Counter.class.php, method counter::getBrowserName()
GetCacheContent in file Cache.class.php, method Cache::GetCacheContent()
Получение данных из кэша
GetCacheSystem in file Cache.class.php, method Cache::GetCacheSystem()
Определение системы кэширования для кэша
GetCaptchaId in file Captcha.class.php, method Captcha::GetCaptchaId()
Метод генерирует и возвращает уникальный индекс для CAPTCHA
GetCart in file shop.class.php, method shop::GetCart()
Извлечение корзины в зависимости от CartType.
GetCatalogItemIdByCmlId in file shop.class.php, method shop::GetCatalogItemIdByCmlId()
Метод возвращает данные о товаре по идентификатору товара стандарта CommerceML
GetCharacteristic in file seo.class.php, method Seo::GetCharacteristic()
Получение характеристики
GetChildrenItemMasDataTemplatesGroup in file Templates.class.php, method templates::GetChildrenItemMasDataTemplatesGroup()
Метод построения поддерева узла дерева
GetChildrenItemMasTemplatesGroup in file Templates.class.php, method templates::GetChildrenItemMasTemplatesGroup()
Метод построения поддерева узла дерева
GetChmod | in file Cache.class.php, method Cache::GetChmod()
GetChmodFile | in file Cache.class.php, method Cache::GetChmodFile()
GetChmodFile in file File.class.php, method File::GetChmodFile()
Получение прав доступа к создаваемым объектом файлов
GetChmodFile in file SiteTemplate.class.php, method SiteTemplate::GetChmodFile()
Получение прав доступа к создаваемым объектом файлов
GetCity in file shop.class.php, method shop::GetCity()
Метод, осуществляющий извлечение города
GetCityArea in file shop.class.php, method shop::GetCityArea()
Получение информации о районе города по идентификатору района
GetCityAreaByName | in file shop.class.php, method shop::GetCityAreaByName()
GetCityByName | in file shop.class.php, method shop::GetCityByName()
GetColor in file Kernel.class.php, method kernel::GetColor()
Создание цвета для некоторого идентификатора.
GetComment in file shop.class.php, method shop::GetComment()
Метод возвращает информацию о комментарии к товару
GetComment in file InformationSystems.class.php, method InformationSystem::GetComment()
Получение информации о комментарии к информационному элементу
GetCommentInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCommentInformationSystemItem()
Получение комментариев информационных элементов
GetCompany in file shop.class.php, method shop::GetCompany()
Метод для получения информации об организации
GetCondOfDelivery in file shop.class.php, method shop::GetCondOfDelivery()
Метод, осуществляющий извлечение условия доставки
GetCondOfDeliveryXml in file shop.class.php, method shop::GetCondOfDeliveryXml()
Метод формирования xml для условия доставки (в xml входит информация и о типе доставки, связанным с условием)
GetConference in file Forums.class.php, method Forums::GetConference()
Метод для получения информации о конференции.
GetConferencePath in file Forums.class.php, method Forums::GetConferencePath()
Получение пути к конференции по ее идентификатору
GetConstant in file Constants.class.php, method Constants::GetConstant()
Получение данных о константе
GetConstantByName in file Constants.class.php, method Constants::GetConstantByName()
Получение данных о константе по ее имени
GetConstants in file Constants.class.php, method Constants::GetConstants()
Устаревший метод, не рекомендуется к использованию с версии 5.1.2
GetContextualWords in file Advertisement.class.php, method Advertisement::GetContextualWords()
Получение информации о контекстной фразе
GetCookie in file shop.class.php, method shop::GetCookie()
Загрузка массива данных из cookies
GetCookieCart in file shop.class.php, method shop::GetCookieCart()
Получить содержимое корзины в cookies
GetCookieExpires in file shop.class.php, method shop::GetCookieExpires()
Метод возвращает время истечения данных в корзине, хранящейся в кукисах.
GetCountAllComments in file shop.class.php, method shop::GetCountAllComments()
Получение числа комментариев к товарам
GetCountCity in file shop.class.php, method shop::GetCountCity()
Получение числа городов для области
GetCountCityAreas in file shop.class.php, method shop::GetCountCityAreas()
Получение числа районов города
GetCountCommentInformationItem in file InformationSystems.class.php, method InformationSystem::GetCountCommentInformationItem()
Определение числа комментариев для информационного элемента
GetCountComments in file InformationSystems.class.php, method InformationSystem::GetCountComments()
Получение числа комментариев к информационным элементам
GetCountCondOfDelivery in file shop.class.php, method shop::GetCountCondOfDelivery()
Получение числа условий доставки для типа доставки
GetCountCountry in file shop.class.php, method shop::GetCountCountry()
Получение числа стран
GetCountCurrency in file shop.class.php, method shop::GetCountCurrency()
Получение числа валют в справочнике
GetCountDiscount in file shop.class.php, method shop::GetCountDiscount()
Получение числа скидок для магазина
GetCounterHotLog in file seo.class.php, method Seo::GetCounterHotLog()
Проверка наличия счетчика статистики HotLog
GetCounterInform in file Counter.class.php, method counter::GetCounterInform()
Получение информации о данных счетчика за определенную дату
GetCounterLiveInternet in file seo.class.php, method Seo::GetCounterLiveInternet()
Проверка наличия счетчика статистики LiveInternet
GetCounterMail in file seo.class.php, method Seo::GetCounterMail()
Проверка наличия счетчика статистики Mail
GetCounterRambler in file seo.class.php, method Seo::GetCounterRambler()
Проверка наличия счетчика статистики Rambler
GetCounterSpyLog in file seo.class.php, method Seo::GetCounterSpyLog()
Проверка наличия счетчика статистики SpyLog
GetCounterYandex in file seo.class.php, method Seo::GetCounterYandex()
Проверка наличия счетчика статистики Yandex
GetCountFormsFill in file Forms.class.php, method Forms::GetCountFormsFill()
Получение количества заполнений формы.
GetCountInformationSystem in file InformationSystems.class.php, method InformationSystem::GetCountInformationSystem()
Определение количества инфосистем
GetCountInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCountInformationSystemItem()
Получение количества элементов информационной системы
GetCountItem in file Cache.class.php, method Cache::GetCountItem()
Определение количества элементов в кэше
GetCountItemsAndGroups in file InformationSystems.class.php, method InformationSystem::GetCountItemsAndGroups()
Получение числа элементов и групп для переданной родительской группы. Для оптимизации числа запросов рекомендуется использовать совместно с FillMemCacheCountItemsAndGroup()
GetCountItemsAndGroups in file shop.class.php, method shop::GetCountItemsAndGroups()
Получение числа элементов и групп для переданной родительской группы
GetCountItemsCatalog in file shop.class.php, method shop::GetCountItemsCatalog()
Получение числа товаров в одном или во всех разделах магазина
GetCountItemsWithConditions in file shop.class.php, method shop::GetCountItemsWithConditions()
Получение числа товаров, параметры которых удовлетворяют заданным условиям
GetCountLocation in file shop.class.php, method shop::GetCountLocation()
Получение числа областей (штатов) для страны
GetCountMessageTheme in file Forums.class.php, method Forums::GetCountMessageTheme()
Получение количества сообщений в теме
GetCountMesures in file shop.class.php, method shop::GetCountMesures()
Получение числа единиц измерения в справочнике
GetCountOrder in file shop.class.php, method shop::GetCountOrder()
Метод выборки количества заказов для магазина
GetCountOrderStatus in file shop.class.php, method shop::GetCountOrderStatus()
Получение числа статусов заказа
GetCountPolls in file Polls.class.php, method polls::GetCountPolls()
Получение числа опросов в группе
GetCountPollsGroup in file Polls.class.php, method polls::GetCountPollsGroup()
Получение числа групп опросов для одного или всех сайтов
GetCountProducers in file shop.class.php, method shop::GetCountProducers()
Получение числа производителей для данного магазина
GetCountProperties in file shop.class.php, method shop::GetCountProperties()
Получение числа свойств товаров конкретного магазина
GetCountProperty4InformationSystem in file InformationSystems.class.php, method InformationSystem::GetCountProperty4InformationSystem()
Получение числа свойств информационных элементов информационной системы
GetCountProperty4Structure in file Structure.class.php, method Structure::GetCountProperty4Structure()
Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют
GetCountry in file shop.class.php, method shop::GetCountry()
Метод, осуществляющий извлечение страны
GetCountryByName | in file shop.class.php, method shop::GetCountryByName()
GetCountSellers in file shop.class.php, method shop::GetCountSellers()
Получение числа продавцов в справочнике
GetCountShops in file shop.class.php, method shop::GetCountShops()
Получение числа магазинов для одного или всех сайтов, обслуживаемых системой управления
GetCountShowingBanner in file Advertisement.class.php, method Advertisement::GetCountShowingBanner()
Получение количества показов баннера
GetCountShowingBannerAtDay in file Advertisement.class.php, method Advertisement::GetCountShowingBannerAtDay()
Получение количества показов баннера за конкретный день
GetCountSystemOfPay in file shop.class.php, method shop::GetCountSystemOfPay()
Получение числа систем оплаты
GetCountTax in file shop.class.php, method shop::GetCountTax()
Получение числа налогов в справочнике
GetCountTypeOfDelivery in file shop.class.php, method shop::GetCountTypeOfDelivery()
Получение числа типов доставок для данного магазина
GetCountTypePrices in file shop.class.php, method shop::GetCountTypePrices()
Получение числа типов цен для магазина
GetCountUnreadMessages in file messages.class.php, method messages::GetCountUnreadMessages()
Получение количества не прочитанных сообщений
GetCoupon in file shop.class.php, method shop::GetCoupon()
Метод возвращает массив с информацией о купоне
GetCouponByText in file shop.class.php, method shop::GetCouponByText()
Возвращает информацию о купоне по его тексту
GetCriticalLevel in file helpdesk.class.php, method helpdesk::GetCriticalLevel()
Получение информации об уровне критичности
GetCurrency in file shop.class.php, method shop::GetCurrency()
Метод, осуществляющий извлечение информации о валюте
GetCurrencyByInternationalName in file shop.class.php, method shop::GetCurrencyByInternationalName()
Метод для получения списка валют с указанным международным названием
GetCurrencyByLike in file shop.class.php, method shop::GetCurrencyByLike()
Метод, возвращающий информацию о валюте из базы согласно имени $string используя оператор LIKE
GetCurrencyCoefficientToShopCurrency in file shop.class.php, method shop::GetCurrencyCoefficientToShopCurrency()
Метод определения коэффициента пересчета валюты товара в валюту магазина
GetCurrencyForShop in file shop.class.php, method shop::GetCurrencyForShop()
Получение валюты, указанной по умолчанию для магазина
GetCurrencyXml in file shop.class.php, method shop::GetCurrencyXml()
Метод формирования xml для валюты
GetCurrentAlias in file Site.class.php, method site::GetCurrentAlias()
Определение основного алиаса сайта
GetCurrentDocumentVersion in file Documents.class.php, method documents::GetCurrentDocumentVersion()
Получение информации о текущей версии документа
GetCurrentLng in file Kernel.class.php, method kernel::GetCurrentLng()
Получения текущего языка центра администрирования
GetCurrentSiteUser in file Site_users.class.php, method SiteUsers::GetCurrentSiteUser()
Метод определения идентификатора текущего пользователя сайта.
GetCurrentUser in file Kernel.class.php, method kernel::GetCurrentUser()
Метод определения идентификатора текущего авторизированного пользователя раздела администрирования
GetCurrentYear in file Kernel.class.php, method kernel::GetCurrentYear()
Получение значения текущего года
GetDataTemplateDirTree in file Templates.class.php, method templates::GetDataTemplateDirTree()
Метод формирования дерева шаблонов.
GetDataTemplatePath in file Templates.class.php, method templates::GetDataTemplatePath()
Получение пути к файлу шаблона
GetDataTemplatePathArray in file Templates.class.php, method templates::GetDataTemplatePathArray()
Метод для построения массива пути от текущего узла к корневому
GetDataTemplatesGroup in file Templates.class.php, method templates::GetDataTemplatesGroup()
Получение информации о группе шаблонов данных
GetDataTemplatesTree in file Templates.class.php, method templates::GetDataTemplatesTree()
Метод построения дерева шаблонов сайта
GetDayInformation in file Counter.class.php, method counter::GetDayInformation()
Получение данных посещаемости за определенный день. Метод использует кэш "COUNTER_DAY_INFORMATION"
GetDBVersion in file Kernel.class.php, method kernel::GetDBVersion()
Метод определения версии MySQL
GetDefaultCurrency in file shop.class.php, method shop::GetDefaultCurrency()
Получение информации о базовой валюте
GetDefaultGroup in file Site_users.class.php, method SiteUsers::GetDefaultGroup()
Получение id группы используемой по умолчанию
GetDefaultOrderStatus in file shop.class.php, method shop::GetDefaultOrderStatus()
Получение статуса заказа, установленного по умолчанию
GetDefaultWarehouse in file warehouse.class.php, method warehouse::GetDefaultWarehouse()
Получение склада по умолчанию для магазина
GetDelimitedGroups in file InformationSystems.class.php, method InformationSystem::GetDelimitedGroups()
Получение иерархического списка групп дополнительнгых свойств групп информационных элементов
GetDelimitedGroups in file shop.class.php, method shop::GetDelimitedGroups()
Формирование дерева групп для магазина.
GetDelimitedGroupsDirExtProperty in file shop.class.php, method shop::GetDelimitedGroupsDirExtProperty()
Метод формирования дерева групп дополнительных свойств групп товаров для магазина.
GetDelimitedGroupsExtProperty in file shop.class.php, method shop::GetDelimitedGroupsExtProperty()
Метод формирования дерева групп для магазина.
GetDelimitedGroupsExtProperty in file InformationSystems.class.php, method InformationSystem::GetDelimitedGroupsExtProperty()
Формирование дерева групп для информационной системы
GetDirPath in file Kernel.class.php, method kernel::GetDirPath()
Получение пути к директории, используемой для решения проблемы с ограничением количества поддиректорий в директории.
GetDiscount in file shop.class.php, method shop::GetDiscount()
Метод, осуществляющий извлечение информации о скидке
GetDmozCatalog in file seo.class.php, method Seo::GetDmozCatalog()
Определение наличия страницы в каталоге Dmoz
GetDocument in file Documents.class.php, method documents::GetDocument()
Получение информации о документе
GetDocumentDir in file Documents.class.php, method documents::GetDocumentDir()
Получение информации о разделе документов
GetDocumentsDirTree in file Documents.class.php, method documents::GetDocumentsDirTree()
Метод формирования дерева разделов документов.
GetDocumentsFromDir in file Documents.class.php, method documents::GetDocumentsFromDir()
Получение списка документов раздела без учета подразделов
GetDocumentsPathArray in file Documents.class.php, method documents::GetDocumentsPathArray()
Метод для построения массива пути от текущего узла к корневому. Предназначен для использования только в центре администрирования.
GetDocumentVersion in file Documents.class.php, method documents::GetDocumentVersion()
Получение информации о версии документа
GetDocumentVersionPath in file Documents.class.php, method documents::GetDocumentVersionPath()
Получение пути к файлу версии документа
GetEItem in file shop.class.php, method shop::GetEItem()
Метод, осуществляющий извлечение информации об электронном товаре
GetEitemCount in file shop.class.php, method shop::GetEitemCount()
Получение количества оставшегося электронного товара
GetEitemsForItem in file shop.class.php, method shop::GetEitemsForItem()
Метод получения данных об электронных товарах конкретного товара
GetEmail in file helpdesk.class.php, method helpdesk::GetEmail()
Получение информации об электронном адресе
GetEmailIsHelpdeskEmail in file helpdesk.class.php, method helpdesk::GetEmailIsHelpdeskEmail()
Проверка, является ли переданный текст адресом службы техподдержки или почтовым демоном, а также, нужно ли отсылать сообщения на электронный адрес пользователю
GetExpires in file Kernel.class.php, method kernel::GetExpires()
Получение времени истечения актуальности страницы
GetExtension in file Kernel.class.php, method kernel::GetExtension()
Метод возвращает расширение файла
GetExternalHtml in file admin_forms_fields.class.php, method admin_forms_fields::GetExternalHtml()
Получить установленный внешний HTML для формы
GetExternalInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetExternalInformationSystemItem()
Получение элементов информационной системы. Переименован с GetInformationSystemItem
GetExtraProperties in file Site_users.class.php, method SiteUsers::GetExtraProperties()
Получение дополнительных свойств по их идентификатору
GetExtraProperty in file Site_users.class.php, method SiteUsers::GetExtraProperty()
Получение значения свойств дополнительного параметра
GetFascicle in file Maillist.class.php, method Maillist::GetFascicle()
Метод возвращает информацию о почтовой рассылке
GetFascicleFiles in file Maillist.class.php, method Maillist::GetFascicleFiles()
Метод возвращает информацию о файле выпуска почтовой рассылки
GetFields | in file SiteTemplate.class.php, method SiteTemplate::GetFields()
GetFileContent in file File.class.php, method File::GetFileContent()
Получение содержимого файла
GetFileExtension in file SiteTemplate.class.php, method SiteTemplate::GetFileExtension()
Определение расширения файла по его названию без расширения
GetFillForm in file Forms.class.php, method Forms::GetFillForm()
Получение списка и значения полей для заполненной формы.
GetFillForms in file Forms.class.php, method Forms::GetFillForms()
Получение списка заполненных форм для формы $forms_id.
GetFillFormsFields in file Forms.class.php, method Forms::GetFillFormsFields()
Получение списка и значения полей для заполненной формы.
GetFirstMessageTicket in file helpdesk.class.php, method helpdesk::GetFirstMessageTicket()
Получение информации о первом сообщении тикета
GetForm in file Forms.class.php, method Forms::GetForm()
Обработка содержимого отправленной формы
GetFormFields in file Forms.class.php, method Forms::GetFormFields()
Получение данных о полях формы
GetFormInfo in file Forms.class.php, method Forms::GetFormInfo()
Получение информации о форме
GetForum in file Forums.class.php, method Forums::GetForum()
Получение информации о форуме
GetForumAccess in file Forums.class.php, method Forums::GetForumAccess()
Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму
GetForumAndItemIdFromPath in file Forums.class.php, method Forums::GetForumAndItemIdFromPath()
Получение данных об идентификаторе форума и темы по переданному массиву с элементами пути
GetForumsGroup in file Forums.class.php, method Forums::GetForumsGroup()
Метод возвращает информацию о группе форумов
GetForumsUsersGroupList in file Forums.class.php, method Forums::GetForumsUsersGroupList()
Получение данных о связи группы пользователей с форумом
GetForumView in file Forums.class.php, method Forums::GetForumView()
Получение информации о дате последнего просмотра форума пользователем
GetGDVersion in file Kernel.class.php, method kernel::GetGDVersion()
Метод определения версии GD библиотеки
GetGradeInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetGradeInformationSystemItem()
Получение информации об оценке информационного элемента
GetGroup in file shop.class.php, method shop::GetGroup()
Получение информации о группе товаров
GetGroupDir in file shop.class.php, method shop::GetGroupDir()
Получение пути хранения файлов группы товаров
GetGroupIdByCmlId in file shop.class.php, method shop::GetGroupIdByCmlId()
Внутренний метод возвращает данные о группе товаров по идентификатору группы товаров стандарта CommerceML
GetGroupPollsWithConditions in file Polls.class.php, method polls::GetGroupPollsWithConditions()
Метод для получения списка групп с запросами по условиям
GetGroups in file shop.class.php, method shop::GetGroups()
Метод возвращает список групп магазина
GetGroupsByPropertyValue in file shop.class.php, method shop::GetGroupsByPropertyValue()
Получение информации обо всех группах, по значению доп. свойства
GetGroupsForUser in file Site_users.class.php, method SiteUsers::GetGroupsForUser()
Определение идентификаторов групп, в которые входит пользователь
GetGroupsInformationSystem in file InformationSystems.class.php, method InformationSystem::GetGroupsInformationSystem()
Формирование дерева групп информационной системы
GetGroupsTree in file shop.class.php, method shop::GetGroupsTree()
Получение массива идентификаторов всего дерева подгрупп данной группы включая идентификатор родительской
GetGroupsXmlTree in file shop.class.php, method shop::GetGroupsXmlTree()
Служебный метод построения дерева xml для групп.
GetGroupWithPath in file shop.class.php, method shop::GetGroupWithPath()
Получение информации о группе по пути, если такая существует в данной подгруппе магазина
GetGroupWithValue in file shop.class.php, method shop::GetGroupWithValue()
Получение информации о группе по наименованию, если такая существует в данной подгруппе магазина
GetHelpdesk in file helpdesk.class.php, method helpdesk::GetHelpdesk()
Получение данных о службе технической поддержки.
GetHtmlCallDoLoadAjax in file admin_forms.class.php, method admin_forms::GetHtmlCallDoLoadAjax()
Получение кода вызова DoLoadAjax для атрибута href
GetHtmlCallTrigerSingleAction in file admin_forms.class.php, method admin_forms::GetHtmlCallTrigerSingleAction()
Формирует ссылку действия для содержимого атрибута href тега a
GetIdInformationItem in file InformationSystems.class.php, method InformationSystem::GetIdInformationItem()
Определение идентификатора информационного элемента по URI элемента и идентификатору информационной группы
GetImageSize in file Image.class.php, method Image::GetImageSize()
Метод определяет высоту и ширину изображения
GetIndexAport in file seo.class.php, method Seo::GetIndexAport()
Определение количества проиндексированных странниц сервисом Апорт
GetIndexGoogle in file seo.class.php, method Seo::GetIndexGoogle()
Определяет количество проиндексированных странниц сервисом Google
GetIndexMsn in file seo.class.php, method Seo::GetIndexMsn()
Определение количества проиндексированных странниц сервисом Bing.com
GetIndexRambler in file seo.class.php, method Seo::GetIndexRambler()
Определение количества проиндексированных странниц сервисом Rambler
GetIndexYahoo in file seo.class.php, method Seo::GetIndexYahoo()
Определение количества проиндексированных странниц сервисом Yahoo
GetIndexYandex in file seo.class.php, method Seo::GetIndexYandex()
Определение количества проиндексированных странниц в Яндекс.ру
GetInfo4Messages in file helpdesk.class.php, method helpdesk::GetInfo4Messages()
Информация о количестве сообщений тикета
GetInformationFromPath in file InformationSystems.class.php, method InformationSystem::GetInformationFromPath()
Определение идентификатора информационной группы и идентификатора информационного элемента по значению URI
GetInformationGroup in file InformationSystems.class.php, method InformationSystem::GetInformationGroup()
Получение информации о группе. Использует кэш "INF_SYS_GROUP"
GetInformationGroupDir in file InformationSystems.class.php, method InformationSystem::GetInformationGroupDir()
Получение пути хранения файлов информационной группы
GetInformationGroupName in file InformationSystems.class.php, method InformationSystem::GetInformationGroupName()
Получение имени информационной группы
GetInformationGroupsPathArray in file InformationSystems.class.php, method InformationSystem::GetInformationGroupsPathArray()
Построение массива пути от текущей группы к корневой
GetInformationGroupsPropertys in file InformationSystems.class.php, method InformationSystem::GetInformationGroupsPropertys()
Получение данных о дополнительном свойстве групп информационной системы
GetInformationGroupsPropertyValue in file InformationSystems.class.php, method InformationSystem::GetInformationGroupsPropertyValue()
Получение информации о значении дополнительного свойства информационных групп
GetInformationItemDir in file InformationSystems.class.php, method InformationSystem::GetInformationItemDir()
Получение пути хранения файлов информационного элемента
GetInformationItemPropertyValue in file InformationSystems.class.php, method InformationSystem::GetInformationItemPropertyValue()
Получение информации о значении дополнительного свойства информационного элемента
GetInformationItemsFromGroup in file InformationSystems.class.php, method InformationSystem::GetInformationItemsFromGroup()
Получение информации об элементах, находящихся в информационной группе
GetInformationItemsPropertyValue in file InformationSystems.class.php, method InformationSystem::GetInformationItemsPropertyValue()
Получение информации о значении дополнительного свойства информационного элемента по ID связи таблицы information_propertys_items_table
GetInformationSystem in file InformationSystems.class.php, method InformationSystem::GetInformationSystem()
Получение данных об информационной системе
GetInformationSystemByStructureId in file InformationSystems.class.php, method InformationSystem::GetInformationSystemByStructureId()
Получение информации об информационной системе, связанной с узлом структуры
GetInformationSystemGroupAccess in file InformationSystems.class.php, method InformationSystem::GetInformationSystemGroupAccess()
Определения уровня доступности информационной группы
GetInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItem()
Получение данных об информационном элементе
GetInformationSystemItemAccess in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItemAccess()
Определение уровня доступности информационного элемента
GetInformationSystemItemProperty in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItemProperty()
Получение данных о дополнительных свойствах элементов
GetInformationSystemItems in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItems()
Получение информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит
GetInformationSystemsDir | in file InformationSystems.class.php, method InformationSystem::GetInformationSystemsDir()
GetInformationSystemsDirPathArray in file InformationSystems.class.php, method InformationSystem::GetInformationSystemsDirPathArray()
Построение массива пути от текущего раздела информационных систем к корневому
GetInformationSystemsDirs in file InformationSystems.class.php, method InformationSystem::GetInformationSystemsDirs()
Формирование дерева разделов информационных систем
GetInitialData in file Counter.class.php, method counter::GetInitialData()
Получение начальных данных для счетчика
GetIp in file ip.class.php, method ip::GetIp()
Получение информации об IP-адресе
GetIpInfo in file ip.class.php, method ip::GetIpInfo()
Получение информации о запретах для переданного ip-адреса
GetIpInformation in file Counter.class.php, method counter::GetIpInformation()
Выборка информации для IP-адреса
GetItem in file shop.class.php, method shop::GetItem()
Метод, осуществляющий извлечение информации о товаре
GetItemByParam in file shop.class.php, method shop::GetItemByParam()
Метод, осуществляющий извлечение информации о товаре по переданным атрибутам элемента
GetItemCountForAllWarehouses in file warehouse.class.php, method warehouse::GetItemCountForAllWarehouses()
Получение количества определенного товара на всех складах
GetItemCountForWarehouse in file warehouse.class.php, method warehouse::GetItemCountForWarehouse()
Получение количества определенного товара на определенном складе
GetItemDir in file shop.class.php, method shop::GetItemDir()
Получение пути хранения файлов товара
GetItemDiscount in file shop.class.php, method shop::GetItemDiscount()
Получение информации о скидке на товар
GetItemFromCart in file shop.class.php, method shop::GetItemFromCart()
Получение информации о товаре из корзины для пользователя
GetItemPath in file Cache.class.php, method Cache::GetItemPath()
Определение пути к элементу
GetItemPath in file shop.class.php, method shop::GetItemPath()
Метод определения идентификатора группы товаров и идентификатора товара по значению URL
GetItemPropertyIdByCmlId in file shop.class.php, method shop::GetItemPropertyIdByCmlId()
Метод возвращает данные о дополнительном свойстве товара по идентификатору дополнительного свойства формата CommerceML
GetItemPropertyValueById in file shop.class.php, method shop::GetItemPropertyValueById()
Метод получения информации о значении дополнительного свойства товара по идентификатору значения
GetItemsFromCart in file shop.class.php, method shop::GetItemsFromCart()
Получение товаров, находящихся в корзине
GetItemsFromCookiesToCart in file shop.class.php, method shop::GetItemsFromCookiesToCart()
Устаревший метод. См. TransferFromCartIntoTable()
GetItemsXmlTree in file shop.class.php, method shop::GetItemsXmlTree()
Метод построения XML для товаров
GetItemXml in file shop.class.php, method shop::GetItemXml()
Метод формирования xml товара
getJsCode in file JsHttpRequest.php, method JsHttpRequest::getJsCode()
string getJsCode()
GetLanguage in file admin_forms.class.php, method admin_forms::GetLanguage()
Получение информации о языке центра администрирования
GetLanguageByShortName in file admin_forms.class.php, method admin_forms::GetLanguageByShortName()
Получение информации о языке центра администрирования по его обозначени.
GetLastInsertId in file Mysql.class.php, method DataBase::GetLastInsertId()
Возвращает ID, сгенерированный колонкой с AUTO_INCREMENT последним запросом INSERT к серверу
GetLastModified in file Kernel.class.php, method kernel::GetLastModified()
Получение времени последнего изменения страницы
GetLastPageTheme in file Forums.class.php, method Forums::GetLastPageTheme()
Получение номера последней страницы темы
GetLib in file lib.class.php, method lib::GetLib()
Получение типовой динамической страницы по её идентификатору
GetLibDir in file lib.class.php, method lib::GetLibDir()
Получение информации о директории типовых дин. страниц
GetLibDirTree in file lib.class.php, method lib::GetLibDirTree()
Формирование дерева разделов
GetLibPath in file lib.class.php, method lib::GetLibPath()
Получение пути к директории lib
GetLibPathArray in file lib.class.php, method lib::GetLibPathArray()
Получение пути от текущего каталога типовых динамических страниц до корневого
GetLibProperty in file lib.class.php, method lib::GetLibProperty()
Получение информации о параметре типовой динамической страницы
GetLinksGoogle in file seo.class.php, method Seo::GetLinksGoogle()
Определение количества ссылающихся страниц с сервиса Google
GetLinksMsn in file seo.class.php, method Seo::GetLinksMsn()
Определение количества ссылающихся страниц с сервиса Bing.com
GetLinksYahoo in file seo.class.php, method Seo::GetLinksYahoo()
Определение количества ссылающихся страниц с сервиса Yahoo
GetLinksYandex in file seo.class.php, method Seo::GetLinksYandex()
Определение количества ссылающихся страниц с сервиса Yandex
GetList in file Lists.class.php, method lists::GetList()
Получение данных о списках
GetListDir in file Lists.class.php, method lists::GetListDir()
Получение информации о разделе списков
GetListDirPathArray in file Lists.class.php, method lists::GetListDirPathArray()
Построение массива пути от текущего раздела к корневому
GetListDirsTree in file Lists.class.php, method lists::GetListDirsTree()
Формирование дерева разделов списков
GetListExtraProperties in file Site_users.class.php, method SiteUsers::GetListExtraProperties()
Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором
GetListItem in file Lists.class.php, method lists::GetListItem()
Получение данных об элементе списка
GetListItemIfIssetValue in file Lists.class.php, method lists::GetListItemIfIssetValue()
Проверка наличия значения в списке
GetListItemsById in file Lists.class.php, method lists::GetListItemsById()
Получение элементов списка в виде массива
GetListItemsValuesById in file Lists.class.php, method lists::GetListItemsValuesById()
Получение элементов списка в виде resource.
GetListPrimaryProperties in file Site_users.class.php, method SiteUsers::GetListPrimaryProperties()
УСТАРЕВШИЙ Получение основных данных о пользователе
GetListsItems in file Lists.class.php, method lists::GetListsItems()
Получение данных об элементах списка
GetLocation in file shop.class.php, method shop::GetLocation()
Метод, осуществляющий извлечение области
GetLocationByName | in file shop.class.php, method shop::GetLocationByName()
GetLogStat in file Search.class.php, method Search::GetLogStat()
Метод для получения сгруппированной информации о поисковых запросах
GetLr | in file seo.class.php, method Seo::GetLr()
GetMailBox in file Mail.class.php, method Mail::GetMailBox()
Формирование имени почтового ящика
GetMailCatalog in file seo.class.php, method Seo::GetMailCatalog()
Определение наличия страницы в каталоге Mail.ru
GetMaillist in file Maillist.class.php, method Maillist::GetMaillist()
Метод возвращает ассоциативный массив с информацией о списке рассылок
GetMaillistXML in file Maillist.class.php, method Maillist::GetMaillistXML()
Устаревший метод генерирующий XML для состояния подписки конкретного пользователя сайта
GetMasGroup in file InformationSystems.class.php, method InformationSystem::GetMasGroup()
Получение массива информационных групп
GetMasGroupToRoot in file shop.class.php, method shop::GetMasGroupToRoot()
Возвращает $this->mas_groups_to_root
GetMasXslGroupPath in file Xsl.class.php, method xsl::GetMasXslGroupPath()
Получение массива с информацией о разделах, составляющих путь от текущего до корневого раздела
GetMd5CacheCountItemsAndGroup in file shop.class.php, method shop::GetMd5CacheCountItemsAndGroup()
Получение хэша для кэширвоания количества товаров и групп
GetMessage in file messages.class.php, method messages::GetMessage()
Получение информации о сообщении
GetMessage in file helpdesk.class.php, method helpdesk::GetMessage()
Получение информации о сообщении.
GetMessage in file Forums.class.php, method Forums::GetMessage()
Получение информации о сообщении
GetMessageByNumber in file helpdesk.class.php, method helpdesk::GetMessageByNumber()
Получение информации о сообщении по его порядковому номеру в тикете
GetMessageForHistory in file helpdesk.class.php, method helpdesk::GetMessageForHistory()
Получение отформатированного сообщения для истории сообщений
GetMessageHistory in file helpdesk.class.php, method helpdesk::GetMessageHistory()
Построение дерева сообщений
GetMesure in file shop.class.php, method shop::GetMesure()
Метод, осуществляющий извлечение информации о единице измерения
GetMesuresByLike in file shop.class.php, method shop::GetMesuresByLike()
Метод, возвращающий информацию о мере измерения из базы согласно имени $string используя оператор LIKE
getmicrotime in file Kernel.class.php, method kernel::getmicrotime()
Получение значения времени
GetMimeType in file Kernel.class.php, method kernel::GetMimeType()
Метод определения MIME-типа файла
GetModule in file Modules.class.php, method modules::GetModule()
Получение информации о модуле
GetMsgList in file Mail.class.php, method Mail::GetMsgList()
Получение списка писем
GetNewUsersInform in file Counter.class.php, method counter::GetNewUsersInform()
Получение информации о новых пользователях сайта
GetOnClickCallDoLoadAjax in file admin_forms.class.php, method admin_forms::GetOnClickCallDoLoadAjax()
Получение кода вызова DoLoadAjax для события onClick
GetOnClickCallTrigerSingleAction in file admin_forms.class.php, method admin_forms::GetOnClickCallTrigerSingleAction()
Формирует ссылку действия для содержимого атрибута onclick тега a
GetOnPageCount in file admin_forms.class.php, method admin_forms::GetOnPageCount()
Получение числа элементов на страницу
GetOrder in file shop.class.php, method shop::GetOrder()
Извлечение заказа по его ID
GetOrderByGuid in file shop.class.php, method shop::GetOrderByGuid()
Извлечение заказа по его GUID
GetOrderDiscount in file shop.class.php, method shop::GetOrderDiscount()
Метод возвращает информацию о скидке для заказов
GetOrderDiscountForSum in file shop.class.php, method shop::GetOrderDiscountForSum()
Устаревший метод. Заменен на GetOrderDiscountForSumAndCount() Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных указанного магазина
GetOrderDiscountForSumAndCount in file shop.class.php, method shop::GetOrderDiscountForSumAndCount()
Метод расчитывает скидку на сумму товара, в соответствии со списком скидок, доступных для указанного магазина
GetOrderDiscountWithConditions in file shop.class.php, method shop::GetOrderDiscountWithConditions()
Метод возвращает список скидок на сумму заказа по заданным условиям
GetOrderInfoArray in file shop.class.php, method shop::GetOrderInfoArray()
Метод формирования массива с информацией о заказе для вставки в заказы
GetOrderItem in file shop.class.php, method shop::GetOrderItem()
Метод, осуществляющий извлечение товара из заказа
GetOrderItems in file shop.class.php, method shop::GetOrderItems()
Метод, осуществляющий извлечение товаров из заказа
GetOrdersStatus in file shop.class.php, method shop::GetOrdersStatus()
Метод, осуществляющий извлечение состояния заказа
GetOrderSum in file shop.class.php, method shop::GetOrderSum()
Расчет суммы заказа
GetOrderXml in file shop.class.php, method shop::GetOrderXml()
Метод формирования xml с данными о заказе, при заданном наименовании xsl-шаблона, осуществляет вывод данных
getOsName | in file Counter.class.php, method counter::getOsName()
GetPageCount in file Search.class.php, method Search::GetPageCount()
Метод определения числа проиндексированных страниц
GetPageInfo in file Search.class.php, method Search::GetPageInfo()
Получение информации о проиндексированных страницах
GetPageRank in file seo.class.php, method Seo::GetPageRank()
Поиск значения Google PageRank. Основан на данных Google toolbar. Возвращает значение PageRank страницы
GetPathDataTemplatesGroupCurrentToRoot in file Templates.class.php, method templates::GetPathDataTemplatesGroupCurrentToRoot()
Метод построения пути от заданного узла дерева групп шаблонов страниц до корневого
GetPathGroup in file shop.class.php, method shop::GetPathGroup()
Метод формирования пути по группам товара
GetPathGroup in file InformationSystems.class.php, method InformationSystem::GetPathGroup()
Формирование пути по информационным группам
GetPathItem in file shop.class.php, method shop::GetPathItem()
Метод формирования пути к товару
GetPathItem in file InformationSystems.class.php, method InformationSystem::GetPathItem()
Формирование пути к данному информационному элементу
GetPathProducer in file shop.class.php, method shop::GetPathProducer()
Метод формирования пути по производителю
GetPathTemplatesGroupCurrentToRoot in file Templates.class.php, method templates::GetPathTemplatesGroupCurrentToRoot()
Метод построения пути от заданного узла дерева групп макетов страниц до корневого
GetPoll in file Polls.class.php, method polls::GetPoll()
Метод возвращает данные об опросе
GetPollsGroup in file Polls.class.php, method polls::GetPollsGroup()
Получение информации о группе опросов
GetPosAport in file seo.class.php, method Seo::GetPosAport()
Определение позиции сайта в поисковой системе Апорт
GetPosGogo in file seo.class.php, method Seo::GetPosGogo()
Определение позиции сайта в поисковой системе GoGo
GetPosGoogle in file seo.class.php, method Seo::GetPosGoogle()
Определение позиции сайта в поисковой системе Google
GetPositionSearch in file seo.class.php, method Seo::GetPositionSearch()
Получение списка позиций в поисковой системе из БД
GetPosLivesearch in file seo.class.php, method Seo::GetPosLivesearch()
Определение позиции сайта в поисковой системе Bing.com
GetPosRambler in file seo.class.php, method Seo::GetPosRambler()
Определение позиции сайта в поисковой системе Rambler
GetPosYahoo in file seo.class.php, method Seo::GetPosYahoo()
Определение позиции сайта в поисковой системе Yahoo
GetPosYandex in file seo.class.php, method Seo::GetPosYandex()
Определение позиции сайта в поисковой системе Yandex
GetPrice in file shop.class.php, method shop::GetPrice()
Метод, осуществляющий извлечение типа цены
GetPriceByCmlId in file shop.class.php, method shop::GetPriceByCmlId()
Метод возвращает данные о цене по идентификатору цены формата CommerceML
GetPriceForCondOfDelivery in file shop.class.php, method shop::GetPriceForCondOfDelivery()
Получение цены доставки с учетом указанного налога
GetPriceForItem in file shop.class.php, method shop::GetPriceForItem()
Метод определения наличия указанной цены для заданного товара
GetPriceForUser in file shop.class.php, method shop::GetPriceForUser()
Метод определения цены товара для заданного пользователя
GetProducer in file shop.class.php, method shop::GetProducer()
Метод, осуществляющий извлечение информации о производителе
GetProducerByName in file shop.class.php, method shop::GetProducerByName()
Метод для получения списка производителей по названию
GetPropertiesGroup in file InformationSystems.class.php, method InformationSystem::GetPropertiesGroup()
Получение данных о дополнительных свойствах информационной группы и их значениях .
GetPropertiesGroupsDir in file shop.class.php, method shop::GetPropertiesGroupsDir()
Получение информации о группе дополнительных свойств групп товаров
GetPropertiesGroupValue in file shop.class.php, method shop::GetPropertiesGroupValue()
Получение данных о значении дополнительного свойства групп товаров
GetPropertiesItemForGroups in file shop.class.php, method shop::GetPropertiesItemForGroups()
Получение информации о принадлежности дополнительного свойства группе товаров
GetPropertiesItemsDir in file shop.class.php, method shop::GetPropertiesItemsDir()
Получение данных о группе дополнительных свойств товара
GetPropertiesOfGroup in file shop.class.php, method shop::GetPropertiesOfGroup()
Метод для получения списка идентификаторов свойств товаров для определенной группы.
GetPropertiesOfGroupForXml in file shop.class.php, method shop::GetPropertiesOfGroupForXml()
Возвращает список свойств, доступных для вывода в группе
GetPropertyACountProperty in file Structure.class.php, method Structure::GetPropertyACountProperty()
Получение количества свойств для разных сайтов
GetPropertyError in file InformationSystems.class.php, method InformationSystem::GetPropertyError()
Метод возвращающий код ошибки, возникающей при работе с методами класса
GetPropertyGroupsDir in file InformationSystems.class.php, method InformationSystem::GetPropertyGroupsDir()
Получение информации о группе дополнительных свойств групп информационной системы
GetPropertyLevel in file Structure.class.php, method Structure::GetPropertyLevel()
Получение информации о максимальном уровне($this->level)
GetPropertyMenuId in file Structure.class.php, method Structure::GetPropertyMenuId()
Получение информации о текущем разделе меню($this->menu_id)
GetPropertySectionPath in file InformationSystems.class.php, method InformationSystem::GetPropertySectionPath()
Получение значения свойтва, содержащего пути по группам
GetPropertySeparator in file Structure.class.php, method Structure::GetPropertySeparator()
Получение информации о разделителе($this->separator)
GetPropertysGroup in file shop.class.php, method shop::GetPropertysGroup()
Получение данных о дополнительных свойствах группы магазина.
GetPropertysInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetPropertysInformationSystemItem()
Получение списка дополнительных свойств и их значений для информационного элемента
GetPropertysItemsDir in file InformationSystems.class.php, method InformationSystem::GetPropertysItemsDir()
Получение информации о группе дополнительных свойств информационных элементов
GetPropertyStructureMass in file Structure.class.php, method Structure::GetPropertyStructureMass()
Получение информации об элементах структуры
GetPropertyStructureParentMass in file Structure.class.php, method Structure::GetPropertyStructureParentMass()
Получение информации о родительских разделах элемента структуры($this->StructureParentMass)
GetPropertyStructurePropertysList in file Structure.class.php, method Structure::GetPropertyStructurePropertysList()
Получение дополнительных свойств структуры
GetPropertyValue in file Structure.class.php, method Structure::GetPropertyValue()
Метод для получения информации о значении свойства структуры
GetPropretyOfGroup in file shop.class.php, method shop::GetPropretyOfGroup()
Получение информации о дополнительном свойстве группы товаров
GetPropretyOfItems in file shop.class.php, method shop::GetPropretyOfItems()
Метод, осуществляющий извлечение свойства товара по идентификатору свойства товара
GetQuery in file seo.class.php, method Seo::GetQuery()
Получение списка поисковых запросов из БД
GetRamblerCatalog in file seo.class.php, method Seo::GetRamblerCatalog()
Определение наличия страницы в каталоге Rambler
GetRealPath in file shop.class.php, method shop::GetRealPath()
Корректирует путь
GetResponsible in file helpdesk.class.php, method helpdesk::GetResponsible()
Получение информации об ответственном лице
GetSearchSystemInform in file Counter.class.php, method counter::GetSearchSystemInform()
Получение информации о поисковых системах
GetSecondaryStat in file Counter.class.php, method counter::GetSecondaryStat()
Получение статистической информации из таблицы сессий
GetSectionPath in file lib.class.php, method lib::GetSectionPath()
Внутренний метод возвращает путь к типовой дин. странице
GetSeller in file shop.class.php, method shop::GetSeller()
Получение информации о продавце по его идентификатору.
GetSellerByName in file shop.class.php, method shop::GetSellerByName()
Метод для получения списка продавцов по названию
GetSessionCart in file shop.class.php, method shop::GetSessionCart()
Получить содержимое корзины в session
GetSettingsForForm in file admin_forms.class.php, method admin_forms::GetSettingsForForm()
Получение информации о настройках для формы у указанного пользователя.
GetShop in file shop.class.php, method shop::GetShop()
Метод, осуществляющий извлечение информации о магазине
GetShopByStructureId in file shop.class.php, method shop::GetShopByStructureId()
Получение информации о магазине, связанном с узлом структуры
GetShopCurrency in file shop.class.php, method shop::GetShopCurrency()
Получение информации о валюте магазина
GetShopDiscount in file shop.class.php, method shop::GetShopDiscount()
Получение списка скидок для магазина
GetShopGroupAccess in file shop.class.php, method shop::GetShopGroupAccess()
Определение уровня доступности группы товаров
GetShopGroupsToRoot in file shop.class.php, method shop::GetShopGroupsToRoot()
Получение массива с данными о каталогах магазина, начиная с данной и до корневой
GetShopItemAccess in file shop.class.php, method shop::GetShopItemAccess()
Определение уровня доступности товара
GetShopPathArray in file shop.class.php, method shop::GetShopPathArray()
Получение пути от текущего каталога к корневому
GetShopsDir | in file shop.class.php, method shop::GetShopsDir()
GetShopsDirPathArray in file shop.class.php, method shop::GetShopsDirPathArray()
Построение массива пути от текущего раздела интернет-магазинов к корневому
GetShopsDirs in file shop.class.php, method shop::GetShopsDirs()
Формирование дерева разделов интернет-магазинов
GetShopsIdForAffiliatePlans in file affiliate.class.php, method affiliate::GetShopsIdForAffiliatePlans()
Получение идентификаторов всех магазинов, в которых доступна парнерская программа
GetShopWhithStructureId in file shop.class.php, method shop::GetShopWhithStructureId()
Метод выбора информации о магазине данного узла структуры сайта
GetSite in file Site.class.php, method site::GetSite()
Получение данных о сайте по его идентификатору
GetSiteUser in file Site_users.class.php, method SiteUsers::GetSiteUser()
Получение информации о пользователе сайта
GetSiteUserAccountSum in file shop.class.php, method shop::GetSiteUserAccountSum()
Метод возвращает сумму пользователя сайта в базовой валюте
GetSiteUserAccountTransaction in file shop.class.php, method shop::GetSiteUserAccountTransaction()
Получение информации о транзакции
GetSiteUserByEmail in file helpdesk.class.php, method helpdesk::GetSiteUserByEmail()
Получение информации о пользователе сайта по его e-mail'у
GetSiteUserByLogin in file Site_users.class.php, method SiteUsers::GetSiteUserByLogin()
Получение информации о пользователе сайта по его логину
GetSiteUsersGroup in file Site_users.class.php, method SiteUsers::GetSiteUsersGroup()
Получение информации о группе пользователей сайта
GetSiteUsersGroupList in file Site_users.class.php, method SiteUsers::GetSiteUsersGroupList()
Получение данных соответствия, пользователя группе пользователей, по идентификатору соответствия
GetSiteUsersGroupsForUser in file shop.class.php, method shop::GetSiteUsersGroupsForUser()
Получение списка групп пользователий, в которых содержится пользователь сайта
GetSiteUsersGroupsForUser in file InformationSystems.class.php, method InformationSystem::GetSiteUsersGroupsForUser()
Получение списка групп пользователий, в которых содержится пользователь сайта
GetSiteUsersGroupsXml in file Site_users.class.php, method SiteUsers::GetSiteUsersGroupsXml()
Формирование XML для группы пользователей
GetSiteUserXml in file Site_users.class.php, method SiteUsers::GetSiteUserXml()
Метод формирования XML с данными о пользователе
GetSpecialPrice in file shop.class.php, method shop::GetSpecialPrice()
Получение информации о специальной цене
GetSpecialPriceForItem in file shop.class.php, method shop::GetSpecialPriceForItem()
Получение информации о специальной цене (в зависимости от количества этого товара в корзине), подходящей для товара.
GetSpecialPricesForItem in file shop.class.php, method shop::GetSpecialPricesForItem()
Получение информации в виде массива о всех специальных ценах товара
GetSpecialPriceValueForItem in file shop.class.php, method shop::GetSpecialPriceValueForItem()
Получение специальной цены (в зависимости от количества этого товара в корзине), подходящей для товара.
GetStatArray in file Counter.class.php, method counter::GetStatArray()
Получение статистической информации из основной таблицы
GetStatDataArray in file Counter.class.php, method counter::GetStatDataArray()
Получение статистических данных за переданный промежуток времени
GetStatus in file helpdesk.class.php, method helpdesk::GetStatus()
Получение информации о статусе
GetStructure in file Structure.class.php, method Structure::GetStructure()
Метод выборки всех страниц структуры
GetStructureAccess in file Structure.class.php, method Structure::GetStructureAccess()
Получение информации о доступе к узлу элементов структуры
GetStructuredListCategoryTicket in file helpdesk.class.php, method helpdesk::GetStructuredListCategoryTicket()
Формирование структурированного списка категорий тикетов
GetStructuredListMessage in file helpdesk.class.php, method helpdesk::GetStructuredListMessage()
Получение структурированного списка сообщений
GetStructuredListTemplateDir in file helpdesk.class.php, method helpdesk::GetStructuredListTemplateDir()
Формирование стуктурированного списка категорий стандартных ответов
GetStructureFilesPath in file Structure.class.php, method Structure::GetStructureFilesPath()
Получение пути к директории lib
GetStructureForParent in file Structure.class.php, method Structure::GetStructureForParent()
Получение дочерних узлов структуры для узла структуры.
GetStructureItem in file Structure.class.php, method Structure::GetStructureItem()
Получение данных об элементе структуры. Идентификатор текущего узла структуры содержится в константе CURRENT_STRUCTURE_ID
GetStructureItemDir in file Structure.class.php, method Structure::GetStructureItemDir()
Получение пути хранения файлов узла структуры
GetStructurePath in file Structure.class.php, method Structure::GetStructurePath()
Определение полного пути к странице
GetStructurePathArray in file Structure.class.php, method Structure::GetStructurePathArray()
Получение пути от текущего узла к корневому
GetStructureProperty in file Structure.class.php, method Structure::GetStructureProperty()
Метод возвращает заполненные св-ва узлов структуры
GetStructurePropertyValue in file Structure.class.php, method Structure::GetStructurePropertyValue()
Получение значения свойства узла структуры по идентификатору узла структуры и идентификатору свойства
GetStructureXml in file Structure.class.php, method Structure::GetStructureXml()
XML для узла структуры. Перед вызовом очистите $Structure->XmlDataFromGenXml4StructureLevelMass
GetSupportEmailId in file helpdesk.class.php, method helpdesk::GetSupportEmailId()
Получение идентификатора электронного адреса службы техподдержки
GetSystemOfPay in file shop.class.php, method shop::GetSystemOfPay()
Метод, осуществляющий извлечение платёжной системы
GetTableFields in file Kernel.class.php, method kernel::GetTableFields()
Получение структуры таблицы БД
GetTableFieldSize in file Kernel.class.php, method kernel::GetTableFieldSize()
Получение размера в символах (не занимаемые байты) поля таблицы.
GetTableNames in file ExecSqlQuery.class.php, method ExecSqlQuery::GetTableNames()
Получение списка таблиц, разделенных запятыми.
GetTag in file tag.class.php, method Tag::GetTag()
Получение информации о теге
GetTagByName in file tag.class.php, method Tag::GetTagByName()
Получение информации о теге по его имени
GetTagByPath in file tag.class.php, method Tag::GetTagByPath()
Получение информации о теге по его пути
GetTagRelation in file tag.class.php, method Tag::GetTagRelation()
Список соответствий тега
GetTags in file tag.class.php, method Tag::GetTags()
Получение информации о тегах
GetTagsGroup in file tag.class.php, method Tag::GetTagsGroup()
Получение информации о группе меток
GetTagsGroupsPathArray in file tag.class.php, method Tag::GetTagsGroupsPathArray()
Построение массива пути от текущей группы меток к корневой
GetTagsGroupsTree in file tag.class.php, method Tag::GetTagsGroupsTree()
Формирование дерева групп меток
GetTax in file shop.class.php, method shop::GetTax()
Метод, осуществляющий извлечение налога
GetTaxIdByCmlId in file shop.class.php, method shop::GetTaxIdByCmlId()
Внутренний метод возвращает данные о налоге по идентификатору налога формата CommerceML
GetTemplate in file Templates.class.php, method templates::GetTemplate()
Получение информации о макете
GetTemplate in file helpdesk.class.php, method helpdesk::GetTemplate()
Получение информации о стандартном ответе
GetTemplate in file Kernel.class.php, method kernel::GetTemplate()
Получение текущего макета
GetTemplateContentFilePath | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateContentFilePath()
GetTemplateContentXml | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateContentXml()
GetTemplateDir in file helpdesk.class.php, method helpdesk::GetTemplateDir()
Получение информации о группе стандартных ответов
GetTemplateDirPathArray in file helpdesk.class.php, method helpdesk::GetTemplateDirPathArray()
Построение пути от корневой директории стандартных ответов до текущей
GetTemplateDirTree in file Templates.class.php, method templates::GetTemplateDirTree()
Метод формирования дерева макетов.
GetTemplateFilePath | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateFilePath()
GetTemplateKeyWords in file helpdesk.class.php, method helpdesk::GetTemplateKeyWords()
Получение информации о ключевом слове
GetTemplatePath | in file SiteTemplate.class.php, method SiteTemplate::GetTemplatePath()
GetTemplatePathArray in file Templates.class.php, method templates::GetTemplatePathArray()
Метод для построения массива пути от текущего узла к корневому
GetTemplatesGroup in file Templates.class.php, method templates::GetTemplatesGroup()
Получение информации о группе макетов
GetTemplatesTree in file Templates.class.php, method templates::GetTemplatesTree()
Метод построения дерева макетов сайта
GetTemplatesUrlServer | in file SiteTemplate.class.php, method SiteTemplate::GetTemplatesUrlServer()
GetTemplateXml | in file SiteTemplate.class.php, method SiteTemplate::GetTemplateXml()
GetTextConformityCoefficient in file Advertisement.class.php, method Advertisement::GetTextConformityCoefficient()
Получение коэффициента схожести текста
GetTextFileSize in file helpdesk.class.php, method helpdesk::GetTextFileSize()
Получение тесктового названия размера файла (в Кб, Мб, Гб)
GetTheme in file Forums.class.php, method Forums::GetTheme()
Метод возвращает информацию о теме форума
GetThemeId in file Forums.class.php, method Forums::GetThemeId()
Получение идентификатора добавленнной темы форума
GetThemeLastMessage in file Forums.class.php, method Forums::GetThemeLastMessage()
Получение последнего сообщения темы
GetThemeView in file Forums.class.php, method Forums::GetThemeView()
Получение информации о дате последнего просмотра темы форума пользователем
GetTicket in file helpdesk.class.php, method helpdesk::GetTicket()
Получение информации об инциденте по его идентификатору
GetTicketByName in file helpdesk.class.php, method helpdesk::GetTicketByName()
Получение информации об инциденте по его имени
GetTicketCategory in file helpdesk.class.php, method helpdesk::GetTicketCategory()
Получение данных о категории инцидентов
GetTicketCategoryPathArray in file helpdesk.class.php, method helpdesk::GetTicketCategoryPathArray()
Построение пути от корневой категории тикетов к заданной
GetTicketFlags in file helpdesk.class.php, method helpdesk::GetTicketFlags()
Получение информации о флаге тикетов
getTimestamp in file Kernel.class.php, method kernel::getTimestamp()
Получение временной метки файла CSS-стиля для страницы
GetTmpId | in file Forums.class.php, method Forums::GetTmpId()
GetTopParentInformationGroup in file InformationSystems.class.php, method InformationSystem::GetTopParentInformationGroup()
Получение родительской группы находящейся в корне для информационной группы
GetTyingProducts in file shop.class.php, method shop::GetTyingProducts()
Получение информации о сопутствующем товаре
GetTyingProductsForItem in file shop.class.php, method shop::GetTyingProductsForItem()
Получение ID сопутствующих товаров для заданного товара
GetTypeOfDelivery in file shop.class.php, method shop::GetTypeOfDelivery()
Метод, осуществляющий извлечение типа доставки
GetTypeOfDeliveryForOrder in file shop.class.php, method shop::GetTypeOfDeliveryForOrder()
Метод извлечения способа доставки определенного типа для заказа с определенными параметрами. Возвращает первый подходящий способ доставки для типа доставки.
GetUpdatePath in file update.class.php, method update::GetUpdatePath()
Получение пути к директории update
GetUrl in file seo.class.php, method Seo::GetUrl()
Поисковый запрос URL и сохранение полученной страницы в кэше
GetUrl in file Kernel.class.php, method kernel::GetUrl()
Запрос URL
GetUrlWithHeader in file Kernel.class.php, method kernel::GetUrlWithHeader()
Запрос URL с возвращением заголовка и данных
GetUseCJ in file Counter.class.php, method counter::GetUseCJ()
Получение данных о использовании кукисов и Java
GetUser in file UserAccess.class.php, method user_access::GetUser()
Получение информации о пользователе
GetUserByName in file UserAccess.class.php, method user_access::GetUserByName()
Получение информации о пользователе по его имени
GetUserDir in file Site_users.class.php, method SiteUsers::GetUserDir()
Метод возвращает абсолютный путь к директории пользователя сайта
GetUserGroups in file Site_users.class.php, method SiteUsers::GetUserGroups()
УСТАРЕВШИЙ Метод определения идентификаторов всех групп, в которые входит пользователь.
GetUsersDir in file Site_users.class.php, method SiteUsers::GetUsersDir()
Метод возвращает абсолютный путь к директории для хранения файлов пользователей
getUsersID in file affiliate.class.php, method affiliate::getUsersID()
Метод формирования массива идентификаторов пользавателей сайта, участвующих в программе партнерских отношений.
GetUsersSuccess in file UserAccess.class.php, method user_access::GetUsersSuccess()
Определение информации о правах доступа пользователя к модулю
GetUsersSuccessEvent in file UserAccess.class.php, method user_access::GetUsersSuccessEvent()
Определение информации о правах доступа пользователя к действию
GetUsersTemplateByUsersId in file helpdesk.class.php, method helpdesk::GetUsersTemplateByUsersId()
Получение информации о шаблонах писем по идентификатору пользователя
GetUserType in file UserAccess.class.php, method user_access::GetUserType()
Метод возвращает данные о группе пользователей центр администрирования
GetValueExtraProperty in file Site_users.class.php, method SiteUsers::GetValueExtraProperty()
Получение значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра
GetValueItemProperty in file shop.class.php, method shop::GetValueItemProperty()
Получение значения дополнительного свойства для товара
GetVersionTimestamp in file Kernel.class.php, method kernel::GetVersionTimestamp()
Получения временной метки по текущей версии системы управления
GetWarehouse in file warehouse.class.php, method warehouse::GetWarehouse()
Получение информации о складе
GetWarehouseItem in file warehouse.class.php, method warehouse::GetWarehouseItem()
Получение информации об остатке товара на складе, получение возможно по shop_warehouse_items_id или паре значений идентификатор склада и идентификатор товара
GetWarehousesXml in file warehouse.class.php, method warehouse::GetWarehousesXml()
Формирование XML для всех складов магазина
GetWarehouseXml in file warehouse.class.php, method warehouse::GetWarehouseXml()
Формирование XML для конкретного склада магазина
GetWeekDayName in file helpdesk.class.php, method helpdesk::GetWeekDayName()
Определение названия дня недели по его номеру
GetWeekend in file helpdesk.class.php, method helpdesk::GetWeekend()
Получение информации о специальном рабочем/выходном дне
GetWeekendArray in file helpdesk.class.php, method helpdesk::GetWeekendArray()
Получение массива дополнительных выходных дней
GetWindowId | in file admin_forms.class.php, method admin_forms::GetWindowId()
GetWorkdayArray in file helpdesk.class.php, method helpdesk::GetWorkdayArray()
Получение массива дополнительных рабочих дней
GetWorkTime in file helpdesk.class.php, method helpdesk::GetWorkTime()
Получение массива рабочих часов службы техподдержки
GetXML4Maillist in file Maillist.class.php, method Maillist::GetXML4Maillist()
Генерация XML для почтовой рассылки
GetXml4StructurePropertys in file Structure.class.php, method Structure::GetXml4StructurePropertys()
Получение XML для свойств структуры. Перед вызовом метода необходимо вызвать $this->GetStructureProperty(array()); и передать массив ID узлов, для которых геренируются св-ва
GetXml4Tags in file shop.class.php, method shop::GetXml4Tags()
Генерация XML для облака тегов магазина
GetXml4Tags in file InformationSystems.class.php, method InformationSystem::GetXml4Tags()
Генерация XML для облака тегов информационной системы
GetXmlContent in file Kernel.class.php, method kernel::GetXmlContent()
Возвращает $this->ShowXmlContent
GetXmlForInformatioItem | in file InformationSystems.class.php, method InformationSystem::GetXmlForInformatioItem()
GetXmlForInformatioItemComments in file InformationSystems.class.php, method InformationSystem::GetXmlForInformatioItemComments()
Создает XML для комметариев
GetXmlForInformationItem in file InformationSystems.class.php, method InformationSystem::GetXmlForInformationItem()
Формирование XML для отображения информационного элемента
GetXmlForItemsOrder in file shop.class.php, method shop::GetXmlForItemsOrder()
Метод формирования xml для товаров в заказе
GetXMLForMessage in file messages.class.php, method messages::GetXMLForMessage()
Формирование XML сообщения
GetXmlForOneComment in file InformationSystems.class.php, method InformationSystem::GetXmlForOneComment()
Генерация XML для комментария и всех его дочерних комментариев.
GetXmlForOrder in file shop.class.php, method shop::GetXmlForOrder()
Метод формирования xml о заказе по идентификатору заказа
GetXmlForSite in file Site.class.php, method site::GetXmlForSite()
Создание XML с информацией о сайте и алиасах
GetXmlProducer in file shop.class.php, method shop::GetXmlProducer()
Метод генерирует XML для производителя в магазине
GetXsl in file Xsl.class.php, method xsl::GetXsl()
Получение информаци об XSL-шаблоне по его имени
GetXslPath in file Xsl.class.php, method xsl::GetXslPath()
Получение пути к файлу xsl
GetYandexCatalog in file seo.class.php, method Seo::GetYandexCatalog()
Определения наличия страницы в каталоге Yandex, тИЦ, темы, страны и региона страницы
get_count_row in file Mysql.class.php, method DataBase::get_count_row()
Метод возвращает количество строк в последнем запросе
get_CSS in file Kernel.class.php, method kernel::get_CSS()
Получение CSS стиля для страницы
get_current_page in file Kernel.class.php, method kernel::get_current_page()
Получение идентификатора текущего узла структуры
get_current_page_path in file Kernel.class.php, method kernel::get_current_page_path()
Получение пути текущей страницы
get_description in file Kernel.class.php, method kernel::get_description()
Получение описания страницы
get_documents_dir in file Documents.class.php, method documents::get_documents_dir()
Метод формирования дерева разделов текущего сайта
get_file_perms in file File.class.php, method File::get_file_perms()
Получение строки прав доступа к файлу
get_information_groups_path in file InformationSystems.class.php, method InformationSystem::get_information_groups_path()
Формирование пути по дереву информационных групп
get_keywords in file Kernel.class.php, method kernel::get_keywords()
Получение ключевых слов страницы
get_mas_information_groups_for_xml in file InformationSystems.class.php, method InformationSystem::get_mas_information_groups_for_xml()
Метод возвращает XML для информационных групп
get_page_id in file Kernel.class.php, method kernel::get_page_id()
Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя
get_polls_name in file Polls.class.php, method polls::get_polls_name()
Получение названия опроса
get_section_path in file Xsl.class.php, method xsl::get_section_path()
Получение пути по дереву разделов XSL. Устаревший метод
get_title in file Kernel.class.php, method kernel::get_title()
Получение заголовка страницы
GISTOGRAMM_LIMIT | in file Counter.php, constant GISTOGRAMM_LIMIT
GoSearch in file Search.class.php, method Search::GoSearch()
Метод выводит результаты поиска запроса $query с помощью XSL-шаблона $xslname в соответствии с дополнительными параметрами
graphic in file Graphic.class.php, class graphic
Система управления сайтом HostCMS v. 5.xx
graphic_diagramma in file Graphic.class.php, method graphic::graphic_diagramma()
Метод вывода круговой диаграммы
graphic_gistogramma in file Graphic.class.php, method graphic::graphic_gistogramma()
Метод вывода гистограммы
Graphic_Linear in file Graphic.class.php, method graphic::Graphic_Linear()
Метод вывода линейного графика
GroupIsParent in file InformationSystems.class.php, method InformationSystem::GroupIsParent()
Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id
GroupIsParent in file shop.class.php, method shop::GroupIsParent()
Определение, является ли группа $group_id непосредственным потомком группы $group_parent_id
Guid in file Kernel.class.php, method kernel::Guid()
Возвращает уникальный идентификатор GUID
Graphic.class.php | procedural page Graphic.class.php
top
h
$headers_string in file Mail.class.php, variable Mail::$headers_string
Заголовки письма
$hidden | in file shop.class.php, variable shop::$hidden
$host in file Mail.class.php, variable Mail::$host
Имя хоста
HeaderDecode in file Mail.class.php, method Mail::HeaderDecode()
Перекодировщик из кодировки письма в кодировку системы
helpdesk in file helpdesk.class.php, class helpdesk
Система управления сайтом HostCMS v. 5.xx
helpdesk.class.php | procedural page helpdesk.class.php
helpdesk.php | procedural page helpdesk.php
hexcode_str in file Security.fns.php, function hexcode_str()
Преобразует строку в hex-последовательность.
HighlightSql | in file Mysql.class.php, method DataBase::HighlightSql()
HtmlToText in file Maillist.class.php, method Maillist::HtmlToText()
Преобразование html в текст
top
i
$iConvertPriceFractionalPart in file shop.class.php, variable shop::$iConvertPriceFractionalPart
Количество знаков после запятой при округлении методом ConvertPrice()
$icon_array in file Kernel.class.php, variable kernel::$icon_array
Массив ассоциаций расширений и пиктограмм
$ID | in file JsHttpRequest.php, variable JsHttpRequest::$ID
$image_extension in file Captcha.class.php, variable Captcha::$image_extension
Расширение рисунка CAPTCHA
$image_height in file Captcha.class.php, variable Captcha::$image_height
Высота изображения с CAPTCHA
$image_width in file Captcha.class.php, variable Captcha::$image_width
Ширина изображения с CAPTCHA
$init in file Wysiwyg.class.php, variable wysiwyg::$init
Массив настроек для tinyMCE.init, заполняется в конструкторе, пример: $this->init['mode'] = "exact";
$is_dir_array in file Cache.class.php, variable Cache::$is_dir_array
Кэш существующих директорий
$ItemMass in file InformationSystems.class.php, variable InformationSystem::$ItemMass
Кэш с данными об элементах
$item_catalog_price in file shop.class.php, variable shop::$item_catalog_price
Цена товара магазина
$iThemeId in file Forums.class.php, variable Forums::$iThemeId
Идентификатор вставленной темы
$iTmpId | in file Forums.class.php, variable Forums::$iTmpId
IconvText in file Mail.class.php, method Mail::IconvText()
Перекодирование текста из кодировки письма в кодировку системы
Image in file Image.class.php, class Image
Система управления сайтом HostCMS v. 5.xx
imagebar in file Graphic.class.php, method graphic::imagebar()
Метод вывода гистограммы
implode_array in file Kernel.class.php, method kernel::implode_array()
Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно
ImportCML in file shop.class.php, method shop::ImportCML()
Импорт из формата CommerceML
ImportCML in file cml.class.php, method cml::ImportCML()
Импорт из формата CommerceML
IncCountMessage in file Forums.class.php, method Forums::IncCountMessage()
Метод наращивания счётчика количества сообщений для пользователя
IncPollReply in file Polls.class.php, method polls::IncPollReply()
Увеличивает число ответов для варианта ответа на опрос. Метод рекомендуется использовать вместо update_vote
IndexationForums in file Forums.class.php, method Forums::IndexationForums()
Метод индексации форумов
IndexationForumsMessages in file Forums.class.php, method Forums::IndexationForumsMessages()
Метод индексации сообщений тем форумов
IndexationShopItems in file shop.class.php, method shop::IndexationShopItems()
Индексация товаров
IndexationStructure in file Structure.class.php, method Structure::IndexationStructure()
Метод индексации элементов структуры
IndexationUser in file Site_users.class.php, method SiteUsers::IndexationUser()
Метод индексации пользователей сайта
InformationItemIncShowCount in file InformationSystems.class.php, method InformationSystem::InformationItemIncShowCount()
Инкрементирование счетчика показов информационного элемента
InformationSystem in file InformationSystems.class.php, class InformationSystem
Класс модуля "Информационные системы"
InformationSystemItemAccess in file InformationSystems.class.php, method InformationSystem::InformationSystemItemAccess()
Определение доступности информационного элемента для пользователя
InformationSystems.class.php | procedural page InformationSystems.class.php
InformationSystems.php | procedural page InformationSystems.php
InitConstants in file Kernel.class.php, method kernel::InitConstants()
Метод инициализации констант сайта в соответствии с константой CURRENT_SITE
Insert in file Cache.class.php, method Cache::Insert()
Вставка значения в кэш
Insert in file Mysql.class.php, method DataBase::Insert()
Вставка записи в таблицу.
InsertAdminForm in file admin_forms.class.php, method admin_forms::InsertAdminForm()
Вставка/обновление формы центра управления
InsertAdminFormsEvent in file admin_forms.class.php, method admin_forms::InsertAdminFormsEvent()
Вставка/обновление информации о событии (дейтсвии) формы администрирования
InsertAdminFormsField in file admin_forms.class.php, method admin_forms::InsertAdminFormsField()
Вставка информации о поле формы центра администрирования
InsertAffiliate in file affiliate.class.php, method affiliate::InsertAffiliate()
Добавление информации об аффилиате
InsertAffiliatePlans in file affiliate.class.php, method affiliate::InsertAffiliatePlans()
Добавление информации о плане аффилиата
InsertAffiliateValues in file affiliate.class.php, method affiliate::InsertAffiliateValues()
Добавление информации о комиссии
InsertBanners in file Advertisement.class.php, method Advertisement::InsertBanners()
Добавление баннера в группу/редактирование приоритета показа баннера в группе
InsertBannersGroup in file Advertisement.class.php, method Advertisement::InsertBannersGroup()
Добавление/редактирование информации о группе баннеров
InsertCategoryTicket in file helpdesk.class.php, method helpdesk::InsertCategoryTicket()
Добавление/обновление информации о категории тикетов
InsertCharacteristic in file seo.class.php, method Seo::InsertCharacteristic()
Добавление характеристики страницы
InsertCity in file shop.class.php, method shop::InsertCity()
Метод, осуществляющий вставку города
InsertCityArea in file shop.class.php, method shop::InsertCityArea()
Метод добавления/редактирования информации о районе города
InsertComment in file shop.class.php, method shop::InsertComment()
Метод добавления/обновления информации об отзыве на товар
InsertCompany in file shop.class.php, method shop::InsertCompany()
Метод для вставки/обновления организации
InsertCondOfDelivery in file shop.class.php, method shop::InsertCondOfDelivery()
Метод, осуществляющий вставку условия доставки
InsertConference in file Forums.class.php, method Forums::InsertConference()
Метод, осуществляющий вставку информации о конференции.
InsertContextualWords in file Advertisement.class.php, method Advertisement::InsertContextualWords()
Добавление/обновление информации о контекстной фразе
InsertCountry in file shop.class.php, method shop::InsertCountry()
Метод, осуществляющий вставку страны
InsertCoupon in file shop.class.php, method shop::InsertCoupon()
Метод для вставки/обновления информации о купоне
InsertCriticalLevel in file helpdesk.class.php, method helpdesk::InsertCriticalLevel()
Добавление/обновление информации об уровне критичности
InsertCurrency in file shop.class.php, method shop::InsertCurrency()
Метод,осуществляющий вставку информации о валюте
InsertDataTemplatesGroup in file Templates.class.php, method templates::InsertDataTemplatesGroup()
Метод добавления/обновления группы шаблонов данных
InsertDiscount in file shop.class.php, method shop::InsertDiscount()
Метод, осуществляющий вставку информации о скидке
InsertEditMessage in file Forums.class.php, method Forums::InsertEditMessage()
Добавление/редактирование сообщения
InsertEItem in file shop.class.php, method shop::InsertEItem()
Метод вставки/обновления информации об электронном товаре
InsertEmail in file helpdesk.class.php, method helpdesk::InsertEmail()
Добавление/обновление информации об электронных адресах
InsertExtraProperty in file Site_users.class.php, method SiteUsers::InsertExtraProperty()
Добавление/редактирование дополнительного параметра
InsertFascicle in file Maillist.class.php, method Maillist::InsertFascicle()
Добавление/редактирование выпуска рассылки
InsertFascicleFiles in file Maillist.class.php, method Maillist::InsertFascicleFiles()
Метод, осуществляющий вставку информацию о файле для выпуса почтовой рассылки
InsertForms in file Forms.class.php, method Forms::InsertForms()
Вставка/обновление информации о форме
InsertFormsFields in file Forms.class.php, method Forms::InsertFormsFields()
Вставка/обновление информации о поле формы
InsertFormsFill in file Forms.class.php, method Forms::InsertFormsFill()
Вставка/обновление информации о заполнении формы
InsertFormsFillValues in file Forms.class.php, method Forms::InsertFormsFillValues()
Вставка/обновление значений заполненной формы
InsertForum in file Forums.class.php, method Forums::InsertForum()
Добавление/редактирование форума
InsertForumsGroup in file Forums.class.php, method Forums::InsertForumsGroup()
Метод добавления/редактирования группы форумов
InsertForumView in file Forums.class.php, method Forums::InsertForumView()
Вставка информации о дате последнего посещения темы форума пользователем.
InsertGroup in file shop.class.php, method shop::InsertGroup()
Вставку/обновление группы товаров
InsertGroupPolls in file Polls.class.php, method polls::InsertGroupPolls()
Вставка информации о группе опросов
InsertHelpdesk in file helpdesk.class.php, method helpdesk::InsertHelpdesk()
Добавление информации о службе технической поддержки.
InsertInformationGroup in file InformationSystems.class.php, method InformationSystem::InsertInformationGroup()
Вставка/обновление информации об информационной группе
InsertInformationGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationGroups()
Вставка/обновление данных об информационной группе. Устаревший метод
InsertInformationItem in file InformationSystems.class.php, method InformationSystem::InsertInformationItem()
Вставка/обновление данных об информационном элементе
InsertInformationItems in file InformationSystems.class.php, method InformationSystem::InsertInformationItems()
Вставка/обновление данных об информационном элементе. Устаревший метод
InsertInformationItemTags in file InformationSystems.class.php, method InformationSystem::InsertInformationItemTags()
Вставка тегов для информационных элементов
InsertInformationPropertys in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertys()
Вставка/обновление информации о дополнительном свойстве информационных элементов
InsertInformationPropertysGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroups()
Вставка/редактирование информации о дополнительном свойстве групп информационной системы
InsertInformationPropertysGroupsValue in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroupsValue()
Вставка/обновление значения свойства информационной группы
InsertInformationPropertysItems in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysItems()
Вставка/обновление значения свойства элемента информационной системы
InsertInformationSystemsDir in file InformationSystems.class.php, method InformationSystem::InsertInformationSystemsDir()
Добавление/обновление раздела информационных систем
InsertInfotmationSystem in file InformationSystems.class.php, method InformationSystem::InsertInfotmationSystem()
Вставка/обновление данных об информационной системе
InsertIp in file ip.class.php, method ip::InsertIp()
Вставка/обновление информации об IP-адресе
InsertItem in file shop.class.php, method shop::InsertItem()
Вставка информации о товаре. Может принимать только часть параметров, при этом обновлены будут только переданные значения
InsertItemDiscount in file shop.class.php, method shop::InsertItemDiscount()
Метод вставки скидки для определенного товара
InsertItemsCatalogTags in file shop.class.php, method shop::InsertItemsCatalogTags()
Вставка тегов для товаров
InsertLib in file lib.class.php, method lib::InsertLib()
Вставка информации о типовой динамической странице
InsertLibDir in file lib.class.php, method lib::InsertLibDir()
Вставка/обновление информации о разделе типовых динамических страниц
InsertLibProperty in file lib.class.php, method lib::InsertLibProperty()
Вставка информации о параметре типовой динамической страницы
InsertLibPropertyListItem in file lib.class.php, method lib::InsertLibPropertyListItem()
Вставка/обновление элемента списка для параметра типовой динамической страницы
InsertList in file Lists.class.php, method lists::InsertList()
Вставка/обновление данных о списке
InsertListDir in file Lists.class.php, method lists::InsertListDir()
Добавление/редактирование раздела списков
InsertListItem in file Lists.class.php, method lists::InsertListItem()
Вставка/обновление данных об элементе списка
InsertLocation in file shop.class.php, method shop::InsertLocation()
Метод, осуществляющий вставку области
InsertMaillist in file Maillist.class.php, method Maillist::InsertMaillist()
Добавление/редактирование информации о рассылке
InsertMessage in file helpdesk.class.php, method helpdesk::InsertMessage()
Добавление/обновление сообщения
InsertMesure in file shop.class.php, method shop::InsertMesure()
Метод, осуществляющий вставку информации о единице измерения
InsertOrder in file shop.class.php, method shop::InsertOrder()
Метод, осуществляющий вставку заказа
InsertOrderDiscount in file shop.class.php, method shop::InsertOrderDiscount()
Метод для вставки/обновления информации о скидке для заказов
InsertOrderItems in file shop.class.php, method shop::InsertOrderItems()
Метод, осуществляющий вставку товара в заказ
InsertOrderStatus in file shop.class.php, method shop::InsertOrderStatus()
Метод, осуществляющий вставку статуса заказа
InsertOrderWithoutSystemOfPay in file shop.class.php, method shop::InsertOrderWithoutSystemOfPay()
Метод вставки заказа, если платежная система не выбрана
InsertPositionSearch in file seo.class.php, method Seo::InsertPositionSearch()
Добавление/обновление статистики по поисковым запросам в БД
InsertPrice in file shop.class.php, method shop::InsertPrice()
Метод, осуществляющий вставку типа цены
InsertPricesToItem in file shop.class.php, method shop::InsertPricesToItem()
Метод вставки связи товара и цены из справочника цен
InsertProducer in file shop.class.php, method shop::InsertProducer()
Метод, осуществляющий вставку производителя
InsertPropertiesGroupsDir in file shop.class.php, method shop::InsertPropertiesGroupsDir()
Добавление информации о группе дополнительных свойств каталогов товаров
InsertPropertiesGroupValue in file shop.class.php, method shop::InsertPropertiesGroupValue()
Вставка значение дополнительного свойства групп товаров
InsertPropertiesItem in file shop.class.php, method shop::InsertPropertiesItem()
Метод вставки значения дополнительного свойства товара
InsertPropertiesItemsDir in file shop.class.php, method shop::InsertPropertiesItemsDir()
Добавление информации о группе дополнительных свойств товара
InsertPropertyForGroup in file shop.class.php, method shop::InsertPropertyForGroup()
Установка принадлежности дополнительного свойства группе товаров
InsertPropertyGroupsDir in file InformationSystems.class.php, method InformationSystem::InsertPropertyGroupsDir()
Добавление информации о группе дополнительных свойств групп информационной системы
InsertPropertysItemsDir in file InformationSystems.class.php, method InformationSystem::InsertPropertysItemsDir()
Добавление информации о группе дополнительных свойств информационных элементов
InsertPropretyOfGroup in file shop.class.php, method shop::InsertPropretyOfGroup()
Вставка дополнительного свойства группы товаров
InsertPropretyOfItems in file shop.class.php, method shop::InsertPropretyOfItems()
Метод, осуществляющий вставку свойства товара
InsertQuery in file seo.class.php, method Seo::InsertQuery()
Добавление/обновление поискового запроса в БД
InsertRecord in file Counter.class.php, method counter::InsertRecord()
Добавление записи в основную таблицу статистики
InsertResponsible in file helpdesk.class.php, method helpdesk::InsertResponsible()
Добавление ответственного пользователя
InsertSearchInQuery in file Search.class.php, method Search::InsertSearchInQuery()
Метод для вставки запроса в журнал поисковых запросов
InsertSeller in file shop.class.php, method shop::InsertSeller()
Метод, осуществляющий вставку или обновление продавца.
InsertSession in file Counter.class.php, method counter::InsertSession()
Вставка записи о сессии
InsertSettings in file admin_forms.class.php, method admin_forms::InsertSettings()
Вставка/обновление информации о настройках формы для пользователя
InsertShop in file shop.class.php, method shop::InsertShop()
Вставка информации о магазине
InsertShopsDir in file shop.class.php, method shop::InsertShopsDir()
Добавление/обновление раздела иентернет-магазинов
InsertSiteUser in file Site_users.class.php, method SiteUsers::InsertSiteUser()
Добавление/обновление информации о пользователе сайта
InsertSiteUserAccountTransaction in file shop.class.php, method shop::InsertSiteUserAccountTransaction()
Вставка в базу данных транзакции по лицевому счету пользователя
InsertSiteUsersMail in file messages.class.php, method messages::InsertSiteUsersMail()
Вставка/обновление сообщения
InsertSpecialPrice in file shop.class.php, method shop::InsertSpecialPrice()
Добавление информации о специальной цене
InsertStatus in file helpdesk.class.php, method helpdesk::InsertStatus()
Обновление/добавление статуса
InsertStructure in file Structure.class.php, method Structure::InsertStructure()
Метод добавления/редактирования узла структуры
InsertStructurePropertys in file Structure.class.php, method Structure::InsertStructurePropertys()
Метод вставки и редактирования дополнительного свойства для структуры
InsertStructurePropertysValue in file Structure.class.php, method Structure::InsertStructurePropertysValue()
Метод вставки и редактирования значения дополнительного свойства в таблице связи
InsertSupportWoktime in file helpdesk.class.php, method helpdesk::InsertSupportWoktime()
Добавление рабочего дня службы технической поддержки
InsertSystemOfPay in file shop.class.php, method shop::InsertSystemOfPay()
Метод, осуществляющий вставку платёжной системы
InsertTag in file tag.class.php, method Tag::InsertTag()
Вставка/обновление тега
InsertTagRelation in file tag.class.php, method Tag::InsertTagRelation()
Вставка соответствия тега элементам контента
InsertTagsGroup in file tag.class.php, method Tag::InsertTagsGroup()
Вставка/обновление группы тегов
InsertTax in file shop.class.php, method shop::InsertTax()
Метод, осуществляющий вставку налога
InsertTemplate in file Templates.class.php, method templates::InsertTemplate()
Метод добавления макета
InsertTemplate in file helpdesk.class.php, method helpdesk::InsertTemplate()
Добавление/обновление информации о стандартном ответе
InsertTemplateDir in file helpdesk.class.php, method helpdesk::InsertTemplateDir()
Добавление/обновление информации о категории стандартных ответов
InsertTemplateKeyWords in file helpdesk.class.php, method helpdesk::InsertTemplateKeyWords()
Добавление/обновление информации о ключевом слове
InsertTemplatesGroup in file Templates.class.php, method templates::InsertTemplatesGroup()
Метод добавления/обновления группы макетов
InsertTheme in file Forums.class.php, method Forums::InsertTheme()
Вставка/обновление информации о теме
InsertThemeUserSubscribe in file Forums.class.php, method Forums::InsertThemeUserSubscribe()
Подписка пользователя сайта на тему форума
InsertTicket in file helpdesk.class.php, method helpdesk::InsertTicket()
Добавление информации об инциденте
InsertTicketFlags in file helpdesk.class.php, method helpdesk::InsertTicketFlags()
Добавление/обновление флага к тикету
InsertToCart in file shop.class.php, method shop::InsertToCart()
Метод добавления информации о товаре в таблицу корзины
InsertTreeGroup in file shop.class.php, method shop::InsertTreeGroup()
Вставки дерева групп для CML v. 2.0x
InsertTyingProducts in file shop.class.php, method shop::InsertTyingProducts()
Метод добавления информации о сопутствующем товаре
InsertTypeOfDelivery in file shop.class.php, method shop::InsertTypeOfDelivery()
Метод, осуществляющий вставку типа доставки
InsertUser in file UserAccess.class.php, method user_access::InsertUser()
Метод вставки и обновления информации о пользователе
InsertUserDeniedAccess in file UserAccess.class.php, method user_access::InsertUserDeniedAccess()
Метод записи в базу информации о неудачной попытке входа в BackOffice
InsertUserGroup in file Site_users.class.php, method SiteUsers::InsertUserGroup()
Вставки/обновление информации о группе пользователей
InsertUsers in file Maillist.class.php, method Maillist::InsertUsers()
Метод добавления/редактирования информации о подписчике
InsertUsers in file Site_users.class.php, method SiteUsers::InsertUsers()
Добавление пользователя в группу
InsertUsersGroup in file Maillist.class.php, method Maillist::InsertUsersGroup()
Метод, открывающий доступ группе пользователей сайта к рассылке
InsertUsersGroup in file Forums.class.php, method Forums::InsertUsersGroup()
Метод добавления/редактирования группы пользователей для определения доступа к форуму
InsertUsersLetterTemplate in file helpdesk.class.php, method helpdesk::InsertUsersLetterTemplate()
Добавление/обновление шаблона письма
InsertVote in file Polls.class.php, method polls::InsertVote()
Устаревший метод. Вставка ответа на опрос.
InsertWarehouse in file warehouse.class.php, method warehouse::InsertWarehouse()
Вставка/обновление склада
InsertWarehouseItems in file warehouse.class.php, method warehouse::InsertWarehouseItems()
Вставка/обновление количества товара на складе.
InsertWeekend in file helpdesk.class.php, method helpdesk::InsertWeekend()
Вставка/обновление информации о специальном рабочем/выходном дне
InsertWord in file admin_forms.class.php, method admin_forms::InsertWord()
Вставка/обновление слова
InsertWordsValue in file admin_forms.class.php, method admin_forms::InsertWordsValue()
Вставка информации о значении слова
InsertXsl in file Xsl.class.php, method xsl::InsertXsl()
Метод вставки/обновления информации об XSL-шаблоне.
InsertXslDir in file Xsl.class.php, method xsl::InsertXslDir()
Метод вставки и обновления XSL-рубрик
insert_alias in file Site.class.php, method site::insert_alias()
Метод вставки/обновления информации об алиасе (домене) сайта
insert_data_templates in file Templates.class.php, method templates::insert_data_templates()
Методы добавления (редактирования) шаблонов страниц
insert_documents in file Documents.class.php, method documents::insert_documents()
Вставка/обновление новых документов
insert_documents_dir in file Documents.class.php, method documents::insert_documents_dir()
Вставка/обновления разделов документов
insert_lists in file Lists.class.php, method lists::insert_lists()
Устаревший метод. Вставка/обновление данных о списке
insert_lists_items in file Lists.class.php, method lists::insert_lists_items()
Устаревший метод. Вставка/обновление данных об элементе списка
insert_module in file Modules.class.php, method modules::insert_module()
Метод вставки/обновления информации о модуле
insert_poll in file Polls.class.php, method polls::insert_poll()
Вставка и обновление опроса
insert_poll_reply in file Polls.class.php, method polls::insert_poll_reply()
Вставка и обновление вариантов ответов
Insert_search_word in file Search.class.php, method Search::Insert_search_word()
Метод формирует индекс для переданного блока страниц
insert_site in file Site.class.php, method site::insert_site()
Вставка/обновление информации о сайте
insert_status in file Documents.class.php, method documents::insert_status()
Метод добавления(редактирования) статусов документов
insert_user_type in file UserAccess.class.php, method user_access::insert_user_type()
Метод вставки и обновления информации о типе пользователей
insert_version in file Documents.class.php, method documents::insert_version()
Метод добавления/редактирования записей о версиях
insert_xsl in file Xsl.class.php, method xsl::insert_xsl()
Метод вставки/обновления XSL. Устаревший метод
insert_xsl_dir in file Xsl.class.php, method xsl::insert_xsl_dir()
Метод вставки и обновления XSL-рубрик. Устаревший метод
ip in file ip.class.php, class ip
Система управления сайтом HostCMS v. 5.xx
ip.class.php | procedural page ip.class.php
ip.php | procedural page ip.php
IpIsNew in file Counter.class.php, method counter::IpIsNew()
Определение наличия записи за сегодняшний день для переданного IP адреса для переданного сайта
isActive in file JsHttpRequest.php, method JsHttpRequest::isActive()
Static function.
IsBase64Encoded in file Mail.class.php, method Mail::IsBase64Encoded()
Проверка строки на то, является ли она закодированной base64
IsOrderOfThisSiteUser in file shop.class.php, method shop::IsOrderOfThisSiteUser()
Метод определяющий, принадлежит ли данный заказ указанному пользователю сайта
IsSearchSystem in file Counter.class.php, method counter::IsSearchSystem()
Определение запроса из поисковой системы. Метод работает с поисковыми системами:
IssetAccessForInformationSystemGroup in file InformationSystems.class.php, method InformationSystem::IssetAccessForInformationSystemGroup()
Проверка возможности доступа пользователя к информационной группе
IssetAccessForShopGroup in file shop.class.php, method shop::IssetAccessForShopGroup()
Проверка возможности доступа пользователя к группе товаров
IssetForumAccess in file Forums.class.php, method Forums::IssetForumAccess()
Определение доступа пользователя к форуму
IssetGroup in file InformationSystems.class.php, method InformationSystem::IssetGroup()
Проверка наличия среди подгрупп данной группы подгруппы с таким же URL как и у вставляемой/редактируемой группы
IssetGroupItemInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetGroupItemInsertUpdate()
Проверка наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента
IssetItem in file InformationSystems.class.php, method InformationSystem::IssetItem()
Проверка наличия элемента с конкретным URL среди информационных элементов данной группы
IssetItemGroupInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetItemGroupInsertUpdate()
Проверка наличия среди информационных элементов данной группы такого, у которого URL совпадает с URL добавляемой/редактируемой информационной группы
IssetModule in file Modules.class.php, method modules::IssetModule()
Метод проверки наличия активного модуля
IssetPath in file Structure.class.php, method Structure::IssetPath()
Метод определения наличия пути
IssetPropertyForGroup in file shop.class.php, method shop::IssetPropertyForGroup()
Определение принадлежности дополнительного свойства группе товаров
IssetSiteUserInUsersGroupInformationGroup in file InformationSystems.class.php, method InformationSystem::IssetSiteUserInUsersGroupInformationGroup()
Проверка вхождения пользователя сайта в группу пользователей, связанную с информационной группой
IssetThemeUserSubscribe in file Forums.class.php, method Forums::IssetThemeUserSubscribe()
Проверка подписки пользователя сайта на тему форума
IssetUserAccessForObject in file UserAccess.class.php, method user_access::IssetUserAccessForObject()
Определене возможности доступа пользователя к управлению объектом
IssetUserEventAccess in file UserAccess.class.php, method user_access::IssetUserEventAccess()
Определение доступности действия формы центра администрирования для пользователя
IssetUsersTypeEventAccess in file UserAccess.class.php, method user_access::IssetUsersTypeEventAccess()
Определение доступности действия формы центра администрирования для группы пользователей
isset_id in file Counter.class.php, method counter::isset_id()
Проверка наличия id сайта
is_dir in file Cache.class.php, method Cache::is_dir()
Проверяет наличие директории и в случае успеха сохраняет результат. Служебный метод.
Image.class.php | procedural page Image.class.php
top
j
$joint_height in file Graphic.class.php, variable graphic::$joint_height
Высота соединяемых частей
$joint_space in file Graphic.class.php, variable graphic::$joint_space
Расстояние между углами сегментов
$joint_space_connection in file Graphic.class.php, variable graphic::$joint_space_connection
Расстояние между сегментами
JoinTags in file tag.class.php, method Tag::JoinTags()
Объединение тегов, теги объединяются по наименьшему идентификатору, тег с наименьшим идентификатором получает данные всех остальных тегов, остальные теги удаляются
JsHttpRequest in file JsHttpRequest.php, method JsHttpRequest::JsHttpRequest()
Constructor.
JsHttpRequest in file JsHttpRequest.php, class JsHttpRequest
JsHttpRequest: PHP backend for JavaScript DHTML loader.
JsHttpRequest.php | procedural page JsHttpRequest.php
top
k
$kernel | in file SiteTemplate.class.php, variable SiteTemplate::$kernel
$keystring in file Captcha.class.php, variable Captcha::$keystring
Значение CAPTCHA
kernel | in file Kernel.class.php, method kernel::kernel()
kernel in file Kernel.class.php, class kernel
Система управления сайтом HostCMS v. 5.xx
Kernel.class.php | procedural page Kernel.class.php
Kernel.php | procedural page Kernel.php
top
l
$legend_height in file Graphic.class.php, variable graphic::$legend_height
Длина легенды
$legend_width in file Graphic.class.php, variable graphic::$legend_width
Ширина легенды
$letters in file Mail.class.php, variable Mail::$letters
Массив, содержащий письма
$level in file Structure.class.php, variable Structure::$level
Максимальный уровень структуры
$line_width in file Graphic.class.php, variable graphic::$line_width
Ширина линии
$LOADER | in file JsHttpRequest.php, variable JsHttpRequest::$LOADER
$lockPrefix in file Kernel.php, variable Session::$lockPrefix
Префикс для блокировки
$lockTimeout in file Kernel.php, variable Session::$lockTimeout
Таймаут попытки заблокировать сессию, в секундах.
lib in file lib.class.php, class lib
Система управления сайтом HostCMS v. 5.xx
lib.class.php | procedural page lib.class.php
lib.php | procedural page lib.php
LinearGraphic in file Graphic.class.php, method graphic::LinearGraphic()
Построение линейного графика
link_len in file Url.class.php, method url::link_len()
Метод сокращения длины строки
lists in file Lists.class.php, class lists
Класс модуля "Списки"
Lists.class.php | procedural page Lists.class.php
Lists.php | procedural page Lists.php
LoadAttachments in file helpdesk.class.php, method helpdesk::LoadAttachments()
Загрузка на сервер вложенных файлов
LoadFile | in file SiteTemplate.class.php, method SiteTemplate::LoadFile()
LoadLibPropertiesValue in file lib.class.php, method lib::LoadLibPropertiesValue()
Загрузка значений параметров типовой дин. страницы для структуры
LoadModuleFiles in file Kernel.class.php, method kernel::LoadModuleFiles()
Служебный метод
LoadModules in file Kernel.class.php, method kernel::LoadModules()
Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS
LoadModulesLngFile in file Kernel.class.php, method kernel::LoadModulesLngFile()
Метод загрузки языкового файла для модуля
load_files in file FileManager.class.php, method FileManager::load_files()
Загрузка файлов
log_access in file EventsJournal.class.php, method EventsJournal::log_access()
Метод протоколирования получения доступа к системе управления
top
m
$mail_box in file Mail.class.php, variable Mail::$mail_box
Почтовый ящик, к которому выполняется доступ
$MasGroup | in file shop.class.php, variable shop::$MasGroup
$MasGroup in file InformationSystems.class.php, variable InformationSystem::$MasGroup
Массив групп
$mas_data_templates_dir | in file Templates.class.php, variable templates::$mas_data_templates_dir
$mas_documents_dir in file Documents.class.php, variable documents::$mas_documents_dir
Массив разделов документов
$mas_lib_dir | in file lib.class.php, variable lib::$mas_lib_dir
$mas_xsl_dir | in file Xsl.class.php, variable xsl::$mas_xsl_dir
$mas_xsl_group_path in file Xsl.class.php, variable xsl::$mas_xsl_group_path
Массив с информацией о пути к каждому разделу XSL
$max_leght_legend in file Graphic.class.php, variable graphic::$max_leght_legend
Максимальная длина подписи легенды в диаграмме
$max_lenght in file Captcha.class.php, variable Captcha::$max_lenght
Максимальная длина строки CAPTCHA
$menus | in file admin_forms_fields.class.php, variable admin_forms_fields::$menus
$menu_id in file Structure.class.php, variable Structure::$menu_id
Идентификатор раздела меню
$MessageTree in file helpdesk.class.php, variable helpdesk::$MessageTree
Дерево сообщений тикета
$min_division_x in file Graphic.class.php, variable graphic::$min_division_x
Минимальное расстояние между делениями по оси х
$min_lenght in file Captcha.class.php, variable Captcha::$min_lenght
Минимальная длина строки CAPTCHA
$min_percent_diagr in file Graphic.class.php, variable graphic::$min_percent_diagr
Минимальный процент, отображаемый на диаграмме
$ModuleClass in file Search.class.php, variable Search::$ModuleClass
Массив соответствия идентификаторов модулей в таблице страниц модулям,
$modules in file Kernel.class.php, variable kernel::$modules
Информация о загруженных модулях системы
Mysqldump.class.php | procedural page Mysqldump.class.php
Mail.class.php | procedural page Mail.class.php
Mbstring.fns.php | procedural page Mbstring.fns.php
Message.fns.php | procedural page Message.fns.php
Mysql.class.php | procedural page Mysql.class.php
MacroReplace | in file SiteTemplate.class.php, method SiteTemplate::MacroReplace()
Mail in file Mail.class.php, class Mail
Система управления сайтом HostCMS v. 5.xx
Maillist in file Maillist.class.php, class Maillist
Класс модуля "Почтовые рассылки"
Maillist.class.php | procedural page Maillist.class.php
Maillist.php | procedural page Maillist.php
MailReport in file Counter.class.php, method counter::MailReport()
Отправка письма с отчетом администратору сайта
MarkEraseSiteUsersMail in file messages.class.php, method messages::MarkEraseSiteUsersMail()
Удаление сообщения пользователем сайта
mb_ereg | in file Mbstring.fns.php, function mb_ereg()
mb_strlen | in file Mbstring.fns.php, function mb_strlen()
mb_strpos | in file Mbstring.fns.php, function mb_strpos()
mb_strrpos | in file Mbstring.fns.php, function mb_strrpos()
mb_strtolower | in file Mbstring.fns.php, function mb_strtolower()
mb_strtoupper | in file Mbstring.fns.php, function mb_strtoupper()
mb_substr | in file Mbstring.fns.php, function mb_substr()
mb_substr_count | in file Mbstring.fns.php, function mb_substr_count()
memory_get_usage | in file Kernel.php, function memory_get_usage()
MessageBlockUnblock in file helpdesk.class.php, method helpdesk::MessageBlockUnblock()
Блокирование/разблокирование сообщения
MessageIsTheme in file Forums.class.php, method Forums::MessageIsTheme()
Проверка сообщения на то, что является ли оно темой
MessageOnlyOwn | in file UserAccess.class.php, method user_access::MessageOnlyOwn()
messages | in file messages.class.php, class messages
messages.class.php | procedural page messages.class.php
messages.php | procedural page messages.php
modules in file Modules.class.php, class modules
Класс модуля "Управление модулями"
Modules.class.php | procedural page Modules.class.php
Modules.php | procedural page Modules.php
MoveInfGroupImage in file SiteTemplate.class.php, method SiteTemplate::MoveInfGroupImage()
Копирование изображений для ИГ
MoveInfItemImage in file SiteTemplate.class.php, method SiteTemplate::MoveInfItemImage()
Копирование изображений для ИЭ
MoveInfItemPropertyImage in file SiteTemplate.class.php, method SiteTemplate::MoveInfItemPropertyImage()
Копирование изображений для доп. свойств ИЭ
MoveShopGroupImage in file SiteTemplate.class.php, method SiteTemplate::MoveShopGroupImage()
Копирование изображений для группы товаров
MoveShopItemImage in file SiteTemplate.class.php, method SiteTemplate::MoveShopItemImage()
Копирование изображений для товара
MoveShopItemPropertyImage in file SiteTemplate.class.php, method SiteTemplate::MoveShopItemPropertyImage()
Копирование изображений для доп. свойств товара
MoveStructureItemPropertyImage in file SiteTemplate.class.php, method SiteTemplate::MoveStructureItemPropertyImage()
Копирование значения доп. свойства типа "Файл" узла структуры
my_array_multisort in file Kernel.class.php, method kernel::my_array_multisort()
Сортировка многомерного массива $array по полю $filed_name
Menu.class.php | procedural page Menu.class.php
top
n
$new_session in file Counter.class.php, variable counter::$new_session
Флаг добавления новой сессии при обновлении данных счетчика
$nextStepDelay in file Kernel.php, variable Session::$nextStepDelay
Время задержки перед повторной блокировкой, в мс.
$nl2br | in file cml.class.php, variable cml::$nl2br
$no_spaces in file Captcha.class.php, variable Captcha::$no_spaces
Флаг, указывающий, слитно писать символы CAPTCHA или нет
NodeIsParent in file Structure.class.php, method Structure::NodeIsParent()
Метод определения принадлежности узла структуры вышестоящему родителю
NoticeTheme in file Forums.class.php, method Forums::NoticeTheme()
Метод делающий тему объявлением или наоборот
numeric_character_references in file Kernel.class.php, method kernel::numeric_character_references()
Метод преобразует сущности в их числовое представление, например &amp;nbsp; в &#160;
top
o
$on_page in file admin_forms.class.php, variable admin_forms::$on_page
Число элементов формы на страницу
$order_field_direction in file admin_forms.class.php, variable admin_forms::$order_field_direction
Направление сортировки: 1 - ASC, 2 - DESC.
$order_field_id in file admin_forms.class.php, variable admin_forms::$order_field_id
Идентификатор поля сортировки.
OrderExtraProperty in file Site_users.class.php, method SiteUsers::OrderExtraProperty()
Метод обновления коэффициентов порядка сортировки
OrderForums in file Forums.class.php, method Forums::OrderForums()
Метод изменения порядка сортировки форумов в группе
OrderForumsGroup in file Forums.class.php, method Forums::OrderForumsGroup()
Метод изменения порядка сортировки групп форумов
OS_UNIX | in file tar.class.php, constant OS_UNIX
top
p
$page_number in file admin_forms.class.php, variable admin_forms::$page_number
Номер текущей страницы формы
$parent_id in file Structure.class.php, variable Structure::$parent_id
Идентификатор родительского узла элемента структуры
$Path in file helpdesk.class.php, variable helpdesk::$Path
Массив, содержащий путь от корневой категории
$PathArrayGetInformationFromPath in file InformationSystems.class.php, variable InformationSystem::$PathArrayGetInformationFromPath
Массив имен узлов, для которых необходимо в результирующем массиве метода GetInformationFromPath() указать наличие этих узлов.
$path_array | in file Documents.class.php, variable documents::$path_array
$path_array | in file Templates.class.php, variable templates::$path_array
$polygon_max_corner in file Captcha.class.php, variable Captcha::$polygon_max_corner
Максимальное значение количества углов многоугольника на фоне CAPTCHA
$polygon_max_radius in file Captcha.class.php, variable Captcha::$polygon_max_radius
Максимальное значение радиуса многоугольника на фоне CAPTCHA
$polygon_min_corner in file Captcha.class.php, variable Captcha::$polygon_min_corner
Минимальное значение количества углов многоугольника на фоне CAPTCHA
$polygon_min_radius in file Captcha.class.php, variable Captcha::$polygon_min_radius
Минимальное значение радиуса многоугольника на фоне CAPTCHA
$port in file Mail.class.php, variable Mail::$port
Порт
$probability in file Cache.class.php, variable Cache::$probability
Вероятность удаления истекших элементов кэша
$PropertyGroupMass in file shop.class.php, variable shop::$PropertyGroupMass
Кэш с данными о дополнительных свойствах групп магазина
$PropertyGroupMass in file InformationSystems.class.php, variable InformationSystem::$PropertyGroupMass
Кэш с данными о дополнительных свойствах информационных групп
$PropertyMass in file InformationSystems.class.php, variable InformationSystem::$PropertyMass
Кэш с данными о свойствах инфоррмационных элементов
$protocol in file Mail.class.php, variable Mail::$protocol
Протокол соединения
Password.class.php | procedural page Password.class.php
PageCompressionBegin in file Compression.class.php, method compression::PageCompressionBegin()
Запуск приема из стандартного потока содержимого для компрессии
PageCompressionEnd in file Compression.class.php, method compression::PageCompressionEnd()
Вывод сжатых данных, размещенных в потоке
PAGE_DIR | in file Kernel.php, constant PAGE_DIR
ParseGoogle | in file seo.class.php, method Seo::ParseGoogle()
ParseHeaderAndBody in file Mail.class.php, method Mail::ParseHeaderAndBody()
Разбор тела сообщения
ParseMessage in file Mail.class.php, method Mail::ParseMessage()
Разбор сообщения по частям
ParseYandex | in file seo.class.php, method Seo::ParseYandex()
PathCorrection in file File.class.php, method File::PathCorrection()
Метод удаляет потенциально опасные символы из пути или имени файла
PathCorrection in file FileManager.class.php, method FileManager::PathCorrection()
Устаревший, заменен File::PathCorrection(). Метод удаляет потенциально опасные символы из пути или имени файла.
PathMkdir in file Kernel.class.php, method kernel::PathMkdir()
Создание директорий относительно корневой директории сайта
php2js in file JsHttpRequest.php, method JsHttpRequest::php2js()
Convert a PHP scalar, array or hash to JS scalar/array/hash. This function is an analog of json_encode(), but it can work with a non-UTF8 input and does not analyze the passed data. Output format must be fully JSON compatible.
phpversion in file Kernel.class.php, method kernel::phpversion()
Метод возвращает номер версии PHP
PNG_QUALITY | in file Kernel.php, constant PNG_QUALITY
polls in file Polls.class.php, class polls
Класс модуля "Опросы"
Polls.class.php | procedural page Polls.class.php
Polls.php | procedural page Polls.php
PrivateOfficeXML in file Site_users.class.php, method SiteUsers::PrivateOfficeXML()
УСТАРЕВШИЙ (новый метод - ShowUserOffice). Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону.
ProcessAjax in file admin_forms.class.php, method admin_forms::ProcessAjax()
Обработчик вызывает обработку действий и построение формы
ProcessOrder in file shop.class.php, method shop::ProcessOrder()
Метод автоматизирует оформление заказа, рекомендуется использовать в Handler'ах систем оплаты
ProcessTypographic in file typograph.class.php, method typograph::ProcessTypographic()
Функция-типограф. Оформляет текст в соответствии со страндартами, принятыми в России.
top
q
$quality in file Graphic.class.php, variable graphic::$quality
Качество рисунка
query in file Mysql.class.php, method DataBase::query()
Метод выполнения SQL-запроса
quoteInput in file JsHttpRequest.php, method JsHttpRequest::quoteInput()
string quoteInput(string $input)
quote_smart in file Security.fns.php, function quote_smart()
Экранирует потенциально опасные символы для MySQL запросов
top
r
$read_lock in file Cache.class.php, variable Cache::$read_lock
Блокировать ли файл кэша при чтении. по умолчанию false
$resize_extension in file Kernel.class.php, variable kernel::$resize_extension
Рашсирения графических файлов, доступные для уменьшения
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RssRead.class.php | procedural page RssRead.class.php
RssWrite.class.php | procedural page RssWrite.class.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RamblerPokupki in file shop.class.php, method shop::RamblerPokupki()
Вывод данных для эксопрта в RamblerPokupki. Метод отправляет соответствующий заголовок и возвращает XML данные.
random_shuffle in file Kernel.class.php, method kernel::random_shuffle()
Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.
ReadRSS in file RssRead.class.php, method RssRead::ReadRSS()
Метод чтения данных из RSS потока
RecalcMessagesInfo in file messages.class.php, method messages::RecalcMessagesInfo()
Метод пересчёта информации о дереве сообщений
RecountAnswerDateTime in file helpdesk.class.php, method helpdesk::RecountAnswerDateTime()
Обновление приблизительной даты ответа на сообщение
ReductionDescription in file Kernel.class.php, method kernel::ReductionDescription()
Укорачивает описание до определённого количества символов, оставляя целое число предлодений
ReFormat in file helpdesk.class.php, method helpdesk::ReFormat()
Преобразование текста в другой формат
RemoveInit in file Wysiwyg.class.php, method wysiwyg::RemoveInit()
Удаление записи из блока tinyMCE.init
RenewMaillist in file Maillist.class.php, method Maillist::RenewMaillist()
Метод обновления информации о подписке для конкретного подписчика
ReplaceFile in file SiteTemplate.class.php, method SiteTemplate::ReplaceFile()
Заменяет макросы в уже существующем файле
ReplaceMacro in file Maillist.class.php, method Maillist::ReplaceMacro()
Производит замену макроподстановки %TEXT в $template_text на переданный текст в $param['text']
ReplaceMailMacro in file helpdesk.class.php, method helpdesk::ReplaceMailMacro()
Макроподстановки в тексте
ReplaceMask in file Site.class.php, method site::ReplaceMask()
Удаляет маску "*." из адреса домена
ReplaceWithoutTagAttribute in file typograph.class.php, method typograph::ReplaceWithoutTagAttribute()
Производит замену массива подстрок $search на массив подстрок $replace в тексте $html, исключая замену в атрибутах HTML-тегов
ReplyMessageText in file helpdesk.class.php, method helpdesk::ReplyMessageText()
Цитирование текста сообщения, на которое посылается ответ
ResetBit in file Kernel.class.php, method kernel::ResetBit()
Установить бит числа в 0
resizeToFile in file Image.class.php, method Image::resizeToFile()
Метод изменения размера изображения
ResizeToFileEx in file Image.class.php, method Image::ResizeToFileEx()
Метод для пропорционального масштабирования изображения
Round in file shop.class.php, method shop::Round()
Округление цен к формату, приведенного в $this->float_format
RssRead in file RssRead.class.php, class RssRead
Система управления сайтом HostCMS v. 5.xx
RssWrite in file RssWrite.class.php, class RssWrite
Ядро, класс для генерации RSS.
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
top
s
$sAllowTag | in file helpdesk.class.php, variable helpdesk::$sAllowTag
$SCRIPT_DECODE_MODE | in file JsHttpRequest.php, variable JsHttpRequest::$SCRIPT_DECODE_MODE
$SCRIPT_ENCODING | in file JsHttpRequest.php, variable JsHttpRequest::$SCRIPT_ENCODING
$section_path | in file Xsl.class.php, variable xsl::$section_path
$section_path | in file lib.class.php, variable lib::$section_path
$SelectFilterCount | in file admin_forms_fields.class.php, variable admin_forms_fields::$SelectFilterCount
$separator in file Structure.class.php, variable Structure::$separator
Разделитель для уровней
$setCookieSubdomain in file shop.class.php, variable shop::$setCookieSubdomain
Устанавливать cookies для поддоменов.
$ShowBottom in file admin_forms.class.php, variable admin_forms::$ShowBottom
Показывать нижнюю строку с действиями
$ShowFilter in file admin_forms.class.php, variable admin_forms::$ShowFilter
Показывать фильтр
$ShowOperations in file admin_forms.class.php, variable admin_forms::$ShowOperations
Показывать действия
$ShowXmlContent | in file Kernel.class.php, variable kernel::$ShowXmlContent
$simbols in file Captcha.class.php, variable Captcha::$simbols
Порядок символов в шрифтах
$sModulesPath | in file Kernel.class.php, variable kernel::$sModulesPath
$sTemplatesUrlServer | in file SiteTemplate.class.php, variable SiteTemplate::$sTemplatesUrlServer
$stream in file Mail.class.php, variable Mail::$stream
Идентификатор открытого соединения с почтовым сервером
$StructuredList in file helpdesk.class.php, variable helpdesk::$StructuredList
Массив, содержащий структурированный список директорий
$StructureMass in file Structure.class.php, variable Structure::$StructureMass
Массив с элементами структуры
$StructureParentMass in file Structure.class.php, variable Structure::$StructureParentMass
Массив родительских разделов
$structure_propertys_list in file Structure.class.php, variable Structure::$structure_propertys_list
Хранит результат запроса на выборку дополнительных свойств структуры
Security.fns.php | procedural page Security.fns.php
SaveHeaders in file Mail.class.php, method Mail::SaveHeaders()
Сохранение заголовков письма
SaveLibPropertiesValue in file lib.class.php, method lib::SaveLibPropertiesValue()
Сохранение настроек типовой динамической страницы для стурктуры в файл
SaveStructure in file Mail.class.php, method Mail::SaveStructure()
Сохранение структуры сообщения
SaveToFile in file File.class.php, method File::SaveToFile()
Сохранение содержимого $content в файл с путем $filepath
Search in file Search.class.php, class Search
Система управления сайтом HostCMS v. 5.xx
Search.class.php | procedural page Search.class.php
Search.php | procedural page Search.php
SearchIndexing in file InformationSystems.class.php, method InformationSystem::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file Forums.class.php, method Forums::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file Site_users.class.php, method SiteUsers::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file Structure.class.php, method Structure::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file shop.class.php, method shop::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchIndexing in file helpdesk.class.php, method helpdesk::SearchIndexing()
Функция обратного вызова для поисковой индексации данных модуля
SearchWords in file Search.class.php, method Search::SearchWords()
Поиск списка слов в индексе. Примеры использования см. в руководстве по интеграции.
select in file Mysql.class.php, method DataBase::select()
Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()
SelectAllItemsFromCartForUser in file shop.class.php, method shop::SelectAllItemsFromCartForUser()
Получение суммы налога, количества элементов и их общей цены для заданного пользователя
SelectAllItemsFromCookieCart in file shop.class.php, method shop::SelectAllItemsFromCookieCart()
Получение общего количества товаров, их общей стоимости и веса из корзины
SelectBanner in file Advertisement.class.php, method Advertisement::SelectBanner()
Определение баннера, доступного для показа
SelectBannersFromGroup in file Advertisement.class.php, method Advertisement::SelectBannersFromGroup()
Получение информации о баннерах группы
SelectBannersGroup in file Advertisement.class.php, method Advertisement::SelectBannersGroup()
Получение информации о конкретной группе баннеров или обо всех группах баннеров
SelectCityArea in file shop.class.php, method shop::SelectCityArea()
Получение информации о районе города (обо всех районах при $city_area_id=-1)
SelectExtraProperties in file Site_users.class.php, method SiteUsers::SelectExtraProperties()
Получение всех дополнительных свойств
SelectFascicle in file Maillist.class.php, method Maillist::SelectFascicle()
Получение данных о выпуске рассылки
SelectForms in file Forms.class.php, method Forms::SelectForms()
Получение данных о формах
SelectFormsFields in file Forms.class.php, method Forms::SelectFormsFields()
Получение данных о поле формы
SelectFormThemes in file Forums.class.php, method Forums::SelectFormThemes()
Получение результата запроса на выборку тем форума
SelectForumsGroup in file Forums.class.php, method Forums::SelectForumsGroup()
Устарвший метод, возвращающий информацию о группе форумов
SelectGroupsByName in file shop.class.php, method shop::SelectGroupsByName()
Получение информации обо всех группах магазина, имеющих название $shop_groups_name
SelectInformationGroups in file InformationSystems.class.php, method InformationSystem::SelectInformationGroups()
Получение информации об информационных группах Устаревший метод, ОСТАВЛЕН ДЛЯ СОВМЕСТИМОСТИ.
SelectInformationSystem in file InformationSystems.class.php, method InformationSystem::SelectInformationSystem()
Получение информации об информационной системе
SelectIp in file ip.class.php, method ip::SelectIp()
Получение информации об IP-адресах
SelectList in file Lists.class.php, method lists::SelectList()
Получение данных о списке
SelectListInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::SelectListInformationGroupPropertys()
Получение списка дополнительных свойств информационных группы информационной системы
SelectListsItems in file Lists.class.php, method lists::SelectListsItems()
Получение данных об элементах списка
SelectMaillist in file Maillist.class.php, method Maillist::SelectMaillist()
Получение данных о рассылке
SelectMessage in file Forums.class.php, method Forums::SelectMessage()
Метод возвращающий информацию о сообщении
SelectPollReply4Poll in file Polls.class.php, method polls::SelectPollReply4Poll()
Получение списка вариантов ответов на опрос по ID опроса
SelectPrice in file shop.class.php, method shop::SelectPrice()
Метод определения цены для заданной группы пользователей
SelectPropertysGroupsByDirParentId in file InformationSystems.class.php, method InformationSystem::SelectPropertysGroupsByDirParentId()
Получение списка дополнительных свойств информационных групп по идентификатору группы дополнительных свойств
SelectPropertysItemsByDirParentId in file InformationSystems.class.php, method InformationSystem::SelectPropertysItemsByDirParentId()
Получение списка дополнительных свойств информационных элементов по идентификатору группы дополнительных свойств
SelectSites in file Site.class.php, method site::SelectSites()
Выбор всех сайтов, поддерживаемых системой управления
SelectSiteUsersGroups in file Site_users.class.php, method SiteUsers::SelectSiteUsersGroups()
Получение данных о всех группах пользователей сайта
SelectStructureForParent in file Structure.class.php, method Structure::SelectStructureForParent()
Получение информации об узлах структуры конкрентного уровня
SelectStructurePropertys in file Structure.class.php, method Structure::SelectStructurePropertys()
Метод выбора дополнительного свойства структуры определенного сайта(false - выбор всех)
SelectThemeSubscribers in file Forums.class.php, method Forums::SelectThemeSubscribers()
Получение списка подписчиков на тему форума
SelectUser in file Maillist.class.php, method Maillist::SelectUser()
Получение информации о состоянии подписки подписчика на рассылку
SelectUserDeniedAccess in file UserAccess.class.php, method user_access::SelectUserDeniedAccess()
Получение списка неудачных доступов к BackOffice для конкретного ip-адреса
SelectUserSubscriptions in file Forums.class.php, method Forums::SelectUserSubscriptions()
Получение списка подписанных тем форума
SelectUserType in file Site_users.class.php, method SiteUsers::SelectUserType()
Метод возвращает параметры группы пользователя
select_alias in file Site.class.php, method site::select_alias()
Получение информации об алиасе (домене) сайта
select_comments in file InformationSystems.class.php, method InformationSystem::select_comments()
Получение комментариев к информационному элементу
select_data_templates in file Templates.class.php, method templates::select_data_templates()
Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $data_templates_id = -1)
select_documents in file Documents.class.php, method documents::select_documents()
Получение информации о документе или обо всех документах.
select_documents_dir in file Documents.class.php, method documents::select_documents_dir()
Метод выбора раздела документов
select_information_items in file InformationSystems.class.php, method InformationSystem::select_information_items()
Устаревший метод получения данных об информационном элементе. Рекомендуется использовать GetInformationSystemItem
select_lists_items in file Lists.class.php, method lists::select_lists_items()
Получение данных об элементе списка
select_modules in file Modules.class.php, method modules::select_modules()
Получение информации о модуле
select_poll in file Polls.class.php, method polls::select_poll()
Метод осуществляет выборку опросов
select_poll_reply in file Polls.class.php, method polls::select_poll_reply()
Метод выбора вариантов ответов по ID ответа
select_site in file Site.class.php, method site::select_site()
Получение данных о сайте
select_status in file Documents.class.php, method documents::select_status()
Получение информации о статусе документа
select_user in file UserAccess.class.php, method user_access::select_user()
УСТАРЕВШИЙ. Получение информации о пользователе
select_user_access in file UserAccess.class.php, method user_access::select_user_access()
Получение нформации о типах доступа пользователей
select_user_type in file UserAccess.class.php, method user_access::select_user_type()
УСТАРЕВШИЙ. Метод выбора типа пользователей
select_version in file Documents.class.php, method documents::select_version()
Метод выборки информации о версиях
select_xsl in file Xsl.class.php, method xsl::select_xsl()
Получение данных о XSL-шаблонах
select_xsl_dir in file Xsl.class.php, method xsl::select_xsl_dir()
Получение информации о XSL-разделах
SendFascicle in file Maillist.class.php, method Maillist::SendFascicle()
Метод отправки выпуска всем подписчикам рассылки
SendMailAboutOrder in file shop.class.php, method shop::SendMailAboutOrder()
Метод отправки писем о поступившем заказе пользователю и администратору
SendMailWithFile in file Kernel.class.php, method kernel::SendMailWithFile()
Метод отправки электронного письма с прикрепленным файлом
SendMessage in file helpdesk.class.php, method helpdesk::SendMessage()
Отправка сообщений
SendNewPassword in file Site_users.class.php, method SiteUsers::SendNewPassword()
Метод отправки нового пароля на почтовый ящик пользователю
SendRegistInf in file Site_users.class.php, method SiteUsers::SendRegistInf()
Метод отправки пользователю регистрационной информации
SentAutoAnswer in file helpdesk.class.php, method helpdesk::SentAutoAnswer()
Формирование и отсылка автоответа на сообщение
Seo in file seo.class.php, class Seo
Система управления сайтом HostCMS v. 5.xx
seo.class.php | procedural page seo.class.php
seo.php | procedural page seo.php
serverParse | in file Kernel.class.php, method kernel::serverParse()
Session | in file Kernel.php, class Session
Session | in file Kernel.php, method Session::Session()
sessionClose | in file Kernel.php, method Session::sessionClose()
sessionDestroyer | in file Kernel.php, method Session::sessionDestroyer()
sessionGc | in file Kernel.php, method Session::sessionGc()
sessionOpen | in file Kernel.php, method Session::sessionOpen()
sessionRead | in file Kernel.php, method Session::sessionRead()
sessionWrite | in file Kernel.php, method Session::sessionWrite()
setAAction in file admin_forms.class.php, method admin_forms::setAAction()
Устанавливает значение AAction
setAAdditionalParams in file admin_forms.class.php, method admin_forms::setAAdditionalParams()
Устанавливает значение AAdditionalParams
SetBit in file Kernel.class.php, method kernel::SetBit()
Установить бит числа
SetCart in file shop.class.php, method shop::SetCart()
Сохранение корзины в зависимости от CartType
SetChmodFile in file File.class.php, method File::SetChmodFile()
Установка прав доступа к создаваемых объектом файлов
SetChmodFile in file SiteTemplate.class.php, method SiteTemplate::SetChmodFile()
Установка прав доступа к создаваемых объектом файлов
SetConfirmation in file Site_users.class.php, method SiteUsers::SetConfirmation()
Установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)
SetConfirmationID in file Site_users.class.php, method SiteUsers::SetConfirmationID()
Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору
SetCookie in file shop.class.php, method shop::SetCookie()
Установка значения cookie
SetCookieCart in file shop.class.php, method shop::SetCookieCart()
Отправить в cookies содержимое корзины
SetCountAllComments in file shop.class.php, method shop::SetCountAllComments()
Установление числа комментариев к товарам
SetCurrentSite in file Admin.class.php, method Admin::SetCurrentSite()
Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта
SetCurrentSiteUser in file Site_users.class.php, method SiteUsers::SetCurrentSiteUser()
Метод авторизации пользователя сайта, необходимо вызывать до начала вывода данных в поток
SetDefaultGroup in file Site_users.class.php, method SiteUsers::SetDefaultGroup()
Установка группы пользователей по умолчанию
setEncoding in file JsHttpRequest.php, method JsHttpRequest::setEncoding()
void setEncoding(string $encoding)
SetExpires in file Kernel.class.php, method kernel::SetExpires()
Метод установления времени истечения актуальности страницы
SetExternalHtml in file admin_forms_fields.class.php, method admin_forms_fields::SetExternalHtml()
Установить внешний HTML для формы
SetFlagTicket in file helpdesk.class.php, method helpdesk::SetFlagTicket()
Применение флага к тикету
SetLastModified in file Kernel.class.php, method kernel::SetLastModified()
Метод установления времени последнего изменения страницы
SetModerator in file Forums.class.php, method Forums::SetModerator()
Метод установления/снятия прав модератора текущего форума для группы пользователей
SetOrderPaymentStatus in file shop.class.php, method shop::SetOrderPaymentStatus()
Изменение статуса оплаты заказа
SetPathArrayGetInformationFromPath in file InformationSystems.class.php, method InformationSystem::SetPathArrayGetInformationFromPath()
Устаналивает свойство $this->PathArrayGetInformationFromPath
SetSessionCart in file shop.class.php, method shop::SetSessionCart()
Отправить в session содержимое корзины
SetTemplate in file Kernel.class.php, method kernel::SetTemplate()
Метод установления текущего макета
SetTemplatePath | in file SiteTemplate.class.php, method SiteTemplate::SetTemplatePath()
SetTemplatesUrlServer | in file SiteTemplate.class.php, method SiteTemplate::SetTemplatesUrlServer()
SetThemeId in file Forums.class.php, method Forums::SetThemeId()
Установка значения идентификатора добавленной темы форума
setTimestamp in file Kernel.class.php, method kernel::setTimestamp()
Изменение временной метки файла CSS-стиля для страницы
setTransparency in file Image.class.php, method Image::setTransparency()
Установка прозрачности для $new_image, равной прозрачности $image_source
SetUnload in file shop.class.php, method shop::SetUnload()
Установка статуса выгрузки заказа
SetUsersTypeAccess in file UserAccess.class.php, method user_access::SetUsersTypeAccess()
Метод вставки/обновления информации о доступе группы пользователей к модулю
SetUsersTypeAccessFormEvents in file UserAccess.class.php, method user_access::SetUsersTypeAccessFormEvents()
Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования
SetUsersTypeEventAccess in file UserAccess.class.php, method user_access::SetUsersTypeEventAccess()
Установление/снятие доступа группы пользователей центра администрирования к событию формы центра администрирования
SetValueExtraProperty in file Site_users.class.php, method SiteUsers::SetValueExtraProperty()
Установка значения дополнительного параметра пользователя
set_CSS in file Kernel.class.php, method kernel::set_CSS()
Метод изменения адреса файла CSS-стиля для страницы
set_current_page in file Kernel.class.php, method kernel::set_current_page()
Метод изменения адреса страницы
set_current_page_data_template in file Kernel.class.php, method kernel::set_current_page_data_template()
Метод изменения шаблона страницы
set_description in file Kernel.class.php, method kernel::set_description()
Метод изменения описания страницы
set_keywords in file Kernel.class.php, method kernel::set_keywords()
Метод изменения ключевых слов страницы
set_title in file Kernel.class.php, method kernel::set_title()
Метод изменения заголовока страницы
shop in file shop.class.php, class shop
Система управления сайтом HostCMS v. 5.xx
shop.class.php | procedural page shop.class.php
shop.php | procedural page shop.php
ShowAddComment in file InformationSystems.class.php, method InformationSystem::ShowAddComment()
Добавление комментария к элементу информационной системы
ShowAddEditTheme in file Forums.class.php, method Forums::ShowAddEditTheme()
Формирование XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
ShowAddress in file shop.class.php, method shop::ShowAddress()
Метод показа адреса для заказчика
ShowAdvertisement in file Advertisement.class.php, method Advertisement::ShowAdvertisement()
Показ баннера с использованием XML
ShowAdvertisementGroup in file Advertisement.class.php, method Advertisement::ShowAdvertisementGroup()
Показ баннера из указанной группы в соответствии с приоритетом. Для вывода баннера используется XSL-шаблон.
ShowAffiliate in file affiliate.class.php, method affiliate::ShowAffiliate()
Показ партнерских программ.
ShowAffiliatStatistics | in file affiliate.class.php, method affiliate::ShowAffiliatStatistics()
ShowArrow in file seo.class.php, method Seo::ShowArrow()
Отображение стрелочек динамики изменения значений
ShowArrowQuery in file seo.class.php, method Seo::ShowArrowQuery()
Отображение стрелочек динамики изменения значений поисковых запросов
ShowBanner in file Advertisement.class.php, method Advertisement::ShowBanner()
Показ баннера
ShowBannerGroup in file Advertisement.class.php, method Advertisement::ShowBannerGroup()
Показ баннера из указанной группы в соответствии с приоритетом
ShowBannerIsTrue in file Advertisement.class.php, method Advertisement::ShowBannerIsTrue()
Переход по ссылке баннера и наращивание счётчика, если с этого показа мы ещё не переходили
ShowBreadCrumbs in file admin_forms.class.php, method admin_forms::ShowBreadCrumbs()
Отображение хлебных крошек.
ShowCart in file shop.class.php, method shop::ShowCart()
Метод показа содержимого корзины
ShowConference in file Forums.class.php, method Forums::ShowConference()
Метод отображения конференции
ShowConfirmation in file shop.class.php, method shop::ShowConfirmation()
Метод вывода сообщения о необходимости подтвердить аккаунт
ShowCounterCode in file Counter.class.php, method counter::ShowCounterCode()
Отображение кода счетчика
ShowDocument in file Documents.class.php, method documents::ShowDocument()
Показ текста текущей версии страницы
ShowEditMessage in file Forums.class.php, method Forums::ShowEditMessage()
Формирование XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
ShowEmptyImage | in file Graphic.class.php, method graphic::ShowEmptyImage()
ShowEnter in file shop.class.php, method shop::ShowEnter()
Метод вывода формы для авторизации пользователя
ShowFlyPanel in file Kernel.class.php, method kernel::ShowFlyPanel()
Формирование панели редактирования элементов ЦА в клиентской части
ShowForm in file Forms.class.php, method Forms::ShowForm()
Отображение формы
ShowForm in file admin_forms_fields.class.php, method admin_forms_fields::ShowForm()
Отображение формы центра администрирования
ShowForm in file admin_forms.class.php, method admin_forms::ShowForm()
Обрабатывает действия формы, вызывает построение формы
ShowForumRss in file Forums.class.php, method Forums::ShowForumRss()
Отображение RSS ленты
ShowHelpdesk in file helpdesk.class.php, method helpdesk::ShowHelpdesk()
Показ списка тикетов службы поддержки
ShowInformationSystem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystem()
Отображение групп и элементов информационной системы
ShowInformationSystemItem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemItem()
Отображение информации об информационном элементе
ShowInformationSystemPageConfig in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemPageConfig()
Вызов настроек информацонной системы, используется в настройках динамической страницы совместно с ShowInformationSystemPageContent в коде динамической страницы
ShowInformationSystemPageContent in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemPageContent()
Вызова информацонной системы, используется в динамической странице совместо с ShowInformationSystemPageContent в настройках динамической страницы
ShowInformationSystemRss in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemRss()
Отображение RSS ленты
ShowItem in file shop.class.php, method shop::ShowItem()
Метод вывода информации о товаре
ShowItemsCompare in file shop.class.php, method shop::ShowItemsCompare()
Метод отображает сравнение выбранных товаров в магазине
ShowLink in file admin_forms.class.php, method admin_forms::ShowLink()
Показ строки ссылок
ShowList in file Lists.class.php, method lists::ShowList()
Отображение элементов списка. Внутренний метод
ShowMaillist in file Maillist.class.php, method Maillist::ShowMaillist()
Метод отображения списка почтовых расслок пользователя
ShowMessage in file Forums.class.php, method Forums::ShowMessage()
Метод отображения сообщений форума
ShowMessages in file messages.class.php, method messages::ShowMessages()
Вывод личных сообщений пользователя сайта
ShowPoll in file Polls.class.php, method polls::ShowPoll()
Метод отображения опроса
ShowPollResult in file Polls.class.php, method polls::ShowPollResult()
Устаревший метод вывода результатов голосования
ShowPolls in file Polls.class.php, method polls::ShowPolls()
Устаревший метод! Метод отображения всех активных опросов
ShowPollsGroup in file Polls.class.php, method polls::ShowPollsGroup()
Отображение групп опросов
ShowPriceList | in file shop.class.php, method shop::ShowPriceList()
ShowProducersList in file shop.class.php, method shop::ShowProducersList()
Метод формирования xml для производителей
ShowSaller in file shop.class.php, method shop::ShowSaller()
Метод для отображение информации о продавце в клиентской части
ShowShop in file shop.class.php, method shop::ShowShop()
Показ магазина (товаров и групп).
ShowShops in file shop.class.php, method shop::ShowShops()
Показ списка магазинов
ShowSiteUserInfo in file Forums.class.php, method Forums::ShowSiteUserInfo()
Отображение данных о пользователе форума
ShowSiteUserRegistartion in file Site_users.class.php, method SiteUsers::ShowSiteUserRegistartion()
Вывод формы регистрации для пользователя сайта
ShowSiteUsersAccount in file shop.class.php, method shop::ShowSiteUsersAccount()
Отображение списка лицевых счетов пользователя
ShowSiteUsersAccountTransaction in file shop.class.php, method shop::ShowSiteUsersAccountTransaction()
Отображение списка транзакций пользователя
ShowStructure in file Structure.class.php, method Structure::ShowStructure()
Метод для отображения структуры в клиентском разделе сайта
ShowSystemOfPay in file shop.class.php, method shop::ShowSystemOfPay()
Метод построения XML для платежных систем
ShowTableRow in file seo.class.php, method Seo::ShowTableRow()
Отображение строк таблицы в Отчете
ShowTableTitleReport in file seo.class.php, method Seo::ShowTableTitleReport()
Отображение шапки таблицы в отчете
ShowTagsCloud in file shop.class.php, method shop::ShowTagsCloud()
Показ облака тегов для магазина
ShowTagsCloud in file InformationSystems.class.php, method InformationSystem::ShowTagsCloud()
Показ облака тегов для информационной системы
ShowThemes in file Forums.class.php, method Forums::ShowThemes()
Метод отображения тем форума
ShowTicket in file helpdesk.class.php, method helpdesk::ShowTicket()
Показ списка сообщений тикета
ShowTypeOfDelivery in file shop.class.php, method shop::ShowTypeOfDelivery()
Метод выбора и показа типов доставки
ShowUserMessages in file Forums.class.php, method Forums::ShowUserMessages()
Показ сообщений пользователя
ShowUserOffice in file Site_users.class.php, method SiteUsers::ShowUserOffice()
Метод отображения кабинета пользователя
ShowUserOrders in file shop.class.php, method shop::ShowUserOrders()
Отображение информации о заказах пользователя
ShowWorktime in file helpdesk.class.php, method helpdesk::ShowWorktime()
Показ режима работы службы техподдержки
show_CSS in file Kernel.class.php, method kernel::show_CSS()
Метод вывода CSS стиля для страницы
show_current_page in file Kernel.class.php, method kernel::show_current_page()
Метод вывода установленной страницы
show_current_template in file Kernel.class.php, method kernel::show_current_template()
Метод вывода текущего макета.
show_description in file Kernel.class.php, method kernel::show_description()
Метод вывода описания страницы
show_error_message in file Message.fns.php, function show_error_message()
Функция выводит сообщение об ошибке
show_information_message in file Message.fns.php, function show_information_message()
Функция выводит информационное сообщение
show_keywords in file Kernel.class.php, method kernel::show_keywords()
Метод вывода ключевых слов страницы
show_message in file Message.fns.php, function show_message()
Функция выводит сообщение об успешной операции
show_title in file Kernel.class.php, method kernel::show_title()
Метод вывода заголовка страницы
show_ws in file Wysiwyg.class.php, method wysiwyg::show_ws()
Метод отображает визуальный редактор
singleton in file Kernel.php, function singleton()
Функция используется для создания сингелтона
site in file Site.class.php, class site
Система управления сайтом HostCMS v. 5.xx
Site.class.php | procedural page Site.class.php
Site.php | procedural page Site.php
SiteTemplate.class.php | procedural page SiteTemplate.class.php
SiteTemplate in file SiteTemplate.class.php, class SiteTemplate
Система управления сайтом HostCMS v. 5.xx
SiteTemplate | in file SiteTemplate.class.php, method SiteTemplate::SiteTemplate()
SiteUsers in file Site_users.class.php, class SiteUsers
Класс модуля "Пользователи сайта"
Site_users.class.php | procedural page Site_users.class.php
Site_users.php | procedural page Site_users.php
Smile2HTML in file Forums.class.php, method Forums::Smile2HTML()
Метод замены смайликов на HTML
smtpMail | in file Kernel.class.php, method kernel::smtpMail()
SortStructureMass in file Structure.class.php, method Structure::SortStructureMass()
Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией
STAT_PERIOD_STORAGE | in file Counter.php, constant STAT_PERIOD_STORAGE
StripInvalidXml | in file Security.fns.php, function StripInvalidXml()
strips in file Kernel.class.php, method kernel::strips()
Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag
strips in file Security.fns.php, function strips()
Вызывает stripslashes для всех элементов массива
strip_tags_attributes in file Kernel.php, function strip_tags_attributes()
Удаление HTML-тегов вместе с атрибутами
Structure in file Structure.class.php, class Structure
Система управления сайтом HostCMS v. 5.xx
Structure.class.php | procedural page Structure.class.php
Structure.php | procedural page Structure.php
StructureToArray in file Mail.class.php, method Mail::StructureToArray()
Разбор структуры сообщения и сохранение результата в массив
str_for_rss in file RssWrite.class.php, method RssWrite::str_for_rss()
Преобразует строку для публикации в RSS, использует str_for_xml() и kernel::numeric_character_references()
str_for_xml in file Security.fns.php, function str_for_xml()
Функция преобразует строку для публикации в XML
Support in file Support.class.php, class Support
Класс модуля "Техническая поддержка"
Support.class.php | procedural page Support.class.php
Support.php | procedural page Support.php
SupportMail in file Support.class.php, method Support::SupportMail()
Метод отправки письма с просьбой о технической поддержке
symbol2ASCII in file Security.fns.php, function symbol2ASCII()
Возвращает текст с печатаемыми символами ASCII кода, а также \n, \r, \t
system_init in file Admin.class.php, method Admin::system_init()
Метод старта сессии для раздела администрирования
top
t
$tabs | in file admin_forms_fields.class.php, variable admin_forms_fields::$tabs
$template_content_filename | in file SiteTemplate.class.php, variable SiteTemplate::$template_content_filename
$template_filename | in file SiteTemplate.class.php, variable SiteTemplate::$template_filename
$template_path | in file SiteTemplate.class.php, variable SiteTemplate::$template_path
$tilt in file Graphic.class.php, variable graphic::$tilt
Наклон диаграммы
tar.class.php | procedural page tar.class.php
Tag in file tag.class.php, class Tag
Система управления сайтом HostCMS v. 5.xx
tag.class.php | procedural page tag.class.php
tag.php | procedural page tag.php
templates in file Templates.class.php, class templates
Система управления сайтом HostCMS v. 5.xx
Templates.class.php | procedural page Templates.class.php
Templates.php | procedural page Templates.php
TicketStatusChange in file helpdesk.class.php, method helpdesk::TicketStatusChange()
Изменение статуса тикета
to_array in file Security.fns.php, function to_array()
Функция приведения аргумента к массиву
to_bool in file Security.fns.php, function to_bool()
Функция приведения аргумента к логическому типу
to_float in file Security.fns.php, function to_float()
Функция приведения аргумента к вещественному типу
to_int in file Security.fns.php, function to_int()
Функция приведения аргумента к целочисленному типу
to_str in file Security.fns.php, function to_str()
Функция приведения аргумента к строковому типу
TransferFromCartIntoTable in file shop.class.php, method shop::TransferFromCartIntoTable()
Метод перемещения информации о заказанном товаре в таблицу корзины
translit_lower in file Url.class.php, method url::translit_lower()
Метод транслитерации с переводом символам исходного текста к прописным
typograph in file typograph.class.php, class typograph
Система управления сайтом HostCMS v. 5.xx
typograph.class.php | procedural page typograph.class.php
typograph.php | procedural page typograph.php
TypographText in file Forums.class.php, method Forums::TypographText()
Типографирование текста с использованием модуля "Типограф"
top
u
$user_function_message in file admin_forms.class.php, variable admin_forms::$user_function_message
Строка с суммарной строкой ошибок, произошедших в пользовательских событиях.
$user_function_result in file admin_forms.class.php, variable admin_forms::$user_function_result
Строка с результатом выполнения пользовательской функции.
$useSmtp in file Kernel.class.php, variable kernel::$useSmtp
Данные внешнего SMTP-сервера для отправки писем
$use_cookies_read_control in file shop.class.php, variable shop::$use_cookies_read_control
Использовать ли систему контроля корректности данных, принимаемых из cookies.
$use_read_control in file Cache.class.php, variable Cache::$use_read_control
Использовать контроль данных с помощью crc32
Url.class.php | procedural page Url.class.php
Unregistration in file Site_users.class.php, method SiteUsers::Unregistration()
Метод удаления пользователя, определяемого по индексу (для клиентского раздела). Удаляет только не активированного пользователя
UnsetCurrentSiteUser in file Site_users.class.php, method SiteUsers::UnsetCurrentSiteUser()
Метод отменяет авторизацию текущего пользователя сайта, используется при "выходе" из
UnsetSiteUserAccountTransaction in file shop.class.php, method shop::UnsetSiteUserAccountTransaction()
Установка активности транзакции в 0 (делает неактивной)
Update in file Mysql.class.php, method DataBase::Update()
Обновление записей в таблицах.
update in file update.class.php, class update
Система управления сайтом HostCMS v. 5.xx
update.class.php | procedural page update.class.php
update.php | procedural page update.php
UpdateCart in file shop.class.php, method shop::UpdateCart()
Метод, осуществляющий обновление данных корзины
UpdateCity in file shop.class.php, method shop::UpdateCity()
УСТАРЕВШИЙ! Метод, осуществляющий обновление города
UpdateCondOfDelivery in file shop.class.php, method shop::UpdateCondOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление условия доставки
UpdateCountry in file shop.class.php, method shop::UpdateCountry()
УСТАРЕВШИЙ! Метод, осуществляющий обновление страны
UpdateCurrency in file shop.class.php, method shop::UpdateCurrency()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о валюте. Является алиасом InsertCurrency()
UpdateDataTemplatesGroup in file Templates.class.php, method templates::UpdateDataTemplatesGroup()
Метод обновления информации о группе шаблонов данных
UpdateDiscount in file shop.class.php, method shop::UpdateDiscount()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о скидке
UpdateGroup in file shop.class.php, method shop::UpdateGroup()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о группе, к которой относятся товары
UpdateGroupPolls in file Polls.class.php, method polls::UpdateGroupPolls()
Метод обновления информаци о группе опросов
UpdateImageForItem in file shop.class.php, method shop::UpdateImageForItem()
Метод обновления информации об изображении для товара
UpdateItem in file shop.class.php, method shop::UpdateItem()
Устаревший метод, осуществляющий обновление информации о товаре. Заменен на InsertItem()
UpdateItemDiscount in file shop.class.php, method shop::UpdateItemDiscount()
УСТАРЕВШИЙ! Метод обновления информации о скидке для определенного товара
UpdateItemPrice in file shop.class.php, method shop::UpdateItemPrice()
Метод обновления связи товара и цены
UpdateLibPropertyOrder in file lib.class.php, method lib::UpdateLibPropertyOrder()
Обновление порядка сортировки параметра типовой дин. страницы
UpdateLocation in file shop.class.php, method shop::UpdateLocation()
УСТАРЕВШИЙ! Метод, осуществляющий обновление области
UpdateMesure in file shop.class.php, method shop::UpdateMesure()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о единице измерения
UpdateOrder in file shop.class.php, method shop::UpdateOrder()
УСТАРЕВШИЙ метод, осуществляющий обновление заказа. См. InsertOrder()
UpdateOrderItems in file shop.class.php, method shop::UpdateOrderItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление товара в заказе
UpdateOrderPropretyOfItems in file shop.class.php, method shop::UpdateOrderPropretyOfItems()
Метод изменения порядка сортировки дополнительных свойств товара
UpdatePrice in file shop.class.php, method shop::UpdatePrice()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа цены
UpdatePricesToItem in file shop.class.php, method shop::UpdatePricesToItem()
Метод обновления дополнительной цены для элемента
UpdateProducer in file shop.class.php, method shop::UpdateProducer()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о производителе
UpdatePropertiesItem in file shop.class.php, method shop::UpdatePropertiesItem()
Метод обновления информации о дополнительных свойствах товара
UpdatePropretyOfItems in file shop.class.php, method shop::UpdatePropretyOfItems()
УСТАРЕВШИЙ! Метод, осуществляющий обновление свойства товара
UpdateShop in file shop.class.php, method shop::UpdateShop()
УСТАРЕВШИЙ! Метод, осуществляющий обновление информации о магазине
UpdateSiteUser in file Site_users.class.php, method SiteUsers::UpdateSiteUser()
Обновление анкетных данных пользователя. Рекомендуется использовать InsertSiteUser().
UpdateSubDir in file Structure.class.php, method Structure::UpdateSubDir()
Метод обновления идентификатора меню у подразделов определенного раздела
UpdateSystemOfPay in file shop.class.php, method shop::UpdateSystemOfPay()
УСТАРЕВШИЙ! Метод, осуществляющий обновление платёжной системы
UpdateTax in file shop.class.php, method shop::UpdateTax()
Метод, осуществляющий обновление налога. Рекомендуется использовать InsertTax()
UpdateTyingProducts in file shop.class.php, method shop::UpdateTyingProducts()
УСТАРЕВШИЙ! Метод обновления информации о сопутствующих товарах
UpdateTypeOfDelivery in file shop.class.php, method shop::UpdateTypeOfDelivery()
УСТАРЕВШИЙ! Метод, осуществляющий обновление типа доставки
url in file Url.class.php, class url
Система управления сайтом HostCMS v. 5.xx
UrlWww in file seo.class.php, method Seo::UrlWww()
Обрезает "www" у домена
UseHttps in file Kernel.class.php, method kernel::UseHttps()
Используется ли HTTPS-доступ
UserAccess.class.php | procedural page UserAccess.class.php
UserAccess.php | procedural page UserAccess.php
UserAuth in file Admin.class.php, method Admin::UserAuth()
Метод производит авторизацию пользователя в разделе администрирования
UserCanAddComment in file InformationSystems.class.php, method InformationSystem::UserCanAddComment()
Определение возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY
UserIsModerator in file Forums.class.php, method Forums::UserIsModerator()
Метод для определения, является ли данный пользователь модератором
UserSessionValid in file Admin.class.php, method Admin::UserSessionValid()
Проверяет, авторизован ли текущий пользователь в центре администрирования
user_access | in file UserAccess.class.php, class user_access
Utf8ToWindows1251 in file Kernel.class.php, method kernel::Utf8ToWindows1251()
Преобразует текст из UTF-8 в Windows1251. В своей работе использует iconv() при его наличии или kernel::utf8_win1251()
utf8_win1251 in file Kernel.class.php, method kernel::utf8_win1251()
Перевод из UTF-8 в Windows-1251, используется при отсутствии iconv()
top
v
$value_cont in file Graphic.class.php, variable graphic::$value_cont
Число значений элементов, для которых строится диаграмма
ValidCaptcha in file Captcha.class.php, method Captcha::ValidCaptcha()
Метод проверки соответствия введенного пользователем текста хранимому в сессии Пример использования метода см. в руководстве по интеграции.
ValidUser in file Site_users.class.php, method SiteUsers::ValidUser()
Метод возвращает идентификатор пользователя по его логину и паролю
valid_email in file Security.fns.php, function valid_email()
Проверка правильности электронного адреса
VisibleTheme in file Forums.class.php, method Forums::VisibleTheme()
Метод, устанавливающий видимость/невидимость темы
vote_result in file Polls.class.php, method polls::vote_result()
Устаревший метод
top
w
$window_id in file admin_forms.class.php, variable admin_forms::$window_id
Идентификатор окна
Wysiwyg.class.php | procedural page Wysiwyg.class.php
warehouse.class.php | procedural page warehouse.class.php
warehouse in file warehouse.class.php, class warehouse
Система управления сайтом HostCMS v. 5.xx
win1251_utf8 in file Kernel.class.php, method kernel::win1251_utf8()
Перевод из Windows-1251 в UTF-8, используется при отсутствии iconv()
Windows1251ToUtf8 in file Kernel.class.php, method kernel::Windows1251ToUtf8()
Преобразует текст из Windows1251 в UTF-8. В своей работе использует iconv() при его наличии или kernel::win1251_utf8()
WordExists in file admin_forms.class.php, method admin_forms::WordExists()
Проверка, существования идентификатора слова
wysiwyg in file Wysiwyg.class.php, method wysiwyg::wysiwyg()
Конструктор
wysiwyg in file Wysiwyg.class.php, class wysiwyg
Система управления сайтом HostCMS v. 5.xx
top
x
$xml | in file ExternalXml.class.php, variable ExternalXml::$xml
$x_pos_1_leg in file Graphic.class.php, variable graphic::$x_pos_1_leg
Х - координата верхнего угла легенды
$x_size in file Graphic.class.php, variable graphic::$x_size
Ширина рисунка
XMLparser.class.php | procedural page XMLparser.class.php
xcacheClearCache in file Cache.class.php, method Cache::xcacheClearCache()
Очистка кэша $cache_name и элемента $item_name в xcache
Xml2Array | in file Kernel.class.php, method kernel::Xml2Array()
Xml2Array2 in file Kernel.class.php, method kernel::Xml2Array2()
Преобразование XML в массив
xsl in file Xsl.class.php, class xsl
Система управления сайтом HostCMS v. 5.xx
Xsl.class.php | procedural page Xsl.class.php
Xsl.php | procedural page Xsl.php
top
y
$y_pos_1_leg in file Graphic.class.php, variable graphic::$y_pos_1_leg
Y - координата верхнего угла легенды
$y_size in file Graphic.class.php, variable graphic::$y_size
Высота рисунка
YandexMarket in file shop.class.php, method shop::YandexMarket()
Вывод данных для эксопрта в Yandex.Market. Метод отправляет соответствующий заголовок и выводит XML данные.
YandexXmlRequest | in file seo.class.php, method Seo::YandexXmlRequest()
top
_
$_contentTypes | in file JsHttpRequest.php, variable JsHttpRequest::$_contentTypes
$_emergBuffer | in file JsHttpRequest.php, variable JsHttpRequest::$_emergBuffer
$_encTables in file JsHttpRequest.php, variable JsHttpRequest::$_encTables
UCS-2BE -> 1-byte encodings (from #128).
$_magic | in file JsHttpRequest.php, variable JsHttpRequest::$_magic
$_nonAsciiChars | in file JsHttpRequest.php, variable JsHttpRequest::$_nonAsciiChars
$_prevDisplayErrors | in file JsHttpRequest.php, variable JsHttpRequest::$_prevDisplayErrors
$_toUtfFailed | in file JsHttpRequest.php, variable JsHttpRequest::$_toUtfFailed
$_unicodeConvMethod | in file JsHttpRequest.php, variable JsHttpRequest::$_unicodeConvMethod
$_uniqHash | in file JsHttpRequest.php, variable JsHttpRequest::$_uniqHash
_CallbackSearch in file Structure.class.php, method Structure::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_CallbackSearch in file InformationSystems.class.php, method InformationSystem::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_CallbackSearch in file shop.class.php, method shop::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_CallbackSearch in file Site_users.class.php, method SiteUsers::_CallbackSearch()
Функция обратного вызова, используется модулем поисковой системы при выводе результатов поиска
_correctSuperglobals in file JsHttpRequest.php, method JsHttpRequest::_correctSuperglobals()
Parse & decode QUERY_STRING.
_decUcs2Decode in file JsHttpRequest.php, method JsHttpRequest::_decUcs2Decode()
Convert FROM UCS-2BE decimal to $toEnc.
_lock | in file Kernel.php, method Session::_lock()
_obHandler in file JsHttpRequest.php, method JsHttpRequest::_obHandler()
Called in case of error too!
_toUtf8_callback in file JsHttpRequest.php, method JsHttpRequest::_toUtf8_callback()
Internal function, used in array_walk_recursive() before json_encode() call.
_ucs2EntitiesDecode in file JsHttpRequest.php, method JsHttpRequest::_ucs2EntitiesDecode()
Decode all %uXXXX entities in string or array (recurrent).
_ucs2EntitiesDecodeCallback in file JsHttpRequest.php, method JsHttpRequest::_ucs2EntitiesDecodeCallback()
Decode one %uXXXX entity (RE callback).
_unicodeConv in file JsHttpRequest.php, method JsHttpRequest::_unicodeConv()
Wrapper for iconv() or mb_convert_encoding() functions.
_unlock | in file Kernel.php, method Session::_unlock()
_xml2Array | in file Kernel.class.php, method kernel::_xml2Array()
__autoload | in file Kernel.php, function __autoload()
__construct | in file File.class.php, method File::__construct()
__destruct | in file Mysql.class.php, method DataBase::__destruct()


HostCMS 5

Основное меню

  • Дерево классов
  • Список всех элементов


Основное меню

  • Дерево классов
  • Список всех элементов